Archive

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Nov << Saturday, October 29, 2005 Sep >>
S S M T W T F
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica
2001-2005 hamedbanaei.com


آرشيو

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

آذر << شنبه 7 آبان 1384 مهر >>
ش ي د س چ پ ج
١ ٢ ٣ ٤ ٥ ٦
٧ ٨ ٩ ١٠ ١١ ١٢ ١٣
١٤ ١٥ ١٦ ١٧ ١٨ ١٩ ٢٠
٢١ ٢٢ ٢٣ ٢٤ ٢٥ ٢٦ ٢٧
٢٨ ٢٩ ٣٠

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


آرشيو

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

دي << سه شنبه 8 آذر 1384 آبان >>
ش ي د س چ پ ج
١ ٢ ٣ ٤
٥ ٦ ٧ ٨ ٩ ١٠ ١١
١٢ ١٣ ١٤ ١٥ ١٦ ١٧ ١٨
١٩ ٢٠ ٢١ ٢٢ ٢٣ ٢٤ ٢٥
٢٦ ٢٧ ٢٨ ٢٩ ٣٠

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


آرشيو

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

آبان << پنج شنبه 7 مهر 1384 شهريور >>
ش ي د س چ پ ج
١
٢ ٣ ٤ ٥ ٦ ٧ ٨
٩ ١٠ ١١ ١٢ ١٣ ١٤ ١٥
١٦ ١٧ ١٨ ١٩ ٢٠ ٢١ ٢٢
٢٣ ٢٤ ٢٥ ٢٦ ٢٧ ٢٨ ٢٩
٣٠

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


HamedBanaei.com

loading ....
صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

چهار شنبه 4 آبان 1384 لينک ثابت
DVD Player

به توصيه من ، يکی از دوستام DVD Player ی از Sony خريد که Divx هم بخواند . من فکر می کردم که Xvid هم بتواند بخواند ولی نشد ! نمايندگی Sony هم نمی دانست . آخر سر گوگل به کمک آمد و گفت که بايد نرم افزار DVD Player را به روز کرد !
چهار شنبه 4 آبان 1384 19:54/ تعداد نظرات 0/ سرگرمي/ لينک ثابت
بلاگفا

من از پشتکار شيرازی خوشم مياد ، بلاگفا رو همچين تغيير داده که اون ر(ق)غيبش که فقط حرف می زنه تا مدتها بايد در موردش فکر کنه !
چهار شنبه 4 آبان 1384 17:06/ تعداد نظرات 1/ اخبار کامپيوتر/ لينک ثابت
سه شنبه 3 آبان 1384 لينک ثابت
ويندوز موبايل 2005

امروز رفتم پيش محمد فروتن تا مناسب ترين ROM ی که برای ويندوز موبايل 2005 پيدا کرده بود رو روی دستگاه من نصب کنيم . اين ROM ِ روش ِ کارش از بيخ با بقيه ROM ها فرق می کنه . توضيحاتش باشه برای بعد
سه شنبه 3 آبان 1384 19:19/ تعداد نظرات 0/ خوره !/ لينک ثابت
تاريخ شمسی جديد

محمد فروتن نسخه جديد برای برنامه تاريخ شمسی روی PPC ساخته که در ويندوز 2005 هم کار می کند . از اينجا می توانيد دريافتش کنيد .
سه شنبه 3 آبان 1384 14:43/ تعداد نظرات 0/ اخبار کامپيوتر/ لينک ثابت
iMac G5

علی رستگار يکی از خوره های apple يک فروند iMac G5 خريده . کمتر کسی تو ايران پيدا می شه که مکنتاژ داشته باشه .

چند تا عکس ديگه يک ، دو ، سه و چهار

هر موقع تونستم براش کارايی تعريف کنم حتما ً يکی می گيرم .
سه شنبه 3 آبان 1384 12:30/ تعداد نظرات 0/ خوره !/ لينک ثابت
شنبه 30 مهر 1384 لينک ثابت
Far Cry

يکی از بازی هايی که توی تابستان تمومش کردم FarCry بود . گرافيک بسيار زيبا ولی به خاطر طبيعی بودن ِ تصاوير، آن ترسناکی که در Doom است را نداشت اما تمام مناظر کاملا ً طبيعی هستند و بعضی موقع به جای دنبال کردن بازی به منظره هاش نگاه می کردم !

BBC در مورد Far Cry و Xbox نوشته .
شنبه 30 مهر 1384 23:32/ تعداد نظرات 0/ سرگرمي/ لينک ثابت
سيل و زلزله

اين چند وقته چه قدر سيل و زلزله و باد و طوفان زياد شده . به قولی بلايای طبيعی ، به قول يکی ديگه هشدارهای خدا . تو اين زلزله پاکستان 50 هزار نفر مردند ، افغانيها هم که لابد اصلا ً آمار ندارند ! دنيای با حالی شده ! اتفاقات تفکر بر انگيزی رخ می دهد ! البته اگر هنوز قدرت تفکری باقی مونده باشه !
شنبه 30 مهر 1384 22:20/ تعداد نظرات 0/ جهان/ لينک ثابت
ستون پنجم

تا جايی که من می دونم سايت WordPress رو با PHP نوشتند . Scoble هم يکی از مشهورترين مايکروسافتی های اينترنت است ولی نمی دونم چرا به جای CS يا مشتقاتش که در خود MS فراوان است رفته سراغ WordPress . مشکوک می زنه !

شنبه 30 مهر 1384 22:16/ تعداد نظرات 3/ جهان/ لينک ثابت
بازی ايرانی

بالاخره يک بازی ايرانی هم ديديم . اميدوارم که قيمت معقولی داشته باشه که بشه خريد ! چون قطعا ً به پای Doom3 با قيمت 2 هزار تومان نمی رسد !
شنبه 30 مهر 1384 22:13/ تعداد نظرات 0/ ايران/ لينک ثابت
جمعه 29 مهر 1384 لينک ثابت
فيلم Doom

سايت فيلمش تغيير کرده ، load شدن اولش کمی سنگين است . در بخش wallpaper هم عکس های خوبی دارد .
جمعه 29 مهر 1384 23:38/ تعداد نظرات 3/ اخبار متفرقه/ لينک ثابت
Search Engine

يک موتور جستجو (از scoble)
جمعه 29 مهر 1384 23:37/ تعداد نظرات 0/ اخبار کامپيوتر/ لينک ثابت
احساس خوبی ندارم !

احساس دور زده شدگی دارم !
جمعه 29 مهر 1384 10:30/ تعداد نظرات 0/ شخصي/ لينک ثابت
پنج شنبه 28 مهر 1384 لينک ثابت
آخرين کار

با اينکه Doom3 قديمی شده ولی هنوز بهترين بازی برای نيمه شب هاست .( سايتش رو که می خواهيد ببينيد صدای speakerها را ته بلند کنيد ! حال می ده !)

منتظرم که فيلمش بياد ! البته Divx ش !

پنج شنبه 28 مهر 1384 15:03/ تعداد نظرات 0/ سرگرمي/ لينک ثابت
تر آفيک

امروز هم در ترافيک گير کردم و به کارم نرسيدم !

ای شهردار ، ای شفتالو ، ای آلبالو ، يکی دو تا ديگه اتوبان رو سر اينهايی که هست بزن !
پنج شنبه 28 مهر 1384 14:42/ تعداد نظرات 0/ ايران/ لينک ثابت
ايرانی بازی

مدل ايرانی !

بهت می گن ، بکن ، نکن ، نگو ، بگو ، نبين ، ببين ، نرو ، برو و .....

خودشون ، نمی کنن ، می کنن ، می گن ، نمی گن ، می بينن ، نمی بينن ، می روند ، نمی روند و ......

بعدش که می گی بهشون چرا بر عکس شد ! ، می گن خودت بی (ا)عرزه بودی ! آدام بايد خودش عاقل باشه !
پنج شنبه 28 مهر 1384 14:38/ تعداد نظرات 0/ ايران/ لينک ثابت
سه شنبه 26 مهر 1384 لينک ثابت
ايران سيما

بالاخره بودجه هاي آنچناني به يک دردي خورد ! سايت ايران سيما آرشيو همه برنامه هاي تلويزيون را دارد . کيفيت تصويرش هم خوبه . از ITIran.com
سه شنبه 26 مهر 1384 13:46/ تعداد نظرات 0/ ايران/ لينک ثابت
دوشنبه 25 مهر 1384 لينک ثابت
خريد کتاب

از کجا می شه کتاب ِخارجی خريد و به ايران هم برسه ؟
دوشنبه 25 مهر 1384 19:46/ تعداد نظرات 2/ ايران/ لينک ثابت
AJAX

اينجا مقاله خوبی درباره ساختن متدهای لازم برای AJAX دارد . اين مقاله وابسته به framework خاصی برای AJAX نيست و همه اش رو خودتان بايد بنويسيد . البته کار هم کرد ! ای کاش اين JavaScript يکم مثل آدم خطاها رو نشان می داد !
دوشنبه 25 مهر 1384 19:33/ تعداد نظرات 0/ خوره !/ لينک ثابت
MP3 روی Fedora

پخش MP3 روی Fedora
دوشنبه 25 مهر 1384 19:14/ تعداد نظرات 0/ خوره !/ لينک ثابت
ترافيک
عجب ترافيکی می شه اين روزها
دوشنبه 25 مهر 1384 15:31/ تعداد نظرات 0/ شخصي/ لينک ثابت
شنبه 23 مهر 1384 لينک ثابت
اهواز ترکيد
اهواز ترکيد
شنبه 23 مهر 1384 20:10/ تعداد نظرات 0/ ايران/ لينک ثابت
فرمودن لينک بده
اينم از لينک به آقاي جوتي !
شنبه 23 مهر 1384 13:29/ تعداد نظرات 1/ شخصي/ لينک ثابت
iPod Video
هنوز نيومده براش روش کپي کردن از DVD هم نوشتند !
شنبه 23 مهر 1384 12:28/ تعداد نظرات 0/ خوره !/ لينک ثابت
شماره سريال هارد

در اينجا نوشته که با namespace ي به نام management چه جوري مي شه اطلاعات هارد ديسک ها رو خواند .
شنبه 23 مهر 1384 11:15/ تعداد نظرات 0/ سرگرمي/ لينک ثابت
جمعه 22 مهر 1384 لينک ثابت
سايت انگليسی
سايت انگليسی من هم که با کمی تغيير در همين کد حاصل می شد ، حاضر شده که به زودی upload می شود . در همه جای کد های اين سايت که زبان اهميت داشته يک True و False برای انگليسی و فارسی قرار دادم که با کمترين تغيير بشه هر دو رو داشت.
جمعه 22 مهر 1384 22:41/ تعداد نظرات 0/ شخصي/ لينک ثابت
ليست ebook

سايت قفسه ليست ebook های مختلف را در خود دارد ، خيلی کند است
جمعه 22 مهر 1384 22:39/ تعداد نظرات 0/ ايران/ لينک ثابت
there.com

وقتی Social Network ها 3D بشه و به شکل Windows Application در بياد . يه چيزی تو مايه های Sims2

البته اين يکی پولی است و برای اجرا شدن بايد يک برنامه 54 مگابايتی را دريافت کرد .
جمعه 22 مهر 1384 12:05/ تعداد نظرات 1/ سرگرمي/ لينک ثابت
پنج شنبه 21 مهر 1384 لينک ثابت
Apple و MS و !Y

مسنجرهای مايکروسافت و ياهو با هم ترکيب خواهند شد

Apple هم iPod های تصويری داد

از اونجايی که نزديک به 2 سال است که از PPCPE استفاده می کنم ، تا به امروز يکبار هم فيلم روی PPC نديدم ! به علت صفحه کوچک ديدن فيلم يا کليپ يا اينجور چيزها هيچ لطفی ندارد فقط باعث خسته شدن چشم می شود ، البته music جای خود را دارد ، حالا بايد ديد apple با iPod تصويری چه می خواهد بکند .
پنج شنبه 21 مهر 1384 22:46/ تعداد نظرات 0/ اخبار کامپيوتر/ لينک ثابت
داتک
فکر کنم داتک BBC فارسی رو فيلتر کرده ، صفحه ای لود نمی شود
پنج شنبه 21 مهر 1384 22:44/ تعداد نظرات 0/ ايران/ لينک ثابت
Xbox 360

بررسی Xbox 360

با اينکه مايکروسافت رو دوست دارم ولی فکر کنم PlayStation3 بهتر باشد
پنج شنبه 21 مهر 1384 22:38/ تعداد نظرات 0/ سرگرمي/ لينک ثابت

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
2005 Oct 25 ,Tuesday Permanent Link
How beautiful is iMac G5

Ali Rastegar , one my old friends bought an iMac G5 around $2500 . It is too expensive comparing to my current PC (Intel P4 3GHz , 1GB RAM , gForce 6600 , 100GB HDD , 17" LG LCD … ) which is near $1200 , But iMac is very very very nice ! I like it ! . The problem is I am a software developer using MS technologies but I can not use them on Mac . also we have another problem here in Iran , softwares for Mac are not available like softwares for Windows .
Here are some screen shots from his Mac
1 2 3 4
2005 Oct 25 , Tue 12:44/ Comments 0/ Geek/ Permanent Link
2005 Oct 17 ,Monday Permanent Link
AJAX
Here is a good article about using AJAX methods .
2005 Oct 17 , Mon 19:36/ Comments 0/ Hobby/ Permanent Link
Stream Video Over Network

I found a source code to get video from webcam and show it in a picturebox , but how can I stream it over network ? I want to use that video in other Windows apps .

I had a solution but I didn't try it , I can start a dll which is running over another machine by remoting , I can use a shared picturebox as a property in that dll , fill that picturebox by webcam machine and show it by other clients , I wish every day had more than 24 hours for geeks ! I have to test this method .
2005 Oct 17 , Mon 19:24/ Comments 0/ Geek/ Permanent Link
How To Post Comment
Click on Permanent link of the post !
2005 Oct 17 , Mon 19:23/ Comments 0/ Hobby/ Permanent Link
Being invisible

Is it good to use your real identity over internet ?

I think the answer is depend on your country and your social rules . Here in Iran it seems to be a problem , I wish I never started my weblog over this domain ! being invisible in Iran is a good idea ! I closed my account at Orkut and other social networking sites .
2005 Oct 17 , Mon 19:15/ Comments 0/ Personal/ Permanent Link
2005 Oct 15 ,Saturday Permanent Link
remaining items

At last Keyvan won ! I started English weblog ! I have to add RSS and some cookies to this site also other pages like software , articles and ... are still waiting for english content .

All of my visitors are familiar with Persian language , so I really don't need to write in English , but I hope that I can find none Persian friends via my English site , and can contact with the other people .

Since 9 month ago which the best ISP around , DATAK , started its IP Wireless service , my life is changed . Being online for 24/7 was a dream and now it is became true ! This service is not very high speed (128/32) but it is more more better than dialup ! I think its price is the same as 1Mbps or more at US ! $50 per month .

The best feature for this English web site is I can say anything I want ! which is not possible at my Persian site ! (they are watching me !! they closed my axblog).

at last , sorry for my poooooor english !
2005 Oct 15 , Sat 18:48/ Comments 1/ Personal/ Permanent Link
Lets Start
Hello World
2005 Oct 15 , Sat 17:09/ Comments 2/ Personal/ Permanent Link

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

  • If you typed the page address in the Address bar, make sure that it is spelled correctly.
  • Open the home page, and then look for links to the information you want.
  • Click the Back button to try another link.

HTTP 404 - File not found
Internet Information Services

Technical Information (for support personnel)

  • More information:
    Microsoft Support


Search

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


ÌÓÊÌæ

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


About Me

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman

About Me

My name is Hamed Banaei , living at Tehran , Iran . I was born at 1981 June 21.

nothing anymore now ! I want to go out ! there pages are dynamic so I can change it later !

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


درباره من

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

حامد بنايی
متولد خرداد 1360
ساکن تهران
دانشجوی مهندسی نرم افزار دانشگاه آزاد تهران جنوب
يک دوستار مايکروسافت تا زمانی که پول از نرم افزارهايش راحت تر بيرون می آيد !
زبان مورد علاقه VB.NET ، اولين زبانی که برنامه نويسی را با آن شروع کردم Basic در Spectrum+ بود (1369)
زمانی علاقه به عکاسی داشتم الان وقتش رو ندارم !

فعلا ً همين !

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


Articles

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
will complete ASAP

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


نوشته ها

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

کتاب آموزشي ويژوال بيسيک دات نت (مقدماتي ) اين کتاب تاليف ِ من و امير است .

استگانوگرافی چيست؟

تفاوت redirect ، transfer و execute

فرم هايی با رنگ ها بهتر

اصول تکنولوژی اينترنت و وب

استفاده XML در ASP

حرکت های زيرکانه Windows .NET Server

وب سرويس چيست

تبديل صفحه کليد به فارسی در ويژوال بيسيک

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


استگانوگرافی

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

Steganography ، هنر مخفی کردن يک متن در متن ديگر ، يکی از هم خانواده های Cryptography يا رمزنگاری است که امروزه بدليل در خواست صنعت در به جا گذاشتن آثاری در فيلم های ويدئويی و صدا برای اعمال copyright استفاده فراوانی پيدا کرده است . به عمل اضافه کردن نشانه ای در عکس ، ويدئو يا صدا برای نشان دهنده هويت آن اثر ، watermarking يا fingerprinting می گويند .

بيشتر

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


فرق transfer و execute

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

رفت و آمد

در ASP.NET برای رفتن از يک صفحه web form به صفحه ديگر راه های مختلفی وجود دارد مانند HyperLink ، response.redirect ، server.transfer و server.execute .
Hyperlink : بدون شک راحت ترين راه برای رفتن از يک صفحه به صفحه ديگر استفاده از hyperlink است . وقتی کاربر در مرورگر خود روی hyperlink کليک کرد مرورگر صفحه جديد را load خواهد کرد .

<a href="WebForm2.aspx">WebForm2</a>

روش ديگر استفاده از hyperlink ، استفاده از Hyperlink Web Server Control است .

<form
id="Form1" method="post" runat="server">

<asp:HyperLink id="HyperLink1" runat="server"

NavigateUrl="WebForm2.aspx">WebForm2</asp:HyperLink>

</form>

وقتی اين کنترل بر روی web form قرار گرفت هنگام اجرا تبديل به نمونه اول می شود . با اين تفاوت که هنگام اجرا می توانيد با استفاده از خاصيت NavigateURL مسير آن را تغيير دهيد .
اگر چه hyperlink کاربر را به صفحه ديگری می برد ولی کليک بر روی آن کاملا ً در اختيار کاربر است . موقعيتی ممکن است پيش آيد که شما به عنوان برنامه نويس بخواهيد کاربر را به صفحه ديگری منتقل کنيد . در چنين زمانی استفاده از Transfer و Execute يا Redirect به کمک شما می آيند .
Redirect
استفاده از متد response.redirect باعث می شود که مرورگر URL ی که در پارامتر آن ذکر می شود را نمايش دهد . وقتی از اين متد استفاده کرديد ، سرور صفحه ای به مرورگر با header ی مشابه 302 Object Moved و آدرس صفحه جديد می فرستد . بدينوسيله مرورگر از آدرس جديد خبردار شده و صفحه جديد را باز می کند .
Transfer
وقتی سرور به server.transfer بر می خورد اجرای فايل فعلی را متوقف و شروع به اجرای فايل جديد که روی همان سرور باشد می کند . به طور پيش فرض مقاديری که در request در فايل اول است به فايل دوم ارسال نمی شود ولی اگر پارامتر دوم Transfer را True و در فايل دوم دايرکتيو ِ EnableViewStateMac را False کنيد مقادير request به فايل دوم ارسال می شود . دقت کنيد که همه اين اعمال در سرور انجام می شود بنابراين مرورگر URL صفحه دوم را نمی داند و همچنان صفحه اول را نشان می دهد .
Execute
اين متد اجازه می دهد تا در فايل اول يک aspx ديگر را صدا زده و اجرا کنيم ، سپس کنترل دوباره به فايل اول باز می گردد . با اين روش می توان توابعی را در صفحه دوم صدا زد و خروجی آنها که در response نوشته می شود را در صفحه اول استفاده کرد .
بر روی صفحه اول يک literal component قرار دهيد ، در صفحه دوم و در load آن response.write "salam" را بنويسيد . حالا در صفحه اول در رويداد کليک يک کليد اين کد را بنويسيد .

Dim sw As IO.StringWriter = New IO.StringWriter()
Server.Execute("WebForm2.aspx", sw)
Literal1.Text = sw.ToString()

حالا برنامه را اجرا کنيد ، متن salam در Literal در صفحه اول نوشته می شود .
چه موقع از کدام استفاده کنيم ؟
برای لينک به صفحه های html معمولی و وقتی اهميت ندارد کاربر چه زمانی به صفحه ديگر برود از hyperlink معمولی می توان استفاده کرد ، وقتی مسير hyperlink تغيير می کند بهتر است از کامپوننت hyperlink استفاده کنيد .
از redirect زمانی استفاده کنيد که به فايل غير ASPX يا خارج از سرور خودتان می خواهيد لينک دهيد . همچنين زمانی که در URL پارامتر هايی را بخواهيد بفرستيد .
اگر می خواهيد در روی سرور خودتان به فايل ديگر ASPX ی ارجاع دهيد از Transfer استفاده کنيد و اگر می خواهيد از خروجی فايل دوم در فايل اول استفاده کنيد از Execute استفاده کنيد .
دقت کنيد که در transfer و execute امکان تداخل کد های html وجود دارد ، اگر چنين شد از همان redirect استفاده کنيد .
ترجمه و خلاصه شده از سايت OnDotnet.com .

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


Links

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman

will complete ASAP

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


لينکستان

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

وب لاگ
آلفا
مجيد رياضی
روجا
خاطرات
زهير معصوميان
وب لاگ تخصصی
دنيای کارتون و کاريکاتور
احسان
مسافر (مهدی)
سلمان
مسافر جزيره
ولی نژاد
جاوا: موسيقي، سينما و عکاسي!
PC Online
حميد جون
آموزش VC++6
نوشته های من
بازی ها
عمو حميد
طراح وب
علی پيروز
دريا و کوه
رايانه
از کامپيوتر چه خبر ؟
برنامه نويسي با VB
يک کليک برای هميشه
وبلاگ های پارسيک
Peysab
عزتی
مداد نوکی
دات
دنيای کامپيوتر و ارتباطات
وب نگار
WebTag
رد هت
ياسمين
جاوا اسكريپتستان
VBKhatoon
دنيای کامپيوتر
ASPdotNET
کليک نهايی
PCNetworks
کامپيوتر آهوی سه گوش
راهی که در پيش است
W3Schools
جوتی
SQLServer
نتکده
دنيای من و رجيستری
OS
Kerman
TehranWeb
RayanIR
دهکده نرم افزار
شاه کليد
پرهام
نگارش
ياسان
ramin4U
Ehsanfa
پدر خوانده
Araz
حسين گيتس
babadotnet
دست نوشت
UWDG
جستجو.نت
عکس ديجيتالی
کانن
استيو
digitalphotocontest
BetterPhoto
PhotoSIG
axBlog
برنامه نويسی
MSDN
FreeVBCode
GotDotNet
IranASP
ASP-Index
برنامه نويس
ايران IT
DevCity
dotnetjunkies
DevX
DevASP.NET
ASP Workshops
dot NET 101
Extreme VB
Developer Fusion
asp.net pro
ايران دات نت
dotnetbips
DeveloperFusion
Developerdex
Computing.net
SearchVB.com
aewNET.com
DevASP.Net
expertsXchange.com
VB.NET Heaven
اخبار
بی بی سی فارسی
CNN
CNET
ZDNet
آريانيوز
جارچی
ITIran
عکس های خبری ياهو
ندا نيوز
همکاران
تک گروپ
علی پرورش
ضرب المثل
محمود بشاش
شاهو طوفانی
اميد آنلاين
شرکتهای مهم کامپيوتری
مايکروسافت
Red Hat
Sony
HP
Toshiba
IBM
Apple
Real
منابع
WindowsXP.nu
مذهبی
زندگی
الشيعه
اجرا شده با دات نت
اصفهان نصف جهان
شهيد باهنر کرمان
نشر علوم
هر کی به من لينک داده
نوت بوک يک هکر
تنها در خانه
يادداشت هاي شبانه
گپ
جزيره دور افتاده
هور آنلاين
طنين يك ترانه
ParsSky
سيپريسك
مجتبی کماليان
PersiaDesert
نيماپ
بی عنوان
IranPress
Pooya
سايتهای مفيد
HelloMahdi
ShirazIT
مجتمع دانشگاهي فناوري اطلاعات ، ارتباطات و امنيت
ISATTIS
ستاره شناسي ايران
Nezafat

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


Softwares

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Ill complete this page tonight

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


نرم افزارها

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

PPCShamsi

نرم افزار تاريخ شمسی برای PocketPC

احتياج به NETCF و فارسی ساز داريد

از اينجا دريافت کنيد

BatteryViewer

نرم افزاری برای نمايش وضعيت باتری در PocketPC 2003

با استفاده از OpenNETCF . برای اجرا احتياج به NET CF داريد

از اينجا دريافت کنيد

axBlog.NET

سايت axBlog يک پايگاه عمومی برای کسانی است که به شکل غير حرفه ای با دوربين های ديجيتالی عکاسی می کنند . می توانيد در اين سايت عضو شويد و عکسهای خود را در آن قرار دهيد . شکل ظاهری اين سايت را آقای بصری طراحی کرده اند. تکنولوژی استفاده شده در اين سايت MS .NET می باشد و برنامه نويسی آن بر عهده من است .

اين سايت به علت برخی مسائل تعطيل شد

SecondNews.com

سايت SecondNews اخبار را از مراکز خبری فارسی جمع آوری می کند و آنها را در شکلی ساده که برای مطالعه روزانه مناسب است در يک مکان جمع آوری می کند. قسمتی از برنامه نويسی نرم افزارهای اين سايت بر عهده من است.

Counter.NET

نرم افزار Counter.NET يک شمارنده هيت برای سايتها می باشد . اطلاعات بيشتر را در اين قسمت ببينيد .

Weblog.NET

Weblog.NET ابزاری است که با دات نت و با استفاده از server control ها برای ساختن وبلاگ طراحی شده است . اطلاعات تکميلی در اين بخش وجود دارد .

TimeCounter.NET

اين برنامه هم نسخه جديد همان TimeCounter قديمی است . البته قابليت شمارش 5 کار همزمان را دارد .

Assistance

اين برنامه کارهای روزانه شما رو می تونه مديريت بکنه . بخش های برنامه عبارتند از :

يادداشت

دفترچه تلفن با فيلدهای اضافه

کارها

تقويم

پيغام روزانه

حسابداری شخصی

تلفن های عمومی

سيستم عامل لازم برای اين برنامه بايد فارسی داشته باشد ، مثلا ً ويندوز پارسا ، بهترين حالت اجرای آن روی ويندوز اکس پی می باشد .

با ويژوال بيسيک نوشته و از حدود 10000 خط برنامه تشکيل شده است . حجم فايل اصلی (EXE) حدود 1.8 مگابايت و حجم کل پکيج 5 مگابايت است . برای خريدن اين برنامه می توانيد به سايت تک گروپ مراجعه کنيد .

TimeCounter

اين برنامه برای اندازه گيری زمان کارها می باشد . مثلا ً شما می خواهيد زمانی که روی يک پروژه وقت می گذاريد را بدست آوريد به راحتی اين برنامه اين کار را برای شما انجام می دهد .

بخش های برنامه :

کاربران ( حذف و اضافه و ... )

عنوان های پروژه ها

محاسبه زمان و گزارش سريع

خروجی به HTML يا Excel

کشيدن نمودار از وضعيت پروژه ها

و ...

تبديل ايران سيستم به يونيکد

با اين برنامه متن هايی که با ايران سيستم نوشته شده اند را به عربی می توانيد تبديل کنيد . بايد زبان default ِ ويندوز شما فارسی باشد . دريافت متن برنامه .

برنامه نويسی سايت انتشارات نشر علوم .

و از ديگر برنامه ها

  • DLL ی که بتوان در textbox فارسی به صورت ايران سيستم نوشت
  • سيستم اطلاعاتی هادی دانش پژوهان
  • سيستم حسابداری برای شرکت لاتسلا
  • سايت حامد بنايی دات کام.

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


How To Use XML

چگونه از فايل XML ِ سايتهای ديگر استفاده کنيم .

چندين روش برای اين کار وجود دارد . روش اول نوشتن يکباره کل متن درون XML است .

نتيجه اين روش را در صفحه می توانيد ببينيد .

برای کنترل بيشتر بر روی متن XML بايد بتوانيد هر element آن را جداگانه بخوانيد . برای اين کار از متن زير استفاده کنيد .

نمونه اين روش را در اين صفحه می توانيد ببينيد .


Articles

تبديل صفحه کليد به فارسی در ويژوال بيسيک

برای تبديل صفحه کليد به فارسی در ويژوال بيسيک 6 :

ابتدا تابع زير را تعريف کنيد :

Public Declare Function LoadKeyboardLayout Lib "user32" Alias "LoadKeyboardLayoutA" (ByVal pwszKLID As String, ByVal flags As Long) As Long

ويندوز اکس پی و 2000 که فارسی نصب شده باشد .

Dim xx As Long
xx = LoadKeyboardLayout("00000429", 1)

ويندوز پارسا 99 و امثال آن

Dim xx As Long
xx = LoadKeyboardLayout("00000401", 1)

کد 401 برای عربی عربستان است که در ويندوز پارسا 99 به جای فارسی به کار می رود .

بر روی ويندوز ME تست نشده است .

تبديل صفحه کليد به فارسی در ويژوال بيسيک دات نت :

ابتدا تابع زير را تعريف کنيد :

Private Declare Function LoadKeyboardLayout Lib "user32" Alias "LoadKeyboardLayoutA" (ByVal pwszKLID As String, ByVal flags As Integer) As Integer

در ويندوز اکس پی و 2000

Dim a as Integer

a = LoadKeyboardLayout("00000429", 1)


WebService

وب سرويس چيست ؟

کسانی که با صنعت IT آشنايی دارند حتما ً نام وب سرويس را شنيده اند . برای مثال ، بيش از 66 درصد کسانی که در نظر سنجی مجله InfoWorld شرکت کرده بودند بر اين توافق داشتند که وب سرويس ها مدل تجاری بعدی اينترنت خواهند بود . به علاوه گروه گارتنر پيش بينی کرده است که وب سرويس ها کارآيی پروژه های IT را تا 30 در صد بالا می برد . اما وب سرويس چيست و چگونه شکل تجارت را در اينترنت تغيير خواهد داد ؟

برای ساده کردن پردازش های تجاری ، برنامه های غير متمرکز (Enterprise) بايد با يکديگر ارتباط داشته باشند و از داده های اشتراکی يکديگر استفاده کنند . قبلا ً اين کار بوسيله ابداع استاندارد های خصوصی و فرمت داده ها به شکل مورد نياز هر برنامه انجام می شد . اما دنيای وب و XML – تکنولوژی آزاد برای انتقال ديتا – انتقال اطلاعات بين سيستم ها را افزايش داد . وب سرويس ها نرم افزارهايی هستند که از XML برای انتقال اطلاعات بين نرم افزارهای ديگر از طريق پروتوکول های معمول اينترنتی استفاده می کنند . به شکل ساده يک وب سرويس از طريق وب اعمالی را انجام می دهد (توابع يا سابروتين ها ) و نتايج را به برنامه ديگری می فرستد . اين يعنی برنامه ای در يک کامپيوتر در حال اجراست ، اطلاعاتی را به کامپيوتری می فرستد و از آن درخواست جواب می کند ، برنامه ای که در آن کامپيوتر دوم است کارهای خواسته شده را انجام می دهد و نتيجه را بر روی ساختارهای اينترنتی به برنامه اول بر می گرداند . وب سرويس ها می توانند از پروتکول های زيادی در اينترنت استفاده کنند اما بيشتر از HTTP که مهم ترين آنهاست استفاده می شود .

وب سرويس هر توع کاری می تواند انجام دهد . برای مثال در يک برنامه می تواند آخرين عنوان های اخبار را از وب سرويس Associated Press بگيرد يا يک برنامه مالی می تواند آخرين اخبار و اطلاعات بورس را از وب سرويس بگيرد . کاری که وب سرويس انجام می دهد می تواند به سادگی ضرب 2 عدد يا به پيچيدگی انجام کليه امور مشترکين يک شرکت باشد .

وب سرويس دارای خواصی است که آن را از ديگر تکنولوژی و مدل های کامپيوتری جدا می کند ، Paul Flessner ، نايب رييس مايکروسافت در dot NET Enterprise Server چندين مشخصه برای وب سرويس در يکی از نوشته هايش ذکر کرده است ، يک ، وب سرويس ها قابل برنامه ريزی هستند . يک وب سرويس کاری که می کند را در خود مخفی نگه می دارد وقتی برنامه ای به آن اطلاعات داد وب سرويس آن را پردازش می کند و در جواب آن اطلاعاتی را به برنامه اصلی بر می گرداند . دوم ، وب سرويس ها بر پايه XML بنا نهاده شده اند . XML و XML های مبتنی بر SOAP يا Simple Object Access Protocol تکنولوژی هايی هستند که به وب سرويس اين امکان را می دهند که با ديگر برنامه ها ارتباط داشته باشد حتی اگر آن برنامه ها در زبانهای مختلف نوشته شده و بر روی سيستم عامل های مختلفی در حال اجرا باشند . همچين وب سرويس ها خود ، خود را توصيف می کنند . به اين معنی که کاری را که انجام می دهند و نحوه استفاده از خودشان را توضيح می دهند . اين توضيحات به طور کلی در WSDL يا Web Services Description Language نوشته می شود . WSDL يک استاندارد بر مبنای XML است . به علاوه وب سرويس ها قابل شناسايی هستند به اين معنی که یرنامه نويس می تواند به دنبال وب سرويس مورد علاقه در دايرکتوری هايی مثل UDDI يا Universal Description , Discovery and Integration جستجو کند . UDDI يکی ديگر از استاندارد های وب سرويس است .

نکات تکنولوژی وب سرويس :

همانطور که در ابتدا توضيح داده شد يکی از دلايل اينکه وب سرويس از ديگر تکنولوژی های موجود مجزا شده است استفاده از XML و بعضی استاندارد های تکنيکی ديگر مانند SOAP ، WSDL و UDDI است . اين تکنولوژی های زمينه ارتباط بين برنامه ها را ايجاد می کند به شکلی که مستقل از زبان برنامه نويسی ، سيستم عامل و سخت افزار است . SOAP يک مکانيزم ارتباطی را بين نرم افزار و وب سرويس ايجاد می کند . WSDL يک روش يکتا برای توصيف وب سرويس ايجاد می کند و UDDI يک دايرکتوری قابل جستجو برای وب سرويس می سازد . وقتی اينها با هم در يک جا جمع می شود اين تکنولوژی ها به برنامه نويس ها اجازه می دهد که برنامه های خود را به عنوان سرويس آماده کنند و بر روی اينترنت قرار دهند .

شکل زير نقش هر کدام از استاندارد ها را در ساختار وب سرويس نمايش می دهد . در قسمت های بعدی هر کدام از اين تکنولوژی ها را بررسی می کنيم .

XML يا eXtensible Markup Language :

XML يک تکنولوژی است که به شکل گسترده از آن پشتيبانی می شود ، همچنين اين تکنولوژی Open است به اين معنی که تعلق به شرکت خاصی ندارد . اولين بار در کنسرسيوم WWW يا W3C در سال 1996 برای ساده کردن انتقال ديتا ايجاد شده است . با گسترده شدن استفاده از وب در دهه 90 کم کم محدوديت های HTML مشخص شد . ضعف HTML در توسعه پذيری ( قابليت اضافه و کم کردن خواص ) و ضعف آن در توصيف ديتاهايی که درون خود نگهداری می کند برنامه نويسان را از آن نا اميد کرد . همچنين مبهم بودن تعاريف آن باعث شد از توسعه يافتن باز بماند . در پاسخ به اين اشکالات W3C يک سری امکانات را در جهت توسعه HTML به آن افزود که امکان تغيير ساختار متنهای HTML مهم ترين آن است . اين امکان را CSS يا Cascade Style Sheet می نامند .

اين توسعه تنها يک راه موقتی بود . بايد يک روش استاندارد شده ، توسعه پذير و داری ساختار قوی ايجاد می شد . در نتيجه W3C XML را ساخت . XML دارای قدرت و توسعه پذيری SGML يا Standard Generalized Markup Language و سادگی که در ارتباط در وب به آن نياز دارد است .

استقلال اطلاعات يا جدا بودن محتوا از ظاهر يک مشخصه برای XML به حساب می آيد . متنهای XML فقط يک ديتا را توصيف می کنند و برنامه ای که XML برای آن قابل درک است – بدون توجه به زبان و سيستم عامل – قادر است به اطلاعات درون فايل XML هر گونه شکلی که مايل است بدهد . متنهای XML حاوی ديتا هستند بدون شکل خاص بنابراين برنامه ای که از آن می خواهد استفاده کند بايد بداند که چگونه می خواهد آن اطلاعات را نمايش دهد . بنابراين نحوه نمايش يک فايل XML در يک PC با PDA و تلفن همراه می تواند متفاوت باشد .

وقتی يک برنامه با متن XML مواجه می شود بايد مطمئن باشد که آن متن حاوی ديتای مورد نظر خود است . اين اطمينان توسط برنامه هايی با نام XML Parser حاصل می شود . تجزيه کننده ها دستورات متن XML را بررسی می کنند . همچنين آنها به برنامه کمک می کنند تا متن های XML را تفسير کند . به صورت اختياری هر متن XML می تواند به متن ديگری اشاره کند که حاوی ساختار فايل XML اصلی باشد . به آن متن XML دوم DTD يا Document Type Definition گفته می شود .

وقتی فايل XML به DTD اشاره می کند برنامه تجزيه کننده فايل اصلی را با DTD بررسی می کند که آيا به همان ساختاری که در DTD توصيف شده شکل گرفته است يا خير . اگر يک تجزيه کننده XML بتواند يک متن را به درستی پردازش کند متن XML نيز به شکل صحيحی فرمت شده است .

وقتی که اکثر نرم افزار ها امکانات وبی خود را افزايش دادند اين طور به نظر می آيد که XML به عنوان يک تکنولوژی جهانی برای فرستادن اطلاعات بين برنامه های انتخاب شود . تمامی برنامه هايی که از XML استفاده می کنند قادر خواهند بود که XML ِ همديگر را بفهمند . اين سطح بالای تطابق بين برنامه ها باعث می شود که XML يک تکنولوژی مناسب برای وب سرويس باشد ، چون بدون اينکه احتياج به سيستم عامل و سخت افزار يکسان باشد می تواند اطلاعات را جابجا کند .

SOAP يا Simple Object Access Protocol :

SOAP يکی از عمومی ترين استاندارد هايی است که در وب سرويس ها استفاده می شود . طبق شواهد اولين بار توسط DeveloperMentor ، شرکت UserLand و مايکروسافت در سال 1998 ساخته شده و نسخه اول آن در سال 1999 ارايه شده است . آخرين نسخه SOAP ، نسخه 1.2 بود که در دسامبر سال 2001 در W3C ارايه شد . نسخه 1.2 نشان دهنده کار زياد بر روی آن و نمايانگر اشتياق زياد صنعت IT برای استفاده از SOAP و وب سرويس است .

هدف اصلی SOAP ايجاد روش برای فرستادن ديتا بين سيستم هايی است که بر روی شبکه پخش شده اند . وقتی يک برنامه شروع به ارتباط با وب سرويس می کند ، پيغام های SOAP وسيله ای برای ارتباط و انتقال ديتا بين آن دو هستند . يک پيغام SOAP به وب سرويس فرستاده می شود و يک تابع يا ساب روتين را در آن به اجرا در می آورد به اين معنی که اين پيغام از وب سرويس تقاضای انجام کاری می کند . وب سرويس نيز از محتوای پيغام SOAP استفاده کرده و عمليات خود را آغاز می کند . در انتها نيز نتايج را با يک پيغام SOAP ديگر به برنامه اصلی می فرستد .

به عنوان يک پروتکول مبتنی بر XML ، SOAP تشکيل شده از يک سری الگو های XMLی است . اين الگو ها شکل پيغام های XML را که بر روی شبکه منتقل می شود را مشخص می کند ، مانند نوع ديتا ها و اطلاعاتی که برای طرف مقابل تفسير کردن متن را آسان کند . در اصل SOAP برای انتقال ديتا بر روی اينترنت و از طريق پروتکول HTTP طراحی شده است ولی از آن در ديگر مدلها مانند LAN نيز می توان استفاده کرد . وقتی که وب سرويس ها از HTTP استفاده می کنند به راحتی می توانند از Firewall عبور کنند .

يک پيغام SOAP از سه بخش مهم تشکيل شده است : پوشش يا Envelope ، Header ، بدنه يا Body . قسمت پوشش برای بسته بندی کردن کل پيغام به کار می رود . اين بخش محتوای پيغام را توصيف و گيرنده آن را مشخص می کند . بخش بعدی پيغام های SOAP ، Header آن است که يک بخش اختياری می باشد و مطالبی مانند امنيت و مسيريابی را توضيح می دهد . بدنه پيغام SOAP بخشی است که ديتاهای مورد نظر در آن جای می گيرند . ديتاها بر مبنای XML هستند و از يک مدل خاص که الگوها (Schemas) آن را توضيح می دهند تبعيت می کنند . اين الگو ها به گيرنده کمک می کنند تا متن را به درستی تفسير کند .پيغام های SOAP نوسط سرور های SOAP گرفته و تفسير می شود تا در نتيجه آن ، وب سرويس ها فعال شوند و کار خود را انجام دهند .

برای اينکه از SOAP در وب سرويس استفاده نکنيم از تعداد زيادی پروتکول بايد استفاده شود . برای مثال XML-RPC تکنولوژی قديمی تری بود که همين امکانات را ايجاد می کرد . به هر حال ، خيلی از سازندگان بزرگ نرم افزار SOAP را بر تکنولوژی های ديگر ترجيح دادند . دلايل زيادی برای انتخاب SOAP وجود دارد که خيلی از آنها درباره پروتکول آن است که فراتر از اين متن می باشد . 3 برتری مهم SOAP نسبت به تکنولوژی های ديگر : Simplicity , Extensibility و Interoperability است .

پيغام های SOAP معمولا ً کدهای زيادی ندارند و برای فرستادن و گرفتن آن به نرم افزار های پيچيده نياز نيست . SOAP اين امکان را به برنامه نويس می دهد تا بنا به نياز خود آن را تغيير دهد . در آخر بدليل اينکه SOAP از XML استفاده می کند می تواند بوسيله HTTP اطلاعات را انتقال بدهد بدون اينکه زبان برنامه نويسی ، سيستم عامل و سخت افزار برای آن مهم باشد .

WSDL يا Web Services Description Language :

استاندارد ديگری که نقش اساسی در وب سرويس بازی می کند WSDL است . همانطور که قبلا ً اشاره کرديم يکی از خواص وب سرويس ها توصيف خود آنهاست به اين معنی که وب سرويس دارای اطلاعاتی است که نحوه استفاده از آن را توضيح می دهد . اين توضيحات در WSDL نوشته می شود ، متنی به XML که به برنامه ها می گويد اين وب سرويس چه اطلاعاتی لازم دارد و چه اطلاعاتی را بر می گرداند .

وقتی که سازندگان نرم افزار برای اولين بار SOAP و ديگر تکنولوژی های وب سرويس را ساختند دريافتند که برنامه ها قبل از اينکه شروع به استفاده از يک وب سرويس بکنند بايد اطلاعاتی درباره آن را داشته باشند . اما هر کدام از آن سازندگان برای خودشان روشی برای ايجاد اين توضيحات ابداع کردند و باعث شد که وب سرويس ها با هم هماهنگ نباشد . وقتی IBM و مايکروسافت تصميم گرفتند تا استاندارد های خود را يکسان کنند WSDL بوجود آمد . در ماه مارس سال 2001 مايکروسافت ، IBM و Ariba نسخه 1.1 را به W3C ارائه کردند . گروهی از W3C بر روی اين استاندارد کار کردند و آن را پذيرفتند . هم اکنون اين تکنولوژی در دست ساخت است و هنوز کامل نشده . ولی هم اکنون اکثر سازندگان وب سرويس از آن استفاده می کنند .

هر وب سرويسی که بر روی اينترنت قرار می گيرد دارای يک فايل WSDL است که مشخصات ، مکان و نحوه استفاده از وب سرويس را توضيح می دهد . يک فايل WSDL نوع پيغام هايی که وب سرويس می فرستد و می گيرد را توضيح می دهد مانند پارامترهايی که برنامه صدا زننده برای کار با وب سرويس بايد به آن بفرستد . در تئوری يک برنامه در وب برای يافتن وب سرويس مورد نظر خود از روی توضيحات WSDL ها جستجو می کند . در WSDL اطلاعات مربوط به چگونگی ارتباط با وب سرويس بر روی HTTP يا هر پروتکول ديگر نيز وجود دارد .

اين مهم است که بدانيم WSDL برای برنامه ها طراحی شده است نه برای خواندن آن توسط انسان . شکل فايلهای WSDL پيچيده به نظر می آيد ولی کامپيوترها می توانند آن را بخوانند و نجزيه و تحليل بکند . خيلی از نرم افزارهايی که وب سرويس می سازند فايل WSDL مورد نياز وب سرويس را نيز توليد می کنند بنابراين وقتی برنامه نويس وب سرويس خود را ساخت به شکل خودکار WSDL مورد نياز با آن نيز ساخته می شود و احتياجی به آموزش دستورات WSDL برای ساختن و استفاده از وب سرويس نيست .

UDDI يا Universal Description , Discovery and Integration :

سومين استاندارد اصلی وب سرويس ها ، UDDI ، به شرکتها و برنامه نويسان اجازه می دهد تا وب سرويس های خود را بر روی اينترنت معرفی کنند . اين استاندارد در اصل بوسيله مايکروسافت ، IBM و Ariba و 50 شرکت بزرگ ديگر ساخته شده است . با استفاده از UDDI شرکتها می توانند اطلاعات خود را در اختيار شرکت های ديگر قرار بدهند و مدل B2B ايجاد کنند . همان طور که از نام آن مشخص است شرکت ها می توانند وب سرويس خود را معرفی کنند ، با وب سرويس ديگران آشنا شوند و از آن در سيستم های خود استفاده کنند . اين استاندارد جديدی است و در سال 2000 ساخته شده ، کنسرسيومی از شرکتهای صنعتی در حال کار بر روی آن هستند ؛ نسخه دوم UDDI در ماه ژوئن سال 2001 ارائه شد و نسخه سوم آن در دست ساخت است .

UDDI يک متن مبتنی بر XML را تعريف می کند که در آن شرکت ها توضيحاتی درباره چگونگی کار وب سرويس شرکتشان و امکانات خود می دهند . برای تعريف اين اطلاعات از شکل خاصی که در UDDI توضيح داده شده استفاده می شود . شرکت ها می توانند اين اطلاعات را در UDDI شرکت خود نگهداری کنند و تنها به شرکت های مورد نظرشان اجازه دستيابی به آنها را بدهند يا آنها را در مکان عمومی و د اينترنت قرار دهند . بزرگترين و مهمترين پايگاه UDDI ، UDDI Business Registry يا UBR نام دارد و توسط کميته UDDI طراحی و اجرا شده است . اطلاعات اين پايگاه در چهار نقطه نگهداری می شود ، مايکروسافت ، IBM ، SAP و HP . اطلاعاتی که در يکی از چهار پايگاه تغيير کند در سه تای ديگر نيز اعمال می شود .

اطلاعات درون اين پايگاه ها شبيه دفترچه تلفن است . White Pages که در آنها اطلاعات تماس شرکت ها و توضيحات متنی آنهاست ، Yellow Pages حاوی اطلاعات طبقه بندی شده شرکتها و اطلاعات درباره توانايی های الکترونيکی آنها می باشد ، Green Pages ، حاوی اطلاعات تکنيکی درباره سرويس های آنها و نحوه پردازش اطلاعات شرکت آنها می باشد .

اطلاعات تجاری و سرويس های شرکت ها کاملا ً طبقه بندی شده است و اجازه می دهد که به راحتی در آنها جستجو کرد . سپس متخصصان IT می توانند از اين اطلاعات استفاده کرده و شرکت ها را برای خدمات بهتر به هم متصل کنند . با اين شرح UDDI امکان پياده سازی مدل B2B را ايجاد می کند و شرکتها می توانند از سرويس های يکديگر استفاده کنند .

شرکت هايی که به UDDI علاقه نشان داده اند قدرت مند هستند و خيلی از آنها از وب سرويس و استاندارد های آن در محصولات خود استفاده می کنند . NTT Communications of Tokyo يکی از شرکت هايی است که در حال اضافه کردن توضيحاتی به ساختار UDDI است . در هر حال شرکت ها هنوز کمی درباره وارد کردن خود در پايگاه های عمومی محتاط هستند . اين چيز عجيبی نيست . شرکتها ابتدا اين امکانات را فقط برای شرکای خود ايجاد می کنند . شرکتهای بزرگ نيز برای مديريت بر سرويس های خود و اشتراک آنها بين قسمت های مختلف از اين استاندارد استفاده می کنند . وقتی اين استاندارد به حد بلوغ خود برسد و کاربران با آن احساس راحتی بکنند استفاده از آن نيز در مکان های عمومی فراگير خواهد بود .

اين تغيير رويه برای شرکت های بزرگی که B2B را به روش های قديمی اجرا کرده بودند مشکل است . بعضی نيز اشکال امنيتی بر اين روش می گيرند و مايل نيستند اطلاعاتشان را بدهند . اما با گذشت زمان و کامل شدن اين تکنولوژی و درک لزوم استفاده از آن شرکت ها چاره ای جز استفاده از آن ندارند .

مترجم : حامد بنايی Hamed@HamedBanaei.com

متن اصلی از سايت http://www.deitel.com گرفته شده است .


GDI+

فرم هايی با رنگهای بهتر

در بعضی از کامپوننت ها رويدادی به نام Paint وجود دارد که مسئول کشيدن شکل ظاهری کامپوننت است . شما می توانيد در اين رويداد کد های مخصوص خودتان را بنويسيد تا مثلا ً رنگ کامپيوننت را تغيير دهيد . بهترين مثال اين کامپوننت ها Form است . برای تست کردن ابتدا يک فرم به پروژه خود اضافه کنيد ، قبل از تعريف کلاس فرم اين سه خط را اضافه کنيد .

Imports System.Drawing

Imports System.Drawing.Drawing2D

Imports System.Drawing.Color

در سابروتين ِ Load ِ فرم اين خط را بنويسيد تا در صورت تغيير اندازه فرم کل آن دوباره کشيده شود .

Me.ResizeRedraw = True

حالا در رويداد Paint اين خطوط را بنويسيد .

Dim rect As New Rectangle(0, 0, Me.Width, Me.Height)

Dim mBrush As New LinearGradientBrush(rect, Pink, _

BlueViolet, LinearGradientMode.ForwardDiagonal)

e.Graphics.FillRectangle(mBrush, rect)

خط اول يک مستطيل را که اندازه آن برابر با اندازه فرم است تعريف می کند . خط دوم که ادامه اش در خط سوم آمده يک Brush از نوع LinearGradientBrush می سازد که در پارامتر اول آن مستطيلی که بايد بکشد مشخص می شود در پارامتر دوم و سوم دو رنگ که بايد در طول اين مستطيل به هم تبديل شود مشخص می شود و آخرين پارامتر مربوط به نوع تبديل اين دو رنگ است . خط سوم هم مستطيل تو پری با استفاده از اطلاعات قبلی می کشد . حالا برنامه را اجرا کنيد .

رويداد Paint در بعضی از کامپوننت های ديگر مثل Button نيز وجود دارد . يک Button بر روی فرم قرار دهيد و در رويداد Paint آن اين خطوط را بنويسيد .

Dim rect As New Rectangle(0, 0, Button1.Width, Button1.Height)

Dim mBrush As New LinearGradientBrush(rect, Aqua, Blue, _

LinearGradientMode.BackwardDiagonal)

Dim mBrush2 As New SolidBrush(Black)

Dim myfont As New Font("Tahoma", 8, FontStyle.Regular)

e.Graphics.FillRectangle(mBrush, rect)

e.Graphics.DrawString("salam", myfont, mBrush2, 10, 10)

و سپس برنامه را اجرا کنيد .


Windows .NET server

حرکت های زيرکانه Windows .NET Server

بررسی ميزان افزايش امنيت ، يکپارچگی و فايده های Windows .NET Server برای برنامه نويسان

مايکروسافت حرفهای بزرگی درباره امکانات ويندوز آينده اش می زند . Windows .NET Server در اوايل سال 2003 ارائه خواهد شد . برای داشتن يک پيش زمينه درباره آن نويسنده مجله دات نت ، Patrick Meader با رييس بخش محصولات مايکروسافت ، Jay Paulus صحبت کرده است . ببينيم مايکروسافت چه چيزهايی را در ويندوز آينده اش برای برنامه نويسان ايجاد کرده و اينکه آيا ادعای مايکروسافت درباره امنيت اين سيستم صحت دارد ؟

Jay Paulus

مجله دات نت يا NM : کليف ريو معاون مديريت در بخش تجاری Windows .NET Server گفته است ، بزرگترين تغيير در Windows .NET Server تاکيد بر روی برنامه نويس هاست . لطفا ً کمی توضيح دهيد .
Jay Paulus يا JP :دات نت Framework را از ابتدا در Windows .NET Server قرار داديم . مايکروسافت در حال دور شدن از طرح قديمی و کلاسيک Application Server ها و استفاده از COM+ است . مانند IIS و AD يا Active Directory که از آن روش ها استفاده می کنند . هم اکنون برنامه نويس می تواند از تمام مزيت های دات نت و XML WebService ها استفاده کند . با Windows .NET Server نسل جديدی از برنامه ها را بوجود آورديم که شرکتهای تجاری بوسيله سيستم های قبلی امکان ايجاد آن را نداشته اند . شما به Application Server به عنوان بخشی از يک Application Platform احتياج داريد . اين يکپارچگی به اين معنی است که برنامه نويس و Admin سيستم با اجرای اين برنامه ها به صورت Web Based مانند بخش بندی کردن هر برنامه برای جلوگيری از تداخل آنها و بحثهای امنيتی ؛ به تمام اجزای آنها کنترل دارند .

NM : شما جنبه يکپارچگی را ذکر کرديد ، خيلی از اين امکانات برای يکپارچگی و ديگر قدرت های Windows .NET Server هم اکنون در Service Pack ها و برنامه های جنبی وجود دارد و می توان آنها را بر روی ويندوزهای فعلی نصب کرد . وقتی چنين امکاناتی وجود دارد چه احتياجی به Windows .NET Server است ؟

JP : اين سوالات را زياد شنيده ايم ؛ "من هم اکنون می توانم از دات نت در ديگر ويندوز ها استفاده کنم ، Windows .NET Server چه امکان ويژه جديدی دارد ؟" ، جواب اين سوالات به دو بخش مربوط می شود . يکپارچگی در دات نت تنها از نقطه نظر انتشار(deploy) نرم افزار مورد نظر است . ديگر نيازی به نگرانی برای انتشار نرم افزارها نيست و می دانم که مطمئنا ً نرم افزار من بدون مشکل بر روی سيستم ديگری کار خواهد کرد . نکته دوم يکپارچگی در IIS6 که يک بار ديگر از اول نوشته شده است می باشد . در ساختار جديد IIS کنترل بيشتری بر روی محدود کردن نرم افزار های تحت وب و استفاده مجدد(Application Recycling) از آنها داريم . می توانيم تعداد يک يا چند برنامه را در pool قرار دهيم و هر pool تنظيمات مربوط خودش را دارد . همچنين برنامه های در هنگام اجرا در يک محيط مجزا اجرا می شود . (isolated)
اين تخييرات از نظر برنامه نويس با اينکه در نحوه نوشتن برنامه ها تغيير خواصی صورت نمی گيرد ولی يک مزيت به شمار می آيد . زيرا سرعت بيشتر در اجرا ، امنيت بيشتر و قابليت توسعه نرم افزارها را به برنامه نويس می دهد . همه اينها به خاطر اين است که اين pool ها مستقيما ً با Kernel-Mode HTTP Listener در ارتباط هستند . اين امکانی که در Windows .NET Server وجود دارد مسئول اجرای تمامی درخواست هايی است که از IIS می رسد . همچنين UDDI نيز به شکل پيش فرض در Windows .NET Server جای گرفته است .
UDDI در حالت يک Yellow Page برای منابع برنامه نويسی است . شرکت های بزرگ اين امکانات را می خواهند اما پشت فايروال های خودشان . برای همين ، امکان Authentication را از روی AD به UDDI هم اضافه کرديم ، بنابراين به غير از لايه های امنيتی که در UDDI وجود داشت لايه ديگری نيز به آن افزوده شد . اين امکانات زمان طراحی بودند .
از ديدگاه زمان اجرای برنامه ها Windows .NET Server امکان ساختن برنامه های پويا را به شما می دهد . برای مثال ، فرض کنيد که يک شرکت مالی را مديريت می کنيد فرض کنيد که سيستمی می خواهيد که بازرگانان اطلاعات مورد نياز خود را در آن پيدا کنند . مطمئنا ً شما می خواهيد که آن ها از آخرين اطلاعات به شکل پويا استفاده کنند . حالا فرض کنيد که می خواهيد مدلی که برای آنها ايجاد کرده ايد را با مدل جديدتری جابجا کنيد . شما آن مدل را در UDDI ثبت کرده ايد و در تعريف آن گفته ايد که به صورت پويا دنبال نسخه های جديد مدل خود بگردد و اگر پيدا کرد آن را با سيستم فعلی عوض کند . اين روش برای گردش به دنبال سرويس های جديد يک استاندارد خواهد شد .
يک سناريو ديگر ، فرض کنيد شما دفاتر فرعی برای شرکتتان داريد و می خواهيد که يک برنامه مرکزی از فروش آنها گزارش کلی تهيه کند . اگر از UDDI برای ثبت آن دفاتر استفاده کنيد ، وقتی که يک دفتر جديد به سيستم اضافه شود شما آن را در UDDI ثبت می کنيد . اين بدين معنی است که برنامه مرکزی می فهمد يک دفتر جديد به ليست اضافه شده است و از آن نيز در گرفتن اطلاعات استفاده می کند . تمام کاری که شما به عنوان برنامه نويس بايد انجام دهيد ثبت سرور جديد در UDDI است ديگر احتياجی به تغييری در برنامه مرکزی نداريد . در حقيقت شما چيزی شبيه Late-Binding Web Service – يک برنامه کاملا ً پويا که از UDDI به عنوان يکی از هسته های مرکزی خود استفاده می کند – داريد .

NM : اجازه بدهيد درباره امنيت که يکی از مشکلات اساسی اين گونه سيستم ها است صحبت کنيم . مايکروسافت چندی پيش تصميم گرفته است که اهميت بيشتری به موضوع امنيت بدهد . چه نقطه با اهميتی در Windows .NET Server وجود دارد که کاربران ، Admin ها و برنامه نويس ها بايد به دنبال اين ويندوز بيايند ؟

JP : مهمترين چيزی که برنامه نويس ها بايد بدانند اين است که کل خدمات اين ويندوز در حالت اوليه بسته شده است . عقيده بر اين است که کل سيستم عامل از ابتدا با درجه امنيت بالا باشد و اين به برنامه نويس ها اين امکان را می دهد که برنامه هايی با امنيت بالاتر بنويسند . اين فقط درباره امنيت در OS نيست بلکه کاربران هم بايد بدانند که چگونه از سيستم ها استفاده کنند تا امنيت نرم افزارهايشان حفظ شود .
بسته بودن خدمات در حالت اول دارای نکات کاربردی مهمی است . برای مثال وقتی برنامه نويس ها ويندوز 2000 را نصب می کردند IIS نيز نصب می شد . در Windows .NET Server خيلی از امکانات به شکل اوليه بسته هستند و برای اينکه از آنها استفاده کنيد بايد از Wizard های موجود استفاده کنيد . حالا فرض کنيد يک سرور داريد که می خواهيد خدمات وب هم بدهد . شما بايد بعد از نصب ويندوز با استفاده از Wizard مخصوص پورت 80 را باز کنيد و IIS را به کار بياندازيد . اما هنوز IIS نيز قفل شده است تمام کاری که در اين حالت انجام می دهد دادن سرويس به صفحه های ايستا است بنابراين ريسک استفاده از آن کم است . برای اجرای برنامه های در IIS بايد از Wizard مخصوص استفاده و آن برنامه را آزاد کنيد . اگر شما سرور Index می خواهيد بايد آن را فعال کنيد ، يا اگر بخواهيد از front-page server extension استفاده کنيد هم بايد آن را فعال کنيد . به همين شکل اگر بخواهيد از ASP و يا ASP.NET استفاده کنيد بايد آنها را نيز فعال کنيد .

NM : شما چگونه همه اين کارهای را انجام می دهيد و شعار استفاده آسان محصولات را می دهيد ؟
JP : Wizard ها کمک خيلی خوبی هستند . اما تغييراتی در رويه مايکروسافت داده شده است . در گذشته مايکروسافت فقط به مفيد بودن و استفاده راحت فکر می کرد . من فکر می کنم که عوام به طور کل به ما می گويند که سادگی استفاده را دوست دارند ولی امنيت در درجه بالاتری قرار دارد . بنابراين هميشه بايد برای هدف هزينه هايی را نيز پرداخت کرد . ما در حال تلاش هستيم که مردم هر دوی اينها را در سيستم های ما داشته باشند .

NM : يک گزارش جديد از گروه گارتنر مشخص کرده است که شرکتها به علت حمله های زيادی که به IIS می شود آن را رها می کنند . مهمترين دليلی که برای اين کار می آورند ناموفق بودن Admin ها در نصب patch هايی است که شما برای ويندوز و IIS می دهيد . آيا مايکروسافت فکری برای اين مشکل کرده است ؟
JP : بله ، ما يک محيط گرافيکی جديد برای نصب patch ها ايجاد کرده ايم که کار مردم را آسان می کند . کار زيادی بر روی کل ساختار اين قسمت از ويندوز شکل گرفته تا کار Admin ها را آسان کند . مدل جديدی ايجاد شده است که شرکت ها برای خود يک Windows Update Server دارند . شرکت ها patch ها را برای اين سرورها قرار می دهند و به شکل خودکار ديگر سرورها patch های مورد نياز خود را از آنجا دريافت می کنند . اين روش کارهايی که برای update شدن ويندوز انجام می شد را کمتر می کند .

با تلخيص
منبع
http://www.fawcette.com/dotnetmag

مترجم : حامد بنايی


Counter.NET

درباره و روش استفاده

دريافت

آخرين بروز رسانی : 2002/12/23

درباره و روش استفاده :

Counter.NET يک فايل DLL برای شمارنده يا Counter سايتها می باشد . اين برنامه اطلاعات را در يک فايل Access ذخيره می کند .

ابتدا فايل فشرده شده که حاوی فايل DLL اصلی ، DLL تاريخ شمسی و فايل Access می باشد دريافت کنيد . سپس در ويژوال استوديو يک پروژه جديد برای مثال با نام myCounterTest بسازيد .

حالا فايلهای DLL را در دايرکتوری Bin از پروژه جديدی که ساخته ايد کپی کنيد . فايل MDB را هم در دايرکتوری DB کپی کنيد .

در قسمت References اين دو فايل را اضافه کنيد .

از toolbox يک Table انتخاب و بر روی webform قرار دهيد .

اين خط را در بالای کد های webform بنويسيد .

Imports CounterDLL.HamedBanaei

حالا در سابروتين ِ Load از WebForm اين خطوط را بنويسيد .

Dim x As New MyCounter()

با اين خط يک نمونه از کلاس MyCounter می سازيد .

x.DBPath = Server.MapPath("db/counterdb.mdb")

آدرس فايل ديتابيس را بوسيله اين property وارد می کنيد .

x.RequestData = Request

آبجکت Request را برای دريافت اطلاعات مرورگر و سيستم عامل ست می کنيد .

Response.Write(x.IncreaseCounter("mymain"))

تعداد هيت های صفحه mymain را يکی اضافه می کند . برای هر صفحه می توانيد يک اسم داشته باشيد ، مثلا ً mainpage ، testpage يا هر چيز ديگر . اگر از قبل آن نام در ديتابيس وجود داشته باشد مقدار آن را يکی اضافه می کند و اگر آن نام وجود نداشته باشد آن را ايجاد می کند و مقدار يک را برای آن در نظر می گيرد .

Response.Write(x.CounterValue("mymain", MyCounter.CounterValueKinds.Today))

بوسيله اين تابع می توانيد تعداد هيت های يک صفحه ( مانند mymain ) را از ديتابيس بخوانيد . پارامتر دوم مشخص می کند که کل هيت ها باشد يا فقط هيت های امروز .

Dim ds As New DataSet()

ds = x.GetBrowserPercent("mymain")

خروجی تابعی که در صد استفاده از مرورگر ها يا سيستم عامل ها را می دهد يک DataSet است که در جدول آن ، فيلد اولش نام مرورگر يا سيستم عامل و فيلد دوم در صد آن در صفحه مورد نظر است .

Response.Write("<br>")

Dim i As Integer

For i = 0 To ds.Tables(0).Rows.Count - 1

Response.Write(ds.Tables(0).Rows(i)(0) + " " + ds.Tables(0).Rows(i)(1).ToString + " <br>")

Next

نوشتن اطلاعات جدول .

ds = x.GetOSPercent("mymain")

For i = 0 To ds.Tables(0).Rows.Count - 1

Response.Write(ds.Tables(0).Rows(i)(0) + " " + ds.Tables(0).Rows(i)(1).ToString + " <br>")

Next

x.GetChart(MyCounter.Dates.LastWeek, "mymain", Table1)

بوسيله GeChart می توانيد نموداری مانند آنچه من در سايتم دارم داشته باشيد . پارامتر اول تعداد روزهای نمودار است ، پارامتر دوم نام صفحه مورد نظر و سوم همان جدولی است که بر روی webform ايجاد کرده ايد .

x = Nothing

نتيجه نهايی :

شما برای اينکه فقط يک هيت ثبت کنيد می توانيد از 5 خط اول مثال استفاده کنيد . برای کشيدن نمودار و استفاده از ديگر اطلاعات از webform ديگری استفاده کنيد .

در صورت وجود هر گونه ايراد يا پيشنهاد به من نامه بدهيد .

دريافت :

CounterNEt.zip 22KB

متن برنامه بالا 30 کيلوبايت

اين صفحه نمونه فايل بالاست .

www.HamedBanaei.com


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Being invisible

Is it good to use your real identity over internet ?

I think the answer is depend on your country and your social rules . Here in Iran it seems to be a problem , I wish I never started my weblog over this domain ! being invisible in Iran is a good idea ! I closed my account at Orkut and other social networking sites .
2005 Oct 17 ,Mon 19:15/ Personal
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Lets Start
Hello World
2005 Oct 15 ,Sat 17:09/ Personal
Name : Keyvan Nayyeri
Email : keyvan [this is our at sign] keyvannayyeri.com
Site : http://www.nayyeri.net
Comment : Welcome back )
Time : 2005 Oct 15 ,Sat 17:12
Name : Kasra Tayefeh
Email : tayefeh [this is our at sign] gmail.com
Site :
Comment : Happy new blog ! Sir !:)
Time : 2005 Oct 18 ,Tue 15:43
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
How beautiful is iMac G5

Ali Rastegar , one my old friends bought an iMac G5 around $2500 . It is too expensive comparing to my current PC (Intel P4 3GHz , 1GB RAM , gForce 6600 , 100GB HDD , 17" LG LCD … ) which is near $1200 , But iMac is very very very nice ! I like it ! . The problem is I am a software developer using MS technologies but I can not use them on Mac . also we have another problem here in Iran , softwares for Mac are not available like softwares for Windows .
Here are some screen shots from his Mac
1 2 3 4
2005 Oct 25 ,Tue 12:44/ Geek
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
How To Post Comment
Click on Permanent link of the post !
2005 Oct 17 ,Mon 19:23/ Hobby
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
remaining items

At last Keyvan won ! I started English weblog ! I have to add RSS and some cookies to this site also other pages like software , articles and ... are still waiting for english content .

All of my visitors are familiar with Persian language , so I really don't need to write in English , but I hope that I can find none Persian friends via my English site , and can contact with the other people .

Since 9 month ago which the best ISP around , DATAK , started its IP Wireless service , my life is changed . Being online for 24/7 was a dream and now it is became true ! This service is not very high speed (128/32) but it is more more better than dialup ! I think its price is the same as 1Mbps or more at US ! $50 per month .

The best feature for this English web site is I can say anything I want ! which is not possible at my Persian site ! (they are watching me !! they closed my axblog).

at last , sorry for my poooooor english !
2005 Oct 15 ,Sat 18:48/ Personal
Name : JraNil
Email : i [this is our at sign] jranil.net
Site :
Comment : Happy new job hamed. we are waiting for the next one :D shall be something like Photoblog !!!
Time : 2005 Oct 17 ,Mon 06:02
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Stream Video Over Network

I found a source code to get video from webcam and show it in a picturebox , but how can I stream it over network ? I want to use that video in other Windows apps .

I had a solution but I didn't try it , I can start a dll which is running over another machine by remoting , I can use a shared picturebox as a property in that dll , fill that picturebox by webcam machine and show it by other clients , I wish every day had more than 24 hours for geeks ! I have to test this method .
2005 Oct 17 ,Mon 19:24/ Geek
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
AJAX
Here is a good article about using AJAX methods .
2005 Oct 17 ,Mon 19:36/ Hobby
Name *
Email * *
Web Site *
Comment *

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
Being invisible
remaining items
Lets Start

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
AJAX
How To Post Comment

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
How beautiful is iMac G5
Stream Video Over Network

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

ويندوز موبايل 2005
تاريخ شمسی جديد
iMac G5

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
How beautiful is iMac G5

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
remaining items
Lets Start

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

Main Page
About Me
Softwares
Gallery
Search
Links
Writings
Archive
فارسی

Blogs I read(ENs)

Keyvan
Scoble
Hanselman
AJAX
Stream Video Over Network
How To Post Comment
Being invisible

I like These Websites

Microsoft Channel9 Coding4Fun TextAmerica


HamedBanaei.com

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


HamedBanaei.com

صفحه اصلي
درباره من
نرم افزارها
گالری
جستجو
لينکها
نوشته ها
آرشيو
English

DVD Player
بلاگفا

دوستان

محمد فروتن امير احساني کيوان نيري علي پرورش techopedia p30world علي حاج شفيعيها

مفيد

اول سوال هاي خود را از اين سايت بپرسيد بعد به ديگران ايميل بدهيد !

شما هم PocketPC يا گوشي هاي موبايلي که از Symbian استفاده مي کنند داريد؟ اين سايت مفيد ِ فکر کنم !

Channel 9
GTA San Andreas Doom3


Weblog.NET

صفحه اصلی

درباره

نرم افزار Client

نرم افزار Web Service

نرم افزار Server Control

سوالهای شما
اخبار

2004/04/03 نسخه دوم آماده شد . اطلاعات بيشتر در مورد نسخه دوم .

برنامه Client

با استفاده از اين برنامه می توانيد اطلاعات خود را در سرور کنترل کنيد . فرستادن متن جديد ، ويرايش و حذف و ديگر امکانات در اين قسمت انجام می شود . برای اجرای اين برنامه احتياج به نصب Net Framework. و ويندوز 98 به بعد داريد .

آخرين بروز رسانی : 2004/01/23

اطلاعات بيشتر

برنامه WebService

اين برنامه ، واسط بين برنامه Client و بانک اطلاعاتی بر روی سرور است .

آخرين بروز رسانی : 2003/12/12

اطلاعات بيشتر

برنامه Server Control

اين برنامه حاوی قسمت هايی است که بينندگان سايت شما آن را مشاهده می کنند .

آخرين بروز رسانی : 2003/11/16

اطلاعات بيشتر

من برنامه نويس نيستم ، چگونه از اين سيستم می توانم استفاده کنم .

آخرين بروز رسانی : 2003/12/14


 Thumbnail

يک برنامه برای تغيير اندازه عکس ها . ظاهرش که قشنگه !

تبديلات

تبديل DVD به AVI و DivX . لينکش .

خاطرات کودکی !

توضيحاتی درباره بازی Mortal Kombat: Deadly Alliance را در اينجا بخوانيد .

MultiZilla

MultiZilla مرورگری است مبتنی بر Mozilla با اين تفاوت که Tab و برخی امکانات ديگر را بيشتر از موزيلا دارد .