ICTNA :: Information and Communication Technology News Agency

| صفحه اول | درباره ما | تماس با ما | ارسال خبر | پيشنهاد سوژه | ورود به سایت | نويسندگان | عضويت | خدمات | جستجو | عضويت در خبرنامه ها | سايتهای مرتبط |

طبقه بندی

ا خبار

اخبار اختصاصی

امنيت

مقاله

گزارش

مصاحبه

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌ ‌
تبليغات

سفارش آگهی
مقاله

جمعه، 4 آذرماه 1384

نخستین نگاه به OpenOffice.org 2.0

باند شهروندان;چگونه عمل كنيم؟

راديوهاي "FRS" سرويس راديويي خانوادگي

راديوآماتور كيست؟
جمعه، 27 آبانماه 1384

پنج روش رايگان براي افزايش ترافيك وب‌سايت
جمعه، 20 آبانماه 1384

نقش R&D در نوآوري و موفقيت شركت‌ها
سه شنبه، 17 آبانماه 1384

با Thin Clientها آشنا شويد
جمعه، 13 آبانماه 1384

راهنماي ابزار پيكربندي PPP در لينوكس
شنبه، 7 آبانماه 1384

حفظ مشتری با استفاده از خدمات پست الکترونيک
پنجشنبه، 5 آبانماه 1384

فروشگاه‌ آينده و نگراني درباره سوء استفاده از RFID
یکشنبه، 1 آبانماه 1384

بررسي شاخص‌هاي جهاني فناوري ارتباطات و اطلاعات
شنبه، 30 مهرماه 1384

FreeBSD انتخابي ديگر

دندان هاي آبي براي يك هدست

تهيه قوانين و مقررات براي كيفيت ارائه خدمات
سه شنبه، 26 مهرماه 1384

نگاهي دوباره: سولاريس ۱۰ رويدادي در دنياي اپن سورس

تخصص شبكه و مدرك ‍‍‍CCNP
یکشنبه، 24 مهرماه 1384

سامانه نمایشگر موقعیت اضطراری

مختل كننده‌ تلفن‌هاي همراه

تلفن همراه – ابزار تجارت همراه
پنجشنبه، 21 مهرماه 1384

پدر فراموش شده كامپيوتر
پنجشنبه، 7 مهرماه 1384

آشنايي با مسيريابهاي سيسكو
جمعه، 1 مهرماه 1384

مروري بر ويژگي هاي نسخه 5.0.1 بانك اطلاعاتي MySQL

آشنايي با پروتكل SSL و عملكرد آن
شنبه، 19 شهریورماه 1384

نگاهي به امكانات نسخه جديد SQL Server 2005
چهارشنبه، 16 شهریورماه 1384

+ADSL2 - ADSL2 عبور از مرزهاي سرعت
پنجشنبه، 10 شهریورماه 1384

آشنايي با مسيريابهاي سيسكو

فن آورى Bluetooth چيست ؟

راهنماي خريد: هرآنچه كه بايد درباره MP3 Player بدانيم
سه شنبه، 8 شهریورماه 1384

واحدهای سازنده مديريت روابط با مشتری (CRM)

ساخت CDهاي Autorun
یکشنبه، 6 شهریورماه 1384

ده اصطلاح رايج
شنبه، 5 شهریورماه 1384

WiMax استاندارد جديد شبكه هاي بي سيم
یکشنبه، 30 مردادماه 1384

هفت اشتباه بزرگ در تجارت الكترونيك‌
شنبه، 29 مردادماه 1384

آشنايي با ISA Server 2004
جمعه، 28 مردادماه 1384

تدوین نرم افزار بهینه سازی شبکه ارتباط سیار در قالب یک پروژه ملی ضروری است
پنجشنبه، 27 مردادماه 1384

CIO كيست ؟!

فلسفه اپن سورس

پورتال چیست؟
دوشنبه، 24 مردادماه 1384

آينده شبكه هاي بيسيم
یکشنبه، 23 مردادماه 1384

نرم‌افزارهاي ساخت Flash
شنبه، 22 مردادماه 1384

پروتكل امنيتي Kerberos
پنجشنبه، 20 مردادماه 1384

پورتال چيست؟
چهارشنبه، 19 مردادماه 1384

ماشين رياضي جديدي براي رام كردن اعداد اول

به دنياي Live Linux خوش آمديد
شنبه، 15 مردادماه 1384

استانداردهاي امنيت‌
سه شنبه، 11 مردادماه 1384

مقدمه اي بر Dot NET Remoting
چهارشنبه، 29 تیرماه 1384

چگونه مي توانيد سايت خود را روي اينترنت قرار دهيد؟
دوشنبه، 27 تیرماه 1384

نگاهي به‌سند راهبردي امنيت فضاي تبادل اطلاعات كشور
یکشنبه، 26 تیرماه 1384

آشنائى با عناصر يک شبکه محلى
دوشنبه، 20 تیرماه 1384

XML - اين خوان هفت‌رنگ‌
جمعه، 17 تیرماه 1384

صنعت طراحی وب ایران: هر چقدر که تيغ مى برد
پنجشنبه، 16 تیرماه 1384

مكا نيسم هاى پرداخت در تجارت الكترونيك
سه شنبه، 14 تیرماه 1384

نگاهي به لايحه آزادي اطلاعات

نقش زنان در جامعه‌ اطلاعاتي
شنبه، 11 تیرماه 1384

آشنائى با گواهينامه هاى وب سايت
جمعه، 10 تیرماه 1384

ترجمه فارسی پروانه BSD

شرکت بزرگی که به جنبش بازمتن پیوسـت

نقش‌های یک مدیر سیستم
شنبه، 14 خردادماه 1384

يك سيستم پرتال چيست و چگونه كار مى كند ؟
چهارشنبه، 11 خردادماه 1384

آیا XML جواب همه چیز است ؟

آشنایی با CVS

نصب و پیکربندی سرویس‌دهنده Squid

آشنایی با وظایف یک مدیر سیستم

آشنایی با automount و autofs

ترجمه فارسی Sun Industry Standards Source License

AbiWord : واژه‌پرداز سبک و کار
یکشنبه، 8 خردادماه 1384

وضعيت بازار شبكه‌هاي محلي بي‌سيم
دوشنبه، 2 خردادماه 1384

جايگاه زنان در جامعه اطلاعاتى: يک ديدگاه جامعه شناختى
شنبه، 31 اردیبهشتماه 1384

70 درصد توليد ناخالص ملي كشورها متاثر از فناوري اطلاعات است

آشنايي با سيستم فايل GNU/Linux

استاندارد شبكه‌های محلی بی‌سيم

نگاهی بر ورای 3G بی‌سيم

نسل جديد SCSI
سه شنبه، 27 اردیبهشتماه 1384

نصب و پیکربندی NAT در Windows 2003
سه شنبه، 20 اردیبهشتماه 1384

مديريت شبكه چيست؟
شنبه، 10 اردیبهشتماه 1384

انواع تلفن گويا در بازار محصولات تلفن گويا

راه هايى آسان براى جلب مشتريان به سايت
سه شنبه، 30 فروردینماه 1384

مزيت ما در بخش نرم‌افزار است
دوشنبه، 29 فروردینماه 1384

پايگاه داده هاى پيشرفته

ارزيابي، كليد طلايي موفقيت سايتهاي اينترنتي
یکشنبه، 28 فروردینماه 1384

با انواع DVD آشنا شويد
پنجشنبه، 25 فروردینماه 1384

ويندوز "Longhorn" چيست؟

شبکه‌ي ارتباطات چيست؟
دوشنبه، 15 فروردینماه 1384

دسترسي آسان به دنياي اطلاعات
پنجشنبه، 11 فروردینماه 1384

اندر احوالاتٍ آژاکس
دوشنبه، 8 فروردینماه 1384

بابيلون چيست؟
یکشنبه، 7 فروردینماه 1384

سال 1384 براي طراحان وب: حرکت به سوي طراحي مبتني بر CSS

امضاء ديجيتالي و كاربرد آن در حفظ امنيت شبكه
پنجشنبه، 4 فروردینماه 1384

سیمبیان چیست ؟
پنجشنبه، 20 اسفندماه 1383

نصب اسکوئید در سه سوت !

بانك‌هاي اطلاعاتي بسيار بزرگ، دي‌بي2 يا آداباس
دوشنبه، 17 اسفندماه 1383

حقيقت سرورهای مجازی

اصول ERP

مدیریت پروژه

چرا بايد به مدرسه برگرديم

بهبود کار

آنچه اينترنت نمي تواند انجام دهد

آنارشي و اينترنت
پنجشنبه، 13 اسفندماه 1383

نكته براى مقاله نويسى در www
دوشنبه، 10 اسفندماه 1383

براي بالا بردن ارزش فعاليت‌هاي IT بايد مانند يک مدير اجرايي بينديشيد
یکشنبه، 9 اسفندماه 1383

برآورد اندازه‌ى پروژه‌هاى نرم‌افزارى
سه شنبه، 4 اسفندماه 1383

استفاده از پنج محرك خريد براى افزايش فروش
دوشنبه، 3 اسفندماه 1383

TCP/IP عرضه کننده‌ی توانایی‌های روبه رشد شبکه‌ای

روان‌شناسى در IT
جمعه، 30 بهمنماه 1383

درسهايي از اتخاذ سياست صنعتي در برزيل و چين

"تلفن اينترنتي" و تحولاتي که در عرصه مخابرات در حال وقوع است

مدلسازى (Modeling)
پنجشنبه، 29 بهمنماه 1383

43 درصد از اولین بازديدهای اینترنتی ، از طریق موتورهای جست و جو گر صورت می گیرد

امنيت اطلاعات در كار الكترونيكى
چهارشنبه، 28 بهمنماه 1383

کارايى سرويس دهنده وب يکى از کارهاى جديد در طراحى سرويس دهنده ها است
دوشنبه، 26 بهمنماه 1383

بررسی معماری سرویس گرا

بررسى و شبيه سازى تکنيک هاى جمينگ در ماهواره ها و سيستم هاى فضايى

نگاهى به استانداردهاى امنيتى اطلاعات و ارتباطات
شنبه، 24 بهمنماه 1383

مجلس راه ميانه‌اي ندارد: يا اصلاح حداقلي يا اصلاح انقلابي

Boot Managerها در يك نگاه

سیستم عاملی به اندازه یک دیسکت

پنج روز تاخت و تاز در اینترنت
پنجشنبه، 24 دیماه 1383

طرح استفاده فراگير از سيستم عامل لينوكس در كشور(در مواجهه با چالش‌هاي پيش رو)

آيا گوگل به شما لبخند خواهد زد؟

نگاهي به قابليت‌هاي لينوكس

جرایم رایانه ای (۳):عصر اطلاعات

جرایم رایانه ای (۲) آرپانت، هكرها، كركرها و فريك‌ها

جرايم رايانه ای:‌مقدمه‌اى بر جرم، عدالت و مجازات( بخش نخست)

نگاهى به لايحه حريم خصوصى

مديريت زنجيره تامين

جايگاه اينترنت در هنگ کنگ

دشوارى هاى روزنامه نگارى IT:هشت سال بايكوت

اخراج از سرور به خاطر انتقاد

درخواست بانك‌ها روى ميز مديران شتاب

مسئولان جرايم رايانه اى اين مقاله را بخوانند!

هزارتوى مناقصه هاى شرکت مخابرات

روزنامه نگارى اينترنتى ،بيم ها و اميدها

وب هاستينگ اختصاصى يا اشتراکى؟

سالى که نکوست از بهارش پيداست

توليد محتواى فارسى

واقعیت این است : پارس آنلاین آی اس پی خوبی نیست!

پنج اشتباه در استفاده از آموزش الکترونيکى

سال 83 : سال حمايت از توليد محتواى فارسى روى وب

ارزیابی فروش نرم افزارهای ERP
چهارشنبه، 23 دیماه 1383

روزنامه نگارى آنلاين ،مدلسازى براى رسانه هاى خبرى در وب
سه شنبه، 22 دیماه 1383

شبکه Wi-Fi الکامپ امن نيست !

بررسی حملات DOS

ده اقدام براى تعديل رفتار استفاده‌كنندگان از خدمات و كاهش هزينه‌هاى IT
شنبه، 19 دیماه 1383

همه چيز در مورد اولين ويروس موبايل

پايان سلطنت نوکيا بر بازار موبايل

فناوری استرس
سه شنبه، 1 دیماه 1383

آيا تلفن همراه واقعا مضر است ؟!

تاريخچه پارازيت
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر
موافقت نامه سايت
ايستنا :: آژانس خبری فناوری اطلاعات و ارتباطات
© کليه حقوق متعلق به سايت ايستنا و گروه همکاران سايت ميباشد.
اخلاق و منش انسانی نقل محتوای توليد شده توسط اين سايت را مشروط به
درج منبع با عنوان کامل آژانس خبری فناوری اطلاعات و ارتباطات يا ICTNA.ir آزاد ميداند

Copyright 2004-2009 ICTNA. All rights reserved. ©


عناوين

امنيت

مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 1 دیماه 1383

06:13 PM

December 21, 2004

تاريخچه پارازيت

يكشنبه، 22 تير، 1382

تاريخچه پارازيت

ايجاد اختلال يا پارازيت انداختن روی امواج ماهواره ای پديده تازه ای نيست. نخستين اختلال در کانال های ماهواره ای در آوريل سال 1986 ثبت شد.
در آن سال بييندگان کانال "هوم آفيس باکس" (Home Office Box) با ديدن عبارت "کاپيتان نيمه شب" به جای برنامه های اين شبکه شگفت زده شدند. اين اختلال در برنامه ها با هدف انتقاد از افزايش قيمت اشتراک اين کانال تلويزيونی صورت گرفت. يک سال بعد کانال "پلی بوی" نيز با همين مشکل رو به رو شد.

در ماه دسامبر 1995، برنامه های مد- تی وی (Med-TV) ايستگاه تلويزيونی کرد زبانی که برای ترکيه برنامه پخش می کرد، قطع شد که بعدا معلوم شد به دليل انداختن پارازيت بوده است، ولی شناسايی منشا اين پارازيت ممکن نبود. روزنامه صباح ترکيه ادعا کرد که مقامات اين کشور مسئول اين اختلال هستند.

همچنين در چين، گروه غيرقانونی فالون گونگ موفق شد که در امواج تلويزيون دولتی چين به نام "سی سی تی وی" اختلال ايجاد کند. پيش از آن اقدامات فالون گونگ به نفوذ به سيستم های کابلی محلی و پخش برنامه های خودشان به جای برنامه های دولتی محدود بود.

ولی در سپتامبر سال 2002، ماهواره ای که امواج تلويزيون دولتی چين را مخابره می کرد، در واقع "ربوده شد" و برای پخش تبليغات فالون گونگ در سرتاسر کشور چين مورد استفاده قرار گرفت. مقامات چين گفتند که اطمينان دارند اين امواج مزاحم از تايپی پايتخت تايوان صادر می شود. پس از آن، 15 نفر به اتهام نفوذ به سيستم های تلويزيونی، به حبس هايی تا 20 سال محکوم شدند.
تازه ترين نمونه اختلال در شبکه های تلويزيونی در زمان جنگ عراق رخ داد. در شب آغاز جنگ تلويزيون دولتی عراق به طور موقت دچار اختلال شد، به طوری که برنامه های معمول خبری و سرودهای مهين پرستانه، با خطوط افقی رنگی که از يک منبع ناشناخته می آمد، جايگزين شده بود. پس از آن اين شبکه بارها شاهد تلاش هايی برای ايجاد اختلال به روش های نظامی و متعارف تر بود.

پارازيت در ايران

به دنبال نا آرامی های دانشجويی ماه گذشته، سختگيری ها در مورد دسترسی به رسانه های خارجی در ايران شدت گرفت و مقامات ايرانی تلويزيون های فارسی زبان مستقر در لس آنجلس را مسئول تحريک مردم به شورش معرفی کردند.

بدين ترتيب کار جمع آوری ديش های ماهواره ای شديدتر شد. در ايران با توجه به ارزانتر شدن تجهيزات ماهواره ای در سالهای اخير بيشتر خانواده ها به آسانی توان خريد آن را دارند.

آن گروه از بينندگان اين کانال های ماهواره ای که توانسته اند ماهواره های خود را با وجود سختگيری های اخير حفظ کنند، می گويند که به تازگی شاهد اختلال در اين برنامه ها در داخل تهران و اطراف آن بوده اند.

روزنامه های تهران اخيرا از قول يکی از نمايندگان مجلس گزارش کردند که يک نهاد نظامی از چندين پايگاه خود و همچنين کاميون های حامل اين تجهيزات امواج قوی ای برای پارازيت انداختن روی اين برنامه ها ارسال می کند.

طبق اعلام سازمان بهداشت جهانی، قرار گرفتن مداوم در معرض ميزان زياد تشعشع ماکروويو - که استفاده از آنها برای پخش پارازيت روی امواج ماهواره ای ضروری است - می تواند روی سلامت افراد از جمله باروری مردان اثر بگذارد. اين مساله سبب نگرانی بعضی از مقامات در ايران شده است.
پارازيت همچنين روی شبکه های تلفنی و خدمات اينترنتی نيز اختلال ايجاد کرده است.

احمد معتمدی، وزير پست و تلگراف و تلفن مخالفت خود را با پخش پارازيت اعلام کرده و محمد خاتمی، رييس جمهور نيز گفت که دولت چنين اقدامی را تاييد نکرده است. وی خواستار اقدام عليه مسئولان پخش پارازيت شد.

در پی اختلال در ماهواره قبلی شبکه های تلويزيونی فارسی زبان يعنی "يوتلست هات برد" اين شبکه ها به ماهواره تل استار 12 منتقل شدند، ماهواره ای که فقط برای دريافت و پخش امواج از آمريکای شمالی طراحی شده است. اين نشان می دهد که اختلال فعلی در اين برنامه ها بايد در اثر امواجی که از قاره آمريکا صادر می شود، به وجود آمده باشد.

در روز ششم ژوئيه پازيت های پراکنده و تاحدی موثر ديده شد و سپس در روز بعد از آن ادامه يافت. مشاهدات روز هشتم ژوئيه نشان دهند شدت گرفتن اين پازايت ها بود که دريافت همه اين کانال های ماهواره ای را غيرممکن می کرد. تحقيقات در مورد اين مساله ادامه دارد.

البته اين پرسش مطرح است که راه مقابله با کسانی که درصدد اختلال در امواج ماهواره ای هستند چيست؟

چين اخيرا به منظور جلوگيری از تکرار مزاحمت های قبلی در پخش برنامه های تلويزيونی، ماهواره ای به نام "اپ استار" ساخت فرانسه خريداری کرده که به يک "فن آوری ويژه" برای جلوگيری از "ربوده شدن" امواج مجهز است. سازندگان ماهواره اکنون چنين امکانی را برای مشتريان خود فراهم کرده اند.

چنين نوآوری هايی می تواند تضمين کند که امواج ماهواره ای توسط فرد يا گروه مخالف مورد استفاده قرار نگيرد، هر چند اين تجهيزات امکان پارازيت انداختن روی امواج کانال های تلويزيونی "مخالف" را از بين نمی برد و در آينده بينندگان باز هم ممکن است به جای برنامه های ماهواره ای شاهد صفحه های سفيد بر تلويزيون خود باشند

لینک ثابت || نوشته شده توسط || نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر
موافقت نامه سايت
ايستنا :: آژانس خبری فناوری اطلاعات و ارتباطات
 کليه حقوق متعلق به سايت ايستنا و گروه همکاران سايت ميباشد.


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 1 دیماه 1383

06:32 PM

December 21, 2004

آيا تلفن همراه واقعا مضر است ؟!

سه شنبه، 25 شهريور، 1382

آيا تلفن همراه واقعا مضر است ؟!

مدتهاست‌ درباره‌ي‌ خطر تلفن‌هاي‌ همراه‌ از گوشه‌ و كنار اخطارهايي‌ را مي‌شنويم، اما آيا اين‌ تلفن‌ها واقعا خطرناك‌ هستند؟

sharifdaily: تلفن‌هاي‌ همراه‌ وسايل‌ ارتباطي‌ بي‌ سيم‌ هستند كه‌ از امواج‌ الكترومغناطيسي‌ براي‌ برقراري‌ ارتباط‌ بهره‌ مي‌برند. اين‌ امواج‌ نخستين‌ بار توسط‌ هانيريش‌ هرتز كشف‌ شدند.
امواج‌ الكترومغناطيسي، همانند هر نوع‌ موج‌ ديگر حامل‌ انرژي‌ هستند. اين‌ امواج‌ عرضي‌ هستند، يعني‌ راستاي‌ نوسان‌ آنها بر جهت‌ انتشار عمود است. براي‌ انتقال‌ نياز به‌ محيط‌ واسطه‌ نداشته‌ و مي‌توانند در خلا منتشر شوند. درست‌ مثل‌ هر موج‌ ديگر، اين‌ امواج‌ نيز داراي‌ مشخصه‌هاي‌ فركانس، دامنه‌ و طول‌ موج‌ مي‌باشند. سرعت‌ آنها ثابت‌ و برابر ‌٣٠٠ هزار كيلومتر بر ثانيه‌ مي‌باشد.
طيف‌ امواج‌ الكترومغناطيس‌ بسيار گسترده‌ است‌ و از امواج‌ راديويي‌ با فركانس‌ در محدوده‌ كيلوهرتز تا گيگا هرتز كه‌ معادل‌ طول‌ موجهاي‌ كيلومتري‌ تا سانتيمتري‌ است، تا پرتوهاي‌ گاما كه‌ طول‌ موج‌ كمتر از ‌٠/١ نانومتر دارند گسترده‌ است.
نور مرئي‌ از امواج‌ الكترومغناطيسي‌ با طول‌ موج‌ بين‌ ‌٠/٤ تا ‌٠/٨ ميكرومتر تشكيل‌ شده. دستگاههاي‌ تلفن‌ همراه‌ در محدوده‌هاي‌ فركانسي‌ خاصي‌ از امواج‌ راديويي‌ فعاليت‌ مي‌كنند كه‌ عبارتند از ‌٨٧٢ تا ‌٩٦٠، ‌١٧١٠ تا ‌١٨٧٥ و ‌١٩٢٠ تا ‌٢١٧٠ مگاهرتز. امواج‌ الكترومغناطيس‌ به‌ دو دسته‌ يونيزان‌ و نايونيزان‌ تقسيم‌ مي‌شوند. امواج‌ يونيزان‌ عبارتند از پرتوهاي‌ فوق‌ بنفش، ايكس‌ و گاما و به‌ دليل‌ انرژي‌ زيادي‌ كه‌ دارند مي‌توانند اتمهاي‌ موجود در مسير را يونيزه‌ كنند. ساير امواج‌ از جمله‌ امواج‌ راديويي‌ چنين‌ خاصيتي‌ را ندارند. به‌ همين‌ دليل‌ تا مدتها تصور مي‌شد امواج‌ راديويي‌ بي‌ خطر هستند. در واقع‌ خطر موجود در امواج‌ يونيزان‌ به‌ دليل‌ اثرات‌ بيولوژيكي‌ است‌ كه‌ ايجاد مي‌كنند. اين‌ آسيب‌ در اثر بر هم‌ كنش‌ پرتو يونيزان‌ باDNA سلولها رخ‌ مي‌دهد و در نتيجه‌ سلولها از نظر ژنتيكي‌ آسيب‌ مي‌بينند كه‌ ممكن‌ است‌ آنها را از بين‌ ببرد يا در بدترين‌ حالت‌ به‌ سلولهاي‌ سرطاني‌ تبديل‌ كند و اين‌ آثار يك‌ قرن‌ است‌ كه‌ شناخته‌ شده‌اند. اما تنها چند دهه‌ است‌ كه‌ آثار مخرب‌ پرتوهاي‌ پرتوهاي‌ نايونيزان‌ نيز شناسايي‌ شده‌ است. مهمترين‌ تاثيري‌ كه‌ اين‌ نوع‌ امواج‌ دارند ايجاد گرما است. اجاق‌هاي‌ مايكروويو كه‌ در زندگي‌ خانگي‌ بسياري‌ از انسانها وارد شده‌اند از امواج‌ مايكروويو كه‌ از نظر طول‌ موج‌ بين‌ امواج‌ راديويي‌ و فرو سرخ‌ قرار دارند. براي‌ گرم‌ كردن‌ غذا به‌ همين‌ شيوه‌ استفاده‌ مي‌كنند. امواج‌ راديويي‌ كه‌ از تلفن‌ همراه‌ منتشر مي‌شوند نيز طول‌ موج‌ نزديك‌ به‌ مايكروويو داشته‌ و قابليت‌ ايجاد حرارت‌ در محيط‌ اطراف‌ خود را دارند. اين‌ موضوع‌ باعث‌ مي‌شود وقتي‌ از اين‌ تلفن‌ها استفاده‌ شود، درجه‌ حرارت‌ بخشي‌ از مغز كه‌ در مجاورت‌ آنها قرار دارد اندكي‌ بالا رود. اين‌ امواج‌ آثاري‌ از نوع‌ مغناطيسي‌ نيز دارند. وقتي‌ سلولهاي‌ بدن‌ انسان‌ در عرض‌ امواج‌ الكترومغناطيسي‌ قرار بگيرند، در غشاء آنها تغييراتي‌ رخ‌ مي‌دهد. غشاء سلول‌ داراي‌ دريچه‌هاي‌ بسيار كوچك‌ نانومتري‌ است‌ كه‌ از جنس‌ مولكولهاي‌ پروتئين‌ هستند. فعاليتهاي‌ سلولي‌ كه‌ شامل‌ ورود و خروج‌ مواد باشند از طريق‌ اين‌ دريچه‌ها انجام‌ مي‌شوند. بعضي‌ از اين‌ دريچه‌ها به‌ صورت‌ الكتريكي‌ تحريك‌ مي‌شوند تا باز يا بسته‌ شوند.
امواج‌ الكترومغناطيسي‌ مي‌توانند در بدن‌ انسان‌ ميدانهاي‌ الكتريكي‌ توليد كنند. اين‌ ميدانها روي‌ دريچه‌هاي‌ غشاء سلول‌ تاثير گذاشته‌ و باعث‌ تداخل‌ در عملكرد آنها مي‌شوند. با اين‌ حال‌ هنوز خطرزا بودن‌ امواج‌ تلفن‌هاي‌ همراه‌ به‌ اثبات‌ نرسيده‌ است. شدت‌ ميدان‌ توليد شده‌ توسط‌ اين‌ دستگاه‌ كم‌ است‌ و ثابت‌ نشده‌ كه‌ حرارت‌ توليد شده‌ آن‌ در سطح‌ خطرناك‌ باشد، گرچه‌ قابل‌ اندازه‌گيري‌ است. ميدانهاي‌ الكتريكي‌ نيز وضعيت‌ مشابهي‌ دارند؛ با اينكه‌ به‌ وضوح‌ در بدن‌ ايجاد مي‌شوند، اما شدت‌ پاييني‌ دارند و نمي‌توان‌ به‌طور قطع‌ آسيب‌ را به‌ آنها نسبت‌ داد. بررسي‌هايي‌ كه‌ تاكنون‌ انجام‌ شده‌ نيز رابطه‌ آماري‌ معني‌ داري‌ بين‌ استفاده‌ از تلفن‌ همراه‌ و بيماري‌ خاصي‌ را در انسان‌ نشان‌ نداده‌ است. با اين‌ وجود تاثير امواج‌ تلفن‌ همراه‌ روي‌ موجودات‌ ديگري‌ از جمله‌ كرم‌ها به‌ اثبات‌ رسيده‌ است. بنابراين‌ هنوز به‌ هيچ‌ وجه‌ نمي‌توان‌ اين‌ امواج‌ را بي‌ خطر اعلام‌ كرد. به‌ همين‌ دليل‌ انجام‌ اقدامات‌ پيشگيرانه‌ ضروري‌ است. استفاده‌ از گوشي‌هاي‌ كم‌ تشعشع‌ و هندفري‌ مي‌تواند امواج‌ دريافتي‌ را تا ‌٩٥ درصد كاهش‌ دهد. هرچند استفاده‌ از هندفري، به‌ دليل‌ متمركز كردن‌ امواج‌ ممكن‌ است‌ خطر را به‌ شكلي‌ ديگر ايجاد كند.
به‌ هر حال، انسان‌ امروزين‌ خود را در محاصره‌ امواج‌ الكترومغناطيس‌ قرار داده‌ و حلقه‌ محاصره‌ را روز به‌ روز گرد خود تنگ‌تر مي‌كند. تا وقتي‌ بي‌ خطر بودن‌ تلفن‌هاي‌ همراه‌ اثبات‌ نشود، بايستي‌ با احتياط‌ از آن‌ها استفاده‌ كرد. توصيه‌هاي‌ ايمني‌ را جدي‌ بگيريد! سوتيتر: تلفن‌هاي‌ همراه‌ از امواج‌ راديويي‌ كوتاه‌ براي‌ ارتباط‌ استفاده‌ مي‌كنند. بي‌ خطر بودن‌ اين‌ امواج‌ براي‌ انسان‌ همواره‌ مورد ترديد قرار گرفته‌ است. گرچه‌ هنوز آسيب‌ زا بودن‌ آنها به‌ اثبات‌ نرسيده‌ است، اما كاهش‌ استفاده‌ از تلفن‌ همراه‌ خطر آسيب‌ احتمالي‌ را به‌ حداقل‌ مي‌رساند.

لینک ثابت || نوشته شده توسط || نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر
موافقت نامه سايت


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 19 دیماه 1383

12:17 AM

January 08, 2005

فناوری استرس

دوشنبه، 25 خرداد، 1383

BBC: نتايج تحقيقات جامع صورت گرفته از سوی دانشگاه "Surrey" نشان ميدهد که استفاده از چنين ابزارها و دستگاههای باعث مزاحمت و آزار افراد در دراز مدت ميشود.
در اين نظرسنجی بسياری از افراد پرسش شونده اظهار داشته اند که استفاده از ابزارهای چون کامپيوتر، موبايل، پست الکترونيک و کوته پيام باعث کاهش بردباری، تحمل و آرامش شان شده است.
بيش از نيمی از افراد مورد مطالعه معتقد بودند استفاده از ابزارهای مدرن ارتباطی و اطلاعاتی در جلسات کاری يا حين صحبت با ديگران نامناسب و گاه توهين آميز است و فقط ۱۱ درصد از افراد فکر ميکردند پاسخ به يک تماس تلفنی موبايل يا ارسال کوته پيام در جلسات ميتواند مقبول ديگران قرار گيرد.
۶۰درصد پاسخ دهندگان گفته اند قوانين عرفی و غير رسمی ای برای استفاده از تجهيزات الکترونيکی قائل هستند.
مطالعات دانشگاه "Surrey "بمنظور آزمودن نگرشها به ابزارهای مدرن و الکترونيکی روز انجام شده است.
براساس نتايج اين نظرسنجی ها بايد با رهنمود مديران به کارمندان استرس های ناشی ازکاربرد تجهيزات الکترونيک را از محیط کار از بين برود.
" Paul Mould " یکی از محققان مرکز مخابراتی" Siemens " دراين باره مي گويد: بايد ظوابط مشخص و آرامش بخشی هنگام کار با موبايل و کلا وسائل ارتباطی از اين دست در محيط های کار به اجرا گذاشته شود.
وی افزود: عرفا پاسخ به يک تماس تلفنی در ميان صحبت با ديگران بدين معناست که اين تماس مهمتر از مکالمه با فرد حاضر است و بنوعی توهين به او تلقی ميشود همانطور که جواب به يک تماس تلفنی در ميان يک جلسه اداری بمعنای بی اهميت شمردن آن جلسه است.
وی گفت: اما ظاهرا افراد جوانتر کمتر از ديگران از پاسخ تلفنی طرف مقابل خود در هنگام مکالمه يا ميان يک جلسه رسمی آزرده خاطر ميشوند!
" پروفسور ميشل وارن " از دانشگاه "Surrey " مي گويد : وقتی نتوانيم با فرد مورد نظرمان تماس بگيريم مضطرب و کم طاقت ميشويم و از اينکه صدای زنگ موبايلمان يک جلسه را برهم زند عصبی و شرمنده ميشويم.
" Paul Moulds " از شرکت زيمنس مي گويد : فشارهای روانی محيط کار، حرص و جوش و آشفتگی مسائلی هستند که برای از بين بردن آنها به يک نهضت مديريتی نياز هست.

© اين ياداشت عينا در خروجی خبرگزاری سينا و صفحه کامپیوتر روزنامه دنیای اقتصاد قرار گرفت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 19 دیماه 1383

12:23 AM

January 08, 2005

پايان سلطنت نوکيا بر بازار موبايل

چهارشنبه، 27 خرداد، 1383

عکس از تصویریاب گوگل

Iran ICT News: بر اساس گزارش بی.بی.سی، سهم شرکت نوکیا در بازار جهانی گوشی های موبایل در سه ماهه نخست سال نزول زیادی داشته است.
بررسی جامع گروه پژوهش بازار حاکی از آن است که سهم این رهبر صنعتی در بازار از 6/36% به 9/28 % در یک دوره مشخص سال 2003 تنزل کرده است.
روی هم رفته بازار گوشی های موبایل از طریق ارسال کالا ناگهان به 34% یعنی 153 میلیون دستگاه افزایش یافته بود در حالیکه رقبای نوکیا نتوانسته اند سهم بازار را در اختیار بگیرند.
این بدترین عملکرد نوکیا در اروپای غربی بوده است زیرا نوکیا 10% از سهم خود از بازار موبایل را از دست داده است. شرکت نوکیا دو مسئله بنیادین دارد.
یکی از آنها در رابطه با اپراتورها در عرضه گوشی های شخصی است و دیگری موضوع تولید است که در مقایسه با مدلهایی که رقبای آنها عرضه می کنند کارآمد نیست.
روسیه از یک سو موضوع مهمی است. برزیل نیز در تلاطم است و در بازارهای جا افتاده مانند اروپای غربی و امریکای شمالی جایگزینی های زیادی صورت گرفته است.
تقاضا برای گوشی های نوکیا طی سه ماهه گذشته افزایش داشت اما به اندازه دیگر رقبایش نبوده است.
در ماه آوریل شرکت نوکیا دریافت که نمی تواند هم پای سرعت سرسام آور رشد در بازار حرکت کند و این به دلیل فاصله های موجود در مجموعه گوشیهای میان بر بوده و ضمناٌ هر قدر مجموعه گوشی ها مهمتر شوند باز سود حاصل کافی نخواهد بود.
آن موقع این شرکت فنلاندی پذیرفت که سه ماهه نخست امسال را از دست داده است اما تخمین می زند که سهم آنها در بازار 35%تنزل نماید.
اما رقبا میزان فاصله با این شرکت را کمتر از قبل کرده اند و بنظر می رسد که نوکیا در حال از دست دادن سلطنت 40%درصدیش در بازار موبایل جهان است و شعار "پرفروش ترین در پنج قاره" در حال رنگ باختن است.
رقیب اصلی نوکیا یعنی موتورالا توانست سهم خود از بازار جهانی موبایل را از 7/14%به 4/16% افزایش دهد در حالیکه صنایع الکترونیک سامسونگ کره شاهد رشدی از8/10% به 5/12 % بوده است.
تفاسیر کارشناسان بازار حاکی از آن است که در نظر گرفتن میزان تقاضای مشتریان واقعی به جای خرده فروشان بهترین اقدام است و شرکت نوکیا میدان را به شش رقیب اصلی خود واگذار کرده است.
در سه ماهه نخست روسیه اصلی ترین موضوع بود. بازار نوکیا نیز در تلاطم بوده و بازارهای جا افتاده ای مانند اروپای غربی و آمریکای شمالی جایگزینی های زیادی صورت گرفته است.
یافته ها بیانگر آن است که در بازارهای جا افتاده مدل های قدیمی با مدلهای امروزی که فن آوری های نوینی مانند دوربین و صفحه رنگی نمایش دارند، جایگزینی یافته است.
این نوسانات نوکیا را وادار کرده است تا نگرش خود در مورد افزایش ارسال گوشی های موبایل برای دومین بار در این سال تعدیل نماید.
حال انتظار می رود 600 میلیون دستگاه موبایل بیشتر از 580 میلیون دستگاه برآورده شده در ماه مارس امسال فروش و ارسال شود و این کاملاٌ از 520 میلیون دستگاهی که در سال 2003 فروش رفته بود بیشتر باشد.

© اين ياداشت عينا در خروجی خبرگزاری سينا قرار گرفت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 19 دیماه 1383

12:29 AM

January 08, 2005

همه چيز در مورد اولين ويروس موبايل

پنجشنبه، 28 خرداد، 1383

اولين ويروس مهم موبايل توسط شبکه تلفن همراه در حال پخش شدن است البته شرکتهای ضد ويروس اين کرم را بی ضرر ميدانند اما اين ميتواند هشداری جدی باشد برای دارندگان تلفن همراه که احتمالا بايد در آينده منتظر ويروس های خطرناک زيادی باشند.

اين کرم که با نام Cabir شناخته ميشود خود را روی شبکه GSM تلفن همراه منتشر ميکند و به گوشی های که با سيستم عامل سيمبين (Symbain) کار ميکنند نفوذ ميکند.

شرکتهای ضدويروس مردد هستند که آيا اين ويروس ميتواند هشدار آغازين يک سری ويروس های مشابه خطرناک باشد يا خير.

Symbian

گراهام کلولی معاون فنی شرکت ضدويروس Sophos ميگويد : " اين ويروس نقطه عطفی در تاريخچه ويروس هاست اما از نظر فنی مورد خاصی نيست" هنگامی که فايل آلوده پخش ميشود صفحه نمايشگر گوشی بطور خودکار پيام "Cabir" را نمايش ميدهد و هر بار که گوشی روشن و خاموش ميشود کرم خود را درون دايرکتوری های مختلف گوشی منتشر ميکند و بوسيله مودم بلوتوث محيط اطراف خودش را اسکن ميکند تا در سيستم های ديگر خود را منتشر کند. اين محدود به موبايل های اطراف نيست و کرم با اسکن بلوتوث بدنبال پيدا و آلوده کردن هر نوع دستگاه مبتنی بر فن آوری بلوثوث هست خواه يک پرينتر باشد يا يک نوت بوک که مودم بلوتوث دارد.

مت پرسی از شرکت ضدويروس F-Secure در اين باره ميگويد : "من از تلاش برای منتشر کردن چيزی بدتر از اين ويروس در ماههای آينده هم شگفت زده نميشوم"

چطور آلوده شويم ؟!

محدوده توزيع اين کرم بسيار محدود است چرا که Cabir تنها خود را با مودم بلوتوث گوشی آلوده منتشر ميکند و اين يعنی دامنه انتشاری در حدود ۳۰ متر !!!

البته اين زياد خوشایند نيست چرا که بسيار پيش ميآيد که ما بی خبر از همه چيز همراه با گوشی بلوتوث دارمان در اماکن عمومی مثل محل کار،مترو يا خيابان از ۳۰ متری گوشی های آلوده گذر کنيم.

سيمبين دارها بايد منتظر اين ويروس پيشرو از منابع ناشناس اطرافشان باشند چرا که هنوز شرکتهای توليد کننده موبايل يا ضدويروس راه کار عملی جامعی برای اين مورد ارائه نکرده اند.

ساختار

پس از اجراي کرم EPOC.Cabir ابتدا يک پيغام نمايش مي دهد ، سپس خود را درون يک دايرکتوري بر روي موبايل کپي مي کند.(اين دايرکتوري به صورت پيش فرض قابل رؤيت نيست)
هر گاه موبايل روشن شود اين کرم شروع به کار مي کند. حتي اگر محتويات دايرکتوري APPS پاک شود باز هم اين کرم فعال خواهد بود.
پس از شروع به کار اين کرم ، به صورت مداوم به جستجوي دستگاه هايي که قابليت بلو توث دارند مي پردازد و اولين دستگاه يافت شده را مورد حمله قرار مي دهد. در نتيجه به خاطر جستجوي مداوم شارژ باطري خيلي زود تمام خواهد شد.

جزئيات بيشتر :

پس از اجراي اين کرم اعمال زير را انجام مي دهد :
1-پيغام "Cabir" بطور خودکار روی صفحه نمايشگر گوشی ظاهر ميشود.

2- فايلهاي زير را بر روي موبايل ايجاد خواهد کرد :
\SYSTEM\APPS\CARIBE\CARIBE.APP
\SYSTEM\APPS\CARIBE\CARIBE.RSC
\SYSTEM\APPS\CARIBE\FLO.MDL
\SYSTEM\SYMBIANSECUREDATA\CARIBESECURITYMANAGER\CARIBE.APP
\SYSTEM\SYMBIANSECUREDATA\CARIBESECURITYMANAGER\CARIBE.RSC
\SYSTEM\SYMBIANSECUREDATA\CARIBESECURITYMANAGER\CARIBE.SIS
\SYSTEM\RECOGS\FLO.MDL
\SYSTEM\INSTALLS\CARIBE.SIS

3- تلاش براي انتشار خود به دستگاه هاي داراي قابليت بلو توث ، بدون توجه به نوع دستگاه
4- هر بار پس از اينکه موبايل خاموش و روشن مي شود آغاز به کار مي کند.

منبع

گروه ضد ويروس F-Secure معتقد است اين ويروس توسط ويروس نويسانی که تحت نام Rugrat نوشته شده است مت پيرسی مدير انگليسی F-Secure ميگويد : ظاهرا اين گروه بدنبال ويروس های مخرب نيست و فقط بدنبال اثبات ادعاهای خود است کسی که چنين ويروسی نوشته ميتوانسته بجای استفاده بلوتوث از دفترتلفن گوشی و SMS استفاده کند و در ابعاد وحشتناکی خود را منتشر کند يا بجای پيام اخطار و پر کردن دايرکتوری ها دفتر تلفن گوشی را پاک کند يا پيام های بدی برای آنها ارسال کند اما اين کار را نکرده و اين نشان از حسن نيت نسبی ويروس نويس دارد.

حالا ديگر بايد همانگونه که مراقب رايانه های خود هستيم بايد مراقب گوشی های موبايلمان هم باشيم بايد بدنبال دانلود و نصب چيزی شبيه به يک ديواره آتش يا آنتی ويروس برای گوشی هايمان باشيم.

اما در مقابل شرکتهای معروفی مانند سيمانتک معتقد نيستند که به اين زودی ها با يک موج ويروس موبايلی مواجه خواهيم بود.

کرم بارور

آقای کلومی ميگويد که ما چهار سال پيش ويروسی را برای کامپوترهای دستی Palmپيدا کرديم که آن زمان ديگر شرکتهای ضدويروس پيشبنی کردن که بزودی موجی از ويروسهای اينچنينی براه خواهد افتاد اما چنين نشد! کلومی همچنان معتقد است هنوز سيستم عامل فراگير ويندوز اولين و بزرگترين هدف ويروس نويسان است.

طبق گزارش Sophos اخيرا ويروسی بنام ۹۰ ميل از هر ۱۰۰۰ ميل فرستاده شده روی شبکه را بخود آلوده کرده است که گسترده ترين ويروس ايميلی در نوع خود بحساب می آيد که با وجود حجم گسترش و خساراتش به مانند Cabir در جهان سر و صدا نکرده چرا که کبير نخستين ويروس تحت موبايل در جهان است و اين نقطه عطفی است در تاريخ ويروس نويس جهان.

چطور از شر کبير خلاص شويم ؟!‌

1- يک برنامه مديريت فايل بر روي موبايل نصب کنيد.
2-گزينه ديدن فايلهاي درون دايرکتوري سيستم را فعال کنيد.
3- در درايو هاي A تا Z به دنبال دايرکتوري \SYSTEM\APPS\CARIBE بگرديد.
4-از دايرکتوري CARIB فايلهاي CARIBE.APP, CARIBE.RSC و FLO.MDL را پاک کنيد.
5- به اين دايرکتوري برويد : C:\SYSTEM\SYMBIANSECUREDATA\CARIBESECURITYMANAGER
6- فايلهاي CARIBE.APP, CARIBE.RSC و CARIBE.SIS را پاک کنيد.
7- به دايرکتوري C:\SYSTEM\RECOGS برويد.
8- فايل FLO.MDL را پاک کنيد.
9- به دايرکتوري C:\SYSTEM\INSTALLS برويد.
10- فايل CARIBE.SIS را پاک کنيد.

© اين ياداشت عينا و به قلم نگارنده (آرش کريم بيگی) در خروجی خبرگزاری سينا قرار گرفت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 22 دیماه 1383

12:49 PM

January 11, 2005

ده اقدام براى تعديل رفتار استفاده‌كنندگان از خدمات و كاهش هزينه‌هاى IT

سه شنبه، 19 آبان، 1383

امروزه با شرايط اقتصادى نابسامان و روند توسعه‌ى محتاطانه، IT براى كنترل و مديريت هزينه‌ها و تضمين هم‌خوانى مخارج با اهداف سرمايه‌گذاران و گردانندگان صنايع، به شدت زير فشار قرار دارد. در حقيقت IT با اختصاص دادن صحيح منابع و به حداقل رساندن آن‌ها در زمينه‌هاى غير توليدى، خود را به عنوان يك حرفه مطرح مى‌كند...

Photo orbis
نويسنده: استيوى ساكس
منبع: www.computerworld.com
مترجم: نازنين كى‌نژاد

يكى از راه‌هاى حفاظت منابع و دست‌يابى به يك‌پارچگى، افزايش كارايى است. البته اين تنها نيمى از راهى است كه بايد پشت سر گذاشته شود. IT همچنين بايد براى بهينه‌سازى مخارج و سرمايه‌ى هزينه شده براى يك حرفه، ابزارهاى مورد استفاده و خدمات ارايه شده را كنترل كند. از اين‌ها گذشته، وقتى مصرف‌كنندگان نهايى تمام گنجايش خدمات IT را بدون بازگشت هيچ سرمايه‌اى، مصرف مى‌كنند، حتا اگر IT عملكرد موفقى داشته باشد، نتيجه چيزى جز اتلاف وقت و هزينه نيست.

مديريت تقاضا... يعنى تعديل رفتار مصرف‌كننده‌ى نهايى از راه ايجاد بخش‌هاى شغلى، كه اين بخش‌ها از نظر مالى پاسخ‌گوى ميزان و چگونگى مصرف منابع مالى هستند... اين عمل، در حقيقت نسل بعدى اقدامات انجام شده در مديريت خدمات IT را تشكيل مى‌دهد. با اين اقدامات همچنين مى‌توان از مصرف گنجايش خدمات IT به گونه‌اى كه به سوددهى منجر نشود، جلوگيرى كرد. مى‌توان اين روش‌ها را به ساير روش‌هاى مديريت IT ضميمه كرد تا از اين راه IT به جاى تبديل شدن به يك وسيله‌ى رفاهى يارانه‌اى به يك حرفه‌ى سودآور تبديل شود.

به طور معمول IT در مقام گفتن "نه" يا محدود كردن تقاضاهايى كه خود تامين‌كننده‌ى آن است، قرار ندارد. در حالى كه بايد اين وضعيت را تغيير داده، اجازه ندهد كه به وسيله‌ى تقاضاهاى مشتريان هدايت شود. پويايى و تمايل به يكنواخت نبودن در انسان‌ها، نقش مهمى در ايجاد اين تغيير بازى مى‌كند. البته تجربه ثابت كرده است كه انسان زمانى رفتار خود را اصلاح مى‌كند كه تحت تاثير يك نيروى مثبت يا منفى قرار داشته باشد. در اين راه نه تنها تعداد تقاضاها، بلكه ماهيت آن‌ها نيز بايد دگرگون شود و اين عمل ميسر نيست مگر با ارايه‌ى اطلاعاتى به استفاده‌كنندگان خدمات، تا از اين راه بتوانند آگاهانه‌ تصميم بگيرند.

در اين‌جا 10 پيش‌نهاد براى مديريت بهتر تقاضا ارايه مى‌شود:

1- از خدمات كه به صنايع و جوامع حرفه‌اى (به طور كلى) و به افراد (به طور جزيى) ارايه مى‌كنيد، فهرستى تهيه كنيد.

2- از سطح خدمات _ آن طور كه مورد انتظار مصرف‌كننده است_ گزارشى تهيه كنيد. توافق بر سر سطح خدمات، هر دو طرف را راضى نگه مى‌دارد. ممكن است شما براى تعداد صفحه‌هاى چاپ شده، تعداد و نيز كوتاهى يا بلندى پيغام‌هاى الكترونيكى، ميزان اطلاعات ذخيره شده و ساير تقاضاهايى كه IT با آن دچار مشكل بوده است، محدوديت‌هايى در نظر بگيريد. به ياد داشته باشيد كه موتور فاكتور شما گاه بايد به جريمه‌هاى نقدى نيز متوسل شود.

3- خدمات جديد را با اهداف شغلى‌تان دوباره به شكلى يك‌پارچه، تعريف كنيد.

4- با توجه به معيارهاى مالى‌تان، در فهرستى كه تهيه كرده‌ايد، روى تمام اين خدمات برچسب قيمت بگذاريد.

5- در اين مرحله ميزان كاربرد و كارآيى منابع را از سخت‌افزار گرفته تا كاركنان، تخمين بزنيد.

6- يك بروشور ارايه‌ى خدمات با امكان انتخاب چندين گزينه، در قيمت‌هاى مختلف، طراحى كنيد. (براى مثال هم خدمات حفاظتى 5 روزه و هم 7 روزه ارايه كنيد، يا به استفاده‌كنندگان امكان دهيد از ميان چند mail box با ظرفيت‌هاى مختلف يكى را انتخاب كنند.)

7- روند اجراى كار را توضيح دهيد و رضايت مصرف‌كنندگان خدمات ارايه شده را به دست بياوريد.

8- گزارشى از هزينه‌ها و قيمت خدمات و نيز فاكتورهاى بخش‌هاى مختلف تهيه كنيد.

9- بخش‌هاى سلف سرويس و خوديارى ايجاد كنيد.

10- و بالاخره ابزارهايى براى حمايت و پشتيبانى خدمات و كسب رضايت مشترى توليد كنيد.

اين 10 مرحله، به جامعه‌ى مصرف‌كنندگان و مديران مشاغل، ابزراهايى براى اصلاح و تعديل رفتار يا الگوهاى خريد ارايه مى‌كند. به اين ترتيب آن‌ها مى‌توانند خدمات مورد استفاده‌ى كاركنان و همين‌طور سطح ارايه‌ى اين خدمات و تاثير آن‌ها بر بودجه را زير نظر داشته باشند.

اين خدمات با روش‌هاى آسان و كاربردى ارايه شده و هم مصرف‌كننده و هم مديران IT را حمايت مى‌كنند.

اگر از اين روش به درستى استفاده كنيد خواهيد ديد كه چگونه الگوهاى رفتارى موسسه يا سازمان‌تان تغيير مى‌كند.

همواره به شدت نسبت به نيازهاى ضرورى و رفتارهاى مشتريان حساس باشيد و تلاش كنيد با ارايه‌ى خدمات بهتر در مديريت IT و مديريت خدمات رسانى، سود بيشترى جذب سازمان خود كنيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 22 دیماه 1383

12:58 PM

January 11, 2005

بررسی حملات DOS

جمعه، 22 آبان، 1383

شايد بيشتر مديران شبكه‌ها و علاقه مندان به امنيت اسم حملاتي موسوم به DOS را در سال‌هاي اخير شنيده باشند. اما بيشتر آنها ندانند DOS چگونه عمل مي‌كند و پيامدهاي ناشي از اين حمله چيست ؟ گروهي نيز تفكرات نادرسي از حملات DOS در ذهن دارند و فكر مي‌كنند كه مي توان با استفاده از يك ديوار آتش نرم‌افزاري يا برنامه‌هايي ديگر از اين قبيل با حملات DOS و DDOS مقابله كرد و جلوي آن را گرفت...

نیما مجیدی - عکس از آرش کریم بیگی

نيما مجيدی- بسياري از سايت‌هاي بزرگ نيز در حال حاضر قادر به مقابله با حملات DOS نيستند زيرا اين حملات به نوع متفاوتي سازماندهي مي‌شوند و در بيشتر اوقات با ايجاد ترافيكي بالا لشكري از Packet هاي TCP را به سمت سرويس‌هاي خدمات دهنده سرازير مي‌كنند. به عنوان مثال در هنگام به وجود آمدن و شناسايي ويروس Blaster پس از آلوده شدن صدها هزار كامپيوتر در سراسر دنيا بوسيله اين كرم كامپيوتري كه از يك ضعف در سيستم عامل‌هاي ويندوز مايكروسافت استفاده مي‌كرد، خبري با اين عنوان كه اين ويروس در روز 20 اگوست شروع به فرستادن پاكت‌هايي به سمت سايت windowsupdate.com مي‌نمايد در رسانه‌هاي امنيتي انتشار يافت كه در پي آن مسئولين امنيتي مايكروسافت چاره‌اي جز از كار انداختن سايت Windowsupdate.com و حذف آن از DNSهاي جهاني نديدند. با اينكه آنها تا آخرين لحظات از عنوان كردن روش خود يعني از كار انداختن سايت مورد نظر خودداري مي‌نمودند، اما قابل پيش‌بيني بود كه به هيچ وجه سرويس‌هاي خدمات دهنده مايكروسافت نيز قادر به مقابله با اين حجم ترافيك بالا نخواهند بود و دير يا زود از سرويس دهي باز مي‌مانند.

چگونگي عملكرد ويروس Blaster براي ايجاد يك حمله DOS
1- در طي يك هفته ويروس Blaster انتشار يافت و حدود 50000 هزار ماشين را در سراسر دنيا آلوده ساخت.
2- پس از رسيدن به روزي كه كرم Blaster براي آن تاريخ برنامه‌ريزي شده بود، قرار بر اين بود كه ماشين‌هاي آلوده از سراسر دنيا شروع به ارسال پاكت‌هايي به پورت 80 سايت www.windowsupdate.com كنند كه يكي از سايت‌هاي مايكروسافت مي‌باشد در نتيجه با مشغول شدن سرويس دهندگان سايت براي رسيدگي به درخواست‌هاي ماشين‌هاي آلوده امكان جوابگويي به درخواست‌هاي مشتريان واقعي نبود و همين باعث به وجود آمدن يك حمله DOS مي‌شد.

امروزه نسل جديدي از حملات DOS به وجود آمده‌اند كه DDOS نام گرفته‌اند. اين حملات نوع گسترش يافته حملات DOS هستند كه از اواخر سال 1999 مورد استفاده قرار گرفته‌اند . در سال 2000 حملات DDOS توسط نفوذگران براي از كار انداختن و حمله به سايت‌هاي بزرگي مانند, e-Bay CNN , Amazon مورد استفاده قرار گرفته است.

بررسي حملات D.D.O.S
در چند ماه گذشته در گيرودار دادگاه جنجالي شركت SCO سايت اين شركت توسط طرفداران سيستم عامل‌هاي لينوكس و كدباز مورد حمله DDOS قرار گرفت و براي چند روز از كار افتاد، اين حمله يكي از بي‌سابقه‌ترين و سخت‌ترين حملات DDOS در چند سال اخير محسوب مي‌شود.

نمودار زير ميزان Hit هاي وارد شده به سايت Sco را در ثانيه نشان مي دهد .
منظور از Hit درخواست هايي مي باشند كه از سرويس دهنده تقاضا مي شوند.

همانطور كه در شكل مشاهده مي‌كنيد اين حملات از تاريخ چهارشنبه 10 دسامبر و در ساعت 3:20 شروع شده كه تعداد پاكت‌هاي ارسالي 34000 پاكت در ثانيه بوده است. در روز پنجشنبه 11 دسامبر و در ساعت 2:50 صبح حمله كنندگان دست به حمله ديگري زدند اين بار با هزاران ماشين از سراسر دنيا سرويس Ftp و WEB شركت Sco را با آدرس هاي www.Sco.com و Ftp.Sco.com مورد حمله SYN Flood قرار دادند.

تعداد درخواست‌ها براي حمله در اين روز به حداكثر خود يعني 50000 درخواست در ثانيه رسيد و بالاخره در ساعت 10:45 روز پنجشنبه شركت Sco مجبور به حذف ماشين سرويس دهنده وب خود شد تا با اين كار از ورود درخواست‌هاي حمله كنندگان براي اتصال به اين ماشين جلوگيري كند.

اين روزها نسل جديدي از ويروس ها كه پس از Blaster به وجود مي آيند از تكنيك DOS براي حمله به اهداف خود استفاده مي‌كنند . اين كرم هاي اينترنتي پس از آلوده كردن تعداد زيادي ماشين در سراسر دنيا در تاريخي خاص شروع به ارسال پكت به سوي اهداف از قبل تعيين شده مي‌كنند و حمله اي را به صورت DOS به وجود مي آورند مانند انواع ويروس MY. doom . اين حملات به علت گستردگي ارسال درخواست‌ها ترافيك زيادي را بر روي اينترنت ايجاد مي‌كنند و شركت‌ هاي مورد حمله قرار گرفته كار زيادي در جهت مقابله با آن نمي‌توانند انجام دهند.

در مورد ديگر مي توان به ويروسCycle اشاره كرد كه يك ويروس ايراني بود و در اهداف خود را به همين وسيله مورد حمله قرار مي داد.

با بررسي اين حملات مي‌توان نتيجه گرفت با اين كه در روش DDOS از تكنيك‌هاي ساده و قديمي استفاده مي‌شود اما مي‌توان با ترتيب دادن حملات گسترش يافته شركت‌هاي بزرگي مانند Microsoft و Sco را نيز دچار مشكل كرد تا جايي كه تنها چاره‌اي كه براي مسئولين امنيتي اين شركتها باقي مي ماند قطع ارتباط ماشين‌هايي است كه مورد حمله قرار گرفته‌اند.

در ادامه به بررسي روشن‌تري از حملات DOS و آشنايي با چگونگي عملكرد پروتكل TCP مي‌پردازيم. سپس انواع حملات DOS را طبقه‌بندي كرده و تشريح مي‌كنيم و ابزاري كه نفوذگران از آن براي ايجاد اين حملات استفاده مي‌كنند را معرفي خواهيم كرد.

D.O.S (Denial Of Service Attack)
حمله‌اي كه باعث جلوگيري از كار يك سرويس يا مانع دسترسي به منابعي شود را حمله DOS گويند . به عنوان مثال حملات D.O.S بر روي ماشين‌هاي سرويس دهنده وب ممكن است منجرب به اين شود كه سرويس دهنده قادر به سرويس دهي به مشتريان نباشد. يا پر كردن پهناي باند يك ماشين باعث قطع ارتباط اين ماشين با شبكه اصلي مي شود.
براي بررسي دقيق‌تر و بيان نحوه عملكرد حملات D.O.S احتياج به بررسي پاكتهاي TCP و چگونگي برقراري ارتباط تحت پروتكل TCP/IP است كه در اين مقاله به بررسي اجمالي از آن مي پردازيم .

بررسي اجزاي داخل يك پكت TCP :

اجزاي داخلي يك پكت TCP شامل اطلاعاتي در مورد درگاه مبدا درگاه مقصد شماره رشته داده ها و... مي‌باشد كه باعث مي‌شود اطلاعات در مسير اينترنت جا به جا شوند.

بررسي عملكرد پروتكل TCP
سه مرحله اصلي دست دادن يا برقراري ارتباط بين يك سرويس دهنده و يك مشتري:
در اين شكل سرويس دهنده(Server) با اسم TCP B و مشتري(Client) با اسمTCP A نشان داده شده است.

1 - مشتري پكت TCP را با علامت SYN براي سرويس دهنده ارسال مي نمايد . اين پكت باعث مي شود سرويس دهنده متوجه گردد كه مشتري درخواست ارسال اطلاعات را دارد. در اين هنگام مشتري منتظر جواب از سوي سرويس دهنده باقي مي‌ماند تا در صورت برگشت جواب اطلاعات را ارسال كند .
2 - سرويس دهنده پس از دريافت در خواست مشتري يك پكت را با علامت SYN/ACK در پاسخ براي مشتري ارسال مي‌نمايد. اين پكت نشان دهنده اجازه برقراري ارتباط و ارسال اطلاعات مي‌باشد.
3- مشتري پس از دريافت پكت از سوي سرويس دهنده يك ACK براي سرويس دهنده ارسال مي‌كند .
4 - سپس مشتري اقدام به ارسال اطلاعات مي‌كند.

بررسي انواع روش‌هاي DOS

بررسي حمله SYN flood :
اين حمله با ارسال درخواست‌هاي متعدد با علامت SYN به ماشين قرباني باعث پر شدن سف Backlog مي‌شود. اما Backlog چيست؟ تمامي درخواست‌هايي كه به ماشين وارد مي‌شوند و شامل علامت SYN براي برقراري ارتباط مي‌باشند در قسمتي از حافظه به ترتيب ذخيره مي‌شوند تا پس از بررسي جواب آنها داده شده و ارتباط برقرار شود، اين قسمت از حافظه Backlog Queue نام دارد. وقتي كه اين قسمت به علت درخواست‌هاي زياد پر شود، سرويس دهنده مجبور به رها كردن درخواست‌هاي جديد مي‌شود و در نتيجه از رسيدگي به اين درخواست‌ها باز مي ماند (Denial Of Service) . ) شكل شماره 4-1 (

بررسي Reset(RST) :
پاكت‌هايي كه به علامت RST ارسال مي‌گردند باعث مي‌شوند كه ارتباط مورد نظر قطع گردد. در واقع اگر ماشين A به سمت ماشين B پاكتي را با علامت RST ارسال كند درخواست اتصال مورد نظر از Backlog پاك خواهد شد.
از اين حمله مي توان براي قطع اتصال دو ماشين استفاده كرد. به اين ترتيب كه اتصالي كه بين دو ماشين A و B برقرار است را نفوذگر با ارسال يك در خواست RST به ماشين B از طرف ماشين A قطع مي‌كند. در واقع در داخل پكتي كه از سوي ماشين نفوذگر به سمت قرباني ارسال مي‌شود IP مشتري گذاشته مي‌شود و در اين صورت ماشين B كه سرويس دهنده مي‌باشد ارتباط مورد نظر ماشين A را از Backlog حذف مي‌كند.
در اين روش شخص حمله كننده بوسيله ابزاري مي‌تواند IP جعلي توليد كرده و در واقع درخواست خود را جاي ماشين ديگري ارسال كند. به اين تكنيك Spoofing نيز گفته مي شود . (شكل شماره 5-1(

با كمي دقت در شكل شماره 5-1 در مي‌يابيد IP مبدا (SourceIP) كه در پكت ارسالي از سوي ماشين حمله كننده به سمت ماشين B ميرود همان IP ماشين شماره A مي باشد(1.1.1.1( . در صورتيكه IP ماشين شماره C كه نفوذگر از آن استفاده مي‌كند چيز ديگري است . (1.1.1.3(

بررسي حمله Land Attack :
در اين حمله با استفاده از روش Spoofing در پاكت‌هايي كه به سمت سرويس دهنده ارسال مي‌شود به جاي IP و Port مبداء و مقصد IP و Port خود ماشين سرويس دهنده قرار داده مي‌شود.
در واقع IP و PORT ماشين سرويس دهنده به سمت خود سرويس دهنده ارسال مي‌شود. اين عمل باعث مي شود تا در سيستم عامل‌هاي قديمي يك حلقه داخلي Routing به وجود بيايد كه باعث پر شدن حافظه و به وجود آمدن حمله DOS مي شود. اين حمله در ماشين‌هاي Win 95 (winsok 1.0) و Cisco IOS ver 10.x و سيستم‌هاي قديمي باعث از كار افتادن سيستم مي‌شد اما امروزه تمامي سيستم هاي هوشمند مانند IDS ها قادر به شناسايي اين حملات مي باشند و اين حمله تاثير زيادي بر روند كاري سرويس دهنده ندارد.

بررسي حمله Smurf Attack :
اين حملات با ارسال درخواست‌هاي ICMP به سمت محدوده‌اي از IP هاي amplifier باعث وسعت دادن ترافيك و به وجود آمدن حمله DOS مي شوند.
حمله كننده مي‌تواند درخواست‌هاي ICMP خود را به صورت Spoof شده و از طرف ماشين قرباني به IP هاي amplifier ارسال كند با ارسال هر درخواست صدها جواب براي درخواست ICMP به سمت ماشين قرباني سرازير مي شوند و ترافيك آن را بالا مي برند. ( شكل شماره 6 - 1)
Amplifier: تمام شبكه‌هايي كه درخواست‌هاي ICMP را براي IP broadcast خود فيلتر نكرده‌اند يك Amplifier محسوب مي شوند.
حمله كننده مي‌تواند در خواست‌هاي خود را مثلا به IP هايي مانند:
192.168.0.xxx كه X مي تواند 255, 223, 191, 159, 127, 95, 63, 31, 15, 7, 3 يعني IP هاي Broadcast باشند ارسال كند . البته قابل ذكر است IP broadcast بستگي به چگونگي بخش‌بندي IP در شبكه دارد.

IDS: اين برنامه ها نسل جديد برنامه هاي امنيتي هستند كه قادرند ترافيك يك شبكه را مورد بررسي قرار داده و حملات جديد نفوذگران را شناسايي كرده و جلوي آن را بگيرند خصوصيت اين برنامه ها هوشمند بودن آنها است. اين برنامه ها در لايه هاي پايين شبكه تمامي پكتهاي رد و بدل شده بين ماشين ها را خوانده و مورد بررسي قرار مي‌دهند.

معرفي ايزارهاي D.O.S
چند نمونه از برنامه‌هايي كه توسط نفوذگران بر روي ماشين‌هاي Zombie براي حملات DOS مورد استفاده قرار مي‌گيرند به شرح زير مي باشند:
Trin00
TFN2K(Tribe Flood Network)
Stacheldraht
t wintrin00
mstream
Evil bot
Pulse 2002 (BY Security Storm)

تمامي اين برنامه‌ها قادرند به عنوان ابزاري براي به وجود آوردن حملات DOS مورد استفاده قرار گيرند.
نفوذگران براي آن كه بتوانند حملات خود را به صورت كامل انجام دهند احتياج به ماشين‌هاي زيادي دارند تا با در اختيار گرفتن پهناي باند ماشين‌هاي آلوده يا همان Zombie ها حملات DOS خود را شكل دهند بيشتر آنها به نفوذ به اين ماشين‌ها بر روي آنها برنامه هايي را نصب مي‌كنند كه قادرند تا در زمان مشخص فرمان‌هاي خود را بر روي آنها اجرا كنند يكي از اين برنامه ها Evil bot است كه نفوذگر مي‌تواند فرمان‌هاي خود را از طريق يك IRC server به صدها ماشين آلوده در يك زمان ارسال كند.

Zombie: بيشتر ماشين‌هاي موجود در دانشگاه‌ها و يا مراكز دولتي به علت پهناي باند مناسبي كه دارند و همچنين رعايت نكردن اصول امنيتي كافي هك شده و بعد از نصب ابزار DOS بر روي آنها توسط نفوذگران براي تشكيل حملات DOS مورد استفاده قرار مي‌گيرند، در اصطلاح Zombie به ماشين‌هايي گفته مي‌شود كه توسط نفوذگران هك شده‌اند و نفوذگران قادرند با درخواست‌هاي خود از روي اين ماشين‌ها قرباني خود را مورد حمله قرار دهند.

--------------------------------------------
1- windowsupdate.comيكي از سايت‌هاي مايكروسافت كه امكان دريافت اخرين Patch هاي سيستم عامل‌هاي مختلف ويندوز بوسيله آن امكان پذير است.
2- براي اطلاعات و اخبار بيشتر در مورد عملكرد blaster مي توانيد به پيوندهاي زير مراجعه كنيد :
http://www.hat-squad.com/blog/archives/000042.html
http://www.hat-squad.com/blog/archives/000041.html
http://www.hat-squad.com/blog/archives/000038.html
3- اخبار مربوط به حمله DDOS بر روي سرويس شركت SCO :
http://www.computerworld.com/governmenttopics/government/legalissues/story/0,10801,88065,00.html?f=x62
http://www.caida.org/analysis/security/sco-dos
4- براي اطلاعات و اخبار بيشتر در مورد عملكرد ويروس Cycle مي توانيد به پيوند زير مراجعه كنيد:
http://www.hat-squad.com/pe/000074.html

در صورتيكه احساس مي‌كنيد شبكه شما توسط حملات DOS مورد حمله قرار مي گيرد مي توانيد از سرويس هاي بررسي حملات گروه امنيت Hat-Squad استفاده نماييد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 22 دیماه 1383

01:19 PM

January 11, 2005

شبکه Wi-Fi الکامپ امن نيست !

پنجشنبه، 28 آبان، 1383

شبکه Wi-Fi الکامپ امن نيست !

بهرنگ فولادی،نيما مجيدی،آرش کريم بيگی: چند روز پیش از آغاز کار نمایشگاه الکامپ این تیتر در روزنامه ها جلب توجه می کرد: "کامپیوترهای خود را به الکامپ بیاورید تا ازاینترنت پرسرعت الکامپ استفاده کنید" که حاکی از ارائه سرویس اینترنت بیسیم در محل نمایشگاه برای بازدید کنندگان بود. این خبر از این جهت جالب توجه بود که درواقع اولین تجربه ارائه دسترسی به اینترنت با استفاده از تکنولوژی Wi-Fi برای عموم در یک نمایشگاه بزرگ آنهم در ابعاد الکامپ بود.
شبکه های بیسیم رایانه ای به خاطر استفاده از زیرساخت رادیویی در مقایسه با سایر شبکه های متداول، آسیب پذیری امنیتی بیشتری دارند. از این رو گروه امنیتی-تحقیقاتی Hat-Squad تصمیم به آزمون امنیتی این شبکه گرفت.
روز سه شنبه مورخه 26/8/83 در اولین روز برگزاری نمایشگاه، این آزمون امنیتی با استفاده از یک دستگاه کامپیوتر Note-Book که برای این منظور تنظیم و آماده شده بود، انجام گرفت. در مرحله نخست، با استفاده از Note-Book تنظیم شده و استقرار در سالنهای نمایشگاه ، امواج رادیویی دریافت گردید و اطلاعات اولیه کسب شد. در هر سالن 3 تا 4 AP-Access Point قراد داده شده است که با SSID=elecomfair2004 کار برقراری ارتباط شبکه ای را در محدوده آدرسهای IP 1.0.0.0/8 تامین می کنند. علاوه بر این AP ها بیش از یازده AP دیگر که عمدتا در غرفه های مختلف شرکت کنندگان در نمایشگاه نصب شده اند، نیز تشخیص داده شد. فهرستی از AP های موجود در شکل 1 نشان داده شده است.

شکل 1 نمایش AP موجود و مشخصات آنها
شکل 1 نمایش AP موجود و مشخصات آنها

شکل 2 نمایش سیگنالهای دریافتی
شکل 2 نمایش سیگنالهای دریافتی

نکته قابل توجه این است که بجز 2 تا 3 عدد از این AP ها، مابقی بخصوص elecompfair2004 فاقد پروتکل رمز گذاری اطلاعات WEP بودند. WEP پروتکل رمز گذاری است که برای تامین امنیت تبادل اطلاعات در شبکه های بیسیم به طور وسیع مورد استفاده قرار می گیرد. اگر چه این پروتکل نیز دارای ضعفهای امنیتی بوده و قابل نفوذ می باشد، اما همین حداقل تدبیر امنیتی نیز در این مورد نادیده گرفته شده است. عدم استفاده از این پروتکل امکان شنود امواج رادیویی شبکه های بیسیم را فراهم می کند. بطویکه با استفاده از امکانات نرم افزاری خاص و برنامه نویسی کارت شبکه بیسیم و تحت نظر گرفتن ترافیک شبکه، نفوذگر یا نفوذگران احتمالی قادر به تشخیص و ضبط پاکتهای داده حامل اطلاعات حساس مانند کلمات عبور یا پیغامهای خصوصی و حتی ارسال اطلاعات جعلی خواهند بود.
با توجه به اطلاعات جمع آوری شده از AP ها در مرحله قبلی ترافیک رادیویی شبکه عمومی مربوط به elecompfair2004 در لایه شبکه (Network Layer) و ترافیک مربوط به AP های خصوصی مستقر در غرفه ها در لایه ارتباطی (Data Link Layer) کاملا قابل شنود و دسترسی بود.
نمونه ای از ترافیک ضبط شده مربوط به شبکه عمومی elecompfair2004 در آدرس http://www.hat-squad.com/elecomp2004 قابل دسترسی می باشد.

شکل 3 نمایش نمونه ای از ترافیک شبکه ( سرور DOURAN-01 در حال SMB Broadcast)
شکل 3 نمایش نمونه ای از ترافیک شبکه ( سرور DOURAN-01 در حال SMB Broadcast)

در مرحله بعدی آزمون تیم hat-squad تعدادی از کامپیوتر های متصل به شبکه بیسیم elecompfair2004 شامل ایستگاههای کاری ثابت در غرفه ای نمایشگاه و Note-Book های متصل، مورد پویش امنیتی محدود بدون نفوذ Security Scan قرار گرفت که خلاصه ای از نتایج آن در آدرس http://www.hat-squad.com/elecomp2004 قابل دریافت می باشد که دال بر ناامن بودن ساختار و سهولت در نفوذ و خرابکاری از طرف نفوذگر یا نفوذگران احتمالی است.
موضوع مدیریت امنیتی یا Security Event management امروزه در برگزاری نمایشگاهها، گردهمایی ها و رویدادهای تجاری، سیاسی و ورزشی از اهمیت خاصی برخوردار می باشد. شایسته است که مسوولین برگزاری چنین رویدادهایی در کشور ، توجه بیشتری به تامین امنیت اطلاعات و خدمات داشته باشند. بخصوص نمایشگاهی در قد و قواره الکامپ که بزرگترین نمایشگاه و همایش فناوری اطلاعات و ارتباطات کشور است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 23 دیماه 1383

01:35 PM

January 12, 2005

روزنامه نگارى آنلاين ،مدلسازى براى رسانه هاى خبرى در وب

21 دى 1383 - ایرنا - روزنامه نگارى آنلاين را به خاطر استفاده از فن آورى ميتوان از ساير
روزنامه نگاريها تميز داد.نوع چهارم از روزنامه نگارى که در ويژگى هايش
متفاوت با انواع ديگر روزنامه نگارى سنتى است .

نشريه اينترنتى هفت سنگ (ang Persian E-Magazine7s)در ادامه اين مطلب
آورده است ، قبل از شناخت انواع مختلف روزنامه نگارى آنلاين ،بايد به اين
مطلب اشاره شود که اينترنت به لحاظ تاثيرى که اکنون بر روزنامه نگارى مى-
گذارد،را به دو گونه در نظر گرفت .

راهى که به سوى دفاتر خبرى و ميزکار روزنامه نگاران باز کرده است
با نام CAR(خبرنگارى با کمک کامپيوتر) و ديگر اينکه نوع تخصصى جديدى
از روزنامه نگارى يعنى "روزنامه نگارى آنلاين " را به وجود آورده است .

مشخصات بارز استفاده از اينترنت به عنوان وسيله خبرنگارى براى رسانه
هاى سنتى، در دسترس بودن آرشيو قابل جستجو،پايگاه هاى اطلاعاتى ومنابع
خبرى بر روى اينترنت براى روزنامه نگاران است .

اين نوع از روزنانه نگارى در بسيارى از کشورها در مقايسه با ايالات
آمريکادر مراحل اوليه خود به سر ميبرد.

دانشمندان متعددى آثار CARبر روزنامه نگارى و مراحل خبرنگارى را
مطالعه کرده اند و به اين نتيجه رسيده اند که علاوه بر منفعت هاى بيچون و
چرا (اطلاعات بيشتر و منابع گسترده تر) بسيارى از روزنامه نگاران از حضور
اينترنت در کارشان واهمه دارند.

تحقيقى از BBCبريتانيا نشان داده است فن آوريهاى رسانه جديد چه
مشکلاتى را در دفاتر خبرى به وجود آورده است .خبرنگاران از کمبود زمان
براى استفاده بهينه و کنترل تکنولوژى و احساس اضطراب به خاطر طبيعت "آنى"
شکايت دارند.

مساله ديگر که خبرنگاران با آن روبرو هستند اين است که چگونه با
ايميل و گروهاى خبرى در محيطى که تنوع اطلاعات بسيار زياد است کار کنند،و
اين مساله غالبا ارتباط سريع و بدون نام در کار است .

روزنامه نگارى آن لاين بايد اين تصميم را اتخاذ کند که کدام رسانه
بهتر يک مطلب را بيان ميکند.(چند رسانگى)،بايد فضايى را به عموم اختصاص
دهد تا بتوانند عکس العمل نشان دهند،ارتباط برقرار کنند يا حتى در يک
مطلب مشارکت کنند.

اين نوع از روزنامه نگارى همچنين بايد راه هايى را در نظر گيرد که
اين مطلب با مطالب،آرشيوها،منابع و همين طور با لينک هاى ديگر هم ارتباط
داشته باشد.

اين نوع ايده آل و مثال زدنى روزنامه نگارى آن لاين است ، به گونه اى
که توسط متخصصان جهانى تعريف شده است .

سايتى که به کاربران اجازه نظر دادن ،ارسال مطالب و فايل را بدون
هيچ گونه مانع يا فيلترى ميدهد سايت "باز" و در مقابل سايتى که به
کاربران اجازه مشارکت ميدهد اما تحت کنترل شديد سردبير،سايت "بسته "
خوانده ميشود.

جهانيترين نوع رسانه خبرى آنلاين سايت هاى خبرى هستند که به طور
معمول شامل منتخبى از مطالب هيئت تحريريه به علاوه يک بخش تحت کنترل براى
ارتباطات و مشارکت هاست .

نمونه هايى از اين قبيل سايت هاى مانند CNN،BBC، MSNBCاز روزنامه
هاى آن لاين هم به همين گروه تعلق دارند.

علاوه بر اين موارد ،مباحث درسى ،کتابها،برنامه هاى کلاس هاى روزنامه
نگارى و دانشگاهها،به کارگيرى و آموختن مهارت ها(کارکردن بانرم افزارها،
يادگيرى XML، HTMLمهارت هاى خاص نوشتن خبر بر روى وب) در گروه سايت هاى
اصلى خبرى جاى ميگيرند.

سايت هاى طبقه بندى شده و فهرست وار،نوع دوم روزنامه نگارى آن لاين
هستند که کمابيش در مقوله قبل ميگنجد.اما غالبا اين نوع سايت ها(مانند
Yahoo) يا آژانس ها(Newsindex) با جستجوگرهاى خاص شان شناخته ,Altavista
مى شوند.

روزنامه نگارى آن لاين لينک هايى را از منابع گوناگون سايت هاى خبرى
ارايه ميدهد که اين لينک ها غالبا طبقه بندى شده اند.

اين گونه سايت ها معمولا کار زيادى در در حوزه تحريريه خود انجام نمى
دهند اما گاهى مکان هايى را براى چت ،مبادله خبر يا لينک براى عموم
پيشنهاد ميکنند.

"سايت هاى تفسيرى"،نوع سوم روزنامه نگارى آن لاين ،سايت هايى هستند در
باره رسانه هاى خبرى و در کل ،مطالب رسانه ها که گاهى به عنوان مراقبان
رسانه هااز آنها ياد ميشود.

بعضى از آنها مانند يک سايت طبقه بندى شده گسترده (مانند European
journalism center Medianews) به وسيله تعدادى خبرنگار تهيه ميشود و
عموما درباره مطالب ديگر بحث ميکنند.

اين "روزنامه نگارى درباره روزنامه نگارى" يا"متاژورناليسم " به طور
خاص آن لاين شکل ميگيرد.

"سايت هاى مشارکتى و بحث و گفتگو" نوع چهارم روزنامه نگارى آن لاين
هستند.اين سايت ها در مرحله اول فضايى را براى تبادل ديدگاه ها و نظرات
ارايه ميدهد.

سايت هاى متعددى قابليت اين را يافته اند که اين تقاضاى عمومى را
براى مشارکت و ارتباط پاسخ دهند با پيگيرى موضوعاتى براى بحث درباره بخش
ديگرى بر روى نت .

اين نوع روزنامه نگارى آن لاين همچنين "وبلاگ هاى گروهى" را معرفى
کرده است که توسط افراد متعددى براى بيان تجربياتشان ساخته ميشوند.

اين مطلب از شماره ۱۷ بولتن جامعه اطلاعاتى ،به نقل از مجله
اينترنتى هفت سنگ (ang Persian E-Magazine7s) گرفته شده است .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:29 AM

January 13, 2005

ارزیابی فروش نرم افزارهای ERP

نويسنده: ناصر شريفيان

2 فروردين 1383 - systemgroup - تصميم گيرى در مورد انتخاب يك بسته نرم افزارى مناسب ERP از يك فروشنده مناسب يكى از مهمترين تصميمات در اين مورد شناخته مى‌شود كه با ارزيابى صحيح واصولى توليد كنندگان و فروشندگان اين نرم افزارها در بازار ERP انجام پذير خواهد بود.
وقتى سازمان شما تصميم مى‌گيرد يك سيستم ERP را انتخاب و خريدارى كند، چه معيارهايى را بايد در مورد فروشنده سيستم ERP مدنظر داشته باشد؟ چگونه مى‌توانيد اطمينان حاصل كنيد كه آن فروشنده همه نيازهاى شما را در مورد اين سيستم‌ها برآورده خواهد ساخت و به طور كلى چه فاكتورهايى را بايد در مورد سازمان خود و همينطور فروشنده نرم افزار ERP در نظر داشته باشيد؟
اكثر سازمان‌هايى كه تصميم به استفاده از اين سيستم‌ها مى‌گيرند، ماه‌ها به ارزيابى فرآيندهاى كسب و كار خود مى‌پردازند و بررسى مى‌كنند كه آيا آنها نياز به متناسب سازى نرم‌افزارهاى مربوطه خواهند داشت يا خير و مهم‌تر از همه اين‌كه آنها چه انتظاراتى از يك نرم‌افزار ERP خواهند داشت ؟
مرحله بعدى نيز، به انتخاب يك فروشنده مناسب ERP مربوط مى‌شود. اما با وجود تنوع زيادى كه در مورد سيستم‌هاى(راه حلهاى[1])ERP وجود دارد، تعيين اين كه كدام‌يك به بهترين نحو، نيازهاى سازمان شما را برآورده مى‌سازد، كار دشوارى به نظر مى‌رسد. تعداد زيادى از شركت‌ها بدون اين كه به بررسى جوانب مختلف امر بپردازند، اقدام به خريد اين نرم افزارها مى‌كنند. تعدادى نيز در مراحل راه اندازى اين سيستم‌ها با مشكلات جدى مواجه مى‌شوند كه اگر قبل از اقدام به خريد، شركتهاى فروشنده ERP و نيازها و انتظارات خاص خود را مورد بررسى و بازنگرى بيشترى قرار مى‌دادند، به اين مشكلات دچار نمى‌شدند.

Adam Golden & Dawn Scaiano

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:30 AM

January 13, 2005

سال 83 : سال حمايت از توليد محتواى فارسى روى وب

6 فروردين 1383 - بخش مقاله آى تى ايران - مرسوم است که در آغاز هر سال گروه‌ها و اصناف گوناگون جامعه ، شعارها و برنامه‌هاى خود را براى يک سال پيش رو اعلام مى کنند و مى‌کوشند با ترسيم فضايى اميدوار کننده ، چشم‌انداز و vision خود براى ماه‌هاى آينده تشريح کنند. از اين رو شايسته‌ است که جامعه کارشناسان ، دست‌اندرکاران ، منتقدان و حاميان صنعت فناورى اطلاعات در ايران نيز همچون ساير اصناف و گروه‌ها براى سال پيش رو يک شعار مناسب انتخاب کنند و بر مبناى آن حرکت‌ها و برنامه‌هاى خود را مشخص و هماهنگ کنند.
مايلم در آغاز سال جديد ، به عنوان يک عضو کوچک از جامعه اطلاعاتى ايرانى ، پيشنهادى را از طريق اين تريبون باارزش ، سايت آى‌تى ايران ، مطرح کنم و نظر علاقه‌مندان و صاحبنظران را جويا شوم.
چنانکه مى‌دانيد ، در سالى که گذشت با وجود تمام مشکلات سياسى و اقتصادى عمومى جامعه و همزمان با مشکلات جارى صنعت IT در کشور از جمله اعمال بى‌ضابطه و پر و افت‌وخيز سياست فيلترينگ و نيز تداوم مشکلات مربوط به زيرساخت‌هاى ضعيف و يا نارساى شبکه ارتباطى و اطلاعاتى کشور ، جريان توليد محتواى فارسى تحت حمايت جنبش وبلاگ‌نويسى به زبان فارسى همچنان به رشد خود ادامه داد و توانايى‌ها و ضعف هاى بالقوه خود را نشان داد.
رشد مثبت و قابل توجه اين جريان نشان داد که جامعه کاربران فارسى زبان در شبکه اينترنت داراى اين پتانسيل قوى و مناسب هستند که با به‌کار انداختن قوه خلاقيت خود ، توليد محتواى فارسى روى وب را به يک واقعيت و يک دستاورد ارزشمند بدل سازند. چه خوب است که اين نيروى بالقوه را که چنديست به قعل درآمده و ارزش‌هاى خود را نشان داده‌است پاس داريم و با پيوستن به اين حرکت خود‌جوش آن را به يک فعاليت مدنى جهت‌دار و با برنامه تبديل کنيم. مقدمه سخن را کوتاه مى‌کنم و در چند بند اهميت و برخى جنبه‌هاى کليدى تلاش در جهت عملى ساختن شعار <توليد محتواى فارسى روى وب> را برمى‌شمارم :

1- پيش از هر چيز بديهى به نظر مى‌رسد که اين جنبش داراى بالاترين و نيرومند‌ترين جايگاه براى حفظ و حراست از زبان فارسى در سپيده‌ دم قرن بيست‌ويکم است. طوفان انقلاب فناورى اطلاعات ديريست که سراسر دنيا را درنورديده و اينک مى‌رود که جامعه ايرانى را با همه جنبه‌هاى سنتى و مدرن خود دربرگيرد. شايسته است پيش از آنکه فضاى سايبر مختصات و ويژگى‌هاى خود را به ما تحميل کند ، در پديد آمدن همين مختصات مشارکتى فعال داشته باشيم. من عقيده‌ دارم مرحله اول فرآيند ساخت و برپا شدن جامعه اطلاعاتى هنوز به پايان نرسيده و اندک فرصتى براى مشارکت در پايه‌گذارى زيربناى اين جامعه باقى مانده‌است.

2- اکنون به نظر مى‌رسد که از يک سو ، نيروى انسانى متخصص لازم براى طراحى و توسعه سيستم‌هاى نرم‌افزارى توليد محتواى فارسى روى وب به پختگى و مهارت لازم براى پوشش دادن نيازهاى آحاد جامعه در فضاى سايبر رسيده‌است و از سوى ديگر ، چندى است که اهل قلم و ناشران کتاب و مطبوعات با ابزارهاى ديجيتالى هزاره سوم براى اطلاع‌رسانى و سخن‌پراکنى آشتى کرده‌اند و با جنبه‌هاى گوناگون آن آشنا شده‌اند. اين بهترين فرصت براى بهره‌بردارى از فرصت‌ها و عملى کردن روياهاست. ترديد ندارم که جامعه متخصصين IT در ايران هم توان لازم براى پشتيبانى از اين جنبش را يافته‌اند و هم از رويکرد ساير اقشار جامعه به اين نهضت فنى و فرهنگى استقبال خواهند کرد.

3- شايسته است که نخبگان علمى و فنى جامعه ، خصوصا در صنعت فناورى اطلاعات ، اهميت و ارزش جنبشى را که بدون دستور و امر حکومتى و کاملا خود‌جوش به وجود آمده‌است را دريابند و با ترسيم خط مشى و آرمان‌ها و اهداف مناسب ، آن را پيش از آنکه دير شود هدايت و راهبرى کنند. لازم است دقت کنيم اگرچه آغاز اين حرکت کاملا مردمى و خودجوش صورت شکل گرفته است اما بى‌ترديد حمايت علمى ، فنى و معنوى نخبگان مستقل را براى ادامه مسير نيازمند است چه در غير اين‌صورت همچون ساير پديده‌هاى طبيعى اجتماعى فروکش کرده و به انواع ضعف‌ها و نارسايى‌هاى تکنيکى و محتوايى آلوده خواهد شد. در راس اين نارسايى‌ها مى‌توان به خطراتى اشاره کرد که از بابت هجوم طبيعى و سرسام‌آور واژگان غير فارسى پديد آمده‌اند و اينک مى‌رود تا تمام هستى اين زبان زنده دنيا را در کام خود کشد.

4- شايسته است تمام مطبوعات مرتبط با کامپيوتر و فناورى اطلاعات در برنامه‌هاى اصلى خود در سال 1383 جاى مناسبى نيز براى پيوستن به جنبش توليد محتواى فارسى درنظرگيرند. اين نشريات از يک سو آشنايى کافى با مشکلات و مسائل مربوط به فناورى اطلاعات دارند و از سوى ديگر هم فرهنگ و زبان مخاطب را بهتر مى‌شناسند و هم ابزار و توان لازم براى توليد محتوا – اين مهمترين و بنيادى‌ترين مشکل صنعت نشر اطلاعات روى وب - را دارند.
اين نشريات بايد اهميت جايگاه کليدى خود در اين جريان را دريابند ، سستى و رخوت را به کنارى نهند و در اين حرکت پيش‌گام باشند. هم‌اکنون سايت‌هاى فارسى زبان و نوپاى بسيارى در اينترنت پديدآمده‌اند که از بابت مشکلات توليد محتوا در رنجند. اگر اين مشکلات تداوم يابد و سايت‌هاى جديد التاسيس بدون حمايت رها شوند بسيارى از استعداد‌هاى نهفته و جوان پيش از رسيدن به بلوغ پژمرده خواهند شد. اکنون که ذوق و شوق پيوستن به اين جريان بسيارى از جوانان را متوجه خود ساخته است ، هرگونه بى‌محلى و بى‌توجهى به آنان از سوى ناشران مطبوعات خصوصا ناشران مطبوعات کامپيوترى ، معنا و تفسير ديگرى جز سستى ، بى‌برنامگى ، ناتوانى و عدم شناخت کافى نسبت به مقتضيات زمان خود نخواهد داشت.

5- هم نشريات کامپيوترى و هم ساير مطبوعات ايرانى بايد متوجه کمبود‌ها و ضعف‌هاى سايت‌هاى فارسى زبانى که مستقلا به توليد محتواى فارسى مشغول شده‌اند ، باشند و با نگاهى به پتانسيل‌ها و امکانات و تجربيات خود از منفعت مادى و معنوى و در عين حال استراتژيکى که در سرمايه‌گذارى براى توليد محتواى مناسب روى وب وجود دارد ، غافل نمانند. بنگاه‌هاى مطبوعاتى مى‌توانند با تغيير ساختار کسب و کار خود ، زيرمجموعه جديدى در سيستم خود ايجاد کنند که در کنار توليد محتواى عادى مناسب براى چاپ ، همچون يک Content Provider براى جنبش توليد محتواى فارسى در وب عمل کنند و سايت‌هاى ايرانى را تغذيه نمايند.

6- خوب است که شرکت‌هاى ايرانى توسعه دهنده سيستم‌هاى نرم‌افزارى ، على‌الخصوص شرکت‌هاى فعال در زمينه طراحى و برنامه نويسى وب ، در قالب فعاليت‌هاى تبليغى مشخص و مدون ، توان و تجربه خود در زمينه توليد محتواى فارسى روى وب را به عموم مردم اعلام نمايند. اين حرکت تبليغى در عين حال مى‌تواند خون تازه‌اى به رگ‌هاى صنعت نرم‌افزار در ايران تزريق کند.

7- شايسته است که بازيگران عمده صنعت فناورى اطلاعات در ايران در يک حرکت هدفمند و مطالعه شده ، صنعت و صنف ميزبانى وب را از اين بى‌سامانى و هرج‌ومرج نجات دهند و زيرساخت‌هاى مناسبى براى دوام و قوام صنعت توليد محتوا روى وب پديد آورند. رقابت‌هاى کم ارزش و سخيف بر سر فروختن چند مگابايت فضاى وب به قيمت چند هزار تومان ، آنهم با پايين‌ترين کيفيت سرويس‌دهى و عدم پاسخگويى و پشتيبانى مناسب ، بايد جاى خود را به رقابت‌هاى سازنده بر سر ارائه فضاى‌ها کافى روى وب با قيمت‌هاى کارشناسى و با بهترين قابليت‌ها دهد. نگذاريم که اين صنعت نوپا نيز به بيمارى‌هاى مزمن و تاريخى جامعه و اقتصاد ايرانى دچار شود.

پى‌نوشت:
براى اينکه صحبت‌ها در حد حرف باقى نماند ، شخصا اميدوارم در اين حرکت مشارکت داشته باشم. به همين جهت قصد دارم در سال 83 از طريق ارسال مقاله و کمک فنى به سايت‌هاى مرتبط با فناورى اطلاعات از جمله آى‌تى ايران و نيز چند سايت مرتبط با ساير علائق شخصيم ، وظيفه‌اى که براى خودم مى‌شناسم را به انجام برسانم. براى مطالعه جزئيات بيشتر درباره برنامه‌هاى شخصى من در اين زمينه ، يادداشتى را که در همين رابطه در وبلاگم گذاشتم مطالعه کنيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:31 AM

January 13, 2005

پنج اشتباه در استفاده از آموزش الکترونيکى

نويسنده: عليرضا جهانگرد

12 فروردين 1383 - بخش مقاله آى تى ايران - داگرچه آموزش الکترونيکى فنآورى مورد بحث روز مى‌باشد، اما شرکتهايى که اقدام به پياده‌سازى اين فنآورى مى‌نمايند اگر از برخى موارد مشکل‌زا حذر ننمايند، با دشواريهاى فراوانى مواجه خواهند شد.

1- عدم حمايت مديريت ارشد سازمان در مراحل خريد و اجراى مداوم
استقرار فنآورى تنها يک بخش از اجراى آموزش الکترونيکى مى‌باشد. براى کسب موفقيت در درازمدت، مباحث سازمانى از مهمترين چالشها مى‌باشند. مباحثى چون: پيوند آموزش و راهبرد تجارى سازمان، تأمين حمايت مالى، اولويت بندى نيازهاى مربوط به فنآورى و متقاعد کردن کاربران به استفاده از اين روش آموزشى بجاى روشهاى پيشين.
بهترين شيوه: تشکيل کميته پياده سازى آموزش الکترونيکى که در آن يکى از مديران بلند پايه شرکت در رده معاونين يا اعضاى هيأت مديره، به همراه اعضايى به نمايندگى از تمامى حوزه‌ها (از جمله دفتر فنآورى اطلاعات) براى راهبرى توسعه، استقرار و رشد مداوم آموزش الکترونيکى، شرکت دارند.

2- محتواى آموزشى خسته کننده و ضعيف
محتواى ضعيف عامل شکست آموزش الکترونيکى بوده و دانشجويان را به سرعت پراکنده مى‌نمايد. محتوايى که تنها خواندنى باشد توجه دانشجو را جلب نمى‌کند. محتوايى که نيازهاى آنان را برآورده ننمايد نيز، بدون استفاده خواهد ماند.
بهترين شيوه: حصول اطمينان از اينکه محتواى آموزشى از نظر فنآورى داراى طراحى مناسب مى‌باشد و دانشجويان را مجذوب خود مى‌نمايد. انتخاب دقيق محصولات آماده و يا سفارشى که منطبق با نياز کارمندان و ضامن رشد حرفه‌اى آنان باشد، بهتر از خريد کتابخانه‌هاى حاوى صدها عنوان مطلب مى‌باشد.

3- فنآورى که کاربرد آن سخت بوده و غيرمطمئن باشد
وقتى که استفاده از فنآورى، خود يک چالش براى دانشجو باشد، آموزش رخ نخواهد داد. حتى در صورت اجرا نيز، بکارانداختن فنآورى مسئله اصلى مى‌شود و آموزش در مرتبه دوم قرار مى‌گيرد.
بهترين شيوه: حصول اطمينان از اينکه زيرساختهاى موجود نيازهاى اوليه آموزش الکترونيکى را برآورده مى‌سازند و فنآورى بکارگرفته شده براى دانشجويان قابل درک و روشن مى‌باشد. همکارى نزديک با دفتر فنآورى اطلاعات در هر مرحله از ايجاد و استقرار آموزش الکترونيکي. ارتقاء اجزا بر اساس رشد نيازمنديها در عوض خريد فنآورى که داراى امکاناتى اضافى مى‌باشد که بکار نمى‌آيند.

4- فرهنگى که پذيراى آموزش الکترونيکى نباشد و يا هيچ اطلاعى از آن نداشته باشد.
فنآورى عالى و محتواى آموزشى ممتاز مورد قبول دانشجويان واقع نمى‌شود، مگر اينکه آنان از قبل آمادگى تجربه آموزش الکترونيکى را داشته باشند. آموزش الکترونيکى با آموزش کلاسى بسيار متفاوت است و اغلب اتفاق مى‌افتد که کاربران بعنوان يک خط‌مشى آموزشى با چشم ترديد به آن مى نگرند.
بهترين شيوه: ساماندهى يک تيم از بخشهاى مختلف سازمان که شامل بازرگانى، آموزش و مديريت مى‌شود، بمنظور تهيه مداوم اطلاعات، تجربيات و پشتيبانى مورد نياز دانشجويان.

5- عينيت نيافتن آموزش الکترونيکى همراه با نتايج قابل اندازه‌گيرى
قراردادن دوره‌هاى آموزشى در يک فهرست بلندبالا، استفاده از آنها را تضمين نمى‌کند. حتى تعداد دسترسى‌ها به اين دوره‌ها هم بيانگر تعداد کاربرانى که مطلب را ياد گرفته‌اند نمى‌باشد. جلب حمايت مداوم مديريت بستگى به نتايج قابل سنجشى دارد که تأثير مستقيم در تجارت شرکت دارد.
بهترين شيوه: تعيين خط مبناى اندازه‌گيرى مهارتهاى کاربران و قراردادن مقاصدى براى رشد دانشجويان با استفاده از آموزش الکترونيکي. تدوين برنامه آموزش الکترونيکى براى هر کارمند همراه با تجربياتى که باعث ايجاد دگرگونى در کارايى شغلى وى مى‌شود و ترتيب دادن سيستمى براى اندازه‌گيرى اين نتايج.

alireza433@yahoo.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:32 AM

January 13, 2005

واقعیت این است : پارس آنلاین آی اس پی خوبی نیست!

نويسنده: بهروز نوعى‌ پور

13 فروردين 1383 - يادداشت هاى يک شهروند اينترنت - مى‌خواستم امروز درباره موضوع حمايت از توليد محتواى فارسى روى وب توضيح بيشترى دهم و بحث را کمى تخصصى‌تر و جدى‌تر دنبال کنم ولى يک موضوع ساده اما مهم باعث شد که آن را به فردا يا پس فردا واگذار کنم.
امروز مى‌خواهم قضاوت خودم را درباره شرکت سرويس دهنده اينترنت <پارس‌آنلاين> بيان کنم. جان کلام خيلى ساده و کوتاه است : از پارس‌آنلاين سرويس اينترنت نخريد چون ISP خوبى نيست. هم سرويس‌دهى خوبى ندارد و هم بى‌ضابطه فيلتر مى‌کند.

حالا توضيح مى‌دهم چرا :
اولا ، پس از گذشت چند سال از سرويس دهى ISP هاى بزرگى چون پارس آنلاين ، ندارانه ، اوراکل اينترنت ، افرانت و ديگران امکان قضاوت درباره کيفيت کار اين شرکت‌ها وجود دارد. به بيان ديگر ، به اندازه کافى سابقه عملکرد هرکدام از اين شرکت‌ها در مطبوعات و افکار عمومى ثبت و مطرح شده است. بنابراين يک قضاوت کلى درباره هرکدام از اين ISP هرگز يک قضاوت شتابزده نخواهد بود.
ثانيا ، درطول سالهاى گذشته ISP هاى کوچک و بزرگ فراوانى پا به عرصه فعاليت گذاشته‌اند. در همه‌جاى دنيا رسم است که وقتى در يک حوزه خدمات عمومى ، شرکت‌هاى زيادى با يکديگر به فعاليت و رقابت مى‌پردازند ، رسانه‌هاى مستقل به ارزيابى و Benchmark ميان خصوصيات و ويژگى‌هاى مهمترين آنها از جنبه‌هاى گوناگون مى‌پردازند. به نظر من از اين پس ما نيز در ايران به چنين Benchmark هايى درباره کيفيت سرويس دهى ISP هاى ايرانى نياز داريم. البته در شرايط کنونى انتشار يک Benchmark دقيق و مستقل شهامت زيادى مى‌خواهد که من آن را در وجود هيچکدام از رسانه‌هاى چاپى و رسمى ايران نمى‌بينم. بنابراين تنها راه ممکن براى اين کار انتشار ارزيابى‌ها به صورت آنلاين است.
متاسفانه تاکنون هيچ Benchmark دقيق و مناسب فنى و عمومى درباره کيفيت سرويس دهى ISP هاى مهم ايران منتشر نشده است واين البته تاحدودى نيز به عدم تمايل اين شرکت‌ها به آشکارشدن ضعف‌هايشان برمى‌گردد.
در غياب اين ارزيابى‌هاى کارشناسى و قابل اعتماد چاره نخواهد بود که به گفته‌ها و شنيده‌ها و اظهار نظرهاى شخصى اين و آن تکيه کنيم و من خود مى‌دانم که ارزيابى و قضاوت من چيزى بيش از يک نظر شخصى نيست ، ولى شما بگوييد ، چاره چيست؟
به هر جهت ، حالا ديگر مى‌توانم نظر شخصى خودم را درباره پارس‌آنلاين بيان کنم. طى يک سال گذشته از سرويس اينترنت بسيارى از ISP هاى مهم تهران استفاده کردم و کيفيت آنها را بايکديگر مقايسه کردم. متاسفانه در هربار آزمايش سرويس پارس‌‌آنلاين ، نتيجه منفى بود.
شخصا براى مسوولين شرکت پارس‌آنلاين بسيار متاسفم که ارزيابيم درباره‌اش به هيچ رو مثبت نيست. دو سه سال پيش که سايت بى‌بى‌سى فارسى خبر از آغاز به کار اين شرکت داد ، من بر اين تصور بودم که پارس‌‌آنلاين يکى از بهترين ISP هاى ايران خواهد شد. البته پارس‌آنلاين به گمانم بزرگترين ISP شد ولى بهترينش نشد و واقعا متاسفم...

http://infotechmedia.com/behrooznp/

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:34 AM

January 13, 2005

توليد محتواى فارسى

نويسنده: محمود بشاش

24 فروردين 1383 - همکاران سيستم - نگران نباشيد، در اين مقاله شما را تشويق به توليد محتواى فارسى و يا تشويق به اسم گذارى سال 83 به عنوان سال توليد محتواى فارسى نخواهم کرد.
در اين مقاله سخن از محتواى فارسى نيست بلکه سخن از توليد است. به نظر من بخش اصلى اين جمله " توليد محتواى فارسى" همان کلمه اول آن است در حالى که با خواندن آن، معمولاً روى بخش دوم آن متمرکز مى‌شويم و شايد شما هم مثل من متوجه شده باشيد اين روزها و خيلى روزهاى قبل هم صحبت از اين موضوع بسيار بوده است.
من هم مانند شما به اين موضوع اعتقاد دارم که ما بايد محتواى فارسى توليد کنيم ولى بر خلاف نظر برخى از دوستان، اعتقاد ندارم هر آنچه که به زبان فارسى نوشته شود را اولاً اسمش را مى‌توان گذاشت محتوا ثانياً اين کار را مى‌توان گفت توليد. پس با يک بحث داغ شما را به يک چالش جدى دعوت مى‌کنم.
من معتقد هستم همان گونه که مثلا در صنعت مانيتور، هر کس در ايران مى‌گويد ما توليد مى‌کنيم، در دلمان نجوا مى‌کنيم که کاش مى‌گفتيد مونتاژ نه توليد چرا که وقتى فناورى توليد بسيارى از قطعات مانيتور در ايران وجودندارد، پس چگونه ما توليد مى‌کنيم، همان گونه هم در صنعت فناورى اطلاعات و ارتباطات، خوب است روى اين کلمه توليد بيشتر فکر کنيم و درست از آن استفاده کنيم.
هدف من اصلاح کلمات و عبارات نيست، چرا که شما با بازى با کلمات مى‌توانيد مونتاژ کردن را جاى توليد کردن به مردم بقبولانيد ولى نفس موضوع را نمى‌توانيد تغيير دهيد. توليد محتوا يعنى اينکه شما طبق دانش و تجربه خود، طبق آموخته‌ها و سواد فارسى خويش و با بررسى نياز موجود، محتوا بسازيد. محتوايى که کسى به آن نياز ندارد هم بى خاصيت است. يک روز با دوست خوبم سردبير مجله کامپيوتر و ارتباطات بحث بود. سخن از وب لاگ‌ها شد. همين نکته مورد توجه بود که اطلاعات بى خاصيت، خروارها هم که در يک وب سايت جمع آورى شود، اسمش را نمى توان گذاشت توليد محتواى فارسي.
شما براى قضاوت در مورد اين موضوع کافى است سرى بزنيد به وب سايت‌هاى معروف ايرانى که در اين زمينه يعنى توليد محتواى فارسى فعال هستند. مثلاً همين سايت شخصى خود من در آدرس www.mahmoodb.com ، شايد بتوان گفت 70% مطالب آن ترجمه مطالب سايت‌هاى خارجى است. البته ترجمه نيز نوعى توليد محتوا است، اما در حقيقت تغيير شکل محتوايى است که کسان ديگرى آنها را بر اساس دانش و تجربه خود توليد کرده اند. همين ترجمه کردن مطالب، خودش معضلى است چرا که در نگارش و لحن موضوع هم تاثير مى‌گذارد. آدم احساس مى‌کند دارد اداى خارجى ها را در مى آورد ولى به زبان فارسى اين کار را مى‌کند.
در موضوع ترجمه، پارامتر مفيد بودن، بيشتر جلب توجه مى‌کند يعنى چون اصولاً ترجمه کردن کمى سخت است، معمولاً مى‌گرديم و مطالب مفيد ترى را براى ترجمه انتخاب مى‌کنيم که به طور خودکار محتواى توليد شده، مفيد خواهد بود. به همين خاطر است که مثلاً مطالب سايت من جالب است، چرا که براى خواننده مفيد خواهد بود و خواننده شايد در زمان خواندن آنها به فکر اين نباشد که آيا اين ها ترجمه است يا تاليف و بيشتر به اين فکر باشد که از اين مطالب در کار خود چه استفاده اى ببرد.
نمونه سايت ديگرى که مى توان روى آن صحبت کرد سايت www.itiran.com است. اين وب سايت ترکيبى از وب سايت خبرى و وب سايت مقاله است. البته بگذريم که اين ترکيب خودش کمى ايراد دارد ولى فعلاً قصد به چالش بردن اين موضوع را ندارم چون ممکن است مقالات بعدى من را ديگر چاپ نکنند! به هر حال، در مورد اخبار چون اصولاً ما صاحب فناورى IT نيستيم، پس اخبار چندان زيادى هم نداريم به همين دليل ترجمه اخبار خوب است که اتفاق افتد ولى در مورد مقالات، کمى نگران کننده است که تعداد مقالات ترجمه شده از تعداد مقالات توليد شده خيلى بيشتر باشد. ما حتى در مورد انتخاب مقاله براى ترجمه هم مشکلاتى داريم. ببينيد دوستان، همين مقاله را که در مورد پنج شرکت برتر مبارزه با Spam است:
http://www.itiran.com/artic/show.asp?no=8212290823 با چه دقت و صرف وقت ترجمه شده است. (يکى از منابع:
http://www.darwinmag.com/read/020104/spam.html ) و البته کار خوبى انجام گرفته است ولى من شخصاً براى بررسى اين موضوع سراغ اطلاعات انگليسى آن مى روم چرا که شما اگر کمى دقت کنيد مى‌بينيد که تعداد بسيار زيادى کلمات انگليسى در متن است که امکان ترجمه آنها نبوده است و اين موضوع هم زيبائى و هم خوانايى متن را تحت تاثير منفى قرار داده است. پس شايد در مفيد بودن اين مقاله کمى جاى تامل باشد. همين جا اشاره مى کنم به يک مشکل جنبي. فکرش را بکنيد که اگر شما بخواهيد در مورد پنج شرکت برتر ايرانى توليد نرم افزارهاى امنيت شبکه يا ضد ويروس بررسى کنيد، کجاى اينترنت مى‌توانيد اين اطلاعات را پيدا کنيد. اگر هم کسى چنين مقاله اى بنويسد، به عنوان يک مقاله تبليغى به آن نگاه خواهد شد و کسى آن را چاپ نخواهد کرد در حالى که در همين مقاله ترجمه شده موضوع بحث، چند شرکت خارجى را تبليغ کرده ايم.
در جاى خود روى اين موضوع و نوع نگاه مطبوعات ما به آن مى توان بحث کرد که اين نوع نگاه باعث چه تاثيرات منفى در برخى زواياى صنعت IT در ايران شده است.
يک موضوع جالب ديگر، فرض کنيد شما يک مقاله توليد کرده ايد، کدام سايت ايرانى را مى‌شناسيد که به راحتى اين سايت خارجى:
http://www.webpronews.com/submit.html بتوانيد مقاله خود را براى چاپ ارسال کنيد؟ همين سايت ITIran، در کدام قسمت آن مى‌توان مقاله ارسال کرد؟ کجاى اين وب سايت قوانين، مقررات و شرايط ارسال مقاله قابل مشاهده است؟

يک سؤال جالب مى‌پرسم. همين سايت ITIran، در حال حاضر پس از اين همه زحمت که دوستان خوب ما در اين سايت کشيده اند، صدها مقاله و خبر را در خود گنجانده است، ولى همين سايت براى پخش محتواى فارسى که در خود دارد چه ابزارى در اختيار کسانى که مى‌خواهند از اين اخبار و اطلاعات در سايت خود استفاده کنند قرار داده است؟ شما اين سايت را ببينيد که با چه روش ساده اى به همه اين امکان را مى‌دهد که از اطلاعات موجود در آن، در وب سايت خود استفاده کنند:
http://www.ientry.com/page/content/wpw_headlines.html
در مورد توليد محتوا، راستش را بخواهيد به نظر من آن قدر مهم است که دلم نمى‌خواهد بعد از آن کلمه فارسى اضافه کنم يعنى در جامعه IT ايرانى، مشکل توليد داريم نه مشکل زبان. وقتى مشکل توليد داريم يعنى اينکه هر چقدر هم که روى فارسى بودن آن تکيه کنيم، مشکلى حل نخواهد شد. يعنى مثلاً اگر چند نفر از متخصصان اين صنعت را در يک اتاق جمع کنيم و بخواهيم که فقط و فقط روى محتواى فارسى کار کنند، قادر به توليد آن نخواهند بود. يکى از آن چند نفر البته خود من هستم ! فرض کنيم همه اين چند نفر بگويند که توليد محتواى فارسى مشکل است چرا که بسيارى از اصطلاحات و کلمات مورد استفاده ما انگليسى (زبان اصلى) است و ما کلمات معادل آنها را در فارسى فعلاً نداريم. من مى‌گويم اشکالى ندارد، فارسى بودن محتوا مهم نيست ومحدوديت زبان را حذف کنم، شما چند درصد فکر مى‌کنيد که بتوانند محتواى انگليسى يا ترکى يا آلمانى توليد کنند؟ من در مورد اين درصد نظرى نمى‌دهم چون قصد تحميل اين نظرات را ندارم و البته اطلاعات آمارى قابل اتکاء هم ندارم ولى عددى که در ذهن من است بسيار کوچک است.
يادم است که در زمان تحصيل هم سخت ترين کلاس ها براى دوستان من، کلاس انشاء بود چون تنها کلاسى بود که روى توليد محتوا تکيه داشت. هرچند نمره انشاء من هميشه خوب بود ولى من هم از اين کلاس چندان دل خوشى نداشتم. پس شايد اصولاً ما ايرانى ها اين چنين بار آمده ايم و از همان ابتدا روى توليد محتوا مشکل داشتيم. (دقت کنيد که کم کم دارم کلمه فارسى را حذف مى کنم) ولى غافل از اين که خرج کردن پول نفت ممکن است ما را از توليد خيلى چيزها بى نياز کند ولى نه از توليد محتوا.
حالا که چندين سال است که براى جهانيان ثابت شده که داشتن اطلاعات يعنى داشتن قدرت و تمام موفقيت هاى تجارى مخصوصاً تجارت‌هاى روى خط وابسته به ميزان و دقت اطلاعات ما دارد، داريم چوب کم کارى‌هاى خودمان روى توليد محتوا و به دست آوردن تخصص و مهارت و از همه مهم تر علاقه توليد را مى‌خوريم. ولى اين مشکلى نيست که نتوان از عهده حل آن برآمد و قطعاً با صرف وقت و هزينه و پشتيبانى عوامل مختلف اجتماعى، سياسى و اقتصادى، اين موضوع سروسامان خواهد گرفت.
فقط يک موضوع کوچک به عنوان يک عضو کوچک از جامعه IT من را آزار مى‌دهد، به شما مى‌گويم تا خيال خودم راحت شود و آن اين است که اين جريان يعنى حمايت از توليد محتواى فارسى که باز من پيشنهاد مى‌کنم کلمه فارسى را از جلوى آن برداريم، به بيراهه نرود و وقت و هزينه‌هاى هنگفتى صرف زوائد و حواشى موضوع نشود و در آخر چيزى به دست نيايد يا چيز مفيدى بدست نيايد. شايد موضوع خيلى ساده تر از اين حرف ها باشد و شايد من زيادى نگران هستم، شايد اگر معلمان کلاس انشاء کمى بيشتر به اهميت آن توجه کنند، خيلى از مشکلات آتى ما در مورد توليد محتوا حل شود شايد هم من بيش از حد ساده انگارى مى‌کنم. به هر حال، اين موضوع نياز به عزم ايرانى دارد.
از کسانى که اين مقاله را چاپ مى‌کنند و کسانى که آن را مطالعه مى‌کنند متشکرم. چون تمام آن در داخل ايران توليد شده است، در مورد کيفيت آن، خودتان قضاوت کنيد. اگر هم پيشنهادهايى براى فارسى‌تر کردن آن داريد مثلا" جايگزينى کلمات با کلمات بهتر، براى من ارسال کنيد.

mahmoodb@sgnetway.com
www.mahmoodb.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:35 AM

January 13, 2005

سالى که نکوست از بهارش پيداست

نويسنده: آرش کريم بيگى

سالى که نکوست از بهارش پيداست

25 فروردين 1383 -

IranICTNews - قطعا شما هم جزو افرادى بوديد که بعد از تحويل سال نو سعى در برقرارى يک تماس تلفنى ساده و کوتاه با تلفن ثابت يا سيار دوستان و خويشانتان داشتيد يا يک کوته پيام (sms) آماده کرده بوديد تا براى دوستانتان ارسال کنيد و حلول سال نو را به آنها تبريک بگوييد و سال خوشى را برايشان آرزو کنيد اما بخاطر اختلالات عجيب شبکه تلفن ثابت و سيار کشور موفق به اين کار نشديد؟
در آغاز سال نو شبکه ارتباطى کشور بمعناى کلمه مقلب القلوب شده بود :

:: SMS ايرانى
مهندس رستمى مسئول SMSC شرکت مخابرات ايران در تاريخ ۲۷ اسفند ۸۲ (يعنى ۳روز مانده به تحويل سال نو) در مصاحبه اى با سرويس جامعه اطلاعاتى خبرگزارى ايسنا اظهار کرده: در ايام تعطيلات، بحران خاصى براى ارسال و دريافت پيام كوتاه پيش بينى نمى‌شود و نياز به تمهيدات خاصى در اين زمينه وجود ندارد اما در عمل درست از لحظه تحويل سال تا ساعت ۱۷:۴۵ همان روز تقريبا هيچ پيامى ارسال نميشد و از ساعت ۱۴ هر يک ساعت به يک ساعت چند پيام هم زمان دريافت ميشد و بعد از آن دوباره امکان ارسال پيام وجود نداشت !
نگارنده در ساعات ۱۲ - ۱۴ و ۱۶ امکان ارسال پيام را مورد آزمون قرار داده که در هر آزمون ۲۰ بار تلاش براى ارسال پيام انجام شده که در دونوبت اول هيچ پيامى ارسال نشد و تنها در نوبت آخر در آخرين تلاش ها تنها يک پيام ارسال شد که بعد از ارسال پيام عدم موفقيت دريافت از طرف مخاطب روى صفحه تلفن ظاهر شد !‌ اين درحالى است که روابط عمومى شرکت مخابرات در تاريخ ۱۸/۱/۸۳ اطلاعيه اى صادر کرده و ادعا کرده طى دو هفته‌ نخست سال تعداد ‌٢٧ ميليون و ‌٥٨٤ هزار و ‌٥١٨ پيام، توسط سرويس پيام كوتاه ارسال شده، كه از اين تعداد در هر روز حداكثر ‌٤٨/٩٧ و حداقل ‌٢٤/٩٧ درصد از پيام‌هاى ارسالى با موفقيت دريافت شده‌اند !!!
رقم بالاى ارسال موفقيت آميز ۲۷ ميليون و ‌٥٨٤ هزار و ‌٥١٨ پيام در دوهفته نخست سال و تقاضاى فعال سازى سرويس براى هزار و ‌٩٤٧ مشترك نشان دهنده اقبال و نفوذ سرويس کوته پيام در ميان مشترکين تلفن همراه کشور ميباشد. طبق آمار شرکت مخابرات تاکنون ‌٩٢٧ هزار و ‌٧٢٩ مشترك کوته پيام مخابرات شده اند.

:: موبايل ايرانى
اصولا موبايل در اين مملکت يک شى اضافى يا حداکثر لوکس و ناکارآمد بحساب ميآيد ! در روز اول سال نو تقريبا امکان نداشت شما بتوانيد يک تماس ساده را با موبايل يک ميليون تومانى خود برقرار کنيد (حتى اگر خداى نکرده شبکه به شما اجازه دخول هم ميداد مشترک مورد نظر در دسترس نبود يا حداکثر تمام مسير ها بسمتش اشغال بودند) تا اينجا را داشته باشيد تا در مورد اماکن تفريحى و توريستى اى که هر ساله ملت براى تفريح و گذراندن تعطيلات به آنجا ميروند صحبت کنم ! استانهاى گيلان و مازندران بلاشک جزو اولين و بهترين انتخابهاى ملت خوشگذران ايران براى گذراندن تعطيلات هستند ! مسلما عده اى از مردم حق دارند چند روز تعطيلى خود را در کنار سواحل درياى بى رژيم حقوقى خزر سرکنند ! دو ميليون نفر از اين عده استان مازندران را انتخاب کردند تا اينجا همه چيز عادى بنظر ميرسد اما فاجعه آنجاى شروع ميشود که تقريبا تمام اين افراد يک گوشى کوچک تلفن در جيب خود دارد که توقع سرويس دهى دارد اما دريغ از آنتن و سرويس !‌ ۵۰ درصد گوشى ها که اصلا بدلايلى شبکه نداشتند (آنتن بود و شبکه محترم پذيراى اين حجم ترافيک نبود) و آن ۵۰ درصدى هم که شبکه داشتند بهيچ وجه قادر به شماره گيرى يا ارسال و دريافت کوته پيام نبودند ! يکى از مديران لايق مخابرات هم بعد از تعطيلاف فرمودند که سالى ۱۰ روز ترافيک شبکه استان بچنين وضعى پيدا ميکند و از نظر اقتصادى نيازى به بالا بردن امکانات شبکه در استان نيست چرا که در روزهاى ديگر سال شبکه با ضريب موفقيت تماس بالايى مشغول سرويس دهيست واقعا که ما عجب ملت متوقعى داريم براى موبايل ۶۹ دلارى يک ميليون تومان پول ميدهند و توقع سرويس قابل قبول هم دارند !!!

:: تلفن ايرانى
در سه روز اول سال جارى برقرارى ارتباط تلفنى با شهرستان يا خارج از کشور تقريبا غير ممکن بود ! کافى بود گوشى تلفن را برداريد و رقم صفر را شماره گيرى کنيد بلادرنگ بوق اشغال يا سوت گوش خراشى بگوش ميرسيد در معدود مکالمات بين المللى برقرار شده هم کيفيت پايين صوت و مکث و کشيده شدن و تغيير کيفيت صوت ناخودآگاه شما را به اين فکر مى انداخت که شايد خداى نکرده شرکت مخابرات هم ارتباطات بين الملل را از طريق فن آورى VOIP برقرار ميکند !!! گو اينکه کيفيت صوت و ضريب موفقيت تماس هاى بين المللى در همان زمان با استفاده از کارت هاى تلفن اينترنتى موجود در بازار بمراتب بهتر و ارزان تر از سرويس ارائه شده توسط شرکت مخابرات بود ! شاهکار مخابرات ايرانى به همين جا ختم نميشود : در بعضى از مراکز تلفنى کلان شهر تهران بعد از برداشت گوشى با چند ثانيه مکث صداى بوق آزاد بگوش ميرسيد يا حتى از آن بدتر بوق اشغال زده ميشد !!! مهندس احمد نظر پور مديركل پشتيبانى و فنى شركت مخابرات استان تهران در اين باره به خبرنگار سرويس فن آورى اطلاعات ايسنا با خونسردى پاسخ داده : طبق استانداردهاى جهانى هيچ گاه تمامى مشتركان تلفن نمى‌توانند به صورت همزمان، بوق آزاد در اختيار داشته باشند و در ترافيك‌هاى سنگين و موارد بحرانى، تعريف‌هاى خاصى براى مراكز تلفن در نظر گرفته مى‌شود ايشان در پايان مصاحبه خود فرمودند با گذشت زمان اين قضيه حالت طبيعى پيدا مى‌كند و شهروندان متوجه مى‌شوند كه در موارد خاص مانند اول سال نو، نمى‌توانند به صورت همزمان از سرويس‌هاى شركت مخابرات استفاده كنند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:35 AM

January 13, 2005

وب هاستينگ اختصاصى يا اشتراکى؟

نويسنده: سعيد درويش پازوکى

وب هاستينگ اختصاصى يا اشتراکى؟

25 فروردين 1383 -

ITbUZZER - شرکت ارائه کننده خدمات وب هاستينگ شما ميتواند متناسب با نوع خدماتى که ارائه ميکند و سطح مسئوليت پذيرى بهترين دوست و يا بدترين دشمن شما باشد! يک وب سايت موفق وابستگى شديدى به نوع خدمات وب هاستينگ آن دارد و اين مساله بسيار مهم است که شما بتوانيد متناسب با نوع فعاليت و هدف مورد نظر سرويس مناسبى را براى حضور بر روى اينترنت انتخاب کنيد.
مهمترين نکته اين است که آيا نياز و انتظار شما را يک سرويس وب هاستينگ که در آن وب سايتهاى مختلفى همراه وب سايت شما بصورت مشترک از يک سرور استفاده ميکنند پوشش ميدهد و يا حتماً نياز است که از يک سرويس وب هاستينگ اختصاصى استفاده کنيد؟ قبلا از هر کارى ابتدا به اين پرسش پاسخ دهيد.

آدرس اختصاصى و اشتراکى
هر سرورى که به اينترنت متصل است داراى يک IP منحصر به فرد است. اين عدد منحصر به فرد شناسه اى است که براى دسترسى به سرويسهاى موجود بر روى آن سرور در اينترنت از آن استفاده ميشود. هيچ دو سرورى در اينترنت نميتوانند IP يکسانى داشته باشند ولى يک سرور ميتواند با يک IP چندين سرويس به مشترکين ارائه کند بدين معنى که هم ميتواند بعنوان يک سرويس دهند Email و هم سرويس دهنده Web عمل نمايد. اين آدرس با يک نام دامنه (Domain Name) نيز شناخته ميشود و براى دسترسى به آن سرور هم ميتوان از IP آن و هم نام دامنه استفاده نمود. با اين کار کاربر ميتواند براى دسترسى به محتويات وب سايت مورد نظرش درون مرورگر خود نام دامنه يا IP سرور را وارد کند. در هاستينگ اشتراکى وب سايت شما همراه با چندين وب سايت ديگر بر روى يک سرور قرار دارند و سرور از روى نام دامنه قادر به تشخيص وب سايت مورد نظر بازديد کننده ميباشد ولى در هاستينگ اختصاصى تنها وب سايت شماست که بر روى سرور قرار دارد و IP سرور شما با هيچ وب سايت ديگرى به اشتراک گذاشته نميشود.
بسيارى از سايتهاى کوچک و متوسط از نوعى از سرويس هاستينگ استفاده ميکنند که به آن "Virtual Hosting" گفته ميشود (همان هاستينگ اشتراکى) و در اين نوع هاستينگ چندين وب سايت مشترکاً بر روى يک سرور قرار دارند و چون از يک سرور مشترک استفاده ميکنند بنابراين از يک IP مشترک نيز برخورداند.
وب سايتهاى بزرگ و آنهايى که نياز به سرويسى بسيار پايدار و هميشه قابل دسترس بدون کوچکترين ريسکى را دارند نميتوانند از يک سرور اشتراکى استفاده کنند چراکه حجم ترافيک سرازير شده از سوى چندين وب سايت خيلى سريع سرور را گرفتار خود ميکند. اين گونه وب سايتها نياز به يک سرويس هاستينگ اختصاصى دارند و بسيارى از شرکت هاى ارائه کننده خدمات اينترنتى گزينه ها و تعرفه هاى جداگانه اى براى خدمات اختصاصى خود دارند. کدام يک از اين سرويسها مناسب شماست؟ بگذاريد نگاهى به معايب و مزاياى هر يک داشته باشيم.

sdpazoki@itbuzzer.net

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:38 AM

January 13, 2005

روزنامه نگارى اينترنتى ،بيم ها و اميدها

نويسنده: سيداحمد لواسانى

روزنامه نگارى اينترنتى ،بيم ها و اميدها

2 ارديبهشت 1383 -

روزنامه ايران - مقدمه: سايت ojr.org گزارش مى دهد كه در تحقيق گسترده و جامعى كه در شروع هزاره جديد در مورد وضعيت روزنامه نگارى در آمريكا انجام شده است مشخص شده كه يكى از نقطه هاى روشن اين حرفه حضور در اينترنت واستفاده از آن است. ولى اين مطالعه نشان مى دهد كه آينده اين رشته در اينترنت تهديدهايى نيز دارد: سود كم، وابستگى به محتوياتى كه در رسانه هاى ديگر توليد مى شود و عدم مشخص شدن اين نكته كه بالاخره خوانندگان نيز بايد به توليد محتوا كمك كنند يا نه.
اين گزارش پانصد صفحه اى كه توسط دانشكده روزنامه نگار ى دانشگاه كلمبيا تهيه شده است از بررسى محتويات مقالات، مخاطبين، صاحبان، وضعيت اقتصادى و ميزان سرمايه گذارى در هشت رسانه خبرى روزنامه ها ، مجلات، اينترنت، راديو، شبكه هاى تلويزيونى ملى، شبكه هاى تلويزيونى كابلى و شبكه هاى تلويزيونى محلى به دست آمده است.اين گزارش به خوبى مى تواند نمايى از وضعيت روزنامه نگارى نوين در آمريكا را به تصوير بكشد.
مدير اين پروژه عقيده دارد كه اين گزارش نشان مى دهد در جايى كه ما در سال ۲۰۰۴ در آن ايستاده ايم، روزنامه نگارى در حال گذار از يك دوره مهم تاريخى است، دوره اى كه احتمالاً به اندازه اختراع تلگراف يا تلفن مهم خواهد بود.
اين مطالعه نمايى نگران كننده از كاهش ميزان جذب مخاطبين توسط تمام رسانه ها به جز راديو و اينترنت نشان مى دهد. در اين ميان اينترنت بيشترين موفقيت را در جذب جوانان به اخبار دارد. اين در حالى است كه رسانه هاى قديمى تر حتى قبل از ظهور اينترنت نيز در جذب اين عده از مخاطبين مشكل داشته اند.
بر اين اساس اين نكته كه رسانه ها چه ميزان مى بايست روى ارائه مطالب اينترنتى خود سرمايه گذارى كنند بسته به فرهنگ، افق و جرأت مديران آن رسانه دارد.
آيا اينترنت تهديدى براى ديگر رسانه ها است؟

متن کامل مقاله را در سايت روزنامه ايران بخوانيد

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:39 AM

January 13, 2005

هزارتوى مناقصه هاى شرکت مخابرات

نويسنده: محمد حسن رشيدى

هزارتوى مناقصه هاى شرکت مخابرات

28 فروردين 1383 -

بخش مقاله آى تى ايران - ، چون در شرايط و اسناد مناقصه هاى بعض از سازمانها و شركت ها ، خصوصاً شركت مخابرات ايران نكات و موارد متضاد با شرايط زمان و مخالف سير تحولات جهانى وجود دارد ، بنده را بر اين داشت كه چند سطرى در اين باره بنويسم :

مدتى است كه شعار ها و ادعاهاى بسيارى بشرح ذيل رايج گرديده :
- فن آورى اطلاعات و ارتباطات محور توسعه اقتصادى ، امحمد حسن رشيدى
ACT@mail.dci.co.ir

هزارتوى مناقصه هاى شرکت مخابرات
بخش مقاله آى تى ايران - ، چون در شرايط و اسناد مناقصه هاى بعض از سازمانها و شركت ها ، خصوصاً شركت مخابرات ايران نكات و موارد متضاد با شرايط زمان و مخالف سير تحولات جهانى وجود دارد ، بنده را بر اين داشت كه چند سطرى در اين باره بنويسم :

مدتى است كه شعار ها و ادعاهاى بسيارى بشرح ذيل رايج گرديده :

- فن آورى اطلاعات و ارتباطات محور توسعه اقتصادى ، اجتماعى و فرهنگى عصر حاضر مى باشد .
- به اثبات رسيده است كه ارتباط اقتصادى دانش محور مرتبط با صنعت تكنولوژى پيشرفته مانند ارتباطات ، سرويس هاى مالى الكترونيك و تجارت الكترونيكى است .
- ICT موتور محركه اقتصاد دانش محور است .
- تجارت الكترونيكى گام اول فرهنگ سازى جامعه بسمت اقتصاد دانش محور است .
- تو سعه و بكار گيرى ICT چشم انداز جهانى شدن و رقابت جدى در امور اقتصاد ى است .
- اينكه برنامه چهارم توسعه كشور با شعار دانايى محور آغاز مى گردد .

و نيز با توجه به تغيير نام وزارت پست و تلگراف و تلفن به وزارت ارتباطات و فن آورى اطلاعات كه بالطبع تغيير ساختار ، شرح وظيفه ، تعاريف و گسترش حيطه مسئوليت و قبول وظايف بيشتر در پى داشته و براى اين تغيير و تحول كه از قبل مطالعه و تحقيق و بررسى شده اگر بصورت عينى و عملى در زير مجموعه اين وزارت منجمله شركت مخابرات ايران صورت نپذيرد ، مطمئناً نتيجه منطقى و پيش بينى شده حاصل نمى شود و كما فى السابق در حد شعار باقى مانده و معضلاتى در پى خواهد داشت و در بهترين شرايط مى بايد مسير رشد و بالندگى را با حركت لاك پشتى طى نمود .

موضوع قابل طرح : مناقصه شماره 82/147 موضوع 7قلم و به تعداد 139 دستگاه اندازه گيرى فيبر نورى است كه مهلت ارائه پاكات 26.01.83 مى باشد .

1) برابر بند 10-1 از مشخصات فنى ، پيشنهاد دهنده را ملزم به ارائه نمونه براى هر آيتم بمنظور چك نمودن مشخصات فنى مى نمايد .

سئوال اين است كه :
- اين شرط با صرف نظر از آنچه در باب تجارت الكترونيكى شنيده و ديده ايم ، آيا هيچ سنخيت و تعاملى با شيوه تجارى معمول و مرسوم جهان دارد ؟
- مسلماً تعدادى شركت در اين مناقصه حضور خواهند داشت و اگر قيمت متوسط هر دستگاه از هر آيتم بطور متوسط 8000 دلار در نظر گرفته ( 7 x 8000 = US$56,000 ) و صرفنظر از ديگر هزينه ها مانند بيمه ، حمل و نقل و مهمتر از همه وقت مصروفه و نيز سپرده شركت در مناقصه بمبلغ 24,500 دلار براى 7 قلم . به چه دليل منطقى مى بايد يك شركت آنهم در زمان حاضر متحمل چنين هزينه گزاف و بيموردى براى حضور در يك مناقصه گردد ؟
- از جمع حاضرين در مناقصه ، يك شركت برنده مناقصه خواهد بود .
بقيه شركت ها براى بازگرداندن دستگاهها چه بايد انجام دهند ؟
شركت هاى مطرح جهان و صاحب تكنولوژى دستگاههاى اندازه گيرى به دليل مسئله حصر اقتصادى قادر به حضور مستقيم در مناقصه ها نيستند چه رسد به ارسال نمونه ! آنهم 7 دستگاه ! آنهم آخرين تكنولوژى ! و….
بديهى است كه شركت هاى واسطه مى بايد متحمل چنين هزينه هايى گردند .
- شركت هايى مانند Tektornix ، Agilent ، Nettest و امثالهم اولاً اينگونه دستگاهها را براى كشور خاصى توليد ندارند و نيز مشخصات فنى قرار داده شده بر روى سايت هاى اينترنتى آنان به تفكيك كشور و تنوع كيفيت نبوده و نيست .
- وقتى تاييديه بند به بند مشخصا فنى به همراه بروشور و كاتالوگ كه تمامى صفحات آنها مهر و امضاء مى گردد ، بانضمام سپرده شركت در مناقصه و پس از برنده شدن ، ضمانت نامه 10% حسن انجام كار ، قرارداد بلند بالاى يكطرفه ، بازرسى بين المللى ، بازرسى قبل از حمل توسط كارشناسان اعزامى و النهايه بازبينى كالا در انبار انجام مى گيرد ، ديگر چه نيازى به نمونه براى اثبات مدعا مى تواند باشد ؟!
مگر اينكه كارشناسان و مسئولان ذيربط در اين گونه مناقصه ها بعلت نداشتن اطلاعات لازم علمى و فنى چون قادر به تشخيص و تطبيق مشخصات ارائه شده با خواسته خويش را ندارند ، ديگران را مجبور به ارائه نمونه براى هر آيتم مى نمايند !!!
البته بندها و تبصره هاى ديگرى در شرايط و مشخصات فنى مناقصه ها وجود دارد كه با قوطى هيچ عطارى جور در نمى آيد .

2) برابر بند 9-1 مناقصه مذكور در بخش انگليسى درخواست 10 سال پشتيبانى پس از حمل و در بخش فارسى 15 سال پشتيبانى پس از دوره گارانتى ( 16/5 سال پس از حمل ) دارند .
- اگر اين زحمت را بخود دهند و از چند سايت معتبر بازديد داشته باشند ، متوجه خواهند شد كه تعهدات پشتيبانى سخت افزارى اعلام شده براى بعض از اقلام 5 سال و براى بعض ديگر 7 سال درج گرديده و با زحمت بسيار مى توان از شركت هاى معتبر تعهد 10 سال خدمات پشتيبانى ( عملى و واقعى نه ظاهرى و صورى ) پس از آخرين حمل را دريافت داشت .
اعتقاد مديران اين شركت ها بر اين است كه بعلت رشد تكنولوژى : تغيير ، تنوع ، ارتقاء سطح كيفى ، توقعات و انتظارات و ….
توليد اين دستگاهها پس از چند سال يا به روز شده يا از خط توليد خارج و نسل جديدى جايگزين مى گردد . و تا زمانيكه مجبور نشده ايم توليد ادامه و سرويس پشتيبانى بدون مشكلى ارائه خواهد شد .

3) نكته قابل ذكر ديگر : در مقايسه با ديگر كشور ها از جمله كشور هاى حاشيه خليج فارس كه متن قرارداد اينگونه مناقصه ها در حد چند صفحه و بسيار مختصر و مفيد و مشخصات فنى بصورت كامل و دقيق و مشروح .
اما در كشور ما پيش نويس قرارداد فارسى و انگليسى بين 60 تا 100 صفحه با خط و نشان هاى آنچنانى ، داراى سرفصل ها و بندهاى بى ربط به موضوع مناقصه ، يكطرفه و بعبارتى قرارداد تركمان چاى و مشخصات فنى كه غالباً كپى ناخوانا ، ناقص و … مى باشد .

4) موضوعات ديگر مانند آموزش ، تعميرات ، كاليبراسيون ، تطويل زمان ، تمديد و تجديد ، ابطال مناقصه پس از چندين ماه و بعضاً دو سال و اندى ، تلاش براى عضويت در تجارت جهانى اما نپذيرفتن ضمانت نامه از بانك هاى معتبر كشور ها و التزام به ارائه آن فقط از طريق يكى از بانكهاى ايرانى و … كه هر يك نياز به بررسى جداگانه و تجديد نظر اساسى دارند و شرح آنها در اين مقال نمى گنجد .

بگذاريم و بگذريم ، اميد است گوش شنوا و دل بيدارى پيدا شود و اصرار بيهوده بر شيوه هاى سنتى و منسوخ شده در امر تجارت در كشور ما هم پايان پذيرد و زمان عمل به شعارهاى پر رنگ و لعاب فرا برسد . انشاء ا… .
با احترام وتشكر
*مدير عامل شر كت ارتباطى تجارى آراد آسيا

ACT@mail.dci.co.ir

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:40 AM

January 13, 2005

مسئولان جرايم رايانه اى اين مقاله را بخوانند!

نويسنده: على رشيدى

مسئولان جرايم رايانه اى اين مقاله را بخوانند!

10 ارديبهشت 1383 -

بخش مقاله آى تى ايران - من يک داستان دارم شايد شما هم بدردتون بخوره .
موضوع از جايى شروع شد که يک بنده خدايى اومد يک سايت معتبر رو به اسم سايت من هک کرد . منم خواستم شکايت کنم که اگر اون سايت ( که عربى بود ) شکايتى کرد از من بتونم جلوى بسته شدن دومين خودم رو بگيرم . زنگ زدم 110
گفتم: آقا چرايم اينترنتى لطفا .
اينجورى جواد داده شد : جرايم اينترنتى چى هست ؟ .
گفتم : آقا در مورد کامپيوتر هست .
جواب داد : با مرکز پليس کرمان تماس بگيريد اونا جواب ميدن .
زنگ زدم اونجا بعد از دست به دست شدن تلفن خلاصه يکى گوشى رو برداشت
گفتم آقا من يک شکايت اينترنتى داشتم
جواب داده شد که : ما مامور ميفرستيم که پيگيرى کنن . آدرس و تلفن رو گرفتن مامور ها هم اومدن
يک گروه بان و 2 تا سرباز بيسيم به دست اومد جولو گفت آقا چى شده ؟ گفتم مشکل اينه اينه اينه . توضيح دادم گفت آقا اينو ما نميتونيم کارى کنيم تشريف بياريد کلانترى 13 . رفتم کلانترى 13 اونجا صحبت کردم گفتن آقا شما اينجا اومدى چيکار بورو دادکسترى شکايت بنويس ما در خدمتيم . منم که تا بحال ازين کارا نکرده بودم رفتم و شکايتى نوشتم و دادم دست قاضى محترم
قاضى گفت : جوان از کى شاکى هستى
جريان رو تعريف کردم شکايت نامه رو هم دادم بهش .
گفت حالا من چيکار کنم
گفتم نميدونم تاحالا ازين کارا نکردم
گفت ما هم نکرديم ولى بيا اينم امضا بورو کلانترى بده اونا پيگيرى ميکنن برات
تشکر کردم و رفتم کلانترى . اونجا به دليل اشتباه رئيس کلانترى منو پاس دادن به کلانترى 17 . همش واسه 200 متر جابه جايى يک اسم !!
دوباره برگشتم چريان رو تعريف کردم اونا اينجورى جواب دادن به من
شما بورو آدرس خونه طرف رو گير بيار ما ميگيريمش !!!
گفتم آقاى محترم اون شخص تهران هست اصلا ربطى به کرمان نداره . جواب دادن که ما نميتونيم کارى بکنيم .
گفتم آقا من يه سوال داشتم
گفت بفرما
گفتم آقا اگه کسى قتل هم انجام بده همين جورى با شاکى صحبت ميکنيد .
جواب دادن که اون قتل هست مربوط نيست به اين موضوع .
منم از اونجا که قانونى نوشته نشده بود ولى نوشته هاى آى تى ايران رو خونده بودم در مورد پيش نويس جرايم . جرم رو ميدونستم که جعل کامپيوترى هست و بين 2 تا 10 سال مثل اينکه در پيش نويس تعيين شده بود . تا اونجا شد که گفتم آقا کار اين شخص بين 2 تا 10 سال زندان داره .
گفت که شما آدرس رو بده . من آدرس سايت اين شخص رو داده بودم ولى مثل اينکه برادران ما موضوع رو نميگرفتن که از روى آدرس سايت هم ميشه آدرس خونه شخص رو پيدا کرد .
به هر حال من که بيخيال شدم . فقط اين نامه رو مينويسم براى کسانى که مثل من دلشون رو به حرف هاى برادران ارجمند ما خوش کردن که جرايم کامپوترى خوش کردن . اگه برنامه اى مينويسى حتما روش قفل بزار چون کسى جواب شما رو نميده اگه کپى شد . اگه سايت باز ميکنى بستنش ساکت شو بشين کنج خونه حرف هم نزن چون آدرس خونه طرف رو نميدونى و ....
اميد وارم آقاى پرويزى شخص پنهان جرايم اينترنتى اينا يى که ميگم رو بخونه . به هر حال اگر شما اين متن رو در سايت آى تى ايران قرار نميديد اگر با اين آقا ميتونيد صحبتى داشته باشيد بگيد افرادى هستن که اينجورى حقشون داره ضايع ميشه و شما کارى نميکنيد .

ali_hacker2000@yahoo.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:40 AM

January 13, 2005

درخواست بانك‌ها روى ميز مديران شتاب

نويسنده: مهدى عليا

درخواست بانك‌ها روى ميز مديران شتاب

8 ارديبهشت 1383 -

اقتصادى بلاگ - شنبه هفته جارى را مى‌توانستيم روز مهم و سرنوشت‌سازى براى بانكدارى الكترونيكى و به ويژه گسترش طرح شتاب بناميم. اما چنين نشد، باز هم انجام كارى براساس برنامه‌ريزى پيش نرفت وعده‌ها عملى نشد. مشتريان كه پس از مدت‌ها آگاهى از پيوستن بزرگترين بانك تجارى كشور به طرح شتاب روز خوبى را براى فعاليت‌هاى بانكى خود متصور بودند اين روز را به خوبى سپرى نكردند چه دستگاه‌هاى خودپرداز بانك ملى خدمات بانكى به دارندگان كارت‌هاى الكترونيكى 4 بانك ديگر عضو شتاب خدمات ارايه نمى‌داد و مشتريان از اين دستگاه‌ها دست خالى بازگشتند. با اينحال يك مقام آگاه بانكى خبر داد بانك ملى هنوز به طور كامل و عملى به طرح شتاب نپيوسته است!

سابقه بانكدارى الكترونيكى
اواخر دهه 1360 بانك‌هاى كشور با توجه به كاربرد كامپيوترهاى شخصى و احساس نياز به اتوماسيون عمليات بانكى كوشيدند به رايانه‌اى كردن عمليات بانكى بپردزاند. در سال 1372 طرح جامع اتوماسيون بانكى پس از مطالعات و بررسى‌ها در قالب پيشنهادى براى حركت جهت جامع‌نگرى در برنامه‌ريزى فعاليت‌هاى انفورماتيكى بانك‌ها به مسوولين شبكه‌ بانكى ارايه شد كه با مصوبه مجمع عمومى بانك‌ها در سال 72، طرح جامع اتوماسيون سيستم بانكى شكلى رسمى به خود گرفت. اجرا و پيشبرد اين طرح بر اساس مصوبه مجمع عمومى بانك‌ها به عهده مشاور اجرايى بانك مركزى گذاشته شد كه بانك مركزى در همان سال شركت خدمات انفورماتيك را به عنوان سازمان اجرايى بانك مركزى گذاشته شد كه بانك مركزى در همان سال شركت خدمات انفورماتيك را به عنوان سازمان اجرايى طرح جامع اتوماسيون سيستم بانكى تاسيس كرد. وظيفه شركت خدمات انفورماتيك براساس دستورالعمل‌هاى بانك مركزى فراهم آوردن امكانات لازم براى تهيه طرح جامع و برنامه‌ريزى براى پياده‌سازى اتوماسيون شبكه بانكى كشور بود.
طى سال‌هاى 72 و 73 جرقه‌هاى ايجاد سوئيچ ملى جهت بانك‌دارى الكترونيكى زده شد زمانى كه شبكه ارتباطى بين بانك ملى و فروشگاه‌هاى شهروند ايجاد شد وافرادى كه كارت بانك‌ ملى را داشتند مى‌توانستند از خدمات فروشگاه‌هاى شهروند استفاده كنند.
تا سال‌هاى 79 و 80 همچنان شركت خدمات انفورماتيك به عنوان شركت انحصارى و يكه‌تاز در عرصه فراهم كردن زيرساخت‌هاى بانكدارى الكترونيكى به شمار مى‌رفت. تا اينكه رييس كل سابق بانك مركزى تصميم گرفت با تاسيس اداره‌اى خاص در ساختار بانك مركزى، اين وظيفه را از شركت خدمات انفورماتيك سلب كند. مرحوم نوربخش در بيستم خرداد 1381 مجموعه مقررات حاكم بر مركز شبكه تبادل اطلاعات بين بانكى موسوم به شتاب را به تصويب رساند و بدين سان اداره شتاب بانك مركزى در اول تيرماه 81 تاسيس و با هدف فراهم كردن زيرساخت بانكدارى الكترونيكى آغاز به كار كرد.
كليه سخت‌افزارها و نرم‌افزارها در 13 مرداد ماه 81 در اختيار اداره شتاب بانك مركزى قرار مى‌گيرد واز شركت‌ خدمات انفورماتيك و شركت ملى انفورماتيك سلب مسووليت مى‌شود.
شركت خدمات انفورماتيك با مشكلات و مسايل حاشيه‌اى بسيار مواجه شد و نتوانست در فراهم كردن زيرساخت‌هاى بانكدارى الكترونيكى به توفيق شايانى دست يابد.
بنابراين از تابستان 1381 اداره شتاب بانك مركزى عهده‌دار فراهم ساختن زيرساخت‌هاى بانكدراى الكترونيكى شد و طرح شبكه تبادل اطلاعات بين بانكى متولد شد.

شتاب مرحوم نوربخش
مرحوم نوربخش رييس كل سابق بانك مركزى به جرات قدرتمندترين و بانفوذترين رييس كل بانك مركزى در طول تاريخ جمهورى اسلامى بوده است. برخورد شركت خدمات انفورماتيك با برخى مشكلات در فراهم ساختن زيرساخت‌هاى بانكدارى الكترونيكى او را به اين ايده رساند كه بانك مركزى دخالت بيشترى در اين زمينه داشته باشد و اداره شتاب بانك مركزى را تاسيس كرد. البته بايد به يك نكته ديگر نيز اشاره كرد. زمانى كه بانك مركزى متوجه شد بانك‌ها تمايلى به برقرارى ارتباطات بين بانكى ندارند، دخالت بيشترى در اين زمينه كرد تا جايى كه طرحى را در شوراى عالى بانك‌ها به تصويب رساند كه براساس آن كليه بانك‌هاى كشور ملزم به پيوستن به شبكه شتاب شدند و همگان مى‌دانستند كه نوربخش بر عقيده و طرح‌هايش استوار و در اجراى آن توسط بانك‌ها مصر بود.
آزمايشات اوليه شبكه تبادل اطلاعات بين بانكى با 3 بانك دولتى آغاز شد. دو بانك تخصصى كشاورزى و توسعه صادرات و يك بانك تجارى صادرات ايران در پايلوت اوليه اين طرح حضور داشتند. دو بانك خصوصى سامان و كارآفرين در همان سال‌هاى اول آغاز به كارشان درخواست كردند كه در آزمايش‌هاى اوليه شتاب حضور داشته باشند اما شتاب با ايجاد ارتباط بين دستگاه‌هاى خودپرداز ATM سه بانك رسماً متولد شد.
بانك مركزى با هدف ايجاد سوئيچ ملى به عنوان زيرساخت بانكدارى الكترونيكى و برقرارى ارتباط بين بانك‌ها و طرح شتاب را به پيش برد. مسوولان شتاب اين طرح را در دو فاز طراحى كرده بودند كه در مرحله اول مى‌بايست شتاب به ايجاد ارتباط براى ارايه خدمات يكسان كارت‌هاى بانكى الكترونيكى (كارتى‌هاى Debit و Credit) بپردازد و در فاز بعدى كليه ارتباط بين بانكى و Transaction بين بانكى را پوشش دهد.
بر اين اساس 4 كميته هماهنگى شتاب، تبليغات شتاب، تشكيلات شتاب و تسويه شتاب تاسيس شد نتيجه حاصله از اين كميته‌ها در قالب طرح و ايجاد تغييرات ساختارى يك برنامه براى پيوستن شتاب ظهور يافت و روش‌ها، سازمان‌ها و ابزارها براى اتصال يك بانك به شتاب طراحى و معرفى شد. آزمايش‌هاى اوليه شتاب به خوبى پيش‌ رفت و با ايجاد اتصال بين دستگاه‌هاى خودپرداز ATM و پايانه‌هاى فروش POS سه بانك اوليه عضو شتاب، داردندگان كارت‌هاى الكترونيكى يك بانك عضو شتاب مى‌توانستند از دستگاه‌هاى دو بانك ديگر استفاده كنند. در زمستان 82 بانك خصوصى سامان نيز به طرح شتاب پيوست و بانك‌هاى عضو شتاب به عدد 4 رسيد.

بانك‌هاى بزرگ جلو نيامدند
با وجود الزام بانك‌ها براى پيوستن به شتاب و تلاش براى ايجاد زيرساخت‌هاى بانكدارى الكترونيكى از سال 72 با طرح جامع اتوماسيون و در 2 سال اخير با طرح شتاب، چرا بانك‌هاى بزرگ كشور از اين طرح‌ها استقبال نكرده‌اند؟
پاسخ به اين پرسش را بايد از چند زاويه نگريست. نكته اول اين است كه متوليان شكبه بانكى تا به امروز نتوانسته‌اند طرح جامع، عملى و زيربنايى در جهت پياده‌سازى بانكدارى الكترونيكى در كشور ارايه كنند.
هر بانكى به طور مستقيم طرح‌هاى بانكدارى الكترونيكى خود را پيش برده و مى‌برد. بانك ملى با طرح سيبا، بانك تجارت با طرح SGB، بانك صادرات با طرح سپهر، بانك رفاه با طرح جارى همراه، بانك كشاروزى با طرح مهر، بانك ملت با طرح جام و بانك‌هاى خصوصى با طرح‌هاى بانكدارى 24 ساعته به صورت مجزا و منفرد، بانكدارى الكترونيكى را در حوزه تحت پوشش خود تجربه كرده و مى‌كنند. دوم اينكه با آغاز به كار شتاب در 3 بانك دولتى، ساير بانك‌ها منتظر بودند تا نتيجه كار را ببينند.
نكته سوم ايجاد مشكلات در زمينه‌هاى سخت‌افزارى و نرم‌افزارى بود. بانك‌ها هركدام مجزا اقدام به تهيه سخت‌افزار‌ها و نرم‌افزارهاى خاسى براى بانكدارى الكترونيكى كرده بودند و زمانى كه بحث شبكه واحدى براى برقرارى ارتباطات بين بانكى مطرح شد، مديريت بانك‌ها را متاثر از اين تفكر كه بايد سخت‌افزارها و نرم‌افزارهاى خريده شده قبلى را به دور بياندازند و سخت‌افزارهاى طرح جديد را خريدارى كنند در پيوستن به طرح جديد به ترديد انداخت.
نكته چهارم اينكه مديران شبكه بانكى با عنايت به خاستگاه علمى و مديريتى و فعاليت متمادى در ساختارهاى بانكدارى سنتى ايران روش‌‌هاى بانكدارى سنتى را مى‌پسنديد و از طرح‌هاى بانكدراى الكترونيكى خيلى استقبال نكردند به عبارتى ديگر مديران معتقد به بانكدارى سنتى در ايران علاقه‌اى به بانكدارى الكترونيكى و كاهش شعب بانكى ندارند. چه با اجراى بانكدارى الكترونيكى، شعب بانك‌ها كاهش مى‌يافت و اين متضاد با علاقه‌ها و ساختارهاى مديريتى مديران شبكه بانكى بود. نكته پنجم را مى‌توان مشكلات ساختارى بانك‌ها و هزينه براى استاندارهاى جديد برشمرد. كاربرد سخت‌افزارها و نرم‌افزارها براى پياده‌سازى بانكدارى الكترونيكى هزينه‌هاى بسيارى بر مديريت بانك ها باز مى‌كرد كه آنان را به ترديد وامى‌داشت.
نكته ششم اينكه بانك‌هاى بزرگ كشورمعتقدند پيوستن به طرح مشتركى به عنوان طرح شتاب با ساير بانك‌ها به نفع بانك‌هاى خصوصى و كوچك است. چراكه اين بانك‌ها با داشتن شعب اندك مى‌توانستد از اميتازات و خدمات شعب فراوان و گسترده بانك‌هاى بزرگ براى خدمات‌رسانى به مشتريان خود استفاده كنند. بر اين اساس شعب گسترده بانك‌هاى دولتى و بزرگ كشور به عنوان شعب بانك‌هاى خصوصى و كوچك نيز به شمار مى‌رفت در حاليكه بانك‌‌هاى دولتى هزينه‌هاى فراوانى براى شعب خود خرج كرده بوده و مى‌كنند. و اما نكته آخر اينكه مديران بانك‌ها هنوز نسبت به مساله امنيت شبكه شتاب آشنا نبودند. بروز برخى مشكلات در دستگاه‌هاى قديمى خودپرداز بانك ملى و اتفاق افتادن نخستين سرقت اينترنتى بانكى در ايران، بانك‌هاى بزرگ را با مقوله‌‌اى به نام امنيت شبكه بيشتر آشنا ساخت. بانك ملى كه كليه خدمات سخت‌آفزارى و نرم‌افزارى خود را باز شركت خدمات انفورماتيك (مسوول سابق فراهم ساختن زيرساخت‌هاى بانكدارى الكترونيكى در كشور) خريدارى كرده بود به مشكل برخورد و بانك‌هاى ديگر را به فكر فرو برد. به طورى كه كمتر به سمت شركت خدمات انفورماتيك آمدند بنابراين عدم آشنايى به تامين امنيت شبكه در طرح شتاب نيز يكى از دلايل عدم استقبال بانك‌هاى بزرگ كشور از طرح شتاب بود.

اما بانك بزرگ آمد
با وجود بروز برخى مشكلات و مسايل در پيوستن بانك‌هاى كشور به طرحى جامع و مشترك در زمينه بانكدارى الكترونيكى، در اواخر سال 82 اعلام شد كه بانك ملى ايران به عنوان دارنده بيشترين شعب و بزرگترين بانك تجارى كشور به طرح شتاب مى‌پيوندد. بيشتر مسوولان شتاب با ارايه راه‌حل‌‌هايى از ترديد بانك‌ها در پيوستن به طرح مذكور بودند. اينكه هر بانكى با سخت‌افزار و نرم‌افزار خاص خود مى‌تواند به شتاب بپيوندد صرفاً بايد استاندارد 8583 را رعايت كند، اينكه پيوستن به شتبا هزينه‌هاى سنگينى بر بانك‌هاى كشور ايجاد نمى‌‌‌كند، اينكه بانك‌هاى بزرگ براى ارايه خدمات به مشتريان بانك‌هاى كوچك مى‌توانند كارمزد دريافت كنند و اينكه شتاب مى‌تواند امنيت شبكه بانكى را تامين كند از شك و ترديد‌هاى بانك‌هاى تجارى براى پيوستن به شتاب كاست و در اينجا بود كه درخواست‌هاى بانك‌ها براى پيوستن به شتاب در ميز اداره شتاب بانك مركزى قرار گرفت.
خبر پيوستن بانك ملى به شبكه شتاب از دى ماه سال گذشته افشا شد زمانى كه كليه مسايل فنى و قراردادهاى حقوقى بين بانك ملى و ادره شتاب بانك مركزى حل شده بود و بانك ملى هر لحظه آماده پيوستن به شبكه تبادل اطلاعات بين بانكى بود. اما اين پيوستن تا تاريخ پنجم ارديبهشت 83 به تعويق افتاد. مسايل فنى و قراردادهاى حقوقى هيچ مشكلى نداشت و علت تعويق صرفاً هماهنگى‌هاى مديريتى بود كه باعث شده بود اين پيوستن به تعويق بيافتد. بالاخره اعلام شد كه بانك ملى ايران به عنوان بزرگترين بانك تجارى كشور از اين تاريخ رسماً به طرح شتاب مى‌پيوندد و شماره بانك‌‌هاى عضو شتاب را به مى‌رساند. با پيوستن بانك ملى كه خود به تنهايى به اندازه 4 بانك عضو ديگر طرح شتاب دستگاه خودپرداز داشت، خدمات كارت الكترونيكى گسترش يافت و طرح شتاب نيز اهميتى بيش از پيش پيدا كرد. دستگاه‌هاى خودپرداز بانك ملى از جمله دستگاه‌هايى به شمار مى‌رود كه همواره داراى نقدينگى است.
بر اساس آمارهاى منتشر شده كل دستگاه‌هاى خودپرداز متصل به شبكه در بين 5 بانك عضو حدود 1200 دستگاه است كه خدود نيمى از اين دستگاه‌ها از آن بانك ملى است. همچنين بانك ملى صادركننده حدود يك ميليون و 300 هزار كارت بانكى الكترونيكى است كه با در نظر داشت حدود 900 هزار كارت الكترونيكى صادر شده توسط 4 بانك ديگر عضو شتاب تعداد كارت‌هى الكترونيكى استفاده شده در طرح شتاب به رقمى حدود 2 ميليون و 200 هزار كارت مى‌رسد. سواى پوشش شتاب در زمينه اتصال دستگاه‌هاى خودپرداز هنوز توفيقى در زمينه اتصال پيشرفته و كامل دستگاه‌هاى پايانه فروش (POS) در فروشگاه‌ها و مراكز خريد كالا صورت نگرفته است و اگر اين POS ها قابليت استفاده براى دارندگان كارت الكترونيكى بانك‌هاى عضو شتاب را داشته باشند مى‌توان گفت طرح شتاب به ثمر نشسته است.
بنابراين دارندگان 2 ميليون و 200 هزار كارت الكترونيكى بانك‌هاى عضو مى‌توانند از 1200 دستگاه خودپرداز در سراسر كشور اقدام به دريافت وجه كنند.

شتاب رقيب پيدا كرد
هنوز يك سال از فعاليت شتاب به عنوان سوئيچ ملى در پياده‌سازى بانكدارى الكترونيكى نمى‌گذرد كه رقيبى براى اين طرح در كشور پيدا شد.
يك شركت دولتى و توليدكننده نرم‌افزار اعلام كرده كه در حال تهيه و پياده‌سازى سوئيچ بانكدارى الكترونيكى است. يك مقام آگاه و بلندپايه در اين شركت كه نخواست نامش فاش شود گفت اين طرح مراحل اوليه آزمايشان را پشت‌سر مى‌گذارد و مى‌تواند رقيبى براى شتاب باشد. هرچند كه با رعايت استاندارهاى تعريف شده مى‌توان بين اين طرح و طرح شتاب ارتباط برقرار كرد. اين شركت همان شركتى است كه طرح 700 شعبه يك بانك تجارى را به اجرا رساند.
اما شايد اين رقيب كمى دير كرده باشد چرا كه مسوولان شتاب اعلام كرده‌اند به جز بانك‌هاى مسكن، رفاه و صنعت و معدن ساير بانك‌هاى دولتى و خصوصى درخواست عضويت در طرح شتاب را به بانك مركزى فرستاده‌اند حتى قول‌هايى چون پيوستن بانك سپه و تجارت در شش ماهه اول سال جارى به شتاب و بانك ملت در شش ماهه دوم داده شده است. بانك كارآفرين نيز با رعايت برخى مسايل فنى به زودى به اين طرح متصل مى‌شود.
بانك ملى با پيوستن خود به شتاب كمك شايانى به گسترش اين طرح كرد. اينك ميز مديران شتاب پر از درخواست‌هاى بانك‌ها براى پيوستن به شبكه شتاب است و مديران شتاب روزهاى پركارى را سپرى مى‌كنند.

mehdioliya@yahoo.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:43 AM

January 13, 2005

اخراج از سرور به خاطر انتقاد

نويسنده: عليرضا شيرازى

اخراج از سرور به خاطر انتقاد

12 ارديبهشت 1383 -

بخش مقاله آى تى ايران - شرکت سايرس هاستينگ در پاسخ انتقاد بنده از مشکلات پيش آمده ضمن اختلال در سايت پارسيک مرا مجبور به ترک سروهايشان کردند
اختلال در سايت پارسيک ( parseek.com) در نخستين روزهاى سال بدترين عيدى و اتفاق در سال جديد براى من بوده است.کدام مدير سايت و وب مسترى است که از اختلال در سايت خود حتى به مدت يک روز ناراحت نباشد.
به هر حال اين مشکل بر طرف شد و خبر راه افتادن مجدد پارسيک ر ضمن ذکر دلايل آن در وبلاگ Itiran.net نوشتم که در برخى از سايتها و روزنامه ها نيز منتشر شد .درست فرداى روز انتشار اين مطلب شاهد اختلال در سايت پارسيک بودم و در همان شب مدير شرکت ايرانى با من تماس گرفته و اعلام کرد که آقاى ميردامادى مدير شرکت سايرس هاستيگ (Cirrus Hosting) ضمن آنکه شخصا اقدام به قطع موقت سرويس سايت کرده اند اعلام کرده اند که سايت پارسيک ديگر نمى تواند بر سرورهاى شرکت فوق باشد.با شخص على ميردامادى و با کمک مسنجر تماس گرفتم تا حدالمکان نسبت به رفع کدورت اقدام کنم. اما متاسفانه آقاى ميردامادى فکر ميکردند که انتشار مطالب در روزنامه ها عملى مغرضانه از سوى من بوده و به نوعى از نفوذ خويش بهره برده ام!. شهرام شريف مدير سايت سايت آى تى ايران و همچنين دبيران بخش روزنامه هايى که اين مطلب در آنها منشر شده است قطعا اولين کسانى هستند که نادرستى اين قضيه را ميدانند.
لازم به ذکر است سايت پارسيک ميهمان سرورى در ديتا سنتر شرکت سايرس هاستيگ بوده اما خود سرور بصورت اختصاصى در اجاره و اختيار يک شرکت ايرانى (رايانه نت)ميباشد و برخورد آقاى ميردامادى حتى در قطع موقت سرويس بدون کسب اجازه از شرکت ايرانى حرکتى غير قانونى،خارج از عرف و اختلال در خدمات شرکت ايرانيست.خالى از لطف نيست که اشاره اى به بخشى از پيامهاى رد وبدل شده با شخص آقاى ميردامادى در پاسخ به اعتراض بنده و همچنين اعلام اينکه برخوزد ايشان را در روزنامه ها منتشر خواهم کرد داشته باشم.
جالب آنکه ايشان در تمام مدت صحبتهاى خود ضمن تحقير بنده معترف بودند که مطالب من هيچ تاثيرى در کار شرکتشان نداشته و نخواهد داشت .

[Ali Mird] man vaghean az inkare shoma delkhor shodam
[Ali Mird] shoma khodetoon ro khaili bozorg mikhastin jelve bedin
[Ali Mird] behar hal man shoma esmesho mikhay bezar tahdid ya har chize digeyee, man nemitoonam be shoma service bedam
[Ali Mird] ta akharesham vaysadam, shoma too abrar ke hichi, boro too har rooz nameye dige yee khasti bede chap konan
[Ali Mird] man aslan dirooz website shomaro stop karde boodam nemidoonam ki dobare start karde, vali man felan kootah oomadam
[Ali Mird] bebin man aslan mikham ta akharesh beram, vazifeyee ham dar moghabele adami mesle to nadaram .
[Ali Mird] pas man az hamin emrooz service ro ghat mikonam

و البته چون سرويس همان شب قطع نشد ديگر بحث ادامه پيدا نکرد و من نيز سرور و سايت خود رادر روزهاى بعد منتقل کردم. هزينه اينکار با توجه به تنظيمات و ترافيک سايت پارسيک کم نيست در حاليکه ميتوانستم مدتها از سرويس شرکت ايرانى با هزينه بسيار پايين ترى استفاده کنم. جالب آنکه اين شرکت فرداى آنروز اقدام به انتشار جوابيه اى در رد چند جمله انتقاد من کرده اند. در حليکه من به خاطر سايتم مجبور به سکوت بودم. در تکميل مطالب جوابيه ايشان تنها چند نکته اشاره داشته باشم.
اول آنکه بنده به عنوان مشاور فنى چندين بار به شرکت کانادايى معرفى شده بودم و در سالهاى گذشته نيز چندين مرتبه با شخص احسان ميردامادى (از ديگر مديران سايرويس هاستيگ ) و به صورت آنلاين مشکلات سرور را بر طرف کرده ايم.و در ايام نوروز امسال نيز مدير شرکت ايرانى از آنها براى همکارى با من درخواست کرده بودند.
آشنايى آنها با بنده و رابطه با شرکت ايرانى آنقدر زياد بود که از من براى تاسيس دفتر تهرانشان دعوت کردند و حتى براى آن از مدير شرکت ايرانى اجازه گرفتند!
در خواست بنده بسيار ساده بوده است و تنها اعلام تقاضاى IP جديد را داشتم.موردى که به شرکتهاى ديگر اعلام شده بود اما هرگز اطلاعيه در اين مورد به شرکت ايرانى نرسيد (شايد هم به خاطر درگيرى مالى!) . در ضمن حداقل ميتوان انتظار داشت که چننين تغييرى که ميتوان آنرا بزرگترين تغيير در يک ديتا سنتر دانست در سايت رسمى اين شرکت اطلاع داده شود.
همانطور که قبلا نيز اشاره داشتم شرکت ايرانى را بيش از شرکت کانادايى مقصر ميدانم چرا که حداقل اشتباه آنها انتخاب يک چنين شرکتى به عنوان شرکت همکار و تامين کننده سرور بوده است.
حتما متوجه شده ايد که بنده بيش از يک مشترى غير مرتبط با سايرس هاستيگ بوده ام و توقع اطلاعات زيادى نيز نداشتم.
حتى اگر بپديرم که گله من از آنچه بر سايتم گذشته به قول آقابان بچه گانه باشد . اما قطع سرويس بدون اجازه و اطلاع و تهديد به قطع کلى سرويس و در نهايت تحميل بار مالى و فکرى بخاطر تغيير سرور مسئله اى کودکانه نيست و به نظر ميرسد که تا زمانيکه در کشورمان قانونى براى اينگونه يکه تازيها وجود ندارد ميبايست انتظار اينگونه رفتارها را از همکاران خارج از کشور داشت.
مشکلات فنى در تجارتهاى مرتبط با تکنولوژى پذيرفته شده و تا حدودى قابل اغماض است.اما پشتيبانى و برخورد منطقى و مناسب ديگر يک حق مسلم براى مشتريان است.اصلى ساده که بايستى توسط هر شرکتى پذيرفته شود. اميدوارم اتفاقى که براى سايت پارسيک درسى حداقل براى خود من در انتخاب ميزبانى بهتر و آغازى براى برخورد با يکه تازيهاى شرکتهاى خارجى نسبت به همکاران و مشتريان ايرانى خود باشد .

* مدير سايت پارسيک parseek.com

a_shirazi@yahoo.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:45 AM

January 13, 2005

دشوارى هاى روزنامه نگارى IT:هشت سال بايكوت

نويسنده: مينو مومنى

دشوارى هاى روزنامه نگارى IT:هشت سال بايكوت

20 ارديبهشت 1383 - شرق - اين روزها با نظرى كوتاه بر كيوسك هاى روزنامه فروشى به راحتى مى توان نام ده ها هفته نامه، ماهنامه و فصلنامه را ديد كه در حوزه فناورى اطلاعات به نوعى مشغول به كارند، حتى هستند روزنامه هايى كه چند صفحه خود را اختصاص به اين حوزه نوپا و جوان داده اند. اين وضعيت در خبرگزارى هاى رسمى و با سابقه اى چون ايسنا، ايرنا، ايلنا و... نيز به چشم مى خورد. در اين خبرگزارى ها مى توان با يك كليك ساده بر روى بخش فناورى اطلاعات در كمتر از چند دقيقه به حجم نسبتاً وسيعى از اخبار در اين حوزه دست يافت.
همه اين عوامل باعث مى شود كه بى ترديد به اين نتيجه رسيد كه مطبوعات تخصصى آى تى و به نوعى آى تى نويسى مانند سابق ديگر براى مردم غريب و نا آشنا نيست و از طرف ديگر در خواست مكرر براى گرفتن امتياز اين گونه نشريات همه و همه بار ديگر اين ترديد را به يقين كامل مى رساند كه داشتن اين گونه نشريات نياز امروزه جامعه ماست اما در اين روزها همزمان با تب و تاب جشنواره مطبوعات شاهد هستيم با تمامى تلاش مسئولان و خبرنگاران شاغل در چنين مطبوعات تخصصى بار ديگر اين حوزه و نقش كليدى آن از ديد مسئولان در عرصه مطبوعات ناديده گرفته شده است و...

• نخستين تولد
قريب به ۱۵ سال قبل تنها يكى دو نشريه مطالب تخصصى علمى را منتشر مى كرد و مسئولان اين نشريات هيچ گاه تصور نمى كردند با خاص تر شدن حوزه هاى علمى تخصصى عملاً اين نشريه ها با همه محبوبيت و مقبوليت خود بين جوانان فراموش شود. از حدود ۸ سال قبل با گسترش محدود تكنولوژى كامپيوتر، يكى دو نشريه آغاز به فعاليت كردند و عملاً نخستين تجربه هاى روزنامه نگارى در حوزه كامپيوتر آغاز شد. نگاهى به مطالب نشريات نخستين اين حوزه نشان مى دهد توجه عمده آنان به انتشار مطالب تخصصى و آموزشى بوده. عمده مخاطبان آنها نيز قشر هاى خاص و نخبگان فنى را در بر مى گرفت.
به مرور با گسترش سريع فناورى كامپيوتر و ايجاد شبكه هاى اطلاع رسانى و خصوصاً وارد شدن پديده اينترنت به جامعه ايران نياز به وجود نشرياتى با رويكرد وسيع تر به اين عرصه احساس شد. در سال ۱۳۷۷ نخستين صفحات آى تى و كامپيوتر در روزنامه ابرار اقتصادى منتشر شد. در اين صفحات اخبارى درباره دنياى كامپيوتر، بازار قطعات در ايران و وضعيت اين رشته در كشورهاى پيشرفته منتشر مى شد. پيش از اين نيز در محدوده سال هاى ۶۸ تا ۷۶ تعدادى نشريه كامپيوترى منتشر مى شد كه رويكرد آنها كمتر به سمت ايران و بيشتر متمايل به ترجمه متون خارجى در اين زمينه بود. بنابر آمارهاى وزارت ارشاد هم اكنون بيش از ۵۰ نشريه (فصلنامه، ماهنامه و هفته نامه) در زمينه كامپيوتر، اينترنت و به طور كلى فناورى اطلاعات مجوز انتشار گرفته اند. در مقابل از چهار سال قبل تا كنون به دنبال گسترش سريع اينترنت و استفاده رسانه ها از جمله مطبوعات از اين ابزار ساده و قوى اطلاع رسانى تعدادى زيادى از روزنامه ها با ايجاد صفحات مخصوص اينترنت و آى تى به اين مقوله توجه نشان دادند.
سيد محمد صفى زاده مدير مسئول گروه نشريات ابرار درباره ايجاد صفحات كامپيوتر براى نخستين بار در روزنامه ابرار اقتصادى مى گويد: روزنامه نگارى امروز بدون توجه به نيازهاى اساسى جامعه و علايق آنها كارى عبث است. به همين منظور ابرار اقتصادى در برهه اى از زمان با شناخت وضعيت رو به رشد تكنولوژى كامپيوتر تصميم به انتشار صفحات ويژه كامپيوتر گرفت. هر چند در ابتدا برخى افراد پيش بينى مى كردند اين صفحات مخاطب چندانى پيدا نكند اما امروزه شاهد آن هستيم كه بسيارى از روزنامه ها اقتصادى و حتى غير اقتصادى وجود چنين صفحاتى را لازم مى دانند.
ايمان بيك سردبير هفته نامه عصر ارتباط كه خود در آن زمان مسئوليت صفحات كامپيوترى ابرار اقتصادى را بر عهده داشت درباره نخستين تجربيات روزنامه نگارى خويش در اين عرصه مى گويد: كار در عرصه بكر آى سى تى كه آن موقع سرويس كامپيوتر نام داشت پر از تجربه و كشف بود. من و چند نفر از دوستانم هيچ نمونه تجربه شده اى در اين زمينه نداشتيم. البته طبيعى است كه لازم نبود اصول كار روزنامه نگارى را كشف كنيم اما نحوه اطلاع رسانى در حوزه كامپيوتر تجربه نشده بود و قطعاً روش هاى جديدى را مى طلبيد. نخستين تجربه هاى روزنامه نگارى در حوزه آى سى تى با مشكلات خاص خود همراه بود. از جمله فقدان منابع خبرى و همچنين مشكلات دسترسى به شبكه هاى اطلاع رسانى كه عملاً بر نحوه فعاليت بر اين عرصه تاثير مى گذاشت.
ايمان بيك در اين باره مى گويد: آن وقت ها اينترنت به معناى امروزى در دسترس نبود. به عنوان نمونه سرعت اينترنت به قدرى كند بود كه براى ديدن صفحه نخست ياهو بايد ۱۵ دقيقه به انتظار مى ماندى، از طرف ديگر خبرگزارى ها هنوز اين حوزه را نمى شناختند و ما براى كسب خبر واقعاً سختى مى كشيديم.

• تكامل بعد از تولد
با گذشت چند سال از ورود صفحات آى تى به روزنامه ها، امروزه آى تى نويسى و خبرنگار آى تى واژه هاى نامأنوسى نيستند اما اين رشد كمى هنوز نتوانسته مخاطبان اين عرصه را كاملاً راضى كند. همچنان كه سال ها فعاليت مجلات كامپيوتر نيز به نتايج كاملاً خوشايندى براى مخاطبان نرسيده است.
بهروز نوعى پور عضو هيات تحريريه ماهنامه شبكه در ارزيابى از وضعيت نشريات آى تى مى گويد: در تمام طول حيات نشريات كامپيوترى يا به تعبير جديد نشريات آى تى در ايران ما با وضعيت سعى و خطا و نرسيدن به نقطه بهينه رو به رو بوده ايم. اگر علم كامپيوتر و فناورى اطلاعات پيشرفت زيادى نمى كرد ما هم اكنون نشريات بسيار متبحرى در اين عرصه داشتيم. متاسفانه به علت سرعت تحولات اين صنعت ما همواره چند گام از وضعيت مطلوب عقب تر و در حال تمرين براى رسيدن به نقطه بهينه هستيم.
به عقيده نوعى پور تحولات عرصه كامپيوتر تاثير متقابلى نيز بر سلايق مخاطبان و نياز نشريات كامپيوترى به مطالب متنوع تر داشته است. به طورى كه در گذشته كافى بود نشريات اين عرصه از همكارى چند مهندس نرم افزار و سخت افزار بهر ه مند باشند اما امروزه نه تنها در برخى نشريات به اندازه كافى نيروى متخصص در اين حد وجود ندارد بلكه اساساً ديگر وجود چند مهندس فايد ه اى ندارد. تنها به اين دليل كه در همين مدت علم و صنعت كامپيوتر به ده ها شاخه تخصصى ديگر تقسيم شده و تسلط بر هر كدام از اين گرايش ها كار آسانى نيست.
ايمان بيك نيز در اين باره اعتقاد دارد كه از ميان نشريات آى تى آنها كه ماهنامه هستند شكل و طبيعت كارشان با صفحات و سرويس هاى آى تى نشريات تفاوت دارد و به جز يكى دو ماهنامه بقيه بيشتر در حوزه علوم و تخصص هاى آى تى فعال هستند و با توجه به مخاطبانشان مسير درست خود را انتخاب كرده اند. اما آن جا كه بحث صفحات آى تى نشريات پيش مى آيد و كار به صورت روزانه انجام مى شود رويكرد بيشتر خبرى است و خوشبختانه افزايش تعداد منابع خبرى و خبرنگارانى كه در اين حوزه فعاليت مى كنند در كنار تحرك بيشتر در آى تى ايرانى و منابع توليد خبر كار را ساده تر كرده است.
با اين همه سردبير هفته نامه عصر ارتباط به نوعى به سستى، كندى و عدم پويايى و پيروى از الگوى يكسان در نشريات آى تى اشاره مى كند و در مورد ضعف هاى اين دسته از نشريات مى گويد: بسنده كردن به مطالب خبرگزارى ها، شباهت محتوايى نشريات به هم، عقب ماندگى از دانش روز و حتى اتفاقات داخلى، فقدان تنوع و در نهايت آگهى زدگى به نوعى وجه اشتراك اين نشريات تبديل شده كه تا اندازه اى آغاز خوب اين رشته تخصصى را كمرنگ ساخته است.
به رغم استقبالى كه از نشريات و صفحات آى تى در طى چند سال گذشته به عمل آمده، همپاى رشد روزنامه نگارى آى تى در اين عرصه انتقادهايى نيز در اين زمينه متوجه اين دسته از مطبوعات شده است تا آن جا كه برخى منتقدان اغلب اين نشريات را صرفاً ترجمه نه چندان خوبى از نمونه هاى خارجى مى دانند.
بهروز نوعى پور در اين باره اعتقاد دارد: استفاده بيشتر از ترجمه تا حدودى طبيعى است زيرا از نظر فنى و مهندسى ما يك كشور وارد كننده علم محسوب مى شويم. علم در آن سوى دنيا با سرعت چندين برابر كشور ما توليد مى شود و ما همين كه فرصت كنيم آن را به موقع ترجمه كنيم هنر بزرگى انجام داده ايم. اما از طرفى محتواى اين نشريات چندان راضى كننده نيست به اين دليل كه اولاً تعداد نشريات فارسى كامپيوترى كه هم اكنون در ايران منتشر مى شود به مرز اشباع رسيده است و وقتى شما ۱۵ تا ۲۰ نشريه داشته باشيد كه مطالب مشابه اى چاپ كند، مخاطب سرگردان مى شود و در واقع اين نشريات از تعداد مخاطبان يكديگر كم مى كند.
نوعى پور مشكل اصلى را در نبود گرايش تخصصى اين نشريات مى داند و مى گويد: اغلب آنها از الف تا ى در هر زمينه اى مقاله و خبر چاپ مى كنند تا به زعم خودشان مخاطب را راضى نگاه دارند.
وى در ادامه مى افزايد: مشكل ديگرى كه وجود دارد موضوع حضور اينترنت است. در حال حاضر بسيارى از خوانندگان نشريات كامپيوترى به اينترنت نيز دسترسى دارند. از آن جا كه حجم زيادى از مطالب نشريات ترجمه است اين گروه از خوانندگان بالقوه امكان دسترسى به اصل مطلب در اينترنت را دارند در عين اينكه سرعت انتشار مطالب در اينترنت و كيفيت مطالب خارجى به هيچ وجه قابل مقايسه با مطالب داخلى نيست، بنابراين برخى از خوانندگان اين نشريات با اين سئوال مواجه مى شوند كه اصولاً فلسفه مراجعه به نشريات فارسى چيست.

• مشكلات بعد از تولد
از چند سال قبل كه رشته آى تى به نوعى جاى خود را در ميان روزنامه ها باز كرد، موضوع روزنامه نگاران آى تى و شكل فعاليت آنها مورد توجه قرار گرفته است. اين كه روزنامه نگارى آى تى نيازمند چه پيش نيازها و آگاهى هايى از عرصه هاى آى تى و روزنامه نگارى است، پرسشى است كه ذهن روزنامه نگاران اين عرصه را به خود مشغول كرده است.
ايمان بيك در مورد نيازمندى هاى يك روزنامه نگار آى تى مى گويد: هر روزنامه نگار اين عرصه طبيعتاً بايد آى سى تى را به خوبى دريابد و درك كند. آى سى تى روى ساختارهاى سياسى يك جامعه به شدت اثرگذار است.
بنابراين برقرارى موازنه دانش آى سى تى و سياست مى تواند مورد علاقه و پيگيرى يك آى تى نويس واقع شود. به همين صورت اقتصاد يا فرآيند هاى اجتماعى، فرهنگى و غيره. بيك با اشاره به اين كه شرايط مطلوب در فضاى آى تى نويسى ايران شكل نگرفته مى گويد: بچه هاى اين حوزه يا خبرنگار بوده اند و بعد به حوزه آى سى تى وارد شده اند كه طبعاً نيازمند مطالعه و كسب دانش آى سى تى هستند و يا از حوزه آى سى تى به روزنامه ها آمده اند كه بايد با تجربه بيشتر و كسب دانش روزنامه نگارى و ارتباطات، راهكار هاى بهينه انتقال دانسته ها و اخبار را به مخاطب بياموزند.
به اعتقاد وى يك مشكل عمده نيز فقدان جايگاه مشخص براى حوز ه هاى تخصصى در سيستم هاى آموزشى روزنامه نگارى ماست. در جايى كه روزنامه نگار ورزشى، اقتصادى يا سينمايى تربيت نمى شوند، نمى توان انتظار گشايشى در رشته آى تى نويسى داشت اما ناديده گرفتن آى تى نويسى در جشنواره مطبوعات به نظر من خيلى بى انصافى است. در دو سه سال گذشته در آستانه جشنواره همواره اين مسئله را ياد آور شده ايم اما تا كنون اثر نبخشيده است.
بدرالسادات مفيدى عضو هيات مديره انجمن صنفى روزنامه نگاران ضمن تائيد اين موضوع كه جاى آى تى نويسى در رشته هاى رقابتى جشنواره مطبوعات خالى است مى گويد: آى تى نويسان مى توانند امسال آثار خود را براى بخش علمى ارسال كنند و از سال آينده تلاش مى كنيم رشته ويژه اى را براى اين دسته از مطالب در نظر بگيريم.
به هر حال با همه مشكلاتى كه در عرصه روزنامه نگارى آى تى وجود دارد به نظر مى رسد همپاى تكنولوژى كامپيوتر و اينترنت اين رشته نيز در حال رشد و طى كردن مراحل تكامل خود است و براى رسيدن به اين مرحله تكاملى نياز به توجه بيشترى از سوى متوليان اين عرصه احساس مى شود.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:46 AM

January 13, 2005

جايگاه اينترنت در هنگ کنگ

نويسنده: ايمان محسنى نيا

جايگاه اينترنت در هنگ کنگ

26 ارديبهشت 1383 - سرکنسولگرى جمهورى اسلامى ايران هنگ کنگwww.Iranconsulate.org.hk

بخش مقاله آى تى ايران - هنگ کنگ ارائه کننده خدمات مطلوب اينترنتى و داراى محيطى مناسب به جهت توسعه اينگونه نيازها و پيشرو در تجارت الکترونيکى است. هنگ کنگ را HUB آسيا مى نامند که دليل آن پيشرفت سريع خدمات فنى و مهندسى ، الکترونيک و IT مى باشد. اين عنوان در جهت انجام خدمات تجارى و اقتصادى بروز و بهره گيرى از صنعت IT در اين سرزمين ميباشد. هنگ کنگ منطقه اى است که فعاليت تجارى و استفاده از تکنولوژى صبح و شب در آن در جريان بوده و خدماتش را به داخل هنگ کنگ و خارج از آن ارائه مى کند. اين فعاليتها همه به جهت سرويس مناسب IT بوده و باعث پيشرفت در اين منطقه گرديده است. همانطور که در گزارش قبلى عنوان گرديد ، موقعيت مناسب هنگ کنگ در زمينه IT مى تواند براى کشورمان بسيار سودمند بوده و در اين زمينه فعاليتهاى دو جانبه صورت پذيرد. با توجه به رشد سريع سرويس دهندگان خدمات اينترنت (ISP) در هنگ کنگ در سال 1993 ، استفاده از اينترنت به شدت بين کاربران خانگى و مراکز ادارى و تجارى رواج يافته و رشد قابل ملاحظه اى نموده است. طبق آمار ارائه شده در سال 2003، %61 خانواده ها در هنگ کنگ داراى کامپيوتر شخصى بوده و %80 از اين کامپيوتر ها به اينترنت متصل مى باشند.
%44 از مراکز تجارى رسمى نيز به اينترنت متصل مى باشند. تا فوريه 2003 ، هنگ کنگ 4/2 ميليون کاربر اينترنت را در خود جاى داده است.ترافيک اينترنت نيز به 28372 ترابيت در شبکه هاى با پهناى باند بالا در ماه رسيد. فروش کالا و ارائه خدمات از طريق اينترنت براى شرکتهاى هنگ کنگى در سال 2001مبلغى در حدود 1/22 ميليون دلار هنگ کنگ سود آورى داشته که %185 رشد، نسبت به سال 2000 را دارا مى باشد. هرچند ، اگر منصفانه محاسبه کنيم تجارت الکترونيکى در هنگ کنگ تا پايان سال 2001 در مراحل آغازين بود و تنها % 5/1 از شرکتهاى هنگ کنگى کالاهاى خود را توسط اينترنت به فروش رساندند. بدنبال استراتژى آى تى " ديجيتال 21 " دولت هنگ کنگ ، اين منطقه به عنوان HUB منطقه آسيا پاسيفيک به جهت خدمات اينترنتى چه در زمينه ترافيک آن و چه در نحوه ارتباط دادن شناخته شد.

نوع خدمات
خيلى ها از اينترنت براى ارتباط گيرى و دريافت اطلاعات استفاده مى کنند. ولى معاملات و تجارت الکترونيکى توسط اينترنت رو به افزايش است.%8/11 از شرکتهاى هنگ کنگى وب سايت مربوط به خود را دارند که %61 آن مربوط به شرکتهاى بزرگ ( مستخدمين بيش از 100 نفر) تا %1/8 براى شرکتهاى کوچک ( مستخدمين کمتر از 10 نفر). اين وب سايتها بيشتر به جهت انتشار اطلاعات مربوط به شرکتها و هچنين دريافت اطلاعات از مشتريان شرکتها. تنها %5/1 از شرکتهاى هنگ کنگى در سال 2002 توسط اينترنت اقدام به فروش محصولات خود و يا سرويسهاى خود به مخاطبين نموده اند. که اين رقم در سال 2001 %43/0 بود. طى تحقيقى توسط محقق استراتژيک ،%13 از شرکتهاى هنگ کنگى دستور خريد و فروش خود را بصورت ONLINE قبول نمودند و اين در منطقه آسيا و پاسيفيک آنها را پيش انداخته. طبق بررسى گروه اکونوميست هنگ کنگ در اين زمينه مقام دوم در آسيا و مقام دهم در دنيا را تا سال 2003 بخود اختصاص داده است. تحقيق ديگرى توسط AC Nielsen بيانگر آن است که يک سوم کاربران اينترنت در هنگ کنگ از خدمات بانکى ONLINE استفاده کرده که يکبار در هفته يا بيشتر مى باشد و اين هنگ کنگ را درمرتبه بالاتر از کره جنوبى ، سنگاپور و تايوان در زمينه استفاده از خدمات بروز بانکى قرار مى دهد.

• تجارت با مشترى ( مصرف بصورت online )
مصرف بصورت online زمانى است که خريد و فروش و درخواست کالا توسط اينترنت صورت پذيرد. سايتهاى مختلفى براى اين گونه خدمات در هنگ کنگ وجود دارد، همانند: فروشگاه online سايتهاى ارائه دهنده خدمات مالى ، خريد و فروش بليط و اطلاعات خدماتي. بنا به گزارشى به عنوان " هنگ کنگ بعنوان يک انجمن اطلاعاتى" که توسط اداره سرشمارى و آمار در سال 2002 تهيه گرديد، تنها %2/3 از کاربران اينترنت وارد کننده کالا يا خدمات بوده که اين نشان دهنده شروع آنها در اين زمينه مى باشد و در حال توسعه قرار دارد. بزرگترين مانعى که سد راه پيشرفت تجارت الکترونيک در هنگ کنگ است تصميم گيريهاى افراد به جهت امنيت شبکه هاى اينترنتى است و اينکه آيا دادو ستد ازطريق اينترنت مطمئن است يا خير؟ %8 از کاربران اينترنت در سال 2002 بصورت ONLINE اقدام به خريد نموده اند که از استراتژى آن لاين و آف لاين استفاده نمودند.

• تجارت الکترونيکى B2B تجارت آن لاين بين شرکتها
اين نوع تجارت شامل شرکتهايى مى شود که از اينترنت براى بدست آوردن سود و انجام معامله با مشترى از آن استفاده مى کنند. اين نوع معامله بصورت تبادل الکترونيکى اطلاعات توسط شبکه قبل از اينکه به وب راه پيدا کند به بهره بردارى مى رسد. تعدادى از
اين وب سايتها هم در هنگ کنگ به بهره بردارى رسيده اند. اين نوع وب سايتها معمولا براى تجارت اجناسى همچون فولاد يا فعاليتهاى منبع يابى و يا مديريت تهيه کالاهاى زنجيره اى در اين زمينه مى باشند. با توجه به مرکزيت هنگ کنگ در رابطه با تجارت در منطقه انجام معامله از طريق شيوه B2B تاثير درتوسعه تجارت الکترونيکى محلى در سال جديد خواهد گذارد. طبق مطالعه "انجمن فرآورش هنگ کنگ " در رابطه با تجارت الکترونيک در هنگ کنگ در دسامبر 2002 نشان دهنده رشد قابل توجه د رارتباط از طريق پست الکترونيک ، ارسال پيام SME . 57% از شرکتها براى 80% از پرسنل خود پست الکترونيک اختصاص داده و 69% از آنها از اينترنت با پهناى باند بالا استفاده مى کنند.که اين رقم در شش ماه گذشته 64% بود.

• معامله الکترونيکى وابسطه به دولت
در ژانويه سال 2000 ، دولت حکم معامله الکترونيکى را به تصويب رساند و بنا به تاسيس سازمان کليدى عمومى در اين زمينه نمود تا اعتماد جامعه را به قانونى بودن و قابل اجرا بودن اين گونه معاملات جلب نمايد. پست وخط تجارى هنگ کنگ دو قسمت مجوز دارشناخته شده در انجام اين گونه معاملات هستند.براى ترويج اينترنت در هنگ کنگ ، دولت نسبت به طرح و ارائه سرويس حمل الکترونيکى نموده است. همانند سرويس الکترونيکى مناقصه. طى مطالعه اى که بر روى دولت الکترونيکى هنگ کنگ صورت گرفت در سال 2002 ، هنگ کنگ مقام هفتم در بازار دولت الکترونيکى دنيا را به خود اختصاص داده است.

• سرويس دهندگان اينترنت در هنگ کنگ (ISP)
بنا به اظهارات مسئولين اداره ارتباط از راه دور هنگ کنگ 234 شرکت خدمات دهى اينترنت هنگ کنگ تا نوامبر 2002 وجود داشته است. همچنانکه کليه شرکتهاى داراى مجوز در اين زمينه فعال نبوده وبازار ISP هنگ کنگ توسط تعدادى حکم فرما مى شد . در نوامبر 1996 انجمن سرويس دهندگان اينترنت شکل گرفت و مسئوليت آنها توسعه اين صنعت در هنگ کنگ بود.شرکتهاى عضو در اين انجمن به بيش از 75% از استفاده کنندگان بازار انترنت هنگ کنگ بود. استفاده از اينترنت با پهناى باند بالا و خطوط ADSL , LMDS و مودمهاى کابلى بيشتر و بيشتر در بين کابران محبوبتر مى شوند. در حال حاضر 9 شرکت مشغول سرويس دهى اينترنت با پهناى باند بالا در هنگ کنگ مشغول به فعاليت هستند.

• ارائه دهندگان مطالب اينترنتى
با يک احساس فراملى مى توان عنوان کرد که بيشتر وب سايتها در هنگ کنگ داراى مطالب سودمند مى باشند. موفقيت يک وب سايت در ارائه مطالب جذاب و مناسب آن مخصوصا در قسمت اقتصادى و ... مى باشد که فرد مخاطب را به خواسته هايش هدايت مى نمايد.حتى بعضى از اين وب سايتها بصورت online عمليات بانکى و مالى نيز ارائه مى دهندبهضى از اين وب سايتها فقط روى يک موضوع خاص و بعضى ديگر نيز در زمينه هاى مختلف ديگر مانور مى دهند.بعنوان نمونه وب سايت tdctrade.com يک سايتى است که در زمينه ارتباط دهى تجارى براى شرکتهاى هنگ کنگى و يا کليه علاقه مندان براى تجارت با هنگ کنگ مى باشد. •

• ارائه دهندگان نرم افزار از طريق وب
اين گونه شرکتها از طريق وب سايت خودشان به ارائه نرم افزارها پرداخته و مى توان با پرداخت حق عضويت از ليست آنها يک برنامه را انتخاب کرده و با وارد شدن به آن از آن استفاده نمود ( اين بيشتر براى نرم افزارهايى است که نياز به مجوز License از شرکت سازنده دارند ). در حال حاضر در هنگ کنگ 50 نوع از اين شرکتها يا وب سايتها موجود مى باشد. پيش بينى مى شود که تعداد زيادى از شرکتهاى کوچک و متوسط با بهره گيرى از امکانات اين وب سايتها استفاده بيشترى ببرند. بنا به گزارش اداره سرشمارى و آمار هنگ کنگ حدود 1/66% از شرکتها کوچک و متوسط(SME) و 5/40% از شرکتهاى کوچک به اينترنت متصل مى باشند. در حال حاضر بيش از 300000 شرکت کوچک و متوسط (SME) در هنگ کنگ موجود مى باشد. علاوه بر خدمات عنوان شده اين شرکتها به عنوان مشاور در امور تجارت الکترونيک نيز بکار گرفته مى شوند. •

• • صادرات
با توجه به قابليت هنگ کنگ در ارتباط از راه دور (Telecommunication)، موقعيت بى نظيرى براى چين ايجاد گرديده ، تا نسبت به استفاده از قابليتهاى هنگ کنگ در زمينهاى تجارت الکترونيک همينطور ترافيک شبکه اينترنت براى جمهورى خلق چين مفيد واقع گردد. انتقال بسيار از اطلاعات صوتى ، تصويرى و تلفن اينترنتى همينطور نت ميتينگ در هنگ کنگ بخوبى اجرا مى گردد. با توجه به فعاليت شرکتهاى پرتال در هنگ کنگ ، اين شرکتها هنگ کنگ را به هاب خارجى براى شرکتهاى مختلف تجارى تبديل نموده است.
WTO چين بدنبال جذب کردن بيشتر شرکتهاى خارجى تا از هنگ کنگ براى اتاق کنترل خود به جهت فعاليتهايشان در چين استفاده کنند. همانند: بانک اطلاعاتى، ثبت و اجاره صفحات خانگى، تبديل و معامله حمايتهاى تکنيکى و ... که هنگ کنگ در آن قوى تر مى باشد. بسيارى از اپراتورهاى هنگ کنگى جاى پاى ثابتى در بازار اينترنت خارجى بدست آورده اند. براى مثال شرکت PCCW شبکه هاى ارتباطى از راه دور و شرکت سرويس شبکه اى وسومين بزرگترين ISP را در اختيار دارد. PCCW تايوان به تازگى شبکه WAN خود را به اتمام رسانده و بدنبال اتصال به شبکه از راه دور تايوان بوده تا بتواند سرويس اينترنت خود را همينطور خدمات پست الکترونيکى به نحو مطلوبى ارائه دهد. شرکت " چاينا دات کام " نيز نسبت به تاسيس يک زيرمجموعه کره اى که 7 روز هفته و 24 ساعته اقدام به توسعه تجارت تبليغات اينترنتى کنند.در اکتبر 1999 شرکت يک سهميه 60% از شرکت کره اى که در توليد وب سايت است را بدست آورد . شرکت هاچيسون و پيونگ کونگ 40% از سهميه پرايس لاين دات کام را به خود اختصاص دادند و يک تاجر عمده آن لاين آمريکايى نيز سهمى از ارائه کنندگان مطالب اينترنتى در تايوان و چين را از آن خود کرد.

• توسعه صنعت و ديدگاه بازار ( آخرين تحولات) •
با توجه به اعلام اتحاديه بين المللى ارتباطات از راه دور سود حاصله از تجارت الکترونيک در آسيا و اقيانوسيه از 35 ميليارد دلار آمريکا در سال 2000 به 500 ميليارد دلار آمريکا در سال 2003 افزايش پيدا خواهد کرد. ( يک ميانگين سالانه 14 درصدى). ولى سود سهام B2B 85% از کل محاسبه خواهد شد. اين نواحى شاهد رشد و توسعه حجم پهناى باند اينترنت بين المللى در اتصال اينترنت آسيا واقيانوسيه به جهان شدند.
يک گزارش توسط مکنزى نشان داد که در 3 سال گذشته استفاده کنندگان از ليزلاين به سرعت رشد نموده . ( قابل توجه که خط اينترنت منازل نيز در هنگ کنگ ليز لاين مى باشد). در اواسط 2002 ، شبکه هاى با پهناى باند 300 ميليون کاربر خانگى در 20 کشور صنعتى دنيا داشتند. نتيجه گيرى اينکه خطوط با پهناى باند در آينده بازار خوبى را دارا خواخند شد و افراد زيادى براى استفاده از آنها په در واحدها ادارى چه تجارى و حتى در منازل روى خواهند آورد. صنعت صوت و تصويرو بازيها نيز قطعا تحت تاثير اين بازار قرار خواهند گرفت. بعضى از صنايع همگانى هنگ کنگ مثل: China Light and Power ويا China Gas به طرق گوناگونى وارد صنعت اينترنت شدند.
توسعه تکنولوژى شبکه هاى بى سيم نيز به تلفن هاى همراه امکان انجام عمليات در اينترننت و استفاده از آن را توسط گوشى خواهند داد. طى گزارش نشريه "صنعت کامپيوتر" ، شمار کاربران بين المللى اينترنت از 533 ميليون در سال 2001 به 46/1 ميليارد در سال 2007 و نسبت کابران اينترنت که بى هدف از اينترنت استفاده مى کنند از 16% در سال 2001 به 8/56% در سال 2007 خواهد رسيد. سرويسهاى معروف موبايلها مثل SMS ثابت کردند که بخوبى توسط مصرف کنندگان مورد استفاده قرار مى گيرند. پيش بينى مى شود که 10% از تجارت الکترونيکى جهانى توسط عبور از موبايلها صورت پذيرد در سه سالى آينده و بيش از 600 ميليون موبايلهاى اينترنتى فروخته خواهند شد در سالهاى 2002 تا 2005 در دنيا. توسعه تکنولوژى 3G نيز بهدا استفاده و امکانات استفاده از موبايلهاى اينترنتى را بهبود مى بخشد.

• بازار چين
• چين بزرگترين استفاده کننده از اينترنت در منازل مى باشد.(1/59 ميليون ) درمنطقه آسيا و اقيانوسيه و دومين منطقه بعد از ايالات متحده آمريکا ( 166 ميليون). بنا به اظهار WTO چين ، چين در فازهاى مختلف سرمايه گذارى خارجى در ارتباط از راه دور و سرويس اينترنت خود را آغاز خواهد نمود. اين اقدام براى شرکتهاى هنگ کنگى فرصتهاى بسيار عالى را به ارمغان خواهد آورد.
شرکتهاى هنگ کنگى از بازار بين اطلاعات بيشتر و ارتباطات بهترى دارند. اين بزرگترين امتياز براى آنها نسبت به ديگر شرکتهاى خارجى مى تواند باشد. شرکتهاى هنگ کنگى در زمينه هاى مشاوره، اجرائيات ، و راه کارهاى مختلف همينطور آموزش تبحر دارند. براى بازار ISP رقابت بسيار زياد است. جدا از هزينه هاى زياد ارتباط ، يک مشکل ديگر در اين است که سرويس دهندگان اينترنت هنوز نتوانسته اند متوجه شوند که چگونه خدمات و سرويس خود را بنوعى ارائه کنند که هزينه هاى زياد آنرا بتواند در بياورند.
در محدوده ICP نيز چون هنوز چين در نواحى همانند بازاريابى ، ابتکار، قوى نيست بعضى از شرکتهاى چينى وب سايت راه اندازى نموده اند ولى نمى دانند که چگونه از آن به نحو مطلوب بهره بردارى کنند تا تاثير گذار باشد. شرکتهاى هنگ کنگى قابليت انجام فروش مجدد با ارزش افزوده توسط اينترنت و مديريت عالى به انجام برسانند. شرکتهاى هنگ کنگى ممکن است يک برترى داشته ، يا از مهارتشان استفاده مى کنند يا از تکنولوژى در تجارت خودشان و يا ارائه بازاريابى و سرويس خلاق.
سرويسهايى مثل: طراحى وب سايت ، نياز به شناخت از بازار چين را دارد که در اينجا اين شرکتهاى هنگ کنگى هستند که مى توانند. براى مثال : بيش از 78% صفحات وب در دنيا به زبان انگليسى هستند و کمتر از 1% به زبان چيني. آن سايتهايى که قابليت جستجو دارند و يا سايتهاى جستجو گر ( Serach Engine) و يا سايتهاى مترجم مى توانند در بازار چين بخوبى فعاليت کنند.
رشد شرکتهاى خصوصى در چين بازار خوبى را براى ASP ها تشکيل داده چون آنها بيشتر نياز به استفاده از IT را دارا مى باشند.بيشتر شرکتهاى کوچک و متوسط آهسته آهسته نياز It خود را از طريق استفاده از ASP فراهم مى کنند که از هزينه سنگين جلوگيرى کنند. هرچه بيشتر شرکتهاى خارجى وارد بازار چين شوند ( بعد از ورود چين به WTO ) آنها هنگ کنگ را پنجره اى به عنوان ميزبان وب سايتهاشان و تنظيم بانکهاى اطلاعاتيشان مى دانند. • طرح CEPA
طى طرح CEPA ، شرکتهاى هنگ کنگى مى توانند شرکتهاى مشارکتى در چين تاسيس کرده که از اول اکتبر 2003 شروع که 5 نوع سرويس ارزش افزوده از راه دور را بدون محدوديت جغرافيايى ارائه کنند اين سرويسها شامل : سرويس مرکز اطلاعات اينترنت، سرويس حفظ و ارسال ، مراکز تماس اينترنتى، مرکز دستيابى به اينترنت وارائه کردن مطالب اينترنتى مى باشد. در ضمن شرکتهاى هنگ کنگى فقط مى توانند تا 50% شراکت داشته باشند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:50 AM

January 13, 2005

مديريت زنجيره تامين

نويسنده: مريم وجدى وحيد*

مديريت زنجيره تامين

31 خرداد 1383 - 1- چكيده
امروزه مديريت زنجيره تامين به عنوان يكى از مبانى زير ساختى پياده‌سازى كسب و كار الكترونيك در دنيا مطرح است. هدف اين مقاله مرورى بر مباحث مديريت زنجيره تامين است و در آن پس از بيان مفاهيم آن، ارتباط آن با تجارت الكترونيك و به طور كلى نقش آن در فناورى اطلاعات مورد بررسى قرار گرفته است. اين مقاله سعى دارد تا با روشن كردن مفاهيم اصلى مديريت زنجيره تامين جايگاه آن را در توسعه فناورى اطلاعات به ويژه تجارت الكترونيك تبيين كند.

2- مقدمه
در رقابت‌هاى جهانى موجود در عصر حاضر، بايد محصولات متنوع را با توجه به درخواست مشترى، در دسترس وى قرار داد. خواست مشترى بر كيفيت بالا و خدمت رسانى سريع، موجب افزايش فشارهايى شده است كه قبلاً وجود نداشته است، در نتيجه شركت‌ها بيش از اين نمى‌توانند به تنهايى از عهده تمامى كارها برآيند. در بازار رقابتى موجود، بنگاه‌هاى اقتصادى و توليدى علاوه بر پرداختن به سازمان و منابع داخلى، خود را به مديريت و نظارت بر منابع و اركان مرتبط خارج از سازمان نيازمند يافته‌اند. علت اين امر در واقع دستيابى به مزيت يا مزاياى رقابتى با هدف كسب سهم بيشترى از بازار است. بر اين اساس، فعاليت‌هاى نظير برنامه ريزى عرضه و تقاضا، تهيه مواد، توليد و برنامه ريزى محصول، خدمت نگهدارى كالا، كنترل موجودى، توزيع ، تحويل و خدمت به مشترى كه قبلا همگى در سطح شركت انجام مى شده اينك به سطح زنجيره عرضه انتقال پيدا كرده است. مسئله كليدى در يك زنجيره تامين، مديريت و كنترل هماهنگ تمامى اين فعاليت‌ها است. مديريت زنجيره تامين ( SCM ) پديده‌اى است كه اين كار را به طريقى انجام مى‌دهد كه مشتريان بتوانند خدمت قابل اطمينان و سريع را با محصولات با كيفيت در حداقل هزينه دريافت كنند.

در حالت كلى زنجيره تامين از دو يا چند سازمان تشكيل مى‌شود كه رسماً از يكديگر جدا هستند و به وسيله جريان‌هاى مواد، اطلاعات و جريان‌هاى مالى به يكديگر مربوط مى‌شوند. اين سازمان‌ها مى‌توانند بنگاه‌هايى باشند كه مواد اوليه، قطعات، محصول نهايى و يا خدماتى چون توزيع، انبارش، عمده فروشى و خرده فروشى توليد مى‌كنند. حتى خود مصرف كننده نهايى را نيز مى‌توان يكى از اين سازمان‌ها در نظر گرفت.

3- تاريخچه مديريت زنجيره تامين
در دو دهه 60 و 70 ميلادى، سازمان‌ها براى افزايش توان رقابتى خود تلاش مى‌كردند تا با استاندارد سازى و بهبود فرايندهاى داخلى خود محصولى با كيفيت بهتر و هزينه كمتر توليد كنند. در آن زمان تفكر غالب اين بود كه مهندسى و طراحى قوى و نيز عمليات توليد منسجم و هماهنگ، پيش‌نياز دستيابى به خواسته‌هاى بازار و درنتيجه كسب سهم بازار بيشترى است. به همين دليل سازمان‌ها تمام تلاش خود را بر افزايش كارايى معطوف مى‌كردند.
در دهه 80 ميلادى با افزايش تنوع در الگوهاى مورد انتظار مشتريان، سازمان‌ها به طور فزاينده اى به افزايش انعطاف پذيرش در خطوط توليد و توسعه محصولات جديد براى ارضاى نيازهاى مشتريان علاقه مند شدند. در دهه 90 ميلادى، به همراه بهبود در فرايندهاى توليد و به كارگيرى الگوهاى مهندسى مجدد، مديران بسيارى از صنايع دريافتند كه براى ادامه حضور در بازار تنها بهبود فرايندهاى داخلى و انعطاف پذيرى در توانايى‌هاى شـــــركت كافى نيست، بلكه تامين كنندگان قطعات و مواد نيز بايد موادى با بهترين كيفيت و كمترين هزينه توليد كنند و توزيع كنندگان محصولات نيز بايد ارتباط نزديكى با سياست‌هاى توسعه بازار توليد كننده داشته باشند. با چنين نگرشى، رويكردهاى زنجيره تامين و مديريت آن پا به عرصه وجود نهاد. از طرف ديگر با توسعه سريع فناورى اطلاعات در سال‌هاى اخير و كاربرد وسيع آن در مديريت زنجيره تامين، بسيارى از فعاليت‌هاى اساسى مديريت زنجيره با روش‌هاى جديد درحال انجام است.

4- تعريف مديريت زنجيره تامين
تعاريف مختصر و جامعى كه مى توان از زنجيره تامين و مديريت زنجيره تامين ارايه داد، عبارت‌اند از:
زنجيره تامين: زنجيره تامين بر تمام فعاليت‌هاى مرتبط با جريان و تبديل كالاها از مرحله ماده خام (استخراج ) تا تحويل به مصرف كننده نهايى و نيز جريان‌هاى اطلاعاتى مرتبط با آنها مشتمل مى‌شود. به طور كلى، زنجيره تامين زنجيره‌اى است كه همه فعاليت‌هاى مرتبط با جريان كالا و تبديل مواد، از مرحله تهيه ماده اوليه تا مرحله تحويل كالاى نهايى به مصرف كننده را شامل مى شود. درباره‌ى جريان كالا دو جريان ديگر كه يكى جريان اطلاعات و ديگرى جريان منابع مالى و اعتبارات است نيز حضور دارد. (LAUDON & LAUDON 2002)
مديريت زنجيره تامين : مديريت زنجيره تامين بر يكپارچه سازى فعاليت‌هاى زنجيره تامين و نيز جريان‌هاى اطلاعاتى مرتبط با آنها از طريق بهبود در روابط زنجيره ، براى دستيابى به مزيت رقابتى قابل اتكا و مستدام مشتمل مى‌شود. بنابراين، مديريت زنجيره تامين عبارت است از فرايند يكپارچه سازى فعاليت‌هاى زنجيره تامين و نيز جريان‌هاى اطلاعاتى مرتبط با آن، از طريق بهبود و هماهنگ سازى فعاليت‌ها در زنجيره تامين تــــوليد و عرضه محصول (LAUDON&LAUDON 2002).
بنابراين براى بررسى يك سازمان منحصر به فرد در چارچوب اين تعاريف، بايد هر دو شبكه تامين كنندگان و كانال‌هاى توزيع در نظر گرفته شوند. تعريف ارايه شده براى زنجيره تامين، موضوعات مديريت سيستم‌هاى اطلاعات، منبع‌يابى و تداركات، زمان‌بندى توليد، پردازش سفارشات، مديريت موجودى، انباردارى و خدمت به مشترى را در بر مى‌گيرد.
براى مديريت موثر زنجيره تامين ضرورى است كه تامين كنندگان و مشتريان با يكديگر و در يك روش هماهنگ و با شراكت و ارتباطات اطلاعاتى و گفت و گو با يكديگر كار كنند. اين امر يعنى جريان سريع اطلاعات در ميان مشتريان و عرضه كنندگان، مراكز توزيع و سيستم‌هاى حمل و نقل كه بعضى از شركت‌‌ها را قادر مى سازد كه زنجيره‌هاى عرضه بسياركارايى را ايجاد كنند. عرضه‌كنندگان و مشتريان بايد اهداف يكسان داشته باشند. عرضه‌كنندگان و مشتريان بايد اعتماد متقابل داشته باشند. مشتريان در زمينه كيفيت محصولات و خدمات به تامين‌كنندگان خود اعتماد مى‌كنند.
علاوه بر آن عرضه‌كنندگان و مشتريان بايد در طراحى زنجيره تامين براى دستيابى به اهداف مشترك‌ و تسهيل ارتباطات و جريان اطلاعات با يكديگر شريك شوند. بعضى شركت‌ها كوشش مى‌كنند تا كنترل زنجيره تامين خود را با كنترل عمومى عمودى – با استفاده از مالكيت و يكپارچگى تمام اجزاى مختلف در امتداد زنجيره تامين از تهيه مواد و خدمات تا تحويل محصول نهايى و خدمت به مشترى به دست آورند. اما حتى با اين نوع ساختار سازمانى، فعاليت‌هاى مختلف و واحدهاى عملياتى ممكن است ناهماهنگ باشد. ساختار سازمانى شركت بايد بر هماهنگى فعاليت‌هاى مختلف براى دستيابى به اهداف كلى شركت تمركز كند.
5- پنج عملكرد براى مديريت در برابر چالش هاى زنجيره تامين:
بسيارى از تكنولوژى‌ها و ابزارها در بهبود راهكارهاى زنجيره تامين مورد استفاده قرار مى‌گيرد. دامنه پياده‌سازى تكنولوژى، راه‌هاى جديدى را براى تغيير ساختار سازمانى از تكنولوژى سخت‌افزار به تكنولوژى نرم‌افزار و اطلاعات براى سازماندهى مى‌گذارد. براى رسيدن به كارايى و اثربخشى در مديريت زنجيره تامين پنج عملكرد را براى مديريت تفكيك كرده‌ايم كه اين پنج وظيفه تا اندازه‌اى عاملى براى سازماندهى است.
مهارت و اثربخشى مديريت زنجيره تامين به صلاحيت و درستى اين پنج عملكرد وابسته خواهد بود. شكل 1 پنج عملكرد را نشان مى دهد.

شكل 1. پنج عملكرد براى مديريت زنجيره تامين

عملكرد1: ساختار شركاى زنجيره تامين:
طراحى زنجيره تامين بر اساس كارايى كه بر روى عوامل استراتژيك و با توجه و نيازمندى‌هاى مشترى براى طراحى زنجيره تامين است، پايه‌ريزى شده‌ است، به طورى‌كه محدوده محصولات موجود، سرويس‌ها، محصولات جديد يا بخش مشتريان را پوشش مى‌دهد. بر پايه آگاهى از محصول نهايى در زنجيره تامين پايه‌ريزى مى‌شود. اين به اين مفهوم است كه در دوره طولانى، كيفيت محصولات براى ادامه رقابت، بايد توسعه و بهبود بيابد. همچنين يكپارچگى زنجيره تامين، ميزان رقابت‌پذيرى سازمان را تعيين خواهدكرد .

عملكرد 2: پياده سازى ارتباطات مشاركتى:
اين بخش به انواع مشاركت‌هاى ضرورى براى شركت اشاره مى‌كند. اين عملكرد ارتباطات زنجيره تامين را به مشاركت با عوامل خارج از شركت گسترش مى‌دهد. هر تغييرى در زنجيره تامين بايد به اطلاع شركا برسد و در كل زنجيره پياده شود.
در اين قسمت عمليات پشتيبان فرآيندهاى زنجيره تامين بيان مى شوند.
• سازماندهى تغييرات و نقش عملكردها در تغييرات زنجيره تامين
• فرآيند مشاركتى براى طراحى مجدد زنجيره تامين
• اجراى ارزيابى ها و نقش آنها
• جايگاه عملكرد مديريت زنجيره تامين درون شركت

عملكرد 3 : طراحى زنجيره تامين براى سود دهى استراتژيك:
مديريت زنجيره تامين، مشاركت موثر عوامل خارج از شركت را ايجاب مى‌كند. اما ارتباط هر شركت با شركت‌هاى خارج از آن بسيار مشكل‌زا است. در مورد شركاءدقت به موارد زير ضرورى است:
• مركز رقابت: هدف مديريت زنجيره تامين و انتخاب شركا چه تاثيرى بر اهداف رقابتى دارد؟
• انگيزه شركا
• ساختار شركا

عملكرد 4 : اطلاعات مديريت زنجيره تامين
نقش سيستم‌هاى اطلاعاتى را در اصلاح زنجيره تامين نبايد ناديده گرفت. اين بخش نقش تكنولوژى را در اصلاح زنجيره تامين نشان مى دهد. تغييرات سيستمى بايد تغييرات ( اصلاح ) فرآيندها و استراتژى شركت تحت الشعاع قرار دهد.
• عناصر سيستم زنجيره تامين
• نوآورى تكنولوژيكى
• استفاده از وابسته هاى نرم افزارى
• مشكلات موجود در مراحل پياده سازى

عملكرد 5: كاهش هزينه زنجيره تامين:
شاخص اصلى بهبودى زنجيره تامين، كاهش هزينه است. اين كوشش‌ها براى استراتژى‌ها و سياست‌هاى كارايى انجام مى شود. پنج دليل اصلى هزينه زايى عبارت‌اند از:
• عدم وضوح فرآيند زنجيره تامين
• تغييرات رويه هاى داخلى و خارجى شركت
• ضعف موجود در طراحى توليد
• وجود اطلاعات ناقص براى تصميم گيرى
• ضعف حلقه هاى زنجيره در ارتباط ميان شركا زنجيره تامين

6- طرح كلى يك زنجيره تامين :
به طور كلى زنجيره‌تامين، زنجيره‌اى است كه همه فعاليت‌هاى مرتبط با جريان كالا و تبديل مواد، از مرحله تهيه ماده اوليه تا مرحله تحويل كالاى نهايى به مصرف كننده را شامل مى‌شود. در ارتباط با جريان كالا دو جريان ديگر كه يكى جريان اطلاعات و ديگرى جريان منابع مالى و اعتبارات است نيز حضور دارد.

محققان و نويسندگان مختلف ، نگرش‌ها و تعاريف متفاوتى را از زنجيره تامين ارايه كرده اند. برخى زنجيره تامين را در روابط ميان خريدار و فروشنده محدود كرده اند، كه چنين نگرشى تنها بر عمليات خريد رده اول در يك سازمان تمركز دارد. گروه ديگرى به زنجيره تامين ديد وسيع‌ترى داده و آن را شامل تمام سرچشمه‌هاى تامين (پايگاه‌هاى تامين) براى سازمان مى دانند. با اين تعريف ، زنجيره تامين شامل تمام تامين كنندگان رده اول ، دوم ، سوم ... خواهد بود. چنين نگرشى به زنجيره تامين ، تنها به تحليل شبكه تامين خواهد پرداخت . ديد سوم ، نگرش زنجيره ارزش <پورتر> است كه در آن زنجيره تامين شامل تمام فعاليت‌هاى مورد نياز براى ارايه يك محصول يا خدمت به مشترى نهايى است. با نگرش ياد شده به زنجيره تامين ، توابع ساخت و توزيع به عنوان بخشى از جريان كالا و خدمات به زنجيره اضافه مى‌شود. در واقع بااين ديد، زنجيره تامين شامل سه حوزه تدارك ، توليد و توزيع است .

7- فرآيندهاى اصلى
مديريت زنجيره تامين داراى سه فرآيند عمده است كه عبارت‌اند از:
1) مديريت اطلاعات
2)مديريت لجستيك
3) مديريت روابط (RELATIONSHIP MANAGEMENT) .
مديريت اطلاعات : امروزه نقش ، اهميت و جايگاه اطلاعات براى همگان بديهى است . گردش مناسب و انتقال صحيح اطلاعات باعث مى‌شود تا فرآيندها موثرتر و كاراترگشته و مديريت آنها آسان‌تر گردد. در بحث زنجيره تامين - همان طور كه گفته شد -اهميت موضوع هماهنگى در فعاليتها، بسيار حائز اهميت است . اين نكته در بحث مديريت اطلاعات در زنجيره ، مديريت سيستم هاى اطلاعاتى و انتقال اطلاعات نيز صحت دارد. مديريت اطلاعات هماهنگ و مناسب ميان شركا باعث خواهد شد تا تاثيرات فزاينده‌اى در سرعت، دقت، كيفيت و جنبه‌هاى ديگر وجود داشته باشد. مديريت صحيح اطلاعات موجب هماهنگى بيشتر در زنجيره خواهد شد. به طور كلى در زنجيره تامين ، مديريت اطلاعات در بخش‌هاى مختلفى تاثيرگذار خواهد بود كه برخى از آنهاعبارت‌اند از:
مديريت لجستيك (انتقال، جابجايى، پردازش و دسترسى به اطلاعات لجستيكى براى يكپارچه سازى فرآيندهاى حمل و نقل، سفارش دهى و ساخت، تغييرات سفارش، زمان‌بندى توليد، برنامه هاى لجستيك و عمليات انباردارى) ; تبادل و پردازش داده‌ها ميان شركا (مانند تبادل و پردازش اطلاعات فنى، سفارشات و...) : جمع آورى و پردازش اطلاعات براى تحليل فرآيند منبع يابى و ارزيابى ، انتخاب و توسعه تامين كنندگان ; جمع آورى و پردازش اطلاعات عرضه و تقاضا و ... براى پيش بينى روند بازار و شرايط آينده عرضه و تقاضا; ايجاد و بهبود روابط بين شركا.
چنانچه پيداست ، مديريت اطلاعات و مجموعه سيستم هاى اطلاعاتى زنجيره تامين مى تواند برروى بسيارى از تصميم‌گيرى‌هاى داخلى بخش‌هاى مختلف زنجيره تامين موثر باشد كه اين موضوع حاكى از اهميت بالاى اين مولفه در مديريت زنجيره تامين است .
مديريت لجستيك : در تحليل سيستم هاى توليدى (مانند صنعت خودرو)، موضوع لجستيك بخش فيزيكى زنجيره تامين را در بر مى گيرد. اين بخش كه كليه فعاليت‌هاى فيزيكى از مرحله تهيه ماده خام تا محصول نهايى شامل فعاليت‌هاى حمل و نقل، انباردارى، زمان‌بندى توليد و... را شامل مى شود، بخش نسبتا بزرگى از فعاليت‌هاى زنجيره تامين را به خود اختصاص مى دهد. در واقع ، محدوده لجستيك تنها جريان مواد و كالا نبوده بلكه محور فعاليت‌هاى زنجيره تامين است كه روابط و اطلاعات ، ابزارهاى پشتيبان آن براى بهبود در فعاليت‌ها هستند.
مديريت روابط: فاكتورى كه ما را به سمت فرجام بحث راهنمايى مى كند و شايد مهم‌ترين بخش مديريت زنجيره تامين به خاطر ساخت و فرم آن باشد، مديريت روابط در زنجيره تامين است. مديريت روابط، تاثير شگرفى بر همه زمينه‌هاى زنجيره تامين و همچنين سطح عملكرد آن دارد. در بسيارى از موارد، سيستم هاى اطلاعاتى و تكنولوژى مورد نياز براى فعاليت‌هاى مديريت زنجيره تامين به سهولت در دسترس بوده و مى توانند دريك دوره زمانى نسبتا كوتاه تكميل و به كار گمارده شوند. اما بسيارى از شكست‌هاى آغازين در زنجيره تامين ، معلول انتقال ضعيف انتظارات و توقعات و نتيجه رفتارهايى است كه بين طرفين درگير در زنجيره به وقوع مى پيوندد. علاوه بر اين ، مهم‌ترين فاكتور براى مديريت موفق زنجيره تامين ، ارتباط مطمئن ميان شركا در زنجيره است، به گونه اى كه شركا اعتماد متقابل به قابليت‌ها و عمليات يكديگر داشته باشند. كوتاه سخن اين كه درتوسعه هر زنجيره تامين يكپارچه، توسعه اطمينان و اعتماد در ميان شركا و طرح قابليت اطمينان براى آنها از عناصر بحرانى و مهم براى نيل به موفقيت است.
8- فازهاى اصلى مديريت زنجيره تامين
فاز اول: طراحى مفهومى

فاز اول نشان دهنده استراتژى ساخت است. در اين فاز نحوه اداره سازمان با ايجاد يك تصوير براى آينده و ايجاد يك ساختار براى پياده سازى تعيين مى‌شود. براى فرآيندهاى فاز اول يك مدل ويژه سازمان لازم است كه از يك سازمان به سازمان ديگر متفاوت است. بحث اصلى در اين فاز طراحى مفهومى است كه مدركى براى تصديق و اجراى دو فاز ديگر است. هدف از اجراى اين فاز درك جزييات مربوط به هزينه‌ها و شناخت سيستم و منافع پياده‌سازى SCM است.

فاز دوم: طراحى جزييات و تست
اين فاز همان‌طور كه در شكل پايين مشاهده مى‌‌شود مى تواند همزمان با فاز اول و سوم اجرا شود. يعنى جزييات طراحى مى‌شود و به طور هم‌زمان راه حل‌ها در دنياى واقعى تست مى‌شوند. در اين فاز ايجاد تغييرات در ساختار سازمان و در نظر گرفتن آنها براى پياده‌سازى در سيستم به منظور پشتيبانى طراحى زنجيره تامين جديد توصيه مى‌شود.

فاز سوم: پياده سازى
در اين فاز در ادامه فاز دوم، زمان‌بندى پياده سازى دوره هاى بلندمدت عمليات و تغييرات در سيستم به منظور ايجاد تسهيلات انجام مى‌گردد. شكل زير فازهاى اصلى مديريت زنجيره تامين را نشان مى‌دهد:

شكل 2. فازهاى اصلى SCM

9- فن‌آورى اطلاعات و مديريت زنجيره تامين
مديريت زنجيره تامين بر رويكردى مشترى محور استوار است. بر اين اساس، ارتباط به موقع و كامل بين همه عناصر زنجيره براى اطلاع از نيازهاى مشترى و ميزان تامين نيازها از ضروريات زنجيره است. براى تسهيل جريان اطلاعات و مديريت دقيق آن بسترى مناسبى از نرم افزارها و سيستم هاى اطلاعاتى يكپارچه و شبكه هاى اكسترانت و اينترانت موردنياز است. با به كارگيرى تجارت الكترونيك در زنجيره تامين نيز مى توان بر مبناى مدل)7 B2B و8 (B2E براى توصيف عمليات خريد، فروش و مبادله محصــولات، خدمات و اطلاعات ازطريق شبكه هاى رايانه اى و به خصوص اينترنت با تامين كنندگان بهره جست.
برمبناى مدلى ديگر از تجارت الكترونيك (E-COMMERCE) شركت‌هاى همكار در يك زمينه به خصوص از طريق شبكه‌هاى الكترونيكى نيز مى توانند به همكارى و اشتراك مساعى بپردازند. چنين همكارى اغلب بين شركت‌هــاى حاضر در يك زنجيره تامين اتفاق مى افتد.

با توجه به اين كه بر مبناى مدلى ديگر از تجارت الكترونيك (E-COMMERCE) شركت‌هاى همكار در يك زمينه به خصوص ازطريق شبكه هاى الكترونيكى نيز مى توانند به همكارى و اشتراك مساعى بپردازند. چنين همكارى اغلب بين شركت‌هــاى حاضر در يك زنجيره تامين اتفاق مى افتد.
با به كارگيرى تجارت الكترونيك در زنجيره تامين نيز مى توان برمبناى مدل )7 B2B و8 (B2E براى توصيف عمليات خريد، فروش و مبادله محصــولات، خدمات و اطلاعات از طريق شبكه هاى رايانه اى و به خصوص اينترنت با تامين كنندگان بهره جست.

10 - بررسى جايگاه مديريت زنجيره تامين در پياده‌سازى تجارت الكترونيك
به طور كلى مديريت زنجيره تامين يكى از زيرساختارهاى پياده‌سازى تجارت الكترونيك است. از ديد صنعتى تجارت الكترونيكى بين بنگاه‌ها عمدتا در صنايعى رخ مى‌دهد كه زنجيره تامين در آن جا شكل گرفته باشد. يك توليدكننده همواره عاملى است كه در وسط فرآيند فعاليت اقتصادى قرار دارد. توليد كننده خود خريدار كالا از تامين كنندگان خود و فروشنده كالايى جديد به خريداران خود است. چون فروشنده به توليدكننده خود تامين كنندگان دارد و ضمنا خريدار كالا نيز ممكن است خود مشتريانى داشته باشد، ما با زنجيره‌اى از بنگاه‌ها روبه‌رو هستيم كه هر كدام هم خريدار و هم فروشنده هستند. اين مجموعه شبيه به زنجير است، زيرا همه به هم وابسته هستند. با مديريت درست زنجيره تامين همه عناصر موجود در زنجيره منتفع شده و ضمنا با ارايه كالاى مرغوب و ارزان جامعه را نيز منتفع مى‌كند. از همين رو يكى از مسايل مهم صنايع در كشورهاى پيش رفته «مديريت زنجيره تامين يا (SCM)، Supply Chain Management» است. يكى از عناصر مهم مديريت زنجيره خودكارسازى امر خريد و فروش بين اعضاى زنجيره است. اين امر آن قدر مهم و حياتى است كه حتى قبل از ظهور اينترنت صنايع خودروسازى و هوافضايى كه بزرگ‌ترين و پيچيده‌ترين زنجيره‌هاى تامين را دارند، خود با صرف هزينه گزاف اقدام به ايجاد شبكه كرده بودند.
در حال حاضر استاندارد EDI كه امروزه با كمك سازمان جهانى استانداردها در محيط اينترنت و بر بستر استاندارد XML براى امور تجارى در حال كاربرد است، از همين شبكه‌هاى اختصاصى به وجود آمده است. براى مديريت زنجيره تامين پايدارى زنجيره يك عامل مهم و حياتى است و معمولا اشكال پيچيده، كارآمد و پايدار مديريت زنجيره تامين تنها در بنگاه‌هاى بزرگ اقتصادى ديده مى‌شود. درحال حاضر در كشور ما در اين زمينه كمبود جدى وجود دارد. از يك طرف تعداد بنگاه‌هاى اقتصادى بزرگ در كشور بسيار كم است. اين تعداد كم هم عمدتا ماهيتى غيرخصوصى دارند و بنابراين خود با مشكل پايدارى در مواجه با مسايل سياسى روبه‌رو هستند. از طرف ديگر تعداد زنجيره‌هاى تامين پايدار نيز در كشور بسيار كم است. دو نمونه قابل ذكر را مى‌توان صنعت خودرو و صنايع نفت كشور دانست.

11- موانع پياده‌سازيSCM
تحولات اخير كشورهاى منطقه آنها را ناگزير به به كارگيرى محصولات مديريت زنجيره تامين در حوزه صنايع مى‌سازد. پيش بينى مى‌شود در سال‌هاى آتى فرصت‌هاى بازار محصول مناسبى براى محصول در منطقه وجود داشته باشد كه فرصت‌هاى صادرات محصول را فراهم مى‌نمايد. اين كشورها به عنوان بازار بالقوه محصول در نظر گرفته مى‌شود.

به لحاظ ساختارى مهم‌ترين مشكلى كه زنجيره تامين با آن روبروست، مشكل تعدد مراكز تصميم گيرى براى توليد، تبديل و جريان كالاست. اين امر موجب تشديد نوسانات تقاضا در طول زنجيره مى شود. هرچقدر از انتهاى زنجيره به سمت ابتداى زنجيره (اولين تامين كننده) حركت كنيد، نوسانات تقاضا تشديد مى‌گردد. اين پديده به اثر «شلاق چرمى» معروف است. اين مسئله موجب افزايش موجودى انباشته ميان اعضاى زنجيره مى‌گردد كه در نهايت باعث بالارفتن هزينه و قيمت نهايى كالا شده و قدرت رقابت زنجيره كاهش خواهديافت.
فناورى اطلاعات ازطريق تسهيل و تسريع تبادل اطلاعات سازمان و تامين كنندگان را قادر به آگاهى و تامين به موقع احتياجات يكديگر مى كنــد و اين فلسفه توليد به هنگام را قوت مى‌بخشد.

در سال‌هاى آتى با رشد صنعت نرم‌افزار پيش‌بينى مى‌شود كه محصول در صنايع مونتاژ قطعات الكترونيكى نيز نفوذ داشته باشد. پيش‌بينى مى‌شود با رواج به كارگيرى فن‌آورى اطلاعات در صنايع و آماده‌سازى زيرساختارها و بستر پياده‌سازى سيستم‌هاى مديريت زنجيره تامين حجم تقاضا به طور فزاينده‌اى افزايش يابد.

12- بررسى تكنولوژى توليد و برآورد نحوه تامين دانش فنى مورد نياز
مديريت زنجيره تامين بر رويكردى مشترى محور استوار است. لذا ارتباط به موقع و كامل بين همه عناصر زنجيره براى اطلاع از نيازهاى مشترى و ميزان تامين نيازها از ضروريات زنجيره است. براى تسهيل جريان اطلاعات و مديريت دقيق آن بسترى مناسبى از نرم افزارها و سيستم‌هاى اطلاعاتى يكپارچه و شبكه هاى اكسترانت و اينترانت موردنياز است.

توليد محصول در داخل يا ارايه محصول از طريق مشاركت‌ با توليدكنندگان محصول در دنيا امكان‌پذير است. كه در در صورت توليد داخل منجر به توسعه صنعت نرم‌افزار در شركت خواهد شد و در صورتى كه محصول توسط با سرمايه‌گذارى مشترك با شركت خارجى امكان به كارگيرى نيروى متخصص در زمينه بازاريابى و خدمات پشتيبانى نصب و راه‌اندازى محصول و خدمات پس از فروش را خواهد داشت.

13- نتيجه‌گيرى
امروزه شركت‌ها دريافته‌اند كه بخش خريد آنها مى تواند به طور فزاينده اى در افزايش كارآيى و اثربخشى آنها موثر باشد و به همين دليل شيوه هاى خريدشان را تغيير داده و سعى كرده اند تا براى كالاهاى خود شيوه خريد مناسب را بيابند، به طورى كه بخش خريد بتواند به عنوان جزيى از شركت ، اهداف استراتژيك خريد شركت را برآورده سازد. براى تحقق اين امر هر خريد استراتژيك نيازمند يك برنامه ريزى استراتژيك خريد براى كالاى مورد نظر است كه معناى اين سخن برقرارى يك رابطه استراتژيك با تامين كنندگان است .آشكار است كه براى تحقق اين امر بايد با تامين كنندگان شايسته و منتخب روابط استراتژيك برقرار كرد تا در جوار همكارى استراتژيك با آنها بتوان به مزاياى رقابتى مورد نظر دست يافت.
براى رسيدن به اهداف توسعه فناورى اطلاعات و كسب و كار الكترونيك پياده‌سازى راه‌حل‌هاى مديريت زنجيره تامين در سازمان‌ها به عنوان ضرورت اساسى مطرح مى‌گردد. توصيه مى‌شود صنايعى نظير صنعت خودرو، صنايع هوا فضا و پتروشيمى كه تامين‌كنندگان زيادى دارند از اين راه‌حل براى بهبود ارتباط با تامين‌كنندگان بهره‌گيرند.

مراجع:
1. سايت اطلاع رسانى ثناراى
2. جزوه مديريت زنجيره تامين سازه‌گستر سايپا
3. سايت اطلاع‌رسانى مجله تدبير
4. طهمورث ، سهراب ، ضرورت برنامه ريزى منابع توليدى " MRPII" .
5. مجله روش شماره 61 دى ماه 79 .
6. فلاح آبكنارى ، اسماعيل . سيستم برنامه ريزى تامين مواد " MRP ".
7. مجله روش شماره 61 دى ماه 79 .
8. سعيدى كيا ، على اكبر – مظفرى فرد ، جعفر و رياضى درسى ، محمد طاهر .
9. مديريت زنجيره تامين ، مجله روش شماره 61 دى ماه 79 .
10. Supply chain Management . James , B . A yers – 2000
11. معصومى ، مريم . ارايه راهكار براى طراحى يك سيستم تامين قطعه در چهارچوب مديريت زنجيره تامين . پايان نامه كارشناسى ارشد . دكتر غضنفرى – دانشگاه علم و صنعت .
12. منبع يابى استراتژيك در مديريت تامين كنندگان ، پايان نامه كارشناسى ارشد .
13. دانشگاه علم و صنعت
14. مديريت زنجيره تامين ، پايان نامه كارشناسى ارشد ، دانشگاه اميركبير – 1380 .
17-K . Herbst – D . Garcia – J . Wells Bringing together the links in the supply chain
18 - F. M . Read . & K . Walsh Technological Innovation Within the supply chain
* دانشجوى كارشناسى ارشد فناورى اطلاعات
كارشناس شركت مگفا
m-vajdi@magfa.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:53 AM

January 13, 2005

نگاهى به لايحه حريم خصوصى

23 خرداد 1383 - خبرگزارى جمهورى اسلامى - لايحه "حريم خصوصى " که به تصويب کميسيون لوايح دولت رسيده است ، استفاده از روشهاى غيرقانونى و غيرمتعارف براى جمع آورى اطلاعات شخصى افراد را ممنوع مى کند.

به گزارش روز چهارشنبه پايگاه اطلاع رسانى سخنگوى دولت ، بر پايه
اين لايحه "جمع آورى اطلاعات شخصى بايد از خود اشخاص صورت گيرد واستفاده از
وسايل و روشهاى غيرقانونى وغير متعارف در اين امر ممنوع است ".

همچنين بر اساس اين لايحه ،کليه موسسات عمومى و موسسات خصوصى که خدمات
عمومى ارايه مى دهند، نبايد اطلاعات شخصى افراد را جمع آورى کنند مگر اينکه
آن اطلاعات براى انجام وظايف و فعاليتهاى قانونى و سازمانى آنها به طور
متعارف ضرورت داشته باشد.

لايحه حريم خصوصى داراى هفت فصل و۸۳ ماده است که پيش از اين فصلهاى
اول و دوم آن منتشر شده بود.

"تعاريف و کليات "،" حريم خصوصى جسمانى "،" حريم خصوصى اماکن و منازل"
،" حريم خصوصى در محل کار "،" حريم خصوصى اطلاعات ، " حريم خصوصى ارتباطات "
و" مسووليت هاى ناشى از نقض حريم خصوصى " هفت فصل لايحه حريم خصوصى را تشکيل
مى دهد.
پايگاه اطلاع رسانى سخنگوى دولت ، جزييات بيشترى از اين لايحه را شامل
فصل هاى سوم ، چهارم و پنجم ( مواد۱۷ تا۵۷ اين لايحه ) به شرح ذيل
منتشر کرد.
فصل سوم : حريم خصوصى اماکن و منازل ********************************
ماده ۱۷ - اماکن خصوصى ومنازل مصون از تعرضند ،هيچ کس نمى تواند
بدون رضايت مالک متصرف قانونى وارد مکان خصوصى يا منزل او شود.
ماده ۱۸ - کار گذاشتن هر نوع وسيله پايش در اماکن خصوصى و منازل
افراد بدون رضايت قانونى آنجا ممنوع است .

ماده ۱۹ - استفاده از هر نوع وسيله پايش مستقر خواه در اماکن خصوصى
و منازل يا ساير اماکن جهت نظارت بر فردى که در ملک خصوصى يا منزل خود
به سر مى برد در صورتى که بدون رضايت او صورت گرفته باشد ممنوع است .

ماده ۲۰ - مجوز ورود به اماکن خصوصى و منازل تنها در صورت وجود ظن
قوى مبنى بر ضرورت آن (از قبيل جلوگيرى از وقوع جرم يا کشف متهم ، آلات ،
ادوات و ادله جرم و يا جلوگيرى از معدوم شدن ادله مربوط ) و عدم امکان
تحقق اهداف ياد شده از ساير طرق قانونى صادر خواهد شد و علاوه بر موردى
بودن و کلى نبودن آن ، بايد مسائل ذيل در آن تصريح شده باشد : نوع اتهام ،
کيفيت و زمان ورود، اشخاص و اموالى که بايد مورد تفتيش قرار گيرند يا
دلائلى که بايد جمع آورى شوند و نشانى دقيق مکان خصوصى يا منزل.

ماد۲۱ه چنانچه حسب دلائل و اوضاع و احوال، ظن قوى به کشف متهم يا
اسباب و آلات و دلائل جرم در وسائل نقليه ، راکبان و محموله هاى آن وجود
داشته باشد، به شرط رعايت ساير تشريفات بازرسى و تفتيش در مقررات مربوط،
بازرسى و تفتيش انها منوط به کسب اجازه مخصوص مقام قضايى نيست .

ماد۲۲ه چنانچه ضابطان در اجراى دستور مقام قضائى وارد مکان خصوصى يا
منزل شوند، مکلفند در چارچوب مجوز صادره عمل کنند. عدول از آن نقض حريم
خصوصى محسوب مى گردد.

ماد۲۳ه ضابطان به هنگام ورود به اماکن خصوصى و منازل بايد اوراق
هويت خود را نشان دهند و اصل مجوز مقام قضائى را به همراه داشته باشند و
يک نسخه از آن را حسب مورد به مالک يا متصرف قانونى مکان يا منزل تحويل
دهند و رسيد آن را در جهت درج در پرونده دريافت دارند.

تبصره چنانچه مالک يا متصرف قانونى درمکان خصوصى يا منزل حضور نداشته
باشند، ضابطان مکلفند جهت دسترسى به آنان تلاش متعارف به عمل آورند. چنانچه
على رغم تلاش متعارف ، مالک يا متصرف قانونى را پيدا نکنند بايد طى
صورتجلسه اى تلاشهاى صورت گرفته را جهت درج در پرونده گزارش کرده و پس از
ورود به مکان خصوصى يا منزل يک نسخه از مجوز مذکور را به آنجا الصاق
نمايند.

ماد۲۴ه مجوزى که براى ورود به اماکن خصوصى و منازل صادر مى شود در
موارد زير بلااثر مى گردد.
يک بار اجراء شده باشد.
شخص صادر کننده مجوز يا مقام صلاحيت دار ديگرى آن را لغو کرده باشد ۱
از تاريخ صدور آن ۱۵ روز گذشته باشد ولى اجراء نشده باشد. ۲
هدفى که به خاطر آن مجوز صادر شده است منتفى گرديده باشد. ۳
ماد۲۵ه بازرسى و تفتيش اطلاعاتى که در هرنوع منبع اطلاعاتى افراد ذخير۴ه
شده است تابع مقررات حاکم بازرسى و تفتيش اماکن خصوصى و منازل خواهد بود.

فصل چهارم : حريم خصوصى در محل کار
********************************
ماده ۲۶ مديران و کارفرمايان مجاز به استفاده از نظارتهاى الکترونيکى
مگر آنکه بر مبناى دلائل متعارف ، ظن قوى مبنى بر ارتکاب فعاليتهاى ;نيستند
مجرمانه در ارتباط با محيط کار از قبيل سرقت يا تخريب اموال محل کار يا
سوء استفاده از اموال محل کار وجود داشته باشد يا اين امر براى تامين
امنيت و بهداشت محل کار يا کارکنان و مستخدمان ضرورى باشد.
تبصر۱ه استفاده از نظرات الکترونيکى در محلهاى کار در صورتى مجاز است
که روشهاى ديگرى براى تامين مقاصد اين ماده در دسترس نباشد.
تبصر۲ه منظور از نظارت الکترونيکى در اين قانون اعم است از نظارتهاى
قابل ذخيره و بدون ذخيره .

ماد۲۷ه در اجراى ماده فوق مدير و کارفرما بايد پيش از اقدام به
نظارت ، دلائل آن ، زمان نظارت ، اشخاص ، پستها، مکانهاى مورد نظر، روشها و
وسائل به کار رفته براى نظارت و اطلاعاتى که قرار است درباره آنان نظارت
شود کتبا به اطلاع آنها برساند.افرادى که نسبت به اين امر اعتراضى داشته
باشند مى توانند اعتراض خود را به مقامات موضوع ماده ۲۹() ارائه نمايند.

ماد۲۸ه تجهيزات تصويربردارى که به قصد نظارت الکترونيکى به کار
مى روند بايد کاملا قابل رويت باشد و همچنين در محلى که نظارت در آنجا صورت
مى گيرد علائمى به کار رفته باشد که به کارکنان و مستخدمان و ارباب رجوع
توجه دهد که محل تحت نظارت الکترونيکى قرار دارد. شنود و ضبط اصوات تابع
مقررات مربوط به فصل ششم اين قانون خواهد بود.

ماد۲۹ه تاييد نظارت الکترونيکى در دستگاههاى دولتى و عمومى بايد
توسط بالاترين مقام سازمانى مربوط و در شرکتها و کارگاههاى خصوصى توسط
وزارت کار و امور اجتماعى و بر طبق آئين نامه اى مشتمل بر زمان ، مکان ، شيوه
و وسائل نظارت و فعاليت مورد نظارت که به تصويب هيئت وزيران مى رسد، صورت
مى گيرد.

ماد۳۰ه اطلاعات ذخيره شده در فيلمها و نوارها و نظائر آن ظرف حداکثر
شش ماه پس از تاريخ ذخيره بايد معدوم شوند.
تبصره چگونگى نظارت بر ضبط و نگهدارى ونحوه معدوم ساختن اطلاعات ذخيره
شده به موجب آئين نامه اى خواهد بود که با رعايت اين قانون و بنابه پيشنهاد
وزارتخانه هاى کشور، کار و امور اجتماعى و صنايع و معادن به تصويب هيئت
وزيران مى رسد.
فصل پنجم حريم خصوصى اطلاعات
****************************
بند اول جمع آورى اطلاعات شخصى و نحوه استفاده و دسترسى به آنها
ماد۳۱ه کليه موسسات عمومى و موسسات خصوصى که خدمات عمومى ارائه مى دهند
نبايد اطلاعات شخصى افراد را جمع آورى کنند مگر اينکه آن اطلاعات براى انجام
وظايف و فعاليتهاى قانونى ، سازمانى آنها به طور متعارف ضرورت داشته باشد.
تبصر۱ه اطلاعات شخصى حساس تابع ماده ۴۲() مى باشد.
تبصر۲ه جمع آورى اطلاعات شخصى بايد تا آنجا که مقدور و معقول مى باشد از
خود اشخاص صورت گيرد و استفاده از وسائل و روشهاى غيرقانونى و غيرمتعارف
در اين امر ممنوع است ..
ماد۳۲ه موسسات مورد اشاره در اين بند بايد هنگام جمع آورى اطلاعات شخصى
افراد موارد زير را کتبا به اطلاع آنان برسانند :

آزادى افراد در ارائه اطلاعات يا ملزم بودن قانونى آنان به ارائه آنها
هويت موسسه جمع آورى کننده اطلاعات و چگونگى تماس با آن ۱
هر نوع قانونى که جمع آورى اطلاعات خاص را لازم مى شمارد ۲
امکان يا عدم امکان دسترسى خود فرد به اطلاعات جمع آورى شده ۳
اهداف و مقاصدى که اطلاعات به خاطر آنها جمع آورى گرديده است ۴
اشخاصى که موسسات مذکور، اطلاعات را به آنها افشاء خواهند کرد ۵
نتايجى که عدم ارائه اطلاعات ممکن است براى فرد داشته باشد. ۶
ماد۳۳ه چنانچه جمع آورى اطلاعات شخصى افراد از طريق پرسش از اشخاص ۷
ديگر انجام مى گيرد، علاوه بر لزوم رعايت مفاد بندهاى مذکور در ماده قبل،
موارد زير نيز بايد رعايت گردد :

اخذ اطلاعات کتبى باشد.
محقق صريحابه پرسش شونده اعلام نمايد که از طرف تحقيق شونده ماذون است ۱
نتايج عدم ارائه اطلاعات و يا ارائه اطلاعات کذب به او تفهيم گردد. ۲
ماده ۳۴ - موسسات ياد شده بايد اطلاعات شخصى افراد را فقط براى هدف اوليه
جمع آورى آنها به کار برند و نمى توانند جهت اهداف و مقاصد ديگرى از آنها
استفاده کنند يا آنها را در اختيار سايرين قرار دهند ، مگر اينکه :
طبق قانون ، استفاده يا در اختيار ديگران قرار دادن لازم يا مجاز باشد.
هدف ثانوى با هدف و قصد اوليه جمع آورى اطلاعات کاملا مرتبط باشد. ۱
افراد به استفاده از آن اطلاعات يا افشاى آنها رضايت داده باشند. ۲
تبصره ممنوعيت موضوع اين ماده شامل کليه افرادى که به نحوى از انحاء ۳
به اطلاعات مزبور دسترسى دارند يا از آنها مطلع شده اند نيز مى گردد و
اعمال اختيارات فوق تنها از سوى موسسات مزبور مجاز است ..
ماده ۳۵ چنانچه يک موسسه ، اطلاعات شخصى را طبق ماده فوق مورد استفاده
يا در اختيار ديگران قرار دهد بايد مراتب را در پرونده مربوط منعکس کند.
ماده ۳۶ پس از جمع آورى اطلاعات شخصى ، موسسات مربوط بايد براى حمايت از
اطلاعات جمع آورى شده و به منظور جلوگيرى از سوء استفاده از آنها، گم شدن
آنها، دسترسى غيرمجاز به آنها و تغيير يا افشاى آنها تدابير ضرورى اتخاذ
کنند.
ماده ۳۷ موسسات مورد اشاره بايد صريحا اصول حاکم برمديريت اطلاعات شخصى
نظير نوع اطلاعات شخصى اى که نگهدارى مى کنند، مقاصد و اهدافى که اطلاعات به
خاطر آن نگهدارى مى شوند، چگونگى جمع آورى اطلاعات شخصى و نگهدارى آنها و
استفاده و در اختيار قرار دادن آنها را در يک سند بيان کرده واين سند را
در دسترس افراد ذينفع قرار دهند.
ماده ۳۸ افرادى که اطلاعات شخصى آنها درموسسات مشمول اين قانون نگهدارى
مى شود حق دسترسى به اطلاعات مذکور را به نحو مورد نظر خود دارند و موسسه
مکلف به اجابت درخواست آنها مى باشد، مگر در موارد زير :
دسترسى به اطلاعات ، تهديد جدى وقريبالوقوع نسبت به حيات يا سلامتى
افراد ايجاد کند. ۱
دسترسى به اطلاعات طبق قانون ممنوع باشد.
فراهم آوردن امکان دسترسى ، به ظن قوى به کشف تحقيق ، تعقيب و رسيدگى به ۲
جرائم و مجازات مجرمان لطمه بزند. ۳
تبصره دسترسى به اطلاعات شخصى ، رايگان بوده و نسخه بردارى ازآن با هزينه
متعارف مجاز خواهد بود.
ماده ۳۹ اگر فرد اثبات کند که اطلاعات شخصى جمع آورى شده مربوط به او
نادرست يا ناقص بوده يا به روز نيستند، موسسه دارنده اطلاعات بايد حسب
مورد اطلاعات لازم را انجام داده و اطلاعات جديد را اضافه نمايد.
ماده ۴۰ اگر فرد و موسسه درباره صحت و کامل و به روز بودن اطلاعات شخصى
جمع آورى شده در موسسه ،اختلاف نظر داشته باشند، فرد مى توانداز موسسه بخواهد
تا ادعاى وى مبنى بر عدم صحت و کامل و به روز نبودن اطلاعات جمع آورى شده
راجع به وى در پرونده او منعکس شود . چنانچه اطلاعات شخصى وى در اختيار
ديگر موسسات قرار گيرد اعتراض فرد نيز بايد به آن موسسات منعکس شود.
ماده ۴۱ اگر فردى ، متقاضى دسترسى به اطلاعات شخصى خود يا اصلاح يا به
روز کردن آنها باشد، موسسه اى که اطلاعات را نگهدارى مى کند بايد :
امکان دسترسى را فراهم کرده يا دلائل رد آن را کتبا ارائه دهد.
اطلاعات شخصى را اصلاح يا به روز کرده يا دلائل موجه و قانع کننده ۱
امتناع از اصلاح يا يه روز کردن آن اطلاعات را کتباارائه دهد. ۲
دلائل تاخير درپاسخگويى به درخواست دسترسى به اطلاعات شخصى خود يا اصلاح
يا به روز کردن آنها را ظرف حداکثر۳۰ روز از زمان درخواست کتباارائه دهد۳.
تبصره در موارد مذکور در اين ماده ، متقاضى مى تواند از تصميمى که موسسه
مربوط نسبت به رد درخواست او اتخاذ مى کند به مرجع ذيصلاح اعتراض نمايد.
ماده ۴۲ موسسات ياد شده نبايد اطلاعات شخصى حساس مربوط به افراد را
جمع آورى نموده يا مورد استفاده قرار دهند ، مگر در موارد زير :
آن افراد رضايت داده باشند.
جمع آورى يا استفاده صريحا طبق قانون مجاز باشد. ۱
جمع آورى يا استفاده ، به طور متعارف براى جلوگيرى از يک تهديد شديد ۲
قريبالوقوع نسبت به حيات يا سلامتى فرد و جامعه يا کاهش اين تهديد ۳
ضرورى باشد.
جمع آورى يا استفاده براى تحقيق يا تحليل آمارى راجع به خدمات رفاهى
يا آموزشى اى که از بودجه هاى دولتى استفاده مى کنند ضرورى باشد. ۴
اطلاعات جمع آورى شده مربوط به اصل و نسب نژادى يا قومى يک فرد بوده
و به منظور کمک به خدمات رفاهى يا آموزشى برخوردار از هزينه هاى دولتى ۵
جمع آورى شده باشد.
تبصره در اجراى بندهاى ۴() و ۵() ، نام و مشخصات شناسنامه اى و ساير
مشخصاتى که به هر ترتيب منجر به شناسايى افراد مى گردد نبايد سوال شود.
بند دوم اطلاعات شخصى در فعاليتهاى رسانه اى
ماد۴۳ه افشاى امور خصوصى افراد در رسانه هاى همگانى ممنوع است مگر به
شرح مقرر در قانون
ماد۴۴ه استفاده از نام ، شباهت تصويرى و صوتى افراد در رسانه هاى همگانى
براى مقاصد تبليغاتى ، خريد و فروش هر نوع کالا و خدمات و يا به هرطرق ديگر
به قصد کسب سود، بدون رضايت آنان و با اجتماع شرايط زير ممنوع است :
در جريان استفاده از نام يا شباهت تصويرى و صوتى آن فرد، وى براى
مخاطبان رسانه شناخته شده يا قابل شناسايى باشد. ۱
نام او به گونه اى ضميمه کالا يا خدمات شده باشد که وى را براى کل
جامعه يا اجتماعى که وى در آن زندگى مى کند قابل شناسايى قرار دهد. ۲
ماده ۴۵ انتشار يا پخش تصوير يا صوت افراد که در حالتهاى غيرمتعارف
آنها تهيه شده و قصد تهيه کننده يا ناشر يا پخش کنده صرفا لطمه زدن به
شهرت ، اعتبار يا حيثيت اجتماعى يک فرد باشد ، ممنوع است .
ماده ۴۶ انتشار نام ، تصوير و ساير جزئيات زندگى ( نظير شغل، سمت ، محل
سکونت و غيره ) اشخاصى که اقدام به خودکشى کرده اند در رسانه هاى همگانى
مگر با اجازه خود آنان يا نماينده يا قائم مقام آنان و يا ;ممنوع است
به حکم مقام قضايى و يا قوانين خاص ديگر.
ماد۴۷ه انتشار نام ، تصوير و ساير جزئيات زندگى ( نظير شغل، سمت ، محل
سکونت و غيره ) اشخاصى که در نتيجه وقوع حوادث و بلاياى طبيعى يا مصنوعى
دچار آسيبهاى ناخوشايند جسمى يا روانى شده اند در رسانه هاى همگانى ، در
صورتى که انتظار متعارف نسبت به عدم انتشار آنها وجود داشته باشد ممنوع
مگر با اجازه خود آنان يا نماينده يا قائم مقام آنان . ;است
ماد۴۸ه هويت ، تصوير، محل سکونت و محل کار کودکان و زنانى که قربانى
سوء استفاده ها يا جرائم جنسى واقع شده اند نبايد در رسانه هاى همگانى
منتشر يا پخش شود.
حاضر شده اند< عدم افشاى نام خود >ماده ۴۹ افشاى هويت منابعى که با شرط
اطلاعاتى را در اختيار رسانه ها قرار دهند، بدون رضايت صريح آنان ممنوع
است .مسئوليت اعلان و انتشار اطلاعات با رسانه مربوط مى باشد.
ماده ۵۰ ورود عواملرسانه هاى همگانى به جلساتى که به صورت غيرعلنى تشکيل
مى شود و نيز انتشار اخباراين قبيل جلسات بدون رضايت مسئول آن جلسه ممنوع
است .
ماده ۵۱ فيلمبردارى يا تصويربردارى از افراد و انتشار يا پخش تصوير يا
صداى آنها به استثناى مقامات دولتى و عمومى و نيز ساخت و انتشار يا پخش
آثار غيرمجاز اشتقاقى ( ناشى از ميکس و مونتاژ و نظاير آن ) در رسانه هاى
همگانى ، بدون رضايت صاحبان تصاوير يا صوت يا اثر ممنوع است .
موضوع اين ماده اشخاصى هستند که از وظايف <مقامات دولتى يا عمومى >تبصر۱ه
و اختيارات اساسى برخوردار بوده ، نقش بسيار مهمى در اداره مسائل عمومى
يا در اداره حوادث مملکتى دارند و اعمال آنها مستقيما با منافع عمومى در
ارتباط است و يا در ديد عموم واجد چنين نقش حساسى به شمار مى آيند.رهبر،
روساى قواى سه گانه و وزراء از جمله اين اشخاصند.
تبصره ۲ استوديودهاى عکاسى و فيلمبردارى مکلفند عکسها و فيلمهاى شخصى
يا خانوادگى متقاضيان را تنها به تعداد خواسته شده و با رعايت شرايط
تهيه شده توسط متقاضى تکثير کرده و پس از تکثير نگاتيو عکسها و فيلم
اصلى را به صاحب آن عودت دهند.
ماده -۵۲ فيلمبردارى يا تصوير بردارى رسانه هاى همگانى از مشترکات عمومى
اماکن تحت تصرف اشخاص حقوقى حقوق عمومى آزاد است .فيلمبردارى يا عکسبردارى
از درون اماکن يا نهادهاى مذکور بايد با اطلاع قبلى مقامات ذيصلاح انجام
گيرد.
تبصره : فيلمبردارى يا تصوير بردارى رسانه هاى همگانى ازاماکن عمومى ادارى
حساسيت هاى خاص نظير مراکز نظامى وامنيتى تابع قوانين و مقررات خاص آنهاست .
ماده -۵۳ به هنگام فيلمبردارى يا تصوير بردارى در ادارات ، موسسات و
سازمان هائى که قبلا از مسئولان ذيصلاح آنها اجازه لازم اخذ شده است اخذ رضايت
کارمندان آنجا افرادى که درآنجا تردد مى کنند و به نحو اتفاقى و جزئى در
معرض فيلمبردارى قرار مى گيرند ضرورى نيست ، مگر آنکه مکان مذکور در زمره
مکان هاى عرفا حساس مثل بيمارستان ها ، زندانى ها ، کلانترى ها و تيمارستان
باشد که در اين صورت کسب رضايت افراد مذکور يا اولياء و سرپرستان قانونى
آنها لازم است .
تبصره : فيلمبردارى يا تصوير بردارى موضوع صدر اين ماده بايد قبلا به اطلاع
کارکنان و مستخدمان اداره ،موسسه يا سازمانى که درآنجا فيلمبردارى يا تصوير
بردارى به عمل مى آيد ، رسيده باشد.
ماده ۵۴ - فيلمبردارى يا تصويربردارى رسانه هاى همگانى ازافراد کمتر از۱۸
سال و مجانين و انتشار يا پخش آن بدون اجازه ولى يا قيم آنان ممنوع است .
ماده ۵۵ - چنانچه از حوادثى که در اماکن عمومى رخ مى دهد فيلمبردارى يا
تصوير بردارى به عمل آيد رسانه مربوط در صورتى مى تواند بدون رضايت افرادى
که از آنها فيلمبردارى يا تصويربردارى به عمل آمده تصاوير يا اعمال
وگفتار آنها را پخش يا منتشر کند که به طور متعارف اطمينان حاصل کند آن
موارد کاملا خارج از حريم خصوصى قرار دارند.
ماده ۵۶ فيلمبردارى يا تصويربردارى رسانه ها از افرادى که در يک جمع يا
اجتماع خصوصى حضور دارند بدون رضايت آن افراد ممنوع است .رسانه هاى همگانى
مى توانند از افرادى که در يک جمع يا اجتماع عمومى شرکت دارند بدون رضايت
قبلى آنهافيلمبردارى يا تصويربردارى کنند مگر در صورت هر يک از شرايط زير :
فرد خاصى صريحا مخالفت خود را با اين اعلام کرده باشد يا حضور آن فرد در
جمع يا اجتماع به گونه اى باشد که انتظار متعارف داشته باشدتصوير وى در آ۱ن
جمع يا اجتماعى بدون رضايتش منتشر يا پخش نشود.
هويت صاحب تصوير با ذکر نام يا مشخصات او معرفى شده باشد يا حضور وى
در آن تصوير به نحوى برجسته شده باشد که وى را عمدا به ديگران معرفى کند۲.
رسانه به قصد بهره بردارى از نام يا شهرت صاحب تصوير آن را منتشر يا
پخش کند. ۳
تبصره مقامات دولتى و عمومى مذکور در تبصره ۱۹()ماده ۵۱() از شمول اين
ماده مستثنا مى باشند.
ماده ۵۷ به هنگامى که براى تهيه يک برنامه سرگرمى از دوربينهاى مخفى
استفاده مى شود پس از ضبط صحنه هاى مورد نظر بايد پيش از پخش ، رضايت
افرادى که موضوع فيلمبردارى قرار گرفته اند جهت پخش اخذ شود. در صورت
عدم رضايت ، پخش مطالب مذکور ممنوع است .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:55 AM

January 13, 2005

جرايم رايانه ای:‌مقدمه‌اى بر جرم، عدالت و مجازات( بخش نخست)

نويسنده: آوستين سارات

جرايم رايانه ای:‌مقدمه‌اى بر جرم، عدالت و مجازات( بخش نخست)

7 تير 1383 - بخش مقاله آی تی ایران - ما با جرايم زندگى مى‌كنيم و مظاهر اين جرايم، زندگى ما را احاطه كرده است. اكثر ما از جرم بيزاريم و احساس مى‌كنيم كه در مقابل آن بسيار آسيب‌پذيريم اما ارتكاب يك جرم نيز مى‌تواند به همان اندازه مجذوب كننده باشد. امروزه در بيشتر شهرهاى ايالات متحده، ترس از جرم به يكى از واقعيت‌هاى انكارناپذير زندگى مردم تبديل شده است و افرادى پيدا مى‌شوند كه در مقابل واقعيات جرم واكنش صحيحى نشان نمى‌دهند.

ترس از جرم حقيقت دارد و مى‌توان آن را از گام‌هاى سريع و نگاه‌هاى پنهانى عابرينى كه در تاريكى خيابان‌ها گم مى‌شوند، احساس كرد. با وجود ترس از جرايم، ما مشتاقانه داستانهاى جنايى را در برنامه‌هاى تلويزيونى و فيلم‌ها دنبال مى‌كنيم، با كنجكاوى نسبت به اين سئوال كه “چه كسى اين كار را كرده؟” به تماشاى اين فيلم‌ها مى‌نشينيم و مشتاقيم كه بينيم جرمى اتفاق مى‌افتد، تحقيقات براى يافتن مجرم آغاز مى‌شود، مجرم به ‌پاى ميز محاكمه كشانده مى‌شود و به سزاى عمل خود مى‌رسد. حضور جرم در خيابان‌ها يادآور آسيب‌پذيرى خود ما و در معرض خطر بودن آزادى‌ها و حقوق ما است. همان‌طور كه از ديدن اجراى عدالت در داستان‌هاى جنايى تلويزيون و سينما، احساس رضايت مى‌كنيم، فرصت مى‌يابيم تا انگيزه‌هاى سياه‌ درونى خودمان را نيز بررسى كينم و از خود بپرسيم: “ آيا در ما مجرمى خفته است؟”

ترس از جرم و جذبه آن، كه هر يك از سويى ما را به خود مشغول مى‌كند ، تنها بخشى از اين داستان است. روى هم رفته جرم يك مشكل قانونى و اجتماعى بزرگ است و تنها يك مشكل روانشناختى فردى نمى‌باشد. امروزه سياستمداران، ترس ما از جرم و تمايل ما به آن را در جهت منافع سياسى خود مورد استفاده قرار مى‌دهند. نحوه واكنش ما در برابر جرم به ما كمك مى‌كند تا به اين سؤال كه ما كه هستيم، چه ارزشى داريم و تحمل‌مان تا چه اندازه است، پاسخ دهيم. آيا واكنش ما دلسوزانه است يا سخت‌گيرانه؟ آيا هدف ما متنبه كردن است يا مجازات كردن؟ اعاده حيثيت و خوشامدگويى به مجرمان براى بازگرداندن آنان به اجتماع است يا انتقام‌جويى؟ مجموعه كتاب‌هاى جرم، عدالت و مجازات با هدف بررسى اين موضوعات و طرح اين سئوال پديد آمده است كه چرا ما از جرم مى‌ترسيم و به آن تمايل داريم؟ در اين كتاب‌ها به بررسى مقاصد و انگيزه‌هاى جرم و مجرمان و واكنش ما در مقابل آن‌ها پرداخته مى‌شود و نهايتاً به وسيله واداشتن ما به تفكر درباره واكنش‌هايمان در مقابل جرم، حقايقى را درباره خود و جامعه‌اى كه در آن زندگى مى‌كنيم مى‌آموزيم.

جرم هميشه چالشى براى چيرگى بر قواعد و آزمايشى براى ارزش‌ها و تعهدهاى مردمِ مطيع قانون است. گاهى اوقات جرم، عملى چون عمل راسكلنيكوف (شخصيت اصلى داستان جنايت و مكافات) است و نمودى از عدم تمايل بعضى افراد براى زندگى مطابق قواعدى است كه به وسيله يك جامعه سازمان‌ يافته، ترسيم شده است. جرم در اين حالت، محدوديت‌هاى قانون را مشخص مى‌كند و نواقص قوانين را به ما يادآور مى‌شود. حتى گاهى اوقات درماندگى، بيش از سركشى موجبات اعمال جنايى را فراهم مى‌آورد و گاهى اوقات اعمال جنايى مجرمان، يك نياز يا آسيب شديد را نشان مى‌دهند. بنابراين مواجهه با جرم، همانند رويارويى با واقعيت‌هايى چون اختلافات اجتماعى، طبقاتى، نژادى و مسائلى چون غفلت، رهاكردن و سوءاستفاده از كودكان است، كه رفتارهاى آتى اين كودكان با ديگران بازتاب تجارب تلخ‌شان خواهد بود. گاهى جرم يا آنچه عمل مجرمانه گفته مى‌شود، تلاشى براى عدالت‌خواهى يا اعتراض به بى‌كفايتى قوانين موجود براى دستيابى به سطوح بالاتر اخلاقى مى‌باشد.
مشخص كردن دليل جرم، انگيزه‌هاى مجرمان و اينكه آيا جرم برخاسته از سركشى، درماندگى يا نياز به عدالت است، هرگز كار آسانى نيست. تنوع انگيزه‌ها و مقاصد جرم به اندازه تنوع افرادى است كه مرتكب جرم مى‌شوند. جرايم چون روح انسان‌ها، پنهان و رمزآميز است. در صورتى كه تضمينى براى امنيت فردى كسى كه گام در راه كشف جرم مى‌گذارد وجود داشته باشد، ميل به شناخت رازهاى جرم و مجرمان بسيار قوى است.

گرچه اين ميل هر قدر هم قوى باشد، هيچ تمهيدى وجود ندارد كه پاسخ پرسش‌هاى خود را درباره جرايم با نوعى يقين علمى بيابيم. البته ما مى‌توانيم به بعضى از اين پرسش‌ها درباره جرم با مطالعه علل سركشى، درماندگى و عدالت‌خواهى كه ممكن است در ارتكاب جرم نهفته باشد، پاسخ دهيم. مجموعه كتاب‌هاى جرم، عدالت و مجازات به ما در اين راه كمك مى‌كنند. در اين كتاب‌ها، داستان‌هايى بعضاً مهيج و مسحور كننده و غالباً روزمره و معمولى از جرم و مجرمانى بعضاً مشهور و عمدتاً گمنام روايت شده است.

به علاوه اين مجموعه كتاب‌ها، به دادرسى‌هايى كه توسط آن‌ها، جرايم مورد بررسى قرار مى‌گيرند و مجرمان ‌شناخته مى‌شوند و به طرح دعوى‌هايى كه در آن‌ها گناه و بيگناهى تشخيص داده مى‌شود، نگاهى بيطرفانه دارد. در مطالعه اين دادرسى‌ها، هيجانِ تعقيب افرادى كه قوانين را به مبارزه مى‌طلبند، لمس مى‌كنيم و با مسئله محافظت از حقوق اين افراد مواجه مى‌شويم. به راه آوردن مجرمان نيازمند كارآمد و دقيق بودن اجراى قانون است. تنها موارد نادرى وجود دارد كه در برابر سبعيت و انحراف بيش از حد برخى مجرمان، احساس درماندگى مى‌كنيم. پليس، دادستان‌ها، وكلاى مدافع، قضات و اعضاى هيئت‌هاى منصفه، مجرى عدالت كيفرى هستند و در فعاليت روزانه خود مى‌كوشند كه حقوق افراد تضمين شود. سيستم عدالت قهريه چيست؟ چگونه كار مى‌كند؟ چرا چنين سيستمى داريم؟‌ در مجموعه كتاب‌هاى جرم، عدالت و مجازات، هيجان تعقيب مجرمان حين تلاش براى دستگيرى آنان را تجربه مى‌كنيم. همچنين در اين كتاب‌ها حقيقت جارى سيستم عدالت كيفرى و شكوه و عظمت دادگاه‌هايى نشان داده مى‌شود كه روال كار آن‌ها مذاكره بر سر گناهكار بودن مجرمان است.

پس از آنكه جلسه دادرسى تمام مى‌شود، دادخواست به نتيجه مى‌رسد و گناهكار از بيگناه تشخيص داده مى‌شود، لحظه مجازات فرا مى‌رسد. مجازات گناهكار، وارد آوردن دردى به او به خاطر دردى است كه وارد آورده است و اين رويه عمرى به اندازه خود تمدن دارد. “چشم در برابر چشم و دندان در برابر دندان” آيه‌اى از انجيل است كه به ما يادآور مى‌شود، مبناى مجازات، درد است. اما واكنش ما در مقابل مجرمان بايد بهتر از خود جرم و متفاوت با آن باشد. با وجود اين راهنمايى انجيل، قانون اساسى “مجازات بيرحمانه و غيرعادي” را منع مى‌كند و اين نشان مى‌دهد كه در مجازات مجرمان، مسئله تنها يافتن كسى كه بايد مجازات شود نيست، بلكه نحوه مجازات نيز اهميت دارد. اما آيه مجازات انجيل، نحوه مجازات را براى ما روشن نمى‌كند. آيا ما بايد به تجاوزگر، تجاوز كنيم يا خانه آتش‌افروز را به آتش بكشيم؟ مطمئناً عدالت و انصاف پاسخ منفى مى‌دهند. حال بايد بپرسيم كه مجازات بايد چگونه باشد؟ در دنيايى كه مجازات نه صورت معينى دارد و نه يك واكنش اتوماتيك به جرم مى‌باشد، بايد دست به انتخاب زد و اين انتخاب بايد توسط ما صورت گيرد. انتخاب‌ها، رويه‌ها و خط مشى‌هاى مجازات در مجموعه كتاب‌هاى جرم، عدالت و مجازات مورد بررسى قرار مى‌گيرند. چرا بايد مجازات كنيم و چگونه بايد مجازات كنيم؟ از بررسى سابقه واكنش‌هايى كه در برابر جرم نشان داده شده است، درباره عقلانيت و تناسب واكنش‌هايى كه امروزه نشان داده مى‌شود، چه مى‌توانيم بياموزيم؟ كدام روش كارايى دارد؟ آيا درد بايد تنها مقياس مجازات باشد؟

مجموعه كتاب‌هاى جرم، عدالت و مجازات به بررسى برخى از مسائل اساسى زندگى اجتماعى انسان‌ها مى‌پردازد. در اين كتاب‌ها ترس و جذبه نسبت به جرم و واكنش‌هاى ما در برابر آن مطالعه مى‌شود. آن‌ها به ما يادآور مى‌شوند كه اين موضوعات بى‌نهايت جدى هستند. در اين كتاب‌ها موضوعاتى در حيطه‌ قانون، ادبيات و فرهنگ عامه گردآورى شده است تا ما را وادارد كه مجدداً و از ابتدا درباره اين موضوع بيانديشيم كه ما كه هستيم و چگونه مى‌توانيم و مى‌خواهيم در كنار هم زندگى كنيم.

جامعه عارى از جرم تا به حال وجود نداشته است و پس از اين نيز وجود نخواهد داشت. با تغيير جامعه، جرايم نيز تغيير مى‌كنند. با رشد جامعه، جرايم نيز رشد مى‌كنند. فناورى‌هاى جديد، فرصت‌هاى جديدى براى مجرمان پديد مى‌آورد و پديد آمدن جرايم مرتبط با رايانه‌ها درست مانند پديد آمدن جرايم مرتبط با هر نوع پيشرفت فناورى ديگر بوده است.

كتاب جرايم رايانه‌اى، ديدگاه روشنى از موارد اساسى ارتباط ميان جرم و رايانه را ارائه مى‌كند و به ويژه بر نياز به حفاظت از مفاهيم با ارزشى چون امنيت و حريم خصوصى كه اهميت بسيار زيادى در جامعه دارند تأكيد مى‌كند و بيان مى‌دارد كه رايانه‌ها تأثير ضد و نقيضى در دموكراتيزه كردن جرم داشته‌اند. در اين كتاب، خطرات بالقوه هرزه‌نگارى و “تروريسم رايانه‌اي” به نحوى متقاعد كننده مورد بررسى قرار گرفته است و به همين ترتيب نشان داده شده است كه چه ‌طور يك طبقه جديد از مجرمان، به سوى جرايم رايانه‌اى كشيده مى‌شوند و چگونه انواع سنتى جرايم با واقعيت‌هاى روز انطباق مى‌يابند.

در اين كتاب مجموعه‌اى مهيج از تصاوير مجرمان رايانه‌اى ارائه مى‌شود كه باعث طرح سئوالات بسيارى مى‌شوند: آيا جرايم رايانه‌اى همان جرايم قديمى هستند كه با استفاده از فناورى جديد ارتكاب مى‌يابند؟ كدام قسمت از قانون كيفرى در ارتباط با جرايم رايانه‌اى حائز بيشترين اهميت است؟ آيا نياز داريم كه قوانين جديدى در اينباره وضع كنيم؟ آيا بخش‌هاى مختلف موجود در قانون كيفرى براى تهديد‌هاى جديد كفايت مى‌كنند؟ آيا جرايم رايانه‌اى آنگونه كه در نتيجه‌گيرى اين كتاب پيشنهاد مى‌شود، تنها يك گروه از جرايم يقه‌ سفيد است يا خود مفهومى كاملاً جديد دارد؟

و در انتها، اين كتاب به ما امكان مى‌دهد سئوالات جديدى مانند نحوه استفاده از رايانه‌ها براى اجراى قانون و مقابله با جرايم رايانه‌اى مطرح ‌كنيم. اين كتاب با بيانى صريح و جذاب، يادآور وجود دو قابليت انطباق‌پذيرى و نوآورى در مجرمان است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:58 AM

January 13, 2005

جرایم رایانه ای (۲) آرپانت، هكرها، كركرها و فريك‌ها

نويسنده: جينا دي آنجليز
مترجم: سعيد حافظي

جرایم رایانه ای (۲) آرپانت، هكرها، كركرها و فريك‌ها

29 تير 1383 - بخش مقاله آی تی ایران - اصطلاح فضاى رايانه‌اى (Cyberspace) براى اولين بار در سال 1982 در يك داستان علمى ـ تخيلى بكار برده شد. ما در گفتارمان از فضاى رايانه‌اى، بعنوان يك مكان فيزيكى ياد مى‌كنيم اما در واقع‌ اينطور نيست. فضاى رايانه‌اى اگر چه اصطلاحى نسبتاً جديد است اما مفهوم آن جديد نيست و پيدايش‌ اين مفهوم، همزمان با اختراع تلفن توسط الكساندر گراهام‌بل در سال 1876 بوده است. در حقيقت مى‌توان گفت كه اولين “جرايم رايانه‌اي” در سال 1878 ارتكاب يافتند.

مرتبط:
بخش نخست این مقاله: ‌مقدمه‌اى بر جرم، عدالت و مجازات

شركت بل تعداد زيادى پسر نوجوان را كه قبلاً در اداره تلگراف بعنوان تلگراف رسان كار مى‌كردند، براى متصل كردن تماس‌هاى تلفنى و ارائه اطلاعات به مشتركان سرويس تلفن استخدام كرد. اما همانطور كه بروس استرلينگ (Bruce Sterling) در كتاب خود با نام “مقابله با هكرها” (The Hacker Crackdown) اشاره كرده است، ‌اين شركت بزودى با مشكلاتى از سوى كاركنان جوان خود مواجه شد:

“ ‌اين بچه‌ها با مشتريان، بى‌ادبانه و با گستاخى برخورد مى‌كردند، سر به سر آنها مى‌گذاشتند و معمولاً آن‌ها را مسخره مى‌كردند. بدتر از همه آنكه از حقه‌هايى هوشمندانه در صفحه سوئيچ‌هاى اتصال استفاده مى‌كردند و به ‌اين وسيله تماس‌ها را قطع مى‌كردند و كارهايى از ‌اين قبيل انجام مى‌دادند. توانايى، مهارت فنى و ناشناس بودن‌ اين پسران در انجام ‌اين شيطنت‌ها، مجموعه عواملى را تشكيل مى‌داد كه باعث بروز مزاحمت‌ها و مشكلات مى‌شد.”
شركت بل در نهايت تصميم گرفت كه خود را از شر ‌اين بچه‌ها خلاص كند و تصميم به استخدام خانم‌هاى جوان و محترم گرفت و نتيجه آن شد كه بروز چنين رفتارهاى ناپسندى تقريباً از ميان رفت.

همانند فضاى رايانه‌اى كه سابقه آن از آنچه اكثر مردم مى‌پندارند بسيار بيشتر است، ‌ايده ‌اينترنت نيز كه بسيارى از ما تنها طى چند سال اخير با آن آشنا شده‌ايم ـ بسيار قديمى ‌است.‌ ايده‌ اينترنت در اوايل دهه 1960 و در زمانى شكل گرفت كه تشكيلات نظامى ‌ايالات متحده و شركت راند (RAND Corporation) تصميم گرفتند از رايانه‌ها براى حصول اطمينان از امكان برقرارى ارتباطات پيوسته در صورت تهاجم هسته‌اى استفاده كنند. سيستمى‌كه تنها داراى يك رايانه مركزى باشد در مقابل صدمات وارده بسيار آسيب پذير خواهد بود. آنچه ما امروزه از آن با عنوان “‌اينترنت” ياد مى‌كنيم، سيستمى‌ از رايانه‌هاى مرتبط با هم است به نحوى كه‌ اين رايانه‌ها از تعداد بسيار زيادى خط تلفن براى برقرارى ارتباط با يكديگر استفاده مى‌كنند و به ‌اين ترتيب اطمينان حاصل مى‌شود كه در صورت عدم توانايى يك مسير براى ارسال اطلاعات، مسير ديگرى قابل دسترسى خواهد بود.

آنها رايانه‌ها را به صورت شبكه‌اى به هم متصل كردند و‌اين كار باعث شد كه انجام محاسبات و اجراى برنامه‌ها با سرعت بسيار بيشترى انجام شود زيرا اپراتورهاى رايانه‌ها مجبور نبودند كه اطلاعات را به صورت نوارهاى مغناطيسى يا كارتهاى پانچ ارسال كنند. بجاى ارسال اطلاعات به ‌اين شكل، ‌امكان ارسال اطلاعات به صورت الكترونيكى از طريق سيم‌هاى تلفن در يك لحظه بوجود آمد.

اين پيش‌نمونه ‌اينترنت در سال 1969 با عنوان آرپانت (شبكه آژانس پروژه‌هاى تحقيقاتى پيشرفته) ‌ايجاد شد و به وسيله وزارت دفاع به اجرا درآمد. براى اهداف دفاعى بجاى تنها يك مسير، مسيرهاى زيادى وجود داشت كه اطلاعات از طريق آنها در شبكه جابجا مى‌شد. آپارنت در اصل به وزارت دفاع و چندين دانشگاه (دانشگاه كاليفرنيا در لس‌آنجلس، موسسه تحقيقاتى استنفورد، دانشگاه كاليفرنيا در سانتا باربارا و دانشگاه يوتا) متصل شده بود. اما در سال 1971، آرپانت گسترش يافت و دانشگاه‌ها و آژانس‌هاى دولتى بيشترى را در برگرفت كه دانشگاه‌ هاروارد، موسسه صنعتى ماساچست (MIT) و سازمان ملى هوانوردى و فضايى (NASA) را شامل مى‌شد.

پس از آن، موضوع جالب توجهى رخ داد. بجاى مبادله خدمات محاسباتى، كاربران شبكه شروع به رد و بدل كردن يادداشت‌ها و نامه‌هاى الكترونيك و “صحبت كردن” با يكديگر در قالب گروه‌هاى خبرى و مباحثه‌اى كردند. از سال 1973، كشورهاى ديگر و به تبع آن تمام شبكه‌هاى ديگر به آرپانت متصل شدند.

اين شبكه‌هاى رايانه‌اى با آرپانت سازگار بودند زيرا از يك زبان ارتباطى جهان استفاده مى‌كردند كه به آن پروتكل كنترل شبكه (NCP) گفته مى‌شد ( امروزه ‌اين زبان را معمولاً با عنوان پروتكل كنترل ارسال، كنترل‌اينترنت (TCP/IP)مى‌شناسند. ممكن است متوجه شده باشيد كه گاهى هنگام جستجو در ‌اينترنت، رايانه شما خواستار يك “آدرس IP” مى‌باشد). همزمان با توسعه پروتكل‌هاى شبكه، استفاده از اسامى‌حوزه‌ها (Domains) نيز آغاز شد. براى مثال، بجاى تلاش براى يافتن شماره سرور 204.50.77.34 شما مى‌توانيد با آدرس “explora .com” جستجو كنيد و‌ اين عبارت شما را به همان آدرس عددى هدايت مى‌كند.

تا قبل از سال 1986، تنها كسانى كه به نوعى با شركت‌هاى بزرگ رايانه‌اى مانند IBMيا ديجيتال الكترونيكس در ارتباط بودند، امكان دسترسى به ‌اينترنت داشتند اما پس از ‌اين سال با كاهش قيمت رايانه‌هاى شخصى و افزايش سرعت آن‌ها، امكان دسترسى به ‌اينترنت براى افراد معمولى نيز فراهم شد. حال‌ اين سئوال پيش ميآايد كه در سال 1986 چه اتفاقى افتاد؟ درآن سال، شبكه ملى زيربناى علمى‌ (NSFNET) تبديل به “ستون فقرات” ‌اينترنت شد. سرعت فزآينده ‌اينترنت در ارسال داده‌ها به معنى آن بود كه‌ اينترنت مى‌تواند داده‌هاى بيشترى را جابجا كند. مطابق با صفحات وب چند رسانه‌اى اكسپلورا (EXPLORA) در سال 1989، آرپا، مديريت آرپانت را متوقف كرد زيرا آرپانت بر اثر مجتمع شدن با شبكه‌هاى ديگر، تبديل به‌اينترنت شده بود. شبكه جهان‌گستر (World Wide Web) كه همه ما هر روز مطالبى درباره آن مى‌شنويم، از سوئد نشات گرفت.

متصل كردن رايانه‌هاى بيشمار در سراسر دنيا به يكديگر منجر به پيشرفت‌هاى حيرت آورى در زمينه‌هاى آموزشى، فناورى و اقتصادى شده است. نامه‌هاى الكترونيك يا‌ ايميل، به ما امكان مى‌دهد كه ظرف چند ثانيه با ديگران ارتباط برقرار كنيم. “اتاق‌هاى گپ” و “گپ‌هاى مبتنى بر‌اينترنت” (IRC) به ما امكان مى‌دهد كه به وسيله صفحه كليد، بطور همزمان با افراد متعددى در سراسر دنيا ارتباط برقرار كنيم. ‌اينترنت بخودى خود گستره‌اى از اطلاعات بسيار متنوع است و بهانه پيدا نكردن يك مفهوم در دائره المعارف را از دانش آموزان آاينده سلب مى‌كند اما در عين حال شبكه جهان‌گستر باعث شده است كه انواع حيرت انگيزى از جرايم (رفتارهاى كيفرى) پديد آيد.

در فوريه سال 1995، پس از چندين سال پيگرد، كوين ميتنيك (Kevin Mitnick) به جرم كلاهبردارى رايانه‌اى دستگير و متهم شد. بازداشت او، به خبرسازترين رويداد دنياى رايانه تبديل شد. ‌اين حادثه دست كم در سه كتاب ثبت شد ـ يكى از‌اين سه كتاب نوشته كسى است كه ميتنيك را بازداشت كرد ـ و بدون ترديد منجر به ساخت فيلم‌ها و آثار ديگرى در‌ اينباره شد. اما ميتنيك دقيقاً چه كرده بود كه باعث شد توجه تمام رسانه‌ها به او جلب شود؟ او به سيستم‌هاى رايانه‌اى متعددى دسترسى غيرقانونى پيدا كرده بود، برنامه‌هاى رايانه‌اى را به سرقت مى‌برد و براى انجام‌ اين كار از سرويس‌هاى تلفن راه دور استفاده مى‌كرد. حال‌ اين سئوال مطرح مى‌شود كه يكنفر چگونه مى‌تواند در دستكارى سيستم‌هاى رايانه‌اى و ديگر فناورى‌ها، تا‌ اين حد مهارت پيدا كند؟ ميتنيك بدليل جرايمى‌كه مرتكب شده بود توسط مقامات فدرال تحت تعقيب قرار گرفت.

اين تعقيب ناموفق دو سال بطول انجاميد تا آنكه در كريسمس سال 1994، ميتنيك كوشيد كه به درون فايل‌هاى رايانه‌اى يك فيزيكدان و متخصص امنيت رايانه به نام تسوتومو شيمومورا (Tsutomu Shimomura) در كاليفرنيا رخنه كند. پس از حدود شش هفته رديابى، شيمومورا، ميتنيك را در كاليفرنياى شمالى پيدا كرد.

ميتنيك به هزاران شماره كارت اعتبارى و اطلاعات مهم ديگر دسترسى پيدا كرده بود و امكان يافته بود كه از‌ اين اطلاعات براى سرقت صدها و هزاران دلار ـ اگر نگوئيم ميليون‌ها دلار ـ استفاده كند. اما او‌ اين كار را نكرد. ميتنيك حتى اظهار كرد كه به رايانه‌هاى وزارت دفاع نيز رخنه كرده است. او مى‌توانست‌ اين اطلاعات را نابود كند يا باعث يك بحران نظامى‌ جهانى شود. اما ‌اين كار را نكرد. او مى‌توانست به اطلاعات حساس رايانه‌هايى دسترسى پيدا كند كه مجاز به ديدن آنها نبود. مانند بيشتر هكرهاى رايانه، ميتنيك در سيستم‌هايى كه به آنها رخنه كرده بود " گشت مى‌زد" و سپس آنجا را ترك مى‌كرد.

اگر چه بسيارى از دوستان و نزديكان ميتنيك در اواخر دهه 1970 و اوايل دهه 1980 ـ گروهى با نام تبهكاران روسكو (Roscoe Gangs) ـ اعتراف كرده بودند كه او تمايل زيادى به مختل كردن سرويس تلفن افرادى داشت كه به او صدمه زده بودند يا به او توهين كرده بودند. اما ‌اين اظهارات به عنوان بخشى از سابقه كيفرى او محسوب نشد.

ميتنيك در سن 17 سالگى به جرم سرقت كتاب‌هاى راهنماى قطعات الكترونيك از فروشگاه پسفيك بل (Pacific Bell)به مدت شش ماه محكوم به حبس و مجازات تعليقى شد و در سال 1987 به دليل سرقت نرم افزار از طريق يك خط تلفن به سى و شش ماه حبس تعليقى محكوم شد. برخى از روزنامه‌نگاران و مقامات مسئول، ميتنيك را به عنوان تهديدى براى امنيت هر خانواده آمريكايى معرفى كرده بودند اما نويسندگان بسيارى از گروه‌هاى مختلف با ‌اين عقيده موافق نبودند. در واقع بيشتر هكرها به اندازه‌‌اى كه در رسانه‌ها منعكس مى‌شود، تهديد كننده نيستند.

هكرها در يك مورد مهم با كركرها تفاوت دارند. كارهايى كه آن‌ها انجام مى‌دهند معمولاً از روى بدخواهى نيست. انگيزه بيشتر هكرها براى‌ اين كار، تمايل شديد به يادگيرى نحوه كار سيستم رايانه، يافتن راهى براى ورود مخفيانه به آن‌ها و پيدا كردن سوراخ‌هاى امنيتى ‌اين سيستم‌ها است. هيجان خواندن اطلاعاتى كه مى‌دانند اجازه ديدن آنها را ندارند يا انجام كارى كه مى‌دانند قانونى نيست به لذت دست زدن به چنين تجاربى توسط هكرها به عنوان سرگرمى‌ مى‌افزايد. مانند هر سرگرمى ‌ديگر، هك كردن مى‌تواند تبديل به يك عادت شود. بسيارى از هكرها، ساعاتى طولانى را پشت رايانه خود مى‌گذرانند در حاليكه داراى همسر و خانواده مى‌باشند و مى‌كوشند كه شغل خود را از دست ندهند. كوين ميتنيك هنگامى‌كه احساس كرد همسرش در كار هك كردن او دخالت مى‌كند تصميم به جدا شدن از او گرفت.

در دهه 1970 واژه هكر به شخصى اطلاق مى‌شد كه در برنامه نويسى بسيار ماهر و باهوش باشد. بعدها در دهه 1980‌ اين واژه به معنى شخصى بود كه در “نفوذ” به سيستم‌هاى جديد به صورت ناشناس تبحر داشته باشد. امروزه بيشتر با هدف ترساندن هكرها، رسانه‌ها و مقامات مسئول مانند آژانس‌هاى دولتى و ادارات پليس، ‌اين واژه را به هر شخصى كه مرتكب يك جرم مرتبط با فناورى شود، اطلاق مى‌كنند. ‌اين درست است كه هكرهاى كنجكاو، مى‌توانند سهواً باعث زيان‌هاى قابل توجهى شوند اما جستجو براى يافتن اطلاعات و آموزش ـ نه انتقام گيرى يا صدمه زدن به ديگران ـ عاملى است كه باعث مى‌شود اكثر هكرها سرگرمى ‌خود را به نحوى بيرحمانه دنبال كنند.

از سوى ديگر كركرها، هكرهايى بدخواه هستند. آنها به سيستم‌ها رخنه مى‌كنند تا خرابكارى كنند، ويروس‌ها و كرم‌هاى رايانه‌اى را منتشر كنند، فايل‌ها را پاك كنند يا بعضى انواع ديگر ويرانى را ببار آورند. اختلاس، كلاهبردارى يا جاسوسى صنعتى (سرقت اطلاعات محرمانه يك شركت) تنها بخش كوچكى از اهداف احتمالى كركرها مى‌باشد. جاسوسى رايانه‌اى همانطور كه بين شركت‌ها وجود دارد، ميان كشورها نيز در جريان است بنابراين امنيت ملى ما را با مخاطره مواجه مى‌كند. تروريسم رايانه‌اى، توسعه رايانه‌اى دهشتناك ديگرى است كه شايد امنيت ميليون‌ها انسان را در سراسر دنيا تهديد كند. هيچ بحثى در‌اين نيست كه آنچه كركرها انجام مى‌دهند همانقدر كه غير قانونى است، مخاطره آميز نيز مى‌باشد.

شكل ديگرى از جرايم رايانه‌اى را “فريك‌هاى تلفن” مرتكب مى‌شوند. فريك‌ها بجاى دسترسى به سيستم‌هاى رايانه‌اى، از طريق خطوط تلفن در دنياى رايانه گشت مى‌زنند. فريك‌ها از ميان اولين هكرها در دهه 1970 پديد آمدند. يكى از حوادثى كه بوسيله فريك‌ها بوجود آمده بود و در مجله دنياى رايانه در شماره 24 فوريه سال 1997 توسط شارون ماكليس (Sharon Machlis)گزارش شد، مربوط به اداره پليس شهر نيويورك (NYPD) مى‌شد. فريك‌ها به سيستم تلفن‌ اين اداره نفوذ كرده بودند و متن ضبط شده‌اى را كه به تماس‌گيرندگان خوشامد مى‌گفت تغيير داده بودند.

در متن ضبط شده جديد گفته مى‌شد كه افسران پليس مشغول خوردن نان شيرينى و نوشيدن قهوه هستند و فرصت جواب دادن به تلفن‌ها را ندارند. ‌اين پيام به تماس‌گيرندگان توصيه مى‌كرد كه در موارد اورژانس با شماره 119 تماس بگيرند.

هكرها و فريك‌هاى ديگر به سيستم‌هاى پست صوتى شركت‌هايى نفوذ كردند كه خدمات معاف از ماليات به مشتريان خود ارائه مى‌كردند. آن‌ها صندوق‌هاى پست صوتى خود را بر روى خط يك شركت‌ ايجاد كردند سپس اطلاعات را از طريق‌ اينترنت ارسال مى‌كردند و با هزينه ‌اين شركت خدمات پست صوتى و تلفن راه دور رايگان در اختيار ديگران قرار مى‌دادند.

سه فريك در كاليفرنيا برنامه خطوط تلفن سه‌ ايستگاه راديويى مختلف را براى جلوگيرى از برقرارى هرگونه تماس با آن‌ها تغيير دادند تا فقط خودشان بتوانند هنگام پخش زنده يك مسابقه راديويى با‌ اين ايستگاه‌ها تماس برقرار كنند. ‌اين مردان در نهايت به اتهام كلاهبردارى رايانه‌اى، گناهكار شناخته شدند. آن‌ها به ‌اين وسيله برنده بيش از 20.000 دلار پول نقد، دو اتومبيل پورشه و دو سفر تفريحى به جزاير ‌هاوايى شده بودند.

تهديد هكرها، كركرها و فريك‌ها تا چه حد جدى است؟ كدام دسته از مجرمان رايانه‌اى بيش از بقيه خطرناك هستند؟ ما نياز داريم كه سيستم‌هاى خود را در مقابل كدام فعاليت‌ها بيش از همه محافظت كنيم؟ آيا راهى براى جلوگيرى كامل از نفوذ به درون سيستم‌هاى رايانه‌اى و خطوط تلفن ما وجود دارد؟

اين پرسش‌ها، پاسخ‌هاى ساده‌اى دارند. احتمالاً هيچ راهى براى جلوگيرى كامل از نفوذ وجود ندارد اما مى‌توانيم وقوع آن دسته از جرايم رايانه‌اى را كه بالقوه خطرناك هستند به حداقل برسانيم. آگاهى و مديريت خوب كاركنان در قالب آموزش آنان مى‌تواند كارآمدترين دفاع در مقابل رخنه در سيستم امنيتى رايانه باشد.

افراد بسيارى، كوين ميتنيك را يك “مهندس اجتماعي” بزرگ مى‌دانند. او به دفعات بيشمار توانست اپراتورهاى سيستم (Sysops) و مديران سيستم (Sysadmins) را متقاعد كند كه او به صورت قانونى از سيستم‌هاى رايانه‌اى آن‌ها استفاده مى‌كند. او همچنين در تماس تلفنى يا ارتباط شخصى با منشى‌ها يا نگهبانانان امنيتى بسيار خوشايند و متقاعد كننده برخورد مى‌كرد تا بتواند گذرواژه‌ها و اطلاعات مهم ديگر را از بسيارى شركت‌ها بدست آورد و بعد بتواند از‌اين اطلاعات براى رخنه در رايانه‌اى‌اين شركت‌ها استفاده كند.

مثال ديگرى از “مهندس اجتماعي” در سال 1976 و در هنگامى ‌رويداد كه جرى اشنايدر (Jerry Schneider) توانست چندين هزار دلار را در يك برنامه تلويزيونى زنده با نام “60 دقيقه” اختلاس كند. اشنايدر به عنوان شخصى كه پاسخ درست داده است با برنامه تماس گرفت، به يك كارمند بانك شماره حساب دان راتر (Dan Rather) مجرى برنامه را داد و سپس در تلفن گفت: “ده هزار دلار!” راتر ناباورانه فرياد زد: “شما نمى‌توانيد به سادگى با تماس تلفنى شماره كارت اعتبارى يكنفر را بگيريد و بجاى پانصد دلار، ده هزار دلار از حساب او برداريد.” اشنايدر پاسخ داد: “چرا، مى‌توانم.” او در واقع‌ اين كار را در تلويزيون شبكه‌اى انجام داد.

اما خود رايانه‌ها تنها يك ابزارند. ‌اين افراد هستند كه مرتكب جرايم رايانه‌اى مى‌شوند و مردم نيز مانند فايل‌هاى رايانه‌اى مى‌توانند به عنوان منابع اطلاعات حفاظت شده يا حساس مورد استفاده قرار گيرند. نكته خوبى كه در‌اين ميان وجود دارد آنست كه مردم نيز مى‌توانند از جرايم رايانه‌اى جلوگيرى كنند. هر قدر ما بيشتر درباره انواع مختلف جرايم رايانه‌اى و ابزارهاى كه براى جلوگيرى از آن‌ ايجاد شده است بدانيم، امنيت بيشترى خواهيم داشت.

ادامه دارد

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

11:59 AM

January 13, 2005

جرایم رایانه ای (۳):عصر اطلاعات

نويسنده: جينا دي آنجليز
مترجم: سعيد حافظی

جرایم رایانه ای (۳):عصر اطلاعات

31 تير 1383 - بخش خبر آی تی ایران - با ارزشترين دستاورد جامعه ما گندم، فولاد يا حتى فناورى نيست بلكه اطلاعات است. به دليل وجود شبكه‌هاى رايانه‌اى، امروزه تقريباً هر كسى مى‌تواند به گستره مبهوت كننده‌اى از اطلاعات دسترسى پيدا كند.

در فضاى رايانه‌اى هيچ مرزى وجود ندارد. اينترنت بين المللى است ـ با آنكه در حدود80 درصد كاربران اينترنت (در سال 1996) در ايالات متحده مى‌باشند ـ و اطلاعات زيادى درباره هر موضوعى كه تصور كنيد، به صورت رايگان در آن قابل دستيابى است.

بدليل آنكه امروزه افراد بسيار زيادى به اينترنت دسترسى دارند، جرايم رايانه‌اى تبديل به يك مسئله اجتماعى شده است. درست همانگونه كه هر شهروند آمريكايى كه بخواهد مى‌تواند در انتخابات شركت كند، هر كسى با يك رايانه و مودم مى‌تواند مرتكب يك جرم رايانه‌اى شود و به يك مجرم رايانه‌اى “يقه سفيد” (White Collar) تبديل شود.

زمانيكه اصطلاح مجرم يقه سفيد طى چندين دهه گذشته باب شد، تصور مى‌شد كه جرايم مشخصى توسط اين افراد ارتكاب مى‌يابد به نحوى كه هيچكس بطور طبيعى به رفتار كيفرى آن‌ها مظنون نمى‌شود. به اين افراد حرفه‌اى، كاركنان “يقه سفيد” گفته مى‌شد ( در مقابل كاركنان نا‌متبحر يا نيمه‌متحبر يعنى “يقه آبى‌ها”). جرايم يقه سفيد معمولاً بوسيله حرفه‌اى‌ها صورت مى‌گرفت زيرا آن‌ها توانايى و دسترسى لازم را براى ارتكاب جرايمى مانند اختلاس، كلاهبردارى و جعل سند در اختيار داشتند. مطمئناً كاركنان يقه آبى نيز مى‌توانستند مرتكب چنين جرايمى شوند اما يك جرم شناس به نام ادوين ساترلند(Edwin Sutherland) اصطلاح مجرم يقه سفيد را بكار برد تا ساير دانش پژوهان را آگاه كند كه تمام مجرمان در قالب يك تصوير كلى قرار نمى‌گيرند، بدان معنى كه تمام آن‌ها از طبقات اقتصادى ـ اجتماعى پائين نيستند. با اين حال، در اواخر دهه 1990 اصطلاح يقه سفيد معنى دقيقى نداشت و حيطه كاربرد آن به وسيله استفاده گسترده از رايانه‌ها سطح‌بندى شده بود. امروزه “جرم يقه سفيد” به سادگى به معنى “جرم عارى از خشونت” يا “جرم اقتصادي” است.

با رشد فزاينده ميزان دسترسى مردم به فناورى، اين مفهوم تبديل به ابزارى قدرتمند در دست تعداد رو به تزايد مجرمان شده است. در بيشتر جرايم رايانه‌اى، خشونت وجود ندارد بلكه بيشتر طمع، غرور يا ديگر ضعف‌هاى شخصيتى قربانى است كه در ارتكاب اين جرايم نقش اصلى را بازى مى‌كند. اين جرايم بر پايه عدم صداقت استوارند نه اجبار، به اين دليل، جرايم رايانه‌اى از نوع يقه سفيد در نظر گرفته مى‌شوند. هيچ تعريف قانونى براى اصطلاح جرم يقه سفيد وجود ندارد اما بصورت كاربردى مى‌توان آن را به اين شكل تعريف كرد: بيشتر جرايم يقه سفيد بدون استفاده از زور ارتكاب مى‌يابند بنابراين بيشتر نيازمند برنامه ريزى هستند، مانند سرقت مسلحانه. بعضى جامعه‌شناسان معقتدند افرادى كه اين جرايم را مرتكب مى‌شوند از مجرمان معمولى يا خيابانى قابل تشخيص هستند يا حداقل زمانى قابل تشخيص بودند. يك افسر پليس كه متخصص جرايم رايانه‌اى است مى‌گويد: “ افرادى كه ما دستگير مى‌كنيم بطور متوسط داراى مدرك ليسانس هستند. آنها براى كار خود برنامه ريزى مى‌كنند.” امروزه جرم هاى رايانه‌اى بيشتر نيازمند مهارت بسيار زياد هستند تا شيرينكارى‌هاى جالب توجهى كه غالباً توسط هكرهاى اواخر دهه 1980 صورت مى‌گرفت.

درست همانند اصطلاح جرم يقه سفيد كه انواع بسيار مختلفى از جرايم را پوشش مى‌دهد، اصطلاح جرم رايانه‌اى نيز گستردگى زيادى دارد. اين اصطلاح، جرايمى را كه به وسيله يك رايانه، درون يك فضاى رايانه‌اى و عليه يك رايانه ارتكاب مى‌يابند را شامل مى‌شود. بعضى از اين جرايم كاملاً جديد هستند در حاليكه جرايم ديگر جرايم قديمى‌ترى هستند كه از رايانه به عنوان ابزار استفاده مى‌كنند. رشد دائم و تنوع بى‌پايان جرايم رايانه‌اى، تدوين قوانينى با احاطه مناسب بر جرايم رايانه‌اى جديد را دشوار ساخته است. بعضى جرايم مانند اختلاس كلاهبردارى و جعل سند توسط قوانين موجود پوشش داده مى‌شوند. جرايم ديگر مانند خرابكارى رايانه‌اى، تروريسم رايانه‌اى و جاسوسى رايانه‌اى نسبتاً جديد هستند. براى اين جرايم جديدتر، نص قوانين موجود گاهى اوقات اجازه تحت پيگرد قراردادن آنچه بطور وضوح جز رفتار كيفرى محسوب مى‌شود را نمى‌دهد.

از آنجا كه ميليون‌ها نفر در سراسر دنيا به فناورى برتر دسترسى دارند، جرايم رايانه‌اى ممكن است تقريباً توسط هر كس با هدف قانون‌شكنى ارتكاب يابد ـ يا حتى فقط ميل شديد يادگيرى هر چيز ممكن درباره نرم‌افزار و سيستم هاى رايانه‌اي. براساس نظر ويك سوسمان (Vic Sussman)در مجله اخبار ايالات متحده و گزارش جهانى (U.S. News and World Report)، امروزه تقريباً تمام جرايم يقه سفيد، شامل استفاده از رايانه‌ها يا ارتباطات راه دور مى‌شوند. اين موضوع بيشتر نتيجه وابستگى ما به رايانه‌ها است تا هر مهارت فناورى ديگر كه در بيشتر مجرمان “معمولي” وجود دارد. اما مجرمان “معمولي” يا “خياباني” نيز با روندى فزاينده به جرايمى دست مى‌زنند كه مرتبط با فناورى مى‌باشد مانند سيستم‌هاى تلفنى و پيجرها و همينطور رايانه‌ها.

دنياى تجارى بورس و معاملات بزرگ مثال روشنى از يك صنعت مبتنى بر رايانه‌ها براى حفظ اطلاعات و انتقال مقادير عظيم پول با طى فواصل بسيار زياد مى‌باشد. بسيارى از صنايع و خدمات مهم ديگر نيز “مبتنى بر فناوري” هستند. هر قدر رايانه‌هاى بيشترى به يكديگر متصل شوند و هرقدر روند حذف پول نقد در جامعه ـ با اتكاء بر كارت هاى اعتبارى، كارت‌هاى بدهى و كارت هاى ATM بجاى پول نقد ـ كنيم، جرايم رايانه‌اى مطمئناً افزايش بيشترى خواهند يافت. سازمان‌هاى مجرى قانون و شركت‌هاى نرم‌افزارى و رايانه‌اى بر سر پيشتاز بودن در مبارزه با جرايم رايانه‌اى به وسيله خلق و تقويت سيستم‌هاى امنيتى رايانه‌اى جديد با هم به رقابت مى‌پردازند.

اين مجرمان رايانه‌اى چه كسانى هستند؟ اگر چه معمولاً يك مجرم رايانه‌اى يك مرد جوان است اما مجرمان نسبتاً متفاوتى به نام “جيكي” (Geeky) با وقت آزاد زياد و ميل شديد براى رخنه در شبكه‌ها وجود دارند. اكثر جرايم يقه سفيد به وسيله كاركنان فعلى و سابق شركت‌هايى ارتكاب مى‌يابند كه مورد حمله رايانه‌اى قرار مى‌گيرند. 75 تا 80 درصد جرايم رايانه‌اى تحت پيگرد قرار گرفته، به وسيله كاركنان فعلى و قبلى اين شركت‌ها ارتكاب مى‌يابد.

باك بلوم بكر (Buck Bloom Becker) نويسنده و متخصص جرايم رايانه‌اى مى‌گويد: “ما بايد هنگام صحبت درباره كسانى كه گستره وسيعى از جرايم رايانه‌اى را مرتكب مى شوند از كليشه‌هاى عمومى فراتر برويم.” عليرغم تمام توجه رسانه‌ها و حجم زياد اخبارى كه منعكس مى‌كنند‏، هكرها درصد بسيار كوچكى از مجموع مجرمان رايانه‌اى را تشكيل مى‌دهند. همانگونه كه يك گزارشگر اشاره كرده است: “هكرها ياد گرفته‌اند كه مرتكب جرم شوند و مجرمان ياد گرفته‌اند كه هك كنند.”

انواع بسيار متنوعى از جرايم رايانه‌اى، از سرقت مشخصات افراد و ايجاد مزاحمت به وسيله فرستادن مطالب و تصاوير مستهجن و كلاهبردارى گرفته تا جرايم يقه سفيد معمولى وجود دارد. عمومى‌ترين شكل اين جرايم، سرقت و كلاهبردارى به صورت آنلاين (Online) مى‌باشد. فريك‌ها‏، كركرها و گاهى اوقات هكرها به طور غير قانونى به پست صوتى، پست الكترونيك و شماره حساب‌هاى اتصال به شبكه دسترسى پيدا مى‌كنند و از آن‌ها استفاده مى‌كنند كه اين كار مشمول تقلب مالياتى يا تقلب در استفاده از خطوط تلفن مى‌شود. گزارشگرى به نام شارون ماكليس (Sharon Machis) نقل از يك افسر سابق پليس به نام والت منينگ (Walt Maning) كه اينك به عنوان يك مشاور امنيتى در تگزاس كار مى‌كند، مى‌گويد: “يكى از شركت‌هاى مشترى ما تنها ظرف سه روز مبلغى در حدود 5/4 ميليون دلار از دست داده بود” و اين ناشى از همين گونه رخنه‌ها به درون سيستم مى‌باشد. اين شركت دريافت كه تنها پس از آنكه يك زن با آن‌ها تماس گرفته بود تا درباره خدمات پست صوتى رايگان اين شركت مطالبى سوال كند، قربانى اين حمله رايانه‌اى شده است.

كدهاى دسترسى راه دور بسيار مورد توجه هكرها، كركرها، فريك‌هاى تلفن، و همينطور مجرمان خيابانى مى‌باشد. دريك سوسمان مى‌نويسد: “يك دانشگاه زمانى متوجه شد مورد حمله قرار گرفته است كه قبض تلفن ماهانه آن به مبلغ 200.000 دلار، به جاى يك پاكت نامه، در يك جعبه براى آنها فرستاده شد! ” بعضى مجرمان رايانه‌اى اين كدها را بوسيله گشت زنى در اينترنت و با “سوار شدن بر شانه ديگران” بدست مى‌آورند ـ آن‌ها از خط تلفن كه مراقب هك شدن نيستند استفاده مى‌كنند و به جستجو در شبكه مى‌پردازند. يك دليل براى آنكه اين كار تبديل به شكلى عمومى از جرايم رايانه‌اى در ميان هكرها شده، آن است كه اين مجرمان معمولاً براى پرداختن به سرگرمى خود بايد روزى 10 تا 12 ساعت از خطوط تلفن استفاده كنند و طبعاً اين كار هزينه بالايى خواهد داشت. مجرمان ديگر اين كدها را از تابلوى اعلانات الكترونيكى “سرقت” (Pirate BBS) بدست مى‌آورند و از اين محل براى مبادله رايگان نرم‌افزارها، شماره كارت‌هاى اعتبارى و اطلاعات ديگر استفاده مى‌كنند.

هكرها، كركرها و فريك‌ها تقريباً هميشه علاقمند بدست آوردن امكان استفاده رايگان از تلفن مى‌باشند. براى مثال در روسيه، مقامات مسئول دريافتند كه هكرهاى بسيارى تمايل دارند با پليس رايانه‌اى و ديگر افراد دولتى در قبال بدست آوردن دسترسى رايگان به اينترنت همكارى كنند. در روسيه تقاضاى بسيار زيادى براى اينترنت وجود دارد اما هزينه يك ساعت اتصال به اينترنت معادل 3 دلار است كه مبلغ بالايى محسوب مى‌شود و افراد كمى امكان استفاده از آن را دارند. مقامات مسئول در روسيه همانند مقامات مسئول شركت‌هاى اينترنتى بزرگ مانند آمريكا آنلاين (AOL)، اميد دارند كه بتوانند با دادن امكان دسترسى رايگان اينترنتى به هكرها، در مقابل اطلاعات ـ معامله‌اى طعنه آميز ـ به امنيت اينترنت و ديگر شبكه‌هاى رايانه‌اى در مقابل هر نوع نفوذ جدى امنيتى كمك كنند.

سرقت نرم‌افزار از ديگر مسائل در حال رشدى است كه ظاهراً غير قابل رفع مى‌باشد. در قانون حق نشر آمريكا، اين كار غير قانونى است اما اكثر موارد سرقت نرم‌افزار در آن سوى آب‌ها رخ مى‌دهد. در عين حال قوانين حق نشر فدرال غالباً حتى براى تحت پيگيرد قرار دادن شهروندان ايالات متحده نيز جامعيت ندارد. پرونده ديويد لاماكچيا (David Lamachia) يكى از موارد معروف در اين زمينه مى‌باشد. لاماكچيا يكى از دانشجويان موسسه صنعتى ماساچست (MIT) بود. او از طريق يك سرويس تابلوى اعلانات (BBS) در رايانه‌هاى MIT اقدام به توزيع نرم‌افزار رايگان مى‌كرد. اداره تحقيقات فدرال (FBI) پس از مدتى جستجو لاماكچيا را دستگير كرد و او در سال 1994 به كلاهبردارى رايانه‌اى متهم شد. نرم‌افزارى كه او توزيع مى‌كرد بالغ بر يك ميليون دلار قيمت داشت اما لاماكچيا مدعى شد كه نرم‌افزار را به دليل استفاده مالى توزيع نكرده است و بنابراين ناقض قوانين حق نشر فدرال نبوده است. او بعد از اين ماجرا از دانشگاه اخراج شد.

تخمين زده مى‌شود كه سرقت نرم‌افزار در سطح جهان بيش از 5 ميليارد دلار در سال به شركت‌هاى آمريكايى خسارت وارد مى‌كند. در كتابى با نام ” نزديك شدن به صفر” ، آورده شده است كه كشورهاى زيادى به نام ” تك نسخه‌اي” شناخته مى‌شوند ـ كشورهايى كه در آنها يك نسخه از برنامه نرم‌افزارى به صورت قانونى خريدارى مى‌شود و از روى آن نسخه، نسخه‌هاى زيادى به صورت غير قانونى تكثير مى‌شود. در اين كتاب كشورهاى تايوان، تايلند، هنگ كنگ، سنگاپور، برزيل، هند و ژاپن به عنوان تعدادى از كشورهاى تك نسخه‌اى معرفى مى‌شوند. سرقت نرم‌افزار در چين نيز عموميت دارد و باعث تأثير بر روابط دموكراتيك و اقتصادى ميان چين و ايالات متحده شده است.

در يكى ديگر از موارد سرقت نرم‌افزار مشخص شد كه يكى از دانشجويان دانشگاه پوگت ساوند (Puget Sound) اقدام به توزيع 100 برنامه نرم‌افزارى به صورت رايگان از يك صفحه وب شخصى در شبكه دانشگاه مى‌كند. يك گزارشگر در اين مورد مى‌گويد: “ قيمت بعضى از اين بسته‌هاى نرم‌افزارى بيش از 3.700 دلار به ازاى هر نسخه بود.” صفحه شخصى اين دانشجو بسته شد، دانشگاه او را توبيخ كرد و جامعه ناشران نرم‌افزار خواستار مجازات سختى براى او شد. اما نهايتاً اين دانشجو را مجبور كردند كه يك مقاله 20 صفحه‌اى درباره تخلف از قانون نشر در دانشگاه‌ها بنويسد و 50 ساعت كار خدمات اجتماعى انجام دهد. كارلا ‌هاورث (Karla Haworth) در شماره 11 جولاى 1997 مجله “ تاريخچه آموزش عالي” نوشت: “ افراد زيادى در دنياى رايانه از نتيجه شكايت جامعه ناشران نرم‌افزار از اين دانشجو شگفت زده شدند.” مشكل تحت پيگيرد قرار دادن بسيارى از پرونده‌هاى سرقت نرم‌افزار، حتى در ايالات متحده، در پرونده لاماكچيا و پوگت ساوند كاملاً مشهود است. به هر روى، سرقت نرم‌افزار از جرايم رايانه‌اى بسيار شايعى است كه بايد تحت پيگيرد قرار گيرد.

يكى از وحشتناك‌ترين جرايم رايانه‌اى، سرقت مشخصات است. اين نوع كلاهبردارى امروز بسيار آسانتر شده است زيرا اطلاعات شخصى افراد بسيارى به صورت آنلاين و رايگان قابل دسترسى است و حتى اطلاعات شخصى بيشتر را مى‌توان يا مبلغى اندك بدست آورد. آيا مى‌دانيد اگر نام خانوادگى شما در كتاب راهنماى تلفن باشد، بدون توجه به اينكه شما رايانه داريد يا نه، احتمالاً تلفن و آدرس شما در شبكه جهان‌گستر قابل دسترسى خواهد بود؟
شايد تعجب كنيد كه چگونه تمام اين اطلاعات شخصى به شبكه رايانه‌ها راه يافته است. يادآور مى‌شويم كه اولين شبكه‌هاى رايانه‌اى، دولتى بودند. با افزايش ميزان دسترسى به رايانه‌ها و آسانتر شدن استفاده از آن‌ها، شركت‌هاى خصوصى همانند دولت، شروع به استفاده از رايانه‌ها براى نگهدارى اطلاعات كردند. روزنامه‌نگارى به نام پيتر مك‌گراد (Peter Mcgrath) درباره رايانه‌ها مى‌گويد: “رايانه‌ها تبديل به انبارهاى نگهدارى محرمانه‌ترين جزئيات زندگى مردم شدند. هر كسى كه يك حساب در بانك باز مى‌كرد، ردپايى الكترونيكى از خود به صورت مخارج خانه، خريدارى اشياء مورد علاقه و ملاقات با دكتر بجا مى‌گذاشت. سرويس تلفن، ردپايى ايجاد مى‌كرد كه منجر به شناسايى اقوام و دوستان شخص مى‌شد. حتى يك شماره امنيت ملى داراى قابليت اتكاء بالقوه اى بود. به وسيله آن يك دنبال كننده ردپا مى‌توانست از رايانه‌هاى دولتى، عدم بازپرداخت ماليات صاحب آن شماره را دريابد. امروزه كه شماره گواهينامه رانندگى افراد نيز در رايانه‌هاى شبكه‌اى بزرگ، ذخيره مى‌شود، مشخصات فيزيكى اشخاص ـ رنگ چشم، قد و امثال آن ـ نيز قابل دسترسى مى‌باشد.

براى خواندن نوارهاى مغناطيسى، كارتهاى اعتبارى و كارتهاى ATM و ثبت ميليون‌ها خريد و فروشى كه هر روزه انجام مى‌شود، به رايانه نياز داريم. خوشبختانه با وجود آنكه امكان دسترسى به اين اطلاعات شخصى براى همه وجود دارد، عده كمى درصدد استفاده از اين اطلاعات با مقاصد غير اخلاقى مى‌باشند. گزارشگرى به نام تي. ترنت گگاكس (T.Trent gegax) در شماره 19 جولاى 1997 مجله نيوزويك، گزارشى درباره پرونده كاترين رمبو (Kathryn Rembo) نوشت. كاترين يكى از قربانيان سرقت مشخصات بود. يكنفر اطلاعات شخصى كاترين را در يك فرم استخدام يافته بود و آن را در بانك داده‌هاى اينترنت و موتورهاى جستجو قرار داده بود و سپس با استفاده از اين اطلاعات، اقدام به درخواست كارت اعتبارى كرده بود. در اين گزارش قيد شده است كه اين شخص، “يك اتومبيل جيپ به قيمت 22.000 دلار، پنج كارت اعتبارى، يك آپارتمان و يك وام 3.000 دلارى را با استفاده از اطلاعات شخصى كاترين رمبو و سوابق اعتبارى خوب او به چنگ آورده بود.”

چارلز پاپاس (Charles Pappas) نويسنده ستونى به نام “شبكه ايمن”، درباره پرونده بورلى ريد (Beverly Reed) مطالبى ‌نوشت. كيف پول خانم ريد در سال 1991 دزديده شد. چند ماه بعد او فهميد كه مشخصات او نيز به سرقت رفته است. نام سارق نيز بيورلى ريد بود اما او از شماره تأمين اجتماعى خانم ريد براى گرفتن كارت‌هاى اعتبارى استفاده مى‌كرد. بيورلى ريد سارق، با استفاده از كارت اعتبارى خانم بيورلى ريد، 36.000 دلار قرض ببار آورد و اين باعث شد از خانم بيورلى خانه‌اش را از دست بدهد.

پاپاس تحقيقات خود را بر يافتن اين نكته متمركز كرد كه اطلاعات شخصى تا چه حد از طريق اينترنت قابل دسترسى است. او شروع به جستجو براى يافتن يك دوست قديمى در اينترنت كرد و دريافت كه بعضى از اين اطلاعات به صورت رايگان قابل دسترسى مى‌باشد و با پرداخت مبلغ بسيار اندكى، امكان دسترسى بسيار بيشترى فراهم مى‌آيد. پاپاس نوشت: “حدود دو روز وقت و 50 دلار پول صرف كردم و مطالبى را درباره او فهميدم كه احتمالاً همسرش نيز از آنها خبر ندارد. با صرف مقدارى پول بيشتر، من به سادگى توانستم سابقه رانندگى، سابقه كيفرى و ادعا نامه‌هاى جبران كاركنان دوستم و مطالب بيشترى در مورد او را بدست آورم.

با اين حال، پاپاس خاطر نشان مى‌كند كه سرقت مشخصات، به صورت ناگهانى پديدار نشد زيرا افراد بيشترى به مرور شروع به گشت زدن در اينترنت كردند. سرقت مشخصات همچنين زمانى رخ مى‌دهد كه مجرمان، زباله‌هاى افراد را مى‌كاوند تا قبض رسيدها و اطلاعات حساس ديگر را از اين طريق بدست آورند. آنگى فارلى ((Angie Farleigh يكى از اعضاى گروه تحقيقاتى مصلحت عمومى كاليفرنيا (CPIRG) است و معتقد است كه افزايش‌هاى اخير در تعداد پرونده‌هاى سرقت مشخصات در حقيقت به رايانه ارتباط دارد. پاپاس به نقل از آنگى مى‌نويسد: “بانك داده ما انباشته از تعداد بسيارى پرونده جديد در اين مورد است. در حال حاضر حدود 5.000 پرونده در اين مورد وجود دارد… راهى براى تقسيم بندى آنها نيست اما من معتقدم كه شبكه، سرقت مشخصات را بسيار آسان كرده است.”

همانند سرقت مشخصات، بعضى جرايم رايانه‌اى ديگر نيز جديد نيستند و تنها در اين مورد با هم متفاوتند كه امروزه مجرمان، از رايانه براى ارتكاب اين جرايم استفاده مى‌كنند. براى مثال، پولشويى ـ بدست آوردن پول از طرق غير قانونى يا پول “كثيف” به نحوى كه قانونى يا “پاك” به نظر برسدـ چندين دهه است كه ارتكاب مى‌يابد.

يك پولشو كه از رايانه استفاده مى‌كند قادر خواد بود اين جرايم را بسيار سريعتر و كارآمدتر انجام دهد، درست همانند كاركنان معمولى كه با استفاده از رايانه، كارهايشان را سريعتر و كارآمدتر انجام مى‌دهند. در جولاى سال 1997 مجله اكونوميست گزارش كرد كه برنامه نويسان، فعالانه سيستم‌هاى رايانه‌اى جديدى مى‌نويسند كه امكان ارتكاب جرايم پولشويى را بسيار آسان‌تر ـ و حتى شناسايى آن را براى مجريان قانون سخت‌تر ـ مى‌كند:

“كارت‌هايى با ارزش ذخيره شده وجود دارد كه به مشتريان امكان مى‌دهد پول را در يك ريز تراشه موجود در قطعه‌اى پلاستيك ذخيره كنند. اين كارت‌ها را مى‌توان همانند يك كارت اعتبارى حمل كرد. سيستم‌هاى مبتنى بر رايانه براى استفاده از اين كارت‌ها وجود دارد مانند سيستم‌هايى كه امكان پرداخت در اينترنت دارند. صحبت‌هايى درباره سيستم‌هاى پيوندى شنيده مى‌شود كه مى‌توانند امكان پرداخت به وسيله كارت هوشمند و مبتنى بر شبكه را به طور همزمان فراهم آورند.” (در زمان نوشته شدن اين متن، اين سيستم‌ها هنوز در مراحل ابتدايى بودند و براى استفاده عمومى توليد نشده بودند). در بعضى انواع جرايم رايانه‌اى مانند “پولشويى رايانه‌اي” استفاده از يك رايانه، شناسايى يا اثبات جرم را دشوارتر مى‌كند. “ناخنك زدن” جرمى است كه در آن از رايانه براى جابجايى الكترونيك پول، از صدها يا هزاران حساب جداگانه استفاده مى‌شود . به دليل آنكه مقادير سرقت شده كوچك هستند، بيشتر صاحبان حساب‌ها متوجه اين سرقت نمى‌شوند اما اين مقادير كم، با هم جمع مى‌شود و نهايتاً سارق در پول غلت خواهد زد.

تقلب در بيمه (دروغ گفتن به يك شركت بيمه به منظور بدست آوردن پول بيمه نامه) تقلب در سرمايه گذارى و كار در خانه، همگى در فضاى رايانه‌اى نيز وجود دارند. يك روزنامه نگار مى‌نويسد كه اين امكان براى “سارقان رايانه‌اي” وجود دارد كه در رايانه‌هاى شركت‌هاى كشتيرانى، براى “كشتى‌هاى خيالي” قرارداد بيمه ببندند سپس اين كشتى‌ها را غرق شده اعلام كنند و پول بيمه نامه را دريافت كنند. اگرچه تقلب در بيمه احتمالاً عمرى به اندازه خود بيمه دارد اما استفاده از رايانه‌ها براى ارتكاب اين نوع جرايم و سپس از بين بردن ردپاى آن واقعاَ جديد است.

گاهى اوقات مرز ميان جرايم رايانه‌اى و جرايم معمولى چندان واضح نيست. براى مثال در ميشيگان سه پرونده مختلف تقلب در استفاده از ماشين فروش بليت مترو وجود داشت. حكم قاضى اين پرونده‌ها آن بود كه تقلب در استفاده از اين ماشين‌ها مشمول جرايم رايانه‌اى نمى‌شود زيرا اين ماشين‌ها چيزى بيشتر از يك ماشين فروش ليموناد ندارند. به بيان ديگر، اين جرم عليه يك ماشين فروشنده ارتكاب يافته بود نه يك رايانه.

وسعت بى اندازه جرايم رايانه‌اى به اين معنى است كه همگى ما بايد بدون توجه به سطح تخصصمان در رايانه ، مراقب امنيت رايانه‌اى خود باشيم. سيستم‌هاى مالى جهانى، سازمان‌هاى دفاعى و شركت‌هاى تجارى خصوصى، اتكاء شديدى به رايانه دارند. رى كلى (Ray kelly) معاون اجرايى وزارت دارايى مى‌گويد: “به دليل آنكه مجازاً هر جنبه از زندگى روزمره آمريكايى‌ها، امروزه در قالب اطلاعات به زيرساخت‌هاى رايانه‌اى وارد مى‌شود، همگى ما بايد مراقب آن باشيم.”

باك بلوم بكر معتقد است بدون توجه به اينكه ما واقعاً از رايانه‌ها استفاده مى‌كنيم يا نه، به دليل آنكه همگى ما بر رايانه‌ها تكيه داريم، “همه ما كاربران رايانه هستيم.” ما نبايد جرايم رايانه‌اى را به عنوان يك فعاليت نامربوط به خود در نظر بگيريم زيرا باعث مى‌شود چشم ما بر روى مخاطراتى كه اين جرايم براى هريك از ما پديد مى‌آورند، بسته شود.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

08:01 PM

January 13, 2005

نگاهي به قابليت‌هاي لينوكس

شنبه، ۱۰ مردادماه ۱۳۸۳

شرق - شايان سهند - چه بخواهيم چه نخواهيم، كامپيوتر جزيى از زندگى روزمره ما شده است. حتماً شما تا به حال كليپى را با كامپيوتر تماشا كرده‌ايد، از آهنگى با كيفيت ديجيتال لذت برده ايد، متنى را تايپ كرده‌ايد يا شبى را به گشت و گذار در دنياى اينترنت يا چت‌روم‌ها به صبح رسانده‌ايد! بستر اجرايى همه اين برنامه‌ها برنامه‌اى مادر به نام سيستم عامل است. به احتمال زياد شما يكى از نسخه‌هاى ويندوز مايكروسافت مانند ويندوز ۹۸ يا XP را استفاده مى كنيد. آيا تا به حال برايتان پيش نيامده كه كامپيوترتان خود به خود ريست شود يا يك روز صبح كه كامپيوتر اداره تان را روشن مى كنيد بالا آمدن ويندوزتان را نبينيد؟

آيا تا به حال به فكر امتحان كردن سيستم عامل ديگرى افتاده ايد؟ يك سيستم عامل با كارايى بيشتر: يك سيستم عامل امن، چند منظوره، قابل اعتماد و كاربردى به معناى واقعى كلمه، البته مقصود توليدات شركت انحصارطلب مايكروسافت يا سيستم عامل صنعتى يونيكس (Unix) و يا سيستم گرانقيمت اپل مكينتاش (Apple Macintosh) نيست. ما مى خواهيم از سيستم عامل ديگرى صحبت كنيم: سيستم عامل «آزاد» لينوكس (Linux).

اگر چه «لينوكس» خالق مشخصى ندارد، ولى اين «لينوس توروالدز» (Linus Torvalds) دانشجوى فنلاندى بود كه در ۲۵ آگوست ۱۹۹۱، اين راه را آغاز كرد. او از همان ابتدا روياى ايجاد يك سيستم عامل اپن سورس (Open Source) يا بازمتن با كارايى بالا، ضريب اطمينان فوق العاده و امنيت باور نكردنى را در سر مى پروراند. صحبت از بازمتن بودن «لينوكس» به ميان آمد؛ كسانى كه تا اندازه اى با زبان هاى برنامه نويسى آشنايى دارند مى دانند كه سيستم عامل هايى مانند ويندوز مايكروسافت كه خود را در دسترس همگان قرار نمى دهند و آنچه كه كاربران خريدارى مى كنند، تنها برنامه قابل اجرايى است كه هيچ اطلاعاتى از جزئيات درونى كاركرد سيستم عامل را نمى توان از آن فهميد. اما در مورد «لينوكس» وضع به گونه ديگرى است؛ به اين صورت كه سورس يا متن «لينوكس» براى كليه علاقه مندان و برنامه نويسان باز و قابل تغيير و بهينه سازى است.

«لينوس توروالدز» هسته «لينوكس» موسوم به كرنل را تحت امتياز «جى پى ال» (GPL: GNU General Public License) منتشر كرد، طبق اين امتياز كه در برابر امتياز انحصارطلبانه «كپى رايت» (Copyright)، «كپى لفت» (Copyleft) ناميده مى شود، كاربران و برنامه نويسان اجازه هرگونه دخل و تصرف در كد برنامه ها، استفاده مجدد از كل يا بخشى از برنامه ها در برنامه اى ديگر و فروش يا پخش مجدد برنامه ها را دارند؛ به شرط اينكه ماهيت بازمتن برنامه ها تحديد نشود و تمام حقوق «كپى لفت» به خريدار نيز منتقل شود.

به گفته «توروالدز» «فراهم كردن اين امكان كه «لينوكس» آزادانه در اختيار علاقه مندان قرار گيرد، قطعاً درست ترين تصميم زندگى ام بوده است. همه دست به دست هم مى دهند تا «لينوكس» را كاراتر نمايند و هر يك نيز به نوعى نتيجه كوشش خود را مى گيرند. اين برگ برنده اى است كه «لينوكس» در برابر سيستم عامل هاى رقيب در دست دارد: شما به واسطه همكارى با اين پروژه آزاد چون قطره اى به درياى پهناور «لينوكس» وارد مى شويد.»

«لينوس توروالدز» اولين هسته «لينوكس» را ايجاد كرد چرا كه مانند تمامى برنامه نويسان ابتداى دهه نود ميلادى، او نيز فقدان يك سيستم عامل بازمتن را براى پيشرفت پروژه گنو (GNU) احساس مى كرد. پروژه گنو يك جنبش نرم افزارى بين المللى جهت «ايجاد يك سيستم شبيه يونيكس كاملاً آزاد» است كه «ريچارد استالمن» (استاد سابق دانشگاه MIT) در سال ۱۹۸۴ آن را پايه گذارى كرده بود. هدف «استالمن» از آغاز اين پروژه تحت لواى بنياد نرم افزارهاى آزاد (FSF: Free Software Foundation) ايجاد شرايطى بود كه در آن هيچ كس نيازى به پرداخت پول براى خريد و استفاده از نرم افزار نداشته باشد. در حقيقت اگر اين اتفاق نمى افتاد استفاده شايسته از كامپيوتر در انحصار عده قليل متمولين قرار مى گرفت.

هسته لينوكس به دست دانشجويان و برنامه نويسانى از سراسر جهان پرورده شد و در كنار ساير برنامه‌هاى پروژه گنو به صورت توزيع هايى با كاربرد عام يا خاص در اختيار عموم قرار گرفت. از آنجايى كه بسيارى از نرم افزارهاى مهم درون سيستم عامل لينوكس از محصولات پروژه گنو است نام صحيح اين سيستم عامل «گنو / لينوكس» است. آنچه كه من و شما به عنوان يك توزيع لينوكس از آن استفاده مى كنيم در واقع نمونه اى است از يك هسته واحد - كه لينوكس ناميده مى شود _ به همراه ابزارهايى كه در پروژه بازمتن گنو توليد شده اند. تعداد توزيع هاى كنونى لينوكس دقيقاً مشخص نيست ولى با مراجعه به سايت www.linux.org مى توانيد فهرستى از حدود ۲۵۰ توزيع ثبت شده لينوكس را ببينيد. در واقع تفاوت توزيع هاى مختلف لينوكس تنها در پشتيبانى و ابزارهايى است كه به همراه هسته عرضه مى شوند. از جمله مهمترين توزيع هاى لينوكس مى توان توزيع هاى ردهت (Redhat)، دبيان (Debian)، مندريك (Mandrake)، زوزه (Suse)، اسلك ور (Slackware) و جنتو (Gentoo) را نام برد.

مسئله اى كه مطرح مى شد اين بود كه آيا بازمتن بودن لينوكس و فقدان سازنده خاص براى آن باعث كندى پيشرفت آن نمى شود؟ روند قضايا نشان داد كه اين گونه نبود، چرا كه همان طور كه «لينوس توروالدز» نيز گفته است «اغلب برنامه نويسان خوب براى كسب مستقيم درآمد برنامه نمى نويسند، بلكه هدف آنها از اين كار رسيدن به لذت خلق كردن است، لذتى كه با ديدن حاصل كار آنها را فرا مى گيرد.» شاهد اين ماجرا همكارى جمع دوستانه چهارصد هزار نفرى پروژه گنو براى توسعه «لينوكس» است در حالى كه جمع برنامه نويسان مايكروسافت از ده هزار نفر بيشتر نيست. البته بد نيست بدانيد كه بخش قابل توجهى از انرژى برنامه نويسان پروژه گنو صرف خنثى سازى كارشكنى هاى توليدكنندگان نرم افزار مى شود.

به عنوان نمونه شركت مايكروسافت از در اختيار قراردادن جزئيات شيوه پارتيشن بندى NTFS - يكى از روش هاى قرار دادن اطلاعات روى هارد ديسك _ به عموم خوددارى مى كند. در نتيجه برنامه نويسان پروژه لينوكس مجبور شدند اين شيوه را به روش آزمون و خطا و مهندسى معكوس كشف كنند. به همين دليل است كه اكنون كليه بسته هاى نرم افزارى مجانى كه با پارتيشن NTFS كار مى كنند، فقط امكان خواندن از آن را براى كاربر فراهم مى نمايند و توانايى نوشتن را با هشدار و به مسئوليت كاربر در اختيار او مى گذارند.

از طرفى ديگر عدم همكارى توليدكنندگان سخت افزار با برنامه نويسان پروژه «گنو / لينوكس» نيز باعث شده است كه همه بار توليد راه انداز سخت افزار بر دوش برنامه نويسان پروژه گنو بيفتد. اتفاقى كه افتاده يادآور جمله معروف گاندى است: «ابتدا تو را ناديده مى گيرند، سپس مسخره ات مى كنند و بعد با تو مى جنگند. ولى در نهايت پيروزى از آن توست.» و به جرات مى توان گفت كه «لينوكس» تا يك قدمى پيروزى پيش آمده است، امروزه حدود ۷۰ درصد از كل اطلاعات اينترنت بر روى سرويس دهنده هاى تحت سيستم عامل «لينوكس» قرار دارد. شركت اوراكل، مطرح ترين توليدكننده برنامه هاى ايجاد و مديريت بانك هاى اطلاعاتى آخرين نسخه برنامه خود را فقط براى اجرا بر بستر «لينوكس» عرضه كرده است.

اين همه اطمينان به «لينوكس» براى چيست؟ براى آنكه جهان امروز بيش از هر چيز جوياى امنيت است؛ امنيتى كه در «لينوكس» به واسطه ديواره آتش و لايه هاى امنيتى مختلف فراهم شده است. تقريباً هيچ ويروسى براى «لينوكس» شناخته نشده است و كرم هاى رايانه اى (برنامه هاى مخرب) نهايتاً توانايى از بين بردن محتويات دايركتورى خانگى يك كاربر _ نه كل سيستم _ را دارند. اين طور نيست كه «لينوكس» فاقد هرگونه اشكال امنيتى باشد. ولى بازمتن بودن آن باعث مى شود بسيارى از اشكالات امنيتى، پيش از ايجاد خسارت و در مراحل توسعه و برنامه نويسى كشف و اصلاح شوند. در صورتى كه در سيستم عامل ويندوز براى مشخص شدن ضعف هاى امنيتى بايد هزينه سنگين ناشى از خسارت هاى آنها را بپردازيم.

از ديگر مزاياى «لينوكس» مى توان به پايدارى بسيار بالا به دليل طراحى درست هسته، عدم از كار افتادن كل سيستم به علت اشكال در يك قسمت از آن، سرعت بالاى سيستم عامل، توانايى اجراى همزمان چند وظيفه از سوى چند كاربر، چندكاربرى بودن به معناى واقعى و قابليت اجرا بر روى سخت افزارهاى مختلف را نام برد. سيستم عامل «لينوكس» حتى اين امكان را دارد كه از آن بتوان به صورت يك سيستم زنده و قابل حمل استفاده كرد؛ يعنى مى توان آن را بدون نيازى به نصب و از روى يك سى دى اجرا كرد؛ نام يكى از توزيع هاى اين «لينوكس» زنده «ناپيكس» (Knopixx) است. نسخه اى فارسى از «ناپيكس» ساخته شده كه نام آن «شبديكس» است.

نشان «لينوكس» يك پنگوئن است. برخلاف ساير سيستم عامل هاى تجارى، اين نشان زياد جدى نيست! اين پنگوئن تنبل نشسته كه «توكس» نام دارد، مظهر پايدارى «لينوكس» است. اين نشان داستان جالبى دارد. «لينوكس» در ابتدا هيچ علامتى نداشت. هنگامى كه «لينوس توروالدز» براى تعطيلات به استراليا رفته بود، موقع بازى با يك پنگوئن، دست او را گاز گرفت! همين ايده اى شد تا از به عنوان نشان «لينوكس» استفاده كند.

• لينوكس در ايران
حدود دو سال است كه دولت جمهورى اسلامى ايران پروژه اى را براى فارسى سازى «لينوكس» و نهايتاً توليد سيستم عامل ملى تدوين كرده است. تصويب اين طرح به پيشنهاد «مركز فناورى اطلاعات و ارتباطات پيشرفته شريف» (AICTC) و با مديريت اين مركز انجام شد. اين پروژه از پنج پروژه زير تشكيل شده است:
۱ _ توسعه نرم افزارهاى منبع آزاد
۲ _ تدوين استراتژى استفاده از نرم افزارهاى منبع آزاد
۳ _ پروژه لينوكس فارسى
۴ _ توسعه كاربردهاى لينوكس
۵ _ تشكيل انجمن Open Source ايران

طبق برنامه زمان بندى شده نيمه سال ۲۰۰۶ ميلادى بايد شاهد اتمام اين پروژه باشيم!

• لينوكس: يكى از زيباترين دستاوردهاى بشرى
لينوكس در سايه همكارى و تبادلات علمى هزاران نفر در سرتاسر جهان ايجاد شده و توسعه يافته است. گستردگى اين مشاركت به قدرى است كه سيستم عامل لينوكس را «زيباترين دستاورد همكارى جمعى بشر» ناميده اند. فرهنگى كه بر جامعه لينوكس و بازمتن حاكم است فرهنگ يارى، اشتراك اطلاعات و تلاش براى بهبود هر چه بيشتر محصولات است. هر كس مى خواهد با اين سيستم عامل كار كند، بايد تمامى ديدگاه ها و عقايد قبلى خود را درباره نرم افزار و سيستم عامل كنار بگذارد و با يك ديدگاه جديد وارد دنياى لينوكس شود، چون «لينوكس» در جهانى با فرهنگ متفاوت زندگى مى كند.

• سايت هايى در مورد لينوكس

هسته لينوكس:
Kernel. Org

كدها و بسته هاى نرم افزارى لينوكس:
www.sourceforge.net
www.rpmfind.net
www.linux.org

پخش هاى لينوكس:
www.redhat.com

زيربناى محيط گرافيكى:
www.x.org

پروژه KDE:
www.kde.org

پروژه Gnome:
www.gnome.org

پروژه سيستم عامل ملى:
www.farsilinux.org

لينوكس براى ايرانيان:
www.technotux.com

منابع:
www.technotux.com
www.gnu.org
www.linux.org
kernel.org
www.linuxiran.org
www.farsilinux.org

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

08:02 PM

January 13, 2005

آيا گوگل به شما لبخند خواهد زد؟

شنبه، ۲۸ آذرماه ۱۳۸۳

مهدي رودكي - اگر گوگل به شما لبخند بزند، تمام بازار به شما لبخند مي‌زند. اما گوگل دختر طنازی است که تنها به پسران پرمغز و رعنا لبخند مي‌زند. اين پسران همان سايت‌های پرمحتوا و محبوبی هستند که از ساختاری مناسب در طراحي برخوردارند.

سايت شما در اينترنت همانند کتابي مهم در کتابخانه‌اي بزرگ است. شما سايت را طراحي کرده‌ايد تا از آن استفاده شود، کتاب نيز نوشته شده است تا خوانده شود. براي آنکه راهنماي اين کتابخانه کتاب شما را به ديگران توصيه کند، کتاب شما ضمن داشتن محتواي مناسب بايد بتواند نظر مساعد وي را نيز جلب کند.
شايد مجبور باشيد هر هفته جلد کتاب خود را تغيير دهيد، يا بعضي از صفحات آنرا به روز رساني نماييد. اما اين کتابداران هر هفته عوض مي‌شوند و شما بايد به طور مداوم وقت خود را صرف شناسايي رفتار اين کتابداران نماييد به اين اميد که کتاب شما را توصيه کنند. آيا شما وقت اين کار را داريد؟

راه حل منطقي همواره اين است که شما زبان مشترکي با اين کتابداران بيابيد تا بهتر يکديگر را تفهيم نماييد. در اين کتابخانه تنها کتاب شما وجود ندارد بلکه هزاران کتاب ديگر با همان موضوع کتاب شما نيز وجود دارند. مولفان اين کتابها هم در جست‌وجوي زبانی مشترک با کتابداران هستند، آنها هم مي‌خواهند کتابشان خوانده شود. چه بايد کرد؟

راهنمايان اينترنت، يا همان موتورهاي جست‌وجوگر نيز همين رفتار را با سايتها دارند. آنها براي هر موضوع هزاران سايت می شناسند اما تنها چند سايت را قبل از همه در نتايج جست‌وجو قرار مي‌دهند و به ديگران معرفی مي‌کنند. شما با چه زباني مي‌توانيد موتور جست‌وجوگر را متقاعد کنيد که سايت شما را اول از همه به ديگران توصيه کند؟

برخي از موتورهاي جست‌وجوگر را با پول مي‌توان متقاعد کرد. به عبارت ديگر هر سايتي که پول بيشتري بپردازد، در ابتدا به همه معرفي مي‌شود. به اين موتورهاي جست‌وجوگر رتبه بازاي پول مي‌گويند نظير Overture.com .
اما قدرت موتورهاي جست‌وجوگر جاي ديگري نهفته است. آنجا که شما با هر مقدار پول باز هم نمي‌توانيد در نتايج جست‌وجو حضور داشته باشيد و راهی به ابتدای نتايج بيابيد. اين موتورهاي جست‌وجوگر خريديني نيستند و شما نمي‌توانيد برای سايت خود رتبه‌ای بخريد. اينجا رتبه‌ها را بايد به چنگ آوريد و به طور مداوم برای حفظ آنها بايد تلاش کنيد.

خوشبختانه، اين گونه موتورهای جست‌وجوگر متقاعد شدني هستند. به عبارت ديگر شما با دانستن اصول و قواعد آنها، مي‌توانيد زبانی مشترک با آنها داشته باشيد. اگر بتوانيد اين زبان مشترک را بيابيد آنگاه سايت شما حتي مي‌تواند در صدر نتايج جست‌وجو قرار بگيرد. به اين رتبه‌ها، رتبه‌هاي عادي (طبيعي) موتور جست‌وجوگر مي‌گويند.

حال بار ديگر اين سوال مطرح مي شود که اين زبان مشترک را چگونه مي يابيد؟ SEO به عنوان ابزار اصلي بازاريابي الکترونيک يک تخصص بسيار جدي است. تخصصي که يک هنر است: هنر کسب رتبه‌هاي بالا در گوگل و موتورهاي جست‌وجوگر ديگر! SEO کسي است که اين هنر را به خوبي مي‌داند. او زبان مشترک براي ارتباط با موتور جست‌وجوگر را مي داند.
او مي داند که رفتار موتور جست‌وجوگر در طول زمان چگونه بوده است و امروز چه رفتاري دارد. او به خوبي مي‌داند که موتور جست‌وجوگر هر روز سازي را کوک مي‌کند و باز هم اوست که اين سازها را به خوبي مي‌شناسد. او به خوبي مي‌داند که چگونه راه ورود موتور جست‌وجوگر به سايت شما را هموار کند و سايت شما را برايش دوست داشتني نمايد.

کيست که گوگل را نشناسد و نام آنرا نشنيده باشد. اگر گوگل به شما لبخند بزند، تمام بازار به شما لبخند مي‌زند. اما گوگل دختر طنازی است که تنها به پسران پرمغز و رعنا لبخند مي‌زند. اين پسران همان سايت‌هاي پرمحتوا و محبوبی هستند که از ساختاری مناسب در طراحي برخوردارند.

SEO مي‌تواند سايت شما را براي گوگل و هر موتور جست‌وجوگر ديگري جذاب نمايد، ساختار آن را اصلاح کرده، قابليت‌هاي آن را به خوبي عرضه کند به گونه‌اي که بتواند در ميان سايت‌هاي ديگر سر راست کند.
شما اگر اين زبان مشترک را نمي‌دانيد از يک SEO کمک بگيريد. يا حداقل يک SEO را دوست داشته باشيد و توصيه‌های وی را گوش کنيد. همچنين مي‌توانيد خود يک SEO باشيد تنها کافيست که چند ماه زمان صرف کنيد و لحظه به لحظه همراه موتورهای جست‌وجوگر باشيد!
آيا گوگل به شما لبخند خواهد زد؟

منبع: رهنمون

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 24 دیماه 1383

08:05 PM

January 13, 2005

طرح استفاده فراگير از سيستم عامل لينوكس در كشور(در مواجهه با چالش‌هاي پيش رو)

طرح استفاده فراگير از سيستم عامل لينوكس در كشور
(در مواجهه با چالش‌هاي پيش رو)
نويسنده: عليرضا توكلي
كارشناس دفتر همكاري‌هاي فناوري

1- مقدمــه
در هر كامپيوتر، حداقل يك سيستم عامل وجود دارد. سيستم عامل مهم‌ترين برنامه نصب‌شده در كامپيوتر است كه وظايف اصلي ذيل را برعهده دارد:
- مديريت و سازماندهي برنامه‌ها، پرونده‌ها و نرم‌افزارها
- راه‌اندازي، مديريت و بكارگيري سخت‌افزار
- برقراري ارتباطات بين استفاده كننده كامپيوتر، نرم‌افزار و سخت‌افزار
- مديريت و سازماندهي ارتباط با شبكه
به يك تعبير ساده مي‌توان گفت سيستم عامل نقش «روح» را در پيكر سخت‌افزار و شبكه ايفا مي‌كند.

تصميم درخصوص انتخاب سيستم عامل كليه ابعاد فني كامپيوتر و فناوري اطلاعات را تحت‌الشعاع قرار مي‌دهد و هر سيستم عاملي كه انتخاب شود خشت اول و زيربناي توسعه‌ فني و نرم‌افزاري فناوري اطلاعات را مشخص مي‌كند.

اين طرح بنا دارد چالش‌ها و تهديدهاي ناشي از فقدان يك سيستم عامل مناسب در كشور را مطرح و با بررسي تجربه و رويكرد ساير كشورها در مواجهه با اين چالش‌ها، راه حل عملي براي رسيدن به سيستم عامل ايده‌آل ملي را نشان دهد. در انتها نيز راهبردها و راهكارهاي دولت براي توسعه و ترويج اين سيستم عامل بيان خواهد شد.

2- چالش‌ها و تهديدهاي ناشي از فقدان يك سيستم عامل مطلوب در كشور
1-2- چالش اقتصادي: استفاده از رايانه و شبكه‌هاي رايانه‌اي در كشورهاي مختلف دنيا و ازجمله در ايران، به سرعت در حال رشد و گسترش است. براي استفاده از هر رايانه نيز حداقل يك سيستم عامل بايد روي آن نصب شده باشد. بنابراين تعداد كاربران رايانه، حداقل سيستم‌عامل‌هاي مورد نياز در يك كشور را تعيين مي‌كند.

در مرجع(1) رشد تعداد كاربران اينترنت در دنيا مشخص شده است. همانطور كه در اين مرجع بيان شده، تعداد كاربران جهاني شبكه رايانه‌اي از كمتر از 20 ميليون نفر در سال 1995 ميلادي به حدود 100 ميليون نفر در سال 1997 ميلادي و 400 ميليون نفر در سال 2000 ميلادي رسيد و پيش‌بيني مي‌شود در سال 2005 ميلادي به حدود يك ميليارد كاربر برسد.
در كشور ما نيز تعداد كاربران شبكه‌هاي اطلاع‌رساني و اينترنت از 1/8 ميليون نفر در سال 1380 به 6 ميليون نفر در سال 1382 رسيد كه پيش‌بيني مي‌شود در سال 1384 به 19 ميليون نفر برسد.(2) بنابراين درصورتي كه سيستم عامل ويندوز، سيستم عامل اصلي در كشور باشد و با عنايت به لزوم پيوستن ايران به سازمان تجارت جهاني و رعايت حقوق مالكيت معنوي و تعهدات بين‌المللي، سالانه هزينه هنگفتي بايد صرف خريد نرم‌افزار و مجوزهاي استفاده از آنها بشود.
جدول (1) هزينه‌هاي پايه ويندوز و نرم‌افزارهاي اصلي نوشته‌شده تحت آن را نشان مي‌دهد(3) (قيمت‌ها از سايت Amazon در تيرماه 83 اخذ شده است).

جدول 1: هزينه‌هاي پايه ويندوز و نرم‌افزارهاي اصلي نوشته‌شده تحت آن

جدول فوق نشان مي‌دهد كه هر كامپيوتر حداقل 710 دلار بايد صرف نرم‌افزارهاي اصلي (Windows+office) كند. هزينه نرم‌افزار سرور كه در سازمان‌ها و شركت‌ها مورد نياز است بر تعداد كامپيوترهايي كه به سرور وصل مي شوند تقسيم مي‌شود، بنابراين براي محاسبه هزينه به ازاي هر كامپيوتر بايد هزينه نرم افزار سرور يعني مبلغ 3.679/95 دلار تقسيم بر 25 گردد كه بيش از 174 دلار مي‌شود. با فرض اينكه 50% كامپيوترهاي موجود در كشور نياز به امكانات شبكه داشته باشند، حداقل هزينه متوسط نرم‌افزار به ازاي هر كامپيوتر 783/5 دلار خواهد شد. اگر بخواهيم در يك سال براي كليه 19.000.000 كامپيوتر پيش‌بيني شده نرم‌افزار بخريم، هزينه آن برابر 14.886.500.000 دلار خواهد شد. به عبارت ديگر سود يك سال درآمد نفت كشور را بايد صرف خريد نرم‌افزار بنماييم. اگر فرض كنيم تا 5 سال بعد از آن نياز به ارتقاي نرم‌افزارها نباشد هزينه متوسط سالانه نرم‌افزار حداقل 2.977.000 دلار در سال خواهد شد.

بنابراين به طور متوسط حدود 3 ميليارد دلار در سال صرف خريد نرم‌افزار خواهد شد.( اين برآورد حداقل هزينه مورد نياز است، جهت صحت اين ادعا كافيست هزينه 783/5 دلار به ازاي هر كامپيوتر در ايران را با هزينه حدود 6000 دلار به ازاي هر كامپيوتر از 1/2 ميليون كامپيوتر موجود در ادارات دولتي تايوان مقايسه كنيد)(4)

2-2- چالش امنيت: گسترش شبكه‌هاي رايانه‌اي در سطح دنيا و امكان ارتباط همه كامپيوترها به يكديگر، پتانسيل نفوذ به هر كامپيوتر از هر جاي دنيا را فراهم نموده است. وجود نقطه ضعف يا آسيب‌پذيري در سيستم عامل، راه نفوذ رايج‌تر و در دسترس‌تري را در اختيار مهاجمين قرار مي‌دهد. بر اين اساس، امنيت سيستم عامل به منزله مهم‌ترين مولفه در امنيت اطلاعات و شبكه‌هاي رايانه‌اي محسوب مي‌شود. وجود ارتباطات و اتصال‌هاي رايانه‌اي گسترده، مسئله جدي امكان جاسوسي الكترونيكي به نفع سازندگان سيستم عامل و قدرت‌هاي سياسي حاكم بر آنها را مطرح مي‌سازد.
از نظر فني، فناوري فعلي به شكل ساده‌اي امكان اجراي برنامه در محيط طرف مقابل در يك اتصال الكترونيكي را فراهم آورده است.(4)

درصورت بي‌توجهي به اين مسئله بخشي از مشكلات امنيتي متصور به شرح ذيل است:
- شنود هوشمندانه
- واكشي تدريجي يا مقطعي اطلاعات
- خرابي برنامه‌ريزي‌شده تدريجي يا به يك‌باره
- ويروس‌هاي رايانه‌اي
- بدست‌گرفتن كنترل‌هاي رايانه‌اي
- مختل كردن كليه ارتباطات در شبكه‌هاي رايانه‌اي
- جايگزيني اطلاعات غلط در سيستم‌هاي نرم‌افزاري حساس
- مختل كردن برنامه‌هاي كاربردي به ويژه سيستم‌هاي نرم‌افزاري پشتيبان تصميم
- ايجاد اختلال اقتصادي از طريق تغيير يا خراب كردن اطلاعات بانك‌ها، سيستم‌هاي مالي و اعتباري
- مختل كردن عكس‌العمل‌هاي نظامي از طريق تخريب يا فريب سيستم‌هاي اداري و نظامي

اگر سيستم عامل ويندوز، سيستم عامل اصلي در كشور باشد، مسئله امنيت بسيار جدي است. بنا بر گزارش‌هاي رسيده سيستم عامل ويندوز و ساير نرم‌افزارهاي توليدي مايكروسافت بيشتر در معرض خطر ويروس‌ها و هكرها قرار دارند و بسياري از كشورها معتقدند كه ايالت متحده با منافذ وكانال‌هاي مخفي طراحي شده در اين سيستم عامل، اهداف جاسوسي خود را برآورده مي‌كند. مشكلات امنيتي ويندوز وقتي به نقطه اوج رسيد كه در سال 1999 يك متخصص رمزنگاري كانادايي در آمريكا، يك ويژگي NSAkey مرتبط با سازمان امنيت ملي (آمريكا) National Security Agency Key) را در ويندوز پيدا كرد و اعلام كرد كه ايالات متحده مي‌تواند با جمع‌آوري سيگنال‌هاي الكترونيكي از سرتاسر جهان و پردازش دقيق آنها جاسوسي كند. هر چند مايكروسافت اين ويژگي را بي‌ضرر اعلام كرد اما تضميني براي اين امر وجود ندارد(5)

اهميت مطالب فوق وقتي روشن مي‌شود كه توجه كنيم: بدون امنيت اطلاعات، امنيت سياسي اقتصادي و نظامي نيز ميسر نخواهد بود.

3- راه‌حل‌هاي موجود در مواجهه با چالش‌هاي اقتصادي و امنيتي سيستم عامل
با توجه به چالش‌ها و تهديدهاي ناشي از فقدان سيستم عامل مطلوب در كشور، تصميم درباره سيستم عامل پايه، يكي از راهبردي‌ترين تصميمات در برپايي بناي با شكوه فناوري اطلاعات مي‌باشد.
در برابر اين تصميم راهبردي سه گزينه اصلي ذيل وجود دارد:
- استفاده از سيستم عامل متن باز لينوكس (Open Source)
- استفاده از سيستم عامل ويندوز
- طراحي و پياده‌سازي يك سيستم عامل جديد با مديريت متخصصان ايراني

يكي از مدل‌هاي تصميم‌گيري براي انتخاب بهترين و مناسب‌ترين گزينه از راه‌حل‌هاي فوق، تعيين معيارها و ويژگي‌هاي سيستم عامل ايده‌آل براي جمهوري اسلامي ايران و سپس مقايسه هر يك از راه‌حل‌ها با سيستم عامل ايده‌آل و انتخاب منطبق‌ترين گزينه بر آن است.

4- ويژگي‌هاي سيستم عامل ايده‌آل ملي
براساس مدل گفته‌شده و با استفاده از نظرات كارشناسان خبره در حوزه سيستم عامل و فناوري اطلاعات، ويژگي‌هاي ذيل تعيين شده است:
- سيستم عامل ايده‌آل ملي، بايد زبان و خط فارسي را به خوبي پشتيباني نموده و از استانداردهاي بين‌المللي (مانند UniCode) بهره‌برداري نمايد.
- سيستم عامل ايده‌آل ملي، در ارتباط با كاربران ايراني از زبان فارسي استفاده نموده و بر اساس نيازها و شرايط استفاده‌كنندگان فارسي زبان، بومي شده باشد. اين امر، رشد چشمگيري در استفاده از فناوري اطلاعات در جامعه به همراه خواهد داشت.
- سيستم عامل ايده‌آل ملي، بايد قابليت ايجاد امنيت اطلاعات و ارتباطات بنا بر نياز سازمانها را داشته باشد، به گونه‌اي كه امكان جاسوسي الكترونيكي، سرقت يا خرابي تدريجي اطلاعات، شنود هوشمندانه و خرابي برنامه‌ريزي شده در زمان‌هاي ويژه و موارد مشابه را به حداقل برساند.
- در سيستم عامل ايده‌آل ملي، نكاتي مانند كاربر پسند بودن، شباهت محيطي با سيستم عامل‌هاي رايج، عملكرد مناسب، سازگاري با نرم‌افزارهاي موجود و پشتيباني از اسناد الكتريكي رايج لحاظ شده باشد.
- سيستم عامل ايده‌آل ملي، بايد براي استفاده كننده ايراني، پشتيباني و خدمات پس از عرضه كافي داشته و نهادهاي پشتيباني‌كننده آن مسووليت بر طرف كردن هر گونه اشكال در سيستم عامل را بپذيرند.
- سيستم عامل ايده‌آل ملي، بايد توانايي‌هاي ويژه‌اي در پياده‌سازي زيرساخت شبكه‌هاي ارتباطي -كه نقش جدي در توسعه فناوري اطلاعات و ارتباطات دارد- داشته باشد.
- امكان توسعه، تغيير و هر نوع اصلاح در سيستم عامل ايده‌آل ملي، بنابر نيازها و سياست‌هاي كشور و توسط كارشناسان داخلي وجود داشته باشد. اين امر مستلزم اين است كه سيستم عامل از لحاظ حقوق معنوي و اقتصادي متعلق به كشور ديگري نبوده و كد برنامه آن موجود باشد.
- هزينه و زمان دستيبابي و بهره‌برداري از آن معقول بوده و سازماندهي لازم براي توسعه آتي و همراهي آن با تحولات سريع سخت‌افزاري و نرم‌افزاري فناوري اطلاعات ايجاد شده باشد.(6)

5- انتخاب سيستم عامل مناسب براي كشور
در مقايسه هر يك از گزينه‌هاي مطرح‌شده با معيار و ويژگي‌هاي مطرح‌شده در بخش قبل، چنين مي‌توان جمع‌بندي كرد:
الف) گزينه «سيستم عامل ويندوز»: با توجه به اينكه:
- اين سيستم عامل متعلق به شركت مايكروسافت بوده و كد برنامه آن در اختيار نمي‌باشد لذا امكان تغيير آن بنا بر نيازها و سياست‌هاي كشور وجود ندارد.
- به لحاظ تأمين امنيت اطلاعات و ارتباطات -به دليل در اختيار نبودن كد برنامه آن و امكان گذاشتن كانال مخفي براي سرقت يا خرابي اطلاعات توسط شركت سازنده و آسيب‌پذيرتر بودن آن در مقابل ويروس- به هيچ عنوان قابل اتكا نمي‌باشد.
- به دليل آمريكايي بودن شركت مركزي مايكروسافت، نمي‌توان از آن انتظار پشتيباني رسمي و قابل اتكايي در ايران داشت.
- اگر ايران مجبور شود بنابر تعهدات بين‌المللي بهاي آن را بپردازد، ميزان هزينه پرداخت شده براي ويندوز و برنامه‌هاي كاربردي تحت آن و هزينه‌هاي ارتقا بسيار هنگفت است.
بنابراين سيستم عامل ويندوز عليرغم استفاده فعلي در كشور، گزينه مناسبي نيست و با سيستم عامل ايده‌آل تطبيق چنداني ندارد.

ب) گزينه «طراحي و پياده‌سازي يك سيستم عامل جديد با مديريت متخصصان ايراني» : اين گزينه با توجه به اينكه:‌
- به زمان و هزينه قابل توجه و هنگفتي كه دارد. (زمان و هزينه مورد نياز براي طراحي يك سيستم عامل جديد، با نگاهي به زمان و هزينه سيستم عامل‌هاي موجود، قابل بررسي است، توسعه سيستم عامل لينوكس از سال 1991 تاكنون -حدود 13 سال- ادامه داشته است و زمان توسعه ويندوز نيز بيش از اين مدت بوده است.)
- مديريت تخصصي، پيچيده و مستمري بر كارشناسان تا رسيدن به سر منزل مقصود را مي‌طلبد.
- به دليل نياز به سازگاري مستمر با نرم‌افزارها و سخت‌افزارهاي موجود و نسل‌هاي بعدي آنها -با توجه به پيشرفت‌ها و تحولات سريع سخت‌افزاري و نرم‌افزاري به وجودآمده- همراهي سيستم عامل جديد با شرايط روز و توسعه كارآمدي آن بسيار مشكل و شايد محال باشد.
انتخاب معقولي به شمار نمي‌آيد. بطور خلاصه انتخاب اين گزينه، هزينه، زمان هنگفت و مديريت تخصصي، پيچيده و مستمري را مي‌طلبد و در نهايت اين پروژه را سرعت تحولات سخت‌افزاري، نرم‌افزاري و نيازهاي روزافزون كاربران تهديد مي‌نمايد.

ج) گزينه «استفاده از سيستم عامل متن باز لينوكس» : سيستم عامل لينوكس سه ويژگي اساسي دارد:
اولين ويژگي آن اين است كه كد برنامه آن در اختيار همه بوده، و از قوانين ذيل (مجوز GPL) تبعيت مي‌كند:
- اجراي برنامه با هر موضوع، تحت اين سيستم عامل آزاد است.
- تغيير برنامه براي تطبيق با نيازها به شرط ذكر مأخذ آزاد است.
- توزيع نسخه تغيير يافته آن براي بهره‌برداري ديگران از تغييرات انجام‌شده آزاد است.
در اختيار بودن، كد لينوكس امكان فارسي‌سازي و بومي‌سازي سيستم عامل از سطح هسته اصلي تا لايه‌هاي كاربردي را امكان‌پذير ساخته و امنيت مورد نياز سازمان‌ها را با استفاده از نرم‌افزارهاي امنيتي داخلي امكان‌پذير مي‌سازد (براي ايجاد امنيت نمي‌توان به نرم‌افزارهاي خارجي -كه امكان تعبيه راه‌هاي نفوذ از پيش تعيين‌شده در آن مي‌باشد- اعتماد كرد)
دومين ويژگي آن، رايگان بودن آن است كه باعث شده حمايت جهاني برنامه‌نويسان، دانشگاه‌ها، مراكز علمي و تحقيقاتي و حتي شركت‌هاي تجاري را در اختيار داشته باشد، كشورهاي استفاده‌كننده نيز از اين ويژگي براي توسعه ارزان فناوري اطلاعات در بين آحاد جامعه بهره برده‌اند.
سومين ويژگي آن، همراهي با تحولات سخت‌افزاري و نرم‌افزاري فناوري اطلاعات است، دليل اين امر اين است كه تاكنون برنامه‌نويسان و سازمان‌هاي متعدد در بسياري از كشورها روي اين سيستم عامل كار كرده و در توسعه مستمر آن سهيم بوده اند. رويكرد متن باز لينوكس، مدل سازماني توسعه آن و وجود ابزارهاي برنامه‌نويسي قوي و رايگان، همراهي آن با تحولات بين‌المللي را تضمين مي‌نمايد.

اين ويژگي‌ها باعث شده كه زمينه و امكان تامين اكثر معيارها و ويژگي‌هاي مورد نظر براي سيستم عامل ايده‌آل ملي توسط اين سيستم عامل وجود داشته باشد.

6- رويكرد و تجربه ساير كشورها
نكته جالب توجه اين است كه جايگزيني لينوكس در سازمان‌هاي دولتي، نه تنها در كشور ما به عنوان يك راه‌حل مناسب مدنظر كارشناسان و مسئولين قرار گرفته بلكه در كشورهايي مانند آلمان و انگلستان كه رابطه سياسي خوبي با آمريكا دارند و درآمد سرانه آنها چند برابر درآمد سرانه كشور ماست مورد توجه قرار گرفته است:

انگليس: پارلمان اين كشور براي توسعه نرم‌افزار و كاهش هزينه‌هاي رقابتي به ويژه در شركت‌هاي نوپا، رويكرد متن باز را به دولت توصيه كرده است. كابينه انگلستان در دسامبر 2001 ميلادي در متني تحت عنوان «نرم‌افزارهاي متن باز و استفاده آنها در دولت بريتانيا» دلايل مشاركت انگلستان در رويكرد متن باز و استفاده از اين محصولات در دولت را ذكر كرده است. در اين متن كه به مراكز دولتي اعم از وزارتخانه‌ها و آژانس‌هاي وابسته به آنها، دولت‌هاي محلي و بخشهاي ديگر ازجمله خدمات بهداشت ملي ارسال شده است. دلايل استفاده از نرم‌افزارهاي متن باز و سيستم عامل متن باز به عنوان يك نرم‌افزار مهم پايه‌اي به اين صورت بيان شده است:
- نياز هميشگي به راه حلي با صرفه اقتصادي
- اطمينان از سازگاري سيستم‌ها
- كاهش هزينه‌ها و ريسك در سيستم‌هاي دولتي
- امنيت سيستم‌هاي دولتي
در اين بررسي با استناد به يك گزارش خبري به ناامني نرم‌افزار Microsoft IIS به عنوان يك نرم‌افزار متن بسته اشاره شده و آمده است كه برخي از نرم‌افزارهاي متن بسته، ناامن‌تر از سيستم‌هاي متن‌باز هم‌تراز خود مي‌باشند و حملات اينترنتي به آنها كمتر صورت گرفته است. اين متن در 15 جولاي 2002 ميلادي به عنوان دستورالعمل اجرايي به سازمان‌ها ابلاغ گرديد و هم‌اكنون در سازمان‌هايي مانند e-envoy وسازمان تجارت دولتي (OGC) در حال اجرا است.

آمريكا: در اين كشور نيز همچون ساير كشورها، سيستم‌هاي متن باز در حال گسترش مي‌باشند. به عنوان نمونه شركت IBM، تعدادي كامپيوتر مبتني برلينوكس را به آژانس‌هاي آمريكايي شامل نيروي هوايي، دفاع، كشاورزي، انرژي و سازمان هواپيمايي فروخته است. بورس اصلي آمريكا (wall street) لينوكس را به عنوان سيستم عامل خود برگزيد، به اين دليل كه ويندوز را ايمن نمي‌دانست.
وزارت دفاع آمريكا با كمك سازمان تحقيقاتي دولتي Mitre گزارشي از نرم‌افزارهاي مورد استفاده در وزارت دفاع تهيه كرد كه شامل ميزان استفاده، نوع استفاده و دلايل استفاده از اين نرم‌افزارها بود.(8) در اين بررسي دو هفته‌اي (مارس 2002 ميلادي) مشخص شد كه 110 نرم‌افزار متن باز در وزارت دفاع استفاده مي‌شود كه چهار دليل عمده براي استفاده از آنها به شرح ذيل است:
- پشتيباني نرم‌افزاري‌هاي زيربنايي : اساسي‌ترين دليل براي استفاده از نرم‌افزارهاي متن باز است. 65 نرم‌افزار زيربنايي در وزارت دفاع وجود دارد. نمونه‌هايي از آنها عبارتند از : سيستم عامل Open BSD، لينوكس و سرويس‌دهنده‌هاي Apache و SendMail
- توسعه و توليد نرم‌افزار
- امنيت: چهل ابزار امنيتي در وزارت دفاع استفاده مي‌شود كه مي‌توان از Open BSD و لينوكس به عنوان Fire wall و بازرسي شبكه و نرم‌افزارهايي چون ACID, Snare, SARA كه براي يافتن آسيب‌پذيري‌هاي امنيتي شبكه و مراقبت براي تشخيص حمله به شبكه، به كار مي‌روند نام برد.
- تحقيقات : بيست ابزار نرم‌افزاري به عنوان ابزارهاي تحقيقاتي با كمك‌تحقيقاتي در وزارت دفاع در حال استفاده هستند. در اين گزارش از سيستم عامل لينوكس به همراه نرم‌افزار خوشه‌بندي Beowolf و نرم‌افزار condor به عنوان ابزاري مناسب براي تبديل كامپيوترهاي قديمي و ارزان به ابركامپيوترهاي بسيار كم‌هزينه نام برده شده است.(9)

آفريقاي جنوبي: انجمن ملي مشاور در امور نوآوري با نام اقتصادي NACI در گزارشي به مقوله استفاده از نرم‌افزارها و توليد آنها و هزينه‌هاي ارزي كه از اين بابت از كشور خارج مي‌شود پرداخته است. در اين گزارش تأكيد شده كه هزينه نرم‌افزار، بار سنگيني را بر كشورهاي در حال توسعه مانند آفريقاي جنوبي مي‌گذارد و بايد سياست اين كشورها به گونه‌اي تغيير يابند كه ورود نرم‌افزارها با كمترين هزينه صورت پذيرد. در ادامه، زيرپاگذاشتن قوانين حق تكثير، انتخاب نامناسبي شمرده شده و به لزوم استفاده از نرم‌افزارهاي متن باز اشاره شده است . از اين طريق مي‌توان توليدات داخلي را جايگزين محصولات گران خارجي نمود. در اين گزارش مزاياي اصلي سيستم‌هاي متن باز بدين صورت عنوان شده است:
- كاهش هزينه‌ها و وابستگي كمتر به فناوري‌ها و مهارت‌هاي وارداتي
- امكان استفاده از نرم‌افزارها براي همه افراد و ارگان‌ها
- دسترسي همگاني به نرم‌افزار بدون نياز به هزينه مالكيت
- مانع كمتر براي ورود به بازار كه باعث مشاركت شركت‌هاي كوچكتر و درنتيجه افزايش مهارت‌هاي محلي مي‌گردد.
- شركت در شبكه جهاني توليد نرم‌افزار
يك نمونه عملي در آفريقاي جنوبي تبديل محيط گرافيكي KDE در لينوكس به محيط KDE با زبان بومي است. اين پياده‌سازي در سه ماه انجام شد كه نشان‌دهنده سادگي تبديل و اختصاصي كردن اين گونه نرم‌افزارهاست.

سه كشور چين، ژاپن و كره جنوبي، پروژه مشتركي براي توسعه گونه‌اي از سيستم عامل متن باز لينوكس تعريف كرده‌اند كه سيستم عامل اصلي در اين سه كشور خواهد شد. اين كشورها استفاده از اين سيستم عامل در مدارس را شروع كرده و در حال تربيت نسلي آشنا به لينوكس مي باشند.

7- وضعيت و فعاليت‌هاي انجام شده در كشور
در كشور ما از دي ماه سال 1381 شوراي عالي انفورماتيك قراردادي را با «مركز فناوري اطلاعات و ارتباطات پيشرفته شريف» براي فارسي سازي لينوكس منعقد كرده است كه با مديريت اين مركز تاكنون عقد قرارداد پروژه‌هاي ذيل انجام شده است:
مرحله اول:
- الگوريتم دوجهته اتصال و يوني‌كد با هدف فراهم كردن كتابخانه‌اي از توابع به منظور تسهيل پياده‌سازي الگوريتم دوجهته و اتصال يوني‌كد.
- مرتب‌سازي، جست‌وجو و شرايط محلي فارسي با هدف مشخص كردن نيازمندي‌هاي دقيق مرتب‌سازي فارسي به علت عدم وجود استاندارد ملي، بر اساس لغت‌نامه‌ها و مراجع ديگر.
- تقويم فارسي با هدف استخراج الگوريتم تقويم تاريخ جلالي و تحويل تاريخ‌ها براي كاربرد در لينوكس
- فونت مرجع فارسي و فونت open type
- صفحه كليد فارسي با هدف رفع اشكالات صفحه كليد فارسي در سيستم عامل لينوكس
- لوح فشرده نمايش لينوكس فارسي با قابليت راه‌اندازي از لوح فشرده بدون آسيب‌رساني با سيستم عامل موجود كاربر با هدف فرهنگ‌سازي.
مرحله دوم :
- پشتيباني يوني‌كد فارسي در glibc (كتابخانه اصلي مربوط به زبان c در لينوكس)
- پشتيباني يوني‌كد فارسي در Mozilla (مرروگر، مخدوم پست الكترونيك، دفترچه آدرس)
- پشتيباني يوني‌كد فارسي در Mysql (بانك اطلاعاتي)
- پشتيباني يوني‌كد فارسي در Postgerlsql (بانك اطلاعاتي)
- پشتيباني زبان فارسي در IMP (خادم پست الكترونيك مبتني بر وب)
- پشتيباني زبان فارسي در aspell (غلط‌ياب واژگان فارسي)
- تحليل و تعريف ملزومات واسط كاربري گرافيكي (GUI) فارسي
- تهيه واژه نامه مرجع براي ترجمه محيط لينوكس
يكي از مراكز فعال ديگر در اين عرصه، مركز امنيت شبكه شريف است كه با همكاري گروه امنيت شبكه مركز تحقيقات مخابرات ايران، اولين همايش سيستم عامل و امنيت را برگزار نمودند. در اين طرح مخصوصاً در قسمت رويكرد و تجربه سايركشورها از دستاورد تحقيقات اين مركز استفاده شده است.

8- راهبردها و راهكارهاي دولت در ايران
در بررسي چالش‌ها و تهديدهاي ناشي از فقدان يك سيستم عامل مناسب در كشور گزينه‌ها و راه‌حل‌هاي موجود و تجربه ساير كشورها در مواجه با اين چالش‌ها، مشخص گرديد كه رويكرد سيستم عامل متن باز (لينوكس) كه كد برنامه‌هاي آن به رايگان قابل دسترسي است، روشي است كه با توجه به گراني نرم‌افزارهاي تجاري و كاهش ضريب امنيتي آنها، با كمترين زمان و هزينه، امكان بومي‌سازي و فارسي‌سازي استاندارد سيستم عامل و حفظ استقلال و امنيت رايانه‌اي كشور را فراهم مي‌سازد.
عزم دولت بر اين است كه لينوكس و نرم‌افزارهاي متن باز را جايگزين ويندوز و نرم‌افزارهاي تحت آن
نمايد.

مراحل جايگزيني به شرح ذيل پيشنهاد مي‌شود:
الف ـ جايگزيني نرم‌افزار مديريت و راهبري شبكه لينوكس در سرورها: برتري ويژگي‌ها و توانمندي‌هاي سيستم عامل لينوكس و يونيكس در حوزه سرورها كاملا مشخص است به گونه‌اي كه سازمان‌ها و شركت‌هايي كه نياز به نگهداري و تبادل اطلاعات انبوه داده‌ها يا سرعت و كارايي قابل توجهي دارند، اين خانواده از سيستم عامل را براي سرورها انتخاب مي كنند. به عنوان نمونه مي‌توان به استفاده از لينوكس به عنوان سيستم عامل سرور پايگاه جست‌وجوي google در اينترنت و سيستم عامل اصلي بانك اطلاعاتي Oracle اشاره كرد.
آمارها و اطلاعات موجود نيز نشان مي دهد كه سيستم عامل سرور لينوكس و يونيكس با در اختيار داشتن 47% از سهم سرورها در سال 2002 ميلادي رتبه اول را به خود اختصاص داده و پيش بيني ها نشان مي دهد كه اين رتبه با سهم 51% در سال 2007 ميلادي حفظ خواهد شد. اين در حاليست كه سهم بازار سيستم عامل سرور ويندوز از 28% در سال 2002 ميلادي به 34% در سال 2007 ميلادي خواهد رسيد. به عبارت ديگر روندها نشان مي دهد كه سيستم عامل اصلي و پيشرو در حوزه سرورها، خانواده لينوكس خواهد بود.

منبع: Thibodeau, Patrick. Unix: Far From Legacy but Far More Challenged. ComputerWorld, July 2003.

تغيير سيستم عامل سرورها از ويندوز و ناول به لينوكس در سازمان‌هاي دولتي در سه مرحله مي‌تواند انجام شود:
مرحله اول: آموزش كليه كارشناسان شبكه سازمان‌هاي دولتي
مرحله دوم: مهاجرت سريع از ويندوز به لينوكس (در نرم‌افزارهايي كه در مدت محدود مي‌توانند تبديل شوند).
مرحله سوم: مهاجرت برنامه‌ريزي شده از ويندوز به لينوكس (در نرم‌افزارهايي كه نياز به بازنويس مجدد برنامه دارند).
ب ـ جايگزيني سيستم عامل لينوكس در كامپيوتركاربران : براي اجراي اين مرحله مناسب است كه فرايند جايگزيني سيستم عامل لينوكس در سرورها انجام شده و از طرف ديگر توزيع كارآمد، پايدار و فارسي‌سازي شده مناسبي در اختيار باشد.
براي ترويج و فرهنگ‌سازي مراحل فوق انجام اقدامات ذيل از طرف دولت پيشنهاد مي‌شود:
1- سمينارهاي ترويجي و برگزاري مسابقات دانش‌آموزي و دانشجويي در حوزه لينوكس
2- آموزش كارشناسان فناوري اطلاعات دولت براي مديريت و راهبري لينوكس و برخورداري اين كارشناسان از مزاياي آموزشي مصوب
3- آموزش كاربري لينوكس بر اساس استاندارد ICDL براي كاركنان دولت و دانش‌آموزان مدارس
4- تهيه ابزارها و نرم‌افزارهاي تبديل( براي مهاجرت سريعتر و راحت‌تر به لينوكس) و در دسترس بودن آخرين و بهترين نسخه سيستم عامل لينوكس فارسي
5- صدور بخشنامه براي نصب لينوكس در سرورهاي جديد، مبتني بر لينوكس بودن قراردادهاي جديد نرم‌افزاري و مشخص كردن مهلت براي تبديل نرم‌افزارهاي موجود به نرم‌افزارهاي مبتني بر لينوكس.
6- حمايت از ايجاد و رشد مراكز توسعه نرم‌افزاري لينوكس در دانشگاه‌هاي فني و مهندسي
7- حمايت از نهادهاي پشتيبان لينوكس در كشور
8- عقد قرارداد توليد نرم‌افزارهاي اصلي مورد نياز مبتني بر لينوكس توسط سازمان مديريت شامل نرم‌افزارهاي مالي و حسابداري، دبيرخانه، انبار، اموال و منابع انساني (گزينش، آموزش، ارزيابي، كارگزيني، رفاه بيمه و امور درماني، بازنشستگي)
9- توسعه سيستم عامل‌هاي خاص منظوره مبتني بر هسته لينوكس فارسي (ازجمله: سيستم عامل‌هاي موجود در بانكداري، فروشگاه‌ها، موبايل و موارد مشابه).

8- جمع‌بندي و نتيجه‌گيري
ترديدي نيست كه سيستم عامل لينوكس كه با توجه به نيازهاي امنيتي و شرايط كشور تهيه و بومي شده باشد، راه‌حل مواجهه با چالش‌هاي اقتصادي و امنيتي مربوط به فقدان يك سيستم عامل مناسب در كشور است. حداكثر سه سال فرصت وجود دارد كه جايگزيني اين سيستم عامل در سطح دولت بطور كامل انجام شود. هدف‌گيري اصلي تبديل سرورها به لينوكس است كه امنيت و پايداري قابل اتكايي را ايجاد خواهد كردو هدفگيري بعدي تبديل كامپيوتر كاربران است. براي اينكه اين تغيير به صورتي منطقي و طبيعي اتفاق بيفتد، لازم است ابتدا اطلاع‌رساني، فرهنگ‌سازي و آموزش لازم صورت پذيرفته و سپس با قوانين و مقررات و ايجاد نهادهاي لازم و پشتيبان، قطعيت يابد.

9- منابع و مآخذ:
1- سيدعلي اكرمي‌فر «راهبردهاي توسعه سيستم عامل بومي در كشور» مجموعه مقالات همايش سيستم عامل و امنيت، دي‌ماه 1382
2- «سند راهبردي توسعه فناوري اطلاعات و ارتباطات كشور» ، وزارت پست، تلگراف و تلفن، مركز تحقيقات مخابرات، بهمن 1381
3- www.amazon.com
4- رسول جليلي، علي هادوي، روح‌اله آل‌شيخ، «مروري بر رويكرد كشورهاي دنيا به پديده‌ متن باز» مجموعه مقالات همايش سيستم عامل و امنيت ، دي ماه 1382
5- http:/Amsterdam.nettime.org/lists-Archives/nettime-1-0007/msg00024.html
6- «سيستم عامل ايده‌آل ملي» سرمقاله ماهنامه افق لينوكس، مركز ارتباطات و فناوري اطلاعات پيشرفته شريف، تير 1383
7- "open source software use within UK government", July 2002/office of the e-envoy, www.e-envoy.gov.uk
8- Defence Information systems Agency, "open source within DoD Request for comment" Aug 2002, www. disa.mil/pao/opensource.html
9- "use of Free/open source software in the us. Department of Defence, "version 1.2.02/Nov.2002, the MITRE Corporation.

منبع: ایتان

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 24 بهمنماه 1383

03:57 PM

February 12, 2005

پنج روز تاخت و تاز در اینترنت

نوشته : علی دریس زاده

اشاره :
يكي از مقالات برگزيده شماره جاري ماهنامه شبكه (۵۰)- شبكه‌ها زير بار ترافيك شديد از كار مي‌افتند، كامپيوترها پي‌درپي ري‌ست مي‌شوند و به اين ترتيب، بانك‌ها، خطوط هوايي و بيمارستان‌ها عملاً فلج مي‌گردند. علت همه اين‌ها حمله يك كرم اينترنتي به نام Sasser است كه در ماه مي گذشته، به مدت 5 روز بر اينترنت حكمراني ‌كرد و ميليون‌ها كامپيوتر را آلوده ساخت. امروزه، ويروس‌هاي خطرناكي مانند Sasser‌، بيشتر و سريع‌تر از گذشته به پي‌سي‌هاي كاربران راه مي‌يابند. نيمه اول سال 2004 ميلادي، نسبت به دوره زماني مشابه در 2003، چهار برابر ويروس جديد ويندوزي به خود ديد. در شرايطي كه چنين حملاتي، كامپيوترها و شبكه‌ها را از هر سو مورد تهديد قرار مي‌دهد، به بررسي سيستمي پرداختيم كه قرار است از ما در برابر اين تهديدات محافظت كند. خالق Sasser كيست؟ كوتاه‌ترين پاسخ اين سؤال عبارت است از يك نفوذگر نابكار. اما حقيقت اين است كه Sasser در عين حال، محصول مشترك همان سيستم و مكانيزمي است كه قرار است از كاربران كامپيوترها محافظت به عمل آورد. سوراخي كه اين كرم در آن حركت مي‌كرد، و يا به زبان ديگر، حفرة امنيتي كه Sasser از طريق آن در اينترنت از كامپيوتري به كامپيوتر ديگر مي‌رفت، توسط كارمندان يك شركت امنيتي در كاليفرنيا كشف شد. شركت مايكروسافت سپس با ارايه يك Patch يا اصلاحيه براي اين حفره امنيتي، كليه اطلاعات فني لازم براي سوءاستفاده از آن را در اختيار نفوذگران سراسر دنيا قرار داد. در يك كلام، بايد در مورد اين‌كه آيا چنين درماني از خود مرض بدتر نيست، به شكلي جدي تأمل كرد. براي پاسخ به اين سؤال و آگاهي از مزايا و معايب سيستم حفاظتي مبتني بر Patch يا اصلاحيه‌ها – ردپاي Sasser را دنبال كرديم ...

Aliso Viejo ، كاليفرنيا، 8 اكتبر 2003
يوجي اكاي (Yuji Ukai ) به منظور كشف نقاط ضعف و راه‌هاي جديد براي نفوذ به پي‌سي‌ شما استخدام مي‌شود. با وجود سپري شدن مدت زمان طولاني از ساعت كاري عادي شركت EEye Digital Security، جايي كه اُكاي در آن روي نرم‌افزار «مديريت آسيب‌پذيري امنيتي» كار مي‌كند (ابزاري كه شركت‌هاي بزرگ جهت حفاظت از شبكه‌هاي كامپيوتريشان در برابر نفوذ هكرها از آن استفاده مي‌كنند)، او همچنان پشت كامپيوتر اداري‌اش نشسته است.
او اكنون بايد در منزلش باشد، اما در عوض ترجيح داده است كمي تفريح كند. و تفريح از نظر اُكاي، به معناي جستجو مانند يك سگ شكاري براي پيدا كردن رخنه‌هاي امنيتي در ميان ميليون‌ها خط كدهاي نرم‌افزاري است كه رايج‌ترين و پركاربردترين سيستم‌عامل جهان يعني ويندوز را تشكيل داده‌اند.
محصولات شركت EEye به‌منظور پيش‌بيني راه‌هاي نفوذ هكرها به نرم‌افزارها و مسدود نمودن آن‌ها طراحي و ساخته مي‌شوند. مشتريان اين محصولات انتظار دارند EEye تحت هر شرايطي از كامپيوترهايشان محافظت به عمل بياورد، حتي اگر هنوز راه‌حل و اصلاحيه‌اي رسمي براي مشكلِ پيش آمده، وجود نداشته باشد.
به همين دليل، محققين و متخصصين حرفه‌ها و تجارت‌هايي چون EEye، دائماً در حال كاوش و جستجو در ويندوز هستند تا نقاط ضعفي را بيابند كه كسي از آن‌ها خبر ندارد.
سوابق شركت، خود گوياي همه چيز است. طي تنها 30 روز گذشته، اُكاي و هم قطارانش، مايكروسافت را از وجود 6 نقطه ضعف امنيتي جديد در ويندوز مطلع ساخته‌اند.
اُكاي خودش يكي از آن‌ها را پيدا كرده بود. يك فرمان بلاستفاده در بخشي از ويندوز به نام سرويس workstation. چيزي به او مي‌گفت كه بخش‌هاي ديگري از سيستم نيز بايد داراي اين نقطه ضعف باشند. به اين ترتيب برنامه كاري امشبش مشخص مي‌شود. جستجو درون فايل‌هاي dll براي يافتن رخنه موردنظر. كارش را با بررسي ساير سرويس‌هايي (برنامه‌هايي كه بخش‌هاي مختلفي از سيستم‌عامل ويندوز را به اجرا در مي‌آورند) كه به طور پيش‌فرض فعال هستند آغاز مي‌كند. تقريباً بلافاصله، رخنه جديدي را كشف مي‌كند. آن هم در چه جايي، نزد رئيس بزرگ.سرويس زير سيستم مسؤول امنيت داخلي يا Local Security Authority Subsystem.
LSASS كليه جنبه‌هاي مرتبط با امنيت داخلي سيستم‌عامل ويندوز را كنترل مي‌كند. با آنچه يافته است، او اكنون مي‌تواند اين سرويس را غيرفعال كند، كه به اين ترتيب ويندوز لااقل براي مدت كوتاهي عاري از هرگونه محافظ مي‌گردد. او همچنين مي‌تواند از LSASS براي اجراي هر برنامه دلخواهش استفاده كند، و به اين ترتيب، اين «گارد امنيتي» ويندوز را به يك عامل درونيِ آماده به خدمت براي خود بدل كند، عاملي كه قادر است كنترل ويندوزهاي 2000 و XP را در اختيار بگيرد. هكرها هم چنانچه از اين نقطه ضعف امنيتي مطلع مي‌شدند و مهارت لازم را نيز مي‌داشتند، مي‌توانستند از آن بهره‌برداري كنند.
اُكاي به رئيسش اطلاع مي‌دهد كه روشي به شكل عجيب، ساده را براي كنترل LSASS يافته است. ظرف چند ساعت، افراد مسؤول در EEye در حال مكالمه تلفني با مايكروسافت هستند. بخش مهم و عمده‌اي از كل كامپيوترهاي دنيا، داراي يك حفره امنيتي بزرگ مي‌باشند. خوشبختانه، تنها EEye و مايكروسافت (تا آن‌جايي كه خودشان مي‌دانند) از اين مهم آگاهي دارند. اكنون مايكروسافت بايد اين مشكل را پيش از آن‌كه ديگران مطلع شوند برطرف سازد.
سرويسي كه EEye ارايه مي‌كند، از مشتريانش محافظت به عمل مي‌آورد، ولي همچنين، 2 دسته از كاربران ويندوز را نيز به وجود مي‌آورد. آن‌هايي كه در برابر آسيب‌پذيري‌هاي كشف شده جديد محافظت مي‌شوند (مشتريان EEye)، و بقيه ما، كه بايد (شايد ماه‌ها) براي دستيابي به يك Patch يا اصلاحيه صبر كنيم و نسبت به خطرات محتمل و بالقوه‌اي كه پي‌سي‌هايمان را در آينده به خطر مي‌اندازد ناآگاه باقي بمانيم.

ردموند، واشنگتن، 8 اكتبر 2003
در مركز واكنش امنيتي مايكروسافت (MSRC)، يك ساختمان اداري معمولي در قلب محوطه ساختمان‌سازي غول نرم‌افزاري جهان، ده نفر از نخبه‌ترين اعضا گروه امنيتي، به مانند پزشكان اتاق اورژانس براي مرمت يك ويندوز زخمي در تلاش و تقلاء هستند.
كوين كين (Kevin Kean)، مدير MSRC مي‌گويد: گروه وي ابتدا گزارش دريافتي را تجزيه تحليل كرده و مورد مشكل آفرين را بازسازي مي‌كنند. سپس برنامه‌نويسان و مديران توليد گروهي موسوم به SWI (گروه ضربت براي ضعف‌هاي امنيتي ويندوز)، را وارد صحنه مي‌كنند كه در نهايت منجر به ايجاد يك اصلاحيه مي‌شود.
كين ادامه مي‌دهد: پس از آگاهي از چگونگي اصلاح يك مشكل، MSRC وارد يك پروسه طولاني و دقيق مي‌شود تا اطمينان پيدا كند كه يك اصلاحيه خوب و مطمئن توليد كرده است.
موردِ LSASS به سرعت به يك دلمشغولي بزرگ تبديل مي‌شود. در كمتر از يك هفته، گروه ده نفري آناليست‌ها، صدها برنامه‌نويس، مدير توليد و آزمايش‌كنندگان عيوب نرم‌افزاري را وارد گود مي‌كنند.
با وجود احتمال وقوع يك فاجعه، استفان تولوز (Stephan Toulouse)، مدير برنامه امنيت شركت، قدري اوضاع و احوالش بهتر از گذشته است چرا كه EEye به يك توافقنامه مهم صنعت نرم‌افزار موسوم به افشاء متعهدانه يا Responsible Disclosure پايبند است. طبق مفاد اين توافقنامه غيررسمي، يابنده يك نقطه ضعف امنيتي، پيش از اعلان جزييات فني آن به عموم، به شركت توليدكننده نرم‌افزار براي ارايه راه‌حل فرصت كافي مي‌دهد.
توافقنامه Responsible Disclosure به اين‌ترتيب، موقتاً از استفاده‌كنندگان نرم‌افزار پشتيباني مي‌كند، لااقل در تئوري. اگر EEye بلافاصله جزييات فني و چندوچون اين مورد را روي امنيت منتشر مي‌كرد، گروه MSRC با كابوس ترميم يك رخنه امنيتي همزمان با توليد و انتشار ويروس‌ها و كرم‌هاي جديد توسط هكرها مواجه مي‌شد. اما مخفي نگاه داشتن جزييات مسأله، ممكن است برداشت اشتباهي از امنيت را نيز سبب شود. در حالي كه مايكرسافت روي اصلاحيه امنيتي كار مي‌كند، يك نفوذگر بدطينت ممكن است رخنه را كشف كرده و پنهاني مورد سوء استفاده قرار دهد.

«تنها يك خط كد بود ...»
نمي‌دانم چرا مايكروسافت در اصلاح آن آنقدر تأخير داشت.
يوجي‌اُكاي، مهندس نرم‌افزار ارشد شركت EEye Digital Security

كين مي‌گويد، اكثر محققين امنيتي امروزه از انتشار جزييات فني يك مورد، پيش از ارايه اصلاحيه براي آن، خودداري مي‌كنند، امري كه در گذشته كاملاً به ندرت صورت مي‌پذيرفت. در نتيجه، مايكروسافت مي‌تواند روي توليد اصلاحيه‌هايي كه مشكلات جانبي ايجاد نمي‌كنند تمركز كند. اما اين پروسه به آزمايش نياز دارد، و در اين مورد خاص به آزمايش‌هاي متعدد و مكرر.

ردموند، 13 آوريل 2004
بيش از 6 ماه از كشف اُكامي گذشته است. مايكروسافت اصلاحيه‌اش را، همراه با جزييات مشكلِ LSASS در بولتن امنيتي‌اي كه MS04-011 نام مي‌گيرد منتشر مي‌كند. با چنين تأخيري، مايكروسافت عملاً يكي از رهنمودهاي توافقنامه Responsible Disclosure را نقص كرده است. شركت‌هاي امنيتي معمولاً توافق مي‌كنند كه اصلاحيه‌ها بايد تا 30 روز پس از كشف يك اشكال ارايه شوند. كين توضيح مي‌دهد كه اصلاحيه مذكور، نه‌تنها نقصي را كه اكاي در LSASS پيدا كرده، بلكه 13 مورد آسيب‌پذيري امنيتي مرتبط ديگر را نيز برطرف مي‌سازد. كاربران ويندوز و اهالي IT بايد به سرعت اين اصلاحيه را نصب كنند، مبادا كامپيوترها و شبكه‌هايشان در معرض غارت و نابودي قرار بگيرد.
گزارش فني ارايه شده، كه مسؤولين و مديران سيستم‌ها به منظور ارزيابي بي‌خطري اجراي اين اصلاحيه بر روي كامپيوترهايشان مورد استفاده قرار مي‌دهند، همچنين حاوي اطلاعات فني است كه يك نفوذگر ماهر براي مهندسي معكوس اصلاحيه و نوشتن برنامه‌هايي براي حمله به پي‌سي‌هاي بدون patch به آن نياز دارد.

روسيه، 29 آوريل 2004
دقيقاً 16 روز بعد، 3 بعدازظهر به وقت محلي، يك هكر روسي به نام Houseofdabus يك به اصطلاح proof-of-concept exploit (برنامه‌اي كه نشان مي‌دهد چگونه مي‌توان كنترل يك پي‌سي patch نشده را به دست گرفت) براي رخنه امنيتي LSASS منتشر مي‌كند.
قطعه كدي كه Houseofdabus ارايه مي‌كند يك نمونه كار حرفه‌اي و عالي است. نويسنده كد ادعا مي‌كند كه اين exploit را روي ده نسخه مختلف روسي و انگليسي از ويندوزهاي XP و2000 با موفقيت آزمايش كرده است. نوشته‌اي كه در دل اين قطعه كد جاي گرفته مي‌گويد:‌ «اين نمونه به عنوان يك كد از نوع proof-of-concept و صرفاً به مقاصد آموزشي و نيز براي آزمايش توسط افراد مجاز كه مجوز انجام اين كار را دارند ارايه شده است.» هيچ‌كس باور نمي‌كند كه اين كد فقط توسط افراد مجاز مورد استفاده قرار خواهد گرفت. براي ويروس‌نويسان كه معمولاً مهارت كمتري نسبت به exploit نويسان دارند، اين كد يك موهبت آسماني است.
دلايل انگيزشي Housofdabus براي انجام چنين عملي مشخص نيستند، اما سارا گوردن متخصص ويروس‌ها، كسي كه تاكنون با چند دوجين ويروس‌نويس ديدار و گفتگو داشته است، مي‌گويد بيشتر افرادي كه به مبادرت به نوشتن كدهاي exploit مي‌كنند، تنبلي و اهمال كاربران پي‌سي‌ها و شركت‌ها را دليل تأخير در به كارگيري اصلاحيه‌هاي امنيتي مي‌دانند. آن‌ها براين باورند كه حضور كدهايشان بر روي خط، تلنگري است كه واكنش سريع‌تر در قبال پوشش حفره‌هاي امنيتي را به دنبال خواهد داشت.
در ردموند، كين از ماجراي كد Houseofdabus مطلع مي‌شود و گروه MSRC را به نوعي حالتِ آماده باش به نام «watchful normalcy» فرا مي‌خواند. حالت آماده باشي كه در آن آناليست‌ها، اينترنت را به دنبال يافتن نشانه‌هايي دال بر سوء استفاده از كد exploit مورد بررسي قرار مي‌دهند.

هلسينكي، فنلاند، 1 مي 2004
در ساعت 02/7 دقيقه صبح به وقت محلي، تحليل‌گران امنيتي شركت فنلاندي توليدكننده ضدويروس F-secure، متوجه مي‌شوند يك كرم جديد كه نقطه ضعف امنيتي LSASS را مورد بهره‌برداري قرار مي‌دهد سرانجام وارد صحنه شده است. F-Secure يك بيانيه رسمي در مورد اين كرم به ساير مراجع و شركت‌هاي توليدكننده ضدويروس‌ها ارسال مي‌كند و كرم را Sasser مي‌نامد.
Sasser به سرعت گسترش مي‌يابد و باعث از كار افتادن يا reboot شدن ناگهاني كامپيوترهاي آسيب‌پذير مي‌گردد. اين كرم ظاهراً آسيب عمومي به سيستم‌ها تحميل نمي‌كند، ولي در عمل، پي‌سي‌هاي آلوده به علت تلاش كرم براي اشباع كردن شبكه محلي و تكثير خود، غيرقابل استفاده مي‌شوند.
هنگامي كه اخبار Sasser به مايكروسافت مي‌رسد، مهندسين كرم را روي يك پي‌سي آزمايشگاهي مورد بررسي قرار مي‌دهند تا از نحوه انتشار آن مطلع شوند.
در همين حال، كين ساير گروه‌هايي را كه بايد در ماجرا دخالت داده شوند به دور خود جمع مي‌كند. همچنين افراد تيم Communications wing شركت را، كه وظيفه اطلاع‌رساني به عموم و ارايه ساير خدمات اضافه به مشتريان را به عهده مي‌گيرند.
كين مي‌گويد: «در چنين شرايطي يك وضعيت 24 در 7 (24 ساعت شبانه‌روز و 7 روز هفته در پشتيباني ارايه سرويس) پيش مي‌آيد. تعدادي اتاق جنگ برپا مي‌كنيم و شيفت‌هاي كاري چرخشي به وجود مي‌آوريم.»
حدود 10 ساعت بعد، گونه دومي از Sasser با عنوان Sasser.B، روي صفحه رادار F-Secure ظاهر شده است. Sasser.B آن قدري با نوع اوليه تفاوت دارد كه شركت‌هاي ضدويروس را مجبور به ارايه فايل‌هاي بروزرساني جديدي براي كشف و پاكسازي‌اش كند.

ردموند، 2 ماه مه 2004
تا فرا رسيدن يكشنبه، ظرف تنها 24 ساعت از ظهور Sasser، مايكرسافت تصميم به انجام فعاليت‌هاي گسترده‌تر و اضافه بر سازماني مي‌گيرد كه تا آخر هفته به طول خواهد انجاميد. اطلاع‌رساني گسترده و به طور خاص ايجاد و هدايت يك Webcast، قرار دادن مرتب و مستمر اطلاعات لازم بر روي وب سايت شركت، اقدام به نصب و برپايي آگهي و ارايه اطلاعات به شركت‌هاي سازنده پي‌سي و شركاي مهم خود، و حتي پرداخت پول به گوگل براي اطمينان از اين‌كه هرگونه جستجويي جهت كسب اطلاعات در مورد اين كرم منجر به ديدن آگهي‌اي مي‌شود كه به سايت Microsoft.com براي دريافت اصلاحيه و ساير ملزومات اشاره مي‌كند، از جمله اين اقدامات هستند.
با وجود همه اين تلاش‌ها، مايكروسافت تنها در حال تقلا براي بازداشتن Sasser از پيشروي است. گزارش‌هاي مربوط به اثرات و عوارض كرم از همه جا سرازير مي‌شوند.‌ كارهاي جاري در شركت‌هايي چون Goldman Sachs و British Airways متوقف شده است، كامپيوترها در نيمي از ادارات پست تايوان آلوده شده‌اند و Sasser، طاعون‌وار، پي‌سي‌هاي نمايندگي‌هاي دولت در هنگ‌كنگ و در سكوهاي نفتي مقابل ساحل مكزيك را مورد حمله قرار مي‌دهد.
اهميت، بزرگي و دامنه خرابي كه كرم به وجود مي‌آورد، گيج‌كننده است. تعداد 5 هزار سيستم كامپيوتري و تجهيزات اشعه‌ايكس وابسته به آن‌ها در يك بيمارستان در Lund سوئد از كار مي‌افتند. 1200 عدد كامپيوتر در اداره مركزي كميسيون اروپا در بروكسل نمي‌توانند به اينترنت متصل شوند و بانك Sun Trust و American Express در اياالات متحده، براي ساعت‌ها، ارتباطشان را با اينترنت از دست مي‌دهند.
با فرا رسيدن غروب يكشنبه، تقريباً 5/1 ميليون نفر، ابزار رايگاني را از سايت مايكروسافت دريافت كرده‌اند كه Sasser را از بين مي‌برد. اما هنوز خيلي مانده كه كار Sasser به انتها برسد...

وافنسن، آلمان، 3 مه 2004
در 900 نفريwaffensen ، واقع در 21 مايلي شهر برمن در شمال غربي آلمان، چنين شايع است كه
Sven Jaschan، يك دانش‌آموز دبيرستاني 18 ساله، كل سه ماه اخير را به نوشتن و ويرايش يك سلسله كرم‌هاي اينترنتي كه خودش Skynet، ولي شركت‌هاي توليدكننده برنامه‌هاي ضدويروس، Netsky مي‌نامندش، گذرانده است. گونه‌هاي مختلف اين كرم، كه پيش از Sasser ظاهر شده بود، (و يكي از فعالترين و رايج‌ترين كرم‌ها در اينترنت به شمار مي‌آمد) هر ماهه ده‌ها هزار سيستم كامپيوتري را بارها آلوده مي‌ساخت. هدف Netsky اما غارت و نابودي كاربران بي‌گناه نيست، جنگ‌افزاري است براي نبرد عليه كرم‌هاي ديگري (Mydoom و Bagle) كه ماشين‌هاي آلوده را به يك شبكه توزيع اسپم تبديل كرده‌اند.
Netsky كنترل كامپيوترهاي آلوده مذكور را در اختيار مي‌گيرد و كرم‌هاي ارسال‌كننده اسپم را حذف مي‌كند. - كمي بيش از دو ماه از زمان ظهور اولين كرم Netsky، باز هم چنين گفته مي‌شود كه Jaschan، بيست و نهمين نسخه كرم را كه Netsky.AC نام دارد در شبكه مدرسه منتشر مي‌كند. به مانند نسخه‌هاي پيشين، اين‌گونه جديد نيز حاوي يك پيام مخفي است، اما در اين پيام خاص، نويسنده پيام مسؤوليت نوشتن Sasser را برعهده مي‌گيرد...
«آهاي، شركت‌هاي توليدكننده ضدويروس، با شما هستم. آيا مي‌دانيد كه ما هستيم كه برنامه ويروس Sasser را نوشتيم؟!؟. بله، درسته! چرا اسمش را Sasser گذاشته‌ايد؟ يك راهنمايي: كد ] مربوط به بخش[ FTP-Server ]ويروس[ را با معادل Skynet.V مقايسه كنيد!!! هاهاها ما شبكه آسماني (اشاره به نام Skynet) هستيم....»

هلسينكي، 4 ماه مه 2004
شركت‌هاي توليدكننده برنامه‌هاي ضدويروس، صبح روز سه‌شنبه در حال حاضر بررسي ادعاي مطرح شده در پيام مخفي موجود در Netsky.AC هستند. متخصصين تحليل‌گر شركت F-Secure، كرم‌هاي Sasser و Netsky را كالبد شكافي مي‌كنند و فلوچارت و روندكاري روال‌هاي Sasser را با جزييات زياد تهيه مي‌نمايند.
ترسيم و نمايش گرافيكي موارد فوق، اين متخصصين را قادر مي‌سازد تا كد و سبك برنامه‌نويسي خالقش را با كرم مقايسه كنند. و سرانجام، Mikko Hypponen، مدير تحقيقات بخش ضدويروس شركت F-Secure، در حالي كه به خروجي گرافيكي ياد شده اشاره مي‌كند مي‌گويد: «همان كسي كه Netsky را توليد كرده، Sasser را نوشته است.» شركت‌هاي ضدويروس و مايكروسافت تخمين مي‌زنند هر يك از نسخه‌هاي چهارگانه Sasser از نيم ميليون تا چند ميليون كامپيوتر را در سراسر جهان آلوده ساخته است. هر بار حمله و آلوده‌سازي ويروس، ويندوزهاي XP و 2000 را، بدون اخطار قبلي، به شمارش معكوس 60 ثانيه‌اي غيرقابل بازگشتي براي راه‌اندازي مجدد وامي‌دارد. هنگامي كه كارمندان صبح روز دوشنبه به سركارشان بازگشتند، پي‌سي‌هاي آلوده نشده و patch نشده‌شان، امواجي از حملات ويروسي را در اينترنت به راه انداخته بودند، حملاتي كه تا فرونشستن‌شان هنوز زماني باقي بود و Sasser سريع‌تر از هر كرم شناخته‌ شده ديگري، پي‌سي‌هاي سراسر جهان را آلوده مي‌ساخت.

وافنسن، 5 مي 2004
در حالي كه داستان Sasser، سوژه داغ رسانه‌هاي خبري جهان شده است، FBI به جمع تعقيب‌كنندگان نويسنده كرم خبرساز مي‌پيوندد.
Jaschan، بنا به گفته خودش كه در مجله آلماني stern چاپ شد، طي نامه‌اي به يكي از دوستان خود، كه تنها به نام MarleB از او ياد مي‌شود، چنين اظهار مي‌كند كه مي‌خواهد از ويروس‌نويسي دست بكشد و قصد نابودي هارد ديسكش‌ را دارد.
6 ماه پيش از اين، مايكروسافت با تخصيص يك بودجه 5 ميليون دلاري براي پاداش دادن به افرادي كه اطلاع‌رساني و راهنمايي‌شان منجر به دستگيري و محكوميت نويسندگان كدهاي مخرب فراگير شود، تكاني به دنياي ويروس‌نويسي داده بود.
كمي بعدتر در همان روز، MarleB و يكي ديگر از دوستان مدرسه‌اي مرد جوان، با دفتر مركزي مايكروسافت در آلمان تماس مي‌گيرند تا ببينند در صورت معرفي نويسنده Sasser، از سخاوت 250 هزاردلاري مايكروسافت بهره‌مند مي‌شوند يا نه.

دشمنان رخنه‌ها:‌ اعضاء هسته اصلي مركز واكنش امنيتي شركت مايكروسافت از چپ به راست عبارتند از AmyCarroll، Kevin kean، Stephen Toulouse و Richie Lai.

تماس تلفني، به Hemanshu Nigam نماينده شركت مايكروسافت كه مديريت برنامه پاداش ضدويروس را برعهده دارد ارجاع داده مي‌شود. Nigam مي‌گويد: «به افراد تماس گيرنده گفتيم كه بله. با كمال ميل پاداش را پرداخت مي‌كنيم.»
نيگام اما توضيح مي‌دهد كه پيش از پرداخت پاداش، آن‌ها بايد اطلاعاتي را ارايه كنند كه براي مايكروسافت قابل تجزيه و تحليل فني باشد تا صحت ادعاي مطرح شده به اثبات برسد. MarelB كد منبع نسخه‌اي از Sasser را ارسال مي‌كند. تاكنون فاش نشده كه MareB چگونه به اين كد دست يافته است. نيگام مي‌گويد: «مهندسين امنيت ما پس از آناليز كردن اطلاعات ارسالي به اين نتيجه رسيدند كه مدعيان، حرف بي‌پايه و اساسي نزده‌اند.»
مايكروسافت اكنون فكر مي‌كند كه به احتمال قريب به تعيين، مرد مورد نظرش را يافته است Sven Jaschan. اين اولين‌بار خواهد بود كه در يك برنامه پاداش‌دهي، اطلاعات ارايه شده توسط خبر دهنده، واقعاً منجر به دستگيري فرد موردنظر مي‌شود.

سياتل، 7 مي 2004
به مجرد دريافت تأييد صحت اطلاعات مربوط به Sasser، نيگام با مأموران تحقيق فدرال تماس مي‌گيرد. يك واحد ويژه FBI در سياتل، بلافاصله با يك مركز پليس در استان Lower Saxony آلمان ارتباط برقرار مي‌كند. كمي بعد در همان روز، مأمورين به كلبه محل زندگي Sven Jaschan 18 ساله و خانواده‌اش هجوم مي‌برند و كامپيوتر Jaschan را توقيف مي‌كنند. در جريان بازجويي‌ها، Jaschan به نقشي كه در خلق Sasser، Netsky و ديگر گونه‌هاي آن‌ها داشته است اعتراف مي‌كند.
تنها 2 ساعت پس از بازداشت، در حالي كه Jaschan هنوز در توقيف پليس قرار دارد، پنجمين نسخه Sasser در اينترنت پديدار مي‌شود. برخي از متخصصين امنيت شك مي‌كنند كه شايد نفوذگران ديگري در حال اشاعه Sasser باشند و يا اين‌كه Jaschan دست به اعتراف دورغين زده باشد. مراجع آلماني اما، لااقل تا اين لحظه، كماكان مطمئن هستند كه مجرم واقعي را در اختيار دارند. Jaschan احتمالاً Sasser.E را دقايقي پيش از ورود مأمورين به خانه‌اش منتشر ساخته است. اين ادعاي مسؤولان آلماني است.

هانوفر، آلمان، ژوئن 2004
با وجود اعتراف Jaschan، يك محاكمه تحت قوانين آلمان بايد انجام بگيرد. هلموت تِرِنت‌من (Helmut Trentmann) مدعي‌العموم Lower Saxony، عهده‌دار محاكمه Jaschan مي‌شود. محاكمه‌اي كه بايد در يكي از روزهاي ژانويه 2005 در هانوفر، مركز استان، به اجرا درآيد.
ترنت‌من، Jaschan را جواني توصيف مي‌كند كه اوقات فراغتش را به‌كار با كامپيوترش مي‌گذراند. او مي‌گويد كه مدعي عليه «يك موجود عجيب و غريب و بسيار باهوش است.»
ترنت‌من برپايه مدارك و شواهد مايكروسافت و متخصصين كامپيوتر، متقاعد شده است كه Jaschan ويروس Sasser را خلق و منتشر ساخته و اين عمل را مغرضانه و با نيت خرابكاري انجام داده است. ترنت‌من مي‌گويد: «او Sasser را در چند مرحله روي خط قرار داده! و همه اين مراحل را به تنهايي انجام داده است. او، دوستانش را از آنچه انجام مي‌داده مطلع كرده و به اين مسأله افتخار مي‌كرده است.»
ترنت‌من البته توضيح مي‌دهد كه سوءنيت Jaschan بايد به اثبات برسد. مي‌گويد: «فكر مي‌كنم جاه‌طلبي او براي بهتر شدن در برنامه‌نويسي بوده است. اين عمل برايش به مثابه يك مسابقه و رقابت بود. اما در روزهايي كه به دستگيريش ختم شد، ترس برش داشته بود. او از تحقيقات FBI مطلع شده بود. و اكنون كل ماجرا برايش بسيار بزرگ و حاد شده است.»

ارباب كرم‌ها: دانش‌آموز، Sven Jaschan، 18 ساله، متهم به نوشتن Netsky و Sasser.

از ديدگاه خود Jaschan، گرچه وضعيت قانوني‌اش نامشخص باقي مي‌ماند، ممكن است اين شانس را بيابد كه مهارت‌هايش را در راه بهتري به‌كار بگيرد: يك شركت توليد كننده فايروال آلماني مي‌خواهد او را به عنوان برنامه‌نويس استخدام كند.

هانوفر، سپتامبر 2004
در حالي كه ماهنامه PC World به پوشش خبري ماجرا پرداخته است، ترنت‌من از 5 نفر از منابع خبري تحقيق مي‌كند. 4 نفر از آن‌ها، هم كلاسي‌هاي Jaschan هستند. ترنت‌من و ساير بازجويان، احتمال مشاركت بعضي از اين افراد را در انتشار Sasser ممكن مي‌دانند.
در همين زمان، 2 گونه جديد Sasser ظاهر مي‌شوند. شايد همدستان Jaschan هنوز دست از كار نكشيده‌اند. در بيست‌وسوم آگوست، Sasser.G، كه در زمان انعكاس اخبار بازجويي‌ها، جديدترين گونه كشف شده بود، در اينترنت گشت‌وگذار مي‌كرد. نسخه‌هاي قديمي‌تر Sasser هر روز به آلوده‌سازي سيستم‌هاي Patch نشده ادامه مي‌دهند. و رقيبان مرموز و اسپم دوست Jaschan، يعني آن‌هايي كه كرم‌هاي Bagle و MyDoom را خلق كردند نيز همچنان به كار خود مشغول هستند و هر چند روز يك‌بار گونه جديدي از محصولشان را ارايه مي‌كنند.
همه گروه‌هاي درگير در اين ماجرا، مدعي هستند كه اعمال و اقداماتشان به سود ديگران بوده است. كشف EEye و اكاي در مورد حفره امنيتي LSASS به مشتريان شركت كمك كرده است، چرا كه اگر يك اخلال‌گر، زودتر از نقطه ضعف امنيتي مذكور مطلع مي‌شد، امنيت سيستم‌هاي اين مشتريان به خطر مي‌افتاد. انتشار اصلاحيه مايكروسافت نيز به مشتريانش كمك كرده كه از بروز مشكل پيش‌گيري كنند.
Houseofdabus اظهار مي‌كند كه exploit ارايه شده توسط وي، تنها مقاصد آموزشي داشته است. Jaschan نيز مدعي مي‌شود او در حال ارايه سرويس به ديگران در مقياسي بزرگ از طريق اينترنت بوده است. اگر چه گسترش با حداكثر سرعت ممكن، هدف اصلي Sasser بوده است، اما Netsky در نقطه مقابل، به كامپيوترهاي آلوده به Bagle و MyDoom حمله مي‌كرد (دو كرمي كه در كنار هم به Spam Zombies معروف بودند) و پي‌سي‌هاي مذكور را از ارسال هرزنامه به ديگران باز مي‌داشت.
اگر همه به فكر آسايش و امنيت ما هستند، پس چرا دائماً در حال ضربه خوردن از ويروس‌ها و كرم‌هايي هستيم كه اثرات مخربشان هربار شديدتر مي‌شود، كدهاي خطرناكي كه اطلاعاتمان را از بين مي‌برند، شبكه‌هايمان را فلج مي‌كنند و كامپيوترهايمان را از كار مي‌اندازند؟
واقعيت اين است كه در عمل، اصلاحيه‌ها از همه ما محافظت نمي‌كنند، بلكه كساني را حفاظت مي‌كند كه به سرعت از اصلاحيه مربوط استفاده مي‌كند. به گفته گرهارد اِشِل‌بِك (Gerhard Eschelbeck) مدير شركت امنيتي Qualys، تنها نيمي از كاربران پي‌سي‌ها، اصلاحيه‌ها را در بازه زماني سه هفته از تاريخي ارايه‌شان به‌كار مي‌گيرند. اين امر، نيمي ديگر از اين جمعيت كثير را در معرض خطر كرم‌هايي قرار مي‌دهد كه اگر اين اصلاحيه‌ها منتشر نمي‌شدند، شايد اصلاً به وجود نمي‌آمدند. در ضمن شكي نيست كه نمي‌توانيم سيستم اصلاحيه‌ را به سادگي و همين الان دور بياندازيم.
نفوذگران و خرابكاران، حتي بدون كمك‌هاي ناآگاهانه و غيرعمدي مايكروسافت، همواره در حال جستجوي آسيب‌پذيري‌هاي نرم‌افزارها خواهند بود. چنين نفوذگران ناپيدايي، ممكن است آسيب‌هاي بسيار مهمتري به‌وجود بياورند زيرا كاربران كامپيوترها در معرض دزديده‌شدن هويت و داده‌هايشان قرار مي‌گيرند و تجارت‌ها و كسب‌وكارها در معرض جاسوسي.
راه‌حل عاجل، توليد نرم‌افزاري است كه از ابتدا امن باشد. تا آن زمان، بهبود سيستم اصلاحيه‌نويسي، بايد اولويت‌كاري همه افراد درگير اين مسأله باشد. كاربران، به هرحال، فعلاً يك انتخاب بيشتر ندارند: Patch كردن سيستم‌هايشان، به موقع و به دفعات.

انتظار تا كي؟
برخي متخصصين امنيت معتقدند زماني كه شركت‌هاي نرم‌افزاري صرف توليد يك Patch يا اصلاحيه مي‌كنند، بيش از حد طولاني است، امري كه باعث مي‌شود كامپيوترهاي جهان ماه‌ها بدون حفاظ باقي بمانند.
در مورد نقطه ضعف امنيتي LSASS، يوجي‌ اُكاي، مهندس نرم‌افزار ارشد شركت EEye از ميزان تأخيري كه مايكروسافت در اصلاح يك خط كد از خود نشان داد گيج و متعجب شده است. وي مي‌گويد: «اصلاحيه LSASS، مورد پيچيده‌اي نبود، بنابراين قابل درك نيست كه چرا آن‌ها براي ارايه يك اصلاحيه، 188 روز وقت صرف كرده‌اند.» «اين يك قانون نانوشته است كه انتظار داريد شركت‌هاي نرم‌افزاري چنين مشكلي را (مورد LSASS) طي 30 روز و يك مورد پيچيده‌تر را طي مدت 60 روز برطرف كنند.»
Rob Shively، مدير Pivx Solutions، شركتي كه نرم‌افزارهاي مديريت اصلاحيه‌ها و نقطه‌ضعف‌هاي امنيتي توليد مي‌كند، با اكاي هم عقيده است. وي مي‌گويد چنانچه Pivx يك حفره امنيتي را با ارايه شواهد و مدارك كافي به شركت مربوطه‌اش معرفي كند، انتظار دارد كه مشكل در مدت 1 ماه برطرف شود. او معتقد است، چنانچه نتوان به سرعت يك اصلاحيه توليد كرد، توليدكننده نرم‌افزار مشكل‌آفرين، بايد لااقل يك برنامه كمكي از طريق اينترنت در اختيار كاربران قرار دهد، (برنامه‌اي كه معمولاً ويژگي يا بخش مشكل‌دار برنامه مورد بحث را غيرفعال مي‌سازد) تا لااقل كاربران همچنان در معرض خطر باقي نمانند.
در مقام دفاع، كوين‌كين، مدير مركز واكنش امنيت شركت مايكروسافت و استفان تولوز، مدير برنامه امنيت شركت مي‌گويند كه هر حفره امنيتي و هر اصلاحيه، در نوع خود يك چالش منحصر به فرد مي‌باشد.
در مورد LSASS، تعداد 13 رخنه امنيتي ديگر نيز بايد برطرف مي‌شد. اين را تولوز مي‌گويد.
كين مي‌گويد مايكروسافت بايد ميان زماني كه صرف توليد اصلاحيه مي‌كند و كيفيت آن، تعادل به‌وجود بياورد. «ما نمي‌خواهيم دست به ريسكي بزنيم كه نتيجه آن عدم اعتماد مشتريان به اصلاحيه‌ها باشد.»
اما برخي از كاربران معتقدند اصلاحيه‌اي كه ارايه‌اش 6 ماه زمان ببرد، حتي اگر هنگام انتشارش كاملاً آزمايش شده و قابل اعتماد باشد، غيرقابل قبول است. تام كِلِرمن، متخصص ارشد مديريت امنيت داده‌ها در بانك جهاني مي‌گويد: «ما به اصلاحيه‌ها، پيش از آن‌كه خرابكاران به كدهاي نفوذ دست يابند احتياج داريم.» او مي‌افزايد: «از منظر ديگر، كاربران پي‌سي‌ها نيز مسؤوليت مهمي در اين پروسه دارند. كلرمن معتقد است كاربران بايد حداكثر پس از 24 ساعت از ارايه اصلاحيه، آن را مورد استفاده قرار دهند. وقتي كسي يك رخنه امنيتي كشف مي‌كند، هكرها بلافاصله آماده حمله مي‌شوند و در حالي كه كاربران در اجراي اصلاحيه‌ها اين دست و آن دست مي‌كنند، آن‌ها شبكه‌هاي دنيا را مورد هدف قرار مي‌دهند.»
Mac Donnell Ulsch مديرشركت Janus Risk Management مي‌گويد: «اگر قرار باشد روزي مشتريان، نرم‌افزارهايي دريافت كنند كه از همان ابتدا امن باشند، بايد خواستار ايجاد تغيير در روش توليد نرم‌افزارها در اين راستا باشند» و ادامه مي‌دهد كه: «ولي در حال حاضر به نظر مي‌رسد كه هيچ درخواست سازمان يافته‌اي براي اين منظور وجود ندارد.»

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 24 بهمنماه 1383

03:58 PM

February 12, 2005

سیستم عاملی به اندازه یک دیسکت

نوشته: امين ناصري كريمي

اشاره :
به گفته‌ي سازندگان اوليه‌ي این سیستم عامل، Menuet هیچ گونه ریشه و اساسی از استاندارد Unix یا Posix ندارد، بلکه براساس یک سیستم عامل مخصوص پایه گذاری شده است.

تا کنون سیستم عامل‌های مختلفی ارایه شده، اما بی‌شک یکی از کم حجم ترین آنها MenuetOS است که با توجه به گرافیک بالا از حجمي به اندازه یک دیسکت برخوردار است. MenuetOS سیستم عاملی است که کاملا با زبان اسمبلی 32 بیتی نوشته شده است. این سیستم به صورت Open Source (کد باز) بوده و سورس آن در وب سایت آن در دسترس همگان قرار داده شده تا همه بتوانند در توسعه آن همکاری کنند. این کار موجب شده تا افراد زیادی از هر کجای دنیا در توسعه آن شرکت کنند و توسعه آن سریع تر صورت گيرد.
به گفته‌ي سازندگان اوليه‌ي این سیستم عامل، Menuet هیچ گونه ریشه و اساسی از استاندارد Unix یا Posix ندارد، بلکه براساس یک سیستم عامل مخصوص پایه گذاری شده است.
هدف از طراحی این سیستم عامل حذف لایه‌های اضافی بین بخشهای مختلف از یک OS که موجب پیچیده شدن برنامه نویسی و بوجود آمدن باگها می شود، ذکر شده است .
از دیگر ویژگی های جالب این سیستم، این است که رابط گرافیکی کاربر (GUI) به سادگی با زبان اسمبلی ارتباط برقرار کرده و برنامه نویسی در این محیط را آسان می‌سازد.

از جمله ویژگی های بارز این سیستم عامل می‌توان به موارد زیر اشاره کرد:

- قابلیت چند وظیفه ای (Multitasking) ، Multithreading ، Ring-3 protection
- رابط گرافیکی با حداکثر رزولوشن 1024x 1280 و 16 میلیون رنگ
- IDE: ادیتور و ماکرو اسمبلر برای ساختن کرنل و برنامه های کاربردی
- TCP/IP Stack با قابلیت Loopback ،راه اندازهای (Deriver) PPP و Ethernet
- ابزارهای شبکه شامل سرورهای FTP ، HTTP ، Mp3 ، SMTP
-کلاینتهای IRC ، HTTP ، NNTP و TFTP
- فرم ها با قابلیت پذیرش Skin جدید
- قرار گرفتن بدون هیچ گونه فشرده سازی در یک فلاپی

همه موارد فوق مربوط به سیستم عاملی است که حجمی به اندازه یک دیسکت دارد که با توجه به حجم پایین می توان گفت که بی نظیر است.
در انتها نحوه نصب آن را به اختصار بیان می کنیم:

قبل از همه چيز شما مي بايست اين نرم افزار را از بخش دانلود سايت، دانلود كنيد و سپس آن را Extract كرده و setup.exe را اجرا كنيد اين برنامه براي نصب نياز به يك ديسكت خالي دارد. يك ديسكت Format شده در درايو A قرار دهيد و Y را تايپ كنيد، صبر كنيد تا برنامه فايلهاي مورد نياز خود را بر روي ديسكت كپي كند.
پس از اينكه فايلها كپي شد حال مي بايستي setup.exe را در درايو C قرار دهيد.
حال كامپيوتر خود را با ديسكتي كه ساختيد بوت كنيد در قسمت اول يكي از گزينه ها كه بستگي به كارت گرافيك و مانيتور شما دارد را انتخاب كنيد( 2 يا 3 مناسبند).بعد از اين مرحله، گزينه 1 را انتخاب كنيد، در مرحله بعد بازهم گزينه 1 را انتخاب كنيد. مرحله بعد نوع اتصال Mouse شما راسوال مي كند كه معمولا گزينه 1 مناسب مي باشد چون بيشتر Mouse ها از اين نوع هستند.
مرحله آخر بسيار مهم است، توجه داشته باشيد كه حتما setup.exe را در درايو C قرار داده باشيد، در اين مرحله گزينه 2 را انتخاب كنيد.
حال اين سيستم عامل به شما اعلام مي كند كه براي ادامه كليد Esc را بزنيد، اين كار را انجام دهيد و وارد اين سيستم عامل شويد و از آن لذت ببريد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 24 بهمنماه 1383

03:59 PM

February 12, 2005

Boot Managerها در يك نگاه

نوشته: شهرام شعباني

اشاره :
استفاده از نرم‌افزارهاي مديريت راه‌اندازي كامپيوتر (Boot Manager) به كاربران اجازه مي‌دهد تا چندين سيستم‌عامل مختلف روي كامپيوتر خود نصب نموده و در زمان راه اندازي، سيستم عامل مورد نظر خود را انتخاب كنند.

به طور كلي نرم افزارهاي مديريت راه اندازي كامپيوتر از نظر عملكرد و پيچيدگي به چند سطح مختلف تقسيم بندي مي‌شوند :
1_نرم‌افزارهايي كه با خواندن Boot Sector از اولين درايو (Partition) ديسك سخت، سيستم‌عامل را راه اندازي مي‌كنند. چنين نرم افزارهايي قدرت تشخيص فايل‌هاي سيستمي را نداشته و از اينرو توان پشتيباني از چندين سيستم عامل مختلف روي يك درايو را ندارند.
اين برنامه‌ها، ظاهر ساده‌اي داشته و فضاي كمي را اشغال مي‌كنند. به طور مثال OS/2 ، Lilo
و BootManager جزء اين دسته از نرم افزارهاي مديريت راه‌اندازي محسوب مي‌شوند.
2_نرم‌افزارهايي كه مي‌توانند Boot Sector را از فايل مشخصي بخوانند و آن را در حافظه مقيم كنند. اين برنامه‌ها معمولا جزئي از سيستم عامل‌هايي محسوب مي‌شوند كه انتظار مي‌رود در كنار ساير سيستم عامل‌ها به كار گرفته شوند. اين دسته از نرم‌افزارهاي مديريت راه‌اندازي از ظاهر بسيار ساده‌اي برخوردارند.
به عنوان مثال برنامه‌هاي NT OS Loader و PTS_Dos جزء اين دسته از نرم افزارها هستند.
3_ اين گروه شامل نرم‌افزارهاي قدرتمند و تمام عياري است كه قابليت جستجو و شناخت فايل هاي سيستمي را دارند. اين نوع از برنامه‌ها مي‌توانند به طور خود كار سيستم عامل‌هاي مختلف نصب شده روي كامپپيوترتان را كشف و شناسائي نمايند.
اين نوع نرم افزارهاي مديريت راه اندازي, نسبت به سيستم و پيكربندي فايل‌هاي سيستم عامل كامپيوتر شما هوشيار هستند و با تهيه نسخه‌ي پشتيبان از اين فايل‌ها، شما را در به اختيار داشتن چندين سيستم عامل مختلف بر روي يك درايو ياري مي‌نمايد. معروفترين نرم افزارهايي كه به اين روش عمل مي‌كنند عبارتند از : BootWizard 3.x , System Commander و BootIt.
4_اين گروه شامل نرم‌افزار‌هايي است كه علاوه بر در اختيار داشتن تمامي امكانات نرم افزارهاي دستهء سوم, به كاربران امكان داشتن چندين سيستم عامل مختلف در يك درايو و حتي يك شاخه را نيز مي‌دهند. بوسيله اين برنامه‌ها كاربران مي‌توانند درايوهاي دلخواه خود را از ديد ساير سيستم عامل‌ها مخفي كرده و اجازه دسترسي را از آنها سلب نمايد.
زماني كه سيستم عامل جديدي روي كامپيوترتان نصب مي‌كنيد, ممكن است نياز شود تقسيمات ديسك سخت خود را تغيير دهيد. به همين منظور معمولا در بسته‌هاي نرم افزاري اين گونه برنامه‌ها(گروه سوم و چهارم) ابزارهايي براي مديريت ديسك سخت وجود دارد كه اين برنامه‌ها كاربر را قادر مي‌سازد تا اعمال متنوع و مختلفي از قبيل حذف, ايجاد, فرمت و يا تغيير اندازه‌ي هر يك از درايوهاي دلخواه را بدون از دست رفتن اطلاعات, به انجام برساند.
به دليل محدوديت هاي موجود در سيستم فايل FAT16 كه در سيستم عامل هايي همچون MS_Dos , Windows95/98/Me وجود دارد , تقريبا 40% از فضاي ديسك سخت به هدر مي رود. با كمك نرم افزارهاي مدير ديسك مي‌توانيد فضاهاي هدر رفته ديسك را تجزيه و تحليل نموده و با تغيير نوع سيستم فايل كامپيوتر خود از FAT16 به FAT32 يا NTFS, مقدار هدر رفته‌ي ديسك را به حداقل برسانيد( امكان برگرداندن آن نيز وجود دارد ).
با امكانات و تسهيلاتي كه برنامه مدير ديسك در اختيار شما قرار مي‌دهد, مي‌توانيد به سادگي اعمال مختلفي را روي سيستم‌هاي NTFS ,Linux Ext2 , Linux Swap و حتي Linux ReiserFs انجام دهيد.
به عنوان مثال يكي از اين برنامه‌ها كه در مقايسه با بقيه، از قدرت بيشتري برخوردار است، نرم‌افزار Acronis OS Selector مي‌باشد. برخي از ويژگي‌هاي مهم اين برنامه از اين قرار است :
• پشتيباني از بيش از 100 سيستم عامل روي يك كامپيوتر
• پشتيباني از سيستم عامل‌هايي كه در Primary Partition (بخش اوليه ديسك سخت ) نصب مي‌شوند.
• پشتيباني از سيستم عامل‌هايي كه در Logical Partition (بخش منطقي ديسك سخت) نصب مي‌شوند.
• امكان راه اندازي سيستم از درايوهاي A وB
• پشتيباني از چندين سيستم عامل كه بر روي يك FAT جاي گرفته اند.
• تهيه خود كار نسخه پشتيبان از فايل هاي مهم و حياتي سيستم از قبيل : IO.sys , MSDOS.Sys , Command.com , config.Sysوبازيابي آنها
• تشخيص آلوده شدن Boot Sector به ويروس
• امكان رمزگذاري روي منوي Boot (منوي راه اندازي سيستم عامل ها)
• امكان رمزگذاري روي ليست سيستم عامل هاي موجود در منو يا هر يك از آنها.
كار با اين‌گونه برنامه‌ها به تخصص و تجربه‌ي كافي نياز دارد، بنابراين هنگام نصب و استفاده از چنين برنامه‌هايي، جانب احتياط را رعايت كنيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 24 بهمنماه 1383

04:26 PM

February 12, 2005

مجلس راه ميانه‌اي ندارد: يا اصلاح حداقلي يا اصلاح انقلابي

بي‌شک داغترين موضوع ماه‌هاي اخير مخابرات کشور، ماجراي واگذاري امتياز اپراتور دوم موبايل به ترک‌سل بوده است. اين ماجرا فرصت مناسبي ايجاد کرد تا کارشناسان، صاحب‌نظران و دست‌اندرکاران صنعت مخابرات کشور و نيز مسئولان بخش‌هاي مختلف، بار ديگر سراغ مباحثي چون استفاده از توان داخلي و ابعاد استراتژيک صنعت مخابرات بروند. اين ماجرا همچنين يادآور جايگاهي بود که مجلس شوراي اسلامي، چه از نظر نظارت و چه از نظر قانون‌گذاري، از آن برخوردار است. اما هم‌اکنون همة نگاه‌ها متوجه مجلس است و اين، دقت‌نظر بيش از پيش نمايندگان را براي اصلاح و بهبود شرايط موجود مي‌طلبد. در زير، با نگاهي کوتاه به دو راهبرد پيش روي مجلس در خصوص امتياز اپراتور دوم موبايل، به بيان برخي انتظارات کارشناسان و دلسوزان صنعت مخابرات از مجلس مي‌پردازيم:

در روزهاي اخير قرارداد واگذاري اپراتوري دوم تلفن‌همراه به کنسرسيوم موسوم به " ايران‌سل " ، منتظر تصميم‌‌گيري مجلس براي اجرايي شدن است. مجلس هفتم با تصويب طرحي دوفوريتي که دولت را ملزم به اخذ مجوز از مجلس براي انعقاد اين قرارداد ‌کرد، عملاً نشان داده است که رويه‌اي خلاف مجلس ششم در پيش گرفته است و مي‌خواهد در مقابل سياست‌گذاري‌هاي مخابراتي دولت، نقش فعال‌تري ايفا کند. مجلس هفتم، دغدغة حمايت از توان داخلي و تقويت بخش خصوصي داخلي دارد و همچنين مسائل امنيتي را از جمله دلايل تغيير رويکرد خود قلمداد مي‌کند.

روش کار مجلس هفتم نسبت به مجلس ششم بسيار تغيير کرده‌است: اولاً نوع اين طرح از نظر الزام دولت به لغو يک تصميم خاص، تازگي دارد. ثانياً اينکه در بررسي اين قرارداد، از ترکيبي از کميسيون‌هاي صنايع و معادن، اقتصادي و امنيت بهره برده مي‌شود، نشان‌دهندة نگاه جديد مجلس به حوزة مخابرات است. از ديگر تفاوت‌هاي مجلس هفتم با مجلس ششم در اين زمينه، پررنگ‌تر شدن نقش مرکز پژوهش‌هاي مجلس به عنوان بازوي فکري نمايندگان مجلس در اين قرارداد که برگزاري جلسات متعدد با کارشناسان و پي‌گيري شديد براي کسب تمامي اطلاعات قرارداد، از اهم فعاليت‌هاي اين مرکز بوده است. البته به نظر مي‌رسد به‌دليل تخصصي بودن مباحث حوزه مخابرات، مرکز پژوهش‌هاي مجلس بايد تعامل بيشتري با کارشناسان و استادان دانشگاهي برقرار نمايد تا بتواند به سئوالات نمايندگان مجلس به نحو احسن پاسخ گويد.

راهبردهاي پيش‌رو

اما راهبردهاي مجلس شوراي اسلامي در قبال اين قرارداد، با توجه به اظهارنظرهاي نمايندگان، از دو حالت خارج نيست:

1- اولين راهبرد که از طريق تعدادي از نمايندگان، که اکثراً نيز از جمله مخالفين تصويب طرح دوفوريتي الزام دولت به اخذ مجوز از مجلس بوده‌اند، پي‌گيري مي‌شود، "تصويب اين قرارداد با پاره‌اي اصلاحات" است.

دولت در لايحه مربوط به اين قرارداد که به مجلس تقديم کرده‌است، چهار بند را ذکر نموده که در آن تمامي تدابير امنيتي را منوط به پيشنهاد وزارت ارتباطات و فناوري اطلاعات و وزارت اطلاعات کرده و دولت مکلف شده‌است در قلمرو شبکه‌هاي غير مادر مخابرات در ايجاد شبکه‌هاي تلفن‌همراه نظارت بيشتري داشته باشد. همچنين تصويب اين قرارداد را بعد از نظر مثبت مجلس، منوط به تاييد توجيه اقتصادي آن از سوي شوراي اقتصاد کرده است. اما حتي نمايندگان موافق با تصويب قرارداد نيز، اصلاحيه‌هاي فوق را کافي نمي‌دانند و اصلاحيه‌هاي ديگري را نيز لازم مي‌دانند:

مهمترين اصلاحيه نمايندگان موافق قرارداد، بنا به گفته دکتر صادق‌زاده، رييس کميته مخابرات مجلس، "افزايش سهم شرکاي ايراني و کاهش زمان مجوز واگذاري اپراتوري" است. رييس کميته مخابرات مجلس در پاسخ به خبرنگار روزنامه ايران مي‌گويد: "ما انتظار داريم دولت ترکيب سهام شرکت‌هاي ايراني و خارجي در اين قرارداد را به گونه‌اي اصلاح کند که حداقل 51 درصد سهامداران، ايراني و حداکثر 49 درصد سهامداران،‌ غيرايراني باشند". همچنين وي اظهار مي‌دارد: "در قرارداد فعلي، زمان واگذاري 16ميليون تلفن‌همراه، 15سال تعيين شده است که اين زمان بايد کاهش يابد؛ چرا که براي تکنولوژي‌هاي امروز، مدت زمان 15سال طولاني است و هر روز فناوريهاي نويني به بازار عرضه مي‌شود."

نمايندگان طرفدار اين راهبرد، دغدغة اصلي خود را تأمين خدمات مورد نياز مردم در اسرع وقت، با کمترين هزينه و حداکثر کيفيت ذکر مي‌کنند.

هرچند دولت در لايحه تقديمي خود، حتي اين خواسته‌هاي حداقلي نماينده‌ها را نيز برآورده نکرده‌است، اما با توجه به چراغ سبز ترک‌ها، که فقط به مديريت اپراتوري اين پروژه، بالا بردن آمار تعداد مشترکين خود و رقابت با اپراتورهاي مطرح جهان چشم دوخته‌اند و همچنين با توجه به پيشنهادهايي که دولت در گزارش خود به مرکز پژوهش‌هاي مجلس مطرح کرده است، به طور قطع اگر مجلس در مورد تصويب اين قرارداد به اجماع برسد، اين اصلاحيه‌هاي حداقلي به عنوان راهبرد اصلي نمايندگان مدنظر خواهد بود.

2- راهبرد ديگري که مدنظر تعدادي از نمايندگان است، مخالفت با انعقاد اين قرارداد و لغو آن است. خواستة اين نمايندگان اين است که "مديريت اپراتوري" هم بر عهده شرکت‌هاي ايراني باشد و فقط از شرکت‌هاي خارجي به عنوان مشاور و نقشي شبيه نقش يک مربي خارجي در هدايت يک تيم ملي ورزشي استفاده شود. از ديدگاه اين نمايندگان، براي تشکيل يک تيم ورزشي قدرتمند نياز به اعطاي تبعيت ايراني به بازيکنان مطرح خارجي نيست و تربيت جوانان با‌ استعداد ايراني توسط مربيان خارجي کفايت مي‌کند؛ به عقيدة اين نمايندگان، در اين صورت اين قرارداد از مشکلات امنيتي ناشي از سپردن مديريت اپراتوري به خارجي‌ها نيز به دور مي‌ماند. همچنين، از ديد نمايندگان معتقد به اين راهبرد، ايجاد شبکه دوم تلفن همراه نيازمند سرمايه‌گذاري خارجي کلان نيست و استفاده از سرمايه‌هاي داخلي نيز، براي اين امر کفايت مي‌کند.

هرچند بسياري از متخصصين وصنعتگران داخلي و استادان دانشگاهي نيز از راهبرد دوم حمايت مي‌کنند، اما مجلس در صورت تصويب اين راهبرد، بايد بداند که به انقلابي در صنعت مخابرات و در راستاي استفاده حداکثر از توان داخلي دست زده‌است و لازم است خود را براي تبعات آن نيز آماده کند. آنچه نمايندگان محترم بايد در پي‌گيري اين راهبرد مدنظر داشته باشند، اين است که جاده واگذاري اپراتوري دوم تلفن‌همراه به گونه‌اي طراحي شده‌است که به طور طبيعي بخش خصوصي داخلي را توان پيمودن آن نيست و آرمان استفاده حداکثر از توان داخلي، بدون تغييرات بنياني در تفکرات تصميم‌گيران دولتي و بدون تبديل اين هدف به يک آرمان ملي فراتر از حوزه وزارت ICT ، فقط منجر به محروم شدن مردم از خدمات تلفن‌همراه با کيفيت بهتر خواهد شد.

بنابراين، نمايندگان طرفدار اين راهبرد، بايد سريعاً در جهت رفع مشکلات احتمالي و بهبود وضعيت کلي صنعت مخابرات، به تصويب طرح‌هاي لازم ديگر نيز اقدام کنند كه از جمله مي‌توان به موارد زير اشاره کرد:

1- اصلاح لايحه وظايف وزارت جديدالتأسيس ارتباطات و فناوري اطلاعات و تاکيد به اين نکته که وظيفه اين وزارتخانه فقط " خدمات رساني" نيست. اين وزارت ، به عنوان بزرگترين مشتري صنعت مخابرات، وظيفة مهم حمايت از توان داخلي در رقابت با رقيبان خارجي را بر عهده دارد. براي تحقق اين امر، بايد با همکاري نهادهاي ديگر همچون وزارت صنايع و معادن و سازمان مديريت و برنامه‌ريزي، "سياست خريد دولتي در صنعت مخابرات" تدوين شود و در صورت لزوم به تصويب مجلس برسد.

2- پي‌گيري در جهت اصلاح برنامه تدويني وزارت صنايع با عنوان "استراتژي صنعتي کشور" با هدف تعيين اولويت‌هاي ملي در حوزه صنعت کشور و پي‌ريزي محيط حمايتي از صنايع استراتژيک کشور از ديگر اقدامات لازم در اين خصوص است. حمايت از صنايع استراتژيک، سياستي است که در اکثر کشورهاي پيشرو و جديداً توسعه‌يافته مانند کره، مالزي، هند، سنگاپور و غيره به‌طور جدي پي‌گيري مي‌شود و در کشور ما بدليل کمونيستي جلوه دادن اين سياست، مورد توجه برنامه‌ريزان صنعتي قرار نگرفته است. اين امر در مورد صنعت مهم و استراتژيک مخابرات از اهميت بيشتري برخوردار است.

3- ايجاد بسترهاي تقويت انگيزه کارآفرينان و سرمايه‌گذاران همراه از جمله با ادامه اصلاح روند تورمي در اقتصاد کشور، كاهش بهرة بالاي بانکي، اصلاح قوانين کار و بيمه و امثال آن از ديگر اقدامات لازم در اين خصوص است. صنعت مخابرات، حاوي ويژگي‌هايي است که نيازمند حمايت از مديران صنايع در جهت امکان جابجايي شاغلين در اين صنعت و استفاده بهينه‌تر از نيروي انساني مجرب‌تر در پروژه‌هاي مختلف تحقيقاتي و توليدي شرکت‌هاي مخابراتي است و اين نياز به تدوين قوانين متناسب آن دارد. بنابراين مجلس محترم بايد در اين خصوص تدابير لازم را مدنظر قرار دهد.

4- برنامه‌ريزي در جهت اصلاح ديدگاه مديران ارشد تصميم‌گير در مورد جذب سرمايه‌هاي خارجي و تأکيد بر اين ديدگاه که تسهيل سرمايه‌گذاري مستقيم خارجي، به‌معني توسعه فناوري نيست. "همکاري تکنولوژيک" را نبايد با "همکاري سرمايه‌گذارانه" و مثلاً "سرمايه‌گذاري مستقيم خارجي" معادل دانست؛ به‌خصوص در فناوري‌هاي جديد مخابراتي (مانند تلفن‌همراه و اينترنت) که برگشت سرمايه به سرعت اتفاق مي افتد، جذب سرماية خارجي چندان مورد نياز ما نيست.

5- در نهايت، الزام دولت به مطالعه، طراحي و تدوين نظام ملي نوآوري و نظام ملي، تأسيس نهادهاي تأمين سرمايه ريسک‌پذير ( venture capital )، نهادهاي حقوقي چون ثبت اختراع و دادگاه‌هاي تخصصي نهادهاي مطالعاتي ويژه تکنولوژي چون پايش ( monitoring )، پيش‌بيني ( forecast )، دوربيني ( foresight ) و غيره، نهادهاي استاندارد و تاييدکننده کيفيت و صلاحيت، انواع شرکت‌هاي طراحي و مهندسي، انواع نهادهاي پيمانکاري و مديريت پروژه، نهادهاي اطلاع‌رساني و انتشار تکنولوژي، مراکز رشد ( Incubators )، پارک‌هاي فناوري، خوشه‌هاي صنعتي، مناطق ويژه صنعتي، نهادهاي سياست‌گذاري، نهادهاي ترويجي، تشکل‌ها و مراکز ملي خدمات فناوري (آزمايشگاه‌هاي ملي و مراکز ملي انتقال تکنولوژي) از جمله اجزاي مهم در نظام ملي فناوري و يا نظام ملي يادگيري هستند و بسياري از آنان در بخش مخابرات کشور وجود ندارند و يا اينکه فقط داراي تابلويي بدون خروجي‌هاي لازم هستند. مجلس محترم بايد در جهت تحقق و ايجاد چنين ساختارهايي به‌ويژه در صنعت مخابرات تدابير لازم را بينديشد.

طبق ارزيابي‌هاي کارشناسان، بازار صنعت مخابرات کشور (تجهيزات و خدمات) در سال، در حدود 6 ميليارد دلار است و تسخير بازارهاي منطقه‌اي مانند آسياي ميانه، عراق، افغانستان و حتي کشورهاي آفريقايي نيز همگي از جمله فرصت‌هايي هستند که بايد به آنها توجه کرد و البته استفاده از بازار پرکشش داخلي در جهت فعال‌سازي متخصصين ايراني، شرط لازم ورود به اين عرصه است. فراهم کردن محيط مناسب رشد براي صنعت داخلي و در عين حال، ارزيابي مستمر عملکرد آنان (با اين توجه که به سرنوشت توليد پيکان منجر نشود)، بايد مد نظر نمايندگان طرفدار راهبرد "لغو قرارداد با اپراتور خارجي" قرار گيرد تا در نهايت، شاهد رشد توانمندي داخلي در حدي باشيم که بتوانند با رقباي خارجي در همة زمينه‌ها رقابت کنند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 26 بهمنماه 1383

12:55 PM

February 14, 2005

نگاهى به استانداردهاى امنيتى اطلاعات و ارتباطات

نوشته: مهدى راستى

خبرهايى مبنى بر پيش نويس سند ملى امنيت فضاى تبادل اطلاعات کشور که
هدف از آن تعيين استانداردهايى در حوزه امنيت اطلاعات و ارتباطات است ،
همه جا ديده مىشود، اما استانداردهاى امنيت اطلاعات و ارتباطات چيستند؟
استانداردها مستنداتى هستند که بمنظور هماهنگ کردن و در نتيجه بهبود
کارآيى و بهره ورى سيستم ها و يا افزايش ايمنى و سلامت در يک مجموعه
ارائه مىشوند و عملا معيارى براى مقايسه و ارزيابى سيستم ها نيز فراهم
مىکنند.
استانداردهاى امنيتى در حوزه شبکه هاى کامپيوترى را مىتوان بر اساس
حوزه مقبوليت و تدوين به دسته هاى زير تقسيم کرد :
- استانداردهاى بين المللى : استانداردهايى که توسط موسسه هاى
استانداردسازى بين المللى، که محدوده وسيعى از کشورها در آنها عضويت
دارند، تدوين مىشوند (نظير استانداردهاى ISOو IETF).
اعتبار اين استانداردها به نوع استاندارد بستگى ندارد و کاملا وابسته
به اعتبار جهانى موسسه استانداردسازى است .
- استانداردهاى منطقه اى و ملى : استانداردهايى که توسط سازمان ها و
موسسه هاى صاحب اختيار کشورها يا اتحاديه هاى منطقه اى تدوين مىشوند. در
داخل کشورها نيز استانداردهاى بسيارى بخصوص در بخش هاى مختلف دولتى،
نظامى و اقتصادى تدوين مىشود.
- استانداردهاى صنعتى و تجارى : استانداردهاى فنى که توسط صنايع و
شرکتها ايجاد و ترويج شده اند (نظير استانداردهاى و GSM ITU)
- استانداردهاى : de factoاستانداردهايى که توسط سازمانها يا موسسه هاى
خاصى تدوين شده اند ولى مقبوليت گسترده اى پيدا کرده اند (نظير۷۷۹۹ BSو
PKC)
استانداردها را بطور کلى مىتوان به چهار نوع تقسيم نمود :
استانداردهاى پايه که مربوط به اصطلاحات ، علائم ، نشانه ها، قرادادها،
... هستند.
- روشهاى تست و استانداردهاى تحليل که براى اندازه گيرى مشخصات بکار
مىروند.
- استانداردهاى محصول، سرويس performanceکه آستانه هاى قابل قبول را
مشخص مىکنند.
- استانداردهاى سازمانى يا مديريتى که فعاليتهاى يک سازمان و روابط
بين آنها را توصيف و مدل مىکنند
استانداردهاى امنيت اطلاعات و ارتباطات نيز مىتواند به اين چهار گروه
تقسيم شود. اگرچه ISOاين استانداردها را به سه دسته زير تقسيم کرده
است :
- استانداردهاى مديريت امنيت
- استانداردهاى مربوط به الگوريتم ها و تکنيک ها
- استانداردهاى ارزيابى امنيتى
دسته مهم ديگرى از مستندات که اغلب در غالب دستورالعملها ارائه
مىشوند، دستورالعملهاى پياده سازى امنيت هستند که اغلب بصورت
دستورالعملهاى پيکربندى امن سيستم ها و شبکه ها ارائه مىشوند.
به نظر مىرسد بهترين روش براى تعيين استانداردهاى امنيت در داخل
کشور، تلفيق استانداردهاى معتبر جهانى در حوزه امنيت فضاى تبادل اطلاعات
است .
براى آشنايى با فهرست جامعى از استانداردهاى امنيت اطلاعات تحت عنوان
Information Systems Security Standards Handbookک ه توسط سازمان منطقه اى
APECارائه شده است ، مىتوانيد به آدرس اينترنتى
tm۱۸l /estg /estgh۲۶ www.apectelwg.org /apecdata /telwg /e
مراجعه کنيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 26 بهمنماه 1383

12:58 PM

February 14, 2005

بررسى و شبيه سازى تکنيک هاى جمينگ در ماهواره ها و سيستم هاى فضايى

يکى از روش هاى موثر براى مقابله با ماهواره ، تکنيک هاى جمينگ است .
نتايج شبيه سازى نشان مىدهد که براى سيستم هاى ماهواره اى باند باريک ،
JSRحدود۱ تا B۲ Dعملکرد اين سيستم ها را مختل مىکند اما سيستم هاى
ماهواره اى طيف گسترده با توجه به نرخ چيپ اين مدولاسيون ها، JSRهاى بالاترى
نياز است .
در بين تکنيک هاى جمينگ ، جمينگ پالسى داراى بهترين عملکرد بوده و به
دليل روشن شدن در زمان کوتاهى از دوره کارى، آشکارسازى آن هم بسيار مشکل
است .
جمر سينوسى ساده ترين جمر مىباشد اما به راحتى قابل کشف و حذف شدن
توسط فيلترها مىباشد به اين دليل بايد فرکانس سينوس تا حد ممکن به
فرکانس مرکزى نزديک باشد.
از نظر استراتژى جمينگ نيز بهترين عملکرد هنگامى حاصل مىشود که جمينگ
در زمان انتشار سيگنال فضايى انجام شود که مستلزم داشتن اطلاعات سيگنال و
گيرنده جستجو مىباشد.
تکنيک جمينگ يکى از راه هاى مقابله با ماهواره مىباشد.
اين روش داراى اين مزيت است که خسارت فيزيکى به ماهواره يا گيرنده
وارد نکرده و در نهايت نمىتوان وجود يا نبود آن را بيان کرد.
در تکنيک جمينگ باند پهن يا AWGNکل پهناى باند پوشش داده مىشود، در
حقيقت اين جمينگ سطح نويز گيرنده را بالا مىبرد، اين جمينگ يک سيگنال
AWGNمىباشد.
جمينگ سينوسى به راحتى توليد شده و تنها يک فرکانس را تحت تاثير قرار
مى دهد، عيب اين جمينگ کشف آن مىباشد چون به صورت يک پالس در طيف توان
مشاهده مىشود.
در جمينگ پالسى، جمر تنها در زمانى خاص روشن شده و جمينگ را انجام
مى دهد، اين جمينگ در کسر کوچکى از زمان انجام مىشود.
اکثر سيستم هاى ماهواره اى از تکنيک تصحيح خطا استفاده مىکنند، در
اين قسمت اثر جمرهاى مختلف به سيستم هاى کدينگ بررسى مىشود.
تنتايج شبيه سازى نشان مىدهد که تکنيک هاى جمينگ به تکنيک هاى باند
باريک موثر بوده است .
در بين تکنيک هاى جمينگ شبيه سازى شده ، جمينگ سينوسى ساده ترين تکنيک
بوده و به راحتى توليد مىشود اما جمينگ پالسى به دليل دامنه جمينگ بسيار
بالاتر در توان يکسان بهترين عملکرد را براى تخريب عملکرد داشته است .
علاوه بر اين چون کسرى از ثانيه انجام مىشود کشف و مبارزه با آن مشکل
است .
اما تکنيک هاى طيف گسترده بسته به نرخ چيپشان در مقابل جمرها مقاوم
هستند و هرچه نرخ چيپ بالاتر باشد، مقاومت بالاترى را داراست ، در اين مورد
هم موثرترين تکنيک جمينگ پالسى است .
اين مقاله توسط "داريوش عباسى مقدم " کارشناس ارشد مخابرات صنايع
مخابرات صا ايران و دکتر " محمد سليمانى" استاد دانشکده برق دانشگاه علم
و صنعت در سمينار هفته پيش دفاع الکترونيک ارايه شده است .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 26 بهمنماه 1383

01:01 PM

February 14, 2005

بررسی معماری سرویس گرا

نوشته: سهیل توده فلاح

اشاره :
در چهار دهه اخیر ، پیچیدگی نرم افزارها روز بروز بیشتر شده و تقاضا برای نرم افزارهای قدرتمندتر افزايش يافته است. در این میان ، به نظر می رسد که روشهای قدیمی جوابگوی نیازهای در حال رشد کنونی نیستند و نیاز به ایجاد و بکارگیری روشهایی است که بوسیله آنها بتوان بر این پیچیدگیها در زمانهايی کوتاهتر غلبه کرد. از طرفي امكان كنار گذاشتن سیستمهای نرم افزاری موجود که تا به حال مشغول سرویس دهی به مشتریان بوده اند ، وجود ندارد و می بایست سیستمهای جدید را بصورت یکپارچه و در کنار همین سیستمها بوجود آورد. معماری سرویس گرا ، با تکیه بر محاسبات توزیع شده و بر پایه شبکه ها و لایه های میانی و همچنين زبانهایی که توليد نرم افزارهای توزیع شده را فراهم مي كنند ، بعنوان راه حلی مناسب جهت از میان برداشتن مشکلات و مسائل مذكور مطرح گرديده است. در این مقاله ضمن معرفی این معماری به محاسبات سرویس گرا و نیازهای آن پرداخته و معماری سرویس گرای توسعه یافته به عنوان راه حلی برای رفع این نیازها ارائه می شود.

معرفی
تعاريف گوناگوني از معماري سرويس گرا ارائه شده است كه از جمله آنها مي توان به تعاريف زير اشاره كرد:
مجموعه قوانين ، سياستها و چهارچوبهايي كه نرم افزارها را قادر مي سازد تا عملكرد خود را از طريق مجموعه سرويسهاي مجزا و در عين حال مربوط به هم در اختيار ساير درخواست كنندگان قرار دهند تا بتوانند بدون اطلاع از نحوه پياده سازي و تنها از طريق رابطهاي استاندارد و تعريف شده ، این سرويسها را پيدا كرده و فراخواني نمايند.و یا معماری سرویس گرا روشي برای ساخت سیستمهای توزیع شده اي است که در آنها عملکرد سیستم بصورت سرویس در اختیار کاربران و یا سایر سرویسها قرار می گیرد.
از ديگرتعاريف ارائه شده مي توان به "واحدهاي نرم افزاري آماده در شبكه (Network-available Software Unit) " يا "سرويسهاي سطح حرفه (Business-level services) " اشاره كرد.
در حال حاضر ، تکنولوژی سرويسهاي وب(Web Services) و پیاده سازی نمونه های موفق از آن، نشان داده است که SOA می تواند به عنوان راه حلی عملی و دست یافتنی در طراحی سیستمهای جدید و یکپارچه-سازی سیستمهای بزرگ موجود ، مطرح گردد. البته ذکر تفاوت سرويسهاي وب و SOA در اینجا لازم به نظر می رسد.
سرويسهاي وب مجموعه ای از تکنولوژیهایی همچون XML,SOAP,WSDL و UDDI می باشد که امکان ارائه راه حل و برنامه نويسي جهت رفع مشکلی خاص را فراهم مي نمايد.
در حالی که SOA یک معماریست و از مجموعه مشخصی از تکنولوژیها فراتر مي باشد. اگرچه SOA بر اساس این تکنولوژیها راه حل ارائه می نماید ، اما در عین حال مستقل از هر یک از آنها است.
آنچه اهمیت دارد تعریف سرویس به عنوان مهمترین عنصر این معماری می باشد.
سرویس ، رفتار قرادادی تعریف شده ایست که هر قطعه ای می تواند آنرا جهت استفاده سایر قطعات در سیستم تهیه و پیاده سازی نماید.
در این معماری ، همه توابع به عنوان سرویس تعریف می گردند. این توابع شامل توابع حرفه (Business functions) و تراكنشهاي حرفه‌اي (Business transactions)می باشند كه تراكنشهاي حرفه خود شامل توابع سطح پايين (Low-level functions) و توابع سيستمي سرويسها(System service functions) هستند.
سرویسها بصورت مستقل طراحی و پیاده سازی شده و به عنوان جعبه سياه عمل می نمایند. قطعات دیگر در خارج از این قطعه نیازی به دانستن نحوه انجام کار در این سرویس را ندارند و تنها به نتیجه آن نیازمندند.
قطعات، سرویسهای خود را از طریق رابطها (interface) در اختیار قطعات دیگر قرار میدهند که این رابطها قابل دستیابی و فراخوانی هستند، بدون اینکه محل قرار گیری آنها اهمیت داشته باشد (رابطهاي محلي يا دور ) . در ضمن این رابطها می توانند به همان نرم افزار كاربردي یا به آدرسی در محل دیگری از شبکه مرتبط باشند .
رابطها به عنوان کلیدی در برقراری این ارتباطها هستند و از طریق آنها نوع پارامترهای ورودی و نتایج (خروجی) مشخص می گردد.
بعلاوه ، با ایجاد قابلیت توزیع شدگی به شكلي مناسب و بدون وابستگی زیاد ، می توان سرویسها را در قسمتهای مختلف شبکه و بصورت بعضا تکراری ( مخصوصا برای سرویسهای مهم ) قرار داد تا این سرویسها همیشه در دسترس بوده و در صورت زیاد شدن درخواستها بتوان با استفاده از تکنیکهای Load Balancing به تمامي آنها به‌خوبی پاسخ داد.

ویژگیهای سرویس و محاسبات سرویس گرا
محاسبات سرویس گرا (SOC) ، نمونه ای از محاسبات است که در آن طراحی و توسعه سیستم های کاربردی بر پايه سرویس به عنوان عنصر اساسی ، انجام می گیرد. سرویس ها عناصری هستند که مستقل از پلتفرم بوده و در ساخت سیستمهای توزیع شده سریع و ارزان قیمت کمک می نمایند. همچنین سازمانها را قادر می- سازند تا توابع خود را از طریق زبانها و پروتکلهای بر پایه XML پیاده سازی و بر روی اینترنت یا اینترانت ارائه نمایند.
از آنجا که سرویسها از طریق سازمانها و شرکتهای گوناگون تهیه می شوند و جهت دسترسي كاربران مختلف می بایست همواره در دسترس باشند ، رعایت ویژگیهای زیر ضروری می باشد:

- مستقل از تکنولوژی باشند؛ به این معنا که بکارگیری و مکانیزم فراخوانی و پیدا کردن سرویسها به راحتی و از تمام محیطها ( سیستمهای عامل مختلف و زبانهای برنامه سازی گوناگون ) میسر بوده و وابسته به پلتفرم خاصی نباشد.

- وابستگی بسیار پایینی بین درخواست کننده و ارائه دهنده سرویس وجود داشته باشد و یا بعبارتی Loosly Coupled باشد. به این معنا که درخواست کننده نباید هیچ نیازی به دانستن ساختار داخلی و نحوه پیاده سازی سرویس داشته باشد. برای این منظور ، فراخوانی سرویس از طریق بکار گیری مکانیزم پیغام (Message) بجای فراخوانی API انجام می گردد.

- درخواست کننده نباید نیازی به دانستن محل قرارگیری سرویس داشته باشد و بعبارتی معماری سرویس گرا می بایست Location Transparency را پشتیبانی نماید. به این ترتیب که محل قرارگیری سرویس و مشخصات آن در مخزنی (Repository) قرار می گیرد و درخواست کننده ، محل و اطلاعات لازم را از طریق بازیابی آن از این مخزن بدست می آورد.

سرویس ها می توانند به دو شکل ساده و ترکیبی ارائه شوند. سرویسهای ترکیبی ، سرویسهایی هستند که بر اساس بکارگیری چند سرویس ساده ( یا ترکیبی) ایجاد می شوند. برای مثال ، ممکن است سیستم توزیع شده ای بر اساس چند سرویس ساده صدور صورتحساب ، ثبت سفارش ، مدیریت روابط مشتری و ... سرویسهای ترکیبی گسترده تری در ارتباط با حرفه اي خاص ایجاد نماید.
سیستمهای ساخته شده بر اساس سرویس ، ترکیبی از سرویسهای مستقل هستند که عملکردهای خود را از طریق رابطهای تعریف شده ای در اختیار کاربران (بالقوه ) خود قرار میدهند. (Web Service Description Language)WSDL از جمله راههایی است که بطور گسترده برای تعریف این رابطها بکار می رود تا بوسیله آن جزئیات لازم برای اتصال درخواست کننده به ارائه دهنده سرویس تعریف شود.

نرم افزار به‌عنوان سرویس
اصل ارائه شده " نرم افزار- بعنوان- سرویس" از محاسبات سرویس گرا ، بر اساس مدل ASP مطرح گشته است. ASP هویت سوم شخصیست که بكارگيري سرويسهاي نرم افزاري و دسترسی مشتری را به بسته نرم افزاری از طریق شبكه، مدیریت و میزبانی می نماید.به‌عبارتی ASP ها راهی برای رفع نیازهای IT شرکتها از طریق واگذاری بخشي از این نيازها یا تمامی آنها به بیرون از سازمان می باشند.
برای این منظور ASP با استفاده از زیر ساختهای خود ، ارتباط بین مشتری و نرم افزار ارائه شده را برقرار کرده و دسترسی وی به داده ها و توابع موجود را بصورت در دسترس (online)، مدیریت می نماید.
اگرچه نظریه "نرم افزار بعنوان سرویس" اولین بار توسط ASP ارائه شد ، اما مشكلات این روش باعث ایجاد کدهایی می شد که معمولا قابل استفاده مجدد نبوده و محدود به مشتری خاص می بود ، بعبارتی وابستگی زیادی بین سرویس ارائه شده و سیستم استفاده کننده بوجود می آمد.
معماری سرویس گرا اجازه میدهد تا نظریه "نرم افزار بعنوان سرویس"، گسترش یافته تا از طریق آن بتوان پردازشها و تراکنشهای پیچیده را بعنوان سرویسهايی با قابلیت استفاده مجدد ارائه کرد و به این ترتیب سیستمها را مستقل از سرویسها طراحی و تولید نمود.

معماری سرویس گرای مقدماتی

SOA شیوه ای منطقی برای طراحی سیستمهای نرم افزاری است که از طریق آن سرویسهایی جهت ارائه به کاربران یا سایر سرویسهای توزیع شده بر روی شبکه ایجاد می شود و این سرویسها از طریق رابطهای تعریف شده در دسترس می باشند.
معماری سرویس گرای مقدماتی ، راهی برای تبادل اطلاعات بین عاملهای نرم افزاری بوسیله پیغام تعریف می نماید. این عاملها ، درخواست کننده سرویس (مشتری) و یا تهیه کننده سرویس می باشند. علاوه بر این دو، عامل دیگری بعنوان عامل کشف سرویس نیز وجود دارد. در معماری سرویس گرا معرفی سرویسها و همچنين نحوه ارتباط این سه شرکت کننده نیز اهمیت دارد. این ارتباطات عبارتند از : منتشر کردن سرویس ، پیدا کردن سرویس و متصل شدن به سرویس.

شکل 1 (براي مشاهده نماي بزرگتر، روي تصوير کليک کنيد)

در یک سناریو بر پایه سرویس ، تهیه کننده ، سرویس را پیاده سازی کرده و از طریق شبکه به ارائه توضیحات آن سرویس برای درخواست کننده یا عامل کشف سرویس می پردازد. در خواست کننده معمولا درخواست پیدا کردن سرویس را به عامل کشف سرویس میدهد تا از طریق آن به توضیحات ارائه شده سرویس و محل آن دسترسی پیدا کند. سپس با بکارگیری این اطلاعات به تهیه کننده سرویس متصل شده و از سرویس ارائه شده استفاده می نماید.
بدین ترتیب ، سرویس بعنوان قطعه نرم افزاری پیاده سازی شده ای که توسط یک رابط تعریف شده مستند گرديده است و نه تنها بوسیله خود تهیه کننده بلکه توسط سایر عواملی که از نحوه پیاده سازی آن خبر ندارند ، نیز قابل استفاده و فراخوانی است. این ویژگی جعبه سیاه بودن سرویس از اصل ماژولاریتی در مهندسی نرم افزار به ارث رسیده است. البته سرویس با تعاریفي مانند ماژول ، قطعه نرم افزاری یا شی تفاوت دارد ، زیرا نه تنها در سطح برنامه ها و نرم افزارهاي کاربردی ، بلکه در سطح حرفه و حتی مابین سازمانها نیز قابل بكارگيري و استفاده مجدد مي باشد.
در واقع سرویسها، نمایش عملکرد معنی داری از حرفه هستند که می توانند بنا به نیاز مشتری در سرویسها و توابع بزرگتر یا جدید بکار گرفته شوند.
رابطها به سادگی مکانیزمی جهت برقراری ارتباط بین سرویس و نرم افزارها یا سایر سرویسها ایجاد می نمایند. از لحاظ تکنیکی، رابط سرویسها ، توضیحاتی در مورد نام و امضاء متدهای یک سرویس هستند که توسط درخواست کننده ، قابل فراخوانی می باشند.

معماری سرویس گرای توسعه یافته
معماری سرویس گرای مقدماتی به برخی از مسائل موجود در یک معماری مبتنی بر سرویس نمی پردازد. از جمله این مسائل، مدیریت، هماهنگ سازی سرویسها ، متناسب کردن آنها ، امنیت ، مدیریت تراکنشها و ... می باشد.این نکات که در شکل 2 نمایش داده شده است ، در معماری سرویس گرای توسعه یافته در نظر گرفته شده است.

شکل 2 (براي مشاهده نماي بزرگتر، روي تصوير کليک کنيد)

معماری مقدماتی در لايه پاييني این معماری لایه ای قرار گرفته است. لایه ترکیب سرویس در معماری توسعه یافته ، شامل توابع و نقشهای لازم برای یکپارچه کردن چند سرویس بعنوان سرویس ترکیبی می باشد. سرویس ترکیبی بدست آمده ، توسط Service Aggregator بعنوان یک سرویس مقدماتی استفاده می گردد و یا توسط درخواست کنندگان سرویس بکارگرفته می شود.
Service Aggregator تهیه کننده سرویسی است که سرویسهای ارائه شده توسط سایر تهیه کنندگان را یکپارچه می نماید تا از آنها سرویسهای جدید بسازد، همچنین مشخصات و کدهایی را تهیه می کند تا در مورد سرویسهای ترکیبی عملیات زیر را انجام دهد:

- متناسب کردن : کنترل اجرای سرویسهای ترکیب شده و مدیریت گردش داده ها در بین آنها و انتقال آن به خروجی.

- کنترل کردن : مجوز دادن به رخدادها و اطلاعات تولید شده توسط سرویسهای ترکیبی جهت به اشتراک گذاشتن و منتشر کردن رخدادهای ترکیبی سطح بالاتر ( برای مثال از طریق فیلتر کردن و خلاصه سازی)

- مطابقت دادن : حصول اطمینان از حفظ جامعیت سرویسهای ترکیبی از طريق تطبیق دادن محدودیتها و نوع پارامترهای سرویسهای بکار رفته.

- ترکیب خواص سرویسها : بکارگیری ، مجتمع سازی و دسته بندی ویژگی هاي سرویسهای ترکیب شده جهت بدست آوردن خواص ترکیبی جدید که دربردارنده کارایی ، هزینه ، امنیت ، جامعیت ، قیاس پذیری ، در دسترس بودن و قابلیت اطمینان می باشد.

استانداردهای جدید ارائه شده با عنوان زبان اجرای پردازشهای حرفه برای سرویسهای وب ، تلاشی است که بر اساس XML ، تعریف سرویسهای وب جدید را که از ترکیب سرویسهای موجود بدست می آیند ، ارائه دهد.یک پردازش BPEL بصورت انتزاعي با ارجاع و اتصال به portTypeهای تعیین شده در WSDL اي ايجاد مي شود كه در سرویسهای وب موجود در یک پردازش ، تعريف شده است.
مدیریت نرم افزارهای کاربردی مهم و بحرانی تجارت الکترونیک ، مي بايست نظارت عمیق و جامعی در محیطهای توزیع شده داشته باشد. خارج از دسترس بودن یک عنصر کلیدی در سیستمهای توزیع شده، تاثیر منفی زیادی بر کل چرخه گذاشته و باعث بیرون رانده شدن ارائه کننده سرویس از بازار می شود.
برای رويارويي با چنین موقعیتهایی ، سازمانها نیاز به کنترل دائم سرویس و حصول اطمینان از سلامتی سیستم دارند. کارایی می بایست همیشه ، در هر شرایطی و با هر بار کاری ، در سطح قابل قبولی باشد.
برای مدیریت قسمتهای مهم و بحرانی و سرویسهای ویژه ، معماری توسعه یافته ، در لایه مدیریت سرویس بعنوان بالاترین سطح ، سرویسهای مدیریت شده را ارائه کرده است.
این لایه شامل دو قسمت مدیریت عملکرد و مدیریت بازار می باشد. کارکرد مدیریت عملکرد بدین صورت است که قسمتهای مهم سیستم را پشتیبانی می نماید. این لایه جزئیاتی از کارایی سیستم را جهت ارزیابی آن ارائه میدهد و بدین صورت سازمان را قادر می سازد تا بر اساس وضعیت نرم افزار و تکمیل شدن تراکنشهای حرفه ، تصمیم گیری نماید. اپراتور سرویس ، مسئول انجام امور مربوط به این واحد است.
مدیریت عملکرد ، قابلیت بسیار مهم و کلیدی است که می تواند صحت و کارایی کلی سیستم را کنترل نماید و بدین ترتیب از بروز مشکلات شدید و خطا در سرویسها جلوگیری کند.
این خطاها ممکن است بر اثر اجتماع و هماهنگ سازی سرویسها و بخاطر عدم رعایت توافقهای در سطح سرویس (SLA) اتفاق بیافتد.
مدیریت و کنترلهای مناسب باعث کاهش احتمال بروز چنین خطاهایی می شود؛ بدین ترتیب که صحت ، پایداری و همچنين مناسب بودن ارتباط بین توابع بکار رفته در سرویسهای ورودی و خروجی را بررسی و کنترل می نماید.
قسمت دیگر در لایه مدیریت ، مدیریت بازار می باشد. مسئولیت این واحد ارائه پروتکلها و قوانین استاندارد در سطح حرفه می باشد تا از این طریق امکان استفاده از سرویسهای تعبیه شده در بازارهای مختلف بوجود آيد.
در ضمن برخی از تسهیلات و سرویسهای پایه برای امور مالی ، تضمین کیفیت و ... در این لایه قرار می گیرد تا از این طریق بازارهای مختلف بتوانند در کمترین زمان به سرویسها دسترسی یابند.
این قسمت از لایه مدیریت ، توسط سازندگان بازار که کنسرسیومی از شرکتهای فعال در این عرصه هستند ، کنترل و نگهداری می گردد.
درنهايت ، با توجه به نكات مذكور مي توان معماري سرويس گرا را روشي در جهت بهبود طراحي و استفاده از سيستمهاي نرم افزاري دانست ، اگرچه مشكلات و چالشهاي پيش روي آن همچنان نيازمند بررسي تجارب گذشته و نيز ارائه راه حل مناسب پيرامون مسائل مطرح در این معماري مي باشند.

منابع:

1- Channabasavaiah. Kishore, et al., Migrating to a service-oriented architecture, Part 1, IBM official web site, 16 December 2003.

2- Bieber .guy , Carpenter.Jeff , Introduction to Service-Oriented Programming , Motorola ISD , 2003

3- Zimmermann.Olaf, et al., Elements of Service Oriented Analysis and Design, IBM official web site, 2 June 2004.

4- Papazoglou Mike, Service-Oriented Computing :Concepts, Characteristics and Directions, Tilburg University , Proceeding of the forth international conference on web information system engineering , IEEE , 2003

5- Hao Ding, Exploiting Extended Service-Oriented Architecture for Federated Digital Libraries, Information Management Group, Norwegian Univ. of Sci.& Tech, 2004

6- Andrew Yang , Critical Infrastructure for Service-Oriented Architecture, Westbridge Technology ,2004

7- Mark Colan , Service-Oriented Architecture Expands the Vision of Web Services , Part 1 , IBM official web site , 21 April 2004

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 28 بهمنماه 1383

01:30 PM

February 16, 2005

کارايى سرويس دهنده وب يکى از کارهاى جديد در طراحى سرويس دهنده ها است

اين مقاله توسط "سعيد شريفيان " و " مصطفى صفوى" از دانشکده مهندسى
برق دانشگاه امير کبير در دهمين کنفرانس انجمن سالانه کامپيوتر ايران ۲۷(
تا۲۹ بهمن ) ارايه شده است .

مدلسازى کارايى سرويس دهنده هاى وب يکى از زمينه هاى تحقيقاتى جديد
در طراحى اين سرويس دهنده ها مىباشد.
بدون داشتن مدل درستى از سرويس دهنده پشتيبانى واقعى، کارايى سرويس
دهنده پيش بينى کار مشکلى است .
به دست آوردن ظرفيت سرويس دهنده ها در تصميم گيرى براى توسعه آنها از
اهميت ويژه اى برخوردار است .
با گسترش اينترنت يک سايت ممکن است در روز با ميليون ها در خواست
روبه رو شود که اگر اين درخواست ها در زمان هاى کوتاهى با حجم زياد به
سرويس دهنده برسند باعث اشباع شدن سرويس دهنده و افزايش زمان پاسخ دهى و
حتى از کارافتادن آن مىشوند.
براى جلوگيرى از اين حالت مکانيزم هاى QOSدر سرويس دهنده هاى وب به
کار مىروند.
اين مکانيزم ها سبب مىشوند تا درخواست هاى بيش از توان سرويس دهنده
بلوکه شوند، اين کار به سرويس دهنده اجازه مىدهد تا در خواست هاى محدودى
را با زمان سرويس دهى قابل قبول ارايه کند.
براى بهينه سازى پارامترهاى اينگونه مکانيزم هاى QOS، وجود مدل دقيق
از کارايى سرويس دهنده وب ضرورى است .
اين مدل بايد بتواند کارايى سرويس دهنده را در شرايط بحرانى بار زياد
که سرويس دهنده نزديک به حالت اشباع است به خوبى عمل کند.
هر سرويس دهنده وب داراى نرم افزارى است که امکان دسترسى کاربران را
به فايلهاى موجود بر روى اين سرويس دهنده فراهم مىکند.
اين فايلها شامل فايلهاى استاتيک از نوع HTMLو يا فايلهاى ديناميک
از نوع اسکريپهاى طرف سرويس دهنده مىباشند.
سرويس دهنده آپاچى يک سرويس دهنده چند ريسمانى است که هر ريسمان
وظيفه پاسخ گويى به يک درخواست هاى ورودى وارد صف ارتباطات TCPپذيرفته
شده دارند.
اين درخواست ها تا آزاد شدن يک ريسمان که اصطلاحا به آن Workerمى
گويند براى پاسخ گويى به آنها بايد در اين صف به انتظار بمانند.
هر Workerتا اتمام کارش درخواست جديد را از صف نمىگيرد و تعداد
Workerهايى که مىتوانند همزمان وجود داشته باشند توسط پارامتر Clients
Maxآپاچى قابل تنظيم است .
هر Workerپس از پايان سرويس دهى به درخواست و سپرى شدن زمان alive
Keepو نيامدن درخواست جديد از طرف همان کاربر به کار خود خاتمه مىدهد
و با بستن ارتباط قبلى درخواست جديد را از صف انتظار مىگيرد.

لینک ثابت || نوشته شده توسط || نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 29 بهمنماه 1383

01:23 AM

February 17, 2005

امنيت اطلاعات در كار الكترونيكى

شرق: حميد دليلى - تهديدات موجود در پيش روى امنيت سيستم هاى اطلاعاتى را مى توان به سه دسته اصلى تقسيم كرد: افشاى اطلاعات محرمانه (تهديد «افشا»)، صدمه به انسجام اطلاعات (تهديد «دستكارى») و موجود نبودن اطلاعات (تهديد «تضييق خدمات»). به طور مرسوم، امنيت اطلاعات در وهله اول با تهديد «افشا» همراه بوده است.

در دنياى امروز، وابستگى ما به سيستم هاى اطلاعاتى طورى است كه دستكارى غيرمجاز يا فقدان گسترده اطلاعات، پيامدهاى ناگوارى را موجب خواهد شد. در كار الكترونيكى، لازم است كه همه انواع اطلاعات از طريق شبكه ، دسترس پذير باشند. بنابراين، امنيت اطلاعات شرط ضرورى كار الكترونيكى است.

در هنگام كاركردن در يك شبكه باز، جريان اطلاعات در شبكه در معرض افشا و دستكارى غيرمجاز است. بنابراين براى حفاظت از محرمانگى و انسجام آن اطلاعات، رمزگذارى قوى ضرورى است. كمك غيرمستقيم رمزگذارى به ما اين است كه از وجود شبكه هاى اطلاعاتى اطمينان حاصل كنيم. پس از مقابله موثر با تهديدات «دستكارى» و «افشا»، مى توان با ايجاد اضافات كافى در شبكه هاى اطلاعاتى، دردسترس بودن اطلاعات را تحقق بخشيد. فناورى اينترنت در اصل براى به وجود آوردن همين نوع از اضافات طراحى شد و هنوز هم براى اين منظور مناسب است.

• ايجاد زيرساختار شبكه
معمارى اينترنت، معمارى شبكه اى غالب در اوايل دهه ۲۰۰۰ است. اينترنت بر پروتكل اينترنت (آى پى) استوار است، كه مى توان آن را روى همه انواع شبكه هاى فيزيكى و تحت همه انواع برنامه هاى كاربردى به كار انداخت. استقلال پروتكل اينترنت هم از شبكه هاى فيزيكى و هم از برنامه هاى كاربردى، نقطه قوت اصلى آن است. اين پروتكل حتى با فناورى هاى شبكه اى كاملاً جديد، مثل «شبكه محلى بى سيم» (دبليولن) يا «سرويس راديويى بسته اى عمومى» (جى پى آراِس) و شبكه «سامانه عمومى ارتباطات همراه» (جى اس ام) نيز كار مى كند.

برنامه هاى جديد، مثل وب، «ووآى پى» و بسيارى برنامه هاى ديگر كه در آينده عرضه مى شوند را مى توان به راحتى با سرويس استاندارد پروتكل اينترنت اجرا كرد. معمارى اينترنت اساساً از سال ۱۹۷۴ ثابت مانده و همچنان قدرت خود را اثبات مى كند. بنابراين شعار قديمى «آى پى وراى همه، همه چيز برروى آى پى» امروز بيش از هر زمان ديگرى صدق مى كند.

عيب هاى اصلى «آى پى» ، فضاى ناكافى نشانى، عدم پشتيبانى از جابه جايى فيزيكى، فقدان كيفيت متمايز سرويس و فقدان امنيت آن است. «گروه فوق العاده مهندسى اينترنت» هر يك از اين موضوعات را مدنظر قرار داده و راه حل هاى استانداردى نيز براى هر يك از آنها پيشنهاد شده. در نگارش ششم و جديد «آى پى» عملاً تعداد نشانى هاى نامحدود و گسترش پذيرى آن بهتر از نگارش ۴ (كنونى) است. «آى پى سيار» (اِم آى پى) براى هر دو نگارش تعريف شده.

اين «آى پى» براى ميزبان سيار اين امكان را فراهم مى آورد كه از يك شبكه به شبكه ديگر جابه جا شود، ضمن اينكه نشانى هاى «آى پى» دائمى خود را كه در همه ارتباطات با اين ميزبان مورد استفاده قرار مى گيرد، حفظ مى كند. اين امر منجر به تحرك واقعى، نه صرفاً در چارچوب فناورى يك شبكه (مثل «جى اس ام»)، بلكه بين انواع مختلف شبكه ها، مثل «دبليولن» ، «جى پى آر اس» و شبكه هاى سيمى مى شود. كيفيت سرويس را مى توان در اينترنت به وسيله «سرويس هاى متمايز اينترنتى» كه يك طرح اولويت بندى ساده مستقل از كشورها است و كاملاً مناسب شبكه هاى جهانى است، تكميل كرد.

امنيت عمومى سطح «آى پى» توسط «آى پى سك» (پروتكل امنيت اينترنت) كه بر رمزنگارى و «پروتكل مديريت كليد» همراه با آن يعنى «مبادله كليد اينترنتى» (آى كائى) استوار است، فراهم مى شود.اگرچه همه اين كاركردها را نمى توان در لايه «آى پى» به انجام رساند، اما هركار كه ممكن است بايد در همانجا به انجام برسد؛ و اين، ويژگى خوب معمارى اينترنت است كه كل كاركردهاى لايه «آى پى»، چه از شبكه هاى فيزيكى و چه از برنامه ها، مستقل است. مثلاً «آى پى سِك» با (و در) همه شبكه ها و تحت انواع برنامه ها كار مى كند. اينترنت مى تواند از «قانون مور» نهايت استفاده را ببرد. اين قانون در اصل خود حكايت از آن دارد كه عملكرد ريزپردازنده ها هر ۱۸ ماه دو برابر مى شود، در حالى كه قيمت آنها ثابت مى ماند. عجيب اينكه، اين قانون بيش از ربع قرن است كه دوام آورده.

تقريباً همين رفتار را مى توان در بسيارى از حوزه هاى ديگر نيز مشاهده كرد، از جمله در مورد حافظه موقت، ديسك سخت، شبكه محلى، شبكه محلى بى سيم، سوئيچ شبكه محلى و مسيرياب «آى پى». اما حتى در حوزه مخابرات سيار [موبايل] كه نسبتاً سريع پيشرفت مى كند، طول عمر يك نسل از توليد، ۱۰ سال است، نه دو سال. تلفن راديويى اتومبيل در سال ،۱۹۷۱ تلفن همراه اروپاى شمالى در سال ۱۹۸۱ و سامانه عمومى ارتباطات همراه در ۱۹۹۱ مورد استفاده عموم قرار گرفتند و «يوام تى اس» احتمالاً در سال ۲۰۰۲ وارد ميدان مى شود.
اين بدان معنا است كه صرفه مندى فناورى اينترنت براساس بسته، همواره بسيار سريع تر از فناورى مخابراتى مبتنى بر «تركيب تقسيم زمانى» متعارف پيشرفت مى كند.

بنابراين در زمان كوتاهى، همه برنامه ها روى «آى پى» قرار مى گيرند. در سيستم تلفن معمولى، روشن است كه «ووآى پى» بسيار با صرفه تر از مخابرات معمول، چه در محدوده هاى محلى و چه در مناطق گسترده است. با پيشرفت هايى كه در ارتباطات بى سيم و «آى پى» به وقوع پيوسته، فقط دو سال طول مى كشد كه ارتباطات سيار هم به همين وضعيت برسد. اگر قرار باشد كه «يواِم تى اِس» يك لاكر بوم شناختى داشته باشد، همان شبكه فيزيكى، همراه با شبكه محلى بى سيم (دبليولن)، سرويس راديويى بسته عمومى (جى پى آر اس) و...

تحت «آى پى» خواهد بود. بنابراين منطقاً مى توانيم بپذيريم كه كار الكترونيكى بر معمارى اينترنت استوار خواهد بود و جنبه هاى امنيت شبكه اى آن نيز همانند امنيت اينترنت خواهد بود.
دانش فراگير به معناى استفاده از فناورى اطلاعات در يكى از اشكال گوناگون آن، در همه عرصه هاى زندگى و با همه ابزار قابل تصور است. وسايل خانگى متداول شامل ريزپردازنده هايى هستند كه نرم افزارهايى را به كار مى اندازند كه بخش عمده كاركرد اين وسايل را به انجام مى رسانند. در آينده نزديك، اكثر اين ابزارها، اغلب با دسترسى بى سيم، شبكه بندى خواهند شد. همچنين به منظور حصول امنيت، لازم است كه سيستم هاى رمزنويسى كليد عمومى و كليدهاى رمزنويسى مخفى داشته باشند تا پيكربندى و مديريت امن آنها امكانپذير شود. اين بدان معنا است كه ما در همه جا، رايانه هاى با شبكه بندى كوچك و رمزنويسى تعبيه شده در درون آنها خواهيم داشت. اين رايانه ها به قدرى رايج خواهند شد كه آنها را رايانه يا فناورى اطلاعات به شمار نخواهيم آورد؛ همان طور كه امروزه به الكتريسيته كه همه جا از آن استفاده مى كنيم، چندان توجه نمى كنيم.

به زودى تقاضاى بسيار براى ابزارهاى ارزان قيمت و كوچك را كه محيط رابط «آى پى»، «آى پى سك» و «دبليولن» را بر روى فقط يك تراشه سيليكن به كار مى اندازند شاهد خواهيم بود. بقيه سطح اين تراشه به يك ريزكنترل گر همه منظوره، درگاه هاى ورودى و خروجى و حافظه اختصاص مى يابد تا دستگاه هاى مختلف را كنترل كند. اين تراشه ها اكنون توليد شده اند و به زودى اكثر ميزبان هاى متصل به اينترنت را تشكيل مى دهند.

• تأثير افزايش جابه جايى پذيرى
سياربودن در مفهوم وسيع تر كلمه به معناى توانايى كاربر در دسترسى به اطلاعات، مستقل از محل و مكان او است. در عمل، لازمه اين امر معمولاً نوعى از پشتيبانى جابه جايى پذيرى از سوى دستگاه پايانه و شبكه اصلى است. البته جابه جايى پذيرى تهديدهاى جديد امنيتى را به دنبال نمى آورد، اما تهديدهاى موجود را جدى تر مى سازد؛ زيرا دسترسى به اطلاعات، مستقل از مكان صورت مى گيرد. همچنين امنيت سيستم، از هر جايى و توسط هر فرد مجاز مى تواند مورد حمله قرار گيرد.

بايد توجه كرد كه جابه جايى پذيرى و بى سيم بودن دو چيز متفاوتند، اگر چه اغلب با هم همراهند. جابه جايى پذيرى به معناى توانايى كاربر يا پايانه، در حركت از يك شبكه (يا نقطه اتصال) به شبكه ديگر است؛ بى سيم بودن يعنى جايگزين ساختن كابل شبكه يا آخرين پيوند شبكه با پيوندهاى ارتباطى بى سيم (مثل راديويى يا مادون قرمز). بى سيم بودن به تنهايى، جابه جايى پذيرى چندانى را امكانپذير نمى كند. مثلاً در يك شبكه «سامانه عمومى همراه» (جى اس ام)، عمده پيچيدگى شبكه و نرم افزار پايانه بايد به امر انتقالات، يعنى گذر پايانه سيار از يك ايستگاه اصلى به ايستگاه ديگر تخصيص يابد. ضمن اين كه بى سيم بودن و جابه جايى پذيرى، هر يك به طور جداگانه ممكن است مفيد باشند، وقتى كه با هم تركيب مى شوند بهترين عملكرد را دارند. به همين دليل دسترسى بى سيم به شبكه هاى سيار اهميت روزافزونى پيدا مى كند.

• راه حل هاى ممكن
امنيت اطلاعات موضوعى چند بعدى است كه با جنبه هاى غيرفنى متعددى ارتباط دارد. همواره براى تحقق امنيت، ابزارهاى فيزيكى، پرسنلى و اجرايى لازمند و ابزارهاى فنى به تنهايى بى فايده اند. اما وقتى كه در يك شبكه نامطمئن كار مى كنيد، امنيت بدون استفاده از رمزنگارى ميسر نمى شود. بنابراين بخشى از راه حل، «آى پى سك» است كه مى توان به عنوان يك سازوكار استاندارد براى حفاظت در برابر استراق سمع و دستكارى پيام در شبكه به كار برد.

رمز نگارى كليد عمومى، مثلاً براى تاييد اصالت و براى مديريت كليدها، لازم است. به علاوه يك «زيرساختار كليدهاى عمومى» لازم است تا كليدها را به شيوه اى اطمينان بخش، به مالكان آنها پيوند دهد. «زيرساختار كليدهاى عمومى» نمونه اى از خدمات «شخص ثالث امين» است كه هميشه بر اعتماد و اطمينان استوارند. تحقق فيزيكى «زيرساختار كليدهاى عمومى» در قالب گواهينامه انجام مى گيرد. اعتماد به دست آوردنى است نه ديكته كردني. طرف هاى مختلف بايد بتوانند تصميم بگيرند به چه كسى، در چه موضوعاتى و تا چه اندازه اعتماد كنند. همچنين در هر سيستم به يك «مبناى رايانشى قابل اعتماد» نياز داريم. اين «مبناى رايانشى قابل اعتماد» بايد [تا حد امكان] كوچك شده و مبتنى بر طرح هاى آزاد باشد. بايد بتوانيم حسابرسى كنيم تا به آن اعتماد كنيم.

چشم پوشى از امنيت بخش هايى از سيستم در خارج از «مبناى رايانشى قابل اعتماد» نبايد امنيت كل سيستم را به خطر اندازد. به طور سنتى، كنترل دسترسى و صدور مجوز براى آن براساس تاييد اصالت هويت كاربر (هويتى كه در شكل يك نام نمود مى يابد) صورت مى گيرد. اين كار در سيستم هاى بزرگ عملى نيست، زيرا تشخيص حقوق دسترسى يك فرد صرفاً براساس نام او، امكان ناپذير است. عموماً ما بيشتر علاقه منديم كه اطمينان حاصل كنيم كاربر به انجام كارى كه انجام مى دهد مجاز است يا خير و نه اين كه بدانيم او كيست. بنابراين به جاى تعيين هويت او، بايد قادر به تاييد اصالت حقوق او باشيم. صدور مجوز ها ابزار عمومى خوبى هستند كه مى توان براى چنين اهدافى، حتى در سطوح سيستم هاى جهانى به كار گرفت. امنيت و قابليت استفاده، از اقتضائات متضاد با هم هستند. وقتى كه سيستم ها را امن تر مى كنيم، طبعاً از قابليت استفاده آنها مى كاهيم. كار الكترونيكى چيزى است كه بايد در شرايط مربوط به كاربر عادى هم عمل كند، يعنى براى هر كسى قابل استفاده باشد. تركيب قابليت استفاده با امنيت، چالش اصلى عصر ما است.

كار با اينترنت به پيشرفت خود ادامه مى دهد و به عرصه هاى جديد برنامه هاى كاربردى گسترش مى يابد. كاهش سرانه قيمت محصولات، عملاً همه برنامه ها را به استفاده از فناورى اصلى «آى پى» سوق خواهد داد. اگر جابه جايى پذيرى، كيفيت خدمات و امنيت، محور اصلى خدمات اينترنت در نسل آينده باشند، در آن صورت يك سكوى عمومى جهانى خواهيم داشت تا كار الكترونيكى را بر روى آن استوار كنيم.

«آى پى سك» و «زيرساختار كليد عمومى» مانع موثرى در مقابل افشاى غيرمجاز و دستكارى ناشى از ترافيك شبكه ايجاد مى كنند. وجود اضافات كافى در شبكه، مانع تضييق خدمات است. با راه حل هاى استاندارد و ارزان قيمتى كه مرتباً ارزان تر هم مى شوند، مى توان به همه اينها دست يافت.

بنابراين سكوى فنى براى كار الكترونيكى امن، در حال شكل گرفتن است و جنبه هاى شبكه اى امنيت را مى توان حل كرد. اما وقتى كه با افراد و با جريان هاى پيچيده اطلاعات سروكار داريم، هيچ راه حل استاندارد ساده اى براى امنيت كل سيستم وجود ندارد. براى تعريف فرآيندهاى اصلى پيشگانى و جريان هاى اطلاعاتى و مقتضيات امنيتى ملازم با آنها كار زيادى لازم است. بايد در طراحى اين فرآيندها، امنيت نيز وارد شود. بايد ساز و كارهاى استاندارد امنيت به كار گرفته شوند تا اطمينان حاصل شود كه سيستم هاى اطلاعاتى مورد استفاده، امنيت جريان هاى اطلاعاتى را به خطر نمى اندازند.

هيچ روش شناخته شده اى براى اثبات امنيت كل فرآيندها وجود ندارد. بايد مداوماً به نظارت و به بازخورد دادن به فرآيندهايمان بپردازيم. همچنين بازرسى به وسيله يك طرف بيرونى (كه مسئوليتى در استقرار يا اجراى سيستم ندارد) لازم است.

خوشبختانه ما به مرحله اى رسيده ايم كه قدرت پردازش فزاينده و ديگر پيشرفت هاى فنى آتى، به نفع افراد است. استفاده پذيرى هر سيستم اطلاعاتى يك چالش عمده است. تركيب استفاده پذيرى با امنيت، بسيار دشوارتر است. هدف اصلى در طراحى سيستم ها نبايد بهينه سازى استفاده از منابع رايانشى هر چه ارزان تر باشد، بلكه بايد كار افراد را هر چه اثربخش تر و خوشايندتر سازد. اين يك عرصه تحقيقاتى بين- رشته اى است كه انتظار مى رود در آينده اهميت بيشترى پيدا كند.

ضعيف ترين نقطه در موضوع امنيت، همچنان افراد و نگرش هاى آنها خواهد بود. مدت هاست كه علت اصلى در عمده نقض امنيت ها، رفتار غيرمجاز افراد غيرمجاز در كارهاى روزانه شان است. درحالى كه ابزارهاى فنى و سكوهاى فنى امن و قابل اندازه گيرى براى موفقيت در كار الكترونيكى ضرورت دارند، اما كمبودهاى موجود در جنبه هاى غيرفنى امنيت را جبران نمى كنند. امنيت را بايد تعريف، طراحى و در فرآيندهاى كارى تعبيه كرد. افراد بايد به خوبى راهنمايى شوند، آموزش ببينند و انگيزه مند شوند. همچنين بايد به نظارت و بازخورد و نيز به بازرسى مستقل توجه كرد. اين امر مستلزم آن است كه كل سازمان ها كار را از رده بالاى مديريت خود شروع كنند. امكانات حاصل از كار الكترونيكى چنان است كه بايد در درازمدت، اطمينان حاصل شود كه از زمان و كار به بهترين صورت استفاده مى شود.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

نام:

پست الکترونيک:

وبسايت:

نظر شما:

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 29 بهمنماه 1383

02:55 PM

February 17, 2005

43 درصد از اولین بازديدهای اینترنتی ، از طریق موتورهای جست و جو گر صورت می گیرد

نوشته : علی محمد آقازمانی

سخن اول
امروزه شبكه جهاني اطلاع رساني ( اينترنت ) ، تغييرات گسترده اي را در شيوه هاي اطلاع رساني و ارتباطاتي در ميان شخصيت هاي حقيقي ( افراد ) و حقوقي (شركتها و سازمان ها ) ايجاد كرده است كه اين دگرديسي ، بستري ممتاز براي خلق دهكده جهاني هزاره سوم در قرن بيست و يكم مي باشد . اين جهان الكترونيكي را كه امروزه در قالب اينترنت يا پهنه جهاني وب ملاحظه مي كنيد ، بيش از سه دهه از تولدش نمي گذرد. گويي ديروز بود كه شركت ياهو ، با آن دو مهندس جوان فارغ التحصيل دانشگاه استانفورد آمريكا (www.stanford.edu)، سايتي با چند web page ساده ايجاد كرد و آرام آرام ، حركت رو به رشد عظيم خود را دنبال نمود. پايگاهي كه در سال 1994 ميلادي ، كمتر از يكصد وب پيج بود و شايد روزانه هزار نفر بيشتر از داخل امريكا اين پايگاه را مشاهده نمي كردند ، امروزه به چنان عظمتي دست يافته است كه هر روز ، ميزبان ميليون ها كاربر اينترنتي از اقصي نقاط جهان است . سايتي با صدها هزار صفحه وب در زمينه هاي مختلف با هشت فرمت زباني متنوع و بازارچه هاي الكترونيكي خريد گسترده و زيبا ! امروزه كمتر كسي را مي توان سراغ داشت كه اينترنت را با ياهو متناظر نداند. همانطور كه كامپيوتر را با ويندوز مايكروسافت ، مي شناسند!
سخن دوم
بد نيست قبل از شروع بحث خود ، آمارهايي را از جهان اينترنت ارائه كنيم . به هر حال هميشه دانستن اطلاعات آماري ، ذهنيت سازي خوبي براي مخاطب و بستر سازي مطلوبي براي درك فضايي است كه از آن سخن به ميان مي ايد. اينترنت محصول پروژه آرپاي وزارت دفاع آمريكا در اواخر دهه هفتاد ميلادي متولد شد و اندك اندك روحيه ميليتاريستي موجود در آن ، رنگ و بوي ديگري به خود گرفت . اينترنت قوي ترين رسانه الكترونيكي حال حاضر جهان است كه هم به لحاظ كاربر و هم به لحاظ وسعت اطلاعات و قابليتهاي ارتباطاتي و اطلاع رساني حاكم بر ان ، سازمان رسانه اي ديجيتال بلامنازعي را تشكيل داده است. ادعا نمي كنيم كه فرمت الكترونيكي جهان از ادم ها گرفته تا اشيا ، در اينترنت قرار گرفته است . اما ، دستيابي اطلاعاتي به هر چيز در جهان اطراف ما ، بالاخره با يك رديابي و جستجو در پهنه وب امكان پذير است . بر اساس آمارهاي رسمي كه توسط سازمان ها و گروه هاي بين المللي حاكم بر فضاي اينترنت منتشر مي شود ، قريب به 700 ميليون كاربر تا اواخر سال 2003 به اينترنت راه پيدا كرده اند و بيش از 33 ميليون دامنه در اينترنت ايجاد شده است كه بيشترين پسوند ، متعلق به پسوند دات كام بوده است . سال گذشته حدود 6 ميليارد دلار از بازارچه هاي الكترونيكي مستقر در سايت هاي اينترنتي ، خريد الكترونيكي صورت گرفته است كه چند درصد از تجارت جهاني را به خود اختصاص مي دهد. بر اساس امارهايي كه سايت جستجوي مشهور گوگل اعلام كرده است ، بيش از 3 ميليارد صفحه وب در اينترنت ايجاد شده است كه اين موتور جستجو قابليت مشاهده و جستجوي اطلاعاتي در 70 درصد اين 3 ميليارد را دارا مي باشد. از سويي ديگر ، در چند سال اخير ، كاربران علاقه زيادي به انتشار الكترونيكي ياداشت هاي روزانه خود در اينترنت ، و تحت قالب وبلاگ نشان داده اند كه اين موضوع ، باعث ايجاد صدها هزار وبلاگ شخصي در اينترنت شده است . در حقيقت امروزه مي توان يادداشت ها و نوشته هاي شخصي و روزانهء ميليونها عضو اين كره خاكي ( ساكنان دهكده جهاني ) را در پهنه جهاني وب خواند و براي انها پيغام نيز گذاشت . جالب است بدانيد كاربران اينترنت باز ايراني ، رتبه اول در تعداد وبلاگ هاي شخصي را در اينترنت بر عهده دارند و زبان فارسي رتبه تاپ در ميان فرمت هاي زباني اينترنت دارد. بر اساس اطلاعاتي كه نگارنده جمع آوري كرده است ، در 4 سال اخير ، بيش از 15 هزار سايت اينترنتي خصوصي يا رسمي توسط ايرانيان در اينترنت ايجاد و مديريت شده است كه حدود 20 درصد ان متعلق به شركت ها وسازمان هاي خصوصي و دولتي بوده است . ضريب نقوذ اينترنت در ميان اقشار مختلف ايران اگر چه كم است ، اما سال گذشته وزير ارتباطات و فناوري اطلاعات اعلام كرد تا 5 سال آينده ، ميليونها كاربر اينترنت فارسي زبان خواهيم داشت . ايجاد خطوط پر سرعت اينترنت ماهواره اي ( كه البته ماهانه 60 هزار تومان بر اورد مي شود ) خود تدارك يك انقلاب ارتباطاتي در جمهوري اسلامي ايران خواهد بود كه قطعا ايدئولوژي ها و دكترين هاي مختلف سياسي ، فرهنگي ، اقتصادي و اجتماعي و علمي كشور را دست خوش تغييرات پربركتي خواهد كرد .
با اين اوصاف ، حضور در اينترنت ، بسيار مهم است . خواه بخواهيم خاطرات روزانه خود را منتشر كنيم و با ديگران چت كنيم ، يا پروژه ها و رزومه كاري شركت خود را به صورت مالتي مديا در اينترنت معرفي كنيم. به هر حال ، حضور ، اجتناب ناپذير است .
سخن سوم
گفتيم كه حدود 20 هزار سايت اينترنتي متعلق به شركت هاي ايراني در وب ايجاد شده است . اما اگر فرصتي داشته باشيم و به 1 درصد اين پايگاه ها به صورت تصادفي نگاهي بكنيم ، درخواهيم يافت كه مثل برخي از كارهاي ما ايرانيان ، هول هولكي و سرهم بندي فوري بوده است و حتي ابتدايي ترين شاخص هاي طراحي و راه اندازي سايت هاي اينترنتی را هم رعايت نكرده ايم. خوب علت زياد است و شايد يكي از مهمترين علل ان باشد كه بسياري از شركتها و كارخانجات ايراني ، عقيده دارند كه نمي خواهند رقمي معادل 400 الي 500 هزار تومان ، كه شايد معادل حقوق 2 يا 3 كارگر در ماه باشد را صرف سايتي در اينترنت كنند . آنهم وقتي كه مشتري ثابت دارند و نيازي به صادرات و بازاريابي نيست . اين ايدئولوژي متاسفانه يا خوشبختانه ، دكترين اكثريت مديران شركتهاي ايراني است كه يا سايت دارند و يا ندارند. البته با اين اوضاع هم حق دارند. . . .
به هر حال صحبت هاي بخش " سخن دوم " را نبايد فراموش كرد. بسياري از شركت ها و كارخانجات ، هزينه هاي ميليوني صرف تبليغات در رسانه هاي جمعي و سنتي مكتوب ميكنند و سالانه كاتالوگ ها و تقويم هاي خيلي خوشگلي را طراحي و چاپ مي كنند. اما به محض تغيير در توليد ، تغيير فرايند كاري ، تغيير آدرس و خيلي مسائل پيش پا افتاده يا مهم ديگر ، بسياري از اين هزينه ها ، اثر دراز مدتي را دنبال نمي كند. همه از اين مسئله غافل هستيم كه بالاخره براي ماركتينگ ، به دنبال رسانه اي برويم كه هميشه انلاين و بر خط است . همه به ان در هر زمان و مكاني دسترسي دارند. به هر زباني قابل دريافت است و با هر فرمت قابل ديدن.
حتي تاثير گذاري سايت هاي اينترنتي را ، كاتالوگ هاي چاپي و حتي كارت هاي ويزيت الكترونيكي ندارند. چرا كه همه انها ، بالاخره در ميز كشوي من و شما قرار دارند و فقط ما آن را مي بينيم. از همه مهمتر كه اگر ان ها را جا بگذاريم يا گم كنيم ، دسترسي به انها خيلي مشكل است . اما پايگاه وب ، اين معضلات را ندارد.
سخن چهارم!
شركت ها و موسسات صنعتي و بازرگاني بسياري در كشورمان ، از نعمت سايت اينترنتي ( اگر آن را نعمت بخوانيم ) برخوردارند. اما تقريبا نه خودشان ان را به خاطر مي آورند و به روز رساني ميكنند ونه ديگران از آن با خبرهستند.
مگر اينكه زير سربرگ نامه انها ، به شركت و خريدار محلي اعطا شود و وي از روي كنجكاوي به سراغ پايگاه بيايد. پايگاه هايي كه اين وضعيت را دارند ، به قول يك مثل چيني كه ميگويد : " سايت نداشتن بهتر از سايت بد داشتن است ! " ، بايد تغيير رويه دهند. در حقيقت بايد رفتار سازماني ديجيتال خود را تغيير دهند. امروزه مشتري شناسي و ارضاي نيازهاي اطلاعاتي و ارتباطاتي وي ، مهمترين وظيفه حوزه هاي روابط عمومي شركت ها و موسسات صنعتي و بازرگاني كشورهاست . ان ها هستند كه بايد نيازها را درك كنند و براين اساس ، به دنبال رفع ان بر ايند. يكي الترناتيو موثر ، وب سايت است .
ما در ادامه ، پس از ان كه همه شركت ها و موسسات صنعتي ، به خصوص تهويه مطبوعي هاي خودمان را به حضور گسترده در رسانه اينترنت و راه اندازي سايت اينترنتي آبرودار دعوت مي كنيم ، به ارائه راهكارهايي براي معرفي وحضور بهتر سايت هاي اينترنت در پهنه جهاني وب اشاره خواهيم كرد.
سخن پنجم : داستان رتبه بندی
باید بدانیم که موتورهای جست و جو یکی از مهم ترین ابزارهای مارکتینگ برای سایت های اینترنتی هستند. هر روز درصد بالايی از حجم کاربران اینترنت در اقصی نقاط جهان برای یافتن اطلاعات خود که می تواند در انواع و فرمت های مختلف باشد به موتورهای جست و جو رجوع می کنند. در واقع این موتورهای جست و جو یک نوع بازار مکاره هستند. مکاره بودن برخی از ان ها وقتی بیش تر ثابت می شود که بفهمیم این موتورها نتایج از قبل تعیین شده ای را برای ما تهیه دیده اند ! خزنده ها(Crawler) که با نام های خزنده جو از برنامه هايی به نام عنکبوت(spider)در وب می خزند و لینک ها را می یابند و صفحات وب را بیدا می کنند و در موتورهای جست و جو ایندکس می کنند. اما دایرکتوری های اینترنتی فقط یک صفحه از سایت را در خود نگه می دارند.
•Spider (عنکبوت)
اسپايدر يا روبوت (Robot)، نرم افزاري است كه كار جمع آوري اطلاعات مورد نياز يك موتور جستجوگر را بر عهده دارد. اسپايدر به صفحات مختلف سر مي زند، محتواي آنها را مي خواند و اطلاعات مورد نياز موتور جستجوگر را جمع آوري مي كند و آنرا در اختيار ساير بخش هاي موتور جستجوگر قرار مي دهد.
كار يك اسپايدر، بسيار شبيه كار كاربران وب است. همانطور كه كاربران، صفحات مختلف را بازديد مي كنند، اسپايدر هم اين كار را انجام مي دهد با اين تفاوت كه اسپايدر كدهاي HTML صفحات را مي بيند، اما كاربران نتيجه حاصل از كنار هم قرار گرفتن اين كدها را مشاهده می کنند.
اسپايدر، به هنگام مشاهده صفحات، از خود بر روي سرورها(server) رد پا برجای مي گذارد. شما اگر اجازه دسترسي به آمار ديد و بازديدهاي صورت گرفته از يک سايت و اتفاقات انجام شده در آنرا داشته باشيد، مي توانيد مشخص كنيد كه اسپايدر كدام موتورهاي جستجوگر صفحات سايت را مورد بازديد قرار داده اند.
اسپايدرها كاربردهاي ديگري نيز دارند، به عنوان مثال عده اي از آنها به سايت هاي مختلف مراجعه مي كنند و فقط به بررسي فعال بودن لينك هاي آنها مي پردازند و يا به دنبال آدرس پست الكترونيكي (Email) افراد مي گردند.
•Crawler (خزنده)
كراولر، نرم افزاري است كه به عنوان يك " فرمانده" براي اسپايدر عمل مي كند. کراولر مشخص مي كند که اسپايدر كدام صفحات را مورد بازديد قرار دهد. در واقع کراولر تصميم مي گيرد كه كدام يك از لينك های صفحه ای كه اسپايدر در حال حاضر در آن قرار دارد، دنبال شود. ممكن است همه آنها را دنبال كند، بعضي ها را دنبال كند و يا هيچ كدام را دنبال نكند.
فیلتر وردها کلماتی مثل : "که " ، " و" ، " صفحه اصلی" هستند که معمولا خیلی زیاد در صفحات وب به کار می آیند.
استاپ وردها نیز کلماتی هستند که بر اساس دکترین هر موتور جست و جویی متفاوت است و در صورتی که این گونه کلمات در سایت شما باشد ممکن است صفحات سایت شما از بانک اطلاعات موتور جست و جو حذف شود و رتبه سایت شما بسیار کاهش یابد. کلمات غیر اخلاقی - نژاد پرستانه و امثالهم از این دسته موارد هستند که البته آلتاویستا و گوگل نسبت به این کلمات کاملا مشتری مدار هستند !
5 نکته را فراموش نکنید :
1- موتور های جست و جو صفحاتی که کلمات کلیدی ان ها در بالای صفحه هستند را بیش تر از صفحات دیگر دوست دارند.
2- موتورهای جست و جو صفحاتی که فلان کلمه کلیدی بیش از سایر کلمات در ان تکرار شده است را ارجح می دانند.
3- به این نکته باید توجه داشت که همیشه اختصارات را کنار توصیف کامل ان اختصار درج کنید .
4- اگر در صفحات سایت شما به هر زبانی غلط املایی وجود داشته باشد موتورهای جست و جو سایت شما را ردیابی نمیکنند.
5- موتور های جست و جو به تعداد لینکی که به سایت شما از سایت های دیگر داده می شود خیلی اهمیت می دهند.
اما برای داشتن یک سایت موفق در اینترنت و معرفی موفق تر به موتورهای جست و جو چه باید کرد، سوالی است که طی 3 جلسه از روز دوشنبه در صفحه 9 به آن خواهيم پرداخت .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 30 بهمنماه 1383

12:45 PM

February 18, 2005

مدلسازى (Modeling)

نوشته : ساسان نیکوکار

امروزه يك سازمان نرم‏افزارى موفق سازمانى است كه بتواند بسادگى نرم‏افزارهايى را توليد كند كه نيازهاى كاربران در آن ديده شده باشد. چنين سازمانى كه بتواند چنين نرم‏افزارى را با روشها و ابزار مؤثر و در زمان مناسب پياده‏سازى كند، مى‏تواند در امر تجارت موفق باشد. محصول اوليه يك تيم توليد نرم‏افزار، بهينه نمى‏باشد و شعار نمى‏دهد بلكه مهم است كه نرم‏افزارى را پياده‏سازى كرده باشد كه نيازهاى كاربران و تجارت را برآورده سازد. بقيه موارد حالت ثانويه به حساب مى‏آيند. نكته مهمى در اين شعار وجود دارد. متأسفانه بسيارى از سازمانهاى نرم‏افزارى درگير حالت ثانويه مى‏باشند. براى پياده‏سازى نرم‏افزارى كه اهداف موردنظر را برآورده سازد، شما بايد كاربران را ملاقات كنيد تا نيازهاى واقعى سيستم شما بدست آيد. مى‏توان گفت براى اينكه شما در نهايت بتوانيد نرم‏افزارى با كيفيت بالا به وجود آوريد، بايد داراى افراد و ابزارى مناسب به همراه هدف مشخص و واضحى باشيد.

مدل كردن، قسمت مركزى تمامى فعاليتهايى است كه پياده‏سازان نرم‏افزارى را به سمت توليد يك محصول مناسب راهنمايى مى‏كند. ما سيستم‏ها را مدل مى‏كنيم براى اينكه رفتارها و ساختارهايى را كه در سيستم خود مى‏خواهيم بصورت كتبى داشته باشيم، ما مدل مى‏كنيم تا بتوانيم معمارى سيستم خود را كنترل كنيم و بتوانيم سيستمى را كه در حال ساختن آن مى‏باشيم بهتر درك كنيم، امكان Reuse را در سيستم داشته باشيم و همچنين ريسكهاى پروژه را مديريت كنيم.

بسيارى از سازمانهاى نرم‏افزارى شروع به انجام كارهاى بزرگ مى‏كنند، ولى مشكل اصلى اين است كه آنها همانند ساختن لانه براى پرنده‏ها عمل مى‏كنند (براى ساختن لانه پرنده مى‏توان با تعدادى تخته و ميخ و بدون نياز به نقشه اقدام به ساخت لانه كرد).

اگر شما واقعاً مى‏خواهيد كه نرم‏افزارى را بدون هدف و در كمترين زمان ممكن توليد كنيد مشكلات اين كار فقط نوشتن خود برنامه مى‏باشد، ولى در واقع هدف اصلى ايجاد يك نرم‏افزار صحيح مى‏باشد و پياده‏سازى يك نرم‏افزار كارا وابسته است بر ابزار، فعاليتها و معمارى كه آن نرم‏افزارى استفاده مى‏كند. بسيارى مواقع پروژه‏ها بصورت كوچك شروع مى‏شوند ولى پس از مدتى به پروژه‏هاى بزرگ تبديل مى‏شوند، بخاطر آنكه آنها موفقيت كارى خودشان را در اين راه قربانى مى‏كنند. در پروژه‏هاى كوچك (ساختن لانه پرنده) صدمات وارده كم است ولى در پروژه‏هاى بزرگ (ساختن خانه مسكونى) نتيجه‏اش بسيار زيانبار خواهد بود.

عناصر زيادى در موفقيت يك پروژه نقش دارد كه يكى از آنها كه در همه رعايت مى‏شود، مدلسازى است. ما مدل مى‏كنيم تا كاربران تصويرى ازمحصول نهايى را مشاهده كنند، ما حتى مدل مى‏كنيم تا ريسكهايى هايى را كه بر سرراه پروژه قرار دارد پيدا كنيم. پس مى‏توان گفت كه مدلسازى در اصل يك كار تكنيكى است.

مدلسازى چيست؟

يك مدل ساده شده هستى است كه وجود دارد. در اصل مدل يك نقشه از سيستم را فراهم مى‏كند. مدلها ممكن است دربرگيرنده جزئيات يك برنامه باشند. پس به طور كلى مى‏توان گفت كه يك مدل خوب، مدلى است كه تمام عناصر درگير در پروژه و روابط بين آنها و نحوه اثرگذارى آنها را مشخص كند. هر سيستمى ممكن است توسط چندين مدل شرح داده شود و در هر مدلى يك نقشه شماتيكى وجود دارد كه بر تشريح سيستم مى‏پردازد. پس با اين همه چرا ما مدل مى‏كنيم؟

ما مدل مى‏كنيم تا كه سيستمى را كه مى‏خواهيم پياده‏سازى كنيم بهتر درك كنيم‏

از مدلسازى به چهار نتيجه مى‏رسيم:

  • مدلها به ما كمك مى‏كنند كه سيستمى را كه مى‏خواهيم به آن برسيم بهتر تصور كنيم.
  • مدلها به ما اجازه مى‏دهند تا ساختار و رفتار سيستم را مشخص كنيم.
  • مدلها ما را در جهت ساخت صحيح سيستم راهنمايى مى‏كنند (براى ما الگوهايى (Pattern) را ايجاد مى‏كنند كه مى‏توانيم در پروژه‏هاى بعدى خود از آنها استفاده كنيم. اين كار باعث افزايش امكان Reuse در پروژه مى‏شود).
  • مدلها تصميماتى را كه در جهت كاربردى سيستم بايد گرفته شوند مستند مى‏كنند.

ما در اصل مدلها را براى سيستمهاى پيچيده ايجاد مى‏كنيم. زيرا نمى‏توانيم آنها را يكجا تصور كنيم. انسان توانايى درك چيزهاى پيچيده را ندارد و در درك آنها محدوديت دارد. ولى با مدل سازى در هر نسخه روى يك جزء از سيستم كار مى‏شود، بايد توجه داشت كه مدل‏سازى مى‏تواند روى تخته، كاغذ، كارتهاى CRC و... صورت گيرد. ولى چيزى كه مهم است مدل كردن سيستمهاى پيچيده مى‏باشد و شكستن آنها به سيستمهاى كوچكتر كه قابل درك بوده و به راحتى قابل پياده‏سازى مى‏باشند.

اصول مدلسازى:

تجربه چهار اصل را براى مدلسازى پيشنهاد مى‏كند:

اول: انتخاب مدلهايى كه براى ساخت داراى تأثيرات كارآمد و عميقى بر روى اينكه چگونه مى‏توان به يك مشكل حمله كرد و چگونه مى‏توان براى آن راه‏حل پيدا كرد مى‏باشند.

به معنى ديگر مدل خود را خوب انتخاب كنيد. يك مدل خوب مشكلات موجود در سرراه پياده‏سازى را تصوير مى‏كند و مسيرى را كه راهى مناسبتر از آن پيدا نمى‏كنيد پيشنهاد مى‏دهد، ولى مدلهاى نامناسب شما را به بى‏راهه راهنمايى خواهند كرد. در توليد نرم‏افزار مدلهايى را كه شما انتخاب مى‏كنيد مى‏توانند تاثير زيادى بر روى ديد شما به مسائل داشته باشند. اگر شما يك سيستمى را بعنوان پياده‏ساز يك بانك اطلاعاتى درنظر داشته باشيد، به احتمال زياد روى روابط موجوديتى كه رفتارشان همانند triggerها و Store Procedureها مى‏باشد تمركز خواهيد كرد. اگر شما سيستمى را بعنوان يك آناليست مشاهده كنيد، مدلها را به احتمال زياد از ديد الگوريتم و جريان داده‏هايى كه بين پروسس‏ها در حال حركت مى‏باشند بررسى مى‏كنيد. پس نتيجه مى‏شود كه هر مدل ديدى به سيستم ما مى‏دهد كه اين ديدها، گوناگون بوده و هزينه و سودهاى خاص خود را دارند.

دوم: هر مدلى بسته به شرايط بايد از لايه‏هاى گوناگونى بررسى شود. اين مسئله هم در دنياى واقعى و هم در صنعت نرم‏افزار صادق است. گاهى يك مدل سريع و راحت همانند User Interface مشخص مى‏كند كه ما نيازمند چه مى‏باشيم. اين مسئله در تعيين Platform، شبكه و مسائلى از اين قبيل حائز اهميت مى‏باشد.

بهترين مدلها آنهايى هستند كه اجازه دهند شما جزئيات و وابستگى‏هاى سيستم خود را بشناسيد و متوجه شويد كه به كدام علت به آنها در سيستم خود نيازمند باشيد. در بسيارى از مدلها يك طراح يا كاربر مى‏خواهد بر روى «چه چيز» متمركز شود و يك پياده‏ساز مى‏خواهد بر روى «چه طور» تمركز كند، هر دوى اينها مى‏خواهند يك سيستم را در لايه‏ها و زمانهاى مختلف تصوير كنند.

سوم: بهترين مدلها آنهايى هستند كه به واقعيت نزديك و در ارتباط با آن باشند. مدل مناسب بايد با دنياى واقعى مرتبط باشد و مشخص كند كه در كدام قسمتها داراى ضعف مى‏باشد. در اصل تمامى مدلها حالت ساده شده‏اى از دنياى واقعى هستند، نكته اصلى در مدل اين است كه جزئيات اصلى و مهم سيستم از قلم انداخته نشده باشد.

در نرم‏افزار، نقطه ضعف در از بين رفتن ارتباط بين مدل آناليز شده و مدلى كه طراحى مى‏شود مى‏باشد. اين شكاف بين مدلها باعث ايجاد شكافهاى بيشترى در پروژه در زمانهاى مختلف خواهد بود.

چهارم: هيچ مدلى به تنهايى كارايى كافى ندارد. هر سيستم بزرگى بهتر است كه داراى خط مشيى باشد كه به سمت يك مجموعه از مدلهاى كوچك با كمترين وابستگى حركت كند. اگر شما سازنده يك ساختمان باشيد، هيچ نقشه‏اى وجود ندارد كه تمام جزئيات را براى شما مشخص كرده باشد. در حداقل شرايط شما به چندين نقشه مانند برق ساختمان، طبقات، لوله‏كشى و... نيازمند باشيد. شايد جمله سؤال برانگيز، وجود كلمه «با كمترين وابستگى» در اصل چهارم مى‏باشد. اين به معناى داشتن مدلهايى است كه مى‏توانند بطورى مستقل و جداگانه ساخته شده و استفاده شوند. اما هنوز هم بر همديگر وابستگى دارند. مثلاً در نقشه ساختمان، نقشه برق ساختمان يك نقشه جداگانه و كامل مى‏باشد كه مى‏تواند پياده‏سازى شود، ولى هنوز بر نقشه بناى ساختمان وابستگى دارد زيرا با تغيير در آن ممكن است نقشه برق نيز دچار تغيير شود. اين واقعيت در سيستمهاى نرم‏افزارى شى‏ءگرا صادق است. براى درك معمارى چنين سيستمهايى شمانيازمند چندين View بهم مرتبط مى‏باشيد كه شامل موارد زير مى‏باشد.

- Usecase View (نيازمنديهاى سيستم را مشخص كرده و نمايش مى‏دهد).

- Design View (پيداكردن مشكلات سيستم و مشخص كردن راه‏حلهاى مربوط به آنها).

- Process View (پردازش Threadهاى موجود در سيستم را در قالب توزيع شده مدل مى‏كند).

- Development View (پياده‏سازى و اداره كردن درك فيزيكى سيستم را برعهده دارد).

- Deployment View (بر روى مهندسى و تكنولوژى گسترش برنامه متمركز مى‏باشد).

هر كدام از ديدها ممكن است داراى ساختار گوناگونى باشند ولى درمجموع همه آنها نقشه يك سيستم نرم‏افزارى را نشان مى‏دهند. البته بايد توجه داشت كه در سيستمهاى گوناگون هر كدام از اين مدلها ممكن است داراى اهميت بيشترى نسبت به ديگر مدلها باشند. مثلاً در Graphic User interface(GUI) ديدهاى Usecase مهم است. در سيستمهاى Realtime ديد پردازشى مهم است و در برنامه‏هاى تست و Web ديد پياده‏سازى و گسترش برنامه از اهميت بالايى برخوردار است.

امروزه يك سازمان نرم‏افزارى موفق سازمانى است كه بتواند بسادگى نرم‏افزارهايى را توليد كند كه نيازهاى كاربران در آن ديده شده باشد. چنين سازمانى كه بتواند چنين نرم‏افزارى را با روشها و ابزار مؤثر و در زمان مناسب پياده‏سازى كند، مى‏تواند در امر تجارت موفق باشد. محصول اوليه يك تيم توليد نرم‏افزار، بهينه نمى‏باشد و شعار نمى‏دهد بلكه مهم است كه نرم‏افزارى را پياده‏سازى كرده باشد كه نيازهاى كاربران و تجارت را برآورده سازد. بقيه موارد حالت ثانويه به حساب مى‏آيند. نكته مهمى در اين شعار وجود دارد. متأسفانه بسيارى از سازمانهاى نرم‏افزارى درگير حالت ثانويه مى‏باشند. براى پياده‏سازى نرم‏افزارى كه اهداف موردنظر را برآورده سازد، شما بايد كاربران را ملاقات كنيد تا نيازهاى واقعى سيستم شما بدست آيد. مى‏توان گفت براى اينكه شما در نهايت بتوانيد نرم‏افزارى با كيفيت بالا به وجود آوريد، بايد داراى افراد و ابزارى مناسب به همراه هدف مشخص و واضحى باشيد.

مدل كردن، قسمت مركزى تمامى فعاليتهايى است كه پياده‏سازان نرم‏افزارى را به سمت توليد يك محصول مناسب راهنمايى مى‏كند. ما سيستم‏ها را مدل مى‏كنيم براى اينكه رفتارها و ساختارهايى را كه در سيستم خود مى‏خواهيم بصورت كتبى داشته باشيم، ما مدل مى‏كنيم تا بتوانيم معمارى سيستم خود را كنترل كنيم و بتوانيم سيستمى را كه در حال ساختن آن مى‏باشيم بهتر درك كنيم، امكان Reuse را در سيستم داشته باشيم و همچنين ريسكهاى پروژه را مديريت كنيم.

بسيارى از سازمانهاى نرم‏افزارى شروع به انجام كارهاى بزرگ مى‏كنند، ولى مشكل اصلى اين است كه آنها همانند ساختن لانه براى پرنده‏ها عمل مى‏كنند (براى ساختن لانه پرنده مى‏توان با تعدادى تخته و ميخ و بدون نياز به نقشه اقدام به ساخت لانه كرد).

اگر شما واقعاً مى‏خواهيد كه نرم‏افزارى را بدون هدف و در كمترين زمان ممكن توليد كنيد مشكلات اين كار فقط نوشتن خود برنامه مى‏باشد، ولى در واقع هدف اصلى ايجاد يك نرم‏افزار صحيح مى‏باشد و پياده‏سازى يك نرم‏افزار كارا وابسته است بر ابزار، فعاليتها و معمارى كه آن نرم‏افزارى استفاده مى‏كند. بسيارى مواقع پروژه‏ها بصورت كوچك شروع مى‏شوند ولى پس از مدتى به پروژه‏هاى بزرگ تبديل مى‏شوند، بخاطر آنكه آنها موفقيت كارى خودشان را در اين راه قربانى مى‏كنند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 30 بهمنماه 1383

01:45 PM

February 18, 2005

"تلفن اينترنتي" و تحولاتي که در عرصه مخابرات در حال وقوع است

نوشته : محمدرضا شیخ عطار

با توجه به گسترش بحث و تبادل‌نظر راجع به مفاهيمي چون " تلفن اينترنتي " و “IP Telephony” و “VOIP” در جامعه، در مطلب زير به معرفي مختصري از اين تحول تکنولوژي و پيامدهاي آن مي‌پردازيم:

مقدمه و تعاريف

مفهوم " تلفن اينترنتي " يا به اصطلاح “IP Telephony” از آنجا نشأت مي‌گيرد که مي‌خواهيم از شبکه‌هاي مبتني بر پروتکل اينترنت ( IP ) در کاربردهايي چون تلفن استفاده کنيم. در واقع از زماني که امکان انتقال صدا از طريق شبکه‌هاي اينترنتي (مبتني بر IP ) گسترش يافته است، موضوع "تلفن اينترنتي"، به موضوعي مهم در صنعت مخابرات جهان تبديل شده است؛ موضوعي که نقطه عطفي در همگرايي سرويس‌هاي مخابراتي نيز خواهد بود. چرا که دو شبکه متفاوت از نظر مقررات و سياستگذاري را به يکديگر پيوند داده است:

• شبکه تلفني سوئيچينگ عمومي ( PSTN ) که همة کشورها به صورت گسترده از آن استفاده مي‌کنند و

• شبکة اينترنت که مبتني بر تکنولوژي سوئيچينگ بسته‌اي است.

البته اصطلاح “IP Telephony” تعاريف مختلفي بين مهندسان و سياستگذاران دارد؛ در اين مقاله، اين اصطلاح به معني يک روش کلي براي انتقال صدا، فاکس و سرويس‌هاي وابسته از طريق شبکه‌هاي سوئيچينگ بسته‌اي مبتني بر IP ، به کار مي‌رود.

تولد "تلفن اينترنتي"

از موضوعات کليدي که توجه سياستگذاران، قانونگذاران و صنعت‌گران حوزه مخابرات را به خود جلب نموده است، اين حقيقت است که امروزه، اينترنت و ديگر شبکه‌هاي مبتني بر IP به صورت روزافزون جايگزين شبکه‌هاي تلفن سوئيچينگ مداري مي‌شوند و با اصلاح شبکه‌هاي زيرساخت و يا استقرار زيرساخت‌هاي جديد، اين روند جايگزيني، سرعت بيشتري به خود خواهد گرفت.

يکي از سرويس‌هايي که بر اساس اين تغيير و تحول متولد شده است، " تلفن اينترنتي " است. توسعه اين شبکه حداقل از دو ديدگاه قابل بررسي است:

1- از نظر کاربران: سرويس "تلفن اينترنتي" امکاناتي را جهت ارايه خدمات صوتي با قيمتي ارزان فراهم مي‌کند. همچنين امکان انتقال انواع داده (ديتا) را نيز مهيا مي‌کند که امکان ارايه آن از طريق شبکه سوئيچينگ مداري (تلفن معمولي) وجود ندارد.

2- از نظر صنعت: مزيت اصلي تکنولوژي " تلفن اينترنتي " ، همگرا کردن سرويس‌هاي مختلف صوتي، ديتا و تصوير و ارايه همزمان خدمات مختلف و همچنين، تعريف سرويس‌هاي جديد براي کاربران است. به اين ترتيب، فعالان عرصه ارايه خدمات مخابراتي، مي‌توانند با سرمايه‌گذاري کم و مخارج عملياتي پايين، طيف وسيعي از سرويس‌ها را در اختيار کاربران خود قرار دهند.

تاکنون چندين اپراتور بين‌المللي مخابرات عمومي (PTO) اعلام کرده‌اند که همه ترافيک بين‌المللي خود را به ساختار مبتني بر IP منتقل خواهند کرد و به منظور انجام اين تغيير و انتقال، سرمايه‌گذاري لازم را نيز انام داده‌اند. يکي از دلايل اصلي اين تغيير و تحول، هزينه پايين انتقال ترافيک از طريق شبکه‌هاي مبتني بر IP است. برخي برآوردها نشان مي‌دهد که با استفاده از اين تکنولوژي، انتقال ترافيک با هزينه‌اي برابر با يک‌هشتم هزينه انتقال از طريق شبکه سوئيچينگ مداري امکان‌پذير است.

سرعت رشد "تلفن اينترنتي"

اگرچه در مورد پيش‌بيني آهنگ رشد " تلفن اينترنتي " اختلاف‌نظر وجود دارد، اما همه صاحب‌نظران بر اين باورند که رشد اين تکنولوژي نسبتاً سريع خواهد بود. آمارها نشان مي‌دهد ترافيک صوتي که در جهان از طريق شبکه اينترنت منتقل مي‌گردد، با رشدي 23 درصدي نسبت به سال 2002، 11 درصد کل ترافيک صوتي را در سال 2003 به خود اختصاص داده است.

از طرف ديگر بايد توجه نمود که هم‌اکنون در دنيا حتي خطوط سوئيچينگ مداري (تلفن معمولي) نيز به طور روزافزوني زير بار انتقال اطلاعاتي غير از صوت قرار گرفته‌اند. در اين رابطه، آمارهايي که ITU-T ارائه کرده است، تعداد خطوط بين‌المللي مربوط به شبکه تلفن معمولي را که از آنها براي برقراري ارتباطات ديتا استفاده شده است با خطوط بين‌المللي که مخصوص انتقال ديتا هستند مقايسه مي‌کند. اين آمار به قرار زير است:

محل استقرار خطوط | تعداد خطوط مورد بررسي | درصد خطوطي که مربوط به شبکه PSTN (تلفن معمولي) است | درصد خطوطي که مخصوص انتقال ديتا است
اروپاي غربي | 162000 | 32% | 68%
آسيا | 53000 | 41% | 59%
آمريکاي جنوبي | 18000 | 46% | 54%
کاراييب | 12000 | 82% | 18%

اين آمارها بيانگر اين حقيقت هستند که بسترهاي مخابراتي تلفني که تا سال‌هاي قبل، فقط وظيفه برقراري ارتباطات صوتي را بر عهده داشتند، امروزه به مسيرهايي پرترافيک جهت نقل و انتقال انواع مختلفي از اطلاعات مخابراتي تبديل شده‌اند که لزوماً از نوع صوت نيستند. تغييراتي که در نوع ترافيک عبوري از شبکه‌هاي تلفني ايجاد شده، باعث شده است که اهداف طراحي اين شبکه‌ها نيز تغيير کند و شبکه‌هاي مخابراتي جهت انجام ماموريت‌هاي جديد اصلاح گردد. در بسياري موارد، اصلاح شبکه‌هاي سوئيچينگ مداري موجب رشد بازار مخابرات و به طور خاص رشد بازار " تلفن اينترنتي " شده است.

فشار اقتصادي "تلفن اينترنتي" روي PTO ها

سرويس " تلفن اينترنتي " تاثير اقتصادي فراواني بر فعاليت شرکتهاي مخابراتي تلفني گذاشته است و به عنوان جدي‌ترين رقيب سيستم‌هاي تلفني رايج، چالش‌هايي را براي اين شرکت‌ها ايجاد کرده است. اينکه " تلفن اينترنتي " توانسته است رقيبي جدي براي بازار مخابرات تلفني باشد، دو دليل عمده دارد:

اولاً، کاربرد و توسعة " تلفن اينترنتي " به همگرا شدن سرويس‌هاي صوتي و تصويري و ديتا منجر شده و باعث شده است که ديگر نيازي به سرمايه‌گذاري جداگانه روي هر کدام از اين سرويس‌ها نباشد و سرمايه‌گذاري فقط روي يک تکنولوژي که همان " تلفن اينترنتي " باشد، صورت پذيرد؛ اين امر باعث کم شدن هزينه‌هاي عملياتي توسعة شبکه‌هاي مخابراتي شده است.

ثانياً، رشد اين تکنولوژي مانع موجود بر سر راه رقابت در عرصه ارايه خدمات تلفني را حذف کرده است؛ به طوري که صاحب‌نظران صنعت مخابرات بر اين باورند که راه‌اندازي يک سرويس VOIP (تلفن اينترنتي) که توان رقابت در عرصه مخابرات را داشته باشد، به مراتب آسان‌تر و کم‌هزينه‌تر از همتاي سوئيچينگ مداري خود است.

از آنجا که قيمت پايه مکالمات " تلفن اينترنتي " ، قيمت‌هاي مصوب PTO ها را شکسته و موجب کاهش اين قيمت‌ها شده است، اين شرکت‌ها مجبور شده‌اند سرويس‌هاي جديدي صوتي ارايه نمايند تا قسمتي از درآمد از دست رفته خود را جبران کند. به همين دليل و با وجود اينکه PTO ها در برابر حضور " تلفن اينترنتي " به عنوان يک تکنولوژي جديد در عرصه مخابرات، مقاومت مي‌کنند، اکثر تحليل‌گران صنايع مخابراتي بر اين باورند که آينده بازار " تلفن اينترنتي " بسيار درخشان است. مدير شرکت Global Crossing (شرکتي که ارايه‌کننده سرويس‌هاي يکپارچه بر روي زيرساخت‌هاي خصوصي بر مبناي IP است) اين باور تحليل‌گران صنايع مخابراتي را قبول دارد و مي‌گويد: همچنان فرصت رقابت بين " تلفن اينترنتي " و شبکه PSTN در بخشها و کاربردهاي مختلف مخابراتي وجود دارد، اما از نظر استفاده و هزينه، " تلفن اينترنتي " نيز برتر خواهد بود.

پيشرفت تکنولوژي "تلفن اينترنتي" و مقايسه آن با شبکه PSTN

نظرها و ايده‌هاي مختلفي که در ارتباط با تکنولوژي " تلفن اينترنتي " ارايه مي‌گردد، نشان مي‌دهد که اين تکنولوژي هنوز به بلوغ نرسيده و مراحل رشد خود را طي مي‌کند. در مقام مقايسه بايد گفت که امروزه صاحب‌نظران مسائل ارتباطي کمتر دربارة شبکه‌هاي PSTN و سيستم‌هاي TDM صحبت مي‌کنند؛ اين امر ناشي از آن است که تکنولوژي شبکه‌هاي PSTN دوران بلوغ خود را سپري کرده است و کاملاً اميد مي‌رود که شبکه‌هاي متداول سوئيچينگ مداري صوتي در آينده‌اي نزديک جاي خود را به شبکه‌هاي سوئيچينگ بسته‌اي صوتي بدهند. آمارها نيز اين موضوع را تأييد مي‌کنند؛ طبق آماري که ITU-T درسال 2002 از رشد بازار تکنولوژي " تلفن اينترنتي " ارايه کرده است نشان مي‌دهد در سال 2000، چهار ميليون دقيقه ترافيک صوتي از طريق شبکه " تلفن اينترنتي " منتقل شده است و در سال 2001 اين مقدار به شش ميليون دقيقه رسيده است. همچنين درآمد حاصل از بازار تجهيزات " تلفن اينترنتي " که در سال 1998، حدود 279 ميليون دلار بود، تا سال 2005 به بيش از 10 ميليارد دلار خواهد رسيد.

دورنماي "تلفن اينترنتي" در ايران

تحولات و فعاليت‌هاي اخير در حوزه مخابرات جهاني و جهت‌گيري آن به سمت ايجاد و توسعة شبکه‌هاي مبتني بر سوئيچينگ بسته‌اي، تأثيراتي را بر سياست‌ها و فعاليت‌هاي اخير شرکت مخابرات ايران گذاشته است. از آن جمله، اجراي پروژه PAP (يا اينترنت پرسرعت) است که مي‌تواند زيرساخت مناسب را جهت گذار از شبکه سوئيچينگ مداري به سمت ايجاد يک شبکه سوئيچينگ بسته‌اي در داخل کشور فراهم کند.

يکي از مباحث مهم در اين زمينه، لزوم راه‌اندازي سرويس‌هاي متنوع ديتا در کشور است. هرچند مسئولان بر آن هستند که با خصوصي‌سازي در مخابرات، سرعت اين تحولات را در کشور افزايش دهند و بدنه غير قابل انعطاف و دولتي مخابرات کشور را با بخش خصوصي تعويض کنند، اما به نظر مي‌رسد ضعف و شفاف نبودن قوانين، حرکت در اين مسير و همسو شدن با تحولات جديد تکنولوژي را دچار اخلال کرده است.

اهميت اين مسئله در حوزة ديتا و به ويژه " تلفن اينترنتي " بيشتر است؛ به عنوان مثال، حرکت به سمت ايجاد شبکه " تلفن اينترنتي " و گذر از تکنولوژي قديمي سوئيچينگ مداري به شبکه‌هاي مبتني بر IP ، ملاحظات مختلفي را از جمله تنظيم مقررات مطابق با شرايط کشور و همچنين توجه به ابعاد فني مسئله، مي‌طلبد. هرچند در سالهاي اخير، تغيير بعضي سياست‌هاي مخابرات در حوزه سوئيچينگ مي‌تواند حاکي از اثرگذاري تحولات جديد بر تفکر حاکم بر مخابرات کشور باشد (که از آن جمله مي‌توان به برنامه‌ريزي براي عدم توليد سوئيچ‌هاي مداري از سال 1385 اشاره کرد.). اما اين تغييرات براي پيشبرد اهداف مخابرات کافي نيست. براي حرکت در اين مسير بايد گام‌هاي اساسي‌تري برداشته شود و استفاده از تجربيات ديگر کشورها مي‌تواند در اين زمينه کارساز باشد. با توجه به اينکه در بسياري از کشورهاي پيشرفته براي ايجاد شبکه‌هاي " تلفن اينترنتي " تحولات اساسي صورت گرفته است، مي‌توان حداقل در ابعاد فني با استفاده از تجربه اين کشورها، ايجاد و توسعه شبکه فعلي ديتا را که در ابتداي راه قرار دارد، به گونه‌اي پيش برد تا در آينده با مشکلات کمتري مواجه شد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 30 بهمنماه 1383

01:49 PM

February 18, 2005

درسهايي از اتخاذ سياست صنعتي در برزيل و چين

تهیه کننده : عبدالحمید شوری

در سال‌هاي اخير، سياست‌هايي چون " خصوصي‌سازي " و " سرمايه‌گذاري خارجي " به فراواني از طرف برخي مديران و متخصصان حوزه‌هاي توسعة صنعتي کشور مطرح شده است. اما تجربة برخي کشورهاي مطرح در زمينة اصلاحات صنعتي و اقتصادي، بيانگر آن است که بحث " سياست صنعتي " پيچيده‌تر از اين نسخه‌هاي تک‌خطي است. نوشتار حاضر بخشي از نظرات دکتر رضوي، عضو هيأت علمي دانشکدة مديريت دانشگاه تهران است که در گزارشي تحت عنوان " تبيين ضرورت اتخاذ سياست صنعتي - تکنولوژي در اقتصاد ايران " منعکس شده است. در اين نوشتار، تجربة برزيل و چين بررسي شده است که حاوي نکات جالبي است:

مقدمه
در کشور ما طي ساليان گذشته، سرمايه‌گذاري‌هاي قابل‌ توجهي براي توسعة صنعتي صورت گرفته است. ولي مقايسة کشور ما با کشورهايي چون کره و مالزي حکايت از ناکامي ما در افزايش سهم ارزش‌افزودة بخش صنعت در توليد ناخالص داخلي و نيز ناتواني در جذب تعداد زيادي از متقاضيان جوياي کار در بخش صنعت دارد. اين در حاليست که، اين کشورها فرآيند توسعة خود را تقريباً به طور همزمان با کشور ما آغاز کرده‌اند. از سوي ديگر، از نقطه‌نظر حضور در بازارهاي جهاني مربوط به کالاها و خدمات مبتني بر تکنولوژي برتر نيز کشور ما هيچ سهمي در اين بازارها ندارد. حتي بازار داخلي کشور نيز، که از حمايت‌هاي دولت برخوردار است، عمدتاً بر اساس تکنولوژي‌هاي منسوخ شکل گرفته است.

سير تاريخي ديدگاه‌هاي توسعة صنعت و اقتصاد
طي دهه‌هاي 1980 و 1990، دو ديدگاه متفاوت در مورد نحوة متحول‌كردن اقتصاد و صنعت در محافل اقتصادي و سياست‌گذاري كشورهاي مختلف، به‌ويژه در كشورهاي در حال صنعتي‌شدن و آژانس‌هاي بين‌المللي، مطرح بوده است:

• يكي ديدگاهي كه بر تعديل ساختاري و تثبيت اقتصادي تأكيد مي‌کند و

• ديدگاهي كه اتخاذ سياست صنعتي‌ - تكنولوژيك و هماهنگ نمودن آن با سياست‌هاي اقتصاد كلان را توصيه مي‌کند.

ديدگاه اول در دهة 1980 بسيار مطرح و فراگير بود؛ ولي طي دهه 1990 به تدريج از نفس افتاد و عليرغم برخي دستاوردهاي مثبت آن ديگر چندان حرفي براي گفتن ندارد. اما ديدگاه دوم، محور توسعة صنعتي در اکثر کشورهاي تازه‌ صنعتي‌شده محسوب مي‌شود و به‌تدريج از اهميت زيادي، حتي براي کشورهاي توسعه‌يافته، برخوردار مي‌شود.

مفهوم سياست صنعتي
از ديدگاه نظريه‌پردازان كليدي اين حوزه، " سياست صنعتي - تکنولوژيک " ، با بسياري از ابزارهاي سياست‌گذاري مالي و پولي، كه قابل كپي‌برداري از يک کشور به کشور ديگر هستند، متفاوت است. در اين زمينه، هيرويا اونو، مهمترين نظريه‌پرداز سياست صنعتي در ژاپن مي‌گويد:

" سياست صنعتي رابطة روشني را بين اهداف و ابزار حصول آنها مشخص نمي‌كند. نظريه‌پردازي، مضمون و اشكال سياست صنعتي در هر مورد متفاوت است. اتخاذ سياست صنعتي در يک کشور به مرحلة توسعة اقتصاد آن، شرايط طبيعي و تاريخي آن، روابط بين‌المللي حاكم و موقعيت سياسي و اقتصادي آن كشور بستگي دارد. به همين دليل، از يك کشور به کشور ديگر و از يك دوره به دورة ديگر، ممکن است تفاوت‌هاي زيادي در سياست صنعتي وجود داشته باشد. "

براي درک مفهوم سياست صنعتي بايد توجه داشت که سياست صنعتي حمايت از صنايع ناكارآمد نيست؛ ايجاد موانع تعرفه‌اي و غيرتعرفه‌اي درازمدت براي پشتيباني از صنايع غيررقابتي نيست؛ ملي كردن صنايع نيست؛ افزايش سهم دولت در سرمايه‌گذاري و مالكيت صنعتي نيست.

بطور خلاصه، سياست صنعتي عبارت است از: مجموعة چشم‌اندازها، سياست‌ها و اقدامات هماهنگ، هدفمند و مبتني بر برنامه‌ريزي بلندمدت بخش دولتي در جهت ايجاد توانايي‌هاي نوين يا معرفي تحولات لازم براي تغيير ساختار فعاليت‌هاي موجود صنعتي يك کشور.

اقدمات دولت در چارچوب سياست صنعتي عبارتند از: چشم‌اندازسازي از طريق هدف‌گيري گزينشي و اولويت‌بندي صنايع، سازمان‌دهي بهينة رقابت بين بنگاه‌هاي فعال در يك رشتة صنعتي، اتخاذ سياست‌هاي بازرگاني مناسب براي حمايت از صنايع منتخب و بنگاه‌هاي فعال در آن صنايع (البته به صورت زمان‌بندي‌شده و فقط در قبال دستيابي بنگاه‌ها به برخي شاخص‌هاي عملكردي ‌توافق شده) و ايجاد محيط باثبات اقتصاد كلان از طريق اتخاذ سياست‌هاي پولي، مالي، ارزي و تجاري مناسب. به اين معني، سياست صنعتي به هيچ‌وجه به معني دخالت‌هاي بدون برنامة دولت در فعاليت‌هاي صنعتي نيست ؛ دخالت‌هايي كه به جاي برنامه‌ريزي سنجيده و مؤثر، بر مديريت بحران‌ها در كوتاه‌مدت تمركز دارد و در واقع، به جاي ارائة چشم‌انداز و شيوه‌هاي رسيدن به‌ آن، فقط در صدد جلوگيري از زيان‌هاي ناشي از بحران‌ها است.

تفاوت سياست صنعتي با سياست‌هاي توسعه و سياستهاي اقتصاد کلان
سياست صنعتي با سياست‌هاي توسعه و همچنين سياستهاي اقتصاد كلان تفاوت‌هايي دارد؛ سياست‌هاي توسعه عمدتاً به مسائلي از قبيل درجة رشد و نحوة توزيع رشد يا درآمد در تمامي بخش‌هاي اقتصادي، مناطق مختلف و گروه‌هاي متفاوت اجتماعي مي‌پردازد. اين سياست‌ها تمركز خاصي روي بخش صنعت و نيازهاي يك برنامة صنعتي ندارند . از سوي ديگر، محورهاي مركزي در سياستهاي اقتصاد كلان، سياست‌هاي مالي و پولي هستند. در اين زمينه، ژاپني‌ها چندين دهه قبل در مفاهيم اقتصاد كلان غربي تجديد نظر اساسي كردند و سياست صنعتي را به عنوان پاية سوم اقتصاد كلان در كنار دو پاية ديگر، يعني سياست‌هاي مالي و سياستهاي پولي، مطرح نمودند. امروزه، در آسياي جنوب شرقي، يك پايگاه نظري قوي براي طراحي، اتخاذ و اِعمال سياست صنعتي وجود دارد. چنين ديدگاهي درك‌هاي سنتي از اقتصاد كلان و توسعه را متحول كرده است.

مروري بر تجربة کشورهاي پيشرو در توسعة صنعتي

1- برزيل
در مقايسه با اكثر كشورهاي در حال توسعه، برزيل سابقة طولاني‌تري در زمينة توسعة صنعتي دارد. اين كشور، عليرغم مشكلات عميق اجتماعي، نظير توزيع بسيار ناعادلانة درآمد و وجود تبعيض‌نژادي، دست‌آوردهاي چشمگيري در زمينة توسعة صنعتي و تكنولوژيك داشته است. کشور برزيل، علاوه بر صدور انواع كالاهاي سرمايه‌اي، مهندسي و با تكنولوژي برتر به کشورهاي آمريكاي جنوبي، در برخي رشته‌ها همچون صنعت هواپيماسازي، صنايع نساجي، چرم و صنايع غذايي و براي مدتي در صنايع نظامي، توان رقابتي بالايي در بازارهاي بين‌المللي داشته است.

سياست جايگزيني واردات در فرآيند توسعة صنعتي برزيل
تا قبل از جنگ جهاني دوم، عمدة فعاليت‌هاي اقتصادي و صادراتي برزيل بر توليد، پردازش و صادرات محصولات كشاورزي، مخصوصاً قهوه و كائوچو بنا شده بود. در حالي که، قبل از آن (يعني بعد از جنگ جهاني اول)،‌ شركت‌هاي چندمليتي، نظير فورد و جنرال‌موتورز، به برزيل آمده بودند.

در دهة 1930، برزيل فرآيند توسعة صنعتي خود را بر اساس سياست جايگزيني واردات آغاز نمود. انتخاب سياست جايگزيني واردات، در آن زمان، يك انتخاب آگاهانه نبود؛ بلكه، وقوع پاره‌اي رويدادها در صحنة اقتصاد بين‌المللي، جايگزيني واردات را بر اين كشور تحميل کرد. از جملة اين رويدادها، مي‌توان به از بين رفتن بازار لاستيك برزيل در اواخر قرن نوزدهم و سقوط بازار قهوه و ساير كالاهاي صادراتي طي بحران بزرگ دهة 1930 اشاره کرد. در طي دو سال، در بحران موسوم به سقوط بزرگ، رابطة مبادلة ارزي اين كشور 46.6درصد سقوط كرد.

جايگزيني واردات در اين كشور در دو مرحله صورت گرفت؛ مرحلة اول جايگزيني واردات در دورة 1930 تا 1955 اجرا شد. در اين دوره، عمدتاً كالاهاي مصرفي اساسي توليد مي‌شد و صنايع نساجي، غذايي، سيمان، آهن و فولاد، كاغذ، مواد شيميايي و ماشين‌آلات مورد توجه و حمايت قرار گرفتند.

مرحلة دوم جايگزيني واردات در دورة 1955 تا 1968 اجرا شد. در اين دوره، عمدتاً از صنايع فولاد، خودروسازي، ماشين‌آلات الكتريكي و الكترونيكي، صنايع پالايش نفت و پتروشيمي و صنايع داروسازي حمايت شد. خصوصيت ويژة اين دوره اين بود که، علاوه بر بنگاه‌هاي خصوصي ملي، بنگاه‌هاي دولتي و شركت‌هاي چندمليتي نيز حضور چشمگير در فعاليت‌هاي اقتصادي و صنعتي داشتند.

از نفس‌افتادگي سياست جايگزيني واردات در فرآيند توسعة صنعتي برزيل
سياست جايگزيني واردات تا سال 1962 موفقيت‌آميز بود؛ بطوريكه در دورة 1955 تا 1961 اقتصاد اين كشور سالانه بطور متوسط 10.9‌درصد رشد کرد. اما با آغاز دهة 1960، تداوم رشد شتابان بخش صنعت بر اساس سياست جايگزيني واردات به دلايل متعدد ممکن نبود. يکي از مهمترين اين دلايل به عدم كفايت تقاضاي مؤثر داخلي به دليل توزيع بسيار نابرابر درآمدها مربوط مي‌شد. در اين دهه، كه به تعبير نظريه‌پردازان برزيلي، دهة از نفس‌افتادگي رويكرد جايگزيني واردات است، رشد اقتصادي به‌طور قابل‌ملاحظه‌اي كاهش يافت. به‌طوريكه در دورة 1962 تا 1968، متوسط سالانة رشد اقتصادي حدود 3.5‌درصد بود. كاهش رشد اقتصادي و بروز تنش‌هاي اجتماعي از يك طرف و دخالت دولت آمريكا از طرف ديگر، زمينة تشكيل حكومت نظامي را در اين کشور فراهم کرد.

سياست توسعة صادرات در فرآيند توسعة صنعتي برزيل
به‌ دنبال تشكيل اولين دولت نظامي در برزيل، سياست توسعة صادرات كالاهاي صنعتي، علاوه بر جايگزيني واردات، در راستاي حل معضلات اقتصادي مبتلا‌به كشور، در دستور كار قرار گرفت. در نتيجة چنين سياستي، صادرات محصولات كارخانه‌اي به‌طور قابل‌ملاحظه‌اي افزايش يافت و سهم اين صادرات از كل صادرات، از رقم 2‌درصد در سال 1960 به رقم 27‌درصد در سال 1975 و 45‌درصد در سال 1987 رسيد.

طي دهة 1968 تا 1978، بر پاية استقراض خارجي، حمايت از صنايع داخلي، سرمايه‌گذاري‌هاي وسيع در كالاهاي سرمايه‌اي و واسطه‌اي (به‌خصوص مواد و شيميايي) و توجه به صادرات، " معجزة برزيل " صورت گرفت. در اين دوره، متوسط سالانة رشد اقتصادي برزيل 9‌درصد بود. پاية اجتماعي و سياسي چنين سياستي، اتحاد سه‌گانه‌اي بود كه بين سرماية خارجي، بخش خصوصي داخلي و بخش دولتي شكل گرفت.

در اين دوره، بخش صنعت نيز به‌طور چشمگيري توسعه يافت؛ به‌طوريكه، در دهة 1970 تا 1980، متوسط نرخ رشد سالانة توليدات كارخانه‌اي برزيل حدود 9‌درصد بود؛ اين بهترين عملكرد صنعت برزيل از آغاز دهة 1970 تاكنون است.

اين روند رشد صنعتي، همانگونه كه بيان گرديد، بر پاية استقراض خارجي و انجام سرمايه‌گذاري‌هاي وسيع حاصل شده بود. چنين روندي تنها در صورتي مي‌توانست تداوم يابد كه صنعت برزيل قادر باشد با افزايش ‌بهره‌وري و ارتقاي رقابت‌پذيري در مجموعه‌اي از كالاهاي صادراتي، زمينه‌هاي لازم را براي بازپرداخت بدهي‌هاي خارجي فراهم آورد.

عليرغم قدم‌هاي اساسي كه براي رشد بهره‌وري و افزايش رقابت‌پذيري كالاهاي صنعتي برداشته شد، متوسط رشد بهره‌وري طي دهة 1970 تا 1980، از رقم 2.5‌درصد در سال فراتر نرفت. بدين ترتيب، به دليل عدم توانايي برزيل در بازپرداخت بدهي‌هاي خارجي، بدهي‌هاي خارجي اين كشور سريعاً افزايش يافت؛ بطوريكه از رقم 50 ميليارد دلار در اواخر دهة 1970 به رقم 100 ميليارد دلار در سال 1987 رسيد. نتيجه آنكه، عليرغم دستاوردهاي مثبت در زمينة توسعة صنعتي و ايجاد توانايي‌هاي تكنولوژيك، بار ديگر سياست توسعة صنعتي اين كشور با بحران مواجه گرديد.

نقش دولت در فرآيند توسعة صنعتي برزيل
شروع جنگ جهاني دوم را شايد بتوان نقطة عطفي در توسعة صنعتي برزيل به شمار آورد؛ از يك طرف، رهبران اين كشور موفق شدند از اين موقعيت نوظهور استفاده كرده و در ازاي حمايت از دولت‌هاي متفق، امتيازات قابل توجهي از آمريكا بگيرند. به عنوان مثال، اعتبارات مالي ايجاد اولين كارخانة ذوب آهن و شركت معدني بهره‌برداري از سنگ آهن را آمريكا تأمين کرد. از طرف ديگر، حضور افسران برزيلي در جبهه‌هاي اروپايي جنگ جهاني دوم و مشاهدة تغييرات تكنولوژيكي چشمگيري كه در صنايع نظامي كشورهاي پيشرفته اتفاق افتاده بود، تأثيرات عميقي بر تفكرات و تمايلات اين افسران بر جاي گذاشت. به‌طوريكه، پس از بازگشت اين افسران به کشور، بحث‌هاي ريشه‌اي فراواني در زمينة تجديد ساختار اجتماعي - اقتصادي كشور مطرح شد. وجود اين تفكرات و نهادهاي شكل‌دهنده و ارائه‌كنندة آنها، نقش مهمي را در دخالت ژنرال‌ها در سياست برزيل در اواسط دهة 1960 ايفا نمود.

طي دهه‌هاي 1950 و 1960، نهادهاي مذكور دو چشم‌انداز را براي توسعة برزيل در دستور کار قرار دادند؛ اولين چشم‌انداز بر اهميت برنامه‌ريزي و سرمايه‌گذاري گستردة بخش دولتي و بكارگيري توانايي‌هاي بخش خصوصي داخلي و خارجي در فرآيند توسعة صنعتي اعتقاد داشت. چشم‌انداز ديگر، در کنار تاکيد بر برنامه‌ريزي دولت، بر محوريت سرماية خارجي جهت ارتقاي صنعت و ايجاد تحرك اساسي در آن تأكيد مي‌ورزيد. همانطوركه قبلاً بيان گرديد، ابتدا ديدگاه اول بكار گرفته شد، ولي با از نفس‌افتادگي سياست جايگزيني واردات، كم‌كم ديدگاه دوم غالب گرديد.

متعاقب غلبة ديدگاه دوم در فرآيند توسعة صنعتي برزيل، " معجزة برزيل " اتفاق افتاد. تحولاتي كه در دورة دولت‌هاي نظامي اتفاق افتاد، بر سه محور تكيه داشتند: اول، دخالت مستقيم دولت در زمينه‌هاي برنامه‌ريزي، تأمين منابع‌، سرمايه‌گذاري در بعضي زمينه‌ها و ايجاد زيربناها. دوم، تكيه بر استقراض خارجي براي پوشاندن كسري تراز بازرگاني و بعضاً كسري بودجه. سوم، ارتقاي موقعيت بين‌المللي برزيل، که محور اصلي آن كامل كردن زنجيرة مجموعه‌هاي صنعتي و ايجاد قابليت‌هاي تكنولوژيك بومي در صنايع استراتژيك بود.

در ساية چنين اقداماتي، توانايي‌هاي صنعتي و تكنولوژيك برزيل در صنايعي همچون هواپيماسازي، صنايع نظامي، مخابرات، خودروسازي، صنايع واسطه‌اي و ماشين‌سازي ارتقا يافت. عليرغم اين دستاوردها، عملكرد عمومي صنايع برزيل طي دهة 1980 منفي بوده است و اين روند در سال‌هاي اول دهة 1990 نيز تداوم داشته است.

در همين دوره، دولت برزيل سياست " بازار رزرو شده " را براي صنايع مخابرات و كامپيوتر در پيش گرفت؛ ائتلافي از بخش‌هاي فني ارتش و جامعة دانشگاهي اين سياست را پيشنهاد کرده بود. اين سياست، كه مباحث فراواني را در ميان نظريه‌پردازان و برنامه‌ريزان توسعة صنعتي كشورهاي مختلف برانگيخت، به عنوان نمونه‌اي از ورود نسبتاً موفق يك كشور در حال صنعتي‌شدن به عرصة تكنولوژي‌هاي برتر ارزيابي مي‌شود.

عليرغم دستيابي به توانمندي‌هاي مذكور، برزيل هزينه‌هاي سنگيني را نيز در فرآيند توسعة صنعتي متحمل شد. يكي از اين هزينه‌ها تورم افسارگسيخته بود. در دهة 1980، نرخ تورم در برزيل در محدودة 100 تا 270‌درصد قرار داشت. هزينة دومي كه پيش از اين نيز بدان اشاره شد، انباشت بدهي‌هاي خارجي بود كه اقتصاد اين كشور را با بحران جدي مواجه ساخت.

2- چين
ورود چين به صحنة تجارت جهاني، به عنوان يك قدرت نوظهور صنعتي، تحولات مهمي را در تجارت بين‌المللي به دنبال داشته است. بازار وسيع اين كشور و انتقال آن از يك اقتصاد كشاورزي به يک اقتصاد صنعتي موجب شده است تا تحليل‌گران توسعة اقتصادي تحولات اقتصاد چين را با دقت دنبال كنند.

چين كشوري است كه، عليرغم اينکه بسياري از بنگاه‌هاي صنعتي آن دولتي هستند، طي دهة گذشته رشد قابل‌توجهي داشته است و ورود چشمگيرش به بازارهاي جهاني براي مدتي موجب بي‌ثباتي ساير اقتصادهاي شرق آسيا شده است؛ ولي امروزه با توجه به حجم چشمگيرش، به آن به عنوان عامل ثبات اين اقتصادها نگريسته مي‌شود. طي دورة 1978 تا 1995، اقتصاد چين بيش از چهار برابر گسترش يافته است و متوسط رشد سالانة آن در حدود 8‌درصد بوده است. اين کشور از نظر توان علمي و تكنولوژيک نيز در دهة 90 پيشرفت قابل ملاحظه‌اي داشته است. به‌طوريكه، طي سال‌هاي 1995 تا 1998، صادرات محصولات تكنولوژي برتر آن 30درصد رشد کرده است.

کشور چين، بدون توسل به خصوصي‌سازي گسترده، اصلاحات ريشه‌اي را در صنايع دولتي محقق ساخته و ارتباطات خود را با شركت‌هاي چندمليتي به‌نحوي استراتژيك سازمان‌دهي كرده است. در روابط تجاري دوجانبه و همچنين ورود به سازمان تجارت جهاني نيز بر اساس اولويت‌هاي خود عمل كرده و تسليم كشورهاي غربي به‌ويژه آمريكا نشده است.

برنامة اصلاحات اقتصادي چين در سال 1978
تا پيش از اصلاحات سال 1978، اهداف اقتصادي چين عبارت بودند از: نيل به خودكفايي، ‌از بين بردن اختلاف شهر و روستا و از بين بردن اختلاف طبقاتي در جامعه. بر همين اساس، برنامه‌ريزان اين كشور بر رشد اقتصادي بالا و تمركز بر صنايع سنگين تأكيد داشتند. در اين دوره، بر اساس سياست درون‌گرا، بيشتر بر بازار داخلي تمرکز شد و ارتباطات بسيار محدودي با اقتصاد جهاني شکل گرفت. اگرچه، از اوايل دهة 1960 و پس از آن طي انقلاب فرهنگي، تحولات مهمي در ساختار صنعتي چين صورت پذيرفت، اما مشكلات اين كشور همچنان باقي بود. از جملة اين تحولات، كاهش اهميت صنايع سنگين بود.

‌خلاصه‌اي از مشكلات اين دوره از ديد كارشناسان چيني عبارتند از:

• دنبال كردن رشد، بدون توجه به مسألة كارآيي،

• تأكيد بيش از اندازه بر صنايع سنگين،

• بي‌توجهي به ارتقاي تكنولوژي بنگاه‌هاي موجود،

• توليد بيش از حد محصولات اوليه و واسطه‌اي و انباركردن آنها و

• در نهايت از دست‌رفتن نيروي انساني ماهر و متخصص به دليل از هم‌گسيختگي‌هاي ناشي از انقلاب فرهنگي.

با مرگ مائو و تعويض کادر رهبري چين، دورة جديدي در توسعة اين كشور آغاز گرديد. در اين دوره، که از سال 1978 آغاز گرديد، برنامه‌اي تحت عنوان نوسازي چهارگانه شامل مدرنيزه كردن كشاورزي، صنعت، علوم و تكنولوژي و توان دفاعي در دستور کار دولت چين قرار گرفت.

در اجراي برنامة نوسازي چهارگانه، رهبري جديد دست به اصلاحات گسترده‌اي در اكثر حوزه‌هاي اقتصادي زد. ويژگي اصلي اين اصلاحات اين بود كه از يك الگوي ازپيش‌طراحي‌شده پيروي نمي‌کرد. اين اصلاحات متكي بر تجربه‌اندوزي از به‌كارگيري سياست‌هاي جديد در مناطق جغرافيايي و در حوزه‌هاي عملكرد محدودي بود كه در صورت موفقيت به ساير مناطق و حوزه‌ها تسري مي‌يافت.

سياست صنعتي چين در اصلاح ساختار صنعتي كشور
بر اساس برنامة نوسازي چهارگانه، اصلاحات در بخش صنعت در زمينه‌هاي مختلف اعم از برنامه‌ريزي، ساختار مديريت، قيمت‌گذاري، بازاريابي و تجارت صورت پذيرفت. به‌واسطة انجام اين اصلاحات، صنعت چين از عملكرد چشمگيري برخوردار شد. از سال 1981 تاکنون، رشد بخش صنعت اين كشور روند صعودي داشته و به‌جز سال‌هاي 1986، 1989 و 1990، همواره بالاي 10 درصد بوده است. اصلاحات انجام‌شده در بخش صنعت بر سه محور متمركز بوده است‌: تغيير در نگرش حاكم بر اولويت‌بندي صنايع، تغيير در نظام مديريت و نظام انگيزشي و اتخاذ سياست‌ توسعة صادرات صنعتي.

سياست دوبال و يك‌بدن (تغيير اولويت‌هاي صنعتي)
در کشور چين، تا قبل از انجام اصلاحات اقتصادي، در اولويت‌بندي صنايع، محوريت با صنايع سنگين بود. با آغاز اصلاحات در بخش صنعت، ضمن كنار گذاشتن سياست محوريت صنايع سنگين، صنايع سبك و تبديلي كشاورزي در اولويت قرار گرفتند.

در اواخر دهة 1980، توسعة صنايع با تكنولوژي برتر (high tech) نيز در دستور كار برنامه‌ريزان چيني قرار گرفت. منظور از اتخاذ اين سياست دوگانه، كه از آن به عنوان سياست دوبال و يك‌بدن ياد مي‌شود، آن بود كه اقتصاد چين با بهره‌برداري از توانايي‌هاي صنايع سبك و كشاورزي (يك‌بال) و به‌كارگيري تكنولوژي برتر در جهت توسعة اقتصادي و نه صرفاً نظامي (بال ديگر)، قادر خواهد بود تا جهش‌هاي لازم را براي ورود به بازارهاي جهاني و نوسازي صنعتي صورت دهد.

در دهة اول اصلاحات، رشد صنايع سبك و كشاورزي قابل‌توجه بود. دولت چين، با تدوين برنامة 863 در سال 1986، تلاش‌هاي تازه‌اي را براي توسعة صنايع با تكنولوژي برتر آغاز کرد. هدف اين برنامه، گردآوري بهترين منابع تكنولوژيك در 15 سال آينده به منظور همگامي با تحولات تكنولوژي برتر در دنيا و ايجاد حمايت‌هاي لازم تكنولوژيک در جهت توسعة اقتصادي بود. در اين برنامه، صنايع بيوتكنولوژي، هوافضا، تكنولوژي اطلاعاتي، ‌ليزر، اتوماسيون، انرژي و مواد پيشرفته هدفگيري شده بودند. اين برنامه در سال 1987 با برنامة ديگري، كه بر به‌كارگيري توانايي‌هاي تكنولوژيك در صنعت تمركز داشت، تكميل گرديد.

دولت چين در سال 1991 برنامة جديدي را كه در آن، 11 صنعت استراتژيك مبتني بر تكنولوژي پيشرفته هدفگيري شده بودند، اجرا کرد. اين مسأله، حاكي از توجه ويژة دولتمردان چيني به صنايع تكنولوژي برتر است.

اگرچه در زمينة عملكرد فعاليت‌هاي مبتني بر تكنولوژي برتر در چين، اطلاعات زيادي در دست نيست، اما شواهد گوياي جا افتادن تفكر تجاري در فعاليت‌هاي مربوطه و همچنين جذب شركت‌هاي خارجي صاحب تكنولوژي برتر است.

اولويت‌دادن به نوسازي و بهبود كارآيي بنگاه‌هاي موجود
يكي از مهم‌ترين موانع توسعة صنعتي چين، كم‌توجهي به مقولة بهره‌وري و كارآيي بنگاه‌هاي صنعتي بوده است. به همين دليل، در روند اصلاحات به ايجاد و به‌كارگيري انگيزه‌ها، سازوکارها و نهادهاي مناسب براي بهبود كارآيي و بهره‌وري توجه خاصي شده است. اين امر، از طريق تفويض نسبي قدرت برنامه‌ريزي و تصميم‌گيري از سطح ملي به سطوح منطقه‌اي و شهري، در عين متمركز كردن قدرت و مسؤوليت بنگاه‌ها نزد مديران، صورت پذيرفته است.

در راستاي تفويض نسبي قدرت برنامه‌ريزي و تصميم‌گيري در اصلاحات صنعتي دهه‌هاي 1980 و 1990، بخش قابل توجهي از اختيارات دولت مركزي به سطوح منطقه‌اي و شهري تفويض گرديد. بدين ترتيب، مقامات استاني و شهري، بخش قابل‌توجهي از مسؤوليت‌ها را در زمينة بازبيني طرح‌هاي استراتژيك بنگاه‌ها، ايجاد شبكه‌هاي صنعتي، مشخص‌كردن محدوده‌هاي قيمت‌گذاري، تشويق صادرات، تنظيم تعهدات مالي و ارزي و مذاكرات دسته‌جمعي بين كارگران و كارفرمايان به عهده گرفتند.

متمركز ساختن قدرت و مسؤوليت در سطح بنگاه نزد مديران نيز با ايجاد نظام قراردادي مسؤوليت انجام پذيرفته است. در اين نظام، دو امر مورد توجه بوده است: اول، انعقاد قرارداد استيجاري با مدير يا گروهي از مديران و يا كل كاركنان كارخانه به مدت سه تا پنج سال به منظور استفاده از امكانات توليدي بنگاه. دوم، تفويض بسياري از اختيارات از جمله نگه‌داشتن بخشي از سود، استخدام و اخراج، قيمت‌گذاري و ساير تصميمات كليدي بنگاه به مديران. بدين ترتيب، دولت چين، از طريق انعقاد قراردادهاي استيجاري و بدون توسل به سياست خصوصي‌سازي گستردة بنگاه‌هاي دولتي، توانسته است تحولي در نظام مالكيتي سوسياليستي ايجاد كند تا از مزاياي انگيزشي نظام بازار نيز برخوردار باشد.

افزايش صادرات صنعتي
يكي ديگر از محورهاي كليدي اصلاحات صنعتي چين، تشويق صادرات بوده است. اين كشور، از يك سو سياست تشويق صادراتِ شديداً تهاجمي را در ارتباط با بازارهاي جهاني در پيش گرفته و از سوي ديگر، كنترل‌هاي محدودكننده‌اي را در رابطه با واردات، به‌ويژه واردات كالاهاي مصرفي، اعمال نموده است. حاصل اتخاذ چنين سياست‌هايي، تراز بازرگاني مثبت اين كشور در سال‌هاي اخير بوده است. همچنين، طي سال‌هاي اخير، سهم صادرات كالاهاي صنعتي از كل صادرات اين كشور به‌طور مستمر افزايش يافته است. ضمن اينكه، در همين دوره، صادرات ماشين‌آلات و وسائل حمل‌و‌نقل از رشد خارق‌العاده‌اي برخوردار بوده و از كمتر از 1 ميليارد دلار در سال به بيش از 30 ميليارد دلار در سال افزايش يافته است.

سياست‌هاي ويژه‌اي كه در دستيابي اين كشور به عملكردهاي صادراتي فوق مؤثر بوده‌اند عبارتند از:

1- ايجاد مناطق ويژة جغرافيايي به منظور متمركز كردن فعاليت‌هاي صادراتي: اين مناطق، كه با هدف توسعة صادرات و جذب سرمايه‌گذاري خارجي ايجاد گرديده‌اند، تسهيلات مالياتي به سرمايه‌گذاران خارجي ارائه كرده و از تعرفه‌هاي گمركي كمتر، تسهيلات زيربنايي بهتر، بازار كار منعطف‌تر و بالاخره كنترل‌هاي بوروكراتيك ساده‌تر برخوردارند.

2- تقويت شبكه‌هاي توليدي در جهت سازماندهي توانايي‌هاي صادراتي: اگرچه صنايع هدفگيري‌شده براي صادرات به بازارهاي بين‌المللي، صنايعي بوده‌اند كه چين در آنها توانايي رقابت داشته است، اما اين صنايع لزوماً همان صنايع هدفگيري‌شده براي توسعة صنعتي نيستند و شامل صنايع سبك، نساجي، ماشين‌آلات و كالاهاي الكترونيكي هستند. علاوه‌ بر اينگونه هدفگيري رشته‌اي، برنامه‌اي نيز تحت عنوان ايجاد شبكه‌هاي توليدي براي صادرات از اواخر دهة 1980 آغاز گرديد. هدف اين برنامه، بهره‌برداري از توانايي‌هاي بنگاه‌هاي پيشرفتة فعال در صنايع فوق‌الذكر و به‌كارگيري آنها به عنوان طلايه‌داران شبكه‌هاي صادراتي بوده است. اهداف اين شبكه‌ها، كاهش شكاف موجود بين بنگاه‌ها در زمينه‌هاي بهره‌برداري و كيفيت، ورود به كالاهاي با ارزش‌افزودة بالاتر و ايجاد تخصص در ميان بنگاه‌ها، در عين افزايش تنوع، بوده است. در اين رابطه، برخي معتقدند كه شكل‌گيري اين شبكه‌ها در رقابتي‌نمودن كالاهاي چيني نقش به‌سزايي داشته است.

3- ارائة حق صادرات مستقيم: در سال‌هاي اخير، به بنگاه‌ها و گروه‌هاي صنعتي كه حائز شرايط لازم بوده‌اند، حق صادرات مستقيم كالا تفويض شده است. شرايط برخورداري از اين حق عبارتست از: داشتن سابقة صادرات به ميزان حداقل تعيين‌شده، برخورداري از توانايي‌هاي بازاريابي در بازارهاي مقصد و دستيابي به حداقلي از رشد در صادرات براي تمديد اين حق.

4- نظام قراردادها و شاخص‌هاي صادراتي: چين از يك نظام پيچيدة قراردادها بين مناطق و مركز در زمينة كسب ارز خارجي برخوردار است. بدين‌ترتيب كه تمامي استان‌ها بايد قراردادهاي ساليانه‌اي را با وزارت بازرگاني امضا نمايند. در اين قراردادها، اهداف صادراتي و ميزان يارانه‌هاي مورد نياز، كه با كسب منابع ارزي خارجي از دولت مرکزي ارائه مي‌گردد، قيد مي‌گردد.

5- بهره‌برداري از سرمايه‌هاي خارجي: گستردگي بازار داخلي چين و علاقة شركت‌هاي چندمليتي براي حضور در اين بازار، بسته بودن بازار چين براي سال‌هاي متمادي و تسهيلاتي كه در مناطق ويژة اين كشور ارائه مي‌گردد، موجب شد كه با شروع فرآيند اصلاحات، حجم وسيعي از سرمايه‌هاي خارجي به اين کشور سرازير گردد.

پس از تصويب قانون سرمايه‌گذاري مشترك و ايجاد مناطق ويژة تجاري در سواحل جنوب شرقي چين، به‌تدريج سرمايه‌گذاري مستقيم خارجي در چين آغاز گرديد. تا سال 1984، حجم اين سرمايه‌گذاري‌ها از يك ميليارد دلار فراتر نرفته بود؛ اما، از اوايل دهة 1990، حجم سرمايه‌گذاري‌هاي خارجي رو به افزايش نهاد. اين ميزان فقط در سال 1995 به حدود 34 ميليارد دلار بالغ گشت. اين سرمايه‌گذاري‌ها كه در مناطق ويژة صادراتي صورت مي‌پذيرفت، يكي از دلايل رشد سريع صادرات اين كشور بوده است. علاوه‌ بر سرمايه‌گذاري خارجي، چين مقادير قابل‌توجهي نيز از بازارهاي مالي بين‌المللي استقراض نموده است.

6- سياست " بزرگ‌ها را بچسبيد، كوچك‌ها را رها كنيد " : تا قبل از سال 1997، دولت چين حدود 305‌هزار بنگاه اقتصادي را در اين كشور در اختيار داشت كه سهم بالايي از توليد صنعتي چين را تأمين مي‌کردند. در سپتامبر سال 1997، دولت مركزي چين سياست جديدي را در ارتباط با بنگاه‌هاي صنعتي اين كشور مطرح نمود كه از آن به عنوان سياست " بزرگ‌ها را بچسبيد و كوچك‌ها را رها كنيد " ياد مي‌شود. هدف دولت چين از طرح چنين سياستي، ايجاد بنگاه‌هاي بزرگ و توانمندي است كه توانايي‌هاي لازم جهت غلبه بر موانع حضور در بازارهاي شبه‌انحصاري جهاني و رقابت با شركت‌هاي چندمليتي را داشته باشند.

برنامه‌ريزان اقتصادي چين معتقدند که صرفاً با تكيه بر " صرفه‌هاي مقياس " ناشي از توليد انبوه (كه خصوصيت اغلب بنگاه‌هاي چيني است) و برخورداري از نيروي كار ارزان نمي‌توان در بازارهاي صادراتي حضوري پايدار داشت؛ از اينرو، ايجاد بنگاه‌هاي بزرگ چندبخشي، همانند جائبول‌هاي كره‌اي، جهت حضور پايدار در بازارهاي جهاني الزامي است. به همين منظور، دولت چين در نظر دارد، از ميان بنگاه‌هاي صنعتي تحت مالكيت خود، هزار بنگاه را كه توانايي‌هاي بالقوة تبديل‌شدن به بنگاه‌هاي توانمند را دارند، انتخاب نمايد و طي يك دورة زماني معين، حمايت‌هاي همه‌جانبه از آنها به عمل آورد. البته، در طول اين دوره هر يك از اين بنگاه‌ها كه عملكرد خوبي از خود نشان ندهند، از دامنة شمول حمايت‌هاي دولت خارج مي‌گردند.

بر اين اساس، دولت چين اميدوار است در پايان دورة مذكور حداقل 120 بنگاه، که توانايي‌هاي لازم را جهت شركت در بازارهاي صادراتي دارند، از ميان بنگاه‌هاي انتخابي ايجاد شوند. بدين ترتيب، به بنگاه‌هايي كه در زمرة 120 بنگاه انتخابي قرار گيرند، امتيازات قابل‌توجهي از قبيل حق تقدم در اخذ وام، حق تأسيس شركت‌هاي مالي، برخورداري از معافيت مالياتي از 15‌درصد تا 100‌درصد تعلق خواهد گرفت. سرنوشت ساير بنگاه‌ها نيز به دست سازوكار بازار سپرده خواهد شد.

چين و سازمان تجارت جهاني
اگرچه چين يكي از بنيانگذاران موافقتنامة عمومي تعرفه و تجارت (گات) در سال 1947 بود، اما با پيروزي كمونيست‌ها در سال 1949، اين كشور از عضويت گات خارج شد و چندين دور مذاكرات تجاري جهاني بدون حضور اين كشور انجام شد. از سال 1986 و قبل از شروع مذاكرات دور اروگوئه، چين مجدداً خواستار عضويت در گات شد؛ اما اين تقاضا بي‌پاسخ ماند. مذاكرات دور اروگوئه نيز، پس از 7 سال، با جايگزيني سازمان تجارت جهاني در سال 1994 پايان يافت.

از آن زمان به بعد، همواره چالشي ميان چين و اعضاي بزرگ سازمان تجارت جهاني از جمله آمريكا، ژاپن، اتحادية اروپا و كانادا در خصوص شرايط عضويت چين در اين سازمان وجود داشته است. به رغم مسائل حاشيه‌اي نظير حقوق بشر و يا برخي مسائل سياسي ديگر كه در تشديد اين چالش مؤثر بوده‌اند، يك عامل عمده مانع عملي شدن درخواست چين بوده ‌است؛‌ در واقع، چين به دنبال آن بوده است كه با شرايطي كه براي كشورهاي درحال توسعه و جهان سوم در نظر گرفته شده، به عنوان يك كشور در حال توسعه، وارد اين سازمان شود. اما اعضاي بزرگ سازمان بر اين امر پافشاري كرده‌اند كه چين، به دليل حجم زياد اقتصادش، بايد در گروه كشورهاي توسعه‌يافته به عضويت سازمان در آيد. هدف آنها اين بود که چين، با پذيرش مسؤوليت‌هاي بيشتر در زمينة آزادسازي تجاري، بازارهاي خود را بر روي كالاها و خدمات كشورهاي صنعتي بگشايد.

كشورهاي بزرگ صنعتي و اقتصادي جهان معتقدند پي‌ريزي ساختارهاي نوين تجارت بين‌الملل، بدون حضور پرجمعيت‌ترين كشور جهان، هنگام اجرا با موفقيت چنداني همراه نخواهد بود. لذا عضويت چين در اين سازمان، هم به موفقيت مصوبات مذاكرات كمك خواهد كرد و هم بازار بستة اقتصاد چين را بر روي كالاهاي صنعتي اين كشورها خواهد گشود. از طرف ديگر، چين نيز به اين نكته واقف است كه بدون عضويت در اين سازمان، صادرات صنعتي اين كشور تداوم نخواهد يافت. به همين دليل، با اتخاذ سياست‌ها و تدابيري جديد، تلاش‌هاي وسيعي را جهت ايجاد توانمندي‌هاي لازم براي مقابله با تبعات احتمالي عضويت در اين سازمان آغاز کرده بود؛ تا اينکه، عليرغم وجود اختلاف نظرها، اخيراًً با عضويت چين در اين سازمان موافقت شد.

مآخذ
• Gereffi, Gary, 1989, (Manufacturing Miracles), Princeton U. press.

• Sichaan & Jiangsu, 1998 (The Bigger< The Better ) , Far Eastern Economic Review.

• صباغيان ، علي ، 1378 ، (الزامات عضويت چين در سازمان تجارت جهاني ) ، روزنامة همشهري 26/8/78

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 3 اسفندماه 1383

02:22 AM

February 21, 2005

روان‌شناسى در IT

منبع: ComputerWeekly
مترجم: افروز رضاخانى

همکاران سیستم - روى نوريس معتقد است كه آگاهى از مسايل شخصيتى، ارتباطات شغلى بين كاركنان IT و مديران را بهبود مى بخشد. شناخت شخصيت‌ها به مديران IT كمك مى‌كند توليدات را افزايش داده، موانع ارتباطى بين بخش IT و ديگر بخش‌هاى شغلى را برطرف كنند.

من، به عنوان يك روان‌شناس مشاور شركت‌هاى بزرگ IT در مورد منابع انسانى، دريافتم كه بخش مهمى از كاركنان IT رفتارى از خود نشان مى‌دهند كه ما روان‌شناسان آن‌را ”درون‌گرايى واكنش‌پذير “ مى‌ناميم.

درون‌گرايان واكنش‌پذير، كه هميشه در تلاش هستند طبق قوانين عمل كنند، قبل از انجام فعاليت نياز به انديشيدن دارند و نيز مى‌خواهند ارتباطى مناسب برقرار كنند.

درون‌گراهاى واكنش‌پذير نسبت به فشارهاى شغلى، كه خود تهديدى براى توليد به شمار مى‌رود، آسيب‌پذيرند. براى مثال درخواست ناديده‌گرفتن برخى قوانين، فرار از تنگنا و كاهش هزينه‌ها اگرچه منطقى به نظرمى‌رسد، زنگ خطرى براى كاركنان IT است. آموزش كاركنان IT براى شناخت و درك شخصيت انسان‌ها مى‌تواند راه‌حلى سودمند باشد.

به عنوان مثال در سال گذشته اعضاى گروه ارتقاى سيستم‌هاى يك بانك مهم بين‌المللى از كمبود انگيزه و بى‌علاقگى به كار رنج مى‌بردند. اگر يكى از اعضاى اين گروه با مشكلى هر چند جزيى مواجه مى‌شد، مديران بخش‌هاى مربوط او را توبيخ مى‌كردند.

درواقع اين‌كاركنان IT همواره تحت سلطه‌ى رفتار پرخاش‌گرانه‌ى مديرانى بودند كه الگوى طبيعى رفتار آن‌ها فرياد كشيدن، درخواست‌هاى غير منطقى و بى‌علاقگى به مشكلات مردم بوده‌ است.

به كاركنان IT اين‌طور آموزش داده شد كه مديران ادارى ”درون‌گراهاى فعال“ (افرادى كه مطابق ويژگى‌هاى شخصيتى خود رفتار مى‌كنند) هستند و به اين ترتيب سو تفاهم‌ها برطرف شد.

به‌ اين صورت كه، آن‌ها ديگر اين رفتارهاى منفى را شخصى تلقى نمى‌كردند و با وجود بى‌علاقگى به درون‌گراهاى فعال به آن‌ها احترام مى‌گذاشتند.

از آن‌جا كه درون‌گراهاى فعال افرادى به طور ذاتى موفق هستند، مى‌خواهند وظايف شغلى خود را به بهترين نحو انجام دهند. بنابراين نيازى نيست چندان به نظرات آن‌ها توجه شود.

ايجاد تغييرات نبايد تنها برعهده‌ى مديريت IT باشد. مى‌توانيم با دادن اطلاعاتى به كاركنان غير IT درباره‌ى رفتارهاى خاص كاركنان IT، روابط بين اين دو گروه را بهبود بخشيم.

اغلب كاركنان IT را مى‌توان به‌عنوان يك عامل بازدارنده (آن‌ها تمايلى به فعاليت‌هاى عجولانه و شتاب‌زده ندارند)، كند (آن‌ها محتاط و دقيق هستند) و هم‌چنين انعطاف‌ناپذير (اين افراد نمى‌خواهند قوانين و دستورالعمل‌هاى كارى را ناديده بگيرند) درنظر گرفت.

شناخت چگونگى عمل‌كرد كاركنان‌ IT مى‌تواند به تغيير رفتارها در اين زمينه كمك كند. اين مساله به‌نوبه‌ى خود عكس‌العمل‌هاى مديريت را تحت تاثير قرار مى‌دهد. اگر مديران، كاركنان IT را از تصميم‌هاى خود مطلع كنند، مقدمات توسعه‌ى توليدات را فراهم مى‌كنند.

زيرا كاركنان IT به تحقيق روى يك موضوع علاقه دارند و آن موضوع را از تمام زوايا مى‌سنجند. آن‌ها از تصميمات شتاب‌زده بيزارند.

ايجاد همكارى به‌جاى مخالفت مهم‌ترين گام براى افزايش بازدهى IT است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 3 اسفندماه 1383

05:40 PM

February 21, 2005

TCP/IP عرضه کننده‌ی توانایی‌های روبه رشد شبکه‌ای

نويسنده : نیک لانگلی
مترجم : نازنين كي‌نژاد
ناشر : همكاران سيستم

TCP/IP چیست؟

TCP/IP استاندارد شبکهی جهانی برای اینترنت است و از همان ابتدا به جای استفاده از وسایل مخصوص، برای ایجاد و تنظیم ارتباط بین شبکهای به کار میرفت.

در اوایل دههی 70 تیم طراح TCP/IP اهداف خود را به این شکل مشخص کرد: "ارتباطات بین شبکهای شامل دو بخش اصلی میشود: انتقال سریع پیام و کنترل همهجانبهی مکالمات."

TCP/IP نام خود را از دو تفاهمنامهی بااهمیت (تفاهمنامهی کنترل انتقال Transmission Control Protocol و تفاهمنامهی اینترنت Internet Protocol) وام گرفتهاست. TCP/IP در واقع مجموعهای از تفاهمنامههای مختلف مانند HTTP و FTP است که در حوزههای دیگر دارای اهمیت هستند. TCP/IP برای مصرفکنندگان واقعی مناسب و بیدردسر است.

آغاز TCP/IP

TCP/IP به پروژهی وزارت دفاع آمریکا (برای اطمینان از تداوم ارتباطات نظامی پس از حملهی هستهای) مربوط میشود.

وزارت دفاع آمریکا از دانشگاه استانفورد و مسوولان تفاهمنامه برای گسترش این طرح حمایت خود را اعلام کردند. به این ترتیب TCP/IP قبل از ورود به بازار عمومی با یونیکس BSD ، به یک استاندارد نظامی تبدیل شد.

TCP/IP برای اهداف آموزشی با نسخهی 4 (این نسخه هنوز هم متداول است) به بازار آمد. برای کسب اطلاعات بیشتر میتوانید به این آدرس مراجعه کنید:

www.cs.utexas.edu/users/chris/think/Early_Days_Of_TCP/Introduction

موارد استفادهی TCP/IP

IP به لایهی 3 مدل شبکهای OSI (که به تحویل، تجزیه و دوباره سوارکردن قطعات میپردازد) مربوط است. TCP (در لایهی چهارم، لایه انتقال) ارتباطات بین دستگاهها را بررسی میکند.

هر دستگاه کاربرد خاصی دارد و به دلیل آنکه TCP/IP در سطوح متوسط به بالای مدل OSI مورد استفاده قرار میگیرد، ویژگیهای شبکهی زیربنایی اهمیت چندانی ندارد.

خدمات TCP/IPاز يك مدل مشتری- سرور استفاده میکنند که در این مدل میزبان، دادهها و اطلاعات را در ازای تقاضای مشتریان، مانند مرورگرهای وب فراهم میکند.

ویژگیهای بارز TCP/IP

TCP/IP از استانداردهای نامحدود و غیر اختصاصی استفاده میکند و میتواند هر نوع فناوری شبکهای، عمومی یا خصوصی، LAN( local area network)، WAN( Wide area net work) یا بدون سیم ارتباط برقرار کند. با وجود پیش‌رفتهای روزافزون فناوری ارتباطات اینترنتی کنونی به طور كامل به الگوهای سال 1970 شباهت دارند.

چگونه میتوانیم کار با TCP/IP را یاد بگیریم.

فقط یک روز برای آموختن دستورالعملها وقت لازم است و میتوانید در کمتر از 3 روز آموزشهای عملی مربوط را تکمیل کنید.

موارد استفادهی TCP/IP

در انتقال دادهها و شبکههای صوتی

TCP/IP در چه سیستمی اجرا میشود؟

به طور تقريبي در تمام شبکههای گسترده، بدون سیم و محلی (بدون توجه به تامینکننده)

عدهی کمی از مردم میدانند:

TCP/IP به دلیل ویژگیهای ياد شده پدیدهای بدون مرز نام گرفته است. مسیر طی شده توسط هر پیام با مسیر پیامهای دیگر فرستاده شده از دو دستگاه مشابه ارتباطی ندارد.

چه تحولاتی در این زمینه در جریان است؟

نسخهی شمارهی 6 IP تحت عنوان آیندهی اینترنت به بازار معرفی شده است.

قیمت TCP/IP

حقوق افراد با مهارتهای TCP/IP به دلیل تنوع حوزهی فعالیت، بسیار متفاوت است و انتظار میرود در آیندهای نزدیک این میزان به بیشترین حد در محدودهی شغلهای مشابه برسد.

آموزش

آموزشهای مورد نظر را میتوانید از تامینکنندگان تجهیزات شبکه و آموزشگاههای مستقل فرابگیرید. دوره‌های آموزشی وب در این زمینه، قدیمی اما قابل استفاده هستند. میتوانید به این آدرسها مراجعه کنید:

www.tcpipguide.com

www.w3schools.com/tcpip/default.asp

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 4 اسفندماه 1383

05:44 PM

February 22, 2005

استفاده از پنج محرك خريد براى افزايش فروش

نويسنده: باب ليداک (CIO.com)
مترجم: بهاره عابدين
ناشر: همکاران سیستم

به منظور فروش هر چه بيش‌تر و به دست آوردن نتايج فورى بدون افزايش هزينهها، در آگهى‌هاى خود، صفحات وب و ديگر پيام‌هاى فروش از اين 5 روش استفاده كنيد.

چه‌گونه مى‌توان به بازارى مستعد براى برداشت‌هاى مالى چشم‌گير دست يافت؟

1- مزايا را ملموس کنيد

مردم با توجه به اعتمادى که يك محصول در آن‌ها به وجود مى‌آورد، آن محصول يا خدمت را مى‌خرند. اين موضوع را به هنگام تهيه‌ى آگهى‌هاى خود، صفحات وب و ديگر ابزارهاى فروش، در نظر داشته باشيد.

براى بزرگ‌نمايى احساس خوبى که مشترى پس از استفاده از محصول شما تجربه خواهد کرد، از کلمات واضح و روشن استفاده کنيد.

2- احساس نياز را بزرگ جلوه دهيد

پس از ارايه‌ى تصور خود از آن‌چه که مشترى با استفاده از محصول يا خدمت شما به دست خواهد آورد، آن‌چه را که وى در صورت نخريدن محصول شما از دست خواهد داد، يادآورى کنيد.

مردم اغلب با احساس نياز بيش‌تر، تمايل بيش‌ترى براى به دست آوردن پيدا مى‌کنند. با يادآورى آن‌چه مشترى در صورت نخريدن محصول شما از دست مى‌دهد، تقاضاى فروش را تقويت کنيد. براى مثال با چنين تبليغى، آگهى شما تاثيرگذارتر مى‌شود:

"شما که هر ماه براى پرداخت صورت‌حساب‌هاى‌تان تلاش مى‌کنيد، سعى کنيد براى رييستان ارزش افزوده ايجاد کنيد."

3- گزينه‌هاى توليد را کاهش دهيد

در هر آگهى، تنها يک محصول يا يک خدمت را تبليغ کنيد. بيش‌تر مردم براى انتخاب يک گزينه دچار مشکل ميشوند. به ويژه زمانى‌که تصميم به خريد يک محصول يا خدمت، سبب شود که از خريد محصول يا خدمت ديگر منصرف شوند يا آن را به تعويق اندارند. آن‌ها به طور معمول وقتى با چنين مشکلى روبه‌رو مى‌شوند، تصميمى نمى‌گيرند و بدين ترتيب شما فروش خود را از دست مى‌دهيد.

هم‌چنين، چند محصول يا خدمت را در يک بسته و با يک قيمت، قرار دهيد، تا با اين کار مشکل تصميم‌گيرى براى خريد گزينه‌هاى جداگانه را حذف كنيد و فروش خود را افزايش دهيد. بدين ترتيب گزينه‌هاى تصميم‌گيرى خريد به "آرى" يا "خير" محدود مى‌شوند.

4- گزينه‌هاى خريد را بيش‌تر کنيد

تعيين كنيد چه گزينه‌هايى از خريد، فروش شما را افزايش و کدام گزينه‌ها فروش را کاهش مى‌دهند. افزون بر اين، راه‌هاى گوناگونى را که براى خريد مشتريان از شما وجود دارد، مشخص سازيد.

ممكن است استفاده از روش‌هاى مشابه براى افراد گوناگون مناسب نباشد. اگر براى مشتريان بالقوه راه مطلوب و آسانى براى سفارش دادن وجود داشته باشد، آن‌ها به سرعت وارد عمل خواهند شد. براى مثال بسيارى از بازارياب‌هاى برخط، فقط سفارش‌هاى آنلاين را قبول مى‌کنند، در حالى‌که مى‌توانند با افزايش راه‌هاى سفارش كالا يا خدمات براى مشترى مانند تلفن، فکس و نامه پستى، فروش خود را به راحتى افزايش دهند.

5- روش‌‌هاى خريد را ساده کنيد

اگرخريد را براى مشترى ساده کنيد، فروش بيش‌ترى خواهيد داشت. بنابراين سعى کنيد راه‌هايى پيدا کنيد که خريد را ساده‌تر و سريع‌تر مى‌کنند. براى مثال بسيارى از بازارياب‌هاى اينترنتى، حتا زمانى‌ که سفارش، تنها شامل يک يا دو گزينه مى‌شود، از کارت‌هاى خريد براى فرآيند سفارش استفاده مى‌کنند.

مشترى را به تحمل فرآيندهاى پيچيده‌ى کارت‌هاى خريد، آن هم فقط براى خريد يک مورد، مجبور نکنيد. چرا که برخى از مشتريان به همين دليل خريد را رها خواهند کرد.

وقتى تنها يک يا دو گزينه براى سفارش خريد وجود دارد، از يک فرم خريد آنلاين ساده به جاى کارت خريد استفاده کنيد. با اين کار فروش شما افزايش مييابد.

هر کدام از اين عوامل ميتواند فروش شما را افزايش دهد. پس از هم اکنون در آگهى‌هاى خود، صفحات وب و ديگر پيام‌هاى فروش از آ‌ها استفاده کنيد. اين عوامل محرك بدون افزايش هزينهها نتايجى فورى به دنبال خواهند داشت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 9 اسفندماه 1383

03:40 PM

February 27, 2005

برآورد اندازه‌ى پروژه‌هاى نرم‌افزارى

نويسنده: بيتا باقرى
ناشر: همکاران سیستم

اين مقاله به طور عمده از كتاب - IT Project Estimation-A Practical Guide to the Costing of Software اقتباس شده است و سعى بر ارائه كلياتى از تجربه و توصيه يك برآورد كننده حرفه اى، دارد.

صنعت نرم‌افزار در سال‌هاى اخير شكوفايى قابل توجهى داشته و به سمت "دست‌يابى" روش‌مند به اهداف و "مهندسى" در حركت بوده است. مديريت پروژه‌هاى نرم‌افزارى و محيطى كه اين پروژه‌ها در آن اجرا مى‌شوند، نيازمند دانش مجرد است؛ حقايقى كه از طريق مشاهده و اندازه‌گيرى به دست مى‌آيند.Tom DeMarco در اين باره مى‌گويد: "آن‌چه را كه قابل اندازه‌گيرى نيست، نمى‌توان كنترل و مديريت كرد."

برآورد اندازه‌ى پروژه به 3 دليل عمده، ضرورى به نظر مى‌رسد:

1- به منظور تعديل پروژه: مقايسه‌ى هزينه و سود پروژه و ارزيابى‌هاى "اگر –آن‌گاهى" براى انتخاب بين گزينه‌هاى كاركردى، محيطى و تكنيكى مختلف.

2- به عنوان بخش جدا نشدنى نظم مهندسى نرم‌افزار. در پروژه‌هاى توليد نرم‌افزار بر خلاف ساير پروژه‌ها (براى مثال پروژه‌هاى ساختمانى) در هر زمان از كار ممكن است كه اجزاى بنيادين پروژه تغيير كند، در نتيجه بايد روشى براى كنترل اين تغييرات و اثرات آن‌ها وجود داشته باشد. به گونه‌اى كه در نهايت اين تغييرات به شكست پروژه منجر نشوند.

3- بهبود فرآيندهاى توليد نرم‌افزار و ارزيابى تاثيرهاى بهبود فرآيند بر كيفيت محصول.

آيا پروژه‌هاى نرم‌افزارى، مشابه ساير پروژه‌ها قابل تخمين هستند؟

مطابق نظر [1]Paul Coombs دوازده قانون كور ولى بديهى در تخمين وجود دارد، اولين و مهم‌ترين اين قانون‌ها، به شرح زير است:

قانون 1: تخمين‌هاى شما اشتباه خواهند بود.

چه‌گونه مى‌تواند غير از اين باشد وقتى شما قرار است آينده را پيش‌گويى كنيد! به ويژه در پروژه‌هاى نرم‌افزارى كه عوامل تاثيرگذار بر آن‌ها بسيار زياد است. بنابراين مديران، مشتريان يا كارفرمايان هرگز نبايد انتظار داشته باشند كه تمام برآوردها دقيق و بى‌نقص باشند.

اما مى‌توان با واقع‌بينى در كار احتمال اشتباه در برآوردها را به حداقل رساند. هرگز نبايد در برآوردها بسيار بدبين يا بسيار خوش‌بين بود. يادآورى اين نكته ضرورى است كه هر دونوع تخمين خوش‌بينانه (Under Estimation) و بدبينانه (Over Estimation) معايبى مانند دست‌ نيافتن به بازار (در حالت بدبينانه) و از دست دادن بازار (در حالت خوش بينانه) را به همراه دارند كه در در بازار رقابتى پذيرفته نيست.

چه كسى بايد تخمين را انجام دهد؟

در بهترين حالت كسى بايد تخمين فعاليت‌هاى پروژه را انجام دهد كه خود مجرى آن‌هاست. به عبارت ديگر بهترين برآورد را كسى انجام مى‌دهد كه درباره‌ى چه‌گونگى انجام كار اطلاعات كامل و يا در انجام كار مشابه سابقه داشته باشد، بنابراين تعيين و آموزش شخصى به عنوان تخمين‌زننده‌ى حرفه‌اى در بلند مدت موثر نخواهد بود؛ زيرا اين شخص به تدريج با دور شدن از روند اجراى كار، قابليت‌هاى فنى خود را در تخمين از دست خواهد داد.

از اين رو بهترين تخمين‌زننده‌ى فعاليت‌هاى يك پروژه‌ى نرم‌افزارى مدير يا مدير فنى پروژه خواهد بود. از سوى ديگر، يك مسوول تمام‌وقت براى ارزيابى تخمين‌ها و تعديل آن‌ها لازم است. تا از يك سو با كنترل برآوردهاى كنونى پروژه را در مسير درست خود هدايت كند و از سوى ديگر با مستند سازى و نگه‌دارى برآوردها، اطلاعات تاريخچه‌اى معتبرى براى تخمين‌هاى بعدى فراهم كند. مسووليت اين شخص كنترل اعتبار تخمين‌هاى انجام شده، كنترل يكپارچگى و هماهنگى اين تخمين‌ها با تخمين‌هاى بعدى و قبلى و تامين اطلاعات تاريخچه‌اى معتبر براى تخمين‌هاى بعدى است.

بهترين زمان براى تخمين پروژه چه موقعى است؟

دومين قانون تخمين به اين سوال پاسخ خواهد داد:

قانون 2: اندازه‌ى پروژه در هر زمان قابل تخمين است.

درست است كه در ابتداى پروژه بسيارى مسايل مانند هدف پروژه، نيازمندى‌هاى غير كاركردى مورد نظر، Platform مورد نظر، روش مورد استفاده، زبان برنامه نويسى ،تعداد آزمايش‌هاى لازم و ... مشخص و شفاف نيستند اما همواره عددى قابل ارايه است و به تدريج به دقت اين عدد اضافه خواهد شد.

تكنيك‌هاى تخمين:

به چهار روش مى‌توان تخمين را انجام داد:

1- قضاوت افراد با تجربه: استفاده از افراد خبره در ارايه‌ى تخمين فعاليت‌ها.

2- مقايسه: مقايسه پروژه‌ى مورد نظر با ساير پروژه‌هاى مشابه.

3- پايين به بالا: شكستن كار به اجزاى كوچك‌تر، تخمين هريك از اجزا و سپس جمع زدن تخمين‌ها با هم.

4- محاسبه رياضى: استفاده از مدل‌هاى محاسباتى براى به دست آوردن برآورد اندازه‌ى كار. در اين روش مقاديرى كه نشان دهنده‌ى ويژگى‌هاى پروژه هستند، در معادلاتى وارد مى‌شوند كه نتيجه‌ى اين معادلات تخمين اندازه پروژه در قالب زمان يا هزينه است.

نكته مهم استفاده از ضرايب تعديل در تخمين‌هاست. هر تخمينى از دو بخش تشكيل شده است؛ عدد پايه و ضريب تعديل. براى مثال تخمين پايه‌ى 20 روز و ضريب تعديل 50% براى يك فعاليت؛ به اين معناست كه اين فعاليت دست پايين (در بهترين حالت) در مدت 20 روز انجام خواهد شد و بيش‌ترين زمان لازم براى انجام آن 30 روز خواهد بود. مقوله‌ى "ريسك" در ضريب تعديل لحاظ خواهد شد، نه در عدد پايه. به عبارت ديگر يكى از عوامل موثر در تعريف ضريب تعديل، ريسك‌هاى اجراست.

قانون 3: هر تخمينى بايد ضريب تعديل داشته باشد.

به طور منطقى در هر تخمين بايد گام‌هاى زير پيموده شود:

1- تهيه فهرستى از فعاليت‌هايى كه بايد تخمين زده شوند.

2- تخمين هر يك از فعاليت‌هاى فهرست‌بندى شده.

3- جمع كردن تمام آن تخمين‌ها.

4- اضافه كردن ضريب تعديل.

براى انجام تخمين درست ابتدا بايد مواردى كه نيازمند تخمين هستند مشخص و تعريف شوند. ريسك تخمين نه فقط اشكال در محاسبه تخمين است بلكه در اكثر مواقع اشكال در تخمين به علت فراموش كردن تخمين بعضى فعاليت ها يا ريسك هاست. بنابراين:

قانون 4: تهيه‌ى فهرستى از اقلام نيازمند تخمين به مراتب مشكل‌تر از تخمين آن‌هاست.

اقلام نيازمند تخمين مى‌توانند نرم‌افزار، مديريت پروژه، مديريت فنى، سخت‌افزار، گواهى‌نامه‌ها و پيمان‌كاران يا به عبارت ديگر تمام عوامل هزينه‌ى سيستم باشند. بنابراين آشنايى با پروژه اهميت زيادى دارد.

قانون 5:كيفيت تخمين به آشنايى با پروژه مورد نظر وابستگى زيادى دارد.

قانون6: هر چه‌قدر جزييات اقلام نيازمند تخمين را بيش‌تر كنيد، ديرتر به عدد مشخص تخمين مى‌رسيد.

اقلام نيازمند تخمين بايد تا سطح معنادارى شكسته شوند. نه آن‌قدر جزيى باشند كه براى تخمين به زمان زيادى نياز داشته باشند و نه آن‌قدر كلى كه دقت تخمين را كاهش دهند.

بعضى فعاليت‌هاى پشتيبانى كه به طور مستقيم در توليد وارد نمى‌شوند، در حالت عادى فراموش مى‌شوند و بايد در اين باره بسيار دقت كرد.

پس از تهيه‌ى فهرست اقلام نيازمند تخمين نوبت انجام تخمين است. براى انجام عمل تخمين ابتدا:

قانون 7: مفروضات خود را ثبت كنيد.

با نوشتن مفروضات لحاظ شده، دقت و شرايط تخمين معلوم مى‌شود. مفروضات مى‌توانند به دسته‌اى خاص از فعاليت‌ها مربوط و يا در كل پروژه حاكم باشند، مانند دست‌رسى به منابع در زمان‌هاى مشخص يا ثبات نيازمندى‌هاى مورد نظر پروژه.

حال بايد ريسك‌هاى پروژه هم تعريف شوند تا بتوان ضريب تعديل را تعريف كرد.

قانون 8: ضريب تخمين به صورت نسبتى با استفاده از ريسك‌ها تعريف مى‌شود.

اكنون تخمين اقلامى كه به همراه مفروضات و ريسك‌ها به دقت شناسايى و فهرست شده‌اند، امكان‌پذير است. به خاطر داشتن اين نكته بسيار ضرورى است كه:

قانون 9: هيچ روش كامل و جامعى وجود ندارد.

اگر روش كاملى وجود داشت، همه از آن استفاده مى‌كردند، همه‌ى پروژه‌ها به موقع انجام مى‌شدند و به مباحث پيچيده نيازى نبود. تمام روش‌هاى موجود، به تخمين زننده‌ها كمك مى‌كنند تا نسبت به تخمين‌هاى خود اعتماد بيش‌ترى داشته باشند.

يك روش متداول، تخمين براساس احساس تخمين‌زننده است. در اين حالت از هيچ مدل رياضى استفاده نمى‌شود و تخمين‌زننده براساس فاكتورهايى مانند اندازه‌ى فعاليت، پيچيدگى فعاليت، ميزان آشنايى با فعاليت مورد نظر و كل پروژه، مهارت‌ها و دانش تيم انجام دهنده‌ى كار و ... عمل تخمين را انجام مى‌دهد.

تخمين براساس يك فعاليت پايه‌ى روش ديگر تخمين است. در اين روش زمانى مشخص براى نوع خاصى از فعاليت در نظر گرفته مى‌شود و تخمين اندازه‌ى ساير فعاليت‌ها در مقايسه با آن فعاليت تعريف مى‌شود.

براى تخمين اندازه‌ى پروژه مى‌توان از مدل‌هاى محاسباتى مانند Function Point Analysis ,COCOMO و ابزارهايى كه بر پايه‌ى اين روش‌ها تهيه شده‌اند، استفاده كرد.

مرحله‌ى بعدى تخمين مدت زمان يا طول پروژه و به عبارت ديگر برنامه‌ريزى پروژه است.

قانون 10: طول پروژه به ماه بايد بزرگ‌تر از متوسط تعداد افراد تيم باشد.

براساس تخمين هر يك از فعاليت‌ها و به همراه ساير تكنيك‌هاى برنامه‌ريزى، پروژه‌ى زمان‌بندى پروژه تهيه مى‌شود.

قبل از ارسال تخمين‌ها براى مرور، بايد يكپارچگى و هم‌خوانى آن‌ها با يكديگر دوباره كنترل و از درستى آن‌ها اطمينان حاصل شود.

قانون 11: كسى غير از تخمين‌زننده‌ى اول بايد تخمين‌ها را مرور كند.

اگر براى مرور شخص ديگرى با مسووليت مستقل وجود ندارد، بايد ريسكى به ساير ريسك‌ها اضافه شود.

در نهايت پس از اجراى پروژه بايد تخمين‌ها نگه‌دارى شوند تا در تحليل‌هاى بعدى مورد استفاده قرار گيرند.

قانون 12: اطلاعات پروژه‌ى خاتمه يافته بايد نگه‌دارى شوند.

به عبارت ديگر گزارش انجام يك پروژه مى‌تواند راه‌گشاى اجراى پروژه‌هاى بعدى باشد.

[1] - IT Project Estimation-A practical Guide to the Costing of Software

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 10 اسفندماه 1383

12:51 PM

February 28, 2005

براي بالا بردن ارزش فعاليت‌هاي IT بايد مانند يک مدير اجرايي بينديشيد

نويسنده : ديويد تيلر ( www.ComputerWeekly.com )
مترجم : نازنين كي‌نژاد
ناشر : همكاران سيستم

ديويد تيلر، نويسندهي کتاب پرفروش مديريت "رهبري آشکار"، فرصتها و چالشهاي مديران IT را در حوزهي فعاليت آن‌ها مطرح کردهاست. او در چهار مقاله مصاحبههاي خود را با بيش از 300 مدير IT (شامل راهکارهايي سودمند براي موفقيت بخش IT) منتشر کردهاست.

موضوع اين مقاله بحث تازهاي نيست: "پروژههايي با هزينهاي بيشتر از بودجه‌ي برآوردشده"، "نياز به ايجاد هماهنگيهاي شغلي"، "ارتباط با مشتريان"، "مهارتها و قابليت تغييرپذيري و هماهنگي با تغييرات". البته با صحبت کردن دربارهي سرعت تغييرات احتمالي کاري از پيش نميبريم.

دربارهي اين مسايل به طور مفصل با بيشتر مديران ارشد اجرايي صحبت کردهام. بايد اقرار کنم که فناوري نوين در حل بسياري از مشکلات سازمانها موثر بوده است، با اين حال 80 درصد اين افراد از صرف هزينه‌هاي بينتيجه در اين زمينه ناراصي بوده‌اند.

من تا حد زيادي منظور اين افراد را درک ميکنم:

· آيا سيستم مديريت نوين به راستي برمبناي آگاهي و توزيع ارزشها تنظيم شده‌است؟

· آيا بايگاني و کنترل دادهها به درستي صورت ميگيرد؟

· آيا مديريت ارتباط با مشتري در سازمانها نهادينه شده است؟

خبر ارتقاي يکي از مديران اجرايي به عضويت در هيات مديره به واقع مرا شگفت‌زده کرده است.

البته در برخي مواقع هنوز هم جاي اميدواري وجود دارد. براي مثال يکي از اين مديران اجرايي در جايي گفته است: "من براي بهبود فعاليتهاي شرکت به يک مدير IT نياز دارم. زيرا به نقش فناوري مطلوب در بهبود روابط با مشتريان شرکت آگاه هستم. مديران IT ميتوانند با درايت شرکت را در مسير درست آن هدايت کنند."

افراد با پاسخ به پرسش زير مسير حركت خود را مشخص مي‌كنند:

آيا هدف شما ساختن آينده‌اي پربار و سودمند است يا اين‌كه فقط قصد تكرار گذشته‌ي ناموفق مديريت را داريد؟ به قول معروف "هر كه باد بكارد، توفان درو خواهدكرد."

مطابق تحقيقاتي كه انجام داده‌ام، يا بايد ديدگاه‌هاي مديران اجرايي را تغيير دهم يا اين‌كه اين انديشه‌ها را با صداي بلند براي خودشان تكرار كنم. ناگزير روش دوم را انتخاب مي‌كنم، به اين اميد كه هر چه زودتر براي ايجاد تغييرات اقدام كنيد.

هفت ويژگي مورد نياز مشاوران IT

رييس هيات مديره درخواست‌هاي خود را از مدير مالي، بدون توجه به اولويت آن‌ها مطرح مي‌كند.

زبان ارتباطي

با زباني روان و صريح صحبت كنيد.

از خود يك قهرمان بسازيد.

در محيط كار انساني كامل باشيد. هيچ‌گاه نقش يك قرباني را بازي نكنيد‏، به عبارت ديگر از خود ضعف نشان ندهيد. فراموش نكنيد افراد در صورتي در كنار شما باقي مي‌مانند كه شايستگي اعتماد كردن را داشته باشيد.

شخصيتي قوي در محيط كار براي خود طراحي كنيد.

همه‌ي ما روي كاغذ و در تفكرات خود (به معناي واقعي) افرادي موفق و خوب هستيم، اما شما بايد اين خصوصيات را به زيردستان خود اثبات كنيد. همواره دو مساله را در نظر داشته باشيد: "تعداد افرادي كه شما را مي‌شناسند و ميزان محبوبيت شما نزد اين افراد."

تاثير وتشويق

دنيا را از دريچه‌ي ديد مشتري ببينيد و خواهش مي‌كنم هيچ‌گاه من مشتري را "مصرف‌كننده" نناميد. تنها يك صنعت ديگر در دنياست كه از اين عبارت استفاده مي‌كند: "قاچاق مواد مخدر."

قوه‌ي ادراك

شما بايد از همان ابتدا با رفتار خود مسير انديشه‌ي افراد را هدايت كنيد. قوه‌ي ادراك، پايه و زيربناي تمام فعاليت‌هاي شماست. بنابراين توصيه مي‌كنم بناي كار را بر ايجاد ارتباط مثبت و اعتماد پايه‌گذاري كنيد.

رهبري

در اين مرحله نقش شما آگاه كردن ديگر مديران است.

فعاليت‌هاي شغلي

به ياد داشته باشيد هدف اصلي فعاليت شما قبل از هر چيز موفقيت شغلي است. اهميت كسب اعتبار در بازار را دريابيد. در حرفه‌ي خود همه‌فن‌حريف باشيد، خواهيد ديد كه موفقيت با چه سرعت بي‌پاياني به سوي شما سرازير مي‌شود. با اتكاي همه جانبه به فناوري مطمئن باشيد در نيمه‌ي راه متوقف خواهيد شد.

مشكلات IT از نظر مديران اجرايي

نكات ياد شده كليد مهارت، عملكرد و موفقيت شما هستند. با اجراي آن‌ها قوه‌ي ادراك، تفاهم و ارتباطات تيم شما افزايش مي‌يابد. مديران اجرايي چهار نكته‌ي مثبت و منفي را در حوزه‌ي IT در نظر مي‌گيرند. من اين نكات را با راه‌كارهاي مورد نظر خود بيان مي‌كنم.

نكات مثبت

· خود در قلب فعاليت‌هاي سازمان جاي دهيد. باور كنيد چندان كار سختي در پيش نداريد. از به كار بردن عبارت "شغل" در مورد افراد ديگر خودداري كنيد، فراموش نكنيد كه شغل و حرفه در وجود شما قرار گرفته است. اين جملات نظريه نيستند، با عمل به آن‌ها به نتيجه‌ي مطلوب دست پيدا خواهيد كرد. هرگونه رخنه و فاصله‌اي بين شما و شركت ناشي از عملكرد شما و تيم‌تان است. شما بايد فرد مورد اطمينان و بهترين دوست هيات مديره باشيد.

· به جاي افزودن به هزينه‌هاي شركت، يك مركز سوددهي باشيد. تمام فعاليت‌هاي شما بايد پروژه‌هاي سودمند شغلي باشد. در واقع تيم شما بايد بازگشت سرمايه را به شركت خود تضمين كند. پروژه‌هاي خود را اولويت‌بندي كنيد و سوددهي بيش‌تر را سرلوحه‌ي كارهاي خود قرار دهيد.

· اكنون شما در مركز توجه قرار داريد و بايد به اندازه‌ي كافي براي مشتريان واقعي قابل رويت باشيد. به اين ترتيب به يكي از اهداف IT جامه‌ي عمل مي‌پوشانيد. مديريت سايت شركت خود را به دست گرفته، از بازارياب‌هاي خبره‌ي اينترنتي IT استفاده كنيد.

· به جاي تمركز بر چيستي فناوري، فغاليت خود را بر چه‌گونگي آن متمركز كنيد. از شما مي‌خواهم در عين كمك به مشتريان كنوني خود، افراد جديدي را جذب كنيد. راه‌هاي موفقيت خود را در اختيار ديگران قرار ندهيد.

نكات منفي

· سرعت انجام پروژه‌ها بايد بيش‌تر از وضعيت كنوني باشد. بيش از پيش انعطاف‌پذير باشيد. بايد زمان به اتمام رساندن پروژه‌هاي خود را بهينه‌سازي كنيم. اكنون ديگر زمان اين پرسش” تا كي بايد اين كار را انجام دهد“ به پايان رسيده است. بايد بتوانيد زمان انجام برنامه‌هاي خود را به روز تقليل دهيد( توصيه مي‌كنم به ماه و هفته فكر نكنيد). به تامين‌كنندگان كدهاي خودكار اعتماد كنيد.

· تقاضاي بودجه‌ي خود را هرسال افزايش ندهيد، مگر آن‌كه دليل قانع‌كننده‌اي براي اين كار داشته باشيد. سعي كنيد به جاي افزايش هزينه‌ها، ارزش افزوده‌ي شركت را ارتقا دهيد. هيچ عذر و بهانه‌اي در اين مورد پذيرفته نخواهد بود.

· پاسخ منفي است(!) – اما سوال مربوط به اين پاسخ چيست؟ چرا هر بار پاسخ درخواست‌هاي من منفي است؟ همه چيز امكان دارد، پس با "پاسخ مثبت" آغاز كنيد. به دنبال راه‌حل‌هاي ديگري براي مشكلات موجود باشيد. كنترل امور را به دست بگيريد.

· هرگز ديگران به كم‌سوادي محكوم و آن‌ها را مورد تمسخر قرار ندهيد. از لغات قابل فهم براي عموم استفاده كنيد. شايد شما از طرح معما لذت مي‌بريد، اما من و ديگر مديران اجرايي هيچ جذابيتي در اين مساله نمي‌بينيم. به ياد داشته باشيد كه به كار بردن كلمات سخت دليل داشتن هوش زياد نيست. كلماتي استفاده كنيد كه براي والدين شما قابل درك باشد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 13 اسفندماه 1383

10:01 PM

March 03, 2005

نكته براى مقاله نويسى در www

نويسنده: Craig Lock
ناشر: eMarketingway.ir

نوشتن مقاله در وب، شما را در معرض ديدگان افراد بسيار زيادى قرار خواهد داد. به اين ترتيب با صرف كمترين هزينه ها معروفيت خود را تضمين مى كنيد. براى اين كار تنها نياز به صرف اندكى زمان و تلاش داريد. نوشتن مقاله در موضوعات دلخواه كار بسيار آسانى است و مراحل معينى دارد.

عده اى براى مجلات و سايت هاى خود به دنبال محتواى باارزش هستند و صدها نويسنده در انتظارند تا نوشته هاى خود را روى وب قرار دهند. در انتهاى هر مقاله بخشى براى معرفى نويسنده وجود دارد كه براى شما به عنوان يك تبليغات مجانى عمل مى كند.

مقالاتى كه حاوى اطلاعات باارزش هستند و دستورالعمل هاى خاص ارائه مى دهند، عموماً مورد استقبال قرار مى گيرند و خوانندگان فراوانى دارند. در اينجا چند نكته در مورد نوشتن مقاله در وب را يادآور مى شويم.

1-اين نكته را بپذيريد كه نوشتن مقاله در دنياى آن لاين با نوشتن مقالات چاپى تفاوت دارد. زيرا افراد عادت دارند كه هنگام خواندن مقالات وب تنها مطالب را مرور كنند. صفحه را به سرعت حركت مى دهند و تنها به دنبال نكات كليدى هستند.

2-به مخاطبين مورد نظر خود فكر كنيد و براى آنها مطلب بنويسيد.

3-براى مقاله خود يك عنوان جذاب انتخاب كنيد كه توجه افراد را سريعاً به خود معطوف كند و آنها را به خواندن مقاله مشتاق كند.

4-عنوان مقاله بايد كوتاه نگه داشته شود، اما در انتخاب تيترهاى داخلى آزادى بيشترى داريد. با دقت آنها را انتخاب كنيد تا در لحظه خواننده را جذب خود كنند.

5-در نوشتن مقاله دقت كنيد و حرفه اى عمل كنيد. در مورد موضوعاتى كه از آنها اطلاع كامل داريد، مطلب بنويسيد. هيچ مطلبى را به طور اتفاقى و بدون پشتوانه علمى در مقالات خود نياوريد.

6-پاراگراف هاى مقاله بايد كوتاه باشند.

7-مقدمه چينى نكنيد و به سرعت به نكته اصلى نزديك شويد.

8-روى اطلاعات باارزش براى مخاطبين خود تكيه كنيد.

9-اصل اختصار را رعايت كنيد. اکثر مردم مايلند به سرعت اطلاعات را دريافت كنند و معمولاً زمان محدودى دارند.

10-در نوشته خود از كلمات اضافه يا هم معنا استفاده نكنيد و مقاله را در حد 1500 كلمه نگه داريد. اكثر اشخاصى كه مقالات عالى را براى قرار دادن در سايت خود خريدارى مى كنند، طرفدار مقالات بين 500 تا 2000 كلمه هستند. به صورت اجمالى سخن بگوئيد. اختصار نشاندهنده باارزش بودن نوشته است.

11-در متن مقاله از علامت تعجب(!) براى جلب توجه خواننده به بخش هاى خاص استفاده كنيد.

12-از تظاهر پرهيز كنيد. خودتان باشيد تا مقاله شما واقعى به نظر برسد.

13-از نكات طنزآميز استفاده كنيد. مردم حتى وقتى در حال دريافت اطلاعات در مورد مسائل كاملاً جدى هستند، مايلند استراحت كوتاهى داشته باشند و قدرى بخندند.

14-از درون خود براى نوشتن كمك بگيريد. سخنان بى تكلف بيشتر به دل مى نشيند. تنها كافيست كه جملات را مرتب و به هم متصل كنيد.

15-راستگو و امين باشيد و از مطالب ديگران در مقاله خود استفاده نكنيد. اين كار نوعى دزدى است. پس خودتان براى نوشتن مطالب تلاش كنيد و اگر از سخنان يا ايده هاى شخص يا مقاله ديگرى استفاده كرديد، حتماً نام او را در كنار مطلب آورده شده، ذكر كنيد و از او تشكر كنيد.

16-متواضع باشيد و تصور نكنيد كه خوانندگان در سطحى پايين تر از شما قرار دارند.

17-از شماره گذارى و بخش بندى در مقاله خود براى مرتب كردن مطالب استفاده كنيد. به اين ترتيب دنبال كردن مطلب براى خواننده ساده تر خواهد بود.

18-اطلاعات شخصى خود را در انتهاى مقاله قرار دهيد. مطمئن شويد كه اين اطلاعات براى دسترسى آسان به شما كافى هستند. اين بخش يك تبليغات مجانى براى شما خواهد بود.

19-در انتهاى مقاله پيشنهادى را براى خوانندگان در نظر بگيريد مثل ارسال مطلبى خاص به آدرس پست الكترونيك آنها. به اين ترتيب ليستى از افراد علاقه مند را خواهيد داشت كه بعدها مى توانيد در بخش بازاريابى خود از آنها استفاده كنيد.

20-قبل از قرار دادن مقاله روى وب تمام لينك هاى موجود در آن را چك كنيد.

21-مقاله خود را از طريق سيستم هاى پاسخگوى خودكار (Auto Responders) منتشر كنيد.

22-مقاله را با يك جمله يا پيام تاثيرگذار به اتمام برسانيد. آخرين جمله و پاراگراف شما بايد خلاصه اى از تمام مقاله باشد و به نحوى خواننده را تشويق كند كه از همين حالا نكات گفته شده را اجرا كند.

23-نهايتاً مقاله خود را دوباره چك كنيد تا كلمات ناهماهنگ يا اشتباهات املايى در آن وجود نداشته باشد. در واقع شما ويراستار مقاله خود هستيد.

24-مطمئن شويد كه مقاله روند و جريان مناسبى دارد و مطالب به هم پيوسته و مرتب قرار گرفته اند.

25-دوباره خوانى و دوباره خوانى تا جايى كه مطمئن شويد كه همه چيز درست است.

براى نوشتن مقاله "بهترين ها را انجام دهيد و منتظر عالى ترين ها باشيد."

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

12:51 AM

March 07, 2005

آنارشي و اينترنت

اينترنت بيشتر از آنارشي سياسي، آنارشي اخلاقي را ترويج مي كند و اين كه آنارشي اخلاقي ذاتاً ويرانگر است پيامد منطقي چنين وضعيتي فروپاشي اخلاقي است و نه يگانگي اخلاقي اين فروپاشي به معناي بد كلمه آنارشيستي است، چرا كه وسيله براي انتشار يافتن و به هم پيوستن ترجيحات خودساخته اي از هر نوع است

گوردون گراهام
علي ملائكه
كلمة آنارشي (aarchy) به دو طريق معنا مي شود، يك معناي مثبت و يك معناي منفي آنارشي در كاربرد مثبت آن، شيوه اي كه آنارشيست هاي مشهوري چون پرودون و كروپتكين آن را به كار مي بردند، به معناي فقدان دولت و به اين دليل به معناي آزادي از قدرت قهري دولت است كاربرد منفي و رايج تر آنارشي نيز بيانگر فقدان دولت است، اما دقيقاً به همين دليل، به صورت شرايطي از بي قانوني و آشوب تصور مي شود به طور خلاصه آنارشي- جامعه بدون دولت- را مي توان به صورت يك آرمان يا يك خطر تلقي كرد
در واقع استدلال ها به نفع آنارشي به عنوان يك آرمان هرگز در نظريه سياسي جدي گرفته نشده است، چرا كه عموماً تصور مي شود كه اين آرمان به طور بديهي غيرواقع گرايانه است با اين وجود است كه مي توان اين سخن را به نفع آن بيان كرد: قدرتمندترين ابزار مصيبت انساني، چه در دوران گذشته و چه در دوران مدرن، دولت بوده است هيچ جماعت جنايتكاري تا به حال حتي به به وجود آوردنِ آن درجه اي از وحشت و رنج نزديك نشده است كه به ميانجيگري دولت هاي تحت تسلط استالين، هيتلر، مائو يا پل پوت امكان پذير شد آيا حقيقت دارد كه جوامع بدون دولت بدتر از اين جوامع هستند؟
مخالفان آنارشي، آنهايي كه اين كلمه را به معناي منفي به كار مي برند، ممكن است پاسخ دهند كه ما نبايد در مورد موهبت هاي دولت بر مبناي بدترين نمونه هاي آن قضاوت كنيم آنها همچنين ممكن است بپذيرند كه دولت واقعاً نامطلوب است، اما مجادله كنند كه دولت شري ضروري است، به همان طريقي كه براي مثال يك عمل جراحي كسترده شري ضروري است اين طرح استدلال آشنا را به طرزي عالي مي توان در افكار «تامس هابز» يافت ايده اين است كه دولت، كه به صورت قدرت انحصاريِ اجبار مشروع تعريف مي شود، ضروري است تا از جنگ همه عليه همه جلوگيري كند، عدالت را به اجرا درآورد و از بي گناهان و آسيب پذيران محافضت به عمل آورد
آنارشيت هاي مثبت به نوبه خود ممكن است پاسخ دهند كه اين مدعا نوعي مصادره به مطلوب كردن است حقيقت اين است كه دستگاه دولت، مقصود نظري اش هرچه كه باشد، ممكن است براي دست يازيدن به ظلم و بهره كشي از بي گناهان و آسيب پذيران مورد استفاده قرار گيرد هنگامي كه چنين وصفي رخ مي دهد، انحصار كارآمد دولت بر قوه قهريه شرايط را بدتر مي كند آن گاه پرسش آنارشيست ها اين است كه آيا به وجود آوردن و حفظ كردن بنيادي اجتماعي با امكان انحراف يافتني اين همه ويرانگر عاقلانه است
مقصود من حل و فصل كردن منازعه ميان آنارشيست ها و مدافعان دولت نيست بلكه مي خواهم نشان دهم كه تصور آنارشي را مي توان به دو طريق متفاوت مورد ملاحظه قرار داد، و اين كه افرادي كه برداشتي مثبت از آن دارند بنيادهايي فكري براي ديدگاهشان دارند اين ملاحظه اگر قرار باشد كه با سؤالي متفاوت موجه شويم يعني اين كه آيا ظهور اينترنت گامي در جهت آنارشي نيست ضرورت دارد؛ زيرا اگر چنين باشد، ما پيش از اين كه از اين آنارشي استقبال كنيم يا از آن بهراسيم، بايد سؤال كنيم كه كدام معناي آنارشي مورد نظر است
اينترنت دو خصلت بارز دارد، بين الملل گرايي (انترناسيوناليسم) اش و عوام گريي (پوپوليسم)اش بين الملل گرايي اينترنت صرفاً مربوط به اين حقيقت نيست كه باعث ارتباط يافتن مردماني از ملل مختلف مي شود، چرا كه بسياري از ابزارها و فعاليت هاي انساني چنين كاري را انجام مي دهند نكته در اين جاست كه جست وجو در اينترنت كاملاً نسبت به مرزهاي ملي بي اعتنا است مردماني كه در غيرانيترنت غربيه مي بودند، كه توسط علائق مشتركي پيوند مي يابند كه هيچ ربطي به مليت ندارد اينترنت از اين جهت در تضادي شديد با آنچه فيلسوفان «جامعة مدني» مي گويند قرار مي گيرد، يعني جامعه اي كه خصوصيتِ آن پيوند دادن افراد غريبه يا وحدت بخشيدن به آنها درون يك حكم يا حوزة سياسي است
به همين دليل اينترنت جدا از دلايل ديگر داراي اين پتانسيل است كه از لحاظ سياسي ضدحكومت و برانداز باشد اما شكل اين براندازي بسيار عميق است و اين وضع صرفاً به خاطر اين نيست كه جاسوسان يا افرادي مانند آنها اكنون شكلي تقريباً غيرقابل كشف شدن از ارتباط با رهبران سياسي شان را در اختيار دارند، امري كه حقيقي و مهم است حقيقي و مهم است يا اين كه تروريست ها مي توانند در امنيتي نسبي اطلاعات را مبادله كنند، بلكه اين وضع به دليل آن است كه همة تعامل ها بر روي شبكه اينترنت مي توانند بدون توجه بر مرزهاي ملي صورت گيرد از آن جايي كه جهان روابط بين الملل تاكنون عمدتاً به صورت روابط بين دولت ها بوده است، و وضع جديد به معناي آن است كه اكنون فضايي در حال رشد از تماس و همكاري وجود دارد كه دولت ها، حتي در هماهنگي با يكديگر، كنترل ناچيزي بر آن دارند از آن جايي سلطه (Authority) دولت، گرچه با قدرت (power) آن يكسان نيست، به طور غيرمستقيم بر آن قدرت تكيه دارد، اين پتانسيلِ اينترنت در كاهش دادن قدرت دولت ها با به وجود آوردن معنايي از فعاليتي بي اعتنا به آن همزمان پتانسيلي براي كاهش دادن سلطة دولت است به همين دليل است كه يك آنارشيست ممكن است از اينترنت استقبال كند
دومين خصلت اينترنت عوام گرايي يا پوپوليسم آن است بار ديگر بايد از نظر داشته باشيم كه اين عوام گرايي نه در مرتبه اي سطحي بلكه در مرتبه اي عمقي قرار دارد در شرايط حاضر صلاحيت هاي خاصي براي جست وجو كردن چيزهاي بر روي شبكه و مهم تر از آن مشاركت كردن در آن لازم نيست و هيچ سيستم واقعي سانسوري كه مشاركت ها را در غياب چنين صلاحيت هايي مانع شود وجود ندارد تنها نوع سانسوري براي مثال توسط دولت سنگاپور وشركت هايي كه دسترسي افراد را به انيترنت ممكن مي كنند، [براي جلوگيري از دسترسي با سايت هاي غيراخلاقي] پيشنهاد شده است مقصودي كاملاً متفاوت دارد به علاوه با در دسترس بودن گسترده كامپيوترها در مدارس و كالج ها و تأسيس كافه هاي اينترنتي، هزينه استفاده و وارد شدن به اينترنت آن قدر ناچيز شده است كه از آنها هم كار چنداني براي مقابله كردن با عوامگرايي سيستم به صورت يك كل برنمي آيد
اين خصلت عوام گرايانه اينترنت بيشترين شادي آنارشيست ها را باعث مي شود، چرا كه به نظر مي رسد امكان اجتماعي بين المللي نويني را عرضه مي كند كه در آن معمولي ترين افراد مي تواند دسترس نامحدودي به جهان اطلاعات داشته باشد و كم اهميت ترين افراد مستقيماً در شكل دهي به جهان دخالت كنند افراد بر روي اينترنت بر مبناي علائق و انتخاب هاي فردي خودشان عمل مي كنند و هم پيمان مي شوند و انجام دادن چنين كارهايي توسط مرزهاي ملي يا قدرت هاي مسلط بارزسي نمي شود تحقق آنارشي مثبت هنگامي كامل مي شود كه ما به اين تابلو، تصوير دولت هاي ناكامي را بيفزاييم كه علي رغم قدرت هاي قاهرشان عاجزانه به اين وضعيت مي نگرند
گرچه اين تحليل و سنايويي كه مجسم مي كند، كاملاً تخيلي و بي اساس نيست، اما بر مبناي مفروضاتي است كه نياز به بررسي دارند اين امر تنها هنگامي حقيقت دارد كه دسترسي نامحدود به دانش بر سازندة قدرت يافتن عمومي باشد و بر همين قياس در صورتي كه ناتواني در محدود كردن آن به عنوان تقليل يافتن قدرت دولت شمرده شود دومين فرض اين است كه توانايي در مشاركت كردن در جهان اينترنت نيز به وجود آورندة قدرت يا به عبارت ديگر تأثيري بر پيامدها در جهان [واقعي] باشد
يك نتيجه گيري مقدماتي بايد اين باشد اين انديشه كه اينترنت ويژگي هاي مثبتي براي آنهايي دارد كه آنارشي را به عنوان يك آرمان تلقي مي كنند، بي وجه نيست اما تنها هنگامي كاملاً اثبات مي شود كه بررسي برخي از مفووضات تعيين كننده را تأييد كند
براي ذهني كه آنارشي را به عنوان شرايطي كه بايد از آن ترسيد تلقي مي كند، همان ويژگي هاي اينترنت كه آنارشيست ها تحسين مي كنند ممكن است نقض هاي آن دانسته شود اينترنت زمينة كاملاً برانگيزاننده اي براي توطئه هاي جنايتكارانة در اختيار پست ترين مخرج مشترك انگيزش هاي انساني است البته چنيني ديدگاهي دقيقاً همان مفروضات را مي پذيرد، و بنابراين در معرض همان ترديدها قرار مي گيرد كمترين چيزي كه در اين مورد مي توانيم بگوييم اين است كه موضع بدبينانه نه ضعيف تر و نه قوي تر از موضع خوش بينانه است
اما يك مسير فكري ديگر وجود دارد كه ارزش كارش را دارد اين نظريه بر اين ايده استوار است كه اينترنت بيشتر از آنارشي سياسي، آنارشي اخلاقي را ترويج مي كند و اين كه آنارشي اخلاقي ذاتاً ويرانگر است براي بررسي اين موضوع لازم است كه نگاهي اندكي دقيق تر به ايده تربيت اخلاقي بيندازيم در اين جا من تنها مي توانيم طرح مختصري از مسيري فكري ارائه دهم كه برخي از تأكيدات نسبتاً جزيي آن بر روان شناسي اخلاقي تكيه دارد
من از كلمه «ترجيحات» (prefereces) به عنوان اصطلاحي ژنريك براي آن انگيزش هاي انساني استفاده خواهم كرد كه نوعي عنصر سنجشي مثبت دارد- مثل اشتياق، علاقه، كنجكاوي و غيره در مقابل آنهايي كه سبعانه ترند- مثل ترس، خشم، آشفتگي و غيره «ترجيحات» به اين معنا دست كم تاحد طبيعي هستند؛ به اين معنا كه پيش از اين كه اجتماعي شدن صورت پذيرد، حتي شايد پيش از آن كه اجتماعي شده آغاز شود، برخي از چنين ترجيحاتي در انسان ها وجود دارند و به توضيح دادن رفتارشان كمك مي كنند فرايند اجتماعي شدن ممكن است به مثابه تزكيه شدن اين ترجيهات از طريق فرآيند پذيرش تأثيرات خارجي برساخته مي شود
بنابراين براي مثال، به اين معنا ترجيح دادن، بيان كردن خود طبيعي محسوب مي شود؛ بدون چنين ترجيحي انسان ها زبان نمي آموزند اما اين ترجيح، في نفسه، به معناي واقعي كلمه متنافر (icoheret) است؛ تنها با بدست آوردن زباني توارثي و ابداع نشده است كه اين ترجيح را مي توان به درستي درك كرد [از طرف ديگر] كسب كردن چنين زباني پذيرفته شدن اين ترجيح طبيعي داشتن به خود بيانگري، توسط قواعد جامعه سخنگويان زبان است
به نظر من چيزي شبيه مثال بالا را بايد در مورد اخلاقيات هم بيان كرد تكانه هاي طبيعي كه در كانون اخلاقيات قرار دارند و به عبارتي اساسي فعال براي خودآگاهي اخلاقي را تشكيل مي دهند، هرچه كه باشند، تعريف خود را هنگام بدست مي آورند كه در معرض فرآيند پالايش دهندة مجموعه اي به ارث رسيده و غيرابداع شده از ارزش ها و آداب قرار گيرند به نظر من اشتباه هست كه فكر كنيم امور به علت آن كه تمايل به آنها وجود دارد داراي ارزش مي شوند؛ برعكس اميال ما هنگامي شكل مي گيرند كه آنها را با آنچه آموزيم از طريق تجربه جمعيِ به ارث رسيده در مورد آنچه ارزش تمايل داشتن را دارد، يعني چيزي كه ارزشمند (valuable) است، متناسب مي كنيم بنابراين براي مثال، به عقيدة من علاقه به موسيقي، يك ترجيح طبيعي است، اما در عين حال علاقه اي است كه بلوغ خود را از طريق تناسب يافتن با يادگيري دربارة اشكال و تركيب بندي هاي موسيقيايي بدست مي آورد كه تجربة جمعي نشان مي دهد كه اهدافي كافي براي تحقق يافتن آن ترجيح هستند
بر اين سؤال تربيت اخلاقي درسال هاي اول زندگي آشكارتر است، اما به طوري بي پايان ادامه مي يابد و در همه مرحله شكل آن مشابه است در معرض قرار داده و تعويل كردن ترجيحات طبيعي با تأثيرات اجتماعي كردن اين روند پيامد بجاي هماهنگ شدن ترجيحات انسان هاي در غير اين صورت جدا از هم را به وجود مي آورد، و بنابراين به وجود آوردن جامعة متمدن را ممكن مي كند به طور خلاصه تربيت اخلاقي يك روند اجتماعي شدن است، و به همين علت كه به نظر من معمولاً منحرفان جدي اجتماعي، مثلاً قاتلان زنجيره اي، به شكلي ريشه اي توسط سابقه روان شناختي شان از خود بيگانه شده اند امر بارز در مورد اينترنت اين است كه شكل گيري آنچه را كه «هم آميزي مطلق علائق» مي نامم ممكن و حتي تشويق خواهد كرد
منظور من از اين اصطلاح اين است كه توانايي پرسه زدن صرف در شبكة ساختار نيافته اي از ترجيحات است كه به مجال همساني (cogruece) صرف را فراهم مي آورد و نه هماهنگي (coordiatio) پرسه زنندگان در اينترنت اين فرصت را دارند كه در جست وجوي روحيه هاي مشابه باشند و آن نوع تأثيرات اصلاح و تزكيه كننده را كه در فرايندهاي طبيعي يادگيري عمل مي كنند ناديده بگيرند اين وضعيت بارزتر از همه شايد در مسائلي مانند شبكه هاي پورونوگرافي كودكان خود را نشان مي دهد كه در آن جلوي ترجيحات شريرانه گرفته نمي شود، چرا كه آن چيزهايي كه مانع اين نوع ترجيحات مي شوند را جست وجوكننده در اينترنت مي تواند ناديده بگيرد و سپس تمايل اين فرد پرسه زن اينترنتي با دريافت كردن پاسخ هاي تأييدكننده از جانب افراد داراي ترجي مشابه، تقويت مي شود
پيامد منطقي چنين وضعيتي فروپاشي اخلاقي است و نه يگانگي اخلاقي اين فروپاشي به معناي بد كلمه آنارشيستي است، چرا كه وسيله براي انتشار يافتن و به هم پيوستن ترجيحات خودساخته اي از هر نوع است يقيناً چنين وضعيتي هرگز نمي تواند كامل شود، چرا كه ميزاني پايه اي از ارتباط هميهش مورد نياز است، ارتباط برقرار كردن به نوعي زبان نياز دارد و اين امر به نوبه خود به تسليم كردن ترجيحات شخصي به تأثيرات اجتماعي كننده- به طريقي كه بين از اين توصيف شد- نياز دارد علاوه بر اين خود پيوند يافتن ترجيحات خودساخته به فعاليتي همگام نياز به ميزاني از نظم و انضباط اجتماعي را نيازمند است اما آنچه كه اين روش نوين برقرار شدن تماس بين انسان ها امكان پذير مي كند، انتشار يافتن گسترده تر تمايلات آزاد شده، بدون تأثيرات فرهيخته كننده اي است كه به طور طبيعي بر آنها لگام مي زند و آنها را محدود مي كند
مقصود از اين شيوة انديشيدن راه انداختن جاروجنجال نيست تنها مقصود اين است كه يادآوري شد كه اينترنت در واقع ابزاري با امكانات جديد است كه بايد به درك عميقي از آن رسيد منظور من از ترسيم كردن ين خط فكري كه نتيجه گيري معيني را به دست مي دهد، به راه انداختن بحث در اين مورد است و نه اين كه مانع ساير نتيجه گيري ها شوم از اين مهم تر اگر ادعاهايي را كه من مطرح كردم بتوان تأييد كرد، اين امر هيچ استلزام صريحي از مورد آنچه مي توان درمورد ورد آنها انجام داد به همراه نمي آورد، اگر اصلاً بشود كاري انجام داد

گوردون گراهام استاد فلسفة اخلاق دانشگاه ابردين اسكاتلند و نويسندة كتاب «اينترنت: يك تحقيق فلسفي» (راتلج، 1999) است

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

12:52 AM

March 07, 2005

آنچه اينترنت نمي تواند انجام دهد

مروري بر كتاب «تأملي فلسفي دربارة اينترنت»هيوبرت دريفوس
گمنامي و واقعيت شبيه سازي شده اينترنت امكان پرهيز از تعهد داشتن را فراهم مي آورد. دريفوس استدلال مي كند كه اينترنت دشمن غايي تعهد بي قيد و شرط در جامعة مدرن غربي است، ، درست همان طور كه كي يركگارد در زمان خودش مطبوعات را اين چنين مي دانست.

علي نيكويي

هيوبرت دريفوس فيلسوف معاصر آمريكايي و استاد دانشگاه بركلي در زمينه هاي متفاوتي طبع آزمايي كرده است. از جمله او يكي از منتقدان تأثيرگذار پروژة هوش مصنوعي بوده است، كه محور كتاب مشهور او «آن چه كامپيوترها نمي توانند انجام دهند» (۱۹۷۲) بود. كتابي كه او بعدها دنباله اي هم بر آن نوشت تحت عنوان «آنچه كامپيوترها هنوز نمي توانند انجام دهند». او در اين كتاب ها و در كتاب ها و مقالات ديگرش از ديدگاهي پديدار شناسانه بر تفاوت بنيادي ميان انسان هاي متجسد و داراي كالبد و ماشين هاي نامتجسد تأكيد كرده است. محور اصلي نقد او اولين مقالات و كتاب هايش در ابتداي دهة 1970 بر پروژة هوش مصنوعي كه در آن زمان در جريان بود، متمركز بود، اين پروژه كه بعدها آن را «هوش مصنوعي خوب سبك قديم» (AIFOG) ناميدند، در واقع آن سنت افلاطوني و دكارتي را دنبال مي كرد كه توانايي هاي فكري انتزاعي را مهم ترين جنبة هوش انساني به حساب مي آورد. براساس همين عقيده بود كه پژوهش گران AIFOG براي اجراي پروژه هوش مصنوعي شان كامپيوترها را با معرف هاي سمبوليك قواعد و فاكت ها برنامه ريزي كردند به اين اميد كه اين امر نهايتاً به كامپيوترها توانايي كنش هوشمندانه اعطا كند.
امروزه پس از چند دهة تلاش درستي انتقاد دريفوس از اين پروژه آشكار شده و برنامة تحقيقاتي AIFOG تقريباً رو به زوال مي رود و پژوهش گران اصلي هوش مصنوعي به سوي الگوهايي از ذهن انسان با پيچيدگر بيشتر رو آورده اند. دريفوس در نقدش بر برنامه پژوهشي AIFOG از اين استدلال نيچه تبعيت مي كند كه توانايي هاي عاطفي و شهودي وجود متجسدها در جهان براي كنش هوشمندانه نقشي بنيادي دارند.
دريفوس در كتابش «دربارة اينترنت» در واقع به بسط دادن نظر انتقادي اش دربارة هوش مصنوعي در مواجهه با پديدة اينترنت مي پردازد.، پديده اي كه به قول خودش در مقدمة كتاب، صرفاً يك ابداع جديد تكنولوژيك نيست، بلكه معرف سنخ جديدي از ابداعات تكنولوژيك است، سنخي كه مي تواند آشكاركنندة ماهيت خود تكنولوژي باشد. به نظر او تا به حال ابداعات تكنولوژيك در ابتدا براي رفع نيازهايي مشخص به وجود آمده و سپس عوارض جانبي غيرقابل انتظاري را آفريده اند. مثلاً تلفن ابتدا براي تسهيل ارتباطات در تجارت به وجود آمد اما امروزه به وسيله متعارف كاملاً خانگي و حتي براي پركردن فضاي خصوصي بدل شده است. اما در مورد اينترنت كه در ابتدا براي به وجود آوردن ارتباط بين دانشمندان به وجود آمد، اين امر كاملاً به حاشيه رانده شده و مشخص شده است كه اصولاً اينترنت آن قدر فراگير و مرتباً در حال تغيير است كه به جاي آن كه وسيله اي براي برطرف كردن نيازي خاص باشد، هرلحظه كاربرد تازة غافل گيركننده اي براي آن كشف مي شود و به اين ترتيب به جوهر تكنولوژي يعني اين كه دسترسي هر چيزي امكان پذير شود، نزديك شده است. دريفوس در اين جا به پيروي از هايدگر به اين خطر تكنولوژي مدرن (واينترنت به عنوان نمونه اي كامل از آن) اشاره مي كند كه سوژه انساني در خطر محو شدن در برابر توليد ابژه هاي تكنولوژيك مدرن است. يا به عبارت ديگر انسان مدرن در خطر بردگي تكنولوژي مدرن است.
كتاب به چهار فصل تقسيم مي شود. دريفوس در فصل اول به «گزافه گويي دربارة ابر پيوندها (هايپرلينك ها)» به شكست هوش مصنوعي در بازيابي اطلاعات داراي مناسبت در اينترنت مي پردازد و نشان مي دهد كه شكل حقيقي و حركت جسم هاي ما نقشي اساسي در به وجود آمدن معنا دارد و فقدان تجسد به فقدان مناسبت مي انجامد. هنگامي كه ما در اينترنت جست وجو مي كنيم، بدن ما در اين جست وجو شركتي ندارد. جست وجو توسط يك موتور جست وجو صورت مي گيرد كه از قواعد و فاكت هاي معيني پيروي مي كند، يعني وضعيتي شبيه يك انسان مبتدي در مدل كسب مهارتي، كه دريفوس در فصل بعدي آن را مفصلاً شرح مي دهد چنين موتور جست وجويي نمي تواند عناصر مختص موقعيت را مورد ملاحظه قرار دهد و به اين ترتيب عملكردي در سطح پايين مهارت خواهد داشت.
مسأله ديگر كه دريفوس در اين فصل به آن مي پردازد اين است كه اينترنت حاوي مقادير هنگفتي از اطلاعات ابرپيوند يافته (هايپرلينك شده) است بدون آن كه كتابداري وجود داشته باشد كه آنها را طبقه بندي يا انتخاب كند. سازمان بندي اطلاعات در اينترنت تك سطحي و انعطاف پذير است و امكان اجازة همه لينك هاي ممكن را مي دهد، هرچيزي را حفظ مي كند و همة متن ها را در دسترس قرار مي دهد. چنين خصوصياتي به گفتة دريفوس زمينه را براي رشد يافتن گسترش بين متني و جست وجوي بازيگوشانه و غيرمتعهد بدون هدف واضح فراهم مي كند. به اين ترتيب اينترنت «سوژة مدرن با هويت ثابت را كه ميل به داشتن مدلي كامل و قابل اعتماد از جهان دارد» موجب نمي شود، بلكه سوژة پست مدرني متلوّني را مي آفريند كه آمادگي گشايش به افق هاي هميشه جديد را دارد.
در فصل دوم كتاب با نام «يادگيري از راه دور چقدر از آموزش دور است؟» دريفوس دربارة پديدارشناسي آموزش مهارت ها و نياز به شاگردي كردن مستقيم براي كسب كردن سطوح بالاي مهارت بحث مي كند. او معتقد است كه بدون درگير شدن و حضور، مهارت آموزي ممكن نيست.

دريفوس در اين فصل يك مدل كسب مهارت شامل پنج شيوة كاركرد را از مرحلة «مبتدي» تا مرحله خبرگي شهودي كه آن را «فرد عملي» مي نامد ارائه مي دهد. فضاي سيبرنتيكي در اينترنت حوزه تعاملات بدون خطرپذيري است كه در آن تعهدي واقعي وجود ندارد و بنابراين يادگيرندگان امكان رسيدن به مرحله اي بالاتر از «كارداني» را ندارند. به قول دريفوس «اگر حضور از راه دور [در اينترنت] نتواند تدريس در كلاس درس و حضور در سالن سخنراني را به نحوي انتقال دهد كه از طريق آن مشاركت جويي شاگردان توسط معلمان متعهد و حضور شاگردان نزد استاداني امكان پذير شود كه سبك عمل آنها به طور روزمره براي اين شاگردان آشكار باشد تا مورد تقليد قرار گيرد، آن گاه يادگيري از راه دور تنها مي تواند كارداني به وجود آورد و تبحر و خرد عملي كاملاً دور از دسترس خواهند ماند». تأكيد دريفوس بر اهميت حضور جسمي روزمره در نزد استادان براي كسب سطوح مهارتي در حد استادي و خرد عملي است.
دريفوس روشن مي كند حضور جسمي به صورت شاگردي كردن تنها راه بدست آوردن يك سبك است. منظور از «سبك» خصوصيات رويكرد استاد و شيوه مشكل گشايي توسط اوست. به قول دريفوس «يك معلم الهام بخش مانند ويتگنشتاين نسل هاي متعددي از داشنجويان را به جاي مي گذارد كه نه تنها سبك او بلكه حتي اطوار او را تقليد مي كند».
فصل سوم كتاب «حضور از راه دور نامتسجد و متروك شدن امر واقعي» به توصيف بدن به عنوان منبع حس ما از تسلط بر واقعيت مي پردازد و اين كه چگونه فقدان پيوستگي و هماهنگي پس زمينه اي- كه خصوصيت حضور از راه دور است- به فقدان درك واقعيت افراد و اشيا مي انجامند.
اينترنت نمي تواند دستيابي به تسلط كامل را موجب شود. دريفوس در اين فصل از برداشت مر لوپونتي از «حداكثر تسلط» استفاده مي كند كه مقصود از آن گرايشي جسمي براي بدست آوردن تسلط مطلوب بر جهان است. هنگامي كه ما به چيزي مي نگريم گرايش داريم، بدون فكر كردن به اين كار بهترين فاصله را براي دريافت شي هم به عنوان يك كل و هم بخش هاي مختلف آن پيدا كنيم» اين حداكثر تسلط يا احاطه گرايش بدن ما، از طريق حركت كردن مداوم، تجربه هاي ما در اين جهان را به صورت تجربياتي از اشيا پايدار سازمان دهد. دريفوس در پيروي از پديدارشناسي جسم مرلوپونتي اين بحث را مطرح مي كند كه اگر حسي از حضور [واقعي] بايد در حضور از راه دور وجود داشته باشد، ما بايد مداوماً امكان بدست آوردن تسلط بر هر چيز را كه در مقابل ما قرار مي گيرد را فراهم كنيم. چنين وضعيتي هنوز در فضاي سيبرنتيكي به وجود نيامده است و احتمالا هرگز به وجود نخواهد آمد. تعامل ميان بدن ها، آنچنان كه مرلوپونتي آن را بيان مي كند، به عبارت ديگر تعامل و روزمره متجسد را نمي توان در فضاي سيبرنتيكي كسب كرد، هرچه قدر هم كه اين رابطه با تصاوير سه بعدي، صداي استريو، كنترل رباتي از راه دور و غيره غني شده باشد. فصل پاياني كتاب با نام «نيهيليسم در بزرگراه اطلاعاتي: گمنامي در برابر تعهد در عصر حاضر» به طور مشروح توضيح مي دهد كه چگونه معنا نياز به تعهد و تعهد واقعي به خطرپذيري واقعي نياز دارد؛ در حالي كه اينترنت ما را به اجتناب كردن از خطر تعهد واقعي سوق مي دهد.
گمنامي و واقعيت شبيه سازي شده اينترنت امكان پرهيز از تعهد داشتن را فراهم مي آورد. دريفوس استدلال مي كند كه اينترنت دشمن غايي تعهد بي قيد و شرط در جامعة مدرن غربي است، درست همان طور كه كي يركگارد در زمان خودش مطبوعات را اين چنين مي دانست. جست وجوگران گمنام و نامتعهد اينترنت لذت را به محور زندگي هاي ما بدل مي كنند. اين جست وجوگران به قول كي يركگارد در حوزة زيباشناختي وجود زندگي مي كنند، كه نهايتاً نوميدي را براي آنها به بار مي آورد. تنها راه خروج از اين نااميدي پذيرفتن تعهد بي قيد و شرط حوزة مذهبي وجود است. با وجود آن كه اينترنت تعهد بي قيد و شرط را منع نميكند، امكان بر دوش گرفتن چنين تعهدي را تضعيف خواهد كرد. به قول دريفوس: «براي آزمودن اين كه آيا فردي تعهد بي قيد و شرط دارد، بايد ديد كه آيا فرد اشتياق و شجاعت انتقال دادن آنچه را آموخته است از شبكه به دنياي واقعي دارد يا نه». در اينجا هم مانند مسأله كسب كردن مهارت دريفوس اين امكان را مد نظر قرار نمي دهد كه آنچه در فضاي سيبرنتيكي آموخته مي شود عمدتاً در همان فضاي سبرنتيكي مورد استفاده قرار مي گيرد. در مجموع در اين كتاب اينترنت وسيله اي خطرناك براي يادگيري شمرده مي شود كه به علت گرايش ذاتي آن بر غلبه يافتن بر ما و سوق دادن ما به سوي زندگي بدون تعهد در حوزة زيباشناختي بايد با احتياط بسيار با آن برخورد كرد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

10:03 AM

March 07, 2005

بهبود کار

نويسنده: Meridith Levinson
CIO
مترجم: زهره چكنی

فرامينگهام- زمانی كه Berni Marcus و Arthur Blank تصميم به خريد يك تعداد انبار تا سقف پر از لوازم و ابزار خانه‌سازی گرفتند، كه هر سازنده يا صاحبخانه‌ای روزی به آنها احتياج پيدا می‌كنند، در واقع دست گذاشتند روی نقطه حساس آمريكاييها، يعنی علاقه وافر به سايز، حق انتخاب و چانه‌زنی بر سر قيمت. در سال 1978، شركت Home Depot پا به عرصه وجود گذاشت. بالاخره انسان توانست همان حسی را تجربه كند كه بچه‌ها هنگام بازی دارند.

Home Depot با كارمندان باهوش و ماهر خود، كه در امر ساخت‌و ساز خبره‌اند با آن لباس‌های قرمز آرم‌دارشان كم‌كم به يك نشان فرهنگی آمريكا تبديل می‌شود و همراه Harley Davidson كوكاكولا و فورد وارد عرضه فرهنگی می شوند.

Home Depot به نشانه‌ای از تجارت آمريكايی نيز تبديل شد تا 1986 با 60 فروشگاه و 6600 كارمند، اين شركت در فروش به رقم يك ميليارد دست يافت. از آن هنگام تا سال 2000 درآمد شركت تقريبا هر دو سال يكبار دو برابر شد. موفقيت شركت با حاشيه‌نشيتی طبقه متوسط آمريكا، رشد حيرت‌آور جمعيت و رونق معاملات املاك در سال‌های دهه 1980 همزمان بود.

Home Depot ايده‌ای خارق‌العاده در زمانی بسيار مناسب بود و توانست در سال 1980 شركت Lowe's سی وهفت ساله را كه فروشنده شماره يك لوازم و مصالح خانه‌سازی بود را پشت سر گذارد. امروز، اين شركت دومين فروشنده لوازم خانه سازی بزرگ آمريكا است كه تنها wal-mart را پيش روی خود دارد و در تمام دنيا اولين و بزرگترين فروشگاه‌های لوازم خانه‌سازی زنجيره‌ای است، كه درامدی معادل 64.8 ميليارد دلار دارد، در واقع 11 درصد سهم بازار لوازم خانه‌سازی تعريف نشده آمريكا را شامل می‌شود. اين شركت يك روز درميان يك فروشگاه جديد افتتاح می‌كند.

آنچه در رونق و رشد چشمگير Home Depot تاثير زياد داشت، به غير از همزمانی با رونق اقتصادی تاريخی آمريكا مدل تجارت غيرمتمركز نيز بود كه در آن فروشگاه‌ها منطقه‌ای می‌شوند و اين مديران قسمتهای مختلف هستند كه در مورد كيفيت و كميت كالاها در قفسه‌ها مسئول هستند. آقايان ماركوس و بانك معتقد بودند كه افرادی مسئول اين گونه انتخابها باشند كه از همه كس به مشتريان نزديكترند نه اينكه روسای بخشهای مختلف كه كاره‌ای نيستند.

IT نيز در اين زمينه نقش بسيار چشمگيری به عهده داشته است. Home Depot به سيستم‌های خانگی بسيار وابسته بود با ساخت برنامه‌های خود، شركت نرم‌افزار در حال تغيير off-the-shelf را آزرده نكردند و برای نصبهای بی‌انتها برای كل شركت وقت و پول خود را صرف نكرده است. وجود يك بانك اطلاعاتی استاندارد و يك ساختار برنامه كه از اجزا نرم‌افزار استفاده مجدد می‌كرد به كاركنان IT امكان می‌داد تا برنامه‌هايی بسازند نظير سيستم‌ سفارش متحرك يا Mobile Ordering System (كه يك گاری مجهز به كامپيوتر و چاپگر كه كارمندان می‌توانستند در تمام فروشگاه آن را به حركت درآورند و محصولات و تغييرات قيمتها را مدام ضبط كنند و سفارشات را انجام دهند)، Lickety split اما با ركورد هزاره كه همه كشور را فرا گرفت، روزهای درخشان Home Depot نيز به پايان رسيد. ناگهان استراتژی‌های سال‌های دهه 1980 و 1990 ناگهان، ناكارآمد شدند و به نظر می رسيد كه با داشتن بيش از 1000 فروشگاه در ايالات متحده، كانادا، پورتوريكو و آمريكای جنوبی ديگر نمی‌شد بر تصميم‌گيری محلی اتكا كرد. زيرا اين رويكرد موجب اغتشاش در آرايش فروشگاهی، و سردر گمی مشتری‌هايی شده بود كه توقع داشتند در فروشگاه‌های مختلف Home Depot محصولات يكسانی ببينند، برای شركت حمايت از اين سيستم‌ها كه Home Depot به آن می‌باليد، بسيار گران بود، زيرا برای تغيير آن نيروی فوق‌العاده‌ای نياز بود. حتی ساختار انبارداری كه بسيار شبيه ساير سيستم‌های H.D بود بسيار فرسوده و آسيب‌پذير بود. در زمانی كه شركت‌های Target و wal-Mart و كلوپ‌های انبارداری (Warehouse Clubs) به تعداد فروشگاه‌های خود اقدام كردند، Home Depot به يك فروشگاه بزرگ تبديل می‌شد كه در آن روزها در آمريكا روز به روز بيشتر می‌شدند، همچنان از بين رفته بود.

وقتيكه در دسامبر 2000، Robert Nardelli پست مدير ارشد اجرايی شركت را به عهده گرفت، دست به ايجاد تغييرات بزرگی در اين فروشگاه زد. به ويژه در حوزه تمركز خريد، طراحی فروشگاه‌ها و بازاريابی. در جريان اين تغييرات مهم شركت Home Depot درگير رقابتی فشرده بود با رقبای سرسخت خود از جمله Lowe's كه روز به روز هم رشد می‌كردند.

شركت در حال پيشرفت بود (زيرا نرخ‌های بهره در تاريخ به پايين‌ترين رقم رسيده بود) ناگهان با حمله 11 سپتامبر كه مردم بسيار آسيب ديده بودند و بيشتر در منزل می‌ماندند، شركت حقيقتا با مخمصه‌ای جدی رو به رو شد. از سه ماهه دوم سال مالی 2001 تا سه ماهه سوم سال مالی 2003، يعنی 30 ماه متوالی درآمد خالص و فروش فروشگاه‌ها ارقام بسيار پايينی را نشان می‌دادند. سهام Home Depot از 67 دلار برای هر سهم در 1999 به 20 دلار در ژانويه 2003 رسيد و شاخص رضايت مشتری در آمريكا (American Customer Satisfaction Index) در سال‌های 2002 و 2003 برای شركت Lowe's رقمی بالاتر از Home Depot را نشان می‌داد.

می بايست كاری می‌شد.

اما چه كاری؟

پاسخ Home Depot، تاسيسات زيربنايی ‌بود، تاسيسات و تاسيسات بيشتر.

 | ادامه مقاله
1 | بهبود كار
2 | صرف يك ميليارد دلار در ساختار تاسيسات IT
3 | حل مشكل در زمان ثبت
4 | پروژه‌ای برای سرعت بخشيدن به پاسخگويی به مشتريان
5 | E-Learning
6 | استراتژی جديد تكنولوژی اطلاعاتی جهت رقابت
7 | تكنولوژی بالا، در مقابل تماس و ارتباط بالا
8 | تعادل واقعی
 | كل مقاله بصورت يكجا

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

10:17 AM

March 07, 2005

چرا بايد به مدرسه برگرديم

فرامينگهام- Mike Grimm مدير ارشد اجرايی شركت Seton Co همواره تكنولوژی را راهی برای كنترل قيمتهای ساخت محصولات در شركت خود می‌داند، اين شركت سازنده پوشش‌های چرمی داخل اتومبيل، محل كار او از 1998 است. تا وقتی كه وی به كالج برنگشته بود، نظرش همين بود.

در مارس 2005، آقای Grimm در يك موسسه آموزشی وابسته به دانشگاه پنسيلوانيا ثبت نام كرد، تا دوره‌های حسابداری و امور مالی بخش مديريت غيرمالی را آموزش ببيند. برای Grimm پنج روز و نيم طول كشيد كه توانست مسائل اساسی و خطرات مالی را ياد بگيرد او می‌گويد: من قبلا اهل عمل بودم و توجهی به خرج كردن پولهايم نداشتم.

Grimm معتقد است كه كلاس‌ها به او كمك كرد تا بداند چطور تكنولوژی را با اهداف كاری شركت همسو كند.

به گزارش CIO Survey اغلب مديران ارشد اطلاعاتی حدود 82 درصد كارهای IT را موجب رونق كار خود به حساب آورده‌اند، اما وقتی كه به نقطه بالای IT می‌رسند، مسائل مالی و حسابداری ديگر ارزش خود را از دست می‌دهد.

Hal Varian، استاد دانشكده مديريت اطلاعات و سيستم در دانشكده بازرگانی دانشگاه "بركلی" كاليفرنيا می‌گويد: تمامی مديران ارشد اطلاعاتی می‌بايست با طرح بودجه سرانه آشنا باشند. بايد مفهوم ارزش فعلی دلار (ارزشی كه دلار امروز برای خريد يك كالا با توجه به نرخ بهره در آينده می‌بايست داشته باشد) را بداند و هم چنين، عمليات حسابرسی و ماليات آشنايی داشته باشد. اگر اين افراد با اينگونه مسائل آشنا نباشند، بايستی در دوره‌های آموزشی امور مالی كه در اكثر دانشگاه‌ها و دانشكده‌های بازرگانی ارائه می‌شوند، شركت كنند و يا از دوره‌های اينترنتی استفاده كند اغلب سازمان‌های تجاری آنها را بصورت آن‌لاين ارائه می‌دهند.

برای Susan Lang، مدير ارشد اطلاعاتی Pierce Transit، مسائل امنيتی از ديگر امور مهمتر است. اين شركت يك موسسه حمل و نقل عمومی در ايالت واشنگتن است. وی اخيرا در رشته‌های مديريت مالی و غيرمالی دانشگاه واشنگتن شركت كرده است. او می‌گويد اين كلاسها به او كمك كرد تا به نحو بهتری پروژه‌های خود در شركت را از جمله پروژه خريد نرم‌افزار مالی Mitchal Humprey را اجرا كند. اين دوره به او كمك كرد كه به مسائل مالی آتی شركت را بهتر و دقيقتر در طول RFP مطالعه كند. او می‌گويد، اكنون دقيقا می‌دانم به چه نگاه می كنم. مثلا اگر او درباره سلامت مالی شركت سازنده سوالات داشته باشد، اين مسائل را به مدير ارشد مالی شركت ارجاع می‌دهد.

Peter Knuston در مورد طول دوره Wharton كه Lang هم در آن شركت كرده است، می‌گويد: مسائل اداری بسيار خسته كننده و غيرواقعی هستند، عقيده بر آن است كه مدير ارشد اطلاعاتی ما بايد بداند زمانی كه مدير ارشد اجرايی نگران وضع شركت در Wall Street است و مدام با هيات مديره صحبت می كند، چه بايد كند.

Knuston استاديار حسابداری در دانشگاه Warton است. او می‌گويد، استادان از مطالعات موضوعی استفاده می‌كنند تا نشان دهند چطور مديران ارشد اطلاعات می‌توانند با بررسی راه‌كارهای جايگزين سرمايه‌گذاری تصميم‌گيری‌های مالی را بهتر انجام دهند.

به عنوان يك مزيت ديگر، اين كلاس‌ها به بعضی از مديران ارشد اطلاعات كمك می‌كند تا سرمايه‌گذاری‌های شخصی بسيار موفق‌تری داشته باشد. Lang می گويد: پول كمتری را بی‌جهت خرج می‌كنم و اين بسيار خوب است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

10:19 AM

March 07, 2005

مدیریت پروژه

نویسنده: Elizabeth Larson and Richard Larson

ترجمه‌ و تلخیص‌: شهنازپیروزفر

یكی از عوامل موفقیت پروژه وجودیك طرح پروژه است كه به خوبی تعریف شده باشد. در اینجا شیوه ‌شش مرحله‌ای ‌برای ایجاد یك طرح ‌پروژه‌ آمده ‌است:

مرحله 1: طرح پروژه‌ را برای ‌ذینفعان ‌كلیدی‌ توضیح دهید و درباره اجزای كلیدی‌ آن مذاكره نمایید.

متاسفانه، "طرح پروژه یكی از اصطلاحات غیر قابل ‌‌درك ‌در مدیریت ‌پروژه ‌است. طرح پروژه سندی پویاست كه می‌تواند در دوره زندگی پروژه تغییر یابد. و همانند ‌نقشه‌‌، جهت‌گیری ‌پروژه‌ را مشخص‌ می‌كند. تصور كلی بر اینست كه طرح ‌پروژه ‌معادل دوره زمانی پروژه ‌است. اما دوره زمانی یكی از ‌مولفه‌های طرح ‌است. طرح ‌پروژه ‌محصول ‌عمده فرایند‌ برنامه‌ریزی كلی پروژه است. لذا همه مستندات برنامه‌ریزی را در بر می‌گیرد. برای مثال، طرح پروژه ‌ساخت ‌یك ساختمان اداری جدید نه تنها شامل مشخصات ساختمان ‌است، بلكه بودجه ‌و زمان‌بندی‌، خطرات، پارامترهای ‌كیفیت، عوامل ‌‌محیطی و غیره ‌را نیز در بر می‌گیرد.

اجزای ‌طرح ‌پروژه ‌عبارتند از:

- خطوط ‌‌راهنما: كه گاهی اوقات ‌معیارهای كارآیی ‌نامیده ‌می‌شوند. زیرا كارآیی ‌‌كلي‌ پروژه ‌‌با این معیارها سنجیده ‌می‌شود.

- طرحهای‌ مدیریت‌ خطوط ‌‌راهنما: این ‌طرحها شامل ‌مستندسازی‌ مدیریت ‌واریانسها در پروژه هستند.

- سایر محصولات ‌فرایند برنامه‌ریزی: این ‌محصولات ‌شامل ‌طرحهایی‌ برای مدیریت ‌خطر، كیفیت، تداركات، استخدام‌ و ارتباطات هستند.

مرحله ‌2: تعریف نقشها و مسئولیت ها

شناسایی ذینفعان-- یعنی كسانیكه كه به پروژه ‌یا خروجی آن علاقمندند. شناسايي ‌ذينفعان ‌چالش‌ برانگیز و در پروژه‌های ‌پر خطر و بزرگ ‌دشوار است.

مرحله ‌ 3: توسعه بیانیه‌ حوزه كار

بیانیه ‌حوزه ‌‌كار از مهمترین ‌اسناد در طرح ‌پروژه ‌است. این بیانیه برای حصول اتفاق نظر با ذینفعان ‌درباره پروژه ‌به ‌كار می‌رود. این ‌سند در دوره ‌زندگی ‌پروژه ‌رشد و تغییر می‌كند. بیانیه‌حوزه‌ كار شامل:

- نیاز كسب ‌و كار و مساله ‌كسب ‌و كار است

- اهداف ‌پروژه‌، به منظور حل ‌مشكلات ‌كسب ‌و كار

- مزایای انجام پروژه

- حوزه ‌‌پروژه

مرحله ‌4: توسعه‌ خطوط‌ راهنمای ‌‌پروژه

خطوط‌ راهنمای ‌حوزه ‌پروژه. به ‌محض ‌اینكه ‌یافته‌های ‌پروژه ‌در بیانیه ‌حوزه‌ پروژه‌ تایید شدند، باید به صورت ساختار تقسیم فعالیت درآیند. در این حالت، خطوط راهنما شامل همه یافته‌های تولید شده در پروژه است و لذا همه كارهای انجام شده را شناسایی می‌كند. این یافته‌ها باید غیر انحصاری باشند. برای مثال، ساخت یك اداره، یافته‌های بسیاری از جمله نحوه ساخت، توصیه‌ها، طرح‌ها و دورنماها را در بر می‌گیرد.

- خطوط راهنمای زمان بندی و هزینه

- شناسایی فعالیت‌های مورد نیاز برای تولید هر یك از یافته‌های شناسایی شده در خطوط راهنمای حوزه پروژه. شرح مبسوط نحوه وابستگی وظایف‌ به ‌عوامل متعدد نظیر تجربه تیم، خطرات پروژه، عدم قطعیت، ابهام مشخصه‌ها، میزان هزینه مورد نیاز و ....

- شناسایی منابع هر فعالیت

- تخمین زمان مورد نیاز برای تكمیل هر فعالیت

- تخمین هزینه هر فعالیت ‌با استفاده از میانگین نرخ ساعات هر منبع.

- بررسی محدودیت‌های منبع یا زمان واقعی مورد نیاز هر منبع

- تعیین فعالیت‌های وابسته و توسعه مسیر بحرانی

- تعیین تقویم زمانی همه فعالیت‌ها به صورت (هفتگی، ماهانه، فصلی، سالانه)، به عبارتي هرفعالیت به چه میزان زمان نیاز دارد و زمان شروع و پایان آن چه هنگام است.

این فرایند یكباره شكل نمی‌گیرد، بلكه‌ در خلال پروژه، برخی یا همه این گام‌ها تكرار خواهند شد.

مرحله 5: ساخت طرح‌های مدیریت خطوط‌ راهنما

به محض اینكه خطوط راهنمای حوزه، زمان بندی و هزینه پروژه را بنا نهاديد، طرح‌های مدیریت این خطوط راهنما، ایجاد می‌شوند. معمولا همه طرح‌های مدیریتی شامل فرایند بازنگری و تصویب برای اصلاح خطوط راهنما هستند. معمولا سطوح مختلف تصویب برای انواع مختلف تغییرات لازم است. همه درخواست‌های جدیدحوزه، زمان یا بودجه پروژه‌ را تغيير نمي‌دهند، اما برای مطالعه درخواست‌های جدید و تعیین میزان تاثیرشان بر پروژه، به یك فرایند نیاز داریم.

مرحله 6 : ارتباطات

طرح ارتباطات ‌یكی از جوانب مهم طرح پروژه ‌است. این سند به موارد ذیل اشاره دارد:

- هر فرد در پروژه چه گزارشاتی، در چه فرمتی و با چه رسانه‌ای را درخواست مي‌كند.

- اطلاعات پروژه در كجا ذخیره می‌شوند و چه كسی می‌تواند به اطلاعات دسترسی پیدا كند.

- چه پارامترهایی برای حصول اطمینان از كیفیت محصول مورد توجه قرارگرفته‌اند.

- چه تدابیری برای رویارویی با عدم قطعیت‌ها اندیشیده شده است.

به محض اینكه طرح پروژه تكمیل شد،باید محتوای آن به ذینفعان كلیدی ارائه شود.

مراحل بعدی عبارتند از: اجرا و كنترل طرح پروژه.

توسعه یك طرح شفاف پروژه زمان‌بر است. مدیر پروژه شاید بخواهد هرچه سریعتر به مرحله اجرا برسد. اما اگر برای ایجاد یك طرح شفاف پروژه، زمان صرف كند، به آسانی می‌تواند موفقیت پروژه‌ را تضمین كند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

10:19 AM

March 07, 2005

اصول ERP

تدوین : شهناز پيروزفر

ERP چيست؟ نرم‌افزار برنامه‌ریزی منابع سازمانی (Enterprise Resource Planning) یا ERP سعی دارد تا عملكرد همه واحدهای شركت را در یك سیستم كامپيوتری يكپارچه نموده و نیازهای مختلف خاص هرواحد را پاسخ گوید.

این ادعای بزرگی است! یك برنامه نرم‌افزاری كه بتواند نیازهای افراد مالی و منابع انسانی را برآورده سازد. هریك از واحدها سیستم كامپيوتری منحصربه خود را برای بهینه سازی عملكردهایش دارد. اما ERP آنها را در یك برنامه نرم‌افزاری يكپارچه تركیب می‌كند. این برنامه از طریق یك پايگاه داده‌ها اجرا می‌شود، لذا واحدهای مختلف می‌توانند اطلاعات را ساده‌تر به اشتراك بگذارند و با هم ارتباط برقرار سازند. این شیوه یيكپارچه در صورتیكه شركت‌ها نرم‌افزار را به درستی نصب كنند، مزایای متعددی دارد.

برای مثال، دریافت سفارش مشتری. در واقع هنگامی كه مشتری سفارش می‌دهد، سفارش به صورت كاغذی یا كامپيوتری در واحدهای مختلف شركت در گردش است. این گردش سبب تاخیر در پاسخ‌گویی به سفارش می‌شود، در ضمن پيچيك از افراد شركت به درستی نمی‌داند كه وضعیت سفارش در هرنقطه چگونه است.

ERP سیستم‌های كامپيوتری مستقل رادر واحدهای مالی، منابع انسانی و انبارداده‌ها در هم می‌شكند و آنها را با برنامه نرم‌افزاری يكپارچه كه به ماجول‌های نرم‌افزاری تقسیم می‌شود، جايگزين می‌سازد. بدین ترتیب واحدهای مالی، ساخت و انبارداده‌ها هنوز هم نرم‌افزار خودشان را دارند، با این تفاوت كه حالا نرم‌افزارها به یكديگر لینك شده‌اند،به گونه‌ای كه واحد مالی می‌تواند با مراجعه به انبارداده‌ها از تحویل سفارش مطلع شود. اكثر نرم‌افزارهای ERP انعطاف پذیرهستند، به گونه‌ای كه شما می‌توانید بعضی از ماجول‌ها را نصب كنید بدون اینكه نیاز باشد تا كل بسته را بخرید. برای مثال، بسیاری از شركت‌ها فقط ماجول مالی یا منابع انسانی ERP را نصب می‌كنند.

چگونه ERP می‌تواند كارآیی كسب و كارشركت را بهبود بخشد؟

نكته مهم این است كه به مدت زمانی كه به طول می‌انجامد، توجه نكنیم، به طور متوسط پس از یك یا سه سال این نرم افزار كارآیی را افزایش می‌دهد.

ERP چه چيزی را در كسب كار اصلاح می‌كند؟

پنج دلیل عمده استفاده از ERP در شركت‌ها عبارتند از:

اطلاعات يكپارچه مالی- از آنجاییكه كه مدیر اجرایی ارشد شركت سعی دارد از كارآیی مطلع شود، شاید با گفته‌های متفاوتی مواجه شود. واحد مالی مجموعه اعداد مربوط به خود را دارد و سایر واحدها نیز به همین ترتیب. ERP نسخه واحدی از واقعیت است و سئوال براگيز نخواهد بود. زیرا هر فردی از یك سیستم مشابه استفاده می‌كند.

يكپارچگی اطلاعات سفارش مشتری - سیستم‌های ERP می‌توانند در جایی استقرار یابند كه سفارش مشتری دریافت، سفارش وی تحویل و صورتحساب صادر شود.اگراین اطلاعات دریك سیستم نرم افزاری نگهداری شود، شركت می تواند به سادگی سفارشات، ساخت، موجودی و عرضه را همزمان ردیابی كند.

استانداردسازی و سرعت دهی به فرایندهای ساخت - شركت های سازنده به ويژه آنهایی كه از ادغام چند شركت به وجودآمده‌اند، چندین واحد كسب و كار دارند كه ممكن است از روش‌ها و سیستم‌های كامپيوتری متفاوتی استفاده كنند. سیستم‌های ERP با بهره گيری از روش‌های استاندارد، برای اتومات سازی بعضی از گام‌های فرایند ساخت به كار می‌روند.استانداردسازی این فرایندها و استفاده از یك سیستم كامپيوتری يكپارچه می‌تواند سبب صرفه جویی در زمان شود و بهره‌وری را افزایش دهد.

  • كاهش موجودی- ERP به جریان روان‌ترفرایند ساخت كمك می‌كند و رویت پذیری فرایند سفارش را در شركت بهبود می‌بخشد.

استانداردسازی اطلاعات منابع انسانی - منابع انسانی، به ويژه درشركت‌هایی كه چندین واحد كسب و كار دارند، ممكن است یك روش ساده و يكپارچه برای ردیابی زمان كارمندان و برقراری ارتباط با ایشان در زمینه خدمات نداشته باشد. ERP می‌تواند در این مورد كمك كند.

هزینه واقعی ERP چقدر است؟

اخیرا متا گروپ درباره هزینه كل مالكیت ERP شامل سخت‌افزار، نرم‌افزار، خدمات حرفه‌ای و كارشناسان داخلی مطالعاتی را انجام داده است. ازبین 63 شركتی كه مورد بررسی قرار گرفته‌اند، ازجمله شركت‌های كوچك -متوسط و بزرگ صنعتی، مبلغ موردنظر به طور متوسط 15 میلیون دلار بوده است. و متا گروپ به این نتیجه رسید كه پياده سازی ERP گران است و چندان به نوع شركتی كه از آن استفاده می‌كند، بستگی ندارد.

هزینه‌های پنهان ERP كدامند؟

1. آموزش: هزینه‌های آموزش بالاست. زیرا كاركنان مجبورند مجموعه فرایندهای جدیدی را فرا بگيرند. بدتر اینكه، شركت‌های خارجی آموزشی نیز نمی‌تواننددراین مورد به شما كمك كنند. آنها به افراد نحوه بكارگيری نرم‌افزار را می‌آموزند نه روش‌های خاص استفاده از آن در كسب و كار شركت. شرایطی را مهیا نمایید و تحت آن شرایط فرایندهای مختلف كسب و كار را كه از سیستم ERP تاثیر می‌پذيریرند، شناسایی كنید.

به خاطر داشته باشید كه مسوولین واحد مالی از همان نرم‌افزاری استفاده می‌كنند كه مسوولین واحد فروش استفاده كرده‌اند، هر دوی آنها اطلاعاتی را وارد می‌كنند كه بر هر دو سیستم تاثیر گذارند. لذا باید از متخصیین تكنولوژی اطلاعات بخواهید كه چنين دوره‌های آموزشی را برگزارنمایند.

2. آزمایش و يكپارچه سازی: آزمایش ارتباط بین بسته‌های ERP و سایر بخش‌ها، هرینه ديگری را به دنبال خواهد داشت. یك شركت سازنده شاید برنامه‌های كاربردی از تجارت الكترونیك و زنجیره تامین گرفته تا محاسبه مالیات برفروش و باركدينگ را دارا باشد. همه يكپارچه سازی‌ها با ERP در ارتباطند. بهتر است این برنامه‌ها را از یك فروشنده ERP بخرید. آزمایش يكپارچگی ERP به همراه آموزش باید صورت گيرد.

3. سفارشی سازی: برنامه‌های افزودنی تنها سرآغاز هزینه‌های يكپارچه سازی ERP محسوب می‌شوند. هزینه ديگری كه بهتر است تا حد امكان از آن اجتناب شود، سفارشی سازی هسته اصلی نرم‌افزار ERP است. این وضعیت زمانی رخ می‌دهد كه نرم‌افزار ERP نتواند یكی از فرایندهای كسب و كار را مدیریت كند و شما تصمیم می‌گيرید با سفارشی سازی نرم‌افزار مشكل را حل كنید. سفارشی سازی می‌تواد بر هر ماجول سیستم ERP تاثیر گذارد، زیرا آنها كاملا با هم در ارتباطند. ارتقاء بسته ERP نیز معضل بزرگی است. زیرا مجبورید دوباره برای نسخه جدید، سفارشی سازی را انجام دهید. و از سوی ديگر، فروشنده از شما پشتيبانی نخواهد كرد و باید كارشناسان جدیدی را برای انجام سفارشی سازی و پشتيبانی استخدام نمایید.

4. تبدیل داده‌ها: تبدیل اطلاعات نظیر سوایق مشتری، عرضه كننده، طراحی محصول از سیستم قدیم به سیستم جدید ERP هزینه براست.

5. تجزیه و تحلیل داده‌ها: اغلب، داده‌های سیستم ERP به منظور انجام تجزیه و تحلیل، باید با داده‌های سیستم‌های خارجی تلفیق شوند. كاربرانی كه تجزیه و تحلیل‌های حجیم انجام می‌دهند، باید هزینه انبارداده‌ها را نیز در نظر بگيرند. زیرا ERP شناسایی تغییرات روزانه داده‌ها را به خوبی انجام نمی‌دهد و برای این منظور باید یك برنامه سفارشی نوشته شود.

6. مشاوره: هنگامی كه كاربران نمی‌توانند دراین زمینه برنامه‌ریزی كنند باید از مشاور كمك بگيرند، لذا هزینه مشاور نیز به هزینه‌های فوق افزوده می‌شود.

7. جايگزینی بهترین‌ها: موفقیت ERP به استخدام افراد ماهر بستگی دارد. این نرم‌افزار بسیار پيچيده است و نمی‌توان آن را به هر كسی سپرد. بدتر اینكه، شركت باید برای جايگزینی افراد پس از اتمام پروژه نیز آماده باشد.

8. هيچگاه كار تیم‌های پياده سازی اتمام نمی‌پذیرد: اكثر شركت‌ها با پروژه ERP همانند سایر پروژه‌ها رفتار می‌كنند. به محض اینكه نرم‌افزار نصب شد، تیم به كار اصلی خود مشغول می‌شود. اما باید توجه نمایید كه تیم پياده سازی ارزشمنداست. زیرا اطلاعاتشان درباره فرایندهایی نظیر فروش، ساخت، منابع انسانی و... بیشتر از مسئولین این فرایندهاست. لذا آنان نباید به كار اصلی خود مشغول شوند، زیرا پس از نصب ERP كارهای زیادی را باید انجام دهند. نوشتن گزارشات حاصل از اطلاعات سیستم جدید ERP حداقل برای یكسال آنان را مشغول نگاه می‌دارد.

چرا اغلب پروژه‌های ERP شكست می‌خورند؟

ERP مجموعه‌ای از عملیات خوب برای انجام وظایف شركت نظیر مالی، ساخت و .... است. شما به منظور بهره برداری بهتر ار نرم‌افزار باید افرادی را در شركت داشته باشید تا روشهای كاری را با نرم‌افزار تطبیق دهند.اگر افراد واحدهای مختلف درباره برتری روشهای كاری لحاظ شده در نرم‌افزار نسبت به روشهایی كه آنها به كار می‌برند، به توافق نرسند، برای استفاده از نرم‌افزار مقاومت نشان می‌دهند یا از واحد تكنولوژی اطلاعات درخواست می‌كنند تا نرم‌افزاری تهیه نماید كه متناسب با روش‌های كاری آنان باشد. و در اینجاست كه پروژه ERP شكست می‌خورد. از طرفی سفارشی سازی نرم‌افزار ،آن را ناپايدارتر و نگهداریش را دشوار می‌كند.

مزایای ERP

  • كاهش هزینه‌های حمل موجودی

  • كاهش هزینه‌های سفارش

  • كاهش هزینه‌های تولید

  • كاهش هزینه‌های نگهداری سوابق

  • كاهش هزینه‌های حمل و نقل

  • كاهش سرمایه گذاری در تجهیزات

  • فرایندهای تولید انعطاف پذیرتر

  • بهبود كارآیی كه به سوددهی بيشتر یا افزایش سهم بازار منجر می‌شود

  • افزایش شفافیت فرایند برای مشتری

  • افزایش رضایت مشتری

معایب ERP

  • نصب و نگهداری این سیستم‌ها بسیار گران است.

  • استفاده از بعضی از این سیستم‌ها دشوار است.

  • برای به اشتراك گذاشتن برخی از اطلاعات حساس كه برای یك فرایند ضروری است، با مقاومت فراد مواجه می‌شوید.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 17 اسفندماه 1383

10:21 AM

March 07, 2005

حقيقت سرورهای مجازی

نويسنده: Tom Yager
Infoworld
مترجم: نازنين حقيقی

سانفرانسيسكو- مجازی سازی سرور يكی از تكنولوژی‌های نادری است كه آنقدر خوب است كه به نظر واقعی نمی‌آيد، اما واقعی است. اولين كاربرد آن، ادغام سخت‌افزار سرور بلااستفاده بر روی تعداد كمتری دستگاه بود. اين تكنولوژی، از همان ابتدا به يك راه‌حل چندمنظوره تبديل گشته كه قابليت اطمينان بيشتر، مديريت بهتر و ساير مزايايی را فراهم می‌سازد كه آن را ابزاری تقريبا حياتی برای مديران مراكز اطلاعاتی شركت ساخته است. خلاصه كردن دانش مجازی سازی كه سبب فعاليت آن می‌شود، خود مجازی‌سازی است. اگر بخواهيم يك تعريف بسيار ساده شده ارائه دهيم، يك سرور مجازی تنها با استفاده از نرم‌افزار، رفتار و قابليت‌های يك كامپيوتر مستقل را تقليد می‌كند.

سيستم نامگذاری مجازی‌سازی آسان است. انتهای ناحيه نرم‌افزاری توسط يك نمونه واحد از يك سيستم عامل معمولی اشغال می‌شود كه به طور مستقيم روی سخت‌افزار سرور نصب می‌گردد. در بالای آن، يك لايه، مجازی سازی، هدايت مجدد و شبيه سازی را كنترل می‌كند كه در نتيجه،‌كامپيوتر مجازی را پديد می‌آورد. به تركيب اين دو لايه پايين‌تر، ميزبان يا host گفته می‌شود. ميزبان نحوه عمل كامل يك كامپيوتر شخصی متداول را يكسره تا BIOS RAM خود فراهم می‌كند و می‌تواند هر تعداد كامپيوتر شخصی مستقل كه شما انتخاب می‌كنيد را با استفاده از پيكربندی‌های متغيير تعريف شده توسط كاربر سريع اضافه نمايد.

تا زمانيكه شما يك سيستم عامل روی يك كامپيوتر شخصی مجازی نصب نكنيد، همانند سرورهای فيزيكی بدون استفاده می‌باشد. سيستم‌های عاملی كه شما روی‌ ميزبان‌های مجازی خود نصب می‌كنيد، مهمان يا guest خوانده می‌شوند. نصب يك سيستم‌عامل مهمان می‌تواند به سادگی راه‌اندازی از CD نصب سيستم‌عامل باشد. اين دقيقا شبيه نصب يك سيستم‌عامل روی يك كامپيوتر شخصی است و به طور كلی اگر از خود می‌پرسيد چگونه مجازی سازی عمل خواهد كرد، پاسخ اين است: "درست مثل يك كامپيوتر شخصی".

در واقع، در يك محيط كاملا ويندوزی، گم كردن مكانتان آسان است: آيا به سيستم‌عامل ميزبان ويندوزخود نگاه می‌كنيد يا به يكی از چهار سيستم‌عامل مهمان ويندوزی كه اندكی قبل نصب نموديد؟ ممكن است گيچ شويد، اما سيستم‌عامل‌های مهمانتان و برنامه‌های كاربردی آنها هيچ‌گاه اينطور نمی‌شوند. هر سيستم‌عامل مهمان تصور می‌كند كل دستگاه تنها در اختيار او است و به عبارتی همينطور هم می‌باشد.

سخت‌افزار مبتنی بر نرم‌افزار

سيستم‌های عامل و برنامه‌های كاربردی كه روی سرورهای مجازی كار می‌كنند بر منابع از قبيل حافظه، هارددرايوها و پورت‌های شبكه كنترل مستقيمی ندارند. در عوض، مديريت مجازی كه زير سيستم‌عامل و برنامه‌های كاربردی قرار می‌گيرد، در خواست‌ها برای تعامل با سخت‌افزار را متوقف می‌سازد و آنها را همانگونه كه مناسب می‌بينيد، كنترل می‌نمايد.

مورد شگفت‌آور واقعی كه اين تكنولوژی را به چيزی شبيه معجزه تبديل می‌كند آن است كه، يك راه‌حل مجازی سازی در سطح جهانی مثل ESX Server شركت VMware می‌تواند يك پيكربندی سخت‌افزاری يكپارچه بسازد كه شباهت اندكی به سخت‌افزار زيربنايی دارد. برای مثال، ميزبان ممكن است فرايند راه‌اندازی اوليه يك كنترلر SCSI را جز به جز شبيه سازی كند و سيستم‌عامل مهمان را متقاعد سازد كه اين راه ‌اندازی حتی زمانيكه هيچ كنترلر SCSI فيزيكی وجود نداشته باشد، در حال انجام است. اين روش می‌تواند درايوهای IDE را نيز شبيه درايوهای SCSI نمايد، يك آداپتور اترنت را به چندين آداپتور تبديل نمايد و گيت‌وی‌هايی بين سيستم‌های عامل قديمی‌تر و سخت‌افزار مدرن بدون پشتيبانی همچون آداپتورهای Fiber Channel ايجاد كند. شما سرورهای خودتان را می‌سازيد كه دقيقا متناسب با نيازهای برنامه‌های كاربردی‌تان است، اما از يك ماوس به جای يك پيچ‌گوشتی استفاده می‌كنيد.

نصب سيستم‌عامل و نرم‌افزار روی يك سرور فيزيكی كامپيوتر شخصی هر بار كه به آن نيازداريد می‌تواند خسته كننده باشد. خوشبختانه، در مورد مجازی‌سازی مجبور به انجام اين كار نيستيد. پس از اينكه يك پيكربندی سخت‌افزار مجازی را دقيقا مطابق خواسته‌تان تنظيم نموديد، می‌توانيد image ديسك‌ آن سرور را در يك فايل ذخيره سازيد و از آن بعنوان الگويی برای ساير سيستمهای مهمان استفاده نماييد. در عمل، اين مايه خوشحالی است شما می‌توانيد يك سرور مجازی را از طريق كپی كردن image پشتيبانی نماييد. می توانيد از راه كپی كردن فايل image، يك سرور جديد بسازيد- كپی كردن ويندوز نيازمند فعال‌سازی مجدد و يك مجوز مناسب است- يا يك سرور موجود را به سخت‌افزار فيزيكی متفاوتی انتقال دهيد.

سرورهای مجازی تمام مزايا و معايب سرورهای عادی را دارند. آنها دوباره راه‌اندازی می‌شوند، خاموش می‌شوند، موقتا متوقف می‌گردند (suspend)، پاسخ نمی‌دهند (not responding error) و حتی خراب می‌شوند. اگر يك سيستم‌عامل مهمان يا يك درايور دستگاه كه از آن استفاده می‌كند پر اشكال باشد، كامپيوتر شخصی مجازی از كار می‌افتد. اما نه كامپيوتر فيزيكی ونكته همين جاست.

اگر سيستم‌عامل شما خراب شود يا يك برنامه كاربردی متوقف گردد، يا حتی اگر شما يك برنامه اصلاحی نرم‌افزار نصب كنيد كه نيازمند راه‌اندازی مجدد باشد، هيچ اتفاقی برای سخت‌افزار نمی‌افتد. فعاليت يك دستگاه مجازی می‌تواند به مفهوم كاملا مجازی يا به روشی كه به واقعيت نزديك‌تر است به دستگاه ديگری منتقل گردد. حتی اگر دستگاه‌های سخت‌افزاری مشخصی بدرستی كار نكنند، تا وقتی كه هدف انتقال عمليات با استفاده از يك آداپتور شبكه ثانويه و يك مسير جايگزين جهت ذخيره‌سازی می‌باشد، انتقال عمليات دقيقا به عمان صورتی عمل خواهد نمود كه اگر كامپيوترهای شخصی مجازی، كامپيوترهای فيزيكی بودند عمل می‌كردند.

در بسياری موارد، سيستم مديريت شركت بر يك انتقال عمليات مجازی چنان نظارت خواهد كرد و واكنش نشان خواهد داد كه انگار چيزی واقعی است. راه‌حل‌هايی از قبيل HP OpenView سرورهای مجازی را همچون سرورهای فيزيكی می‌بينند و با آنها به همان صورت رابطه خواهند داشت. پيكربندی‌های گزارش شده سرورها پس از اينكه مجازی می‌شوند تغيير خواهند يافت، اما بسيار متحمل است كه مديريت روزمره شركت، تغيير اندكی را تجربه نمايد.

بعلاوه، اغلب سيستم‌های مجازی‌سازی نرم‌افزار مديريت ويژه راه‌حل را همراه دارند، كه به يك مدير امكان می‌دهد در يك كنسول مركزی بنشيند و تمام سرورهای مجازی در يك شركت را كنترل نمايد. اين نكته‌ای جالب است كه يك كارت اترنت مجازی رابدون حتی تماس با سخت‌افزار می‌توان تعويض نمود.

يك كنسول مديريت راه‌حل مجازی سازی به شما ميزان كنترلی روی كامپيوترهای شخصی مجازی‌تان می‌دهد كه از آنچه مديران می‌توانند با ابزارهای معمول انجام دهند فراتر است. شما می‌توانيد از يك مكان مركزی كامپيوترهای شخصی مجازی را طبق نياز راه‌اندازی و خاموش كنيد. همچنين اين امكان وجود دارد كه آنها را چند لحظه‌ای متوقف كنيد، كه بدون ايجاد خسارت آنها را در وضعيت كنونی‌شان ثابت نگه می‌دارد، يا آنها را برای مدت طولانی متوقف می‌سازد و از طريق ذخيره وضعيت آنها در يك فايل روی ديسك آنها را در يك توقف طولانی قرار می‌دهد. شما می‌توانيد از راه رونويسی فايل ديسك طی يك دوره ترمينال كامپيوترهای شخصی را از يك وضعيت پشتيبانی شده مجدد راه‌اندازی كنيد و تغييراتی كه مهمان را غير فعال نموده‌اند از ميان برداريد.

برای مثال، اگر پيكربندی ذخيره‌سازی فيزيكی شما از تسهيم ديسك پشتيبانی نمايد- بررسی‌های خود ما با يك سوئيچ ذخيره سازی SAN شركت Emulex و يك آرايه ديسك Xserver RAID شركت Apple Computer صورت گرفت- گزينه VMotion محصول شركت VMware به شما امكان می‌دهد يك مهمان در حال اجرا را در چند لحظه‌ای متوقف سازيد و آنرا مجدد روی يك سرور فيزيكی ديگر راه‌اندازی نماييد. ظرف چند ثانيه، شما می‌توانيد تمام مهمانان در حال كار و برنامه‌های كاربردی‌شان را از يك سرور به سرور ديگر بفرستيد تا دستگاهی را جهت تعمير باز كنيد. يا شما می‌توانيد از VMotion جهت امتيازات آماده سازی مجدد استفاده نماييد. يك كامپيوتر شخصی مجازی كه در حال متوقف ساختن آن بخش شبكه است كه اشغال می‌نمايد می‌توند به مكانی با ترافيك كمتر منتقل شود.

در محيط‌هايی با تلفيقی از سيستم‌های عامل- وضعيتی عادی كه حتی ادغام ساده را به يك امر نامنظم تبديل می‌نمايد-يك راه‌حل ميزبانی از هر سيستم‌‌عامل در VM خودش است. برای مثال شما می‌توانيد روی يك سرور PC كه در حال اجرای يكی از راه‌حل‌های مجازی سازی VMware است، هر تركيبی از Windows 2003 Server، ويندوز 2000 و Windows NT 4.0، صورت‌های مختلفی از لينوكس و Free BSD را اجرا نماييد.

شما حتی می‌توانيد از VM ها جهت ميزبانی نسخه‌های مختلفی از يك سيستم‌‌عامل استفاده كنيد. مجازی سازی تنها راه اجرای برنامه‌های كاربردی طراحی شده برای Red Hat 7.2 و SuSE 9.0 بطور همزمان روی يك سرور واحد است.

بی‌نقص از هر نظر

مجازی سازی كاری چشمگير است، اما چاره تمام مشكلات نيست. شما هيچگاه نمی‌توانيد يك كامپيوتر شخصی مجازی بسازيد كه از نظر عملكرد بر سيستم فيزيكی زيرين برتری داشته باشد. شما نيازهای سيستم برنامه‌های كاربردی‌تان را از طريق انتقال آنها به محيطی مجازی تا حد بسياری در خواهيد يافت. احتمالا آنها يا بدليل اينكه فضای كمی از سرور اصلی را مورد استفاده قرار دادند- اين حالت معمول است- و يا اينكه چقدر جاگير هستند شما را شگفت زده خواهند نمود. در صورت لزوم، شما می‌توانيد آنهايی كه مناسب نيستند را حذف كنيد.

ودر حاليكه يكی از مزايای عمده مجازی امنيت است- دسترسی غيرمجاز به سيستمی كه وجود ندارد نمی‌توان كاری از پيش برد- يك كامپيوتر شخصی مجازی شده هنوز می‌تواند به خطر بيفتد. خوشبختانه، راه چاره، رونويسی كپی‌ديسك كامپيوتر شخصی مجازی با يكی است كه معلوم است سالم می‌باشد، اما مديريت سرورهای مجازی هنوز نيازمند هوشياری است.

در نهايت، ادغام سخت‌افزار تنها يك دليل انتخاب مجازی سازی سرور است و جاذبه زيادی دارد. با اين همه بسته به نيازهای منحصر به فرد هر بخش، مديران IT مطمئن هستند راه‌های بيشماری پيدا می‌كنند كه مجازی سازی می‌تواند به نفع شركت شما باشد. باوركردنی نيست؟ شايد. اما آنقدر خوب است كه نمی‌توان آنرا از دست داد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 20 اسفندماه 1383

11:07 AM

March 10, 2005

بانك‌هاي اطلاعاتي بسيار بزرگ، دي‌بي2 يا آداباس

وقتي كه تعداد سطرها يا ركوردهاي يك جدول يا فايل از چند صد ميليون يا چندين ميليارد تجاوز كند، يا وقتي كه تعداد مراجعه به يك بانك اطلاعاتي از چند صد مورد در ثانيه تجاوز كند، در ايران، ما احتياج به يك مين‌فريم (MainFreame) معمولي آي‌بي‌ام با سيستم عامل او-اس-390 و بانك اطلاعات دي‌بي2 (DB2) داريم. رقيب قبلي دي‌بي2 عبارت از بانك اطلاعات آداباس(ADABAS) از شركت سافت‌وير اي‌جي (Software AG) بود كه با توجه قيمت زياد، عدم پشتيباني مناسب و اجبار به داشتن ليسانس نرم افزاري، در حال حاضر تا حد زيادي متروك مانده است. اگر چه به صورت موردي و خاص بانك اطلاعات اراكل و سوپرا براي مين‌فريم نيز در سازماني يافت مي‌شود، اما از دور رقابت خارج شده و طالب چنداني ندارند. اين مقاله به نقاط ضعف و قوت اين دو محصول، براي آنهايي كه هنوز شكي در دل دارند مي‌پردازد. اگر تصميم خود را گرفته‌ايد، از همين جا مقاله را رها كرده و ادامه ندهيد.
پس ادامه مي‌دهيم. محصول دي‌بي2 را در حال حاضر 3 شركت مبنا، خدمات انفورماتيك و شركت داده‌پردازي ايران، ارايه و پشتيباني مي‌نمايند. به نظر ما شركت داده‌پردازي ايران از هر نظر و با فاصله بسيار زياد، بهتر از ديگران است. دي‌بي2 به ده‌ها شركت، وزارت‌خانه و بانك فروخته شده است. بانك اطلاعات آداباس، به شركت واحد اتوبوس‌راني، فولاد مباركه، وزارت دارايي و بانك مركزي ايران از طرق مختلفي فروخته شده و اگر چه هنوز كار مي‌كند و پشتيباني مي‌شود، ولي در غير از فولاد مباركه كه داراي ليسانس مي‌باشد، ازآينده نامعلومي برخوردار است. اينك به مقايسه مختصر آنها مي‌پردازيم:

مقايسه اجمالي:

پشتيباني و نگهداري دي‌بي2 در ايران چندين سال است كه بصورت مستمر انجام مي‌گيرد و افراد زيادي نگهداري و تعمير آنرا بعهده دارند كه در كلاس‌هاي آموزشي لازم در كشور انگليس يا شركت داده پردازي ايران حضور يافته‌اند. تعداد افرادي كه با اين محصول نرافزارهاي كاربردي نوشته‌اند زياد مي‌باشد. اكثر توليد كنندگان نرم افزار بصورت كلاينت‌سرور و از طريق ODBC كاربردهايشان را مي‌نويسند. با توجه با محصول استراتژيك آي‌بي‌ام بنام Websphere Application server، مناسب است كه كاربردها را بر روي Internet منتقل نمود تا دسترسي كاربر از طريق Internet بصورت راحت و بدون ترس از ويروس و نقاط ضعف رايانه‌هاي رايج انجام پذيرد.
پشتيباني و نگهداري ADABAS در ايران از بدو ورود آن بصورت خيلي ضعيف ارائه شد و در حال حاضر پشتيباني مناسبي براي آن وجود ندارد. تعداد نفرات براي پشتيباني آن كم است و كاربردهايي كه از قبل با اين محصول نوشته شده است، بدون ارتقا و بهبود در حال اجرا مي‌باشند.

حق امتياز يا ليسانس نرم‌افزار

بانك اطلاعاتي دي‌بي2 بدون ليسانس بوده و با قيمت خيلي كم در دسترس سازمانها قرار مي‌گيرد. ولي بانك اطلاعاتي آداباس با ليسانس بوده و با قيمت خيلي زياد در دسترس قرار مي‌گيرد . حدوداً يك نسخه آن بر روي محيط‌هاي او-اس-390 يا زد-او-اس (Z/OS) بيش از يك ميليون دلار قيمت دارد. محصول بدون ليسانس با پشتيباني خوب، قيمت پائين و بدون اشكال، بهتر از محصولي با ليسانس گمراه كننده، قيمت گزاف و بدون پشتيباني مي‌باشد كه با خود اشكالات عديده‌اي را به همراه مي‌آورد.

آموزش

آموزش بانك اطلاعاتي DB2 در كشور انگليس، و ايران انجام مي‌گيرد كه همه از كيفيت عالي برخوردار مي‌باشند.
آموزش بانك اطلاعاتي ADABAS بيشتر در كشور آلمان و ايران انجام مي‌گيرد كه داراي كيفيت عالي ميباشند.

مستندات

كتاب‌ها و مقالات متعددي از طريق شركت IBM (كه خود يكي از بزرگترين انتشاراتي‌هاي دنيا مي‌باشد) هر لحظه در رابطه با DB2 و محصولات جانبي آن انجام مي‌گيرد. به علت سابقه طولاني در اين امر، نوشته‌هاي آن بصورت روان و ساخت يافته مي‌باشند كه هر كاربر مي‌تواند موضوعات مورد توجه خود را براحتي و به آساني مورد مطالعه قرار دهد.
كتاب ها و مقالات در رابطه با محصولات SoftWare AG يك نقص كلي دارند كه از شركت آلماني آن مي باشد. بدين معني كه كتابها و مقالات اول بزبان آلماني نوشته شده و بعد توسط مترجمين به زبان انگليسي ترجمه مي‌شوند. به سبب اين ترجمه، راحتي و رواني نوشتار حذف شده و در مواردي كيفيت آن پائين مي‌آيد. نكته ديگر اينكه قدرت انتشاراتي آن به اندازه آي‌بي‌ام نبوده و دسته بندي موضوعات در مقايسه با كتابهاي آي‌بي‌ام، ساخت يافته نمي‌باشند. در مواردي هم براي يافتن يك مطلب، بايستي كتابهاي متعددي را مطالعه نمود.

نقاط ضعف و قوت

يكي از اشكالات عمده بانك اطلاعاتي ADABAS رابطه‌اي نبودن آن مي‌باشد. اين بانك اطلاعاتي از Inverted List براي دسترسي به داده‌ها استفاده مي‌نمايد و براي سازگار شدن با محيط‌هاي رابطه‌ايي مشكل عمده و جدي وجود دارد كه بايستي Data Conversion صورت پذيرد. يكي از قوت‌هاي بانك اطلاعاتي DB2 رابطه‌اي بودن آن است كه با دشواري كم مي‌تواند با بانك‌هاي اطلاعاتي رابطه‌اي روي Mainframe يا PC ارتباط برقرار نموده و براحتي به داده هاي آنها دسترسي داشته باشد.
با توجه به نيازهاي امروزي كاربران دنيا كه نيازمند استفاده از كاربردهاي كلاينت‌سرور و تحت وب بسيار محسوس مي‌باشند. توليد اين نوع كاربردها با توجه به ذرايورهاي نوشته شده توسط آي‌بي‌ام و شركت‌هايي كه با آن همكاري مي‌نمايند، بسيار آسان و سريع مي‌باشد كه آداباس و محصولات جانبي آن داراي اين قابليت و راحتي نمي‌باشند.
به جهت اينكه DB2 از سخت افزارهاي خود IBM همچنين از سيستم هاي عامل خود شركت IBM استفاده مي‌نمايد، داراي سرعت بسيار زياد در اجرا است و خيلي مناسب براي پردازش تعداد ركوردهاي عظيم مي‌باشد. در عوض ADABAS براي وفق دادن خود با سخت افزارها و سيتم عامل‌هاي IBM مجبور مي‌باشد كه از رابط‌هايي استفاده نمايد كه در مقام مقايسه، كندتر از مورد DB2 مي‌باشد.
نيز با توجه به امكانات سيستم عامل او-اس-390 يا زد-او-اس براي تنظيم بار و انجام عمليات موازي، مي‌توان مجموعه او-اس-390 و دي‌بي2 را تبديل به يك Transaction Monitor قوي نموده و هزاران كاربر را به صورت همزمان به آن وصل نمود. محيط DB2 براي توليد سيستم‌هاي كاربردي، محيطي امن، آسان، قابل انعطاف و سريع است.

نتيجه گيري:

يك مين‌فريم (MainFreame) معمولي آي‌بي‌ام با سيستم عامل او-اس-390 و بانك اطلاعات دي‌بي2 (DB2) مي‌تواند بستري مناسب براي سامانه‌هاي بسيار بزرگ و عظيم سازمان‌ها، بانك‌ها، وزارت‌خانه‌ها و شركت‌هاي بزرگ ايراني باشد. اين راه حل مي‌تواند هزاران كاربر همزمان، چند صد تراكنش موازي و همزمان و چندين ميليارد قلم اطلاعاتي را پشتيباني نمايد. چون داراي ليسانس نيست، قيمت آن ارزان بوده و از پشتيباني مناسب ايراني برخوردار است. از تمام استانداردهاي روز دنيا براي توليد نرم‌افزارهاي كلاينت سرور و تحت وب، پشتيباني مي‌نمايد.

مختصري در باره شركت سافت‌وير اي‌جي SoftWare AG با اختصار (SAG)

يكي از ده شركت بزرگ و مستقل توليد كننده نرم‌افزار در جهان و بزرگترين شركت نرم افزاري در اروپاست و مركز آ ن در شهر دارمشتاد آلمان واقع شده است. اين شركت در سال 1969 تاسيس گرديده. محصولات خود را از طريق بيش از 80 نمايندگي در سراسر جهان عرضه مي‌نمايد. فعاليت‌ها‌ي اين شركت در زمينه توليد و بازاريابي محصولات نرم افزاري بنيادي و كاربردي است. مشخصات شركت به قرار زير است:
- يكي از معتبرترين و پر سابقه‌ترين شركت‌هاي كامپيوتري دنيا
- توليد كننده بزرگ انواع محصولات سازماني
- ارايه كننده بزرگ تكنولوژي‌هاي جديد و قوي جهت بانك‌هاي اطلاعاتي
- درآمد ساليانه شركتSAG حدود يك ميليارد دلار است
- 4000 كارمند فعال
- پشتيباني سخت افزاري: IBM main frame , Intel
- پشتيباني نرم افزاري: Win95/98/2000/NT, unix, open Vms

نرم افزارهاي زير محصولات بنيادي اين شركت مي‌باشند:

ABABAS : سيستم مديريت پايگاه داده يا بانك اطلاعات
predict : فرهنگ داده‌ها
Natural : محيط تكنولوژي نسل چهارم

علاوه بر اينها SAG تعداد زيادي محصولات نرم افزاري ديگر در زمينه هاي مختلف عرضه نموده است.

-Natural security Connect
-Predict case Text Retrival
-ADABAS
-com-plete
-Entire net-work
-EntireX
-Entire Access
-Entire Broker
-Super natural

در سال 1971 نخستين نسخه ADABAS به بازار عرضه شد. در سال 1972 نخستين شعبه SAG در امريكاي شمالي تاسيس شد. اين شركت توجه و قواي خود را روي بازار امريكاي شمالي متمركز كرد. در سال 1976 مجددا توجه خود را معطوف به اروپا نمود و در همين سال شروع به توليد زبان نسل چهارم natural نمود كه اين زبان در سال 1979 به بازار عرضه شد. بانك اطلاعاتي ADABAS بهمراه ساير محصولات اين شركت حدودا از 13 سال پيش وارد بازار ايران ش و در چندين سازمان و ارگان مختلف بكار گرفته شد. شركت داده پردازي ايران در چند سال اول ورود اين محصول به ايران وظيفه پشتيباني آن را بعهده داشت. بانك اطلاعاتي ADABAS از نسخه V4.3 به ايران وارد شد و بالاترين نسخه‌اي كه در ايران در حال حاضر نصب شده است نسخه V7.1.3 مي‌باشد.

بانك اطلاعاتي DB2

از سال 1983 كه شركت IBM بانك اطلاعاتي DB2 را بر روي سيستم عاملMVS ارايه نمود، تاكنون تغييرات مثبت زيادي در آن ايجاد شده تا نيازهاي جديد و روز افزون كاربردهاي كامپيوتري را برآورده سازد. همزمان با اين تحولات، شركت IBM اين محصول را براي محيط‌هاي ديگر نيز ارايه نمود و در سال 1997 با ارايه DB2 برروي سيستم‌هاي عامل VSE/ESA,UNIX,windows عملا ورود اين محصول را به محيط‌ سيستم‌هاي باز (open systems) اعلام نمود. برخي از خصو صيات DB2 عبارتند از:
- قابليت دستيابي (Accessible)
- قابليت كاربردي (Applicable)
- قابليت اشتراك گذاشتن اطلاعات
- قابليت كنترل و مديريت اطلاعات (Manageable)
- قابليت اتصال به سيستم‌هاي باز (Extensible)
شركت IBM با درك روشن از موقعيت كنوني تكنولوژي اطلاعات، پردازش توزيع شده Distributed Processing، client/server ، سيستم‌هاي باز (open system)، تكنولوژي پديده‌گرا (object oriented technology) و پردازش شبكه‌اي را محور اصلي توسعه كليه رده‌هاي كامپيوتري خود برگزيده است.
بانك اطلاعاتيDB2 از سال 1378 از طريق شركت داده پردازي ايران وارد شده و بلا فاصله شركت‌ها، وزارت‌خانه‌ها، سازمان‌ها و بانك‌هاي مختلفي اين محصول را خريداري نموده و بكار گرفتند. با توجه به امكانات وسيعي كه اين بانك اطلاعاتي در اختيارشان قرار مي‌داد، شروع به نوشتن كار بردهايشان نمودند. بانك اطلاعاتي رابطه اي DB2 از نسخه V5.1 وارد بازار ايران شد و نسخه‌هايي از آن بر روي سيستم عامل‌هاي مختلفي از جمله windows, linux, os/390, mvs,VSE/ESA نصب گرديد. در حال حاضر آخرين نسخه قابل دسترسي آن DB2 V7.1 مي‌باشد.
بر روي DB2 7.1 ابزارهاي مختلفي براي پشتيباني و نگهداري و راهبري آن موجود ميباشد. شركت داده پردازي ايران از جمله شركت‌هايي است كه پشتيباني و نگهداري اين محصول را در حال حاضر بعهده دارد. DB2 پيشگام بانك‌هاي اطلاعاتي رابطه‌ايي مي‌باشد كه در حال حاضر قابليت object-relational نيز به آن اضافه شده و بيش از 80 ميليون كاربر در حدود 350000 شركت ازآن استفاده مي‌نمايند.

ويژگيها:

- بزرگترين و معتبرترين شركت كامپيوتري دنيا
- توليد كننده بزرگ انواع محصولات سخت افزاري ونرم‌افزاري
- درآمد ساليانه شركتIBM يكصد بيليون دلار است
- 280000 كارمند فعال
- پشتيباني سخت افزاري: IBM Mainframe, RISC, As/400, SUN Sparc, HP/ux, PS/2
- در حال حاضر سه نوع ساخت مختلف ازآن وجود دارد:
1) DB2 UDB for Windows, OS/2, unix and linux
2) DB2 UDB for AS/400
3) DB2 UDB Server for os/390 & Z/os

يونيورسال Universal,UDB

UDB به معني اين است كه DB2 قادر مي‌باشد هر نوع اطلاعات الكترونيكي شامل موارد زير را ذخيره نمايد:
- داده‌هاي رابطه‌اي سنتي
- اطلاعات باينري ساختار يافته و غير ساختار يافته
- مستندات و متون به هر زباني
- گرافيك، تصوير، صوت، فيلم
- نقشه‌هاي جغرافيايي (GIS)
2) DB2 UDB همچنين به منابع داده‌اي ديگر دسترسي دارد. شامل :
- DB2 Family
- ديگر بانك‌هاي اطلاعاتي رابطه مانند Oracle يا Sybase
- بانك‌هاي اطلاعاتي غير رابطه‌اي از قبيل VSAM يا IMS
- OLE DB2 Providers (MS-Access Or MS-Excel)

ابزارهاي موجود بر روي DB2 V7.1:

1) DB2 Adminstration tool
2) DB2 Automation tool
3) DB2 Data Expore Facility
4) DB2 Table Editor
5) DB2 Buffer Pool Analyzer
6) DB2 Performance Monitor
7) DB2 Archive Log Compression tool
8) DB2 Log Analysis Tool

ابزارهايي مجاني بر روي كلاينت:

DB2 Control Center
DB2 Procedure Builder
DB2 Extenders
DB2 Installer
DB2 Visual Explain
DB2 Estimator
Net.Dara for os/390

ابزارهاي مرتبط با DB2 كه وارد بازار ايران نشده است:

DB2 Data Propagator for os/390
DB2 Object Restore Tool for os/390
DB2 Web Query Tool for os/390
DB2 SQL Performance Analyzer for os/390
DB2 Recovery Manager for os / 390
DB2 Object Comparison Tool for z /os
DB2 Data Joiner

مشخصات نويسنده: آقاي ميرحميد رضايي، مدير بانك‌هاي اطلاعاتي شركت بهسازان ملت، rezaee@behsazan.com تلفن:0212009194

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 20 اسفندماه 1383

03:15 PM

March 10, 2005

نصب اسکوئید در سه سوت !

نویسنده : نیما دلخاک

ناشر : ایستنا

اینجا می خوام خیلی راحت و ساده نصب اسکوئید رو بهتون بگم از اول

موقع نصب لینوکس غیر از پارتیشن های معمول مثل

Code:

/boot

/

/swap

بسته به حجم هاردتون یک یا دو پارتیشن با اسم زیر ایجاد کنین

Code:

/00

/01

موقع نصب ترجیها نرم افزار mc رو نصب کنین
موقع نصب تیک ادشینال سافت ورز رو بزنید و ام سی رو از توی شلز پیدا کنید و تیک بزنید

حالا که لینوکس نصب شده به ترتیب این کار ها رو بکنید
1 - این دستورات رو به تعداد پارتیشن هایی که ساختید بزنید

Code:

chown  squid.squid  /00

chown  squid.squid  /01

mc رو اجرا کنید
فایل squid.conf رو باز کنید اونو میتونید تو آدرس زیر پیدا کنید

ETC ---> squid ---> squid.conf
مقادیر زیر رو به ترتیب سرچ کنید و از حالت پیش فرض به این چیز هایی که میگم تغییر بدین

Code:

 visible_hostname [ a name ]

 cache_mem 128

 maximum_object_size 8192

 ipcache_size 8192

 cache_dir ufs /00  [hajme partition] 16 256

 cache_dir ufs /01  [hajme partition] 16 256

 cache_access_log  <--- alamate number sign ro az ghablesh pak konid

 cache_store_log   none

 negative_dns_ttl  0 min

 http_access_allow  all

 httpd_accel_ host virtual

 httpd_accel_port 80

 httpd_accel_with_proxy  on

 httpd_accel_uses_host_header on

 ie_refrash on

ذخیره کنین و خارج شین

3- دستور setup رو بزنین
رو انتخاب کنید system service
squid , named رو تیک بزنین
خارج شید

حالا دستور زیر رو اجرا کنین
squid -z

کار اسکوئید تمومه میتونید راه افتادن اون رو با دستور زیر تست کنید
pstree
باید این خط رو ببینید
squid --> squid --> unlinked
میمونه transparent کردن که از این دستورات استفاده کنید

Code:

Iptables –A INPUT –s ! [ your network ip / mask ex. 10.10.20.1/25 ] –d [ cache server IP ] –p tcp –dport 3128 –j DROP

Iptables –A PREROUTING –t nat –p tcp –dport 80 –j REDIRECT –to-port 3128

Iptables-save

فقط برا ایکه فایل لاگتون زیاد پرنشه اینکارو بکنین که هر یه ساعت خالیش کنه
تو
ETC/cron.hourly/
یه فایل از cron.mountly به اینجا کپی کنید و محتویاتشو تغییر بدین به این شکل

Code:

#! /bin/sh

cat /dev/null > /var/log/squid/access.log

EXIT0;

مخلص همه /\/ / /\/\ /\

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 4 فروردینماه 1384

12:57 PM

March 24, 2005

سیمبیان چیست ؟

در ابتدا تلفن های همراه دارای ساختار پیچیده ای نبودند . سخت افزار محدود نیاز به نرم افزارهای پیچیده نداشت ، تا اینکه شرکتهای مطرح ساخت گوشی های تلفن همراه نسل های دوم و سوم گوشی های خود را عرضه کردند . این گوشی ها دارای امکانات سخت افزاری بیشتری بودند که شامل سی پی یو ، رم و هارد بوده و تقریبا به صورت یک کامپیوتر کوچک طراحی شدند . در این زمان بود که این شرکتها به اهمیت نرم افزار در این گوشی های پی برده و رقابت نرم افزاری در کنار رقابت سخت افزاری شروع شد . مایکروسافت یکی از شرکتهایی بود که قبلا روی سیستم عامل کامپیوتر های جیبی خود کار کرده بود و Windows CE را به همین منظور طراحی کرده بود . این ویندوز قابلیت این را داشت که روی موبایل ها نیز نصب شود . بعد از رسمیت یافتن موبایل های نسل جدید شرکت های مطرح در این صنعت که به مشکلات بی شمار Windows CE پی برده بودند و نمی خواستند نرم افزار این صنعت را در انحصار یک شرکت نگه دارند با همکاری هم سیستم عامل جدیدی برای موبایل ها به وجودد آوردند که Symbian نام گرفت . البته رقبای دیگری نیز مثل سیستم عامل Linux در این صنعت وجود دارند که فعلا به صورت عمده استفاده نشده اند . در اصطلاح به موبایل هایی که از این سیستم عامل استفاده می کنند SmartPhone گفته می شود .

پیدایش و حیات Symbian :
شرکت نرم افزاری Symbian برای اولین بار در ماه ژوئن سال 1998 به صورت کاملا مخفی و خصوصی برای کار بر روی سیستم عاملی برای کار روی موبایل ها تاسیس شد . مقر اصلی این شرکت در انگلیس تاسیس شد اما هم اکنون دارای حدود 750 کارمند در کشورهای انگلیس ، ژاپن ، سوئد و آمریکاست که درکار تحقیق و برنامه نویسی برای گسترش سیستم عامل و نرم افزارهای آن هستند . تا اواخر سال 2003 هیجده موبایل از پنج شرکت معروف سونی ، نوکیا ، فوجیتسو ، موتورولا و زیمنس با این سیستم عامل عرضه شد و علی رغم قیمت بالا مورد استقبال قرار گرفت و حدود 26 موبایل هم در برنامه این شرکتها و چند شرکت دیگر با این سیستم عامل در برنامه ساخت قرار گرفت . هم اینک نیز 48 مورد از این موبایل ها به بازار عرضه شده و یا به زودی عرضه خواهد شد . آمار فروش موبایل های Symbian تا پایان سال 2003 به 6.7 میلیون موبایل رسید و در سال 2004 نیز با رشد بی سابقه فروش مواجه شد به طوری که طبق آمار شرکت در سال 2004 فروش این نوع موبایل ها رشد 201 درصدی داشته است . به علت فروش بالای موبایل های Symbian هر روزه بر تعداد برنامه نویسان آن افزوده شده و نرم افزارهای فوق العاده ای برای این سیستم عامل طراحی می شود . تا اواخر تابستان سال 2004 تعداد این برنامه ها 3254 مورد گردیده است .

شرکت های به وجود آورنده :
14 شرکت اصلی و چند شرکت فرعی از به وجود آوردندگان این محصول بودند ، بعضی از این شرکتها در زمینه نرم افزار و بعضی از آنها در زمینه سخت افزار به رشد این سیستم عامل و موبایل های آن کمک کرده اند . از اصلی ترین شرکتها می توان به Nokia ، Sony-Erricson ، LG ، Samsung ، Motorola ، Arima ، BenQ ، Fujitsu ، Lenovo ، Sanyo ، Sendo ، Mitsubishi Electronics و Siemense اشاره کرد .

تکنولوژی Symbian :
Symbian شبیه دیگر سیستم عامل های مدرن و امروزی که برای PC ها وجود دارند ، به وجود آمده است . بنابراین دارای امکانات خوبی مثل Multitasking ، MultiThreading و همچنین مدیریت حافظه می باشد . در طراحی اولیه مبنای کار را بر روی این موضوع بنا نهاده اند که این سیستم عامل می بایست روی امکانات سخت افزاری بسیار کم ( مثل 4 مگابایت رم ) کارایی فوق العاده ای داشته باشد . به همین دلیل این سیستم عامل می تواند روی موبایل های امروزی فوق العاده سریع کار کرده و حداقل مشکل را داشته باشد . مبنای کار این سیستم عامل بر اساس event ها بنا نهاده شده است ( شبیه دیگر سیستم عامل های امروزی مثل ویندوز ) و سی پی یو طوری مورد استفاده قرار می گیرد که کمترین میزان بار روی موبایل قرار گیرد . هم اکنون با اینکه نسخه هشتم Symbian عرضه شده است اما نسخه 7 این سیستم عامل روی موبایل ها قرار می گیرد و تا به حال نسخه های مختلفی از آن بدون اینکه به صورت کامل استفاده شوند به فراموشی سپرده شده اند . جالبترین مورد برای این سیستم عامل به وجود آمدن اولین کرم و ویروس موبایل روی این سیستم عامل در سال 2004 بود . این کرم که Cabir نام دارد می تواند با استفاده از تکنولوژی Bluetooth خود را به موبایل های دیگر منتقل کند .

زبانهای برنامه نویسی برای Symbian :
بدون شک زبان اصلی برنامه نویسی برای Symbian زبان C++ است اما زبانهای مختلفی برای برنامه نویسی در این سیستم عامل به وجود آمده اند . از جمله مهمترین زبانها می توان به OPL ، Python ، Visual Basic ، Perl و Personal Java اشاره کرد . هر یک از این زبانها می توانند امکانات کامل برنامه نویسی در Symbian را فراهم نمایند . رشد زبانهای برنامه نویسی در این سیستم عامل بسیار سریع می باشد . به طوریکه نصف این زبانها همین امسال وارد این سیستم عامل شده اند و بدون شک این رشد با ورود زبانهای دیگر ادامه خواهد یافت . ابزارهای برنامه نویسی مختلفی از جمله ادیتورهای متنوع نیز برای کار با این زبانها به همراه شبیه سازهای موبایل ( برای تست برنامه روی PC قبل از نصب آن روی موبایل ) به بازار عرضه شده است .

رابط های کاربری :
هم اکنون دو رابط اصلی کاربری برای Symbian به وجود آمده است . اولین رابط که بیشترین استفاده را در موبایل ها دارد توسط نوکیا نوشته شده است . این رابط دارای نسخه های مختلفی است اما Series 60 نسخه اصلی این رابط است که بسیار مورد استقبال قرار گرفته است . رابط کاربری دوم با نام UIQ به وجود آمده است که دارای امکانات بسیار خوبی است و رفته رفته در حال باز کردن جای خود در بین شرکت های تولید کننده موبایل است . هر دوی این رابط ها به صورت کاملا گرافیکی و شبیه به هم طراحی شده اند و کار با آنها بسیار راحت است .

بازی بر روی Symbian :
خوشبختانه سیستم عامل Symbian یکی از غنی ترین سیستم عامل ها برای بازی کردن است . به خصوص بعد از تولید N-gage اولین کنسول بازی موبایلی توسط نوکیا که بر اساس Symbian و رابط کاربری Series60 به وجود آمد ، سیل بازیهای مختلف و حرفه ای به سوی این موبایل و در کنار آن این سیستم عامل سرازیر شد . حتی شرکت های مطرح بازی سازی هم اکنون به صورت حرفه ای روی این سیتم عامل و موبایل های دارای این سیستم عامل سرمایه گذاری می کنند .

منبع خبر: سایت AboutSymbian
ترجمه : www.winbeta.net نیما گلشاهی

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 7 فروردینماه 1384

08:05 PM

March 27, 2005

امضاء ديجيتالي و كاربرد آن در حفظ امنيت شبكه

از : مهدي راستي
امضاء ديجيتال يكي از روشهاي ايمن‌سازي اطلاعات است كه كاربردي مشابه با امضاء معمولي در معاملات دارد و يكي از روشهاي معتبر حفظ امنيت در شبكه مي باشد .

اين روش به خصوص در مساله تجارت الكترونيك كه امروزه در جهان صنعت و فن آوري از طرفداران بسياري برخوردار است ، جايگاه ويژه‌اي دارد.

در مساله تجارت الكترونيك با دو مساله مهم روبرو هستيم كه اولي تصديق اصالت ، و دومي محرمانگي است .

تصديق اصالت به اين معنا كه آيا شخصي كه ادعا ميكند آقاي الف است، درست مي‌گويد؟، و محرمانگي به اين معنا كه در صورتي كه شخص ثالثي پيام‌هاي ارسالي و دريافتي را از طريق شبكه گوش دهد، نمي‌تواند محتواي پيام را تشخيص دهد.

امضاء ديجيتال عمدتا در مورد مشكل اول مطرح مي‌شود. بدين ترتيب كه فرد الف بايد توسط يك كليد خصوصي ادعاي خود را تصديق كند و اين توسط گيرند احراز هويت شود.

بسياري از قوانين مدرن امروزي كه از روش امضاء ديجيتال بهره جسته‌اند، الگوريتم كليد عمومي را به عنوان الگوريتم رمزنگاري انتخاب كرده‌اند.

اليته سيستم‌هاي كليد عمومي مي‌توانند براي حل هر دو مشكل فوق استفاده شوند، يعني هم محرمانگي اطلاعات را فراهم كنند و هم تصديق اصالت كنند.

الگوريتم كليد عمومي بدين شكل عمل مي‌كند كه براي فراهم كردن محرمانگي پيام با كليد عمومي دريافت‌كننده رمز مي‌شود و براي تصديق هويت پيام با كليد خصوصي فرستنده رمز مي‌شود.

در مورد هر كدام از اين روشها ، الگوريتم رمزنگاري براي تمام پيام بكار مي‌رود .

بطور خلاصه سيستم‌هاي كليد عمومي امكانات زير را ايجاد مي‌كنند كه شامل تاييد فرستنده و صحت داده‌هاي ارسالي فرستنده براي گيرنده ، و هم چنين صحت گيرنده براي فرستنده در برابر تقلب شخص ثالث است.

چنين امري به حفاظت شبكه كمك مي‌رساند و درجه اعتبار را به ويژه در تجارت الكترونيك بالا مي‌برد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 7 فروردینماه 1384

08:06 PM

March 27, 2005

سال 1384 براي طراحان وب: حرکت به سوي طراحي مبتني بر CSS

بهروز نوعي پور
سه شنبه 2 فروردين 1384
از ماهنامه شبکه

اشاره :
استفاده از تكنيك CSS-based Design تاثيري محسوسي روي زيبايي صفحات وب و سبک‌تر شدن آن هنگام استفاده از مرورگر دارد. اين موضوع ممكن است هم براي طراحان وب و هم براي كاربران اينترنت مهم باشد.

اگر شما نيز يک طراحي وب هستيد، لابد مي‌دانيد يا دست‌کم شنيده‌ايد که مدتي است يک شيوه جديد در طراحي صفحات وب مورد توجه متخصصان اين عرصه قرارگرفته ‌است. اين شيوه جديد که اصطلاحا CSS-based Design يا طراحي مبتني بر CSS ناميده مي‌شود در مقابل روش متداول کنوني، يعني Table-based Design مطرح شده است و تعداد قابل توجهي از طراحان برجسته جزو حاميان آن به شمار مي‌آيند. دقت کنيد که ((طراحي مبتني بر CSS)) به غير از ((استفاده از CSS‌ در طراحي صفحات)) است. در شيوه فعلي چيدمان عناصر يک صفحه وب به کمک جدول بندي انجام مي‌شود. شيوه‌اي که مشکلات خاص خود را دارد و طراحان وب به خوبي با آن آشنا هستند. اما در شيوه جديد با استفاده از امکانات Cascading Style Sheets مي‌توان صفحات وب را آسان‌تر، دقيق‌تر، زيباتر و سبک‌تر و از همه مهمتر (و جالب‌تر) بدون استفاده از المان Table طراحي کرد.
اين تکنيک در طراحي صفحات وب البته موضوع جديدي نيست و از معرفي آن توسط طراحان برجسته‌اي مانند Eric Meyer (مولف يکي از معروف‌ترين کتاب‌ها در زمينه CSS) و ديگران خيلي وقت است که مي‌گذرد. اما چنانکه پيداست هنوز اين روش جديد طراحي در ميان طراحان وب از استقبال چنداني برخوردار نشده است. يک علت اصلي در اين زمينه آنست که هنوز نرم‌افزارهاي مهم و معروفي مثل Dreamweaver ، Microsoft Frontpage و Adobe GoLive اين تکنيک را به عنوان روش پيش فرض طراحي صفحات وب اختيار نکرده‌اند و بسياري از طراحان وب که از اين برنامه‌ها استفاده مي‌کنند، همچنان ناگزيرند به روش مرسوم عمل کنند.

اما چرا اين موضوع را براي يادداشت نوروزي امسال انتخاب کرده‌ام؟ دو سه دليل براي اين کار داشتم. نخست اينکه به بهانه سال جديد از شما دعوت کنم پيش از آنکه اين تکنيک توسط نرم‌افزارهاي مذکور پذيرفته شود، به اهميت اين شيوه جديد دوباره بينديشيد، شايد مانند من تصميم بگيريد که به سمت تکنيک مبتني بر CSS حرکت کنيد. اين شيوه امکان ايجاد تغييرات راديکال در Layout صفحات وب را آسان مي‌کند. موضوعي که در پروژه‌هاي بزرگ اهميت خاصي دارد. من اگرچه اين يادداشت را برايتان نوشته‌ام اما هنوز خودم تجربه و مهارتي در اين زمينه ندارم و تنها پس از بررسي‌هاي فراوان به اين نتيجه رسيدم که ديگر زمان آن فرارسيده‌است که خودم را با شيوه جديد سازگار کنم.
دليل دوم که ممکن است مهمتر به نظر برسد تاثيري است که به‌کارگيري اين شيوه در افزايش زيبايي صفحات و سبک‌تر شدن آن هنگام استفاده از مرورگر دارد. طبق ارزيابي‌هاي فني انجام شده، سرعت بارگذاري صفحات وبي که بر اساس جدول طراحي شده‌اند کمتر از سرعت صفحات مشابهي است که بر اساس CSS ‌طراحي شده‌اند زيرا مرورگر براي تفسير جداول HTML و نمايش‌آنها که گاه به دليل تعدد و تودرتو بودن بسيار پيچيده مي‌شوند، بايد زمان بيشتري از سيکل‌هاي پردازنده کامپيوتر را مصرف کند. اين خبر براي کاربران ايراني اينترنت مي‌تواند اهميت زيادي داشته باشد زيرا اگر سرعت کند دسترسي به وب در ايران را همچنان يک معضل مهم تلقي کنيم، آنگاه معلوم مي‌شود که با حرکت همگاني طراحان وب به سمت استفاده از اين تکنيک جديد، مخاطبان سايت‌هاي ايراني شاهد يک بهبود قابل ملاحظه در ميزان سهولت دسترسي به سايت‌هاي ايراني خواهند بود. اگر به کيفيت پايين سرويس دهي برخي از شرکت‌هاي ميزباني وب (Hosting) در ايران و کند بودن پاسخ سرورهاي روي اين ميزبان‌ها (Server Response) توجه کنيم، آنگاه اهميت اين موضوع دوچندان مي‌شود. در عين حال شيوه مورد بحث به گونه‌اي است که طراح وب را وادار مي‌کند که از طراحي مبتني بر تصوير يا Image-based Web Design که به دليل وجود نرم‌افزارهايي مانند Adobe ImageReady و Macromedia Fireworks و سهولت استفاده از آنها (تکنيک استفاده از Slice‌ها) بسيار رايج است هرچه بيشتر پرهيز کند. چيزي که به نوبه خود موجب افزايش راندمان نمايش صفحات وب و سهولت ايجاد تغييرات بعدي در آنها مي‌شود.
استفاده از روش مبتني بر CSS‌ دقيقا به همين دليل طراحان وب را از استفاده از جاوا اسکريپت‌هايي که توسط نرم‌افزارهاي مذکور صرفا براي کارهاي ساده‌اي مانند Mouse Rollover داخل صفحات وب تزريق مي‌شوند بي‌نياز مي‌کند و اين به نوبه خود بازهم صفحات را سبک‌تر و انعطاف‌پذيرتر مي‌کند. بنابراين دلايل متعددي وجود دارد که نشان مي‌دهد جايگزين کردن تدريجي شيوه جديد به جاي شيوه قديمي يک کار قابل توجيه است.
خواستم از فرصت آغاز سال جديد استفاده کنم و به اين بهانه روي اهميت موضوع تاکيد و دوستان و همکارانم را به ورود به اين عرصه تشويق کنم. بحث فني تفصيلي درباره اين تکنيک را به مقاله‌اي جداگانه در آينده واگذار مي‌کنم ولي براي آنکه دست خالي نيز اين صفحه را ترک نکنيد، پيشنهاد مي‌کنم اگر به اين موضوع علاقه‌مند هستيد و هنوز چيزي درباره آن نمي‌دانيد، مطالب موجود در سايت Zen Garden متعلق به Dave Shea (که مولف يکي از بهترين کتاب‌ها در زمينه طراحي مبتني بر CSS‌ است) را مطالعه کنيد و مثال‌هاي اشاره شده در آن را ببينيد. سال خوبي برايتان آرزو مي‌کنم.

پي‌نوشت:
لازم به يادآوري است که هم‌اکنون تعدادي از سايت‌هاي ايراني (خصوصا برخي وبلاگ‌ها) از اين روش استفاده کرده‌اند و اينگونه نيست که کسي در ايران با موضوع آشنايي نداشته باشد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 8 فروردینماه 1384

01:47 PM

March 28, 2005

بابيلون چيست؟

بابيلون در واقع يک ديکشنري است اما به نظر من بابيلون همه چيز است. (چرا؟)

به خاطر اينکه به هر زباني و در هر تخصصي که بخواهيد ترجمه مي کند.

طرز کار بابيلون به اين صورت است که يک فايل exe که خود برنامه مي باشد را نصب مي کنيد سپس فايلهاي bgl که شامل خود ديکشنريها هستند را به آن معرفي مي کنيد.

براي دريافت ديکشنري بايد به سايت www.babylon.com مراجعه کنيد.

تاکنون بابيلون تا ورژن 5.0.4 ساخته شده است که هر يک از ورژنهاي آن داراي چندي ايراد بوده اند.

بابيلون 3 : در اين نسخه گرافيک برنامه بسيار پايين بود و ايرادهايي که داشت اين بود که شما قادر به نصب بيش از 25 ديکشنري نبوديد.

بابيلون 4 : گرافيک آن نسبت به نسخه قبل کمي بهتر شد و در آن مي توانستيد تا 30 ديکشنري را نصب کنيد. اما براي نصب هر ديکشنري يک سريال لازم داشتيد.

بابيلون 5 : اين نسخه از نظر گرافيکي فوق العاده است ولي با اين حال يک مورد مشکل در آن مشاهده شده و آن هم غير قادر بودن ترجمه از زباني غير اروپايي (مانند عربي) به ساير زبانها است.

بابيلون 5.0.4 : در اين نسخه که جديدترين نسخه مي باشد تاکنون هيچ مشکلي مشاهده نشده است.

حال براي دانلود بابيلون ورژن 5 اينجا را کليک کنيد(5 مگابايت):

http://www.babylon.com/redirects/download.cgi?type=400

براي دانلود ديکشنريهاي که بوسيله بابيلون ساخته شده اند به اينجا برويد:

http://www.babylon.com/display.php?id=141&tree=5&level=2

براي دانلود ديکشنريهايي که به وسيله افراد ساخته شده اند به اينجا برويد:

http://www.babylon.com/gloss/glossaries.html

بعد از دانلود اولين کاري که بايد بکنيد نصب ديکشنري انگليسي به انگليسي است که آن را مي توانيد از اينجا دريافت کنيد:

http://info.babylon.com/glossaries/385/Babylon_English.BGL

سايز اين ديکشنري 6 مگابايت است.

بعد از اين کار براي اينکه بتوانيد لغتي را تلفظ کنيد بايد برنامه ديگري هم دريافت کنيد.

در مورد ساير ديکشنريها و برنامه پخش صدا بعداً صحبت مي کنم.

نکته اي که يادم رفت بگويم، ديکشنريهايي بابيلون به 70 زبان و به تعداد بيش از 1600تا مي باشد که بويسله کاربران ساخته شده اند.

يعني افراد آنها را ساخته اند. بعداً در اين مورد مفصلاً توضيح مي دهم.

وقتي که ديکشنري را نصب کرديد به مدت يک ماه مي توانيد از آن استفاده کنيد اما بعد از يک ماه در برنامه دچار بعضي مشکلات خواهيد شد.

براي همين بايد سريال برنامه را وارد کنيد.

من چون خودم چندين ديکشنري در بابيلون ساخته ام داراي سريال شخصي هستم که به مدت يکسال است.

همينطور کرک برنامه هم دارم.

طرز کار بابيلون

حال براي دانلود بابيلون ورژن 5 اينجا را کليک کنيد(5 مگابايت)

http://www.babylon.com/redirects/download.cgi?type=400

براي آپديت کردن بابيلون هم اين لينک را کليک کنيد، بهتر از به جای لینک بالایی لینک زیر را دانلود کنید:

http://www.babylon.com/redirects/purchase.cgi?type=64

پس از اينکه آن را دانلود کرديد آن را نصب کنيد.

حال آن را اجرا کنيد.

براي اجراي آن دو راه داريد:

1- لغتي را در متني مي بينيد و مي خواهيد آن را ترجمه کنيد، مي توانيد با فشار دادن کليد موس و گرفتن يک کليد (شيفت يا کنترل و ...) ترجمه آن لغت را مشاهده نماييد.

2- کليد F10 را فشار و لغت مورد نظر را وارد نماييد.

براي تغيير دادن اين تنظيمات از منوي اصلي گزينه Configuration را انتخاب کرده سپس در قسمت Find مي توانيد با کليک روي دکمه Change تنظيمات دلخواه را انجام دهيد.

در پنجره اصلي برنامه يک جعبه متن براي وارد کردن لغت و در کنار دو دکمه وجود دارد. دکمه Go ترجمه را نشان مي دهد، دکمه بعدي (Say it) کلمه را تلفظ مي کند که براي اينکار نياز به دانلود برنامه لازمه خود را داريد که از اينجا مي توانيد دريافت کنيد:

http://www.babylon.com/display.php?id=14&tree=3&level=2#2

در قسمت بالا 4 دکمه وجود دارد که به ترتيب عبارتند از:

Close: براي بستن پنجره

Fits window size: براي تغيير اندازه پنجره به بهترين سايز متناسب با لغات

Menu: تنظيمات برنامه

Fix current window…: با اين کار پنجره هميشه در جلوي برنامه ها قرار مي گيرد.

در قسمت مياني ترجمه لغت را ميتوان ديد.

اما در قسمت پايين دو لينک وجود دارد:

Online Glossaries: اگر به اينترنت متصل باشيد معني لغت مورد نظر در تمام ديکشنريها به نمايش در مي آيد.

Spelling Alternatives : تمام لغاتي که شبيه لغت مورد نظر مي باشد به نمايش در مي آيد. اين ويژگي زماني به درد مي خورد که هجاي يک لغت را به درستي ندانيد.

در قسمت بالا زير نوار عنوان چندين دکمه وجود دارد، دو دکمه که به شکل مثلث هستند لغت بعد و قبل را نشان مي دهند، و اگر روي دکمه Sidebar کليک کنيد منوي سايدبار نشان داده مي شود که شامل اين موارد است:

در قسمت Results تمام ديکشنريهايي که نصب کرده ايد و لغت توسط آنها ترجمه شده است به نمايش در مي آيد که با کليک بر روي هر يک ترجمه آن ديکشنري به نمايش در مي آيد.

Glossary options: در اين قسمت تمام ديکشنريهايي را که نصب کرده ايد نمايان است. در اين قسمت مي توانيد مکان هر يک از آنها را مشخص و آنها را حذف يا نصب نماييد.

Web Search: در اين قسمت لغت مورد نظر به وسيله موتوهاي جستجو مشخص مي شود.

Conversions: در اين قسمت که کمي جالب است مي توانيد تبديلاتي از قبيل واحد پول و زمان و اندازه ها را انجام دهيد. (اگر در بابيلون عددي را وارد کنيد آن عدد در اين قسمت به واحدهاي ديگر تبديل مي شود)

وقتي لغتي را وارد کنيد ترجمه آن در کادر ترجمه نمايان مي شود. اگر اين لغت در يکي از ديکشنريهاي مربوط به خود بابيلون ترجمه شود در کنار لغت نوع آن به وسيله يک حرف n يا v يا adj يا ... (اسم، فعل، صفت و ...) مشخص مي شود، در بابيلون 5 در کنار اين حرف مثلثي قرار دارد که اگر روي آن کليک کنيد ليستي تمام مشخصات کلمه از قبيل جمع و مفرد و ماضي و ... را نشان مي دهد. سپس اگر روي هر کدام از لغات درون ليست کليک کنيد منويي به نمايش در مي آيد که شامل دو گزينه است، اولي آن لغت را کپي مي کند و بعدي آن را درون برنامه اي که اکنون اجرا شده است Paste مي کند.

دیکشنریهای بابیلون

در این قسمت شما را با دیکشنریهای بابیلون آشنا می کنم.

همانطور که قبلاً گفته بودم پس از دانلود و نصب بابیلون نیاز به دیکشنریهای آن که در فایل BGL هستند نیاز دارید.

این دیکشنریها در زبانهای مختلف و در زمینه های متنوع می باشند.

برای دانلود این دیکشنریها به این صفحه بروید:

http://www.babylon.com/gloss/glossaries.html

بابیلون بیش از 1600 دیکشنری در 70 زبان دنیا را دارا است.

اگر در این صفحه بروید قسمتی به نام search وجود دارد که اگر در آن کلمه ای وارد کنید دیکشنریهایی که در مورد آن کلمه هستند را جستجو می کند.

در قسمت پایین آن عناوین متفاوتی از قبیل Languages و Education و News & Media و ... وجود دارد. اگر بر روی هر کدام از آنها کلیک کنید صفحه ای باز می شود که خود شامل دیکشنریهای متفاوت است.

برای مثال روی قسمت Languages کلیک کنید. صفحه دیگری در مقابل شما باز می شود که شامل تمام زبانهای دنیا می باشد. برای نمایش دیکشنریهای فارسی در قسمت Persian بروید.

حال تمام دیکشنریهای فارسی در روبروی شما می باشد.

دیکشنریهایی با نامهای متفاوت می بینید (اگر در پایین صفحه اعداد 1 و 2 و ... را ببینید یعنی اینکه صفحه های دیگری از آن موضوع موجود می باشد)

حال می توانید یکی از کارهای زیر را انجام دهید:

1- روی عنوان دیکشنری کلیک کنید تا اطلاعات بیشتری در روبروی شما در مورد آن دیکشنری قرار گیرد (اطلاعاتی از قبیل ورژن و امتیاز و ...)

2- روی دکمه دانلود کلیک کنید تا دیکشنری را به طور کامل دانلود کنید.

3- روی دکمه Subscribe کلیک کنید تا دیکشنری را به طور موقت داشته باشید یعنی اینکه فایلی حدود 2 کیلو بایت دانلود می کنید و هنگامی که به اینترنت متصل هستید می توانید معنی لغات را ببینید، در حالی که اگر آن را به طور کامل دانلود کنید اگر به اینترنت وصل نباشید می توانید معنی لغات را ببیند.

اطلاعاتی که از هر دیکشنری در سایت نمایان است عبارتند از:

1- عنوان دیکشنری

2- توضیحاتی از دیکشنری از دیدگاه نویسنده آن

3- نام سازنده دیکشنری (در قسمت راست)

4- تعداد لغات دیکشنری (زیر نام نویسنده)

5- تعداد کاربرانی که آن را دانلود کرده اند (زیر تعداد لغات)

و اگر روی اطلاعات بیشتر دیکشنری بروید اطلاعات بیشتری از قبیل ایمیل و سایت سازنده و امتیاز آن و توضیحات آن از دیدگاه سایت بابیلون را می توانید ببینید. همینطور می توانید به سازنده آن پیشنهاداتی بدهید.

فکر کنم به اندازه کافی از توضیحات دیکشنری آگاه شدید. حال در مورد هر یک از دیکشنریها توضیح می دهم (و تعدادی از دیکشنریهای جالب آن).

1- Babylon English-English: کامل ترین دیکشنری سایت بابیلون که لغات را با تمام معانی آن و در تمام زمینه ها از قبیل کامپیوتر و پزشکی و معانی خودمانی (اسلنگ) و نام افراد و مکانها و لغات تخصصی و ... را به انگلیسی ترجمه می کند. تعداد لغات آن 140 هزار و مجموع معانی آن حدود 2 میلیون و سایز آن 6 مگابایت می باشد.

http://info.babylon.com/cgi-bin/temp.cgi?id=901&layout=gt_new.html

نمونه ترجمه:

bush [bʊʃ]

n. perennial plant which has woody stems and branches and ranges in height from very low to the size of a small tree, shrub; wilderness, outback; tuft; minor league

•

Bush [bʊʃ]

n. famil name; George Walker Bush (born 1946), 43rd president of the United States (2001-), former governor of Texas; George Herbert Walker Bush (born 1924), 41st president of the United States (1989-1993)

2- Concise Oxford English Dictionary: یازدهمین نسخه دیکشنری معروف آکسفورد که دارای 240 هزار لغت و 1700 لغت جدید می باشد. به نظر من این دیکشنری به این دلیل جالب است که هر لغتی را که وارد می کنید معنی آن همراه با اسم و فعل و صفت و قید و ... ، تمامی اصطلاحات آن لغت ، طرز استفاده از آن (گرامر) ، مخففها، و در آخر ریشه آن کلمه را به شما می گوید(که از چه کشوری گرفته شده است و به چه معناست). سایز آن 9 مگابایت می باشد.

http://www.babylon.com/redirects/download.cgi?type=1044

نمونه ترجمه:

rock1

■ noun
1> the hard mineral material of the earth's crust, exposed on the surface or underlying the soil. ▶a mass of this projecting out of the ground or water. ▶(the Rock) Gibraltar. ▶a boulder. ▶N. Amer. a stone of any size.
2> Geology any natural material with a distinctive mineral composition.
3> Brit. a kind of hard confectionery in the form of cylindrical peppermint-flavoured sticks.
4> informal a diamond or other precious stone.
5> informal a small piece of crack cocaine.
6> (rocks) vulgar slang a man's testicles.

Phrases:
between a rock and a hard place informal faced with two equally difficult alternatives.
get one's rocks off vulgar slang have an orgasm.
on the rocks informal
1> experiencing difficulties and likely to fail.
2> (of a drink) served undiluted and with ice cubes.

Derivatives:
rockless adjective
rock-like adjective

Origin:
ME: from OFr. rocque, from med. L. rocca.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 11 فروردینماه 1384

01:57 PM

March 31, 2005

اندر احوالاتٍ آژاکس

منبع : وبنما

حتما شنيدن واژه‌ی آژاکس شما رو ياد باشگاه آژاکس آمستردام می‌ندازه ولی اين آژاکس(Ajax)ی که من می‌خوام بگم يه چيز ديگست...

¤ Ajax سرنام چه عبارتیه؟ ¤
Ajax مخفف نيست بلکه کوتـاه شده‌ی عبارت Asynchronous JavaScript + XMLه.

¤ حالا این Asynchronous JavaScript + XML یـا آژاکس که می‌گی چی هست؟ ¤
آژاکس مجموعه‌ای از چند فناوری است که تحت مدل ویژه‌ای (معروف به مدل آژاکس) برای ارتباط با web applicationها بکار می‌ره.

¤ اين فناوری‌ها چیـا هستن؟ ¤
XHTML و CSS که طبيعتا برای ارائه مبتنی بر استاندارد (standards-based presentation)
XML و XSLT برای تبادل داده‌ها و manipulation
Document Object Model يا همون Document Object Model برای انجام فعل و انفعال و نمايش دینامیک (dynamic display and interaction)
XMLHttpRequest برای بازيابی اطلاعات ناهمگام (asynchronous data retrieval)
و جاوا اسکریپت

¤ خب٬ مدل آژاکس که می‌گفتی چه فرقی با مدل استاندارد داره؟ ¤
در مدل کلاسيک (استاندارد) تو بخش browser client فقط يه user interface داريم که درخواست‌های HTTP رو به طور مستقيم به وب‌سرور تو قسمت سيستم‌های سمت سرور يا server-side systems می‌فرسته و بعد همين interface پاسخ‌ها رو به صورت داده‌های تلفيقی HTML و CSS دريافت می‌کنه و تحويل کاربر می‌ده. اما در مدل آژاکس بعد از user interface جانوری به اسم موتور آژاکس (Ajax engine) قرار می‌گيره. اين موجود ابتدا توسط user interface و بوسيله‌ی جاوا اسکریپت فراخونی می‌شه (JavaScript Call) و درخواست HTTP کاربر رو دريافت و به صورت XMLHttpRequest به وب/XML سرور ارسال می‌کنه. سپس پاسخ‌ها به صورت داده‌های XML به اين موجود دوست داشتنی داده می‌شه. موتور آژاکس هم عين بچه‌ی آدم اون‌ها رو تبديل به HTML + CSS data می‌کنه و تحويل اينترفيس می‌ده.

¤ حالا اين همه جنگولک بازی چه فايده‌ای داره؟ ¤
فايدش در اينه که کار سريع‌تر پيش می‌ره چونکه مدل آژاکس ناهمگام(asynchronous)ه ولی مدل کلاسيک همگام(synchronous)ه.

¤ فارسی بلغور کن ما هم بفهميم! ¤
اين تصوير همه چيز رو بهتر می‌گه.

¤ تـا حالا چه کسايی از آژاکس استفاده کردن؟ ¤
گوگل يکی از کمپانی‌هايست که از آژاکس به خوبی استفاده کرده. ارکات٬ جی‌ميل٬ نسخه‌ی جديدGoogle Group ٬ Google maps و Google Suggest همگی نمونه‌هايی عالی از به کارگيری آژاکس هستند.
A9.com و Flickr نيز از آژاکس استفاده می‌کنن.

¤ گفتی که XML و XSLT دوتـا از تکنولوژی‌هايی هستن که در applicationهای آژاکس بکار می‌رن ولی ما تو Google Suggest اثری از XML نديديم. جريان از چه قراره؟! ¤
همونطور که قبلا گفتم XML و XSLT برای تبادل داده‌ها بکار می‌رن. منتهی شما مجبور نيستين که برای اين کار حتما از اين دو استفاده کنين. تکنولوژی‌های ديگه‌ای هم مثل JSON وجود داره.

¤ آيا applicationهای آژاکس از applicationهای سنتی بهترن؟ ¤
ببينيد applicationهای آژاکس شامل مجموعه‌ای پیچیده‌ی از کدهای جاوا اسکریپت هستند که بر روی کلاينت اجرا می‌شوند و نوشتن چنين کدهايی بدون داشتن باگ و ايرادهای امنيتی کار بسيار مشکلی است. اما از سوی ديگر چنين applicationهايی فشار بسيار کمتری بر روی سرورها می‌آورد و سرعت بيشتری دارند. همچنين دست توسعه‌گر (developer) را بازتر می‌کند.

¤ آيا applicationهای آژاکس جايگزين applicationهای سنتی می‌شن؟ ¤
شايد٬ به هر جهت آژاکس مزيت‌های فراوانی نسبت به مدل کلاسيک دارد.

امیدوارم مفید بوده باشه.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 15 فروردینماه 1384

01:44 PM

April 04, 2005

دسترسي آسان به دنياي اطلاعات

استفاده از دنياي اينترنت به يکي از نيازهاي روزمره و اصلي ما تبديل شده. اما آيا تا به حال از خود پرسيده ايد چطور اين اطلاعات به دست شما مي رسد؟ web اينترنت را به مفهوم واقعي متحول کرده است. در گذشته اي نه چندان دور ، کاربران اينترنت براي يافتن اطلاعات و استفاده از آن با دشواري هاي فراواني مواجه بودند. در بسياري از موارد کاربر حتي با دانستن آن که اطلاعات در کجا قرار دارد ، نمي توانست از آنها استفاده کند. به همين دليل با ابداع web در 1989 روشهاي دستيابي به اطلاعات ساده شد و رشد اينترنت نيز به طور چشمگيري افزايش يافت. افزودن Java Appletc به صفحات HTML باعث شد تا تبادل اطلاعات مابين کاربر و سرويس دهنده در اينترنت بهتر و ساده تر شود و web را به محيطي جذاب و دست داشتني بدل نمايد.
web هر روز در حال تغيير است زيرا سکويي که برروي آن قرار گرفته هر روز متحول مي شود و هر روز منابع جديد فراواني به آن اضافه مي شود.

بيشترين اطلاعات مربوط به چيست؟

هر مجموعه اطلاعاتي که به طور معمول به شکل صفحات web در دسترس هستند با يک آدرس ويژه قابل دستيابي است و هر روز به تعداد اين آدرس ها افزوده مي شود.
بيشترين منبع اطلاعات در اينترنت و بخصوص در web را دانشگاه هاي جهان تشکيل مي دهند و گروه ديگر محققين هستند که با جمع آوري اطلاعات فراوان در همه زمينه ها و ارائه آن در اينترنت به ارتقاء دانش بشري کمک شاياني مي کنند و گروه بعدي را هم بخش هاي تجاري تشکيل مي دهند.

ارتباط با کامپيوتر اصلي

web کليدي قوي براي اجراي برنامه هاي کاربردي است. درست مشابه يک سيستم عامل در کامپيوترهاي شخصي با اين تفاوت که در web مي توان يک برنامه را براي استفاده چندين کاربرد به صورت همزمان به اشتراک گذاشت. برنامه ها عموما به صورت فايل هاي HTML که در زبان web نيز گفته مي شود هستند. يک فايل HTML در واقع صفحه web را به وجود مي آورد.
کامپيوترهايي که فايل HTML در روي آن قرار دارند server ناميده مي شوند. بنابر اين وقتي صحبت از يک سايت web مي شود ، اشاره به کامپيوتر يا مجموعه کامپيوترهايي است که با برقراري ارتباط با آنها مي توانيم از فايل هاي HTML موجود در آنها استفاده کنيم.

راحتي کار با امکانات جديد

آدرس دهي که در گذشته به کار گرفته مي شد بسيار پيچيده بوده و استفاده از آن مستلزم داشتن دانش فراواني درباره کامپيوتر بود. شايد به همين دليل هم تا اوايل دهه 90 اينترنت عموما توسط متخصصان کامپيوتر مورد استفاده قرار مي گرفت اما با ابداع web توسط دو دانشمند جوان در موسسه اي در سرن سوئيس روشهاي گذشته اگر چه منسوخ نشدند اما ديگر چندان مورد استفاده قرار نمي گيرد.

#

براي آن که در انتخاب آدرس web آشفتگي به وجود نيايد ، موسسه اي به نام internic متولي ثبت و ارائه آنها شده است
هر شرکت ، ارگان يا شخص ، مشخصي با تناسب نوع فعاليت يا نام شرکت و محدوده عملکرد نامي براي استفاده از آدرس web خودش انتخاب مي کند. از طرف ديگر هر آدرس web بيانگر حضور يک شخص يا گروه ، موسسه و... در اينترنت است که براي سهولت دسته بندي آنها بهتر است از مفهوم Domain استفاده شود. براي آن که در انتخاب آدرس webآشفتگي به وجود نيايد ، موسسه اي به نام internic متولي ثبت ارائه آنها شده است.
طراحان سيستم مي توانند تصميم بگيرند که کدام فايل در هنگام مراجعه به آدرس هاي واقع برروي اين Server به عنوان اولين فايل توسط مرورگر باشند. به عنوان مثال طراح تصميم مي گيرد که اولين فايلي که توسط مرورگر به صورت اتوماتيک يافت شده و متغيير مي شود main.html باشد ، به اين ترتيب مراجعه کننده به آدرس ديگر لازم نيست نام فايل را بنويسد بلکه کافي است آدرس را ذکر کند تا سيستم به صورت اتوماتيک فايل اصلي را يافته و تغيير کند. در ابتداي آدرس ها ممکن است عبارت //: http توجه شما را به خود جلب کند.
اين عبارت به معناي نوع پروتکل يا قراردادي است که انتقال اطلاعات را در شبکه انجام مي دهد. نوشتن اين عبارت در ابتداي هر آدرس به مرورگر مي گويد که مي خواهيد از امکانات يک web server استفاده کرده و به يک آدرس web دسترسي پيدا کنيد. هر چند در مرورگرهاي جديد نيازي به نوشتن اين عبارت نيست.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 25 فروردینماه 1384

11:15 AM

April 14, 2005

شبکه‌ي ارتباطات چيست؟

نويسنده : www.softwaremarkeretingsource.com
مترجم : بهاره عابدین
ناشر : همکاران سیستم

به طور ساده مي‌توان شبکه‌ي ارتباطات را هنر ملاقات افراد با هم و سودمندي‌هاي حاصل از اين ارتباطات تعريف کرد.

بيش‌تر فايده‌ي اين‌ گونه ارتباطات به دست آوردن اطلاعات و حرکت به سمت رشد بيش‌تر کسب و کار خواهد بود.

هر ارتباط موفق کاري يا شخصي، بين دو طرف برقرار کننده‌ي ارتباط، ارتباطي يکتاست که در طول زمان ادامه مي‌يابد. شبکه‌ي ارتباط موثر شامل تمام آن چيزهايي است که در ساخت و نگه‌داري بلند مدت ارتباطات با ديگر افراد حرفه‌اي و شاخص به کار گرفته مي‌شوند. اينترنت وسيله‌ي بسيار خوبي براي ايجاد چنين شبکه‌اي است. مي‌توان ارتباطات را از طريق گروه‌هاي خبري، انجمن‌ها و پست الکترونيک توسعه داد. از آن‌جا که هيچ‌چيز به اندازه‌ي ارتباط چهره به چهره و رو در رو در شروع يک رابطه موثر نيست، همايش‌هايي مانند ISDEF و SIC از اهميت ويژه‌اي برخوردار شده‌اند. البته تمام تماس‌ها مفيد و با ارزش نيستند. تمام مسيرها اطلاعات قابل توجهي را فراهم نمي‌آورند، بايد ارزيابي کنيد که آيا يک ارتباط و اطلاعات ناشي از آن ارزش وقت گذاشتن دارد يا خير.

شبکه‌ي ارتباطات درهاي جديدي را به روي شما خواهد گشود، البته بيش‌تر در اين‌باره که "چه کسي را مي‌شناسي و نه اينکه به طور قطع چه چيزي را مي‌داني".

چگونه شبکه ارتباطات را بسازيد؟

1- ياري‌گر واقعي ديگران باشيد.

2- روشنفکر باشيد.

3- جزييات شخصي را به خاطر بسپاريد.

4- به تفاوت‌هاي فرهنگي احترام بگذاريد.

5- درباره‌ي مردم و شرکت‌هاي آن‌ها بررسي کنيد تا با اهداف و علايق‌شان بيش‌تر آشنا شويد.

6- كارهاي خوب ديگران را جبران كنيد.

7- واسطه‌اي براي آشنايي افراد جديد با يكديگر باشيد.

جاي‌گاه اصلي اين شبکه کجاست؟

افراد مختلف در لباس‌هاي متفاوت ظاهر مي‌شوند. هر فرد مي‌تواند به طور بالقوه يک فرصت شبکه‌اي به شمار آيد. اين موضوع درست مانند ترافيک موتورهاي جست‌وجوگر است، هرچه تعداد افراد موجود در شبکه‌ي هدف بالاتر رود، شانس موفقيت در برقراري ارتباط سودمد و سازنده افزايش مي‌يابد. منظور از شبکه‌ي "هدف"، مجموعه‌ي افرادي است که براي برقراري ارتباط قابليت بيش‌تري دارند، برخي از اين افراد يا سازمان‌ها ‌عبارت‌اند از:

1- انجمن هاي تجاري يا سازمان‌هاي صنعتي خاص

2- نمايشگاه‌ها

3- دوستان

4- مدارس

5-گروه‌هاي خبري متمرکز و عناوين مشخص مناظرات

6- مشتريان

7- عرضه‌کنندگان

8- مصرف‌کنندگان

شبکه‌ي ارتباطات خود را بر اساس ارزش گروه‌هاي هدف، پيوسته گسترش دهيد و پالايش کنيد. اگر تنها به منافع يك‌طرفه مي‌انديشيد و فقط در پي به دست آوردن هستيد شبكه‌ي ارتباطي شما به احتمال زياد پيش‌رفتي نخواهد داشت؛ چرا که شبکه ارتباطات موفق عبارت است از برقراري رابطه و تعامل کامل مبتني بر تامين منافع دو طرف. بنابراين اطلاعات خود را با ديگران به اشتراک بگذاريد تا کسب و کار آن‌ها هم رشد کند.

در بسياري موارد شبکه‌ي ارتباطات و همکاري‌هاي مشترک با يکديگر منافات دارند، ولي در برخي موارد باعث هم‌افزايي يکديگر مي‌شوند.

همکاري مشترک

همکاري مشترک يک راه بسيار مناسب براي شرکت‌هاي نرم‌افزاري به منظور بازاريابي و درآمد جديد است. شرکا مي‌توانند نقاط قوت يكديگر را در بازارهاي حساس يکي کنند. اين مساله به طور معمول به اين ترتيب است که شرکت‌هاي بزرگ باعث اعتبار بخشيدن به شرکت‌هاي کوچک‌تر و در عوض شرکت‌هاي کوچک باعث ايجاد و تسهيم دانش در زمينه‌ي تخصص‌‌هاي ويژه براي شرکت‌هاي بزرگ‌تر مي‌شوند. هم‌افزوني ارتباطات در شکل‌هاي مختلف ظاهر مي‌شود، اما بهترين شکل آن وقتي است که همه از آن سود ببرند، همکاري مشترک راه خوبي براي به دست آوردن مشتريان مربوط است. اغلب، شركاي حرفه‌اي به گونه‌اي مکمل يکديگر مي‌شوند که مي‌توانند محصولي ترکيبي ارايه کنند که پيش از اين هيچ‌کدام به تنهايي قادر به توسعه آن نبودند.

انتظارات

بايد درک روشني ازنقاط ضعف و قوت محصولات و شرکت‌ها داشته باشيد. با آگاهي از اين نكات، شما در هر زمينه شرکايي پيدا مي‌کنيد که در نواحي ضعف شما، نقاط قوتي دارند:

1- آن‌چه را بايد سفارش دهيد، مشخص كنيد.

2- مشخص كنيد كه در جست‌وجوي چه هستيد.

3- زمان خود و شريك‌تان را هدر ندهيد.

انواع متفاوت همكاري يا ارتباط كه براي توليدكنندگان نرم‌افزار به كار مي‌روند از اين قرار هستند:

محصول‌سازي

1- تبادل خبرنامه‌ها

2- ادغامات

3- تبادلات خطي

4- تبادل دانش يا فناوري

5- تسهيم درآمد

6- تبادل آگهي

سود دوجانبه در رابطه

يك رابطه‌ي موفق تنها زماني شكل مي‌گيرد كه شامل همكاري دو طرفه و بر مبناي برد طرفين باشد.

كساني كه همكاري‌هاي استراتژيك و شبكه‌ي ارتباطات را كنترل مي‌كنند سود و موفقيت بلندمدت به دست خواهند آورد.

رهنمودهاي نهايي:

1- منابع واجد شرايط را بشناسيد

2- به ياد داشته باشيد كه جنبه‌هايي از حقيقت شما را كساني مي‌سازند كه با آن‌ها در ارتباط هستيد.

3- هر رابطه‌اي مفيد و سازنده نيست.

4- همكاران بالقوه را ارزيابي كنيد.

5- زماني را به تشكر كردن اختصاص دهيد.

6- بدانيد كه نتايج هميشه به صورت آني به دست نمي‌آيند.

7- هميشه كارت بازرگاني خود را به همراه داشته باشيد

بسيار فعال و پي‌گير باشيد. شما مي‌توانيد يك شبكه‌ي ارتباطي گسترده داشته باشيد تا هر زمان كه به آن نياز داشتيد، در دست‌رس باشد. با وجود ابزارهاي سنتي، شبكه‌هاي شخصي براي پيش‌برد كسب و كارتان ضروري هستند. شبكه‌ي ارتباطي، دو طرفه است. پس وقتي كه درخواست كمك مي‌كنيد به كمك ديگران اطمينان داشته باشيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 25 فروردینماه 1384

01:33 PM

April 14, 2005

ويندوز "Longhorn" چيست؟

مترجم: شراره حداد

مايكروسافت اكنون در حال توليد نسخه جديد ويندوز با كدی به نام "Longhorn" می‌باشد. "Longhorn" به منظور ايجاد پايه‌ و اساسی برای ابداع يك صنعت جديد طراحی شده است كه در نهايت شركت‌های بازرگانی را قادر به استفاده از تكنولوژی به نحو احسن و رويارويی با موانع كمتری می‌سازد. و همچنين به مشتريان امكان می‌دهد تا مزايای بيشمار و گسترده اين تكنولوژی را بهتر بشناسند.

"Longhorn" به پيشرفت و بهينه‌سازی موارد مهم ذيل كمك می‌كند:

* تمركز دقيق و جدی روی اصول بنيادی و اساسی سيستم عامل از جمله افزايش سطح قابليت اطمينان، عملكرد و كارآيی و سهولت استفاده.

* كمك هر چه بيشتر به كاربران كامپيوتر به منظور عملكرد هوشيارانه و كسب تجربيات جديد و جالب بدست كاربران خانگی.

* پلاتفرم توسعه دهنده نسل بعدی كه توسعه دهندگان را در ايجاد برنامه‌های كاربردی موفق ياری می‌دهد.

ما در حال حاضر از نزديك با مشتريان خود گفتگو كرده و نظرات آنها را می‌شنويم. چه شما از يك كامپيوتر در خانه يا در محل كار استفاده كنيد يا عضوی از گروه توسعه دهندگان ويندوز باشيد، "Longhorn" مطمئنا ابتكارات عمل بی نظير و بی‌سابقه‌ای را در اختيار شما می‌گذارد كه در واقع دنيای كاربران ويندوز را به دوران و دهه ديجيتال رهنمون می‌سازد.

مايكروسافت تاريخ دقيق دستيابی گسترده به سيستم عامل كلاينت ويندوز "Longhorn" را به 2006 تغيير و اعلام نموده است. تكنولوژی‌های توسعه دهنده ويندوز WinFX نيز برای ويندوز Windows Server 2003 و XP در دسترس خواهد بود.

ردموند، واشنگتن، 27 آگوست سال 2004: شركت مايكروسافت اعلام كرده است كه امكان دسترسی گسترده به سيستم عامل كلاينت (سرويس گيرنده) ويندوز با كد "Longhorn" در سال 2006 فراهم خواهد شد و عناصر مهم اين پلاتفرم توسعه دهنده ويندوز WinFX در "Longhorn" برای ويندوز XP و Windows Server 2003 نيز در دسترس خواهد بود.

"Longhorn" قابليت بهره وری كاربر را افزايش داده و قابليت‌های مهم جديدی را برای توسعه دهندگان نرم‌افزار به ارمغان می‌آورد و همچنين ميزان اهميت، كاربرد و قابليت اطمينان آنرا بالا می‌برد.

بيل گيتس، رئيس بخش نرم‌افزار شركت مايكروسافت گفت، دستيابی مشتريان به "Longhorn" در سال 2006 پيشرفت‌های مهمی را در زمينه‌های كارآيی، ايمنی و قابليت‌ اطمينان ببار آورده و به ايجاد هر چه سريعتر برنامه‌های كاربردی جديد و مناسب بدست توسعه دهندگان صنعت كمك می‌كند.

مايكروسافت پس از عرضه "Longhorn" يك سيستم فرعی ذخيره‌سازی ويندوز را با كدی به نام "WinFX" در اختيار مشتری قرار می‌دهد. اين سيستم ذخيره‌سازی جديد يك سازمان داده و قابليت‌های مديريت پيشرفته‌ای را فراهم می‌سازد كه با در دسترس قرار گرفتن كلاينت "Longhorn" در ابتدا بصورت بتا (آزمايشی) مورد استفاده قرار می‌گيرد.

Jim Allchin، معاون گروه پلاتفرم‌های شركت مايكروسافت گفت، مشتريان ما به طور واضح بيان كرده‌اند كه خواهان افزايش هر چه بيشتر ميزان توليد و بهره‌وری و همينطور كاربرد آسانتر و قابليت اطمينان و امنيت روزافزون هستند، همچون ساير ابتكارات عملی كه اكنون آنها را بكار می‌بنديم. جهت برخورداری مشتريان از اين ويژگی‌ها بايد چندين معامله را انجام دهيم. مصرف‌كنندگان و OEM‌ها (سازندگان تجهيزات اصلی) نيز بدنبال اين ويژگی‌ها در چهارچوب زمانی مناسبی هستند. ديد بلند مدت ما به پلاتفرم ويندوز نيز همينطور باقی خواهد ماند.

Jeff Truax، مدير IT شركت Frontier Airlines گفت: مطالبی كه مايكروسافت اكنون اعلام می‌دارد امكان دستيابی "Longhorn" را سريعتر می‌سازد. به نظر می‌رسد كه با پيشرفت قدرت توليد و بهره‌وری و همچنين امنيت بيشتر و تمركز روی نكات و اصول اساسی، بتوان مزايا و بهره‌ بيشتری در تجارت كسب نمود.

در جلسه‌ای كه با حضور صدها توسعه دهنده برتر شركت‌های سراسر دنيا انجام شد، مايكروسافت اعلام نمود كه تكنولوژی‌های توسعه دهنده ويندوز WinFX از جمله سيستم فرعی جديد عرضه شده با كد "Avalon" و سيستم فرعی جديد برقراری ارتباط با كد Indigo در سال 2006 برای ويندوز XP و Windows Server 2003 مايكروسافت در دسترس خواهند بود، كه در نهايت زمينه مناسب برای توسعه دهندگان را جهت نوشتن برنامه‌هايی كه روی صدها ميليون كامپيوتر قابل اجرا خواهند بود فراهم كرده و گسترش می‌دهد ودر نتيجه تجربيات كاربران اين سيستم عامل‌ها نيز بالا می‌رود.

Scott Borduim مقام ارشد اين تكنولوژی در شركت Autodesk گفت، Avalon و Indigo هر دو به ما امكان می‌دهند تا برنامه‌های كاربردی دلخواه خود و مشتريان كنترل كننده چرخه حيات آنها را ايجاد نماييم. در دسترس بودن Avalon‌ و "Longhorn" برای ويندوز XP همچون "Longhorn" به ما امكان می‌دهد تا اين تكنولوژی‌ها را سريعتر كشف نموده و مورد بهره‌برداری قرار دهيم.

Leslie House، معاون Vivendi Universal Games Knowledge Adventure Studio گفت، ظهور هسته پلاتفرم جديد WinFX در ويندوز XP و ويندوز 2003 به برنامه‌های كاربردی WinFX امكان می‌دهد تا پايگاه‌های نصب شده گسترده‌تری را در برگرفته و پلاتفرم بهتر و جذابتری را برای نرم‌افزار آموزشی ما ايجاد نمايد.

"Avalon" يك سيستم فرعی گرافيكی است كه سازندگان را قادر به ايجاد برنامه‌هايی می‌سازد كه ميزان تجربيات كاربران را بالا می‌برد.

"Indigo" نيز روش جديدی برای ايجاد و اجرای سيستم‌های مرتبطی است كه بر اساس معماری مبتنی بر سرويس‌های وب ساخته شده است. پشتيبان سرويس‌های وب پيشرفته در "Indigo" پيام‌های قابل تبادل مطمئن‌تر و ايمن‌تر و همچنين قابليت عمل گسترده‌تر در چند محيط را فراهم می‌سازد.

بيانات كنونی فقط به سيستم عامل كلاينت "Longhorn" مربوط می‌شود. قابليت دستيابی به سيستم عامل سرور ويندوز "Longhorn" نيز تا سال 2007 ادامه خواهد يافت.

Copyright 2005 IDG News Service.All right reserved.
Copyright 2005, PC World Iran, All rights reserved.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 28 فروردینماه 1384

07:48 PM

April 17, 2005

با انواع DVD آشنا شويد

اميرحسين نصراللهي - از سال 1996 که ديسکهاي ذخيره اطلاعات با فرمتي به نام DVD وارد بازار شدند ، تاکنون پسوند هاي متعددي بر اين فرمت اضافه شده که از جمله آنها مي توان به پسوندهاي -R,+R,-RW,+RW,+R DLاشاره کرد.
در واقع افزوده شدن اين پسوند ها از زماني آغاز شد که ديسکهاي دي وي دي با قابليت رايت کردن وارد بازار شدند.
متاسفانه بر خلاف سي دي ها ، استانداردهاي متفاوتي براي ساخت يک ديسک دي وي دي وجود دارد و گوناگوني اين استانداردها تا حدودي باعث سر درگمي مشتريان براي خريد دستگاهي مناسب مي شود. اين هفته مي خواهيم اين پسوند هاي متفاوت را براي شما رمز گشايي کنيم.
براي اين منظور بد نيست ابتدا به معرفي دو اتحاديه عظيم که در زمينه دستيابي به استاندارد هاي پيشرفته تر با يکديگر رقابت دارند ، بپردازيم. DVD FORUM نام اتحاديه اي شامل بيش از 200 کمپاني بزرگ است که در زمينه پيشرفت تکنولوژي ديسکهاي دي وي دي همکاري دارند.
از جمله اين کمپاني ها مي توان به هيتاچي ،ميتسوبيشي ، سوني و پايونير اشاره کرد. اين اتحاديه وظيفه ثبت استاندارد هاي جديدي که از طرف شرکت هاي عضو ارائه مي شودرا بر عهده دارد.استانداردهايي که اين اتحاديه ارائه مي کند همگي داراي يک علامت منفي در کنار پسوند دي وي دي هستند.از طرف ديگر DVD+RW Alliance نام اتحاديه ديگري است که در رقابت شديد با DVD FORUM است.
اعضاي اين اتحاديه نيز بالغ بر 200کمپاني بزرگ هستند که از جمله آنها مي توان به ياماها، سوني ، DELL و hp اشاره کرد. در اين ميان نکته جالب حضور کمپاني سوني در هر دو اتحاديه است.
استانداردهاي ارائه شده اين اتحاديه همانطور که از نام آن مشخص مي شود با يک علامت مثبت همراه است. در واقع مي توان وجود اين استانداردهاي متفاوت را نتيجه رقابت اين دو اتحاديه دانست که سعي دارند با وضع اين استانداردها فروش محصولات جانبي مربوط را نيزانحصاري نمايند.
فرمت هاي اتحاديه DVD FORUM عبارتند از:
DVD-R: در اينجا حرف R مخفف کلمه RECORDABLE است. به اين ترتيب شما ميتوانيد با استفاده از يک دستگاه رايتر دي وي دي اطلاعات را بر روي اين ديسک ذخيره نماييد.
فناوري بکار رفته دراين استاندارد بسيار شبيه به فناوري استاندارد CD-R است که در آن ديسک يک بار رايت مي شود و مي توان آن را بارها خواند.
دستگاههاي که داراي اين استاندارد هستند تنها مي توانند بر روي سي دي هاي DVD-R رايت نمايند.
(DVD-RW :(DVD-R/W ديسک هاي داراي اين استاندارد نيز قابل رايت هستند وفن آوري به کار رفته در آنها بسيار شبيه ديسک هاي CD-RWاست.
دستگاههايي که داراي اين استاندارد هستند قابليت پخش و رايت بر روي ديسک هاي DVD-RW و DVD-R را دارند.در مقابل ، ديسک هاي اتحاديه DVD+RW Alliance با فورمت هاي مثبت قرار دارند که مي توان گفت از چند جهت بر مدلهاي منفي برتري دارند ، ازجمله مي توان به امکان اضافه کردن ، پاک کردن وهمچنين جابجا کردن اطلاعات بر روي ديسک رايت شده - بدون تاثير گذاشتن براطلاعات ديگر- اشاره کرد. همچنين عمل فايناليزه کردن ديسک نيز به نحوي انجام مي شود که سرعت خواندن اطلاعات از روي ديسک بالا مي رود.
DVD+R: ديسک هاي اين استاندارد نيز قابل رايت هستند. دستگاههايي که داراي اين استاندارد هستند تنها مي توانند اطلاعات را بر روي ديسک هايي با فرمت DVD+R رايت کنند.
DVD+RW: دستگاهي که داراي اين فرمت باشد مي تواند بر روي ديسک هايي با استاندارد DVD+R و DVD+RW اطلاعات را رايت کند و ديسک هاي اين استاندارد نيز از نظر عملکرد تفاوتي با مدل DVD+R ندارند.
اين نکته لازم به ذکر است که تمامي ديسک هاي با استانداردهاي بالا در رده اي از dvd با نام dvd 5 يا dvd 10 قرار دارند dvd 5 ديسکهايي با يک لايه و يک لبه و ظرفيت 4.7GB هستند و ديسک هاي dvd10 داراي يک لايه ودو لبه و 9.4GBظرفيت هستند.
DVD+R DL: اين نوع ديسک ها از همان فن آوري ديسک هاي DVD+RW بهره مي برند با اين تفاوت که داراي دو لايه مي باشند. به اين ترتيب ظرفيت اين ديسک ها نسبت به مدل هاي قبلي دو برابر شده است. اين ديسک ها جزو رده اي از ديسک ها با نام DVD 9 و DVD 18 هستند. ديسک هاي DVD 9 داراي دو لايه و يک لبه و ظرفيت 8.5GB هستند و ديسک هاي dvd 18 داراي دو لايه و دو لبه وظرفيت 15.9GB اند. تمامي ديسک هاي ذکر شده در بالا دراکثر دستگاههاي پخش دي وي دي رايج در بازار قابل خواندن هستند.
استاندارد ديگري که توسط اتحاديه آليانس ارائه شده است DVD-RAM است که مزيت اين نوع ديسکها بر مدلهاي قبلي امکان چند بار رايت اطلاعات بر روي آنها است. از طرف ديگر اين نوع ديسک ها در دستگاههاي موجود دربازار قابل پخش نيستند و براي استفاده از آنها تياز به دستگاهي متفاوت است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 29 فروردینماه 1384

10:29 PM

April 18, 2005

ارزيابي، كليد طلايي موفقيت سايتهاي اينترنتي

با توجه به رشد استفاده از اينترنت در كشور و توجه بيشتر سازمانها و شركتها به استفاده از آن، اين سوال مطرح مي‌شود كه وب سايت هر مركز به عنوان پنجره‌اي به آن ، آيا توان اطلاع‌رساني و رفع نياز مراجعين را دارد؟ يك كارشناس وب سايتهاي اينترنتي جواب به اين سوال را مطرح كردن بحث "ارزيابي و معيارهاي ارزش يك سايت" عنوان كرد.

" عليرضا پرورش " گفت: بحث "ارزيابي سايت" (‪ (Site Evaluation‬يكي از بحثهاي مطرح در دنياي اينترنت است كه از اوايل دهه ‪ ۹۰‬ميلادي هر روز به اهميت آن افزوده مي‌شود.

وي افزود: با گسترش هر چه بيشتر تجارت الكترونيكي در دنيا بالاتر بودن رتبه يك سايت براي افزايش موفقيت، هر روز اهميت بيشتري پيدا مي‌كند.

وي بااشاره به اينكه مهمترين پارامتر براي ارزيابي يك سايت تعداد بيننده آن است، گفت: باتوجه به اين نكته كه ماهيت اينترنت پوشش يك سايت در سراسر جهان است، تعداد بيننده مهمترين عامل برتر بودن يك سايت محسوب مي‌شود.

وي تصريح كرد: انتخاب سايتهاي برتر دنيا معمولا با استفاده از اين پارامتر انجام مي‌شود.

به گفته وي در ارزيابي اين مبحث، مواردي مانند تعداد بيننده در هر روز ، تعداد صفحه‌ديده شده در هر روز و تعداد صفحه ديده شده به ازاي هر بيننده مطرح مي‌شود.

اين كارشناس،معيار ديگري كه براي ارزيابي سايتها مطرح مي‌شود را "سرعت" آن دانست و گفت: بيننده بايد در كمترين زمان ممكن به اطلاعات موجود در سايت دست پيدا كند.

پرورش مهمترين ابزار براي نمايش و بدست آوردن پارامترهاي ذكر شده را استفاده از نرم‌افزارهاي آماري مخصوص وب‌سايت دانست كه تمامي پارامترهاي آورده شده در اين بحث را به همراه اطلاعات كاملا جزئي و دقيق در اختيار قرار مي‌دهند.

وي نرم‌افزار "ديپ ماتريكس"(‪ (DeepMatrix‬از نوع ابزار "‪ "Server Side‬و دو نمونه ابزار "‪ "Client Side‬شامل "‪ "Stats.ir‬و "‪ "netsup.com‬را از جمله نرم افزارهاي مناسب ارزيابي سايت معرفي كرد.

يك كارشناس فناوري اطلاعات نيز معيارهاي ارزيابي يك وب سايت را مواردي مانند سرعت بالا آمدن و نحوه طراحي صفحات، نحوه استفاده از آمار سايت براي جذب بيننده بيشتر و روشهاي جلب بيننده به سايت دانست.

"عطا خليقي" با اشاره به موارد فوق خاطرنشان كرد: كه هنوز به اهميت اين مباحث در ميان سايتهاي ايراني توجه خوبي نشده است.

وي با تاكيد بر اينكه در زمان حاضر سايتهاي ايراني بيشتر به‌يك "بروشور" تبديل شده‌اند، گفت: تا زمانيكه بحث تجارت الكترونيكي در بين سايتهاي ايراني قابل اجرا نباشد بايد وجود اين بروشورهاي اينترنتي را بپذيريم.

وي با اشاره به اينكه سايتهاي خارجي به مبحث ارزيابي بسيار اهميت مي‌دهند، گفت: آنها مواردي مانند جستجوي بهتر در موتورهاي جستجوگر، روشهاي افزايش بيننده، كمك بهتر و بيشتر به كاربر براي استفاده از خدمات ارايه شده روي سايت و فروش بيشتر را همواره مد نظر دارند.

خليقي، تصريح كرد: بي‌توجهي به معيارهاي ارزيابي سايت، در ميان سايتهاي دولتي بيشتر به چشم مي‌خورد چرا كه براي آنها به دليل نبود امكانات تجارت و كم اهميتي تعداد بينندگان، اين مبحث نيز مطرح نيست.

وي يكي ديگر از دلايل عدم توجه مديران سايتهاي ايراني به مبحث ارزيابي سايت را پايين بودن ضريب نفوذ اينترنت در كشور و نبود فرهنگ استفاده صحيح از اينترنت دانست.

يك كارشناس بازاريابي الكترونيك در اين زمينه، آشنا نبودن طراحان وب ايراني بامقوله ارزيابي وب سايت به صورت حرفه‌اي و تخصصي را مطرح كرد.

"مهدي رودكي" در گفت وگو با ايرنا گفت: اكثر سايتهاي ايراني تنها براي عقب نماندن از " طايفه سايت داران " طراحي شده‌اند و گويا براي كارفرمايان آنها مهم نيست كه سايت آنها چه تاثيري در كسب و كارشان خواهد داشت.

وي بيان داشت : طراحان وب ايراني توانمند هستند اما هيچگاه‌توان خود را در قالب يك پروژه كه براي كمك به كسب و كار مشتري ، شامل مواردي مانند انتخاب نام دامنه، طراحي و برنامه‌نويسي سايت، بازاريابي الكترونيك، تحليل آمار سايت، تحليل فروشها و موارد بسيار ديگر است، به كار نمي‌گيرند.

اين كارشناس درباره ارزيابي سايت گفت: اين مقوله به دارنده سايت كمك مي‌كند تا به نحو موثرتري با مخاطبان خود ارتباط برقرار كرده و مخاطبان واقعي را شناسايي كند.

رودكي ، ارزيابي سايت را شامل طراحي و برنامه‌نويسي ، معماري اطلاعات، تهيه محتوا و مخاطب سنجي ، بازاريابي، فروش و روانشناسي مخاطب دانست.

وي با اشاره به اينكه موتور جستجوگر مهمترين بيننده هر سايت است، گفت:
حضور درموتورهاي جستجوگر و فهرستها،تعداد پيوندهاي به سايت و صفحات داخلي آن و رتبه‌هاي سايت نيز از موارد ديگر ارزيابي يك سايت به شمار مي‌آيند.

به گفته وي با استفاده از برخي ابزار تحليل آمار سايت مانند‪،WebAlizer‬ ‪ WebTrend ،DeepMetrix ،ClickTracks‬مي‌توان تعداد كاربران، صفحات بازديد شده، فايلهاي درخواست شده، فرمهاي پر شده، كلمات جستجو شده، سايتهاي لينك دهنده، فناوري مورد استفاده كاربران و موارد ديگر را بررسي كرد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 29 فروردینماه 1384

11:19 PM

April 18, 2005

پايگاه داده هاى پيشرفته

نويسنده: احمد پهلوان تفتى

تعريف علمى و تئوريكى كه از پايگاه داد ها در دنياى نرم افزار ارائه گرديده است عبارت است از : مجموعه اى از داده هاى بهم مرتبط كه طبق يك ساختار مشترك ، تحت كنترل متمركز و با حداقل افزونگى به صورت اشتراكى و همزمان قابل استفاده باشند .

اما امروز وقتى صحبت از فناورى هاى نوين در عرصه پايگاه داده ها و نرم افزار هاى مرتبط با آن به ميان مى آيد، محيطى به مراتب قدرتمند تر و انعطاف پذير تر از تعريف فوق به ذهن مى آيد كه براى مديران ، طراحان و برنامه نويسان پايگاه داده ها نويد لذت بخش توسعه و توليد سريع(RAD) محيطهاى مبتنى بر بانك هاى اطلاعاتى را بهمراه دارد .

در سالهاى اخير متوليان و تصميم گيران بسته هاى بانك هاى اطلاعاتى با توجه به شرايط حاكم بر دنياى امروز از قبيل رشد روز افزون داده ها و اطلاعات ، وسعت ، گستردگى حيطه كاربرى و ..... استانداردهاى متنوع ديگرى را براى اينگونه محصولات تدوين نموده اند كه در ذيل به برخى از آنها اشاره مى گردد .

Platform Independency:
اين مقوله مربوط به مفهوم قابليت نصب و راه اندازى بسته بانك اطلاعاتى بر روى سيستم عامل هاى مختلف (انعاف پذيرى در نصب) است . يك پايگاه داده پيشرفته لزوما وابسته به سيستم عامل خاص و يا احتمالا بستر سخت افزارى ويژه اى نيست و از اين طريق قابليت انعطاف پذيرى و اطمينان بالايى را براى كاربران خود فراهم مى آورد .

Locking & Concurrency:
براى اطمينان از صحت داده ها و جلوگيرى از تاخيرها و انتظارات طولانى در محيط هاى پر كار پايگاه داده ها ، از اين تكنولوژى جهت مديريت بهينه فرآيندها و داده هاى بانك اطلاعاتى استفاده مى شود .

Long Term Transaction Handling:
در يك محيط پايگاه داده بعضا تراكنش (Transaction) يا تراكنش هايى در سيستم به صورت معلق (Suspend) بوجود مى آيند ( بدين معنى كه پس از ارسال آنها دستور همانند دستور Commit مبنى بر تائيد آنها صادر نمى گردد ) كه اين امر باعث بروز ترافيك در صف مربوط به تراكنش ها و توقف نسبى آنها مى شود. يك پايگاه داده مناسب بايد بتواند اين امر را بخوبى كنترل و مديريت نمايد .

Memory Utilization Support:
كنترل در نحوه تخصيص و واكشى حافظه ، تنظيم و به طور كلى مديريت حافظه ديگر امتيازى است كه در يك پايگاه داده پيشرفته وجود دارد .

Encoding & Decoding Data:
يك پايگاه داده پيشرفته امنيت بالايى براى داده ها و كاربران خود فراهم مى آورد . از جمله اين موارد مى توان به توانايى به رمز در آوردن داده هاى ذخيره شده در بانك اطلاعاتى اشاره نمود .

Block Level Recovery :
در يك بانك اطلاعاتى پيرشفته ، در صورت بروز خرابى در بانك ، شما مجبور به بازيابى تمام فايل ها (Full Recovery) نيستيد . يعنى مى توان فقط بلاك هاى معيوب را بازيابى نمود و فرآيندى را بر روى ساير داده ها انجام نداد .

64 Bit Proccessing:
اين واژه به مفهوم پردازش در مدل 64 بيتى است كه سرعت و كارآيى بالترى را نسبت به ساير مدل ها بهمراه دارد .

Multimedia & Large Object Support:
مديريت و كنترل در نحوه خيره و بازيابى داده هاى بزرگ كاراكترى ، باينرى ، صوتى و تصويرى در تمامى پايگاه داده هاى پيشرفته وجود دارد .

Standby Database:
Satandby يك پشتيبان از پايگاه داده اوليه است كه بر روى يك سرور ثانويه قرار مى گيرد و تمام تغييرات پايگاه داده با يك تكنولوژى خاص بر روى آن درج مى گردد و به صورت Standby در موارد بروز خطا و نارسايى در بانك ، فعال گرديده و مورد استفاده كاربران قرار مى گيرد .

Cluster Support:در يك پايگاه داده توزيع يافته (Distributed Database) در صورت سنگين شدن پردازشهاى يك سرور و يا ازدياد تراكنش در طرف يك يا چند سرور خاص ، بايد امكان انتقال فرآيندها به سوى سرورهاى ديگر وجود داشته باشد . اين مهم در پايگاه داده هاى مدرن امروزى همچون Oracle وجود دارد .

ANSI/SQL 92 Standard Compatible:
رعايت موارد مندرج در استانداردANSI / SQL 92 از ملزومات و پيش نيازهاى يك پايگاه داده پيشرفته است كه در آن تمامى موارد مورد لزوم براى بانك هاى اطلاعاتى امروزى لحاظ گرديده است .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 30 فروردینماه 1384

12:04 PM

April 19, 2005

مزيت ما در بخش نرم‌افزار است

دیدگاه دکتر صفوی در حوزه مخابرات
تنظیم: سعید سلیمانی

دربارة توانمندي شرکت‌هاي داخلي مخابرات، هم ابراز ترديد شده است و هم ابراز تأييد. اما نکتة مهم اين است که بدانيم دقيقاً در کدام حوزه از مخابرات توانمند هستيم و در کدام بخش، به‌ناچار بايد از محصولات خارجي استفاده کنيم. دکتر صفوي، سرپرست پژوهشکده شبکه در مرکز تحقيقات مخابرات ايران و عضو هيأت علمي دانشگاه صنعتي اميرکبير، در گفتگو با ايتان به بيان اين نکته پرداخته است که مزيت ما در بخش نرم‌افزار است:

براي بررسي توان داخلي در صنعت مخابرات بايد به تقسيم‌بندي سخت‌افزار/ نرم‌افزار در اين صنعت توجه کرد. هم‌اکنون، در پروژه‌هاي مخابراتي که در آنها از سيستم‌هاي هوشمند استفاده مي‌شود، بيش از 70 درصد سرمايه‌گذاري‌ها مربوط به بخش نرم‌افزار و کمتر از 30 درصد آن مربوط به قسمت سخت‌افزاري پروژه است؛ به همين دليل، در حال حاضر، کشورهايي که نيروي‌هاي انساني مستعدي دارند، فرصت دارند که بخش نرم‌افزاري پروژه‌هاي بزرگ مخابرات جهان را انجام دهند؛ امروزه، در هندوستان و حتي ايران، شاهد اين توانمندي هستيم.

مزيت ما در نرم‌افزار است

به عنوان شاهدي بر اين ادعا، مي‌توان به تجهيزات " سافت‌سوئيچ " اشاره کرد؛ در حال حاضر، گرايش جهاني مخابرات به سمت سوئيچ‌هاي چندمنظوره‌اي است که بتوانند چندين کاربرد داشته باشند. به عنوان مثال، يک سوئيچ MSC موبايل ، عملکرد سوئيچ تلفن ثابت را داشته باشد و درعين حال، وظيفه سوئيچ ديتا را انجام دهد و کنترل آن نيز به طور نرم‌افزاري انجام شود. بنابراين، مي‌توان گفت روزبه‌روز، نقش نرم‌افزار در پروژه‌هاي مخابراتي پررنگ‌تر مي‌شود. بنابراين، با توجه به نيروي متخصصي كه در اختيار داريم، در کشور ما توان رقابتي بسيار خوبي در حوزة طراحي و کار با نرم‌افزارهاي مخابراتي وجود دارد.

خودکفايي به معناي توليد همه‌چيز نيست

در زمينة توليد قطعات سخت‌افزاري بايد به اين نکته توجه کرد که لازم نيست يک کشور، تمام قطعات مورد نياز پروژه‌هاي خود را در داخل بسازد تا خودکفا محسوب شود. ممکن است ما فقط توانايي طراحي سيستم ( system engineering ) داشته باشيم و در عين حال، برخي تجهيزات مورد نياز را از ديگر کشورها وارد کنيم؛ همان کاري که ديگر کشورها هم انجام مي‌دهند. به عنوان مثال، قسمت RF ترمينال‌هاي VSAT ، که در ايران هم خيلي از آنها استفاده مي‌شود، از ژاپن تهيه مي‌شود. يعني درحاليکه کمپاني سازندة اصلي در مريلند آمريکاست و به‌عنوان يکي از بزرگ‌ترين توليدکنندگان ترمينال‌هاي VSAT در دنيا شناخته شده است، قسمت‌هاي RF مورد نياز خود را از ژاپن مي‌خرد. دليل اين امر آن نيست که آمريکا نتوانسته‌ است تکنولوژي RF را در VSAT به‌دست آورد ؛ علت آن است که اين شرکت، براساس ملاحظات اقتصادي يا به دليل اولويتي که به سرمايه‌گذاري در بخش‌هاي ديگر داده است، اين قسمت از کار را به ژاپني‌ها واگذار کرده است.

بنابراين نبايد تصور کنيم براي خودکفايي بايد حتي کوچکترين بخش‌هاي سخت‌افزاري، مانند مقاومت يا IC و يا هرگونه چيپ هوشمند را خودمان بسازيم. زيرا در اين صورت، چون توان انجام همة بخش‌ها را نداريم، تصور خواهيم کرد که در هيچ زمينه‌اي توان رقابت و توليد نداريم.

خودکفايي در مخابرات به اين معني است كه در عين حال كه ممكن است برخي تجهيزات مورد نياز را از خارج وارد کنيم و يا در قالب پروژه‌هاي مشترک، آنها را توليد کنيم، بتوانيم توان مهندسي سيستم و طراحي را به دست آوريم. البته نمونه‌هايي از اين قبيل، در کشور داريم؛ مثلاً در فناوري ASIC يا IC هاي با عملکرد خاص ( Application Specific IC )، شرکت‌هايي در کشور هستند که با همکاري دانشگاه‌ها و يا به‌صورت مستقل، طراحي ASIC را انجام مي‌دهند، اما کار توليد ( Manufacturing ) آن به توليدکنندگان سنگاپوري و تايواني واگذار مي‌شود.

بايد بر " طراحي سيستم " متمرکز شويم

بنابراين، با توجه به نقاط قوت و مزيت‌هايي که از نظر نيروي انساني داريم، اگر فعاليت‌هاي خود را بر نرم‌افزار و به خصوص، در زمينة " طراحي سيستم " متمرکز کنيم، مي‌توانيم خيلي خوب با ديگران رقابت کنيم. همانگونه که همة ايراني‌هايي که در بهترين کمپاني‌هاي مخابراتي دنيا کار مي‌کنند، فقط به قطعه‌سازي نمي‌پردازند؛ بلکه صاحب ايده هستند و چون در محيطي مناسب قرار دارند، به ايده‌هاي آنها امکان رشد داده مي‌شود و مي‌توانند آنها را عملي کنند. حتي در بين اين افراد، در حد مسئوليت‌هاي مديريتي بعضي از کمپاني‌هاي بزرگ مخابراتي دنيا هم ديده مي‌شود.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 10 اردیبهشتماه 1384

12:28 AM

April 30, 2005

راه هايى آسان براى جلب مشتريان به سايت

نويسنده: Michael Corcoran
مترجم: همکاران سیستم

تا چه قدر مايلايد به راز نوشتن تبليغاتى دست يابيد که مشتريان را به شدت جذب برادههاى آهن به آهنربا به سايت شما جذب کند؟

پس به دقت متن زير را بخوانيد.

نوشتن چنين تبليغى تنها به اندکى دانش و ابتکار نياز دارد. هرکسى ميتواند اين کار را انجام دهد، حتا شما!

اين کار به سادگى و با اجرا کردن دستورات زير امکانپذير است. افراد زيادى در اينترنت وجود دارند که ميتوان از آنها يارى گرفت.از آن جمله ميتوان بهJoe Vitale، Jay Abraham،Cory Rudl،Mark Joyner اشاره کرد که از افراد سرشناس در نوشتن تبليغات هستند. در اينترنت گشتى بزنيد و دستنوشتههاى اين اشخاص را پيدا کنيد. در حاليکه تبليغات را ميخوانيد از خود بپرسيد: «چه چيزى اين تبليغ را از ساير تبليغها اينچنين متمايز کرده است؟» اگر اين کار را ادامه دهيد، کليد جادويى موفقيت آنها را خواهيد يافت.

چيزى که در حين خواندن اين متنها با آن روبهرو ميشويد، ترفندى است که آنها براى فروش محصولات خود از آن استفاده ميکنند. ترفند زيرکانهى آنها اين است.....

همهى آنها يک عنوان جذاب و گيرا دارند و به دنبال آن متنى ميآيد که بيننده را به خواندن ادامهى متن ترغيب ميکند. شما به هيچ وجه از خواندن ادامه آن منصرف نخواهيد شد. اين همان ترفند ساده اي است که آنها به کار ميبرند. ولى براى بار اول نوشتن چنين متنى کار چندان سادهاى هم نيست.

نوشتن متنى که فروش شما را مثل آب شدن يخ در آفتاب گرم تابستان سرعت ببخشد، به کمى تمرين و اطلاعاتى دربارهى طرز رفتار مردم نياز دارد. چند مورد از اين اطلاعات را به زودى برايتان بازگو خواهم کرد.

چند دقيقه فکر کنيد، از بين سايتهايى که به طور پراکنده و سريع آنها را مرور کردهايد چه تعداد نظرتان را به سرعت به خود جذب و شما را به خواندن مطالب ترغيب کرده است؟

پس هميشه قبل از اينکه سايتى را طراحى کنيد، به خاطر داشته باشيد که هرگز نماى ظاهرى سايت به تنهايى مشتريها را جذب نميکند، چون آنها ظاهر سايت را تنها وقتى دوست دارند که عبارات و کلمات شما آنها را قانع کند.

من در مورد تبليغات الکترونيکى ابتدا مبلغى را براى نوشتن يک تبليغ جذاب و گيرا هزينه ميکنم و اگر چيزى باقى بماند براى طراحى گرافيکى سايت خرج ميکنم.

آيا تا به حال با بسيارى از سايتهاى زيبا روبهرو نشدهايد که حتا در فروش يکى از کالاهاى کوچک خود ناتوان هستند؟ فکر ميکنيد چرا چنين اتفاقى ميافتد؟ چون بيشتر آنها فقط طراحان گرافيکى هستند و از نوشتن تبليغات چيزى سر در نميآورند.

کسانى که فکر مى کنند بعد از اين که سايت را روى اينترنت قرار دادند، ميليونها نفر به سمت آن هجوم ميآورند، سخت در اشتباه هستند.آنها تجربهى سختى را پشت سر خواهند گذاشت و در نهايت خواهند فهميد که اشتباه بزرگى مرتکب شده اند!

ممکن است شخصى با اين توصيفات را بشناسيد و يا خودتان دچار چنين سرنوشتى شده باشيد، ولى نا اميد نباشيد هنوز فرصت براى جبران باقيست!

بهتر است ابتدا ياد بگيريد چهگونه يک تبليغ گيرا و جذاب بنويسيد و در وقت و هزينه خود صرفهجويى کنيد. من بسيار توصيه ميکنم که ابتدا بر روى نوشتن تبليغ، تمرين کنيد. سپس پيش از اينکه پول خود را براى ثبت دامنه و اجارهى فضا، برنامه نويسى و طراحى آن خرج کنيد، آن را آزمايش کنيد و وقث و هزينه ارزشمند خود را بيشتر از اين هدر ندهيد!

اکنون قبل از اين که وب سايت بعدى را طراحى کنيد، "ساختار" نوشتن يک تبليغ گيرا را توضيح ميدهم:

روش نوشتن يک تبليغ گيرا براى سايت

با اين که پيشتر نيز آن را توضيح دادم به خاطر اهميت آن دوباره يادآورى ميکنم که بيشتر نيروى خود را روى نوشتن تبليغ و نه طراحى گرافيکى سايت و زيبا نمودن آن صرف کنيد. به عبارت ديگر هرگز تصاوير و طراحى گرافيکى باعث برانگيختن تمايل مشتريان به خريد از سايت نميشود .

1. در عنوان تبليغ بايد اطلاعات بيشترى در اختيار مشتريان خود قرار دهيد.

تنها چند لحظه فرصت داريد تا توجه بازديدکنندگان را جلب کنيد و آنها را به خواندن ادامهى آن ترغيب کنيد. تيتر شما بايد در خواننده براى دانستن مطالب بيشتر، کشش ايحاد کند. عناوين داراى عبارات منفى به طرز باور نکردنى اين مقصود را برآورده ميکنند. براى مثال:

عبارت منفيStop being internet marketing failure هر خريدار اينترنتى را به سمت خود جذب مى کند و يا جملهى Discover 10 vital things to do right now کمک ميکند تا بيننده به خواندن بقيه متن ترغيب شود. با اين کار يک عبارت منفى به نتيجه مثبت ميانجامد.

و يا اين نمونه "آيا تا به حال دربارهى به دست آوردن دوبارهى سرمايه خود فکر کرديد؟" که شما را به خواندن ادامهى آن هدايت ميکند؟ شکى نيست که مردم به طور طبيعى با عنوانهاى منفى به متن جذب مى شوند. چرا؟ چون بيشتر مردم به همين شکل برنامهريزى شدهاند. چيزهايى مردم که به طور معمول به خاطر دارند، بيشتر خاطرات منفى آنهاست تا خاطرات مثبت. از عنوانهاى منفى استفاده کنيد و به اين ترتيب افراد زيادى را به سمت خود جذب کنيد.

2. تا حد ممکن از به کار بردن حروف بزرگ و درشت پرهيز کنيد.

اين کار در خواندن پيام شما وقفه ايجاد مى کند و خواندن آن را کند مى کند. از حروف درشت براى تاکيد روى مطالب و از خط کشيدن زير کلمات براى تاکيد بيشتر استفاده کنيد. عنوان را با کلماتى به اندازهى ساير کلمات آغاز کنيد.

3. متنى گيرا و جذاب بنويسيد.

مردم را مورد خطاب قرار دهيد و به گونهاى بنويسيد که با اشتياق مطالب را دنبال کنند. براى شروع ميتوانيد از ساختار تبليغات يکى از اجناسى که آن را خريدهايد استفاده کنيد.

4. مطالب خود را به صورت منسجم و مرتبط با يکديگر بنويسيد.

اگر اين نکته را رعايت نکنيد، مطمئن باشيد مشتريان زيادى را از دست خواهيد داد. از نوشتن تبليغات طولانى نترسيد. اگر آن را به درستى تنظيم کنيد و بنويسيد، بينندگان تمام آن را خواهند خواند. اشتباه در اينجاست که فکر کنيم تبليغ طولانى مانع موفقيت ماست. اگر آن را صحيح بنويسيد حتا يک تبليغ 10 صقحهاى خيلى بهتر از يک تبليغ کوتاه عمل ميکند.

5. تبليغات تمام محصولاتى را که مى خريد جمع آورى کنيد.

آنها را نگهدارى کنيد و بعدها از آن استفاده کنيد. وقتى ميخواهيد يک تبليغ بنويسيد، جملاتى از آن را که مناسب به نظر ميرسد انتخاب کنيد و آنها را با نوشتهى خودتان بياميزيد. برخى از کلمات جملهها را تغيير دهيد و دوباره آن را مرتب کنيد. در پايان يک نوشتهى عالى و قوى خواهيد داشت!

6. هربار که کالا يا خدمتى را ميفروشيد، از مشتريان خود بخواهيد که ميزان رضايت خود را از خريد در دفاتر شما ثبت کنند.

آنها را در تبليغات خود قرار دهيد. تاييد آنها براى موفقيت شما اهميت دارد و اعتبار قابل قبولى را براى شما به ارمغان مى آورد. تبليغ شما بدون توصيه و تاييد ديگران کامل نمى شود. حتا اگر در گرفتن تاييديه از مشتريان خود دچار مشکل هستيد، ميتوانيد در مقابل دريافت رضايتنامه، محصولات و خدمات خود را به رايگان در اختيار مشترى قرار دهيد.

7. يک نکته بسيار مهم؛ متن شما بايد بدون خطا باشد. حتا ممکن است وجود يک حرف يا کلمهى اشتباه و يا متن ناتمام موجب شکست شما در فروش شود. متن خود را مختصر و بدون ابهام بنويسيد. اگر متن گنگ و نامفهوم باشد، به طور قطع خوانندگان و در نتيجه مشتريان زيادى را از دست خواهيد داد.

8. نوشتن يک متن تاثيرگذار و کارا با يک بار تلاش به ثمر نمى رسد.

متن خود را يک روز بنويسيد و روز بعد دوباره آن را بررسى کنيد. ميبينيد که نياز به بازنويسى دارد. نوشتن و تکميل يک متن ممکن است 30 روز طول بکشد. اگر افزايش ميزان خوانندگان و در نتيجه خريداران را در نظر بگيريد، به اهميت صرف کردن وقت براى نوشتن اين متن پى ميبريد.

بعد از اين مراحل شايد فکر کنيد که ميتوانيد يک متن عالى بنويسيد و فروش موفقى داشته باشيد.

البته هميشه چنين نيست. نکاتى ومجود دارد که بايد بدانيد تا صد در صد به موفقيت برسيد:

از دوستان خود بخواهيد تا متن شما را بررسى کنند.

به آنها بگوييد که هرگونه اشتباه نوشتارى، دستورى و يا ابهامى در جملات و عبارات و يا هر گونه اشکال ديگر که در آن ميبينند به شما اطلاع دهند. از آنها بخواهيد که اين کار را با صداقت و دقت انجام دهند و سعى کنند چيزى را از قلم نيندازند. به آنها بگوييد اگر اشتباهتان را به شما بگويند، از آنها رنجيده خاطر نخواهيد شد و اين کار آنها براى شما چهقدر ارزشمند است. اين روش کمک فوقالعادهاى براى نوشتن يک متن عالى و گيراست.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 10 اردیبهشتماه 1384

12:49 AM

April 30, 2005

انواع تلفن گويا در بازار محصولات تلفن گويا

نويسنده: على واحد - http://weblog.radmanitd.com

زمانى که با مشتريان صحبت مى شود همه انواع اينگونه سيستمها را تحت يک نام و آن هم \\"تلفن گويا\\" مى شناسند. در حاليکه در خانواده محصولات تلفن گويا، سيستمهاى متعدد با تعاريف متعدد داريم که هريک کاربرد خاص خود دارد و در واژگان فنى واژه جداگانه اى دارند و بهتر است مشتريان بدانند که کدام سيستم مد نظرشان مى باشد.

به لحاظ اينکه در بازار توليد اين سيستمها (سيستمهاى تلفن گويا) کار مى کنيم اغلب ديده ام که مشتريان گاه همه اين سيستمها را با يک نام مى شناسند و گاه حتى نام ها را به جاى يکديگر به کار مى برند. در اين مطلب نگاهى خواهيم داشت به برخى از اين واژه ها.

سيستمهاى تلفنى (Telephony systems) : سيستمهاى تلفنى به همه سيستمهايى اطلاق مى شوند که به نحوى از طريق خط تلفن به کاربر (کاربر انسانى و يا يک سيستم کامپيوترى ديگر) سرويس مى دهند. اين واژه به نوعى همان \\"تلفن گويا\\" در معنى عام مى باشد و همه انواع سيستمها را شامل مى شود.

برخى مواقع براى اينکه سيستمهاى مبتنى بر کامپيوتر در اين خانواده را از ساير سيستمها جدا کنند آنها را تحت عنوان Computer Telephony Systems خطاب مى کنند. IVR System : Intercative Voice Responce : سيستمهاى IVR را طبق تعريف به گروهى از نرم افزارهاى کاربردى اطلاق مى کنند که ترکيب اصوات ورودى تلفن (voice Telephone input) و شماره گير هاى تلفن (Toch-tone keypad) را دريافت مى کنند و از طريق صدا (Voice) ، نمابر (Fax) تماس مجدد (Callback) ، نامه هاى الکترونيکى (email) و ساير رسانه ها (media) پاسخ مى دهند. IVR سيستم ها مى توانند به عنوان عضوى از يک برنامه کاربردى بزرگتر که به پايگاه داده ها (Data Base) نيز متصل مى باشند مورد استفاده قرار گيرند.

. برخى از انواع سيستمهاى IVR عبارتند از : - سيستمهاى تلفن بانک و سيستمهاى پاسخگوى تلفنى بازار سهام - نظر سنجى هاى تلفنى - مراکز تلفن و منشى هاى تلفنى - سيستمهاى ثبت سفارش - سيستم هاى اطلاع رسانى Voice Mail: V-mail Or vmail : پست صوتى : اينگونه سيستمها يا به صورت منفرد و يا به عنوان بخشى از يک IVR موظف به دريافت پيامهاى صوتى و يا فاکس کاربر هستند. اين سيستمها به صورت يک ماشين پاسخگو (Answering Machine) عمل مى کنند و گاهى از يک پيامگير ساده (مانند دستگاههاى پيامگير و يا تلفن هاى داراى پيامگير) عملى مى کنند و گاهى قابليت آن را دارند که به جاى استفاده از پيامگيرى هاى متعدد براى يک سازمان به عنوان يک مرکز مشترک، پاسخگوى همه تماس ها باشند، پيامها را تفکيک کنند و با انتخاب فرستنده پيام، آن را به صورت انحصارى در اختيار بخش و يا فرد خاصى قراردهند. اين سيستمها اين تفکۡ ?ک پيام را از طريق ايجاد صندوق هاى پستى صوتى (Voice Mail Box) انجام مى دهند. برخى از اين گونه سيستمها به شکلى هستند که امکان پاسخگويى به پيام هاى دريافتى را براى مالک پيامگير و يا صاحب صندوق پستى فراهم مى کنند.

در اين سيستمها به هر پيام يک شماره خاص اختصاص داده مى شود و شخصى که پيام گذاشته است مى تواند با تماس مجدد بعد از يک بازه زمانى و با وارد کردن آن شماره، چنانچه به پيامشان پاسخ داده شده باشد آن را دريافت کنند. از ديگر امکانات اين سيستمها ارسال يک پيام به گروهى از صندوق هاى پستى، اضافه کردن متن به پيامهاى دريافت شده، تهيه گزارشهاى مختلف براى هر صندوق و يا صندوق هاى پستى صوتى به صورت آمارى و نمودارى، پخش پيغامهاى اوليه (Greeting Message) مختلف براى صندوق هاى پستى مختلف، محاسبه زمانهاى تاخير، خبر کردن صاحب صندوق در هنگام دريافت يک پيام از طريق يک تماس تلفنى، SMS، سيستمهاى ارسال پيام به صورت Pageing، باز کردن يک پنجره روى کامپيوتر فرد، ارسال email با پيوست پيام صوتى و يا بدون آن و .... مى باشند.

ACD:Automatic Call Distributerيک ابزار کامپيوتر تلفنى که تماس هاى تلفنى دريافت شده را مديريت کرده و بر اساس اطلاعات موجود که مى تواند در پايگاه داده هاى آن وجود داشته باشد، آنها را به محل هاى خاصى ارتباط دهد. CTI: Computer Telephony Integrationبه اين سيستمها Computer Telephony نيز مى گويند. اين سيستمها براى مديريت تماس هاى تلفنى از طريق کامپيوتر کاربرد دارند. اين سيستمها مى توانند با ايجاد مراکز تماس يا مراکز تلفن (Call Center) ها خدمات مختلفى را به کاربر ارائه کنند .اين خدمات مى تواند از انتقال خط به واحد مربوطه به مانند يک منشى تلفنى خودکار گرفته تا انواع متعددى از سرويس هاى خاص به کاربر را شامل شود.

به عنوان مثال برخى از کاربردهاى CTI ها را مى توان چنين بيان کرد: -تعيين اعتبار تماس گيرنده (Authenticate Callers): از طريق برخى روشهاى استاندارد مى توان با دريافت شماره تلفن تماس گيرنده، نام وى را از پايگاه داده مربوطه استخراج نمود و قبل از آنکه کاربر بخواهد پاسخگوى وى باشد، اطلاعات مورد نياز در مورد وى در صفحه نمايش کامپيوتر نمايش داده شود. بدين ترتيب، ضمن بالارفتن سرعت ارائه اطلاعات، قبل از صحبت با مشترى مى توان صلاحيت، اعتبار و ساير مشخصات وى را مشاهده کرد.

- پردازش صدا (Voice Recognition) : از طريق الگوريتم هاى مطرح، صدا تشخصى داده شود و يا به عنوان عاملى براى شناسايى يک کاربر (Voice Verification) و يا براى تشخيص صدا (Voice Recognition) و تبديل اطلاعات صوتى وى به اطلاعات متنى (Speech To Text) استفاده شود. - انتقال خط از طريق دريافت شماره داخلى و يا از طريق پردازش صداى فرد تماس گيرنده - ايجاد کنفرانس هاى صوتى و يا ويدوئى از طريق خطوط تلفن -حسابدارى مالى براى تماس هاى تلفنى کاربران - هدايت کابران براى دريافت راهنما از سيستم هاى موجود.

AIN:Advanced Intelligent Network شبکه پيشرفته هوشمند:اين شبکه به شکلى است که سرويس هاى ارائه شده به خطوط تلفن را از سوئيچ هاى تلفنى جدا مى کند و اجازه مى دهد بدون اينکه نيازى به تغيير و يا دستکارى در سوئيچ هاى مخابراتى باشد، سرويس جديدى را به صاحبان خطوط تلفن ارائه نمود. اين سرويسها اغلب به صورت ابزارهاى سودمند (انتقال خط (Call Divert) ، انتظار مکالمه (Call Waiting) ، پيامگير (Answering Machine) سرويسهاى بيدارباش (Wake Up Services) ، سرويسهاى اعلام ساعت و ....) باشند.

اين سرويس ها توسط مراکز مخابراتى و به جهت ايجاد تسهيلات مختلف به مشترکين تلفن داده مى شود. همانگونه که مشاهده مى شود ، اين تعاريف به گونه هستند که همديگر را پوشش مى دهند. بدين ترتيب که سيستمهاى تلفنى به عنوان مجموعه مرجع مطرح مى شوند. اين سيستمها شامل سيستمهاى صوتى تلفنى و ساير سيستمها مى باشند.

در شاخه سيستمهاى صوتى تلفنى، سيستمهاى IVR به عنوان يک گروه بزرگ قرار مى گيرند. در حاليکه سيستمهاى پيامگير ساده مى توانند مجزا باشند و زمانى که به سراغ پست صوتى مى رويم وارد شاخه IVR ها مى شويم. IVR ها انواع مختلفى دارند. براى مثال ACD براى مديريت و انتقال خطوط به کار مى رود. در حاليکه در CTI ها علاوه بر اين امکان به صورت دلخواه، بحث ارتباط با پايگاه داده هاى سيستمهاى ديگر و ساير سيستمهاى کامپيوترى مطرح مى شود. AIN نيز چنانچه ذکر شد توسط مشترى ايجاد نمى شود.

بلکه توسط مراکز مخابراتى ايجاد شده و سرويسهاى محدودى را ارائه مى کنند. پرکاربردترين سيستمها در سازمانهاى ما سيستمهاى IVR و CTI مى باشند که توسط آنها اطلاع رسانى عمومى صورت مى گيرد و يا با اتصال به ساير سيستمها، به کاربر اين امکان داده مى شود که از راه دور و از طريق خطوط تلفن به تبادل اطلاعات با سيستمهاى عملياتى بپردازند. در آينده در مطلبى جداگانه به جايگاه تجارى اين سيستمها در بازار نرم افزارى ايران خواهم پرداخت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 20 اردیبهشتماه 1384

09:11 AM

May 10, 2005

مديريت شبكه چيست؟

از: مهدي راستي
در حالت كلي وقتي صحبت از مديريت شبكه به ميان مي‌آيد توقع مديريت و كنترل تمام جنبه‌هاي شبكه ايجاد مي‌شود و همين مساله بنوعي مشكل ساز است.

برخي مجموعه‌هاي نرم‌افزاري با چنين ديدگاهي سعي مي‌كنند كه مولفه‌هاي بسيار فراوان جدا از هم (كه هر يك بصورت خاصي كار مي‌كنند) تشكيل‌دهنده يك شبكه را درك و به روش يكساني ارائه كنند كه البته دشواري چنين كاري سبب هزينه مالي و زماني بسياري مي‌شود.

محصولاتي كه روي يك جنبه تمركز مي‌كنند معمولا كاراتر و ارزانتر هستند و استفاده از آنها ساده‌تر مي‌باشد، ولي سادگي آنها سبب قابليتهاي كمتر آنها مي‌شود.

از طرف ديگر، نسخه‌هاي كوچكتر محصولات پرقابليت تر تقريبا هر كدام از جنبه‌هاي مدل ‪ FCAPS‬را، اگر چه با محدوديت‌هايي، با قيمت مناسب مي‌پوشانند.

بر اساس مدل ‪ FCAPS‬مديريت شبكه مي‌تواند به پنج دسته كلي تقسيم شود كه عبارتند از:
‪Security Management‬
‪Fault Management‬
‪Configuration Management‬
‪۴ Performance Management‬
‪۵ Accounting Management‬
اهميت هر كدام از اين جنبه‌ها نيز براي مديران شبكه معمولاگ بر اساس ترتيب ذكر شده است.

محدوديتهايي كه معمولا ابزارهاي ارزان‌قيمت تر دارند بخاطر محدوديت كارهايي است كه ‪ SNMP‬مي‌تواند انجام دهد.

ابزارهايي كه تنها متكي بر ‪ SNMP‬هستند، تنها مي‌توانند بخشهاي ‪ Fault Performance‬و از مدل ‪ FCAPS‬را پوشش دهند، بنابراين بسياري از ابزارهاي مديريت جامع، ‪agent‬هاي خاص خود را دارند.

بهر حال بايد توجه داشت ابزارهايي كه بتوانند تمام جنبه‌هاي مدل ‪FCAPS‬ را پوشش دهند، محدود و بسيار گرانقيمت هستند.

اغلب محصولات مديريت شبكه ارزان قيمت تنها ابزارهاي مانيتورينگ هستند.

اين محصولات اطلاعات شبكه را بصورت طيف وسيعي از روشها از ‪pop-up‬ ‪system-tray‬ها و نمايه‌هاي چشمك زن گرفته تا گراف‌هاي پيچيده مقادير حداقل و حداكثر و آستانه بر حسب زمان نشان مي‌دهند.

تعداد محصولات مديريت شبكه ارزان قيمت بسيار فراوان است.

اين محصولات با هر تركيبي از ويژگيهاي مختلف كه بتوان تصور كرد، ارائه شده‌اند، كه اين ويژگي‌ها را مي‌توان در موارد زير ديد.

‪inventory helpers, DNS managers, IP address figurers, switch and‬ ‪router watchers, event alarms, SNMP MIB everything, network‬ .‪diagrammers and packet analyzers‬
كشف شبكه يا ارائه نقشه شبكه يكي از اهداف اوليه ابزارهاي مديريت شبكه به حساب مي‌آيد.

اغلب محصولات سعي مي‌كنند كه نقشه لايه ‪ ۳‬شبكه را با استفاده از ‪،ping‬ ‪ ،SNMP‬و پورتهاي ‪ TCP‬و ‪ UDP‬استخراج كنند. ابزارهاي پيشرفته‌تر سعي مي‌كنند نقشه لايه دو را نيز استخراج كنند، اگرچه اكثرا بدليل مشكلاتي نظير يكسان نبودن پياده‌سازيهاي ‪ SNMP‬نمي‌توانند نقشه دقيقي در اين مورد ارائه كنند.

بهرحال هيچ ابزاري كه بتواند توپولوژي فيزيكي شبكه را استخراج كند ارائه نشده است.

مساله مهم ديگري كه بايد مدنظر قرار داد پشتيباني محصولات است كه همواره بايد در نظر باشد.

ابزارهاي مديريت شبكه ارزانقيمت معمولا از پايگاه داده‌هاي معمول، ‪ distributed processing‬و ‪ redundancy‬پشتيباني نمي‌كنند و با شبكه‌هاي بسيار بزرگ مشكل پيدا مي‌كنند.

بهرحال بايد توجه داشت كه حتي بودجه ‪ ۱۰‬هزار دلاري براي مديريت شبكه نشان از محدوديت منابع مالي دارد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 27 اردیبهشتماه 1384

11:29 PM

May 17, 2005

نصب و پیکربندی NAT در Windows 2003

نوشته: امین ناصر کریمی

ناشر: مجله شبکه

در این مقاله توضیح خواهیم داد که چگونه NAT را در ویندوز 2003 نصب و پیکربندی کنیم.

NAT یا ترجمه آدرس شبکه (Network Address Translation) یکی از پرکاربردترین پروتکلهای ترجمه و نگاشت IP است که در لایه سطح 3 شبکه مدل OSI فعالیت می کند.

عملکرد NAT مانند یک واسط میانی بین شبکه داخلی ( Internal) وشبکه خارجی (External) است،پکتهایی که از یک شبکه خصوصی می آیند توسط NAT مدیریت می شوند وسپس به مقصد مورد تقاضایشان ارسال می شوند.

یک آدرس در اینترنت مشاهده می شود و آدرسهای داخلی در اینترنت نشان داده نمی شوند.یک جدول در Router ساخته می شود که لیستی از آدرسهای محلی (Local) وعمومی (Global) در آن قرار دارد می گیرد و از آن به عنوان یک مرجع برای ترجمه IP ها استفاده می شود.
براي مشاهده تصوير روي شمايل بالا کليک کنيد

NAT می تواند به چندین روش کار کند:

NAT استاتیک:
یک IP ثبت نشده (Unregistered) به یک IP ثبت شده نگاشت می شود به صورت یک به یک،که هنگامی مفید است که بخواهیم به یک وسیله از خارج شبکه دسترسی پیدا کنیم.

NAT داینامیک:
یک IP ثبت نشده از طریق گروهی از IP های ثبت شده به یک IP ثبت شده نگاشت می شود.
به طور مثال ، یک کامپیوتر با IP ، 192.168.10.121 به اولین IP در دسترس در محدوده 212.156.98.100 تا 212.156.98.150 ترجمه می شود.

Overloading (سربارگذاری) :

یک فرم از NAT داینامیک است که چندین IP ثبت نشده را به یک IP ثبت شده نگاشت می کند ، اما از پورتهای مختلف استفاده می کند.
برای مثال، IP آدرس 192.168.10.121 به 212.56.128.122:Port Number (مثلا 212.56.128.122:1080 ) نگاشت خواهد شد.

Overlapping (همپوشانی) :
هنگامی است که آدرسهای داخل شبکه با آدرسهای بیرون شبکه همپوشانی (Overlap) می شوند-IP آدرسها در یک شبکه دیگر نیز رجیستر شده اند.روتر (Router) می بایست یک جدول جستجو از این آدرسها را نگهداری کند تا بتواند آنها را قطع کند و با IP آدرسهای رجیستر شده یکتا جایگزین کند.

NAT چگونه کار می کند:

یک جدول از اطلاعاتی درباره هر پکت(Packet) که عبور کرده توسط NAT نگهداری می شود.هنگامی که یک کامپیوتر در شبکه تلاش می کند تا به یک وب سایت در اینترنت متصل شود:
• هدر (Header) IP مبدا تغییر کرده و IP آدرس کامپیوتر NAT جایگزین آن می شود.
• IP آدرس مقصد به IP آدرس مخصوص داخلی تغییر می کند بر اساس رکوردهای جدول)

NAT می تواند به عنوان یک فایروال اساسی مورد استفاده قرار گیرد ، مدیر شبکه (Administrator) می تواند پکتهایی که از یک IP معین وارد/خارج می شوند را فیلتر کند و دسترسی به یک پورت بخصوص را اجازه دهد یا منع کند.

نصب NAT :

برای نصب NAT شما می بایست ویزارد Configure your server را از administrative tools اجرا کرده و سپس RRAS/VPN را انتخاب کنید.حال NEXT را کلیک کنید،RRAS اجرا می شود. همانطور که در تصویر زیر می بینید می بایست یک اتصال به اینترنت داشته باشید و نوع آن را مشخص کنید،واینکه آیا می خواهید فایروال را فعال کنید.

براي مشاهده تصوير روي شمايل بالا کليک کنيد

Next را کلیک کنید و ادامه دهید،پروسه نصب آغاز شده و سرویسها مجددا راه اندازی می شوند.

پیکربندی NAT :

پیکربندی NAT از طریق Routing and Remote Access انجام می شود ، که از طریق Administrative Tools قابل دسترسی است.
براي مشاهده تصوير روي شمايل بالا کليک کنيد

هرکدام از قسمتها را که می خواهید پیکربندی کنید بر روی آن double click کنید ، این کار پنجره properties مربوطه را باز می کند و شما می توانید تنظیمات آن را تغییر دهید مثل Packet filtering و Port blocking و همچنین فعال/غیرفعال کردن یک سری خصوصیات مانند Firewall .
همانگونه که در تصویر زیر مشاهده می کنید خصوصیات مربوط به Remote router نشان داده شده است.

براي مشاهده تصوير روي شمايل بالا کليک کنيد

در تب(Tab) مربوط به NAT/Basic Firewall شما می توانید نوع واسط(Interface type) را با توجه به نحوه اتصال به شبکه انتخاب کنید ،که من Public interface connected to the internet را انتخاب کرده ام.
دکمه های Inbound filters و outbound filter به شما تا ترفیک ناشی از IP آدرسها یا packet protocol ها را محدود کنید. مطابق بر این ،پکتهای TCP معینی قبل از اینکه به کامپیوتر کلاینت برسند،متوقف می شوند.بنابراین شبکه را امن تر می کند.
برای مثال هنگامی مفید است که شما بخواهید پکتهایی که از یک IP آدرس که در لیست سیاه نوشته شده است می آیند را رد کنید،یا دسترسی کاربران داخلی را به پورت 21 (FTP) محدود کنید.
برای تنظیمات بیشتر مربوط به Firewall به Tab ،Services and Ports بروید،در این قسمت شما می توانید سرویسهایی را که می خواهید کاربرانتان به آنها دسترسی داشته باشند را انتخاب کنید،همچنین قادر خواهید بود سرویسهای بیشتری را خودتان با مشخص کردن جزییات آن مثل شماره پورت ورودی و خروجی به این لیست اضافه کنید.

براي مشاهده تصوير روي شمايل بالا کليک کنيد

لیستی از این سرویسها در شکل بالا قابل مشاهده است.
دکمه Add به شما اجازه میدهد تا یک سرویس جدید ایجاد کنید،با کلیک بر روی Add پنجره ای جلوی شما باز می شود و از شما می خواهد نام سرویس، شماره TCP و UDP و IP آدرس کامپیوتری که میزبان این سرویس است را وارد کنید.
اگر یکی از سرویسهای موجود در لیست فعال نشده باشد آنگاه هر کلاینت که در Domain ویندوز 2003 است نمی تواند به آن سرویس خاص دسترسی یابد.
به عنوان مثال ، اگر تنظیمات مانند شکل بالا باشد و یک کامپیوتر بخواهد به سایت FTP وصل شود نخواه توانست.
همانگونه که مشاهده کردید ،NAT یک خصوصیت مفید است که امنیت را به یک شبکه های کوچک و متوسط اضافه می کند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 31 اردیبهشتماه 1384

12:22 AM

May 21, 2005

نسل جديد SCSI

نويسنده: Galen Gruman
InfoWorld
مترجم: امين ايزدپناه

استاندارد ذخيره‌سازي قديميSCSI در شرف متحول شدن است. دو نوآوري فني كه به صورت مجزا در سال جاري صورت گرفتند، انواع درايوهاي ديسكي مورد استفاده از سوي سازمان‌ها در سيستم‌هاي ذخيره‌سازي‌شان را تغيير خواهند داد.

يك دگرگوني كه سال‌هاي متعدد در توليد رخ داده است حركت به سوي يك رابط جديد بوده – SAS (SCSI متصل‌شده به صورت سريال) – كه اتصالات سريع‌تر، انعطاف‌پذيرتر و قابل اعتمادتري را براي درايوها فراهم ‌آورد. مشخصه جديد همچنين امكان پشتيباني ابزارهاي SAS و درايوهاي ارزان‌تر SATA را فراهم مي‌سازد.

همزمان، با كوچك شدن رابط SAS، درايوهاي 2.5 اينچ رده سازماني جايگزين مدل‌هاي 3.5 اينچ خواهند شد. در بلندمدت اين بدان معني خواهد بود كه ديتاسنترها فضاي ذخيره‌سازي بيشتري را بدون اشغال نمودن محيط ساختمان در اختيار خواهند داشت. درايوهاي كوچك‌تر همچنين مصرف انرژي را كاهش خواهند داد، سرعت دسترسي به داده‌ها را افزايش خواهند داد، و ظرفيت كلي آرايه‌هاي درايو را خواهند افزود.

در ابتدا اين تغييرات نامحسوس خواهند بود، با سرورهاي جديد كه در اواسط سال جاري وارد عرصه مي‌شوند و به جاي SCSI هاي موازي سنتي داراي درايوهاي داخلي SAS هستند. همچنان كه به پايان سال نزديك مي‌شويم آرايه‌هاي درايو بيشتري استفاده از درايوهاي SAS را آغاز خواهند نمود. John Monroe، يك تحليلگر در Gartner، خاطرنشان مي‌كند: "SAS اكنون از سوي OEM هاي عمده مورد تاييد قرار مي‌گيرد." تا سا‌ل‌هاي 2008 تا 2010 (پيش‌بيني‌ها متفاوت است)، همه درايوهاي SCSI از نوع درايوهاي SAS خواهند بود.

Greg Hartzog، رييس زيرساخت ذخيره‌سازي در Optimus Solutions، مي‌گويد: "چيزي كه IT شاهد آن خواهد بود تداوم گرايش به ظرفيت و كارآيي بهتر با قيمت كمتر است."

اگر چه تكنولوژي SCSI پشت پرده در حال تحول است، اما سازمان‌ها نبايد نگراني‌اي در مورد تطبيق زيرساخت ذخيره‌سازي خود به منظور مديريت تغيير داشته باشند. زيرا درايوها از همان مجموعه فرمان درايوهاي قبلي SCSI استفاده مي‌نمايند، در واقع هيچ نيازي به اعمال تغيير در معماري ذخيره‌سازي سازمان وجود ندارد، چرا كه مجموعه فرمان SCSI و رابط‌هاي خارجي بدون تغيير باقي مي‌مانند. همچنين، Jay Krone، مدير بازاريابي محصول Clariion در EMC، خاطر نشان مي‌كند كه اسمبلي‌هاي هد درايوها يعني بخش‌هايي كه اعمال ذخيره و خواندن داده‌ها را انجام مي‌دهند بدون تغيير مي‌مانند.

Franco Castaldini، مدير محصول ذخيره‌سازي سازماني در Seagate Technologies، مي‌افزايد: "كاري وجود ندارد كه IT انجام دهد. آنها نيازي به ايجاد تغيير در middleware يا مديريت ذخيره‌سازي خود ندارند."

درايوهاي قديمي‌تر SCSI موازي با SAS سازگار نيستند، از اين رو سازمان‌ها بايستي هر دو نوع دستگاه SCSI را در DAS و SANهاي خود داشته باشند تا هنگامي كه دستگاه‌هاي قديمي‌تر طي سال‌هاي آينده از رده خارج گردند. اما اين فقط به معني نگهداري دو نوع دستگاه در وضعيتي است كه اشكال پيش مي‌آيد و شايد هم در وضعيت بازآرايي آرايه‌ها به منظور به حداقل رساندن تعداد كابينت‌ها (هر نوع در يك مكان)، اين نظر Krone است.

يك رابط كوچك‌تر و انعطا‌ف‌پذيرتر

حركت به سوي SAS اتصال ميان يك درايو و مقصد (چه كانكتور درايو موجود بر روي مادربورد يك سرور و چه آداپتور گذرگاه ميزبان درون يك كابينت آرايه درايو) را به شكل قابل ملاحظه‌اي متحول مي‌سازد. اتصال جديد تقريبا مشابه كانكتور SATA كه در حال حاضر براي ما آشناست مي‌باشد، و اين شباهت هدفدار است. كنترلرهاي SAS هم با درايو‌هاي SAS و هم با درايو‌هاي SATA كار مي‌كنند زيرا كابل‌ها در هر دو از لحاظ فيزيكي و الكتريكي يكسان هستند. اين امر به فروشندگان امكان استفاده از منابع تغذيه‌، كيس‌ها و صفحات يكسان را در تمامي محصولاتشان مي‌دهد، كه كاهش هزينه‌هاي توليد و در نتيجه كاهش قيمت‌ها براي سازمان‌ها را در پي خواهد داشت، اين گفته Hartzog است.

Craig Butler، مدير بازاريابي محصول ذخيره‌سازي ديسك در IBM، مي‌گويد: "ما درايوهاي SAS با حجم‌هاي بسيار بالا خواهيم داشت چرا كه آنها هم در سرورها و هم در آرايه‌ها به كار برده خواهند شد، از اين رو ارزان‌تر خواهند بود."

علاوه بر كاهش هزينه‌هاي توليد كه استانداردسازي محفظه‌ها اين امر را در پي خواهد داشت، پشتيباني دوگانه درايوهاي SAS و SATA توسط رابط SAS به اين معني است كه سازمان‌ها مي‌توانند هر دو نوع درايو را در يك محفظه (enclosure) تركيب نمايند. اين امر مي‌تواند به يكپارچه كردن ذخيره‌سازي در يك ساختار فيزيكي كمك نمايد در عين حالي كه تفكيك كاركردي ميان اين درايوها پشتيباني مي‌گردد: استفاده از SAS براي برنامه‌هاي كاربردي داراي تعامل بالا و كارآيي بالا، و SATA براي برنامه‌هاي كاربردي با عمل خواندن طولاني و كارآيي پايين از قبيل رسانه پيوسته (streaming) و آرشيوسازي.

اما Harry Mason، رييس SCSI Trade Association و مدير بازاريابي صنعتي درLSI Logic، خاطرنشان مي‌كند كه اگر محفظه‌هاي درايو مخصوص آن طراحي نشده باشد آميختن دو درايو با يكديگر مي‌تواند مشكلاتي را ايجاد نمايد. به دليل سرعت چرخش متفاوت ديسك در آنها، درايوهاي SAS و SATA به ميزان متفاوت لرزش ايجاد مي‌كنند، كه اين موضوع باعث آسيب رسيدن به كابينت مي‌گردد. مديران ذخيره‌سازي كه خواهان تركيب دو نوع درايو در يك كابينت هستند، اگر نمي‌خواهند دستگاه تكان بخورد بايستي اطمينان حاصل كنند كه فروشنده محفظه كابينت را براي مهار چنين لرزش‌هايي طراحي نموده است.

به علاوه، برخي رابط‌ها كاربرد دوگانه خواهند داشت، در حالي كه سايرين اين گونه نخواهند بود. براي جلوگيري از وقوع رخدادي همچون اتصال يك درايو SAS به يك كانكتور مخصوص SATA از سوي يك شخص، كابل‌هاي SATA داراي زائده‌ي پلاستيكي هستند كه آنها را در برابر وارد شدن به هر چيزي به جز يك كانكتور SAS محافظت مي‌نمايد. كابل‌هاي SATA هم در كانكتورهاي SATA و هم در كانكتورهاي SAS جاي مي‌گيرند.

بنا بر گفته Butler از شركت IBM، پشتيباني رابط SAS براي درايوهاي SATA و SAS "كار ذخيره‌سازي رده‌بندي شده را تسهيل مي‌بخشد". او در حالي كه استفاده از ذخيره‌سازي رده‌بندي شده را توصيه مي‌نمايد مي‌گويد، يك رابط مشترك بدان معني است كه سازمان‌ها مي‌توانند به سادگي برخي درايوها را براي انجام پشتيبان‌گيري و آرشيوسازي توسط درايوهاي SATA و بقيه را براي دسترسي تراكنشي توسط درايوهاي SAS پيكربندي نمايند، همگي با رك‌ها و كابينت‌هاي يك آرايه. رابط مشترك همچنين امكان عرضه‌ي محصولات پرمنفعت را به شكلي ارزان‌تر براي فروشندگان فراهم مي‌آورد.

يك از مزاياي نامحسوس‌تر SAS اين است كه SCSI از قالب يك تكنولوژي موازي به سوي يك قالب سريال پيش مي‌رود. رابط‌هاي فعلي SCSI استفاده از حداكثر 15 درايو را براي هر كابل مجاز مي‌شمارند، اما كابل‌ها داراي پهناي‌باند لازم جهت پشتيباني همزمان اين همه درايو در محيط‌هاي واقعي نيستند. حركت به سوي SAS تعداد اتصالات قابل آدرس‌دهي را براي هر پورت – بدون استفاده از بسط ‌دهنده‌ها – به 4032 افزايش مي‌دهد، اين رقم را با 127 براي FC (Fibre Channel) مقايسه كنيد.

از آنجايي كه اتصال به هر درايو به شكل سريال است، هيچ اشتراك پهناي باندي براي بازداشتن سيستم‌هاي ذخيره‌سازي از به كار بردن تمامي اين اتصالات وجود ندارد. طبيعت سريال SAS همچنين بدان معني است كه يك نقص در يك درايو نمي‌تواند ساير درايوها را تحت تاثير قرار دهد. (امكان بروز نقص يكي از دلايلي است كه SCSI به عنوان چنين تكنولوژي قابل اطميناني محسوب گرديده است: معماري موازي تاثير نقصان درايو را افزايش مي‌دهد.) در گذشته، رويكرد موازي به اين دليل مورد استفاده قرار مي‌گرفت كه داده بيشتري مي‌توانست به صورت همزمان بر روي يك اتصال منتقل گردد. اما تكنولوژي سريال كنوني – و كنترلرهاي خاص مديريت تمامي اتصالات منفرد – به نقطه‌اي از پيشرفت رسيده است كه رويكرد موازي ترجيح داده مي‌شود، همان گونه كه FireWire، USB، FC و اتصالات اترنت نشان داده‌اند.

SAS همچنين وعده مي‌دهد كه سد كارآيي SCSI را با سرعت جاري 3 گيگابيت در ثانيه مي‌شكند. Monroe از شركت Gartner مي‌گويد: "شما قادر نيستيد نرخ انتقال تكنولوژي موازي را افزايش دهيد. ما به انتهاي خط رسيده‌ايم." بر طبق اعلام SCSI Trade Association، دستگاه‌هاي اوليه SAS همچنين داراي سرعت 300 مگابيت در ثانيه خواهند بود، و نرخ انتقال بايد تا سال 2008 به 6 گيگابيت در ثانيه و تا سال 2010 به 12 گيگابيت در ثانيه افزايش يابد.

SAS همچنين پشتيباني پورت‌هاي دوگانه، كه دو اتصال به يك درايو را به منظور افزودن قابليت اعتماد در موارد وجود نقص فراهم مي‌نمايند، را در بر مي‌گيرد؛ همينطور در مورد كنترلرهاي RAID اضافي – همانگونه كه در مورد FC وجود داشت.

Butler از شركت IBM مي‌گويد، نتيجه پشتيباني ابزارهاي بيشتر و سرعت‌هاي انتقال بالاتر، كلاسترهاي بزرگتري از درايوها در آرايه‌هاي داراي ظرفيت‌هاي ذخيره‌سازي بسيار بالا و كارآيي بالا خواهد بود. اين بايستي به SAS در جانشين شدن به جاي FC در تمامي رده‌هاي ذخيره‌سازي به جز بالاترين كارآيي (جايي كه هزينه بيشتر FC ارزش كارآيي بهتر را داشته باشد) كمك نمايد.

بنا بر گفتهMason از شركت LSI Logic، SAS همچنين در ذخيره‌سازي راه نزديك كاربرد دارد. او مي‌گويد IT مي‌تواند دستگاه‌هاي متعدد SAS (آرايه‌ها يا درايوهاي خارجي) را از طريق اتصالات مستقيم SAS به SAS بدون نياز به نصب يك SAN محلي يا اشتراك آن شبكه با ترافيك ديگر به هم پيوند دهد. Mason پيش‌بيني مي‌نمايد برخي از سازمان‌ها در صدد استفاده از SAS براي ايجاد اين حلقه‌هاي ذخيره‌سازي راه نزديك به عنوان يك بخش الحاقي به SAN ها بر آيند، نه به عنوان يك جايگزين. به شكلي مشابه، پيش‌بيني Butler از شركت IBM اين است كه SAS براي كلاسترهاي ذخيره‌سازي خارجي دو‌گره‌اي مورد استفاده قرار گيرد.

همچنان، فروشندگان انتظار دارند كهSAS نخستين محصول خود را در رده سرورها ارائه دهد، رده‌اي كه در حال حاضر متكي بر درايوهاي SCSI مي‌باشد كه دليل اين امر نيز قابليت اطمينان و كارآيي بالاي آنها است. SAS اين كارآيي و قابليت اطمينان را افزايش مي‌دهد در عين حالي كه به فروشندگان امكان استفاده از همان چيپ‌ست‌ها و كانكتورها را با هزينه‌هاي كاهش يافته براي سرورهايشان مي‌دهد. Butler از شركت IBM خاطرنشان مي‌كند كه اين درايوها تا سال 2006 بر روي سرورها استاندارد خواهند شد. اما Monroe از شركت Gartner مي‌گويد از آنجايي كه بسياري از سازمان‌ها اخيرا سرورهاي خود را جايگزين نموده‌اند، سرورهاي مبتني بر SAS تا نوسازي بعدي در مقياسي وسيع گسترش نخواهند يافت.

ميني‌درايوها: pathsServer هاي دو گذره همچنين از روند توسعه SCSI ثاني بهره خواهند برد: حركت به سوي درايوهاي رده سازماني كوچك‌تر. درايوهاي 2.5 اينچي انرژي كمتري مصرف مي‌كنند و گرماي كمتري توليد مي‌نمايند، و كارآيي آنها – زمان‌هاي دسترسي و جستجو – بهتر از درايوهاي 3.5 اينچي مي‌باشد چرا كه در اين درايوها هدهاي درايو فاصله كمتري را بايد طي نمايند. اين امر آنها را براي برنامه‌هاي كاربردي تراكنشي مناسب و عالي مي‌سازد.

اندازه كوچك مزيت ديگري نيز در پي دارد. بر طبق گفته Mason از شركت LSI Logic، وجود درايوهاي 2.5 اينچي SAS بدان معني است كه سرورهاي blade مي‌توانند به جاي استفاده از درايوهاي 2.5 اينچي ATA – طراحي شده براي نوت‌بوك‌ها – كه در گذشته ناچار به استفاده از آنها بودند از تكنولوژي قابل اطمينان SCSI كه داراي كارآيي بالايي مي‌باشد استفاده نمايند.

Butler از شركت IBM تصديق مي‌نمايد كه: "ما مي‌دانيم كه جايي كه ظرفيت فيزيكي كم است از درايوهاي 2.5 اينچي در يك سرور يا blade استفاده خواهيم كرد."

براي آرايه‌هاي درايو، Hartzog از شركت Optimus پيش‌بيني مي‌نمايد كه اول از همه آرايه‌هاي رده متوسط، درايوهاي 2.5 اينچي SAS را در ميان خود بپذيرند. او خاطرنشان مي‌كند كه اغلب آرايه‌هاي رده متوسط 14 درايو را در يك رك 19 اينچي جاي مي‌دهند، اما در صورتي كه به اندازه‌ي 2.5 اينچ مهاجرت نمايند قادر به نگهداري 30 درايو خواهند بود.

Mason از شركت LSI Logic مي‌گويد: "SAS واقعا از حركت به سوي 2.5 اينچ نهايت بهره‌برداري را خواهد كرد و ساير تكنولوژي‌ها را پشت سر خواهد گذاشت. فاكتور اندازه كوچك يك عامل تعيين‌كننده است."

اگر چه درايوهاي 2.5 اينچي SAS به فروشندگان در ارائه آرايه‌هاي درايو كوچك‌تر يا افزايش مجموع ظرفيت در فضاي كابينت يكسان ياري مي‌‌رسانند، Castaldini از شركت Seagate بر اين عقيده است كه درايو 3.5 اينچي همچنان سال‌ها مورد استفاده قرار خواهد گرفت. چرا كه درايوهاي SATA داراي يك نسخه 2.5 اينچي رده‌ي سازماني نيستند، از اين رو براي استفاده از مزيت محفظه‌هاي تركيبي و تطبيقي، فروشندگان به استفاده از درايوهايي با اندازه يكسان ادامه خواهند داد. دليل ديگر آن است كه گاهي اوقات به ازاي هر گيگابايت، قيمت درايوهاي 2.5 اينچي SATA بيشتر از نسخه‌هاي 3.5 اينچي خواهد بود. Butler از شركت IBM مي‌گويد: "مشخص نيست كه قيمت به ازاي هر گيگابايت در مورد درايوهاي 3.5 اينچي چه وضعيتي دارد." او خاطرنشان مي‌كند كه آنها براي دستيابي به پذيرش وسيع نياز به برابري و تعادل قيمت دارند.

با اين وجود، تغيير در دنياي هارد ديسك‌ها شايع است. علي‌رغم پيش‌بيني‌هاي صورت گرفته در مورد پايان آن، هارد ديسك همچنان به راه خود ادامه مي‌دهد، با افزايش ظرفيت ذخيره‌سازي فراتر از تراكم ترانزيستور مطرح شده توسط قانون مور. به زودي درايو سازماني SCSI گام مهم ديگري به سوي جلو بر خواهد داشت – اين بار در سادگي، قابليت اطمينان، و هزينه كمتر.

iSCSI برای كجا مناسب است؟

در حالي كه فروشندگان تجهيزات ذخيره‌سازي شروع به فروش SAS و درايوهاي 2.5 اينچي مي‌نمايند، آنها همچنين iSCSI را وارد عرصه مي‌كنند. اما درواقع iSCSI فرمي از SCSI محسوب نمي‌گردد، و آن هيچ رابطه واقعي با تحول تكنولوژي SCSI ندارد.

iSCSI در واقع يك رابط خارجي به منظور اتصال سيستم‌هاي ذخيره‌سازي مي‌باشد، شبيه FC (Fibre Channel) يا Infiniband. يك اتصال iSCSI از Ethernet به عنوان انتقال داده استفاده مي‌كند و فرمان‌هاي مديريت ذخيره‌سازي را براي انتقال توسط TCP/IP بسته‌بندي مي‌نمايد. اما يك اتصال iSCSI با سيستم‌هاي ذخيره‌سازي ATA، SCSI و FC به شكل مساوي كار مي‌كند. (FC هم يك تكنولوژي اتصال خارجي است و هم يك تكنولوژي درايو خاص، اما همانند iSCSI، آن همه انواع سيستم درايو را متصل مي‌نمايد.)

اين بدان معني است كه سازمان‌ها بايد جداي از مزاياي درايوهاي 2.5 اينچي و SAS به ارزيابي مزاياي iSCSI بپردازند – در اصل يك روش اتصال ارزان‌تر SAN با كارآيي پايين‌تر. Jay Krone، مدير بازاريابي محصول Clariion در شركت EMC، مي‌گويد: "مزيت اصلي، هزينه كمتر اتصال است."

Harry Mason، مدير بازاريابي صنعتي در LSI Logic، مي‌گويد: "يك مكتب فكري در بازار سرور low-end وجود دارد مبني بر اين كه iSCSI راه ارزان‌تري براي انجام ذخيره‌سازي (از نوع اتصال مستقيم) است." اما Mason به اين امر اعتقاد ندارد. "SAS در اين نوع از پياده‌سازي، iSCSI را متوقف ساخت زيرا آن تمامي قابليت‌ها و پهناي باند را بدون نياز به ايجاد يك محيط جديد فراهم مي‌آورد." Mason محصولاتي از شركت‌هايي همچون LeftHand Networks و EqualLogic نام مي‌برد كه به iSCSI به عنوان يك جايگزين مناسب SAN براي محيط‌هاي با قابليت پايين از قبيل تجارت‌هاي كوچك و براي مرتبط ساختن SAN هاي مجزا نگريسته‌اند.

كاربرد SAS در نوارها (Tape ها)

SCSI نه تنها در درايوهاي ديسكي بلكه در درايوهاي نواري نيز مورد استفاده قرار گرفته است، اما اعتناي عمومي كمي به نحوه‌ي گسترش SAS در كتابخانه‌هاي نواري شده است. Franco Castaldini از شركت Seagate خاطرنشان مي‌كند كه هيچ فروشنده نواري هنوز به دنبال plugfest هاي SCSI Trade Association نبوده است، جايي كه به عنوان مثال فروشندگان محصولات SAS را تست ‌نمايند.

Greg Hartzog از شركت Optimus Solutions معتقد است كه SAS مي‌تواند مزيت بزرگي براي كتابخانه‌هاي نواري محسوب گردد، به دليل طول كابل افزايش يافته و اندازه كابل كوچك‌تر و انعطاف‌پذيرتر. او مي‌گويد مشتريانش نسبت به ايده‌ي كتابخانه‌هاي نواري خارجي اما از نوع اتصال مستقيم براي پشتيبان‌گيري شعبه‌اي و ساير انواع محلي آن علاقه نشان مي‌دهند. Harry Mason از شركت LSI Logic اين مطلب را تصديق نموده و مي‌گويد در اغلب سازمان‌ها كتابخانه‌هاي نواري به خوبي در خارج از اتصالات FC (Fibre Channel) جاي نمي‌گيرند زيرا كتابخانه‌هاي نواري معمولا به شكلي كه درايوهاي ديسكي به مقصد متصل مي‌گردند اتصال نمي‌يابند بلكه از طريق كابل‌ها اين اتصالات را برقرار مي‌كنند.

اما آداپتورهاي درايوهاي نواري FC حدود 1000 دلار قيمت دارند، Hartzog خاطرنشان مي‌كند، اين امر IT را پيش از گسترش آنها به تفكر بيشتر وا مي‌دارد. او مي‌گويد: "نوار SAS بايستي از لحاظ قيمت به رقابت بپردازد."

Mason مي‌گويد او "علاقه زيادي را از سوي فراهم كنندگان نوار نسبت به طرح‌هاي SAS" مشاهده كرده است. يك دليل براي اين امر اين است كه پروتكل‌هاي SCSI "همواره يك مدخل خوب براي رباتيك درايو نواري" بوده است، اين نظر Kevin Schoonover، مدير مهندسي در Arrow Enterprise Storage است. Schoonover مي‌گويد، با اساس SCSI خود و امكان كابل‌كشي بهترش، فراهم‌كنندگان نوار اكنون مي‌توانند SAS را به جاي FC گران‌تر مد نظر قرار دهند، و از مزاياي يك اتصال كابلي بدون نياز به مهاجرت به يك مجموعه فرمان متفاوت بهره‌مند گردند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 31 اردیبهشتماه 1384

12:28 AM

May 21, 2005

نگاهی بر ورای 3G بی‌سيم

نويسنده: Ira Brodsky
Network World
مترجم: زهره چكنی

فرامينگهام- صنايع موبايل سازی بالاخره خدمات بی سيم 3G را پس از مدت‌های مديد انتظار عرضه می‌كنند كه پيشاپيش يك مشكل بسيار بزرگ محسوب می‌شود. در حاليكه شبكه‌های 3G حدودا سه برابر ظرفيت كنونی شبكه‌های 2G را ارائه می‌دهند، برنامه‌های 3G مثل تلويزيون موبايل و دسترسی به اينترنت، شبكه‌های اداری و e-mail بيش از 20 برابر طول موج برنامه‌های 2G نظير پيام‌رسانی صوتی و نوشتاری را مبادله می‌كند. تجهيزات بی سيم 3G، به ويژه گوشی‌های دارای دوربين‌های ديجيتال با تمايز رنگ و وضوح تصوير بالا و نمايشگرهای رنگی، می‌توانند بسيار بيش از شبكه‌های 3G اپراتورهای تلفن موبايل، تقاضای بازار را موجب شود.

اين صنعت در حال كار برای برطرف ساختن مشكل از طريق محدودسازی و كنترل تقاضا است و همچنين از طريق به كاربردن جديدترين پيشرفت‌های تكنولوژی برای بهره‌گيری از حداكثر عملكرد از تكنولوژی‌های 3G كنونی صنايع موبايل در پی حل مشكلات می‌باشد. در اين صنعت اعتقاد بر آن است كه می‌توان تقاضا برای خدمات 3G را محدود كرد، خدماتی نظير رسانه Streamings‌. اين كار را می‌توان با ادغام قيمت‌گذاری، multicasting و download در ساعات غير اوج ترافيك انجام داد. حدس قوی آن است كه اغلب مشتريان دستيابی به محتوای حرفه‌ای ساخت از طريق يك منو را خواهند پسنديد.

در همين حال اين صنايع در حال ساخت تكنولوژی‌های 3G پيشتاز هستند، يعنی WCDMA يا Wideband Code Division Multiple Access و EV-DO يا Evolution Data Optimized كه نسخه پيشرفته WCDMAs پكت دسترسی با سرعت بالا است، و HSDPA كه سرعت بالايی تا حدود 10 مگابيت در ثانيه را ايجاد می‌كند. نسخه پيشرفته EV-DO Rev A سرعت بالای 3.1 مگابيت بر ثانيه و تاخير كمتر را ايجاد می‌كند.

اما، اگر مشتريان و كاربران، كه طعم موبايل باند پهن را چشيده‌اند، برداشتن همه آن امكانات اصرار خواهند داشت- يعنی استفاده از تلفن‌های موبايل و كارتهای PC plug-in تا بتوانند همه محتويات مورد نظر خود را دريافت كرده و upload كنند.

www.rysavy.com) Rysary Research) روی اين موضوع تحقيق كرد و به اين نتيجه رسيد كه اپراتورهای موبايل، اكنون بايد برنامه‌ريزی كنند تا نيازهای رو به فزونی برای خدمات با سرعت بالا را جوابگو باشند، خدماتی نظير ويديوی موبايل و e-mail موبايل. اين پلاتفرم تكنولوژی پيشگام در ارائه اين خدمات در واقع يك MIMO است يعنی يك پيچيده‌سازی تقسيم فركانس ورودی/خروجی چندتايی Orthogonal، همچنين اين تكنولوژی هسته‌ای مورد استفاده محصولات شبكه بی‌سيم "pre-n" است كه پيشتر محصولات برجسته‌ای نسبت به WLAN را عرضه كرده‌اند.

صنايع موبايل به يك مرحله بحرانی رسيده است، آيا اين صنعت به انواع اينترانت جديد مثل Wi MAX Foram امكان تهيه برنامه‌هايی با ظرفيت بالاتر را می‌دهد يا نه، آيا صنعت درگير مشكلات می‌شود و رهبری تهيه تكنولوژی را برای جايگزين‌سازی استانداردهای 3G كنونی به دست می‌گيرد يا نه؟

مسئله جدی و سخت است. شكی نيست كه بی‌سيم 3G حداقل 7 سال مورد استفاده خواهد داشت و سيستم‌هايی نظير HSDPA و EV-DORev ميليون‌ها مشتری راضی نگه خواهند داشت. شكی نيست كه تكنولوژی 3G مدام به پيشرفت ادامه می‌دهد. البته در بعضی نقاط منطقی‌تر است كه يك پلاتفرم تكنولوژی جديد را بگيرد كه می‌توانند صنعت را ورای ظرفيت‌های HSDPA و EV-DO Rev A ببرد.

صنايع تلفن موبايل بايد اطمينان حاصل كنند كه نياز و خواست رو به فزونی كاربران برای باند پهن را پاسخگو هستند. اين مسئله ممكن است به قيمت حذف تكنولوژی 3G امروزه باشد. اما بهتر است صنعت تكنولوژی خود را حذف كند نه اينكه اجازه دهد ديگری اين كار را انجام دهد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 31 اردیبهشتماه 1384

12:35 AM

May 21, 2005

استاندارد شبكه‌های محلی بی‌سيم

سيامک عضدالملکی
azods@ieee.org

1.پيش درآمد

امروزه با بهبود عملكرد، كارايی و عوامل امنيتی، شبكه‌های بی‌سيم به شكل قابل توجهی در حال رشد و گسترش هستند و استاندارد IEEE 802.11 استاندارد بنيادی است كه شبكه‌های بی‌سيم بر مبنای آن طراحی و پياده سازی می‌شوند.

در ماه ژوئن سال 1997 انجمن مهندسان برق و الكترونيك (IEEE) استاندارد IEEE 802.11-1997 را به عنوان اولين استانداردِ شبكه‌های محلی بی‌سيم منتشر ساخت. اين استاندارد در سال 1999 مجدداً بازنگری شد و نگارش روز آمد شده آن تحت عنوان IEEE 802.11-1999 منتشر شد. استاندارد جاری شبكه‌های محلی بی‌سيم يا همانIEEE 802.11 تحت عنوان ISO/IEC 8802-11:1999، توسط سازمان استاندارد سازی بين‌المللی (ISO) و مؤسسه استانداردهای ملی آمريكا (ANSI) پذيرفته شده است. تكميل اين استاندارد در سال 1997، شكل گيری و پيدايش شبكه سازی محلی بی‌سيم و مبتنی بر استاندارد را به دنبال داشت. استاندارد 1997، پهنای باند 2Mbps را تعريف می‌كند با اين ويژگی كه در شرايط نامساعد و محيط‌های دارای اغتشاش (نويز) اين پهنای باند می‌تواند به مقدار 1Mbps كاهش يابد. روش تلفيق يا مدولاسيون در اين پهنای باند روش DSSS است. بر اساس اين استاندارد پهنای باند 1 Mbps با استفاده از روش مدولاسيون FHSS نيز قابل دستيابی است و در محيط‌های عاری از اغتشاش (نويز) پهنای باند 2 Mbpsنيز قابل استفاده است. هر دو روش مدولاسيون در محدوده باند راديويی 2.4 GHz عمل می‌كنند. يكی از نكات جالب توجه در خصوص اين استاندارد استفاده از رسانه مادون قرمز علاوه بر مدولاسيون‌های راديويی DSSS و FHSS به عنوان رسانهانتقال است. ولی كاربرد اين رسانه با توجه به محدوديت حوزه عملياتی آن نسبتاً محدود و نادر است. گروه كاری 802.11 به زير گروه‌های متعددی تقسيم می‌شود. شكل‌های 1-1 و 1-2 گروه‌های كاری فعال در فرآيند استاندارد سازی را نشان می‌دهد. برخی از مهم‌ترين زير گروه‌ها به قرار زير است:

- 802.11D: Additional Regulatory Domains
- 802.11E: Quality of Service (QoS)
- 802.11F: Inter-Access Point Protocol (IAPP)
- 802.11G: Higher Data Rates at 2.4 GHz
- 802.11H: Dynamic Channel Selection and Transmission Power Control
- 802.11i: Authentication and Security

كميته 802.11e كميته‌ای است كه سعی دارد قابليت QoS اِتـِرنت را در محيط شبكه‌های بی‌سيم ارائه كند. توجه داشته باشيد كه فعاليت‌های اين گروه تمام گونه‌های 802.11 شامل a، b، و g را در بر دارد. اين كميته در نظر دارد كه ارتباط كيفيت سرويس سيمی يا Ethernet QoS را به دنيای بی‌سيم بياورد.

كميته 802.11g كميته‌ای است كه با عنوان 802.11 توسعه يافته نيز شناخته می‌شود. اين كميته در نظر دارد نرخ ارسال داده‌ها در باند فركانسی ISM را افزايش دهد. باند فركانسی ISM يا باند فركانسی صنعتی، پژوهشی، و پزشكی، يك باند فركانسی بدون مجوز است. استفاده از اين باند فركانسی كه در محدوده 2400 مگاهرتز تا 2483.5 مگاهرتز قرار دارد، بر اساس مقررات FCC در كاربردهای تشعشع راديويی نيازی به مجوز ندارد. استاندارد 802.11g تا كنون نهايی نشده است و مهم‌ترين علت آن رقابت شديد ميان تكنيك‌های مدولاسيون است. اعضاء اين كميته و سازندگان تراشه توافق كرده‌اند كه از تكنيك تسهيم OFDM استفاده نمايند ولی با اين وجود روش PBCC نيز می‌تواند به عنوان يك روش جايگزين و رقيب مطرح باشد.

كميته 802.11h مسئول تهيه استانداردهای يكنواخت و يكپارچه برای توان مصرفی و نيز توان امواج ارسالی توسط فرستنده‌های مبتنی بر 802.11 است.

فعاليت دو كميته 802.11i و 802.11x در ابتدا برروی سيستم‌های مبتنی بر 802.11b تمركز داشت. اين دو كميته مسئول تهيه پروتكل‌های جديد امنيت هستند. استاندارد اوليه از الگوريتمی موسوم به WEP استفاده می‌كند كه در آن دو ساختار كليد رمز نگاری به طول 40 و 128 بيت وجود دارد. WEP مشخصاً يك روش رمزنگاری است كه از الگوريتم RC4 برای رمزنگاری فريم‌ها استفاده می‌كند. فعاليت اين كميته در راستای بهبود مسائل امنيتی شبكه‌های محلی بی‌سيم است.

شكل 1-1- گروه‌های كاری لايه فيزيكی

شكل1-2- گروه‌های كاری لايه دسترسی به رسانه

اين استاندارد لايه‌های كنترل دسترسی به رسانه (MAC) و لايه فيزيكی (PHY) در يك شبكه محلی با اتصال بی‌سيم را دربردارد. شكل 1-3 جايگاه استاندارد 802.11 را در مقايسه با مدل مرجع نشان می‌دهد.

شكل 1-3- مقايسه مدل مرجعOSI و استاندارد 802.11

محيط‌های بی‌سيم دارای خصوصيات و ويژگی‌های منحصر به فردی می‌باشند كه در مقايسه با شبكه‌های محلی سيمی جايگاه خاصی را به اين گونه شبكه‌ها می‌بخشد. به طور مشخص ويژگی‌های فيزيكی يك شبكه محلی بی‌سيم محدوديت‌های فاصله، افزايش نرخ خطا و كاهش قابليت اطمينان رسانه، همبندی‌های پويا و متغير، تداخل امواج، و عدم وجود يك ارتباط قابل اطمينان و پايدار در مقايسه با اتصال سيمی است. اين محدوديت‌ها، استاندارد شبكه‌های محلی بی‌سيم را وا می‌دارد كه فرضيات خود را بر پايه يك ارتباط محلی و با بُرد كوتاه بنا نهد. پوشش‌های جغرافيايی وسيع‌تر از طريق اتصال شبكه‌های محلی بی‌سيم كوچك برپا می‌شود كه در حكم عناصر ساختمانی شبكه گسترده هستند. سيـّار بودن ايستگاه‌های كاری بی‌سيم نيز از ديگر ويژگی‌های مهم شبكه‌های محلی بی‌سيم است. در حقيقت اگر در يك شبكه محلی بی‌سيم ايستگاه‌های كاری قادر نباشند در يك محدودهعملياتی قابل قبول و همچنين ميان ساير شبكه‌های بی‌سيم تحرك داشته باشد، استفاده از شبكه‌های محلی بی‌سيم توجيه كاربردی مناسبی نخواهد داشت.

از سوی ديگر به منظور حفظ سازگاری و توانايی تطابق و همكاری با ساير استانداردها، لايهدسترسی به رسانه (MAC) در استاندارد 802.11 می‌بايست از ديد لايه‌های بالاتر مشابه يك شبكه محلی مبتنی بر استاندارد 802 عمل كند. بدين خاطر لايه MAC در اين استاندارد مجبور است كه سيـّاربودن ايستگاه‌های كاری را به گونه‌ای شفاف پوشش دهد كه از ديد لايه‌های بالاتر استاندارد اين سيـّاربودن احساس نشود. اين نكته سبب می‌شود كه لايهMAC در اين استاندارد وظايفی را بر عهده بگيرد كه معمولاً توسط لايه‌های بالاتر شبكه انجام می‌شوند. در واقع اين استاندارد لايه‌های فيزيكی و پيوند داده جديدی به مدل مرجع OSI اضافه می‌كند و به طور مشخص لايه فيزيكی جديد از فركانس‌های راديويی به عنوان رسانهانتقال بهره می‌برد. شكل1-4، جايگاه اين دو لايه در مدل مرجع OSI را در كنار ساير پروتكل‌های شبكه سازی نشان می‌دهد. همانگونه كه در اين شكل مشاهده می‌شود وجود اين دولايه از ديد لايه‌های فوقانی شفاف است.

شكل 1-4- جايگاه 802.11 در مقايسه با ساير پروتكل‌ها

برای كسب اطلاعات بيشتر در خصوص گروه‌های كاری IEEE 802.11 می‌توانيد به نشانی http://www.ieee802.org/11 مراجعه كنيد. علاوه بر استاندارد IEEE 802.11-1999 دو الحاقيه IEEE 802.11a و IEEE 802.11b تغييرات و بهبودهای قابل توجهی را به استاندارد اوليه اضافه كرده است كه در ادامه اين مقاله به بررسی آنها خواهيم پرداخت.

2.معماری شبكه‌های محلی بی‌سيم

معماری 802.11 از عناصر ساختمانی متعددی تشكيل شده است كه در كنار هم، سـّيار بودن ايستگاه‌های كاری را پنهان از ديد لايه‌های فوقانی برآورده می‌سازد. ايستگاه بی‌سيم يا به اختصار ايستگاه (STA)، بنيادی‌ترين عنصر ساختمانی در يك شبكه محلی بی‌سيم است. يك ايستگاه، دستگاهی است كه بر اساس تعاريف و پروتكل‌های 802.11 (لايه‌های MAC و PHY) عمل كرده و به رسانه بی‌سيم متصل است. توجه داشته باشيد كه براساس تعريف كلاسيكِ شبكه‌های كامپيوتری، يك شبكه كامپيوتری مجموعه‌ای از كامپيوترهای مستقل و متصل است كه منظور از اتصال در اين تعريف، توانايی جابجايی و مبادله پيام‌ها است. ايستگاه‌های كاری بی‌سيم امروزی عمدتاً به صورت مجموعه سخت‌افزاري/نرم‌افزاری كارت‌های شبكه بی‌سيم پياده‌سازی می‌شوند. همچنين يك ايستگاه می‌تواند يك كامپيوتر قابل حمل، كامپيوتر كفدستی و يا يك نقطه دسترسی باشد. نقطه دسترسی در واقع در حكم پلی است كه ارتباط ايستگاه‌های بی‌سيم را با سيستم توزيع يا شبكه سيمی برقرار می‌سازد. كوچكترين عنصر ساختمانی شبكه‌های محلی بی‌سيم در استاندارد 802.11 مجموعه سرويس پايه يا BSS ناميده می‌شود. در واقع BSS مجموعه‌ای از ايستگاه‌های بی‌سيم است.

2-1- همبندی‌های 802.11

در يك تقسيم بندی كلی می‌توان دو همبندی را برای شبكه‌های محلی بی‌سيم در نظر گرفت. سـاده‌ترين همبندی، فی‌البداهه (Ad Hoc) و براساس فرهنگ واژگان استاندارد 802.11، IBSS است. در اين همبندی ايستگاه‌ها از طريق رسانه بی‌سيم به صورت نظير به نظير با يكديگر در ارتباط هستند و برای تبادل داده (تبادل پيام) از تجهيزات يا ايستگاه واسطی استفاده نمی‌كنند. واضح است كه در اين همبندی به سبب محدوديت‌های فاصله هر ايستگاهی ضرورتاً نمی‌تواند با تمام ايستگاه‌های ديگر در تماس باشد. به اين ترتيب شرط اتصال مستقيم در همبندی IBSS آن است كه ايستگاه‌ها در محدوده عملياتی بی‌سيم يا همان بُرد شبكه بی‌سيم قرار داشته باشند. شكل 2-1 همبندی IBSSرا نشان می‌دهد.

شكل 2-1- همبندی فی‌البداهه يا IBSS

همبندی ديگر زيرساختار است. در اين همبندی عنصر خاصی موسوم به نقطه دسترسی وجود دارد. نقطه دسترسی ايستگاه‌های موجود در يك مجموعه سرويس را به سيستم توزيع متصل می‌كند. در اين هم بندی تمام ايستگاه‌ها با نقطه دسترسی تماس می‌گيرند و اتصال مستقيم بين ايستگاه‌ها وجود ندارد در واقع نقطهدسترسی وظيفه دارد فريم‌ها (قاب‌های داده) را بين ايستگاه‌ها توزيع و پخش كند. شكل 2-2 همبندی زيرساختار را نشان می‌دهد.

شكل2-2- همبندی زيرساختار در دوگونه BSS و ESS

در اين هم بندی سيستم توزيع، رسانه‌ای است كه از طريق آن نقطه دسترسی (AP) با ساير نقاط دسترسی در تماس است و از طريق آن می‌تواند فريم‌ها را به ساير ايستگاه‌ها ارسال نمايد. از سوی ديگر می‌تواند بسته‌ها را در اختيار ايستگاه‌های متصل به شبكه سيمی نيز قراردهد. در استاندارد 802.11 توصيف ويژه‌ای برای سيستم توزيع ارائه نشده است، لذا محدوديتی برای پياده سازی سيستم توزيع وجود ندارد، در واقع اين استاندارد تنها خدماتی را معين می‌كند كه سيستم توزيع می‌بايست ارائه نمايد. بنابراين سيستم توزيع می‌تواند يك شبكه 802.3 معمولی و يا دستگاه خاصی باشد كه سرويس توزيع مورد نظر را فراهم می‌كند.

استاندارد 802.11 با استفاده از همبندی خاصی محدوده عملياتی شبكه را گسترش می‌دهد. اين همبندی به شكل مجموعه سرويس گسترش يافته (ESS) بر پا می‌شود. در اين روش يك مجموعه گسترده و متشكل از چندين BSS يا مجموعه سرويس پايه از طريق نقاط دسترسی با يكديگر در تماس هستند و به اين ترتيب ترافيك داده بين مجموعه‌های سرويس پايه مبادله شده و انتقال پيام‌ها شكل می‌گيرد. در اين همبندی ايستگاه‌ها می‌توانند در محدوده عملياتی بزرگ‌تری گردش نمايند. ارتباط بين نقاط دسترسی از طريق سيستم توزيع فراهم می‌شود. در واقع سيستم توزيع ستون فقرات شبكه‌های محلی بی‌سيم است و می‌تواند با استفاده از فنّاوری بی‌سيم يا شبكه‌های سيمی شكل گيرد. سيستم توزيع در هر نقطه دسترسی به عنوان يك لايه عملياتی ساده است كه وظيفه آن تعيين گيرنده پيام و انتقال فريم به مقصدش می‌باشد. نكته قابل توجه در اين همبندی آن است كه تجهيزات شبكه خارج از حوزه ESS تمام ايستگاه‌های سيـّار داخل ESS را صرفنظر از پويايی و تحركشان به صورت يك شبكه منفرد در سطح لايه MAC تلقی می‌كنند. به اين ترتيب پروتكل‌های رايج شبكه‌های كامپيوتری كوچكترين تأثيری از سيـّار بودن ايستگاه‌ها و رسانه بی‌سيم نمی‌پذيرند. جدول 2-1 همبندی‌های رايج در شبكه‌های بی‌سيم مبتنی بر 802.11 را به اختصار جمع بندی می‌كند.

802.11 Topologies
Independent Basic Service Set (IBSS) ("Ad Hoc" or "Peer to Peer") | Infrastructure
 | Basic Service Set (BSS) | Extended Service Set (ESS)

جدول 2-1- همبنديهای رايج در استاندارد 802.11

2-2- خدمات ايستگاهی

بر اساس اين استاندارد خدمات خاصی در ايستگاه‌های كاری پياده‌سازی می‌شوند. در حقيقت تمام ايستگاه‌های كاری موجود در يك شبكه محلی مبتنی بر 802.11 و نيز نقاط دسترسی موظف هستند كه خدمات ايستگاهی را فراهم نمايند. با توجه به اينكه امنيت فيزيكی به منظور جلوگيری از دسترسی غير مجاز بر خلاف شبكه‌های سيمی، در شبكه‌های بی‌سيم قابل اعمال نيست استاندارد 802.11 خدمات هويت سنجی را به منظور كنترل دسترسی به شبكه تعريف می‌نمايد. سرويس هويت سنجی به ايستگاه كاری امكان می‌دهد كه ايستگاه ديگری را شناسايی نمايد. قبل از اثبات هويت ايستگاه كاری، آن ايستگاه مجاز نيست كه از شبكه بی‌سيم برای تبادل داده استفاده نمايد. در يك تقسيم بندی كلی 802.11 دو گونه خدمت هويت سنجی را تعريف می‌كند:

- Open System Authentication
- Shared Key Authentication

روش اول، متد پيش فرض است و يك فرآيند دو مرحله‌ای است. در ابتدا ايستگاهی كه می‌خواهد توسط ايستگاه ديگر شناسايی و هويت سنجی شود يك فريم مديريتی هويت سنجی شامل شناسه ايستگاه فرستنده، ارسال می‌كند. ايستگاه گيرنده نيز فريمی در پاسخ می‌فرستد كه آيا فرستنده را می‌شناسد يا خير. روش دوم كمی پيچيده‌تر است و فرض می‌كند كه هر ايستگاه از طريق يك كانال مستقل و امن، يك كليد مشترك سّری دريافت كرده است. ايستگاه‌های كاری با استفاده از اين كليد مشترك و با بهره‌گيری از پروتكلی موسوم به WEP اقدام به هويت سنجی يكديگر می‌نمايند. يكی ديگر از خدمات ايستگاهی خاتمه ارتباط يا خاتمه هويت سنجی است. با استفاده از اين خدمت، دسترسی ايستگاهی كه سابقاً مجاز به استفاده از شبكه بوده است، قطع می‌گردد.

در يك شبكه بی‌سيم، تمام ايستگاه‌های كاری و ساير تجهيزات قادر هستند ترافيك داده‌ای را "بشنوند" – در واقع ترافيك در بستر امواج مبادله می‌شود كه توسط تمام ايستگاه‌های كاری قابل دريافت است. اين ويژگی سطح امنيتی يك ارتباط بی‌سيم را تحت تأثير قرار می‌دهد. به همين دليل در استاندارد 802.11 پروتكلی موسوم به WEP تعبيه شده است كه برروی تمام فريم‌های داده و برخی فريم‌های مديريتی و هويت سنجی اعمال می‌شود. اين استاندارد در پی آن است تا با استفاده از اين الگوريتم سطح اختفاء وپوشش را معادل با شبكه‌های سيمی نمايد.

2-3-خدمات توزيع

خدمات توزيع عملكرد لازم در همبندی‌های مبتنی بر سيستم توزيع را مهيا می‌سازد. معمولاً خدمات توزيع توسط نقطه دسترسی فراهم می‌شوند. خدمات توزيع در اين استاندارد عبارتند از:

- پيوستن به شبكه
- خروج از شبكه بی‌سيم
- پيوستن مجدد
- توزيع
- مجتمع سازی

سرويس اول يك ارتباط منطقی ميان ايستگاه سيّار و نقطه دسترسی فراهم می‌كند. هر ايستگاه كاری قبل از ارسال داده می‌بايست با يك نقطه دسترسی برروی سيستم ميزبان مرتبط گردد. اين عضويت، به سيستم توزيع امكان می‌دهد كه فريم‌های ارسال شده به سمت ايستگاه سيّار را به درستی در اختيارش قرار دهد. خروج از شبكه بی‌سيم هنگامی بكار می‌رود كه بخواهيم اجباراً ارتباط ايستگاه سيّار را از نقطه دسترسی قطع كنيم و يا هنگامی كه ايستگاه سيّار بخواهد خاتمه نيازش به نقطه دسترسی را اعلام كند. سرويس پيوستن مجدد هنگامی مورد نياز است كه ايستگاه سيّار بخواهد با نقطه دسترسی ديگری تماس بگيرد. اين سرويس مشابه "پيوستن به شبكه بی‌سيم" است با اين تفاوت كه در اين سرويس ايستگاه سيّار نقطه دسترسی قبلی خود را به نقطه دسترسی جديدی اعلام می‌كند كه قصد دارد به آن متصل شود. پيوستن مجدد با توجه به تحرك و سيّار بودن ايستگاه كاری امری ضروری و اجتناب ناپذير است. اين اطلاع، (اعلام نقطه دسترسی قبلی) به نقطه دسترسی جديد كمك می‌كند كه با نقطه دسترسی قبلی تماس گرفته و فريم‌های بافر شده احتمالی را دريافت كند كه به مقصد اين ايستگاه سيّار فرستاده شده‌اند. با استفاده از سرويس توزيع فريم‌های لايه MAC به مقصد مورد نظرشان می‌رسند. مجتمع سازی سرويسی است كه شبكه محلی بی‌سيم را به ساير شبكه‌های محلی و يا يك يا چند شبكه محلی بی‌سيم ديگر متصل می‌كند. سرويس مجتمع سازی فريم‌های 802.11 را به فريم‌هايی ترجمه می‌كند كه بتوانند در ساير شبكه‌ها (به عنوان مثال 802.3) جاری شوند. اين عمل ترجمه دو طرفه است بدان معنی كه فريم‌های ساير شبكه‌ها نيز به فريم‌های 802.11 ترجمه شده و از طريق امواج در اختيار ايستگاه‌های كاری سيّار قرار می‌گيرند.

2-4- دسترسی به رسانه

روش دسترسی به رسانه در اين استاندارد CSMA/CA است كه تاحدودی به روش دسترسی CSMA/CD شباهت دارد. در اين روش ايستگاه‌های كاری قبل از ارسال داده كانال راديويی را كنترل می‌كنند و در صورتی كه كانال آزاد باشد اقدام به ارسال می‌كنند. در صورتی كه كانال راديويی اشغال باشد با استفاده از الگوريتم خاصی به اندازه يك زمان تصادفی صبر كرده و مجدداً اقدام به كنترل كانال راديويی می‌كنند. در روش CSMA/CA ايستگاه فرستنده ابتدا كانال فركانسی را كنترل كرده و در صورتی كه رسانه به مدت خاصی موسوم به DIFS آزاد باشد اقدام به ارسال می‌كند. گيرنده فيلد كنترلی فريم يا همان CRC را چك می‌كند و سپس يك فريم تصديق می‌فرستد. دريافت تصديق به اين معنی است كه تصادمی بروز نكرده است. در صورتی كه فرستنده اين تصديق را دريافت نكند، مجدداً فريم را ارسال می‌كند. اين عمل تا زمانی ادامه می‌يابد كه فريم تصديق ارسالی از گيرنده توسط فرستنده دريافت شود يا تكرار ارسال فريم‌ها به تعداد آستان‌های مشخصی برسد كه پس از آن فرستنده فريم را دور می‌اندازد.

در شبكه‌های بی‌سيم بر خلاف اِتِرنت امكان شناسايی و آشكار سازی تصادم به دو علت وجود ندارد:

  1. پياده سازی مكانيزم آشكار سازی تصادم به روش ارسال راديويی دوطرفه نياز دارد كه با استفاده از آن ايستگاه سيّار بتواند در حين ارسال، سيگنال را دريافت كند كه اين امر باعث افزايش قابل توجه هزينه می‌شود.

  2. در يك شبكه بی‌سيم، بر خلاف شبكه‌های سيمی، نمی‌توان فرض كرد كه تمام ايستگاه‌های سيّار امواج يكديگر را دريافت می‌كنند. در واقع در محيط بی‌سيم حالاتی قابل تصور است كه به آنها نقاط پنهان می‌گوييم. در شكل زير ايستگاه‌های كاری "A" و "B" هر دو در محدوده تحت پوشش نقطه دسترسی هستند ولی در محدوده يكديگر قرار ندارند.

شكل 2-3- روزنه‌های پنهان

برای غلبه بر اين مشكل، استاندارد 802.11 از تكنيكی موسوم به اجتناب از تصادم و مكانيزم تصديق استفاده می‌كند. همچنين با توجه به احتمال بروز روزنه‌های پنهان و نيز به منظور كاهش احتمال تصادم در اين استاندارد از روشی موسوم به شنود مجازی رسانه يا VCS استفاده می‌شود. در اين روش ايستگاه فرستنده ابتدا يك بسته كنترلی موسوم به تقاضای ارسال حاوی نشانی فرستنده، نشانی گيرنده، و زمان مورد نياز برای اشغال كانال راديويی را می‌فرستد. هنگامی كه گيرنده اين فريم را دريافت می‌كند، رسانه را كنترل می‌كند و در صورتی كه رسانه آزاد باشد فريم كنترلی CTS را به نشانی فرستنده ارسال می‌كند. تمام ايستگاه‌هايی كه فريم‌های كنترلی RTS/CTS را دريافت می‌كنند وضعيت كنترل رسانه خود موسوم به شاخصNAV را تنظيم می‌كنند. در صورتی كه ساير ايستگاه‌ها بخواهند فريمی را ارسال كنند علاوه بر كنترل فيزيكی رسانه (كانال راديويی) به پارامتر NAV خود مراجعه می‌كنند كه مرتباً به صورت پويا تغيير می‌كند. به اين ترتيب مشكل روزنه‌های پنهان حل شده و تصادم‌ها نيز به حداقل مقدار می‌رسند. شكل 2-4 زمان‌بندی RTS/CTS و وضعيت ساير ايستگاه‌ها را نشان می‌دهد.

شكل 2-4- زمان‌بندی RTS/CTS

2-5- لايه فيزيكی

در اين استاندارد لايه فيزيكی سه عملكرد مشخص را انجام می‌دهد. اول آنكه رابطی برای تبادل فريم‌های لايه MAC جهت ارسال و دريافت داده‌ها فراهم می‌كند. دوم اينكه با استفاده از روش‌های تسهيم فريم

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 31 اردیبهشتماه 1384

10:58 PM

May 21, 2005

آشنايي با سيستم فايل GNU/Linux

ميثاق محمدي‌زاده
ماهنامه شبکه - آبان ۱۳۸۳ شماره ۴۸

فايل‌ها يكي از بنيادي‌ترين مفاهيم سيستم‌عامل هستند. هر سيستم‌عاملي براي ساخت يك فايل، نگهداري اطلاعات آن، دسترسي و بازيابي فايل، تغيير خصوصيات فايل و عمليات‌ و مفاهيم مرتبط با فايل از ساختاري بهره مي‌برد كه از آن به سيستم فايل (File system) ياد مي‌شود. FAT16 سيستم فايل معروفMS-DOS است، FAT32 وNTFS در ويندوز استفاده مي‌شوند و يونيكس، سولاريس،BSD و OSL2 هر كدام سيستم فايل مرتبط با ساختار كرنل خود را دارندExt . هم سيستم فايل انحصاري سيستم‌عامل اپن‌سورس گنو/ لينوكس است كه همزمان با توسعه اين سيستم‌عامل خلق شد. گنو/ لينوكس بخشي از پايداري و قدرتمندي خود را همراه ويژگي‌هاي منحصربه ‌فردي مانند دادن مجوزها و مالكيت‌ها به هر فايل را مديون سيستم ‌فايل خود است. در نوشتار زير نگاهي اجمالي به اين سيستم فايلي داريم.

تاريخچه
لينوس توروالدز در طراحي سيستم‌عامل آزمايشي خود در سال 1991 از سيستم فايلMinix استفاده كرد. سيستم فايلMinix جوابگوي نيازهاي توروالدز بود و به خوبي در سيستم‌عامل جديد جا افتاد. با به‌وجود آمدن يك جنبش اينترنتي براي توسعه اين سيستم‌عامل جديد و تبديل آن به يك سيستم‌عامل اپن‌سورسِ قابل استفاده براي عامه مردم، نارسايي و مشكلات سيستم فايلMinix ظهور كرد و نياز به طراحي يك سيستم فايل جديد توسط مشتاقان لينوكس حِس شد. دو مشكل عمده Minix در سيستم فايل عبارت بودند از كوچك بودن نام فايل‌ها (حداكثر 14 كاراكتر) و فضاي حافظه بسيار محدود (بلوك آدرس‌دهي فقط 16 بيتي بود يعني 216=46 مگابايت)
طراحي (Virtual File System) VFS توسط <كريس پروون زنو> راه را براي خلق يك سيستم فايل جديد با توانايي و كارايي بهتر ازMinix هموار ساختVFS . يا همان لايه مجازي سيستم‌ فايل توسط خود آقاي توروالدز توسعه داده شد و به كرنل لينوكس اضافه گرديد. بلافاصله در آوريل 1992 سيستم‌ فايل جديد،Extended File system ، در نسخه 96/0 لينوكس به‌جاي سيستم فايلMinix استفاده شد. در واقع بنيان‌گذارانEXT fs عبارتند از Remy Card از آزمايشگاه ماساچوست، "Theodor Ts o" از انجمن تكنولوژي ماسوچوست و Stephan Tweedie از دانشگاه رادينبرگ.

 | Minix | Ext Fs | Ext2 Fs | Xia Fs
Max FS Size | 64 MB | 2 GB | 2 GB | 2 GB
Max File Size | 64 MB | 2 GB | 2 GB | 64 MB
Max File Name | 16/30 c | 255 c | 255 c | 248 c
3 time Support | no | no | yes | yes
Extensible | no | no | yes | no
var. block size | no | no | yes | no
Maintained | yes | no | yes | ?

ويژگي مهم EXT fs حافظه دو گيگا بايتي براي سيستم فايل و نامگذاري 255 كاراكتري فايل‌ها است. همراه ساير بخش‌هاي لينوكس كه روح توسعه در آن‌ها جريان داشت، در ژانويه 1993،EXT fs بهSecond Extended File system ارتقاء داده شدEXT . مشكلاتي داشت كه مي‌بايست برطرف مي‌شدند. مانند عدم كارايي مناسب Inode ها وLink List ها و عدم امكان استفاده از Time stamps (ثبت زمان‌هاي مربوط به هر فايلEXT2 fs .( نسبت به نگارش قبلي خود بسيار بهتر و مطمئن‌تر بود و مشكلات و باگ‌هاي موجود برطرف شده بودند. ولي از پايداري لازم برخوردار نبود. همزمان باEXT2 fs ، سيستم فايلي هم براساس ساختارMinix به نام Xia طراحي شد كه يك سيستم فايل مطمئن و پايدار بود. در نسخه‌هاي بعديEXT2 fs ، پايداري آن هم به حد مناسب رسيد و به عنوان سيستم فايل مخصوص لينوكس معرفي و عرضه شد. پس از مدت زيادي كه از زمان عرضه و استفاده EXT3 fs گذشت، نسل جديدEXT به نامEXT3 fs طراحي شد. پررنگ‌ترين ويژگي 3EXT استفاده از فناوري journaling است. Journaling روشي براي ثبت وقايع هر فايل است تا انسجام و سازگاري داده‌ها با سيستم براي هميشه تضمين شود.Vfs اين توانايي را هم ايجاد كرده است كه لينوكس بتواند با ديگر سيستم‌ فايل‌هاي موجود نيز در تعامل باشد و سيستم‌ فايل‌هاي ديگري هم براي عمليات‌خود تعريف كند.
همان‌طور كه در تاريخچه گفته شد، اولين نسخه‌‌هاي لينوكس همراه با سيستم فايلMinix عرضه شدند كه يك سيستم فايل مناسب و كارا مي‌نمود ولي پيشرفت پروژه گنو و طراحي يك سيستم‌عامل اپن‌سورس فراگير، نيازمند سيستم‌ فايل جديدتري بود. كليد سيستم فايلext به وسيله طراحي ساختارVFS رقم خورد. براي شناخت بيشتر اين سيستم فايلي، ابتدا لايه مجازي سيستم فايل استفاده شده در لينوكس را بررسي مي‌كنيم.

Virtual File system) VFS)

شکل 1

براي مشاهده تصاوير مقاله در اندازه واقعي، روي آنها کليک کنيد
لينوكس از يك لايه مجازيVFS براي سيستم فايل خود استفاده مي‌كند. اين لايه مجازي ميان سيستم فايل در كرنل و لايه فراخواني فرايندهاي كاربران لينوكس واقع شده است (شكل 1).

همان‌طور كه شكل نشان مي‌دهد،VFS بر روي سيستم فايل قرار گرفته و با گرفتن توابع فراخواني پروسس‌هاي كاربران، اطلاعات تجزيه و تحليل شده را به سمت يك بلوك سيستم‌ فايل هدايت مي‌كند. هر پروسس در وضعيت كاري كاربر با اين لايه سيستم فايل در ارتباط است نه به‌صورت مستقيم با رويه‌هاي سيستم فايل. هسته سيستم‌عامل با به‌كارگيريVFS اين توانايي را به كرنل مي‌دهد كه بدون هيچ نگراني از فرمت‌هاي گوناگون پشتيباني كند، مانند فرمت فايل يونيكس و ويندوز. همچنينVFS باعث تسريع در عمليات‌هاي سيستم فايل شده و در هر فراخواني فقط نياز به دسترسي به يك بلوك است.

مفاهيم اوليهext
Extendedfs از مفاهيم يونيكس براي ساختاربندي خود استفاده مي‌كند. مهم‌ترين اين مفاهيمInode ،Directories وLink List ها مي‌باشند.

Inode

شکل 2

براي هر فايل يك ساختار بلوك مانندInode وجود دارد و هر فايل در لايه فيزيكي سيستم‌عامل تبديل به يكInode مي‌شود. هرInode از بخش‌هاي مختلفي تشكيل مي‌شود كه هر بخش شامل يك سري اطلاعات است. نوع فايل، اندازه فايل،owner يا مالك فايل، مجوزها و خصوصيات فايل، تاريخ‌هاي ثبت شده براي فايل مانند تاريخ ايجاد، آخرين دسترسي، اصلا‌ح و اشاره‌گرها، مهم‌ترين اطلاعات هرInode را تشكيل مي‌دهند. داده‌هاي هر فايل درData Block ها ذخيره و نگهداري مي‌شوند كه هر Inode تعدادي اشاره‌گر به اين ديتابلوك‌ها دارد. هر فرايندي در سطح سيستم‌عامل كه نياز به فايلي مشخص دارد كافيست شماره آن فايل را به دست بياورد و با رجوع بهInode فايل تمام اطلاعات لازم را در اختيار خواهد داشتInode .ها ساختاري همانند شكل 2 دارند.

Directories
دايركتوري‌ها همان ساختار درختي آشناي سازمان‌دهي فايل‌ها هستند.
ساختار هر دايركتوري به صورت زير مي‌باشد:

Inode number
entry length
file name

شکل 3

Lengthها مدخل‌هاي اشاره‌كننده به Link ها هستند.
هر دايركتوري مي‌تواند شامل فايل يا زيردايركتوري باشد. دايركتوري‌ها نام هر فايل همراه شمارهInode آن را در خود ذخيره مي‌كنند. هسته سيستم‌عامل براي يافتن يك فايل ابتدا دايركتوري‌ها را اسكن مي‌كند و با پيدا كردن شمارهInode فايل آدرس فيزيكي فايل در ديسك توليد مي‌شود (شكل 3). از ديگر وظايف دايركتوري‌ها مديريتLink List ها است.

Link
همانند يونيكس، مفهوم لينك هم درext مطرح و به كار برده شده استLink List . مي‌تواند يك اشاره‌كننده به فايل يا دايركتوري يا بلوك‌هايي از داده‌ها باشد. شما با ايجاد يك لينك مي‌توانيد دسترسي سريع به فايل يا دايركتوري داشته باشيد. خود هسته سيستم‌عامل هم براي دسته‌بندي اطلاعات ازLink List ها استفاده مي‌كندLink .ها در سطح كاربر هم قابل تعريف و به‌كارگيري هستند و به لينك‌هاي سخت‌افزاري و نرم‌افزاري تقسيم‌بندي مي‌شوند.

ساختار فيزيكي Ext Fs
سيستم فايلext لينوكس ساختار فيزيكي‌ همانند سيستم فايلBSD دارد. بدين‌صورت كه حافظه سيستم‌ فايل تماماً بهBlock Group ها تقسيم مي‌شود. اين بلوك‌ها در اندازه‌هاي 1K، 2K،4K قرار مي‌گيرند و هر بلوك براي يك سري اطلاعات با كاربردي خاص استفاده مي‌شود. ساختار حافظه فيزيكي سيستم فايلext به اين شكل است:

Boot Sector
Block Group 1
Block Group 2
...
Block Group N

هر يك از اينBlock Group ها هم ساختاري اين چنين دارند:

Super Block
FS Description
Block Bitmap
Inode Table
Data Block

همان‌طور كه مشاهده مي‌شود هرBlock Group در ابتدا شامل يكSuper Block است كه اطلاعات مدير سيستم(Root) به همراه اطلاعات كلي مربوط به بلوك در آن قرار مي‌گيرد. بخش بعدي اطلاعات مربوط به سيستم‌ فايل است و در ادامه جدولInode ها، داده‌هاي هر بلوك و بيت‌هاي كنترلي بلوك وInode قرار مي‌گيرند.
در اين شيوه از ساختار‌بندي فايل، چون جدولInode ها فاصله‌اي بسيار نزديك با بلوك‌ داده‌ها دارد كارايي سيستم چندين برابر مي‌شود و سرعت دستيابي به اطلاعات هر بلوك از فايل‌ها افزايش مي‌يابد. همچنين با ايجاد يك ساختار بلوك‌بندي شده فضاي آدرس‌دهي منطقي كمتري مصرف مي‌شود.

Ext2 fs سيستم فايل استاندارد گنو / لينوكس
پس از به كار گرفته شدن سيستم فايلExt fs در هسته گنو/ لينوكس برخي نواقص و نارسايي‌هاي آن ظاهر شد و بنابراين به سيستم فايل Second Extended fs ارتقاء داده شد. قريب يك دههExt2 fs پيش‌فرض سيستم فايل لينوكس در كرنل و توزيع‌هاي تجاري بود.
شايد بتوان مهمترين شاخصه‌هايExt2 fs كه باعث متمايز شدن آن از تمامي سيستم‌ فايل‌هاي قبل از خود شد را به‌صورت زير ليست كرد:
Ext2 fs توانايي كار و پشتيباني با فايل‌هايي با فرمتي غير ازExt را هم داراست. به راحتي با داشتن يكVFS فايل‌هاي ويندوز و يونيكس و ديگر سيستم‌عامل‌هاي تجاري همانندBSD و فرمتV را شناخته و از اين فرمت‌ها در كنارExt استفاده مي‌كند.
Ext2 fs قابليت نامگذاري فايل‌ها تا 255 كاراكتر را ميسر مي‌كند و حتي در صورت تعريف بلوك‌هاي بزرگ‌تر باز هم اين اندازه قابل افزايش است.
به‌صورت پيش‌فرض، حافظه فيزيكي 2Ext برابر2 گيگا بايت است. اين اندازه از سيستم فايل همراهVFS امكان ايجاد يك پارتيشن بزرگ تا اندازه4 گيگا بايت را ميسر مي‌كند و ديگر نيازي به تقسيم يك پارتيشن بزرگ به اندازه‌هاي كوچك‌تر به وجود نمي‌آيد.
Ext fs با تخصيص پنجاه درصد بلوك‌هاي حافظه به حساب ريشه (Root) توانايي‌هاي بالقوه‌اي در اختيار مدير سيستم قرار مي‌دهد. با استفاده از اين بلوك‌ها امكان پيگيري فرايندهاي كاربران به آساني ميسر مي‌شود.
از خصوصيات ويژهExt2 fs امكان‌دهي به كاربر درset كردن خصوصيات يك فايل در زمان ساخت يا بعد از آن است. حتي يك كاربر مي‌تواند برخي رفتارهاي سيستم فايل را هم به تناسب خود تغيير دهد. اين اعمال تغييرات به‌وسيله ارايه ابزارهاي بسيار ساده‌اي كه از طرف جامعه اپن‌سورس به كاربران هديه مي‌شود، به آساني صورت مي‌گيرد.
اجازه تعريف اندازه بلوك‌هاي فيزيكي سيستم فايل به مدير سيستم ديگر مزيتExt2 fs است. مدير سيستم مي‌تواند برحسب نياز بلوك‌ها را به صورت دستي سايزبندي كند. اين امر موجب كارايي هر چه بيشتر سيستم در مواجه با فرايندهاي بلوكه شده مي‌شود.
استفاده ازLink ها درExt2 fs به راحتي امكان‌پذير است و با يك دستور <>Ln در پوسته فرمان مي‌توانيد براي فايل‌ها و دايركتوري‌ها، يكLink درست كنيد.
در سيستم فايلExt2 fs ،State هاي سيستم فايل قابل ثبت و نگهداري است. فيلدSuper Block در هر بلوك سيستم فايل وظيفه‌اي براي نگهداري اين اطلاعات دارد كه قابل بازخواني هستند.
و مزيت آخرExt2 fs در دسترس و همگاني بودن توابع كتابخانه‌اي سيستم فايل است كه اين امكان را مي‌دهد، هر كاربري با به‌كارگيري اين توابع توانايي هرگونه تغيير، اصلاح و به‌وجود آوردن و ساخت را در 2Ext به‌دست آورد. به همين خاطر ابزارهاي بسياري براي كار باExt2 fs موجود و قابل تهيه هستند. از ابزار پيكربندي سيستم فايل تا ابزار اشكال‌زدايي آن. مهمترين اين ابزارها عبارتند ازDebugfs :،dump2 fs ،tune fs ،e2fsck ،Mk2 fs .

Ext3 fs نسل جديد سيستم فايل گنو / لينوكس
در كرنلي كه ازExt2 fs استفاده مي‌كند اگر عملياتshut down به درستي انجام نشود، به عنوان مثال قطع برق ياCrash كردن سيستم، شاهد بروز دو مشكل عمده هستيم: امكان خرابي و از بين رفتن داده‌ها و دوم اين‌كه سيستم براي بوت مجدد نيازمند به استفاده از ابزار اسكن داده‌ها براي شناسايي و تشخيص داده جهت سازگاري آن‌ها با سيستم فايل است. گاهي در اين موارد مدت زمان زيادي بايد صبر كنيد تا چند گيگابايت اطلاعات توسط سيستم خوانده شوند كه اين بسيار نامطلوب استthree Extended fs . نسل جديدExt2 fs مشكل را برطرف كرده استExt3 fs . با بهره‌گيري از تكنولوژي <>journaling يا <سيستم ثبت وقايع فايل‌ها>، امنيت داده‌ها و سازگاري و انسجام اطلاعات را در هنگام وقوع خطاهاي سخت‌افزاري تظمين مي‌كند.
Ext3 fs توسط آقاي Tweedie (از بنيان‌گذاران سيستم فايل (Ext fs توسعه يافته و از هسته 15.4.2 به بعد قابل استفاده است.
Journaling از روشي در ذخيره و نگهداري داده‌ها بر روي ديسك استفاده مي‌كند كه ديگر نيازي به سازمان‌دهي اطلاعات بلوك‌هاي سيستم فايل و تنظيم كردن آدرس‌هاي منطقي نيست و هيچ زماني در فرايند بوت براي شناخت داده‌ها و انسجام آن‌ها با سيستم فايل صرف نمي‌شود. در ضمن امنيت داده‌ها هم تأمين مي‌شود. در زمان وقوع يك خطاي سخت‌افزاري، ژورنالينگ از اطلاعات داده‌ها پشتيباني مي‌كند و باعث مي‌شود هيچ‌گونه اطلاعات جديدي بر روي داده‌ها نوشته نشود.
سرعت و بهره توان عملياتيExt3 fs به مراتب بيشتر ازExt2 fs استExt3 fs . از سه روش براي بالا بردن سرعت استفاده مي‌كند. در روشData = write back ، پس ازCrash كردن سيستم، داده‌هاي قديمي استفاده مي‌شود. در اين روش اطمينان صحت داده‌ها پايين مي‌آيد ولي سرعت بالا‌ مي‌رود. در روش Data = ordered (پيش‌فرض) از هر گونه اضافه شدن اطلاعات به داده‌هاي بلوك‌هاي سيستم فايلInode ها جلوگيري مي‌شود. اين مد بهترين كارايي را دارد. در سومين روشData= journal ، سيستم از يك فايل بزرگjournal براي نگهداري اطلاعات سيستمي ضروري براي ذخيره و بازيابي داده‌هاي ديسك استفاده مي‌كند. مي‌شود گفت كه فايل journal در واقع فايلBackup سيستم است.
Ext3 fs باExt2 fs سازگاري كامل دارد و تبديل و ارتقاء به آساني و با چند خط فرمان‌نويسي درshell سيستم صورت مي‌پذيرد. و اين كار بدون هيچ‌گونه نياز به فرمت كردن يا پارتيشن‌بندي يا اختلال در بلوك‌هاي داده‌هاي سيستم فايل صورت مي‌پذيرد. يعني شما فقط فايلjournal را به سيستم فايلExt2 fs اضافه مي‌كنيد.
به‌كارگيري تكنولوژيjournaling در سيستم فايل علاوه بر مزاياي گفته شده، باعث ايجاد يك تاريخچه از هر فايل در سيستم شده و عمليات پيگيري وقايع هر فايل به آساني امكان‌پذير مي‌شود. گذشته از اين ژورنالينگ در ديگر امكانات هسته هم استفاده مي‌كند.
همه اين ويژگي‌ها باعث شده‌اند كه بسياري از شركت‌هاي تجاري سيستم فايل 3Ext را به عنوان پيش‌فرض توزيع گنو/ لينوكس خود انتخاب كنندRed Hat . از نسخه 2/7،Ext3 fs را در نسخه لينوكس خود به‌كار برد.

منابع:
1) www.Technotux.com
2) www.tldp.org/Howto/filesystemhowto.html
3) http://web.mit.edu/tytso/www/linux/ext2intro/html
4) http://web.mit.edu/tytso/www/linux:ext2.html
5) www.linuxtoday/redhatext3information.html

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 31 اردیبهشتماه 1384

11:01 PM

May 21, 2005

70 درصد توليد ناخالص ملي كشورها متاثر از فناوري اطلاعات است

دبير شورايعالي اطلاع‌رساني، گفت:‌ انديشمندان و نخبگان كشور دچار يك غفلت بزرگ شدند و در اين شرايط مبهوت چالش‌هاي سياسي و اجتماعي شده و از وظيفه‌ي اصلي خويش غافل مانده‌اند.

به گزارش خبرنگار سرويس فناوري اطلاعات خبرگزاري دانشجويان ايران (ايسنا)، در همايش فرهنگ‌، فناوري اطلاعات و ارتباطات و توسعه، مهندس جهانگرد با اشاره به برگزاري اين‌گونه همايش‌ها، گفت: از نظر من برگزاري اين همايش‌ها جايگاه ويژه‌اي در برنامه‌ي توسعه‌ي آينده‌ي ايران دارد و اگر بگويم كه اين موضوع به عنوان مهمترين و شايسته‌ترين مطلبي است كه در بخش انديشه‌ي كشورها بايد به آن پرداخته شود سخن گزافي نگفتم.

وي، با اشاره به اينكه برنامه‌ي توسعه‌ي چهارم كشور تاكيد ويژه‌اي در بكارگيري ICT دارد، گفت: فناوري اطلاعات و ارتباطات به عنوان موتور توسعه‌ در برنامه‌هاي بلند مدت و ميان مدت ايران مطرح است و در اين ميان تعريف ICT، قلمروهاي آن و تاثير و تاثيراتي كه مي‌تواند داشته باشد از مهمترين موضوعات آن است.

وي با اشاره به پديده‌ي اينترنت، گفت: با واسطه‌ي شدت نفوذي كه اين پديده در جامعه‌ي ما داشته ما ضمن تهديد انگاري در تمام شئون جامعه به تدريج فرصتي پيدا كرديم تا به فرصت‌هاي آن نگاه كنيم و نوعي فرصت انگاري در مورد اين موضوع به وجود آمد.

وي، ادامه داد: در مواجهه با پديده‌هاي جديد با دو رويكرد تهديدانگاري و شيفتگي روبرو هستيم كه اين دو رويكرد احتياج به تدبير و تدبر دارد تا به بهره‌مندي از فرصت‌ها دست يابيم، بنابراين نياز داريم پديده‌ي جديد و چالش‌هاي آن را بشناسيم تا بتوانيم چگونگي رفتارمان را در اتخاذ مواضع پيدا كنيم.

دبير شوراي عالي اطلاع‌رساني با بيان اينكه انسان به عنوان تار و پود فعاليت‌ها و ICT به عنوان محمل كار محسوب مي‌شود، اظهار داشت: از سال 1983 و 1984 به بعد پديده‌ي كامپيوتر در سيستم‌هاي مخابراتي به كار گرفته شد و در حقيقت پيوندي بين كامپيوتر و مخابرات به وجود آمد كه با اين پيوند در حقيقت وارد عصر اطلاعات شديم و پديده‌ي شبكه حاصل اين پيوند بود.

وي، در ادامه تاكيد كرد: توسعه‌ در به‌كارگيري IT در بخش‌هاي مختلف اجتماعي و اقتصادي امروز به سطحي از پيچيدگي و نفوذ رسيده كه برآورد مي‌شود كه اگر كشورها از اين موضوع غفلت كنند در حقيقت از مبحثي كه نزديك به 70 درصد توليد ناخالص ملي را متاثر شناخته غافل شده‌اند كه اين موضوع در دهه‌ي آينده مشكل ساز خواهد بود.

جهانگرد، سرمايه‌ي انساني را مهمترين چالش توسعه عنوان كرد و افزود: در كشورهاي شبيه ما نيروي انساني مهارت بسيار كمي دارد و فرار مغزها نيز يك پديده‌ي عمومي در بين كشورهاي مختلف است و اين در حالي است كه خروج يك نفر فارغ‌التحصيل در سطح دكتري از كشوري موجب جابجايي يك ميليون دلار فرصت است.

وي در ادامه يادآور شد: كشور آمريكا به اين مبحث توجه جدي داشته و امروز اين كشور به عنوان منبع تعامل جهاني در بحث ارتباطات شده و در حقيقت امروزه هاب مبادله‌ي اطلاعات و ارتباطات جهان آمريكاست.

وي، گفت: شكل گيري برنامه‌ي توسعه‌ي ICT (تكفا) در كشور سبب ايجاد يك نگاه توسعه‌يي و همه جانبه در بكارگيري ICT شده است. نهادسازي، فعاليت‌هاي جاري و مطالعات بنيادين و تدوين برنامه‌ي استراتژيك اطلاع‌رساني از فعاليت‌هايي است كه شوراي عالي اطلاع‌رساني انجام داده است.

وي با بيان اينكه تا كنون نزديك به 4 هزار پروژه در اين حوزه و در راستاي اهداف تكفا در كشور آغاز شده، گفت: تمام اعتباراتي كه براي حوزه‌ي پژوهش داشتيم فقط در حوزه‌ي علوم انساني هزينه كرديم و در بخش تكنولوژيكي هزينه نكرديم چون در اين بخش به طور خودكار هزينه پرداخت مي‌شود و در اين راستا با دانشگاه‌هاي مختلف در زمينه‌هاي اقتصادي، ادبيات، حقوق و ‌جامعه‌شناسي قرارداد بستيم.

جهانگرد در ادامه يادآور شد: فناوري بخش ساده‌ي اين مبحث است و مهمتر از آن بحث بكارگيري فناوري اطلاعات است، گفت: در طي دو دهه‌ي گذشته بين ما و محيط پيرامونمان گسست خطرناكي شكل گرفته و با دشمن انگاري ارتباط علمي و پژوهشي ما قطع شده و فقدان يك ارتباط و تعامل صحيح با پيرامون باعث شده كه تصور كنيم هرچه مي‌گوييم صحيح است در نتيجه سوادمان نيز نقص پيدا كرده است.

دبير شوراي عالي اطلاع‌رساني با اظهار تاسف از اينكه در طي دو دهه‌ي گذشته هيچ محصول فكري جديد در حوزه‌ي علوم انساني نداشتيم، گفت: اين موضوع بسيار خطرناك است بنابراين هرچه زودتر بايد كاري كنيم كه اين خلاء پر شود و اميدوارم اين همايش و همايش‌هايي از اين قبيل بتواند موجب خلق و توليد محصولاتي براي پاسخ گفتن به اين مبحث مهم و استراتژيك باشد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 2 خردادماه 1384

12:44 AM

May 23, 2005

جايگاه زنان در جامعه اطلاعاتى: يک ديدگاه جامعه شناختى

نويسنده: دکتر شيرين احمدنيا

اين نوشته اساساً ترجمه اى است از مقاله دكتر شيرين احمدنيا به زبان انگليسى كه در فصلنامه "زن فرزانه" در پاييز 2003 توسط موسسه مطالعات و تحقيقات زنان به چاپ رسيده است.
دكتر شيرين احمدنيا استاديار دانشگاه علامه طباطبايى (عضو دپارتمان هاى جامعه شناسى و مطالعات زنان) است

مقدمه
اميدهايى وجود دارد که جنبش جهانى زنان نيز بتواند تا حد زيادى از پتانسيل و وعدههاى انقلابى ارتباطات الکترونيکى، همچنانکه تمام دنيا از آن بهره مند مى شود سود ببرد. همانطور که گيتلر (1991: 91)(Gittler ) خاطر نشان کرده، در سراسر دنيا زنان امروزه فناوريهاى اطلاعاتى و ارتباطى را در جهت اهداف جنبش زنان بكار مى گيرند. ارتباطات الکترونيکى، شبکه سازى زنان و اقدامات جلب حمايت براى ايشان را به روشهايى که قبلا امکان پذير نبودند، تسهيل مى کند.
در اين نوشته، ابتدا مختصراً به معنا، امتيازات و قابليتهاى آنچه که "جامعه اطلاعاتى" ناميده مى شود، نظر ميافکنيم، سپس نقش و جايگاه فعلى زنان در فضاى جامعه اطلاعاتى در سطح جهانى را مورد بررسى قرار مى دهيم به‌طوريكه هم امتيازات فناوريهاى اطلاعات و ارتباطات براى زنان و هم موانعى كه در اين راستا وجود دارد به ويژه در ارتباط با زنان کشورهاى در حال توسعه، مورد تاكيد قرار گيرد.
سوالاتى كه در ارتباط با زنان پيش روى ما قرار دارد عبارتند از اينکه:
- آيا زنان به عنوان نيمى از جمعيت هر جامعه، به طرز مناسبى در دنياى فناوريهاى اطلاعاتى و ارتباطات (يا جامعه اطلاعاتى) حضور موثر دارند؟ يا اينكه احتمالاً الگوهاى ديرينه ى نابرابرى جنسيتى و تبعيض عليه زنان در عرصه‌هاى اجتماعى و اقتصادى همچنانكه در رسانه هاى قديمى معمول بوده، در اينجا نيز دوباره تکرار مى‌شوند؟ موضوع شکاف ديجيتالى جنسيتى در اين ارتباط مورد بحث قرار خواهد گرفت.
- نحوه حضور زنان در اين عرصه واقعا چگونه است؟ يا اينکه آنان به عنوان بخشى از مشارکت‌کنندگان در جامعه اطلاعاتى واقعاً به چه مشغولند؟ در اين ارتباط وعده‌هاى اصلى فناورى اطلاعاتى و ارتباطات و منافع واقعى اين فناوريها در جهت توانمندسازى گروههاى زنان فعال و نيز موانع موجود مورد توجه قرار مى‌گيرد.

جامعه اطلاعاتى: يک مفهوم نسبتاً جديد!
برخى بر اين باورند که هنوز تعريفى عام از جامعه اطلاعاتى واقعاً وجود ندارد و تعاريف پيشنهاد شده اغلب نارسايند و فقط موضوعات خاص يا تاثيرات ويژه اى را مورد توجه قرار مى‌دهند. با اين همه، به طور کلى بسيارى به اين موضوع اذعان دارند که جامعه اطلاعاتى پديده‌اى است که در هر جنبه از زندگى افراد نفوذ پيدا کرده است و بر تک تک سلولهاى جامعه و هر بخش از فعاليتهاى آن تاثير گذاشته است.
http://www.itu.int.osg.spu.wsis-thenes/vision /vision.html
اعتقاد بر اين است كه سه عنصر اصلى يعنى دانش و اطلاعات؛ ازدياد فناوريهاى اطلاعات و ارتباطات؛ و دسترسى و كاربرد فناوريهاى اطلاعات و ارتباطات، اساس و بنيان جامعه اطلاعاتى را تشکيل مى دهد (همان).
طبق گزارش نهايى برنامه‌ى" فرصت ديجيتالى" از جانب برنامه عمران ملل متحد (UNDP, 2001) “ فناوريهاى اطلاعاتى و ارتباطاتى به عنوان تواناساز قدرتمندى براى اهداف توسعه شناخته مى شود، چرا كه ويژگيهاى منحصر به فرد آن، ارتباطات و تبادل اطلاعات را به طور قابل توجهى بهبود مى بخشد و منجر به تقويت وايجاد شبکه هاى جديد اجتماعى و اقتصادى مى‌شود:
- فناوريهاى اطلاعات و ارتباطات فراگير و چندجانبه عمل مى كنند: اين فناوريها را مى توان در مورد محدوده ى وسيعى از فعاليتهاى انسانى از استفاده شخصى گرفته تا تجارت و حکومت به کار گرفت.
- اين فناوريها، تواناساز (enablor) عمده اى در خلق شبکه ها است، و در نتيجه کسانى که به اين شبکه ها دسترسى دارند را قادر مى سازد تا از دستاوردهاى حاصله كه با افزايش استفاده، فزونى مى يابد بهره مند شوند.
- اين فناوريها، انتشار اطلاعات و دانش را با آزاد كردن محتوى از جايگاه فيزيکى آن، تسريع مى‌کند.
- ماهيت مجازى و ديجيتالى بسيارى از توليدات و خدمات اين فناوريها، اين امکان را فراهم آورده که هزينه هاى جانبى به صفر برسد يا کاهش يابد.
- قدرت اين فناوريها در ذخيره کردن، بازيابى، طبقه بندى، تصفيه، توزيع و تسهيم اطلاعات بدون شک مى‌تواند به فوايد كارايى بيشتر در امر توليد، انتشار و داد وستد منجر شود.
- افزايش کارايى و کاهش هزينه ها در نتيجه ى كاربرد اين فناوريها، به ايجاد توليدات و خدمات و مجارى توزيع جديد در چارچوب صنايع سنتى و نيز الگوهاى تجارى نوين و صنايع جديد منتهى شده است.
- با ايجاد و گسترش شبکه ها، اين فناوريها مى‌توانند فراتر از محدوديتهاى زبانى و فرهنگى عمل كرده و از طريق امكان دادن به افراد و گروهها براى زندگى و کار در هر گوشه و هرجا، به اجتماعات محلى امكان مى دهند صرف نظر از مليت شان بخشى از جامعه شبکه اى جهانى را تشكيل دهند و سياستهاى جارى و ساختارهاى محدودكننده ى قانونى و نظام مند فعلى كه در درون ملتها و ميان آنها عمل مى كنند را به چالش بكشند.
در سطح جهان همگان اذعان مى دارند که بخش فناوريهاى اطلاعاتى و ارتباطاتى سريع ترين حوزه رشديابنده ى اقتصاد جهانى است.
http://www.isiswomen.org /onsite/knowhow/ict_gender.html
در عين حال، در تمامى کشورها فرايند ساخت جامعه اطلاعاتى برتوسعه فرايندهاى فنى و زيربنايى متمركز شده است كه از نقطه نظر جنسيتى خنثى يا بى طرف تلقى مى شود.
http://www.unesco.org/press/pr2002/02opal8e.html

حضور يا غيبت زنان: مسئله ى شکاف ديجيتالى جنسيتى
با در نظر گرفتن مباحث جنسيتى، گاه عنوان مى‌شود که فناوريهاى اطلاعات و ارتباطات مى‌توانند آنچنانكه در اعلاميه پکن و برنامه اقدام آن همانند ساير اسناد ملل متحد تشخيص داده شده است به عنوان ابزارى براى بهبود شرايط برابرى جنسيتى و افزايش توانمندى هاى اجتماعى، سياسى، واقتصادى زنان به خدمت گرفته شوند. اما با اينحال، برخى همچنان معتقدند که اين فناوريها مى‌توانند به نابرابريهاى موجود مبتنى بر جنسيت در زمينه ى فرصتها و منابع تداوم بخشيده و اشکال جديدى از نابرابرى ميان زنان و مردان را بوجود بياورند.
http://www.unesco.org/press/pr2002/02opal8e.html
در کنفرانس مقدماتى وزيران کشورهاى اروپايى براى اجلاس جهانى جامعه اطلاعاتى تاکيد گرديد که برابرى جنسيتى بايد همه حوزه هاى فناوريهاى اطلاعات و ارتباطات را شامل شود که عبارتند از:
- کاربران
- توليد کنندگان
- سياست گذاران
با اينحال، هرچند زنان بطور بالقوه 50 درصد مصرف کنندگان توليدات و خدمات و نيز نيروى كار فناوريهاى اطلاعات و ارتباطات را تشكيل مى دهند كه مى توانند ايده هاى مفيدى براى توليد محصولات جديد، خدمات و سبک هاى مديريتى نوين ارائه نمايند، اما در سطح کشورهاى منطقه آسيا و اقيانوسيه همانند ساير نقاط دنيا، زنان و مردان به طور برابر از گستره و رشد کاربرد فناوريهاى اطلاعات و ارتباطات برخوردار نشده اند. زنان به ويژه از نظر دستيابى به فناوريهاى اطلاعاتى و ارتباطاتى با موانع و محدوديتهاى نهادينه شده، نظام مند و ايدوئولوژيک درگير هستند.
http://www.isiswomen.org /onsite/knowhow/ict_gender.html
عدم حضور يا فقدان نظرات و ديدگاههاى زنان در جامعه اطلاعاتى حكايت از اين دارد که فناوريهاى اطلاعاتى و ارتباطاتى "جديد" نيز انعكاس دهنده ى بسيارى از الگوهاى جنسيتى
( در ارتباط با قدرت، ارزشها و دورنگاهداشتن) است که طى دهه ها در سطح رسانه هاى "قديمى" شاهد آن بوده ايم. در واقع، اين الگوها را نمى توان از روابط جنسيتى موجود در جامعه به عنوان يک کل جدا كرد. در عين حال كه براى زنان دستيابى به ميزانى از کنترل در عرصه ى ارتباطات و فناوريهاى اطلاعاتى و ارتباطاتى جهت تضمين اين امر که منافع جامعه ارتباطاتى و اطلاعاتى به صورت برابر بين زنان و مردان توزيع مى‌شوند، جنبه ى حياتى دارد.
http://www.wacc.org.uk
به اعتقاد نانسى هافکين (Nancy Hafkin)، طى پنج سال گذشته، سازمانهاى غيردولتى، چند مليتى و بنيادهاى خصوصى مقادير قابل توجهى بودجه را براى طرحهاى مروج استفاده از فناوريهاى اطلاعات و ارتباطات در کشورهاى در حال توسعه اختصاص داده اند. تجربه پروژه هاى مرتبط با توسعه در حوزه هاى ديگر نشان داده که زنان به نحو منصفانه اى از چنين طرحهايى بهره مند نمى‌شوند، مگر اينکه تلاشهاى خاصى براى تعيين جايگاه و نيازهاى آنان صورت بگيرد يا اقدامات موثرى براى مشارکت دادن آنان، به کار گرفته شود
(Virtual Seminar Series on Gender and ICTs, July 2002).
برخى از طرحريزان توسعه معتقدند که فناورى اطلاعاتى از لحاظ جنسيتى بيطرف است و در نتيجه زنان و مردان بايد به طور عادلانه از کاربرد آن منتفع شوند. با اين حال نتايج يک تحقيق (بر مبناى شش مطالعه موردى از پروژه هاى ترويج فناورى اطلاعات و ارتباطات در آسيا، آفريقا و آمريکاى لاتين) بنا بر گزارش هافكين اين فرضيه را که زنان به نحو برابر از پرژه هاى توسعه منتفع نيستند، را مورد تائيد قرار مى دهد(همان منبع ).
اصطلاح «شکاف ديجيتالى» (digital divide) به فاصله بين افراد داراى مهارتهاى استفاده از کامپيوتر و اشخاص فاقد اين مهارت اشاره مى‌کند. هرچند «شکاف ديجيتالى» مى‌تواند به اين واقعيت اشاره داشته باشد که زنان معمولا از سطح سواد کامپيوترى نازل ترى برخوردارند، علت آن همچنين مى‌توان در عدم آموزش، فقر و دسترسى نامناسب زنان به تکنولوژى جستجو كرد كه در نتيجه مى بينيم زنان به نسبت كمترى در دنيا از كامپيوتر استفاده مى كنند. هرگاه زنان به آموزش وامكان دسترسى دست پيدا كرده اند شاهد آن بوده ايم كه از كامپيوترها براى آموزش خود استفاده كرده اند، با ديگران شبکه هايى راتشکيل داده، فرصتهاى شغلى و اقتصادى براى خود و ساير زنان بوجود آورده اند و ديگران را در معلومات خود شريک كرده اند.
http://www.worldcivilsociety.org/report
خانم سوزان تلتشر(Susan Teltscher) از «کنفرانس ملل متحد در مورد تجارت و توسعه» نيز اظهار داشته که غالباً موانع اساسى بر سر راه دسترسى زنان به امتيازاتى كه فناورى اطلاعاتى و ارتباطى فراهم مى كند وجود دارد موانعى نظير فقر، سطح پايين آموزش، عدم آشنايى با يك زبان دوم، عدم دسترسى به کامپيوتر و شکاف ديجيتالى: يعنى ماهيت دنياى فناورى اطلاعات و ارتباطات كه تحت سلطه ى مردان قرار دارد.
http://www.worldcivilsociety.org/report
از نظر مشاركت در دانش فناوريهاى اطلاعات و ارتباطات نيز زنان در شرايط محروميت قرار دارند، چرا که تعداد ايشان از لحاظ ثبت نام در دوره هاى آموزشى علوم و تکنولوژى نسبت به مردان در مراتب بسيار پايينترى قرار دارد. در سال 1990، درصد زنان ورودى به رشته هاى علوم و تکنولوژى در سطح دانشگاهى عبارت بود از 10درصد در آفريقا، 40درصد در آمريکاى لاتين، 32 درصد در اروپاى غربى،کمتر از 30 درصد در اروپاى شرقى و 34درصد در منطقه آسيا و اقيانوسيه (Hamelink ,1999).
خانم جيليان مارسل(Gillian Marcelle) از پيشقراولان فعال در زمينه توسعه و اجراى استراژيهاى عدالت جنسيتى در بخش فناوريهاى اطلاعات و ارتباطات ادعا مى‌کند که سياست گزارى در زمينه فناوريهاى اطلاعات و ارتباطات در صورتى كه مبتنى بر فرايند تصميم گيرى آگاهانه و مطلع از مسائل جنسيتى باشد به شكل فوق العاده اى سود مند خواهد بود . با اين حال، ميزان برابرى جنسيتى در سطوح تصميم گيرى در ميان دست اندرکاران فناوريهاى اطلاعات و ارتباطات هنوز در سطح غير قابل قبولى است.
http://www.worldbank.org/gender/digitaldivide
به نظر هاملينک (Hamelink, 1999:33) درتوزيع منابع فناوريهاى اطلاعات و ارتباطات بويژه کاربرد آن در ارتباط با زنان نابرابرى مشاهده مى‌شود. مشكل اينجاست که كسب مهارتهاى فناوريهاى اطلاعات و ارتباطات تقريبا تماماً به سواد ارتباط دارد، ... و چنين شرايطى بويژه زنان را تحت تاثير قرار مى دهد، چرا که در سراسر دنيا نرخ بيسوادى زنان نسبت به مردان بالاتر است. هرچند وى خاطرنشان مى‌سازد، که اين فناوريها مى توانند ابزارى توليد كنند مبتنى بر صدا، تماس، تصوير يا نمادهايى که مستلزم سواد نيستند، اما اين بازارهايند كه نيروى محركه براى اينگونه نوآوريهاى تكنولوژيك هستند و نيازهاى بى سوادان معمولاً از سوى آنان مورد غفلت يا بى توجهى قرار دارد (همان منبع).
رزا دلگادو(Rosa Delgado) از انجمن «جامعه اينترنتى» نتيجه مى‌گيرد که اکثريت زنان کشورهاى در حال توسعه در نتيجه ى فقدان سواد کامپيوترى computer literacy و غالباً كمبود آموزش از فرصتهاى حائز اهميت شغلى و تحصيلات تکميلى باز مى مانند.
http://www.worldcivilsociety.org/report
مايکل پاستور(Micheal Pastor) در مقاله اش تحت عنوان «شکاف ديجيتالى در سطح جهانى هنوز وجود دارد» به گزارش اشتغال جهانى (منتشره توسط سازمان جهانى کار) ارجاع مى‌کند و نتيجه مى گيرد که فناوريهاى اطلاعات و ارتباطات «پناسيل تواناساز»ى را براى بهبود شرايط زندگى زنان فراهم مى‌سازد، اما گزارش مذكور حقيقت ديگرى را نيز آشكار مى‌کند مبنى بر اينکه خلا جنسيتى ديجيتالى نيز در سطح کشورها وجود دارد به اين ترتيب كه زنان همچنان خود را شاغلين به شغلهاى سطوح پايين ترى در عرصه ى فناورى اطلاعات و ارتباطات مى‌يابند. در حاليکه مردان به دستمزدهاى بالاتر و مشاغل پرمسئوليت ترى صعود کرده اند.
http://www.cyberatlas.internet.com/big_picture/geogeraphics/
article
اگرچه فناوريهاى ازاطلاعات و ارتباطات اين قابليت را دارد که مشاغلى را براى زنان و بهبود زندگى آنان فراهم کند، گزارش مذکور يادآور مى‌شود که بطور کلى زنان به کسب درآمدهاى پايينتر، بيکارى بيشترو تمركزدر مشاغل کم مهارت تر ادامه مى‌دهند (همان).
عمده ترين شکل شکاف ديجيتالى جنسيتى مربوط به استفاده از اينترنت است، به طوريکه کمترين ميزان کاربران را در کشورهاى در حال توسعه، را زنان تشکيل مى‌دهند. به عنوان مثال، فقط 38 درصد از کاربران اينترنت در آمريکاى لاتين زنان هستند، در حاليکه در اتحاديه اروپا اين رقم 25 درصد، در روسيه 19 درصد، در ژاپن 18 درصد و در خاورميانه فقط 4 درصد است. بنا به اين گزارش، در سطح جهان، بيشترين تعداد كاربران اينترنتى را مردان، دانش آموختگان دانشگاهى و يا آنان كه از ميانگين درآمد بالاترى برخوردارند تشکيل مى‌دهند. تنها آنجا كه دسترسى به اينترنت توسعه ى خوبى يافته است، نظير کشورهاى اسکانديناوى و آمريکا است که از فاصله جنسيتى در استفاده از اينترنت كاملاً كاسته شده است (همان منبع).
طى کنفرانس تداركاتى وزيران مجمع-اروپايى براى اجلاس جهانى جامعه اطلاعاتى (بخارست 2002) بر فهرستى از موانع خاص جنسيتى در دسترسى به فناوريهاى ارتباطى و اطلاعاتى به شرح زير تاکيد شد:
- هزينه هاى بالاى دسترسى و گزينه هاى تکنولوژى
- دسترسى محدود در جهت آموزش مهارتهاى جديد (فقدان اطلاعات و تشويق لازم درمورد درخواست براى فراگيرى فناوريهاى ارتباطات و اطلاعات)
- ناكافى بودن شبکه ها و وجود اين تصور كه اين فناوريها "مردانه" است
برخى نيز بر اين باورند که تفاوتهاى موجود ميان زنان در ردسترسى به اينترنت از جمله تحت تاثيرعوامل زير قرار دارد:
- عامل جغرافيايى (تفاوتهاى مناطق شهرى و روستايى)
- وضعيت خانوادگى (مادران مجرد دسترسى كمتر دارند)
- سن کاربران (مشکل دسترسى براى زنان بالاى 45 سال)
البته در اين مورد نيز توافق وجود دارد که اطلاعات محدود در مورد وضعيت زنان بعنوان کاربران ، توليدکنندگان و تصميم گيران اين فناوريها، ارزيابى دقيقترى در خصوص شکاف ديجيتالى جنسيتى را امكان پذير نمى سازد.
در مورد شکاف بين زنان در مناطق روستايى و شهرى، گالاگر و ماير(Gallagher and Mayer, 2001 ) خاطر نشان مى گردند که بدون دستيابى به فناوريهاى ارتباطات و اطلاعات ، زنان در مناطق روستايى نمى‌توانند در منافعى که در حوزه آموزش، درآمدزايى، بهداشت و ساير موارد که از فناوريهاى اطلاعات و ارتباطات مى‌تواند بدست آيد سهيم باشند همچنانکه مى دانيم زنان شهرى هم در ابتداى مسير استفاده از اين قابليتها قرار دارند.
http://www.worldbank.org/gender/digitaldivide
على رغم كمبود اطلاعات در مورد شکاف ديجيتالى جنسيتى، شواهد محكمى موجود دارد حاکى از آنكه زنان :
- از منابع مالى کمترى براى خريد تجهيزات جديد برخوردارند
- زمان محدودترى براى کسب مهارت ها و معلومات جديد دارند
- در چارچوب و قوانين بازى جامعه اطلاعاتى(که در آن فناوريهاى اطلاعات و ارتباطات، بسرعت حوزه هاى کار و تجارت، آموزش و اداره حکومت را متحول مى كنند) اثرگذارى كمترى مى توانند داشته باشند
- زنان همينطور فاقد اعتماد بنفس و دلگرمى براى پيگيرى فعالانه ى فرصتهاى مربوط به فناوريهاى اطلاعات و ارتباطات هستند
http://www.unesco.org/press/pr2002/02opal8e.html

نويدهاى فناوريهاى اطلاعات و ارتباطات براى زنان و موانع موجود
توانايى فناوريهاى اطلاعات و ارتباطات در توانمندسازى زنان از طريق آموزش بهتر و ارتباطات گسترده و در جهت توليد درآمد شخصى براى ايشان نبايد دست کم گرفته شود. بوخارت و اولدر(2003) با اشاره به وضعيت زنان در منطقه خاورميانه و شمال آفريقا يادآور مى‌شوند که آداب و رسوم سنتى در همه اين کشورها مورد چالش قرار گرفته است و بويژه بر نقش و سهم اينترنت در اين ارتباط تاكيد مى كنند. هاملنيک (1999) نيز معتقد است فناوريهاى اطلاعات و ارتباطات اشکال جديدى از ارتباطات را بوجود مى‌آورد که مى‌تواند زنان را قادر به فروپاشيدن موقعيت اجتماعى بسته اى که غالبا در آن محصورند سازد. همچنين فرصتهاى نوينى را براى اشتغال زنان در مشاغلى فراهم مى‌آورد که مستلزم مهارتهاى جديد است. هرچند متذکر مى‌شود که سياستهاى محکمى لازم است تا اين فناوريها بتوانند تاثير مثبتى بر زندگى زنان بگذارد. در جوامع دانايى محور (Knowledge socities) که در حال ظهور است دستيابى به ارتباطات يک ابزار کليدى براى مشارکت و ادغام اجتماعى social inclusion به حساب مى‌آيد. بوخارت و اولدر (2003) همچنين يادآور مى‌شوند که با در نظر گرفتن آنچه آنان انقلاب اطلاعاتى مى‌نامند بازارهاى شغلى به هيچ وجه با شتاب افزايش تعداد افراد جوانى که به آن وارد مى‌شوند هماهنگ نبوده است. با ورود زنانى که در حال حاضر قصد کارکردن دارند اين شرايط حادتر نيز شده است و طبقه جديدى از کاركنان اطلاعاتى که احتمالا عمدتا متشكل از زنان خواهد بود در حال ظهور است.
ميزان بهره مند شدن از فرصتهاى ناشى از فناوريهاى اطلاعات و ارتباطات براى زنان هم در درون كشورها و هم در مقايسه ميان کشورها بسيار متفاوت است. زنان ساکن در کشورهايى که بهترين عملکرد در پروژه هاى توسعه ى اينگونه فناوريها را داشته اند، مانند استونى يا برخى کشورهاى اروپاى مرکزى، يا زنان ساکن در مناطق شهرى در يک موقعيت ممتاز يا برترى قرار دارند.
http://www.unesco.org/press/pr2002/02opal8e.html
در "گزارش نهايى برنامه فرصت ديجيتالى" (UNDP, 2001:15) ) با ارجاع به قابليتهاى فناورى هاى اطلاعات و ارتباطات در برقرار کردن ارتباط ميان افراد و اجتماعات محلى با اطلاعات و منابعى فراتر از مرزهاى جغرافيايى شان ، بويژه بر اهميت و سودمندى اين نکته در ارتباط با اجتماعات به حاشيه رانده شده و گروههايى مانند زنان، جوانان و اقليتهاى قومى تاكيد شده است. افراد اين گروهها مى‌توانند به اطلاعات مورد نظر خود دسترسى پيدا کنند و به تبادل اطلاعات موردعلاقه خود بپردازند، قدرت جمعى خود را تقويت کنند و راه حلهاى مناسب براى بهبود و توسعه ى شرايط خود را بيابند. به عنوان نمونه از گروه زنان فعال در مکزيکوسيتى ياد شده است كه توانستند با برقرارى ارتباط با گروه زنان همفکر خود در کاليفرنيا از طريق پست الکترونيکى e-mail اطلاعات مفيدى را در مورد كارخانه نساجى اى كه در آن مشغول به كار بودند كسب كنند و در جريان چانه زنى در باب شرايط كارى خود با مديريت كارخانه از آن در جهت حمايت از حقوق خود سود ببرند! (همان منبع).
كابرراـ بالزا (Cabrera-Balleza) بر اساس نتايج يك طرح پژوهشى درباره استفاده از فناوريهاى ارتباطات و اطلاعات توسط سازمانهاى زنان در آسيا و اقيانوسيه به اين نتيجه رسيد كه گروههاى زنان با بهره گيرى از امكانات اين گونه فناوريها توانسته‌اند در زمينه‌هاى زير به موفقيتهايى دست يابند:
- انجام تحقيق و دستيابى به اخبار و اطلاعات
- بهبود مهارتها و معلومات شخصى و سازمانى
- پيگيرى و مشاركت در برنامه هاى زنان در مقياس جهانى
- انتشار اطلاعات و محصولات و مطالب تبليغاتى
- كسب شناخت در زمينه ى عوامل موثر بر توسعه در سطوح محلى و منطقه اى
- تبادل اطلاعات و تجربيات
- تنظيم و هماهنگى فعاليتها هم در كشور و هم در خارج از كشور
- مشاركت در جامعه مدنى و اجتماعات محلى
- شناسايى مرتبطين جديد و گسترش شركاى توسعه
- ارائه درخواست براى حمايت هاى مالى و فنى
http://www. isiswomen.org /onsite/knowhow/ict_gender.html
پژوهشى كه كابرراـ بالزا از آن نام برده همچنين نشان مى دهد كه اوج استفاده از اين فناوريها در بكارگيرى «پست الكترونيكى» است كه براى مقاصد اجرايى و ادارى و براى مكاتبه با كمك دهنده‌ها و شركاى بين المللى و منطقه‌اى مورد استفاده قرار گرفته است. اينترنت نيز از سوى ديگر براى شبكه سازى و دسترسى به اطلاعات و جلب حمايت مردمى موثر واقع شده است.
فناوريهاى اطلاعات و ارتباطات ميتواند همچنين براى زنانى كه مسئوليت مراقبت از كودكان را دارند يا آنان كه دور از مراكز شهرى سكونت دارند مزاياى زيادى بهمراه داشته باشد و براى مثال براى آنان فرصت كار از منزل يا به عبارت ديگر "دوركارى" (teleworking) را فراهم آورد.
http://www.worldcivilsociety.org/report
سوزان تلشتر از «كنفرانس ملل متحد در خصوص تجارت و توسعه» همچنين تاكيد مى كند كه فناوريهاى جديد ميتواند براى زنانى هم كه درگير امور و فعاليتهاى تجارى و اقتصادى business women هستند، امتيازاتى چون افزايش بهره ورى، ارتقاء ظرفيت كارى، راههاى ارتباطى بيشتر و صرفه جويى در زمان و هزينه ها را به ارمغان آورد.
همچنين بمنظورافزايش توانايى موثر زنان در بهره گيرى از فناوريهاى اطلاعاتى ارتباطى، توصيه‌هاى متعددى بعمل آمده است كه در اينجا به برخى از آنها اشاره مى شود:
- اطمينان حاصل شود از اينكه جنسيت در سياستها و برنامه‌هاى فناوريهاى اطلاعات و ارتباطات لحاظ يا جارى شده باشد و زنان در نهادهاى تصميم گيرنده و سياستگذار حضورداشته باشند.
- با گسترش سياستهاى دولتى كل نگرانه در زمينه اين فناوريها، آنها را براى زنان قابل دسترس تر مفيد و مربوط سازند به نحوى كه نيازهاى زنان و موضوعات جنسيتى مدنظر قرار گيرد.
- ثبت نام دختران در برنامه هاى آموزش اين فناورى ها از طريق تدارك امكانات عملى و تشويقى مانند بورسهاى تحصيلى و فعاليتهاى ارتقاى آگاهى رسانى در اين باب تشويق شود.
- فراهم كردن حمايت هاى مالى اضافى براى ترويج استفاده از اين فناوريها در ميان گروههاى زنان
- هدايت آموزش هاى مستمر در زمينه استفاده از اين فناوريها و قابليتهاى آن (مانند مبادله ساده اطلاعات، تحقيق، پردازش و ذخيره اطلاعات)
- برگزارى كارگاههاى اطلاع رسانى در مورد منافع اين فناوريها به ويژه به عنوان يك ابزار ارتباطى موثر.
- انتشار وسيع (هم بصورت چاپى و هم به صورت فايلهاى الكترونيکى) نتايج پژوهشهاى صورت گرفته درموضوع زنان و فناوريهاى اطلاعات و ارتباطات به ويژه تحقيقاتى كه الگوهايى از كاربرد موفقيت آميز اين فناوريها را توسط سازمان‌هاى زنان ارايه ميدهند
http://www. isiswomen.org /onsite/knowhow/ict_gender. html
فهرستى از توصيه‌ها نيز از سوى كنفرانس مقدماتى وزيران پان اروپايى در اجلاس جهانى جامعه اطلاعاتى عنوان گرديده كه مخاطبين آن همه شركت‌ها، دولتها، بخش خصوصى، جامعه مدنى و جامعه بين المللى را شامل مى گردد. اين توصيه‌ها عبارتند از:
- اعمال ديدگاه معطوف به جنسيت در تدوين استراتژيهاى ملى استفاده و گسترش فناوريهاى اطلاعات و ارتباطات و درگير كردن كامل زنان درتوسعه نظامهاى حكومت الكترونيكي.
- سامان دادن و توسعه ظرفيت زنان براى استفاده از اين فناوريها در جهت اهداف كارآفرينى و گسترش امورتجارى و اقتصادي.
- راه‌اندازى فعاليتهايى به ابتكار حكومت ها بمنظور تشويق جريان سازى جنسيتى در مورد موسسات ارتباطات از راه دور.
- راه اندازى فرايند تدوين گزارشهاى ملى جهت ارزيابى وضعيت زنان و مردان بعنوان كاربران، توليدكنندگان و سياستگذاران در قلمرو فناورى‌هاى اطلاعات و ارتباطات.
تاكنون برخى اقدامات حمايتى نيز در سطح بين المللى براى ترويج و تشويق استفاده از فناوريهاى ارتباطات و اطلاعات در ميان زنان صورت گرفته است و از آن جمله سازمان ملل متحد، دو اجلاس در سال 2002 براى تسهيل دسترسى زنان به اين فناوريهاى جديد برگزار نمود. يكى از اين نشستها تحت عنوان «فناوريهاى جديد اطلاعات و ارتباطات و تاثير و كاربرد آنها بعنوان ابزارى براى پيشرفت و توانمند سازى زنان» در جمهورى كره در نوامبر 2002 برگزار شد و ديگرى تحت عنوان «مشاركت و دسترسى زنان به رسانه ها و تاثير آن بعنوان ابزارى براى پيشرفت و توانمندسازى زنان» با همكارى كميسيون اقتصادى و اجتماعى ملل متحد براى آسياى غربى نيز در نوامبر 2002 در بيروت، لبنان برگزار شد. نكته مهم اين است كه در تدارك براى برگزارى اين دوجلسه، زنان براى شركت در جلسات گفتگوى هفتگى از طريق اينترنت دعوت شدند تا درباره موضوعات كنفرانس‌ها و توانمندسازى زنان و فناوريهاى اطلاعات و ارتباطات نظرات خود را مطرح سازند.
بايد توجه داشت که در كنار منابع و فرصتهايى كه اين فناوريها براى زنان فراهم ميسازند، موانعى نيز براى استفاده زنان و دستيابى به اين فناوريها وجود دارند. مواردى از اين موانع و محدوديت‌ها در پژوهشى كه در منطقه آسيا و باسيفيك صورت گرفته است به شرح زير فهرست شده است:
- عدم ثبات سياسى، اقتصادى و اجتماعي. اين مسئله بويژه در قفقاز، ارمنستان، آذربايجان و گرجستان و منطقه آسياى مركزى نقل گرديده بود كه خود را در نرخ بالاى تورم، مناقشات مسلحانه داخلى يا ساير اشكال آشوبهاى داخلى، نسبت بالاى بلاياى طبيعى و ميزان بالاى اقتدار مركزى نشان مى‌‌دهد.
- فقدان سياستهاى ملى تشويق كننده فناوريهاى اطلاعات و ارتباطات به عنوان ابزار توسعه كه ميتواند از ضعف زيرساختهاى اين فناوريها مانند خطوط تلفن ناكارآمد يا نبود برق در برخى مناطق روستايى و مناطق دور در اقيانوسيه و قسمتهايى از آسيا كه هنوز دسترسى به برق ندارند، ناشى شده باشد.
- هزينه هاى سخت افزار و نرم افزار كامپيوتر و هزينه نگهدارى و اتصال بخصوص هزينه نرم افزارهاى داراى مجوز. هزينه متوسط ماهانه يک اشتراک اينترنتى در كشورهاى حوزه اقيانوسيه که مورد مطالعه قرار گرقته اند 50 دلار آمريكا برآورد شده است. هزينه آن ظرف يكسال بالغ بر يك چهارم يا نيمى از سرانه توليد ناخالص ملى در بسيارى از كشورهاى منطقه اقيانوسيه مى‌گردد كه البته شكى نيست اکثريت مردم اين کشورها توان پرداخت آن را ندارند. از سوى ديگر، گروههاى زنان در شرق و جنوب شرقى آسيا كه به فناوريهاى اطلاعات و ارتباطات، به ويژه به اينترنت و پست الكترونيکى دسترسى داشته‌اند، تصديق كرده‌اند كه هزينه‌هاى ارتباطى آنان به خاطر بكارگيرى فناوريهاى جديد، بسيار كاهش يافته است.
- عدم برخوردارى از مهارتهاى كامپيوترى يا كمبود مهارت در اين زمينه. برخى از زنان در ناحيه اقيانوسيه در زمينه ى حوزه‌هاى مختلقى نظير نصب يا نگهدارى سخت افزار يا نرم افزار، مهارتهاى مبتنى بر اينترنت مانند telnet، f.t.p يا شبکه هاى ارتباط از طريق پست الکترونيکى (mailing lists) واقعا با مشكل روبرو بوده‌اند. نمايندگان يك سازمان غيردولتى زنان از فيجى تحت عنوان «اقدام زنان براى تغيير» عنوان كردند كه آنان حتى استفاده از فكس يا تلفن را ترجيح ميدهند. گروههاى ديگرى در منطقه اقيانوسيه نيز اظهار نمودند كه تماسهاى حضورى و جلسات گروهى هنوز روشهاى موثرترى براى ارتباطات با ديگرسازمانهاى زنان در مقايسه با ارتباطات الكترونيکى شبكه‌اى است.
- آگاهى محدود زنان در زمينه انواع ديگر امکانات و فرصتهاى فراهم شده به وسيله فناوريهاى اطلاعات و ارتباطات ( به غير از دسترسى به اطلاعات).
- محدوديت دسترسى به اطلاعات آنلاين به زبانهايى غير از انگليسي. انگليسى در بسيارى از كشورهاى آسيا و اقيانوسيه نه زبان اول است و نه زبان دوم و در صورتيکه هر استراتژى اطلاعاتى بخواهد موثر واقع شود يكى از مسايل اوليه كه ميبايستى در نظر گرفته شود زبان است. زبان روسى ممکن بود بتواند در قفقاز و منطقه آسياى مركزى تاثير بيشترى داشته باشد. زبان چينى در چين، هنگ كنگ و تايوان و زبان بهاسا در مالزى و اندونزي.
http://www.isiswomen.org/onsite/knowhow/ict_gender.html
در اين گزارش همچنين كيفيت اطلاعات ارسال شده بر روى وب يا گردش اطلاعات به واسطه ساير اشكال فناوريهاى اطلاعات و ارتباطات به عنوان يكى ديگر از موضوعات كليدى در ارتباط با زنان مطرح شده است. نسبت قابل توجهى از اطلاعات بر روى اينترنت از نوع پرونوگرافى است. تعدادى از زنان آسيا و پاسيفيك به وسيله اينترنت به سمت فحشا سوق داده شده‌اند (همان منبع). از سوى ديگر، گفته مى‌شود از اين فناوريها به نحو موثرى در تلاشهاى جهانى جهت پايان بخشيدن به قاچاق زنان و دختران (حدود 700 هزار زن و كودك هرساله قاچاق ميشوند) استفاده شده است. به عنوان مثال، از ابتداى سال 1995 از اينترنت براى ايجاد همکارى بين المللى، مذاکره و تبادل تجربيات براى خانمه دادن به قاچاق زنان استفاده شده است. در مواردى هم از اين فناوريها براى گردآورى اطلاعات در خصوص قاچاق، اطلاع رسانى عمومى در اين زمينه و حتى رهايى زنان قاچاق شده و بازگردانيدن آنها از طريق فراهم نمودن آموزشهاى شغلى، استفاده گرديده است( همان).
توصيه‌هايى نيز براى غلبه بر موانع و محدوديتهاى دستيابى زنان آسيا و اقيانوسيه به فناوريهاى اطلاعاتى و ارتباطات بعمل آمده است. برخى از اين توصيه‌ها به شرح زير فهرست گرديده است:
- بازسازى مجدد اطلاعات در دسترس بر روى اينترنت و تركيب امکانات اينترنت با امکانات رسانه‌هاى "سنتى" يا جا افتاده تر نظير راديو و چاپ.
- آموزش و ظرفيت سازى در مورد سازمانهاى غيردولتى زنان و گروههاى مردمى در زمينه مهارتهاى متعدد فناوريهاى اطلاعات و ارتباطات - برخى از اين نمونه‌ها آموزشى فعاليتى بوده است كه توسط يك سازمان غيردولتى تحت عنوان «آموزش شبكه سازى الكترونيکى زنان» صورت گرفت و نمونه ديگر آموزش انجمنهاى مردمى زنان درباره فناوريهاى اطلاعات و ارتباطات كه توسط يك سازمان غيردولتى زنان در مانيل صورت گرفته است.
- تسهيل ايجاد و گسترش متون و محتوا بر روى وب، توليد و استفاده از منابع مربوط به اين فناوريها به زبانهاى متفاوت. دو نمونه از اجراى اين راه کار شامل تهيه بانك اطلاعات چند زبانه (توسط سازمان غير دولتى aworc) و توليدات رسانه‌اى ويژه زنان است كه به همت گروههاى رسانه‌اى زنان صورت گرفته است(توسط سازمان غيردولتى Isis international)
شبكه سازى و همكارى با ساير سازمانهاى رسانه‌اى و گروههاى جلب حمايت براى افزايش قابليت دسترسى اين فناوريها به واسطه همگرايى فناوريهايى نظير راديو و اينترنت.
http://www.isiswomen.org/onsite/knowhow/ict_gender.html
بوخارت و اولدر(2003) به ظهور نوعى انقلاب اطلاعاتى در خاور ميانه اشاره داشته و متذکر شده اند كه اين منطقه زمانى يكى از پيشرفته‌ترين بخشهاى دنيا بود؛ مردم اين منطقه در رياضيات، نجوم، علوم و پزشكى مهارت داشتند و به خاطر شعر و هنرهاى ديگر شهرت داشتند. اين پيشرفت با گسترش امپراتورى اسلامى همزمان شد و در واقع آنچه امروز تحت عنوان خاور ميانه و شمال آفريقا باقى مانده است، بقاياى همان امپراتورى بزرگ اسلامى است. اين دو پژوهشگر بر اين باورند كه اين منطقه بار ديگر با اقتصاد جهانى در حال پيوند خوردن است و با گسترش اخير فناوريهاى اطلاعات و ارتباطات که به توسعه اقتصادى اين منطقه كمك ميكند بار ديگر آن را در ارتباطى نزديک با اقتصاد جهانى قرار مى‌دهد. ايندو محقق در گزارش خود جدولى از شاخصهاى فناوريهاى اطلاعات و ارتباطات را در تائيد اين نظر خويش ارائه مى‌کنند . طبق نظر ايشان، ارتباطات از راه دور در سراسر منطقه خاورميانه و شمال آفريقا در طى 10 سال گذشته بسيار بهبود يافته است هرچند هنوز بسيارى كشورها به لحاظ تعداد خطوط تلفن، ارتباطات بين المللى و بويژه خدمات و ارتباطات اينترنتى زير ميانگينهاى جهانى قرار دارند.

بوخارت و اولدر اعتقاد دارند كه موفقيت اقتصاد مبتنى بر فناوريهاى ارتباطات و اطلاعات شديداً در گروى مشاركت تمامى مردم است و لذا هم مردان و هم زنان بايد در اين امر مشاركت داشته باشند. گسترش فرصتهاى کاربرد ICTs نه تنها براى زنان بلکه همچنين براى كشورهاى عربى در کل سودمند به حساب آمده است. به اعتقاد ايشان وارد شدن اين فناوريهاى جديد به دنياى اعراب ابزار كاملى را براى زنان بمنظور تقويت وضعيت اجتماعى‌شان در جامعه فراهم ميكند و باعث خودآگاهى آنان و همچنين مشاركت بيشتر در نيروى كار ميگردد(همان منبع).
اين دو پژوهشگر همچنين يادآور شده اند هرچند نفوذ اينترنت روند آهسته‌اى در خاور ميانه داشته، ولى هم اينک وب سايتهاى بسيارى به زبان عربى و انگليسيدر دسترس زنان عرب قرار دارد و برخى حتى مخصوص زنان طراحى شده‌اند نظير سايت «ارتباط زنان عرب» www.arabwomenconnect.org كه تحت نظارت بنياد توسعه زنان سازمان ملل متحد است.
در سپتامبر 1996 برنامه زنان APC اقدام به انجام يك نظرخواهى از بيش از 700گروه زنان و زنان منفرد از طريق پست الكترونيکى براى تعيين نيازهاى شبكه سازى الكترونيکى و تعيين فرصتهاى تازه نمود. طبق گزارش فارول و همكاران(Farewel et al., 1999)
نتايج کلى اين پژوهش آشكار ساخت كه عليرغم موانع بسيار زنان گامهاى بلندى براى دستيابى به ارتباطات الكترونيکى برداشته‌اند و از حمايت و تسهيلات ايجاد شده بوسيله برنامه هاى آموزشى نظير برنامه حمايت و فعال سازى از سوى شبكه‌هاى APC استفاده برده‌اند.
به نظر مى‌آيد كه افزايش ارتباطات و سهيم شدن در دانش توسط زنان نه تنها در جنوب و شرق اروپا، بلكه در جوامع دوردست در شرق و غرب باعث شده است كه دورنماى مشاركت اينترنتى زنان بهبود يافته و در جهت دنياى عادلانه‌ترى براى زنان پيش مى‌رويم.

فهرست منابع

-Bukhart Grey. E.and Older Susan (2003) The information Revolution in the Middle East and North Africa. Santa Monica:RAND

- Farewell. E. Wood. P.James M.Banks K.(1999) Global Networking for Change. Experiences from thee APC Womens Programme. Pp102-113 in women@internet. Creating New Cultures in Cyberspace. Edited by Wendy Harcourt. Society for international development.

- Gittler A.N.(1999) Mapping womens Global Commiunication and Networking PP.91-101 in Women @internet creating new cultures in Cyberspace. Edited by Wendy Harcourt. Society for international development.

- Hamelink S. J. (1999) Human development pp23-45 in M.Tawfik(chief editir) Word communication and information report 1999-2000 unesco .

-UNESCO (1996) Word Science Report 1996.Paris UNESCO

- - UNDP (2001) Creating a. development dynamic final report of the digital opportunity initiative UNDP july 2001

- Virtual Seminar Series on Gender and ICTs, July 2002.

-Women watch (2002) United nations department of economic and social Affairs
www.arabwomenconnect.org -http://
http://www.un.org/women watch /daw/egm/ict2002/online-

- http://www.itu.int.osg.spu.wsis-thenes/vision /vision.html

http://www. isiswomen.org /onsite/knowhow/ict_gender. htm-

- http://www.unesco.org/press/pr2002/02opal8e.htm
-http://www.wacc.org.uk
http://www.worldbank.org/gender/digitaldivide-

http://www.worldcivilsociety.org/report-

-http://www.cyberatlas.internet.com/big_picture /geogeraphics/article

-http://www.arabwomen.connect.org

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 8 خردادماه 1384

01:27 PM

May 29, 2005

وضعيت بازار شبكه‌هاي محلي بي‌سيم

موسسه ‪ Webtorials‬در گزارشي كه براساس تحقيقات جهاني شكل گرفته است، وضعيت بازار شبكه‌هاي محلي بي‌سيم "‪ "WLAN‬را مورد بررسي قرار داد.

در اين تحقيق كه دومين تحقيق سالانه اين موسسه درباره شبكه‌هاي محلي بي‌سيم بشمار مي‌رود، ‪ ۴۱۹‬متخصص از شركتهاي مختلف شركت داشته‌اند.

بيشتر از يك سوم پاسخ‌دهندگان از شركت‌هايي با بيش از دو هزار كارمند بوده‌اند.

نتايج مهم اين تحقيق عبارتند از:
- رشد بسيار زياد در استفاده از شبكه‌هاي محلي بي‌سيم: تقريبا ‪ ۷۰‬درصد از پاسخ‌دهندگان فن آوري ‪ WLAN‬را در حد وسيع بكار گرفته‌اند يا در حال پياده‌سازي آن هستند. اين درصد نسبت به عدد بدست آمده در تحقيق سال قبل كه ‪ ۵۳‬درصد بود، نشانگر رشد بسيار قابل توجهي است.

- بكارگيري معماريهاي مختلف در پياده‌سازي: ‪ WLAN‬بيش از نيمي از پاسخ‌دهندگان استفاده از نقاط دسترسي هوشمند (‪Access Point‬
‪ (Intelligent‬با قابليتهاي مديريتي و امنيتي متمركز را مدنظر قرار داده‌اند.

يك سوم از افراد، استفاده از نقاط دسترسي هوشمند مستقل و "‪Point‬ ‪ "Standalone Access‬يك سوم معماري مبتني بر ‪point/wireless switch‬ ‪thin access‬را ترجيح مي‌دهند. ‪ ۱۶‬درصد نيز قصد استفاده از مسيريابي ‪ mesh‬در زيرساخت خود دارند.

- بهبود بهره‌وري و قابليت دسترسي كارمندان، دليل اصلي پياده‌سازي:
‪ WLAN‬حدود ‪ ۴۸‬درصد پاسخ‌دهندگان اين فاكتور را به عنوان يكي از دو دليل عمده براي پياده‌سازي ‪ WLAN‬خود دانسته‌اند.

در مقايسه با اين فاكتور، ارزاني و سادگي پياده‌سازي ‪ WLAN‬با ‪ ۲۹‬درصد آرا به عنوان دومين دليل پياده‌سازي شبكه‌هاي بي‌سيم انتخاب شده است.

- تناقض در وضعيت امنيتي ‪ :WLAN‬بر طبق آمار، بزرگترين مانع در پياده سازي شبكه‌هاي بي‌سيم نگراني‌هاي امنيتي در مورد فناوري بي‌سيم است.

اين در حاليست كه بيشتر پاسخ‌دهندگان معتقد به حل شدن مشكلات امنيتي شبكه‌هاي بي‌سيم با محصولات و فن‌آوري هاي موجود هستند.

- وابستگي استفاده از فن آوري بي‌سيم به پيشرفت صنعت بي‌سيم: پاسخهاي مربوط به بكارگيري تلفن‌هاي مبتني بر ‪ ۸۰۲۱۱‬بصورت يكساني بين شركتهايي كه در حال حاضر اين وسائل را بكارگرفته‌اند، شركتهايي كه تصميم به استفاده از آنها را بعد از ‪ ۶‬ماه دارند و آنهايي كه طرح خاصي براي بكارگيري فن آوري صدا روي شبكه‌هاي بي‌سيم ندارند، پخش شده است.

رتبه‌بندي مشابهي نيز در مورد كساني كه تصميم به استفاده از گوشي‌هاي دوحالته "سلولي / بي‌سيم" دارند، ديده مي‌شود.

با توجه به اينكه تجهيزات و نرم‌افزارهاي موجود براي آنها از منظر استاندارد و يكپارچه‌سازي كاملا پرداخته نشده‌اند، بنظر طبيعي مي‌رسد كه علاقه براي بكارگيري اين فن‌آوري بر اساس پيشرفت آن بيشتر شود.

- محدود ماندن رواج ‪ : ۸۰۲۱۱‬نتيجه غيرقابل انتظار در مورد
استانداردهاي مورد استفاده اينكه، نه تنها درصد پاييني از پاسخ‌دهندگان ‪ ۸۰۲۱۱‬را پياده كرده‌اند، تعداد بسيار كمي تصميم به پياده‌سازي آن دارند.

درصد بسياري از پاسخ‌دهندگان بطور مشخص تصميم به عدم استفاده از فن‌آوري ‪ ،۵۴Mbps‬به رغم مزاياي آن در تعدادي زياد، شبكه‌هاي غيرهمپوشان دارند.

در ايران هنوز استفاده از شبكه بي‌سيم به درستي به راه نيافتاده است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 11 خردادماه 1384

07:09 PM

June 01, 2005

AbiWord : واژه‌پرداز سبک و کار

ه جرات می‌توان گفت که امروزه کمتر کاربر کامپیوتری است که به ابزارهای اداری مانند انواع واژه‌پردازها و صفحه گسترده‌ها نیاز نداشته باشد. در دنیـای گنو/لینوکس نیـز واژه‌پـردازهـای متـعددی وجـود دارنـد که معمولا هریک عضوی از یک مجموعه اداری بزرگتر به شمار می‌روند. مانند Kword از مجموعه Koffice و OooWriter از مجموعه OpenOffice.org. واژه‌پرداز AbiWord نرم‌افزاری است که جز یک مجموعه اداری نبوده و تنها یک واژه‌پرداز است. قابلیت‌های آن به همراه سبکی و کم حجم بودن، آنرا گزینه‌ای مناسب برای ایجاد فایل‌های متنی در گنو/لینوکس می‌سازد.

تاریخچه
همانطور که در وب سایت [۱] مربوط به AbiWord می‌خوانیم، AbiWord در ابتدا مانند بسـیـاری از پروژه‌های بازمتن دیگر همانند یک «کلیسای جامع» شروع شد و اکنون مانند یک «بازار» اسـت. AbiWord بخشـی از یـک پروژه بزرگتر به نام AbiSource می‌باشد کـه تـوسـط شرکت SourceGear آغاز شده و هدف آن ایجاد یک مجموعه اداری بازمتن و مستقل از سکو بود. این پروژه کار خود را با واژه‌پرداز که همان AbiWord است، آغاز کرد.
SourceGear کد منبع AbiWord را مـنتشر کرد و به سرعت یک اجتماع اطراف آن ایجاد شد و این اجتماع ادامه پروژه را بر عهده گرفتند. سپس SourceGear کار بر روی پروژه را متوقف کرد.
پــس از آن جـامـعه تــشــکیل شـده شـروع بـه تـوسعه و بهبود AbiWord کرد و نسخه ۱ آن در آوریل ۲۰۰۲ منتشر شد و به دنبال آن نسخه ۲ در سپتامبر ۲۰۰۳ ارائه گشت. در حال حاضر نسخه فعال و پایدار نسخه ۲.۲ می‌باشد.

نگارش فارسی در AbiWord کاملا امکان پذیر است.

ویژگی‌های AbiWord
AbiWord یک واژه‌پرداز کاملا مستقل از سـکوست که بر روی سکو‌هـای نـرم‌افزاری مخـتلفی قـابل اجراست. کد منبع آن طوری نوشته شده است که انتقال بین سکو‌های مختلف به سهولت انجام پذیرد. پشتیبانی آن از قابلیت‌های بین‌المللی سازی بـاعـث شـده تـا محیط آن به زبان‌های مختلفی ترجمه گردد. در حال حاضر، AbiWord برای ۳۰ زبان مختلف موجود است و بر روی سیستم‌عامل‌های مبتنی بر Unix و لینوکس، ویندوز، QNX، مک OSX اجرا می‌شود.
امـروزه بسـته‌هـای AbiWord بـرای بسـیـاری از توزیع‌های لینوکس وجود دارند، ولـی در صورت نیاز به دریافت کد منبع یا بسته‌های اجرایی آن بـرای ویندوز و سـیـستم‌عامل‌های دیـگـر، مـی‌تـوانید بـه [۲] مراجعه نمایید. برای نصب آن در دبیان کافی است دستور زیر را تایپ کنید:

# apt-get install abiword

امکانات متنوع و فرمت‌های ذخیره سازی فراوان
ایـن امـکان وجود دارد تا بتوانید مستندات ایجاد شده در AbiWord را به فرمت‌های بسیار متنوعی ذخیره نمایید. برخی از فرمت‌های مورد پشتیبانی عبـارتـنـد از OpenOffice.org، WordPerfect، MS-Word، RTF، HTML و غیره. بـه ایـن صورت خواهید توانست مستندات ایجاد شـده در AbiWord را در سـایر واژه‌پردازهای رایـج باز کنـیـد و یـا آنـهـا را بـرای دوستان یا همکارانتان که به این واژه‌پرداز را در دسترس ندارند، ارسال نمایید.
AbiWord همـانـنـد هـر واژه‌پرداز مـجـهز دیگر، امکانات متنوعی بـرای فـرمـت بنـدی مستندات و بکارگیری تصاویر، جداول، بالت‌ها، لیست‌ها، پا صفحه، سر صـفحه و غـیـره داراست. هـرچـند کـه ممکن است این امکانات به کاملی واژه‌پرداز‌های قدرتمندی همانند OOoWriter نباشند.
یکی از ویژگی‌های جـالـب AbiWord وجـود Plug-in هـای بسـیار متـنوع بـرای آن اسـت کـه بـاعث گسـترش قـابلیت‌های کاربردی آن می‌گردد. این Plug-in ها قابلیت‌هایی مانند ذخیره کردن به خروجی‌های مختلف، خواندن فرمت‌های مختلف، پـردازش تـصـاویـر بـه AbiWord اضافه می‌کنند. اطلاعات بیـشـتر در مورد Plug-inهای AbiWord را در [۳] ببینید. در دبیان می‌توانید با تایپ دستور زیر این Plug-inها را به راحتی نصب کنید:

# apt-get install abiword-plugins abiword-plugins-gnome

یکی از ویژگی‌هایی که آنرا برای کاربران فارسی زبان مناسب مـی‌سازد، پشتیبانی خوب آن از پاراگراف‌های RTL و زبان فارسی است. نسخه مورد آزمایش ما، جدیدترین نسخه منتشر شـده در زمـان نـگـارش این مقاله یعنی نسخه 2.2.7 می‌باشد. برای تغییر پاراگراف‌ها از LTR به RTL می‌توانید از منوی Format گزینه پاراگراف را انتخاب کرده و RTL را فعال کنید. برای اینکه کار با برنامه آسان‌تر شود، می‌توانید از منوی View بخش Toolbars گزینه Extra را فعال کنید که در آن دگمه‌ای برای حرکت بین پاراگراف‌های راست به چپ و چپ به راست وجود دارد.

نتیجه‌گیری
با اینکه مزایای فراوان AbiWord را نمی‌توان نادیده گرفت و علی رغم اینکه در طی چند ساله اخیر پیشرفت قابل توجهی داشته است، هنوز از نظر امکانات همانند واژه‌پردازهای قدرتمندی مانند OooWriter نیست. ممکن است شما بتوانید نامه نــگاری‌هـای دفتـر کـار خـود را بــا AbiWord کـاملا راه بیاندازید، ولی به طور قطع AbiWord برای یک نویسنده که می‌خواهد کتابش را با آن صفحه بندی کند مناسب نیست. عدم وجود امکاناتی مانند تعیین قلم‌های مختلف برای متون RTL و LTR که در هنگام نگارش بطور خودکار تغییر کنند یا عدم وجود امکان جستجو و جایگزینی فرمت‌ها مثال‌هایی در این مورد هستند.
از طرف دیگر، AbiWord بسیار سبک بوده و در کامپیوترهای قدیمی که اجرای مجموعه‌هایی مانند OpenOffice.org در آنها به دشواری امکان پذیر است، به خوبی اجرا می‌شود.

آلن باغومیان alan@technotux.com

ناشر: irantux.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 11 خردادماه 1384

07:10 PM

June 01, 2005

ترجمه فارسی Sun Industry Standards Source License

بهنام بهجت مرندی blixbox@gmail.com

منبع: http://www.openoffice.org/licenses/sissl_license.html

ناشر: irantux.com

این یـک ترجمه غیـر رسمـی از پروانـــه SISSL است و مــمـکن است اشکالاتی در شکل یا محتوای ترجمه وجود داشته باشد. قصد مترجم از ترجمه پروانه، آشنایی فارسی زبانانــی اســت کــه تــوانــایـــی خواندن مـتن اصلی پروانـه بـه زبان انگلیسی را ندارند و استفاده از این ترجمه برای مقاصد دیگر را توصیه نمی‌کند.]

۱.۰ تعاریف

۱.۱ «استفاده تجاری» یعنی توزیع یا هر چه که کد اصلی را برای طرف سومی در دسترس قرار دهد.

۱.۲ «نسخه همکار» یعنی ترکیبی از کد اصلی و تغییراتی که همکار [در توسعه نرم‌افزار] ارائه داده است.

۱.۳ «روش توزیع الکترونیک» یعنـی روشـی کـه عـمـومـاً در جـامـعه توسعه‌دهندگان نرم‌افزار برای انتقال اطلاعات پذیرفته شده است.

۱.۴ «قابل اجرا» یعنی کد اصلی در هر حالتی غیر از متن کد.

۱.۵ «توسعه‌دهنده نخستین» یعنی شخص یا نــهـادی شـنـاخـتـه شـده بـه عنوان توسعه‌دهنده نخستین متن کد که در نمونه الف به آن اشاره شده است.

۱.۶ «کار بزرگتر» یعنی کاری که کد اصلی یا بخشی از آن را با کدی که زیر پوشش این پروانه نیست ترکیب کند.

۱.۷ «پروانه» یعنی همین سند.

۱.۸ «پروانه دار» یعنی داشتن حق اعطای امتیاز، تا بیشترین حد ممکن، چه بـرای اعـطـای نخستین یا کسب امتیازهای بعدی و برای هر یک یا تمام حقوقی که اینجا آمده است.

۱.۹ «تغییرات» یعنی هر اضافه یا حذفی به/از مسند یا ساختار کد اصلی یا هر نوع تغییر قــبل از آن. یک تغییر عبارتست از:

الف. هر حذف یا اضافه‌ای از/به محتوای یک فایل که حاوی کد اصلی یا تغییرات قبلی آن باشد.

ب. هر فایل جدیدی که محتوی هر بخشی از کد اصلی یا تغییرات قبلی باشد.

۱.۱۰ «کد اصلی» یـعـنی کـد مـنـبع نـرم‌افـزار رایـانه که در نمونه الف با نام کد اصلی به عنوان کد منبع به آن اشاره شده است.

۱.۱۱ «ادعای امتیاز» یعنی هر ادعای امتیازی که در حـال حـاضـر وجـود داشـته بـاشـد یـا از این پس پیدا شود فارغ از هر گونه محدودیت، اسلوب، فرآیند، و اسباب امتیاز برای هر مایملک پروانه‌دار که اهدا شود.

۱.۱۲ «کد منبع» یـعـنی فـرم بـرگزیده کد اصلی برای اعمال تغییرات بر آن، بعلاوه تمام ماژولهایی که دربرمی‌گیرد، بعلاوه فایلهایی که رابط مرتبط با آن را تعریف می‌کنند یا اسکریپتهایی که برای کنترل همگردانی و نصب نسخه اجرایی بکار می‌روند.

۱.۱۳ «استانداردها» یعنی استانداردهایی که در نمونه ب مشخص شده‌اند.

۱.۱۴ «شما» (یا «متعلق به شما») یـعـنی یـک شـخص یـا یک نهاد قانونی که این حقوق به او اعمال می‌شود و با تمام شروط این پروانه یا نسخه بعدی این پروانه که زیر قسمت ۶.۱ انـتشار یافته موافقت کند. برای نهادهای قانونی، «شما» شامل هر نهادی که کنترل کند، کنترل شود یا زیر کنترل مشترک شـمـا باشد می‌گردد. برای اهداف این تعریف، «کنترل» یعنی (الف) قدرتی مستقیم یا غیرمستقیم که عامل هدایت یا مدیریت چـنـان نهـادی بـاشـد، خواه بر طبق قرارداد یا طور دیگر، یا (ب) مالکیت بیش از پنجاه درصد (۵۰٪) سهام واریز نشده یا منافع مالکیت چنان نهادی.

۲.۰ پــروانه کد منبع

۲.۱ اجازه واگذاری رسمی توسعه دهنه نخستین

بدین وسیله توسعه دهنـده نخستین تحت قوانین طرف سوم دارایی فکری اجازه واگذاری رسمی پروانه‌ای غیر انحصاری، جهان شمول، و بدون حق‌امتیاز را به شما می‌دهد:

(الف) تحت حقوق دارایی فـکـری (غـیـر از Patent یـا عـلامـت تـجـاری) دارای پـروانـه توسط توسعه دهنده نخستین برای استفاده، باز تولید، تغییر، نمایش، اجرا کردن، زیرمجوز ساختن و توزیع کد اصلی (یا بخشی از آن) با یا بدون تغییرات، و/یا به عنوان بخشی از کاری بزرگتر؛ و

(ب) تحت تخلف از قوانین Patent در سـاخـت، اسـتـفاده، یا فروش کد اصلی برای ساخت، از پیش ساخته شدن، تمرین، فروش، و پیشنهاد فروش و/یا غیر این ترتیب برای کد اصلی (یا بخشی از آن).

(ج) پروانه‌های اعطا شده در بخش ۲.۱ (الف) و (ب) از تاریـخـی کـه تـوسـعه دهنده نخستین اولین نسخه کد اصلی را با این پروانه توزیع کرده است معتبرند.

(د) عـلی رغـم بـخـش ۲.۱ (ب) در بـالا، هـیـچ پـروانه پتنتی اعـطا نشده است: ۱) برای کدی که شما از کد اصلی حذف کرده‌اید؛ ۲) سوای کد اصلی؛ یا ۳) تخلف از: اول)تغییر در کد اصلی یـا دوم) تـرکیبی از کد اصلی با نرم‌افزار یا ابزاری دیگر که فقط محدود به تغییرات نیست.

۳.۰ محظورات توزیع

۳.۱ استفاده از پروانه

نسخه کـد مـنبـع از کـد اصـلی فقط امکان انتشار با شروط این پروانه یا نسخه‌های آینده این پروانه که در بخش ۶.۱ آمده است را دارد. شما باید یک کـپـی از ایـن پـروانـه را با هـر کپی از کد منبع که توزیع می‌کنید همراه نمایید. شما نباید هیچ شرطی را که نسخه کاربست‌پذیر این پروانه یا حقوق دریـافـت کنندگان را که در ذیل آمده محدود کند، پیشنهاد یا تحمیل کنید. پروانه شما برای انتقال از نسخه شرکت کننده مشروط اسـت بـه مـوافقت کـامل شما با این بخش. تغییراتی را که شما ایجاد کرده‌اید باید صد و بیست (۱۲۰) روز قبل از ارائه نسخه همکار مـنـطبق بـا مـلـزومـات اسـتـانـداردهـا بـاشد. در صـورتـی کـه تغییرات با ملزومات هماهنگ نباشد شما موافقت می‌کنید (اول) هر انحرافی از استانداردها که نتیجه انجام تغییرات شما و مـرجـع تـغـییرات صـورت گـرفته توسط شما باشد یا (دوم) تغییرات شما در شکل کد منبع و برای ایجاد هر گونه انحرافی، و مرجع پیاده‌سازیها یا تغییرات مـمـکن بـرای دیـگـران، تـحـت شروط همین پروانه، بدون حق امتیاز در مدت سی (۳۰) روز از اولین انتقال به مشتری، تغییراتتان منتشر گردد.

۳.۲ اخطارهای لازم

شـما بـایـد اخـطار آمده در نـمـونـه الـف را در هر فایل کد منبع تکثیر کنید. اگر امکان آن نباشد که چنین اخطاری در فایلی خاص بدلیل ساختار آن قرار داده شود، شما بـایـد چـنـین اخطاری را در مکانی (مانند دایرکتوری مربوطه) که کاربر احتمالاً بـدنبال چنین اخطاری می‌گردد قرار دهید. اگر شما یک یا چند تغییر ایجاد کرده‌اید می‌توانید نام خود را به عنوان همکار به اخطار تـوصـیف شـده در نـمونه الف اضافه کنید. همچنین شما باید نسخه‌ای از این پروانه را در هر نوع مستندی برای کد منبع که حقوق دریافت کننده یا حقوق مالکیت مربوط به کد اصلی را توضیح می‌دهد قرار دهید. شما ممکن است قیمتی برای ضمانت، پشتیبانی، غـرامت یا مسـئـولیت از یک یا چند دریافت کننده نسخه کد خود درخواست یا پیشنهاد کنید. در هر صورت، شما امکان چنین کاری را تنها از طرف خـودتـان داریـد، نـه از طـرف تـوسـعـه دهـنـده نخستین. شما باید کاملاً روشن سازید که هر نوع ضمانت، پشتیبانی، غرامت یا مسئولیتی تنها از طرف شما عرضه می‌شـود و شما بدین وسیله مـوافـقـت مـی‌کنید کـه بـرای هر مسئولیتی که در نتیجه ضمانت، پشتیبانی، غرامت یا مسئولیتی که ارائـه کـرده‌ایـد بـه توسعه دهنده نخستین خسارتی وارد کند غرامت بپردازید.

۳.۳ توزیع نسخه قابل اجرا

تنها در حالتی ممکن اسـت شـمـا کـد اصـلـی را بـصـورت اجـرایی یا کد منبع توزیع کنید که ملزومات بخشهای ۳.۱ و ۳.۲ رعایت شده باشند، و اگر شما آگهی در دسترس بودن نسخـه کـد مـنـبع کـد اصـلی تـحـت شـرایـط این پروانه را پیوست نمایید. اخطار باید آشکارا در هر نسخه اجرا پذیر، نسخه منبع، مستندات مربوطه یا هم‌بر که شما حـقـوق دریـافت کننده در رابـطه بـا کـد اصـلی را تـوضیح می‌هید پیوست شده باشد. شاید شما نسخه اجرایی یا منبع متعلق به خود یا حقوق مالکیت خودتان را تحت پروانه‌ای کـه انـتـخاب مـی‌کنید تـوزیع کـنید که ممکن است شرایطی متفاوت از این پروانه داشته باشد، ولی باید شرایط این مجوز را قبول داشته باشد. اگر شما نسـخه اجـرایی یا منبع را با پروانه دیگری توزیع کنید باید کاملاً روشن سازید که شرطی متفاوت با شرایط این پروانه تنها توسط شمـا پـیـشنهاد شـده، نـه تـوسـط تـوسعه دهنده نـخستین. بدین وسیله موافقت می‌کنید تا غرامت هر خسارت وارده به توسعه دهنده نخستین در پی شرایطی که شما پیشنهاد کرده‌اید را بپردازید.

۳.۴ آثار بزرگ

مـمـکن اسـت شـما اثری بزرگتر با ترکیب کد اصلی و کدی دیگر که تابع شرایط این پروانه نیست خلق کنید و اثر بزرگتر را به عنوان محصولی یـگـانه توزیع نمایید. در چنین حالتی شما باید مطمئن باشید که ملزومات این پروانه کاملاً بر کد اصلی اعمال شده است.

۴.۰ امکان ناپذیری موافقت بخاطر قانون یا قاعده

اگر برای شما امکانپذیر نیست که با بعضی از شرایط این پروانه در رابطه با قسمتی از کد اصلی یا تمام آن بدلیل مسائل قانونی، قضایی یا بخاطر قاعده‌ای موافقت کنید می‌بایست:(الف) تا بالاترین حد ممکن با شرایط این پروانه موافقت کنید؛ و (ب) محـدودیتـها و کدهایی را که متاثر می‌شوند شرح دهید. چنین توضیحی باید به فایلی که مسائل قانونی را توضیح می‌دهد و در بخش ۳.۲ آمده و به تمام توزیعهای کد منبع اضافه شود.به غیر از مواردی که قانون یا قاعده منع کرده است چنین توضیحی باید جزئیاتی کافی را که دریافت کننده‌ای با مهارتهای معمول بتواند آن را بفهمد شامل شود.

۵.۰ استفاده از این پروانه

این پروانه برای کدی که توسعه دهنده نخـستین در نمونه الف اشاره کرده است و در تغییراتی که در بخش ۳.۱ مشخص شده بکار می‌رود.

۶.۰ نسخه‌های این پروانه

۶.۱ نسخه‌های جدید.

ممکن است Sun هر چـنـد وقت یکبار نسخه‌های تجدیدنظر شده و/یا جدید از این پروانه را منتشر کند. هر نسخه شماره نسخه مشخصی خواهد گرفت.

۶.۲ اثر نسخه‌های جدید

وقتی کد اصلی تحت نسخـه‌ای خاص از پروانه منتشر شـود شـمـا همـیشه امـکـان استفاده از آن با شرایط آن نسخه را دارید. شما همچنین می‌توانید استفاده از کد اصلی با شرایط هر نسخه بعدی از پروانه که توسط Sun منتشر می‌شود را انتخاب کنید. هیچ کس غیر از Sun حق تغییر شرایط کاربست‌پذیر بر کد اصلی را ندارد.

۷.۰ رفع مسئولیت از تعهد

کـد اصـلـی بـر مبنای «آنچه هست» تحت این مجوز تهیه شده، بدون هر نوع تعهدی چه تصریح شده و چه اشاره شده، بعلاوه، بدون محـدودیـت، مـتـعهد مـی‌شـود که کد اصلی عاری از نقصان، داد و ستد، آماده برای هدفی بخصوص یا بدون تخلف است. تمام مخاطرات مانند کیفیت و کـارایـی کـد اصـلی متوجه شماست. هر صدمه اثبات شده از کد اصلی در هر رابطه باید توسط شما ([و] نه توسط توسعه دهنده نخستین) پـرداخـت شود چه هر نوع سرویسی لازم باشد یا تعمیری یا تصحیحی. این [اخطار] رفع مسئولیت از تعهد بخشی ضروری از پروانه را تشـکیـل مـی‌دهـد. هیچ کاربردی از کد اصلی مجاز نیست مگر تحت این [اخطار] رفع مسئولیت.

۸.۰ فسخ

۸.۱ این پروانه و حقوقـی کـه بـر پـایه آن اعطا می‌شود بطور خودکار فسخ خواهد شد اگر شما از پذیرش شرایطی که در اینجا آمده قصور کنید و در عرض ۳۰ روز از زمـان اطـلاع یـافـتـن از نقـض عهـد اقـدامـی بـرای تـصـحـیح آن نـکـنید. تمام زیر پـروانـه‌هـای کـد اصـلی کـه به شکلی مناسب اعطا شده‌اند می‌بایست [شرایط] فسخ این پروانه را باقی گذارند. قیودی که ذاتاً فراتر از شروط فسخ این پروانه بمانند نیز باید حفظ شوند.

۸.۲ در صـورت اعـمـال فـسـخ چـنـانکـه در بخـش ۸.۱ بالا آمده تمام موافقت‌نامه‌های کاربری (به استثنای توزیع‌کنندگان و فروشندگان) که بشکلی معتبر توسط شما یا هر توزیع‌کننده قبل از فسخ اعطا شده می‌بایست شامل فسخ باشند.

۹.۰ محدوده مسئولیت

تحت هیچ شرایطی و هیـچ اصـل حـقـوقـی، چـه آسـیـب (یا اهمال)، یـا قـرارداد یـا هر شکل دیگری شما، توسعه دهنده نخستین، هـر شـرکت کننـده دیـگر یـا هـر تـوزیـع کـنـنده کـد اصـلی یا تهیه کننده هر بخش از این مجموعه نسبت به هر شخصی بطور غیرمستقیم، ویژه، ضمنی، یا برآیند صدماتی از هر رقم مسئول که است، بدون محدودیت، خسارات مربوط به فقدان حسن نیت، منع عمل، ناتوانی یا بد عمل کردن رایانه، یا هـر نوع دیگری از صـدمات یا خسارات تجاری، حتی اگر طـرف مـورد نـظر از امکان بروز چنین خساراتی مطلع شده باشد، مسئولیتی دارا نمی‌باشـد. ایـن مـحـدودیت مـسـئولیت نمی‌بایست بـر مسئولیت مرگ یا جراحات فردی ناشی از قصور طرف مذکور در حدی که قانون قابل اجرا چنان مسئولیتی را ممنوع کرده اعمال شود. بعضی حوزه‌های قضایی اجازه استثنا کردن یا محدود نمودن خسارات مستقیم و غیرمستقیم را نمی‌دهند بنابراین استثنا و محدودیت شامل شما نمی‌گردد.

۱۰.۰ کاربری توسط حکومت ایالات متحده

حکومت ایالات متحده: اگـر این نرم‌افزار توسط یا از طرف حکومت ایالات متحده یا پیمانکار عمده یا جزء آن (در هر صنفی) بکار گرفته شود، حقوق حـکومـت در قبـال نـرم‌افـزار و مسـتـندات هـمـراه بایستی منطبق بر این پروانه باشد؛ این موضوع مطابق است با 48 C.F.R. 227.7201 تا 227.7202-4 (برای مالکیت بخش دفاعـی) و با 48 C.F.R. 2.101 و 12.212 (برای بخشهای غیردفاعی).

۱۱.۰ گوناگون

این پروانه موافقت کـامـل بـا مـوضـوع مـورد بحث را نشان می‌دهد. اگر هر بندی از این پروانه غیر قابل اجرا بنماید، آن بند تنها باید به اندازه‌ای اصلاح گردد که قابل اجرا شـود. ایـن پروانه می‌بایست توسط بخش قضایی کالیفرنیا اعمال شود (به جز محدوده قانونی، اگر [چنان محدوده‌ای] باشد و در غیر ایـن صورت مقرر شود)، به استثنای محدوده‌ای که تضاد قانونی پیش بیاید. با ملاحظه اختلافی که اگر یک طرف [قرارداد] شهـرونـد ایالات متحده باشد یا نهادی با امتیاز ثبت یا تجارت در ایـالات مـتحده باشـد، هـر دعوی قضایی مربوط به این پروانه می‌بایست در حـوزه قـضـایی دادگاه فدرال نـاحـیـه شـمـالی کالیـفـرنـیـا مطـرح شـود کـه مـحـل دادرسـی آن در بـخـش سـانتاکلارای کالیفرنیا قرار دارد، که مسئولیت هزینه‌ها، بدون مـحـدودیت، هـزینـه‌هـای دادگـاه، دسـتـمزد و هزیـنـه‌هـای مسـتـدل وکالت بر عهده بازنده دعوی است. کاربرد پیمان‌نامه سازمان ملل متحد در رابطه با فروش بین‌المللی کالاها صریحاً مستثنی شده است. هر قانون یا آئین‌نامه‌ای که مقرر کند که زبان یک قرارداد می‌بایست در برابر پیش نویس آن تفسیر شود نمی‌بایست بر این پروانه اعمال گردد.

نمونه الف – پروانه متعارف Sun

محتویات این فایل تحت پروانه متعارف Sun نسخه 1.1 قرار دارد؛

شما نمی‌بایست از این فایل اسـتفـاده کـنـید مـگر پس از موافت با این پروانه. شما می‌توانید نسخه‌ای از این پروانه را از ــــــــــــــــــــــــــــــــــــــــــــــــــــــ بدست آورید.

تـوزیـع نـرم‌افزار بـا ایـن یـروانه توزیعی است بر مبنای «آنچه هست»، بدون هر نوع ضمانت، چه واضح و چه ضمنی. برای اعمال حقوق خاص زبان و محدودیتهای تحت این پروانه، متن پروانه را ببینید.

کد اصلی شامل ـــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ است.

نخستین توسعه دهنده کد اصلی:

شرکت Sun Microsystems.

بخش‌ها توسط ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ ایجاد شده‌اند.

کپی رایت شده بوسیله (C) : ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

همه حقوق محفوظ است.

شرکت کنندگان: ــــــــــــــــــــــــــــــــــــــــــــــــــــــــــــ

نمونه ب – استانداردها

منظور از استاندارد عبارتست از:

خصوصیات قالب فایل XML در OpenOffice.org، مستقر در http://xml.openoffice.org

خصوصیات رابط کاربری برنامه‌نویسی OpenOffice.org، مستقر در http://api.openoffice.org

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 11 خردادماه 1384

07:12 PM

June 01, 2005

آشنایی با automount و autofs

خلاصه
automount و autofs ابزارهای قدرتمند و آسانی در مدیریت سیستم های فایل هستند. ین دو ابزار به تمام کاربران یک ماشین اجازه می‌دهند تا سیستم فایل های متفاوتی که بیشتر مواقع به آنها نیاز پیدا می کنند را به طور اتوماتیک mount کنند.

مقدمه
فایل /etc/fstab ، mountpoint/ های سخت را در خود نگه می دارد. هر نقطه مطابق با یک مکان و یک سیستم فایل (به عنوان مثال یکی از پارتشن های هارد دیسک شما) است. بعدها اگر شما بخواهید به نقاط دیگر دسترسی داشته باشید تنها root می تواند از دستور mount استفاده کند (به جز مواردی که در فایل fstab گزینه user یا users استفاده شده باشد.) به عنوان root نیز باید mountpoint، آنچه که می‌خواهید mount کنید و شاید سیستم فایل و دیگر گزینه‌ها را مشخص کنید.

automount و autofs به مدیر سیستم اجازه می دهند تا همانطور که از دستور mount استفاده می کنید، تمام فایل سیستم هایی که یک ماشین می‌تواند به آنها دسترسی داشته باشد را پیکربندی کند. حالا کاربر می تواند به این سیستم ها از طریقی کاملا شفاف دسترسی داشته باشد، بدون هیچ گونه نگرانی از اینکه کرنل چگونه به او پاسخ خواهد داد.

توضیحات
دستورات autofs و automount مثل یک مدل client/server در شبکه عمل می کند. یک سرور در حال اجرا منتظر یک تقاضا می‌نشیند. وقتی تقاضایی دریافت کرد، سرور autoduplicate می‌کند (از خودش یک کپی می گیرد)، یک بخش به تقاضا پاسخ می‌دهد و بخشی دیگر منتظر تقاضای بعدی می‌ماند. در اینجا autofs نقش سرور را بازی می‌کند و automount یک duplicatedserver. تقاضاها نیز در یک فایل پیکربندی نگهداری می شوند.

autofs
معمولا autofs در زمان boot اجرا می‌شود و هنگام shutdown (یا restart) بسته می‌شود. هر چند مدیر سیستم توانایی شروع یا بستن آنرا به صورت دستی دارد. Autofs می‌تواند چهار حالت داشته باشد:

۱) start: همانطور که از اسمش پیداست، پردازش را شروع می کند. هنگام شروع، autofs به دنبالmapها در فایل پیکربندی etc/auto.master می‌گردد. Mapها نقاط اتصال را مشخص می کنند. سپس automount را برای هر mountpoint راه اندازی می کند. سپس، autofs به دنبال mapهای NIS می گردد. (مباحث مربوط به NIS در این مقاله دنبال نمی‌شود.)
۲) stop: ابزار autofs و تمام automountها را قطع می کند.
۳)reload : نقشه‌های (map) فایل auto.master را بازخوانی می کند و automountهای حاضر را kill می کند و آنها را برای mountpointهای جدید راه می اندازد. نکته اینکه تغییرات ساخته شده در map ها در زمان راه‌اندازی بعدی در حساب اعمال می‌شود. به عبارت دیگر تغییرات در auto.master با restart کردن autofs اعمال می‌شود.
۴) status: پیکربندی حاضر و تمام automountهای در حال اجرا را نشان می دهد.

بطور خلاصه autofs چیزی جز یک اسکریپت مشاور auto.master، قبل از آغاز automountهای ارتباط داده شده به هر mountpoint نیست.

Automount
Automount از یک mountpoint ابتدایی (یکی که به وسیله‌ی autofs برای شروع automount پیدا شده) و از یک map جدید که خصوصیات این mountpoint اولیه را تشریح می‌کند، شروع به کار می کند. Map ارتباط داده شده به automount تمام اطلاعات لازم برای mount کردن سیستم فایل را به صورت اتوماتیک نگه می‌دارد. این mount اتوماتیک به محض اینکه یک نفر تلاش کند تا به چیزی در درخت دایرکتوری که از این mountpoint شروع می شود، دسترسی پیدا کند، انجام می شود. در نهایت، بعد از طی شدن یک زمان غیرفعال( به طور پیش فرض ۵ دقیقه) به طور اتوماتیک unmount می‌شود.

پیکربندی
عمل پیکر بندی توسط دو فایل انجام می شود. فایل auto.master که mountpointها را در خود نگه می‌دارد و یک فایل برای هر mountpoint که گزینه‌های سیستم را برای این mountpoint مخصوص نگه می دارد.

فایل etc/auto.master/
اکنون map هایی که از فرمت sun استفاده می‌کنند را معرفی می کنیم. فرمت دیگر (hesiod) نمی‌تواند syntax تشریح شده در زیر را مدیریت کند. etc/auto.master فایل اصلی autofs است. هر خط یک mountpoint را تشریح می کند و به فایلی که حاوی تشریحات فایل سیستمی که باید از آن نقطه mount شود اشاره می کند. آخرین فیلد اجازه می‌دهد تا گزینه‌هایی را به دستور mount هنگام شروع ارسال کنید. Syntax هر خط به صورت زیر است:

mount_point map_for_the_associated_automount [mount_options_seperated_by_camma]

مثال:

/home /etc/auto.home
/misc /etc/auto.misc –timeout 60
/mnt yp:mnt.map –intro,nosuid,nodev

این فایل سه mountpoint را پیکربندی می‌کند (/home،/misc،/mnt). برای دسترسی به فایل‌های داخل misc برنامه automount فایل etc/auto.misc/ را برای یافتن گزینه‌های mount و کلید مربوط به فایل سیستم را خواهد خواند. دو خط آخر تعدادی گزینه با خود دارند. همانطور که در خط آخر می بینید، autofs و automount کاملا با NIS سازگاری دارند.

Mapهای automount

Syntax این فایل تقریبا مشابه یک فایل auto.master است:

key [mount_options_seperated_by_camma] place

key یک شناسه برای سیستم فایل تحت mountpoint را نشان می‌دهد. Place مکان حقیقی فیزیکی است. اجازه بدهید به مثال قبلی با یک فایل /etc/auto.misc برگردیم:

Kernel –ro,soft,intr ftp.kernel.org:/pub/linux
Cdrom –fstype=iso9660,ro :/dev/cdrom
Floppy –fstype=auto :/dev/fd0
Windoz –fstype= vfat :/dev/hda1

بنابراین مسیر مطلق یک فایل به شرح زیر است:

/mount_point/path/file

پس اگر بخواهیم فایل config.sys در ویندوز را بخوانیم، تنها کافی است که دستور زیر را اجرا کنیم:

$ cat /misc/windoz/msconfig

این نکته را باید متذکر شد که آخرین خط به یک دایرکتوری NFS که import شده رجوع می کند.

نکته: باید این را در نظر داشت که حالت autocomplete در اینجا فعال نیست و شما نمی توانید با استفاده از کلید tab مسیر را کامل کنید. این مورد به این دلیل است که سیستم فایل شما هنوز mount نشده و دایرکتوری مربوطه خالی است.

ایرج هدایتی shotorbaan@yahoo.co.uk
ناشر: irantux.com

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 11 خردادماه 1384

07:12 PM

June 01, 2005

آشنایی با وظایف یک مدیر سیستم

گاهی به عنوان یک کاربر سرویس‌گیرنده گنو/لینوکس که با خوشحالی در یک شبکه در حال کار هستید، فراموش می‌کنید که نقش و کار مدیر سیستم در نگهداری از سرویس‌دهندهای شبکه در شرایط کاری سنگین چقدر مهم می‌تواند باشد. یک سرویس‌دهنده بزرگ ممکن است دارای چندین کاربر باشد که از سرویس‌های متفاوتی بر روی آن استفاده می‌کنند و مسائل مدیریتی مختلفی مانند مدیریت حساب‌های کاربری، دایمن‌های سرویس‌ها و ترافیک شبکه همراه آن وجود دارد. در صورتی که تنها یک کامپیوتر داشته باشید، شما هم کاربر آن خواهید بود و هم مدیر آن. مسئولیت‌های یک مدیر سیستم گنو/لینوکس می‌تواند شامل بسیاری از بخش‌های سیستم‌عامل شود.

موفقیت یک سیستم کامپیوتری پایدار، امن و کارا تا حدود زیادی به مدیر سیستمی که نگهداری از آن را بر عهده دارد، بر می‌گردد. معمولا نگهداری، تنظیم و بروز رسانی سیستم برای حفظ آن در بهترین شرایط کاری، وظیفه چندان آسانی نیست.

شغل مدیر سیستم می‌تواند علاوه بر مدیریت و نگهداری از سیستم، پشتیبانی از کاربران نیز باشد. در زیر لیستی از وظایفی را که ممکن است بر عهده یک مدیر سیستم باشد، مشاهده می‌نمایید. با دیدن این لیست می‌توانید سطح گسترده وظایف یک مدیر سیستم را بهتر درک نمایید.

روشن و خاموش کردن سیستم: شما ممکن است دوست نداشته باشید که هرکسی که دارای یک حساب کاربری بر روی یک سیستم است، قادر به روشن و خاموش کردن آن باشد. مخصوصا وقتی کامپیوتر مورد نظر در حال ارائه خدماتی بر روی شبکه است که نیاز دارید تا همیشه قابل دسترسی باشند.

حساب‌های کاربری: ایجاد حساب‌های کاربری یکی از امور بسیار پایه‌ای یک مدیر سیستم است. بسیاری از شبکه‌ها دارای سیاست‌های خاصی برای حساب‌های کاربران خود هستند و مدیر سیستم باید اعمال‌گر این سیاست‌ها باشد. اعمال حقوق دسترسی ناصحیح برای کاربران می‌تواند راه‌های نفوذ به سیستم شما را باز کرده و باعث سیاه شدن روزگارتان بعنوان یک مدیر سیستم شود.

امنیت: امن‌ترین سیستم‌ها سیستمی است که به جایی متصل نیست و تنها یک کاربر با آن کار می‌کند! البته این کار عملی نیست. بنابراین باید حقوق دسترسی کاربران به گونه‌ای تنظیم گردد که دسترسی به منابع سیستمی همراه با کنترل و محدودیت امکانپذیر باشد.

مانیتور کردن منابع سیستمی: هر سیستمی نیاز دارد تا بطور دائم مانیتور شود. این کار ممکن است توسط اسکریپت‌ها و یا نرم‌افزارهای خاصی صورت گیرد تا در مواقع لازم مدیر سیستم بتواند با مداخله به موقع خود مانع از کار افتادن بخش یا بخشهایی از سیستم گردد. دیسک‌ها پر می‌شوند، پردازنده‌ها درگیر پردازش‌های سنگین می‌شوند، سیستم‌ها Overload می‌شوند و این وظیفه مدیر سیستم است که آنها را در حال کار نگاه دارد.

خودکار سازی برخی وظایف: این امر وظیفه بسیار مهم و دشواری است. خودکار سازی ممکن است شامل نوشتن اسکریپت‌های خاص و تنظیم نرم‌افزارهای کاربردی خاصی باشد تا بتوانند برخی از امور روزمره را بر عهده گرفته و از این طریق قابلیت اطمینان و پایداری سیستم را بالاتر ببرند. خودکار سازی می‌تواند اموری مانند پشتیبان گیری از سیستم و تجزیه و تحلیل فایل‌های ثبت رخداد را بر عهده بگیرد و همچنین می‌تواند تا حد زیادی در وقت مدیر سیستم صرفه جویی نماید. با تهیه و نوشتن اسکریپت‌های مدیریتی خواهید توانست از تایپ تعداد زیادی دستور در طی روز خودداری کنید.

پیکربندی سیستم: تقریبا تمامی دایمن‌ها مانند سرویس‌های فایل، چاپ، وب، پست‌الکترونیک، FTP و... قبل از عملیاتی شدن نیاز به تنظیم و پیکربندی دارند. بسیاری از این نرم‌افزارها نیاز به تنظیم حقوق دسترسی و تعریف کاربران خاص خود را دارا هستند. فایل‌های پیکربندی که برای انجام تنظیمات دایمن‌ها استفاده می‌شوند ممکن است شامل چند تا چند صد خط باشند.

دیسک‌های سخت و فایل سیستم‌ها: دیسک‌های سخت و فایل سیستم‌ها دارای نقش بسیار مهم و پایه‌ای در عملکرد سیستم‌عامل هستند. هر گونه کاستی و نقص در عملکرد آنها می‌تواند باعث افت عملکرد یا توقف کلی سیستم گردد. اقداماتی نظیر بررسی دائمی فضای دیسک و تعریف سهمیه‌های فضا یا Disk Quota جهت کاربران می‌تواند باعث جلوگیری از مصرف کل فضای موجود توسط کاربران خاص گردد.

پشتیبان‌گیری و بازگرداندن نسخه‌های پشتیبان: هیچ چیزی نمی‌تواند مانند یک پشتیبان خوب هنگام از دست رفتن داده‌ها نجات بخش باشد. یک پشتیبان گیری مناسب می‌تواند باعث صرفه‌جویی‌های میلیونی در مواقع اشکال و از دست رفتن داده‌ها شود. این وظیفه که امکان خودکار کردن آن به سادگی امکان‌پذیر است، باید یکی از اولویت‌های اولیه هر مدیر سیستم باشد. فراموش نکنید یکی از اولویت‌های اولیه!

سرویس‌های چاپ: اداره هر نوع خدمات چاپی که بر روی شبکه قرار داشته باشد، دست مدیر سیستم را می‌بوسد! از تنظیم و پیکربندی سرویس‌دهنده‌های چاپ گرفته تا اضافه کردن چاپگرها، تعویض تونر وسایر امور مربوط به چاپ. برخی اوقات مدیران سیستم حتی باید کاغذ چاپگرها را نیز اداره کنند.

مدیریت شبکه: هنگامی که چند کامپیوتر دارید که به هم متصل بوده و باهم در ارتباط هستند، یک شبکه دارید. بنابراین شخصی باید وجود داشته باشد که بر عملکرد این شبکه نظارت داشته و آنرا در بالاترین حد کارایی خود نگاه دارد. وظایفی که یک مدیر شبکه علاوه بر نظارت ممکن است بر عهده داشته باشد، می‌تواند شامل مواردی مانند دیوارهای آتش، مسیریابی و اتصال به شبکه اینترنت باشد. این موارد وظایف کوچکی برای یک مدیر سیستم نیست.

پست‌الکترونیک، وب، بانکهای اطلاعاتی و سایر خدمات: هر ماشین سرویس‌دهنده‌ای می‌تواند عهده دار خدمات میزبانی صفحات وب، ارسال و دریافت نامه‌های الکترونیکی و یا مرکز ذخیره سازی بانک‌های اطلاعاتی باشد. مدیر سیستم باید از هرنظر بر ارائه خدمات اینچنینی نیز نظارت داشته و نگهداری و پیکربندی‌های مرتبط با این نوع خدمات را انجام دهد.

با مرور این لیست، اکنون دید بهتری از گستردگی سطح وظایف و مسئولیت‌های یک مدیر سیستم دارا هستید. در محیط‌هایی با چند صد کاربر و ده‌ها ایستگاه کاری و چندین سرویس‌دهنده مختلف، امر مدیریت سیستم بین چند نفر تقسیم می‌گردد.

آلن باغومیان alan@technotux.com

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 11 خردادماه 1384

07:14 PM

June 01, 2005

نصب و پیکربندی سرویس‌دهنده Squid

یک پراکسی سرور یک سرویس کارآمد جهت شبکه شما یا شبکه شما و اینترنت است که امنیت بالاتری را جهت کاربران اینترنت فراهم می کند و هم چنین می تواند بعنوان یک کش سرور هم استفاده شود که باعث بالا رفتن بازدهی سرور شما و سرعت آن در دسترسی به اینترنت می شود.

Squid اولین برنامه Proxy-Cache با کارآیی بالا بود که به عنوان بخشی از پروژه ی Harvest توسعه داده شد. Squid به راحتی نصب می شود و فایل پیکربندی پیش فرض آن برای نود درصد نصب‌ها درست است و نیازی نیست فایل را تغییر دهید و بهتر است بعضی انتخاب‌ها مثل قوانین نوسازی را تا زمانی که تجربه ی کافی به دست نیاورده‌اید، تغییر ندهید. در این مقاله بر روی انتخاب های پایه ی squidکار خواهیم کرد. در حقیقت در این مقاله انتخاب هایی را که در ده درصد ماشین های دیگر تغییر می کند، معرفی می‌کنیم.

نصب از طریق Pack

جهت نصب Squid ابتدا اطمینان حاصل نمایید که شما بعنوان root وارد شده اید. سپس از فرمان rpm به صورت زیر استفاده کنید:

# rpm –ivh /mnt/cdrom/RedHat/RPMS/squid-*.rpm

شما در هنگام نصب تعداد زیادی از هش (#) را مشاهده می کنید که نشان از نصب squid دارد. برای نصب Squid در توزیع دبیان و توزیع‌های مبتنی بر آن می‌توانید از دستور apt-get install squid استفاده نمایید.

نصب از طریق کد منبع

اگر شما مایل به نصب squid از طریق فایل های source هستید، می‌توانید این کار را جهت همه نسخه‌های لینوکس انجام دهید. یادآور شوم که شما احتیاج به دریافت جدیدترین سورس پایدار squid از وب سایت آن هستید. سورس squid به صورت فایل فشرده شده tar است که شما احتیاج دارید ابتدا آن را غیر فشرده نمایید :

# tar -zxf squid-2.3.STABLE4-src.tar.gz

هنگامی که شما فایل فشرده tar را غیر فشرده نمودید شما از این طریق احتیاج به تنظیم و نصب Squid به صورت زیر دارید:

# cd squid-2.3.STABLE4
# ./configure
# make all
# make install

برای کسب اطلاعات بیشتر جهت نصب آن فایل INSTALL را که در سورس کد موجود است را می توانید مورد بررسی قرار دهید.

تنظیم نمودن Squid

همه تنظیمات این پراکسی سرور در فایل پیکربندی آن است ( squid.conf ) که بستگی به نسخه لینوکس شما ممکن است در مسیرusr/local/squid/etc/squid.conf/ یا etc/squid.conf/ یا etc/squid/squid.conf/ باشد. قبل از انجام هرکاری شما باید مسیر این فایل را در سیستم تان پیدا نمایید:

# updatedb
# locate squid.conf

فایل پیکربندی Squid خود دارای صد و بیست وپنح برچسب جهت انجام تنظیمات است که ما در اینجا همه آن ها را پوشش نخواهیم داد و به اصلی ترین آن ها اشاره خواهیم نمود.

شروع تنظیمات مقدماتی

در فایل پیکربندی squid.conf تعداد زیادی توضیح وجود دارد که قابل استفاده هستند که در این حالت حجم فایل در حدود 76 کیلو بایت است که در صورت حذف این توضیحات حجم آن به 600 بایت کاهش می یابد! که در این صورت ویرایش آن از طریق ویرایش گرها آسان تر خواهد شد.

تعیین درگاه squid

در این مرحله آدرس درگاهی را که squid از آن به درخواست های سرویس‌گیرنده‌ها گوش می دهد را مشخص می کنیم:

http_port 3128

در صورتی که squid cache ما به عنوان web server نیز عمل کند، شماره درگاه را 80 قرار می دهیم.

همچنین می توان از چند درگاه برای این کار استفاده کرد:

http_port 80 3128

تنظیم محل ذخیره objectهای Cache شده:

cache_dir aufs /var/spool/squid/ 100 16 256

پارامتر اول نوع سیستم فابل جهت دایرکتوری ذخیره objectها را تعیین می کند. نوع قدیمی تر آن ufs می باشد. پارامتر دوم مسیر ذخیره داده‌ها را مشخص می‌کند. پارامتر سوم حجم داده‌ها بر روی دیسک بر حسب (مگابایت) را مشخص می کند. پارامترهای چهارم و پنجم تعداد زیر شاخه ها (اولین و دومین رده) برای ایجاد در این شاخه را مشخص می‌کنند. این کار جستجو برای یافتن یک object را راحتتر می کند.

برای استفاده از دو هارد دیسک جهت ایجاد کارآیی بهتر و دسترسی سریعتر به صورت زیر عمل می کنیم:

cache_dir /var/spool/squid/ 100 16 256
cache_dir /mnt/hdb2 100 16 256

/mnt/hdb2 نقطه اتصال هارد دیسک دوم است.

ID قابل اجرای گروه و کاربر:

Squid اگر به عنوان root شروع شود، تنها می تواند به پورت های شماره پایین (مثل پورت80 ) بچسبد. در ضمن از لحاظ امنیتی هم صحیح نیست که پروسه‌ای به عنوان root در حال اجرا باشد. Squid به محض چسبیدن به پورت شبکه ID های گروه و کاربر را تغیر می دهد. این ID ها را به صورت زیر مشخص می کنیم:

cache_effective_user squid
cache_effective_group squid

e-mail برای مدیر cache

اگر Squid از کار بیفتد، یک e-mail به آدرس مشخص شده با برچسب cache_mgr ارسال می شود. همچنین این آدرس به انتهای صفحه های خطایی که به کاربران ارسال می‌شود، اضافه می شود. (به حتم با این صفحات در ضمن کار با اینترنت در منزلتان برخورد کرده اید.)

cache_mgr i-support@mail.vru.ac.ir

اطلاعات FTP login

FTP جهت انتقال فایل های تصدیق شده (فایل هایی که احتیاج به نام کاربر و کلمه عبور دارند) نوشته شده است. برای دسترسی عمومی، یک حساب کاربر مخصوص به نام کاربر anonymouse ساخته شده است. وقتی که شما به یک سرور FTP وارد می شوید، از آن به عنوان نام کاربری خود استفاده می کنید. به عنوان کلمه ی عبور هم از آدرس email خود استفاده کنید. Squid به شما اجازه می دهد که آدرس e-mail ی که به این منظور استفاده می شود را به وسیله ی برچسب ftp_user تنظیم کنید:

frp_user squid@yourdomain.example

کنترل دسترسی و عملگرهای کنترل دسترسی:

access contro list یاACL جهت کنترل دسترسی به Cache مورد استفاده قرار می گیرد. در کنترل دسترسی دو عنصر وجود دارد: کلاس ها و عملگرها.

کلاس ها: یک کلاس معمولا به مجموعه ای از کاربرها ارجاع داده می‌شود.

عملگرها: روی مجموعه ای از acl ها برای ICP و HTTP عمل می کند. یعنی شما می توانید مجموعه های مختلفی از پروتکل های مختلف داشته باشید. برای هر پروتکل یک acl_operator متفاوت وجود دارد. به عنوان مثال برچسب های icp_access و http_access و snmp_access.

acl name type (string|”filename”) [string2][string3][“filename2”]

-Name تعریف شده باید در فایل unique باشد.

-String می تواند یک رشته از IPها باشد:

acl mynet src 10.0.0.0/255.0.0.0

-اگر دو string را پشت سر هم بیاوریم آنها را با or جدا می کنیم:

acl mynet src 10.0.0.0/255.0.0.0 10.1.0.0/255.255.0.0

-اگر String ها بسیار بزرگ باشند آنها را در یک فایل ذخیره کرده و سپس نام فایل را به جای String می آوریم.

acl mynets src “/etc/squid/mynets”

در زیر انواع مشهور ACL که کاربرد فراوانی دارند تشریح می کینم:

1. source/destination IP address

تطابق آدرس های IP در محدوده ی تعریف شده که کلمات کلیدی src برای آدرس های مبدا و src برای مقصد استفاده می شوند:

acl mynet dst -------/--------

acl mynet dst -------/--------

نکته اینکه به جای ذکر فرمت استاندارد ماسک شبکه از فرمت غیر استاندارد، یعنی ذکر تعداد یک ها، استفاده کنید. مثال:

acl mynet src 192.168.10.0/24

2. source/destination Domain address

برای محدودیت دامنه ها به کار می رود. کلمات کلیدی srcdomain برای دامنه های مبدا و dstdomain برای دامنه های مقصد استفاده می شود. مثال:

acl mydomain srcdomain .qualica.com .squid.cache.org

نکته: برای مسدود کردن یک سایت باید هم domain و هم آدرس IP آن را مسدود کنید.

3. regular expression match of requested domain

این نوع از ACLها برای مسدود کردن سایت هایی که حاوی کلمات خاصی است، استفاده می شود. البته این دستور case sensitive است و برای گریز از آن باید از پارامتر-i استفاده کنید. مثال:

acl badurl url_regex –i sxx

همچنین نوع دیگری به نام urlpath_regex وجود دارد که فقط مسیر و نام فایل را چک می‌کند.

4. current day/time

اجازه دسترسی در زمان خاص(روز-ساعت)

acl name time [day-list][start_hour:start_minute-end_hour:end_minute]

که روزهای هفته به صورت زیر است:

S(Sunday), M, T, W, H, F, A(Saturday)

مثال:

acl night time 17:00-24:00
acl week time SA

5. Destination port

برای تعریف مجموعه ای از پورت ها که قرار است به آنها دسترسی داشته باشید یا نداشته باشید.مثلا اگر بخواهیم دسترسی را فقط برای مجموعه خاصی از پورت ها تعریف کنیم به صورت زیر عمل می کنیم. مثال:

acl safe_port port 80 21 443 70 210 1025-65535
http_access deny !safe_port

6. protocol

برای مسدود کردن پروتکل ها با استفاده از پیشوند های سایت مثل http:// یا frp:// برای مثال:

acl ftp proto FTP

7. method

برای مسدود کردن methodها. مانند GET و POST. مثال:

acl post_class method POST

سایر ACL_OPERATOR هایی که در فایل squid.conf مورد استفاده قرار می گیرند:

no_cache - برای جلوگیری از cache کردن موارد خاص.

miss_access - اگر بخواهیم یک سری اطلاعات داخل cache را غیر قابل دسترس کنیم.

مثالی از یک مجموعه acl و acl_operator:

acl nimda urlpath_regex –i \.eml
acl nimda2 urlpath_regex -i root.exe
acl localhost src 127.0.0.1/36
acl all src 0.0.0.0/0.0.0.0
http_access deny nimda
http_access deny nimda2
http_access allow localhost
http_access deny all

Logging -

به طور پیش فرض Squid فعالیت های انجام شده را در چندین فایل ذخیره می‌کند:

cache_access_log /var/log/squid/access.log
cache_log /var/log/squid/cache.log
cache_store_log none

با اضافه نمودن این پارامترها Squid پیغام های خطا را در مسیر var/log/squid/cache.log/ و پیغام های دسترسی به سرور را در var/log/squid/access.log/ ذخیره می‌کند که البته برنامه هایی نیز جهت آنالیز access.log قابل دریافت هسنتد که از آنها می توان به قابل دریافت هسنتد که از آن ها می توان به اشاره نمود. (که با نام sqmgrlog شهرت دارد). برای مشاهده ی نحوه گزارشگیری Squid از دستور tail استفاده می کنیم. دستور tail محتویات یک فایل گزارش را بر روی صفحه نمایش چاپ می کند.

# tail /var/log/squid/access.log

برای انکه دستور tail را مجبور کنیداین عمل را به طور پیوسته انجام دهد از سوییچ –F استفاده کنید.

اندکی در مورد upstream Proxy

شاید یکی از برتری های Squid استفاده از upstream Proxy باشد که می تواند دسترسی به اینترنت تا حد قابل ملاحظه ای بالا ببرد. بعنوان مثال وقتی ISP شما دارای کش جهت کاربرانش می باشد کش سرور شما می تواند سایت های بسیاری را در خود ذخیره کند که این خود تا حد زیادی بازدهی را در مواقع ضروری بالا می برد. یکی دیگر از مزایای Squid پشتیبانی به صورت چندگانه است بدین مفهوم که می توان چندین کش سرور را با هم ارتباط داد که Squid این کار را از طریق پروتکول ICP انجام می دهد. ICP این اجازه را به کش سرورها می دهد که از طریق پکت های سریع UDP با هم ارتباط برقرار نمایند. خوب جهت استفاده از این مزایا شما اول باید مد نظر داشته باشید که آدرس کش سرور ها چیست (proxyserver.yourisp.com) و هم چنین از چه پورتی بدین منظور استفاده می کند . استفاده از upstream Proxy به راحتی امکان پذیر است :

cache_peer proxy.yourisp.com parent 3128 3130
prefer_direct off

خط cache_peer اسم هاستینگ و نوع کشینگ "parent" و پورت پراکسی " 3128 " و پورت 3130 "ICP"را مشخص می کند. اگر کش سرور شما پروتکل ICP را پشتیبانی نمیکند. از این خط استفاده نمایید:

cache_peer proxy.yourisp.com parent 3128 7 no-query default
prefer_direct off

Sharing Caches -

توجه داشته باشید که در مواقع ضروری که یک شرکت چندین ارتباط جهت دسترسی به اینترنت داشته باشد، Squid کش نمودن سرور ها در حالت اشتراک گذاری آن ها می‌پذیرد ( بدین مفهوم که چندین کش سرور با هم ارتباط داشته باشند .) در این صورت باید هر کش سرور این خط را در فایل پیکربندی خود داشته باشد:

cache_peer theotherproxy.yournetwork.com sibling 3128 3130

که اگر دقت نمایید یکی از پارامترها به sibling تغییر یافته بدین مفهوم که فایل های کش را چنانچه در کش سرور دیگر باشد آن ها را دریافت می کند.

پراکسی به صورت ترانسپرنت

ترانسپرنت نمودن پراکسی یک روش است که شما می‌توانید که یک پراکسی سرور را بین شبکه و اینترنت بگذارید و بدون اینکه نیاز به تنظیمات خاصی باشد ما مستقیما به اینرنت وصل خواهیم گردید جهت نصب پراکسی به صورت ترانسپرنت شما به این چیزها احتیاج خواهید داشت :

- یک قانون فایروال (rule) و Redirect نمودن ترافیک خروجی شبکه به پراکسی سرور.
- یک قانون Squid جهت فعال کردن Squid تا اینکه به صورت ترانسپرنت عمل نماید.

جهت اجرای یک قانون فایروال شما به قانونی نظیر زیر احتیاج خواهید داشت :

# iptables –t nat –A PREROUTING –d 207.216.150.1 –p tcp –m tcp –dport 80 –j ACCEPT
# iptables –t nat –A PREROUTING –p tcp –m tcp –dport 80 –j REDIRECT –-to-ports 3128

تنظیمات مورد احتیاج Squid جهت فعال کردن Squid به صورت ترانسپرنت در اینجا ذکر شده اند:

httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on

راه اندازی Squid:

همانطور که اشاره شد هیچ مسیر پیش فرضی جهت دخیره داده ها برای Squid وجود ندارد و مسیر آن را قبلا در فایل squid.conf تعیین کرده ایم. اشیا download شده در شاخه های swap به صورت سلسه مراتبی ذخیره می‌شوند. برای ساخت شاخه های swap به صورت دستی از دستور زیر استفاده می کنیم:

# squid –z

راه اندازی پراسس squid با دستور زیر انجام می شود:

# squid –D –d 1

پارامتر –d 1 برای گزارش عملیات انجام شده مورد استفاده قرار می گیرد. حال می توانید از دستور tail برای تست کردن عملیات انجام شده استفاده کنید.

ایرج هدایتی shotorbaan@yahoo.co.uk
ناشر: irantux.com
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 11 خردادماه 1384

07:16 PM

June 01, 2005

آشنایی با CVS

وقتی با دنیای گنو/لینوکس آشنا می شوید. سعی می کنید درباره آن بیشتر بدانید. از هر موقعیتی برای آشنایی بیشتر با طرز کار سیستم عامل و فرهنگ آن استفاده می کنید. یکی از سوالاتی که بعد از مدتی برای شما پیش می آید. این است که متوجه می شوید تعداد زیادی از پروژه هایی که می بینید٬ توسط گروهی از برنامه نویسان نوشته می شوند. در مراحل بعدی شاید متوجه شوید که این افراد در سرتاسر دنیا از نظر جغرافیایی پراکنده هستند. حال چطور می توان از راه دور یک پروژه زیبا ٬ با شکوه و از نظر فنی کاملا مناسب و حرفه ای را از راه دور دنبال کرد! این سوال من را وادار کرد تا درباره آن تحقیق کنم. ابزارهایی مانند email و لیستهای پستی در بستر مناسبی همچون اینترنت٬ این کار را آسان کرده اند. اما آیا فقط به واسطه آنها می توان به تنهایی از پس کار برآمد ؟ یکی دیگر از جوابهایی که در این راه به آن رسیدم٬ چیزی بود به نام CVS. شاید این کلمه برای شما آشنا باشد و یا برای یک حرفه ای ابزاری مناسب که سالها از آن استفاده می کند. اگر شما با این موضوع آشنا نیستید ٬ این مقاله می تواند شروعی برای آشنایی با این موضوع باشد. شاید روزی شما هم وارد دنیایی مشابه دنیای برنامه نویسان شدید. برای CVS کتابهای متعددی وجود دارند و من قصد ندارم وارد دنیایی از دستورات و روشها برای CVS بشوم. چراکه آنوقت باید روی کتاب قطوری کار کرد. پس تنها به معرفی آن و طرح نمونه ای برای آشنایی مختصر با طرز عملکرد آن می پردازیم.
اما این کلمه CVS به چه معنایی است؟ (Concurrent Versions System) کنترل نسخه های متفاوت ! خوب شاید برگردان آن به فارسی چندان مناسب نباشد. اما در یک جمله ٬ می توان گفت که برای ذخیره کردن تاریخچه کدها یا متون شما است. تاریخچه ! شما متنی دارید و آن را برای اولین بار ایجاد کرده اید. حال هر از گاهی آن را تغییر می دهید و آن را به روز می کنید. اگر تغیراتی را که اعمال کرده اید٬ ذخیره بشوند و هر وقت خواستید بتوانید از این تغییرات مطلع باشید. می تواند در موردی مانند دنبال کردن باگهای یک برنامه مفید باشد. می توانید گذشته را مرور کنید و ببینید که چه چیزی مشکل را ایجاد کرده بود.
ذخیره کردن نسخه های متفاوت از فایل می تواند وقت و زمان زیادی را از شما بگیرد. اما CVS همه را در یک فایل ذخیره می کند. شما نیازی به حفظ و نگهداری شماره هایی که این فایل را به مرور ویرایش می کنید٬ نخواهید داشت. هر زمان که بخواهید می توانید این روند را از روی گزارش ها پیگیری کنید.
اگر شما عضوی از یک گروه هستید و روی یک پروژه کار می کنید ٬ CVS برای شما ابزار مناسبی خواهد بود. می توانید به طور همزمان روی یک پروژه کار کنید. بعضی از رابطها خودشان سعی می کنند تا جلوی ویرایش همزمان را از دو نفر بگیرند. می توانید به صورت جداگانه روی یک پروژه کار کنید و خود CVS بعد از پایان کار ٬ آن را جمع و جور می کند.
پروژه CVS با نوشتن یکسری اسکریپت(Shell script) از سوی Dick Grune برای comp.sources.unix از نسخه شش به بعد در سال 1986 میلادی شروع شد. که می توان گفت که این کدها در CVS امروزی قرار ندارند و حتی قسمتی از آن را تشکیل نمی دهند. در سال 1989 ٬ Brian Berliner طراحی و کدنویسی آن را انجام داد و بعدها Jeff Polk به کمک او آمد.
آشنایی با طرز کار CVS
برای اینکه با طرز کار CVS آشنا شوید. آن را از دو سمت client و server نگاه می کنیم. تا بتوانیم تقریبا آنچه که اتفاق می افتد را ببینیم. مسائل امنیتی و نحوه مدیریت ٬ کارایی و اطمینان لازم را ایجاد می کند.
Server
اولین چیزی که برای مدیرت فایلها نیاز داریم ٬ به اصطلاح یک مخزن است. این مخزن یا همان دایرکتوری ٬ برای قرار دادن فایلهای پروژه ها هستند. بنابراین ایجاد مخزن اولین قدم است. شما می توانید آن را در هر جایی که بخواهید ایجاد کنید. بسته به اینکه کار شخصی خودتان یا شبکه محلی یک دفتر را انجام می دهید و یا اینکه قرار است روی اینترنت باشد و تعداد بیشتری به آن دسترسی داشته باشند. خوب به عنوان مثال یک فایل متنی را با دوستانم روی رایانه شخصی خودم به اشتراک می گذارم. آنها می توانند با کد کاربری خودشان از رایانه من استفاده کنند. چون من از پارتیشن home نگهداری می کنم و از سیستمهای متفاوتی استفاده می کنم٬ امن ترین جا همان دایرکتوری شخصی است. یک دایرکتوری به نام project ایجاد می کنم و مخزن اصلی کارهایم قرار می دهم.
توجه: با توجه به اینکه این یک مثال است. من هر دو سمت client و server را در دایرکتوری شخصی خودم اضافه کردم.

mohammad@debian:~$ mkdir project
mohammad@debian:~$ cd project
mohammad@debian:~/project$ cvs -d /home/mohammad/project init
mohammad@debian:~/project$ ls -l
total 1
drwxrwxr-x 3 mohammad mohammad 1000 2005-04-03 03:08 CVSROOT

همانطور که می بینید بعد از اینکه از دستور CVS برای ایجاد مخزن استفاده کردم. دایرکتوری با نام CVSROOT ایجاد شده است. برای اینکه فایل را در جایی قرار دهیم از یک قسمت برای آن استفاده می کنم. فرض می کنیم که در مورد یک ماژول است. بنابراین یک دایرکتوری دیگر به نام mod1 می سازم. مخزن ما آماده است. البته این مخزن کاملا خالی است. در قسمت بعدی به عنوان نمونه یک فایل به آن اضافه می کنیم.

mohammad@debian:~/project$ ls -l
total 1
drwxrwxr-x 3 mohammad mohammad 1000 2005-04-03 03:08 CVSROOT
drwxr-xr-x 2 mohammad mohammad 48 2005-04-03 03:19 mod1

Client
ما می خواهیم از همان مخزن برای انجام کارها استفاده کنیم. پس اول نیاز داریم تا همانند آن را داشته باشیم. پس یک دایرکتوری ایجاد می کنیم و دستور زیر را اجرا می کنیم.

mohammad@debian:~$ mkdir work
mohammad@debian:~$ cd work
mohammad@debian:~$ ls
mohammad@debian:~$ cvs -d /home/mohammad/project co mod1
cvs checkout: Updating mod1
mohammad@debian:~/work$ ls
mod1

اگر همه چیز به درستی پیش برود. باید یک دایرکتوری به همان نام ماژولی که در نظر گرفتیم ٬ ایجاد می شود. اگر قبلا این ماژول یا دایرکتوری شامل فایلی بود٬ شما آن را در داخل دایرکتوری mod1 مشاهده می کردید. وقتی CVS یک پروژه روی اینترنت را اجرا می کنید٬ قاعدتا فایلهایی هم به همراه آن ایجاد می شوند.
اضافه کردن یک فایل
برای شروع کار ما نیاز به اضافه کردن فایل داریم.

mohammad@debian:~/work/mod1$ ls
CVS
mohammad@debian:~/work/mod1$ touch myfile.c
mohammad@debian:~/work/mod1$ ls
CVS myfile
mohammad@debian:~/work/mod1$

شما می توانید در داخل این فایل یک برنامه کوچک را وارد کنید ٬ تا برای شما قابل لمس باشد. بعد آن را با دستور add اضافه می کنیم. این دستور فایل myfile.c را برای اضافه شدن به ماژولی که روی server وجود دارد علامت گذاری می کند.

mohammad@debian:~/work/mod1$ cvs add myfile.c
cvs add: `myfile.c' has already been entered

توجه: تغییراتی که شما ایجاد می کنید تنها بر روی دایرکتوری شخصی خودتان اعمال می شود. و بعدا باید آن را به روز رسانی کنید.
پس اگر ناراحت شدید که ای داد بیداد نباید این فایل را ایجاد می کردید یا تغییرات لازم را اعمال نکردید. می توانید فایل را حذف کنید.

mohammad@debian:~/work/mod1$ ls
CVS myfile.c
mohammad@debian:~/work/mod1$ rm myfile.c
mohammad@debian:~/work/mod1$ ls
CVS
mohammad@debian:~/work/mod1$ cvs rm myfile.c
cvs remove: removed `myfile.c'
mohammad@debian:~/work/mod1$

بعد از اینکه فایلهایتان را ایجاد و یا حذف کردید. می توانید تغییرات را ثبت کنید. و صد البته برای ثبت شدن آنها بر روی server باید این کار را انجام دهید.

mohammad@debian:~/work/mod1$ cvs commit

اگر شما تغییراتی داده باشید٬ در هنگام اجرای این دستور می توانید دلیل یا نوشته خودتان را بنویسید. توجه کنید ٬ بهتر است همیشه اینکار را بکنید. چرا ؟ چون تنها در زمانی که با یک فایل کار می کنید و حجم کاری وجود ندارد. نیاز مبرم به آن را احساس نمی کنید. اما زمانی که با یک گروه کار می کنید و یا اینکه حجم کار شما زیاد است. بعد از مدت زمانی این نوشته های کوچک حکم زمان یا همان طلا را برای شما خواهند داشت.
به روز رسانی دایرکتوری شما با مخزن
تغییراتی که شما روی کدها اعمال کردید و یا دیگران اعمال کردند. چطور شما و یا دیگران می توانند از آخرین تغییرات با خبر شوند. کافی است با دستور زیر به روز رسانی کنید.

mohammad@debian:~/work/mod1$ cvs update
cvs update: Updating .

با اینکار اطلاعات از روی server به رایانه شما انتقال پیدا می کند. شما و یا فرد دیگری می تواند از آخرین تغییرات با خبر شود. البته با این دستور هیچ اطلاعاتی از روی رایانه شما به server منتقل نمی شود. برای این کار باید از همان دستور CVS commit استفاده کنید. برای تمرین ٬ همانطور که جلوتر گفته شد. کد ساده ای را در فایل بنویسید و تغییرات را دو سمت client و server دنبال کنید. این متنی که خواندید تنها آشنایی با CVS بود. برای آشنایی بیشتر می توانید از کتابهای متعددی که در این زمینه وجود دارند و همینطور بهترین مرجع ٬ همان man فایلها استفاده کنید.

mohammad@debian:~/work/mod1$ man cvs

روی اینترنت می توانید از CVSHOME.ORG استفاده کنید. این برنامه بسیار قوی و سودمند است. اما شما باید دستورات و گزینه های زیاد آن را بلد باشید ! از روی آدرس http://www.wincvs.org به دنبال یک برنامه گرافیکی برای پلتفورم مورد استفاده خودتان بگردید. شاید برای استفاده شما نیازی به دستورات خط فرمان نباشد.
توجه: کدهای این برنامه روی توزیع دبیان سارژ امتحان شدند. برای نصب CVS کافی است آن را با دستور apt-get install cvs نصب کنید.

apt-get install cvs

ناشر: irantux.com
مترجم : محمد درویش
منبع: http://www.gnu.org/software/cvs/manual/html_mono/cvs.html

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 11 خردادماه 1384

07:17 PM

June 01, 2005

آیا XML جواب همه چیز است ؟

این مقاله سنجیدن امکانات و کمبودهای xml برای برنامه های مختلف است . مروری بر اینکه چرا بهترین راه حل برای بسیاری از برنامه نویسی ها و منتشر کردن متون است. در این روزها به هر موردی که توجه می کنید و در مورد آن مطالعه می کنید درباره XML (eXtensible Markup Language) صحبت می کنند. به انتشار اطلاعات توجه کنید٬ روی آن متمرکز شوید. XML به عنوان قابل حمل بودن جا افتاده است. در مورد ایجاد یک نرم افزار جدید با فردی صحبت کنید. برای ساماندهی بعضی اطلاعات و داده ها از XML استفاده می شود و نام آن را در لیست انجام کارها می بینید. از یک مدیر سایت سوال کنید: صفحات داینامیک خود را چگونه طراحی می کند؟ و یا اطلاعات آن صفحات را چگونه برای استفاده مجدد ذخیره می کند؟ کوتاه ترین جوابی که داده می شود ٬ XML است. XML راه حلی مناسب برای بسیاری از مشلات است. به نظر می رسد که در همه جا استفاده می شود. اما آیا این بهترین راه حل برای ذخیره تمام اطلاعات و داده ها است ؟ خیر.
امروزه وقتی به مطلبی توجه می کنید ٬ متوجه می شوید که درباره این زبان قابل حمل XML صحبت می کنند.
همه نیازی به XML برای انجام کارهایشان ندارند یا لزومی برای استفاده از آن نمی بینند. برای یک سازمان کوچک استفاده از طرحی مانند XML چندان هم به درد نمی خورد. یا بهتر بگویم استفاده از آن برایشان به نظر با صرفه نیست. بهترین راه حل برای تشخیص اینکه بدانیم این راه کار به درد شرکت یا سازمانی می خورد یا نه . بررسی اطلاعات و چرخه اطلاعات آن شرکت است . میزان تبادل و استفاده مجدد در جاهای مختلف و برآورد هزینه استفاده مجدد از اطلاعات در جاهای دیگر ٬ امتحانی است برای تشخیص لزوم استفاده از XML . عدم اطلاع آنها از وجود نرم افزار های آزاد که می تواند آنها را به راحتی در مسیر استفاده از این روش قرار دهد نیز می تواند نقشی در استفاده نشدن یا بی اطلاعی بیشتر افراد از XML باشد.

این XML چیست ؟
: XML - اگر معنای آن را به درستی برگردانم- یک زبان نشانه گذاری یا علامت دار است. که می توان به کمک آن زیانهای جدید و علامت داری را به وجود آورد. به طور معمول برای ساختن نشانه های جدید و پردازش ساختمان داده های یک متن ونحوه نمایش آن متن به کار می رود. اما می تواند برای شرح ٬ مدیریت و انتقال داده هایی متفاپت به کار گرفته شود. از جمله متون ٬ عکسها ٬ صدا ٬ فرم ها ٬ فایلهای چند رسانه ای و ... همچنین انتقال اطلاعات و تغییر آنها از یک نوع داده به یک نوع بانک اطلاعاتی دیگر هم استفاده می شود.
بر خلاف HTML که یک زبان برای نمایش اطلاعات در یک مرورگر است و کنترل نحوه نمایش داده ها را به عهده دارد. XML یک استاندارد باز می باشد. یک استاندارد پایه است که وابستگی به رسانه ها ٬ سیستم عاملها و دیگر سیستمها ندارد. قابل توسعه است به این دلیل که سازمانها یا افراد می توانند دستورهای خود - tag ها - را تعریف کنند که معنای خاص خودشان را دارند و این نامهای خاص خیلی بهتر از HTML هستند به دلیل اینکه می توان برای یک موضوع یک معنی از این دنیای بی انتها را در نظر گرفت و آنرا مشخص کرد. این کلمات خاص کاربر پسند تر هستند و یک مفهوم خاص را می رسانند. به عنوان مثال : نشانه <product< یک توضیح خوب برای رساندن یک مفهوم است تا نشانه >h2>

<product> Sample Product </product>

Sample Product

در دنیای پردازشگرهای کلمات فرمت یک داده ارزش بالایی دارد ٬ زمانی که فرمت عوض می شود روی مفاهیم هم تاثیر می گذارد. قدرت XML در توانایی جداسازی مفهوم از فرمت اطلاعات است. بنابراین خالق یک اثر می تواند بدون اتلاف وقت روی فرمت بندی اطلاعات روی یک موضوع کار کند. XML کنترل فرمت اطلاعات به وجود آمده ٬ را به عهده دارد. و مشخص می کند در هر محیط به چه صورتی باید به نمایش در آیند.
تفاوتهایی بین XML با HTML وجود دارند.که عبارتند از امکان پردازش یک متن به کمک یک برنامه نرم افزاری. همچنین استفاده های گوناگون از مفاهیم اطلاعات بدوت توجه به در نظر گرفتن ترتیب آنها. به کار بردن ترکیبی از این اطلاعات با هم و یا با اطلاعات دیگر که شما این امکانات را در HTML ندارید. XML امکان استفاده مجدد از محتوای داده را در یک جای دیگر امکان پذیر می کند. مانند توضیح و شرح یک محصول. در هر کجا که از این اطلاعات مربوط به محصول استفاده کرده باشیم . این امکان را به ما می دهد تا در صورت تغییر در آن محصول ٬ اطلاعات ما در جاهای دیگر هم - که از این روش ذخیره سازی داده ها استفاده کردند - نیاز به تغییر نداشته باشد. به طور خودکار این اطلاعات تغییر می کنند. با توجه به اینکه حالا شما این اطلاعات را در هر کجا و مکانی که استفاده کرده باشید. این قابلیت امکان استفاده مجدد از اطلاعات را فراهم می کند. شما می توانید با یک تغییر ٬ شاهد تغییر در کل کار باشید. این کار برای شرکت یا سازمان شما صرفه جویی در وقت که با ارزش ترین موجودی است و همچنین پول و سرمایه را به ارمغان می آورد. حتی می تواند در ترجمه متون و به روز کردن اطلاعات سایت شما بسیار مفید باشد.
محتوای XML می تواند یک راهنمای معتبر برای به رمز در آوردن یا کد کردن اطلاعات باشد . مانند تعریف یک فرمت خاص برای متون DTD و وارد کردن یک استادندارد به کارهای یک نویسنده است. امکان اعتبار سنجی و همچنین تنطیم محیط را دارد که برای تکمیل ٬ ترکیب ساختارها و دقت استفاده از اطلاعات ضروری است اگر به وجود آوردن یک موضوع پیچیده و مشکلات این مطلب شما را از این کار برحذر نکند. استفاده از آن را مفید و ارزشمند خواهید یافت.

اهداف W3C برای XML
بعد از گسترده شدن اینترنت در دنیا ٬ کاربران با موضوعی با نام صفحات HTML خوب و بد برخورد کردند. صفحاتی که اصلا به روز نمی شدند. در نتیجه W3C به این فکر افتاد که یک راه حل بهتر برای انتشار ٬ دسته بندی ٬ بازیافت و آرشیو داده ها پیدا کند. آنها یکسری اصول را مطرح کردند که این راه حل یا روش جدید باید از آن برخوردار باشد.چیزی بهتر از HTML که نتیجه طراح XML بود. اهداف طراحی XML که جدای از HTML بودند را می توانید از این آدرس www.w3c.com دریافت کنید.
باید به درستی قابل استفاده بر روی اینترنت باشد.
پشتیبانی وسیع از برنامه هایی وب
سازگاری با SGML
برنامه نویسی برای استفاده و پردازش XML باید ساده و راحت باشد
انتخابی دیگر به جز XML در آینده تا حد امکان کم و در بهترین حالت به صفر نزدیک باشد.
متون XML باید خوانا باشند و حتی شخص بتواند آنرا بخواند و تا حد امکان مرتب و منظم باشد.
طراحی آن بسیار سریع باشد
طراحی آن باید فرمت دار و مختصر و کوتاه باشد
متون XML باید به راحتی ساخته شوند
مختصر نبودن XML در درجه اهمیت پایینی قرار داشته باشد.
این مقاله روی دومین موردی که سازمان جهانی روی آن تاکیید دارد ٬ بحث می کند. چرا که XML می تواند در بسیاری از برنامه های کاربردی و وظیفه های نامحدود به کار گرفته شود. پتانسیل استفاده از XML غیر قابل اندازه گیری است. فضا نامحدود است پس ما هدفمان را روی انتشار اطلاعات به کمک XML محدود می کنیم..

کاربردهای XML
در حوزه انتشار ٬ XML توسط نویسندگان ٬ خالقان اثرهای متفاوت و برنامه های مدیریت محتوا استفاده می شود. پدید آورندگان از ابزارها و خواص XML برای تهیه متون خود استفاده می کنند. برنامه های مدیریت محتوا از ابزارها و خواص XML برای بازیابی و یا مشخص کردن داده هایی که بعدا بازیابی می شوند ٬ استفاده می کنند.
آیا این جواب تمامی موارد مورد نیاز را می دهد ؟ خوب ٬در دنیای انتشارات این جواب در بعضی مواقع منفی است. برای اینکه یک محصول منتشر شده می تواند بدون استفاده از XML با موفقیت منتشر شود. پس xml می تواند بلا استفاده باقی بماند. هرچند ٬ XML در اکثر مواقع بهترین گزینه برای سازمانها است. سازمانهایی که زمان چرخه یک موضوع را ارزیابی می کنند و هزینه ایجاد ٬ نگهداری ٬ ترجمه ٬ انتقال ٬ ذخیره سازی ٬ استفاده مجدد ٬ آرشیو و کنار گذاشتن آن را محاسبه می کنند. ZapThink در یک تحقیق متوجه شد که استفاده از مجدد از اطلاعات بزرگترین - گرانترین - کاری است که برای بیشتر سازمانها و شرکتها هزینه بر داشته است. این تخقیق نشان می دهد که مالکان اطلاعات در دنیای حرفه ای ۶۰ درصد از زمان خود را قرار دادن ٬ فرمت بندی و ساختار آن موضوع کرده اند و فقط ۴۰ درصد از زمان را واقعا صرف ایجاد آن کردند. ZapThink:(www.zapthink.com/report.html?id=ZTR-CL100)
واقعیت ناراحت کننده زمانی است که بیشتر ارگانها نمی دانند که چه مقدار زمان را صرف ایجاد یک مطلب کرده اند. مدیریت تلاش می کند آنها را قیمت گذاری کند پس نتیجه می گیرند که XML به درد آنها نمی خورد. اما واقعیت این است که تنها راه اینکه بدانیم XML به درد کارهای یک سازمان می خورد یا نه . بهره مند شدن از مشاوره ٬ کمک گرفتن از یک مدیر اطلاعات حرفه ای است . کسی که بتواند موارد مورد نیاز یک سازمان ٬ چرخه محتوای اطلاعات سازمان و کارهای جاری شما را بررسی و تجزیه و تحلیل کند. سروسهای مورد نیاز مشتریان در آینده ٬ برای مدیریت داده های شما را بررسی و مواردی را پیشنهاد کند . پیشنهاد ابزارهای کمکی و محاسبه برگشت سرمایه شما. بررسی موانع و شاخصها برای عوض کردن - ابزارهای کمکی ٬ پردازش ها و مردم - که نیاز به آدرس دهی دارند . قبل از اینکه شما XML را به عوان یک روش برای انتشار انتخاب کنید . زمانی که شما بدانید که این کار چه مقدار هزینه بردار است و در حین انجام کار با چه مشکلاتی روبرو می شوید. می توانید با آگاهی کامل از کل موضوع تصمیم بگیرید که آیا از XML برای انتشار اطلاعات استفاده کنید یا خیر .
امکانات زیادی توسط XML به وجود آمدند. مانند: ارائه لیست فهرست یک کتاب به دیگران. XML این امکان را به شما می دهد که یک لیست را آماده کنید و برعکس نرم افزاری مانند word که فقط می توان خروجی آن را به یک شکل برای دیگران ارسال کرد. این امکان وجود دارد که مشتری یا شرکت استفاده کننده از این فایل ٬ از اطلاعات استفاده کرده و آنها را به شکل و فرمت مخصوص خودشان در آورند. امکان استفاده در بانکها اطلاعاتی فراهم می شود. استفاده مجدد از این اطلاعات در آینده به راحتی امکان پذیر است . جدا بودن محتوا از فرمت اید داده ها امکان بسیار مناسبی است که توسط XML در اختیار شرکتها و سازمانها و غیره قرار می گیرد.
امکان دارد شما از XML برای ایجاد یک نوشته استفاد کنید و از همین فایل می توانید برای اضافه کردن به محتوا استفاده کنید. این محتوای اضافه شده می تواند با یک فرمت ظاهری دیگر نشان داده شود. علاوه بر این می توان اطلاعات را به شکل های گوناگون و در قسمتهای مشخص شده و جداگانه به نمایش در آورد. برای این کار می توانیم از تکنولوژیی به نام XSLT استفاده کنیم که در مورد آن بعدا صحبت می کنیم.

ابزار های آزاد برای استفاده از XML
نرم افزارهای کاربردی زیادی را می توانید از طریق اینترنت دریافت کنید که هر کدام نقاط قوت و ضعف خودشان را دارند و شاید همه امکانات در یک نرم افزار استفاده نشده باشد و این بستگی به کاربرد شما دارد که می خواهید از آن استفاده کنید.قبل از اینکه از یکی از این نرم افزارهای آزاد برای انجام کار استفاده کنید. از نرم افزارها استفاده کنید. توانایی هایی که برای تهیه و انتشار یک مطلب را به شما می دهند ٬ بررسی کنید. در نهایت بهترین نرم افزار برای کارتان را انتخاب کنید.

  • Altova Authentic (www.altova.com/products_doc.html)
  • XML Cooktop (www.xmlcooktop.com )
  • Open XML Editor (www.philo.de/xmledit)
  • Xray2 (www.architag.com/xray)

    تکنولوژیهایی که با XML در ارتباط هستند
    یک محقق در رابطه با XML , Jonathan Robi (http://www.gca.org/papers/xmleurope2001/papers/bio/s13-lauth2.hml) که در Software AG کار می کند. " XML کاری انجام نمی دهد ! " . این گفته هم درست است واقعا XML به تنهایی کاری نمی کند. نمی تواند متونی را که قرار است به روشهای گوناگون به نمایش در آیند را به وجود آورد. نمی تواند فرمت استفاده شده در تکنولوژی های جدید را به وجود آورد. برای اینکه بتوانم بگوییم XML برای کار ما مناسب است ٬ و یا اینکه تبدیل شود به محصول نهایی که در اختیار کاربر قرار می گیرد . احتیاج به برنامه هایی داریم تا بتوانند این فرمت نهایی را به وجود آورند.و از سوی دیگر نباید به همان فرمتی که بنا به دلایل متفاوت از آن فرار کردیم یعنی HTML در آید.

    XSL و XSLT
    در دنیای HTML چیزی به نام CSS فایلها یا Cascading Style Sheets برای نمایش اطلاعات یک صفحه بر روی مرورگر به شکل مناسب استفاده می شود. برای استفاده از محتوای XML با فرمتهای مختلف نیاز به برنامه های جانبی داریم به دلیل اینکه محتوا از فرمت جدا هستند و ما نیاز به فرمتهای گوناگون برای رسیدن به مقصود نیاز داریم. به روشهای مختلفی می توان فرمت دلخواه را به XML داد. می توان اطلاعات و محتوای فایل XML را به نرم افزار هایی که بر پایه XML کار می کنند ٬ وارد کرد. (حتی می توان از HTML هم برای نشان دادن محتوای XML استفاده کرد. ) قالب XML یا تغییر ظاهر آن توسط زبان XSLT مخفف Extensible Stylesheet Language, Transform انجام می شود. که می تواند XML را در قالبهای متقاوتی ارائه کنید. وقتی شما می خواهید محتوای خودتان را به فرمت ها و قالبهای گوناگونی عرضه کنید ٬ XML امکانات مناسب و قابل انعطاف تری را نسبت به HTML فراهم می کند.
    فرمت XSLT از دستوراتی که از متن XML استفاده نمی کنند بهره می برد و یک قالب خروجی برای آن درست می کند. مثلا دستوری مانند Bold را برای دستور <CompanyName< به کار برده و آن کلمه ای که برچسب دستور را دارند ٬ درشت تر نشان می دهد. این قلبها می توانند به منظور نشان دادن یک فاکتور فروش به کار روند و فرمتهای متنوعی را نشان دهند. مانند: فونت ٬ نوع قلم ٬ اندازه قلم و ... . نشان دادن اطلاعات در یک جدول مرتب شده به هر یک از دستوراتی که در فایل XML استفاده کردید. نرم افزارهای آزادی هستند که برای این کار استفاده می شوند . مانند Saxon ٬ Xalan و ... هر کدام از آنها اجازه تغییر در فرمت را به شما می دهند. بدون اینکه در آینده برای تغییر محتوای XML نیازی به نرم افزارهای کمکی داشته باشید.
    نرم افزار Saxon توسط Michael Kay نوشته شده که نسخه های متفاوتی از آن موجود هستند. یکی از این نسخه ها توانایی اجرا بر روی هر سیستمی که از ماشین مجازی جاوا (JRE) پشتیبانی می کند ٬ را دارد. این نرم افزار روی سایت آقای مایکل کی قرار دارد http://saxon.sourceforge.net ماشین مجازی جاوا JRE را هم می توانید از سایتهای متفاوتی بگیرید. http://www.java.com/en/download/windows_automatic.jsp پردازنده XSLT Xalan برای تبدیل فرمت XML به HTML استفاده می شود. متن ٬ محتواهای مختلف که توسط XML تهیه شدند. همچنین این برنامه برای وب سرور محبوب آپاچی Apache هم آماده شده است که روی سایت http://xml.apache.org/xalan-j قرار دارد.
    یکی دیگر از منابعی که می توان از آن استفاده کرد. برنامه ای است که در مجموعه نرم افزارهای آزاد Mitch Amiano قرار دارد. که آزادانه در اختیار کاربران قرار دارد. این CD از چند هزار نرم افزار تشکیل شده که اطلاعاتی در مورد منبع این نرم افزارها و اینکه آنها را از کجا می توان تهیه کرد هم موجود است. به این ترتیب می توان نسخه جدید آنها را از سایتها دریافت کرد. آقای Mitch یکی از افراد بزرگ جامعه نرم افزارهای آزاد است و وقت زیادی را برای جامعه نرم افزارهای آزاد صرف می کند. یکی از این کارها تهیه همین دیسک است. شما می توانید برای دریافت اطلاعات بیشتر از آدرس زیر استفاده کنید. =http://home.agilemarkup..com/index.php?option=content\&task=view\&id=55\&Itemid=29

    XSL-FO
    این XSL-FO یکی دیگر از زیرمجموعه های XSL است. FO هم برای تهیه قالب برای موضوعات استفاده می شود. بیشتر برای ارائه و نمایش XML در قالب های گوناگون است. اطلاعات بیشتر را می توانید از آدرس http://www.w3c.org/TR/xsl/ دریافت کنید.

    XQuery
    بسیاری از شرکتها اطلاعات خودشان را در یک بانک اطلاعاتی و یا یک فایل XML ذخیره می کنند. Xquery امکان پرس و جو در یک فایل XML را فراهم می کند. به همان سادگی که شما از SQL برای جستجوی یک فایل اکسس -ACCESS- استفاده می کنید. اطلاعات مناسبی را می توانید در آدرس زیر بدست آورید. http://www.datadirect.com/techzone/xml/basics/basics/index.ssp

    کارایی XML
    چگونه XML انتظارات w3c را برآورده می کند? ( www.w3c.com) مطمئنا تعداد زیادی از سایتها بر پایه XML درست شده اند. سایتهایی مانند: Safari , CNN , Fidelity , Wired , ... صفحات پویای آنها در پشت صحنه توسط XML آماده می شوند. در Fidelity مابین سیستم ها و اینترنت به وسیله XML صدها و هزاران تراکنش و عملیات انجام می شود تا بتواند به مشتریان سرویس دهی کند. همچنین این سایت میلیونها دلار در طراحی و ساختار خودش کسب کرده است. با توجه به نیاز این شرکت به تبادل اطلاعات با حجم بالا ما بین سایت و مشتریان ٬ این سایت از XML برای جداکردن اطلاعات شرکتها از یکدیگر استفاده کرده است . (http://www.internetweek.com/newslead01/lead080601.htm)
    در انتشار نوشته ها XML امکانات مفیدی را در اختیار برنامه نویس قرار می دهد تا اطلاعات ذخیره شده در یک بانک اطلاعاتی را به صورت متن به نمایش در آورد. تعدادی از برنامه های کاربردی امکان باز کردن فایل XML و فرمت آن را دارند و می توانند پاراگرافهای لازم به همراه قالب کلی متن را ایجاد کنند. این در دنیای چاپ و نشر الکترونیکی ٬ یعنی همه چیز. این برنامه های کمکی که اتوماتیک قالب یک صفحه را ایجاد می کنند. نشر اطلاعات را راحت و ممکن می سازند.

    هر چند اگر برنامه درست طراحی نشود XML از سرعت و قابلیت برنامه می کاهد. تحقیقات IBM نشان می دهد که نادرست بودن بانک های رابطه ای و اطلاعاتی کوچک ٬ سرعت پردازش را حدود ۱۰ بار کمتر می کند. نتایجی که از تحقیقات روی XML برای برای دست آوردن بهترین حالت انجام دادند ٬ نشان می دهد پتانسیل پردازش این فایلها ٬ انجام حجم بالایی از دستور العملها به کمک سخت افزار امکان پذیر است. شرکتهای تولید کننده سخت افزار به دنبال طراحی سخت افزارهایی هستند تا بتوانند این دستورالعملها را بهتر و سریعتر پردازش کنند. آنها به دنبال تراشه های فوق سریعی هستند تا بتوانند توانایی بیشتری را در اختیار XML قرار دهند که البته البته این نیاز به زمان دارد. nwfusion.com
    باز هم متذکر می شویم که شما نیاز به یک فرد برای مدیریت محتوای شرکت خود دارید. این فرد باید تجربه کافی در طراحی و اجرای روشهای گوناگون استفاده از XML را داشته باشد. XML یک راه حل اقتصادی است . فرد مورد نظر باید توانایی این را داشته باشد تا بعد از طراحی ٬ ترکیبی از نتایج تجزیه وتحلیل تجارت و کارهای شما با نیازهای مشتری را به دست آورد . پس از ارزیابی چرخه کاری شما نتایج را به صورت یک استراتژی واحد در یک سیستم XML و کاملا حرفه ای پیاده سازی کند. این سیستم باید قابلیت این را داشته باشد که اطلاعاتی در مورد نقاط قوت و ضعف تجارت و کار شما را مشخص و میزان برگشت سرمایه شما را اندازه گیری کند.
    استفاده از XML چندان هم شبیه به یک معجزه و یا اکسیر نیست. چیزی نیست که در همه جا از آن استفاده شود. اما استفاده از آن در بیشتر مواقع به نسبت بقیه روشها ترجیح داده می شود. به خصوص در انتشار متون و به طور کلی برنامه هایی که در این زمینه فعالیت می کنند و نیاز دارند که به روشهای گوناگون و اشکال مختلف متون را عرضه کنند. استفاده از XML به نسبت چیزی مانند HTML برای کارهایی که انحصاری و وابسته به حفظ اطلاعات نیستند بسیار مفید و ارزنده است. کیفیت و برتری XML در مقابل استفاده از HTML در این جا کاربرد دارد.

    نوشته : Kay Ethir و Scott Abel
    منبع : XML: the answer to everything?
    ترجمه : محمد درویش
    ناشر: irantux.com

    • لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
    تبليغات متنی

    گُماش
    گروه مشاوران ارتباطات و شبکه

    مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

    مشاوره،طراحی و اجرای شبکه داخلی و گسترده

    مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

    مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

    سفارش آگهی
    ICTNA در وبسايت شما
    با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
    برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
    بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 14 خردادماه 1384

07:13 PM

June 04, 2005

يك سيستم پرتال چيست و چگونه كار مى كند ؟

نويسنده: احمد پهلوان تفتى
ناشر: ITiran

عبارت پرتال به معنى درگاه و در مى باشد . در حقيقت وظيفه يك سايت پرتال جمع آورى اطلاعات از منابع مختلف و ايجاد يك درگاه واحد براى دسترسى به كتابخانه اى از اطلاعات و خدمات دسته بندى و اختصاصى شده مى باشد . پرتال ها با اين هدف ايجاد
مى شوند كه كاربران اينترنت بتوانند گردش خود را در اينترنت از طريق يك مدخل مدرن و ساختيافته شروع نموده و هر موقع كه اراده كنند بدون هيچ مشكلى به نقطه شروع بازگردند .
در يك دسته بندى كلى عملكرد ها و قابليتهاى اصلى يك سيستم پرتال عبارتند از :
- دسترسى به اطلاعات مورد نياز
- ارتباط با ديگر كاربران
- دسترسى به برنامه هاى كاربردى مجزا
- انجام امور روزمره كارى ، شهر ى ، ادارى و ...
بنابراين يك سايت پرتال بايد علاوه بر
قابليتهاى زير بنايى همچون امنيت ، سرعت ، و دقت ، سرويسهاى متععدى نيز در اختيار كاربران و مديران سايت قرار دهد . عمده اين سرويسها عبارتند از:
1- سرويس مديريت محتوا
2- سرويس پست الكترونيك
3- سرويس كنفرانس الكترونيكى
4- سرويس جستجو
5- سرويس عضويت در سايت
6- سرويس نظر سنجى
7- سرويس تكميل و ارسال فرم هاى الكترونيكى
8- سرويس پرداخت اينترنتى
9- سرويس خبر

بايد توجه داشت كه يك پرتال موفق تنها شامل مجموعه اى از منابع اطلاعاتى نيست بلكه تركيب درستى از سرويس هاى اصلى فوق الذكر است .

انواع پرتال :- پرتال هاى شركتى : Corporate Portal
دسترسى اختصاصى به اطلاعات خاصى از يك شركت يا
كمپانى خاص را فراهم مى كند .
- پرتال هاى تجارى : Commerce Portal
از مقوله تجارت الكترونيك پشتيبانى مى كند .
- پرتال هاى شهرى : City Portal
دسترسى به خدمات و اطلاعات يك شهر را ممكن مى
سازد .
- پرتال هاى فراگير : Pervasive Portal
دسترسى از طريق تجهيزات فراگير مثل PDA را ممكن مى
سازد .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 10 تیرماه 1384

12:04 PM

July 01, 2005

نقش‌های یک مدیر سیستم

نقش‌های یک مدیر سیستم

موفقیت یک سیستم کامپیوتری پایدار، امن و کارا تا حدود زیادی به مدیر سیستمی که نگهداری از آن را بر عهده دارد، بر می‌گردد. معمولا نگهداری، تنــظیم و بــروز رسانی سیستم بــرای حفظ آن در بهترین شرایط کاری، وظیفه چندان آسانی نیست.

شغــل مدیر سیستم می‌تواند عــلاوه بر مدیریت و نگهـداری از سیستم، پشتیبانی از کاربران نیز باشد. در زیر لیستی از وظایفی را که ممکن است بر عهده یک مدیر سیستم باشـد، مشــاهــده می‌نمایید. با دیدن این لیست می‌توانید سطح گسترده وظایف یک مدیر سیستم را بهتر درک کنید.

    روشن و خاموش کردن سیستم شما ممکن است دوست نــداشته باشیــد که هرکسی که دارای یک حساب کــاربری بر روی یک سیستم است، قادر به روشن و خاموش کردن آن باشــد. مخصــوصا وقتــی کامپیوتر مورد نظــر در حال ارائه خدمــاتی بــر روی شبــکه اســت که نیاز دارید تا همیشه قابل دسترسی باشند.

    حساب‌های کاربری ایجاد حساب‌های کاربری یکی از امور بسیــار پـایـه‌ای یـک مــدیــر سیــستم اسـت. بسیاری از شبکه‌ها دارای سیاست‌های خاصی برای حساب‌های کاربران خود هستند و مدیر سیستم باید اعمال‌گر این سیاست‌ها باشد. اعمــال حقــوق دستــرسی ناصحیح برای کاربران می‌تواند راه‌های نفوذ به سیستم را باز کرده و باعث سیاه شدن روزگارتان بعنوان یک مدیر سیستم شود.

    امنیت امن‌ترین سیستم‌ها سیستمی است که به جایی متصل نیســت و تنها یک کاربر با آن کار می‌کند! البته این کار عملی نیست. بنابراین باید حقوق دسترسی کاربران به گونه‌ای تنظیم گردد که دسترسی به منابع سیستمی همراه با کنترل و محدودیت امکانپذیر باشد.

    مانیتور کردن منابع سیستمی هر سیستمی نیاز دارد تا بطور دائم مانیتور شــود. ایــن کار ممکن است توسط اسکریپت‌ها و یا نرم‌افزارهای خاصی صورت گیرد تا در مواقع لازم مدیر سیستم بتوانــد بـا مداخله به موقع خود مانع از کار افتادن بخش یا بخشهایی از سیستم گردد. دیسک‌ها پر می‌شوند، پردازنــده‌ها درگیر پردازش‌های سنگین می‌شوند، سیستم‌ها Overload می‌شوند و این وظیفه مدیر سیستم است که آنــها را در حال کار نگاه دارد.

    خودکار سازی برخی وظایف این امــر وظیفه بسیار مـهـم و دشواری است. خودکار سازی ممکن است شامــل نوشتن اسکریپت‌های خاص و تنظیم نرم‌افزارهای کاربردی خاصی باشد تا بتوانند برخــی از امــور روزمره را بــر عهــده گرفـتـه و از ایـن طریق قابلیت اطمینان و پایداری سیستم را بالاتر ببرند. خودکار سازی می‌تواند اموری مانند پشتیبان گیـــری از سیـستم و تجزیه و تحلیل فایل‌های ثبت رخداد را بر عهده بگیرد و همچنین می‌تواند تا حد زیادی در وقت مدیر سیستــم صــرفه جویی نماید. با تهیه و نوشتن اسکریپت‌های مدیریتی خواهید توانست از تایپ تعداد زیادی دستور در طی روز خودداری کنید.

    پیکربندی سیستم تقریبا تمامی دایمن‌ها مانند سرویس‌های فایــل، چاپ، وب، پست‌الکترونیک، FTP و... قبل از عملیاتی شدن نیاز به تنظیم و پیکربندی دارند. بسیاری از ایــن نــرم‌افزارها نــیـاز بــه تنـظـیم حقوق دسترسی و تعریف کاربران خاص خود را دارا هستند. فایل‌های پیکربندی که برای انجام تنظیمات دایـمـن‌ها استفاده می‌شوند ممکن است شامل چند تا چند صد خط باشند.

    دیسک‌های سخت و فایل سیستم‌ها دیسک‌های سـخت و فایل سیستم‌ها دارای نقش بسیار مهم و پایه‌ای در عملکرد سیستم‌عامل هستند. هر گونه کاستی و نقــص در عملــکرد آنــها می‌توانــد باعـث افت عملکــرد یـا توقف کلی سیستم گردد. اقداماتی نظیر بررسی دائمی فضای دیسک و تعریف ســـهمیه‌های فضا (Disk Quota) جهت کاربــران می‌تواند باعـث جلوگیری از مصرف کل فضای موجود توسط کاربران خاص گردد.

    پشتیبان‌گیری و بازگرداندن نسخه‌های پشتیبان هیـچ چیزی نمی‌تواند مانند یک پشتیبان خوب هنگام از دست رفتن داده‌ها نجات بخش باشد. یک پشتیبان گیــری مناســب می‌تــوانــد باعــث صـرفه‌جویی‌های میلیونی در مواقع اشکال و از دست رفتن داده‌ها شود. این وظیفه که امکان خودکار کـــردن آن بـه سادگی امکان‌پذیر است، باید یکی از اولویت‌های اولیه هر مدیر سیستم باشد.

    سرویس‌های چاپ اداره هر نوع خدمات چاپی که بر روی شبکه قرار داشته باشد، دست مــدیر سیستم را می‌بوسد! از تنظیم و پیکربندی سرویس‌دهنده‌های چاپ گرفته تا اضافه کردن چاپگـــرهـا، تعـــویــض تونر وسایر امور مربوط به چاپ. برخی اوقات مدیران سیستم حتی باید کاغذ چاپگرها را نیز اداره کنند.

    مدیریت شبکه هنگامی که چند کامپیوتر دارید که به هم متصل بوده و باهم در ارتباط هستند، یـک شبکه دارید. بنابراین شخصی باید وجود داشته باشد که بر عملکرد این شبکه نظارت داشته و آنرا در بـالاترین حد کارایی خود نگاه دارد. وظایفی کــه یــک مــدیــر شبکه علاوه بر نظارت ممکن است بر عهده داشته باشد، می‌تواند شامل مواردی مانند دیوارهای آتش، مسیریـابی و اتصال به شبکه اینترنت باشد. این موارد وظایف کوچکی برای یک مدیر سیستم نیست.

    پست‌الکترونیک، وب، بانکهای اطلاعاتی و سایر خدمات هر ماشین سرویس‌دهنده‌ای می‌تواند عهده دار خدمات میزبانی صفحات وب، ارسال و دریافت نامه‌های الکتـــرونیــکی و یا مرکز ذخیره سازی بانک‌های اطلاعاتی باشد. مدیر سیستم باید از هرنظر بر ارائه خدمات اینچنینی نــیــز نظارت داشتــه و نگـــهـداری و پیکربندی‌های مرتبط با این نوع خدمات را انجام دهد.

بــا مرور این لیست، اکنــون دیــد بهتــری از گستـردگی سطح وظایف و مسئولیت‌های یک مدیر سیستم دارا هستید. در محیط‌هایی با چند صد کاربر و ده‌ها ایستگاه کاری و چندین سرویس‌دهنده مختلف، امر مدیریت سیستم بین چند نفر تقسیم می‌گردد.

PDF Version

آلن باغومیان alan@technotux.org

ناشر: http://irantux.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 10 تیرماه 1384

02:11 PM

July 01, 2005

شرکت بزرگی که به جنبش بازمتن پیوسـت

شایـد اولیــن چــیــزی کـه بـا شـنـیـدن نـــام شـرکـت Apple به ذهــن متبـادر شــــود مـحـصـولاتـی بـا کیـفــیـت بـالا امـا تـحـت شدیدترین محافظتها برای جلوگیری از کپی برداری رقیبان باشد.

امــا در این مــقــاله خواهید دید که اپل-که به ادعای خود اولین شرکت بزرگی است که به جنبش بازمتن ملحق شده- از سالها پیش پروژه‌های مهم و مفید بازمتن داشته است.

اولین پروژه بازمتن اپل

سایت اپــل و بسیاری سایتـهای دیگر اولین پروژه بازمتن اپل را Darwin که در سـال ۱۹۹۹ منتشـر شـد[ ۱ ] می‌دانـند. اما حقیقت مــاجــرا چیــز دیگری است، اولین پروژه بازمتن اپل MKLinux -توزیع لینوکس اپل که مقدمه‌ای بر انتقال توزیعها به پلتفورم مکینتاش شد[ ۲ ]- بود. ایــن پروژه در ادامه تلاشهای اپل برای ساخت سیستم عامل جدید و انقلابی برای رقابت بــا ویندوز مایکروسافت بــود. شکست پروژه‌های قبــلی باعــث شد تــا اپـل تصمیم به خرید شرکت NeXT و بهره بردن از سیستم عامل و API هایOpenSTEP بگــیـرد[ ۳ ]. کــم کم اپل بخشی از تجربیات این پروژه را هم برای ساخت سیستم عامل بعدی خود Rhapsody -که بر مبنای OpenSTEP قرار داشت- استفاده کرد[ ۴ ] و ادامه توسعه آن را به جامعه بازمتن سپرد. پس از توقف Rhapsody اپل در سال ۹۹ اعلام کرد که قصد کار بر روی [ ۵ ] Mac OS X دارد که بر مبنای Rhapsody قرار داشت، اما با یـــک تفاوت مــهــم، کــاربران و توسعه دهندگان کدهای بسیاری از بخشهای آن را ۲ سال قبل از ارایه رسمــی بـــرای هــردوی PowerPC و x86 در اختــیـار داشتند. هدف پروژه Darwin آشنایی علاقه‌مندان با نسخه بعدی و همچنین بهره بردن از ویژگی‌های پروژه‌های بازمتن بود، اما بـــرای انتشار این پروژه اپل باید یا از مجوزهای موجود یکی را بر می‌گزید یا خودش مجوز جدیدی می‌نوشت.

مجوز آزاد اپل

اپل راه دوم را انتخاب کرد و مجوز APSL را منتشر کرد.[ ۶ ] (APSL(Apple Public Source License اولین بـار در سال ۱۹۹۹ بــرای انتشار کـــدهای Darwin کـــه پـایه و بنیان Mac OS X است منتشر شد. اولین نسخه این مجوز با موافقت (Open Source Initiative(OSI مواجه شد اما در همان زمان ریچارد استالمن –بنیانگزار بنیاد نرم افزار آزاد (FSF) - به بررسی این مجوز پرداخت و اعــلام کــرد ایــن مـــجوز یک مجوز نرم افزاری «آزاد» نیست. مدتی بعد نسخه‌های دیگری از این مجوز با تغییراتی منتشر شدند، ولی سرانجام در ۳۰ جولای ۲۰۰۳ نسخه ۲ مجوز APSL منتشر شد که در معرفی آن از نظرات ریچارد استالمن تشکر شده بــود و مــوفق شده بود گواهی مبنی بر «مجوز نرم افزاری آزاد» بودن ازFSF دریافت کند.[ ۷ ] این مجوز حاصــل بــررســی و تحقیق اپل بر روی مجوزهای GPL,BSD,NPL,MPL,SCSL و مجوز Apache است که توانسته علاوه بر اصول OSI بر اصول FSF نیز پایبند باشد. گــرچــه بنــیاد نرم افزار آزاد هـنوز این مجوز را برای آغاز پروژه‌های جدید کــاملا مناسب نمی‌دانــد ولــی کــار بــر روی پــروژه‌های فعلی را مناسـب تشخیص داده است. به هر صورت APSL برای استفاده داخلی توسط اپل نگارش یافته و اگــر دقیقا مطــابق نظـرات بنیاد نرم افزار آزاد بود دیگر تفاوتی بین APSL و GPL وجود نداشت!

Darwin - معروفترین پروژه آزاد اپل

ایـن پروژه که از سال ۱۹۹۹ آغاز شد پایه و اساس نسخه بعدی سیستم عامل مکینتاش قرار گرفت. Darwin مجموعه‌ای از بسته‌های بازمتن و آزاد است کــه توسط اپــل یــا جامعه بازمتن منتشر شده‌اند. از XNU (که از FreeBSD و میکروکرنل Mach بهره می‌برد) که هسته این مجموعه است گــرفــته تـا راه اندازهای اپل، کامپایلر GCC و بسته‌های کوچک و بزرگ دیگر. اپل از Darwin به عنوان درون مایه Mac OS X نام برده است که این درون مایه از رابط گرافیکی و برخی از ویژگیهای غیر آزاد Mac OS X محروم است. اکثر بسته‌های Darwin تحت مجــوز APSL2 و بقیه تـحـت مجوزهایی مانند GPL و BSD منتشر شده‌اند. پس از ارائه هر بروزرسانی Mac OS X نسخه جدید Darwin هم مطابق با آن منتشـــر می‌شـــود. بـــه عنوان مثال Mac OS X 10.3.8 مطابـق با Darwin 7.8 و Mac OS X 10.4 مطابق با Darwin8 می‌باشد. نکته جالب توجــه درمورد Darwin ارائه همزمان آن بر روی PowerPC و x86 می‌باشد کــه این ویژگی هم به توسعه آن کمک کرده و هم راه مهاجرت اپل به x86 در آینده را هموارتر می‌کند.

در آوریل ۲۰۰۲ اپل با همکـــاری (ISC (Internet Systems Consortium ، بــه منظور سرپرستــی جامعه توسعه دهندگان OpenDarwin.Org ،Darwin را تاسیس کــرد. OpenDarwin.Org خـــود زیـــر مجموعه‌هایی ماننـــد توزیع OpenDarwin و DarwinPorts دارد. تـــوزیــع OpenDarwin هرچنـــد وقت یکبـار بر طبق نسخه‌ای از Darwin منتشر شده و DarwinPorts هدفش انتقال نرم افزارهای مهم بازمتن به Darwin و Mac OS X می‌باشد.

مهمترین مانعی که Darwin را از یک سیستم عـــامل قابل استفاده روزانــه جـــدا می‌کنــد نداشتن رابط کاربر و بسیاری بسته‌های کاربردی مهم مورد نیاز روزانه می‌باشد.امـــا هـدف Darwin تنها پایه و بنیانی برای سیستم عامل اصلی مانند Mac OS X است، پس برای استـــفـاده بهتر از آن نیاز به قرار دادن بسته‌های مهم و توزیع مجدد آن (همانطور که در مورد لینوکس صورت می‌گیرد) می‌باشد. پس بـا استفاده از Darwin هم می‌توان سیستم عاملی کاربردی و کاملا آزاد داشت. با همین هدف پـــروژه GNU-Darwin در نوامبـــر ۲۰۰۰ آغاز شد.[ ۸ ] ایـن پروژه از x11 تا Gnome، از Mozilla Firefox تا هر بسته مهم دیگری را با Darwin هماهنگ کـــرده و تـحت توزیعی با نام GNU-Darwin منتشر می‌کند که هم کاربردی تر و هم نصبش آسانتر است.

گفتنی است نشان غیر رسمــی Darwin یــک Platypus (پستــاندار آبــزی و منقاردار و صـــدفخـوار جنوب استرالیا) با نام Hexley است که ار بسیاری جهات با نشان FreeBSD شباهت دارد.[ ۹ ]

Darwin Streaming Server - متفاوتترین پروژه آزاد اپل

پـــس از معـــرفــی Darwin نوبت به معرفی یکـــی دیـگر از پروژه‌های مهم بازمتن اپل به نام Darwin Streaming Server می‌رسد.[ ۱۰ ]

این پروژه امکان Stream کردن صوت و تصویر از طــــریق پروتکلـــهای استاندارد RTP و RSTP را بـرای شما فراهم می‌کند. کـــدهـــای پایه (Darwin Streaming Server(DSS با (QuickTime Streaming Server(QTSS یکی است و در حقیقت این پروژه برای توسعه دهندگانی است کـــه قصد دارند با استـــفاده از ایـــن تکنـــولوژی با سفارشی سازی بیشتر و بر روی پلتفورمهایی غیـــر از Mac OS X Server مانند ویندوز، سولاریس و لینوکس رسانه‌های QuickTime و MPEG-4 را stream کنند.

DSS یک پروژه بازمتــن است و پشتیبانی از آن تنها توسط جامعه ی بازمتن و لیستهای پستی که اپل فراهم آورده است صورت می‌گیرید ، در صــــورتی که به نسخه تـــجـــــاری و دارای پشتیبانی اپل نیاز دارید QuickTime Streaming Server مناسب شما است.

QTSS که بخشی از Mac OS X Server اســت نسبـت به DSS از ابزارهای تنظیمات و مدیریت حرفه‌ای برخوردار است که بازمتن نیستند. اما DSS همانند QTSS کامل و قابل استفاده است و از قابلیتـهای جالب Skip protection و Instant-on و آخرین استانداردهای دیجیتالی مانند MPEG-4 و 3GPP پشتیبانی می‌کند.

Bonjour - محبوبترین پروژه آزاد اپل

Bonjour نام جدید Rendezvous است کـه همزمان با ارائه Mac OS X 10.2 معرفی شد.[ ۱۱ ] این تکنولوژی شبکه سازی انقلابی امکان ساخت شبکه‌ای فوری از کـــامپیوتــرها و دستگاه‌ها بـــدون نیاز به هیچگونه پیکربندی را برای شما ممکن می‌سازد.

این تکنولوژی امکان ثبت سرویسها و قابلیتهای هر دستگاهی در شبــکه را می‌دهد تا این سرویسها توسط دستگاه‌های دیگر موجود در شبکه به صورت پویا قابل دستیابی باشند. به عبارت دیــگر Bonjour امکان دستیابی دستگاه‌ها به یکدیگر را بدون نیاز به وارد کردن آدرس IP و پیکربــنـدی سرویس دهنده‌های DNS ، از طریق پروتکل استاندارد IP فراهم می‌کند.

برای میسر شدن عدم نیاز به پیکبربندی، Bonjour نیازمند انجام 3 مورد ضروری توسط دستگاه‌هاست.

این دستگاه‌ها باید بتوانند:

- آدرسهای IP را بدون یک سرویس دهنده DHCP معین کنند.

- آدرسهای IP و نامها را بدون یک سرویس دهنده DNS تفسیر کنند.

- سرویسها را بدون استفاده از یک سرویس دهنده directory مستقر سازند.

این تکنولوژی که همچنین بسیار مورد توجه سازندگان مشهـــور چاپــــگر و دوربیــن قـرار گرفت دردسرهای شبکه سازی استاندارد را برای کاربران مکینتاش از بــیــن بـــرد و به امتیازی مهم برای برتری مکینتاش نسبت به سایر پلتفورمها تبدیل شد. اما اینبار اپـــل بر خلاف انتظار عمـــوم ایــــن تکنولوژی را انحصاری نکرد، بلکه آن را با مجوز آزاد APSL برای لینوکس، ویندوز، VxWorks و... منتشر کرد. گفتنـــی اســــت در نســخه‌های جدید KDE و Gnome نسخه‌ای از این تکنولوژی مورد استفاده قرار گرفته است.

Webkit - چارچوب آزاد وب

مایکروسافت و اپــل قراردادی بـــرای همکاری بستند که یکی از بندهای آن قرار دادن Internet Explorer همراه سیستم عامل مکینتاش بود. مدتی گذشت و مایکروسافت به قـولهایش وفا نکرد، مدت قرارداد به پایان رسید و حال اپل مصمم به جبران کم‌کاری‌های مایکروسافت بود. مـــرورگر Safari و مجموعه iWork را می‌توان در همین راستا حساب کرد. اپل برای ساختن مرورگری سریع و در عین حال سبک نیازمند مــوتــورهای HTML و JavaScript بود ولی نه زمان کافی برای اینکار داشت و نه عـــاقلانه بـود که در حقیقت چرخ را دوباره اختراع کند. تصمیم نهایی گرفته شد و موتورهای KHTML و KJS از پروژه KDE پایه کار مرورگر Safari قرار گرفتند. اپـل موتور HTML راWebCore و موتور Javascript را JavaScriptCore نامید.[ ۱۲ ]

اپل بر طبق شرایط مجوز قبلی هردو را تحت پـروانه LGPL منتشر کرد و با توضیحات مختصری در بخش بازمتن سایت خود قـــرار داد. این انتخاب اپل بـــرای تیــم KDE هم مفید بود چـــون به نتیجه تلاششان اعتــبار بسیاری داده بود. اپل و KDE همکاری نزدیکی داشتند، KDE 3.2 بــــا patch های Safari 1.x منتشر شد و مسئــولان پروژه از رابطه خوبشان با اپل در مصاحبه‌ها با خشنودی صحبت می‌کردند. کـم کـم اپـل باـ تغییرات بسیــاری در WebCore آن را با استانداردهای بیشتری سازگار کرد و در حقیقت روش توسعه آن را دگـرگون ساخت. اما تیم KDE به خاطر شیوه‌های متفاوت توسعه در استفاده از patch ها دچار مشکـل می‌شد و این در حالی بود که افکار عمومی انتظار سازگاری صفحات و استانداردهای Safari را در Konqueror داشتند. وضع کم کم از این هم خـرابتر شد. اپل بر طبق شیوه معمول توسعه نرم افزارهایش تغییرات را با Radar و سپس شماره مربوطه مشخص می‌کرد و کسی نمی دانست Radar فلان شماره چه ایرادی را برطرف می‌کند. وضعیت به همین شکل ادامه داشت که WebStandards یک آزمـــون جـــدیــد بـــرای بررســـی ســـازگــاری مرورگر‌ها با استانداردها آماده کرد.[ ۱۳ ] David Hyatt از توســـعه دهندگان Safari کـــار بــر روی این آزمون را آغاز و نتیجه تلاشهایش برای پاس کردن آن توسـط Safari را در وبلاگش[ ۱۴ ] منتشر می‌کرد. سرانجام Safari اولین مرورگری شد که این آزمون را پاس کرد و Hyatt نتیجه تلاشـــش را بــه صورت متن patch منتشر کرد. پس از اعلام این خبر تمام نگاهها به سوی پروژه KDE چرخید که با نسخه جدید KHTML مرورگر Konqueror را هــــم از این آزمون سربلند بیرون آورد. ظاهرا کاربران علاقه مند توسعه دهنده‌های KDE را با ایمیلهایشان کـه خواستار رخ دادن هرچه سریعتر این اتفاق بودند حسابی کلافه کردند! ناگهان تعدادی از توسعه دهنده‌های KDE در وبلاگشان از مشکلات فعلی گله کردند و برخی حتی تا حد این ادعا که اپل از ما سوءاستفاده کرده است پیش رفتند. Hyatt که از وضعیت مـــوجود ناراحت بود در وبلاگ خود با توضیح بیشتر درمورد patch هایش دلیل عدم سازگـــاری آنـــها بـا KHTML را توضیح داد و در ادامه گفت «به نظر شما اپل چه کار بهتری برای وضع موجود می‌تواند انجام دهد؟ من تمام نظرات را می‌خوانم.»

در چنین وضعیتی انتظار هرچیزی می‌رفت غیر از مطلب CNet کــه در آن با بزرگنمایی اظهارات شخصی توسعه دهندگان KDE و تعبیر جملات Hyatt به اینکه «شما از WebCore استفاده کنید» جنجـــالی حسابـی درست کرد.[ ۱۵ ] درگیری بالا گرفت و نوچــــه‌های KDE و اپل در بخش نظــــرات وبلاگها بــــه جــان هم افتاده بودند! اوضاع از این هم خرابتر شد، Ben Goodger در وبلاگ خود[ ۱۶ ] موتور WebCore را از KHTML بهتر دانست و بــه تیم KDE توصیه کرد کار خود را بر مبنای آن قرار دهند. حال نوبت ZDNet Australia بود کـه بنویســــد:« Lead engineer مرورگر Firefox جانب اپل را گرفت!».[ ۱۷ ] از این پس نوچه‌های KDE وبلاگ Goodger را هم مورد لطف قرار می‌دادند.

این وضعیت مدتـــی ادامه داشت تــــا اینکه کنفرانس WWDC آغاز شد. در حاشیه خبرهای جنجالی، خبر متفاوتی قابل مشاهده بود. Hyatt در وبلاگ خود نوشت:«به WebKit سلام کنید!». اپـــل Webkit کــــه چـارچوب(Framework) مرورگر Safari ، برنـــامه Mail و Dashboard و در حقیقت چارچوب وب برای برنامه‌های Mac OS X است و با Objective-C نوشته شده است را آزاد کرد و این درحالی بود که کسی نـــه انتظار آن را داشت نه مجوزی مجبورش می‌کرد. در کنار پروژه آزاد WebKit سایت و خدمات جدیدی هم فراهــم شد که WebCore و JavaScriptCore را هم پوشش می‌دهد. در این سایت جدید بر جامعه بازمتن تاکیـــد بسیــاری شده است و برای تشویق افراد CVS, Mailing List,IRC,wiki و هرچیزی که برای توسعه بهتر و فراگیرتر WebKit لازم باشد در دسترس قرار گذاشته شده است.[ ۱۸ ]

در این سایت پروژه‌های بسیاری به چشم می‌خورد کــــه از جمـــله آنــهــا افـــزایش ســازگــاری بــا صفحات وب، افزودن استانداردهای جدید و بازنویسی WebKit با ++C برای افزایش قابلیت انتقال بین پلتفورمها می‌باشد.

دیگر جای گله و شکایتی بــرای توسعه دهندگان KDE باقــــی نــمانده اســــت. این اقدام اپل علاوه بر تسریع توسعه به پروژه‌هایی مانند GTK+WebCore که نسخه انتقال یافته WebCore با +GTK است[ ۱۹ ] نیز کمک بسیاری می‌کند.

سایر پروژه‌های آزاد اپل

اینها قطعا تنها پروژه‌های آزاد اپل نیستند. از برنامه‌های دارای رابـــط کـــاربـــر ماننـــد نسـخه انتقال یافته XFree86 با نام X11.app و بازی شطرنج 3بعدی Chess.app گرفتــه تــــا OpenPlay و (BLAST(Basic Local Alignment Search Tool و بسیاری پروژه‌های آزاد دیگر در سایت اپل قابل مشاهده هستند.[ ۲۰ ]

متاسفانه برای این شماره هم مقاله کمی طولانی شده و هم فرصت کافی بــــرای معــرفی بیشتر این پروژه‌ها (و پروژه هایی که توضیح مختصر داده ام) نیســت. امیـــدوارم در آینده بــــا جـزئیات بیشتر درباره تمام این پروژه‌ها مطالبی داشته باشیم. البته اگر کسی مشتاق خواندنشان باشد.

PDF Version

علی رستگار rastegar@gmail.com

ناشر: http://irantux.com

[۱] http://developer.apple.com/documentation/Darwin/index.html

[۲] http://mklinux.org/

[۳] http://en.wikipedia.org/wiki/NeXT

[۴] http://en.wikipedia.org/wiki/Rhapsody_(OS)

[۵] http://en.wikipedia.org/wiki/Mac_OS_X

[۶] http://www.opensource.apple.com/apsl/

[۷] http://www.gnu.org/philosophy/apsl.html

[۸] http://www.gnu-darwin.org/

[۹] http://www.hexley.com/

[۱۰] http://developer.apple.com/darwin/projects/streaming/

[۱۱] http://developer.apple.com/networking/bonjour/

[۱۲] http://developer.apple.com/darwin/projects/webcore/index.html

[۱۳] http://webstandards.org/act/acid2/

[۱۴] http://weblogs.mozillazine.org/hyatt/

[۱۵] http://news.com.com/Open-source+divorce+for+Apples+Safari/2100-1032_3-5703819.html?tag=nefd.lede

[۱۶] http://weblogs.mozillazine.org/ben/

[۱۷] http://www.zdnet.com.au/news/software/0,2000061733,39191656,00.htm

[۱۸] http://webkit.opendarwin.org/index.html

[۱۹] http://gtk-webcore.sourceforge.net/

[۲۰] http://developer.apple.com/darwin/projects/

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 10 تیرماه 1384

02:12 PM

July 01, 2005

ترجمه فارسی پروانه BSD

[این یـک ترجمه غیـر رسمـی از پروانـــه BSD است و ممــکن است اشکالاتی در شــکل یــا محتوای ترجمه وجود داشته باشد. قــصد متــرجم از ترجــمه پـروانه، آشنایی فارسی زبانانــی است که توانایی خواندن مـتــن اصــلی پروانـه بـه زبان انگلیسی را ندارند و استفاده از این ترجمه برای مقاصد دیگر را توصیه نمی‌کند.]

متــن زیــر الگــوی پــروانه BSD است. برای ایجاد پروانه خود، مقادیر مالک، سازمان و سال را از مقدار اصلی خودشان که اینجا ارائه شده با مقادیر خودتان عوض کنید.

تــذکــر: شــرط اعــلان آمـده در پروانه فایلهای یونیکس BSD در ۲۲ جولای ۱۹۹۹ توسط رئیس اداره پروانه‌دهی تکنولوژیک دانشگاه کالیفرنیا لغو شد.

توجه کنید که پروانه تازه BSD بدینسان مترادف پروانه MIT است به غیر از ماده آخر بدون موافقت.

<مالک> = نماینده دانشگاه کالیفرنیا
<سازمان> = دانشگاه کالیفرنیا، برکلی
<سال> = ۱۹۹۸

در پـروانه اصلی BSD هر دو مورد عبارت «دارنده حق طبع و شرکت کننده» در رفع مسئولیت به عنوان «نماینده و شرکت کننده» تعبیر می‌شود.

این الگوی پروانه است:

کپی‌رایت (c) <سال>، <مالک>
تمام حقوق محفوظ است.

بازتوزیع و استفاده از متن کد و حالت باینری، با یا بدون تغییر با فراهم کردن شرایط زیر مجاز است:

- بازتــوزیع متن کد باید اخطار حق طبع بالا، فهرست این شروط و [متن] رفع مسئولیت زیر را در مستندات و/یا سایر مواد توزیع، همراه داشته باشد.

- بازتوزیع حــالت باینری باید اخطار حق طبع بالا، فهرست این شروط و [متن] رفع مسئولیت زیر را در مستندات و/یا سایر مواد توزیع، همراه داشته باشد.

- نه نام <سازمان> و نه نــام شــرکت کنـندگان [در توسعه] آن بدون مجوز ویژه نوشته شده از پیش، قابل استفاده برای صحه گذاردن یا ترویج محصولات مشتق شده از این نرم‌افزار نیست.

ایــن نرم‌افزار بوسیله دارنـــدگان حق طبع و شرکـــت کنندگان بشـکل «آنچه هست» تهیه شده و هر گونه تعهد صریح یا ضمنی، بعلاوه تعهد ضمنی داد و ستد اما نه محدود به آن و آماده سازی به منظوری ویژه انکار می‌شود. در هر شرایطی دارنده حق طبع یا شـرکت کننده نمی‌بایست مسئول هیچ آسیب مستقیم، غیرمستقیم، ضمنی، استثنایی، تقلید شده یا منتـــج شــده‌ای باشند (بعلاوه بدست آوردن جانشینی برای کالا یا خدمات، از دست دادن کاربری یا داده‌ها یا سود؛ یا وقفه تجاری، اما نه محدود به اینها) هــــر چنـــد مسبـــب آن باشـد و بر اساس هر نگره‌ای از مسئولیت، خواه در قرارداد، مسئولیت اکید یا شبه جرم (بعلاوه اهمال یا غیر آن) ناشی از هر روشی جدای کــاربـــرد ایــن نرم‌افزار، حتی اگر احتمال چنین خسارتی گوشزد شده باشد.

PDF Version

مترجم: بهنام بهجت مرندی blixbox@gmail.com

ناشر: http://irantux.com

منبع:

http://www.opensource.org/licenses/bsd-license.php

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 11 تیرماه 1384

06:48 PM

July 02, 2005

آشنائى با گواهينامه هاى وب سايت

سخاروش - اينترنت فرصت حضور در عرصه هاى جهانى را براى تمامى علاقه مندان فراهم نموده است و به همين دليل است که امروزه ما شاهد ميليون ها سايت و يا وبلاگ در اين عرصه مى باشيم . بديهى است که از شرايط موجود صرفا" در جهت اهداف مثبت استفاده نگردد و افراد سودجو نيز اينترنت را مکانى براى شکوفائى پتانسيل هاى منفى خود بدانند و به نوعى بر روى آن سرمايه گذارى نمايند .

ايجاد سايت هائى با ظاهرى موجه و ترغيب کاربران براى مشاهده اين گونه سايت ها، يکى از متداولترين روش هاى به دام انداختن و در نهايت سرقت اطلاعات شخصى کاربران است . به نظر مى بايست سايت هائى که درخواست اطلاعات شخصى خاصى نظير شماره کارت اعتبارى و مواردى ديگر از اين نوع را از کاربران مى نمايند ، شناسائى و داراى يک شناسنامه معتبر و مورد اعتماد باشند و به قول معروف جواز انجام اين نوع فعاليت ها را از يک مرکز مطمئن و مورد اعتماد گرفته باشند .

گواهينامه هاى وب سايت ، تلاش ى است در جهت تائيد يک وب سايت و اين که سايت مورد نظر داراى هويتى کاملا" شناخته شده و تائيد شده است . آشنائى با اين نوع گواهينامه ها مى تواند کاربران را در جهت حفاظت از حريم خصوصى يارى نمايد .

گواهينامه هاى وب سايت چيست ؟
در صورتى که يک سازمان تمايل به داشتن يک وب سايت ايمن را داشته باشد که در آن براى دريافت و يا ارسال اطلاعات از رمزنگارى استفاده گردد ، مى بايست اقدام به دريافت يک گواهينامه سايت و يا ميزبان نمايد . شايد اين سوال براى شما مطرح شده باشد که چگونه مى توان تشخيص داد که يک سايت از رمزنگارى استفاده مى نمايد ؟ بدين منظور مى توان به Status bar پنجره مرورگر خود توجه نمود ، در صورتى که يک آيکون شبيه يک قفل بسته يا همان padlock نمايش داده شود ، به منزله استفاده از رمزنگارى توسط وب سايت مورد نظر است . يکى ديگر از روش هاى موجود به منظور تشخيص استفاده از رمزنگارى در يک سايت ، مشاهده بخش آدرس برنامه مرورگر است .

در چنين مواردى از پروتکل https در مقابل http استفاده مى گردد . با حصول اطمينان از اين موضوع که يک وب سايت اطلاعات شما را رمز و ارسال مى نمايد و همچنين داراى يک گواهينامه معتبر است ، يک سطح حفاظتى مناسب در مقابل مهاجمانى که با ايجاد وب سايت هاى مخرب قصد سرقت اطلاعات شخصى شما را دارند ، ايجاد مى گردد.همواره مى بايست قبل از ارسال هرگونه اطلاعات شخصى، نسبت به مقصد ارسال اطلاعات اطمينان ايجاد گردد .

در صورتى که يک وب سايت داراى يک گواهينامه معتبر باشد ، اين بدان معنى است که يک مرکز معتبر صدور گواهينامه قبلا" تمامى مراحل لازم به منظور شناسائى و تائيد هويت سايت را انجام داده است . زمانى که شما يک url را در بخش آدرس برنامه مرورگر خود تايپ مى نمائيد و يا لينکى را دنبال مى نمائيد که شما را به يک وب سايت ايمن هدايت مى نمايد ، مرورگر ويژگى هاى خاصى را در گواهينامه بررسى مى نمايد :

آيا آدرس سايت با آدرس موجود در گواهينامه مطابقت مى نمايد؟

آيا گواهينامه توسط يکى از مراکز مجاز که مرورگر قادر به تشخيص آنان به عنوان يک مرکز معتبر و مورد اعتماد مى باشد ، صادر شده است ؟

آيا مى توان به يک گواهينامه اعتماد نمود ؟

محتويات و ماهيت گواهينامه صادر شده براى يک وب سايت ، سطح اعتماد به سازمان و مرکز صدور گواهينامه را مشخص نموده و اين که تا چه ميزان مى توان به آن اعتماد نمود ؟ مثلا" در صورت مطابقت آدرس وب با آدرس گواهينامه ، صدور گواهينامه توسط يک مرکز معتبر مشخص مى گردد و يا در صورتى که گواهينامه صادر شده داراى تاريخ اعتبار لازم باشد ، نشاندهنده اين موضوع است که سايتى را که قصد مشاهده آن را داريد ، همان سايتى است که مى بايست باشد . در صورتى که به گواهينامه صادر شده اعتماد نگردد ، مى بايست از مکانيزم هائى ديگر براى بررسى هويت گواهينامه صادر شده استفاده نمود (مثلا" ارتباط مستقيم با سازمان ) .
با اطمينان به اعتبار يک گواهينامه به نوعى شما مرکز صدور گواهينامه را که اين بررسى را براى شما انجام داده است نيز تائيد مى نمائيد .

برنامه مرورگر شما به صورت پيش فرض داراى ليستى بالغ بر يکصد مرکز صدور گواهينامه معتبر و تائيد شده مى باشد . اين بدان معنى است که شما صلاحيت يکصد مرکز فوق را به منظور بررسى هويت و اعتبار گواهينامه ها ، پذيرفته ايد . قبل از ارسال اطلاعات شخصى مى بايست وضعيت گواهينامه را بررسى نمود .

چگونه مى توان يک گواهينامه را بررسى نمود ؟
به منظور بررسى گواهينامه يک وب سايت در برنامه هاى مرورگر IE و يا Mozila مى توان از دو روش متفاوت استفاده نمود :

کليک بر روى padlock موجود در status bar پنجره برنامه مرورگر

استفاده از ويژگى certificate در منوى Options

در ادامه ، اطلاعات متنوعى در خصوص گواهينامه نمايش داده مى شود :

چه کسى گواهينامه را صادر نموده است ؟ آيا گواهينامه توسط يک مرکز معتبر و مورد اطمينان صادر شده است ؟ ( در اين رابطه ممکن است با اسامى متفاوتى نظير VerSign,thawte و يا Entrust برخورد نمائيد ) . برخى سازمان ها ممکن است داراى مراکز صدور گواهينامه مختص به خود باشند که از آنان به منظور صدور گواهينامه براى سايت هاى داخلى نظير اينترانت استفاده مى گردد .

گواهنيامه صادر شده متعلق به چه کسى است ؟ گواهينامه مى بايست براى سازمانى که داراى وب سايت مربوطه است ، صادر شده باشد . هرگز گواهينامه هائى را که نام آنان با نام سايت ويا شخص مورد نظر مطابقت نمى نمايد ، تائيد ننمائيد.

مدت زمات اعتبار گواهينامه : اکثر گواهينامه ها براى يک و يا دو سال صادر مى گردند . در اين رابطه يک استثناء نيز وجود دارد و به مواردى بر مى گردد که گواهينامه براى خود مرکز صدور گواهينامه صادر شده باشد. اين نوع گواهينامه ها معمولا" داراى اعتبارى ده ساله مى باشند . همواره مدت زمان اعتبار يک گواهينامه را بررسى نموده و نسبت به گواهينامه هائى که داراى اعتبارى بيش از دو سال مى باشند و يا تاريخ اعتبار آنان به اتمام رسيده است ، حساسِت داشته باشيد .

در صورتى که در خصوص اعتبار يک گواهينامه ترديد داريد و يا داراى ابهاماتى در خصوص ايمن بودن يک سايت مى باشيد ، هرگز اطلاعات شخصى خود را براى آنان ارسال ننمائيد . قبل از ارسال هرگونه اطلاعات شخصى، مى بايست سياست هاى اعلام شده وب سايت مورد نظر در خصوص رعايت محرمانگى اطلاعات مطالعه گردد تا مشخص گردد که آنان با اطلاعات ارسالى شما چه کار خواهند کرد .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 14 تیرماه 1384

04:14 PM

July 05, 2005

نقش زنان در جامعه‌ اطلاعاتي

عدم حضور يا فقدان نظرات و ديدگاه‌هاي زنان در جامعه اطلاعاتي حكايت از اين دارد كه فناوري‌هاي اطلاعاتي و ارتباطاتي «جديد» نيز انعكاس دهنده‌ي بسياري از الگوهاي جنسيتي است كه طي دهه‌ها در سطح رسانه‌هاي «قديمي» نيز شاهد آن بوده‌ايم كه البته اين الگوها را نمي‌توان از روابط جنسيتي موجود در جامعه به عنوان يك كل جدا كرد.

به گزارش خبرنگار سرويس «نگاهي به وبلاگ‌ها»ي ايسنا دكتر شيرين احمدنيا استاديار دانشگاه علامه طباطبايي در وبلاگ http://rezairavani.blogfa.com پيرامون جايگاه زنان در جامعه اطلاعاتي نوشته است:

در سراسر دنيا زنان امروزه فناوري‌هاي اطلاعاتي و ارتباطي را در جهت اهداف جنبش زنان بكار مي گيرند. ارتباطات الكترونيكي، شبكه‌سازي زنان و اقدامات جلب حمايت براي ايشان را به روش‌هايي كه قبلا امكان‌پذير نبودند، تسهيل مي‌كند.

سؤالاتي كه در ارتباط با زنان پيش روي ما قرار دارد عبارت است:

- آيا زنان به عنوان نيمي از جمعيت هر جامعه، به طرز مناسبي در دنياي فناوري‌هاي اطلاعاتي و ارتباطات حضور موثر دارند؟ يا اينكه الگوهاي ديرينه‌ي نابرابري جنسيتي و تبعيض عليه زنان در عرصه‌هاي اجتماعي و اقتصادي همچنان‌كه در رسانه‌هاي قديمي معمول بوده، در اين‌جا نيز دوباره تكرار مي‌شوند؟

آيا موضوع شكاف ديجيتالي جنسيتي در اين ارتباط مورد بحث قرار خواهد گرفت.

- نحوه حضور زنان در اين عرصه واقعا چگونه است و آنان به عنوان بخشي از مشاركت‌كنندگان در جامعه اطلاعاتي به چه مشغولند؟

در اين ارتباط وعده‌هاي اصلي فناوري اطلاعاتي و ارتباطات و منافع واقعي اين فناوري‌ها در جهت توانمندسازي گروه‌هاي زنان فعال و نيز موانع موجود مورد توجه قرار مي‌گيرد.

جامعه اطلاعاتي، يك مفهوم نسبتاً جديد

برخي بر اين باورند كه هنوز تعريفي عام از جامعه اطلاعاتي واقعا وجود ندارد و تعاريف پيشنهاد شده اغلب نارسايند و فقط موضوعات خاص يا تاثيرات ويژه‌اي را مورد توجه قرار مي‌دهند. با اين همه، به طور كلي بسياري به اين موضوع اذعان دارند كه جامعه اطلاعاتي پديده‌اي است كه در هر جنبه از زندگي افراد نفوذ پيدا كرده است و بر تك تك سلولهاي جامعه و هر بخش از فعاليت‌هاي آن تاثير گذاشته است.

اعتقاد بر اين است كه سه عنصر اصلي يعني دانش و اطلاعات؛ ازدياد فناوريهاي اطلاعات و ارتباطات و دسترسي و كاربرد فناوري هاي اطلاعات و ارتباطات، اساس و بنيان جامعه اطلاعاتي را تشكيل مي‌دهد.

طبق گزارش نهايي برنامه‌ي «فرصت ديجيتالي» از جانب برنامه عمران ملل متحد (UNDP, ‌٢٠٠١) «فناوري‌هاي اطلاعاتي و ارتباطاتي به عنوان تواناساز قدرتمندي براي اهداف توسعه شناخته مي‌شود. چرا كه ويژگي‌هاي منحصر به فرد آن، ارتباطات و تبادل اطلاعات را به طور قابل توجهي بهبود مي‌بخشد و منجر به تقويت و ايجاد شبكه‌هاي جديد اجتماعي و اقتصادي مي‌شود.

فناوريهاي اطلاعات و ارتباطات فراگير و چندجانبه عمل مي كنند

اين فناوري‌ها را مي‌توان در مورد محدوده‌ي وسيعي از فعاليت‌هاي انساني از استفاده شخصي گرفته تا تجارت و حكومت به كار گرفت.

اين فناوري‌ها، تواناساز (enablor) عمده‌اي در خلق شبكه‌ها است و در نتيجه كساني كه به اين شبكه‌ها دسترسي دارند را قادر مي‌سازد تا از دستاوردهاي حاصله كه با افزايش استفاده فزوني مي‌يابد بهره‌مند شوند.

اين فناوري‌ها، انتشار اطلاعات و دانش را با آزاد كردن محتوي از جايگاه فيزيكي آن، تسريع مي‌كند.

ماهيت مجازي و ديجيتالي بسياري از توليدات و خدمات اين فناوري‌ها، اين امكان را فراهم آورده كه هزينه‌هاي جانبي به صفر برسد يا كاهش يابد.

قدرت اين فناوري‌ها در ذخيره كردن، بازيابي، طبقه بندي، تصفيه، توزيع و تسهيم اطلاعات بدون شك مي‌تواند به فوايد كارايي بيشتر در امر توليد، انتشار و داد و ستد منجر شود.

افزايش كارايي و كاهش هزينه‌ها در نتيجه‌ي كاربرد اين فناور‌ي‌ها به ايجاد توليدات، خدمات و مجاري توزيع جديد در چارچوب صنايع سنتي و نيز الگوهاي تجاري نوين و صنايع جديد منتهي شده است.

با ايجاد و گسترش شبكه‌ها، اين فناوري‌ها مي‌توانند فراتر از محدوديت‌هاي زباني و فرهنگي عمل كرده و از طريق امكان دادن به افراد و گروه‌ها براي زندگي و كار در هر گوشه و هرجا به اجتماعات محلي امكان مي‌دهند و صرف نظر از مليت‌شان بخشي از جامعه شبكه‌اي جهاني را تشكيل دهند و سياست‌هاي جاري و ساختارهاي محدودكننده‌ي قانوني و نظام‌مند فعلي كه در درون ملت‌ها و ميان آنها عمل مي‌كنند را به چالش بكشند.

در سطح جهان همگان اذعان مي دارند كه بخش فناوري‌هاي اطلاعاتي و ارتباطاتي سريع‌ترين حوزه رشديابنده‌ي اقتصاد جهاني است.

در عين حال، در تمامي كشورها فرايند ساخت جامعه اطلاعاتي بر توسعه فرايندهاي فني و زيربنايي متمركز شده است كه از نقطه نظر جنسيتي خنثي يا بي‌طرف تلقي مي‌شود.

حضور يا غيبت زنان، مسأله‌ي شكاف ديجيتالي جنسيتي

با درنظر گرفتن مباحث جنسيتي، گاه عنوان مي‌شود كه فناوري‌هاي اطلاعات و ارتباطات مي‌توانند آن‌چنان‌كه در اعلاميه پكن و برنامه اقدام آن همانند ساير اسناد ملل متحد تشخيص داده شده است به عنوان ابزاري براي بهبود شرايط برابري جنسيتي و افزايش توانمندي‌هاي اجتماعي، سياسي و اقتصادي زنان به خدمت گرفته شوند. اما با اين‌حال برخي همچنان معتقدند كه اين فناوري‌ها مي‌توانند به نابرابري‌هاي موجود مبتني بر جنسيت در زمينه‌ي فرصت‌ها و منابع تداوم بخشيده و اشكال جديدي از نابرابري ميان زنان و مردان را بوجود بياورند.

در كنفرانس مقدماتي وزيران كشورهاي اروپايي براي اجلاس جهاني جامعه اطلاعاتي تاكيد گرديد كه برابري جنسيتي بايد همه حوزه‌هاي فناوريهاي اطلاعات و ارتباطات را شامل شود كه عبارتند از:

- كاربران

- توليد كنندگان

- سياست گذاران

هرچند زنان به‌طور بالقوه ‌٥٠درصد مصرف كنندگان توليدات، خدمات و نيز نيروي كار فناوري‌هاي اطلاعات و ارتباطات را تشكيل مي‌دهند كه مي‌توانند ايده‌هاي مفيدي براي توليد محصولات جديد، خدمات و سبك‌هاي مديريتي نوين ارايه نمايند؛ اما در سطح كشورهاي منطقه آسيا و اقيانوسيه همانند ساير نقاط دنيا، زنان و مردان به طور برابر از گستره و رشد كاربرد فناوري‌هاي اطلاعات و ارتباطات برخوردار نشده‌اند. زنان به ويژه از نظر دستيابي به فناوري‌هاي اطلاعاتي و ارتباطاتي با موانع و محدوديت‌هاي نهادينه شده، نظام‌مند و ايدوئولوژيك درگير هستند.

براي زنان دستيابي به ميزاني از كنترل در عرصه‌ي ارتباطات و فناوري‌هاي اطلاعاتي و ارتباطاتي جهت تضمين اين امر كه منافع جامعه ارتباطاتي و اطلاعاتي به صورت برابر بين زنان و مردان توزيع مي‌شوند، جنبه‌ي حياتي دارد.

به اعتقاد نانسي هافكين (Nancy Hafkin) طي پنج سال گذشته سازمان‌هاي غيردولتي، چند مليتي و بنيادهاي خصوصي مقادير قابل توجهي بودجه را براي طرحهاي مروج استفاده از فناوري‌هاي اطلاعات و ارتباطات در كشورهاي در حال توسعه اختصاص داده‌اند. تجربه پروژه‌هاي مرتبط با توسعه در حوزه‌هاي ديگر نشان داده كه زنان به نحو منصفانه‌اي از چنين طرح‌هايي بهره‌مند نمي‌شوند، مگر اين‌كه تلاش‌هاي خاصي براي تعيين جايگاه و نيازهاي آنان صورت بگيرد يا اقدامات موثري براي مشاركت دادن آنان، به كار گرفته شود.

برخي از طرح‌ريزان توسعه معتقدند كه فناوري اطلاعاتي از لحاظ جنسيتي بي‌طرف است و در نتيجه زنان و مردان بايد به طور عادلانه از كاربرد آن منتفع شوند. با اين حال نتايج يك تحقيق (بر مبناي شش مطالعه موردي از پروژه‌هاي ترويج فناوري اطلاعات و ارتباطات در آسيا، آفريقا و آمريكاي لاتين) بنا بر گزارش هافكين اين فرضيه را كه زنان به نحو برابر از پروژه‌هاي توسعه منتفع نيستند را مورد تائيد قرار مي‌دهد.

اصطلاح «شكاف ديجيتالي» (digital divide) به فاصله بين افراد داراي مهارت‌هاي استفاده از كامپيوتر و اشخاص فاقد اين مهارت اشاره مي‌كند. هرچند «شكاف ديجيتالي» مي‌تواند به اين واقعيت اشاره داشته باشد كه زنان معمولا از سطح سواد كامپيوتري نازل تري برخوردارند. علت آن را مي‌توان در عدم آموزش، فقر و دسترسي نامناسب زنان به تكنولوژي جستجو كرد كه در نتيجه مي‌بينيم زنان به نسبت كمتري در دنيا از كامپيوتر استفاده مي كنند. هرگاه زنان به آموزش و امكان دسترسي دست پيدا كرده‌اند شاهد آن بوده‌ايم كه از كامپيوترها براي آموزش خود استفاده كرده‌اند با ديگران شبكه‌هايي را تشكيل داده، فرصت‌هاي شغلي و اقتصادي براي خود و ساير زنان بوجود آورده‌اند و ديگران را در معلومات خود شريك كرده‌اند.

خانم سوزان تلتشر(Susan Teltscher) از «كنفرانس ملل متحد در مورد تجارت و توسعه» نيز اظهار داشته كه اصولا موانع اساسي بر سر راه دسترسي زنان به امتيازاتي كه فناوري اطلاعاتي و ارتباطي فراهم مي‌كند وجود دارد. موانعي نظير فقر، سطح پايين آموزش، عدم آشنايي با يك زبان دوم، عدم دسترسي به كامپيوتر و شكاف ديجيتالي.

از نظر مشاركت در دانش فناوريهاي اطلاعات و ارتباطات نيز زنان در شرايط محروميت قرار دارند. چرا كه تعداد زنان از لحاظ ثبت‌نام در دوره هاي آموزشي علوم و تكنولوژي نسبت به مردان در مراتب بسيار پايين‌تري قرار دارد. در سال ‌١٩٩٠؛ درصد زنان ورودي به رشته‌هاي علوم و تكنولوژي در سطح دانشگاهي عبارت بود از ‌١٠درصد در آفريقا، ‌٤٠درصد در آمريكاي لاتين، ‌٣٢ درصد در اروپاي غربي و كمتر از ‌٣٠درصد در اروپاي شرقي و ‌٣٤درصد در منطقه آسيا و اقيانوسيه. (Hamelink ,‌١٩٩٩)

خانم جيليان مارسل (Gillian Marcelle) از پيش‌قراولان فعال در زمينه توسعه و اجراي استراژي‌هاي عدالت جنسيتي در بخش فناوري‌هاي اطلاعات و ارتباطات ادعا مي‌كند كه سياست‌گذاري در زمينه فناوري‌هاي اطلاعات و ارتباطات در صورتي كه مبتني بر فرايند تصميم‌گيري آگاهانه و مطلع از مسائل جنسيتي باشد به شكل فوق العاده‌اي سودمند خواهد بود . با اين حال، ميزان برابري جنسيتي در سطوح تصميم‌گيري در ميان دست اندركاران فناوري‌هاي اطلاعات و ارتباطات هنوز در سطح غير قابل قبولي است.

به نظر هاملينك (Hameling) در توزيع منابع فناوري‌هاي اطلاعات و ارتباطات به‌ويژه كاربرد آن در ارتباط با زنان نابرابري مشاهده مي‌شود. اما مشكل اين‌جاست كه كسب مهارت‌هاي فناوري‌هاي اطلاعات و ارتباطات تقريبا به‌طور كل به سواد ارتباط دارد و چنين شرايطي بويژه زنان را تحت تاثير قرار مي‌دهد. چراكه در سراسر دنيا نرخ بيسوادي زنان نسبت به مردان بالاتر است.

رزا دلگادو (Rosa Delgado) از انجمن «جامعه اينترنتي» نتيجه مي‌گيرد كه اكثريت زنان كشورهاي در حال توسعه در نتيجه‌ي فقدان سواد كامپيوتري computer literacy و غالباً كمبود آموزش از فرصت‌هاي حايز اهميت شغلي و تحصيلات تكميلي باز مي‌مانند.

مايكل پاستور (Micheal Pastor) در مقاله‌اش تحت عنوان «شكاف ديجيتالي در سطح جهاني هنوز وجود دارد» به گزارش اشتغال جهاني (منتشره توسط سازمان جهاني كار) ارجاع مي‌كند و نتيجه مي‌گيرد كه فناوري‌هاي اطلاعات و ارتباطات «پناسيل تواناسازي» را براي بهبود شرايط زندگي زنان فراهم مي‌سازد، اما گزارش مذكور حقيقت ديگري را نيز آشكار مي‌كند مبني بر اينكه خلا جنسيتي ديجيتالي نيز در سطح كشورها وجود دارد. بنابراين زنان همچنان خود را شاغلين به شغل‌هاي سطوح پايين تري در عرصه‌ي فناوري اطلاعات و ارتباطات مي‌يابند. در حالي‌كه مردان به دستمزدهاي بالاتر و مشاغل پرمسؤوليت تري صعود كرده‌اند.

عمده‌ترين شكل شكاف ديجيتالي جنسيتي مربوط به استفاده از اينترنت است، به طوري‌كه كمترين ميزان كاربران را در كشورهاي در حال توسعه را زنان تشكيل مي‌دهند. به عنوان مثال فقط ‌٣٨درصد از كاربران اينترنت در آمريكاي لاتين زنان هستند، در حالي‌كه در اتحاديه اروپا اين رقم ‌٢٥درصد در روسيه ‌١٩درصد در ژاپن ‌١٨درصد و در خاورميانه فقط ‌٤درصد است.

بنا بر اين گزارش در سطح جهان، بيشترين تعداد كاربران اينترنتي را مردان، دانش آموختگان دانشگاهي و يا آنان كه از ميانگين درآمد بالاتري برخوردارند، تشكيل مي‌دهند. تنها جايي كه دسترسي به اينترنت توسعه‌ي خوبي يافته است، كشورهاي اسكانديناوي و آمريكا مي‌باشد كه از فاصله جنسيتي در استفاده از اينترنت كاملاً كاسته شده است.

طي كنفرانس تداركاتي وزيران مجمع اروپايي براي اجلاس جهاني جامعه اطلاعاتي (بخارست ‌٢٠٠٢) بر فهرستي از موانع خاص جنسيتي در دسترسي به فناوريهاي ارتباطي و اطلاعاتي به شرح زير تاكيد شد:

- هزينه هاي بالاي دسترسي و گزينه هاي تكنولوژي

- دسترسي محدود در جهت آموزش مهارت‌هاي جديد (فقدان اطلاعات و تشويق لازم در مورد درخواست براي فراگيري فناوريهاي ارتباطات و اطلاعات)

- ناكافي بودن شبكه‌ها و وجود اين تصور كه اين فناوريها «مردانه» است.

برخي نيز بر اين باورند كه تفاوت‌هاي موجود ميان زنان در دسترسي به اينترنت از جمله تحت تاثير عوامل زير قرار دارد:

- عامل جغرافيايي (تفاوتهاي مناطق شهري و روستايي)

- وضعيت خانوادگي (مادران مجرد دسترسي كمتر دارند)

- سن كاربران (مشكل دسترسي براي زنان بالاي ‌٤٥ سال)

البته در اين مورد نيز توافق وجود دارد كه اطلاعات محدود در مورد وضعيت زنان به عنوان كاربران، توليدكنندگان و تصميم‌گيران اين فناوريها، ارزيابي دقيق‌تري در خصوص شكاف ديجيتالي جنسيتي را امكان پذير نمي‌سازد.

در مورد شكاف بين زنان در مناطق روستايي و شهري، گالاگر و ماير(Gallagher and Mayer, ‌٢٠٠١ ) عنوان شده است كه بدون دستيابي به فناوري‌هاي ارتباطات و اطلاعات، زنان در مناطق روستايي نمي‌توانند در منافعي كه در حوزه آموزش، درآمدزايي، بهداشت و ساير موارد كه از فناوري‌هاي اطلاعات و ارتباطات مي‌تواند بدست آيد سهيم باشندو همچنان‌كه مي‌دانيم زنان شهري هم در ابتداي مسير استفاده از اين قابليت‌ها قرار دارند.

علي رغم كمبود اطلاعات در مورد شكاف ديجيتالي جنسيتي، شواهد محكمي موجود دارد حاكي از آن‌كه زنان:

- از منابع مالي كمتري براي خريد تجهيزات جديد برخوردارند.

- زمان محدودتري براي كسب مهارت ها و معلومات جديد دارند.

- در چارچوب و قوانين بازي جامعه اطلاعاتي (كه در آن فناوري‌هاي اطلاعات و ارتباطات، به‌سرعت حوزه‌هاي كار و تجارت، آموزش و اداره حكومت را متحول مي كنند) اثرگذاري كمتري مي‌توانند داشته باشند.

- زنان همين‌طور فاقد اعتماد به‌نفس و دلگرمي براي پيگيري فعالانه‌ي فرصت‌هاي مربوط به فناوريهاي اطلاعات و ارتباطات هستند.

نويدهاي فناوري‌هاي اطلاعات و ارتباطات براي زنان و موانع موجود

توانايي فناوري‌هاي اطلاعات و ارتباطات در توانمندسازي زنان از طريق آموزش بهتر و ارتباطات گسترده و در جهت توليد درآمد شخصي براي ايشان نبايد دست كم گرفته شود. بوخارت و اولدر(‌٢٠٠٣) با اشاره به وضعيت زنان در منطقه خاورميانه و شمال آفريقا يادآور مي‌شوند كه آداب و رسوم سنتي در همه اين كشورها مورد چالش قرار گرفته است و به ويژه بر نقش و سهم اينترنت در اين ارتباط تاكيد مي‌كنند.

هاملنيك (‌١٩٩٩) نيز معتقد است؛ فناوري‌هاي اطلاعات و ارتباطات اشكال جديدي از ارتباطات را بوجود مي‌آورد كه مي‌تواند زنان را قادر به فروپاشيدن موقعيت اجتماعي بسته‌اي كه غالبا در آن محصورند، سازد. همچنين فرصت‌هاي نويني را براي اشتغال زنان در مشاغلي فراهم مي‌آورد كه مستلزم مهارت‌هاي جديد است. هرچند متذكر مي‌شود كه سياست‌هاي محكمي لازم است تا اين فناوري‌ها بتوانند تاثير مثبتي بر زندگي زنان بگذارد. در جوامع دانايي محور (Knowledge socities) كه در حال ظهور است دستيابي به ارتباطات يك ابزار كليدي براي مشاركت و ادغام اجتماعي social inclusion به حساب مي‌آيد. بوخارت و اولدر (‌٢٠٠٣) همچنين يادآور مي‌شوند كه با در نظر گرفتن آنچه آنان انقلاب اطلاعاتي مي‌نامند، بازارهاي شغلي به هيچ وجه با شتاب افزايش تعداد افراد جواني كه به آن وارد مي‌شوند هماهنگ نبوده است. با ورود زناني كه در حال حاضر قصد كار كردن دارند اين شرايط حادتر نيز شده است و طبقه جديدي از كاركنان اطلاعاتي كه احتمالا عمدتا متشكل از زنان خواهد بود در حال ظهور است.

فناوري‌هاي اطلاعات و ارتباطات مي‌تواند همچنين براي زناني كه مسؤوليت مراقبت از كودكان را دارند يا آنان كه دور از مراكز شهري سكونت دارند مزاياي زيادي به‌همراه داشته باشد و براي مثال براي آنان فرصت كار از منزل يا به عبارت ديگر «دوركاري» (teleworking) را فراهم آورد.

سوزان تلشتر از «كنفرانس ملل متحد در خصوص تجارت و توسعه» همچنين تاكيد مي‌كند كه فناوري‌هاي جديد مي‌تواند براي زناني هم كه درگير امور و فعاليت‌هاي تجاري و اقتصادي business women هستند، امتيازاتي چون افزايش بهره وري، ارتقاء ظرفيت كاري، راههاي ارتباطي بيشتر و صرفه جويي در زمان و هزينه‌ها را به ارمغان آورد.

به‌منظور افزايش توانايي موثر زنان در بهره‌گيري از فناوريهاي اطلاعاتي ارتباطي، توصيه‌هاي متعددي بعمل آمده است كه در اينجا به برخي از آنها اشاره مي شود:

- اطمينان حاصل شود از اين‌كه جنسيت در سياست‌ها و برنامه‌هاي فناوري‌هاي اطلاعات و ارتباطات لحاظ يا جاري شده باشد و زنان در نهادهاي تصميم گيرنده و سياست‌گذار حضور داشته باشند.

- با گسترش سياست‌هاي دولتي كل‌نگرانه در زمينه اين فناوري‌ها، آنها را براي زنان قابل دسترس‌تر مفيد و مربوط سازند به نحوي كه نيازهاي زنان و موضوعات جنسيتي مدنظر قرار گيرد.

- ثبت نام دختران در برنامه‌هاي آموزش اين فناوري‌ها از طريق تدارك امكانات عملي و تشويقي مانند بورس‌هاي تحصيلي و فعاليت‌هاي ارتقاي آگاهي رساني در اين باب تشويق شود.

- فراهم كردن حمايت‌هاي مالي اضافي براي ترويج استفاده از اين فناوريها در ميان گروههاي زنان.

- هدايت آموزش‌هاي مستمر در زمينه استفاده از اين فناوري‌ها و قابليت‌هاي آن (مانند مبادله ساده اطلاعات، تحقيق، پردازش و ذخيره اطلاعات)

- برگزاري كارگاه‌هاي اطلاع رساني در مورد منافع اين فناوري‌ها به ويژه به عنوان يك ابزار ارتباطي موثر.

تاكنون برخي اقدامات حمايتي نيز در سطح بين‌المللي براي ترويج و تشويق استفاده از فناوري‌هاي ارتباطات و اطلاعات در ميان زنان صورت گرفته است و از آن جمله سازمان ملل متحد، دو اجلاس در سال ‌٢٠٠٢ براي تسهيل دسترسي زنان به اين فناوري‌هاي جديد برگزار نمود. يكي از اين نشست‌ها تحت عنوان «فناوريهاي جديد اطلاعات، ارتباطات و تاثير و كاربرد آنها به‌عنوان ابزاري براي پيشرفت و توانمند سازي زنان» در جمهوري كره در نوامبر ‌٢٠٠٢ برگزار شد و ديگري تحت عنوان «مشاركت و دسترسي زنان به رسانه‌ها و تاثير آن به‌عنوان ابزاري براي پيشرفت و توانمندسازي زنان» با همكاري كميسيون اقتصادي و اجتماعي ملل متحد براي آسياي غربي نيز در نوامبر ‌٢٠٠٢ در بيروت، لبنان برگزار شد.

بوخارت و اولدر (‌٢٠٠٣) به ظهور نوعي انقلاب اطلاعاتي در خاورميانه اشاره داشته و متذكر شده‌اند كه اين منطقه زماني يكي از پيشرفته‌ترين بخش‌هاي دنيا بود؛ مردم اين منطقه در رياضيات، نجوم، علوم و پزشكي مهارت داشتند و به خاطر شعر و هنرهاي ديگر شهرت داشتند. اين پيشرفت با گسترش امپراتوري اسلامي همزمان شد و در واقع آنچه امروز تحت عنوان خاورميانه و شمال آفريقا باقي مانده است، بقاياي همان امپراتوري بزرگ اسلامي است. اين دو پژوهشگر بر اين باورند كه اين منطقه بار ديگر با اقتصاد جهاني در حال پيوند خوردن است و با گسترش اخير فناوري‌هاي اطلاعات و ارتباطات كه به توسعه اقتصادي اين منطقه كمك مي كند بار ديگر آن را در ارتباطي نزديك با اقتصاد جهاني قرار مي‌دهد. اين دو محقق در گزارش خود جدولي از شاخص‌هاي فناوريهاي اطلاعات و ارتباطات را در تائيد اين نظر خويش ارائه مي‌كنند . طبق نظر ايشان، ارتباطات از راه دور در سراسر منطقه خاورميانه و شمال آفريقا در طي ‌١٠سال گذشته بسيار بهبود يافته است. هرچند هنوز بسياري كشورها به لحاظ تعداد خطوط تلفن، ارتباطات بين المللي و بويژه خدمات و ارتباطات اينترنتي زير ميانگين‌هاي جهاني قرار دارند.

بوخارت و اولدر اعتقاد دارند كه موفقيت اقتصاد مبتني بر فناوري‌هاي ارتباطات و اطلاعات شديدا در گروي مشاركت تمامي مردم است و لذا هم مردان و هم زنان بايد در اين امر مشاركت داشته باشند. گسترش فرصت‌هاي كاربرد ICTs نه تنها براي زنان بلكه همچنين براي كشورهاي عربي در كل سودمند به حساب آمده است. به اعتقاد آنها وارد شدن اين فناوري‌هاي جديد به دنياي اعراب ابزار كاملي را براي زنان به‌منظور تقويت وضعيت اجتماعي‌شان در جامعه فراهم مي‌كند و باعث خودآگاهي آنان و همچنين مشاركت بيشتر در نيروي كار ميگردد.

اين دو پژوهشگر همچنين يادآور شده‌اند، هرچند نفوذ اينترنت روند آهسته‌اي در خاورميانه داشته ولي در حال حاضر وب سايت‌هاي بسياري به زبان عربي و انگليسي در دسترس زنان عرب قرار دارد و برخي حتي مخصوص زنان طراحي شده‌اند. نظير سايت «ارتباط زنان عرب» www.arabwomenconnect.org كه تحت نظارت بنياد توسعه زنان سازمان ملل متحد است.

در سپتامبر ‌١٩٩٦ برنامه زنان APC اقدام به انجام يك نظرخواهي از بيش از ‌٧٠٠گروه زنان و زنان منفرد از طريق پست الكترونيكي براي تعيين نيازهاي شبكهسازي الكترونيكي و تعيين فرصت هاي تازه نمود.

نتايج كلي اين پژوهش آشكار ساخت كه با وجود موانع بسيار زنان، گام‌هاي بلندي براي دستيابي به ارتباطات الكترونيكي برداشته‌اند و از حمايت و تسهيلات ايجاد شده به‌وسيله برنامه‌هاي آموزشي نظير برنامه حمايت و فعال سازي از سوي شبكه‌هاي APC استفاده برده‌اند.

به نظر مي‌آيد كه افزايش ارتباطات و سهيم شدن در دانش توسط زنان نه تنها در جنوب و شرق اروپا، بلكه در جوامع دوردست در شرق و غرب باعث شده است كه دورنماي مشاركت اينترنتي زنان بهبود يافته و در جهت دنياي عادلانه‌تري براي زنان پيش مي‌رو

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 14 تیرماه 1384

04:26 PM

July 05, 2005

نگاهي به لايحه آزادي اطلاعات

هيات دولت در نشست يكشنبه شب خود لايحه آزادي اطلاعات را در ‪ ۸۳‬ماده تصويب كرد.

مطابق با اصول اين لايحه اطلاعات موجود در موسسه‌هاي عمومي بايد در دسترس متقاضيان قرار گيرد.

"دسترسي به‌اطلاعات حق مردم است، استثناهاي وارد بر حق دسترسي بايد محدود و مشخص و مستند به قانون باشد و تصميمات راجع به عدم افشاي چنين اطلاعاتي بايد توسط يك مرجع حكومتي مستقل مورد تجديد نظر قرار گيرد."
براساس پيش نويس قانون آزادي اطلاعات، به منظور ايجاد شفافيت و پاسخگويي در موسسات عمومي و كمك به سير آنها به سمت مردم‌سالاري مشاركتي، ايجاد حق دسترسي اشخاص حقيقي و حقوقي به اطلاعات موجود موسسات عمومي و ايجاد تكليف بر عهده موسسات مذكور نسبت به افشاي اطلاعات تحت كنترل خود و پيش بيني حق دسترسي به اطلاعات موجود در موسسات خصوصي در صورتي كه اين امر براي اجراي حقوق افراد يا حمايت از آن ضروري باشد، لايحه زير براي طي تشريفات قانوني تقديم مي‌شود.

براساس اين لايحه، اطلاعات به هر نوع معلوماتي كه قابليت انتقال دارد اعم ازآنكه در سندي مندرج باشد يا در يك نرم افزار ذخيره شده و يا درهر وسيله ديگري ضبط شده باشد گفته مي‌شود.

اطلاعات شخصي نيز به اطلاعاتي گفته مي‌شود كه به يك فرد مربوط مي‌شود و از طريق آنها مي‌توان وضعيت آن فرد را شناسايي كرد نظيراطلاعات مربوط به وضعيت خانوادگي، جسمي، روحي، اقتصادي، قومي، مذهبي و فرهنگي.

ازنظر اين لايحه، موسسه عمومي شامل كليه موسسات تقنيني، اجرايي و قضايي است كه بر اساس قانون اساسي و مستقيما به‌وسيله قانون عادي يا ديگر مصوبات حكومتي ايجاد شده باشد.

موسسات عمومي همچنين مي‌بايست بخشي از حكومت را تشكيل داده، متعلق به حكومت و يا تحت كنترل آن باشد و يا اينكه متصدي يك وظيفه عمومي باشد.

از نظر اين قانون، موسسه خصوصي شامل هر موسسه انتفاعي و غيرانتفاعي به استناد موسسات عمومي است.

براساس اين لايحه هر فرد حق جستجو، كسب و اشاعه اطلاعات را در چارچوب مقررات اين قانون دارد و هر شخص حق دارد با رعايت قانون هر گونه اطلاعاتي را كه مي‌خواهد جمع‌آوري و از طريق هر رسانه‌اي كه مي‌خواهد، منتشر كند.

"هر فرد حق دارد تا از انتشار يا پخش اطلاعاتي كه به وسيله او تهيه شده ولي در جريان آماده‌سازي آن براي انتشار تغيير يافته است جلوگيري كند و اجبار تهيه‌كنندگان اطلاعات عمومي و روزنامه‌نگاران به انتشار يا پخش اطلاعات ممنوع است."
"هر شخصي حق دارد آشكارا از فعاليت‌هاي اركان و اجزاي مختلف حكومت و فعاليت ماموران آنها انتقاد كند، هيچ گونه تعقيب اداري، مدني يا كيفري در مقابل صرف انتقاد قابل اعمال نيست."
ماده ‪ ۱۱‬اين لايحه تصريح دارد كه اجبار تهيه‌كنندگان و اشاعه‌دهندگان اطلاعات عمومي به افشاي منابع اطلاعات خود ممنوع است.

"هر شخصي حق دارد با ارايه درخواست به يك موسسه عمومي، مطلع شود كه آيا آن موسسه اطلاعات مورد نظر وي را دارد يا نه، اگر موسسه مذكور، اطلاعات درخواست شده را دارد، اطلاعات مذكور در اختيار وي قرار گيرد در غير اين صورت مطلع شود از كدام موسسه عمومي مي‌تواند اطلاعات مورد نيازش را تهيه كند."
براساس اين لايحه، موسسات خصوصي موظفند بارعايت مقررات اين قانون اطلاعات مورد نياز افراد را كه براي اجراي حقوق يا حمايت از حقوق آنها ضروري است در دسترس آنان قرار دهند.

درفصل دوم اين لايحه كه دسترسي به‌اطلاعات را تبيين كرده،آمده‌است: درخواست دسترسي به اطلاعات عبارت است از درخواست كتبي كه مشخصات اطلاعات درخواست شده با تفصيل كافي در آن نوشته شده است به گونه‌اي كه اگر به يك مامور مجرب موسسه عمومي يا خصوصي تسليم شود وي بتواند در مدتي معقول و با تلاشي متعارف شناسايي كند كه آيا موسسه مذكور، اطلاعات درخواست شده را دارد يا نه."
چنانچه درخواست دسترسي به‌اطلاعات، فاقد تفصيل‌كافي باشد ماموري‌كه درخواست را دريافت مي‌كند بايد بدون‌دريافت هزينه، همكاري لازم را جهت تكميل درخواست انجام دهد.

براين اساس افرادي كه به دلايلي مانند بي‌سوادي يا معلوليت قادر به ارايه درخواست كتبي نيستند، مي‌توانند درخواست خود را به صورت شفاهي مطرح كنند.

ماموري كه درخواست شفاهي را دريافت مي‌كند، بايد آن را مكتوب كند و نام و پست سازماني خود را در آن قيد كرده و رونوشت آن را به متقاضي بدهد.

"درخواست دسترسي به اطلاعات بايد حاوي نام و نشاني و شغل درخواست‌كننده و نيز مشخصات كافي اطلاعات درخواست شده و شكل دسترسي مورد نظر متقاضي باشد." دريكي از تبصره‌هاي اين لايحه‌آمده‌است: درخواست دسترسي به‌اطلاعات شخصي تنها از اشخاص حقيقي كه اطلاعات به آنها مربوط مي‌شود يا نماينده آنها پذيرفته مي‌شود.

"چنانچه درخواست تسليم شده به موسسه عمومي شرايط مذكور را نداشته باشد بايد حداكثر ظرف ‪ ۱۰‬روز به صورت كتبي به متقاضي اطلاع داده‌شود كه نقايص را ظرف ‪ ۱۰‬روز از تاريخ ابلاغ برطرف سازد و گرنه درخواست او رد مي‌شود.

همچنين چنانچه متقاضي در اين مهلت، درخواست خود را تكميل كند، درخواست تكميل شده به‌عنوان درخواست جديدمحسوب خواهدشد، ولي چنانچه متقاضي درخواست خود را تكميل نكند، درخواست او رد مي‌شود و او مي‌تواند به اين تصميم در كميسيون آزادي اطلاعات اعتراض كند.

اين لايحه تصريح دارد: هر موسسه عمومي يا خصوصي كه درخواست دسترسي به اطلاعات را دريافت مي‌كند بايد رسيدي را كه حاوي شماره ثبت، تاريخ دريافت و نام و نام خانوادگي و سمت دريافت‌كننده باشد به متقاضي تحويل دهد.

بر اين‌اساس متقاضي مي‌تواند درخواست خود را از طريق پست سفارشي به موسسه مربوط ارسال كند.

همچنين موسسه عمومي نمي‌تواند از متقاضي دسترسي به اطلاعات هيچ‌گونه دليل يا توجيهي جهت تقاضايش مطالبه كند.

"موسسه عمومي يا خصوصي بايد به درخواست دسترسي به اطلاعات در سريع‌ترين زمان ممكن پاسخ دهد و در هرصورت مدت زمان پاسخ نمي‌تواند بيش از ‪ ۲۰‬روز از زمان دريافت درخواست باشد."
"هر گاه دسترسي به اطلاعات، با توجه به دلايل يا قرائن كافي براي حمايت از جان يا آزادي متقاضي ضروري باشد مهلت پاسخگويي حداكثر ‪ ۴۸‬ساعت خواهد بود."
موسسه عمومي يا خصوصي مي‌تواند در صورتي كه درخواست شامل حجم زيادي از اطلاعات يا مستلزم جستجو در ميان شمار زيادي از سوابق و اطلاعات باشد يا به علت ديگري پاسخگويي در مدت ‪ ۲۰‬روز عرفا مقدور نباشد، پيش از انقضاي مدت، با اعلام كتبي مهلت را تمديد كند.

اين تمديد بايد دقيقا به اندازه نياز بوده و در هر صورت نمي‌تواند از ‪۴۰‬ روز از زمان تسليم درخواست تجاوز كند.

"در صورتي كه ماموران يا مسوولان موسسه عمومي مقررات مواد (‪ ۲۲‬تا ‪ (۲۵‬را رعايت نكنند، مستنكف از حق تلقي و به مجازات مقررات در قانون مجازات اسلامي محكوم خواهند شد."
پاسخ موسسات عمومي به درخواست‌هاي دسترسي به اطلاعات بايد مكتوب بوده و موضوعاتي چون شكل دراختيار قرار دادن اطلاعات درخواست شده، محلي كه اطلاعات درخواست شده در آنجا در اختيار او قرار داده مي‌شود، مدت زماني كه متقاضي مي‌تواند به اطلاعات دسترسي داشته‌باشد، دلايل كافي براي استنكاف از پاسخگويي به تمام يا هر بخش از درخواست اطلاعات را در بر داشته باشد.

موسسه بايد در صورت امتناع از پاسخگويي بيان كند كه آيا موسسه عمومي اطلاعات درخواست‌شده را دارد يا نه و دلايل كافي براي‌امتناع از ارايه اطلاعات را اعلام كند و حق اعتراض درخواست‌كننده به تصميم آن موسسه و مهلت آن را اعلام كند.

همچنين موسسه بايد نام و نشاني موسسه يا موسسات ديگري كه اطلاعات تفصيلي درباره موضوع مورد نظر متقاضي در اختيار دارند را ارايه داده و هزينه‌هايي كه درصورت لزوم متقاضي بايد مطابق اين قانون دررابطه بايك بخش از درخواست يا تمام آن بپردازد.

"پاسخي كه توسط موسسات خصوصي به درخواستهاي دسترسي به‌اطلاعات داده مي‌شود بايد به صورت كتبي و مواردي چون هزينه‌هايي كه در صورت لزوم در رابطه با درخواست پرداخت شود، شكل دسترسي متقاضي به اطلاعات درخواست شده، دلايل كافي در رابطه با رد درخواست يا بخشي از آن، حق اعتراض به تصميم آن موسسه و مهلت آن را به فرد اعلام كند."
بر اساس ماده ‪ ۲۸‬اين لايحه، در اختيار قرار دادن اطلاعات درخواست شده مي تواند، به پرداخت هزينه‌هاي متعارف و معقول توسط شخص متقاضي منوط شود كه اين هزينه‌ها نبايد از هزينه‌هاي واقعي جستجو، آماده‌سازي و در اختيار قرار دادن اطلاعات كه براي پاسخگويي به درخواست لازم است، تجاوز كند.

اين لايحه تصريح دارد كه دريافت هزينه براي درخواست دسترسي به اطلاعات شخصي درخواست‌كننده و درخواست‌هاي حايز نفع عمومي مجاز نيست و در صورت اختلاف، تشخيص درخواست‌هاي حايز نفع عمومي با كميسيون آزادي اطلاعات خواهد بود.

"هريك از وزرا و مسوولان نهادهاي حكومتي مي‌توانند باتاييد كميسيون آزادي اطلاعات و در چارچوب قانون طي دستورالعملي، شيوه محاسبه هزينه‌ها، مواردي كه پرداخت هزينه لازم نيست و حداكثر ميزان هزينه‌هايي را كه مي‌توان دريافت كرد مشخص كنند."
رونوشت مصدق از سند حاوي اطلاعات، رويت سند حاوي اطلاعات و در صورت لزوم استفاده از تجهيزات معمولي موجود در موسسه مربوط براي تهيه رونوشتي از آن، تهيه نسخه تصويري از سند حاوي اطلاعات با استفاده از وسايل شخصي، تهيه نسخه‌اي از متن گنجانده شده در يك اثر صوتي يا تصويري يا نرم افزاري، تهيه يك نسخه دست نوشته‌از سند حاوي اطلاعات از راه‌هايي است كه فرد مي‌تواند براي دسترسي به اطلاعات به موسسه پيشنهاد كند.

موسسه دريافت‌كننده درخواست دسترسي به اطلاعات بايد اطلاعات درخواستي را به شكل پيشنهادي متقاضي در دسترس او قرار دهد.

همچنين اين لايحه تصريح دارد: در صورتي كه درخواست دسترسي به اطلاعات متضمن مواردي از قبيل ايجاد اخلال غيرمتعارف در فعاليت موثر موسسه باشد، موسسات عمومي ياخصوصي ملزم به ارايه اطلاعات در اشكال مورد نظر متقاضي نيستند.

"درصورتي كه شكل درخواست شده متقاضي براي نگهداري از سند حاوي اطلاعات زيانبار باشد و به دليل نبود امكانات لازم، ارايه اطلاعات در شكل درخواست شده واقعا امكان پذير نباشد موسسه مي‌تواند آن را ارايه نكند."
" همچنين درصورتي كه سند حاوي اطلاعات به‌بيش ازيك زبان موجود باشد، اطلاعات درخواست شده بايد به زباني كه متقاضي ترجيح مي‌دهد دراختيار او قرارگيرد." دراين لايحه آمده است : "چنانچه مامور دريافت‌كننده درخواست دسترسي به اطلاعات تشخيص دهد كه اطلاعات درخواست شده در موسسه مربوط به او يافت نمي شود، بايد درخواست مذكور را به واحد اطلاع رساني ارجاع نمايد و واحد اطلاع -رساني بايد بررسي كند كه آيا موسسه عمومي مرجوع‌اليه، اطلاعات درخواست شده را دارد يا نه."
"اگر اطلاعات را ندارد ولي موسسه ديگري را مي‌شناسد كه‌اطلاعات درخواست شده را دارد در سريع‌ترين فرصت ممكن درخواست را به آن موسسه ارجاع و موضوع را به شخص متقاضي كتبا اطلاع دهد."
همچنين اگر اطلاعات درخواست شده از موسسه خصوصي در آن موسسه يافت نشود موسسه بايد كتبا به متقاضي اعلام كند كه‌اطلاعات درخواست شده را ندارد.

"اگر موسسه عمومي ياخصوصي به درخواست شخصي پاسخ قانوني داده باشد مكلف نيست به درخواست كاملا مشابه همان شخص كه ظرف مدت يك ماه پس از درخواست اول داده شده، پاسخ دهد."
درفصل سوم اين لايحه كه به موضوع "ترويج شفافيت" اختصاص دارد،آمده است:
"كميسيون آزادي اطلاعات بايد در سريع‌ترين فرصت ممكن، يك راهنماي ساده و روشن تهيه كند كه اطلاعات عملي لازم براي تسهيل اجراي موثر حقوق پيش بيني شده دراين قانون درآن گنجانده شده باشد و اين راهنما را به رايگان در سطح وسيع، به صورتي كه در دسترس همگان باشد، منتشر كند كه راهنماي مذكور بايد به طور منظم به روز شود."
واحداطلاع رساني علاوه‌برتعهدات ناشي از ديگر مواد اين قانون مكلف است در موسسه عمومي، بهترين رويه‌هاي ممكن را در رابطه بانگهداري اسناد و اطلاعات، بايگاني و در اختيار قرار دادن آنها در موسسه خود توسعه داده و تشويق كند.

همچنين واحد اطلاع رساني بايد به‌عنوان مرجعي براي دريافت درخواست‌هاي اطلاعات، كمك به‌افرادي كه در جستجوي اطلاعات هستند و دريافت شكايات افراد راجع به عملكرد موسسه عمومي در زمينه رعايت آزادي اطلاعات عمل كند." موسسات عمومي بايد اطلاعات مورد نياز درباره مسوول واحداطلاع رساني نظير نام و نام خانوادگي، وظيفه و شيوه‌هاي تماس بااو را جهت دسترسي آسان اعضاي جامعه به وي اعلام كنند.

هريك از موسسات عمومي بايد در راستاي نفع عمومي، دست كم به طور سالانه، اطلاعات كليدي خود را از قبيل توصيف ساختار، كاركردها، وظايف و هزينه‌هاي مالي را در يك كتاب راهنما منتشر سازند.

ارايه جزييات لازم راجع به خدماتي كه مستقيما به‌اعضاي جامعه ارايه مي‌دهد، ساز و كارهاي شكايت شهروندان از تصميمات يااقدامات آن موسسه به همراه گزارشي از شكايت‌ها وپاسخي كه موسسه به‌آنها داده‌است از ديگر مواردي است كه در كتاب راهنما بايد ذكر شود.

دراين لايحه همچنين اطلاعات كافي درباره سيستم‌هاي نگهداري اطلاعات، انواع و اشكال اطلاعاتي كه نگهداري مي‌كنند، مقوله‌هاي اطلاعاتي كه منتشر مي‌سازند و آييني كه براي تقديم درخواست دسترسي به اطلاعات بايد رعايت شود.

ارايه توصيفي از اختيارات و وظايف ماموران ارشد خود و آيين تصميم‌گيري در موسسه، هر نوع مقررات، اصول و خط مشي‌هاي كلي، قواعد، دستورالعمل‌هاي مربوط به وظايف و اختيارات موسسه، مفاد و محتواي تمام‌تصميمات و خط مشي‌هاي كلي موسسه كه آزادي‌ها يا حقوق مردم را تحت الشعاع قرار مي‌دهد به همراه دلايل توجيهي آنها و هرگونه تفسيرهاي رسمي از آن‌ها نيز بايد ذكر شود.

همچنين تمام ساز وكارها يا آيين‌هايي كه به وسيله آنها اشخاص حقيقي و حقوقي و سازمان‌هاي غيردولتي مي‌توانند در سياست‌گذاري‌ها يا اجراي اختيارات آن واحد مشاركت داشته يا به نحو ديگري موثر واقع شود، نيز ذكر خواهد شد.

بر اساس ماده ديگري از اين لايحه،از تاريخ لازم‌الاجرا شدن اين قانون، هيچ قانون و نيزهيچ مصوبه موجد حق و تكليف عمومي قابل طبقه‌بندي به‌عنوان اسرار دولتي‌نيست و كليه طبقه‌بندي‌هاي موجود دراين زمينه لغو مي‌شود و انتشار آن‌ها الزامي خواهد بود.

هرگاه اطلاع‌رساني متعارف درباره قوانين و مصوباتي كه حق و تكليف عمومي ايجاد مي‌كنند نظير مصوبات هيات وزيران،شوراهاي‌شهرستان و استان و شوراهاي عالي حكومتي نظير شوراي عالي انقلاب فرهنگي، شوراي عالي‌اداري، شوراي عالي اقتصاد و شوراي عالي كار صورت نگرفته باشد و متخلف اثبات كند كه هيچ‌گونه اطلاعي از آن قوانين يا مصوبات نداشته و بدون آنكه مرتكب تقصير شده باشد نسبت به آنها جاهل بوده، موسسات عمومي مجاز نخواهند بود تا به استناد آن قوانين يا مصوبات، اشخاص را از حقوق و امتيازات ناشي از قانون يا مصوبه آن محروم سازند يا آنها را به دليل تخلف از قانون يا مصوبه مذكور مسوول شناخته ومورد تعقيب اداري،انضباطي، مدني يا كيفري يا مشمول جريمه مالياتي قرار دهند.

"كميسيون‌آزادي اطلاعات بايد راهنمايي درباره نحوه حسن‌انجام تكليف موسسات عمومي نسبت به‌انتشار اطلاعات تهيه و منتشرسازد و حسب‌درخواست نيز به موسسات عمومي درباره تكليف‌آن‌ها نسبت به‌انتشار اطلاعات،راهنمايي‌هاي لازم ارايه دهد.

"موسسه عمومي مكلف است تا اطلاعات خود را به شيوه‌اي نگهداري كند كه حق دسترسي به آنها را بدان‌گونه كه در اين قانون پيش‌بيني شده، تسهيل كند." كميسيون آزادي اطلاعات پس از مشورت لازم با موسسات ذي ربط بايد راجع به نگهداري، اداره و در اختيار قرار دادن اطلاعات و ارسال آنها به مركز ملي نگهداري اطلاعات، دستورالعمل لازم را تهيه و به آنها ابلاغ مي‌كند.

هيات وزيران نيز مكلف است اساسنامه مركز ملي نگهداري اطلاعات را تهيه و تصويب كند.

موسسات عمومي بايد حق دسترسي به اطلاعات و اجراي موثر اين قانون را به ماموران خود آموزش دهد و واحد اطلاع رساني موسسه عمومي بايد گزارش سالانه درباره فعاليت‌هاي آن‌موسسه دراجراي اين‌قانون به‌كميسيون آزادي اطلاعات ارايه دهد.

درصورتي كه درخواست متقاضي به اسناد و اطلاعات طبقه‌بندي شده توسط دولت (اسرار دولتي) مربوط باشد موسسات عمومي بايد از دراختيار قرار دادن آن‌ها امتناع كنند.

"دسترسي به اطلاعات طبقه‌بندي شده تابع قوانين و مقررات خاص خود خواهد بود."
همچنين چنانچه اطلاعات درخواست شده در زمره اطلاعاتي باشد كه جنبه خصوصي داشته و بصورت عرفي در دسترس ديگران قرارنگيرد، يا در زمره اطلاعاتي باشد كه با نقص احكام حريم خصوصي تحصيل شده‌است، درخواست دسترسي بايد رد شود.

موسسات مشمول اين قانون درصورتي كه پذيرش درخواست متقاضي متضمن افشاي غيرمعقول اطلاعات شخصي درباره يك شخص حقيقي ثالث باشدمي‌توانند از دراختيار قرار دادن اطلاعات درخواست شده خودداري كنند.

در صورتي كه شخص ثالث به نحو صريح به افشاي اطلاعات راجع به خود رضايت داده باشد يا شخص متقاضي، ولي يا قيم يا وكيل شخص ثالث در حدود اختيارات خود باشد، مي‌توان اطلاعات را ارايه داد.

همچنين درصورتي كه متقاضي در زمره خويشان درجه‌اول تا درجه‌سوم شخص ثالث باشد و دسترسي به اطلاعات شخصي او براي اطلاع از حيات، سلامتي يا آزادي او و انجام ساير اقدامات مقتضي ضروري باشد و يا متقاضي يكي از موسسات عمومي باشد و اطلاعات درخواست شده به صورت مستقيم به وظايف آن به عنوان يك مامور عمومي مرتبط باشد مي‌توان اطلاعات را ارايه داد.

براساس اين لايحه درصورتي كه موسسات مشمول اين قانون ظن قوي داشته باشند كه دراختيار قراردادن‌اطلاعات درخواست شده،سلامت‌افراد را به‌مخاطره مي‌اندازد مي‌توانند از در اختيار قراردادن اطلاعات امتناع كنند.

درصورتي كه اطلاعات درخواست شده، برمبناي‌اعتماد، از شخص ثالث دريافت شده باشد و حاوي‌اسرار تجاري باشد يا دراختيار قراردادن آن به احتمال‌قوي خسارت شديد به منافع تجاري يا مالي شخص ثالث وارد كند موسسه مي‌بايد از دراختيار قرار دادن اطلاعات خودداري كند.

موسسات مشمول اين قانون مي‌توانند از دراختيار قراردادن اطلاعات درخواست شده،خودداري كنند، مشروط براينكه ظن قوي وجود داشته باشد كه ارايه اطلاعات لطمه شديد وارد خواهد كرد.

پيشگيري از جرايم يا كشف آنها، بازداشت يا تعقيب مجرمين، مميزي ماليات يا عوارض قانوني يا وصول آنها و نيز اعمال نظارت بر مهاجرت به كشور از مواردي است كه بر اساس ماده فوق مي‌توان از ارايه آن خودداري كرد.

براساس يكي از تبصره‌هاي اين لايحه، استثناي فوق هيچ لطمه‌اي به حقوق مظنونان و متهمان يا محكومان وارد نمي‌كند.

هرگاه درخواست دسترسي به نتايج‌اقداماتي كه داراي تبعات زيست محيطي است مربوط باشد و اطلاعات درخواست شده يك خطر شديد نسبت به سلامت عمومي يا محيط زيست را آشكار سازد موسسات فوق نمي‌توانند بااستناد به استثناهاي فوق از ارايه اطلاعات خودداري كنند.

چنانچه درخواست دسترسي به اطلاعات، مربوط به مواردي باشد كه درزمره يكي از استثناها قرارمي‌گيرد، آن‌بخش از اطلاعات كه مشمول استثنا نيست، بايد تا اندازه‌اي كه به طور معقول از اطلاعات غيرقابل دسترس تفكيك پذيراست، جدا شده و در دسترس متقاضي قرار گيرد.

در فصل پنجم اين لايحه كه به كميسيون آزادي اطلاعات اختصاص دارد، تصريح شده است:به‌منظور حمايت از آزادي اطلاعات و دسترسي همگاني به اطلاعات موجود در موسسات عمومي و موسسات‌خصوصي كه خدمات‌عمومي ارايه‌مي‌دهند وانجام وظايفي كه در اين قانون پيش‌بيني شده‌است و نظارت بر حسن اجراي اين قانون، كميسيون آزادي اطلاعات تشكيل مي‌شود.

"دو صاحب نظر به‌غير از نمايندگان مجلس به انتخاب مجلس شوراي‌اسلامي، براي مدت ‪۳‬سال، رييس مركز اسرار دولتي يا نماينده وي، رييس سازمان مديريت و برنامه‌ريزي كشور يا نماينده وي،رييس شوراي عالي اطلاع‌رساني يا نماينده وي، يك صاحب نظر به انتخاب هيات وزيران براي مدت ‪۳‬سال، يك نفر از قضات ديوان عدالت اداري به انتخاب رييس قوه قضاييه براي مدت ‪۳‬سال، دو نفر به انتخاب سازمان‌هاي غيردولتي براي مدت ‪ ۳‬سال، يك‌نفر به‌انتخاب انجمن صنفي مطبوعات، براي مدت ‪ ۳‬سال و يك نفر به انتخاب كانون وكلاي مركز، براي مدت ‪۳‬سال اعضاي اين كميسيون را تشكيل مي‌دهند."
رييس اين كميسيون با راي اكثريت اعضاي كميسيون براي مدت ‪ ۲‬سال از ميان اعضا انتخاب مي‌شود و انتخاب مجدد وي تنها براي يك دوره ديگر بلامانع است.

"كميسيون داراي شخصيت‌حقوقي و استقلال‌مالي و اداري‌است واشخاصي كه درخواست دسترسي به‌اطلاعات به‌موسسات‌عمومي ياخصوصي تسليم‌كرده‌اند مي‌توانند از تصميمات يا اقدامات آنها كه برخلاف اين قانون صورت مي‌گيرد، به‌كميسيون شكايت كنند.

خودداري موسسه از اعلام اين امر كه آيا اطلاعات درخواست شده را در اختيار دارد يا نه، خودداري از دادن اطلاعات درخواست شده، عدم پاسخگويي موسسه در مهلت پيش‌بيني شده در لايحه، عدم پاسخگويي كتبي موسسه به طرق پيش‌بيني شده، تحميل هزينه‌هاي غيرمتعارف بر درخواست‌كننده بر خلاف لايحه،خودداري موسسه از دادن اطلاعات در شكل خواسته شده بر خلاف اين قانون از جمله مواردي است كه فرد مي‌تواند به كميسيون مذكور شكايت كند.

كميسيون بايد حداكثر ظرف ‪ ۳‬ماه به شكايت‌هايي كه مطابق به آن تسليم شده است رسيدگي و به طور مستدل اتخاذ تصميم كند.

در مورد هر شكايت، كميسيون به شاكي و موسسه‌عمومي يا خصوصي مربوط ‪ ۲۰‬روز فرصت مي‌دهد تا نظرات خود را به صورت كتبي ارايه دهد.

"در رسيدگي به‌تمامي شكايت‌هايي كه مطابق اين لايحه تسليم كميسيون مي‌شود، موسسات عمومي يا خصوصي بايد اثبات‌كنند كه مطابق با تكاليف پيش‌بيني شده در اين قانون انجام وظيفه كرده‌اند."
كميسيون در تصميمي كه مطابق با مواد اين قانون اتخاذ مي‌كند مي‌تواند، تقاضاي تسليم شده را رد كند، ازموسسه عمومي يا خصوصي بخواهد اقدامات لازم براي رعايت تكاليف پيش‌بيني شده در فصل دوم اين قانون را انجام دهند.

درصورت مشاهده بي‌احتياطي يا تقصيرعمدي كاركنان و مستخدمان موسسات عمومي يا خصوصي در عدم رعايت تكاليف پيش‌بيني شده در اين قانون، موضوع را براي رسيدگي انضباطي يا كيفري به مراجع صالحه گزارش دهد.

كميسيون بايد تصميم‌خود را باتصريح به‌امكان اعتراض از آن و مرجع و مهلت آن، به شاكي و موسسات عمومي يا خصوصي مربوط ابلاغ كند.

همچنين كميسيون مي‌تواند بصورت مستقيم از موسسات عمومي بخواهد اقدامات ضروري براي رعايت تكاليف پيش‌بيني شده در فصل سوم،اقداماتي چون ايجاد واحد اطلاع‌رساني درصورتي كه موسسه‌عمومي فاقد واحدمذكورباشد،انتشار برخي اطلاعات، اعمال تغييرات در شيوه‌هاي مربوط به نگهداري، نابودسازي اطلاعات و يا ارسال و انتقال اطلاعات به مركز ملي نگهداري آن‌ها و به‌طور كلي مديريت اطلاعات در چارچوب اين قانون را انجام دهد.

"ارتقاي سطح آموزش ماموران در زمينه حق‌دسترسي به‌اطلاعات، در اختيار قرار دادن گزارش سالانه مطابق با مواد اين قانون و معرفي متخلفان ازفصل سوم اين قانون به هيات‌هاي رسيدگي به تخلفات‌اداري از ديگر مواردي‌است كه كميسيون مي -تواند، انجام دهد."
در اين‌لايحه تصريح شده‌است: كميسيون بايد تصميم خود را با تصريح به امكان اعتراض از آن و مرجع و مهلت آن به موسسه عمومي مربوط ابلاغ كند.

كميسيون جهت تصميم‌گيري مطابق مواد اين قانون اختيار دارد تا هر نوع تحقيقي را كه لازم‌مي‌داند در چارچوب قانون انجام‌دهد از جمله دستورات لازم را به موسسات و اشخاص ذي‌ربط جهت ارايه‌دليل و دعوت‌شهود به‌اداي شهادت را صادر كند و موسسات ذي‌ربط ملزم هستند تا باكميسيون همكاري‌لازم را به عمل آورند.

"شاكي ياموسسه خصوصي مربوط حسب مورد مي‌توانند ظرف ‪ ۳۰‬روز از تاريخ ابلاغ تصميم كميسيون از آن، به ديوان عدالت اداري شكايت كند چنانچه ديوان تصميم را نقض كند بايد مستقيم رسيدگي كرده و تصميم مقتضي صادر كند."
هرگاه ظرف ‪ ۳۰‬روز از تاريخ ابلاغ تصميم كميسيون از آن شكايت نشود تصميم صادر شده قطعي و لازم‌الاجرا خواهدبود و چنانچه ظرف ‪ ۲۰‬روز از تاريخ قطعي‌شدن تصميم كميسيون، موسسه ذي‌ربط اقدامي جهت رعايت آن به عمل نياورد كميسيون بايد به صورت مكتوب موضوع را به دادگاه محل اقامت وي اعلام كند.

مستنكف از تصميم كميسيون به مجازات پيش‌بيني شده براي استنكاف از اجراي تصميمات قضايي محكوم خواهد شد.

براين اساس، كميسيون بايد ظرف سه‌ماه پس از پايان هر سال مالي، گزارشي درباره رعايت اين‌قانون در موسسات عمومي، فعاليت‌هاي خود و حساب‌هاي رسيدگي شده خود در طول آن سال مالي را به‌مجلس شوراي‌اسلامي و رييس‌جمهور تقديم كند.

مجلس شوراي اسلامي و رييس جمهور هر زمان مي‌توانند از كميسيون بخواهند كه درمورد قضيه خاصي گزارش موردي ارايه دهد و كميسيون نيز مي‌تواند هر گزارشي را كه مقتضي بداند به مجلس شوراي اسلامي يا رييس جمهوري ارايه دهد.

تعقيب كيفري رييس و اعضاي كميسيون يا شخصي كه به نمايندگي ازآن يا تحت نظر ايشان انجام وظيفه مي‌كند، به خاطر كارهايي كه در اجراي اختيارات يا وظايف قانوني خود انجام داده‌اند، يا به خاطر گزارش‌هايي كه منتشر كرده‌اند قابل طرح نيست مگر آنكه سوء‌نيت آن‌ها اثبات شود.

در فصل ششم كه به افشاكنندگان خطاهاي حكومت اشاره‌شده، تصريح شده است:
هيچ‌كس را نمي‌توان به خاطر فاش ساختن اطلاعات راجع به خطاها يا اشتباهات موسسات عمومي يا به خاطر افشاي اطلاعاتي كه حاكي ازوجود تهديد جدي نسبت به بهداشت ، سلامت افراد يا محيط زيست، حقوق يا آزادي‌هاي شهروندي هستند، مورد مجازات‌هاي كيفري،اداري يا انضباطي قرار داد.

اين لايحه مي‌افزايد: مگر آنكه وي ظن قوي داشته باشد آن اطلاعاتي كه افشا مي كند حقيقي و درست هستند و دليل خطا يا تهديد جدي نسبت به بهداشت، سلامت افراد يا محيط زيست و يا حقوق و آزادي‌هاي شهروندي است.

"خطا" در اين مورد به معني ارتكاب جرم يا نقض يك تكليف قانوني يا عرفي، يا سوء اجراي عدالت، فساد و سوء اداره جدي يك موسسه عمومي است.

مسووليت‌هاي مدني و كيفري نيز آورده است : هر شخصي كه در نتيجه انتشار اطلاعات غيرواقعي درباره‌او به‌آبرو و شهرتش آسيب وارد شده،حق دارد تا مطابق با قواعد عمومي مسووليت مدني جبران خسارت‌هاي وارد شده را مطالبه كند.

اشخاص حقوقي، كه حقوق عمومي در نتيجه انتشار اطلاعات غيرواقعي به منافع مشروع و از جمله به‌شهرت آنها صدمه وارد شده است مي‌توانند اطلاعات مذكور را تكذيب كنند يا توضيحاتي درباره آنها ارايه دهند و خسارتهاي مادي وارد شده را مطالبه كنند.

اشخاص‌مذكور درماده فوق به هيچ وجه نمي‌توانند به ادعاي هتك حرمت، توهين، افترا يا نشر اكاذيب، تهيه‌كننده ياانتشاردهنده اطلاعات را تحت تعقيب كيفري قرار دهند.

ارتكاب عمدي اعمال جرم‌است و مرتكب‌شونده به‌پرداخت جزاي‌نقدي از سه ميليون تا ده ميليون ريال و يا به حبس از سه ماه و ‪ ۱‬روز تا ‪ ۱۸‬ماه محكوم خواهد شد.

هر فعل يا ترك فعلي كه مانع دسترسي به اطلاعات برخلاف مقررات اين قانون شود و هر فعل يا تركي فعلي كه مانع انجام وظيفه كميسيون آزادي اطلاعات يا وظيفه اطلاع رساني موسسات عمومي برخلاف مقررات اين قانون شود و امحاي جزيي يا كلي اطلاعات بدون داشتن اختيار قانوني اعمال عمدي محسوب مي‌شوند.

دربخش قوانين و مقرراتي كه‌افشاي اطلاعات‌عمومي را ممنوع يامحدود مي‌سازند نيز آمده است: از تاريخ لازم‌الاجراشدن اين قانون تمامي قوانين و مقرراتي كه افشاي‌اطلاعات مشمول اين‌قانون توسط موسسات عمومي ياخصوصي را ممنوع يا محدود مي‌سازند، لغو مي‌شود.

هيچ يك از مواد اين قانون، افشاي اطلاعاتي را كه مطابق با ديگر قوانين و مقررات مجاز است، محدود نمي‌سازد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 16 تیرماه 1384

11:31 AM

July 07, 2005

مكا نيسم هاى پرداخت در تجارت الكترونيك

آی تی ایران - تجارت الكترونيكى دادوستد تجار را وارد عصر الكترونيكى كرده است. اين نوع تجارت به دليل سرعت عمل بالا و صرف هزينه كم در جهان از جايگاه خوبى بر خوردار است. تجارت الكترونيك در تمام ابعاد خود رشد افزونى كرده است. در قرن 19 ميلادى براى اولين
بار دادوستد از طريق تلفن صورت گرفت. در اواسط قرن 20 نخستين كارتهاى اعتبارى عرضه شدند و در دهه 1960 از شبكه هاى رايانه اى‌، پست الكترونيكى و صندوق اتوماتيك بانكى استفاده شد. ظهور اينترنت در سال 1989 و استفاده گسترده از رايانه هاى شخصى در سال 1990 از جمله مهمترين عوامل در تحول تجارت الكترونيك بودند. مهمترين ركن در
تجارت الكترونيك نوع مكانيسم پرداخت است.

خريداران و فرو شندگان با توجه به ميل شخصى خود يكى از اين نوع روشÙ!
‡اى پرداخت را انتخاب مى كنند.انتخاب روشهاى پرداخت الكترونيكى و حذف واسطه گريها در اين نوع پرداخت موجب شكوفايى اقتصادى و افزايش منافع شده است. اين نوع مكانيسم پرداخت تنها محدود به كشور خاصى نيست بلكه جنبه بين الملى دارد. نكته قابل توجه اين است كه نوع مكانيسم پرداخت در تجارت االترونيك داخلى با تجارت در سطح بين
الملل متفاوت است. تجاردر تجارت بين الملل از روش پرداختى استفاده مى نمايند كه منافعشان تأ مين شود.كارتهاى اعتبارى ، پول الكترونيكى ،كارتهاى حافظه اى ، كارتهاى هوشمند ، چكهاى الكترونيكى در تجارت بين الملل كارآيى ندارد بلكه در تجارت داخلى Ø!
§ز اين نوع روشها به جهت صرف هزينه و وقت كم مى توان استفاده كرد. امروزه شاهد گسترش استفاده از اين نوع روشهاى پرداخت در كشورمان هستيم. حال به بررسى هر يك از اين روشهاى پرداخت مى پردازيم.

كارتهاى اعتبارى
اين نوع كارتها ممكن است با كارتهاى بدهى الحاق شده و تحت عنوان\\" سيستم هاى انتقال بدهى\\" ارائه شوند.استفاده از هر يك از اين نوع كارتها جهت پرداخت ارتباط تنگاتنگ با خريد و فروش اينترنتى دارد كه شباهت بسيارى با روشهاى ديگر پرداخت اعم از فكس،تلفن وپست دارد. در اين نوع سيستم پرداخت كارت به معناى واقعى و امضاء آن در عمل توسط در
يافت كننده وجه روئيت نمى شود. ميزان وجه و روز انقضاء از طريق اينترنت توسط پست الكترونيكى يا وب سايت انتقال داده مى شود. در حال حاضر استفاده از اين نوع كارتها به دليل صرف هزينه و وقت كم جهت آشنايى با آنها بسيار رايج است.

مكانيسم كارت اعتبارى بدين ترتيب است كه خريدار (دارنده كارت) به بانكى دستور مى دهد كه وجه درخواستى فروشنده را از محل قرضى كه از بانك كرده است، بپردازد. در انتهاى هر ماه بانك براى صاحب كارت صورت حسابى مبنى بر پرداختهاى انجام گرفته، ارسال مى كند. در حقيقت مبادلات از طريق كارتهاى اعتبارى متضمن يك تعهد ( دريافت وام) است. در صورتى كه بين كشورها و بانكهاى آنها ارتباطات لازم وجود داشته باشد توسط اين كارتها مى توان پول نقد را در خارج از كشور نيز دريافت كرد.

در مورد كارتهاى بدهكار بر خلاف كارتهاى اعتبارى مى توان به اين امر اشاره كرد كه دارنده
كارت قبل از استفاده بايد به مقدار لازم در حساب خود پول داشته باشد و در اين نوع كارتها حساب دارنده بلافاصله يا پس از پايان روز معامله بدهكار مى گردد.
اساس كار سيستم كارت اعتبارى بر پايه اعتماد است و فروشنده مى تواند كالا را خريدارى كند و
پرداخت متعاقبأ صورت گيرد.پرداخت وجه از طريق كارت اعتبارى تضمين شده است و تضمين كننده مسئول پرداخت صورت حساب مشترى و جمع آورى وجه را داراست.

در معاملات سنتى، مشترى كارت اعتبارى را ارائه مى دهد، تاجر امضاء و انعقاد معامله را جهت دستيابى به رمز تأييد شده، تفويض مى كند.هر زمان كه تاجر كارت اعتبارى را از طريق تلفن،پست الكترونيكى و اينترنت تأييد نمايد در اين صورت تضمين كننده كارت ريسك عدم پرداخت را نيز قبول مى كند.در هر حال تاجر مسئول خسارات ناشى از استفاده كارت تقلبى است به فرض مثال زمانيكه خريدار مالك كارت نباشد و از كارت مزبور استفاده كند، در اين صورت هزينه خسارات قبول كارتهاى اعتبارى به دليل توسعه تجارت بر عهده تاجر است. البته در قانون بعضى از كشورها دارنده كارت در صورت سؤاستفاده! از كارت وى تا سقف 50 دلار مسئول خسارت است.

به جهت جلوگيرى از كارتهاى تقلبى و كاهش جرائم حاصل از آن به طور معمول از رويه هاى استانداردى تحت عنوان SET استفاده مى شود.هدف اين نوع پروتكل ايجاد امنيت در پرداختهاى كارتى است. پروتكل SET از يك كليد رمز نگارى و گواهينامه هاى ديجيتالى براى تأييد هويت تاجر و مصرف كنندگان استفاده مى كند. مهم ترين ويژگى اين پروتكل ايجاد امنيت و
تأييد هويت كاربر است.

پول الكترونيكى
پول الكترونيكى يكى از مكانيسم هاى پرداخت الكترونيكى است كه براى معاملات بى نام مورد
استفاده قرار مى گيرد و موجب گسترش تجارت الكترونيك گرديده است. هيچ گونه ابزار پرداخت
مادى از قبيل پول كاغذى و سكه درمكانيسم پول الكترونيكى دخالتى ندارد. هنگامى كه گرايش به سمت كارت اعتبارى به عنوان يكى از مكانيسم هاى پرداخت افزايش يافت و سيستم هاى پرداخت اينترنتى موردقبول جوامع واقع شد پول الكترونيكى يكى ديگر از انواع پرداخت
الكترونيكى براى معاملات الكترونيكى طراحى شد.امروزه در بسيارى موارد پول الكترونيكى در
تجارت الكترونيك جايگزين پول نقد شده است.

مكانيسم هاى ديگر پرداخت از قبيل كارتهاى هوشمند و حتى چكهاى الكترونيكى مى توانند به عنوان اشكالى از پول الكترونيكى طبقه بندى گردند.پول الكترونيكى شكلى از بهاى اندوخته شده است كه به آسانى در ساختارهاى الكترونيكى قابل معامله است در صورت حذف عبارت ساختار الكترونيكى از تعريف فوق اين تعريف مشمول پول كاغذى و سكه مى شود. پول الكترونيكى همانند پول كاغذى است با اين تفاوت كه در مورد پول الكترونيكى در زمان
وقوع معامله ارزش و بها كالا نيز انتقال داده مى شود اما وجه بعدا\\" پرداخت مى شود.يكى از
ويژگيهاى خاص پول الكترونيكى كه منجر به تمايز آن با پول كاغذى مى گردد بى نام بودن پرداخت كننده (مشترى) است هنگاميكه وى از پول الكترونيكى صرفا\\" جهت پرداخت استفاده مى نمايد. بانكMark Twain در ايالات متحده از جمله بانكهايى بود كه آغاز به صدورپول الكترونيكى نمود. اين نوع مكانيسم پرداخت مشتمل برخريد اعتبارات از بانك با ارزش معين است كه براى تجارت الكترونيك مورد استفاده قرار مى گيرد.بسيارى از تجار و مصرف كنندگان به دليل اينكه ضرر و زيان در اين نوع مكانيسم پرداخت كاهش يافته است پول الكترونيكى را جهت پرداخت وجه درمعاملات خود انتخاب مى نما يند. اشخاصى كه توانايى دستيابى به كارت اعتبارى را به جهت عدم داشتن اعتبار كافى را نداشته باشند مى توانند از پول الكترونيكى استفاده كنند. هنگاميكه فردى با پول كاغذى كالايى را خريدارى مى نمايد معمولا\\" تاجر در باب هويت وى سئوالى نمى نمايد (حتى اگر فردى كالاهايى از قبيل الكل- تنباكو- اسلحه و... خريدارى نمايد) گرايش به سمت معاملات پول الكترونيكى بى نام اينترنتى درآمريكا نسبت به اروپا ناچيز است البته شايان ذكر است كه اروپائيان نخستين مصرف كنندگانى بودند كه از اين نوع معاملات استفاده نمودند.در اروپا اكثر مصرف كنندگان به اين نوع روش پرداخت در معاملات اينترنتى گرايش دارند.صحت و سقم پول الكترونيكى بايد مورد تأييد قرار گيرد در اين صورت باىØ!
¯ سيستم تأييد كننده اى موجود باشد كه اقدام به اين عمل نمايد همانند پول كاغذى كه داراى شماره سريال است. هنگاميكه شخص كالايى را خريدارى مى نمايد و پول الكترونيكى را از حساب شخصى خود دربانكى كه داراى حساب است برداشت مى نمايد.
بانك مزبور توانايى تأييد پول الكترونيكى را دارا است بدون اينكه هيچ گونه ارتباطى با اين
معامله داشته باشد. جهت روشن شدن مطلب به بيان مثالى در اين باب مى پردازيم:

مصرف كننده بانك توسط سخت افزار خاصى يك سكه سفيد طراحى مى نمايد.وى اين سكه را براى اينكه ارزش يك دلار يابد توسط پاكت نامه الكترونيكى براى بانك ارسال مى دارد. بانك يك دلار را از حساب وى كسر مى نمايد و درصورتيكه امضاء وى معتبر باشد سكه و پاكت ديجيتالى ارسال شده توسط وى داراى ارزش مى گردد. البته بانك مزبور سكه را نيز با امضاى خود تأييد مى نمايد. هنگاميكه بانك سكه با ارزش يك دلار را براى مصرف كننده ارسال مى دارد وى سكه مزبور را از داخل پاكت برداشته و مى تواند آن را خرج نمايد.تاجر نيز در صورت دريافت سكه آنرا جهت تأييد صحت براى بانك ارسال مى دارد بانك مزبور با مشاهده امضاء خود صحت سكه را تأييد مى نمايد.
در كشور ما هنوز از اين نوع روش پرداخت استفاده نمى شود البته اميد است كه چنين روش پرداختى نيز در سيستم پرداخت الكترونيكى تجارت الكترونيك رايج گردد. از جمله مهمترين ويژگيهاى پول الكترونيكى صرفه جويى در زمان وامنيت اين نوع سيستم است اگر چه احتمال كلاهبردارى نيز است اما با وجود پروتكل هاى امنيتى SET,SSL اين نوع جرايم
نيز كاهش پيدا كرده است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 17 تیرماه 1384

11:00 PM

July 08, 2005

صنعت طراحی وب ایران: هر چقدر که تيغ مى برد

iranseo - صنعت طراحى وب ايران کمتر از ده سال عمر دارد و همانند بسيارى از کشورهاى ديگر به طور کلى صنعتى نوپاست. بازار اين صنعت در داخل کشور، بسيار گسترده و بزرگ است و شرکتهاى بسيارى نيز به عنوان طراح وب در آن فعاليت مى کنند. سال گذشته سايتهاى بسيارى توسط همين شرکتها در وب منتشر شد. از سايتهاى کوچک و شخصى گرفته تا سايتهاى تجارت الکترونيک و پورتالهاى بزرگ دولتي. آنچه که اين مقاله بدان مى پردازد عمدتا تحليل استراتژى هاى ناکارامد به کار گرفته شده از سوى شرکتهاى فعال در اين حوزه است.

1- بازارسنجى ضعيف: اين شرکتها به همه درخواستها پاسخ دادند و با تمام مشتريان چه کوچک و چه بزرگ پاى ميز مذاکره نشستند و يا آنها را به پاى ميز مذاکره کشاندند. ديدگاه منطقى آن است که هر شرکت با توجه به ملاحظات و بررسى هاى مختص به خود بخشى از بازار را مورد هدف قرار دهد و سياستهاى کارى خود را نيز متناسب با همان بازار تدوين کند. اما متاسفانه اغلب آنان بدون سياست کارى بوده و چون بازار مخاطب خود را انتخاب نمى کنند، طبيعتا در تمام بازار به دنبال مشترى و عقد قرار داد مى گردند.

از اين استراتژى ضعيف، روزنامه ها و مجلات به عنوان رسانه هاى تبليغ بيشتر سود مى برند. به نظر مى رسد اگر شرکتهاى ايرانى در انتخاب مشترى دقت بيشترى نشان دهند و از ميان مشتريان موجود، مشتريان بهتر و مطمئن ترى را برگزينند، سود و پايدارى کسب و کار خود را بهتر تضمين مى نمايند. "مشتريان بد" عموما وقت و هزينه شرکتها را اتلاف مى کنند و خدمات پشتيبانى ارايه شده به آنها در بيشتر موارد، پروژه هاى اجرا شده را ضررده مى کند.

حرکت به سوى چنين سياستى از سوى شرکتهاى مجرى، بازار را رشد مى دهد و مشتريان را مجبور به رعايت اصول و قواعد بازار مى کند. شايان ذکر است که که بازار طراحى وب ايران بازارى پخته نيست ضمن آنکه بسيار پراکنده و گسترده است. کنترل عرضه و تقاضا در اين بازار بسيار مشکل است و ميزان تقاضا از سوى مشتريان بنابه دلايل نامشخصى در بازه هاى زمانى مختلف، زياد و کم مى شود. اما با اينحال اين بازار با پارمترهاى نامشخص بازاريابى نمى تواند پوششى بر ضعف شرکتهاى فعال در طراحى وب باشد. بايد اذعان کرد که عموما آنها برنامه مشخص بازاريابى ندارند و استراتژى هاى اتخاذ شده از سوى آنها نيز تا حدى انفعالى و در واکنش به فعاليت ساير رقبا بوده است.

2- همه دنباله رو هستند: رقابت سازنده اى ميان شرکتها وجود ندارد. آنها ضمن آنکه همواره با يکديگر در رقابت هستند تقريبا به تخصص يکديگر احترام نمى گذارند. در بازار طراحى وب ايران همه مدعى هستند و متاسفانه اين بازار رهبر، پيشرو و يا شرکتى بسيار شاخص ندارد. در چنين شرايطى طبيعتا صحت ادعاها کمتر ارزيابى مى شود و چنانچه خلاف آن نيز ثابت شود، هيچ اتفاقى نمى افتد. نبود رهبر يا پيشرو، چنين بازارى را متاثر از پارامترهاى خارج از آن مى کند و بى ثباتى در آن موج مى زند. در هر بازارى اگر شرکت پيشرو از توانايى هاى لازم برخوردار باشد مى تواند در شکوفايى کل بازار نقش داشته باشد. متاسفانه هيچ شرکت طراح وب ايرانى تاکنون نتوانسته است به عنوان يک پيشرو نقش ايفا کند.

همانطور که گفته شد بازار طراحى وب ايران پخته نيست. در بازارهاى پخته همواره يک يا چند پيشتاز وجود دارند و شرکتهاى ديگر تا حدودى خود را با سياستهاى آنها تطبيق مى دهند. همچنين همواره در اين بازارها شرکتهايى هستند که شرکتهاى پيشرو را به رقابت مى کشانند و با مطرح کردن ايده هاى نو به دنبال دستيابى به سهم بيشترى از بازار هستند. به عنوان مثال رقابتى که گوگل در سالهاى اوليه فعاليت خود شروع کرد از اين نوع بود. گوگل در بازار جستجو، موتورهاى جستجوگر محبوب آن زمان را به رقابت طلبيد و در نهايت سهم عمده بازار را از آن خود کرد و آلتاويستاى پيشرو را از اريکه قدرت به پايين کشيد.

3- تکنولوژى هاى متفاوت: اوضاع در اين مورد کمى بهتر است. اصولا شرکتها، تکنولوژى خاصى را به دلايل مختلفى براى اجراى پروژه ها بر مى گزينند. تکنولوژى هاى رايج در ايران مايکروسافت، جاوا و کدباز هستند. هنوز هم شرکتهايى هستند که مدعى اجراى پروژه ها با اکثر تکنولوژى ها بوده حال آنکه تواناييهاى آنها در برخى از اين تکنولوژيها بالا نيست. اين مورد را نمى توان يک ضعف اساسى قلمداد کرد زيرا ممکن است شرکتها از طريق برون سپارى، اجراى پروژه ها را به شرکتهاى همکار خود واگذار کنند. در هر صورت رويکرد به همه تکنولوژيها در فعاليت تيمهاى مديريت پروژه و بازرگانى شرکتها بى تاثير نيست ضمن آنکه قدرت شرکتها را در موردى مانند Branding کاهش مى دهد.

4- ضعف در تعريف خدمات: روشن است که خدمت ارايه شده در نهايت "طراحى وب" است اما در دل همين دو کلمه دنيايى معنا و مفهوم وجود دارد. شرکتهاى ايرانى خدمات خود را نوعا درست تعريف نمى کنند و اطلاعات کاملى نيز ارايه نمى دهند. آنها همواره اميد دارند که در يک جلسه حضورى، برگ برنده خود را رو کنند و طرف مذاکره را مقهور نموده و قراردادى منعقد نمايند. يکى از دلايل اصلى عدم فعاليت شرکتهاى صرفا مشاور در اين بازار نيز دقيقا همين مورد و به عبارت ديگر نبود اطلاعات از خدمات و فعاليت شرکتهاى مجرى است.

در حاليکه اگر شرکتها اطلاعات کاملى از خود و خدمات خود منتشر کنند، شرکتهاى مشاور مى توانند مدت مذاکرات را براى هر دو طرف مذاکره کاهش دهند و کيفيت اجراى پروژه ها نيز بالاتر خواهد رفت. قابل ذکر است که مشتريان ايرانى نيز نوعا تمايل به مذاکرات حضورى دارند. شايد بتوان دلايل زير را براى اين موضوع عنوان کرد: به دليل ضعف اساسى مشتريان با خدمات طراحى وب، آنها مذاکره حضورى را فرصتى براى کسب اطلاعات بيشتر و بالا بردن آگاهى هاى خود مى دانند. نوعا مديران عاملى تصميم گيرنده هستند که براى مطالعه اطلاعات منتشر شده از سوى مجريان، وقت نمى گذارند.

هنوز اين باور شکل نگرفته است که مى توان بيشتر اين مذاکرات را به صورت الکترونيک انجام داد و حتى قرارداد الکترونيکى منعقد کرد. نبود قوانين حقوقى مشخص نيز بر اين موضوع تاثير مى گذارد. همواره مديران سودجو و فرصت طلبى وجود دارند که براى يافتن کانالهاى مناسب زد و بندهاى مالى، نياز به اين جلسات براى آشنايى بيشتر دارند.

5- ضعف در قيمت گذارى خدمات: اصل "هر چقدر که تيغ مى برد" هنوز هم در بين اکثر اين شرکتها رواج دارد و آنها قيمت گذاريهاى خود را در اکثر موارد با توجه به مشترى تعين مى کنند و کمتر به خدماتى که ارايه مى شود توجه مى کنند. به عنوان مثال اگر قيمت گذارى بر اساس طراحى هر صفحه را روشى درست براى قيمت گذارى بدانيم، هم اکنون قيمت طراحى هر صفحه از پنج هزار تومان تا صد و پنجاه هزار تومان متغير است. اين تفاوت مى تواند ناشى از موارد زير باشد:

قراردادهاى دولتى و نيمه دولتى: به دليل پروسه طولانى تصميم گيرى و کاغذ بازى هاى رايج، مذاکرات با طرفهاى دولتى عموما زمان بيشترى مى طلبد. اين موارد و بد حساب بودن اغلب آنها، شرکتها را مجاب به بالا بردن قيمت نهايى پروژه از يک تا سه برابر قيمت واقعى پروژه مى کند. اتخاذ چنين سياستى از سوى شرکتهاى مجرى حتما بر نوع قيمت گذارى ها براى مشتريان عادى آنها نيز تاثير مى گذارد و عملا فرصت تجربه قيمتگذارى بر اساس کيفيت و نوع خدمات ارايه شده را از مجريان مى گيرد.

زدو بندهاى مالى مديران بازرگانى و آى تى همچنين ضعف آگاهى آنها و سازمانهاى وابسته به آنها در بالا رفتن مبلغ قراردادها به شدت تاثير مى گذارد. (به نظر مى رسد اين مورد نياز به توضيح بيشتر نداشته باشد!)

اجراى ضرب العجلى پروژه ها: عمدتا شرکتها و سازمانهاى متقاضى خدمات طراحى وب به "دقيقه نود" فکر مى کنند و تا اجبار فراتر از حد مشخصى را احساس نکنند به استفاده از اين خدمات روى نمى آورند. اين شرايط مى توان شرکت در نمايشگاه، شروع مذاکرات با طرفهاى خارجى، عقب نماندن از "طايفه سايت داران باکلاس" و ... باشد. در چنين شرايطى، آنها معمولا حاضر به پرداخت هزينه بيشترى هستند. آنچه که در عمل اتفاق مى افتد اين است که پروژه ها اغلب در زمان ضرب العجل تعيين شده به اتمام نمى رسد و يا با کيفيت کمترى در زمان تعيين شده انجام مى شود.

طراحان مستقل و کسب و کارهاى خانگى: علاوه بر شرکتهاى طراحى وب، افراد و يا تيمهاى ديگرى نيز در بازار حضور دارند و اين خدمات را ارايه مى دهند. آنها به دليل هزينه کمتر براى اجراى پروژه ها و نداشتن هزينه هاى رايج دفترى در اغلب موارد خدمات خود را با قيمتهاى کمترى ارايه مى دهند. مقايسه قيمت ارايه شده از سوى آنها با قيمت ارايه شده از سوى شرکتها همواره نزد مشتريان يک چالش بزرگ است.

مشتريان ناآگاه و يا کمتر آگاه نمى توانند تفاوت اين قيمتها را هضم کنند. فعاليتها اين افراد و تيمهاى کوچک هم خوب است هم بد. خوب از آن جهت که آنها در آشنا کردن شرکتها و سازمانها به اين خدمات بسيار موثر هستند. اما بد از آن جهت که آنها با خدمات بعضا نامطلوب و پشتيبانى هاى ضعيف بازار را بسيار آشفته مى کنند. عموما مشتريانى که فاکتور اصلى آنها "قيمت پروژه" است تمايل به واگذارى پروژه هاى خود به اين افراد دارند.

به عنوان فردى که تجربه مذاکرات بسيارى از اين دست را دارد، تيمهاى فردى و اقوام و آشنايان مدير عامل را يک رقيب نامرئى مى دانم. بارها اتفاق افتاده است که بعد از يک مذاکره سنگين و طولانى، مدير عامل با گفتن اينکه " البته پسر دبيرستانى من هم مى تواند سايت طراحى کند"، احساس مى کردم که ... بگذريم!

6- تنها به فروش فکر مى کنند: چه مشترى بزرگ باشد و چه کوچک، مجريان پروژه همواره تلاش مى کنند تا آنرا بزرگ جلوه دهند به اين اميد که حجم قرارداد در نهايت افزايش يابد. در نزد اغلب آنها مدير فروشى که بر اساس اصول علمى و تجربى فروش و بازاريابى عمل مى کند و به آينده کسب و کار شرکت مى انديشد در مقايسه با مديران فروشى که کوتاه مدت فکر مى کنند و فقط مى فروشند و بعضا به راهکارهاى خارج از اصول اخلاقى متوسل مى شوند، اعتبار بيشترى دارد زيرا معيار مقايسه، فروش بيشتر است.

7- نبود مديران فروش متخصص در اين حوزه: يکى از مشکلات اساسى بسيارى از شرکتهاى اين حوزه کمبود مدير فروش تخصصى در اين حوزه است. لذا در اغلب موارد مدير عامل شرکت وظيفه فروش را نيز بر عهده دارد. اين مديران عامل چون معمولا از ابتداى راه اندازى کسب و کار با شرکت بوده اند و تجربيات خوبى دارند مى توانند اين نقش را به خوبى انجام دهند که البته بر پست سازمانى "مديريت عاملى" آنها تاثير منفى مى گذارد. ورود مديران فروش با سابقه کار در حوزه هاى ديگر چه مرتبط با نرم افزار و چه غير مرتبط با آن تاثير منفى بر فعاليت کارى شرکتها مى گذارند هر چند در کوتاه مدت، منجر به افزايش فروش شوند. اين مديران فروش اگر از سوى شرکت حمايت شده و آموزش کافى ببيند مى توانند البته تاثير بسيار مثبتى بر ساختار يافته شدن "مديريت فروش خدمات وب" بگذارند.

8- تفکر محدود: آنها خود را با تغييرات موجود کمتر تطبيق مى دهند. درست است که تا مبحثى نو مطرح مى شود همه از آن نام مى برند اما در عمل به کندى خود را با آن مباحث نوين هماهنگ مى کنند. پروپوزالهايى که از سوى آنها ارايه مى شود اغلب محتوا و شکل مشخصى دارد. آنها تنوعى به خدمات ارايه شده از سوى خود نمى دهند. عموما نيازهاى مشترى را به خوبى تشخيص نمى دهند و همواره نيازهاى وى را در غالب تواناييهاى خود تعبير مى کنند.

نتيجه اين کار اين خواهد بود که يا چيزى فراتر از نياز مشترى طراحى مى شود و يا چيزى کمتر از آن. توجه به مديران فروش با سابقه کار در حوزه هاى ديگر نيز ناشى از همين موضوع است زيرا آنها مى توانند با استفاده از ارتباطات و کانالهاى قبلى خود، بر فروش شرکت بيافزايند اما پر واضح است که در روند اين افزايش فروش، شرکت تجربه اى در "مديريت فروش" بدست نمى آورد زيرا با نبود آن مدير فروش، بسيارى از ارتباطات و کانالهاى کسب درآمد قطع مى شود.

9- ضعف در پروپوزالها: پروپوزالهاى ارايه شده از سوى آنان آگاهى هاى لازم را در اختيار مشتريان قرار نمى دهد. محتواى اين پروپوزالها تفاوت خدمات ارايه شده از سوى شرکتهاى مختلف را نشان نمى دهد و نمى توان با مقايسه تنها چند پروپوزال شرکتى را به عنوان مجرى پروژه برگزيد. ضعف نسبى مشتريان نيز بى تاثير بر اين موضوع نمى باشد.

10- تخصص و آموزش را جدى نمى گيرند: آنها براى آموزش کارمندان خود هزينه نمى کنند. با توجه به طبيعت دايما در حال تغيير اينترنت، نقش آموزش بسيار موثر است. به عنوان مثال سليقه گرافيست بسيارى از آنها سالهاست که بدون توجه به تغييرات بوجود آمده در ذائقه کاربران وب ثابت مانده است. شايد اغلب آنها ندانند که از سوى مراجع معتبر، گرافيک متناسب با ذائقه کاربران براى سال 2005 چه چيزى پيش بينى شده است! تشويق کارمندان به افزايش مطالعات در حوزه تخصصى، مراجعه به سايتهاى معتبر و تخصصى و شرکت دادن آنها در دوره هاى آموزشى مرتبط مى تواند در کيفيت اجراى پروژه ها و تداوم آنها در بازار تاثير فوق العاده بگذارد.

با تمام موارد گفته شده، چون صنعت طراحى وب در ايران نوپاست وجود پاره اى از مشکلات موجود طبيعى است. مديران اغلب جوان هستند و خود مقوله مديريت اين نوع شرکتها نيز هنوز جا افتاده نيست و چهارچوب و ساختار آن همانند شرکتهاى فعال در صنعت برق که سابقه اى بيش از چهل سال در ايران دارند، قوام نيافته است. بازار بکرى در داخل کشور و بازارهاى بسيارى در خارج از کشور فراروى طراح وب ايرانى قرار دارد.

اميدواريم مديران و تصميم گيرندگان با اتخاذ راهکارهاى مناسب به سوى هر چه حرفه اى تر شدن گام بردارند. آمادگى تغيير نظرات ارايه شده را دارم لذا خواهشمند است انتقادات و پيشنهادات خود را به آدرس roudaki@iranseo.com ارسال نماييد تا در نسخه هاى بعدى اين مقاله از ديدگاههاى شما نيز استفاده نمايم.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 20 تیرماه 1384

10:55 AM

July 11, 2005

XML - اين خوان هفت‌رنگ‌

مسعود سعيدي
ماهنامه شبکه - مهر 1383 شماره 47

اشاره :
امروزه به هر سمتي كه نگاه مي‌كنيم، با فناوري‌ XML برخورد مي‌كنيم. شايد هيچ يك از حوزه‌هاي علوم انفورماتيك به حد و اندازه‌هاي گستردگي كاربرد XML نرسيده باشد. بر اساس تجربه نويسنده، بسياري از كاربران پس از تلاش‌هاي بسيار و مطالعه در اين زمينه پس از آنكه دريافته‌اند كه XML چيست و موضوع از چه قرار است، همچنان در گير اين مطلب هستند كه كاربرد اين فناوري چيست و اصولاً چگونه مي‌توان از آن استفاده كرد. در اين نوشتار به اين موارد مي‌پردازيم.

XML
همان‌طور كه به‌ياد داريد، XML نام مجموعه‌اي از روش‌هايي است كه توسط آن مي‌توان اطلاعات گوناگون را در درون فايل‌هاي متني ذخيره كرد. اما راه و رسمXML در ذخيره‌سازي اطلاعات با روش‌هاي متداول ثبت داده در فايل‌هاي متني تفاوت‌هايي دارد كه اين دو را كاملاً از يكديگر متمايز مي‌سازد.
در XML اطلاعات به روشي در يك فايل متني ثبت مي‌شوند كه قابل آدرس‌دهي هستند. بدين معني كه يك كاربر مي‌تواند محتويات نشاني ويژه‌اي از يك فايلXML را بخواند و اين موضوع با نوشتن‌هاي متوالي و حتي حذف مواردي از آن فايل توسط كاربران ديگر در زمان‌هاي ديگر، مخدوش نخواهد شد.
براي تشريح بهتر اين مسأله، يك فايل متني ساده را بررسي مي‌كنيم. فرض كنيد كه در يك فايل متني، اطلاعات مختلفي را طي شش سطر نوشته باشيم. در صورتي‌كه كاربري بخواهد به داده‌هاي موجود در خط پنجم اين فايل دسترسي داشته باشد، بايد از ابتداي اين فايل آغاز كرده و به ترتيب به شماره خط مورد نظر خود برسد. در حالي كه در فايل‌هاي متني XML چنين نيست. تفاوت ديگر اين دو حالت در آن است كه اگر در مورد فايل متني ساده، همان كاربر ( يا كاربر ديگري) خطي را قبل از خط مثلاً ششم اضافه كرده باشد ( و يا خطي را قبل از خط ششم در اين فايل حذف كرده باشد)،‌ آن‌گاه براي دسترسي به اطلاعات خط ششم سابق بايد به سوابق ويرايشي فايل مراجعه شود و بر حسب مورد به نشاني متفاوتي از آنچه قبل از ويرايش براي دسترسي به همين خط اطلاعاتي لازم بوده است، اشاره كرد. اما در فايل‌هاي متني XML چنين نيست و نشاني‌هاي اطلاعات موجود در آن‌ها با عمل ويرايش اطلاعات تغيير نخواهد كرد.

چگونه؟
اگر با فايل‌هاي HTML كار كرده باشيد و يا حداقل اين فايل‌ها را ديده باشيد، حتماً به ياد داريد كه در اين فايل‌ها، اطلاعات مختلفي در درون علامت‌ها و يا به عبارت صحيح‌تر در درون برچسب‌هايي واقع شده‌بودند. مثلاً در يك فايل HTML مشاهده خواهيد كرد كه قسمت‌هايي از اين فايل‌ها در بخشي قرار گرفته‌اند كه توسط برچسب‌هاي و محصور شده‌اند. حتي در مواقعي مشاهده مي‌كنيم كه يك واژه تك و تنها هم در درون برچسب‌هايي بسته‌بندي شده است. مثلا <Title>Main</Title>

مجموعه‌اي از برچسب‌هاي استانداردي كه در فايل‌هايHTML به‌كار مي‌روند، همگي توسط نرم‌افزارهاي مرورگر شناخته شده هستند ( البته اين موضوع استثنا‌هايي هم دارد كه فعلاً به آن موارد كاري نداريم). در نتيجه زماني كه يك فايل HTML را توسط يك برنامه مرورگر باز مي‌كنيم، نرم‌افزار مرورگر به‌جاي آن‌كه تمام محتويات واقعي فايل HTML را نمايش بدهد، با استفاده از همان مجموعه برچسب‌هاي از پيش‌تعريف شده و استاندارد، در مي‌يابد كه هر يك از اطلاعاتي كه توسط برچسب‌هاي مختلف بسته‌بندي شده‌اند، را چگونه بايد به نمايش بگذارد. به عنوان مثال، زماني كه مرورگر به عبارتي مي‌رسد كه در لفاف برچسب <Title>…</Title> واقع شده است، مي‌داند كه بايد آن عبارت را در نوار بالايي پنجره كه معمولاً به رنگ آبي است، نمايش دهد.

در فايل‌هاي XML هم از همين فلسفه استفاده مي‌شود. اما در XML از قبل در مورد آن‌كه چنين اطلاعاتي بايد توسط چه نرم‌افزاري به نمايش گذاشته شود، هيچ پيش‌فرضي وجود ندارد. به همين ترتيب در XML هيچ برچسب از قبل تعريف شده‌اي وجود ندارد. كاربران XML از ابتداي كار خود مجازند براي اطلاعات گوناگوني كه قصد دارند در يك فايل XML قرار دهند، برچسب‌هايي با اسامي دلخواه انتخاب كنند. به عنوان مثال شما مي‌توانيد براي ذخيره‌سازي اطلاعات مربوط به نمرات يك كلاس درسي در قالب XML تصميم بگيريد كه يك جفت برچسب به اسم <Student> </Student> داشته باشيد كه در بين آنها نام دانش‌آموزان را ثبت كنيد. همچنين ممكن است بعد از مختصري تأمل دريابيد كه خوب است تا يك جفت برچسب فرعي ديگري را به‌صورت <Score> </Score> در درون برچسب قبلي براي ثبت معدل هر دانش‌آموز به كار ببريد. در اين صورت شايد بخشي از اين فايل به‌صورت زير قابل مشاهده باشد:

<Students>

<Student>

        Hassan

        <Score>18</Score>

</Student>

<Student>

        Hossein

        <Score>19</Score>

</Student>

</Students>

مشاهده مي‌كنيد كه در اين بخش از يك فايل فرضيXML ، اطلاعات دو دانش‌آموز ثبت شده است. توجه داشته باشيد كه در اين فايل برچسب با برچسب تفاوت دارد و برچسب نخست از نظر سلسله‌مراتبي از درجه بالاتري نسبت به برچسب دوم برخوردار است. به عبارت ديگر كاربر يا برنامه‌نويس در قالب XML كاملاً آزاد است كه پس از تعيين ساختار اطلاعاتي داده‌هايي كه قصد ذخيره‌سازي آن‌ها را دارد، اولاً ساختار و برچسب‌هاي مورد نظر خود را تعيين كند و ثانياً داده‌هاي دلخواه خود را در درون آن ساختار جايگذاري نمايد.
بدين ترتيب بدون استفاده از فناوري‌هاي گران‌قيمتي مانند انواع بانك‌هاي اطلاعاتي، قالبي در اختيار كاربر قرار مي‌گيرد كه مي‌تواند توسط آن انواع اطلاعات را ذخيره كرده و از آن مهم‌تر، چنين داده‌هايي را به سكوهاي ديگر انتقال دهد. مي‌دانيد كه انتقال اطلاعات در قالب‌هاي سنتي مانند بانك‌هاي اطلاعاتي علاوه بر موضوع گران‌قيمت بودن آن‌ها، به فاكتورهاي متعددي وابسته است كه هنگام انتقال از يك سكو به سكوي ديگر مطرح مي‌شوند. سبكي يا سهولتي كه استفاده از قالب XML به دست مي‌دهد، چنان كارايي و قابليت انعطافي دارد كه كاملاً توجيه كننده چرايي گستردگي بي‌حد و مرز XML در سال‌هاي اخير است.
آنچه كه در ارتباط با مقايسه بانك‌هاي اطلاعاتي و XML بيان شد، نبايد اين تصور را در ذهن خواننده ايجاد نمايد كه اين فناوري در تقابل با بانك‌هاي اطلاعاتي است. واقعيت آن است كه درهم تنيدگي XML با بانك‌هاي اطلاعاتي چنان گسترده و عميق است كه نمي‌توان آن‌را به‌سادگي تشريح كرد. تا چندي پيش هر روز از شنيدن اصطلاحي كه ابتداي آن با حرف X آغاز مي‌شد و حكايت از به‌كارگيريXML در حوزه ديگري از علوم رايانه‌اي و غيررايانه‌اي مي‌كرد، متعجب مي‌شديم. اما امروزه در صورتي‌كه متوجه شويم كه مثلاً در فلان موضوع هنوز از XML استفاده نمي‌شود، بايد تعجب كنيم. مثلاً چه كسي مي‌توانست حدس بزند كه از XML در ستاره‌شناسي و يا هواشناسي و حتي بازار بورس و برنامه‌ريزي برنامه‌هاي تلويزيوني و . . . استفاده خواهد شد.
براي دست آوردن تصويري از كاربردهاي گسترده XML در حوزه‌هاي مختلف، مي‌توانيد به جدول‌هاي مقاله رجوع كنيد كه در آن تعدادي از كاربردهاي XML در حوزه‌هاي گوناگون معرفي شده‌اند.

Document Type Definition يا DTD
بازگرديم به موضوع اصلي خودمان. تا اينجا بيان كرديم كه در قالب XML كاربر مي‌تواند داده‌ها و قالب و مجموعه برچسب‌هاي لازم براي تعيين ساختار آن اطلاعات را به‌طور دلخواهي تعريف كند. همچنين از قالب HTML براي رسيدن به مفاهيم متناظر در XML استفاده كرديم. در اينجا بازهم از همين روش بهره خواهيم گرفت.
در صورتي‌كه كاربري در هنگام نوشتن وطراحي يك فايل HTML دچار اشتباه شود و به عنوان مثال برچسب را فراموش كند، مرورگر از نمايش صفحه وب اجتناب مي‌كند و شماره خط اشتباه را در فايل HTML به شما اطلا‌ع مي‌دهد. اما در صورتي‌كه كاربري در نوشتن يك فايل XML دچار اشتباه شود، چه كسي متوجه خواهد شد؟
به‌طور معمول دو نوع اشتباه در نوشتن فايل‌هاي XML متداول هستند. گروه نخست اشتباهاتي است مانند آن‌هايي كه در مثال فوق به آن اشاره شد. در اين نوع از اشتباهات، هر نرم‌افزاري كه كمي با قالب و فرمت فايل‌هاي برچسبي يا Markup آشنا باشد، خواهد توانست اشتباه را تشخيص دهد. مثلاً هرگاه برچسبي به‌صورت در فايل ديده شود و آن‌گاه برچسب جفت آن يعني در اين فايل يافت نشود، هر شخص و يا نرم‌افزار Markup قادر به تشخيص اشتباه خواهد بود. فايل‌هاي xml كه چنين اشتباهاتي در متن آن‌ها وجود نداشته باشد، فايل‌هاي خوش‌تركيب يا Well formed نام دارند.
اما در صورتي‌كه در ساختار اطلاعاتي خود، فايلXML را به‌گونه‌اي مي‌خواسته‌ايد طراحي كنيد كه در آن هر اِلمان ( مانند المان Student در مثال قبلي) بايد حتماً داراي جفت برچسب خود باشد. درصورت بروز اين اشتباه هيچ كس نخواهد توانست آن را به شما اطلا‌ع دهد. زيرا اصولاً كسي از ساختار موردنظر شما در زمان طراحي فايلXML اطلاع نداشته است.
براي حل اين مشكلات، درXML ابزارهاي متعددي پيش‌بيني شده است. مثلا‌ً فايل‌هاي DTD فايل‌هايي هستند كه شما مي‌توانيد بدون توجه به اصل داده‌ها، فقط شكل و ساختار سازماني اطلاعات خود را در آن تعريف كنيد. در واقع در فايل‌هايDTD كاربر تعيين مي‌كند كه در فايل XML متناظر چه برچسب‌هايي و چه داده‌هايي به كار گرفته شده‌اند و هر يك از آن‌ها چه ويژگي‌هايي دارند.
در صورتي‌كه با واژگان DTD آشنا باشيم، خواهيم توانست فايلي با پسوند dtd بسازيم كه توصيف‌كننده فايل xml خود باشد. به عنوان مثال براي آن‌كه ساختار اطلاعاتي فايل مثال ابتدايي اين مقاله را توصيف كنيم، مي‌توانيم از عبارات زير در يك فايل DTD بهره گيريم.

<!ELEMENT Students ( Student+ ) >

<!ELEMENT Student ( #PCDATA | Score )* >

<!ELEMENT Score ( #PCDATA ) >

اگر به اين بخش از يك فايلdtd دقت كنيم، متوجه خواهيم شد كه در خط اول گفته مي‌شود كه فايل XML بايد شامل يك المان به‌نام Students باشد كه خود در برگيرنده المان‌هاي فرعي به نام Student است. در همين خط از فايل dtd تاكيد مي‌شود كه تعداد المان‌هاي فرعي Student مي‌تواند زياد باشد. علامت + در انتهاي اين خط چنين مفهومي را مي‌رساند. در خط دوم اين فايل گفته مي‌شود كه المان Student اولاً شامل داده‌هايي از جنس PCDATA است (كه فعلاً به آن كاري نداريم) و در ثاني اين المان داراي المان فرعي‌تري بنام Score است و . . . خلاصه آن‌كه فايل DTD به هر شخص يا نرم‌افزاري كه بخواهد صحت و يا به‌عبارت فني‌تر اعتبار فايلXML را بسنجد، خواهد گفت كه ساختار اين فايل چگونه بايد باشد. نرم‌افزارهاي نمايش دهنده فايل‌هاي xml مي‌توانند در صورت تمايل از اين فايل براي تعيين اعتبار فايل xml قبل از نمايش آن استفاده كنند. تعيين صحت ساختاري يك فايل xml و يا تطابق ساختار آن با آن‌چه در فايلdtd متناظر بيان مي‌شود،Validity نام دارد.

شکل 1 - براي مشاهده عکس در اندازه واقعي روي تصوير کليک کنيد
XML Schema
همان‌طور كه قبلاً خاطرنشان شد، استفاده از dtd يكي از روش‌هاي بيان ساختار اطلاعاتي يك فايلXML است. W3C روش ديگري را براي بيان و تعريف ساختار داده‌اي فايل‌هاي XML توصيه مي‌كند. XML Schema يا به اختصار Schema نامي است كه بر فايل‌هاي تعريف كننده سازمان داده‌اي XML بر اساس توصيهW3C نهاده شده است. فعلاً همين‌قدر اشاره مي‌كنيم كه در واقع Schema نوعي بيان ساختار داده‌اي است كه از زبان XML براي اين منظور استفاده مي‌كند.

در اينجا بد نيست تا اشاره شود كه روش‌ها و تكنولوژي‌هاي ديگري نيز علاوه بر DTD و Schema براي بيان ساختار داده‌اي XML وجود دارند كه تقريباً همگي آن‌ها از قدمت بيشتري نسبت به پيشنهادW3C برخوردار هستند. به عنوان نمونه، XDR يا XML Data Reduced همتاي DTD محسوب مي‌شود و در IE نسخه 5 نيز مورد استفاده واقع شده بود. XDR در چهارچوب BizTalk هم مورد استفاده بوده است. SOX به معني Schema for Object Oriented XML هم تكنيك ديگري در رديفDTD است. از SOX در سيستم تجارت الكترونيك استفاده شده است.
در اين گروه مي‌توان به نمونه‌هاي ديگري هم اشاره كرد RELAX . كه ساخته و پرداخته يكي از محققان ژاپني IBM است، نمونه ديگري به‌شمار ميآيد RELAX . در حقيقت زبان Regular Expression براي XML محسوب مي‌شود كه به W3C هم براي طي كردن فرايند استاندارد‌سازي ارائه شده است. TREX (به معني Tree Regular Expression for XML ) هم نمونه مشابه ديگري براي تعيين سازمان داده‌اي XML است.

مرورگر IE يكي از نرم‌افزارهايي است كه قابليت نمايش فايل‌هاي xml را دارا است. به‌طور كلي به نرم‌افزارهايي كه قابليت قرائت اطلاعاتXML را دارا هستند و مي‌توانند براساس نمايشي از داده‌هايXML كار كنند، Parser گفته مي‌شود. (پارسر اصطلاحي است كه از زمان استفاده از كامپايلر‌ها رواج يافته است. كامپايلر‌ها سورس كد برنامه را Parse مي‌كردند و بر اساس آن فايل Object در فرايند كامپايل ساخته مي‌شد.) در شكل شماره يك تصويري نمايش داده شده است كه در آن اشكال گوناگون نمايش يك فايل xml (همان فايل مثال ابتدايي مقاله) را به تصوير كشيده است. اگر دقت كنيد، كاربر مي‌تواند با كليك كردن بر روي علامت‌هاي + كه مرورگر در كنار گره‌ها نمايش مي‌دهد، آن گره را گشوده و محتويات درون آن را مشاهده كند.

XSL
همان‌طور كه متوجه شديد، تمام هنر IE آن بوده است كه ساختار XML را به‌صورت شاخه‌هاي تعاملي نمايش دهد. در چنين شكلي از نمايش، هيچ ظرافتي در ارتباط با آن‌كه مثلاً المان ريشه (Students) پررنگ‌تر نمايش داده شود و چيزهايي از اين قبيل، به كار گرفته نشده است. البته واقعيت هم غير از اين نيست، زيرا در هيچ جايي ( نه در فايل XML و نه در فايل) DTD هيچ اطلاعاتي درباره چگونگي نمايش اطلاعات موجود در فايل XML گنجانده نشده است.
واقعيت آن است كه معجزه XML هم در همين نكات نهفته است. درXML داده‌ها به‌كلي از ساختار اطلاعات تفكيك شده‌اند و به همين ترتيب هيچ تداخلي نيز بين داده‌ها و اطلاعات ديگر در مورد چگونه به نمايش درآمدن آن‌ها صورت نمي‌گيرد. در صورتي‌كه بخواهيم اطلاعات موجود در يك فايل XML را به نمايش بگذاريم بايد فايل ديگري به كار ببريم كه در آن تمامي اطلاعات لازم در مورد نمايش تك تك داده‌هاي XML ثبت شده باشد. اين فايل در تكنولوژيXML ، XSL و يا XML Style Sheet نام دارد.

فناوري‌هاي ديگر
گفتيم كه XML روشي ساده و كارآمد براي ذخيره‌سازي اطلاعات فراهم مي‌آورد. در واقع تفاوت فايل‌هايXML با فايل‌هاي متني معمولي در آن است كه براي بازيابي اطلاعات فايل‌هاي XML نيازي به طي كردن تمام ركوردهاي ذخيره‌شده در اين فايل‌ها نيست. به عبارت ديگر فايل‌هايXML به‌نوعي با قابليت دسترسي تصادفي (Random Access) هستند. Xpath نام زباني است كه توسط آن مي‌توان به بخش‌هاي گوناگون اطلاعات موجود در فايل‌هاي XML دسترسي يافت. در اين زبان به جاي آن‌كه از syntax فايل‌هاي XML (گره‌ها و برچسب‌ها) استفاده شود، از مسير‌ها و يا Path‌هايي در يك ساختار سلسله مراتبي و درختي (كه در حافظه سيستم تشكيل مي‌شود)‌ براي دسترسي به اطلاعات استفاده مي‌شود. چنين قابليتي همچنين به اين معني خواهد بود كه در اين زبان مي‌توان از امكانات جستجوي الگو (Pattern matching) نيز بهره گرفت.

Xpointer و XLink
Xpointer تكنولوژي مشابه ديگري است كه باز هم براي دسترسي به اطلاعات فايل‌هايXML به كار مي‌رودXlink . زباني است كه امكانات برقراري لينك در فايل‌هايXML را فراهم مي‌كند. درXlink المان‌هاي ويژه‌اي تعريف مي‌شود كه مي‌توان از آن‌ها در بين اطلاعات XML براي ايجاد لينك به منابع ديگر استفاده كرد. اين منابع اطلاعاتي مي‌توانند انواع داده از جمله داده‌هايXML ، ابرداده، و حتي داده‌هاي غير XML مانند تصوير باشد. المان‌هاي ويژه Xlink از همان قواعد XML و مفاهيم URI براي ايجاد لينك استفاده مي‌كنند.

Xinclude
به احتمال زياد با امكانات مكانيسم‌include كه در بسياري از زبان‌هاي برنامه‌نويسي مانندC يا C++ پيش‌بيني شده‌اند، آشنايي داريد. (توسط دستور include امكاناتي فراهم مي‌شود كه مي‌توان بخش‌هاي از يك برنامه‌ را در برنامه ديگري فراخواني كرد.) Xinclude نيز به‌طريق مشابهي مدل يك پردازشي را فراهم مي‌آورد كه مي‌توان توسط آن، از اطلاعات XML واقع در منابع ديگر در فايل ديگر استفاده كرد.

XQuery
Xquery زبان پرس‌و جوي جديدي است كه به زباني غير از XML بيان مي‌شود. از اين زبان براي اجراي پرس‌وجو (Query) بر روي اطلاعات XML با استفاده از عبارات Xpath و مجموعه‌اي از عبارت‌هاي متنوع ديگر كه شباهت زيادي به عبارات SQL دارند، استفاده مي‌شود. ( در بين اين دستورات مي‌توان عبارت‌هايي مشابه با FLWR نيز مشاهده كرد كه در آن واژگاني همچونForLetWhereReturnN ديده مي‌شوند.)

برنامه‌نويسيXML
عملاً بسيار از خوانندگان‌بارها كتاب‌ها و منابع ديگر در ارتباط با XML را مطالعه و يا بررسي كرده‌اند، اما همچنان به كارگيري عملي تكنولوژيXML در پروژه‌هاي نرم‌افزاري خود باز مي‌مانند. شايد مهم‌ترين علت اين موضوع آن باشد كه تقريباً در تمامي كتاب‌هاي معتبر مرتبط باXML و تكنولوژي‌هاي وابسته، سناريوي منابع آموزشي به‌گونه‌اي تنظيم شده است كه بيش از نيمي از كتاب و حتي بيشتر به تشريح مفصل مفاهيمي اختصاص داده مي‌شود كه در اين مقاله تا اين‌جا معرفي شدند.
اما آنچه براي يك برنامه‌‌نويس بيش از هرچيز اهميت مي‌يابد آن است كه مثلاً در محيط‌هاي گوناگون چگونه مي‌توان از‌طريق برنامه‌نويسي به محتويات يك فايل XML دست‌يافت و روش‌هاي اين‌كار چيستند؟ در صورتي‌كه كسي بخواهد از طريق سناريو‌هاي متداول منابع آموزشي به چنين مفاهيمي دسترسي يابد، بايد براي يك مطالعه برنامه‌ريزي شده و منسجم خود را آماده كند كه در دنياي حرفه‌اي جامعه امروز، كار چندان ساده‌اي تلقي نمي‌شود.
هدف ابتدايي اين نوشته آن بوده است كه همين مفاهيم برنامه‌نويسي XML را تشريح كند و براي تأمين پيش‌نيازهاي آن به مقالات قبلي منتشر شده در اين زمينه در ارتباط با XML ارجاع داده شود. اما ترجيح داديم كه يك‌بار ديگر و با زباني متفاوت موضوع XML را به اختصار معرفي كنيم و سپس در شماره ديگري به شرح تفصيلي مقوله برنامه‌نويسي XML بپردازيم. در نتيجه فقط در اينجا به يك معرفي كوچك اكتفا مي كنيم.
به‌طور كلي دو مدل برنامه‌نويسي براي دسترسي به داده‌هاي XML مورد استفاده برنامه‌نويسان است كه به DOM و SAX معروف هستند.

DOM
از آنجايي‌كه داده‌هاي معتبرXML به‌صورت ساختار سلسله مراتبي و درختي از گره‌ها و ديگر المان‌ها نمايش داده مي‌شوند، هر گره مي‌تواند با استفاده از روش‌هاي آشناي دسترسي به چنين ساختارهايي در دسترس قرار گيرد. در تكنولوژيDOM ، قاعده بر آن است كه تمام ساختار درختي داده‌هاي XML را در حافظه سيستم بارگذاري مي‌كنند. بدين ترتيب سرعت دسترسي به داده‌هاي XML افزايش مي‌يابد. از طرف ديگر از آنجاييكه فايل‌هاي XML ‌در كاربردهاي جدي، بسيار حجيم هستند، مسأله مديريت حافظه مجازي (Virtual Memory) تبديل به يك گلوگاه تكنيكي مي‌شود.
رابط‌هاي برنامه‌نويسي گوناگوني براي دسترسي به اطلاعات XML در مدل DOM يا Document Object Model در محيط‌هاي مختلف مانند دلفي،VB ،C++ ،C ، جاوا و ديگر زبان‌هاي اسكريپتي مانند جاوااسكريپت،Vbscript ،Tcl ، Ruby و ... فراهم شده‌اند.

SAX
روش ديگر دسترسي به اطلاعاتXML ، همان قرائت ترتيبي (Sequential) فايل XML و صادر كردن رويدادهاي اين عمل است. بدين ترتيب در هنگام خواندن يك فايلXML ، سلسله‌اي از رويدادهاي گوناگون ناشي از رسيدن به انواع گره‌ها و ديگر موجوديت‌هاي XML توليد خواهد شد. روش استفاده از چنين رويدادهايي براي برنامه‌نويسي تا حدود زيادي مشابه همان روشي است كه از آن در برنامه‌نويسي رابط‌هاي گرافيكي كاربر استفاده مي‌شود. در روش SAX يا Simple API for XML مسأله‌اي به‌نام محدوديت حافظه، حتي در زمان كار با فايل‌هاي بزرگ XML ايجاد نخواهد شد.

حوزه‌هاي گوناگون استفاده از XML
MLCD | زبان نشانه‌گذاري براي اسناد پيچيده
GDA | استاندارد حاشيه‌نويسي) (Annotation اسناد
EMELD | ابرداده (Meta Data) الكترونيك براي زبان‌هاي در معرض خطر
 | زبان رمزگذاري ويژه زبان‌ها و متون باستاني خاورميانه
ETCSL | زبان ويژه ادبيات سومري
XSTAR | سيستم مبتني بر XML براي مطالعات انسان‌شناسي
LEAF | Linking and Exploring Authorithy Files
CDF | فرت تعريف كانال
RSS | RDF Rich Site Summary
OCS | Open Content Syndication
WebML | زبان مدل‌سازي وب
MCF | Meta Content Framework using XML
RDDL | زبان توصيفي فهرست‌هاي منابع
BiblioML | زبان ويژه اطلاعات كتابداري
CTML | زبان ويژه تجارت كنترل شده
GovML | زبان ويژه كاربردهاي دولتي
ParlML | مجموعه‌اي از واژگان متداول در زبان مجلس
JXML | استاندارد اصطلاحات دادگستري
LegalXML | زبان ويژه‌اي در كاربرد فرم‌هاي دادگاه الكترونيك
EML | زبان نشانه‌گذاري در كاربردهاي انتخاباتي
VXML | زبان ويژه در كاربردهاي راي‌گيري
CDX | استاندارد انتقال اطلاعات سازمان‌هاي حفاظت محيطي
VocML | زبان نشانه‌گذاري لغات
XGMML | زبان مدل‌سازي و نشانه‌گذاري قابل‌توسعه گراف‌ها
SGF | فرمت ساختيافته گراف
GXL | زبان تبادل داده گراف‌ها
OSD | زبان توصيفي نرم‌افزارهاي اپن‌سورس
LogML | زبان نشانه‌گذاري Log
XMPP | زبان توسعه‌پذير پيام‌رساني
IETF | زبان پيام‌رساني XML
SMSXML | زبان رمز‌گذاري پيام كوتاه (SMS)
XDNL | زبانNavigation در اسناد
MatML | زبان توصيفي خواص مواد
CML | زبان نشانه‌گذاري در كاربردهاي فرمول‌نويسي شيمي
MoDL | زبان ويژه توصيف ديناميك مولكولي
NCBI | مدل داده‌اي بيولوژي مولكولي
StarDOM | سيستم‌انتقال اطلاعات علمي به XML
BSML | زبان نشانه‌گذاري بيو‌انفورماتيك
BIOML | زبان نشانه‌گذاري در كاربردهاي بيو‌پليمر
CellML | زبان توصيفي سلولي
GEML | زبان توصيف عبارات ژنتيك
GAME | زبان نشانه‌گذاري در كاربردهاي ژنتيك
PROXIML | زبان توصيفي پروتئين
XDELTA | زبان ويژه در كاربردهاي مالياتي
OMF | زبان ويژه براي مشاهدات هواشناسي
OPX | زبان نشانه‌گذاري اطلاعات انسان‌شناسي
OFX | زبان تبادل اطلاعات اقتصادي
FinXML | زبان ويژه ديجيتالي براي بازارهاي سرمايه‌گذاري
IRML | زبان نشانه‌گذاري تحقيقات اقتصادي
XFRML | زبان ويژه در كاربردهاي گزارش‌هاي اقتصادي
XBRL | زبان ويژه در كاربردهاي Business يا كسب و كار
VRXML | زبان ويژه در كاربردهاي گزارش فروشندگان (Vendor Reporting)
MDDL | زبان توصيف داده‌هاي بازار
WeatherML | زبان نشانه‌گذاري در كاربردهاي هواشناسي
swiftML | زبان پيام‌هاي تجاري
MISMO | زبان ويژه در كاربردهاي بانكداري رهني
IOTP | زبان تجارت آزاد در اينترنت
JAXM | سيستم‌پيام‌رساني XML در محيط جاوا
JAXR | مجموعه API جاوا براي رجيسترهاي XML
DPRL | زبان توصيف مالكيت حقوقي ديجيتال
XrML | زبان توسعه‌پذير حقوقي
XACML | زبان توصيفي در كاربردهاي سيستم‌هاي كنترل دسترسي
EBX | زبان تبادل اطلاعات كتاب‌هاي الكترونيك
ITML | زبان نشانه‌گذاري فناوري انفورماتيك
SignedXML | XML در كاربردهاي امضاي الكترونيك
S2ML | زبان ويژه سرويس‌هاي امنيتي
IDMEF | زبان ويژه سيستم‌هاي آشكار‌سازي ورود غير مجاز
BIPS | زبان ويژه سيستم پرداخت بانكي از طريق اينترنت
SML | زبان ويژه كارت‌هاي هوشمند
RETML | زبان ويژه در كاربردهاي معاملات املاك
ACORD-XML | زبان ويژه صنعت بيمه
SML | زبان ويژه فضا‌پيما‌ها (Spacecraft)
UBL | زبان جهاني تجارت
EmXML | زبان ويژه توصيفي در كاربردهاي مديريت وضعيت‌هاي اضطراري
MathML | زبان نشانه‌گذاري در كاربردهاي رياضي
OMDoc | زبان استاندارد اسناد رياضي
SVG | زبان ويژه ذخيره‌سازي اطلاعات گرافيكي
PGML | زبان ويژه در حوزه گرافيك دقيق
VML | زبان توصيفي برداري
IML | زبان توصيف تصوير
VRML | زبان ويژه در مدل‌سازي واقعيت مجازي
WIDL | زبان ويژه توصيف رابط‌هاي اينترنتي (Web Interface)
tXML | زبان ويژه در كاربردهاي حمل‌و‌نقل
PML | زبان نشانه‌گذاري فيزيكي
xNL,xAL | زبان ويژه توصيف نام و نشاني
HEML | زبان ويژه توصيف رويدادهاي تاريخي
tML | زبان نشانه‌گذاري ويژه كاربردهاي مخابراتي
bcXML | زبان نشانه‌گذاري توسعه‌پذير ساخت سازه‌هاي عمراني
EDA | XML و اتوماسيون طراحي الكترونيك
UXF | فرمت تبادل داده UML
JAXB | معماري جاوا براي اتصال XML
XLIFF | فرمت فايل تبادل داده‌هاي Localization در قالب XML
NewsXML | XML در كاربردهاي خبررساني
RDF | چهارچوب توصيفي منابع
RoboML | زبان نشانه‌گذاري در كاربردهاي رباتيك
CBML | زبان ويژه Case Based
DLML | زبان ويژه توصيف منطق
AIML | زبان ويژه كاربردهاي هوش‌مصنوعي
PhysicsML | زبان ويژه كاربردهاي فيزيكي
PML | زبان نشانه‌گذاري Procedural
PIF-XML | Process Interchange Format
QAML | زبان ويژه پرس‌و جو
GML | زبان ويژه كاربردهاي جغرافيايي
XMML | زبان ويژه كاربردهاي معادن و اكتشاف
NVML | زبان ويژه ناوبري و هدايت
XSIL | زبان ويژه تبادل اطلاعات علمي
AstroXML | زبان ويژه در كاربردهاي ستاره‌شناسي
AIML | زبان ويژه توصيف تجهيزات ستاره‌شناسي
SPACE XML | زبان ويژه كاربردهاي علوم فضايي
GedML | XML در اطلاعات شجره‌نامه‌اي
NAA-XML | زبان ويژه براي توصيف اطلاعات آگهي‌هاي تجاري در روزنامه‌ها
AdMakup | زبان ويژه توصيف تبليغات
NITF | فرمت متني صنعت خبري (News Industry)
SportsML | زبان ويژه كاربردهاي ورزشي
CFML | زبان ويژه اختصاصي نرم‌افزار ColdFusion
XPP | زبان ويژه براي ناشرين و چاپخا لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 26 تیرماه 1384

04:57 PM

July 17, 2005

آشنائى با عناصر يک شبکه محلى

سخاروش - با اين که هر شبکه محلى داراى ويژگى ها و خصايص منحصربفرد مختص به خود مى باشد که به نوعى آن را از ساير شبکه ها متمايز مى نمايد ، ولى در زمان پياده سازى و اجراى يک شبکه محلى ، اکثر آنان از استانداردها و عناصر شبکه اى مشابه اى استفاده مى نمايند . شبکه هاى WAN نيز داراى وضعيتى مشابه شبکه هاى محلى بوده و امروزه در اين نوع شبکه ها از مجموعه اى گسترده از اتصالات (از Dial-up تا broadband ) استفاده مى گردد که بر پهناى باند ، قيمت و تجهيزات مورد نياز به منظور برپاسازى اين نوع شبکه ها تاثير مى گذارد .
در ادامه به برخى از مهمترين ويژگى ها و عناصر شبکه اى استفاده شده در شبکه هاى محلى اشاره مى گردد :

رسانه هاى انتقال داده در شبکه هاى کامپيوترى ، ستون فقرات يک شبکه را تشکيل مى دهند . هر شبکه کامپيوترى مى تواند با استفاده از رسانه هاى انتقال داده متفاوتى ايجاد گردد . وظيفه رسانه هاى انتقال داده ، حمل اطلاعات در يک شبکه محلى مى باشد . شبکه هاى محلى بدون کابل از اتمسفر به عنوان رسانه انتقال داده استفاده مى نمايند . رسانه هاى انتقال داده عناصر لايه يک و يا فيزيکى شبکه هاى محلى مى باشند .

هر رسانه انتقال داده داراى مزايا و محدوديت هاى مختص به خود مى باشد . طول کابل ، قيمت و نحوه نصب از مهمترين ويژگى هاى رسانه هاى انتقال داده مى باشند .

اترنت ، متداولترين تکنولوژى استفاده شده در شبکه هاى محلى مى باشد که اولين مرتبه با همکارى سه شرکت ديجيتال ، اينتل و زيراکس و با نام DIX ارائه گرديد . در ادامه و در سال 1983 موسسه IEEE با استفاده از DIX ، استاندارد IEEE 802.3 را مطرح نمود . در ادامه استانداردهاى متعددى توسط کميته هاى تخصصى IEEE ارائه گرديد .

قبل از انتخاب يک مدل خاص اترنت براى پياده سازى شبکه ، مى بايست کانکتورهاى مورد نياز براى هر نمونه پياده سازى را بررسى نمود . در اين رابطه لازم است سطح کارآئى مورد نياز در شبکه نيز بررسى گردد .

مشخصه هاى کابل و کانکتورهاى مورد نياز براى پياده سازى هر يک از نمونه هاى اترنت ، متاثر از استانداردهاى ارائه شده توسط انجمن هاى صنايع الکترونيک و مخابرات ( EIA/TIA ) مى باشد .

با توجه به لايه فيزيکى مربوطه ، از اتصالات متفاوتى در شبکه هاى اترنت استفاده مى گردد . کانکتور RJ-45 ( برگرفته از registered jack ) متداولترين نمونه در اين زمينه است .

براى اتصال دستگاه هاى شبکه اى از کابل ها ى متفاوتى استفاده مى گردد . مثلا" براى اتصال سوئيچ به روتر ، سوئيچ به کامپيوتر ، هاب به کامپيوتر از کابل هاى straight-through و براى اتصال سوئيچ به سوئيچ ، سوئيچ به هاب ، هاب به هاب ، روتر به روتر ، کامپيوتر به کامپيوتر و روتر به کامپيوتر از کابل هاى crossover استفاده مى گردد .

Repeater ، يک سيگنال را دريافت و با توليد مجدد آن ، امکان ارسال آن را در مسافت هاى طولانى تر قبل از تضعيف سيگنال فراهم مى نمايد . در زمان توسعه سگمنت هاى يک شبکه محلى، مى بايست از استانداردهاى موجود در اين زمينه استفاده نمود . مثلا" نمى توان بيش از چهار repeater را بين کامپيوترهاى ميزبان در يک شبکه استفاده نمود .

هاب در واقع repeater هاى چند پورته مى باشند . در اغلب موارد تفاوت بين دو دستگاه فوق ، تعداد پورت هاى ارائه شده توسط هر يک از آنان است . با اين که يک repeater معمولا" داراى صرفا" دو پورت مى باشد ، يک هاب مى تواند داراى چهار تا بيست و چهار پورت باشد . در شبکه هاى Ethernet 10BAST-T و يا Ethernet 100BASE-T استفاده از هاب بسيار متداول است . با استفاده از هاب ، توپولوژى شبکه از bus خطى که در آن هر دستگاه مستقيما" به ستون فقرات شبکه متصل مى گردد ، به يک مدل ستاره و يا star تبديل مى شود . داده دريافتى بر روى يک پورت هاب براى ساير پورت هاى متصل شده به يک سگمنت شبکه اى مشابه نيز ارسال مى گردد . ( بجزء پورتى که داده را ارسال نموده است ) . به موازات افزايش دستگاه هاى متصل شده به يک هاب ، احتمال بروز تصادم و يا Collision افزايش مى يابد . يک تصادم زمانى بروز مى نمايد که دو و يا بيش از دو ايستگاه در يک لحظه اقدام به ارسال داده در شبکه نمايند . در صورت بروز يک تصادم ، تمامى داده ها از بين خواهد رفت . هر دستگاه متصل شده به يک سگمنت مشابه شبکه ، عضوى از يک collision domain مى باشند .

در برخى موارد لازم است که يک شبکه بزرگ محلى به سگمنت هاى کوچکتر و قابل مديريتى تقسيم گردد. هدف از انجام اين کار کاهش ترافيک و افزايش حوزه جغرافيائى يک شبکه است . از دستگاه هاى شبکه اى متفاوتى به منظور اتصال سگمنت هاى متفاوت يک شبکه به يکديگر استفاده مى گردد . Bridge ، سوئيچ ، روتر و gateway نمونه هائى در اين زمينه مى باشند . سوئيچ و Bridge در لايه Data Link مدل مرجع OSI کار مى کنند . وظيفه Bridge ، اتخاذ تصميم هوشمندانه در خصوص ارسال يک سيگنال به سگمنت بعدى شبکه است . پس از دريافت يک فريم توسط Bridge ، آدرس MAC مقصد فريم در جدول Bridge بررسى تا مشخص گردد که آيا ضرورتى به فيلترينگ فريم وجود دارد و يا مى بايست فريم به سمت يک سگمنت ديگر هدايت گردد .
فرآيند تصميم گيرى با توجه به مجموعه قوانين زير انجام مى شود :
□ در صورتى که دستگاه مقصد بر روى سگمنت مشابه باشد ، Bridge فريم دريافتى را بلاک و آن را براى ساير سگمنت ها ارسال نمى نمايد . به فرآيند فوق، فيلترينگ مى گويند .
□ در صورتى که دستگاه مقصد بر روى يک سگمنت ديگر باشد ، Bridge آن را به سگمنت مورد نظر فوروارد مى نمايد .
□ در صورتى که آدرس مقصد براى Bridge ناشناخته باشد ، Bridge فريم را براى تمامى سگمنت هاى موجود در شبکه بجزء سگمنتى که فريم را از آن دريافت نموده است ، فوروارد مى نمايد . به فرآيند فوق flooding مى گويند. استفاده مناسب از Bridge ، افزايش کارآئى يک شبکه را به دنبال خواهد داشت .

از سوئيچ در برخى موارد به عنوان يک bridge چند پورته نام برده مى شود . با اين که يک Bridge معمولى ممکن است داراى صرفا" دو پورت باشد که دو سگمنت شبکه را به يکديگر متصل مى نمايد ، سوئيچ مى تواند داراى چندين پورت باشد. همانند bridge ، سوئيچ ها داراى دانش و آگاهى لازم در خصوص بسته هاى اطلاعاتى دريافتى از دستگاه هاى متفاوت موجود در شبکه مى باشند و دانش خود را نيز متناسب با شرايط موجود ارتقاء مى دهند(يادگيرى) . سوئيچ ها از اطلاعات فوق به منظور ايجاد جداول موسوم به جداول فورواردينگ استفاده نموده تا در ادامه قادر به تعيين مقصد داده ارسالى توسط يک کامپيوتر براى کامپيوتر ديگر موجود بر روى شبکه باشند .

با اين که سوئيچ و Bridge داراى شباهت هائى با يکديگر مى باشند ، ولى سوئيچ ها دستگاه هائى بمراتب پيشرفته تر و حرفه اى تر نسبت به Bridge مى باشند . همانگونه که اشاره گرديد ، معيار اتخاذ تصميم Bridge براى فورواردينگ يک فريم ، آدرس MAC يک فريم است . سوئيچ داراى چندين پورت است که سگمنت هاى متفاوت شبکه به آنان متصل مى گردند . سوئيچ ها با توجه به تاثير محسوس آنان در افزايش کارآئى شبکه از طريق بهبود سرعت و پهناى باند ، به يکى از متداولترين دستگاه هاى ارتباطى شبکه تبديل شده اند .

سوئيچينگ ، يک فن آورى است که کاهش ترافيک و افزايش پهناى باند در شبکه هاى محلى اترنت را به دنبال خواهد داشت . سوئيچ ها را بسادگى مى توان جايگزين هاب نمود ، چراکه آنان از زيرساخت سيستم کابل موجود مى توانند استفاده نمايند .

سوئيچ ها داراى سرعتى بمراتب بيشتر از Bridge بوده و قادر به حمايت از پتانسيل هاى جديدى نظير شبکه هاى VLAN مى باشند .

يک سوئيچ اترنت داراى مزاياى متعددى است ، مثلا" به کاربران متعددى اجازه داده مى شود که به صورت موازى از طريق مدارات مجازى و سگمنت هاى اختصاصى شبکه در يک محيط عارى از تصادم ، با يکديگر ارتباط برقرار نمايند . بدين ترتيب از پهناى باند موجود به صورت بهينه استفاده مى گردد .

روتر مسئوليت روتينگ بسته هاى اطلاعاتى از مبداء به مقصد را در شبکه هاى محلى برعهده دارد و امکان ارتباطى را براى شبکه هاى WAN فراهم مى نمايد . در شبکه هاى محلى روتر شامل broadcast بوده و سرويس هاى ترجمه آدرس محلى نظير ARP و RARP را ارائه مى نمايد و مى تواند با استفاده از يک ساختار Subnetwork ، شبکه را سگمنت نمايد . به منظور ارائه سرويس هاى فوق ، روتر مى بايست به LAN و WAN متصل باشد .

وظيفه کارت شبکه ( NIC ) ، اتصال يک دستگاه ميزبان به محيط انتقال شبکه است . کارت شبکه يک برد مدار چاپى است که درون يکى از اسلات هاى موجود بر روى برداصلى کامپيوتر و يا دستگاه جانبى يک کامپيوتر نصب مى گردد . اندازه کارت شبکه بر روى کامپيوترهاى Laptop و يا notebook به اندازه يک کارت اعتبارى است .

کارت هاى شبکه به منزله دستگاه هاى لايه دوم مدل مرجع OSI مى باشند ، چراکه هر کارت شبکه به همراه خود يک کد منحصربفرد را که به آن آدرس MAC مى گويند ، ارائه مى نمايد . از آدرس فوق به منظور کنترل مبادله اطلاعات در شبکه استفاده مى گردد .

هر کارت شبکه داراى کانکتورهائى است که امکان اتصال آن را به محيط انتقال فراهم مى نمايد . در برخى موارد ممکن است نوع کانکتور موجود بر روى يک کارت شبکه با نوع رسانه انتقال داده مطابقت ننمايد . مثلا" در روترهاى سيسکو مدل 2500 از يک کانکتور AUI استفاده شده است و براى اتصال به يک کابل اترنت UTP cat 5 مى بايست از يک transmitter/receiver که به آنان transceiver گفته مى شود ، استفاده گردد . transceiver ، مسئوليت تبديل يک نوع سيگنال و يا کانکتور به نوع ديگرى را برعهده دارد . به عنوان نمونه ، يک transceiver مى تواند يک اينترفيس AUI پانزده پين را به يک RJ-45 jack متصل نمايد . transceiver ، به عنوان يک دستگاه لايه يک شبکه ايفاى وظيفه مى نمايد چراکه صرفا" با بيت ها کار مى نمايد و داراى اطلاعات آدرس دهى خاصى و يا پروتکل هاى لايه بالاتر نمى باشد .

در شبکه هاى LAN و يا WAN ، تعدادى کامپيوتر با يکديگر متصل شده تا سرويس هاى متفاوتى را در اختيار کاربران قرار دهند . براى انجام اين کار ، کامپيوترهاى موجود در شبکه داراى وظايف و يا مسئوليت هاى مختص به خود مى باشند . در شبکه هاى نظير به نظير ( peer-to-peer ) ، کامپيوترهاى موجود در شبکه داراى وظايف و مسئوليت هاى معادل و مشابه مى باشد( هم تراز ) . هر کامپيوتر مى تواند هم به عنوان يک سرويس گيرنده و هم به عنوان يک سرويس دهنده در شبکه ايفاى وظيفه نمايد . مثلا" کامپيوتر A مى تواند درخواست يک فايل را از کامپيوتر B نمايد . در اين وضعيت ، کامپيوتر A به عنوان يک سرويس گيرنده ايفاى وظيفه نموده و کامپيوتر B به عنوان يک سرويس دهنده رفتار مى نمايد . در ادامه ، کامپيوترهاى A و B مى توانند داراى وظايف معکوسى نسبت به وضعيت قبل باشند .

در شبکه هاى نظير به نظير ، هر يک از کاربران کنترل منابع خود را برعهده داشته و مى توانند به منظور به اشتراک گذاشتن فايل هائى خاص با ساير کاربران ، خود راسا" تصميم گيرى نمايند . کاربران همچنين ممکن است ، به منظور دستيابى به منابع اشتراک گذاشته شده ، ساير کاربران را ملزم به درج رمز عبور نمايند . با توجه به اين که تمامى تصميمات فوق توسط هر يک از کاربران و به صورت جداگانه اتخاذ مى گردد ، عملا" يک نقطه مرکزى براى کنترل و يا مديريت شبکه وجود نخواهد داشت . در اين نوع شبکه ها هر يک از کاربران مسئوليت گرفتن Backup از داده هاى موجود بر روى سيستم خود را برعهده داشته تا در صورت بروز مشکل بتوانند از آنان به منظور بازيافت اطلاعات استفاده نمايند . زمانى که يک کامپيوتر به عنوان يک سرويس دهنده در شبکه ايفاى وظيفه مى نمايد ، سرعت و کارآئى آن متناسب با حجم درخواست هاى دريافتى کاهش خواهد يافت .

نصب و عملکرد شبکه هاى Peer-to-Peer ساده بوده و در اين رابطه به تجهيزات اضافه اى به جزء نصب يک سيستم عامل مناسب بر روى هر يک از کامپيوترها، نياز نخواهد بود . با توجه به اين که کاربران مسئوليت کنترل منابع خود را برعهده دارند ، به مديريت متمرکز و اختصاصى نياز نمى باشد .

به موازات رشد شبکه هاى Peer-To-Peer ، تعريف ارتباط بين کامپيوترهاى موجود در شبکه و ايجاد يک هماهنگى منسجم بين آنان ، به يک مشکل اساسى در شبکه تبديل مى شود . اين نوع شبکه ها تا زمانى که تعداد کامپيوترهاى موجود در شبکه کمتر از ده عدد باشد ، به خوبى کار مى کنند و همزمان با افزايش تعداد کامپيوترهاى موجود در شبکه ، کارآئى شبکه به شدت کاهش پيدا خواهد کرد . با توجه به اين که کاربران مسئوليت کنترل دستيابى به منابع موجود بر روى کامپيوترهاى خود را برعهده دارند ، امنيت در اين نوع شبکه ها داراى چالش هاى جدى مختص به خود مى باشد .

در شبکه هاى سرويس گيرنده - سرويس دهنده ، سرويس هاى شبکه بر روى يک کامپيوتر اختصاصى با نام سرويس دهنده قرار گرفته و سرويس دهنده مسئول پاسخگوئى به درخواست سرويس گيرندگان مى باشد . سرويس دهنده يک کامپيوتر مرکزى است که به صورت مستمر به منظور پاسخگوئى به درخواست سرويس گيرندگان براى فايل ، چاپ ، برنامه ها و ساير سرويس ها در دسترس مى باشد .

سرويس دهندگان در شبکه هاى سرويس گيرنده - سرويس دهنده بگونه اى طراحى شده اند که بتوانند بطور همزمان به درخواست هاى سرويس گيرندگان متعددى پاسخ دهند . قبل از اين که يک سرويس گيرنده قادر به دستيابى منابع موجود بر روى سرويس دهنده باشد ، مى بايست سرويس گيرنده شناسائى و به منظور استفاده از منبع درخواستى تائيد گردد . بدين منظور به هر يک از سرويس گيرندگان يک account name و رمز عبور نسبت داده مى شود . بدين ترتيب بر خلاف شبکه هاى Peer-To-Peer ، امنيت و کنترل دستيابى متمرکز و توسط مديران شبکه پياده سازى و مديريت مى گردد . هزينه برپاسازى و مديريت شبکه هاى سرويس گيرنده - سرويس دهنده نسبت به شبکه هاى Peer-to-Peer بمراتب بيشتر است و تمرکز سرويس ها در يک نقطه مى تواند آسيب پذيرى سيستم را افزايش داده و ارائه سرويس هاى online را دچار مشکل نمايد . بدين منظور لازم است از راهکارهائى منطقى به منظور برخورد با مسائل غيرقابل پيش بينى و استمرار ارائه خدمات توسط سرويس دهنده استفاده گردد .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 27 تیرماه 1384

06:25 PM

July 18, 2005

نگاهي به‌سند راهبردي امنيت فضاي تبادل اطلاعات كشور

به استناد بند "ج" ماده ‪ ۴۴‬قانون برنامه چهارم توسعه اقتصادي، اجتماعي و فرهنگي، و همچنين به پيشنهاد شوراي عالي امنيت فضاي تبادل اطلاعات كشور - به عنوان مرجع عالي سياستگذاري اين حوزه - ، سند راهبردي امنيت فضاي تبادل اطلاعات در كشور شكل گرفته است.

هدف از شكل‌گيري اين سند، كه متن آن به تازگي از سوي دبيرخانه شوراي عالي امنيت فضاي تبادل اطلاعات منتشر شده است، تضمين همگرايي و نظام بندي برنامه‌هاي كشور در زمينه امنيت فضاي تبادل اطلاعات عنوان شده است .

نگاهي به مفاد اين سند راهبردي كه "سند بالادستي " برنامه‌هاي بخشي و فرابخشي تبادل اطلاعات و ارتباطات در كشور شمرده شده است مي‌تواند بيانگر هدف والاي اين سند براي قانون مندسازي گستره فعاليت در حوزه فناوري ارتباطات و اطلاعات، و دلايل و چگونگي شكل‌گيري اين سند باشد.

در مقدمه اين سند آمده است : در عصر اطلاعات شاهد شكل‌گيري فضايي هستيم كه در آن فعاليت‌هاي گوناگوني از قبيل اطلاع رساني، داده ورزي، ارائه خدمات، مديريت و كنترل و ارتباطات، از طريق ساز و كارهاي الكترونيكي و مجازي انجام مي‌پذيرد.

اين فضا كه از آن با نام فضاي تبادل اطلاعات ياد مي‌شود در معرض چالش‌ها، آسيب‌ها و تهديدهاي الكترونيك گوناگون نظير ارتكاب جرايم سازمان يافته، تخريب بانك‌هاي اطلاعاتي، حملات مختل‌كننده خدمات، جاسوسي، خرابكاري، نقض حريم خصوصي و نقض حقوق مالكيت معنوي قرارداد، بطوريكه نپرداختن با رويكرد نادرست به امنيت اين فضا مانعي بزرگ پيش روي گسترش كاربرد فناوري ارتباطات و اطلاعات و ورود به جامعه اطلاعاتي خواهد بود.

اين مقدمه مي‌افزايد: با توجه به نوپايي مفهوم امنيت فضاي تبادل اطلاعات و امكان پذير بودن دستيابي به دانش و فناوري‌هاي مرتبط و ضرورت بومي‌سازي اين حوزه با عنايت به ميزان تاثير آن بر امنيت ملي كشور، پرداختن به امنيت فضاي تبادل اطلاعات به عنوان يك ضرورت و اولويت كشور تلقي مي‌شود.

به منظور تعيين نقش حاكميت جهت دهي فعاليت‌هاي اجرايي و هماهنگي، نظارت و هدايت بخش‌هاي درگير موضوع، ايجاد نظامي منسجم در سطح ملي مورد نياز است.

در اين سند براي شكل‌گيري نظام منسجم در اين زمينه اعلام شده كه بايد به هفت ويژگي خاص امنيت در اين فضا و اصول اوليه حاكم بر ان توجه داشت.

اين ويژگي‌ها به شرح زير بيان شده است:
امنيت فضاي تبادل اطلاعات مفهومي كلان و ميان رشته‌اي است كه بر مفاهيم و نظريات گوناگونب در حوزه‌هاي مختلف دانش مبتني است.

امنيت فضاي تبادل اطلاعات امري نسبي است كه به تلقي از مفهوم امنيت كارايي و هزينه وابسته است.

امنيت فضاي تبادل اطلاعات امري زمينه وند است و مجموعه آداب و سنن اخلاقيات، قوانين و ساير مقولات اجتماعي در آن تاثير دارد.

دولت در موضوع امنيت فضاي تبادل اطلاعات كشور نقش كارگزار اصلي را بر عهده دارد.

امنيت فضاي تبادل اطلاعات به مرزهاي جغرافيايي محدود نمي‌شود و از حوزه‌هاي داخلي، منطقه‌اي و جهاني تاثير مي‌پذيرد.

تغييرات سريع فناوري‌هاي زمينه، نوع، ماهيت، درجه اثر و مشكلات امنيتي را به شدت تحت تاثير قرار مي‌دهد و لازم است تهديدها، آسيب پذيري ها و راه‌هاي مواجهه و مقابله با ان به صورت دائم و پويا مورد بررسي قرار گيرد.

حوزه تاثير امنيت فضاي تبادل اطلاعات، كليه فعاليت‌هاي آحاد جامعه در اين فضا را شامل مي‌شود.

با عنايت به اين ويژگي‌ها ، لازم است در كنار امن‌سازي سرمايه‌هاي درون اين فضا،اعم از داده ها، اطلاعات و منابع سخت افزاري، نرم افزاري و ارتباطي، امنيت حوزه‌هاي متاثر از فعاليت‌هاي درون اين فضا مورد اهتمام كافي قرار گيرد.

بايد توجه لازم مبذول شود تا اين فضا نه تنها وسيله‌اي براي تعارض با ارزش‌ها و هنجاري‌هاي جامعه نباشد بلكه محيطي امن براي حفاظت و صيانت از هويت ديني و ملي كشور و رشد فعاليت‌هاي علمي، اقتصادي و اجتماعي در جامعه گردد.

علاوه بر اين بايد مراقب بود كه اين فضا بستري براي انجام هماهنگي‌ها و عمليات، جهت تحقق فعاليت‌هاي غيرقانوني قرار نگيرد. بنابراين منظور از امنيت فضاي تبادل اطلاعات برقراري شرايط و حالتي است كه دارايي‌هاي اين فضا از خطرات مختلف محفوظ بماند و بيم و دغدغه نسبت به تهديد ساير دارايي هاي مادي و معنوي جامعه از اين طريق نيز وجود نداشته باشد.

بر اين اساس امنيت فضاي تبادل اطلاعات فراتر از فعاليت‌هاي اجرايي يك يا چند دستگاه است و نيازمند مشاركت همه بخش‌هاي حاكميتي و اجرايي كشور، بخش‌هايي غيردولتي و همچنين آحاد شهروندان جامعه است.

در سند راهبردي امنيت فضاي تبادل اطلاعات كشور، خط مشي‌هاي كلان ، اهداف كلان ، و راهبردهاي حاصل از تدوين نظام تبادل اطلاعات كشور اعلام شده است.

در اين سند جهت اختصار در بيان، "فضاي تبادل اطلاعات" به اختصار"فتا" ، "امنيت فضاي تبادل اطلاعات"، به اختصار "افتا"، و" شوراي عالي امنيت فضاي تبادل اطلاعات كشور" نيز "شورا" عنوان شده‌است.

خط مشي‌هاي كلان اين سند را در چهار محور مي‌توان رديابي كرد. نخستين محور "اتكا به توانايي‌هاي داخلي و اهتمام به استفاده از بخش غيردولتي" است. دوم "توازن ميان امنيت هزينه و كارايي" است ، و سومين خط مشي " تمركز در سياست‌گذاري و نظام مندي در اجرا عنوان شده است.چهارمين خط مشي اين سند نيز "تلاش جهت افزايش همكاري‌هاي داخلي، منطقه‌اي و بين‌المللي " است.

اما اصولا اهداف كلان از تدوين اين سند راهبردي چيست؟
در اين سند اهداف كلان تدوين نظام تبادل اطلاعات در پنج اولويت تقسيم بندي شده، كه عبارت است از :
صيانت از هويت ديني ملي و ارزش‌هاي انساني جامعه در فتا.

حفظ حريم خصوصي و ازادي‌هاي مشروع.

صيانت از منافع اسرار و اقتدار ملي در فتا.

حفظ زيرساخت‌هاي حياتي كشوردر مقابل حملات الكترونيكي.

حفظ سرمايه‌هاي مادي و معنوي اسرار كسب و كار و مالكيت خصوصي در فتا.

همه مي‌دانيم براي رسيدن به اهداف، "راهبرد" يا همان استراتژي لازم است. بر اساس همين قاعده كلي "راهبردهاي خاص" براي دستيابي به نظام توانمند تبادل اطلاعات در كشور در سند تدوين شده است كه مي‌توان به شرحي كه در پي مي‌آيد آنها را تقسيم بندي كرد:
امن‌سازي زيرساخت‌هاي حياتي كشور در قبال حملات الكترونيكي.

ايجاد و توسعه نظام‌هاي فني فرابخشي افتا.

تامين سلامت و جلوگيري از مخاطرات ناشي از محتوا در فتا.

تقويت صنعت و توسعه خدمات و محصولات افتا.

حمايت از تحقيق ارتقا سطح آگاهي دانش و مهارت‌هاي مرتبط با افتا.

ارتقا سطح همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه افتا.

در راستاي عملياتي كردن اهداف، و در چهارچوب راهبردهايي كه سند براي رسيدن به اهداف كلان ترسيم كرده است بايد مجموعه اقداماتي صورت گيرد كه سند راهبردي امنيت فضاي تبادل اطلاعات كشور ، براساس راهبردهاي كلان خود ، اقداماتي كه بايد صورت گيرد، مجري اقدام و همكار آن را مشخص ، و تقسيم بندي نموده است.

اقدامات مربوط به راهبرد اول:
‪ ۱‬طرح امن‌سازي زيرساخت‌هاي حياتي كشور و منابع ملي در قبال حملات الكترونيكي:
در قالب اين طرح اقدامات تهيه برنامه ملي، ارايه راهكارهاي فني، آموزش و آگاهي رساني امنيتي به همه عوامل درگير در كنترل و هدايت زيرساخت‌هاي حياتي در سطح ملي، ايجاد مراكز جمع آوري اشتراك و تحليل اطلاعات در سطح ملي، نظارت بر تداوم امنيت زيرساخت‌ها از طريق جمع آوري اطلاعات تحليل و مديريت مخاطرات و تشخيص و مقابله با حوادث در سطح ملي انجام مي‌شود.

مجري اين طرح وزارت اطلاعات و همكاران آن وزارت كشور، و دستگاههاي متولي زيرساخت‌هاي حياتي خواهد بود.

‪ ۲‬طرح ايجاد نظام مديريت امنيت زيرساختهاي حياتي در دستگاه‌هاي مرتبط:
در اين چهارچوب، ايجاد سيستم مديريت امنيت، اجراي برنامه‌هاي امن‌سازي زيرساخت‌هاي حياتي، آموزش و آگاهي رساني اينترنتي به همه عوامل درگير در كنترل و هدايت زيرساخت‌هاي حياتي در سطح دستگاه، ايجاد مراكز جمع آوري اشتراك و تحليل اطلاعات در سطح دستگاه، تامين تداوم امنيت زيرساخت‌ها از طريق جمع آوري اطلاعات تحليل و مديريت مخاطرات و تشخيص و مقابله با حوادث در سطح دستگاه مورد نظر است.

مجري اين طرح دستگاه‌هاي متولي زير ساخت‌هاي حياتي ، و همكاران وزارت اطلاعات، و وزارت كشور است.

اقدامات مربوط به راهبرد دوم:
‪ ۱‬طرح ايجاد نظام استانداردها و دستورالعمل فني افتا:
تعيين يا تدوين استانداردها،
تعيين و تدوين خط مشي‌ها و رويه‌هاي فني و مديريتي.

تعيين و تدوين و اعمال طرح ها، برنامه ها، دستورالعمل‌ها و راهنماي ملي.

مجري اين طرح سازمان مديريت و برنامه ريزي ، و موسسه استاندارد و تحقيقات صنعتي خواهد بود كه در اين زمينه وزارت اطلاعات، وزارت دفاع و پشتيباني نيروهاي مسلح از جمله همكاران آنها خواهند بود.

‪ ۲‬طرح تعيين صلاحيت فني محصولات و مديريت افتا تاييد صلاحيت ارزياب هاي فني:
ارايه راه كارهاي فني و ارزيابي فني.

ارزيابي و صدور گواهي محصولات.

ايجاد مركز تاييد صلاحيت مديريت امنيت اطلاعات.

ايجاد مراكز صدور گواهي.

ايجاد مراكز آموزش مميزي امنيت اطلاعات.

ارزيابي امنيتي فتا.

ايجاد آزمايشگاه‌هاي ارزيابي امنيتي محصولات.

تاييد صلاحيت آزمايشگاه‌هاي ارزيابي امنيتي محصولات.

محصولات شامل "ارزيابي امنيتي فتا " ، "ايجاد ازمايشگاههاي ارزيابي امنيتي محصولات" و " تاييد صلاحيت ازمايشگاه‌هاي ارزيابي امنيتي محصولات" است.

‪ ۳‬طرح ايجاد نظام پيش‌گيري مقابله و امداد افتا:
جمع آوري موثر پردازش و مديريت يكپارچه اطلاعات مربوط به حملات تهديدها و آسيب پذيري ها
اطلاع رساني و ارايه هشدارهاي امنيتي در سطح كشور.

كمك به رفع آسيب پذيري ها، تهديدها و تاثيرات حملات.

‪ ۴‬طرح ايجاد نظام تصديق هويت رايانه‌اي:
يكپارچه‌سازي خدمات مبتني بر كليد عمومي.

ايجاد مركز ملي صدور گواهي.

ايجاد مركز صدور گواهي در حوزه دولت.

ايجاد مراكز صدور گواهي در بخش‌هاي غيردولتي و تجاري.

‪ ۵‬طرح ايجاد نظام مقابله با جرايم فتا:
ايجاد مركز تشخيص جرايم فتا.

ايجاد پليس مخصوص فتا.

‪ ۶‬طرح ايجاد زيرساخت محرمانگي در فتا:
نظارت بر كاربرد الگريتم‌هاي رمزنگاري.

نظارت بر كاربرد پروتكل‌هاي امنيتي .

‪ ۷‬طرح ايجاد زيرساخت‌هاي حقوقي مرتبط با افتا:
تهيه لوايح حقوقي و قضايي مورد نياز در حوزه افتا.

آموزش قضات، وكلا، ضابطين و افراد حقوقي در حوزه افتا.

‪ ۳‬اقدامات مربوط به راهبرد سوم:(تامين سلامت و جلوگيري از مخاطرات ناشي از محتوا در فتا)
طرح ايجاد نظام صيانت از ماكيت فكري و معنوي.

طرح ايجاد ساز و كارفني و قانوني سلامت محتوا كه شامل ايجاد سازو كار فني و قانوني صيانت ار ارزش‌هاي ديني و ملي و ايجاد سازو كار مسووليت پذيري ذر توليد و عرضه محتوا است.

طرح ايجاد مراكز عمليات امنيت براي مديريت و نظارت بر وقايع امنيتي در سطوح سازماني ، شبكه‌اي و ملي است.

طرح ايجاد صيانت از حريم خصوصي.

طرح تهيه منشور اخلاق در فتا و ترويج آن.

‪ ۴‬اقدامات مربوط به راهبرد چهارم:(تقويت صنعت و توسعه خدمات و محصولات افتا)
طرح امكان سنجي انتخاب صنعت افتا به عنوان فناوري پيش تاز.

طرح حمايت از توليد، پشتيباني و به كارگيري محصولات داخلي در حوزه افتا.

طرح حمايت از تشكيل و تقويت شركت‌هاي تخصصي و حرفه‌اي در زمينه افتا كه شامل حمايت از ايجاد تشكل‌هاي صنفي، كمك به توسعه صادرات و گسترش بازار و طرح حمايت از تحقيق و توسعه در صنايع مرتبط با افتا است.

طرح حمايت از ايجاد آزمايشگاه‌هاي تخصصي افتا.

طرح حمايت از توسعه مراكز آموزشي حرفه‌اي افتا.

اقدامات مربوط به راهبرد پنجم:( حمايت از تحقيق، ارتقاء، سطح آگاهي، دانش، مهارت‌هاي مرتبط با افتا)
طرح تدوين مباني نظري و معماري افتا.

طرح حمايت از فعاليت‌هاي پژوهشي مرتبط با افتا شامل حمايت از تحقي‌ق و پژوهش و جهت دهي به پژوهش‌هاي مقاطع تحصيلات تكميلي خاص و ميان رشته‌اي مرتبط با افتا، حمايت از انتشار نشريات علمي و تخصصي در زمينه افتا و حمايت از انجمن‌هاي علمي و فني در زمينه افتا.

طرح تقويت دوره‌هاي دانشگاهي در زمينه افتا.

طرح ترويج و توسعه آموزش و آگاهي‌هاي همگاني در حوزه افتا كه شامل طرح فرهنگ‌سازي اخلاقي و اشاعه روحيه مسووليت پذيري است.

اقدامات مربوط به راهبرد ششم( ارتقا سطح همكاري‌هاي منطقه‌اي و بين المللي در زمينه افتا)
طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل فني در حوزه افتا كه شامل طرح فراهم‌سازي امكان دسترسي و استفاده از زيرساخت هتصديق هويت رايانه‌اي منطقه‌اي و بين‌المللي ، طرح فراهم‌سازي امكان دسترسي و استفاده از نظام‌هاي اطلاع رساني و امداد منطقه‌اي و بين‌المللي و طرح همكاري منطقه‌اي و بين‌المللي در حوزه استانداردها و گواهي نامه ها طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسال فرهنگي اجتماعي حوزه افتا شامل طرح همكاري كشورهاي اسلامي در زمينه صيانت از فرهنگ اسلامي در فتا و طرح همكاري كشورهاي فارسي زبان در زمينه صيانت از فرهنگ و زبان فارسي در فتا است.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل اقتصادي تجاري در حوزه افتا شامل كارت‌هاي اعتباري بانكي است.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل حقوقي قضايي و انتظامي در حوزه افتا.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل مرتبط با جامعه اطلاعاتي ئر حوزه افتا كه شامل طرح همگامي و مشاركت در وضع قوانين و تصميم‌گيري هاي منطقه‌اي و بين‌المللي مرتبط با حوزه افتا است.

خطوط راهنما:
خطوط راهنما سند، مجموعه‌اي از ملاحظات ضروري در تحقق اهداف، راهبردها و اقدامات پيش بيني شده است. اين خطوط راهنما شامل موارد ذيل است:
براي دستيابي به وضع مطلوب در هر حوزه، و به تبع آن در كل كشور، پروژه‌هاي لازم با توجه به موانع و فرصت‌ها تعريف شده و انجام آنها از طريق روش‌هاي علمي در حوزه كنترل پروژه به دقت نظارت شود.

در هماهنگي اجزاي مختلف نظام افتا، ساز و كارهاي شناخته شده هماهنگي استفاده شود به گونه‌اي كه به كم‌ترين ميزان نظارت مستقيم نياز باشد.

ساز و كارهاي ارتباطات و بازخورد مناسب براي نگهداري نظام و انطباق آن با تغييرات طراحي شود.

مراحل انجام كار به دقت مستند شده و متدلوژي آن به نحوي كه در ساير بخش‌ها قابل استفاده باشد تهيه گردد.

پس از طراحي كل نظام، بخش‌هاي مختلف آن به صورت كاملا شفاف تعبين و اولويت هر يك براي اجرا مشخص شود.

اقدامات مربوط به راهبرد ششم:
طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل فني در حوزه افتا كه شامل طرح فراهم‌سازي امكان دسترسي و استفاده از زيرساخت تصديق هويت رايانه‌اي منطقه‌اي و بين‌المللي ، طرح فراهم‌سازي امكان دسترسي و استفاده از نظام‌هاي اطلاع رساني و امداد منطقه‌اي و بين‌المللي و طرح همكاري منطقه‌اي و بين‌المللي در حوزه استانداردها و گواهي نامه‌ها.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسال فرهنگي و اجتماهي حوزه افتا شامل طرح همكاري كشورهاي اسلامي در زمينه صيانت از فرهنگ اسلامي در فتا و طرح همكاري كشورهاي فارسي زبان در زمينه صيانت از فرهنگ و زبان فارسي در فتا.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل اقتصادي و تجاري در حوزه افتا شامل كارت‌هاي اعتباري بانكي است.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل حقوقي قضايي و انتظامي در حوزه افتا شامل نظام مقابله با جرايم افتا است.

طرح توسعه همكاري‌هاي منطقه‌اي و بين‌المللي در زمينه مسايل مرتبط با جامعه اطلاعاتي در حوزه افتا شامل طرح همگامي و مشاركت در وضع قوانين و تصميم‌گيري هاي منطقه‌اي و بين‌المللي مرتبط با حوزه افتا است.

خطوط راهنما:
خطوط راهنماي سند، مجموعه‌اي از ملاحظات ضروري در تحقق اهداف، راهبرد ها و اقدامات پيش بيني شده است اين خطوط راهنما شامل موارد ذيل است:
براي دستيابي به وضع مطلوب در هز حوزه و به تبع آن در كل كشور، پروژه‌هاي لازم اعم از مديريتي، پژوهشي، توليدي و نظاير آن با توجه به موانع و فرصت‌ها تعريف شده و انجام آنها را از طريق روش‌هاي علمي در حوزه كنترل پروژه به دقت نظارت شود.

در هماهنگي اجزاي مختلف نظام افتا، از ساز و كارهاي شناخته شده هماهنگي استفاده شود به گونه‌اي كه به كم‌ترين ميزان نظارت مستقيم نياز باشد.

ساز و كارهاي ارتباطات و بازخورد مناسب براي نگهداري نظام و انطباق آن با تغييرات طراحي شود.

مراحل انجام كار به دقت مستند شده و متدولوژي آن به نحوي كه در ساير بخش‌ها قابل استفاده باشد تهيه گردد.

پس از طراحي كل نظام، بخش‌هاي مختلف آن به صورت كاملا شفاف تعيين و اولويت هر يك براي اجرا مشخص شود.

*******
به نظر مي‌رسد سند راهبردي امنيت فضاي تبادل اطلاعات كشور، مجموعه كاملي براي نظام بندي فضاي اطلاعاتي - ارتباطاتي در كشور است كه ايران در دنياي امروز به آن نيازمند است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 29 تیرماه 1384

02:57 PM

July 20, 2005

چگونه مي توانيد سايت خود را روي اينترنت قرار دهيد؟

ناشر: ماهنامه شبکه

اشاره :
هنگامي كه طراحي و ساخت سايت خود را با مهارت به پايان برديد، زمان آن فرا مي‌رسد كه بگذاريد مردم نيز آن را ببينند. در اين مقاله مي‌بينيد كه چگونه مي‌توانيد سايت خود را به سادگي و بدون مشكلات و ايرادات بي‌دليل بر روي اينترنت قرار دهيد. زماني كه موعد انتشار سايتتان بر روي اينترنت فرا مي‌رسد احتمالاً بيشتر وقتتان را صرف محتواي صفحات خواهيد كرد تا نحوه دسترسي آن به صورت آن‌لاين. اما همين نحوه انتشار و اصول آن است كه تفاوت يك سايت حرفه‌اي را از يك سايت غيرحرفه‌اي نشان مي‌دهد.

نحوه كنار هم قرار دادن فايل‌ها و صفحات و اتصالات بين آن‌ها مي‌تواند تأثير زيادي بر كارايي يك سايت داشته باشد. به طوري‌كه اگر لينك‌هاي بين صفحات را به صورتي غير كارا ايجاد كنيد، مرورگر اينترنت مجبور مي‌شود براي گرفتن هر صفحه، دو بار درخواست ارسال نمايد.
هميشه سعي كنيد صفحات وب خود را به ساده‌ترين روشي كه مي‌توانيد بر روي سرويس‌دهنده قرار دهيد، و موقع اتمام كار و انتقال فايل‌ها به سرويس‌دهنده از ايجاد تغييراتي كه باعث از كار افتادن كل سايت مي‌گردد اجتناب كنيد. سعي كنيد سايت خود را به نحوي بسازيد كه همه بازديدكنندگان بتوانند آن را به همان صورتي كه ساخته‌ايد و با همان قابليت‌ها و ويژگي‌ها ببينند.
به خاطر داشته باشيد كه مجبور نيستيد فضاي وب مورد نياز سايت خود را از ISP خود دريافت كنيد. به علاوه فضاهاي مجاني نيز به ندرت تمامي ابزارهاي لازم را در بردارند. به خصوص اگر يك سايت جذاب و پر بازديدكننده ايجاد كرده و براي استقرار آن از چنين فضاهاي مجاني استفاده كرده باشيد، مي‌توانند به سادگي شما را در لحظه نياز تنها بگذارند. به هر حال اگر واقعاً قصد انتشار سايت خود را داريد يا صرفاً در حال بررسي گزينه‌هاي مختلف هستيد، ساخت صفحات وب به صورتي كارا و قابل حمل، نتيجه بيشتري خواهد داشت.

FTP دو مرحله‌اي‌
بسياري از نرم‌افزارهاي طراحي و ويرايش صفحات وب، قادر به انتقال و بارگذاري آن‌ها بر روي سرويس‌دهنده نيز مي‌باشند (كه به اين كار انتشار سايت يا Publish كردن سايت گفته مي‌شود). اين بدين معني است كه تغييراتي كه به سايت خود مي‌دهيد به سرعت به سايت بارگذاري شده بر روي سرويس‌دهنده انتقال داده شده و اعمال مي‌شود. اگر ترجيح مي دهيد همه چيز را دو بار كنترل كنيد، نرم‌افزار طراحي وب خود را به گونه‌اي تنظيم كنيد كه به جاي انتقال و انتشار مستقيم صفحات به سرويس‌دهنده‌ راه دور، آن‌ها را به صورت محلي بر روي هاردديسك منتشر كند و پيش از اين كه آن‌ها را توسط FTP به سرويس‌دهنده راه دور انتقال دهيد، آن‌ها را در مرورگر اينترنت خود مشاهده و كنترل كنيد كه آيا همه چيز درست است يا خير. سعي كنيد پوشه سايت منتشرشده را در ريشه درايو قرار دهيد تا براي بارگذاري آن‌ها بر روي سرويس‌دهنده، مجبور نباشيد در درختواره پوشه‌هاي درايو خود به دنبال آن بگرديد.

‌ FTP متني و دودويي‌
هنگامي كه صفحات HTML ( يا CSS و فايل‌هاي اسكريپتي ) را توسط FTP به سرويس‌دهنده انتقال مي‌دهيد به خاطر داشته باشيد كه اين انتقال در مد يا حالت متن انجام شود تا كاراكترهاي انتهاي خطوط و تعيين‌كننده خطوط جديد در اين فايل‌ها به صورت صحيح فرستاده شده و ساختار اين فايل‌ها به صورت درست منتقل شود. در غير اين صورت متن داخل فايل‌ها به خطوطي بسيار كوتاه يا بسيار بلند تبديل مي‌گردد. در حالت انتقال فايل‌ها در مد متن، سه استاندارد مختلف براي انتقال كاراكترهاي سر سطر وجود دارد. استاندارد مناسب را انتخاب كنيد. همچنين مراقب كاراكترهاي اضافي نرم‌افزارهاي واژه پرداز باشيد. از سوي ديگر، فايل‌هاي گرافيكي، تصاوير، فايل‌هاي صوتي و اجرايي و به عبارت ديگر هر چيزي كه نمي‌توانيد آن را در Notepad باز كنيد بايد در مد يا حالت دودويي يا باينري منتقل شوند. اگر نوع انتقال را براي هر قالب فايل بر اساس پسوند آن‌ها از قبل براي نرم‌افزار FTP مشخص كنيد نيازي نخواهيد داشت مد انتقال را هر بار به صورت دستي تغيير دهيد.

 ديواره آتش‌

در نرم‌افزار Excel با فعال نمودن قابليت ذخيره خودكار فايل صفحه گسترده به صورت يك صفحه وب نيازي نخواهيد داشت خودتان هر بار به طور دستي اين كار را انجام دهيد و مي‌توانيد در وقتتان صرفه‌جويي كنيد.
اگر سايتتان را از كامپيوتر محل كار روزآمد كرده و به سرويس‌دهنده راه دور منتقل مي‌كنيد، احتمالاً كامپيوتر مزبور داراي يك ديواره آتش مي‌باشد كه نقل و انتقالات فايل‌ها را بين كامپيوتر شما و اينترنت زير نظر دارد و جلوي دسترسي‌هاي غير مجاز را مي‌گيرد. حال چه اين دسترسي از بيرون به كامپيوتر شما صورت گرفته باشد و چه از درون كامپيوتر شما به دنياي بيرون صورت گرفته باشد (كه ارتباط نرم‌افزار FTP شما با سرويس‌دهنده راه دور از ديد فايروال نيز در زمره مورد دوم قرار مي گيرد.) لذا اگر نرم‌افزار FTP شما قادر به برقراري ارتباط با سرويس‌دهنده راه دور نمي‌باشد يكي از دلايل آن مي‌تواند اين قضيه باشد. در اين صورت به منظور ارتباط با سرويس‌دهنده راه دور و انتقال فايل‌ها مجبور خواهيد بود براي عبور از ديواره آتش، در حالت غيرفعال كار كنيد. اين حالت را در تنظيمات اتصال خود مشخص كنيد تا مجبور نباشيد هر بار آن را تغيير دهيد.

انتشار خودكار

اين نشاني مانند يك آدرس پست الكترونيك عادي به نظر مي‌رسد و عمل مي‌كند اما Spammerها براي به‌دست آوردن آن دچار مشكل خواهند شد، چرا كه اين آدرس پست الكترونيك، در حقيقت يك تصوير است كه با تكه‌اي كدJavascript همراه شده است.
تنها نرم‌افزارهاي طراحي وب قادر به ايجاد فايل‌هاي HTML نيستند. شما به عنوان نمونه مي‌توانيد در نرم‌افزار Excel نيز فايل جداول خود را به صورت HTML تبديل كنيد. تنها كافي است خانه‌هاي مورد نظر خود را انتخاب كرده و گزينهFile>Save As Web Page را انتخاب كنيد و در پنجره ظاهر شده، دكمه راديويي ذخيره تمام خانه‌ها يا خانه‌هاي انتخاب شده را تنظيم كنيد. با انتخاب گزينه Add interactivity صفحه‌اي با كنترل‌هاي پايه‌اي اكسل ايجاد خواهد شد. پس از آن، دكمه Publish را كليك كنيد. در همين پنجره در صورتي كه مايل باشيد مي‌توانيد گزينهAutoRepublish everythime this workbook is saved را علا‌مت بزنيد كه با اين كار، نيازي نخواهيد داشت به هنگام ذخيره فايل خود، هر بار اين مسير را تكرار كنيد و نرم‌افزار اكسل هنگامي كه شما فايل خود را ذخيره مي كنيد، به طور خودكار فايل HTML آن را نيز ايجاد مي‌كند.

كشيدن و انداختن‌
شما مي‌توانيد براي انتقال فايل‌هاي سايت خود به سرويس‌دهنده، به جاي يك نرم‌افزار FTP جداگانه، از مرورگر اينترنت نيز استفاده كنيد. براي اين كار كافي است آدرس ftp سرويس‌دهنده راه دور را در نوار آدرس مرورگر تايپ كرده و كليد Enter را بزنيد. پس از آن يك پنجره Log in ظاهر مي‌شود كه مي‌توانيد نام كاربري و كلمه عبور خود را وارد كنيد. پس از آن، پوشه‌هاي سايت شما بر روي سرويس‌دهنده راه دور ظاهر مي‌شود. درست به همان شكلي كه پوشه‌هاي يكي از درايوهاي محلي كامپيوتر خودتان ديده مي‌شود. مي‌توانيد هر فايل يا پوشه‌اي را كه مايل باشيد تغيير نام دهيد يا آن‌ها را حذف كنيد و حتي مي‌توانيد درست مانند كشيدن و انداختن از پنجره يك درايو در كامپيوتر خود به پنجره درايوي ديگر، فايل‌ها را از پوشه سايت در حال طراحي در كامپيوتر خود، بر داشته و آن را در داخل پنجره مرورگر بيندازيد. مرورگر خودش فايل‌ها را به سرويس‌دهنده انتقال خواهد داد. ارتباط شما با سرويس‌دهنده راه دور تا زماني كه پنجره‌هاي مرورگري كه به سرويس‌دهنده راه دور به صورت FTP متصل شده‌اند باز است برقرار مي‌ماند و پس از بستن همه اين پنجره‌ها، مرورگر، ارتباط را خاتمه مي دهد ( ارتباط FTP ايجاد شده با سرويس‌دهنده راه دور و نه ارتباط با اينترنت).

راهنماي قدم به قدم‌
FTP را خودكار كنيد براي اتصال FTP تنظيمات كاملي را مشخص سازيد تا فايل‌هاي شما در محلي درست بر روي سرويس‌دهنده FTP قرار گرفته و با نامي درست منتقل شوند.
1 پس از اين كه يك اتصال براي سايت خود ايجاد كرديد، پوشه مبدا، يعني محلي كه فايل‌ها و صفحات سايت شما بر روي كامپيوتر شما قرار دارد را مشخص كنيد. بر روي دكمه Advanced Properties كليك كنيد و در برگه Startup ، پوشه مقصد، يعني پوشه‌اي كه فايل‌ها و صفحات، پس از انتقال به سرويس‌دهنده در آن قرار خواهند گرفت را تعيين كنيد. مد يا حالت انتقال فايل‌ها را بر روي Auto Detect قرار دهيد، مگر اين كه به مشكل برخورد نماييد. | 2 هر سرويس‌دهنده‌اي با سرويس‌دهنده ديگر متفاوت است. لذا براي به دست آوردن يك نتيجه به خصوص، بايد گزينه‌هاي مختلفي را تنظيم نماييد. در زبانهSession مي‌توانيد تعيين كنيد كه آيا نام‌ها تماماً با حروف كوچك ارسال شوند يا خير و يا پسوندها در هر جلسه اتصال و انتقال فايل‌ها تبديل شوند يا خير. براي اين كار گزينه Tools > Options > Convert را انتخاب كنيد. | 3 به جاي انتخاب مد انتقال متن يا ASCII و دودويي به صورت مستقل و جداگانه براي هر فايل، از منوي Tools زير منوي Options و در آن، گزينه Extensions را انتخاب كنيد و تمامي پسوندهايي را كه قرار است در حالت متني يا دودويي انتقال يابند، تعيين‌كنيد. نرم‌افزار WS FTP Pro فايل‌هاي در حال انتقال را نيز به طور خودكار براي شما مرتب مي‌كند.

استفاده از وبلاگ‌ها

اطمينان حاصل كنيد كه كد HTML صفحه وب شما به خوبي نوشته شده است. بسياري از نرم‌افزارهاي ويرايشگر صفحات وب، هنگام طراحي‌صفحات وب، كدهاي HTML اضافي و به‌دردنخور در داخل آن‌ها قرار مي‌دهند كه باعث كند شدن روند بارگذاري صفحه در مرورگر مي‌گردد.
استفاده از يك سايت سرويس‌دهنده وبلاگ روش بسيار آساني براي روزآمد كردن سايت است. چرا كه مي‌توانيد از ابزارهاي از قبل آماده شده توسط سرويس‌دهنده وبلاگ براي اين كار استفاده كنيد و متن جديد خود را به صفحه وب خود اضافه كنيد. و فرقي هم نمي‌كند كه از كجا و چگونه مطلب خود را براي سرويس‌دهنده‌ پست كنيد. از طريق يك صفحه وب، از طريق پست الكترونيك در يك كافي‌نت يا از طريق سرويس ارسال پيام كوتاه موسوم به SMS در تلفن‌هاي همراه. سيستم موجود در سرويس‌دهنده وبلاگ پيام شما را گرفته و آن را به طور خودكار به صفحه وب شما اضافه مي‌كند. لذا مي‌توانيد سايتتان را از هر كجاي دنيا كه بخواهيد، بروز نماييد و مطالب جديد را به آن اضافه نماييد. براي اطلاع از نحوه به كارگيري مطالبي كه براي سايت خود پست نموده‌ايد، سري به اين نشاني بزنيد.

كنترل كنيد و باز هم كنترل كنيد
پس از اين كه تمامي صفحات سايت خود را به صورت دستي كنترل كرديد، اين كار را از طريق سرويس كنترل اعتباري كه به همين منظور و به صورت مجاني در سايت كنسرسيوم جهاني وب (W3C) قرار داده شده است نيز انجام دهيد. سايت W3C پس از بررسي سايت شما، اعلام مي‌كند كه آيا سايت داراي استانداردهاي مناسب يك سايت خوب مي‌باشد يا خير.
‌
سايتتان را به‌صورت قابل دسترس براي همه افراد طراحي كنيد.

اگر داراي مشكل كوررنگي هستيد ببينيد رنگ‌ها چگونه به نظر مي‌رسند و تأثير آن‌ها را بر صفحات سايت خود ببينيد.
با به‌كارگيري نكاتي كه در سايت كنسرسيوم جهاني وب و در اين بخش قرار داده شده است صفحات سايت خود را به گونه‌اي بسازيد كه همه بازديدكنندگان، از جمله افراد داراي ناتوانايي‌هاي جسمي و معلول نيز بتوانند از آن استفاده كنند.

رنگ‌هايي را كه در سايتتان به كار برده‌ايد بررسي كنيد.
تعداد بسيار بسيار زيادي از مردم دچار كوررنگي هستند. اگر مي‌خواهيد ببينيد صفحاتي كه با مهارت و صرف وقت زياد، طراحي كرده‌ايد از ديد چنين افرادي چگونه به نظر مي‌رسد، صفحات خود را از طريق اين سايت بارگذاري كنيد و يا نكاتي را كه در آزمايشگاه رنگ‌ها ذكر شده است مطالعه كنيد تا از بازه رنگ‌هايي كه افراد داراي كوررنگي قادر به تشخيص آن‌ها هستند اطلاع پيدا كنيد.

‌
از امتيازات ويژه‌اي كه سرويس‌دهنده در مورد زبان‌هاي برنامه‌نويسي تحت سرويس‌دهنده در اختيارتان قرار مي‌دهد اطلاع حاصل كنيد.

گزارش‌هاي آماري سايتتان را با دقت دنبال كنيد و ببينيد چه كساني مراجعه مي‌كنند و قصدشان از بازديد سايت شما چه بوده است.
اگر قصد داريد اسكريپت‌هايي را كه به يك زبان تحت سرويس‌دهنده (مانند ASP ) نوشته‌ايد بر روي سايت خود قرار دهيد، اطلاع حاصل كنيد كه آيا سرويس‌دهنده شما، زباني را كه شما با آن برنامه‌نويسي نموده‌ايد، پشتيباني مي‌كند يا خير (به عنوان مثال Perl يك زبان مشترك است كه تقريباً همه سرويس‌دهنده‌ها آن را پشتيباني مي‌كنند) و پيگيري كنيد كه چه مواردي را لازم است رعايت كنيد تا كدهايي كه نوشته‌ايد، واقعاً بر روي سرويس‌دهنده كار كند. اگر سرويس‌دهنده شما يك سرويس‌دهنده يونيكس باشد ممكن است قادر باشيد به آن telnet نماييد و از فرمان CHMOD استفاده نماييد. بيشتر شركت‌هاي فراهم كننده اينترنت اجازه نمي‌دهند كه خودتان چنين كاري را انجام بدهيد و لذا مجبوريد از خود آن‌ها در اين مورد بپرسيد كه سرويس‌دهنده، چه زبان يا زبان‌هايي را پشتيباني مي‌كند. اگر چنين است احتمالاً ممكن است محدوديت‌هاي ديگري هم در مورد اسكريپت‌هايي كه مي‌توانيد در سايتتان استفاده كنيد وجود داشته باشد. سعي كنيد پيش از اين كه يك اسكريپت پيچيده را بنويسيد در اين مورد كسب اطلاع كنيد.

اندازه مناسبي را انتخاب كنيد
شما نمي‌توانيد انتظار داشته باشيد كه همه بازديدكنندگان سايت شما وضوح صفحه نمايش يكسان براي مشاهده آن استفاده نمايند يا همه، به هنگام بازديد از سايت شما، پنجره مرورگر خود را در حالت حداكثر اندازه آن مورد استفاده قرار داده باشند. از اين رو سايت خود را در دقت‌هاي مختلف صفحه نمايش بررسي كرده و ظاهر آن را ببينيد. اگر نرم‌افزار طراحي سايت شما قادر به پيش نمايش صفحات در دقت‌هاي مختلف صفحه نمايش نيست، از ميله جستجوي سريع شركت DQSD كه آدرس سايت آن www.dqsd.net مي‌باشد استفاده نماييد. اين ميله، پس از نصب در ميله وظايف ويندوز قرار مي‌گيرد و علاوه بر مهيا نمودن امكان جستجو از طريق Google براي شما و چندين سايت به درد بخور ديگر، مي‌تواند يك سايت را در پنجره مرورگري با اندازه‌اي مشخص باز نمايد. به طوري كه مثلاً چنانچه قصد جستجو به دنبال چيزي را از طريقGoogle داشته باشيد، ديگر نيازي نداريد خودتان يك پنجرهInetrnet Explorer باز كرده، سايت Google را بياوريد و در جعبه متن جستجو، نام چيزي را كه به دنبال آن بگرديد تايپ كرده و كليد Enter يا دكمه Search را بزنيد. ميله جستجوي سريع DQSD خودش همه اين كارها را براي شما انجام مي‌دهد. براي مشاهده يك سايت مانند http://www.mysite.com در يك وضوح به خصوص نظير 800X600 نيز كافي است در جعبه متن ميله DQSD بنويسيد " winres 600X800 http://www.mysite.com " پس از آن، اين ميله يك پنجره مرورگر با اندازه مشخص شده باز كرده و سايت درخواستي شما را در آن نشان مي‌دهد.

فايل‌هاي پيش‌فرض به كار ببريد

تنظيمات ميزباني وب‌

شما مجبور نيستيد ميزباني سايت وب خود را به فراهم كننده اتصال به اينترنت خود بسپاريد. در زير، نكاتي ذكر مي‌شود كه مي‌توانيد آن‌ها را هنگام انتخاب يك ميزبان در نظر داشته باشيد.

بازي Frontpage
Frontpage Extensions مجموعه‌اي است كه شما را قادر مي‌سازد قابليت‌هايي را به سايتتان اضافه كنيد بدون آن كه لازم باشد خودتان كدي براي استفاده از آن قابليت‌ها بنويسيد، مانند دفاتر يادبود يا Guest book ، فرم‌هاي پرس‌وجو، ابزارهاي جستجو، پيمايش سايت و گالري‌هاي عكس. ببينيد آيا ميزبان شما Frontpage Extensions را پشتيباني مي‌كند يا خير. در غير اين صورت نمي‌توانيد از اين ابزارها استفاده كنيد. اگر سايت وب شما بر روي يك سرويس‌دهنده ويندوز قرار دارد مي‌توانيد در نرم‌افزار Frontpage از منوي File گزينه Open Web را انتخاب كرده و آدرس URL سايت خود را در پنجره ظاهر شده به عنوان نام سايت وب و نيز آدرس FTP سايت خود را به همراه نام كاربري و كلمه عبور آن وارد كنيد تا به سايت خود متصل شويد و به طور زنده با سايت خود، كار كنيد. در اين حالت هر تغييري كه به صفحات خود مي‌دهيد مستقيماً به سايت شما اعمال مي‌شود.

بيت‌هاي پهناي باند
به سايت‌هايي كه قول پهناي باند نامحدود را مي‌دهند هرگز اعتماد نكنيد. چرا كه پهناي باند بالاخره يك مرز و محدوديتي دارد. ممكن است ما از اين مرز اطلاع نداشته باشيم، اما بالاخره اين مرز وجود دارد. چنين سايت‌هايي مي‌توانند از شما پول اضافي مطالبه كنند و يا اگر سايت شما از محبوبيت بالايي برخوردار است آن را بدون اطلاع شما معلق كنند. بر اساس يك حساب سر انگشتي شما براي هر بيست‌هزار بازديد به پانصد مگا بيت پهناي باند نياز خواهيد داشت. بيشتر مردم نيز تنها يك صفحه از سايت شما را بازديد نمي‌كنند و احتمالاً به جاهاي مختلف آن سر مي‌زنند.

پشتيبان‌گيري را جدي بگيريد
سايت شما پشتيبان‌گيري نخواهد شد مگر آن كه شما صريحاً چنين چيزي را درخواست كنيد. همواره يك نسخه پشتيبان از سايت را در محل امني قرار دهيد، به خصوص اگر سايت شما يك سايت مبتني بر پايگاه داده است كه چيزي بيش از صفحات HTML اي كه براي آن نوشته‌ايد را در خود دارد.

كدام پايگاه داده
اگر قصد داريد از پايگاه داده كوچكي براي سايت خود استفاده كنيد، ببينيد آيا ميزبان شما پايگاه داده اكسس ياODBC را پشتيباني مي‌كند يا خير. براي سيستم‌هاي پيچيده‌تر، پشتيباني از پايگاه‌داده‌هاي MySql يا SQL Server و يا ASP.NET را بررسي كنيد اما درباره` مهارت‌هاي برنامه‌نويسي خود منطقي و واقع‌گرايانه برخورد كنيد و چيزي را فراي توان خود انتخاب نكنيد.

گزارش‌هاي آماري
ببينيد چگونه مي‌توانيد دريابيد چه تعداد بازديد كننده به سايت شما مراجعه مي‌كنند، كدام صفحات را بيشتر سر مي‌زنند، از كجاها مي‌آيند و به دنبال چه چيزهايي مي‌گردند.
بيشتر سرويس‌دهنده‌گان وب هنگام درخواست مشاهده يك سايت يا فولدري از يك سايت، به طور پيش‌فرض محل درخواست شده را به دنبال صفحاتي با نام‌هاي index ،default يا welcome با پسوند. htm . ياhtml جستجو مي‌كنند و در صورت موجود بودن يكي از اين فايل‌ها، آن را به مرورگر ارسال مي‌كنند. لذا نيازي نيست شما براي تبليغ سايت خود به ديگران بگوييد مثلاً صفحه index.html را در سايت شما به آدرسhttp://www.mysite.com/index.html ببينند و مي‌توانيد به ديگران يك آدرس وب شسته رفته و تر و تميز به صورتhttp://www.mysite.com بدهيد. اما سعي كنيد در هر يك از پوشه‌هاي سايت خود، يك فايل پيش‌فرض با يكي از نام‌هاي ياد شده در بالا قرار دهيد. چرا كه برخي از سرويس‌دهنده‌ها، هنگامي كه درخواستي را براي مشاهده محتويات يك پوشه دريافت كرده و هيچ يك از فايل‌هاي پيش فرض را در آن پيدا نكردند، به جاي آن، ليست كل فايل‌هاي داخل آن پوشه را نشان مي‌دهند.

صفحاتتان را به صفحه پيش فرض لينك نكنيد
به جاي لينك نمودن يك صفحه به صفحه‌اي با نام پيش فرضي چون index.htm ، سعي كنيد صفحه مورد نظر را به پوشه‌اي كه صفحه پيش فرض در آن قرار دارد لينك كنيد. چرا كه بيشتر مرورگرها تشخيص نمي‌دهند كهwww.mysite.com/books وwww.mysite.com/books/index.htm در حقيقت معادل هم هستند، لذا ممكن است بازديدكنندگان سايت شما لينك‌هايي را كه قبلاً ديده‌اند با رنگي درست مشاهده نكنند (توجه كنيد كه مرورگرها، در يك صفحه وب، لينك‌هايي را كه قبلاً مشاهده كرده‌ايد به رنگي ديگر نشان مي‌دهند تا بدين طريق متوجه شويد كه كدام لينك‌ها را از آن صفحه، مشاهده كرده‌ايد). براي يك لينك، يك آدرس را به كار ببريد و در همه جاهاي ديگر نيز همان را مورد استفاده قرار دهيد. اين كار باعث مي‌شود كه در صورت نياز به انجام تغيير، اين كار سريعتر انجام شود. اگر هنگام كنترل نمودن صفحاتي كه طراحي كرده‌ايد، استفاده از لينك به پوشه، در كامپيوتر شما جواب نمي‌دهد و به جاي آن ليستي از محتواي پوشه مورد نظر به شما نشان داده مي‌شود، فقط بر روي صفحه پيش فرض در آن پوشه كليك كنيد.

براي فايل‌هاي سايت خود ساختاري سلسله مراتبي ترتيب دهيد
طبيعتاً جالب نخواهد بود اگر تمام صفحات و فايل‌هاي سايت خود را در ريشه سايت قرار دهيد. اگر براي فايل‌ها و صفحات سايت خود ساختاري را در نظر بگيريد، مديريت آن‌ها راحت‌تر انجام مي‌شود. بدين ترتيب به هنگام حل يك مشكل در بخشي به خصوص از سايت، تنها با فايل‌هاي درگير در همان مشكل سر و كار خواهيد داشت و اگر اين قسمت، قسمتي است كه عموماً آن را بروز رساني مي‌كنيد، حذف فايل‌هاي قديمي از آن به آساني انجام خواهد شد. شما همچنين مي‌توانيد فايل‌ها را براساس نوع آن‌ها دسته‌بندي كنيد. مثلاً فايل‌هاي گرافيكي را در يك پوشه، فايل‌هاي صوتي را در يك پوشه و كدهاي اسكريپت را در يك پوشه مجزا قرار دهيد. سعي كنيد حتماً پيش از آغاز كار سايت، اين ساختار را مشخص كنيد. چرا كه اگر ساختاري را به صورت موقت ايجاد كرده و به طراحي سايت بپردازيد و بعد تصميم بگيريد تغييري در اين ساختار ايجاد نماييد، بايد كليه لينك‌هاي مربوط به ساختار قبلي را در كل صفحات سايت تغيير دهيد. با اين كار، حتي مدخل‌هاي موتور جستجو (در سايت شما يا موتورهاي جستجوي ديگر) نيز از اعتبار خواهد افتاد و به هنگام جستجو، ممكن است آدرس صفحه‌اي را بدهند كه ديگر وجود ندارد يا به جاي ديگري منتقل شده است.

از علامت تقسيم (/:slash) استفاده كنيد.
هميشه سعي كنيد در انتهايURL هايي كه به پوشه‌ها ربط داده و در صفحات سايت خود به عنوان لينك به كار مي‌بريد، يك كاراكتر (slash) "/" قرار دهيد. به عنوان مثال اگر آدرس www.mysite.com/books را بدون به كارگيري كاراكتر "/" در انتهاي آن استفاده كنيد، مرورگر شما ابتدا از سرويس‌دهنده، فايلي با نام books را درخواست مي‌كند و در صورتي كه چنين فايلي وجود نداشته باشد، سرويس‌دهنده به مرورگر اين مطلب را اطلاع مي‌دهد كه به انتهاي آدرس درخواستي، يك "/" اضافه كند و مجدداً درخواست را ارسال كند. اين به معني طولاني‌ترشدن زمان بارگذاري صفحه بوده در ضمن ممكن است و نه رنگ‌بندي لينك‌هاي ديده شده و ملاقات نشده به صورت درست انجام شود و نه لينك‌هاي نسبي در مرورگرهاي بسيار قديمي، كار خواهد كرد.

نسبي كار كنيد
ساختار دايركتوري سرويس‌دهنده وب راه دور قطعاً مشابه ساختار دايركتوري كامپيوتر شما نخواهد بود. لذا در لينك‌هاي خود هرگز از آدرس‌دهي مطلق (شامل نام درايو و مسير دقيق پوشه‌ها از ريشه تا فايل مورد لينك) استفاده نكنيد چرا كه چنين لينكي قطعاً پس از بارگذاري صفحه وب حاوي آن بر روي سايت در سرويس‌دهنده
راه دور، كار نخواهد كرد. حتي اگر هم نام يكي از پوشه‌هاي به كار رفته در يك لينك را تغيير بدهيد، بايد كل لينك‌هايي كه نام اين پوشه، در بخشي از آن‌ها به كار رفته است را در كل سايت خود تغيير بدهيد. به جاي اين كه خودتان به صورت صريح محل فايل لينك شده را طي يك آدرس‌دهي مطلق در تمامي لينك‌ها مشخص كنيد، از دستور BASE HREF براي مشخص كردن مبدا تمامي لينك‌هاي يك صفحه استفاده كنيد و همچنين از URLهاي نسبي به دايركتوري قبل و بعد در صورت نياز استفاده نماييد. رعايت چنين موردي، سايت شما را تماماً به سايتي قابل حمل مبدل خواهد ساخت.

نام‌هاي كوتاه يا بلند

كمك كنيد ديگران بتوانند سايت شما را در دنيا پيدا كنند

تعداد بي‌شماري بسته‌هاي نرم‌افزاري و سرويس‌هاي آن‌لا‌ين وجود دارند كه قول مي‌دهند سايت شما را در موتورهاي جستجو ثبت كنند، صفحات شما را بهينه كنند (از لحاظ اين كه در آن‌ها تغييراتي را ايجاد كنند كه سريع‌تر توسط موتورهاي جستجو شناسايي شوند) و در كل، رتبه سايت شما را در موتورهاي جستجو بالا ببرند. اگر زندگي سايت شما به بازديدكنندگانش محتاج نمي‌بود مجبور نبوديد پولي خرج كنيد.
ببينيد موتورهاي جستجو در سايت‌ها به دنبال چه چيزهايي مي‌گردند و اطمينان حاصل كنيد كه شما آن چيزي را كه موتورهاي جستجو براي ثبت سايت يا صفحات سايت شما در پايگاه‌هاي داده خود نگاه مي‌كنند، در سايت يا صفحات خود و در جاي درست آن، قرار داده‌ايد. اما با اين وجود، در اين مورد خيلي خود را به دردسر نيندازيد چرا كه سايت‌هايي مانند Google مكرراً فاكتورهاي رتبه‌بندي سايت‌ها را در موتور جستجوي خود تغيير مي‌دهند. صفحات ممكن است يك بار به بالاي ليست‌هاي رتبه‌بندي صعود كنند و يك بار نيز در سطرهاي پايين قرار بگيرند. از اين رو بهتر است وقت خود را صرف بهتر نمودن سايت خود بنماييد تا به بهبود رتبه‌بندي سايت خود در موتورهاي جستجو فكر كنيد.
اطمينان حاصل كنيد كه هر صفحه از سايت شما حتماً يك عنوان مشخص داشته باشد و اين كه تگ TITLE در كدHTML صفحه شما، اولين جزء از قسمت HEAD و نه آخرين جزء است. براي همه تصاوير خود خصوصيت ALT را مشخص كرده و تصاوير را از طريق اين خصوصيت توضيح دهيد. نه تنها موتورهاي جستجو رتبه بهتري به صفحات شما به خاطر انجام اين كار مي‌دهند بلكه اين كار به كساني كه از يك دستگاه صفحه‌خوان براي بازديد سايت شما استفاده مي‌كنند نيز كمك مي‌كند. موتورهاي جستجو بعضي مواقع نگاه مي‌كنند كه سايت شما در چه تاريخي براي آخرين بار بروزرساني شده است، لذا سايت خود را هميشه روزآمد نگه‌داريد و تمامي لينك‌هاي آن را از لحاظ صحت كاركرد كنترل كنيد.
تگ‌هاي META در صفحات از اهميت بسياري برخوردارند. اما آن‌ها تنها نكته‌اي نيستند كه موتورهاي جستجو به آن توجه مي‌كنند. چرا كه بسياري از افراد از اين تگها سوء استفاده مي‌كنند. در بخش META با اين فكر كه توجه افراد بيشتري را به سايتتان جلب كنيد از كلمات و تركيباتي كه ارتباطي با محتواي سايت و صفحات شما ندارند استفاده نكنيد، چرا كه با اين كار رتبه‌بندي شما پايين خواهد آمد و بازديدكنندگان شما نيز خشمگين خواهند شد زيرا درمي‌يابيد كه وعده‌هاي شما دروغين بوده است در نتيجه سايت شما را ترك كرده و هرگز باز نمي‌گردند. در اين زمينه به نكات ذكر شده در اين نشاني و نشاني www.spiderfood.net نيز توجه كنيد.
اهميتي ندارد كه براي نام صفحات سايت خود از پسوند htm. استفاده مي‌كنيد يا html. چرا كه امروزه تمامي مرورگرها هر دو پسوند را مي‌شناسند و قادر به دريافت و نمايش صفحاتي با هر يك از دو پسوند ياد شده هستند. اما براي ايجاد و كنترل نمودن آسانتر لينك‌ها، تنها از يكي از اين دو پسوند استفاده كنيد. اگر نمي‌توانيد پسوند مورد نظر خود را در ابزارهاي ويرايشي خود پيدا كنيد، ممكن است نرم‌افزار FTP شما قادر باشد پسوندها را براي شما تغيير بدهد. شما مجبور نيستيد الزاماً از سيستم نام‌گذاري 3.8 (8 كاراكتر براي نام و 3 كاراكتر براي پسوند) استفاده نماييد. اما دقت كنيد كه نام‌هايي كه به كار مي‌بريد خيلي طولاني نبوده و به راحتي قابل تشخيص باشند.

مراقب حساسيت به حروف باشيد
بسياري از سرويس‌دهنده‌ها از سيستم عامل يونيكس يا لينوكس استفاده مي‌كنند كه بر خلاف سيستم‌هاي ويندوز، در آن‌ها اسامي فايل‌ها و دايركتوري‌ها از حساسيت به بزرگي و كوچكي حروف برخوردارند. به عنوان مثال اگر شما فايلي با نام GreatPhoto.jpg را بر روي سايت خود بارگذاري كنيد و در لينك به اين فايل،GREATPHOTO.jpg را به كار ببريد، لينك شما كار نخواهد كرد. سعي كنيد هميشه تمامي اسامي را با حروف كوچك استفاده كنيد تا سردرگم نشويد. برنامه ويرايشگر صفحات‌وب يا نرم‌افزار FTP بايد گزينه‌اي براي تبديل نام فايل‌ها به حروف كوچك پيش از انتقال آن‌ها به سرويس‌دهنده داشته باشد.

پايگاه داده خود را FTP كنيد

از ميله وظيفه (taskbar) محصول شرکت DSQD براي مشاهده سايت خود در دقت‌هاي مختلف صفحه نمايش استفاده کنيد.
شما معمولاً نمي‌توانيد داده‌ها يا ركوردهاي جديد را به شيوه‌اي كه به راحتي در كامپيوتر خود به پايگاه داده اضافه مي‌كنيد، به طور دستي وارد پايگاه داده‌اي كه بر روي سرويس‌دهنده وب قرار دارد وارد نماييد. اگرچه امكان انتقال ساختار پايگاه داده به سرويس‌دهنده راه دور و سپس وارد كردن داده‌ها در آن وجود دارد اما اين كار در صورت زيادبودن داده‌ها وقت‌گير است. به جاي آن سعي كنيد داده‌ها را از قبل در پايگاه داده خود مانند Access وارد كنيد و سپس فايل پايگاه داده را به سرويس‌دهنده راه دور انتقال دهيد.

آدرس پست الكترونيك خود را مخفي كنيد
اين كه دوستان و آشنايان به راحتي آدرس تماس شما را ببينند و با شما تماس بگيرند خوب است، اما قطعاً دوست نخواهيد داشت كه فرستندگان هرزنامه‌ها و Spammer ها نيز آدرس پست الكترونيك شما را از سايتتان بردارند تا هرزنامه‌ها را به سمت شما سرازير كنند. به جاي تايپ آدرس پست‌الكترونيك خود در صفحات سايت، آن را به صورت يك تصوير گرافيكي در آوريد و يك تكه كد Javascript بنويسيد كه آدرس اصلي را مخفي نگه‌مي‌دارد اما اجازه مي‌دهد هنگامي كه بازديد كنند‌گان بر روي آن تصوير كليك مي‌كنند، نرم‌افزار سرويس‌گيرنده پست الكترونيك آ‌ن‌ها مانندOutlook بارگذاري شود تا بتوانند به آدرسي كه نوشته‌ايد، نامه ارسال كنند. اين شيوه، جلوي بسياري از اسپمرها را مي‌گيرد. در اين صفحه چگونگي انجام اين كار توضيح داده شده و نمونه يك كد اسكريپت قرار داده شده است.

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

سه شنبه، 11 مردادماه 1384

04:27 PM

August 02, 2005

مقدمه اي بر Dot NET Remoting

سعيد احمدلوئي
ماهنامه شبکه - تير ۱۳۸۴ شماره 55

اشاره :
همان‌گونه كه مي‌دانيد وب‌سرويس‌ها امكاني جهت دسترسي به اشياء و توابع از طريق شبكه را فراهم مي‌كنند (در اين زمينه مي‌توانيد به مقاله وب سرويس‌ها و XML در شماره 52 ماهنامه‌شبكه مراجعه نماييد.) وب سرويس‌ها سيستمي بسيار ساده دارند و از آن‌ها مي‌توان به عنوان ابزاري جهت برقراري ارتباط بين سيستم‌هاي با Platformهاي مختلف استفاده كرد، ولي با تمام قابليت‌ها و امكاناتي كه وب‌سرويس‌ها دارند اين تكنولوژي در برخي موارد به اندازه كافي انعطاف‌پذير و سريع نيست و لذا پاسخگوي گروه خاصي از نيازها نيست. بزرگترين عاملي كه اين محدوديت را ايجاد مي‌كند نياز وب سرويس‌ها به IIS و يا به عبارت ديگر ASP.NET runtime مي‌باشد. جهت فائق‌آمدن به اين مسايل مي‌توان از Dot NET Remoting استفاده كرد. در واقع Dot NET Remoting هم دقيقاً همان سرويسي را فراهم مي‌كند كه وب سرويس‌ها فراهم مي‌كنند ولي داراي ويژگي‌هاي خاصي مي‌باشد كه انعطاف و سرعت زيادي نسبت به وب سرويس‌هاي عادي فراهم مي‌كند.

مقدمه‌
به‌طور كلي اگر ساختار يك وب سرويس، (منظور از وب سرويس در اينجا NET ASP . وب‌سرويس مي‌باشد) را بررسي كنيم همواره دو جزء در ساختار آن وجود دارد: جزء اول همان كلاس‌هايي مي‌باشد كه درست مي‌كنيد. به عبارت ديگر در داخل اين كلاس‌ها منطق‌‌كاري وب‌سرويس و توابع عمومي و خصوصي وب سرويس قرار مي‌گيرند و پس از كامپايل، اين كلاس‌ها به يك dll تبديل مي‌شوند. جزء بعدي يك وب سرويس كه همواره موردنياز مي‌باشد برنامه‌اي است كه به يك پورت سيستم گوش مي‌دهد و درخواست‌هاي كلاينت‌ها را مي‌گيرد و به جزء اول مي‌دهد و پس از پردازش پاسخ را گرفته و به كلاينت ارسال مي‌كند. در توليد وب‌سرويس‌هاي عادي تقريباً تمام تمركز روي جزء‌ اول يعني كلاس‌هاي آن است. جزء بعدي همان IIS است كه كافي است در برخي موارد تنظيمات خاصي روي آن انجام دهيم. با استفاده از NET Remoting. سيستم‌هايي جهت دسترسي از طريق شبكه فراهم خواهيم كرد كه در واقع دو بخش يك وب سرويس در آن‌ها هم وجود دارد، ولي اين‌بار مي‌توانيم ازIIS استفاده نكنيم و خودمان برنامه ميزبان (منظور برنامه‌اي كه به شبكه گوش مي‌دهد و تبادل اطلاعاتي بين كلاينت‌ها و كلاس‌هاي ما را فراهم مي‌كند) را بنويسيم. با اين توصيف در واقع مي‌توان گفت كه ASP.NET Web Serviceها نوع ساده‌شده‌اي از سيستم‌هايي هستند كه توسط NET Remoting. مي‌توان توليد كرد چرا كه در استفاده از ASP.NETWeb Serviceها مجبور به استفاده از IIS به عنوان برنامه ميزبان هستيم.
قبل از اين‌كه شروع به پياده‌سازي يك نمونه كامل نماييم، با يك ديد كلي اجزاء سيستم‌ پياده‌سازي شده توسط NET Remoting را مورد بررسي قرار مي‌دهيم.

براي مشاهده تصوير در اندازه واقعي
روي آن كليك كنيد

كلاس‌ها
در سمت سرور، remote object همان كلاس‌هايي مي‌باشند كه منطق اصلي كاري را تشكيل مي‌دهند. اين كلاس‌ها به صورت يك dll روي سرور قرار مي‌گيرند و توابع public اين كلاس‌ها هستند كه در نهايت از طريق كلاينت‌‌ها فراخواني شده و مورد استفاده قرار مي‌گيرند. Formatter كلاسي است كه پاسخ‌هاي سرور (مقادير ارسالي از remote object) را كه به صورت يك سري اشياء مي‌باشند را گرفته و با كدبندي خاصي به يك سري از بايت‌ها تبديل مي‌كند كه مناسب جهت ارسال از طريق شبكه مي‌باشد. همچنين درخواست‌هايي را هم كه كلاينت ارسال مي‌كند از كدبندي خاص آن خارج كرده و تبديل به يك شيء مي‌كند كه قابل‌فهم براي remote object مي‌باشد. سمت كلاينت نيزformatter دقيقاً همين كار را انجام مي‌دهد ولي جهت عكس. به عمليات تبديل يك شيء به فرمتي قابل‌ارسال و يا نگهداري كه توسط Formatter انجام مي‌شود Serialize و به عكس اين عمل Deserialize مي‌گويند. Channel هاي سمت كلاينت و سرور پروتكل ارتباطي بين كلاينت و سرور و تنظيمات مربوط به آن را تعيين مي‌كنند. اين‌ها در واقع همان برنامه ميزبان هستند كه در سمت سرور در حالت Listening قرار دارد و در سمت كلاينت به صورت كلاينت مي‌باشند. اما كلاس Proxy كه فقط در سمت كلاينت وجود دارد كلاسي است كه دقيقاً مانند كلاس‌هاي داخل remote object مي‌باشد. كلاينت قادر به فراخواني توابع remote object به صورت مستقيم و بي‌واسطه نيست چرا كه remote object روي سيستم ديگري در شبكه قرار دارد و لذا كلاسي تحت عنوان كلي Proxy با همان توابع Public كه remote object فراهم مي‌كند در سمت كلاينت ايجاد مي‌شود كه از ديد كلاينت همانند ساير كلاس‌هاي عادي مي‌باشد؛ ولي وقتي كلاينت تابعي از اين كلاس‌ را فراخواني مي‌كند اين تابع يك پيام جهت فراخواني تابع مشابه خود درremote object ايجاد كرده و ارسال مي‌كند و پس از دريافت پاسخ، نتيجه را در اختيار كلاينت قرار مي‌دهد.
توجه داشته باشيد كه تمام اين كلاس‌ها به طور كامل در اختيار شما مي‌باشند و شما مي‌توانيد هر تغيير منطقي موردنياز را در هر كدام از اين كلاس‌ها اعمال كنيد و اين همان انعطاف‌پذيري كاملي مي‌باشد كه NET Remoting . در اختيار شما قرار مي‌دهد. البته توليد تمام اين كلاس‌ها احتمالاً براي برخي زياد هم خوشايند نخواهد بود. چرا كه قطعاً زمان زيادي صرف توليد و اشكال‌زدايي آن‌ها مي‌شود. جهت رفع اين مشكل مي‌توانيد از NET. كمك بگيريد چرا كه اگر نيازي به قابليت‌هاي خاص در اين سا ختار نداريد. دات‌نت تمام اين كلاس‌ها را با رفتار عادي آن‌ها براي شما توليد مي‌كند؛ مگر دو كلاس كه مي‌بايستي شما آن‌ها را توليد كنيد. همان‌طور كه حدس زديد يكي كلاس remote object مي‌باشد كه رفتار اصلي سيستم شما و قابليت‌هايي كه مي‌خواهيد ارايه دهيد در اين كلاس قرار دارد و ديگري برنامه يا كلاس ميزبان مي‌باشد كه قسمت channel را فراهم مي‌كند.
در بيشتر موارد هدف استفاده از NET Remoting . بي‌نياز شدن از IIS يا ASP.NET Runtime مي‌باشد. در ادامه مثال كاملي كه در آن به جاي IIS از يك برنامه console استفاده مي‌شود را بررسي مي‌كنيم. به‌عبارت ديگر برنامه ميزبان يك console Application مي‌باشد. در مثال ارايه شده برنامه كلاينت و سرور به صورت console مي‌باشند تا ضمن حفظ سادگي، رفتار دقيق كلاينت و سرور قابل مشاهده باشد. بديهي است در صورت تمايل مي‌توانيد با انجام چند تغيير جزيي آن‌ها را به برنامه‌هاي windows form تبديل كنيد. در ادامه راهنمايي‌هايي هم جهت اين تبديل آورده شده است. (كدهاي آماده مثال را مي‌توانيد از سايت ماهنامه شبكه دانلود كنيد).

يك مثال
به مثال زير توجه كنيد. همان‌طور كه اشاره شد Remote Object كلاس يا كلاس‌هايي است كه منطق اصلي موردنظر سيستم در آن قرار دارد. در اين‌جا يك كتابخانه ساده (dll) يا يك تابع عمومي را به عنوان remote object پياده‌سازي مي‌كنيم.
همان‌طور كه ملاحظه مي‌كنيد از توابع console استفاده شده تا پيام‌هاي مناسبي هنگام فراخواني سازنده كلاس و يا تابع Hello در خروجي command Prompt چاپ شود. براي توليد اين remote object مي‌توانيد يك پروژه از نوع classlibrary درNET. ايجاد كرده و كد مربوط را در كلاسي كه به صورت پيش‌فرضNET . در پروژه ايجاد مي‌كند بنويسيد و يا مي‌توانيد كد را در يك فايل متني ساده تايپ كنيد و با پسوند.cs ذخيره كنيد و با استفاده از دستور زير آن را كامپايل كنيد: .Csc/t:library/out:My Remote object
dll My Remote object.cs
توجه داشته باشيد كه remote object از اين كلاس ارث‌بري كند (كلاس Marshal By Refobject قابليت‌هاي خاصي به كلاسي كه از او ارث‌بري كند مي‌دهد تا آن كلاس جهت ارايه سرويس‌هاي ماندگار در حافظه (lifetime) بهينه شود).

using System;

using System.Runtime.Remoting;

namespace Client

{

    class Client

    {

        static void Main(string[] args)

        {

           RemotingConfiguration.Configure("Client.exe.config");

           MyRemoteObject.MyRemoteObject obj=new
                             MyRemoteObject.MyRemoteObject();

           Console.WriteLine(obj.Hello());

           Console.ReadLine();

        }

    }

}

Remote Server
قسمت بعدي پياده‌سازي remote server و به عبارت ديگر، برنامه ميزبان مي‌باشد، برنامه ميزبان و remote object را مي‌توانيد در يك فايل يا اسمبلي پياده‌سازي كنيد، ولي استفاده از دو فايل متفاوت قابليت استفاده مجدد
(reuse ability) سيستم را بالا مي‌برد.
وظيفه برنامه ميزبان، درست كردن يك كانال ارتباطي و گوش دادن به يك پورت سيستم مي‌باشد تا به اين وسيله درخواست‌هاي كلاينت‌ها را گرفته و به remote object بدهد. كانال ارتباطي remote server يا برنامه ميزبان را مي‌توان با استفاده از فايل پيكربندي و يا با استفاده از برنامه‌نويسي تنظيم نمود كه هر كدام معايب و مزاياي خاصي دارد. وقتي كه از فايل پيكربندي (configuration file) استفاده مي‌شود، كدنويسي لازم در برنامه ميزبان به حداقل مي‌رسد و همچنين جهت تعويض تنظيمات كانال (به عنوان مثال شماره پورت، يا پروتكل و يا ...) نيازي به دستكاري كدبرنامه و كامپايل مجدد آن نداريد، بلكه فقط كافي‌است تنظيمات موردنظر را در فايل پيكربندي انجام دهيد. فايل پيكربندي فايلي است با فرمت XML كه اطلاعات كانال را در آن قرار مي‌دهند. برنامه ميزبان هنگام اجرا، اطلاعات فايل پيكربندي را خوانده و با توجه به تنظيماتي كه در آن ثبت شده، كانال ارتباطي را ايجاد مي‌كند، البته در صورتي كه از فايل پيكربندي استفاده نكنيد نيز مزيت خاصي خواهيد داشت و آن تغيير دادن تنظيمات كانال در زمان اجرا توسط برنامه مي‌باشد. در اين‌جا جهت توليد برنامه ميزبان از فايل پيكربندي استفاده خواهيم كرد.
اسم فايل پيكربندي را همنام با فايل اجرايي برنامه ميزبان بگذاريد با پسوند config. در اين صورت نام فايل Simpleserver.config خواهد شد. كدهاي داخل اين فايل به صورت زير مي‌باشند.

<configuration>

     <system.runtime.remoting>

         <application name="Client">

              <client url="tcp://localhost:9000/Server">

                  <wellknown

                  type="MyRemoteObject.MyRemoteObject, MyRemoteObject"

                  url="tcp://localhost:9000/MyRemoteObject"/>

              </client>

              <channels>

                  <channel ref="tcp client" />

              </channels>

          </application>

      </system.runtime.remoting>

</configuration>

همان‌طور كه ملاحظه مي‌كنيد اطلاعات كانال و remote object در داخل عنصرsystem.runtime.remoting قرار دارد. عنصر application در فيلد name ، نام سرور را مشخص مي‌كند و در داخل عنصر service مشخصات remote object قرار دارد دو فيلد wellknown و mode مربوط به دسته‌بندي remote objectها مي‌باشد كه در ادامه دسته‌بندي و انواع مختلف remote objectها را توضيح خواهم داد. فعلاً اين دو فيلد را همين‌گونه بپذيريد. در فيلد type مشخص مي‌شود كه اين سرويس مربوط به كدام remote object مي‌باشد. در اين فيلد به زيرساخت NET Remoting. گفته مي‌شود كه در كدام اسمبلي و در چه كلاس و namespaceاي در آن اسمبلي remote object قرار دارد. اگر به فايل توجه كنيد، مقدار رشته‌اي فيلد type با كاما (,) دو قسمت شده است قسمت اول namespace و كلاس مربوط به remote object را مشخص مي‌كند و قسمت دوم نام اسمبلي مربوط به remote object را.
(درNET. كدهاي نوشته شده در بسته‌هاي خاصي به نام assembly بسته‌بندي مي‌شوند. هر اسمبلي دستوراتي به زبان IL و يك سري metadata دارد كه NET runtime. با استفاده از اين اطلاعات آن را اجرا مي‌كند. توجه داشته باشيد كه يك اسمبلي مي‌تواند در چند فايل باشد و يا برعكس چند اسمبلي در يك فايل. در اينجا اسمبلي remote object ما در در داخل يك فايل همنام با اسمبلي آن قرار دارد.) در فيلد Object Url آدرسي را مشخص مي‌كنيم كه قرار است كلاينت‌ها جهت دسترسي به remote object اين آدرس را بدهند. بعداً در فايل پيكربندي برنامه كلاينت خواهيد ديد كه فيلدي با نام Url وجود دارد كه آدرس remote object را در آن خواهيم نوشت. در اين آدرس پس از مشخص كردن پروتكل و IP آدرس كامپيوتري كه برنامه ميزبان در آن قرار دارد، مقداري كه به فيلد Object Url داده‌ايم را در آن قرار خواهيم داد. فيلد Object Url مي‌تواند يك URL كامل باشد بدين صورت كه remote object در روي سيستم ديگري در وب قرار دارد و يا حتي remote object خود يك وب سرويس مي‌باشد. در اينجا به اين فيلد فقط نام اسمبلي remote object را مي‌دهيم و كلاينت هم در فايل پيكربندي خود در فيلد Url از همين نام استفاده خواهد كرد.
اگر دقت كرده باشيد، متوجه شده‌ايد كه مشخصات remote object در داخل عنصر قرار گرفته است. در واقع جالب است بدانيد كه در داخل عنصر<>service به هر تعداد remote object و يا به عبارت ديگر سرويس كه بخواهيم مي‌توانيم معرفي كنيم؛ به شرط اين‌كه به هر كدام از آن‌ها كانال خاصي اختصاص دهيم و به‌طور كلي از عهده مديريت چنين سيستمي برآييم. در چنين حالتي يك برنامه ميزبان درخواست‌هاي استفاده از چندين remote object را گرفته و handel مي‌كند.
عنصر channels تنظيمات مربوط به كانال يا كانال‌هاي ارتباطي را در خود دارد. در اينجا فقط از يك كانال استفاده خواهيم كرد و به جاي ايجاد كانال جديد، از كانال‌هاي تعريف‌شده در Machine.config استفاده مي‌كنيم. جهت اين‌كار از فيلد channel ref و سپس ازid كانال تعريف شده در machine.config استفاده مي‌كنيم. فيلد port هم شماره پورتي كه برنامه ميزبان به آن گوش خواهد داد را مشخص مي‌كند. فايل machine.config فايل XMLاي است كه تنظيمات ويژه‌اي در سطح سيستم در آن قرار دارد، از جمله كانال‌هايي كه به صورت پيش‌فرض در آن تعريف شده‌اند اين فايل در مسير Microsoft.NET Frameuork CONFIG درSystem Root قرار دارد.
با ديدن قسمتي كه در آن كانال tcp client تعريف شده است، متوجه مي‌شويد كه تعريف كانال جديد در فايل پيكربندي برنامه ميزبان كار چندان دشواري نيست. ضمناً علاوه براين كانال پنج كانال ديگر نيز در اين فايل تعريف شده‌اند كه از كانال tcp client در پياده‌سازي برنامه كلاينت استفاده خواهيم كرد. با وجود فايل پيكربندي، تمام كاري كه برنامه ميزبان بايد انجام دهد، خواندن محتويات فايل پيكربندي و ايجاد كانال و قرار دادن آن در حالت listining جهت دريافت درخواست‌هاي كلاينت‌ها مي‌باشد. براي انجام تمام اين كارها كافي‌است يك تابع static كه در كلاس Remoting Configuration قرار دارد را فراخواني كنيم و نام فايل پيكربندي را به عنوان آرگومان به آن بدهيم.
برنامه ميزبان را به هر صورتي كه بخواهيد مي‌توانيد پياده‌سازي كنيد. در اينجا برنامه Console پياده‌سازي مي‌كنيم. در صورت تمايل مي‌توانيد يك برنامه windows Form ساده بنويسيد كه همين كار را انجام دهد. نكته‌اي كه در هر حال بايد به خاطر داشته باشيد اين است كه تا وقتي برنامه ميزبان در حال اجراست و به كانال گوش مي‌دهد، كلاينت‌ها مي‌توانند از remote object استفاده كنند و به محض اين‌كه برنامه ميزبان از حالت اجرا خارج شود، امكان دسترسي به remote object توسط كلاينت‌ها وجود نخواهد داشت. اين موضوع موجب مي‌شود كه انتخاب برنامه ميزبان از نوع برنامه‌هاي سرويس (windows service) كه هميشه در حال اجرا هستند، مناسب باشد. با اين وجود در اين‌جا براي سادگي از يك برنامه console استفاده خواهيم كرد كه تا زماني كه كاربر كليد Enter را نزند، برنامه در حالت اجرا باقي خواهد ماند و خواست ما تأمين مي‌شود. كد برنامه ميزبان به دو صورت زير مي‌باشد:

//MyRemoteObject.cs

using System;

namespace MyRemoteObject

{

    public class MyRemoteObject : System.MarshalByRefObject

    {

        public MyRemoteObject()

        {

            Console.WriteLine("Constructor called");

        }

        public string Hello()

        {

            Console.WriteLine("Hello called");

            return "Hello, .NET Client!";

        }

    }

}

همان‌طور كه ملاحظه مي‌كنيد، اين برنامه فقط شامل يك فراخواني ساده تابع configure مي‌باشد كه نام فايل پيكربندي به عنوان آرگومان به آن داده شده است. تابع ()Readline تا زماني كه كاربر كليد Enter را نزده است، منتظر مي‌ماند. از اين رو برنامه هم در حال اجرا باقي خواهد ماند. پس از كامپايل و درست كردن فايل exe برنامه ميزبان توجه داشته باشيد كه لازم است فايل پيكربندي و dll. مربوط به remote object را كه قبلاً ساخته بوديد، به مسيري كه برنامه ميزبان در آن قرار دارد كپي كنيد.

Client Program
برنامه كلاينت قرار است از remote object توليد شده در قسمت قبل استفاده كند. اين برنامه هم مانند سرور از يك فايل پيكربندي و يك فايل exe. تشكيل شده است. نام فايل پيكربندي برنامه كلاينت را هم به صورت قبل با اضافه كردن config. به نام فايل exe آن بسازيد. اين فايل url مربوط به remote object پروتكل و شماره پورت و نام سيستمي را كه remote object روي آن قرار دارد مشخص مي‌كند. اين فايل به صورت زير مي‌باشد:

//SimpleServer.cs

using System;

using System.Runtime.Remoting;

namespace Server

{

    class SimpleServer

    {

            static void Main(string[] args)

          {

        RemotingConfiguration.Configure("SimpleServer.exe.config");

        Console.WriteLine("Press return to exit");

        Console.ReadLine();

          }

    }

}

اطلاعات موجود در اين فايل مشخص هستند. فقط در مورد channel توجه كنيد كه اين‌بار از tcp client تعريف شده در machine config استفاده شده است. همانند برنامه سرور در كلاينت هم با استفاده از تابع configure فايل پيكربندي خوانده شده و تنظيمات لازم انجام مي‌گيرد و در خط بعد يك object از كلاس remote object تعريف شده و تابع ()Hello آن فراخواني مي‌شود. براي توليد برنامه كلاينت هم مانند قبل مي‌توانيد از .NET استفاده كرده و در صورت تمايل يك برنامه windows form بنويسيد و يا در يك فايل متني ساده كد لازم را بنويسيد و از كامپايلر#C براي توليد exe. آن استفاده كنيد. توجه داشته باشيد كه برنامه كلاينت لازم استreference اي به remote object داشته باشد. براي اين‌كار اگر از NET. استفاده مي‌كنيد، با كليك راست درsolution explorer و انتخاب Add reference ، مي‌توانيد reference را اضافه كنيد و اگر از كامپايل خط فرمان #C استفاده مي‌كنيد، دستور كامپايل فايل به صورت زير خواهد بود:
Csc/target:exe/reference My RemoteObjcet.dll
Simple Client.cs
سؤال مهمي كه در اين‌جا پيش مي‌آيد اين است كه آيا چنانچه بعد از نصب سيستم (كلاينت‌ها و سرور و remote) object بخواهيم تغيير خاصي در منطق كاري remote object (و نه در رابط كاربري آن يعني توابع عمومي كه توسط كلاينت‌ها استفاده مي‌شوند) بدهيم، آيا لازم است نسخه جديد remote object را به تمام سيستم‌هايي كه برنامه كلاينت در آن نصب شده انتقال دهيم؟ بديهي است كه اين‌كار لازم نيست؛ چرا كه اگر اين‌گونه باشد، استفاده از
NET remoting. معني و مفهوم خود را از دست مي‌دهد. لازم است در هنگام توليد برنامه كلاينت referenceاي به remote object در آن ايجاد كنيد و برنامه كلاينت را بنويسيد. هنگام نصب برنامه كلاينت، remote object هم با آن روي سيستم نصب خواهد شد، ولي در ادامه چنانچه نياز به ارتقاء remote object داشته باشيد، كافي ‌است remote object جديد را روي سرور نصب كنيد. كلاينت‌ها به صورت اتوماتيك از remote object جديد استفاده خواهند كرد كد برنامه كلاينت به صورت زير مي‌باشد:

<configuration>

      <system.runtime.remoting>

          <application name="SimpleServer">

             <service>

                  <wellknown

                  mode="SingleCall"

                  type="MyRemoteObject.MyRemoteObject, MyRemoteObject"

                  objectUri="MyRemoteObject"/>

             </service>

             <channels>

                  <channel ref="tcp server" port="9000" />

             </channels>

          </application>

      </system.runtime.remoting>

</configuration>

پس از ساختن فايل exe. برنامه كلاينت سيستم آماده تست مي‌باشد. براي تست ابتدا برنامه سرور را اجرا كنيد تا كانال سمت سرور را ساخته و در حالت listening قرار دهد. سپس كلاينت را اجرا كنيد. اگر همه چيز تا اينجا درست باشد، سيستم كلاينت مقدار بازگشتي از تابع Hello مربوط به remote object را چاپ خواهد كرد. ضمناً در سمت سرور نيز فراخواني انجام شده و تابع Hello در پنجره مربوط به سرور اعلان خواهد شد.
در اين‌جا ليست كامل فايل‌هايي را كه براي اين سيستم درست كرديم مي‌توانيد ببينيد.

توضيحات | Assembly | Source file | Class
كلاس مربوط به Remote object كه تابع Hello () در آن مي‌باشد. | My Remote Object.dll | My Remote Object.cs | My Remote object
برنامه ميزبان كه كانال ارتباطي سرور را با استفاده از اطلاعات موجود در فايل پيكربندي ايجاد مي‌كند. | Simple Server.exe | Simple Server.cs | Simple Server
برنامه كلاينت كه از سرويس استفاده مي‌كند. اين برنامه اطلاعات لازم را از فايل پيكربندي client.exe.confing گرفته و به سرور وصل مي‌شود. | Simple Chient.exe | Simple Chient.cs | SimpleChient

همان‌طور كه قبلاً اشاره شد، remote objectها داراي دسته‌بندي خاصي مي‌باشند كه در اين قسمت به صورت مختصر آن‌ها را توضيح مي‌دهيم. به ‌طور كلي remote objectها به دو دسته كلي well-known و client-activated تقسيم مي‌شوند. نوع well-known خود در دو حالت مي‌تواند مورد استفاده قرار گيرد:
Singleton و.SingleCall (مثالي كه توضيح داده شد، از نوع well-known و دسته singlecall بود.) نوع well-known همان‌طور كه از نامش هم پيداست، اشيايي شناخته شده هستند كه با Url شان آدرس‌دهي مي‌شوند remote objectهاي وwellknown (Single Singleton) Call و به صورت Stateless هستند؛ يعني هربار كه كلاينت تابعي از remote object را فراخواني مي‌كند، هيچ‌گونه سابقه‌اي از اين فراخواني نگهداري نمي‌شود و در فراخواني بعدي نمي‌توانيد هيچ‌گونه استنادي به فراخواني‌هاي قبلي بكنيد. تفاوت Singleton و Single Call نيز در اين است كه در حالت Single Call شي remote object در فراخواني هر تابع ساخته مي‌شود و پس از فراخواني از بين مي‌رود تا فراخواني تابع بعدي، ولي در حالت Singleton فقط يك Object ايجاد مي‌شود و تمام فراخواني‌ها از طريق آن object صورت مي‌پذيرند. لذا مي‌توان از اين حالت جهت اطلاع‌رساني عمومي به تمام كلاينت‌ها استفاده كرد. جهت درك نوع singleton ، مي‌توانيد نوع Singleton را مانند متدها يا propertyهاي static در كلاس تصور كنيد كه بين تمام اشياي آن كلاس به اشتراك گذاشته مي‌شوند. البته اين مطلب فقط جهت درك singleton مي‌باشد و هيچ‌گونه ارتباطي بين اين دو مقوله وجود ندارد. تفاوت عمده remote objectهاي clientactivated عمده با نوع قبلي در اين است كه به صورت statefull هستند و مي‌توانيد به سابقه فراخواني‌هاي قبلي استناد كنيد. البته در استفاده از آن‌ها هميشه به خاطر داشته باشيد كه مقداردهي به يك property ، نيازمند يك ارتباط شبكه‌اي با remote object مي‌باشد. لذا جهت دستيابي به كارايي قابل قبول، سعي كنيد هميشه با حداقل فراخواني‌هاي متدها وproperty هاي remote object به هدف خود برسيد. اشيا Client activated توسط Url شناسايي نمي‌شوند، بلكه NET Runtime. هنگام درخواست كلاينت باتوجه به نوع كلاس درخواستي شي‌ موردنظر را تشخيص داده و يك instance از آن مي‌سازد.
تعيين نوع remote object و مد آن در فايل پيكربندي انجام مي‌شود و كليت كاركرد و سيستم NET Remoting. براي تمام اين انواع به همان صورت مي‌باشد كه توضيح داده شد. لذا در مورد انواع مختلف remote objcetها نگران نباشيد. بديهي است سيستم NET Remoting. بسيار فراتر از آن است كه در يك مقاله به تشريح تمام جوانب آن پرداخت. با اين وجود در اين مقاله تا حد امكان مفاهيم به صورت ساده ارايه شدند و اكنون مي‌توانيد سرويس‌هاي ساده مبتني بر NET Remoting. را پياده‌سازي كنيد.

منابع:
1-MSDN
2- Wrox Press) C Web Service)

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

شنبه، 15 مردادماه 1384

03:01 PM

August 06, 2005

استانداردهاي امنيت‌

افسانه دشتي
ماهنامه شبکه - خرداد ۱۳۸۴ شماره 54

اشاره :
امنيت از ديرباز يكي از اجزاي اصلي زيرساخت‌هاي فناوري اطلاعات به شمار مي‌رفته است. تهديدهاي امنيتي تنها منحصر به تهديدات الكترونيكي نيستند، بلكه هر شبكه بايد از نظر فيزيكي نيز ايمن گردد. خطرات الكترونيكي غالباً شامل تهديدات هكرها و نفوذگران خارجي و داخلي در شبكه‌ها مي باشند. در حالي كه امنيت فيزيكي شامل كنترل ورود و خروج پرسنل به سايت‌هاي شبكه و همچنين روال‌هاي سازماني نيز هست. براي پياده سازي امنيت در حوزه‌هاي فوق، علاوه بر ايمن‌سازي سخت‌افزاري شبكه، نياز به تدوين سياست‌هاي امنيتي در حوزه فناوري اطلاعات در يك سازمان نيز مي باشد. در اين راستا لازم است از روال‌هاي استانداردي استفاده شود كه به واسطه آن‌ها بتوان ساختار يك سازمان را براي پياده سازي فناوري اطلاعات ايمن نمود. استاندارد BS7799 كه در اين شماره قصد معرفي آن را داريم به چگونگي پياده سازي امنيت در همه ابعاد در يك سازمان مي پردازد.

تاريخچه استاندارد
منشاء استاندارد British Standard BS7799 به زمان تاسيس مركز Commercial ComputerSecurityCenter و شكل‌گيري بخش Industry (DTI) UK Department of Trade and در سال 1987برمي گردد. اين مركز به منظور تحقق دو هدف تشكيل گرديد. اول تعريف معيارهايي بين المللي براي ارزيابي ميزان امنيت تجهيزات توليدشده توسط سازندگان تجهيزات امنيتي، به منظور ارائه تاييديه هاي مربوطه بود و دوم كمك به كاربران براي اين منظور

شكل 1

مركز CCSC در سال 1989 اقدام به انتشار كدهايي براي سنجش ميزان امنيت نمود كه به “Users Code of Practice” معروف گرديد. چندي بعد، اجرايي بودن اين كدها از ديدگاه كاربر، توسط مركز محاسبات بين المللي NCC و يك كنسرسيوم از كاربران كه به طور كلي از صاحبان صنايع در انگلستان بودند مورد بررسي قرار گرفت. اولين نسخه اين استاندارد به عنوان مستندات راهبري PD 0003 در انگلستان منتشر گرديد. در سال 1995 اين استاندارد با عنوان BS7799 منشر گرديد و قسمت دوم آن نيز در فوريه سال 1998 به آن اضافه گرديد. اين قسمت مفهوم سيستم مديريت امنيت اطلاعات (Information Security Management System (ISMS را به‌وجود آورد. اين سيستم ISMS به مديران اين امكان را مي دهد تا بتوانند امنيت سيستم هاي خود را با حداقل نمودن ريسك‌هاي تجاري كنترل نمايند. نسخه بازنگري شده اين استاندارد در سال 1995 به عنوان استاندارد ISO ثبت گرديد. در مجمعي كه راي موافق به ثبت اين استاندارد به عنوان استاندارد ISO داده بودند، كشورهايي نظير استراليا و نيوزلند با اندكي تغيير، آن را در كشور خود با عنوان AS/NZS4444 منتشر نمودند. طي سال‌هاي 1999 تا 2002 بازنگري‌هاي زيادي روي اين استاندارد صورت پذيرفت. در سال 2000 با افزودن الحاقيه‌هايي به استاندارد BS7799 كه به عنوان يك استاندارد ISO ثبت شده بود، اين استاندارد تحت‌عنوان استاندارد ISO/IEC17799 به ثبت رسيد.
نسخه جديد و قسمت دوم اين استاندارد در سال 2002 به منظور ايجاد هماهنگي بين اين استاندارد مديريتي و ساير استانداردهاي مديريتي نظير 9001 ISO و 14001 ISO تدوين گرديد. اين قسمت براي ارزيابي ميزان موثربودن سيستم ISMS در يك سازمان مدل (Plan-Do-Check-Act (PDCA را همان‌گونه كه در شكل يك نشان داده شده است ارائه مي نمايد.

نحوه عملكرد استاندارد BS 7799
در راستاي تحقق دومين هدف پيدايش اين استاندارد كه به آن اشاره شد، يعني كمك به كاربران سرفصل‌هايي براي نحوه پياده سازي امنيت در يك سازمان كه در حقيقت يك كاربر سيستم هاي امنيتي مي باشد، تعيين شده است كه عبارتند از:
‌● تعيين مراحل ايمن سازي و نحوه شكل گيري چرخه امنيت‌
● جزييات مراحل ايمن سازي و تكنيك‌هاي فني مورد استفاده در هر مرحله‌
● ليست و محتواي طرح ها و برنامه هاي امنيت اطلاعات مورد نياز سازمان‌
● ضرورت و جزييات ايجاد تشكيلات سياستگذاري، اجرايي و فني تامين امنيت‌

● كنترل‌هاي امنيتي مورد نياز براي هر يك از سيستم هاي اطلاعاتي و ارتباطي‌

● تعريف سياست‌هاي امنيت اطلاعات‌
● تعريف قلمرو سيستم مديريت امنيت اطلاعات و مرزبندي آن متناسب با نوع نيازهاي سازمان
● انجام و پذيرش برآورد مخاطرات، متناسب با نيازهاي سازمان‌
● پيش بيني زمينه ها و نوع مخاطرات بر اساس سياست‌هاي امنيتي تدوين شده‌
● انتخاب هدف‌هاي كنترل و كنترل‌هاي مناسب كه قابل توجيه باشند، از ليست كنترل‌هاي همه جانبه
● تدوين دستور‌العمل هاي عملياتي‌

مديريت امنيت شبكه‌
به منظور تعيين اهداف امنيت، ابتدا بايد سرمايه‌هاي مرتبط با اطلاعات و ارتباطات سازمان، شناسايي شده و سپس اهداف تامين امنيت براي هريك از سرمايه‌ها، مشخص شود.‌سرمايه‌هاي مرتبط با شبكه سازمان عبارتند از: سخت افزار، نرم‌افزار، اطلاعات، ارتباطات، كاربران.

اهداف امنيتي سازمان‌ها بايد به صورت كوتاه‌مدت و ميان‌مدت تعيين گردد تا امكان تغيير آن‌ها متناسب با تغييرات تكنولوژي‌ها و استانداردهاي امنيتي وجود داشته باشد. عمده اهداف كوتاه مدت در خصوص پياده‌سازي امنيت در يك سازمان عبارتند از:
- جلوگيري از حملات و دسترسي‌هاي غيرمجاز عليه سرمايه هاي شبكه‌
- مهار خسارت‌هاي ناشي از ناامني موجود در شبكه‌
- كاهش رخنه پذيري‌

اهداف ميان‌مدت نيز عمدتاً عبارتند از:
- تامين صحت عملكرد، قابليت دسترسي براي نرم‌افزارها و سخت‌افزارها و محافظت فيزيكي صرفاً براي
سخت افزارها
- تامين محرمانگي، صحت و قابليت دسترسي براي ارتباطات و اطلاعات متناسب با طبقه بندي آن‌ها از
حيث محرمانگي و حساسيت‌
- تامين قابليت تشخيص هويت، حدود اختيارات و پاسخگويي، حريم خصوصي و آگاهي‌رساني امنيتي براي
كاربران شبكه، متناسب با طبقه‌بندي اطلاعات قابل دسترس و نوع كاربران‌

تهديدهاي امنيتي
تهديدهاي بالقوه براي امنيت شبكه‌هاي كامپيوتري به صورت عمده عبارتند از:
● فاش شدن غيرمجاز اطلاعات در نتيجه استراق‌سمع داده‌ها يا پيام‌هاي در حال مبادله روي شبكه‌
● قطع ارتباط و اختلال در شبكه به واسطه يك اقدام خرابكارانه‌
● تغيير و دستكاري غير مجاز اطلاعات يا يك پيغام ارسال‌شده براي جلوگيري از اين صدمات بايد سرويس‌هاي امنيتي زير در شبكه‌هاي كامپيوتري ارائه شود و زماني كه يكي از سرويس‌هاي امنيتي نقص شود بايستي تمامي تدابير امنيتي لازم براي كشف و جلوگيري رخنه در نظر گرفته شود:
● محرمانه ماندن اطلاعات‌
● احراز هويت فرستنده پيغام‌
● سلامت داده‌ها در طي انتقال يا نگهداري‌
● كنترل دسترسي و امكان منع افرادي كه براي دسترسي به شبكه قابل اعتماد نمي باشد.
● در دسترس بودن تمام امكانات شبكه براي افراد مجاز و عدم امكان اختلال در دسترسي‌

مراحل پياده سازي امنيت‌
براي پياده‌سازي يك سيستم امنيتي مناسب مراحل زير بايستي انجام گردد:

1- برآورد نيازهاي امنيتي شبكه
بر اساس نوع شبكه طراحي شده، نوع استفاده از آن و كاربردهاي مختلف آن نيازهاي امنيتي شبكه بايستي بررسي گردد. اين نيازها بر اساس انواع سرويس‌هايي كه شبكه ارائه مي‌دهد گسترش مي يابد.

2- اتخاد سياست‌هاي امنيتي لازم‌
در اين مرحله سياست‌ها و تدابير امنيتي لازم اتخاذ مي شود. اين تدابير براي پاسخ به نيازهايي خواهد بود كه در مرحله قبل براي شبكه برآورد شده است.

3- ارائه طرح امنيتي شبكه‌
بر اساس نيازها و سياست‌هاي برآورده كننده آن‌ها، طرحي از سياست كلي شبكه ارائه مي شود، به‌طوري كه تمامي نيازهاي شبكه برآورده شود و در طرح جامع و مانعي كه تهيه شده است هيچ تداخلي وجود نداشته باشد.

4- پياده سازي و تست‌
در اين مرحله تجهيزات و سيستم هاي لازم براي طرح انتخاب مي‌شود. تنظيمات كليه سيستم‌ها پس از تجزيه و تحليل كافي استخراج مي‌شوند. براي تست طرح پياده سازي شده، دسترسي‌ها و امكانات رخنه تست‌شده و در صورت خطا راهكارهاي پيشگيري به‌كار گرفته مي شود.

5- مديريت امنيت‌
اين مرحله كه پس از اتمام پياده‌سازي انجام مي‌شود شامل تمامي مسائل مديريتي امنيت شبكه مي‌باشد. در اين مرحله روش‌هاي مقابله با تهاجم‌ با روش جديد بايد به‌كار گرفته ‌شود و تغييراتي را كه در اثر گذشت زمان در امنيت شبكه روي مي‌دهند تحت كنترل گرفته شوند.

اجراي سيستم امنيتي‌
به منظور اجراي يك سيستم امنيتي شبكه و ارائه قابليت‌هاي بروز امنيتي درشبكه، روال هاي زير بايستي توسط سازمان به صورت مداوم در شبكه اعمال شود:

●تعيين سياست‌هاي امنيتي شبكه‌
در اين قسمت تمامي فرامين و دستورات امنيتي لازم براي فايروال‌ها و سيستم هاي تشخيص تهاجم توسط ابزارهاي خاص استخراج مي گردد.

●اعمال سياست‌هاي امنيتي شبكه‌
دستورات امنيتي تهيه‌شده براي استفاده در تجهيزات و سرويس‌هاي ارائه شده براي امنيت در شبكه پياده سازي مي‌شوند.

●بررسي بلادرنگ وضعيت امنيت شبكه‌
پس از پياده‌سازي سياست‌هاي امنيتي، با استفاده از سيستم هاي بلادرنگ تهاجم (IDS) و يا سيستم‌هاي آناليز فايل‌هاي Log و تشخيص Offline تهاجم، كليه دسترسي‌هاي غيرمجاز انجام شده به شبكه و عبور از سيستم امنيتي تشخيص داده‌شده و در فايل‌هاي Log خروجي ذخيره مي‌شوند.

●بازرسي و تست امنيت شبكه‌
 در اين قسمت با استفاده از ابزارهاي امنيتي، كليه پورت‌ها و سرويس‌هاي شبكه و يا محل‌هاي رخنه به شبكه بازرسي شده و اطلاعات مربوطه در فايل Log مربوطه قرار مي‌گيرند. همچنين در اين قسمت با استفاده از يك سري از ابزارها، به تحليل اطلاعات پرداخته مي‌شود و نتايج حاصل از آن‌ها براي مرحله بعدي نگهداري مي شود.

●بهبود روش‌هاي امنيت شبكه‌
به منظور بهبود عملكرد سيستم امنيتي شبكه، از نتايج حاصل از دو قسمت قبل استفاده مي‌شود و تغييراتي كه از اين بررسي‌ها نتيجه مي‌شود، در سياست‌هاي امنيتي شبكه اعمال مي گردد.

تشكيلات اجرائي امنيت‌
براي پياده سازي يك سيستم امنيتي پويا، وجود تشكيلات امنيتي متناسب با نيازهاي امنيتي سازمان لازم و ضروري مي باشد. گروه‌هاي كاري لازم براي اينكه امور امنيتي يك شبكه به نحو احسن اداره شود عبارتند از:

● سياست امنيت‌
وظايف اين قسمت تدوين سياست امنيتي و بازنگري و اصلاح سياست امنيتي در صورت پيشنهاد گروه مديريت امنيتي مي‌باشد. قسمت سياست امنيتي هماهنگي تشكيل جلسات گروه سياستگذاري امنيتي را از قسمت مديريت امنيتي دريافت كرده و طبق آن عمل مي كند و نتايج حاصله را به مديريت امنيتي تحويل مي دهد.

● مركز هماهنگي واطلاع رساني‌
مركز هماهنگي تمامي گزارش‌ها را از بخش‌هاي مختلف جمع آوري كرده و در واقع نقش رابط بين قسمت‌ها را بازي مي‌كند. اين مركز بيشتر مانند واسط اصلي بين قسمت‌ها و بخش مديريتي عمل مي كند و تغييرات و پيشنهادات گروه مديريتي را به گروه‌هاي كاري منعكس مي‌كنند. وظايف اين قسمت دريافت اطلاعات و گزارش از گروه‌هاي پائين‌تر، پردازش و دسته‌بندي آن‌ها، ثبت اطلاعات، ارسال نتايج به گروه مديريت امنيتي، دريافت تغييرات (تغيير سياست امنيتي) از گروه مديريت امنيتي، ثبت اطلاعات و ارسال آن براي گروه‌هاي پائين‌تر، تشكيل بانك‌اطلاعاتي حاوي آسيب‌پذيري‌ها و پيكربندي امن تجهيزات و سرويس‌هاي شبكه، نگهداري آمار و گزارش حملات انجام شده و واكنش گروه‌هاي مرتبط و ارائه مشاوره در زمينه خريد تجهيزات، آناليز ريسك و ... مي باشد.

● تشخيص و مقابله باحوادث‌
 وظيفه اين قسمت شناسايي و مقابله با حملات و دسترسي‌هاي غيرمجاز مي‌باشد و داراي بخش آماده‌سازي به منظور تعيين روند و سياست سازماني جهت شناسايي، تعيين منابع اطلاعاتي جهت شناسايي تهاجم، تهيه بانك‌اطلاعاتي حاوي الگوهاي حملات شناخته شده ، مديريت مكانيزم هاي ثبت اطلاعات، پشتيباني سيستم و دريافت گزارشات و توصيه‌هاي گروه هماهنگي و اطلاع رساني، بخش كشف تهاجم به منظور نظارت بر فعاليت‌هاي شبكه، نظارت بر فعاليت‌هاي سيستم، بازرسي فايل‌ها و دايركتوري‌ها، جستجوي اتصالات غيرقانوني به شبكه، بازرسي منابع فيزيكي و دريافت و پردازش گزارشات كاربران، بخش پاسخگويي به تهاجم به منظور آناليز گزارش، انتقال اطلاعات حادثه و روند آن به بخش‌هاي لازم، به‌كارگيري سريعترين راهكارها جهت قطع حمله، جلوگيري از وقوع دوباره حمله، بازيابي سيستم به حالت عادي و تعيين خسارت و در انتها بخش تحقيقات به منظور شناخت انواع حملات، دريافت گزارش مقابله ناموفق و تشخيص و مقابله با ويروس‌ها مي‌باشد.

● تشخيص و مقابله با حوادث خاص‌
اين قسمت با اجزاي آماده‌سازي، كشف و پاسخگويي وظايف مقابله با خطرات ناشي از حوادث و پيشگيري از برخي حوادث محتمل را به عهده دارد. اين قسمت گزارش‌هاي مربوط به مقابله با تهاجم يا ويروس يا حادثه خاص را به قسمت مركز هماهنگي براي ارسال به قسمت مديريتي منتقل مي‌كند و سياست ها و موارد اضافه‌شده در برابر حوادث را به عنوان نتيجه دريافت مي‌نمايد.

● بازرسي امنيتي‌
بخش بازرسي امنيتي وظايف بازرسي تجهيزات امنيتي، بازبيني logها و پيغام‌ها و سيستم‌هاي پشتيبان و بازرسي شبكه براي ايجاد امنيت در شبكه را بر‌عهده دارد. در اين نوع بازرسي‌ها بايد اجزا و شبكه به صورت خودكار مورد بررسي قرار گيرند.

● نصب و پيكربندي‌
اين قسمت وظايف پيكربندي امن تجهيزات و سرويس‌هاي شبكه و نصب و پيكربندي سيستم امنيتي شبكه را به
عهده دارد.

●نگهداري و پشتيباني‌
 اين قسمت وظايف محافظت و پشتيباني از كليه تجهيزات و اطلاعات امنيتي، نگهداري و ثبت تجهيزات، گزارش هشدارهاي خودكار، عيب‌يابي شبكه و ارائه سرويس لازم و آمارگيري شبكه را به‌عهده دارد.

آينده استاندارد BS7799

شكل 2

استاندارد 17799 ISO/IEC كه در سال 2000 به عنوان يك استاندارد معتبر توسط ISO پذيرفته شد، در حال بازنگري است و تخمين زده شده كه تا اواسط سال 2005 اين بازنگري تكميل خواهد شد. اصلي‌ترين تغييري كه انتظار مي‌رود در آن انجام گيرد، تغيير در ساختار كنترل‌ها مي‌باشد. اين تغييرات به منظور توصيف بهتر سيستم‌هاي كنترلي، نحوه عملكرد آن‌ها و روابط بين سيستم‌هاي امنيت اطلاعات، صورت مي‌پذيرد. نمودار زير ميزان استفاده از اين استاندارد را تا سال 2004 در جهان نشان مي‌دهد. (شكل2)

آيا قسمت سومي براي استاندارد 7799 BS تدوين خواهد شد؟
اگر قرار است قسمت سومي براي اين استاندارد تدوين گردد، اين قسمت شامل چه مواردي مي باشد؟ نكته قابل اشاره در اين زمينه مقايسه اين استاندارد با استاندارد ISO9000 مي‌باشد. قسمت سوم استاندارد BS7799 در حقيقت توسعه سيستم ISMS مي‌باشد. درست مانند تغييرات ايجاد شده در استاندارد ISO9004 در مقايسه با نسخه هاي قبلي آن.

نتيجه‌گيري‌
اين نوشته قصد داشت كه BS7799 را به عنوان استانداردهاي جهاني براي ايمن‌سازي شبكه‌ها معرفي كند و توجه خواننده را به اين موضوع جلب نمايد كه برقراري امنيت در سازمان، بايستي در همه ابعاد آن صورت گيرد. توجه به چنين استانداردي و شناخت آن، باعث مي‌شود كه بحث موضوعات پيشرفته‌تري نظير برپايي مراكز امنيت شبكه
(Security Operating Center:SOC) ملموس‌تر و دست يافتني‌تر به نظر برسند.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 19 مردادماه 1384

03:35 PM

August 10, 2005

به دنياي Live Linux خوش آمديد

اشاره :
Live Linux به‌گونه‌اي از توزيع‌هاي لينوكس اطلاق مي‌شود كه از روي سي‌دي قابل اجرا هستند و شما احتياجي به نصب آن‌ها برروي سيستم خود نداريد. شما مي‌توانيد با يك Live CD لينوكس از تمامي امكانات و ويژگي‌ها و برنامه‌هاي كاربردي منبع‌باز و سيستم‌عامل لينوكس استفاده كنيد بدون اين‌كه تنظيمات سيستم را عوض كنيد و يا سيستم‌عامل‌هاي موجود برروي سيستم دچار اخلال شوند. اين سي‌دي‌هاي Bootable به‌صورت خودكار پس از قرارگرفتن در درايو CD و بوت شدن سيستم اجرا شده، اقدام به شناسايي سخت‌افزار نموده و با استفاده از حافظه RAM برروي سيستم اجرا مي‌شوند، به‌طوري كه يك سيستم‌عامل كامل داريد و مي‌توانيد با برنامه‌هاي كاربردي خود در تعامل باشيد. به علت ماهيت ذاتي CDهاي زنده (حجم كم، اجراي موقت در حافظه، سبك و كاربردي بودن) سعي مي‌شود كه هر توزيع سي‌دي Live برمحوريك ويژگي و قابليت يا توانايي كاربردي شكل گيرد. همچنين عموماً همه توزيع‌هاي مشهور از يك يا چند سي‌دي Live بهره مي‌برند و هر سي‌دي Live مبتني بر يك توزيع است و از برنامه‌ها و فايل‌هاي آن توزيع استفاده مي‌كند. يك قابليت مهم CDهاي زنده امكان بومي كردن آنان است. بدين معني كه همه مي‌تواند با استفاده از يك هسته مشترك و برمبناي يك توزيع خاص اقدام به توليد و انتشار يك توزيع سي‌دي Live امكانات موردنظر خود بنمايند اكنون كمتر كشوري وجود دارد كه از چند توزيع سي‌دي Live مخصوص خود استفاده نكند. هم‌اكنون در كشورمان نيز دو توزيع <شبديكس> و <پارسيكس> وجود دارند، كه در مقاله به آن‌ها اشاره خواهيم داشت. سرزمينCD‌هاي زنده سرزميني كشف نشده براي كاربران عمومي، حرفه‌اي‌ها و كارشناسان و متخصصان رشته‌هاي كامپيوتري است. من در اين مقاله سعي كرده‌ام از هر مجموعه و خانواده CD‌هاي زنده معروف‌ترين و پركاربردترين آن‌ها را انتخاب و معرفي كنم كه مجموعاً با معرفي دو سي‌دي Live ايراني تعداد آن‌ها به بيست CD زنده رسيد. اميدوارم كه اين مقاله فقط سرآغازي براي حركت شما به سوي سرزمينCDهاي زنده باشد.

1 - لينوكس بدون نصب
اولين خصيصه بارز تمامCDهاي زنده قابليت اجراي لينوكس بدون نياز به نصب است. شما بدون اين‌كه كمترين دغدغه‌اي داشته باشيد مي‌توانيد لينوكس را تجربه كنيد، برنامه‌هاي ارايه شده همراه آن را ببينيد و آن‌ها را آزمايش كنيد و از جذابيت‌هاي لينوكس لذت ببريد. اگر تاكنون تجربه‌اي با لينوكس نداشته‌ايد و تازه كار هستيد با Knoppix
(بخوانيد: ناپيكس) شروع كنيد. ‌CDهاي Live ناپيكس جزء بهترين توزيع‌هاي لينوكسي است كه مبتني بر توزيع معروف Debian GNU/Linux است و همراه محيط گرافيكي KDE و برنامه‌هاي كاربردي معروف لينوكس همچون OpenOffice ،Gaim ،Konqueror ،Mozill و برنامه‌هاي سرويس‌دهنده Apache ،PHP ،My SQL و بسياري برنامه‌هاي متنوع ديگر ارايه مي‌شود. توزيع Knoppix خود يك مبنا براي بسياري ازCDهاي زنده ديگر است كه در ادامه معرفي خواهيم كرد. قدرت پايداري و انعطاف‌پذيري ناپيكس به همراه مجموعه‌اي از كاملترين نرم‌افزارهاي منبع‌باز به‌روز شده از اين توزيع جلوه‌اي خاص ساخته است و طرفداران بي‌شماري دارد.

2-Slax، بهترين انتخاب در دسكتاپ
آيا دوست داريد به جاي داشتن يك سيستم‌عامل برروي كامپيوتر يا لپ‌تاپ خود كه فضاي بسياري از حافظه كامپيوتر شما را هم اشغال مي‌كند آن را در جيب خود هميشه همراه داشته باشيد؟ توزيع سي‌دي Live Slax چنين امكاني را به شما مي‌دهد. Slax يك سي‌دي 158Live مگابايتي مبتني بر توزيع Slaxkware است كه بهترين انتخاب براي استفاده در كارهاي روزانه بر روي كامپيوترهاي خانگي و دسكتاپ است. Slax يك توزيع كوچك، سريع، جذاب با انبوهي از برنامه‌هاي روميزي است كه به‌دنبال هر نرم‌افزار روميزي كه باشيد آن را درSlax خواهيد يافت. Slax از رابط گرافيكي KDE استفاده مي‌كند.
شما مي‌توانيد سي‌دي Live Slax را تهيه كنيد و هميشه همراه خود داشته باشيد و بر روي هر كامپيوتر در كمتر از يك دقيقه لينوكس را اجرا و كارهاي جاري خود را پيگيري كنيد. به اين طريق يك سيستم‌عامل قابل حمل خواهيد داشت!

3 - يك ديسك زنده‌اي براي بازيابي داده‌ها

همانطور كه گفتم هر سي‌دي Live بر محور يك كاربرد اساسي شكل گرفته است. System Recur يك توزيع مخصوص بازيابي داده‌ها و عمليات‌هاي ترميم و اصلاح اطلاعات است. اين توزيع مجموعه‌اي كامل از ابزارها و يوتيليتي‌ها براي بازگرداندن اطلاعات يك سيستم Crash كرده است.GNU Parted،Qt parted ،Partimag ، ابزارهاي فايل‌سيستم،Backupگيري و Sfdisk بخشي از اين مجموعه امكانات هستند كه در يك سي‌ديBootable ارايه مي‌شوند و شما مي‌توانيد به آساني و در هر شرايطي از آن استفاده كنيد و به داد داده‌ها و اطلاعات حياتي خود برسيد! اين توزيع كاملاً با خانواده كامپيوترهاي 86 X سازگار است و از تمامي فايل سيستم‌ها از جمله NTFS پشتيباني مي‌كند. حتي مي‌توانيد از اين توزيع براي رفع خرابي ويندوز هم استفاده كنيد و پارتيشن‌ها و اطلاعات خودتان را نجات دهيد.

4- Mepis، اول آزمايش بعد نصب‌

CDهاي زنده زيادي هستند كه اين امكان را به شما مي‌دهند كه ابتدا گشت‌وگذاري در توزيع موردنظر داشته باشيد، برنامه‌هاي ارايه شده همراه توزيع را ببينيد و قابليت‌ها و جلوه‌هايي كه دنبالشان هستيد را بسنجيد و اگر خواستيد آنگاه اين توزيع از لينوكس را بر روي سيستم نصب كنيد. Mepis يكي از اين توزيع‌هاست كه مي‌توانيد ابتدا آن را بر روي سيستم اجرا كنيد و در صورت تمايل به وسيله فايل نصاب، آن را برروي سيستم نصب كنيد. Mepis يك توزيع پايدار، قدرتمند و پركاربرد است كه مبتني بر توزيع دبيان و KDE مي‌باشد. از امكانات گفتني اين توزيع، امكان نصب از سيستم راه‌دور(Remote Installation) و به‌كارگيري Mepis در شبكه‌هاي DLS ،Wireless ،Dialup وLan است.

5 - بانك برنامه‌هاي روميزي‌
PC Linux OS يك توزيع مبتني برMandrake است كه مخصوص سخت‌افزار كامپيوترهاي روميزي تهيه شده است با بيش از 2 گيگابايت برنامه كاربردي موردنياز يك كاربر روميزي غني شده است. هر نامي را كه در دنياي منبع‌باز به گوشتان خورده باشد را درPC Linux OS خواهيد يافت. Xserver ،KDE ،Open Office ،Thunderbird ،FireFox ،P2P ،Gaim و بسياري برنامه كاربردي كه عموماً بروز شده و آخرين نسخه مي‌باشند، در مجموعه برنامه‌هاي كاربردي اين توزيع جاي دارند. Pc Linux OS از جديدترين سخت‌افزارهاي كامپيوترهاي روميزي نيز پشتيباني به عمل مي‌آورد و تقريباً برروي هر كامپيوتري اجرا مي‌شود.

6-Austrami ، اگر پسورد ويندوز را فراموش كرده‌ايد...
يك توزيع 50 مگابايتي مبتني‌برSlackware با فهرست متنوعي از ابزارها و امكانات مختلف. اما مهمترين ويژگي اين توزيع ارايه ابزاري براي كار با فايل ذخيره‌كننده پسورد ويندوز و سِت كردن پسورد ويندوز حتي در حالت مدير سيستم (Administrator) و خارج از محيط ويندوز است. در واقع لينوكس نه‌تنها با ويندوز قهر نيست بلكه حتي مشكلاتش را هم مي‌تواند برطرف كند. هميشه پنگوئن لينوكس نگاهي محبت‌آميز به پروانه ويندوز داشته است!

7 - لينوكس در ويندوز

بي‌شك يكي از جذاب‌ترين و لذت‌بخش‌ترين CDهاي زنده توزيع Damn Small است. فايل ISO آن فقط 50MB است. Damn Small اين قابليت را دارد كه آن را سفارشي كنيد، يعني خودتان با استفاده از تكنولوژي myDSL نرم‌افزارهاي كاربردي موردنياز را به توزيع اضافه كنيد و آن‌ها را برروي پيكره لينوكس كامپايل و پيكربندي كنيد، نرم‌افزارهايي مانند:
FireFox و Open Office. اما اين‌ها را فراموش كنيد و به اين توزيع توجه كنيد. Damn Small يك فايل فشرده دارد كه مي‌توانيد در ويندوز اين فايل را از حالت زيپ خارج كنيد و لينوكس را در محيط ويندوز اجرا كنيد. dsl-embedded.zip فايلي است كه كافيست در محيط ويندوز Extract شود. با كليك بر روي فايل اجرايي از ويندوز به لينوكس سوييچ مي‌كنيد و دوباره به راحتي مي‌توانيد به ويندوز بر‌گرديد. البته اين كار شبيه‌سازي صرف نيست زيرا شما مي‌توانيد واقعاً از برنامه‌هاي Damn Small استفاده كنيد.

8 - مالتي‌مديا در لينوكس
دوست داريد يك سي‌دي كامل شامل متنوع‌ترين ابزارهاي مالتي‌مديا داشته باشيد؟ علاوه برآن اين سي‌دي همه جا با شما باشد و برروي هر كامپيوتر قابل اجرا؟ Movix را تهيه كنيد. فرمت‌هايAVI ،MPG ،QuickTime ،WMV ، 3MP،ASF ،VORBIS/O GG ،Divx وXDiv مهمترين فرمت فايل‌هاي صوتي تصويري هستند كه Movix براي آن‌ها ابزار پخش‌كننده ارايه مي‌دهد. ابزار كار با CD و DVD و فايل‌هاي مالتي‌مديا تحت وب، ديگر ويژگي Movix است. نسخه‌هاي eMovix و Movix2 از اين توزيع هم عرضه شده‌اند. ديگر توزيع سي‌دي Live مخصوص ابزارها و نرم‌افزارهاي چندرسانه‌اي،Media Linux است. آنقدر برنامه‌هاي متنوع در اين توزيع‌ها گنجانده شده كه با ويژگي‌ها و ظواهر متفاوت، هر مشتاقي را سيراب خواهد كرد!

9- Morphix ، هديه منبع‌باز به دوستداران بازي
براي دوستداران بازي‌هاي رايانه‌اي هم سي‌ديLive داريم. يك سي‌دي كامل بازي كامپيوتري تحت لينوكس. كجا اين همه برنامه سرگرمي و تفريحي را يك‌جا بر روي يك سي‌دي سراغ داريد؟ Morphix اين ويژگي را دارد و هيچ نيازي نيست شما طرفدار منبع‌باز و لينوكس باشيد تا از اين بازي‌ها لذت ببريد. ويندوزي‌ها فرض كنند كه يك سي‌دي شامل صدها برنامه بازي جذاب و رنگارنگ داريم كه برروي يك پلتفرم خاص ارايه شده‌اند. Morphix در قالب يك پروژه براي ساختن و تغييرCDهاي زنده مبتني بر دبيان است كه يكي از اين CDهاي زنده مجموعه‌اي از بهترين بازي‌هاي كامپيوتري ارايه‌‌شده در سه محيط گرافيكي KDE Gnome و Light GUL است.

10- ويروس‌يابINSERT
اين سي‌دي Live مبتني بر توزيع ناپيكس است و شامل انواع ابزارها و برنامه‌ها براي كاربران اختصاصي CDهاي زنده مي‌باشد. ابزارهاي كار با فرمت فايل‌ها، نرم‌افزارهاي RAID و LVM ، برنامه آناليز شبكه، نرم‌افزارهاي شناسايي كارت شبكه و كار با سرور و كلاينت‌هاي شبكه و چند ابزار مفيد و جالب ديگر. اما معروفيت Insert براي ارايه ابزارهاي ويروس‌ياب در كامپيوتر و شبكه‌هاي خانگي است. Clam Antivirus ابزار جستجو در سيستم براي ويروس است كه همراه اين توزيع ارايه مي‌شود. Rootkithunter ، chkrootkit و چند ابزار كوچك ديگر در كنار هم موجب شده‌اند كه Insert يك سي‌دي Live براي استفاده‌هاي امنيتي و دفاعي باشد.

11- تجربه‌اي درFreeBSD
در ميان اين همه CDهاي Live، حيف بود اگر محصولي براي سيستم‌هاي خانواده BSD وجود نداشت. اما طرفدارانBSD ومخصوصاً FreeBSD نگران نباشند. FreeSBIE ديسك زنده‌اي از FreeBSD5.3 است كه همراه برنامه‌هاي كاربردي سيستم‌عامل‌هايBSD مانند برنامه‌هاي چت، اينترنت، مالتي‌مديا، بازي و برنامه‌هاي كاربردي ديگر ارايه شده است. به گفته سايت اينترنتي اين توزيع اگر FreeSBIE را از طريق سي‌دي Bootable اجرا كنيد، هرگز متوجه نخواهيد شد كه با سيستم‌عامل 3.5 FreeBSD كار نمي‌كنيد.

12 - ديسك زنده‌اي براي نمايش پروژه‌هاي تحت وب
شايد تصور كنيد كه CDهاي زنده به‌علت ماهيت آنان و حذف فايل‌ها و پروسه‌هاي اضافي از توزيع، توانايي چنداني در كاربردهاي سرويس‌دهندگي نداشته باشند. اما Lammppix نقض‌كننده اين تصور است و يك سي‌دي Live مخصوص كار با سرويس‌دهنده‌ها و برنامه‌هاي سرور تحت وب را معرفي مي‌كند. Lammppix غالباً در وب سرورها اجرا مي‌شود و به شما اجازه مي‌دهد كه با پروژه‌هاي تحت وب در تعامل باشيد، اسكريپت‌هاي perl را مشاهده كنيد يا نمايش‌هايPHP را پيگيري كنيد و يا برنامه‌هاي MySQL يا Apache را اجرا كنيد. اين سي‌دي Live مبتني برKnoppix وDamn Small مي‌باشد و در يك نگاه برنامه‌هايMySQL ،Apache ،Postgre ،PHP ،Perl و برنامه سرور مخصوصXAMPP را در LAMMpix خواهيد يافت. خلاصه يك ابزار مديريتي كامل براي وب سرور فقط در يك سي‌دي با انبوهي ويژگي منحصربه‌فرد جمع شده است.

13- Sentinjx ، سي‌دي Live ايجاد كلاستر

يك سي‌دي Live و يا بهتر بگوييم يك سيستم‌عامل كامل براي پيگيري، ايجاد و كاربرد كلاسترهاي لينوكس. مرور نرم‌افزارهاي موجود درSentinix خود گوياي توانايي و قابليت اين سي‌دي Live و كاربردهاي آن است:
Nagios ،Nagat ،Snort ،Snortcenter ،ACID ،Cacti ،Nessus ،Mail Scnner ،Postfix ،RRD Tool ،Spam Assassin ،MySQL ،PHP ،Perl ،Python ،Apache و ابزارهايي ديگر كه بردن نامشان از حوصله خارج است. تنوع نرم‌افزارها گوياي كاركرد اين سي‌دي Live است. نرم‌افزارهاي مبارزه اسپم، ساخت و تغيير در كلاستر سرويس‌دهنده و بازرسي پروسه‌هاي فعال تنظيم‌شده در اين توزيع موجود هستند. همچنين اين توزيع از محيط گرافيكي Gnome براي برنامه‌هاي گرافيكي خود استفاده مي‌كند.

14 - براي طرفداران Gnome
Ubuntu يك نام آفريقايي و به معناي <تفسير روح انسانيت> است. يك سي‌دي Live مبتني بر دبيان وDebian Sarge ويژگي اين توزيع استفاده از محيط گرافيكي Gnome و برنامه‌هاي كاربردي تحت اين محيط است و از KDE و برنامه‌هاي اين محيط خبري نيست. اگر به محيط Gnome عادت داريد اين توزيع محبوب شما خواهد بود. Ubuntu يك سي‌دي Live كامل است و كليه برنامه‌هايي را كه نياز داريد را در خود دارد. ابزارهاي گرافيكي، مالتي‌مديا، چندرسانه‌اي، اينترنت، برنامه‌هاي اداري و مديريتي اين توزيع به سرعت روزآمد مي‌شود و از پايداري، سريع الاجرا بودن و سبكي سود مي‌برد.

15- Berry Linux ، توزيع مبتني بر فدورا
اين هم يك توزيع براي كاربران ردهت و Fedora CoreBerry يك توزيع نورسيده در دنياي CDهاي زنده است و از توزيع FedoraCore،RedHat3 و Knoppix3.6 استفاده مي‌كند. اگر خواستيد كه اين توزيع را براي استفاده هميشگي برروي سيستم نصب كنيد به 1/75 گيگابايت فضا نياز داريد. اگر يك توزيع جمع‌وجور با بهترين و جديدترين نرم‌افزارها مي‌خواهيد Berry مي‌تواند يك انتخاب مناسب باشد. Kernel2.6.9 ، Openoffice1.1.3، KDE2.3.3، GIMP2.2.2 ، FireFox1.0، Mplayer1.0، gce3.4.1 و X.org2.3.4 از مهمترين نرم‌افزارهاي همراه Berray هستند. نسخه 0.52 اين توزيع در 19 دسامبر 2004 منتشر شده است.

16- ابزار نرم‌افزاري شبكه‌اي

Live CD Router يك سي‌دي Live براي مسيريابي و تقسيم‌بندي پهناي باند در شبكه‌هاي بي‌سيم ،LAN ،DSL ،T1،Dial up ،ISDN و اتصالات شبكه‌اي خطوط كابلي است. شما مي‌توانيد از اين توزيع به‌عنوان يك فايروال در شبكه‌هاي بي‌سيم يا يك Access point در شبكه‌هاي بي‌سيم استفاده كنيد. هيچ نيازي به نصب نداريد و فقط كافيست كه سي‌دي Live CD Router را داشته باشيد. تنظيم DHCP برروي ماشين سرويس‌دهنده يا كلاينت، يك فيلتركننده براساسNAT ، يك تسهيم‌كننده پهناي باند براي كارت‌هاي بي‌سيم، ابزار احراز هويت، پشتيباني از انواع كارت‌هاي شبكه مانند اترنت، WiFi ،PCI و USB از جمله توانايي‌هاي اين توزيع هستند. اين سي‌دي Live شايد اوج توانايي‌هاي يك توزيع باشد كه به‌صورت Live CD عرضه گرديده است. حقيقتاً يك مدير سيستم يا مدير ارشد شبكه مي‌تواند از آن به عنوان ابزار كارآمدي براي نيازهاي خود استفاده كند.

17- Sentry Firewall

يك فايروال مجموعه CDهاي زنده با يك سي‌دي Live با ويژگي و امكانات كاربري يك ديوار آتش كامل مي‌شود. چند مجموعه از CDهاي زنده اين خصوصيت را دارند اما Sentry كاملترين آن‌هاست. اين توزيع به آساني يك فايروال، سرور و يك IDS را برروي سيستم پياده‌سازي مي‌كند. پيكربندي ساده و سريع براي هر سيستم‌عامل ديگر مزيت جالب sentry است. پيش‌فرض sentry كرنل 4/2 لينوكس است اما براي كامل كردن امكانات خود از پكيج‌هاي كرنل
2/2 مانند penwall هم استفاده مي‌كند. اين توزيع براي اجراي خودكار از syslinux استفاده مي‌كند. به‌غيراز openwall از ساير بسته‌هاي امنيتي مانند Strong Swan ،Ebtales ،WLAN Linux و MPPE استفاده شده است.

18- خودتان برنامه‌ها را اضافه كنيد
يكي ديگر از CDهاي زنده جذاب Linspire است. يك سي‌دي Live مبتني بر دبيان است و تمام ويژگي‌ها و خصوصيت‌هاي يك سيستم‌عامل كامل را دارد. خصوصيت ممتاز Linspire در استفاده از تكنولوژي ClickNRun است. CNR سيستمي براي نصب نرم‌افزارها به سادگي و آساني برروي Linspire است. شما فقط با زدن يك كليك مي‌توانيد نرم‌افزاري را انتخاب، نصب و اجرا كنيد.

19- شبديكس، يك توزيع ايراني

همانند بسياري از كشورها چند سالي است كه ايران هم لينوكس را به‌عنوان سيستم‌عامل ملي معرفي و مجموعه‌هاي متعددي جهت فارسي‌سازي آن يا افزودن امكانات به آن مشغول فعاليت هستند و پروژه <لينوكس ملي ايران> را شروع كرده است. شبديكس كه اكنون نسخه 9/0 آن منتشر شده يك سي‌دي Live مبتني بر Knoppix و توزيع Debian GNU/Linux است و با رابط ‌Farsi KDE مي‌باشد. وقتي شما شبديكس را برروي سيستم اجرا مي‌كنيد شايد از كندي اجراي برنامه، فونت نامناسب و كلمات ترجمه شده غريبه و نامأنوس كمي گيج شويد ولي در عوض يك محيط گرافيكي فارسي مي‌بينيد، راهنماي فارسي برنامه‌ها را مشاهده خواهيد كرد و همه‌چيز بوي فارسي و ايراني بودن را مي‌دهد و اين لذتي خاص را به همراه دارد. در شبديكس خواهيد توانست كه برنامه‌هاي تحت KDE را اجرا و استفاده كنيد و با يك رابط فارسي گشت‌وگذاري در دنياي نرم‌افزارهاي منبع‌باز و لينوكس داشته باشيد. شبديكس توسط شركت چاپار شبديز توزيع و حمايت مي‌شود.

20- پارسيكس تازه متولد شده
به‌تازگي خبر از تولد دومين سي‌دي Live و توزيع ايراني در محافل لينوكسي به ميان آمده و نسخه 45/0 پارسيكس منتشر گرديده است. در سايت رسمي اين پروژه اين‌گونه آمده است:
پارسيكس يك سي‌دي Live مبتني بر لينوكسKnoppix ،Debian sargeT است كه در آن Gnome به عنوان ميزكار پيش‌گزينه استفاده شده و سعي بر آن بوده تا با حذف بسته‌هاي نرم‌افزاري اضافي، يك ميزكار سبك با امكانات لازم در اختيار كاربران قرار داده شود. پارسيكس از صفحه كليد فارسي پشتيباني كرده و مي‌توانيد در آن فارسي تايپ كنيد. پارسيكس همچنين حاوي واژه‌نامه آزاد و باز متني xFarDic است و قلم‌هاي رايگان و آزاد فارسي از پروژه‌هايFarsi Web و FPF استفاده مي‌كند. نسخه 45/0 و اولين نسخه Parsix GNU/Linux در تاريخ 13 بهمن‌ماه 1383 مصادف با 25 ژانويه 2005 ارايه شده است. ديدن اين سي‌دي Live ايراني و استفاده از امكانات آن بي‌شك خالي از لطف نخواهد بود
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
چهارشنبه، 19 مردادماه 1384

08:37 PM

August 10, 2005

ماشين رياضي جديدي براي رام كردن اعداد اول

اعداد اول بسيار زيبا و جذابند و در عين حال معماي حيرت انگيز و سرگردان‌كننده اي را در برابر رياضي دانان مطرح ساخته اند: تعريف اين اعداد كاملا ساده است، رفتار آنها در سلسله اعداد و نحوه ظاهر شدنشان در آن كاملا بي‌نظم و فاقد قاعده به نظر مي‌آيد و هرچه شمار بيشتري از آنها شكارمي‌شوند، كار شكار بعدي‌ها دشوارتر مي‌شود.

طي قرنهاي متمادي رياضي دانان در شرق و غرب عالم به جستجوي راههايي براي دستيابي به اعداد اول برخاسته‌اند و با اين همه بهترين روشهايي كه تا بحال در اين زمينه ابداع شده چنان كند است كه حتي پر سرعت‌ترين كامپيوتر هاي كنوني نيز نمي‌توانند كمك چنداني در شكار اين اعداد شگفت انگيز كنند.

اعداد اول بر طبق تعريف اعدادي هستند كه تنها به ‪ ۱‬و بر خودشان تقسيم پذيرند. به عنوان نمونه اعداد ‪ ۲،۳،۵،۷،۱۱،۱۳،۱۷،۱۹‬اعداد اول كمتر از ‪۲۰‬ در سلسله اعداد طبيعي هستند. اما هرچه در اين سلسله پيش تر برويم اعداد اول ناياب تر مي‌شوند.

بطوريكه اگر چندين ميليون بار به سرعت كامپيوتر هاي كنوني افزوده شود، تنها چند رقم به شماره ارقام بزرگترين عدد اولي كه تا به حال شناخته شده افزوده مي‌گردد.

رياضي دانان در آرزوي دست يافته به روشي هستند كه با استفاده از آن بتوانند با سرعت به يافتن اعداد اول توفيق يابند و يا اگر با عددي هر اندازه پر رقم و بزرگ روبرو شدند بتوانند با سرعت مشخص سازند كه آيا عدد اول است ؟ - اما يافتن چنين روشي به فسفر مغز نياز دارد و نه سرعت كامپيوتر. -
اما يك گروه از رياضي دانان هندي مدعي شده‌اند كه در آستانه دستيابي به همان آزموني هستند كه رياضي دانان قرنها مشتاقانه در آرزويش بوده اند.

مانيندرا اگراوال ‪ ,Manindra Agrawal‬و دانشجويانش نيراج كايال ‪Neeraj‬ ‪ Kayal‬و نيتين سكسنا ‪ Nitin Saxena‬در موسسه تكنولوژي كانپور مدعي شده‌اند كه در آستانه تكميل آزموني هستند كه اول بودن يا نبودن هر عدد طبيعي را با سرعت مشخص مي‌كند. اين آزمون در صورتي كه تكميل شود مي‌تواند تبعات و نتايج بسيار گسترده‌اي براي جهان كنوني به بار آورد.

درحال حاضر بسياري از معاملات تجاري و نقل و انتقالات مالي و نيز مبادله اطلاعات محرمانه از طريق شبكه هاي مخابراتي مانند اينترنت و با بهره گيري از رمز كردن پيامها به انجام مي‌رسد.

اعداد اول در تنظيم اين قبيل رمزها نقشي اساسي بر عهده دارند و از همين رو دستيابي به اعداد اول جديد كه ديگران از آن بي‌خبر باشند براي سازندگان اين رمزها و نيز مشتريان آنان از اهميت زياد برخوردار است.

اما اگر روش اين محققان هندي تكميل شود در آن صورت امنيت اين قبيل نقل و انتقالات در معرض خطر جدي قرار خواهد گرفت.

سابقه قرار گرفتن رياضي دانان تحت جاذبه اعداد اول به قرنها پيش باز مي گردد. در سال ‪ ۱۸۰۱‬كارل گائوس از بزرگترين رياضي دانان اعلام كرد كه مساله تشخيص اعداد اول از اعداد غير اول يكي از مهمترين مسائل حساب به شمار مي‌آيد.

اعداد اول به يك معنا همان نقشي را در سلسله اعداد بازي مي‌كنند كه اتمها در ساختار بناي كيهان دارند- اين اعداد سنگ بناي ناپيداي ديگر اعداد محسوب مي‌شوند.

يكي از عادي‌ترين راههاي شناسايي اعداد اول تقسيم آن به ديگر اعداد است.

از طرف ديگر با اندكي تامل روشن مي‌شود كه اعداد زوج عدد اول نيستند زيرا همگي بر ‪ ۲‬قابل قسمتند.

اعدادي كه بتوان جذر آنها را به دست آورد نيز اول نيستند. اما اين روشها براي شناسايي اعداد اول بزرگ به كلي بي‌فايده‌اند. به عنوان مثال اگر عدد اولي داراي ‪ ۱۰۰‬رقم باشد در آن صورت كل عمر باقيمانده از كيهان بر اساس نظريه هاي جديد كيهانشناسي نيز براي مشخص كردن اول بودن يا نبودن اين عدد با اين شيوه هاي متعارف كفايت نمي‌كند.

بنابراين رياضي دانان به سراغ روشهاي ديگر رفته‌اند. مهمترين سوال در مورد همه اين روشها آن است كه با چه سرعتي مي‌توانند يك عدد اول را مشخص كنند و با ازدياد ارقام عدد اول زمان لازم براي محاسبه چه اندازه طولاني تر مي شود. اگر به عنوان مثال زمان محاسبه به توان ثابتي از شمار ارقام عدد ازدياد يابد در آن صورت اين روش روش قابل قبولي به شمار آورده مي‌شود .

به اين نوع روشها كه زمان به صورت تواني در آنها افزوده مي‌شود "روشهاي تواني" مي‌گويند. روشهاي ديگر كه زمان در آنها با سرعت بيشتري افزايش مي‌يابد روشهاي غيرتواني نام دارند.

به عنوان مثال روش تقسيم معمولي يك روش غيرتواني براي يافتن اعداد اول است. در اين روش زمان لازم براي تعيين اول بودن يك عدد با ‪ d‬رقم، برابر با ‪ /۱۰d/2‬اين نوع روشها بسيار نامناسبند.

در سال ‪ ۱۹۵۶‬منطق‌دان برجسته آلماني كورت گودل اين پرسش را مطرح ساخت كه آيا مي‌توان اين نوع روشهاي تقسيم را بهبود بخشيد. تلاش خود او نهايتا به كشف شماري از روشهاي عملي براي يافتن اعدادي به بزرگي ‪ ۱۰۰‬رقم يا بيشتر منجر شد. همه اين روشها احتمالاتي هستند و بنابراين در مواردي پاسخ غلط به دست مي‌دهند هرچند كه اين موارد بسيار نادرند.

در سال ‪ ۱۹۸۳‬روشي كشف شد كه بسيار نزديك به روشهاي تواني بود. اين روش كه به وسيله سه رياضي دان به نامهاي لئونارد آدلمن از دانشگاه كاليفرنياي جنوبي، كارل پومرانس از آزمايشگاهاي بل در موري هيل نيو جرسي، و رابرت روملي از دانشگاه جورجيا كشف شد به نام خود آنان به روش آپي آر ‪ APR‬شهرت يافت.

در اين روش زمان محاسبه يك عدد داراي ‪ d‬رقم براي است با ‪.(d)ln ln d‬
در اين فرمول
(‪ (ln ln d‬به معناي لگارتيم لگاريتم ‪ d‬است. به لحاظ فني اين روش غير تواني است زيرا توان آن ثابت نيست و زياد مي‌شود. اما سرعت اين ازدياد بسيار بسيار كند است. يعني به ازاي ‪ d =10100‬ميزان ازدياد اين توان تنها ‪ ۵.۶‬مرتبه است. رياضي دانان به شوخي مي‌گويند كه ثابت شده اين توان به سمت بينهايت ميل مي‌كند اما چنين چيزي در عمل مشاهده نشده.

سوالي كه براي رياضي دانان مطرح است آن است كه آيا مي‌توان به روشي دست يافت كه به معناي دقيق و فني كلمه روشي تواني باشد. هيچ كس تصور نمي‌كرد كه احتمال چنين موفقيتي وجود داشته باشد تا اينكه گروه آگراوال بمب خود را منفجر كرد.

ايده انقلابي اين سه تن در سال ‪ ۲۰۰۲‬و زماني كه كايال و سكسنا هنوز دانشجوي دوره ليسانس بودند مطرح شد. در ابتداي سال جاري يك روايت بهبود يافته از روش پيشنهادي اين سه كه به آلگوريتم آ.ك.اس شهرت يافته در نشريه "آنالز او متمتيكس ‪ "Annals of Mathematics‬انتشار يافت.

اين آلگوريتم از نوع روشهاي تواني است و علاوه برآن بسيار ساده است (لااقل براي رياضي دانان چنين است). اين روش از اعقاب يك روش آزمون قديمي موسوم به قضيه كوچك پي‌ير فرما است.

اين قضيه را نبايد با قضيه اصلي فرما كه چند سال قبل پس از ‪ ۳۰۰‬سال اثبات شد اشتباه كرد. اين قضيه مبتني بر نوعي حساب متكي به قدر مطلق ‪modular‬موسوم به "حساب ساعت ‪ "clock arithmetic‬است علت آن تست كه در اين روش اعداد به شكل اعداد روي صفحه ساعت جمع مي‌شوند.

براي آشنايي با اين حساب خاص مورد زير را در نظر بگيريد. يك عدد دلخواه انتخاب كنيد و آن را قدر مطلق ‪ modulus‬بناميد. در مثال ساعت، اين عدد خاص كه قدر مطلق ناميده مي‌شود و مبناي محاسبه قرار مي‌گيرد، عدد ‪ ۱۲‬است.

حال در هر نوع محاسبه رياضي با اعداد صحيح براي تبديل آن سيستم عددي به سيستم عددي قدر مطلق ‪ ۱۲‬كافي است بجاي همه مضارب صحيح عدد ‪ ۱۲‬عدد صفر قرار داده شود. همه اعداد ديگر بر همين اساس تغيير مي‌كنند.

مثلا عدد ‪ ۲۵‬برابر است با ‪ . + ۲۴۱‬بنابراين عدد ‪ ۲۵‬در اين سيستم قدر مطلق برابر است با "‪ ۱‬به قدر مطلق ‪ ."۱۲‬سيستمهاي حساب متكي به قدر مطلق به تعريفي كه ذكر شد سيستمهاي زيبايي هستند زيرا در آنها همه قواعد حساب متعارف كار مي‌كند و درعين حال برخي از اعداد غيرصفر درآن ناپديد مي‌شوند.

قضيه كوچك فرما مي‌گويد اگر يك عدد اول را به عنوان قدر مطلق انتخاب كنيد ، داراي يك مشخصه ويژه خواهد بود. اين مشخصه عبارت از آن است كه يك فرمول خاص يعني ‪ (a)p-1‬در اين سيستم همواره برابر يك خواهد بود.

در اين فرمول ‪ p‬عبارت است از عدد اولي كه به عنوان قدر مطلق انتخاب شده و ‪a‬هر عدد ديگر است كه ضريب ‪ p‬محسوب نمي‌شود.

اگر مقدار فرمول بالا برابر يك نباشد آنگاه عددي كه به عنوان عدد اول تصور كرده بوديد يعني ‪ p‬عدد اول نيست.

به اين ترتيب مي‌توان از اين قضيه كوچك فرما به عنوان مبنايي براي تدوين آزموني جهت تعيين اعداد اول استفاده كرد. اين آزمون كاملا بي‌نقص نيست زيرا شماري از اعداد غير اول نيز از غربال آن رد مي‌شوند.

اما مي‌توان روايت هاي پيچيده تر و دقيق تري از اين آزمون را توليد كرد كه بسادگي به اعداد غير اول اجازه ورود ندهند. يك نمونه پيشرفته از اين آزمونها همان روش "آ.پي.آر" است كه در بالا اشاره شد.

گروه آگراوال از همين قضيه كوچك فرما استفاده كرد اما آن را به نحو ديگري بسط داد. اين گروه به عوض آنكه با اعداد كار كنند از چند جمله‌اي‌ها استفاده كردند.

چند جمله‌اي‌ها عباراتي جبري هستند نظير (‪ .a + b(2‬ايده استفاده از اين روش محصول كوشش آگراوال در دوراني بود كه بر روي رساله دكتري خود كار مي‌كرد و به اتفاق استاد راهنماي خويش "سومنات بيسواس" در سال ‪ ۱۹۹۹‬مقاله- اي را به چاپ رساند كه در آن يك روش آزمون اعداد اول پيشنهاد شده بود كه از همين چند جمله‌اي‌ها استفاده مي‌كرد و به شيوه احتمالاتي محاسبات را انجام مي داد.

آگراوال بر اين باور بود كه مي‌تواند اين روش پيشنهادي را دقيق‌تر و عنصر احتمالاتي آن را حذف كرد.

در سال ‪ ۲۰۰۱‬دو تن از دانشجويان او يعني كايال و سكسنا به يك نكته بسيار حساس و فني توجه كردند. ابتدا اين مساله سبب شد تا گروه سه نفره در آبهاي عميق نظريه اعداد غوطه ور شوند، اما اندك اندك برايشان روشن شد كه تنها يك مانع در راه تكميل روشي جهت آزمودن دقيق و سريع اعداد اول وجود دارد.

مانع از اين قرار بود كه روش آنان تنها در صورتي كار مي‌كرد كه عدد اول مورد نظر كه با ‪ p‬نمايش داده مي‌شود همواره در محدوده خاصي جاي داشته باشد كه با اعدادي كه در آزمون شركت داده مي‌شوند مرتبط باشد.

مشخصه ويژه اين مانع آن است كه عدد " ‪ "p-1‬بايد يك مقسوم عليه يا بخشياب بسيار بزرگ باشد.

گروه سه نفر رياضي دانان هندي براي غلبه بر مشكل به هر دري زدند و با بررسي مقالات مختلف بالاخره دريافتند كه در سال ‪ ۱۹۸۵‬يك رياضي‌دان فرانسوي به نام اتن فووري از دانشگاه پاريس ‪ ۱۱‬اين نكته را به صورت رياضي اثبات كرده است. به اين ترتيب آخرين بخش معما حل شد و آلگوريتم پيشنهادي اين سه نفر با موفقيت پا به عرصه گذارد.

اما اين موفقيت "مشروط" بود. به اين معني كه اين روش براي اعداد اولي كه انسان در حال حاضر مي‌توان به سراغ آنها برود از كارآيي چنداني برخوردار نيست. در روايت اوليه روش پيشنهادي، زمان لازم براي محاسبات كه متناسب با ارقام عدد اول مورد نظر بود، با آهنگ ‪ ۱۰۱۲‬ازدياد پيدا مي كرد.

در روايتهاي بهبود يافته اخير اين روش، سرعت ازدياد زمان لازم براي محاسبات به ‪ ۱۰۷.۵‬كاهش يافته اما حتي در اين حالت نيز اين روش در مقايسه با روش آ پي آر تنها در هنگامي موثر تر خواهد بود كه تعداد ارقام عدد اولي كه قصد شكار و يافتن آن را داريم در حدود ‪ ۱۰۱۰۰۰‬باشد.

اعدادي تا اين اندازه بزرگ در حافظه هيچ كامپيوتر جاي نمي‌گيرند و حتي آن را نمي‌توان در كل كيهان جاي داد.

اما حال كه رياضي دانان توانسته‌اند يك طبقه خاص از آلگوريتمهاي تواني را براي شناسايي اعداد اول مشخص كنند، اين امكان پديد آمده كه به دنبال نمونه‌هاي بهتر اين روش بگردند. پومرانس و هندريك لنسترا از دانشگاه كاليفرنيا در بركلي با تلاش در همين زمينه توانسته‌اند زمان لازم براي محاسبات را از توان ‪ ۷.۵‬به توان ‪ ۶‬كاهش دهند.

اين دو از همان استراتژي كلي گروه هندي موسسه كانپور استفاده كردند اما تاكتيهاي ديگري را به كار گرفتند.

اگر فرضيه‌هاي ديگري كه درباره اعداد اول مطرح شده درست از كار درآيد آنگاه مي‌توان زمان محاسبه را از توان ‪ ۶‬به توان ‪ ۳‬تقليل داد كه در اين حد اين روش كارآيي عملي پيدا خواهد كرد.

در اين حالت يافتن اعداد اول با ‪ ۱۰۰۰‬رقم يا بيشتر به بازي كودكان بدل خواهد شد.

اما در نظر رياضي‌دانان مهمترين و جالبترين جنبه كار گروه سه نفره آ ك اس (كانپ.ر) روشي است كه آنان به كار گرفته‌اند.

اعداد اول براي رياضيات از اهميت بنيادين برخوردارند و هر نوع غفلت در فهم ويژگيهاي آنها باعث مي‌شود خللهاي بزرگ در بناي رياضيات پديدار شود.

روش اين سه رياضي دان هندي هرچند اين خللها و نقصها را پر نكرده حداقل به رياضي دانان گفته است كه در كجا به دنبال اين خللها بگردند.

آلگوريتم پيشنهادي اين سه محقق و همه انواع بديلي كه بر اساس آن ساخته شده متكي به وجود اعداد اولي با مشخصه هاي ويژه هستند. و در اغلب موارد استفاده از اين روش مستلزم آن است كه رياضي دانان اطلاعات دقيقي از نحوه توزيع اين قبيل اعداد اول خاص در ميان ديگر اعداد به دست آورند و به اين ترتيب جغرافياي مكاني اعداد اول را مشخص سازند.

روش پيشنهادي آ ك اس به رياضي دانان اين نكته را آموخته كه ويژگيهاي اين جغرافياي مكاني حائز اهميت است و نيز اين كه هنوز دانش كافي در اين زمينه به دست نيامده است.

در گذشته و در زماني كه نظريه اعداد تنها مورد توجه يك گروه كوچك از رياضي دانان بود ، اين مساله چندان اهميتي نداشت. اما در ‪ ۲۰‬سال گذشته اعداد اول موقعيتي استثنايي در عرصه رمز نگاري و دانش طراحي و شكستن رمزها كسب كرده اند.

رمزها صرفا از نظر نظامي و جاسوسي حائز اهميت نيستند بلكه از آنها در عرصه هاي تجاري و نيز فعالييتهاي اينترنتي در مقياس وسيع استفاده به عمل مي‌آيد. هيچ كس نمي‌خواهد كه راهزنان اينترنتي به اطلاعات شخصي مربوط به حسابهاي بانكي يا شماره كارتهاي اعتباري آنان دست يابد.

هم اكنون دزدي مشخصات شناسنامه اي افراد و جعل هويت آنان به صورت يكي از بزرگترين قلمروهاي فعالييتهاي تبهكارانه در سطح بين‌المللي در آمده است.

سازندگان كامپيوترها و ارائه‌دهندگان خدمات اينترنتي با توجه به آنكه در حال حاضر افراد بسياري از فعاليتهاي خود را از طريق اينترنت انجام مي دهند، نظير اينكه پول قبضهاي برق و آب و تلفن خود را مي‌پردازند يا در كلاسهاي مورد نظر ثبت نام مي‌كنند، يا بليت هواپيما و قطار رزرو مي‌كنند، در تلاشند تا از خطر دستيابي تبهكاران به اطلاعات شخصي افراد جلوگيري به عمل اورند.

يكي از مهمترين سيستمهايي كه در اين زمينه مورد استفاده صنايع است سيستم آر اس آ نام دارد كه متكي به اعداد اول است.

اعداد اول مورد استفاده در اين سيستم در حدود ‪ ۱۰۰‬رقمي هستند. سيستم آر اس آ در بسياري از سيستمهاي كامپيوتري مورد استفاده قرار دارد و در پروتكل اصلي براي ارتباطات امن اينرتنتي نيز گنجانده شده است و بسياري از دولتها، شركتهاي بزرگ و دانشگاهها از آن استفاده مي‌كنند. جواز استفاده از اين سيستم براي بيش از ‪ ۷۰۰‬شركت صادر شده و بيش از نيم ميليون كپي از آن در سطح جهاني مورد استفاده قرار دارد.

براي شكستن رمز آر اس آ بايد مضراب اعداد ‪ ۲۰۰‬رقمي يا بزرگتر را پيدا كنيد. هرچند فاكتور گيري يا عامل مشترك گيري از اعداد سخت تر از آزمودن اول بودن آنهاست اما اين دو مساله با يكديگر ارتباط دارند و رياضي دانان از يك ابزار براي حل هر دو مساله استفاده مي‌كنند.

همه اين جنبه‌ها بر اهميت كشف هر روشي براي محاسبه اعداد اول مي‌افزايد.

در سال ‪ ۱۹۹۵‬زماني كه پيتر شور از آزمايشگاههاي بل اثبات كرد كه مجموعه- اي از آلگوريتمهاي تواني براي فاكتور گيري وجود دارد، لرزه بر اندام بسياري افتاد.

اما خوشبختانه براي استفاده از اين آلگوريتم به كامپيوترهاي كوانتومي نياز است كه هنوز در مرحله تكميل تئوريك قرار دارند.

اكنون روش تازه آگراوال و دوستانش دوباره سيستم آر اس آ را در معرض خطر قرار داده است. آگراوال اكنون اين نكته را نشان داده كه مي‌توان با كامپيوتر هاي معمولي، اعداد را از حيث اول بودن مورد آزمايش قرار داد.

سوالي كه اينك مطرح شده آن است كه آيا الگوريتم مشابهي كه به صورت تواني كار كند براي فاكتورگيري اعداد غيراول نيز موجود است؟ پاسخ اغلب متخصصان به اين پرسش منفي است اما متاسفانه اين متخصصان همين حرف را در مورد آلگوريتم تواني مربوط به اعداد اول نيز مي‌زدند
در حال حاضر رياضي دانان واقعا مطمئن نيستند كه كه آيا چنين آلگوريتمي يافت مي‌شود يا نه.

اگر پاسخ مثبت باشد انگاه سيستم آر اس آ ديگر از امنيت برخوردار نيست.

يك عامل تخفيف‌دهنده نگرانيها آن است كه از سيستم آر اس آ براي انتقال همه محتواي پيامها استفاده نمي‌شود بلكه صرفا "كليد هاي رمز" را كه اندازه شان كوچك است با اين سيستم انتقال مي‌دهند.

براي انتقال بقيه پيام از روشهاي رمزنگاري متعارف بهره گرفته مي‌شود. به اين ترتيب جاسوسان در صدد برخواهند آمد كه به كليد رمزها دست يابند.

به اين ترتيب درسي كه از موفقيت گروه سه نفره هندي گرفته مي‌شود آن است كه بايد با احتياط در ارسال پيامها عمل كرد. اگر اكتشافات مشابه آنچه گروه كانپور بدست اورده تكرار شود، انگاه ديگر نمي‌توان به ايمن بودن ارتباطاتي كه روي اينترنت برقرار مي‌شود اطمينان داشت.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 20 مردادماه 1384

03:15 PM

August 11, 2005

پورتال چيست؟

اشاره:

بهبود و ايجاد اصلاحات در اداره حكومت ها و بخش دولتي موضوعي اساسي در دنياي تجارت امروزاست. لزوم پاسخ گويي به تغييرات ناشي از جهاني شدن، امور اقتصادي و تجارت جهاني، گسترش جوامع و انتظارات مشتريان به ويژهً با پيشرفت هاي دو دهة ي اخير در زمينه فناوري اطلاعات، روندي تكاملي در كشورهاي مختلف پاگرفته است. سرعت اين تغيير و تكامل در كشورهاي مختلف متفاوت است. اين تكامل دربرگيرنده طيف وسيعي از اهداف و چشم اندازها جهت بهبود عملكرد دولت ها در زمينه هاي قوانين و مقررات، شفافيت در اداره حكومت ها، سازندگي و مشاركت عمومي است.

پيشرفتهاي انجام گرفته در زمينه فناوري اطلاعات و ارتباطات (ICT)، در راستاي جامعه اطلاعات تغييرات زيادي در انتظارات شهروندان، ساختار سازمان ها، فرهنگ، علوم و فرآيندهاي كاري ايجاد نموده است. دولت ها به دنبال به كارگيري ابزارها و راهكارهاي مبتني بر (ICT) جهت پاسخگوئي به نياز شهروندان هستند.

تاثير دولت الكترونيكي به طور ساده اداره بهتر كشور با افزايش بازدهي سياست هاي دولت، ارتقاء سرعت و كيفيت خدمات دولتي، تعاملات بيشتر با شهروندان و افزايش بهره وري كليه فرآبندهاي دولتي است.

حال دولت الكترونيكي يكي از مهم ترين محورهاي كاربرد فناوري اطلاعات و ارتباطات در دنيا است. اين اهميت در كشور ما كه دولت بزرگ ترين بنگاه اقتصادي و نهاد فرهنگي است، به مراتب بيشتر است. در تعريف دولت الكترونيكي مي توان گفت كه: دولت الكترونيكي به معناي به كارگيري فناوري اطلاعات و ارتباطات در بخش هاي مختلف دولت، به منظور افزايش بهره وري و ارتقا سطح خدمات رساني است.

پورتال چيست؟

پورتال (Portal) عبارت از درگاهي است به دنياي اطلاعات و منابع اطلاعاتي، به صورت دسته بندي شده و به شكل مورد نياز كاربر.

دكتر يونس شكرخواه استاد ارتباطات دانشگاه علامه طباطبائي، پورتال را به صورت زير تعريف كرده است:

پورتال اساساً يك امكان براي كاربران اينترنت است و بنابراين در گام اول بايد بگويم پورتال، ايران و غير ايران نمي شناسد و براي همه جا مفيد است. به لحاظ برنامه ريزي، طراحي و هزينه هاي آن يك سيستم استاندارد را داراست.

در هر حال پورتال وبگاهي است كه مي كوشد خود را به اولين ايستگاه كاربران براي حركت در اينترنت تبديل كند. پورتال ها غالباً داراي كاتالوگ يا فهرست از ساير وبگاه ها هستند، غالباً موتور جستجو دارند و بعضي از آنها هم امكان چت و پست الكترونيكي به كاربران خود مي دهند.

به پورتال ها وبگاه لنگرگاه( (Anchor site و گذرگاه( Gateway ) هم مي گويند.

در ساده ترين معنا، پورتال دروازه اي است به وب و سكوي پرتابي است كه هر كاربر قبل از رفتن به سراغ مقصدهاي ديگر بايد به عنوان يك مبدا، از آن استفاده نمايد.

ويژگي هاي پورتال عبارتند از:

قابليت دسته بندي و طبقه بندي مطالب و محتويات، مديريت و تجميع مطالب و محتويات ، ارائه ابزارهايي جهت توليد و توسعه مطالب و محتويات ، قابليت ارائه محتويات و مطالب روي هر نوع سامانه و بستري ، قابليت امنيت مناسب ، پشتيباني از زبان هاي مختلف ، سهولت دسترسي به اطلاعات ، قابليت سفارشي سازي و شخصي سازي ، قابليت جستجو و نمايه بندي مطالب و محتويات قابليت مرور مطالب و محتويات دسته بندي شده ، قابليت ارائه يك رشته خدمات از طريق مؤلفه هاي قابل جايگزيني و سفارشي سازي (Portlet).

هدف از طراحي و پياده سازي پورتال، ايجاد وبگاهي واحد، جهت دستيابي به اطلاعات و خدمات تمامي وبگاه هاي دولتي و بخشي از سازمان هاي غيردولتي، بدون نياز به مراجعه مستقيم به تك تك آنها است. اين درگاه به عنوان نقطه واحد و اصلي، به معرفي امكانات و توان مندي ها مي پردازد. هدف اصلي طراحي يك درگاه جامعه، تعاملي و پويا است تا به سهولت جهت اطلاع رساني و خدمات رساني مورد استفاده قرارگيرد.

پورتال فقط وبگاه نيست ولي يكي از بخش هاي اصلي آن به شمار مي رود. پورتال به وبگاه مرجعي گفته مي شود كه كاربران اينترنتي و كساني كه با وب سروكار دارند از آن به عنوان مدخل و منبعي براي پيداكردن وبگاه هاي مورد علاقه شان استفاده مي كنند. هرچند، پورتال ها خدمات رايگان مانند اتاق هاي گفتگو و پست الكترونيكي رايگان و خدمات ديگري به كاربران شان اهدا مي كنند اما هدف اوليه پيدايش پورتال، ايجاد دروازه اي است تا كاربران بر اساس نيازهاي شان وبگاه مورد نظر خود را انتخاب نمايند. اولين پورتال هايي كه در اينترنت به وجود آمدند در واقع وبگاه هاي اختصاصي خدمات دهندگان اينترنتي در ايالات متحده آمريكا بودند. مثلاً وبگاهAOL.com كه مشتركين آن، از وبگاه شركت مزبور به ساير وبگاه ها ربط داده مي شوند. اگر بخواهيم مثالي آشنا براي استفاده كنندگان امروز اينترنتي بزنيم مي توانيم وبگاهYahoo را نام ببريم. وب سايت مذكور خدمات گوناگوني را علاوه بر جستجو در ساير وبگاه ها، به كاربران خود ارائه مي كنند، اطلاعات تجاري، پيش بيني وضعيت آب و هوا و غيره خدماتي از اين قبيل است.

موتورهاي جستجو بخش اعظمي از پورتال ها را در برمي گيرند، اما همه آن نيستند و علاوه بر موتورهاي جستجو و يا وبگاه هاي دايركتوري، كه حاوي اطلاعات طبقه بندي وبگاه هاي ديگر هستند، پورتال هايي بر روي اينترنت وجود دارند كه براي موضوعات بسيار محدودي طراحي و اختصاص داده شده اند.

پورتال هاي دولتي پورتال هائي هستند كه به معرفي و ارايه خدمات دولتي در زمينه هاي مختلف مي پردازند. اين پورتال ها به صورتي طراحي مي شوند كه مراجعه كنندگان، به راحتي به تمام خدمات دولتي مورد نياز دسترسي داشته باشند.

پورتال ها را مي توان از منظرهاي مختلف تقسيم بندي نمود. از لحاظ دامنه تحت پوشش به دو دسته پورتال هاي افقي و پورتال هاي عمودي تقسيم مي شوند. پورتال هاي افقي پورتال هايي هستند كه محدودة تحت پوشش آنها بسيار زياد است. به عنوان مثال وبگاه ياهو يك پورتال افقي است كه تقريباً اكثر موضوعات مورد علاقه مردم را پوشش مي دهد. پورتال هاي عمودي پورتال هائي هستند كه دامنه شمول آنها يك موضوع يا يك صنعت خاص است. اين پورتال ها داراي محدوده تحت پوشش كم ولي داراي عمق زيادي هستند. بدين معني كه روي يك موضوع خاص تعمق دارند و به صورت تخصصي بدان پرداخته اند.

مهندس اميرحسين شكوهي زنجاني
a.h.shokuhi@gmail.com
ناشر: مجله دنیای مخابرات و ارتباطات

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

شنبه، 22 مردادماه 1384

10:53 AM

August 13, 2005

پروتكل امنيتي Kerberos

سعيد احمد لوئي
ماهنامه شبکه - شهريور ۱۳۸۳ شماره 46

اشاره :
شبكه‌اي را با تعدادي كلاينت و چندين سرور در نظر بگيريد. در چنين شبكه‌اي كاربران خواهان دسترسي و استفاده از سرويس‌هايي هستند كه توسط سرورها در سطح شبكه فراهم شده است. به عنوان مثال يك FTP سرور را در نظر بگيريد كه كاربران انتظار تبادل و دريافت فايل از آن را دارند. غالباً در چنين محيط‌هايي نياز داريم كه هويت كاربران براي سرور شناخته شود و درخواست‌هايي كه جهت استفاده از سرويس‌هاي يك سرور ارسال مي‌شود توسط آن سرور اعتبارسنجي شوند، ضمناً در شبكه‌هاي بزرگ مانند اينترنت لازم است كه سرور نيز هويت خود را براي كلاينت اثبات كند. توجه كنيد كه مي‌بايستي هويت كاربري كه به سيستم كلاينت درخواستي را ارسال كرده شناخته شود و به پارامترهايي (به عنوان مثال آدرس IP) كه هويت خود سيستم كلاينت را نشان مي‌دهند نمي‌توانيم اعتماد كنيم. براي رفع چنين مشكلاتي، مكانيزم‌ها يا پروتكل‌هاي امنيتي متعددي به وجود آمدند كه پروتكل كربروس يكي از آن‌ها مي‌باشد.

متن کامل مقاله ( 149 کيلوبايت )

همان‌گونه كه در قسمت قبلي اين مقاله در شماره 46 اشاره شد، براي برقراري امنيت در شبكه‌ها چندين پروتكل امنيتي ساخته شده‌اند كه يكي از آن‌ها كربروس مي‌باشد. در قسمت اول با مفاهيم اوليه پروتكل تشخيص هويت و نحوه كاركرد كربروس آشنا شديد و نسخه 4 اين پروتكل مورد بررسي قرار گرفت. در اين قسمت نسخه‌هاي جديدتر كربروس را به تفضيل بررسي مي‌كنيم.

نسخه 5 كربروس
در نسخه 5 بيشتر مشكلات نسخه‌هاي قبلي حل شده است به طوري كه الگوريتم رمز مورد استفاده و پروتكل آدرس‌دهي لايه شبكه با استفاده از Flagهايي در پيام‌ها مشخص مي‌شوند و لذا به راحتي قابل تغييرند. طول عمر بليط هم به صورت صريح به شكلِ زمان تولد و مرگ بليط در پيام‌ها بيان مي‌شود. البته غير از رفع مشكلات نسخه 4، قابليت‌هاي خاصي نيز در اين نسخه اضافه شده است. گفت‌وگوي كربروس نسخه 5 به صورت جدول 2 مي‌باشد.

همان‌طور كه مشاهده مي‌كنيد باز هم گفت‌وگوها در سه مرحله انجام مي‌شود و هدف گفت‌وگو‌هاي هر مرحله هم همان است كه در نسخه 4 گفته شد. فقط داده‌هاي خاصي در پيام‌ها اضافه شده كه اين داده‌ها به شرح زير هستند:

Times: كلاينت، اين داده را ارسال مي‌كند تا درخواست كند كه از خصوصيات زماني خاصي (time setting) توسط سرور استفاده شود (مثلاً زمان شروع و فرمت زمان)

Nonce: در دو پيام اول و سوم، كلاينت يك مقدار تصادفي به نام Nonce را توليد كرده و به سرور تشخيص هويت در پيام اول و به TGS در پيام دوم ارسال مي‌كند و سپس انتظار دارد كه در پاسخ‌هايي كه دريافت مي‌كند همان Nonce قرار داده شده باشد، البته به صورت رمز شده. به اين ترتيب گام ديگري جهت جلوگيري از حمله تكرار و اطمينان از تازه بودن داده‌هاي دريافتي بر مي‌دارد.

Options: در اين داده، كلاينت درخواست مي‌كند كه بليط ويژگي‌هاي خاصي را داشته باشد.

Flags: ويژگي‌هاي خواسته شده در داده Options توسط كلاينت، در فيلد Flag بليط نگهداري مي‌شود. به عبارت ديگر flags خصوصيات و حالات خاصي را كه يك بليط مي‌تواند داشته باشد نشان مي‌دهد. به عنوان مثال يكي از مقاديري كه flags مي‌تواند داشته باشد RENEWABLE است. بليطي كه در فيلد flags آن، اين قابليت set شده باشد يعني TGS،‌ در صورتي كه عمر بليط تمام شود مي‌تواند با دادن اين بليط به AS بليط جديدي را دريافت كند و كلاينت درگير دريافت بليط مجدد ازAS ، نشود. توجه كنيد كه در غير اين‌صورت لازم است كلاينت، مرحله اول گفت‌وگوي كربروس را انجام دهد و بليط ديگري را دريافت كند.

Subkey: كليد ديگري مي‌باشد كه كلاينت انتخاب كرده و در هر نشست به سرور ارسال مي‌كند تا ارتباطات اين نشست با اين كليد رمز شود. البته اين فيلد اختياري است و در صورتي كه كلاينت آن را ارسال نكند، از همان كليد به اشتراك گذاشته شده در پيام 3 و 4 يعني kc,v استفاده مي‌شود.

Seq: شماره ترتيب پكت‌ها مي‌باشد. كلاينت درAuthenticator شماره آغازي را به سرور ارسال مي‌كند و سرور در هر بسته‌اي كه به كلاينت ارسال مي‌كند يك رقم به اين شماره اضافه مي‌كند. استفاده از اين فيلد جهت اطمينان از اصالت پيام‌ها مي‌باشد. به اين صورت كه در هر بسته مي‌بايستي يك واحد به seq اضافه شده باشد و در صورتي كه seq مقدار مورد انتظار را نداشته باشد كلاينت آن را بسته معتبر نمي‌داند.

Realm: به مجموعه يك AS و TGS و سرورهاي مربوطه و كلاينت‌هايي كه از AS استفاده مي‌كنند يك قلمرو كربروس
(kerberos realm) مي‌گويند. در پيام اول، كلاينت در داده Realmc مشخص مي‌كند كه TGS موردنظر او در چه قلمرويي قرار دارد. در بليط‌ها، Realm مشخص كننده قلمرويي است كه بليط در آن اعتبار دارد. در داخل Authenticator هم كلاينت مشخص مي‌كند كه خود او جزء كدام قلمرو است.
براي درك بيشتر به شكل 1 توجه كنيد كه در آن كلاينت موجود در قلمرو A مي‌خواهد از سروري در قلمرو B استفاده كند. لذا از TGS مربوط به قلمرو خود (A) درخواست بليط استفاده از TGS قلمرو B را مي‌كند و سپس از TGS قلمرو B بليط استفاده از سرور را مي‌گيرد.
همان‌طور كه قبلاً نيز اشاره شد، طراحان كربروس اين پروتكل را براي محيط خاصي طراحي نكرده‌اند و لذا اين پروتكل توسط شركت‌هاي مختلف به صورت‌هاي گوناگوني پياده‌سازي شده است. آن‌چه كه تا اين‌جا شرح داده شد استاندارد اصلي كربروس (RFC 1510) بود، در ادامه چگونگي پياده‌سازي كربروس در ويندوز 2000 را بررسي مي‌كنيم.

كربروس در ويندوز 2000

شكل 1

يكي از مفاهيمي كه در دنياي امنيت مطرح مي‌شود اين است كه زير ساخت‌هاي امنيتي تا جايي كه امكان دارد از ديد كاربر نهايي پنهان يا شفاف (transparent) باشد. به عبارت ديگر، كاربر نهايي جز در مواقع لزوم، درگير مسايل امنيتي شبكه نشود (درگير نشدن كاربر نهايي با مسايل امنيتي امتياز بزرگي است ولي متأسفانه در اغلب موارد برنامه‌نويسان (developers) هم به صورت كاربر نهايي با مسايل امنيتي برخورد مي‌كنند و هم در سطح حرفه‌اي از (1) SSPI استفاده مي‌كنند حال اين‌كه SSPI واسطي است براي درگير نشدن با جزييات زيرساخت‌هاي امنيتي!) مايكروسافت اين امر را در سيستم‌هاي خود كاملاً رعايت كرده است به طوري كه شايد تعجب كنيد اگر بشنويد كه وقتي يك Domain ويندوز 2000 راه‌اندازي مي‌كنيد در واقع يك قلمرو كربروس هم ايجاد كرده‌ايد كه شامل Domain Controller و كلاينت‌‌هاي متصل به آن مي‌باشد، به عبارت ديگر Domain و قلمرو كربروس به يك مفهوم مي‌باشند و در دنياي مايكروسافت به قلمرو كربروس نام Domain اطلاق مي‌شود. در يك قلمرو كربروس، دو سرور وجود داشتند كه يكي سرور تشخيص هويت (AS) و ديگري سرور اعطا‌كننده بليط (LTGS) بود. مايكروسافت اين دو سرور را در يك سرور قرار داده كه همان Domain Controller شبكه است. يعني Domain Controller وظيفه تشخيص هويت و صدور بليط TGT (مانند AS) و نيز صدور بليط براي استفاده از سرورهاي موجود در شبكه (مانند TGS) را به عهده دارد. اگر تاكنون به ساختار ويندوز 2000 توجه كرده باشيد متوجه شده‌ايد كه زيرساخت و سرويس‌هاي امنيتي ويندوز2000 در نقطه خاصي از ساختار سيستم‌عامل قرار ندارد و در كلِ ساختار اين سيستم‌عامل پراكنده شده‌اند كه كربروس هم از اين قاعده مستثني نيست. لذا درك چگونگي كاركرد كربروس شايد كمي پيچيده به نظر برسد. در ادامه به صورت جزيي‌تر ساختار كربروس در ويندوز 2000 را بررسي مي‌كنيم.

در كلاينت‌‌هايي كه عضو Domain ويندوز2000 هستند كتابخانه‌اي به نام Kerberos.dll وجود دارد كه دو مجموعه از توابع را ارايه مي‌كند:
1- توابع لازم جهت ساختن پيام‌هايي كه سيستم كلاينت در پروتكل كربروس ارسال مي‌كند استفاده مي‌شود.
2- توابعي كه پاسخ‌هاي سرور را گرفته و اصالت پاسخ را بررسي كرده و نيز قسمت‌هاي لازم مانند بليط را از پاسخ دريافتي جدا مي‌كنند.
(كتابخانه‌ها يا dll‌ها، برنامه‌هايي هستند كه مانند ساير برنامه‌ها نوشته مي‌شوند ولي معمولاً داراي فرم و ديالوگ نيستند و خودشان به تنهايي كاري انجام نمي‌دهند، بلكه لازم است برنامه ديگري نوشته شود كه از توابع داخل اين كتابخانه‌ها استفاده كند). با استفاده از اين كتابخانه سيستم كلاينت وقتي مي‌خواهد پيام اولي را كه در ساختار پروتكل كربروس توضيح داده شد ارسال كند، يكي از توابع كتابخانه kerberos.dll را فراخواني مي‌كند و اطلاعات لازم براي ساختن پيام اول را (نام DC، نام كاربر، كلمه عبور، nonce) در اختيار اين تابع قرار مي‌دهد و اين تابع پيام را ساخته و به كلاينت مي‌دهد تا به سمت سرور ارسال كند. همچنين هنگام دريافت پاسخ سرور، بسته پاسخ را در اختيار يكي ديگر از توابع اين كتابخانه قرار مي‌دهد تا صحت بسته دريافتي را كنترل كند و بليط را از بقيه داده‌ها جدا كند. كتابخانه‌اي هم با نام Kerberos key distribution Center service) kdcsvs.dll) روي سرور وجود دارد كه كاري مشابه Kerberos.dll به عهده دارد با اين تفاوت كه توابع لازم جهت دريافت بسته‌هاي ارسالي از كلاينت و بررسي اصالت بسته و ساختن پاسخ مناسب در جواب به درخواست كلاينت را در خود دارد.
همان‌طور كه گفته شد، كتابخانه‌ها به تنهايي قابل استفاده نيستند و لازم است برنامه ديگري از توابع كتابخانه استفاده كند. كتابخانه‌هاي سمت سرور و كلاينت كربروس نيز توسط برنامه ديگري فراخواني شده و مورد استفاده قرار مي‌گيرند. برنامه‌اي كه از كتابخانه‌ها استفاده مي‌كند خود يك برنامه دو بخشي است. (فرض كنيد دو فايل .exe كه از توابع همديگر استفاده مي‌كنند) يك بخش از اين برنامه Security reference monitor) srm) نام دارد كه جزء قسمت Executive ويندوز 2000 است (قسمت Executive ويندوز 2000 شامل برنامه‌ها و ماژول‌هاي سيستمي است كه داراي حقوق ويژه‌اي جهت دسترسي به تمام منابع سخت‌افزاري و نرم‌افزاري سيستم مي‌باشند) قسمت دوم اين برنامه local security authority subsystem) lsass.exe) نام دارد كه جزء قسمت Usermode ويندوز 2000 مي‌باشد كه با حق دسترسي كمتري نسبت به srm اجرا مي‌شود و شما مي‌توانيد آن را در task manager مشاهده كنيد. توجه داشته باشيد كه srm و lsass فقط جهت پياده‌سازي پروتكل كربروس در ويندوز 2000 قرار نگرفته‌اند بلكه اين دو برنامه لايه‌اي را فراهم مي‌كنند كه ويندوز2000 بتواند بدون هيچ‌گونه تنظيمات اضافي، در صورتي كه لازم باشد از پروتكل‌هاي ديگري (كتابخانه‌هاي امنيتي ديگري كه در سيستم وجود دارد) جهت تشخيص هويت استفاده كند. LSASS داراي دو سرويس با نام‌هاي winlogon و netlogon است كه توسط آن‌ها اطلاعات هويتي كاربر را مي‌گيرد. WINLOGON سرويسي است كه فرم welcome و پس از فشردن Alt+Ctrl+Del فرم درخواست نام كاربري و كلمه عبور و نام Domain را نشان مي‌دهد.

حال كه ساختار كلي كربروس را متوجه شديد قدم به قدم سناريويي كه ويندوز 2000 در هر بار ورود به Domain اجرا مي‌كند را دنبال مي‌كنيم:
‌● ‌winlogon پس از دريافت Alt+Ctrl+Del فرم ورود به ويندوز (Domain) را نشان مي‌دهد.

● نام كاربري، كلمه عبور، نام Domain را وارد مي‌كنيد و دكمه OK را كليك مي‌كنيد.

● ‌winlogon اطلاعات وارد شده توسط شما را گرفته و به lsass مي‌دهد. LSASS با استفاده از توابع موجود در كتابخانه kerberos.dll كلمه عبور وارد شده را با توابع درهم‌سازي (5 MD) از حالت عادي خارج مي‌كند و متن عادي كلمه عبور به سرعت از بين مي‌رود.

● چنانچه شما نام Domain را وارد نكرده باشيد روال تشخيص هويت توسط winlogon ادامه پيدا مي‌كند، ولي در اين‌جا فرض مي‌كنيم كه مي‌خواهيم وارد Domain شويم، لذا ادامه روال تشخيص هويت به netlogon منتقل مي‌شود. netlogon با استفاده از كتابخانه كربروس درخواست كلاينت را مي‌سازد. اين درخواست شامل: آدرس IP كلاينت، نام DC موردنظر، logon ID name و يك عدد تصادفي به نام nonce كه با استفاده از مقداري كه در مرحله قبل با اعمال توابع درهم‌سازي روي كلمه عبور كاربر توسط winlogon به دست آمده بود رمز شده است. كلاينت انتظار دارد سرور بتواند آن را (nonce) از رمز خارج كرده و مجدداً به كلاينت ارسال كند. البته باز هم به شكل رمز شده، و لذا هويت سرور به كلاينت اثبات مي‌شود. ضمناً سرور هم انتظار دارد كه با استفاده از كليد خصوصي كلاينت كه در Active Directory نگهداري مي‌شود، بتواند آن را از رمز خارج كند. Active Directory يك بانك اطلاعاتي (DB) براي نگهداري موجوديت‌هاي يك شبكه مي‌باشد.

● ‌netlogon پس از ساختن پيام با استفاده از DNS موجود در شبكه IP آدرس كامپيوتر Domain controller را به دست مي‌آورد و پيام ساخته شده را ارسال مي‌كند و سپس منتظر پاسخ مي‌شود.

● سرويس netlogon موجود روي سرور، درخواست بليط tgt كلاينت را مي‌گيرد و آن را به lsass مي‌دهد. lsass با استفاده از كتابخانه kdcsvc.dll موجود روي سرور نام كاربر را در Active Directory جستجو مي‌كند، چنانچه نام پيدا شود با استفاده از كلمه عبور آن كاربر كه در Active Directory ثبت شدهnonce را از رمز خارج مي‌كند و در ادامه پس از تشخيص اصالت پيام، DC در پاسخ به درخواست كلاينت، داده‌هاي زير را به آن ارسال مي‌كند.
1- فلگر مشخص‌كننده نوع پيام (بليطTGT)
2- داده‌هايي كه با استفاده از كليد كلاينت رمز شده كه شامل:
1- كليد نشست، تاريخ انقضاي كليد، تاريخ تشخيص هويت، زمان شروع و پايان استفاده از بليط، نام Domain كه بليط در آن معتبر است و nonce مي‌باشد.
3- بليط TGT (كه توسط كليدي كه در اختيارDC و سرورهاي موجود در شبكه member servers مي‌باشد، رمز شده است

●‌ سرويس كربروسِ سمت كلاينت، پيام را دريافت كرده و پس از بررسي‌هاي لازم و تشخيص اصالت پيام، شما وارد Domain مي‌شويد.
نتيجه اين روال تشخيص هويت، ورود شما به Domain و به دست آوردن بليط TGT مي‌باشد و در هر بار كه وارد Domain ويندوز2000 مي‌شويد اين روال طي مي‌شود.
بديهي است وقتي شما مي‌خواهيد به سروري كه در Domain قرار دارد دسترسي پيدا كنيد و از منابع آن استفاده كنيد، روالي كه در پروتكل كربروس شرح داده شده با استفاده ازlsass و كتابخانه‌هاي كربروس طي مي‌شود (پيام‌هاي 3 و 4 با DC و 5 و 6 با سرور موردنظر تبادل مي‌شوند) كه در اين‌جا به شرح مجدد آن‌ها نمي‌پردازيم.
پروتكل كربروس پروتكل پيش‌فرض تشخيص هويت در ويندوز 2000 مي‌باشد و براي استفاده از آن هيچ‌گونه تنظيماتي را نياز نداريم. با اين وجود در قسمت سياست‌هاي امنيتي (Domain Policy console) قسمتي با نام Policy Kerberos وجود دارد كه از طريق آن مي‌توانيد برخي از مشخصات بليط‌ها و به‌طور كلي پروتكل را تغيير دهيد. به عنوان مثال طول مدت عمر بليط، proxiable بودن بليط كه مشخص مي‌كند سيستمي به نمايندگي از صاحب اصلي بليط، بليط را استفاده مي‌كند (كلاينت A به سرور B دسترسي پيدا مي‌كند و در حين استفاده از B حالتي پيش مي‌آيد كه B براي پاسخ به A لازم است از سرور C استفاده كند در چنين حالتي B از بليط A استفاده كرده و به C وصل مي‌شود) و برخي ديگر از مشخصات بليط‌ها كه قابليت تنظيم دارند. توجه داشته باشيد كه اين تنظيمات به صورت پيش‌فرض تماماً مقاديري كه در استاندارد 1510RFC كربروس آمده است نيستند و مايكروسافت با توجه به پياده‌سازي خود، آن‌ها را تنظيم كرده است. همچنين ملاحظه كرديد كه در بسياري از موارد ديگر هم پياده‌سازي مايكروسافت با استاندارد ارايه شده متفاوت است از جمله يكي ديگر از اين تفاوت‌هاي مهم اين است كه در استاندارد ارايه شده از پروتكل udp استفاده مي‌شود ولي در ويندوز 2000 ازtcp استفاده مي‌گردد.

منابع:
1- Cryptography and network security
By: William Stallings
2- Inside windows 0002 server
by: William Boswell
3- windows 2000 network security design
by: Roberta Bragg, MCSE, MCT

پي‌نوشت:
(1) Security Service Provider Interface يا Security Support Provider Interface

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

یکشنبه، 23 مردادماه 1384

03:02 PM

August 14, 2005

نرم‌افزارهاي ساخت Flash

شريه عصر شبکه - اول خرداد ۱۳۸۴ شماره 7

اشاره :
در اين مقاله به طور مختصر چند نرم‌افزار ساخت و كار با فايل‌هاي فلش معرفي شده است.

نرم‌افزارهاي ساخت فلش
امروزه فلش، استانداردي جهاني براي ايجاد انيميشن‌بُرداري در وب به شمار مي‌رود. اين فرمت توسط شركت ماكرومديا ابداع شده است. نرم‌افزار Flash MX كه محصول شركت ماكرومديا است، اولين نرم‌افزاري است كه فايل‌هاي فلش
(با پسوند swf) توليد مي‌كند، ولي پس از آن شركت‌هاي زيادي شروع به توليد نرم‌افزارهايي براي ساخت فلش كرده‌اند، به‌طوري كه امروزه بيش از صد شركت برروي اين نرم‌افزارها فعاليت مي‌كنند. اكثر اين نرم‌افزارها به اندازه كافي شناخته شده نيستند. كساني كه كارشان طراحي سايت‌هاي وب است و نيز كساني كه به‌طور اتفاقي نياز به ساخت فايل فلش پيدا مي‌كنند، مي‌توانند با استفاده از اين نرم‌افزارها، كارهاي خود را بسيار سريع‌تر و راحت‌تر انجام دهند. حال به معرفي چند نرم‌افزار در زمينه ساخت و كار با فايل‌هاي فلش مي‌پردازيم:

Macromedia Flash (1
ساخت فايل‌هاي فلش با اين نرم‌افزار آغاز شده است. براي كار با آن بايد زباني به نام ActionScript آموخته شود كه مشابه زبان JavaScript است.

2) Adobe live Motion
كساني كه بيشتر با نرم‌افزارهاي شركت ادوبي كار مي‌كنند، شايد علاقمند باشند فايل‌هاي فلش خود را با اين نرم‌افزار ايجاد كنند، زيرا مي‌توانند از فايل‌هاي فتوشاپ و Illustrator و Golive نيز در پروژه خود استفاده كنند.

3) Swish Max
اين نرم‌افزار بسته‌اي ارزان‌تر و مناسب‌تر براي استفاده‌كنندگان غيرحرفه‌اي است. امكانات اين نرم‌افزار بسيار زياد است به‌طوري كه طراحان حرفه‌اي به همراه فلش، از اين نرم‌افزار نيزاستفاده مي‌كنند، زيرا بعضي از كارهاي ساده با اين نرم‌افزار، بسيار سريع‌تر انجام مي‌شود.

4) Swift 3D
اين نرم‌افزار با هدف تبديل اشياء سه بعدي به فرمت فلش ساخته شده و امكانات زيادي براي كمك به طراحان فلش دارد.

5) Kool Movies
اين نرم‌افزار با هدف ساخت فيلم‌ و كارتون‌ با فرمت فلش توليد شده است. طراحان اين نرم‌افزار، خود انيماتورهاي حرفه‌اي هستند. بنابراين اگر هدف شما ساخت نقاشي‌هاي متحرك كوتاه باشد، اين نرم‌افزار مناسب شما است. با اين نرم‌افزار مي‌توانيد جلوه‌هاي مخصوصي را كه با حركت ماوس ايجاد مي‌شوند، درست كنيد.

6) Anim FX
اين نرم‌افزار مخصوص ساخت متون متحرك است. ابتدا بايد متن مورد نظر را تايپ كنيد و سپس از انواع جلوه‌هاي موجود، جلوه مورد نظر خود را انتخاب كنيد. اگر هدف شما تنها ساخت يك نوشته متحرك است، اين نرم‌افزار شايد مناسب‌ترين گزينه باشد.

7) Dream FlashSee
با اين نرم‌افزار مي‌توانيد فايل‌هاي فلش swf خود را به فايل اجرايي exe تبديل كرده يا فايل‌هاي exe را به swf برگردانيد. مزيت فايل exe ساخته شده با اين نرم‌افزار آن است كه براي اجرا، نيازي به پخش‌كننده فايل فلش ندارد، يعني با اجرا كردن آن، فايل فلش به‌طور خودكار نمايش داده مي‌شود.

8) Flashation Menu Builder
براي ساخت دكمه‌ها و منوهاي فلش مي‌توانيد از اين نرم‌افزار بهره بگيريد. با اين نرم‌افزار مي‌توانيد منوهايي كاملاً حرفه‌اي براي وب‌سايت خود بسازيد.

9) SWF Encrypt
شايد براي ساخت فايل swf خود، زحمت زيادي كشيده‌ايد و نمي‌خواهيد ديگران بتوانند به اسكريپت‌هاي شما دسترسي پيدا كنند. اين نرم‌افزار، فايل فلش شما را طوري تبديل به رمز مي‌كند كه به راحتي و در همه جا قابل استفاده بوده و در عين حال، با نرم‌افزارهاي decompiler موجود در بازار، به كد تبديل نشود.

10) Swish Pix
اگر مي‌خواهيد يك آلبوم عكس بسازيد و از آن در وب سايت خود استفاده كنيد، اين نرم‌افزار در پنج مرحله ساده، اين‌كار را برايتان انجام خواهد داد. پس از اضافه كردن عكس‌ها به آلبوم مي‌توانيد صداها و كليپ‌هاي متنوعي به عكس‌هايتان بيافزائيد و نتيجه كار را با فرمت swf ذخيره كنيد.

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
دوشنبه، 24 مردادماه 1384

12:35 PM

August 15, 2005

آينده شبكه هاي بيسيم

ناشر: دنیای اقتصاد

با پيشرفت تكنولوژى و ساخت دستگاه‌‌هاى ارتباطى مختلف از تلفن معمولى گرفته تا دستگاه‌هاى ديگر هر روز نيازها گسترش يافته و همگام با آن نيز تكنولوژى پيشرفت كرده است.

نمونه بارز استفاده از بى‌سيم، بين نيروهاى پليس است كه اگر ديده باشيد هر پليسى يك سيستم بى‌سيم با خود همراه دارد، يا در جنگ‌ها بى‌سيم نقش بسيار مهمى را بازى مى‌كند، در جنگ همان مقدار كه ارتباط بى‌سيم مهم است خطرناك نيز هست. به اين ترتيب شايد بتوان گفت تقريبا يكى از بى‌امنيت‌ترين سيستم‌ها بى‌سيم است كه شما مى‌توانيد با داشتن تنها فركانس شخص مورد نظر مكالمات آنها را كنترل كنيد.

اين يعنى عدم امنيت، مشكلى كه در تمام شبكه‌هاى بى‌سيم چه بى‌سيم صوتى و چه ارتباط اطلاعاتى مثل كامپيوتر وجود دارد. با اين تفاوت كه نفوذ به يك شبكه بى‌سيم كامپيوترى كمى مشكل‌تر از شبكه بى‌سيم صوتى است.

انواع شبكه‌‌هاى بى‌سيم ‌Point to point

شبكه‌هاى بى‌سيم به 2نوع كلى تقسيم مى‌شوند Point to point . يكى از اين شبكه‌ها است.

در شبكه‌هاى point to point، بيشتر براى استفاده از سرويس‌ اينترنت مورد استفاده قرار مى‌گيرد به صورتى كه مثلا ساختمانى كه در آن قرار داريد با نصب يك دكل چندمترى و نصب 2ديش كوچك كه يكى از آنها در محل شما و ديگرى در محل ISP قرار مى‌گيرد و اين دو دقيقا رو به يكديگر هستند شما مى‌توانيد از اينترنت پرسرعت استفاده كنيد.

در ايران تقريبا اكثرISP ها اين خدمات را به مشترى‌هاى خود ارائه مى‌‌كنند. لازم به ذكر است اين نوع شبكه‌ها در دماى 50درجه سانتيگراد از كار مى‌افتند. اين سرويس‌ها بيشتر مورد استفاده شركت‌هاى دولتى بوده و براى يك كاربر خانگى كاربرد چندانى ندارند.

شبكه‌‌هايWi-Fi

شبكه‌‌هاى Wi-Fi برخلاف point to point احتياج به ديد مستقيم ندارند و مانند بى‌سيم‌هاى معمولى عمل مى‌كنند. اين سرويس‌ها 2كاربرد دارند يعنى هم شما مى‌توانيد شبكه داخلى خود را به وسيله Wi-Fi طراحى كنيد و هم اين كه از سرويس اينترنت در اين شبكه‌ها استفاده كنيد كه البته كاربرد اينترنت در حال حاضر براى ما مهم‌تر است. با اين كه اين شبكه نيازى به ديد مستقيم ندارد اما برد محدودى دارد مثلا تا 100متر اطراف خود را پوشش مى‌دهد. اين مشكل به وسيله دستگاهى به نام accesspoint حل شده كه مانند يك دستگاه دريافت و ارسال دو در اطراف ISP نصب مى‌شود. نوع ديگر شبكه‌هاى Wi-Fi سيستم Wimax است.

Wimax دقيقا به صورت سيستم Wi-Fi عمل مى‌كند با اين تفاوت كه Wi-Fi فقط در محدوده يك شهر قابليت كار داشته ولى Wimax امكان ارتباط با برد بسيار وسيع مثلا خطوط بين شهرى را داراست و ISP ديگر مجبور نخواهد بود تا تعداد زيادى اكسز پوينت خريدارى كند.

وضعيت Wi-Fi در ايران‌

تجربه نشان مى‌دهد، خطوط بى‌سيم در كشورهاى پيشرفته مثل آمريكا موفق نبوده با اين حال مخابرات ايران بدون درس گرفتن از اين ماجرا باز هم مى‌خواهد تا روى امكانات اينترنت بى‌سيم سرمايه‌گذارى كند. البته چندى پيش شركتى به نام Tehranweb اقدام به نصب تجهيزات بى‌سيم در تهران و چند شهر ديگر كرد كه متاسفانه با استقبال خوبى مواجه نشد و اين طرح با شكست مواجه شد.

در حال حاضر در تهران فقط شركت داتك اقدام به ارائه سرويس Wi-Fi كرده است. البته چند شركت ديگر نيز براى دريافت مجوز ارايه خدمات اينترنت بى‌سيم ثبت‌نام كرده‌اند.

طريقه استفاده از اين سرويس در تهران‌

هم متاسفانه و هم خوشبختانه در ايران صف دريافت اينترنت Wi-Fi از صف بزرگ‌ترين نانوايى‌ها هم شلوغ‌تر است. شما بايد براى استفاده و دريافت اين سرويس ابتدا به شركت مورد نظر خود (فعلا فقط داتك) مراجعه كرده نوع سرويس و منطقه سكونت خود را مشخص كنيد. تا پس از گذشت مدت نه چندان كوتاهى، سرويس در اختيار شما قرار مى‌گيرد.

كارت‌هاى ارتباطى به شبكه اينترنت Wi-Fi را نيز مى‌توانيد از همان شركت خريدارى كرده يا آن را به‌صورت امانت دريافت كنيد. لازم به ذكر است اين سرويس فعلا در برخى نقاط تهران راه‌اندازى شده است.

شكى نيست كه امكانات Wi-Fi گسترش خواهند يافت و به‌صورت گسترده در اختيار تمام مردم قرار خواهند گرفت و در نهايت همه از اينترنت پرسرعت بهره خواهيم برد. ولى تا آن زمان اين تكنولوژى را مى‌توان در اماكن عمومى مثل هتل‌ها، فرودگاه‌ها و ... در دسترس داشت. آخرين پيشرفت‌ها از دنياى Wi-Fi حاكى از آن است كه مردم در هواپيما، زير زمين و حتى در هنگام حركت با سرعت‌هاى بسيار بالا نيز مى‌توانند از آن بهره ببرند. اما تا وقتى كه اين تكنولوژى در ايران به صورت گسترده مورد استفاده قرار گيرد راه‌ درازى در پيش است

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 27 مردادماه 1384

10:49 AM

August 18, 2005

پورتال چیست؟

نويسنده : حمید مشرف (با اقتباس از Portal Solutions Redbook IBM )
ناشر: همکاران سیستم

پورتال چیست؟

نام پورتال ها را زیاد شنیده ایم، اما شاید برای برخی از ما این سئوال پیش آمده باشد که واقعا یک پورتال چیست؟ چه ویژگیها و خصوصیاتی دارد؟ و چه تفاوتی با یک وب سایت دارد؟ ترجمه کلمه Portal به فارسی در فرهنگهای لغت "دریچه"، "درگاه" و "مدخل" ذکر شده اما کلمه پورتال در تکنولوژی اطلاعات معنی متفاوتی دارد. اگر بخواهیم ساده بگوییم، پورتال صفحه وب واسطی است که امکان دسترسی آسان را به هر چیزی که کاربر ، برای انجام وظیفه یا خواسته اش نیاز دارد – بدون توجه به اینکه محل فیزیکی آن کجاست، فراهم می کند. به بیان دیگر پورتال "درگاهی" است به دنیایی مجازی که کاربر می تواند از طریق امکانات فراهم شده در آن، تمامی نیازهای خود را براورده کند. نیازهایی مانند جستجو و یا خرید(مثلا یک کتاب)، دسترسی به حساب بانکی، افزایش و کاهش اعتبار یک حساب اعتباری و یا به روز رسانی اطلاعات سخت افزاری از محل کار، پورتال همه چیز را از طریق درگاهی واحد برای کاربر خود فراهم می سازد.

ویژگیهای اصلی یک پورتال عبارت اند از:

  1. تجمع اطلاعات

  2. هدف دار بودن اطلاعات

  3. دردسترس بودن اطلاعات

  4. دریچه ورود منحصر به فرد

یک پورتال نیز مانند یک کامپیوتر خانگی، اطلاعات و خدمات گوناگونی را در یک صفحه وب واحد و به صورتی سازگار و خوش ترکیب در دسترس می گذارد. گاهی به این صفحه web top هم گفته می شود. پورتال می تواند نقطه شروع یا صفحه اولیه مشخصی داشته باشد که کاربران در زمان اتصال به وب آن را مشاهده کنند. اگر چه بر خلاف صفحه کامپیوتر، پورتال می تواند از طریق مجموعه وسیع دستگاههایی که قابلیت اتصال به وب در آنها پیش بینی شده (از جمله تلفن های موبایل) مورد استفاده قرار گیرد.

هر چند شباهت ظاهری فراوانی میان یک وب سایت و یک پورتال وجود دارد به گونه ای که در نگاه اول تفاوت محسوسی میان آن دو مشاهده نمی شود اما این دو کاملا از یکدیگر متفاوت اند.سوال اینجاست که به طور مشخص تفاوت آن دو در چیست؟ در پاسخ به این سوال باید گفت ویژگیهای زیر در یک پورتال آن را از یک وب سایت متمایز می کند:

  1. درگاه ورود منفردی که از طریق آن می توان به مجموعه منابع مرتبط با پورتال دست یافت.

  2. نمایش هدفدار اطلاعات با استفاده از تجربیات کاربر.

  3. دسترسی تقسیم بندی شده به انواع داده و اطلاعات گروه بندی شده.

  4. در اختیار گذاشتن امکان ارتباط و همکاری میان تمامی کاربران و استفاده کنندگان پورتال.

  5. امکان پیوستن به نرم افزارها و سیستم های نرم افزاری که گردش کاری مشخص و تعریف شده ای دارند.

تاریخچه خلاصه پورتال

اگر در دنیای کامپیوتر به عقب بازگردیم، زمانی را خواهیم یافت که در آن سیستم های نرم افزاری به گونه ای متحول شدند که دیگر لازم نبود برای کار با یک برنامه، برنامه های دیگر بسته شوند، یعنی می توانستیم همزمان از چند برنامه کاربردی استفاده کنیم بدون آنکه با مشکلی مواجه شویم.امکانی که قبل از آن وجود نداشت. تاریخچه پورتال ها از همان زمان آغاز شد و نسلهای تکامل یافته آنها یکی پس از دیگری پا به عرصه دنیای اطلاعات گذاشتند.

نسل اول پورتال ها :

اولین پورتال ها، که از آنها تحت عنوان نسل اول نام برده می شود، بر فراهم نمودن محتویات ایستا، مستندات و همچنین خوراکهای اطلاعاتی زنده در صفحات وب مبتنی بودند. مثالهای نمونه این نسل سایت های yahoo یا Excite است. این پورتالها در محیطی به هم پیوسته، اهداف مشابهی را دنبال کرده و صفحه واسط مشخص و منحصر به فردی را برای دستیابی به مجموعه اطلاعات توزیع شده در سراسر شرکت یا سازمان خود، در اختیار کاربر می گذاشتند. این اطلاعات معمولا شامل اخبار شرکت، شرایط و فرم های استخدام، اطلاعاتی مربوط به کارکنان و چگونگی ارتباط با آنها، مستندات رسمی و سیاست های اعلام شده شرکت و همچنین لینک های ارتباطی مفید بود.

نسل دوم پورتال ها :

نسل دوم پورتال ها بر اطلاعات مشخص تر و نرم افزارها متمرکز بودند. در اساس شباهت زیادی به خصوص در زمینه فراهم آوردن اطلاعات با نسل اول داشتند با این همه تفاوت مهمی نیز وجود داشت: این پورتالهای امکان همکاری کاربران را در محیطی به هم پیوسته فراهم می کردند و همین امکان، نقطه تمایز آنها با نسل پیشین محسوب می شد.

پورتال های نسل دوم قابلیت همکاری متقابل را در ادارات مجازی برای تیم های کاری و به منظور انجام وظایفشان فراهم می ساختند. نسل دوم پورتال ها سرویس های متعددی داشتند که از جمله آنها می توان به سرویس های مدیریت محتوی ( سازمان دهی و مدیریت اطلاعات مرتبط ) و سرویس های همکاری (که به کاربران امکان می داد با یکدیگر گپ زده و برای یکدیگر ایمیل فرستاده و قرار ملاقات تنظیم کنند) اشاره کرد. در این پورتال ها قابلیت تعریف گروه های کاربری نیزفراهم آمده بود. به بیان دیگر این پورتال ها سازو کار همکاری داخلی را در یک سازمان فراهم می ساختند.

نسل سوم پورتال ها :

نسل سوم با هدف ایجاد فضای مجازی تجارت الکترونیک (E-Business ) بوجود آمد. پورتال های نسل سوم به عنوان واسط ارتباطی کارمندان، تهیه کنندگان، تولید کنندگان و مشتریان قلمداد می شوند. ویژگی فوق العاده این پورتالها امکان مرتبط شدن نرم افزارهای مستقر در سرورهای مختلف است. به بیان دیگر، این پورتال ها نقطه به هم پیوستن محتویات و برنامه های کاربردی مستقر در سرورهای مختلف بطور همزمان و با استفاده از همکاری سرویسهای خدماتی آنان اند. به علاوه امکان دسترسی به محتویات و امکانات سیستمهای مختلف را از طریق ابزارها و تجهیزات متنوع، بسته به نیاز کاربر امکان پذیر می کنند. این گروه پورتال ها مجموعه قابل توجه و ارزشمندی از اطلاعات، مستندات، امکانات و قابلیتهای نرم افزارهای مرتبط را از طریق درگاه واحدی برای کاربر فراهم می کنند.

به علاوه، این پورتالها به صورتی خودکار و بر اساس نقش کاربران هدفمند شده و ویژگیهایی خاص آنها می یابند. به بیان دیگر، نحوه نمایش، محتوی و امکانات در دسترس، بسته به نقش تعریف شده برای کاربر به گونه ای منحصر به فرد و خاص وی در اختیار او قرار می گیرد. کلید توسعه آینده این نسل از پورتال ها،ایجاد چهارچوب های کاری باز ( از قبل تعریف نشده ) برای سرویس های عمومی خواهد بود.

انواع پورتال ها

یک سازمان مجموعه متنوعی از کاربران دارد که از جمله آنها می توان به مشتریان، شرکا، کارمندان اشاره کرد. همه این کاربران علاقه مندند از اطلاعات و خدمات آن سازمان استفاده کنند. کاملا آشکار است که هر کدام از آنها نیازهای خاص و اغلب متفاوتی دارد. برای پاسخگویی به این تنوع، انواع مختلف پورتال ایجاد شده و مورد استفاده قرار می گیرد. به طور کلی بر حسب چگونگی پاسخگویی به نیازهای کاربران، پورتال ها را می توان در چهار گروه زیر دسته بندی کرد:

Business to Customer Portal (B2C)

این نوع از پورتال با سیستمهای CRM [1] مرتبط بوده و دسترسی مستقیم مصرف کننده را به مجموعه وسیعی از اطلاعات و خدمات فراهم می کند – برای مثال، اطلاعاتی مانند "راهنمای استفاده از محصولات" و "وضعیت سفارش مشتری " در خرید های خود و همچنین امکانات ارتباطی کاربر با بخش پشتیبانی مشتریان در این پورتال ها پیش بینی می شود. مانند هر پورتال دیگری، یک پورتال B2C معمولا در قد و قواره ای ارائه می شود که نیازهای مشتریان خود را پاسخ دهد.

Business to Business Portal (B2B)

نوع دیگر پورتال در زنجیره مدیریت منابع شکل می یابد[2]. در این نوع پورتال اطلاعات لازم برای تولید کنندگان،تهیه کنندگان، نمایندگی ها و همچنین توزیع کنندگان، به گونه ای مناسب و دسته بندی شده جمع آوری و در اختیار آنان قرار می گیرد. نمونه عمومی پورتال B2B - برای مثال، یک شریک تجاری را قادر می کند تا به بخشهایی از اطلاعات و امکانات مانند سفارش خرید و صدور فاکتور دسترسی داشته و از امکانات این بخشها استفاده کند. به هم پیوستن برنامه های کاربردی یکی از پیشنیازهای لازم برای یکپارچه سازی محیط های تجاری در بستری واحد و ایجاد محیط مجازی لازم برای کسب و کار است. محیطی که در آن امکان تهیه کالا یا خدمات، صدور صورت حساب خرید و فروش، دسترسی به اطلاعات تولید و دیگر امکانات مرتبط با نیازها فراهم می اید.

B2E

این پورتال ها که اغلب با عنوان پورتال های اینترانتی شناخته می شوند معمولا به منظور تجمیع، انتشار و به اشتراک گذاری اطلاعات و خدمات به پرسنل یک سازمان ایجاد می شوند. B2E ها به دو دسته اصلی تقسیم می شوند:

· پورتالهای کارکنان که امکان دسترسی به محتویات به هم پیوسته ای مانند اخبار شرکت، اطلاعات سخت افزاری و نرم افزاری، موتور جستجو و منابع فنی و گزارشها را در اختیار می گذارد. اطلاعات این نوع پورتال معمولا در دسترس همه کارکنان یک سازمان قرار می گیرد. این پورتال کارکنان و شاغلین یک سازمان را قادر می کند تا از طریق گپ و گروههای گفتگو با یکدیگر در تماس بوده و با یکدیگر همکاری کنند. عموما، این پورتال ها امکاناتی نظیر ثبت نام در یک کلاس و یا یک اردو را نیز در اختیار کاربر خود قرار می دهند. به علاوه کاربران این پورتال معمولا می توانند اطلاعات شخصی خود مانند نام و کلمه عبور را تغییر دهند.

· Knowledge worker portal که با یک یا مجموعه اهداف مشخص مثلا فروش یک محصول ایجاد می گردد. این پورتال ها مجموعه ای از محتویات را به منظور پشتیبانی از فرآیند یا فرآیندهای مشخصی در اختیار می گذارند. برای مثال یک برنامه تکنسین خودکار ممکن است نیازمند منابعی از برنامه های کاربردی دیگر مثلا برنامه های تعمیر و نگهداری باشد تا بتواند اطلاعات لازم در زمینه تاریخچه بازبینی و تعمیر، زمان بندی تجهیز و یا قطعات و لوازم مورد نیاز برای تعمیر آن را کسب کند.

پورتال های عمومی ( Mega Or Public Portal )

این پورتال ها با عنوان پورتال های اینترنتی شناخته می شوند و مهمترین ویژگی آنها فراوانی مخاطبانشان است. این نوع از پورتال ها نیز در دو گروه دسته بندی می شوند:

· پورتال های عمومی که تمامی کاربران اینترنت را مخاطب قرار می دهند (برای مثال Yahoo ، Excite، Google و مانند آن)

· پورتال های خاص ( صنعتی، بازرگانی، خدماتی ) که به آنها پورتال های عمودی نیز گفته شده و مخاطبان محدود و مشخصی دارند ( مانند پورتال های بانکها، سازمانهای دولتی، وزارتخانه ها و ... )

باید توجه داشت که یک پورتال می تواند از پیوند انواع پورتال های دیگر ایجاد شود. به علاوه همانطور که یک سازمان کاربران متنوعی دارد، می تواند ( و گاهی نیز لازم است ) که پورتال های مختلفی برای پشتیبانی از نیازهای آنان داشته باشد.

جنبه های کارکردی یک پورتال

اگر چه پورتال ها در انواع و اندازه های متنوعی ساخته می شوند اما ویژگیهای محدود و مشخصی هسته اصلی آنها شناخته می شود:

v هر پورتال اطلاعات و خدمات را یکجا و در یک محل جمع آوری می کند.

v هر پورتال می تواند در اندازه لازم برای شخص و یا گروه سازمان دراید.

v هر پورتال در هر زمان و از هر مکانی قابل دسترس است.

یک پورتال مجموعه اطلاعات و خدمات را یکجا و در یک محل جمع آوری می کند

هدف اصلی فراهم آوردن امکان دسترسی آسان به هرچیزی ( اطلاعات و خدمات ) است که یک کاربر برای انجام وظایف و مسئولیتهایش به آن احتیاج دارد، صرف نظر از اینکه منبع آن کجا باشد.

اطلاعاتی که یک پورتال فراهم می کند

v داده های ساخت یافته. داده هایی که به صورتی سازمان یافته اند که امکان جستجوی آسان آنها وجود داشته باشد ( اغلب به صورت سلسله مراتب و بر اساس کلمات کلیدی). فهرست الفبایی کتابهای یک کتابخانه مثال خوبی از داده های ساخت یافته است. داده های ساخت یافته اغلب شامل، گزارشها، تحلیلها، پرس و جوهای مشخص و دیگر انواع دانش مرتبط با کسب و کار است.

v داده های بدو ن ساختار، که جستجو در آنها معمولا دشوار بوده و خارج از یک بانک اطلاعاتی قرار دارند. از این نوع داده می توان متن ها، صوت، تصویر و یا گرافیک و اشکالی مانند مستندات Office ، memos ، ایمیل، قرارهای ملاقات را مثال زد.

v اطلاعات خاص [3] ،که شامل محتویات قابل خرید و فروش ( مثل انواع اخبار، گزارشها، اطلاعات مربوط به سهام، کاریکاتورها و محتویات بی اهمیت) بوده و مخصوصا به منظور استفاده در فرایندهای تولیدی دیگر تهیه و در اختیار قرار می گیرند.

خدماتی که به وسیله یک پورتال فراهم می شود

· همکاری، (با عنوان خدمات ارتباطی نیز شناخته می شود ) و به کاربران اجازه می دهد تا با یکدیگر گپ بزنند، در بحثهای گروهی مشارکت داشته باشند، مطالب خود را در اختیار دیگران قرار دهند و...

· مدیریت محتوی که انواع جستجو ها، رهگیریها را مدیریت کرده و همچنین قابلیتهای خاصی را به منظور استخراج داده ها در اختیار می گذارد.

· خدمات شخصی (با عنوان خدمات تراکنشی نیز نام برده می شود ) که کاربران را قادر می سازد تا با دیگر سیستمها ( مثلا سیستمهای فروشنده و یا نماینده یک محصول ) مستقیم و بدون واسطه مرتبط باشند. معمولا این قابلیت به کاربر امکان می دهد تا برای مثال فعالیتهای زیر را انجام دهد:

- محصولات یک سازمان را خریداری کند

- ملاقاتهای خود را زمان بندی کند

- حساب خود را مشاهده یا تراز کند

- در کلاس مورد علاقه خود ثبت نام کند

هر پورتال می تواند در اندازه لازم برای شخص و یا گروه سازمان دراید.

یکی از ویژگیهای جالب یک پورتال شکل و عملکرد متفاوت آن برای اشخاص مختلف است. یکی از روشهایی که به این منظور استفاده می شود، متناسب سازی و تغییر شکل و قابلیتهای پورتال بر حسب خواسته ها یا تجارب شخص یا گروه استفاده کننده از آن است. به همین دلیل است که کاربران متفاوت شکل متفاوتی از یک پورتال مشاهده کرده و اطلاعات و خدمات متفاوتی در اختیار ایشان قرار می گیرد:

  • امکان تغییر بر حسب خواسته ها بر حسب تجارب شخص یا گروه عموما personalize نامیده می شود و به این معنی است که در پورتال امکان انتخاب نحوه نمایش محتوی پیش بینی شده است. اغلب این انتخاب بصورت خودکار و بر اساس نقش کاربر (مثلا پست سازمانی وی) انجام می شود. برای مثال وقتی کارمند فروش به سیستم وارد می شود، به صورت خودکار فهرستی از جدیدترین محصولات برای وی به نمایش در می آید. با این همه در بعضی از پورتال ها انتخاب محتوی نمایش داده شده به کاربر محول می شود تا در زمان ورود به پورتال خود آن را انتخاب کند.

  • تغییر و Customize شدن یک پورتال شامل انتخاب چگونگی شکل ظاهری آن (مثلا رنگ و چیدمان صفحه)،مدل مرورگر و محل نمایش محتویات روی صفحه است. یک پورتال می تواند حتی برچسب و عنوان تجاری مشخصی داشته و ظاهر متفاوتی را برای انواع کاربرانش به نمایش گذارد.

این دو ویژگی به پورتال امکان می دهد تا مجموعه مشخص و تعریف شده ای از کاربران (مثلا مشتریان، شرکا و یا کارکنان) را هدف قرار دهد. بعضی از پورتال ها حتی می توانند برای هر کاربر مشخص، شکل و شمایل متفاوتی از خود نشان دهند.

یک پورتال در هر زمان و از هرمکانی همیشه در دسترس است

از آنجا که پورتال ها برای استفاده در محیط وب ساخته می شوند، در هر زمان و از هر مکانی با استفاده از یک مرورگر استاندارد وب در دسترس اند. انواع تجهیزات مبتنی بر وب نیز از جمله تلفنهای موبایل، دسترسی به پورتال ها را به غایت آسان و مفید کرده اند.

[1] Customer Relationship Management

[2] Supply Chain Management

[3] Syndicate content

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 27 مردادماه 1384

11:07 AM

August 18, 2005

فلسفه اپن سورس

ترجمه : مسعود سعيدي
ماهنامه شبکه - آبان ۱۳۸۳ شماره 48

اشاره :
موضوع اپن‌سورس (Open Source) و موضوع نرم‌افزار آزاد رايگان (Free)، موضوعات پيچيده‌اي نيستند. اما هرچه بيشتر در اين مورد مطالعه مي‌كنيم متوجه وجود لايه‌هاي عميق‌تري مي‌شويم و هرچه پايين‌تر مي‌رويم، موضوع، رنگ و بوي فلسفي بيشتري به‌خود مي‌گيرد. مصاحبه‌اي كه با اريك ريموند ترتيب داده شده است و ترجمه آن را در ادامه مي‌خوانيد، به‌خوبي عمق بحث فلسفه منبع‌باز (اپن‌سورس) را نمايان مي‌سازد. در اين مصاحبه علاوه‌‌‌بر بررسي چند و چون فلسفه منبع‌باز، به جريانات تجاري كه حول و حوش اپن‌سورس شدن تكنولوژي جاوا ميان شركت‌هاي سان و IBM برقرار است، اشاره مي‌شود و موارد ديگري مانند جريان SCO و موضوع مذاكرات بين سان و مايكروسافت نيز مورد نظر قرار مي‌گيرند. بسياري از كاربران و خصوصاً برنامه‌نويسان و علاقمندان به نرم‌افزارهاي منبع‌باز، Eric Raymond را مي‌شناسند. اما اگر بخواهيم او را براي آن گروهي از خوانندگان كه تا اين لحظه نام او را نشنيده‌اند معرفي كنيم، مي‌توانيم او را بنيانگذار جنبش منبع باز و يا حداقل يكي از پيشروترين افراد فعال در اين جنبش نرم‌افزاري بناميم. در اين ارتباط در متن مصاحبه‌ موارد دقيق‌تري را خواهيد خواند. اما به‌جهت معرفي اريك ريموند از زاويه ديگر، مي‌توانيم به بخشي از اتوبيوگرافي او به‌نقل از سايت شخصي وي به‌نشاني /www.catb.org/esr كمك بگيريم. اريك ريموند ضمن فعاليت و تحقيق در روابط انساني جامعه و فرهنگ هكر اينترنتي، به‌عنوان يك فرد ناظر در اجتماع هكرهاي اينترنتي شناخته شده است. تحقيقات او روشنگر موفقيت‌هاي چشمگير مدل توسعه نرم‌افزار منبع‌باز بوده است. در فهرست پروژه‌هاي نرم‌افزاري ريموند، علاوه بر كار بر روي سيستم‌عامل يونيكس، نام يكي از پركاربردترين نرم‌افزارهاي انتقال اطلاعات از طريق پست‌الكترونيك نيز ديده مي‌شود. ريموند علاوه بر فعاليت در حوزه‌هاي نرم‌افزارهاي منبع‌باز، علاقمندي‌هاي ديگري نيز دارد و يكي از طرفداران پروپا قرص ادبيات علمي تخيلي نيز هست. ريموند ضمن داشتن درجه و عنوان كمر‌بند مشكي در ورزش رزمي تكواندو، يك نوازنده ماهر و موسيقي‌دان نيز هست. اما واقعيت آن است كه هيچ يك از موارد فوق در زندگي اريك ريموند به اندازه نقش او در به جريان انداختن جنبش منبع‌باز اهميت نمي‌يابند و افراد بسياري به‌درستي او را يك انسان‌شناس سرگردان و فيلسوف درد‌سرساز مي‌دانند كه بر حسب تصادف، در زمان مناسب در موقعيت درستي قرار گرفته است. مصاحبه‌كننده يعني خانم Terri Wells نيز يكي از آشنايان ريموند است كه سابقه آشنايي آن‌ها به سال‌ها قبل از آن‌كه اريك به شهرت برسد باز مي‌گردد. ضمناً لا‌زم به ذكر است كه در كلا‌م ريموند، هكر نه به معناي متداول آن بلكه به متخصصان خبره كامپيوتر اطلا‌ق مي‌گردد.

‌• از آن دوران و روزگاري كه به عنوان يك برنامه‌ساز چيره دست (geek) كار مي‌كرديد صحبت كنيد. چطور شد كه در اين مسير قرار گرفتيد؟
‌‌‌• تقريباً همه چيز از زماني آغاز شد كه من سعي مي‌كردم برنامه‌نويسي ميني‌كامپيوترهاي اواسط دهه 70 را بياموزم. واقعيت آن است كه من قبل از آن‌كه برنامه‌نويس بشوم، به سيستم‌عامل يونيكس علاقه زيادي داشتم. من مطالعه مقالات اوليه تامپسون و ريچي كه در نشريه Communication of the ACM چاپ مي‌شد و پدرم مشترك آن بود، را خيلي زود شروع كرده بودم. اين موضوع كه من چطور بدون آن‌كه برنامه‌نويسي بدانم، شروع به مطالعه اين جور مقالات كرده بودم، روحيات من را بهتر نمايان مي‌سازد. من هنوز هم همين جوري هستم و يك جانور همه‌چيز خور(Omnivorous) محسوب مي‌شوم.
تقريباً يك سال بعد از اين جريان، من شروع به يادگيري برنامه‌نويسي كردم. سال 1976 را تاريخي مي‌دانم كه مي‌توانم از آن به عنوان تاريخ پيوستن به جامعه هكر‌ها ياد كنم. اين سال، سالي بود كه من با Jargon File آشنا شدم .
(Jargon File عنوان مجموعه‌اي از اصطلاحاً هكر‌ها و برنامه‌نويسان است كه در ابتدا شكل و صورت كتبي داشته است و بعدها بر روي شبكه‌هاي كامپيوتري دانشگاهي و نهايتاً اينترنت قرار گرفت - مترجم). جالب است كه يادآوري كنم كه درهمان سال اول، من بيش از 60 مورد در اين مجموعه ثبت كرده بودم!

‌• در چه زماني متوجه شديد كه شما مسيري فراتر از يك خبره برنامه‌نويس را طي كرده‌ايد و در جايگاه چيزي شبيه يك انسان‌شناس جامعه هكر و فرهنگ‌ آنها قرار گرفته‌ايد؟ و اين موقعيت بر زندگي شما به عنوان يك هكر چه تاثيري داشته است؟
‌• واقعيتش را بخواهيد، من اين وضعيت را از مدت‌ها پيش احساس مي‌كردم. در واقع در سال 1990 يعني زماني كه واژه‌نامه New Hackers Dictionary براي نخستين بار منتشر شد، من چنين احساسي داشتم. در آن زمان چه كسي مي‌‌توانست حدس بزند كه اين كتاب سرآغازي بر كل جريان منبع‌باز محسوب خواهد شد و در حقيقت چرخ‌هاي جنبش منبع‌باز را به‌حركت در خواهد آورد؟

‌• در مورد پيشرفت‌ها و موفقيت‌هاي خود بگوييد، به كداميك از آنها به عنوان يك افتخار ياد مي‌كنيد؟
‌• خوب، من به‌نوعي موجبات بيداري جامعه هكرها را فراهم آوردم و كمك كردم تا اين اجتماع ضمن شناختن خود، جهان را از نو اختراع كند. من اين‌كار را دو‌بار انجام دادم. يك‌بار با انتشار <واژه‌نامه جديد هكر> و يك‌بار با انتشار كتاب ديگرThe Cathedral and the Bazaar. من به اين موارد افتخار مي‌كنم. من نيازي به تشريح بيشتر آنكه چرا به اين موارد افتخار مي‌كنم، نمي‌بينم.

اپن‌سورس
‌• چطور شد كه شما اصطلاح Open source را مطرح كرديد؟ چرا تنها به اصطلاحي مانند Free software اكتفا نكرديد؟
‌• بهترين پاسخ به اين پرسش را مي‌توانيد با رجوع به يكي از نخستين كارهاي من كه در سال 1998 به‌نگارش درآمد، بيابيد. اين نوشته را مي‌توانيد در نشاني زير ببينيد:
 http://www.catb.org/esr/open-source.html

‌• به نظر شما بزرگ‌ترين تفاوت‌ نرم‌افزارOpen source و نرم‌افزارهاي موسوم به Free Software در چيست؟
‌• تفاوتي در كار نيست. در واقع نرم‌افزارهاي اين دو گروه تفاوتي با يكديگر ندارند. كاربران، مجوز‌ها و ابزارها در هر دو مورد مشابه هستند.
اگر قرار باشد بين نرم‌افزار open source و نرم‌افزارهاي Free Software تفاوتي وجود داشته باشد، چنين تفاوتي در روش تبليغ و گرايش‌هاي عرضه‌كنندگان آن‌ها نهفته است. در واقع كاركرد شما به عنوان عرضه كننده نرم‌افزار تفاوتي نمي‌كند، تفاوت در روش بيان شما نهفته است.

‌• احساس شما نسبت به مجوز‌هاي نرم‌افزاري از نوع BSD چيست؟ ليسانس‌هايي كه به كاربر اجازه مي‌دهد تا از حاصل كار ديگران استفاده كرده، آن‌را به هر صورت دلخواهي تغيير داده و مجدداً عرضه كند، بدون آن‌كه هيچ‌گاه ناگزير به بازپرداخت باشد؟
‌• اعتقاد من آن است كه چنين كاربري در بلند‌مدت، سودي نصيبش نخواهد شد. زماني‌كه شما از چنين روشي استفاده كنيد، هيچ‌گاه نخواهيد توانست با گرد هم آوردن گروه كوچكي از برنامه‌نويسان با تعداد بسيار بيشتري از برنامه‌نويسان جامعه منبع‌باز رقابت كنيد.
ممكن در كوتاه مدت تصور شود كه چنين مكانيسمي جواب مي‌دهد. اما همان‌طور كه گفتم، اين روش پاسخگو نيست. به اين صورت كه ممكن است چنين شركتي موفق شود با سرمايه‌گذاري و با خرج كردن پول زيادي در راه تبليغات و بازاريابي و پرداختن دستمزد و موارد ديگر، موفق به جا انداختن محصول خود شود، اما در همين زمان سيستم جهاني منبع‌باز به‌صورت يك بازخورد طبيعي نسخه منبع‌باز همان محصول را عرضه خواهد كرد كه توسط هزاران برنامه‌نويس داوطلب از سراسر دنيا تهيه شده است. چنين محصولي با قيمت بسيار پايين‌تر، كيفيت و قابليت‌هاي بيشتري خواهد داشت.
من تصور مي‌كنم كه اهميت مجوز‌هاي نرم‌افزاري نوع GNU copyleft ، بيش از آن‌كه به تأثير بر اقتصاد و روابط رقابتي بازار مربوط باشد، به‌جهت نمايش جلوه‌اي از انتظارات جامعه برنامه‌نويسان اهميت مي‌يابد.

‌• تعداد قابل توجهي از تكنولوژي‌هاي نرم‌افزاري بر پايه محصولات منبع‌باز شكل گرفته‌اند (خواه به‌دليل قيمت و هزينه‌ها، و خواه به‌دليل كيفيت يا چيزهاي ديگر). زماني ريچارد استالن گفته بود كه اگر بهترين نرم‌افزار را توليد كنيم اما كسي علت و چرايي آن را نداند، آن‌گاه بازنده‌ايم. از طرف ديگر درصورتي‌كه نرم‌افزار ما فراموش شده باشد، اما ايده‌هاي نهفته در آن هنوز زنده باشند، آن‌گاه برنده محسوب مي‌شويم. آيا شما تصور نمي‌كنيد كه ايده‌هاي آزادي نهفته در نرم‌افزارهاي‌ منبع‌باز در پشت انواع محصولاتي كه مي‌توان از اين روش توسعه به‌دست آورد، گم شده باشند؟
‌• خير. من در اين مورد با ريچارد موافق نيستم. زماني كه او مي‌گويد: <بياييد درباره آزادي صحبت كنيم>، من پاسخ مي‌دهم : <بس است. به‌جاي اين‌كار سورس كد را نشان بدهيد>.
هميشه عمل بهتر از حرف و تبليغات بوده است. روش كار ما بيانگر پيام ما است. من فكر مي‌كنم ايده آزادي و رايحه شيرين اختيار، همواره بيشتر از آن‌كه نتيجه حرف‌هاي زيبا در ارتباط با ايده‌ال‌ها و مجردات باشند، از آنچه در عمل انجام مي‌دهيم، ايجاد مي‌شوند.
ما نيازي به ژست گرفتن نداريم، اتكا به آنچه هستيم بسيار بيشتر از اداي ديگري را درآوردن اهميت دارد.

‌• به اعتقاد شما، سيستم‌عامل‌ها و ديگر نرم‌افزارهاي منبع‌باز بايد در انتظار چه تغيير و تحولي باشند تا بتوانند در بين كاربران غير حرفه‌اي، جايگاه خود را بيابند؟
‌‌• ما بايد در مورد طراحي رابط‌هاي كاربر دقت و توجه بيشتري داشته باشيم. در اين مورد اخيراً در مقاله‌اي تحت عنوان The Luxury of Ignorance اظهارنظر كرده‌ام.
راه و رسم يونيكس در همه موارد بسيار مستحكم و غني است، اما در مورد ارتباط با رابط كاربر با مشكل اساسي مواجه هستيم. تا زماني از مواردي مانند امنيت و پايداري و كارايي و سرعت و نظاير آن صحبت مي‌كنيم، ما با يونيكس حكومت مي‌كنيم، اما وقتي كه از رابط كاربر و سهولت كاربر سخن به ميان مي‌آيد، نااميد و وحشت‌زده مي‌شويم. از همه بدتر آن است كه بسياري از ما حتي حساسيت و عمق ناتواني خود را در اين زمينه نمي‌شناسيم.
من اعتقاد دارم كه ما مي‌توانيم در اين زمينه بهتر عمل كنيم. اگرچه اين مسأله نيازمند به اعمال تغييرات بنيادي است و احتمالاً منجر به ايجاد برخورد‌ها و تناقض‌هاي جدي خواهد شد، اما كاملاً عملي خواهد بود و اين‌كار براي ما بسيار سهل‌تر از كسي است كه گرفتار باتلاق ويندوز شده است و سعي در رفع مشكلات اين سيستم‌عامل دارد.

‌• آيا تصور نمي‌كنيد كه شركت‌هايي كه از منبع‌باز سود مي‌برند، بايد ملزم به بازپرداخت به جامعه منبع‌باز بشوند؟
‌•(با خنده مي‌گويد) منظورتان شركت‌هايي مانند ردهت، IBM و ناول است كه در محيطي خارج از جامعه منبع‌باز

به كار توسعه نرم‌افزار مشغول هستند؟ واقعيت آن است كه در پرسش شما دو سؤال نهفته بود كه كوچك‌ترين اشتباه در تعبير و درك آن‌ها مي‌تواند بسيار خطرآفرين باشد.
بله، من تصور مي‌كنم كه شركت‌هايي كه از منبع‌باز تجارت سودآوري دارند، اخلاقاً مديون جامعه منبع‌باز هستند. اما مخالف اين مسئله هستم كه هر كسي به‌خود اجازه دهد تا چنين شركت‌هايي را وادار به پرداخت كند. اعتقاد و شرم اجتماعي در اين مورد مي‌تواند مؤثر باشد، اما اعمال فشار در اين مورد صحيح نيست.
سال‌ها پيش در يك گردهمايي گفته بودم كه در ذهن بسياري از مردم چنين برداشتي وجود دارد و من آن‌را در آن زمان <اصل فشار> يا Pressure Principle ناميدم. بر اساس اين اصل، بسياري از مردم معتقدند كه <مديون بودن شخص X نسبت به شخص Y > به صورت طبيعي به معني آن است كه <گروهي از مردم به‌نام Z به‌درستي بر X فشار خواهند آورد تا حق Y را بپردازد.>
نكته‌اي كه بايد به آن توجه شود آن است كه پذيرش اصل فشار، راه و مسير كوتاهي است كه مستقيماً به جهنم ختم مي‌شود. به اين ترتيب در جهاني زندگي خواهيم كرد كه در آن مردم به‌طور پيوسته در حال اختراع <وظايف اخلاقي> جديدي هستند كه چيزي بيشتر از حكم اعمال فشار و زور براي پيشبرد اهداف نيست.
من به هيچ وجه نمي خواهم در چنين دنيايي زندگي كنم و به همين جهت مخالف اعمال فشار در هر زمينه‌اي به‌جز دفاع شخصي هستم!

پارادايم‌ها
‌•‌ شما از يك سو يك آزاديخواه هستيد و از طرف ديگر يك آنارشيست محسوب مي‌شويد. اين دو ديدگاه بر نگاه شما نسبت به مقوله نرم‌افزار رايگان در برابر منبع‌باز چه تأثيري دارند؟
‌•‌ بينش من، تغذيه‌كننده اصلي بدگماني من نسبت به مقوله نرم‌افزار Free است. معتقدم دلايل تجربي بسياري براي بدگمان بودن نسبت به نرم‌افزار رايگان دارم. اما آنارشيست بودن من به يافتن اشكالات عملي در اين زمينه كمك كرده است.

‌• چه مدتي است كه خود را يك آزاديخواه مي‌دانيد؟ آيا اين تفكرات منجر به شكل‌گيري روش كار شما در برنامه‌نويسي و توسعه نرم‌افزار گرديد و يا به‌طور معكوس، مشاهدات شما در مدل‌هاي توسعه نرم‌افزار شكل‌دهنده ديدگاه‌هاي شما در ارتباط با آزادي افراد بوده است؟
‌• اين موضوع را دقيقاً به‌خاطر دارم. من از سال 1980 به بعد عملاً يك آزاديخواه بودم. اما در آن زمان بيشتر از آن‌كه يك آنارشيست باشم، به Minarchism فكر مي‌كردم و اين وضع سه تا چهار سال ادامه داشت. (مي‌توانيد به مقاله اريك ريموند در نشاني www.catb.org/esr/writings/anarchist.html مراجعه نماييد.)
اعتقادات من بر اقتصاد ارزش آزاد (Value-free) متكي است. بازارهاي اقتصادي و آزادي فردي از يكديگر تفكيك ناپذيرند و دو روي يك سكه محسوب مي‌شوند. در اين شرايط كسي از زور استفاده نمي‌كند. بر اساس چنين ديدگاهي، راه‌حل‌ها و الگوهاي غيرمتمركز اقتصادي كه در آن‌ها هيچ فرد مشخصي سيستم را به تنهايي در كنترل و اختيار خود ندارد بهتر قابل درك خواهند بود.
وضع مدل توسعه نرم‌افزار منبع‌باز(Open source) براي حاميان آزاديخواه كار دشوار‌تري از وضع مفهوم بازار براي آنان نيست. هر دوي اين پديده‌ها بازخورد طبيعي رفتار خودسرانه هستند. اما مي‌پذيرم كه تنها يك فرد آزاديخواه مي‌توانست مدل‌منبع‌باز را همان طور كه من آن را تعريف كردم، تعريف كند.

‌• در صورتي‌كه شما فرهنگ هكر را در يك چهارچوب انسان‌شناسي مطالعه نمي‌كرديد، آيا تصور مي‌كرديد كه در ارتباط با فرايند توسعه نرم‌افزار به همين نتايج مي‌رسيديد؟
‌• شايد. اما دراين‌صورت زبان نتيجه‌گيري‌هاي من حتماً تفاوت مي‌كرد و احتمالاً اين مسئله منجر به دشوار شدن درك اين مفاهيم براي افراد غير متخصص مي‌گشت.

‌• در مورد آنچه الهام‌بخش شما در نوشتن كتاب The Cathedral and the bazzar بوده است، صحبت كنيد. چه بخش‌هاي از اين كتاب براي شما و خوانندگان جالب‌تر بوده است؟ كدام بخش‌ها بيشترين جر و بحث‌ها را برانگيخته است؟ آيا قسمت‌هايي وجود دارند كه خوانندگان از درك آن غافل باشند و شما آن را جالب توجه بدانيد؟
‌‌• من قبلاً در نوشته بسيار مفصلي در سايت شخصي‌ام موضوع چگونگي نوشتن اين كتاب را تشريح كرده‌ام.
آن بخش‌هايي از كتاب كه براي خوانندگان بيشترين جذابيت را دارد، تا حد زيادي به مخاطب بستگي دارد. بسياري از خوانندگان بخش‌هايي را بيشتر مي‌پسندند كه مستقيماً به نرم‌افزار ارتباط دارند. اما من نامه‌هايي از نويسندگان حرفه‌اي دريافت كرده‌ام كه از نثر و ايده‌اليسم اجتماعيِ اثر، تعريف و تمجيد كرده‌اند. گروه ديگري هم از مدل جديد تعاون اجتماعيِ مطرح‌شده در اين كتاب خوششان آمده است و از من تعريف مي‌كنند. اما جالب است كه بدانيد اين گروه اخير با دريافتن آن‌كه من يك فردگراي آنارشيست هستم كه پاسخ طبيعي او به عقايد اوتوپياي اجتماعي، جستجوي يك هفت‌تير است، چندان بر عقيده قبلي‌شان پافشاري نمي‌كنند.
حقيقتش را بخواهيد، كم كم دارم به اين نتيجه مي‌رسم كه ويژگي اصلي اين كتاب در آن است كه به خواننده اجازه مي‌دهد تا تفكرات خود را در آن بيابد. يكي از مهم‌ترين مسائلي كه خوانندگان زيادي آن را ناديده گرفته‌اند، پيش‌بيني من در ارتباط با نقش نرم‌افزارهاي منبع‌باز در بازارها و تجارت نرم‌افزار در زماني است كه صنايع به سمت نرخ‌هاي بازگشتي پايين‌تر در صنايع خدماتي گام برمي‌دارند.

در شركت سان
‌•‌ باز گرديم به فوريه 2004. شما نامه‌هاي سرگشاده متعددي به شركت سان مايكروسيستمز ارسال كرده‌ايد كه در آن‌ها به ادعا‌هاي اين شركت در ارتباط با <دوستي با منبع‌باز> پرداخته‌ايد و به‌طور خاص موضوع نسخه منبع‌باز جاواي شركت سان را مورد بحث قرار داده‌ايد. آيا مي‌توانيد موضوع را به اختصار در اين‌جا تشريح كنيد؟ آيا پيشرفت‌هايي حاصل شده است؟
‌•‌ من مذاكرات متعددي با يكي از مقامات رده بالاي اين شركت در ارتباط با كمك به تدوين يك استراتژي منبع‌باز داشته‌ام. در ارتباط با اين موضوع، جناح‌هاي موافق و مخالف متعددي درون شركت سان وجود دارند و هنوز بر كسي مشخص نيست كه كداميك از اين جناح‌ها پيروز خواهند شد.
به من گفته شده كه يكي از منابع اعمال فشار قوي بر سان در ارتباط با ارائه نسخه منبع‌باز جاوا، از جانب سياست‌هاي جديد خود JCP يا Java Community Process است. بدين ترتيب تقريباً با اطمينان مي‌توان گفت كه نسخه كاملاً باز زبان جاوا به همراه مجموعه‌ كتابخانه‌هاي كلاس به‌زودي از طرف يكي از اعضاي فعال درJCP عرضه خواهد شد. بله همان‌طور كه حدس مي‌زنيد در اين بين نام IBM بر سر زبان‌ها است. سان بايد تصميم خود را بگيرد. يا در برابر اين فشار‌ها مقاومت كند و يا آن‌كه هرچه سريع‌تر رهبري اين پروژه را بر عهده گيرد.
من هرچه در توان داشته باشم در حمايت از جناح منبع‌باز در درون سان به‌كار خواهم بست.

‌• نظر شما در مورد توافق‌نامه جديد 10 ساله ميان سان و مايكروسافت چيست؟ اين موضوع چه تأثيري بر نرم‌افزارهاي منبع‌باز و توسعه‌دهندگان آن خواهد داشت؟
‌• تا اين لحظه مشخص نشده است كه آيا اصولاً تأثيري در كار خواهد بود يا خير. آنچه مرا نگران مي‌كند، تسليم شدن احتمالي سان در مورد توقف پشتيباني اين شركت از پروژه OpenOffice (تحت فشار مايكروسافت) است. هرچند كه كاملاً واضح است كه حتي در اين صورت شركت‌هاي IBM و ناول آماده‌اند تا در اين مسير گام بردارند و جاي خالي سان را پر كنند.
مهم‌ترين مسأله‌اي كه در بلند مدت مشخص خواهد شد، احتمال آن است كه در اين توافق‌نامه مايكروسافت موفق شده باشد تا رضايت سان را در توسعه سيستم‌عامل Blackthorn بر روي هسته سولاريس جلب كرده باشد. (Blackthorn نام رمزي سيستم‌عاملي‌ بعد از سيستم‌عامل آينده مايكروسافت است. اين‌كه آيا اين سيستم‌عامل نسخه‌اي غير از لا‌نگ‌هورن است يا خير و يا آيا در اين مورد كنايه‌اي ‌در كار است يا نه، بر مترجم مشخص نشد.) اين موضوع امري كاملاً محتمل است و شبيه همان مانوري است كه خيلي‌ها مانند اپل با سيستم‌عامل Mac OSX انجام داده‌اند كه امكان اجراي ويندوز را به‌صورت مجموعه‌اي از كتابخانه‌ها و يا روي يك لايه شبيه‌سازي شده، بر روي هسته يونيكس فراهم مي‌كند.
در مورد آن‌كه سياست‌گذاران استراتژيك و ارشد مايكروسافت ناجوانمرد هستند يا نه بحث‌هاي زيادي در جريان است. اما در آن‌كه آن‌ها احمق هستند، كسي شك ندارد. همان‌طور كه كرم‌هاي نرم‌افزاري مانند Sasser يا Netsky به‌ما يادآوري مي‌كنند، معماري و CodeBase ويندوز يك فاجعه است. مايكروسافت بايد راهي براي خلاصي از اين مسير بيابد. مايكروسافت مي‌تواند در حالي كه هنوز ويندوز را به‌صورت Closed-source نگاه دارد، به يونيكس بپيوندد. اين راه هوشمندانه‌ترين راه‌حلي است كه من مي‌توانم با توجه به محدوديت‌ها و نيازمندي‌هاي آنان تصور كنم.

‌• اخيراً مديرعامل شركت JBOSS ، مارك فلوئري، از سان در بسته نگاه داشتن جاوا پشتيباني كرده و بر خلاف نظرات شما در مورد آن‌كه سان بايد جاوا را منبع‌باز كند، از موقعيت سان دفاع كرده است. در اين مورد توضيح ‌دهيد.
‌• برداشت من چنين است كه مارك تصور مي‌كند كه جاوا به‌صورت فعلي (يعني بسته) او را كمتر در معرض رقابت قرار مي‌دهد. البته اين موضوع براي او يك مزيت است، اما براي مشتريان مناسب نخواهد بود. اين مورد مسأله مهمي است كه مشتريان بايد به آن توجه داشته باشند.

‌• از ديدگاه منبع‌باز (و بر خلاف زاويه ديد نرم‌افزارFree) اصولاً چرا به يك سكوي كامل جاوا نياز داريم؟
‌• اين مسأله از اين جهت مهم است كه مانع از انجام حجم زيادي از كارهاي تكراري در مواجهه اجباري با پياده‌سازي‌هاي متعدد و ناسازگار خواهد شد. ما كارهاي بسيار مهم‌تري پيش‌رو داريم كه زمان و انرژي خود را معطوف آن‌ها كنيم.

‌• آيا در اختيار داشتن يك نسخه GPL شده از ماشين مجازي جاوا JVM مانند Kaffe به بحث منبع‌بازشدن جاوا كمك مي‌كند و يا آنكه اين مسأله را تضعيف مي‌سازد؟
‌• تصور مي‌كنم كه اين موضوع كمي فشارها را بر سان براي باز كردن جاوا بيشتر خواهد كرد. اما اين مقدار به اندازه‌اي نيست كه بعضي از جناح‌هاي ايده‌آل گراي ما دوست دارند. آنچه ما بدان نياز داريم چند نسخه ماشين مجازي جاوا يا كتابخانه در رقابت با يكديگر نيست، ما در انتظار يك نسخه ماشين مجازي جاوا هستيم كه قابل انتقال به سكوهاي گوناگون باشد.

‌• آيا بحث منبع‌باز شدن جاوا كاري معقول و مفيد است و يا آن‌كه اين مسأله بايد به‌خاطر جنبش منبع‌باز انجام شود؟
‌• من تصور مي‌كنم كه اگر سان اين كار را با ميل و رغبت كامل و به‌صورت داوطلبانه و در زمان مناسب انجام ندهد، حتماً شركت ديگري مانند IBM پيدا خواهد شد كه پا به ميدان خواهد گذاشت و اين كار را خواهد كرد. بدين ترتيب اختيار و كنترل زبان جاوا از دستان سان خارج خواهد شد و اين مسأله به موقعيت رهبري سان در حوزه جاوا و نتيجتاً بر بازار سان تأثير منفي برجاي خواهد گذاشت. جاسوسان من گزارش مي‌دهند كه پيشرفت‌هاي اخير در جامعه جاواكاران JCP اين مسأله را به امري اجتناب ناپذير مبدل ساخته است كه حداكثر مي‌تواند يك‌سال به‌درازا بكشد.
در نتيجه در پاسخ شما بايد عنوان كنم كه بله، براي منبع‌باز ساختن جاوا از سوي سان دلايل عقلاني كافي وجود دارد.

‌• سان در پاسخ به نامه نخست شما چنين نوشته بود: <ما منبع‌باز را بهتر از هر كس ديگري درك مي‌كنيم. IBM فقط تظاهر به آمادگي به حركت در اين مسير مي‌كند. اما هنوز مانند يك شركت سنتي رفتار مي‌كند.> آيا شما پاسخي براي سان داريد و يا آنكه در اين مورد حق را به سان مي‌دهيد؟
‌• سان اكثراً بيشتر از آن كه عمل كند، حرف مي‌زند. اخيراً حتي حرف‌هاي متقاعد كننده‌اي هم نمي‌زند. مديريت جديد آن‌ها، جاناتان شوارتز به‌تازگي با ادعا‌هاي عجيب و غريب و احمقانه در مورد اختصاصي شدن ردهت خود را به‌خوبي معرفي كرده است.

‌• آيا ميزكار جاواي جديد سان، اگرچه تحت لينوكس نوشته شده است، واقعاً براي جنبش منبع‌باز امري مفيد تلقي نمي‌شود؟
‌• هر اقدامي كه به گسترش لينوكس كمك كند، امري مثبت است. من با خوشحالي از اين اقدام سان تشكر مي‌كنم. حداقل خاصيت اين‌كار در آن است كه اين عمل سان باعث به درازا كشيدن مباحث مطرح شده اخير در سان خواهد شد.

‌• سان براي آن‌كه اثبات كند كه نهايتاً به منبع‌باز خواهد پيوست، چه‌كار مي‌تواند بكند؟
‌• كافي است كه JRE و كتابخانه‌هاي كلاس جاوا را باز كند.

رويدادهاي ديگر

‌• نظر شما در ارتباط با تصميم ضدانحصار اخير اتحاديه اروپا در برابر مايكروسافت چيست؟
‌• من اصولاً هيچ انتظاري از دولت‌ها ندارم. نتيجتاً در اين موارد نه ناراحت مي‌شوم و نه خوشحال.
به همان دليلي كه هيچ‌گاه انتظار نداشتم نتيجه دادگاه ضدانحصار در آمريكا منجر به تغييراتي بشود، تصور نمي‌كنم كه تصميم اخير اتحاديه اروپا نيز منجر به ايجاد تغيير و تحولي بشود. در هر صورت مايكروسافت پي به قيمت اتحاديه اروپا خواهد برد، به همان ترتيبي كه آنها قيمت دادگاه‌هاي آمريكايي را يافتند.
در نهايت نتيجه كلي آن خواهد بود كه اروپاييان، طرف مغبون معامله‌اي خواهند بود كه در آن مقداري از آزادي خود را در برابر جاري شدن قانون ضدانحصار در سر‌زمين خود پرداخته‌اند، بدون آن‌كه از مزاياي آن بهره‌اي برده باشند. تقريباً تمام موارد دخالت و شفاعت دولت‌ها در امور بازار در همه كشورها به چنين حالت‌هايي ختم مي‌شوند.

‌• شما نقش و تأثير انفجار دات كام و همچنين بحران آن‌را در افزايش و كاهش تعداد هكرها براي مشاركت در توسعه پروژه‌هاي نرم‌افزاري منبع‌باز، چگونه ارزيابي مي‌كنيد؟
‌• برخلا‌ف انتظار، من تأثير اين موضوع را بسيار كم مي‌دانم. توجه به آمار فراخوان‌هاي سايت Freshmeat (سايت پشتيبان پروژه‌هاي نرم‌افزاري منبع باز به نشاني www.freshmeat.net ) نشان‌دهنده اين واقعيت است كه منحني رشد در قبل و بعد از چنين فراز و نشيب‌هاي اينترنتي تقريباً همان نرخ را نشان مي‌دهند.
من علت چنين پديده‌اي را در آن مي‌دانم كه نيروهاي اقتصادي سوق‌دهنده جهان به سمت نرم‌افزارهاي منبع‌باز، به اندازه‌اي عميق، ساخت‌يافته و درون‌زا هستند كه تحت تاثير پديده‌هاي سطحي نظير بالا و پايين رفتن ارزش سهام واقع نمي‌شوند.

درباره با لينوكس
‌• شما چگونه با لينوس توروالدز آشنا شديد؟ او چه شخصيتي دارد؟
‌• در سال 1996 در اولين و آخرين كنفرانس نرم‌افزارهاي قابل توزيع مجدد و آزاد با هم آشنا شديم. ما قبل از اين تاريخ با پست‌الكترونيك مكاتبه داشتيم. در نخستين ملاقات قرار گذاشته بوديم تا يك نسخه از كتاب فرهنگ هكر را با يك CD معاوضه كنيم. اولين كلماتي كه در آن ديدار به‌زبان آوردم چنين بود: <متاسفم لينوس، من فراموش كردم كتاب را بياورم.> او نيز در پاسخ چنين گفت: <مشكلي نيست، من هم فراموش كردم CD را بياورم.>

‌• شما مشخصاً به كدام بخش‌هاي لينوكس مي‌توانيد اشاره كنيد و بگوييد كه: <من در اينجا تغييرات بنيادي ايجاد كرده‌ام؟>
‌• بخش‌هاي بسيار زيادي ازEmacs . در واقع بسياري از كاربران اين موضوع را نمي‌دانند. اما من هم CVS اين برنامه را طراحي كرده‌ام و هم رابط‌هاي اشكال‌زدايي GNU آن‌را نوشته‌ام. من فكر مي‌كنم كه سهم كد‌هاي من در كتابخانه‌هاي نرم‌افزاري اين برنامه، به‌جز خود RMS بيشتر از هر كس ديگري است. Fecthmail نرم‌افزار ديگري كه است نوشته‌ام و در مجموعه‌هاي لينوكس گنجانده مي‌شود. كتابخانه courses بخش ديگري است كه من پنج سال نگهدارنده (Maintainer) آن بوده‌ام و در حال حاضرlibungif ناميده مي‌شود. بخش قابل توجهي از يك كتابخانه PNG هم وجود دارد كه كار من ‌بوده است و موارد خرده ريز ديگر. از اين به بعد در هر بار كار با CVS و يا در هر جلسه GDB با Emacs ، به‌ياد من باشيد.

‌• شخصاً كداميك از توزيع‌هاي لينوكس را بيشتر ترجيح مي دهيد و از آن استفاه مي‌كنيد.
‌• لينوكس فدورا

‌• با گسترش كاربرد لينوكس، آيا ممكن است روزي اين سيستم‌عامل هدف ويروس‌ها واقع شود؟
‌• شايد. اما معماري امنيتي يونيكس اين مسأله را بسيار دشوار كرده است. من شخصاً نگراني از اين بابت ندارم.

براي سرگرمي
‌• بسياري از خوانندگان مايلند بدانند سيستم مورد استفاده در منزل شما چه شكلي است؟
‌• براي دانستن اين موضوع مي‌توانيد به نشاني /www.catb.org/esr/writings/ultimate-linux-box مراجعه نماييد.

‌• تاكنون دشوار‌ترين و پيچيده‌ترين پروژه كد‌نويسي شما چه بوده است؟
‌• احتمالاً دشوار‌ترين يا پيچيده‌ترين پروژه چند سال اخير من، نرم‌افزارdoclifter بوده است. اين نرم‌افزار برنامه‌اي است كه با استفاده از تركيبي از تكنولوژي كامپايلر و دانش شهودي (Heuristies) براي ترجمه متن صفحات راهنماي يونيكس (unix man pages) و همچنين ماكروهاي troff ، به فايل‌هاي ساخت‌يافته XML به‌كار برده مي‌شود. اين‌كار تا مدت‌ها امري غيرممكن انگاشته مي‌شد و تصور مي‌رفت كه براي اين‌كار و تفكيك آيتم‌ها، به توانايي و شعور انساني نياز خواهد بود، كه من موفق به انجام آن شدم.
‌• هيچ طرحي براي آغاز كتاب ديگري در آينده نزديك، در سر مي‌پرورانيد؟
‌• به فكر كار بر روي كتابي هستم كه در آن به بحث مهندسي قابليت استفاده براي برنامه‌نويسان يونيكس بپردازم. همچنين خود را براي ويرايش چهارم كتاب فرهنگ هكر آماده مي‌كنم.

‌• Vi را ترجيح مي‌دهيد يا Emacs را؟
Emacs را، اگرچه با Vi هم بسيار راحت هستم و هر از چندي در زمان‌هايي كه پشت سيستم‌خود قرار نگرفته‌ام، از آن براي كارهاي كوچك استفاده مي‌كنم.
‌• چه شباهتي بين در اختيار داشتن يك جواز استفاده از اسلحه شكاري و جواز ازدواج وجود دارد؟

‌• آها، شما به‌دنبال آن جريان هستيد؟ (خواننده محترم، مصاحبه‌كننده بر اساس سابقه آشنايي كه با من دارد، اين سؤال را به اين شكل طرح كرده است.)
در سال 1996 من و همسرم Cathy ، براي دريافت جواز ازدواج به دادگستري مراجعه كرديم. در مدتي كه آنجا بوديم و همين‌طور فرم‌ها را يكي بعد از ديگري پر مي‌كرديم. دست آخر زماني كه داشتيم از دادگستري خارج مي‌شديم، متوجه شديم كه علاوه‌بر جواز ازدواج، هر يك از ما يك جواز حمل اسلحه گرم نيز در دست داريم!
مأموري كه جلوي در ايستاده بود، بلافاصله فرم‌هاي حمل اسلحه را در دستمان تشخيص داد و در حالي كه به نوبت به فرم‌ها ، من و كتي و مجدداً به فرم‌ها، من و كتي نگاه مي‌كرد، با لحن دلسوزانه‌اي گفت: <حواستان را جمع كنيد، براي پشيماني هيچ وقت دير نيست!>

پي‌نوشت‌
آزاديخواهي فلسفه‌اي است كه طرفدار دولت محدود و حامي حقوق شهروندان است. طرفداران اين فلسفه بر اين باورند كه افراد بايد آزاد و مختار به انجام هر آنچه تمايل دارند باشند. محدوده آزادي تعريف شده در اين فلسفه تا جايي است كه آزادي فردي منجر به نقض آزادي فرد ديگري در همان جامعه نباشد. تا اينجا اين فلسفه با بسياري از ديگر عقايد امروزي همخواني دارد. اما تفاوت‌هاي اين فلسفه با فلسفه‌هاي ديگر زماني آشكار مي‌شود كه تعريف دقيق‌تري از <حق> ارائه شود. از ديدگاه اين فلسفه، چيزي به‌نام حقوق مثبت (Positive Rights) مانند غذا، سلامتي يا سرپناه وجود ندارد. تنها حقوق منفي (Negative Rights) مانند تعدي نكردن يا دزدي نكردن، در اين فلسفه معني مي‌يابد. حاميان اين فلسفه بر اين باورند كه استفاده از زور و فشار براي حفظ چنين حقوقي در سطح فردي و احتماعي معني دارد و مشروعيت مي‌يابد.
- آنارشيستم اصطلاح متداولي است كه براي توصيف بسياري از فلسفه‌ها و جنبش‌هاي اجتماعي به‌كار برده مي‌شود كه حامي حذف سلسله مراتب اجتماعي هستند. اين دسته از فلسفه‌ها از اصطلاح آنارشي براي توصيف اجتماعي مبتني بر همكاري داوطلبانه شهروندان آزاد، استفاده مي‌كنند. تفكر آنارشيست فلسفي به هيچ وجه مدافع آشوب و بي‌نظمي نيست، بلكه از اين اصطلاح براي ارجاع به يك رابطه انساني كه به‌طور عمدي گزينش شده است، بهره مي‌برد.
- Minarchism، اشاره به تفكري دارد كه بر اساس آن دولت‌ بايد تا حد امكان كوچك باشد. بسياري از حاميان اين فلسفه خود را بخشي از تفكر Liberatarian مي‌دانند و ادعا مي‌كنند كه مينارشي ادامه فلسفه ليبرال كلا‌سيك است. مينارشيسم از اين ديدگاه در برابر آنارشيسم قرار مي‌گيرد و بر سادگي امور تأكيد دارد
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 27 مردادماه 1384

11:14 AM

August 18, 2005

CIO كيست ؟!

بهروز نوعي پور
ماهنامه شبکه - آبان ۱۳۸۳ شماره 48

اشاره :
اگر سلسله مقالات <الفباي مديريت فناوري اطلاعات> را تاكنون دنبال كرده باشيد، لابد با بعضي از جنبه‌هاي مختلف اين شاخه از علم مديريت آشنا شده‌ايد اصطلا‌حاتي مثل Outsourcing،BPR،ROI،TCO و KM از جمله موارد مهمي هستند كه بايد هر مدير فناوري اطلاعات درباره آن‌ها بداند. اما هنوز درباره مهمترين موضوع اين بحث، يعني <مدير فناوري اطلاعات> سخني نگفته‌ايم. او كيست؟ چه مسووليت‌هايي دارد؟ و براي اينكه بتوان به يك مدير خوب براي اداره كردن امور مربوط به فناوري اطلاعات (در يك سازمان) تبديل شد چه تخصص‌هايي لازم است؟ در اين مقاله مروري اجمالي بر مهمترين مهارت‌هاي عمومي يك <مدير فناوري اطلاعات> خواهيم داشت. و در قسمت بعدي اين مقاله كه درشماره آينده از نظرتان خواهد گذشت، مهارت‌هاي تكنيكي و مسووليت‌هاي اصلي يك CIO را بررسي خواهيم كرد.

CIO كيست؟
اين كلمه سرنام عبارت Chief Information Officer است و ما در زبان فارسي اين مقام اجرايي را در مجموعه مديران يك سازمان يا شركت تحت عنوان <مدير فناوري اطلاعات> مي‌شناسيم. البته معني دقيق و صحيح لغوي اين عبارت <مدير اطلاعات> است و اطلاع داريم كه اين واژه كمي پيش از متداول شدن فناوري اطلاعات در جوامع صنعتي، در مباحث مديريتي مطرح شده بود. اما چون فناوري اطلاعات در جامعه و به‌خصوص محيط شركت‌ها و سازمان‌هاي صنعتي چنان پيشرفت كرده است كه عملاً تمام مقولات مرتبط با <اطلاعات سازماني> را تحت تأثير قرار داده است، مي‌دانيم كه وقتي ذكري از CIO به ميان مي‌آيد، منظور همان مدير فناوري اطلاعات است كه به طور كلي <مديريت گردش، ثبت و امنيت اطلاعات سازماني> جزء وظايف اوست. CIO كسي است كه ناگزير از به‌كاربردن بهترين، مقرون به‌صرفه‌ترين و مناسب‌ترين ابزارها و راهكارهاي شناخته شده براي مديريت اطلاعات در يك سازمان است. بديهي است كه اين ابزارها و راه‌حل‌ها چيزي خارج از حوزه شمول فناوري اطلاعات نيستند. بنابراين چنين فردي بايد شناخت مناسبي از اين شاخه از علم و فناوري داشته باشد ولو اينكه موضوع كار سازمان يا شركت مطبوع او هيچ‌گونه قرابتي با خود صنعت و ابزارهاي فناوري اطلاعات نداشته باشد. امروزه گردش وسيع اطلاعات در صنايع و نهادهاي خدماتي گوناگون بخشي حياتي از گردش امور محسوب مي‌شود و سازمان‌هايي كه قادر به تسهيل گردش اطلاعات در مجموعه خود نيستند در يك فضاي رقابتي قادر به ادامه بقا نخواهند بود. در چنين شرايطي نقش راهبردي افرادي كه در هريك از اين موسسات و شركت‌ها مسؤوليت نگهداري و توسعه شريان‌هاي گردش اطلاعات را برعهده دارند غيرقابل انكار و خطير است. امروزه در كشورهاي صنعتي مرسوم است كه سازمان ها و نهادهاي متوسط (مجموعه‌هايي با بيش از 100 نفر كارمند) يا بزرگ، يك نفر را به عنوان مدير فناوري اطلاعات يا بهتر بگوييم، مدير اطلاعات در سازمان منصوب مي‌كنند و اداره‌كردن امور مذكور را به وي مي‌سپارند. دقت كنيد كه اين مسؤوليت متفاوت از نقش مسؤولين امنيتي و اطلاعاتي در برخي از سازمان‌هاست كه در ارتباط تنگاتنگ با سرويس‌هاي امنيتي يا پليسي كار مي‌كنند، هرچند كه ماده خام موضوع فعاليت هردو دسته <اطلاعات> است. CIO بيشتر به دنبال توسعه گردش اطلاعات كسب وكار و تسهيل روند آن در يك سازمان است، در حالي كه مسؤولين حفاظت اطلاعات مراقب جنبه‌هاي مجرمانه‌ فعاليت اشخاص در محدوده سازمان و محدود سازي نشت اطلاعات حساس سازمان به بيرون از آن هستند. البته بديهي است كه مسؤوليت اين دو گروه از مديران در هر سازماني، در يك نقطه با يكديگر اشتراك پيدا مي‌كند و آن هم جايي است كه امنيت اطلاعات يا كسب‌وكار سازمان از طريق ابزارها و روش‌هاي كامپيوتري و ديجيتالي به مخاطره مي‌افتد.
پرسشي كه در اينجا به‌وجود مي‌آيد اين است كه ويژگي‌ها، توانايي‌ها و مسؤوليت‌هاي خاص يك مدير فناوري اطلاعات چيست؟ به عبارت ديگر اگر بالاترين مقام مديريتي در يك شركت يا سازمان به اين نتيجه برسد كه براي مديريت اطلاعات نيازمند بهره‌گرفتن از چنين فرد يا افرادي است، به كدام گروه از متخصصين و كارشناسان بايد مراجعه كند؟
من در ادامه مقاله، اين ويژگي‌ها را به دو دسته <مهارت‌ها> و <مسؤوليت‌ها> تقسيم‌كرده‌ام. اين موارد در حقيقت خلاصه‌اي است از آنچه كه ممكن است در مقالات و كتاب‌هاي مختلف در زمينه مديريت فناوري اطلاعات پيدا كنيد. شركت يا سازماني كه قصد به خدمت‌گرفتن چنين مديري دارد بايد توقعات خود را از او به‌درستي بشناسد (مسؤوليت‌ها) و توانايي‌ها و تخصص‌هاي لازم (مهارت‌ها) را از او جويا شود.

مهارت‌هايي كه هر مديرفناوري اطلاعات بايد داشته باشد
در اينجا براي سهولت در ترسيم نقش‌هاي اصلي يك CIO، مهارت‌هاي او را به دو دسته عمومي (مهارت‌هاي مديريتي) و اختصاصي (مهارت‌هاي مرتبط با IT) تقسيم كرده‌ام. البته واضح است كه در يك نگاه كلي، همه اين مهارت‌ها با فناوري اطلاعات مرتبط هستند ولي اين تقسيم بندي از آن جهت مفيد است كه بفهميم در هر دسته از مهارت‌ها، كدام جنبه از تخصص وزن بيشتري دارد؟ برخي از مهارت‌ها به‌دست نمي‌آيند مگر اينكه مدير فناوري اطلاعات آگاهي كافي از تكنيك‌هاي عمومي مديريت داشته باشد. در گام بعدي، همين تكنيك‌ها را مي‌توان به مسائل مرتبط با فناوري اطلاعات پيوند زد. اما دسته ديگري از اين مهارت‌ها حاصل نمي‌شوند مگرآن‌كه CIO دانش كافي درباره <راهبرها و تكنيك‌هاي اصلي فناوري اطلاعات> داشته باشد و در وهله دوم اين مهارت‌ها را به جنبه‌هاي عمومي مديريت در سازمان پيوند بزند.

مهارت‌هاي عمومي مديريتي
1- رهبري
بديهي است كه شرط اصلي احراز پست مديريت، داشتن توان رهبري نيروي انساني شاغل در بخش هاي مرتبط و مديريت منابع سازمان در آن حوزه است. خصوصياتي مانند: تعهد، لياقت، شجاعت، بزرگواري، شكيبايي، مسؤوليت‌پذيري و برخورداري از شخصيت مناسب براي احراز اين مقام، جزو مهارت‌هاي عمومي يك مدير است و موضوع مديريت چه فناوري اطلاعات و چه غير آن، تغييري در اين مهم ايجاد نمي‌كند.
يادآوري اين نكته مفيد است كه <مديريت> علمي است كه تكنيك‌ها و فوت و فن‌هايي دارد. اين فنون حاصل ده‌ها سال تجربه وتبادل نظر مديراني است كه داستان شكست‌ها و كاميابي‌هاي خود را با ديگران (از جمله محافل آكادميك) به اشتراك گذاشته‌اند. بهره‌گيري از اين تجربيات و فنون، راه رسيدن به هدف‌هاي يك مدير را كوتاه مي‌كند.

2- درك ماهيت كسب‌وكار
يك موضوع مهم درباره CIO آن است كه وي بايد شناخت مناسبي از ماهيت كسب‌وكار اصلي سازمان يا شركت مطبوع خود داشته باشد. صرف بلد بودنIT كسي را به يك مدير خوب فناوري اطلاعات در يك سازمان تبديل نمي‌كند. پيام مهم اين حرف آن است كه يك مدير خوب براي فناوري اطلاعات در هر سازماني ، احتمالا يك متخصص در زمينه فعاليت همان سازمان است كه خود را به دانشIT نيز مجهز كرده است و نه برعكس. اگر يك مهندس شيمي دوره‌هاي تخصصي مرتبط با كامپيوتر، شبكه و مديريت فناوري اطلاعات را بگذراند، احتمالا خيلي موفق‌تر از يك مهندس كامپيوتر خواهد بود كه پس از گذراندن دوره‌هاي مرتبط با مديريت فناوري اطلاعات، قصد دارد به عنوان يك CIO در يك شركت توليد محصولات شيميايي خدمت كند. زيرا اولي درك مناسبي از ماهيت كسب وكار سازمان مطبوع خود دارد درحالي كه دومي ممكن است برداشت صحيحي از نيازها و مشكلات سازمان خود نداشته باشد.

3- روابط اجتماعي
فناوري اطلاعات چنان‌كه از نام آن برمي‌آيد با اطلاعات سروكار دارد و اطلاعات بخش جدايي‌ناپذير از هر رابطه‌ اجتماعي است. وقتي دو نفر با يكديگر ارتباط كاري برقرار مي‌كنند در حقيقت شكلي از اطلاعات و آگاهي را ميان خود رد و بدل مي‌كنند. تجربه نشان داده است كه آن‌دسته از مديران رده بالاي IT كه روابط عمومي خوبي ندارند ولو با وجود بهره‌مندي از توان فني بالا در زمينه فناوري اطلاعات چندان موفق نيستند.

4- توانايي خلق و مديريت تغيير
بارها در كتاب‌ها و مقالات مرتبط با فناوري اطلاعات، از جمله مقالاتي كه در همين مجله به چاپ رسيده‌است روي ابعاد پيچيده و چندگانه‌ مشكل <سرعت و شدت تغييرات> در محيط پياده‌سازي فناوري اطلاعات تاكيد شده است. مثلا پيش از اين، طي مقالاتي درباره موضوع سيستم‌هاي قديمي(1) و مهندسي مجدد فرآيند‌هاي كسب‌وكار(2) سخن گفتيم. همه اين حرف‌ها مؤيد يك واقعيت است: CIO بايد نسبت به موضوع تغيير و تحول، آگاه و براي خلق يا مديريت اين تغييرات، توانايي كافي داشته باشد.

5- تجربه امور بين‌الملل
فناوري اطلاعات و پديده‌هاي مرتبط با آن مرز نمي‌شناسد و اصولاً يكي از آرمان‌هاي فناوري اطلاعات اين است كه كسب وكارها و فعاليت‌ها را جهاني كند. اينترنت يكي از مهمترين سكوهاي پرتاب كسب‌وكارها در عرصه جهاني است و باوركردني نيست كه مديرIT در سازماني كه داراي روابط و تعاملات بين‌المللي است، بدون شناخت نسبت به ويژگي‌هاي روابط بين‌المللي (مانند درك تفاوت نوع كسب‌وكار و ريتم بازرگاني در كشورها و فرهنگ‌هاي مختلف) بتواند در اين زمينه موفق باشد.

6- ايجاد توازن ميان راهكار و راهبرد
مديريت فناوري اطلاعات آميزه‌اي از تاكتيك‌هاي مقطعي و راهبرهاي كلان است. مديرIT اصطلاحاً بايد Vision ‌داشته باشد: كجا هستيم و به كجا مي‌خواهيم برسيم؟ اما در عين حال مادامي كه به نقطه دلخواهمان نرسيده‌ايم نيز بايد چرخ امور بچرخد. آيا فكر مي‌كنيم براي مديريت امور پرسنلي سازمان نياز به نرم‌افزار خاصي داريم؟ بسيار خوب! بهتر است تا آن زمان كه سازمان بودجه اين كار را فراهم كرد، يك جوري با استفاده از فوت و فن‌هاي موجود امور پرسنلي را اداره كنيم تا نرم‌افزار دلخواه به دستمان برسد. گاهي اوقات براي مديريت اطلاعات در سازمان نيازمند به‌كارگيري راهكارهاي مقطعي هستيم اما نبايد راهبرد اصلي خودمان را فراموش كنيم. درغيراين‌صورت در چرخه امور روزمره گرفتار مي‌شويم.

7- داشتن شهامت جلوگيري از خطاهاي بينشي و عملكردي مديران رده بالا در زمينه IT
يك مدير فناوري اطلاعات بايد آگاه باشد كه فلسفه اصلي حضور او در يك سازمان، عدم اشراف كافي ساير مديران اجرايي آن سازمان بر پيچيدگي‌ها و ظرافت‌هاي مديريت فناوري اطلاعات است. بنابراين چنين فردي بايد شهامت بازداشتن خطاهاي بينشي و عملكردي مديران رده بالاي سازمان را در هر موضوعي كه به فناوري اطلاعات مربوط مي‌شود داشته باشد. اگر روزي مديرعامل يك سازمان، يك بسته نرم‌افزاري E-Commerce خريد و خطاب به كارمندان گفت: مگر نمي‌گويند تجارت الكترونيك؟ خب شما هم خدمات ما را در اينترنت بفروشيد! CIO بايد شهامت آن را داشته باشد كه بگويد: دست نگه داريد! آيا روند فعلي كسب وكارمان با مختصات و ويژگي‌هاي اين بستر جديد بازرگاني همخواني دارد؟

8- ايجاد توازن ميان R&D و كاربرد
<توسعه> بخش جدايي ناپذير از منظومه فناوري اطلاعات است. به همين دليل است كه به عنوان مثال فرآيند توليد نرم‌افزار را با نام Software Development يعني توسعه نرم‌افزار مي‌شناسند. يعني اين فرآيند پاياني ندارد. هميشه جاي تصحيح و بهبود هست. فناوري اطلاعات هميشه در حال توسعه است. با اين وجود بايد توازني ميان توسعه و كاربرد برقرار كرد. بالاخره كي‌ مي‌خواهيم از حاصل اين توسعه استفاده كنيم و كي به بهره‌برداري مي‌رسيم؟ نبايد در مسير توسعه راه افراط را طي كرد و يا در دام روزمرگي و محافظه‌كاري افتاد.

9- برقرار رابطه صحيح با مشاورانIT
برقراري رابطه صحيح و مناسب با مشاورانIT يكي از كارهاي حساس است. بعضي وقت‌ها خود اين مشاوران يا طرف مشاوره آن‌ها، وظيفه و مأموريت اصلي يك مشاورIT را گم مي‌كنند. همه مديران اجرايي سازمان، به‌خصوص مديرIT آن بايد فاصله خود را با مشاور حفظ كنند. تعامل با مشاوري كه امروز مشورت مي‌دهد و فردا خودش با سازمان قرارداد مي‌بندد و در نقش يك پيمانكار ظاهر مي‌شود، كار خطيري است. زيرا چنين فردي همواره مي‌تواند سازمان را مجاب كند كه صلاح و مصلحت آن در اين است كه با او قرارداد ببندد و كار را به او بسپارد. ممكن است يك شركت يا فرد پيمانكار پيش از عقد قرارداد مشاوره هم بدهد ولي كسي كه پست و نقش اصلي او در سازمان <مشورت> است بهتر است كه همواره <مشاور> باقي بماند و در مواقعي كه سازمان قراردادي مي‌بندد ، ياور سازمان و مدافع منافع آن باشد.

10- تشخيص نقاط چرخش راهبردي
اين اندرز حكيمانه مديرعامل شركت اينتل را بايد آويزه گوش خود كنيم: نقاط چرخش راهبردي (3) كسب وكار را به موقع تشخيص دهيم و واكنش مناسب را نسبت به آن اتخاذ كنيم. آن دسته از مديران فناوري اطلاعات كه قادر به شناخت چرخش‌ها و تحولات اصلي صنعتIT نيستند از گردونه تحولات عقب مي‌مانند و گاه خسارات سنگيني را به سازمان يا شركت مطبوع خود تحميل مي‌كنند.

11- آگاهي از چگونگي دخالت صحيح در روند پروژه‌هاي داخلي و Outsource شده
اگر از من بپرسيد مهمترين معضل در زمينه مديريت فناوري اطلاعات در سازمان‌ها و شركت‌هاي ايراني چيست، خواهم گفت عدم توانايي در تعريف جايگاه صحيح و دقيق پيمانكاران طرف قرارداد سازمان. نه تنها در ايران، بلكه در بسياري از نقاط دنيا، كساني كه به نوعي مديريتIT در يك سازمان را به عهده مي‌گيرند دقيقاً نمي‌دانند با متخصصان و پيمانكاراني كه از بيرون به سازمان مي‌آيند تا طي قرارداد يا پروژه‌اي سازمان را ياري دهند چگونه برخورد كنند. آيا اين پيمانكاران رقيب بخش‌IT سازمان هستند؟ در اين مواقع چنين جملا‌تي به كرات شنيده مي‌شود: <چرا مديريت سازمان، اجراي فلان پروژه را به شركت يا افرادي بيرون از سازمان سپرده است مگر ما نمي‌توانستيم آن را انجام دهيم؟ پس ما چه كاره‌ايم؟ چرا پول سازمان به جيب آن‌ها برود؟> يك CIO بايد درك صحيحي از فلسفه وجودي مفهوم Outsourcing يا <برون‌سپاري امور> داشته باشد. مادامي كه چنين بينشي حاصل نشود، مديريت و پرسنل بخشIT يك سازمان خود را در تقابل با شركت‌هاي طرف قرارداد سازمان و به نوعي رقيب او مي‌پندارد.

12- آشنايي با حقوق درIT
لازم است مدير فناوري اطلاعات در هر سازمان يا شركتي با ابعاد حقوقي مسائل مربوط به كاربري و امنيت فناوري اطلاعات نيز آشنايي لازم را داشته باشد تا هر زمان كه لازم شد بتواند در اين‌باره تصميم‌گيري كند و سازمان را در تعيين خط مشي مناسب در اين خصوص ياري دهد. اگر لازم است كاربران فناوري اطلاعات درباره حريم خصوصي خود يا ساير كاربران و نيز موضوعاتي مانند كپي‌رايت، آموزش‌ها و آگاهي‌هاي لازم را دريافت كنند، CIO مي‌تواند برنامه‌هاي مناسب را تدوين و به اجرا بگذارد. همكاري با واحد‌هاي حراست سازمان نيز در اين زمينه اجتناب ناپذير است و در عين حال مدير فناوري اطلاعات بايد آگاه باشد كه هر آن ممكن است يك پرونده حقوقي مرتبط با IT از سوي اشخاص حقيقي و حقوقي عليه سازمان گشوده شود يا سازمان مطبوع وي خود را ناگزير از تسليم يك شكايت حقوقي مرتبط با جرائم رايانه‌اي و شبكه‌اي به دادگاه ببيند. در چنين شرايطي، مدير فناوري اطلاعات مي تواند نقش يك مشاور خوب را براي بالاترين مقام اجرايي سازمان را ايفا كند.

پي‌نوشت‌ها :
(1) درباره Legacy Systems به مقاله‌اي درهمين زمينه كه در شماره 46 ماهنامه شبكه منتشر شده است مراجعه كنيد.
(2) مفهوم اصطلاح Business Process Reengineering يا مهندسي مجدد فرآيندهاي كسب‌وكار طي مقاله‌اي در شماره 47 ماهنامه شبكه توضيح داده شده است.
(3) اصطلاح Strategic Inflection Point به تفصيل در كتاب معروف اندرو گرو كه به فارسي و با عنوان <تنها بي‌پروايان پايدارند> چاپ شده، توضيح داده شده است.

اگر سلسله مقالات <الفباي مديريت فناوري اطلاعات> را تاكنون دنبال كرده باشيد، لابد با بعضي از جنبه‌هاي مختلف اين شاخه از علم مديريت آشنايي پيدا كرده‌ايد. اين دانش تلفيقي از تكنيك‌هاي مديريتي و اصول و مباني پياده‌سازي و توسعه فناوري اطلاعات در يك سازمان است. اصطلاحاتي مثل Outsourcing ،BPR ،ROI ،TCO وKM از جمله موارد مهمي هستند كه بايد هر مدير فناوري اطلاعات درباره آن‌ها بداند. در قسمت قبلي اين مقاله گفتيم كه تعريف يك <مدير فناوري اطلاعات> چيست و براي اينكه بتوان به يك مدير خوب براي اداره كردن امور فناوري اطلاعات (در يك سازمان) تبديل شد به چه مهارت‌هاي عمومي نياز است. در اين مقاله مروري اجمالي بر مهمترين مهارت‌هاي تخصصي يك <مدير فناوري اطلاعات> خواهيم داشت. در بخش آخر از اين مطلب سه قسمتي ، مسووليت‌هاي اصلي يك CIO را بررسي خواهيم كرد.

مهارت‌هاي مرتبط با IT
يك مدير فناوري اطلاعات به اقتضاي ماموريتي كه به او سپرده شده است، بايد علاوه بر مهارت‌هاي عمومي مديريتي، داراي مهارت‌هاي خاص مرتبط با فناوري اطلاعات نيز باشد. هفت مورد از مهمترين مهارت‌هايي كه يك CIO در مقام عمل نياز فراواني به آنها خواهد داشت از اين قرارند :

1- تجربه به‌كارگرفتن فناوري اطلاعات در خدمت سازمان
<فناوري اطلاعات> به خودي خود و به تنهايي چندان كارآمد نيست. اين فناوري معمولا هنگامي ارزش‌هاي اصلي خود را نشان مي‌دهد كه در ارتباط با كاربردهاي واقعي و نيازهاي عيني سازمان به‌كارگرفته شود. آن‌دسته از مديران IT كه بدون توجه به خصوصيات و مقتضات خاص هر سازمان مي‌خواهند نسخه واحد و يكساني براي پياده‌سازي فناوري اطلاعات ارائه كنند‌، معمولاً نتيجه چندان مطلوبي نمي‌گيرند. در اغلب موارد يك مشكل اساسي اين است كه ابزارهاي نصب شده واقعا در خدمت اهداف سازمان عمل نمي‌كنند. در اين شرايط معمولا بهترين راه‌حل اين است كه ‌CIO دنبال راهكارهاي خاص فناوري اطلاعات براي همان سازمان باشد، نه اين‌كه بر پياده سازي يك سيستم عمومي و همه منظوره، اصرار ورزد. سيستم‌هاي همه‌منظوره بهروري مورد انتظار را در مقايسه با گستره كلي فعاليت‌هاي سازمان ايجاد نمي‌كنند. خوشبختانه فناوري اطلاعات يك ابزار انعطاف‌پذير و اصطلاحاً Customizable است. خيلي مهم است كه از اين ويژگي فناوري اطلاعات هنگام تطبيق آن با نيازهاي واقعي سازمان استفاده كنيم. آشنايي با اين موضوع مهم در مديريت فناوري اطلاعات نياز به تجربه ، دانش و تخصص ويژه دارد.

2- ارتباطات
ما در دوره‌اي زندگي مي‌كنيم كه مديران فناوري اطلاعات اغلب در يك تلاش دائمي براي دفاع از نظريه <به‌كارگيري فناوري اطلاعات براي افزايش بهره‌وري سازمان> و توجيه فوايد آن به سر مي‌برند. درچنين شرايطي خيلي مهم است كه يك CIO ، خود در رابطه با يكي از مهمترين مولفه‌هاي كاربري فناوري اطلاعات، يعني <ارتباطات> موفق عمل كنند. در اين‌جا مقصود ما از <ارتباطات>، روابط انساني خصوصاً از طريق ابزارهاي الكترونيكي است. قابل قبول نيست كه كسي مروج به‌كارگيريIT در سازمان باشد، اما خود در ارتباط گيري با ساير افراد (خصوصاً با استفاده از ابزارهايIT) ضعيف عمل كند. يك مدير فناوري اطلاعات بايد در زمينه استفاده از ابزارهاي الكترونيكي براي انجام امور ارتباطي روزانه خود از قبيل ارسال و دريافت منظم ايميل و انجام كارهاي اداري به شيوه الكترونيكي، براي ديگر اعضاي سازمان الگو باشد وگرنه در جاانداختن اين نظريه كه <الكترونيكي كردن امور نهايتاً به نفع سازمان است> موفقيت اندكي به‌دست خواهد آورد. به زبان ساده، ديگر افراد سازمان بايد به چشم خود ببينند كه چگونه يك CIO با تكيه بر ابزارهايي كه استفاده از آن‌ها را تبليغ مي‌كند، خود به موفقيت‌هايي دست‌مي‌يابد.

3- توانايي استخدام، پرورش و به‌كارگرفتن نيروي متخصص در زمينه IT
يكي از چالش‌هاي دائمي در مديريت فناوري اطلاعات، مديريت نيروي انساني ماهر در اين حوزه است. خيلي اوقات ذهن اين افراد ناگزير است با سرعت زياد انبوه درهمي از وقايع، وضعيت‌ها و راه‌حل‌ها را (نوعا در ارتباط با مسائل تكنيكي فناوري اطلاعات) پردازش كند و به تصميم‌گيري بپردازد. به همين دليل در ميان اين قشر از متخصصان، افراد حساس، عصبي، پرتوقع و پرخاشگر كم نيستند. تجربه نشان داده است كه تعامل موفق با اين افراد فقط به صبر و شكيبايي نياز ندارد، بلكه بهره‌مندي از سطحي از دانش علمي و فني نيز ضروري است تا CIO توانايي بالقوه رويارويي با چالش‌هاي برخاسته از سوي اين متخصصان را داشته باشد. يك مدير فناوري اطلاعات با اندوخته علمي و تجربي اندك، قادر به مهار متخصصان IT شاغل در سازمان نيست. متخصصانIT اگر بخواهند، براي فرار از مسووليت‌هاي خود به اندازه كافي باهوش هستند. بنابراين به محض اينكه احساس شود مديرIT يك سازمان دانش و تسلط اندكي بر مسائل فني دارد، انواع كارشكني‌ها، كم كاري‌ها و حتي خرابكاري‌ها ( مانند هك و مشكلات امنيتي) سازمان را تهديد مي‌كند. همين نكته هنگام استخدام و پرورش نيروي انساني متخصص نيز اهميت دارد. به تجربه ثابت شده كه وقتي يك متخصص‌IT هنگام استخدام با يك مدير باهوش و كاردان روبرو مي‌شود، براي انجام وظايف و مسووليت‌هاي خود مصمم‌تر مي‌شود و بهره‌وري بهتري از خود نشان مي‌دهد.

4- آگاهي از گزينه‌هاي فناوري
يكي از مشكلا‌ت عمومي مديران فناوري اطلاعات در سازمان‌هاي مختلف عدم اشراف به گزينه‌هاي مختلف فناوري اطلاعات در يك زمينه خاص است. گاهي اوقات ديده مي‌شود كه يك مديرIT هنگام انتخاب يك راه‌حل (Solution) و پياده سازي آن در سازمان، ديد كوته بينانه‌اي نسبت به تنوع گزينه‌هاي پيش رو دارد. تعصب نسبت به نوع خاصي از محصولات و يا فناوري‌ها، از بدترين و مخرب‌ترين اشكال اين محدوديت نگاه هستند. البته هيچ ايرادي ندارد كه هركدام از متخصصان فناوري اطلاعات به يك سري از فناوري‌ها و ابزارها علاقه و گرايش داشته باشند و اصولا معناي <گرايش تخصصي> همين است. ولي يك مدير فناوري اطلاعات كه تيمي از متخصصان را اداره مي‌كند بايد جامع نگر باشد. اينكه با پيش داوري و بدون مطالعه و بررسي گزينه‌هاي پيش رو ، به دليل علا‌قه يا تعصب، هربار خودمان را به محصولات خاصي محدود كنيم و از فناوري‌ها و ابزارهاي ديگر چشم بپوشيم، ريسك استفاده از فناوري اطلاعات را بالا مي‌برد. زيرا هر ابزار و سيستم خاصي ، معايب و مزاياي خاص خود را دارد و اين‌گونه نيست كه يك گروه از سيستم‌ها را بتوان براي همه مقاصد و كاربردها به عنوان گزينه ايده‌آل در نظر گرفت. معمولا براي هر كاربردي و بسته به شرايط، يك مارك يا يك گروه از ابزارهاي شناخته شده در بازار محصولات و راهكارهاي IT كارايي بيشتري دارند.
5- شناخت دقيق از مسائل امنيت در فناوري اطلاعات
فراهم كردن بستري امن براي گردش اطلاعات در سازمان يكي از مهمترين وظايف يك مدير فناوري اطلاعات است. كسب موفقيت در چنين مسووليتي مستلزم شناخت كافي و دقيق از چالش‌هاي بالقوه پيش روي امنيت سيستم‌ها و شبكه سازمان و مجهز بودن به دانش و تجربه فني و تخصصي لازم براي پيشگيري از حوادث ناخوشايند است. داشتن يكي از مهارت‌هايي كه در همين زمينه ضروري است، مهارت به‌كارگرفتن نيروي متخصص در زمينه امنيت شبكه است. بديهي است كه CIO بسته به ميزان گستردگي فعاليت‌هاي سازمان مطبوعش ناگزير از درگير شدن با طيف وسيعي از مشكلات و مسؤوليت‌ها است و نبايد توقع داشت يك مدير فناوري اطلاعات دقيقاً در كسوت يك كارشناس امنيت شبكه ظاهر شود. اما چون موضوع امنيت اطلاعات سازمان موضوع حساسي است، نيازمند توجه ويژه است و نمي‌توان مديريت آن را به طور كامل به متخصصان امنيت اطلاعات سپرد. حتي گاهي اوقات وضعيتي به‌وجود مي‌آيد كه يك‌ CIO بايد بتواند پيش از چاره‌انديشي براي مقابله با يك حادثه امنيتي، ابتدا نسبت به امانت‌داري و صداقت متخصصان امنيتي شاغل در سازمان اطمينان حاصل كند. زيرا بعضي اوقات منشأ رخنه‌ها و خرابكاري‌ها همان‌جا است! بنابراين در شرايط اضطراري، ميزان اشراف و آگاهي مدير فناوري اطلاعات از مسائل تكنيكي مرتبط با امنيت شبكه و سيستم‌ها نقش تعيين كننده‌اي در مهار چالش‌هاي مربوطه دارد.

6- درك TCO و ROI
دو موضوع مهم ديگري كه يك مدير فناوري اطلاعات بايد حتماً اطلاعات كافي درباره آن‌ها داشته باشد، يكي نحوه محاسبه <هزينه تمام‌شده مالكيت ابزارهاي فناوري اطلاعات> يا اصطلاحاً TCO و ديگري روش تخمين زدن <ميزان بازگشت سرمايه‌ همانگونه كه در مقالا‌ت قبلي همين بخش خوانده‌ايد، در زمينه فناوري اطلاعات> يا ROI مي‌باشد. آگاهي از روش محاسبه پارامتر اول به مدير فناوري اطلاعات كمك مي‌كند كه هنگام تصميم‌گيري درباره خريد هر محصول، راه‌حل، سيستم‌عامل و يا سخت‌افزار، ارزيابي واقع‌بينانه‌اي از هزينه‌هاي جاري و آتي مرتبط با انتخاب خود داشته باشد. گاهي اوقات خريدن يك محصول ارزان قيمت وسوسه انگيز به نظر مي‌آيد. ولي بعداً هزينه‌هاي جاري مرتبط با آن محصول به شدت بالا مي‌رود. مثلا ممكن است هنگام خريدن يك چاپگر ليزري براي شركت يا سازمان چنين وضعيتي رخ دهد. گاهي اوقات نيز برعكس اين وضعيت اتفاق مي‌افتد. يعني تحت تأثير نظر و راي ديگران (و گاه اعتقادات شخصي خودمان) محصولي را مي‌خريم كه ظرفيت پاسخگويي آن خيلي بيشتر از نياز واقعي ما است. در چنين شرايطي ممكن است پول زيادي براي يك كار متوسط خرج شود. درست مثل اين مي‌ماند كه براي اپراتوري شركت، كامپيوترهاي فوق‌العاده سريع و قوي بخريم، حال آنكه آن‌ها كاري بيشتر از تايپ با آن انجام نمي‌دهد. در رابطه با عامل ROI نيز رويكرد مشابهي وجود دارد. ميزان بازگشت سرمايه‌ در زمينه فناوري اطلاعات به سه مولفه‌ هزينه، فايده و ريسك مربوط است. يك سرمايه‌گذاري موفق هنگامي اتفاق مي‌افتد كه با كمترين هزينه و ريسك، بيشتر فايده از به‌كارگيري يك محصول يا راهكار مبتني بر فناوري اطلاعات حاصل شود.

7- آشنايي كامل با كسب‌وكار الكترونيكي
آگاهي از اين واقعيت كه پياده‌سازي و به‌كارگيري فناوري اطلاعات در يك سازمان نهايتاً منجر به برپا شدن درجاتي از كسب‌وكار الكترونيكي در سازمان مي‌شود، براي هر CIO يك ضرورت است. در ابتدا همه‌چيز با چند كامپيوتر ساده شروع مي‌شود و سپس با مقولاتي همچون اينترنت و ايميل ادامه پيدا مي‌كند. به تدريج قسمت بيشتري از امور جاري سازمان با فعاليت‌هاي متكي بر كامپيوتر و اينترنت گره‌ مي‌خورد تا آنجا كه ديگر بقاي كسب‌وكار سازمان بدون بهره‌گيري از اين ابزارها قابل تصور نيست. به تعبيري ، اين همان كسب‌وكار الكترونيكي است. گاهي اوقات مفهوم تجارت الكترونيكي (E-Commerce) كه نوع خاصي از كسب‌وكار الكترونيكي (E-Business) است، با مفهوم اخير اشتباه گرفته مي‌شود. معناي عام اين اصطلاح همانا الكترونيكي شدن امور جاري سازمان است. اما به طور خاص براي ساماندهي اين شيوه از كسب‌وكار ممكن است از محصولات، نرم‌افزارها و راهكارهاي ويژه‌اي نيز استفاده شود. در هرصورت خيلي مهم است كه يك مدير فناوري اطلاعات بتواند تخمين واقع بينانه‌اي از نياز‌هاي آتي سازمان در اين زمينه داشته باشد. دقيقا همان‌طور يك شركت بزرگ نيازمند سپردن كار نگهداري از تأسيسات آب و برق و تهويه ساختمان به مسوولين مربوطه است، زيرساخت اطلاعاتي سازمان (اعم از شبكه‌، كابل‌ها، سخت‌افزارها و نرم‌افزارها) نيز بخش جدايي ناپذير از نيازمندي‌هاي كسب‌وكار سازمان به شمار مي‌روند. با اين تفاوت كه فناوري اطلاعات چيزي بيشتر از يك زيرساخت مدرن براي كسب‌وكار سازمان، بلكه جزيي از فرآيند روزانه آن محسوب مي‌شود. همانطور كه مديران عادي يك سازمان براي بالابردن دانش و مهارت خود در حوزه عمومي مديريت، دوره‌هاي تخصصي ويژه‌اي را در زمينه حسابداري و بازرگاني مي‌گذرانند، مي‌توان حدس‌ زد كه لازم است مديران مرتبط با موضوع فناوري اطلاعات، خصوصا CIO داراي حداقلي از دانش تخصصي مرتبط با كسب‌وكارالكترونيكي باشند.

اگر مجموعه مقالات <الفباي مديريت فناوري اطلاعات> را تاكنون دنبال كرده باشيد، لابد با بعضي از جنبه‌هاي مختلف اين شاخه از علم مديريت آشنايي پيداكرده‌ايد. اين دانش تلفيقي از تكنيك‌هاي مديريتي و اصول و مباني پياده‌سازي و توسعه فناوري اطلاعات در يك سازمان است. اصطلاحاتي مثل TCO، ROI،BPR ، Outsourcing و (KM (1 از جمله موارد مهمي هستند كه بايد هر مدير فناوري اطلاعات درباره آنها بداند. در دو قسمت قبلي اين مقاله گفتيم كه تعريف يك <مدير فناوري اطلاعات> چيست و براي اينكه بتوان به يك مدير خوب براي اداره كردن فناوري اطلاعات (در يك سازمان) تبديل شد به چه مهارت‌هاي عمومي و تخصصي نياز است. در بخش آخر اين مقاله مسووليت‌هاي اصلي يك CIO را بررسي مي‌كنيم.

مسووليت‌هاي اصلي CIO ‌كدامند؟
با توجه به شرحي كه پيرامون مهارت‌هاي عمومي و تخصصي يك مدير فناوري اطلاعات در سازمان آورديم، اينك به راحتي مي‌توان حدس زد كه مسووليت‌هاي اساسي يك CIO چه‌چيزها‌يي هستند. اين مسووليت‌ها از يك سو به مهارت‌هاي عمومي مديريتي وي و از سوي ديگر به مهارت‌هاي تخصصي او مرتبط هستند. اين مسووليت‌ها را از ديدگاه ديگري نيز مي‌توان تقسيم‌بندي كرد. اگر خوب دقت كنيم متوجه مي‌شويم كه برخي از وظايف يك <مدير ارشد اطلاعات> (2) در حقيقت مديريت مقولات نرم‌افزاري مانند خود اطلاعات و نيروي انساني مرتبط با آن و نيز جنبه‌هاي راهبردي مديريت است و برخي ديگر از وظايف او با مقولاتي سخت‌افزاري مانند دستگاه‌ها و سيستم‌هاي كامپيوتري گره خورده است. ايده اصلي و كلي مديريت اطلاعات در سازمان اين است كه يك نفر به نام CIO بايد علاوه بر فراهم ساختن بستر سخت‌افزاري و نرم‌افزاري جريان اطلاعات در سازمان، زمينه گردش صحيح و بهره‌برداري مناسب از اين اطلاعات و اندوخته‌هاي معنوي را در سازمان فراهم سازد.
به يك تعبير مي‌توان نقش مدير فناوري اطلاعات در سازمان را به سيستم گردش وكنترل سوخت، آب و روغن در يك اتومبيل تشبيه كرد. چنين سيستمي علاوه بر فراهم ساختن بستر گردش اين سه ماده حياتي در اتومبيل، به‌طور مرتب بر روند حركت آنها در سراسر سيستم نظارت مي‌كند. اما بديهي است كه يك سازمان چيزي بيش از يك ماشين است و نقش انساني و تدبير يك CIO در مجموعه وظايف و اختيارات او از اهميت فوق‌العاده‌اي برخوردار است. بنابراين، مقولاتي نظير بودجه بندي، مديريت پروژه و مديريت استراتژيك فناوري اطلاعات در سازمان نيز جزو مسووليت‌هاي اصلي اوست.

1- مديريت خدمات و ابزارهاي دپارتمانIT
به طور طبيعي اولين انتظاري كه سازمان از يك مدير ارشد اطلاعات دارد، مديريت روزمره خدمات و ابزارهاي واحد IT سازمان است. اين واحد، بستر لازم براي فعاليت‌هاي اطلاعاتي روزمره ساير واحدهاي سازمان مانند دبيرخانه، واحد ارتباط با ارباب رجوع، حسابداري و بخش‌هاي ديگر را فراهم ‌مي‌كند. مدير فناوري اطلاعات در سازمان بايد بر حُسن اجراي وظايف اين بخش از سازمان نظارت دائمي داشته باشد. همچنين بسيار محتمل است كه واحد IT، خدمات ويژه‌اي نيز به كارمندان سازمان ارائه دهد (مثل اتصال اينترنت يا سرويس ذخيره‌سازي فايل در شبكه). در اين‌صورت، مدير اطلاعات بايد بر نحوه ارائه اين خدمات نيز نظارت داشته باشد.

2- مديريت كارشناسان IT
بديهي است كه تا دو يا چند نفر به عنوان كارشناس كامپيوتر و فناوري اطلاعات در يك سازمان مشغول به كار نباشند، صحبت از مديريت فناوري اطلاعات در آن سازمان معنايي نخواهد داشت. چنانكه پيشتر هم گفتيم، چگونگي تعامل با اين كارمندان و به اصطلاح سروكله زدن با كارشناسان IT سازمان، يكي از دغدغه‌ها و مسووليت‌هاي اصلي يك CIO است.

3- مديريت ارتباطات
يكي از بخش‌هاي مديريت اطلاعات در سازمان، تسهيل روند آن‌دسته از ارتباطات درون و برون سازماني است كه به واسطه ابزارهاي ارتباطي الكترونيكي و كامپيوتري ميان كارمندان شركت از يك سو و نيز ميان كارمندان و مخاطبان فعاليت‌هاي سازمان از سوي ديگر صورت مي‌گيرد. نحوه دخالت مدير ارشد اطلاعات در اين زمينه بيشتر فني و تكنيكي است. نگاه CIO به روند ارتباطات سازمان، نگاه ساختاري است. وظيفه مدير فناوري اطلاعات در اين زمينه آن‌ است كه با شناسايي نقاط ضعف و قوت شريان‌هاي اطلاعاتي درون سازمان و نحوه اتصال آنها به بيرون از سازمان، به طور مداوم در فكر اصلاح و بهبود آن باشد به گونه اي كه كارمندان سازمان براي ارتباط گيري ميان خود و مراجعان و مشتريان سازمان با كمترين مانعي روبرو شوند.

4- فراهم ساختن امنيت اطلاعات و ارتباطات
وقتي صحبت از زيرساخت ارتباطي و اطلاعاتي سازمان به ميان مي‌آيد، بي‌درنگ مهمترين موضوعي كه به ذهن خطور مي‌كند مساله چگونگي امنيت اطلاعات و ارتباطات سازمان است. يك ساختار ارتباطي هرچقدر هم كه پيشرفته باشد، اگر امن نباشد، فلسفه اصلي به‌كارگيري فناوري اطلاعات در سازمان را زير سوال مي‌برد و همه كاركردهاي مثبت آن را به خطر مي‌اندازد. مدير فناوري اطلاعات در سازمان بايد متوجه باشد كه اگر به موازات تسهيل روند گردش اطلاعات در سازمان فكري به حال افزايش امنيت بستر اطلاعاتي نكند، افزايش ميزان تبادل اطلاعات عملا به معني به خطرانداختنِ هرچه بيشتر دانش، تجربه، سرمايه معنوي و از همه مهمتر اسرار محرمانه سازمان است كه گاه ارزش اقتصادي يا راهبردي فراوان دارد.

5- مديريت دانش
از آنجا كه امروزه اطلاعات، يكي از اَشكال اصلي و مهم سرمايه در سازمان‌هاي مترقي محسوب مي‌شود، مي‌توان پيش‌بيني كرد كه آن‌دسته از سازمان‌ها كه خود را نيازمند بهره‌گيري از توان يك مدير ارشد اطلاعات در مجموعه كادر مديريت سازمان مي‌بينند، لابد به سطحي از پيشرفت در استفاده از فناوري اطلاعات رسيده‌اند كه دانش و اطلاعات ذخيره‌شده در سازمان، به كالايي گرانبها در ميان انواع سرمايه ها و داشته‌هاي سازمان تبديل شده است. مديريت دانش يا Knowledge Management در واقع يك مديريت استراتژيك است. همان‌طور كه كنترل سرمايه‌هاي مالي سازمان يكي از حساسترين و راهبردي‌ترين پايه‌هاي مديريت آن است، براي سازماني كه از روش‌هاي دانش‌بر در كسب‌وكار خود استفاده مي‌كند نيز كنترل سرمايه‌هاي اطلاعاتي سازمان بسيار مهم و كليدي است. بدون شك اين مورد يك از مهمترين مسووليت‌هاي يك CIO است.

6- مديريت محتوا
يكي ديگر از وظايف مهم CIO كه ارتباط تنگاتنگي با امور اطلاعاتي روزمره سازمان دارد، نحوه مديريت محتوا يا Content Management است. در اينجا منظور از محتوا چيزي جز همان داده‌ها و اطلاعات با ارزشي كه بر بستر ارتباطي سازمان جاري است نمي‌باشد. بهترين تعبيري كه از مفهوم مديريت محتوا در يك سازمان مي‌توان ارائه كرد همان است كه اصطلاحا Digital Workflow يا چرخه ديجيتالي امور اطلاعاتي سازمان ناميده مي‌شود. اين چرخه ممكن است فقط محدود به آن‌دسته از اطلاعات كه در كالبد سيستم‌هاي كامپيوتري توليد و پردازش مي‌شوند باشد، يا به تدريج تمام چرخه‌هاي غير ديجيتالي بروكراسي سازمان را نيز دربرگيرد و آنها را هم شامل شود.

7- بودجه ‌بندي
مديريت اطلاعات و فناوري اطلاعات در يك سازمان كار بسيار حساس و ظريفي است.CIO بايد همواره به خاطر داشته باشد كه فناوري اطلاعات آمده است كه تا چرخه امور در كسب‌وكار سازمان را تسهيل كند. اگر قرار باشد به‌كارگيري فناوري اطلاعات هزينه‌هاي سازمان را افزايش دهد و بهره‌وري اندكي ايجاد كند، با توجه به پيچيدگي‌هاي فنيIT و نياز مبرم آن به نيروي متخصص ماهر، در مجموع كسب‌وكار سازمان به جاي حركت به سمت چابكي و كارآمدي، به سمت كاهش بازده و پيچيدگي بيشتر حركت خواهد كرد. در چنين شرايطي ممكن است مديريت سازمان از پياده‌سازي فناوري اطلاعات در مقياس عمده صرف‌نظر كند. هنرCIO اين‌است كه يك برنامه زماني قابل دفاع از نحوه هزينه شدن بودجه اختصاص يافته به توسعه كاربري فناوري اطلاعات در سازمان ارائه نمايد. به گونه‌اي كه ديگر مديران سازمان به تدريج آثار مثبت به‌كارگيري فناوري اطلاعات را احساس كنند.

8- مديريت پروژه
گاهي اوقات انجام ماموريت‌هاي محوله به واحد IT سازمان مستلزم به انجام‌رساندن پروژه‌هاي ويژه كوچك و بزرگي است كه فراتر از امور روزمره و عادي اين واحد هستند. در چنين مواقعي كنترل روند آغاز و پايان پروژه بسيار حياتي است. پروژه‌هاي مرتبط با فناوري اطلاعات، حتي پروژه‌هاي كوچك، نوعاً داراي سطحي از پيچيدگي و ظرافت هستند كه اگر پيش‌بيني نشوند، انجام اين پروژه‌ها نهايتا حاصلي جز صرف هزينه‌هاي زياد و بازده اندك نخواهند داشت. زمان‌بندي انجام پروژه‌هاي مشابه نيز از يك سازمان به سازمان ديگر تفاوت دارد. زيرا سيستم كسب‌وكار، زيرساخت اطلاعاتي و ميزان تخصص و دانش نيروي انساني در سازمان‌ها متفاوتند. مديران باتجربه‌تر مي‌توانند با توجه به وضعيت كنوني سازمان و نوع ماموريت و كسب‌وكار سازمان، پيش‌بيني كنند كه يك پروژه مشخص چقدر زمان‌ مي‌برد و به چه پيش‌نيازهايي وابسته است. در واقع هنگامي كه پاي اجراي يكي از اين پروژه‌ها به ميان مي‌آيد، هيچ‌كس بهتر از CIO ‌قادر به تصميم‌گيري صحيح در اين زمينه نيست و از همين رو مديريت و كنترل پروژه هايIT بر عهده اوست.

9- ارتباط با ساير مديران CEO) ، CTO و ...)
واحدIT سازمان يك واحد مجزا نيست. فعاليت روزانه آن با اوضاع و احوال و نيازها و مشكلات ساير بخش‌هاي سازمان گره خورده است. در چنين شرايطي كاملا بديهي به نظر مي‌رسد كه تعامل با مديران ساير بخش‌هاي سازمان را جزو وظايف روزمره CIO بدانيم. حتي گاهي اوقات اين تعامل نقش استراتژيك و حساسي پيدا مي‌كند. مثلا در برخي سازمان‌هاي بسيار بزرگ (مانند شركت‌هاي خودرو سازي) مديران ديگري نيز وجود دارند كه بر حسن به‌كارگيري و مديريت ديگر فناوري‌هاي مورد نياز سازمان نظارت كنند. گاهي اوقات از اصطلاح CTO يا مدير ارشد فناوري براي اين منظور استفاده مي‌شود. در اين گونه موارد، استفاده از فناوري پيشرفته فقط محدود به فناوري اطلاعات نيست بلكه فناوري‌هاي ديگري را نيز دربرمي‌گيرد. حتي در بعضي سازمان‌هاي ممكن است CIO تحت مديريت CTO كه به نوبه خود بر عملكرد تمام جنبه‌هاي فناورانه در سازمان نظارت مي‌كند، عمل نمايد. به هرحال ساختار مديريتي سازمان هرچه كه باشد، مدير ارشد اطلاعات معمولا يكي از آن‌دسته مديراني است كه بنا به ماهيت كار و مسووليتش نياز فراواني به تعامل با ديگر مسوولين سازمان دارد. اين تعامل آنقدر مهم است كه فراتر از يك نياز بلكه جزو مسووليت‌هاي اصلي او به شمار مي‌رود.

10- مديريت استراتژيك
نهايتاً بايد بر اين نكته مهم تاكيد كرد كه مديريت فناوري اطلاعات يا به تعبير ديگر، مديريت اطلاعات سازمان يك مديريت استراتژيك است. معناي اين حرف آن است كه ممكن است موقعيت‌هاي حساس و سرنوشت‌سازي براي راهبري فناوري اطلاعات در سازمان پديد آيد كه نيازمند تصميم‌‌سازي‌ها و تصميم‌گيري‌هاي به موقع و موثر باشد. اين ويژگي ناشي از ماهيت پويا و سيال فناوري اطلاعات و صنعت كامپيوتر است. اين صنعت خيلي سريع تغيير مي‌كند و مديريت مسائل مرتبط با آن، حتي در گستره كوچكي مثل يك سازمان (در مقايسه با گستره كلان جامعه) كندي و رخوت را برنمي‌تابد. تصميمات بايد سريع و موثر اتخاذ شوند. تصميم‌هاي ديرهنگام و يا اشتباه ممكن است عواقب جبران‌ناپذيري درپي‌داشته باشد. متاسفانه هيچ‌كس نمي‌تواند در چنين مواقعي به مدير ارشد اطلاعات بگويد كه كدام تصميم درست خواهد بود. اين وظيفه اوست كه با شناختي كه از واقعيت‌هاي صنعت فناوري اطلاعات و مختصات كسب‌وكار سازمان مطبوعش دارد، تصميم درست و به هنگام را اتخاذ كند و برانجام آن پافشاري نمايد.

پي‌نوشت:
(1) كليه اين عناوين و مفاهيم را در شماره‌هاي قبلي ماهنامه شبكه و تحت همين عنوان " الفباي مديريت فناوري اطلا‌عات " توضيح داده‌ايم.
(2) بد نيست در پايان اين مقاله يادآوري كنم كه معناي دقيق كلمه CIO (برگرفته ازعبارت
Chief information Officer)، مدير ارشد اطلاعات است كه ما در اين مقاله سه قسمتي با نام مديرفناوري اطلاعات از آن ياد كرديم. به‌نظرم‌معادل اخير بيش از معني تحت الفظي كلمه گوياي مسووليت و موضوع اين شغل است.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 28 مردادماه 1384

04:38 PM

August 19, 2005

تدوین نرم افزار بهینه سازی شبکه ارتباط سیار در قالب یک پروژه ملی ضروری است

نوشته : دکتر عبدالرحمن يارعلی

بخش ارتباطات سیار کشور هم اکنون مهمترين, پردرآمدترين واز نظر فن‌آوری پيشرفته‌ترين بخش در عرصه مخابرات است اما با توجه به نیاز روزافزون اين حوزه به توسعه مستمر، لزوم گسترش راهکارهايي در جهت بهبود کيفيت آن احساس مي‌شود. اهمیت پرداختن به این مساله را می‌توان در دو دلیل عمده ذیل خلاصه کرد؛ دلیل اول نیاز همگان به اين وسیله ارتباطی است که بتدريج به جزء لاينفک وسايل شخصي هر فرد تبديل شده و دلیل دیگر سهولت نصب، راه‌اندازی و توسعه شبكه مرتبط با آن به دليل عدم نياز به کابل‌کشي گسترده در سطح شهر يا کشور مي‌باشد.
هم اکنون جدیدترین تکنولوژی‌های جهان که تا چندی پيش تنها در امور نظامي استفاده مي‌شد در تلفن همراه بکار گرفته شده است . بطور مثال مي‌توان از امکان ارسال ديتا با سرعت بالا و امکان استفاده از اينترنت, داشتن دوربين و يک رايانه شخصی دريک تلفن همراه کوچک و فن‌آوری‌هايي مانند Bluetooth برای ارتباط متقابل بین گوشي‌ها و یا ارتباط آنها با رايانه‌ها یاد كرد.
همچنين با بهبود سخت افزار گوشي‌ها (به عنوان مثال افزایش قدرت باتری‌ها) کارآيي آنها روز بروز بالاتر مي‌رود. در قسمت شبکه نيز هر روز تجهيزات پيشرفته‌تر مي‌شوند و متناسب با پيشرفت کيفی و کمی تجهيزات شبکه، قيمت آنها نيز بطور قابل ملاحظه‌ای کاهش می‌یابد.
با توجه به نکات گفته شده لزوم وجود ساختاري پيشرفته و جديد در شرکت ارتباطات سيار براي رسيدن به اهداف فوق ضروری به نظر مي‌رسد و در این راستا تقویت هر چه بيشتر بخش خصوصي براي سرعت بخشيدن به گسترش شبکه تلفن همراه کشور می‌تواند رهگشا باشد.
با توجه به اينکه تفکيک شرکت مخابرات ايران به چهار شرکت مادر تخصصي, زير ساخت, ديتا و ارتباطات سيار در اواخر سال 1383 اتفاق افتاد، مي‌توان گفت برنامه پنج ساله سوم که در پایان سال 1383 به اتمام رسيد بيشتر تحت تاثير شرايط مخابرات قبل از تفکيک است. به عبارت ديگر نتايج مثبت و يا منفی ناشي از اين جداسازی باید در سال‌های بعد مورد بررسي قرار گيرد .
در رابطه با عملکرد شرکت ارتباطات سيار، ضمن اشاره به زحمات شبانه‌روزي پرسنل متعهد آن شركت و تلاشهايي كه براي رفع معضلات انجام شده است، برخی مشکلات داخلی و بیرونی سبب شده كه عملكرد شركت ارتباطات سيار نسبت به عملكرد بهينه فاصله داشته باشد، بطوریکه امروز راند مان كاري شبکه موبایل کشور 40% است.
تا کنون کارشناسان زیادی این مشکلات را بررسی کرده و راهکارهایی برای حل آنها ارائه کرده‌‌اند اما هیچگاه این مشکلات را از یکدیگر تفکیک نکرده و وارد جزئیات آنها نشده‌اند؛ در ادامه این بحث برخی از این مشکلات به تفکیک مورد بررسی قرار گرفته و برای آنها راه حل‌های عملی ارائه شده است :

اطلاعات شبکه وابسته به فرد است

1- اطلاعات مربوط به شبکه در بسياري از مواقع مخدوش است. يک نظام جامع براي جمع آوري اين اطلاعات و يکپارچه‌سازي آنها هنوز وجود ندارد.
مستندسازي بصورت علمی، مدون و كامل صورت نمي‌پذيرد. علاوه بر آن اطلاعات مربوط به شبکه تلفن همراه عموما ناقص، قديمي و پراکنده است و در يک جای واحد نمي‌توان به آنها دسترسي پيدا کرد. اين گونه اطلاعات بسيار وابسته به فرد است.

پیچیدگی شبکه به دلیل استفاده از تجهیزات مختلف

2- وجود تجهیزات سه تولید کننده (Vendor) در شبکه و وجود سيستم‌های مختلف از هر کدام از آنها پيچيدگي بسيار زيادي را در امر نگهداري بوجود آورده است بطوريکه به کارشناسان زيادي با تخصص هاي گوناگون نياز مي باشد.

3-Vendor هاي مختلف هر کدام OMC (مراكز عمليات و پشتيباني) مربوط به خود را دارند و در ضمن واحدهاي مونيتورينگ و ترافيک سنجي آنها نيز متفاوت است. هرکدام از آنها براي شاخص هاي نشان دهنده کيفيت (KPI) فرمول‌هاي جداگانه‌اي دارند که در کنترل و نظارت کیفیت شبکه عدم هماهنگي بوجود مي‌آورند.

توسعه زیرساخت متناسب با توسعه شبکه نیست

4- توسعه همزمان شبکه و واگذاري سيم کارت باعث شده که شبکه هيچوقت در وضعيت Tune کامل قرار نگيرد. توسعه زير ساخت شبكه متناسب با توسعه شبكه نيست. فعال نمودن شماره‌هاي جدید تا بهینه نمودن شبکه كاري اشتباه است. كيفيت شبكه بايد از وضعيت فعلي به زير 5 % برسد.

توزیع کار در ساختار شرکت ارتباط سیار مناسب نیست

5- با توجه به اينکه بخشي از فعاليت هاي نصب و راه اندازی توسط بخش خصوصي انجام مي شود وجود واسطه های زياد باعث کندی کار و کاهش کیفیت مي‌شود.

6- شرکت های خصوصی پيمانکار برای انجام عمليات فني, نيروی متخصص لازم را ندارند و ناچارا از شرکت های خارجي يعني همان Vendor ها و يا کارمندان مخابرات در خارج از وقت اداری و يا کارمندان بازنشسته استفاده مي‌کنند, که استفاده از کارمندان مخابرات باعث ايجاد اغتشاش در سطوح اداری مخابرات و ارتباطات سيار مي شود.

7- بعلت كمبود نيروي ماهر، در بخش هايي بارکاری پرسنل کارشناس شركت بسيار زياد است که با توجه به محدوديت در حقوق و مزايای آنها انگيزه های لازم برای انجام کار باکيفيت بالا را ندارند. مشكل ديگر به عدم استفاده بهينه از نيروي كار برمي‌گردد، به بيان ديگر توزيع کار در ساختار شرکت ارتباطات سيار بصورت مناسبي انجام نمي‌شود مثلا ممکن است يک متخصص کار آمد کاملا بيکار باشد ولي يک وظيفه مهم به يک کارشناس عادی و بي‌تجربه سپرده شود.

8-رابطه کاري بین بخش‌هاي مختلف شرکت ارتباطات سيار بطوری است که بسیاری از اطلاعات که در اختيار يک قسمت قرار دارد از دید واحدهای دیگر که نیازمند آن اطلاعات مي‌باشند پنهان مي‌ماند. علاوه بر آن وظایف سازمانی واحدهای مختلف بخوبي تفكيك نشده و در برخی موارد شاهد انجام كارهاي موازي هستیم.

دیتابیس شبکه نباید توسط پرسنل محلی دستکاری شود

9- معمولا اختلافات بین طراحی و ديتابيس‌ها وجود دارد که باعث ايجاد اختلال در شبکه مي‌شود. با توجه به آنکه هماهنگ سازي اين دو قسمت کاري حجيم است بايد يک روش مکانيزه برای تست کردن و استخراج اختلافات وجود داشته باشد تا بتوان در هر زمان از يکسان بودن طرح یا پیاده‌سازی اطمینان حاصل کرد.

10- با توجه به آنکه امکان عوض کردن پارامتر ها در المانهاي BSC ، MSC و حتي BTS وجود دارد لازم است روشي اتخاذ گردد تا از دستکاري‌هاي ناخواسته توسط پرسنل محلي روي ساختار ديتابيس جلوگیری شود.

شرکت مشاور، وظایف خود را جدی نمی‌گیرد

11- شرکت مشاور خارجي که در آغاز فعاليت اقدامات قابل توجهي در زمينه کمک به بهبود ساختار شبکه مخابرات سيار انجام داده بود در ماه های آخر فعاليت خود جديتي در امر فوق نشان نداده و از پرسنل ماهر کمتر استفاده مي کرد.

12-مکانیزم مناسبی برای ارزیابی عملکرد مشاور خارجی وجود ندارد, اين موضوع بخصوص هنگامی اهمیت پیدا مي‌کند که سهم عمده مشاور ها را در طراحی و توسعه جاری شبکه مد نظر قرار دهیم.

نرم افزارهای شبکه به صورت کامل به روز نمی‌شود

13- به روز کردن نرم افزارها که بطور دائم توسط Vendor ها انجام مي‌شود باعث بروز اختلالاتي در شبکه مي‌گردد. در بعضی وقت ها يک Vendor تنها قسمتی از شبکه را به روز مي‌کند و بخش دیگر بصورت قديمي باقی مي‌ماند که باعث ایجاد مشکل در نرم افزارها جهت مانیتورینگ و بهینه سازی آن مي‌گردد.

14- نرم افزارهای موجود که وظيفه جمع آوری آمارهای ترافيکي برای کنترل مديريت عملکرد شبکه و بهينه‌سازی را بر عهده داشته است با Upgrade کردن هر يک از تجهيزات Vendorها دچار اشکال مي‌شود. بنابراين در صورت تمايل به استفاده از آن بايد ترتيبي اتخاذ گردد که يک تيم مجرب بصورت دائم آماده به روز کردن اين نرم افزارها باشد در غير اينصورت در مدت کمتر از يکسال بطور کامل غير قابل استفاده خواهد شد.

15- وجود نرم افزارهای طراحی و بهینه سازی برای ارتباطات سيار بسيار ضروری است. در صورت تمايل با همکاری شرکت هاي مشاور بايد به فکر تهيه يک بسته نرم افزاری مناسب بود. پيشنهاد مي شود يک پروژه در سطح ملي برای طراحي نرم افزارهای بهينه سازی و طراحي مطرح شود تا با تهيه آن بتوان در هر زمان تغييرات Vendorها و شبکه را بدون وابستگي به شرکت های خارجي بر روی آن اعمال کرد.

مکانیزم برگزاری مناقصات رو به بهبود است ولی . . .

16- به نظر مي رسد مکانيزم برگزاری مناقصات، تهیه RFP, RFI , RFQ و ساير موارد در يک روند رو به اصلاح است به اين معني که سعي مي شود اين فعاليت ها بصورت مدون و با همفکری پرسنل داخل شرکت انجام شود ولي مشکلاتي نيز دراين خصوص به چشم مي خورد اولا مشارکت افراد متخصص غيرعضو درشرکت مخابرات که مي‌توانند به عنوان ناظر بي‌طرف عمل کند بسيارکم است, ثانيا نتايج فرايند تهيه مدارک واسناد مناقصه و انتخاب برنده که مي‌تواند در مناقصات بزرگ بعدی بدون حضور مشاورين خارجي بسيار راهگشا باشد, به درستي مستند سازی نمي شود.

امید است این مشکلات جدی تر و موشکافانه تر توسط مسؤولان مورد بررسی قرار گیرند تا پتانسیل موجود، به بهترین شکل ممکن مورد استفاده و بهره برداری قرار گیرد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

شنبه، 29 مردادماه 1384

04:29 PM

August 20, 2005

آشنايي با ISA Server 2004

ISA Server 2004

مترجم : مهيار داعي الحق
ماهنامه شبکه - خرداد ۱۳۸۴ شماره 54

اشاره :
شركت مايكروسافت نرم‌افزارهاي متعددي را تحت عنوان Microsoft Server Systems در كنار سيستم‌عامل اصلي سرور خود يعني ويندوز 2000 تا 2003 عرضه كرده كه وظيفه ارايه سرويس‌هاي متعددي را از انواع ارتباطات شبكه‌اي گرفته تا امنيت و غيره به عهده دارند. در اين شماره قصد داريم به معرفي سرور كنترل ارتباط شبكه‌اي يعني ISA Server بپردازيم.

● آشنايي‌
برنامه قدرتمند ارتقاء و امنيت شبكه مايكروسافت ISA Server نام دارد. اين برنامه با استفاده از سرويس‌ها، سياست‌ها و امكاناتي كه در اختيار كاربران قرار مي‌دهد قادر است به عنوان راه‌حلي در ايجاد شبكه‌هاي مجازي
(VPN) و يا برپا كردن فضاي حايل به عنوان cache جهت دسترسي سريع‌تر به صفحات وب، مورد استفاده قرار گيرد. همچنين اين برنامه قادر است با ايجاد يك ديواره آتش در لايه Application شبكه، فعاليت سرويس‌هاي مختلف يك شبكه ويندوزي مثل وب سرور IIS، سرويس‌هاي دسترسي از راه‌دور (Routing and Remote Access) را از طريق فيلترگذاري و كنترل پورت‌ها، تحت نظر گرفته و فضاي امني را براي آن‌ها فراهم كند. اين برنامه با استفاده از نظارت دايمي خود بر پروتكل امنيتي SSL و فيلتر كردن درخواست‌هاي Http كه به سرور مي‌رسد، وب سرور و ايميل سرور را از خطر حمله هكرها دور نگه مي‌دارد. به همين ترتيب، كليه ارتباطات شبكه‌اي كه با يك سرور برقرار مي‌شود، از ارتباط Dial up ساده گرفته تا ارتباط با سرورExchange و يا IIS، بايد از سد محكم ISA عبور كنند تا درخواست‌ها و ارتباطات مشكوك با سرور مسدود گردد.
سايت مايكروسافت براي بررسي اهميت وجود ISA در يك شبكه، كليه راه‌حل‌هاي اين برنامه را كه با استفاده از سرويس‌ها و امكانات ويژه موجود در آن، ارايه گشته است به هفت سناريو يا وضعيت مختلف تقسيم كرده كه به آن‌ها مي‌پردازيم. (تصاوير مقاله از سايت مايکروسافت برداشته شده اند)

● سناريوي اول‌

شكل 1

از ISA براي تأمين امنيت ايميل‌ها استفاده مي‌شود. ISA Server با استفاده از دو روش استاندارد يعني SSL decryption وهمچنين Http Filtering اولاً از ورود كدهاي مشهور به malicious كه عمدتاً بدنه انواع كرم‌ها و ويروس‌ها را مي‌سازند جلوگيري به عمل مي‌آورد و ثانياً محتواي درخواست‌هاي Http را براي بررسي مجوز دسترسي آن‌ها و صلاحيت دريافت و ارسال اطلاعات مورد كنكاش قرار مي‌دهد. در اين حالت، ISA همچنين از هر نوع اتصال افراد با اسم كاربري anonymous كه مي‌تواند منشأ شكستن رمزعبورهاي مجاز يك سرويس‌دهنده ايميل شود، جلوگيري مي‌كند. به هر حال با وجود اين كه يك ايميل سرور مثل Exchange راه‌حل‌هاي امنيتي مخصوص به خود را دارد، اما وجود ISA به‌عنوان ديواره آتش يك نقطه قوت براي شبكه به حساب مي‌آيد. ضمن اين‌كه در نسخه‌هاي جديد ISA امكان ايجاد زنجيره‌اي از سرورهاي ISA كه بتوانند با يك سرورExchange در تماس بوده و درخواست‌هاي كاربران را با سرعت چند برابر مورد بررسي قرار دهد باعث شده تا اكنون به ISA عنوان فايروالي كه با قدرت انجام توازن بار ترافيكي، سرعت بيشتري را در اختيار كاربران قرار مي‌دهد در نظر گرفته شود. (شكل 1)

● سناريوي دوم‌

شكل 2
ISA مي‌تواند در تأمين امنيت و دسترسي از راه دور نيز مورد استفاده قرار گيرد. در اين سناريو، يك شركت برخي از اطلاعات سازمان خود را براي استفاده عموم در معرض ديد و يا استفاده كاربران خارج از سازمان قرار مي‌دهد. به عنوان مثال بسياري از شركت‌ها مسايل تبليغاتي و گاهي اوقات سيستم سفارش‌دهي خود را در قالب اينترنت و يا اينترانت براي كاربران باز مي‌گذارند تا آن‌ها بتوانند از اين طريق با شركت ارتباط برقرار نمايند. در اين صورتISA مي‌تواند به صورت واسط بين كاربران و سرويس‌هاي ارايه شده توسط وب سرور يا بانك‌اطلاعاتيSQLServer كه مشغول ارايه سرويس به محيط خارج است، قرار گرفته و بدين‌وسيله امنيت دسترسي كاربران به سرويس‌هاي مجاز و حفاظت از منابع محرمانه موجود در سيستم‌ را فراهم آورد.
(شكل 2)

● سناريوي سوم‌

شكل 3
در اين سناريو، دو شبكه LAN مجزا متعلق به دو شركت مختلف كه در برخي موارد همكاري اطلاعاتي دارند، توسط فضاي اينترنت و از طريق سرورها و دروازه‌هاي VPN با يكديگر در ارتباط هستند. به عنوان مثال يكي از شركاي يك شركت تجاري، محصولات آن شركت را به فروش رسانده و درصدي از سود آن را از آن خود مي‌كند. در اين روش به صورت مداوم و يا در ساعات معيني از شبانه‌روز، امكان ردوبدل اطلاعات بين دو شركت مذكور وجود دارد. در اين زمان ISA مي‌تواند با استفاده از روش Encryption از به سرقت رفتن اطلاعات ارسالي و دريافتي در حين مبادله جلوگيري كند، در حالي كه هيچكدام از دو طرف احساس نمي‌كنند كه فضاي حايلي در اين VPN مشغول كنترل ارتباط بين آن‌هاست. به علاوه اين‌كه با وجود ISA، كاربران براي اتصال به سايت يكديگر بايد از دو مرحله Authentication (احراز هويت) يكي براي سرور يا دروازه VPN طرف مقابل و ديگري براي ISA عبور كنند كه اين حالت يكي از بهترين شيوه‌هاي برقراري امنيت در شبكه‌هاي VPN است. در اين سناريو، وجود يك ISA Server تنها در طرف سايت اصلي يك شركت مي‌تواند، مديريت برقراري امنيت در كل فضاي VPN هر دو طرف را به‌عهده گيرد و با استفاده از ديواره آتش لايه Application از عبور كدهاي مشكوك جلوگيري كند. (شكل 3)

● سناريوي چهارم‌

شكل 4
در سناريوي چهارم، يك شركت قصد دارد به عنوان مثال تعدادي از كارمندان خود را قادر به كار كردن با سيستم‌هاي دروني شركت از طريق يك ارتباط VPN اختصاصي بنمايد. در اين حالت براي دسترسي اين قبيل كارمندان به سرور شركت و عدم دسترسي به سرورهاي ديگر يا جلوگيري از ارسال ويروس و چيزهاي مشابه آن، يك سد محكم به نام ISA ترافيك اطلاعات ارسالي و يا درخواستي را بررسي نموده و درصورت عدم وجود مجوز دسترسي يا ارسال اطلاعات مخرب آن ارتباط را مسدود مي‌كند. (شكل 4)

● سناريوي پنجم‌

شكل 5

سناريوي بعدي زماني مطرح مي‌شود كه يك شركت قصد دارد با برپايي يك سيستم مركزي در محل اصلي شركت، ساير شعبات خود را تحت پوشش يك سيستم (مثلاً يك بانك‌اطلاعاتي) متمركز درآورد. از اين رو باز هم در اينجا مسأله اتصال شعبات شركت از طريق VPN مطرح مي‌شود. در اين صورت ISA با قرار داشتن در سمت هر شعبه و همچنين دفتر مركزي به صورت آرايه‌اي از ديواره‌هاي آتش (Array of Firewall) مي‌تواند نقل و انتقال اطلاعات از سوي شعبات به دفتر مركزي شركت و بالعكس را زيرنظر داشته باشد. اين مسأله باعث مي‌شود تا هر كدام از شعبات و دفتر مركزي به منابع محدودي از يكديگر دسترسي داشته باشند. در ضمن با وجود امكان مديريت و پيكربندي متمركز كليه سرورهاي ISA نيازي به مسؤولين امنيتي براي هر شعبه نيست و تنها يك مدير امنيت، از طريق ISA سرور موجود در دفتر مركزي مي‌تواند كليه ISA سرورهاي شعبات را تنظيم و پيكربندي كند. (شكل 5)

● سناريوي ششم‌

شکل 6

كنترل دسترسي كاربران داخل دفتر مركزي به سايت‌هاي اينترنتي، سناريوي ششم كاربرد ISA محسوب مي‌شود. در اين جا ISA مي‌تواند به كمك مدير سيستم آمده، سايت‌ها، لينك‌هاي URL و يا انواع فايل‌هايي كه از نظر وي نامناسب تشخيص داده شده، را مسدود كند. در همين هنگام فايروال نيز كار خود را انجام مي‌دهد و با استفاده از سازگاري مناسبي كه بين ISA و Active Directory ويندوز وجود دارد، اولاً از دسترسي افراد غيرمجاز يا افراد مجاز در زمان‌هاي غيرمجاز به اينترنت جلوگيري شده و ثانياً مي‌توان از اجراشدن برنامه‌هايي كه پورت‌هاي خاصي از سرور را مثلاً جهت استفاده برنامه‌هاي Instant Messaging مورد استفاده قرار مي‌دهند، جلوگيري نمود تا بدين‌وسيله ريسك ورود انواع فايل‌هاي آلوده به ويروس كاهش يابد.
(شكل 6)

● سناريوي هفتم‌

در تمام سناريوهاي قبلي كه ISA در برقراري ارتباط مناسب و امن بين سايت‌هاي اينترنت، كاربران يا شعبات شركت نقش مهمي را ايفا مي‌كرد، يك سناريوي ديگر نيز نهفته است و آن افزايش سرعت انتقال اطلاعات بين تمام موارد فوق از سايت‌هاي اينترنتي گرفته تا اطلاعات سازماني است. سيستم cache Array موجود در اين برنامه باعث مي‌شود تا هر كدام از كاربران چه در محل اصلي شركت و چه از محل شعبات بتوانند براي ديدن اطلاعات يا سايت‌هاي مشابه راه ميان‌بر را رفته و آن را از هر كدام از ISAهاي موجود در شبكه VPN يا LAN دريافت كنند و بدين‌وسيله حجم انتقال اطلاعات با محيط خارج را تا حدود زيادي در سيستم متوازن نمايند.

● عملكرد
ISA Server كليه سناريوهاي تعيين شده را براساس سه قاعده مختلف يعني سيستم، شبكه و ديواره آتش محقق مي‌سازد كه در اين‌جا به اين سه قاعده اشاره مي‌كنيم.

1- Network Rule
ISA Server با استفاده از قوانين شبكه‌اي موجود و تعريف‌شده در بانك‌اطلاعاتي خودش نحوه ارتباط دو يا چند شبكه را به يكديگر در يك فضاي معين، مشخص مي‌سازد. در اين قاعده كه توسط مدير سيستم قابل تنظيم است مشخص مي‌گردد كه شبكه‌هاي موردنظر طبق كدام يك از دو روش قابل‌طرح، به يكديگر متصل مي‌شوند. اين دو روش عبارتند از:

الف- Network Address Translation) NAT)
اين روش، يك ارتباط يك طرفه منحصربه‌فرد است. بدين معني كه هميشه يكي از شبكه‌ها نقش شبكه اصلي و داخلي (Internal) و بقيه شبكه‌ها نقش شبكه‌هاي خارجي (External) را بازي مي‌كنند. در اين روش شبكه داخلي مي‌تواند قوانين و شيوه دسترسي به اطلاعات و ردوبدل شدن آن‌ها در فضاي بين شبكه‌ها را تعيين كند ولي اين امكان از ساير شبكه‌هاي خارجي سلب گرديده و آن‌ها تابع قوانين تعريف شده در شبكه داخلي هستند. در اين روش همچنين ISA آدرس IP كامپيوترهاي مبدا يك ارتباطNAT را به وسيله عوض كردن آن‌ها درIP خارجي خودش، از ديد كامپيوترهاي يك شبكه (چه كامپيوترهاي متصل از طريق LAN و چه كامپيوترهاي خارجي) مخفي مي‌كند. به عنوان مثال، مدير يك شبكه مي‌تواند از ارتباط بين كامپيوترهاي متصل شده از طريق VPN را با فضاي اينترنت از نوع يك رابطه NAT تعريف كند تا ضريب امنيت را در اين ارتباطات بالا ببرد.

ب - Rout
اين نوع ارتباط يك ارتباط، دو طرفه است. بدين معني كه هر دو طرف مي‌توانند قواعد امنيتي خاصي را براي دسترسي شبكه‌هاي ديگر به شبكه محلي خود تعريف كنند. به‌عنوان مثال ارتباط بين شبكه‌هاي متصل شده به يكديگر در فضاي VPN مي‌تواند يك ارتباط از نوع Rout باشد.
با توجه به اين مسايل ارتباطات قابل اطمينان يك شبكه با شبكه‌هاي مجاور (مثل شعبات شركت) مي‌تواند از نوع Rout و ارتباطات محتاطانه شبكه با كاربران خارجي و كساني كه از طريق RADIUS يا وب به شبكه دسترسي دارند مي‌تواند از نوع NAT تعريف شود.

2- Firewall Rule

علاوه بر نقش مستقيمي كه سياست‌هاي تعريف‌شده در قواعد ديواره آتش در نحوه ارتباط بين شبكه‌ها بازي مي‌كند و مي‌تواند موجب مسدود شدن ارتباطات خارج از قواعد تعريف شده درNetwork Rule شود، اين قواعد همچنين مي‌توانند با تعريف دقيقي كه از پروتكل‌هاي Http ،FTP، DNS،RPC و ... انجام ‌دهند، كليه درخواست‌ها از انواع مذكور را زيرنظر گرفته و به عبارتي فيلتر نمايند. در اين روش مدير امنيت شبكه مي‌تواند امكان دسترسي تعدادي از كاربران را در ساعات خاص و به محتواي مشخص مجاز يا غيرمجاز كند. به عنوان مثال وي مي‌تواند نمايش تصاوير موجود برروي صفحات وب را از طريق فيلتركردن فهرستي از پسوندهاي انواع فايل‌هاي گرافيكي در يك قاعده از نوع Http ، مسدود كند در حالي كه كاربران همچنان بتوانند آن فايل‌ها را از طريق پروتكل ديگري مثلFTP دريافت يا ارسال كنند.
همچنين در قواعد مربوط به فايروال مي‌توان دسترسي كاربران و يا گروه‌هاي كاربري را به تعدادي از آدرس‌هاي URL يا IPهاي مشخص مسدود كرد. ضمن آن‌كه قواعد مربوط به نحوه دسترسي كاربران براي انجام اموري مثل انتشار صفحات وب (Web Publishing) و امثال آن هم در همين جا تعريف مي‌گردد.

3- System Rule
در اين قسمت بيش از سي قاعده مربوط به دسترسي وجود دارد كه قابل انتساب به شبكه محلي مي‌باشند. اين قواعد نحوه ارتباط سرويس‌هاي يك شبكه را با يكديگر و همچنين با ISA مشخص مي‌نمايد. به عنوان مثال سرويسDHCP كه كليه درخواست‌ها و پاسخ‌هاي مربوط به انتساب ديناميك آدرسIP به كامپيوترهاي يك شبكه را مديريت مي‌كند، يا سرويس DSN كه وظيفه ترجمه اسامي و آدرس‌هاي شبكه را انجام مي‌دهد، مورد استفاده ISA قرار گرفته تا بتواند هم موقعيت خود در شبكه و با سرورهايي كه سرويس‌هاي فوق را ارايه مي‌دهند تشخيص دهد و هم با اطلاع از نحوه پيكربندي شبكه و ارتباط آن با محيط خارج اقدام به كنترل آن از طريق قواعد مربوط به شبكه و ديواره آتش بنمايد. به طور كلي سياست‌هاي موجود در قواعد سيستمي روابط ميان ISA و ساير منابع و سرورهاي موجود در شبكه را مشخص مي‌نمايند
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

یکشنبه، 30 مردادماه 1384

12:28 PM

August 21, 2005

هفت اشتباه بزرگ در تجارت الكترونيك‌

مترجم: منصور عمراني‌
ماهنامه شبکه - خرداد ۱۳۸۴ شماره 54

اشاره :
تنوع سليقه در نحوه خريد بين مصرف كنندگان امري مرسوم است. اگر شما يك فروشنده هستيد با اجتناب از چند اشتباه بسيار بزرگ، به مشتريانتان اطمينان خاطر دهيد كه بخش خريد سايت شما چيز وحشتناكي نبوده و كار با آن راحت و آسان است. بر اساس تحقيقي كه توسط يك شركت كارت‌هاي اعتباري منتشر گرديد، تقريباً نيمي از صاحبان كارت‌هاي ويزا نسبت به خريد اينترنتي، ترديدي بي‌دليل دارند. اين تحقيق فاش مي‌سازد كه عليرغم سهولت و راحتي استفاده آنلاين از كارت‌هاي اعتباري، تقريباً حدود 40 درصد مشتريان صاحب كارت‌هاي ويزا، در استفاده از اينترنت براي خريد كالاها و اجناس مورد نظر خود نوعي نگراني و ترديد دارند. متأسفانه بسياري از صاحبان فروشگاه‌هاي تجارت الكترونيك، به جاي اين كه حداكثر تلاش خود را براي كاهش اين دلواپسي‌ها و ترديدهاي مشتريانشان به كار ببرند، به طور ناخواسته آتش ايجاد شده را شعله‌ورتر مي‌كنند! هر روز داستان ديگري درباره خريد كالايي از اينترنت پخش مي‌شود كه باعث ترس و در نتيجه انصراف خريدكنندگان بعدي از خريد اينترنتي مي‌گردد. داستان‌هايي درباره كالاهايي كه به مقصد نرسيده‌اند، صفحات وبي كه قفل شده‌اند يا از كارت اعتباري خريدار دو بار برداشت كرده‌اند و فرم‌هاي خريدي كه تاييد نهايي خريد ندارند. اما اگر شما براي جلب اطمينان مشتريانتان وقت بگذاريد و سايت‌ تجارت الكترونيك خود را از ديد كاربر و نه از ديد فروشنده بر پا كنيد، به سادگي مي‌توانيد اين ترس‌هاي بي‌دليل را از دل مشتريانتان بزداييد. در اين مقاله ما به بررسي هفت اشتباه مهلك كه فروشندگان اينترنتي مرتكب آن مي‌شوند مي‌پردازيم و اصرار مي‌كنيم كه پيش از آن كه شركت شما نيز به شركت ديگري مبدل شود كه با سهل‌انگاري، اعتماد خريداران را درهم مي شكند، براي خود كاري بكنيد.

اشتباه اول: سبدهاي خريد گيج كننده‌
سناريو: خوب، بالاخره شما وارد يك سايت فروش اينترنتي محصولات شده‌ايد و مي‌خواهيد محصول يا كالايي را به صورت Online خريداري كنيد، با خوشحالي كارتان را در گشت و گذار از ميان دالا‌ن‌هاي مجازي اين بهشت Online تمام كرده و چرخ خريد رويايي خود را از انبوهي از اجناس مختلف، كه پس از صرف وقتي زياد با زحمت و دقت انتخاب كرده‌ايد پر نموده‌ايد و آماده‌ايد كه يك عالمه پول خرج كرده و به يك ساعت خريد سخت پايان ببخشيد.
مي‌خواهيد ببينيد كلاً چه چيزهايي در سبد خود گذاشته‌ايد، اما يك لحظه بايستيد! ... دكمه نمايش سبد خريد كجا است؟! در حقيقت از خود مي‌پرسيد چگونه بايد به مرحله كنترل سبد خريد برسم؟ آه، خداي من! من نمي‌توانم چيزهايي را كه انتخاب كرده‌ام عوض كنم! لغو! لغو! لغو!

در دنياي تجارت الكترونيك، فرم‌هاي خريد لغو‌شده و خريداراني كه خريدشان لنگ مانده است چيزي طبيعي هستند. بر اساس گزارش "مطالعه كارايي تجارت الكترونيك" كه توسط شركت Scivisum كه يك شركت مطالعه و تحليل و بررسي در مورد وب مي‌باشد تهيه شده است، فرم‌ها يا سبدهاي خريد هشتاد درصد سايت‌هاي انگليس ايراد دارند. تحقيق اين گزارش كه بر روي 51 سايت مشهور انجام شده است نشان داد كه ميزان لغو فرم‌هاي خريد در سايت‌هاي انگليس، 10 برابر بيشتر از اندازه استاندارد آن است.
راه حل: سادگي! يك سايت رنگارنگ، با نمايي خيالي و خارق‌العاده كه موزيك پخش مي‌كند، رنگ‌هاي رنگين كمان را به نمايش مي‌گذارد و ليستي طويل از انواع و اقسام محصولات مختلف را پيش چشمان مشتري رديف مي‌كند، ذره‌اي ارزش نخواهد داشت اگر مشتريان شما ندانند كجا بايد سفارش‌هاي خود را تكميل كنند.
مالكولم دافيت، مدير واحد تجاري شركت Dreamteam Design اظهار مي‌دارد: "از آنجا كه نمي‌توانيد به هنگام بازديد مشتريان از فروشگاه اينترنتي خود، جلوي هر يك از آن‌ها قرار گرفته و آن‌ها را راهنمايي كنيد، بايد براي آن‌ها امكان مرور جنس‌هايي را كه برداشته و در سبد خريد خود گذاشته‌اند، بسيار آسان سازيد و براي آن‌ها، واسطي ساده و كاربرپسند به منظور كنترل سبد خريدشان فراهم كنيد كه استفاده از آن نيز راحت باشد".
شما همچنين بايد با مشكلات اين كار آشنا باشيد. شبكه ClickZ بيان مي‌دارد كه 47 درصد صاحبان فروشگاه‌هاي اينترنتي اصلاً اطلاعي درباره ميزان ناتمام ماندن فرم‌هاي خريد خود ندارند.

اشتباه دوم: پرس و جوي بي‌دليل‌
سناريو: بازديدكنندگان سايت شما تمايل دارند كه تجربه خريد خود را به سرعت و بدون ايجاد هرگونه وقفه بي‌دليل به اتمام برسانند. حتي در سريعترين و قابل پيمايش‌ترين سايت‌ها، تعداد بسيار كمي از مشتريان، وقت يا حوصله

آن را دارند كه پيش از آن كه اجازه خريد پيدا كنند، زندگينامه خود را تنها به خاطر راضي كردن نياز بي حد و حصر شما به تحقيق در مورد نحوه خريد مشتريان، تايپ كنند. مطمئناً خودتان هم تحمل چنين چيزي را در فروشگاه محلي نزديك خانه خود نداريد، داريد؟
مارك تمپل، مدير واحد اجرايي شركت MAD قبلاً با چنين مواردي برخورد داشته است. او بيان مي‌دارد كه: "يكي از مشتريانMAD ارائه‌دهنده خدمات حقوقي است كه در وب سايت آن‌ها، پيش از آن كه بازديدكننده بتواند كار مورد نظر خود را سفارش دهد مجبور است به 26 سوال پاسخ بدهد. تعدادي از اين سوالات نيز واقعاً سوالات نامربوطي هستند مانند "كجا با ما آشنا شديد؟ يا ميانگين سالانه زماني كه براي انجام چنين اموري صرف مي‌كنيد چقدر است.
راه حل: تمپل اظهار مي‌دارد كه: هرگز سوالاتي كه ارتباطي با روند خريد ندارند از مشتري نپرسيد. مشتريان دوست دارند هر چه زودتر و سريعتر خريد خود را تمام كنند. در حقيقت اساساً به همين دليل است كه مي‌خواهند به صورت Online خريد كنند".

اشتباه سوم: مشكلِ پيدا كردن كالا
سناريو: شما فروشنده‌اي هستيد كه در فروشگاه اينترنتي خود بيش از هر فروشنده ديگري در كره زمين، كفش و لباس و پوشاك عرضه مي‌كنيد. انبار كالاهاي شما هم پر است از انواع و اقسام مختلف هر يك از اين كالاها كه سليقه هر خريداري را برآورده مي‌كند. حالا كه اين طور است، پس حداقل اين كار را براي آن‌ها راحت كنيد! لي

تاملينسون، مدير واحد توسعه بازرگاني شركت موتور جستجوي Mirago نيز با يك مورد خاص برخورد داشته است. او بيان مي‌دارد كه: "يكي از سايت‌هايي كه به صورت روزانه مرا اذيت مي‌كند فروشنده‌اي محبوب است كه طيف وسيعي از محصولات مختلف را از لوازم خانگي گرفته تا لوازم ورزشي، عرضه مي‌كند. وقتي كه وارد سايت اين شركت مي‌شويد در قسمت بالاسمت چپ آن يك كادر جستجو مي‌بينيد. اين كادر جستجو، قابليت بسيار مفيدي به نظر مي‌رسد. اما حقيقت اين است كه بايد در اين كادر، كُد كالا را وارد كنيد. واقعاً بايد پرسيد كسي كه مي‌خواهد خريد كند، از كجا بايد بداند كُد كالاي مورد نظر او در اين سايت چيست؟!"
راه حل: حتماً وقت گذاشته و در سايت خود امكان جستجويي كه كارا و مفيد باشد براي بازديدكنندگانتان فراهم كنيد. محصولات خود را گروه‌بندي كنيد و به نحوي اين كار را انجام دهيد كه مشتريان شما نيز اين گروه‌بندي‌ها را به راحتي بفهمند (از ديد مشتريان به اين قضيه نگاه كنيد نه از ديد خودتان). همچنين اطمينان حاصل كنيد كه سايت شما در موتورهاي جستجوي معروف ثبت شده باشد تا خريداران شما بتوانند از طريق موتورهاي جستجوي خارجي نيز، كالاهاي شما را در اينترنت پيدا كنند. دوروتي آرندت، مدير واحد توزيع و جستجو درKelkoo.co.uk مي‌گويد، تعداد مشترياني كه براي پيدا كردن صفحه محصول مورد نظر خود از موتورهاي جستجوي مختلف استفاده مي‌كنند به ميزان بالايي در حال افزايش است.

اشتباه چهارم: پيمايش با دردسر
سناريو: به صحنه ماجرا توجه كنيد: شما با خوشحالي در حال گشت و گذار در يك سايت ايترنتي هستيد كه يك دفعه متوجه مي‌شويد به‌جاي كليك بر روي لينك صفحه كارت تلفن اينترنتي، بر روي لينك صفحه كارت تلفن كليك

كرده‌ايد. مي‌گوييد. خوب. اشكالي ندارد. به عقب بر مي‌گردم. اما ... آه، خداي من ... مثل اين كه راهي براي برگشت به عقب وجود ندارد. واقعاً هيچ راهي براي خروج از قسمت كارت تلفن اينترنتي وجود ندارد؟!
دومينيك مانك‌هاوس، مدير اجرايي شركت Rackspace احساس شما را درك مي‌كند. او بيان مي‌دارد كه: " تعداد دفعاتي كه با يك سايت خريد اينترنتي با طراحي بسيار بد و قابليت پيمايش بسيار ضعيف برخورد داشته‌ام آنقدر زياد است كه اصلاً نمي‌توانم آن‌ها را بشمارم!" او مي‌گويد: "اگر صفحات يك سايت به طور مداوم ايراد داشته باشد و زمان اعتبار آن ها به سرعت به انقضاء برسد، مشتريان عصباني مي‌شوند". مردم دوست ندارند وارد جايي بشوند كه امكان برگشت ندارد يا روند پيمايششان در صفحاتي گير كند كه عبارت "اخطار! اعتبار صفحه به انقضاء رسيده است" يا "صفحه مورد نظر وجود ندارد" يا "لطفاً اطلاعات خود را مجدداً وارد كنيد" را نشان مي‌دهد.
راه‌حل: صفحاتي براي بازديدكنندگان مهيا كنيد كه اعلان‌‌هايي دقيق و واضح داشته باشند. تعداد صفحاتي را كه در اثناي خريد نياز به بازتازه‌شدن يا كامپايل مجدد دارند را كم كنيد. چنين چيزي كاربرپسندي ناميده مي‌شود. مانك‌هاوس اضافه مي‌كند: "يك سايت خريد اينترنتي بايد ساده باشد تا مردم به راحتي بتوانند آن را پيمايش كنند والا مردم، هرگز باز نخواهند گشت. سايت‌هاي خريد اينترنتي بايد با پرهيز از پيچيدگي پيمايش، از ترساندن مردم از خريد اينترنتي دست بردارند".

اشتباه پنجم: صورتحساب‌هاي عجيب‌
سناريو: خوب. بالاخره شما كالاهاي خود را انتخاب كرده و سبد خريدتان را پر نموده‌ايد و آماده‌ايد تا اطلاعات كارت اعتباري خود را وارد كرده و از طريق اينترنت، اين عنصر آسماني را (البته به صورت كُد شده!) براي فروشنده ارسال كنيد. اما چگونه بايد خريد خود را تاييد كنيد؟ دكمه Submit كجا است؟ اين همه موافقت‌نامه و شرايط قرارداد براي چيست كه بايد تاييد كنيد؟ نكند يك وقت دوبار پرداخت كنم؟! در حالي كه با كادرهايي كوچك در فرم خريد مواجه

شده‌ايد، ناگهان حسي غريب شما را در بر مي‌گيرد كه بايد هر چه زودتر اينجا را ترك كرده و خود را نجات بدهيد و سراغ فروشنده ديگري برويد كه كمتر ترسناك باشد!
ماركوس ريچاردسون، مدير اروپايي شركت WebtraffiQ مي‌گويد اين، ماجرايي آشنا است. "ما متوجه شده‌ايم كه برخي از سايت‌هاي تجارت‌الكترونيك، داراي روند خريدي پيچيده يا طولاني هستند كه باعث مي‌شود خريداران بترسند و به كل درباره خريد خود ترديد كنند".
راه حل: آزمايش كنيد، آزمايش كنيد و باز هم آزمايش كنيد. پيش از بارگذاري سايت تجارت‌الكترونيك خود يا ايجاد تغيير در آن، از صحت كاركرد روند پيمايش و خريد آن، اطمينان حاصل كنيد. بدين ترتيب مي‌توانيد هر نكته‌اي را پيش از آن كه يك خريدار يا بازديدكننده با آن مواجه شود، پيدا كنيد.
لويزي آرنولد، مدير بازاريابي شركت Scivisum پيشنهاد مي‌كند در قسمت پرداخت، حداكثر امكان كنترل به بازديدكنندگان داده شود، به طوري كه قادر باشند به راحتي در روند خريد عقب و جلو بروند، بدون آن كه داده‌اي را از دست بدهند يا مجبور باشند اطلاعاتي را دوباره وارد كنند.
آرنولد همچنين توصيه مي‌كند، به هنگام بررسي و تحت نظر گرفتن سيستم خريد و فروش خود، به ويژه به زمان پاسخ فرم‌هايي كه مشخصات مشتري را مي‌گيرند دقت‌‌كنيد تا در صورت طولاني بودن اين زمان بتوانيد با كوتاه كردن آن، از معطل ماندن مشتري جلوگيري كنيد".

اشتباه ششم: گيج كردن مشتري‌
سناريو: ممكن است فرد متخصص و باهوشي را براي طراحي سايت مدرن خود استخدام كرده باشيد، اما مواظب باشيد كه ديگر زياد از حد هم شورش را در نياوريد. اگر تمامي زرق و برقي كه در سايتتان به راه انداخته‌ايد به صورت

مانعي براي خريداران درآيد كه اساساً جلوي آن‌ها را از رفتن به قسمتي كه مي‌خواهند بروند يا پيدا كردن چيزي كه به دنبال آن مي‌گردند بگيرد، خريداران هرگز علاقه و توجهي به سر‌و‌صدا و شلوغ‌بازي‌هايي كه در سايتتان به راه انداخته‌ايد نشان نخواهند داد.
در حقيقت، هفتاد درصد مردم قادر به خريد از طريق اينترنت نيستند تنها به اين دليل كه چيزي را كه نياز دارند واقعاً پيدا نمي‌كنند. مت رمسي، يكي از مديران E3 Media مي‌گويد اين يك آمار تكان‌دهنده است. اين بدين معني است كه يكي از نكات كليدي موفقيت در توسعه يك سايت، كارايي آن است.
راه حل: اطمينان حاصل كنيد كه سايت شما كاربر پسند باشد و پيش از آن كه سير طراحي آن خيلي جلو برود، تا جايي كه مي‌توانيد، كارايي و كاربرپسندي آن را آزمايش كنيد.
رمسي بيان مي‌كند كه كاربرپسندي و قابليت استفاده، نقش نامحسوسي بازي مي‌كند. به طوري كه اگر هرچه كار با يك سايت سخت‌تر باشد، كاربران آن، احساس مي‌كنند كه محصولات سايت گرانتر است. عكس اين قضيه نيز درست است. اگر سايتي به راحتي قابل مرور و پيمايش باشد و محتواي آن به راحتي قابل درك بوده و عاري از عناصر پيچيده مختلف باشد، كالاهاي آن، ارزانتر از جاهاي ديگر به نظر خواهد رسيد.

اشتباه هفتم: وعده‌هاي پوچ‌
سناريو: شما يك تخته موج‌سواري نو به صورت online خريده‌ايد. امواج دريا بسيار عالي است، اما تخته موج‌سواري شما هنوز در راه است و به دست شما نرسيده است. نتيجه؟ شما نمي‌توانيد به موج‌سواري برويد! هنگامي كه ما چيزي را به صورت online مي‌خريم، طبيعتاً آن را همين الان مي‌خواهيم. حداقل در روزي كه فروشنده تحويل آن را

وعده داده است. سرعت خوب است، صحت و درستي نيز خوب است، و تحويل در حداقل زمان ممكن نيز خوب است. اما تاخير، بسيار بد است. مشتريان هرگز باز نخواهند گشت، چرا كه اگر صريح بگوييم، آن‌ها تعداد بي‌شمار ديگري از فروشندگان را براي خريد جنس مورد نظر خود، پيش رو دارند.
لزار دزاميك، مدير راهبردهاي الكترونيكي شركت UnderWired مي‌گويد، سايت Mothercare بهترين روند خريد را دارد. اگر شما ساعت 5 بعد‌از‌ظهر سفارش داده باشيد، كالاي مورد نظر شما معمولاً صبح روز بعد به دست شما مي‌رسد. اما يكي از رقيبان سر‌سخت آن يكي از بدترين روندهاي خريد را دارد. هميشه تاخير دارد، اجناسي را دوبار مي‌فرستد، يا اجناسي را اشتباهي مي‌فرستد، دوبار براي شما صورت‌حساب مي‌دهد، سيستم عودت‌‌دهي پيچيده‌اي دارد، ... . و در كل مي‌توان گفت خريداري كه يك بار از آن چيزي بخرد ديگر براي خريد پيش او بر نخواهد گشت!
راه حل: براي روند تكميل خريد و تحويل كالا تا آنجا كه مي‌توانيد وقت بگذاريد و پول خرج كنيد. تمام تلاش و زحمات شما به هدر خواهد رفت اگر كالاهاي سفارش داده شده را سر وقت به مشتريان تحويل ندهيد.
دزاميك مي‌گويد تكميل روند خريد با تحويل به موقع كالا به مشتري، تاثير بسيار بزرگي در معرفي مارك محصولات و تجربه كلي مشتريان از خريد اينترنتي‌شان دارد. دراختيار داشتن روان‌ترين سايت اينترنتي دنيا كمكي نخواهد كرد اگر آخرين مرحله آن ناقص بوده يا ايراد داشته باشد. مطالعات گوناگوني نشان مي‌دهد رغبت به خريد دوباره از يك سايت، به ميزان زيادي بر اساس روند تحويل كالا شكل مي‌گيرد.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

شنبه، 5 شهریورماه 1384

02:17 PM

August 27, 2005

WiMax استاندارد جديد شبكه هاي بي سيم

ماهنامه شبکه - آذر ۱۳۸۳ شماره 49

اشاره :
استاندارد جديد wimax براي شبكه‌هاي شهري بي‌سيم، بازار دستيابي به اينترنت را متحول خواهد كرد.

امروزه يافتن و خريدن يك كامپيوتر كيفي كه مجهز به تراشه Wi-Fi نباشد، كاري دشوار است، دكمه‌اي كه به كاربران كامپيوترهاي همراه اجازه دستيابي به اينترنت را فارغ از مكاني كه كاربر در آن حضور دارد مي‌دهد. بدين‌ترتيب از اتاق غذاخوري، اتاق نشيمن و يا كافي‌شاپ مي‌توان به اينترنت وصل شد.
عموم مردم بهWi-Fi به عنوان يك ايستگاه مركزي كاري كه مي‌تواند ارتباط را بين چندين كاربر به‌طور يكسان به اشتراك بگذارد علا‌قمندند. البته با اين محدوديت كه فاصله كاربران براي محيط داخلي (indoor) كمتر از 100 متر و براي محيط خارجي(outdoor) كمتر از 400 متر باشد. اما استاندارد جديدي معرفي شده است كه عملاً توانايي Wi-Fi را زير سؤال برده است. اين استاندارد معروف بهwimax مي‌باشد كه باعث ايجاد ارتباطات بي‌سيم اينترنتي با پهناي باند بالا با سرعتي نزديك به Wi-Fi كه محدوديت‌هاي آن را هم ندارد يعني تا فواصل بالاي حدود 50 كيلومتر را هم پشتيباني مي‌كند.
شبكه‌هاي شهري بي‌سيم با سرعت‌هاي پهناي باند بالا چندان جديد نيستند، اما تجهيزات خاص باندپهن عمدتاً گران قيمت هستند. در حال حاضر شركت‌ها به‌تدريج در حال رسيدن به توافق‌هايي بر روي جزييات استاندارد wimax هستند كه اين منجر به كاهش قيمت اين تجهيزات خواهد شد.
توافقات صنعتي روي جزيياتي نظير اين‌كه چگونه سيگنال‌هاي wimax را رمزگشايي كنيم تا فركانس‌هايي را ايجاد كنيم كه قابل استفاده باشند و چگونه امكان برقراري ارتباط چندين كاربر تا دستيابي به آن فركانس‌ها را فراهم كنيم، سرانجام به شركت‌هايي نظير اينتل اجازه خواهد داد تا تراشه كه حاوي قابليت wimax براي استفاده در تجهيزات بي‌سيم با پهناي باند بالا هستند را بسازند.

و در نهايت انتظار مي‌رود كه قيمت recieverهاي wimax به حدود 50 تا 100 دلار يعني چيزي حدود قيمت DSLها يا مودم‌هاي كابلي امروزي برسد و اين يعني ميليون‌ها نفر از كاربران بالاخره مي‌توانند از سرويس‌هاي رايج اينترنت استفاده كند و به آساني از طريق آنتن‌هاي نصب شده روي بام از هر گوشه شهر به اينترنت وصل شوند.

اگرچه ظهور اوليه wimax در حوزه‌هاي عمومي بوده است، اما با ظهور تدريجي تجهيزات و استانداردها، شاهد موج جديدي از صنايع كوچك و متوسط بي‌سيم خواهيم بود كه ديگر خطوط گران قيمت 1T1/E نيستند و ايستگاه‌هاي كاري همچنين مي‌توانند خدمات خود را در مكان‌هايي بدون خطوط تلفن هم ارايه دهند و اين يعني دستيابي پرسرعت به اينترنت در نواحي دورافتاده‌اي كه غالباً هيچ تجهيزات ارتباطي ندارند.
Wimax كه مخفف Woldwide Interoperability for Microware Access مي‌باشد، كمي فراتر از يك ليست طولاني از مشخصات تكميلي و تخصصي كه نمايشگر تجهيزات بي‌سيم كارخانه‌هاي مختلف كه مي‌توانند با سرعت‌هاي زياد با هم كار كند، است. اين استاندارد با نام IEEE802.16 نيز شناخته مي‌شود كه از سال 1990 كاربرد آن شروع شده است و نقطه مقابل فناوري‌هاي اترنت يا Wi-Fi بوده است. يك واحد انتقال‌دهنده wimax مي‌تواند صوت، تصوير و سيگنال‌هاي اطلاعاتي را در طول فواصل بالاي 50 كيلومتر (با رعايت خط ديد مستقيم) و با سرعتي در حدود 70 مگابيت درثانيه (يعني سرعتي كه براي دستيابي 60 شركت با سرعت خطوط 1T يا صدها كاربر خانگي با سرعت DSL كفايت مي‌كند) انتقال مي‌دهد.
اعلان شركت ا‌ينتل (در ژانويه 2004) كه موضوع اصلي‌اش در رابطه با wimax بود باعث رونق يافتن سريع اين فناوري و توسعه اين استاندارد شد.

شركت سازنده Centrino قبلاً طي يك ابتكار تراشه‌هاي Wi-Fi را درون كامپيوترهاي كيفي قرار داده بود. اسكات ريچاردسون مدير گروه بي‌سيم باند پهن شركت اينتل در اين رابطه گفت: <ما دنبال اين بوديم كه آيا مي‌توان همه شهرها را با Wi-Fi تحت پوشش اينترنتي قرار داد يا خير و اين‌كه شايد پوشش اينترنتي دادن يك شهر با تكنولوژي Wi-Fi كار ساده‌اي باشد اما مشكل از اين قرار است كه مديريت اين شبكه بسياربسيار سخت مي‌شد و در ضمن Wi-Fi بسيار هم محدود عمل مي‌كرد.
ريچادسون مي‌افزايد:‌ ما متوجه شديم كه Wi-Fi نيازمند اين است كه فراتر از يك تكنولوژي حامل رفتار كند و در ضمن از طيف وسيعي از توانايي‌ها هم بهره‌مند شود.

مسلماً wimax كه مي‌تواند در فواصل دورتر و تحت بازه وسيعي از فركانس‌ها كار كند، ايده‌آل خواهد بود. پس اينتل شروع به طراحي پردازند‌ه‌هاي ارتباطي براي كار، تحت اين فركانس‌ها (از 2 تا 11 گيگاهرتز يعني ناحيه‌ اصلي كه توسط Wi-Fi استفاده مي‌شود، امواج مايكرويو و انواع مخصوصي از رادارها) نمود و اولين تراشه را در ماه سپتامبر توليد كردند و سپس شروع به ايجاد و گسترش اتحاديه‌اي به نام اتحاديه wimax نمودند تا محصولات مختلف كارخانه‌ها را در اين مورد تأييد كند و مدعيان و پيشگامان اين تكنولوژي را مشخص سازند.
همچنين Intel Capital، يكي از بخش‌هاي اصلي شركت اينتل، شروع به سرمايه‌گذاري در چندين شركت نمود تا بتواند wimax را تبديل به وسيله سودآور نمايند و از آن به بهترين شيوه استفاده كند.
شركت speakeasy در سياتل، يكي از اين شركت‌هاست و البته مي‌تواند يكي از اولين ا‌ز گسترش‌دهندگان بازار wimax ‌باشد.

اين شركت در سال 1994، به عنوان يك كافي‌نت تأسيس شد تا ارتباطات فوق‌العاده سريع DSL را براي بازيگران كساني كه بازي‌هاي كامپيوتري مفصل online انجام مي دادند يا متخصصيني كه در منزل كار مي‌كردند، فراهم آورد اما به‌خاطر اين‌كه DSL هم تحت خطوط تلفن كار مي‌كند، در نتيجه يك محدوديت ذاتي را با خود به ارث برده است. مثلاً حدود 30 درصد از اهالي شهرهايي كه از خدمات شركت Speakeasy استفاده مي‌كنند از مراكز اصلي تلفن دور هستند. به نقل از يكي از مديران اين شركت، همين دوري افراد از مراكز اصلي تلفن مهم‌ترين محرك براي اين شركت بود تا به دنبال شيوه‌ها و روش‌هاي جديدي باشد و به همين علت، اكنون wimax مهم‌ترين و استراتژيك‌ترين پديده براي تجارت آن‌ها است.
Speakeasy شروع به آزمايش و بررسي فني تجهيزات wimax با استفاده از تراشه‌هاي اينتل نموده است و اميدوار است تا اواسط سال 2005 مشتريان زيادي را به خود جلب كند.
اگر چه ضرورت استفاده از wimax براي مصرف‌كنندگان، كسب و كارها و مردم در نواحي دورافتاده و صعب‌العبور براي داشتن يك دسترسي خوب و موفقيت‌آميز و پرسرعت به اينترنت كاملاً واضح و مبرهن است، اما اين اتفاق هم يك شبه هم رخ نخواهد داد.

در نهايت انتظار مي‌رود كه قيمت recieverهاي wimax به حدود 50 تا 100 دلار يعني چيزي حدود قيمت DSLهاي امروزي يا مودم‌هاي كابلي امروزي برسد و اين يعني ميليون‌ها نفر از كاربران بالاخره مي‌توانند از سرويس‌هاي رايج اينترنت استفاده كند و به آساني از طريق آنتن‌هاي نصب شده روي بام از هر گوشه شهر به اينترنت وصل شوند.
و همين مسأله احتمالاً باعث مي‌شود مدت زماني طول بكشد تا صنايع به سود اقتصادي اين فناوري دست بيابند و آن را عمومي كنند. پس هنوز هم ساختن شبكه‌اي از اتصال‌دهنده‌ها با ارزش است. ريچاردسون مي‌گويد: مردم فكر مي‌كنند كه شما مي‌توانيد تنها يك برج و برج فرستنده اصلي wimax را روي تپه‌اي در اطراف شهر قرار دهيد و با آن اينترنت همه شهر را تأمين كنيد. اما اين همه مسأله نيست، در اين‌جا هم دقيقاً مانند شبكه‌هاي تلفني با افزايش تقاضا ما مجبور به اضافه كردن برج‌‌هاي جديد هستيم. اما شركت Tower stream، شركتي كه قصد اضافه كردن wimax را به سرويس‌هاي خود دارد، اعلام نموده كه اين مشكل بدين شيوه حل مي‌شود كه مي‌توان بر روي ساختمان‌هاي بلند در شيكاگو، نيويورك، بوستون و شهرهاي ديگر، انتقال‌دهنده‌هاي ويژه wimax را نصب كرد و از يك اينترنت پرسرعت با ساختاري بي‌سيم بهره‌مند شد. ساختاري كه مطمئناً بسيار ارزان‌تر از سيم، فيبرنوري و كابل تمام خواهد بود.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 6 شهریورماه 1384

04:47 PM

August 28, 2005

ده اصطلاح رايج

نوشته: ميثم طاعتی - maysam.taati@yahoo.com
ناشر: آی تی ایران

اين مجموعه توضيحى در مورد ۱۰ اصطلاح و تکنولوژى رايج در دنياى اينترنت است.
1) PHP چيست ؟ PHP
سال 1994 توسط Rasmus Lerdorf ايجاد شد و مخفف واژگان
Personal Home Pages به حساب مى آيد. با گسترش قابليت ها و
موارد استفاده اين زبان PHP در معناى Hypertext Preprocessor
به كار گرفته شد. عبارت پيش پردازشگر (Preprocessor)
بدين معنى است كه PHP اطلاعات را قبل از تبديل به
زبان Html پردازش مى كند.
PHP زبان اسكريپتى سمت سرويس دهنده Html Embeded ,
Cross-Platform ,(Server-side) مى باشد .
سمت سرويس دهنده بودن PHP بدين معناست كه تمام
پردازشهاى اين زبان بر روى سرويس دهنده (Server)
انجام مى گيرد. يك سرويس دهنده در حقيقت يك
كامپيوتر مخصوص مى باشد كه صفحات وب در آنجا
نگهدارى مى شوند و از آنجا به مرورگر وب كاربران
منتقل مى شوند.
منظور از Cross-Platform بودن اين زبان اين است كه بروى
هر سيستم و با هر سيستم عاملى از قبيل : Unix, Windows NT,
Macintosh, Os/2 اجرا ميشوند. توجه كنيد كه منظور از
سيستم عامل، سيستم عامل هايى مى باشند كه بر روى
سرويس دهنده نصب مى شوند. PHP نه تنها قابليت اجرا
بر روى هر سيستم عاملى را دارا مى باشد بلكه براى
منتقل كردن برنامه هاى آن از يك سيستم عامل به
سيستم عامل ديگر احتياج بــه تغييرات اندكى
خواهيد داشت و حتى در بعضى از موارد بدون احتياج
به هيچ تغييرى مى توانيد يك برنامه به زبان php را
از يك سيستم عامل به سيستم عامل ديگر منتقل كنيد.
منظور از Html embeded بودن PHP اين است كه دستورات اين
زبان در بين كدهاى html قرار مى گيرند. بنابراين
برنامه نويسى به زبان PHP كمى پيچيده تر از برنامه
نويسى به زبان Html به حساب مى آيد.
PHP بر خلاف زبانهاى برنامه نويسى (Programming Languages)
يك زبان اسكريپتى (Scripting Language) مى باشد به عبارت
ديگر دستورات PHP بعد از رخداد يك رويداد (Event)
اجرا مى شوند. اين رويدادها مى توانند شامل
ارسال يك فرم رفتن به يك URL مشخص و يا مواد ديگر
باشند متداولترين زبان اسكريپتى زبان Java Script مى
باشد كه معمولا براى پاسخ به رويدادهاى كاربر در
مرورگر وب بــه كار مى رود تفاوت عمده Java Script با
PHP در اين است كه Java Script يك تكنولوژى سمت
سرويس گيرنده (Client-side) مى باشد.
زبان هايى مانند Java Script يا PHP تفسير شونده
(Interpreted) ناميده مى شوند. به عبــارت ديگر براى
اجرا به يك مفسر مانند مرورگر وب احتياج دارند.
اما زبانهاى برنامه نويسى مانند C يا Java بعد از
ترجمه به زبان ماشين (Compile) به خودى خود قابل اجرا
مى باشند.

2) XML چيست ؟
در ابتدا لازم است با کلمات تشکيل دهنده XML يعنى
Extensible ، Markup و Language آشنا شويم .Markup ، واژه ئى براى
متاديتا است . متاديتا ، اطلاعاتى در رابطه با
اطلاعات است . قدمت استفاده از Markup به قبل از
کامپيوتر بر مى گردد . مثلا\\" در دنياى نشر از
علائم خاصى در متن هاى ويرايش شده استفاده تا به
پردازنده متن ( انسان و يا ماشين ) اعلام شود ، چه
نوع عملياتى را در رابطه با اطلاعات مى بايست
انجام دهد. HTML يکى از زبان هاى کلاسيک نشانه
گذارى است . مثلا\\" با افزودن تگ به مرورگر اعلام
مى شود که به چه صورت مى بايست اطلاعات نمايش
داده شوند .
زبان (Language) ، به مجموعه اى از کلمات معنى دار و
با مفهوم که عده اى از آنها براى بيان خواسته ها
ى خود استفاده مى نمايند ، اطلاق مى گردد . ( مثلا
زبان فارسى و يا انگليسى)
با کنار هم قرار دادن دو واژه اشاره شده ، با
زبان نشانه گذارى مواجه خواهيم شد . زبان نشانه
گذارى ، به مجموعه اى از کلمات معنى دار و با
مفهوم که توسط عده اى (با آگاهى لازم انتخاب )
استفاده مى گردد ، اطلاق مى گردد. HTML ، نمونه اى
مناسب در اين زمينه است . تمام افرادى که از تگ
هاى HTML استفاده مى نمايند ، بدرستى نسبت به
مفهوم و جايگاه هر يک از تگ ها آشنائى داشته و با
آگاهى کامل آنها را براى بيان خواسته هاى خود
استفاده مى نمايند. مثلا\\" مشخص است که استفاده
از تگ چه نوع پيامدهائى را بدنبال خواهد داشت .
تگ فوق ، توسط مولفين صفحات وب آگاهانه انتخاب
مى گردد و مرورگ!
رها نيز متناسب با تعاريف از قبل مشخص شده ،
واکنش مناسب خود را در رابطه با نحوه نمايش
انجام خواهند داد. يک زبان بسط پذير(Extensible) ،
زبانى است که داراى مکانيزم لازم براى افزودن
کلمات بگونه اى است که توسط ساير استفاده
کنندگان نيز قابل فهم باشد . در دنياى واقعى و در
ارتباط با زبان هاى طبيعى ما هرگز شاهد چنين
وضعيتى نخواهيم بود . ( افزودن يک واژه با معنى
مورد نظر خود و استفاده از واژه با همان معنى
توسط ساير استفاده کنندگان ) با توجه به تعاريف
ارائه شده ، يک زبان نشانه گذارى بسط پذير ، مى
بايست يک زبان نشانه گذارى با قابليت افزودن
کلماتى بيشتر باشد . در عمل ز!
بان نشانه گذارى بسط پذير ، به سيستمى براى
تعريف تمام زبا ن هاى نشانه گذارى با قابليت
توسعه وضعيت موجود ، اطلاق مى گردد.
(SGML)Standard Generalize Markup Language سرچشمه XML بوده و در سال
1988 استاندارد شده است. (HTML)HyperText Markup Language زبانى
است که در ابتدا با استفاده از SGML تعريف گرديد.
HTML يک زبان نشانه گذارى است ، بنابراين انتظار
داريم شامل مجموعه اى از تگ ها بمنظور کنترل
قالب و رفتار اطلاعات در مستندات باشد. XML يک
زبان نشانه گذارى مشابه HTML نمى باشد.XML
زيرمجموعه اى از SGML است ( مکانيزمى براى تعريف
زبان هاى نشانه گذارى). XML همانند SGML يک زبان
نشانه گذارى بسط پذير بوده اما بر خلاف SGML براى
استفاده بر روى وب بهينه شده است .
XML ، يک زبان نشانه گذارى نبوده و در مقابل
مکانيزمى براى ايجاد زبان هاى نشانه گذارى
اختصاصى است.XML شامل مجموعه اى از استانداردها ى
متنوع با کاربردهاى خاص است. XML يک زبان نشانه
گذارى نبوده و در عين حال يک زبان برنامه نويسى
هم نيست . از XML براى ارائه اطلاعات استفاده شده و
بمنظور پردازش اطلاعات، مى بايست برنامه هائى
نوشته گردد .
از XML در موارد زيرمى توان استفاده کرد :
• مبادله اطلاعات بين برنامه هاى نامتجانس ،
بنگاه هاى تجارى و بانک هاى اطلاعاتى
• امکان فعال نمودن مدلى براى نمايش اطلاعات
يکسان بر روى دستگاههاى متفاوت با اهداف و
خوانندگان گوناگون
• يک قالب ذخيره سازى مناسب براى داده ها

3) XSLچيست ؟
عبارت XSL سرنام‌هاى \\"eXtensible Stylesheet Language\\" است. يک
XSL شامل دستورالعمل‌هايى براى شکل‌دهى به
محتويات يک فايل XML است. قالب کلى يک فايل XSL را مى
توانيم با وارد کردن آدرس res://msXML.dll/default.ss.XSL در
قسمت آدرس مرورگر خود مشاهده كنيم. اين مثال،
نمونه‌اى کامل از يک سند XSL است که براى آشنايى
اوليه و دست‌يابى به يک ديد همه‌جانبه، مناسب
خواهد بود.
نتيجه‌ى تبديل و پيكربندى يک سند XML به وسيله XSL،
مى‌تواند به صورت يک فايل html يا يک فايل XML ديگر
باشد.

4) XSLT چيست؟
عمل تبديل XML بوسيله XSL را XSLt مى‌گويند (XSL transform).
براى انجام عمل تبديل، به يک پردازنده‌ى XSLt
نياز داريم تا داده‌هاى سند XML و
دستورالعمل‌هاى XSL را بخواند و بر اساس آن
دستورالعمل‌ها داده‌ها را در خروجى html بنويسد.
مى‌توان اين کار را با برنامه‌نويسى c# و
استفاده از موتور XSLt موجود در c#.net انجام داد و يا
از پردازنده‌هاى XSLt جداگانه‌اى که نمونه‌هايى
از آن‌ها به صورت رايگان موجود است، استفاده
كرد.

5) WAP چيست؟
WAP سيستمى است كه در آن پروتكل ارتباطى و محيط
برنامه نويسى جهت پياده سازى سيستم هاى پياده
سازى سيستم هاى اطلاعاتى مبتنى بر وب روى گوشى
هاى تلفن همراه ارايه مى شود .
پروتكل ارتباطى
پروتكل ارتباطى كه در حال حاضر در اينترنت براى
ديدن صفحات وب استفاده مى شود HTTP است .( البته در
سطح شبكه اينترنت براى فعاليت هاى متفاوت
پروتكل هاى متفاوتى در سطح لايه Application استفاده
مى شود ولى پروتكلى كه جهت ديدن سايت ها از آن
استفاده مى شود HTTP است ) .
وقتى آدرس سايتى را به اينترنت اكسپلورر مى دهيد
تا صفحه مربوط به آن سايت را ببينند ، در پشت
پرده ، اينترنت اكسپلورر بسته اى را حاوى
اطلاعاتى جهت در خواست صفحه آن سايت است به
اينترنت مى فرستد . اطلاعات اين بسته به فرمتى
است كه در پروتكل HTTP تعريف شده است . با اين توصيف
، وقتى صحبت از تلفن همراه مى شود در نگاه اول
مساله حل شده است و فقط كافى است اين بار تلفن
همراه شما چنين بسته اى ساخته و به اينترنت
بفرستد . ولى اين كار براى يك تلفن همراه شدنى
نيست . زيرا بسته هايى كه در پروتكل HTTP ساخته مى
شوند حجم زيادى دارند و لذا لازم است فرستنده
داراى حافظه مناسبى باشØ!
¯ .
در حالى كه تلفن همراه از نظر حافظه بسيار محدود
است ( البته به تازگى گروهى از تلفن هاى همراه با
نام Smart phone وارد بازار شده اند كه از نظر حافظه
نسبت به انواع قديمى تر بسيار قوى تر ند . )
همچنين جهت پردازش بسته هايى كه با پروتكل HTTP
ارسال و دريافت مى شوند ، نياز به پردازشگرى قوى
تر از آن چه كه در يك تلفن همراه وجود دارد ، مى
باشد . لذا جهت ورود تلفن همراه ، به دنياى
اينترنت ضرورى است با توجه به قابليت هاى يك
تلفن همراه پروتكل ويژه اى طراحى شود. اين
پروتكل WAP نام دارد . البته WAP فراتر از يك پروتكل
ساده در لايه Application مى باشد و بهتر است به آن
پشته پروتكل WAP (Protocol St!
ack) بگوييم .
پشته پروتكل WAP داراى شش لايه مى باشد و يك
ارتباط connection less را در دنياى تلفن هاى همراه
ايجاد مى كند . در اين جا اشاره مختصرى به كار هر
يك از لايه ها مى كنيم:
1- :Bearer Layerمعادل همان لايه فيزيكى در TCP/lP مى باشد
ولى اين بار محيط ارتباطيwireless است و لذا پروتكل
هاى ديگرى در اين لايه استفاده مى شود .
2- WDP: اين لايه در واقع همان UDP است . به عبارت
ديگر فعاليت و ساختارى مانند پروتكل UDP در لايه
انتقال TCP/lP دارد .
3- WTLS: لايه اى است كه امنيت ارتباطات را فراهم مى
كند . در اين لايه از پروتكل SSL استفاده مى شود .
4- WTP : اين لايه مديريت در خواست ها و پاسخ ها را
بر عهده دارد .
5-WSP : همانند لايه session در OSi مى باشد ، با تفاوت
هاى مختصرى جهت بهينه سازى .
6- WAE : همانند لايه Application در TCP/lP مى باشد . در واقع
تمام برنامه هايى كه پياده سازى مى شوند در اين
لايه قراردارند و كاربر تلفن همراه و برنامه
نويس WAP ، هر دو، با لايه ارتباط برقرار مى كنند.
مشكل عدم توانايى تلفن همراه جهت استفاده از
پروتكل HTTP با طراحى پشته پرو تكلى جديد ى با در
نظر گرفتن محدوديت هاى تلفن همراه حل شد . ولى
استفاده از اين پروتكل مشكل جديدى را ايجاد مى
كند . كه ضرورى است تدبير خاصى براى حل آن
انديشيده شود .

6) RDF چيست ؟
• از Resource Description Framework به معنى چارچوب توصيف
منابع مى آيد.
• براى توصيف کردن منابع موجود در اينترنت است.
• براى خوانده شدن توسط کامپيوترها طراحى شده
است.
• براى نمايش داده شدن به مردم طراحى نشده است.
• از URIها براى تشخيص منابع وب استفاده مى کند.
• در XML نوشته مى شود.
• يک نمونه از استانداردهاى وب است.
RDF براى اينکه از راهى مشترک براى توصيف اطلاعات
استفاده نشود طراحى شده، بنابراين مى تواند
بوسيلۀ کاربردهاى کامپيوترى خوانده ( درک)
شود.توصيفهاى RDF براى نمايش داده شدن در روى وب
طراحى نشده اند.
مثالهايى از استفادۀ RDF:
• شرح خصوصيات اقلام خريد و فروش، مثل خريدکردن
و موجودي.
• شرح برنامه ريزى زمانى براى رويدادهاى وب.
• شرح اطلاعاتى در مورد صفحات وب، مثل تاريخ
ايجاد واصلاح، عنوان و نويسنده.
• شرح محتويات و درجه عکسهاى وب.
• شرح محتويات ماشيهاى جستجو.
• شرح کتابخانه هاى الکترونيکي.

7) SOAP چيست ؟
• پروتکلى براى دستيابى به سرويسهاى وب است.
• از پروتکل دستيابى به اشياء ساده مى آيد.
• يک پروتکل ارتباطى است.
• براى ارتباط دادن بين کاربردها است.
• قالبى براى پيغامهاى ارسالى است.
• براى ارتباط برقرار کردن از طريق اينترنت
طراحى شده.
• يک زبان مستقل است.
• بر پاىۀ XML ساخته شده.
• ساده و قابل توسعه است.
• به يک استاندارد W3C توسعه خواهد يافت.
SOAP براى توسعه کاربردى ارتباطات اينترنتى بين
برنامه ها مهم است.
يک راه خوب براى برقرارى ارتباط بين کاربردها از
طريق HTTP است.زيرا HTTP بوسيلۀ همۀ جستجوگرهاى
اينترنتى پشتيبانى ميشود.SOAP براى انجام اين کار
طراحى شده است.
SOAP راهى را براى برقرارى ارتباط بين درخواستهاى
ايجاد شده در سيستمهاى عامل مختلف ، با
تکنولوژيهاى مختلف و زبانهاى برنامه نويسى
متفاوت فراهم ميکند.

8) ADO چيست ؟
ADO ميتواند براى دسترسى به پايگاه هاى داده از
صفحات وب ما استفاده شود.
آنچه که بايد قبل از پرداختن به ADO بدانيم
عبارتند از:
1- www، HTML و مقدماتى درمورد صفحات web
2- صفحات سرور فعال ( ASP )
3- زبان پرس و جوى ساخت يافته ( SQL )
ADO :
• يک تکنولوژى ماکروسافت است.
• از ActiveX Data Objects مى آيد.
• به طور اتوماتيک همراه IIS نصب ميشود.
• يک سطح برنامه نويسى براى دسترسى داده ها در
يک پايگاه داده ميباشد.
راههاى دستيابى به يک پايگاه داده از درون يک
صفحۀ ASP:
1- ايجاد يک اتصال ADO به يک پايگاه
2- باز کردن ارتباط با پايگاه
3- ايجاد يک ADO Recordset
4- باز کردن Recordset
5- استخراج داده مورد نياز از recordset
6- بستن recordset
7- بستن ارتباط

9) JavaScript چيست ؟
JavaScript در ميليونها صفحۀ وب براى بهتر کردن
طراحى، فرمهاى معتبر و... بکار مى رود و با netscape
توسعه يافته و رايجترين زبان اسکريپتى روى
اينترنت است.
JavaScript :
• ساخته شده تا با آن بتوان صفحات وب فعال ساخت.
• خطوطى از کدهاى کامپيوترى قابل اجرا است.
• معمولاً مستقيماً در صفحات HTML جاسازى ميشود.
• بدون گردآورى مقدماتى اجرا ميشود.
JavaScript چه کارهايى ميتواند انجام دهد:
ابزار طراحى و برنامه نويسى HTML را در اختيار
قرار ميدهد: مؤلفه هاى HTML معمولاً برنامه نويس
نيستند، اما JavaScript يک زبان اسکريپتى با دستور
لغات بسيار ساده است
ميتواند متنهاى پويا را در يک صفحۀ HTML قرار
دهد:يک عبارت JavaScript مثل اين ميتواند يک متن
متغير را درون يک صفحۀ HTML بنويسد:
document.write(“”+name+””).
ميتواند نسبت به وقايع واکنش نشان دهد: يک JavaScript
ميتواند مجموعه اى براى اجرا کردن در زمانى که
رويدادى رخ ميدهد باشد، مثل زمانى که لود کردن
يک صفحه به پايان رسيده و يا زمانى که کابر روى
يک عنصر HTML کليک ميکند.
ميتواند عناصر HTML را بخواند و بنويسد:يک JavaScript
ميتواند محتويات يک عنصر HTML را بخواند و يا
تغيير دهد.
ميتواند براى داده هاى موجود استفاده شود: يک
JavaScript ميتواند داده هاى فرم را قبل ازاينکه به
يک سرور ارائه شود معتبر کند. اين کار سرور را از
پردازشهاى بزرگ رها ميسازد.

10) JavaScript چيست ؟
قبل از کار کردن با CSS بايد درکى مقدماتى در مورد
WWW ، HTML و ساخت صفحات وب داشته باشيم.
CSS از Cascading Style Sheets به معنى برگه هاى به سبک
آبشارى مى آيد.
اين سبک چگونگى نشان دادن عناصر HTML را تعريف مى
کند.
CSS براى حل کردن مشکلى به HTML 4.0 اضافه شده بود.
با CSS متنهاى HTML ما ميتوانند با استفاده از
سبکهاى خروجى مختلف نمايش داده شوند.
CSSيک مشکل رايج را حل مى کند:
برچسبهاى HTML در اصل براى تعريف محتويات يک متن
طراحى شده بودند.گويى آنها با استفاده از
برچسبهايى مثل ،

، و ... مى گفتند:\\" اين يک عنوان است\\"، \\" اين يک
پاراگراف است\\" و يا \\" اين يک جدول است\\" .
وقتى که دو جستجوگر بزرگ – Netscape و Internet Explorer –
سعى کردندکه برچسبهاى HTML و صفاتى مثل نوع قلم و
رنگ را به مشخصات HTML اصلى اضافه کنند ، ايجاد
سايتهاى وب جايى که محتويات متون HTML به طور
آشکارا از طرح بندى نمايش متن مجزا ميشد، خيلى
خيلى مشکلتر شد.
براى حل اين مشکل کنسرسيوم شبکه گستردۀ جهانى (
W3C ) STYLES را به HTML4.0 اضافه کرد.

منابع :
www.w3schools.ir
www.irandevelopers.com
www.iranphp.net
www.khaterat.ir
www.ccwmagazine.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

سه شنبه، 8 شهریورماه 1384

01:36 PM

August 30, 2005

ساخت CDهاي Autorun

مترجم: ميلاد اميريان‌فر
ناشر: ماهنامه شبکه - اسفند ۱۳۸۳ شماره 52
http://www.shabakeh-mag.com

اشاره :
بيشتر CDها يا DVDهاي تجاري و تبليغاتي به محض اين‌‌كه در درايو قرار مي‌گيرند، به سرعت خود را به كاربر معرفي مي‌كنند، بدون آن‌كه كاربر به چيزي دست زده باشد. اين نوع ارايه اطلاعات در اين CDها يا DVDها هنگامي جذاب‌تر مي‌شود كه با يك صفحه splash، يك انيميشن Flash، يك موزيك مهيج و يا حتي يك فيلم كوتاه همراه شود. در اين مقاله ما مي‌خواهيم با معرفي يك نرم‌افزار، كاري كنيم تا شما بتوانيد به راحتي از امكانات فوق در CDهايي كه مي‌خواهيد رايت كنيد بهره ببريد.

در حالت معمول اگر شما يك فايل انيميشن يا يك موسيقي را روي CD رايت كنيد و آن را درون درايو قرار دهيد اتفاق خاصي نمي‌افتد. چون در سيستم‌عامل‌ها به طور معمول قابليت autorun يا خودراه‌انداز وجود ندارد. (اگر چه در ويندوز XP راه‌هاي زيادي براي اين‌كار وجود دارد).
براي اين‌كه ما يك autorun CD داشته باشيم، علاوه بر اطلاعات موردنظرمان بايد فايل‌هاي ديگري نظير فايل autorun.inf را نيز روي CD قرار دهيم. نوع اين فايل txt ‌بوده و خودتان نيز مي‌توانيد آن را ايجاد كنيد. اما آسان‌ترين راه، استفاده از برنامه‌اي است كه اين‌كار را به راحتي براي شما انجام مي‌دهد. يكي از برنامه‌هايي كه در اين كار به شما كمك فراواني مي‌كند، برنامه‌اي است تحت عنوان 0.2 Autorun wizard v كه نسخه آزمايشي آن از روي نشاني http://www.rjlsoftware.com/software/utility/autorun/order.shtml قابل دريافت است. البته اين برنامه صفحه splash (همان صفحه ظاهر شونده اوليه) خود را به Autorun CD شما مي‌افزايد و همچنين هزينه خريد آن در حدود بيست دلار است.
براي ساختن CD خودراه‌انداز قبل از هر كاري لازم است در آن قسمتي از هاردديسك كه اطلاعات موردنظر شما براي رايت CD وجود دارد، پوشه‌اي ايجاد كنيد كه بعداً در برنامه Autorun wizard مورد استفاده قرار بگيرد سپس بايد برنامه را اجرا كنيد و تمام كارهايي كه CD شما از لحظه قرار گرفتن در درايو بايد انجام دهد را در آن معرفي مي‌كنيد. سپس CD خودرا رايت كنيد.

راهنماي گام به گام
استفاده از برنامه Autorun Wizard

1 - در جايي كه اطلاعات موردنظر شما براي رايت‌ روي CD وجود دارد پوشه‌اي ايجاد كنيد و نام آن را CD Base يا هر نام ديگري كه در حافظه‌تان مي‌ماند بگذاريد و فايل Autorun.zip را در اين پوشه باز كنيد.

2 - فايل Config.exe را اجرا كنيد. با اين كار wizard برنامه آغاز به كار مي‌كند. به زبانه Base folder برويد و آدرس پوشه موردنظرتان را كه فايل‌هاي مربوط به Autorun بايد در آنجا ساخته شوند را وارد كنيد. بدون تعيين اين آدرس نمي‌توانيد وارد مراحل بعدي شويد.

3 - زبانه بعدي Auto Lunch نام دارد. تمام اتفاقاتي كه قرار است وقتي CD را در درايو مي‌گذاريم، بيفتند را در اين‌جا به برنامه معرفي مي‌كنيم. اتفاقاتي مثل باز شدن ويندوز اكسپلورر يا مثلاً اجرا شدن چند فايل و ... مثلاً فايل‌هاي موردنظرتان براي اجرا شدن را انتخاب كنيد. در آخر روي Lunch file و بعد روي Configure كليك كنيد و آدرس فايل‌هايي را كه مي‌خواهيد استفاده شوند به برنامه بدهيد.

4 - روي Icon كليك كنيد. اگر آيكون خاصي را براي CD موردنظر داريد آدرس فايل ICO. را به برنامه بدهيد. همچنين اگر صفحه splash را نيز مي‌خواهيد روي CD داشته باشيد آدرس تصوير آن را به برنامه بدهيد.

5 - روي زبانه options شما مي‌توانيد يك برچسب (label) مشخص و البته يك فايل صوتي wav. را به CD خود ضميمه كنيد. روي زبانه Test روي كليد Test را كليك كنيد. اگر از نتيجه كار راضي هستيد آن را save كنيد و
Autorun wizard را ببنديد.

6 - برنامه رايت CD را باز كنيد و همه فايل‌هاي موجود در فولدر CD Base (يا هر نام ديگري كه انتخاب كرده بوديد) را روي CD رايت كنيد. در اين فولدر به غير از فايل‌هاي موردنظرتان، بايد فايل‌هاي autorun.inf و autorun.dat و autorun.exe نيز وجود داشته باشند.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 8 شهریورماه 1384

01:43 PM

August 30, 2005

واحدهای سازنده مديريت روابط با مشتری (CRM)

برگردان: پیمان رضایی
ناشر: ماهنامه دنیای مخابرات و ارتباطات

CRM يا مديريت روابط با مشتری را يکی از کليدهای تعيين کننده موفقيت شرکت‌ها در قرن 21 ذکر کرده اند. از نظر بسياری از شرکت‌ها، CRM راهبردی تجاری است که سود، درآمد و رضايت مشتری را با لحاظ موارد ذيل برآورده می سازد.

· ايجاد سنجش‌های مرتبط با مشتری مانند امور مشترکين

· تقويت رفتارهای سازمانی به گونه ای که در جهت تحقق نياز و رضايتمندی مشتری باشد.

· انجام فرايندهای متمرکز بر مشتری

سازمان‌ها بايد بدانند که CRM، در دراز مدت ارزش خود را نشان می دهد. تحقق CRM منوط به آن است که سازمان آن را به عنوان راهبردی برای کل سازمان تعريف کند.

فعاليت‌های CRM، بايد در قالب چارچوبی تعريف شوند تا به اين ترتيب از انجام برنامه‌ها بر مبنايي راهبردی، متوازن و يکپارچه اطمينان حاصل شود. اين چارچوب را می توان در قالب 8 واحد سازنده زير شکل داد:

1- چشم انداز: در چشم انداز، تصوير شرکت يا موسسه مشتری گرا ترسيم می گردد. هدف از اين تصوير مشخص کردن موقعيت تجاری است.

2- راهبرد: برای اجرای CRM بايد راهبردی تدوين گردد که طی آن مشتری جزء دارايي‌های شرکت يا بنگاه تجاری تلقی گردد و اين امر با دادن ارزش به مشتری حاصل می شود. در اين راهبرد اهداف بايد تدوين و استفاده از منابعی که برای تعامل با مشتريان به کار می روند، تعيين می گردد.

3- ارائه ی ارزش به مشتری: بايد اطمينان يافت که مجموعه ی خدمات بنگاه و تعاملات با مشتری نوعی ارزش دائمی را به مشتری ارائه کنند،اين امر در تثبيت موقعيت بنگاه در بازار امری ضروری است.

4- همکاری‌های درون سازمانی: بايد ساختار، رفتار و فرهنگ سازمانی را به گونه ای متحول نمود که تمامی کارکنان، شرکاء و توليد کنندگان، همگی در خدمت ارائه ارزش به مشتری باشند.

5- فرايندها: مديريت و اداره ی موثر فرايندهايي چون فرايندهای هيئت مشتری ( به طور مثال پذيرش مشتريان جديد، پرداختن به خواسته‌ها، نيازها، شکايات آن و همين طور برگرداندن مشتريان از دست رفته) و فرايندهای تحليلی و برنامه ريزی برای شناخت مشتری.

6- اطلاعات: جمع آوری اطلاعات خام صحيح و مسيردادن در جای مناسب

7- فناوری: مديريت بر داده‌ها و اطلاعات، درخواست نامه‌های مربوط به مشتری، زيرساخت IT و معماری آن

8- سنجش‌ها: اندازه گيری و سنجش شاخص‌های درونی و بيرونی توفيق و يا عدم توفيق CRM

کليد | وضعيت محافظت | سرمايه گذاری برای محافظت | سرمايه گذاری برای گرفتن بازار | محدود تخريب
پول بيشتر | رقابت متقابل | سرمايه گذاری برای ايجاد | تحقق فرصت‌ها | مديريت دست به عصا
برخی از پتانسيل‌ها | مديريت ايجاد منافع | ايجاد قابليت انتخاب | مديريت درآمد | مديريت درآمد
تعامل | مديريت برای ايجاد منافع | مديريت ايجاد منالع | مديريت درآمد | بررسی تنوع
 | امنيت خيلی زياد | امنيت خوب | آسيب پذير | شکننده

ايجاد چشم انداز CRM

برای ايجاد چشم انداز CRM در بنگاه تجاری، مديران بنگاه بايد اقدامات زير را انجام دهند:

· مفهوم CRM را برای بنگاه تجاری تعريف کنند.

· اهداف را مشخص کنند.

· آنچه را بنگاه برای مشتريان هدف خود در نظر دارد ترسيم کنند.

قدم بعدی- خلق مجموعه ای از ارزش‌های رقابتی و متمايز نام تجاری خدمات. اين مجموعه بايد با توجه به نظريات مشتری و از منظر شرکت تهيه شود. قدم نهايي در ايجاد چشم انداز، ترسيم مسائل مربوط به مشتری در موقعيت‌ها و وضعيت‌های مختلف است.

تدوين راهبرد CRM

راهبرد CRM، اهداف مالی و مسير حرکت خود را از راهبرد کسب و کار خود می گيرد و سعی می کند راهبرد بازاريابی را بر آن اساس تنظيم کند. در راهبرد CRM، کلياتی از چگونگی ايجاد روابط ارزشمند با مشتری و وفاداری مشتری ذکر می شود.

راهبرد کسب و کار

چگونه می توان ارزش را برای صاحبان سهم به ارمغان آورد و مزايای رقابتی را برای او ايجاد کرد.

راهبرد بازاريابی

چگونه می توان فرصت‌های بازار را غنيمت شمرد و تهديدهای ناشی از رقابت را کم اثر کرد؟

· جشم انداز، وضعيت و موقعيت بازار

· تعريف و مميزی بازار،

· تجزيه تحليل توانايي‌ها، ضعف‌ها و فرصت‌ها و تهديدها

· بخش‌های بازار هدف

· اهداف هر بخش از بازار: قدرت نفوذ

راهبرد CRM- چگونه می توان با ارائه ارزش و خلف ارزش برای مشتری، به مشتری نزديک تر شد؟

· چشم انداز: تجربه کار با مشتریچ

· تعريف مشتری: رفتار و بررسی نيازهای او

· تحليل توانايي

· قسمت بندی کردن مشتريان هدف، با توجه به ارزش

· هدف هر بخش از مشتريان تعريف شده:

اکتساب، توسعه، نگهداری و کارايي

· معيارها: رضايتمندی، وفاداری، هزينه ی خدمتگذاری و رضايت کارکنان

· ترسيم راهبرد بر اساس چرخه عمر مشتری

(تصوير1)

مرحله نخستين تدوين راهبرد CRM، قراردادن مشتريان دررده‌های مشخص و تنظيم اهداف و اندازه‌های هر رده و قسمت است.

مرحله دوم، ارزيابی وضعيت مشتريان، به عنوان يکی از دارايي‌هاست. اين ارزيابی مستلزم ترسيم قوت‌هاو ارزش روابط مشتری از دو منظر زير است:

· مشتری چقدر ارزش برای شرکت به ارمغان می آورد؟

· شرکت چقدر ارزش برای مشتری قائل خواهد شد؟

حاصل اين ارزيابی ، ماتريس دارايي مشتری ، است (تصوير2) که ترکيبی از نظريه ی توليد کننده در خصوص رده‌های ارزشی تعريف شده مشتری و برآورد توانايي‌های روابط مشتری است.

مرحله سوم، تعريف اهدافی است که بايد دستيابی شود و تاکتيک‌هايي است که بايد استفاده گردد.

راهبرد مشتری، راهبرد بازاريابی سنتی را برای رده‌های مختلف مشتری هدف، مطابق با نيازها ترسيم می کند.

طراحی تجربه کار با مشتری

تعامل با مشتری، يکی از ملزومات اصلی درآمدهای بالقوه است. نداشتن اين تجربه يا ضعيف بودن، به منزله از دست دادن کل يا برخی از مشتريان است.

با اجرا و پياده سازی سيستم باز خورد مشتريان شرکت از نظريات و شکايت ها مشتری آگاه و به اين ترتيب رفع اين مشکل ها نيز برای شرکت‌ها ميسر می شود.

ايجاد همکاری‌های سازمانی

يکی از راههای برگشت عمده سرمايه گذاری برای CRM، تغيير رفتار سازمانی است. برای انجام اين کار وجلب مشارکت مردم، بايد برنامه ريزی زمانی و دوره ای کرد. مديريت موفقيت آميز تغيير دارای چند مولفه ی عمده است:

· رهبری: مديرعامل بايد تا آنجا که می تواند ساختار سازمان خود را از حالت سلسه مراتبی خارج و آن‌ها را با انگيزه تر نمايد.

· مهارت‌ها و توانايي‌ها: مهارت‌های لازم در زمينه IT، تجزيه و تحليل، مديريت پروژه، تسهيلات و خدمات بايد در سازمان ايجاد گردد.

· دانش: تسهيم دانش، منجر به مشارکت و نوآوری می شود. البته در اين راه موانع زيادی وجود دارد. به کارگيری ابزارهای مديريت دانش و تکنيک‌های آن، از جمله موارد مهم در تسهيم دانش است.

· سازمان: رده‌های تصميم گيری بايد به رده‌های مرتبط با مشتری نزديک شود تا انجام کار سريع تر شود. ساختار سازمانی بايد از سيستم‌های مجازی و جوامع استفاده کند.

· انگيزه‌ها: اهداف بايد با اهداف مشتری هماهنگ باشد چرا که پذيرش مشارکت خود، محرک بسيار توانمندی است.

فرايند طراحی مجدد

استفاده از رويکرد مبتنی بر مشتری، بر بسياری از کاربرها تأثير گذار خواهد شد. اين رويکرد، مشخص می کند که کدام شرکت می تواند خود را ارتقاء دهد و به مشتريان ارزش عرضه دارد. برای انجام مهندسی مجدد مشتری، چارچوب زير پيشنهاد می شود.

· نقاط تأثير گذار بر مشتريان شناسايي و مميزی شوند.

· فرايندهای کليدی را بتوان از نظر مشتری شناسايي کرد و به اين ترتيب بسياری از علل نارضايتی مشترکين مشخص می شود.

·بر اساس تأثير فرايندها روی اهداف راهبردی CRM، اين فرايندها را اولويت بندی کنيد.

· فرايندهای کليدی را بر اساس ميزان تأثيرشان روی ارزش مشتری اندازه گيری برآورد کنيد.

· به هنگام نياز، تغييرات لازم را در بخش‌هايي که مستقيم با مشتري سر و کار دارند و بخش‌های پشتيبانی اعمال کنيد.

مسئوليت کارها و فرايندها را به افراد بسپاريد. اين مسئوليت بايد به صورت متقابل بين افراد تقسيم شود.

· ميزان و چگونگی تأثير تغييرات بر توليد کنندگان و ساير شرکای کاری تان را بررسی کنيد.

· با استفاده از نظريات دريافتی از مشتريان، اهدافی قابل دستيابی و با مفهوم ايجاد کنيد. برای سرمايه هاي مهم تان، توافقنامه سطح سرويس (SLA) درست کنيد.

· مشتريان خود را در رده‌های مختلف تعريف، فرايندها را ارزيابی مجدد و SLA‌ها را مجددا" تعريف نماييد.

خلق راهبرد اطلاعاتی برای مشتريان

CRM موفق، منوط به ايجاد جريان اطلاعات مشتری است که مانند جريان خون در سازمان تلقی می شود و اين جريان، پلی است برای ادغام سيستم‌های تحليلی و عملياتی سازمان.

ايجاد طرح کسب و کار برای منبع يابی، حفظ و ارتقاء موجودی‌های اطلاعاتی از مشتری، يکی از ملزومات دستيابی به اهداف CRM است.

تسهيم و به اشتراک گذاری اطلاعات مشتری در داخل بنگاه تجاری، بخشی از راهبرد منسجم سازمانی است معمولا" موارد زير در اين راهبرد ديده می شوند؛

· مشتری از چه کانال‌هايي بايد استفاده کند.

· چه محصولاتی بايد به مشتری فروخته شود.

· آيا بنگاه تجاری بايد بر افزايش رضايت مشتری تأکيد کند.

· کدام حوزه از زنجيره ارزش مشتريان بنگاه، فرصت‌هايي برای کسب مزايای رقابتی است وکجای کار مشتری را رنج می دهد.

چه بايد کرد:

· بايد راهبرد اطلاعاتی مناسبی را برای CRM تهيه کرد. اطلاعات مشتری بنيان هر برنامه ی CRM است.

· حلقه‌های ضعيف در زنجيره ارزش روابط مشتری بنگاه خود را شناسايي و تقوطت کنيد.

تحقق CRM با به کارگيری فناوری

بنگاههای تجاری معقول منابع فراوانی برای کاربردهای CRM دارند. اين کاربردها گستره اي بزرگ از سيستم‌های رو به رشد گرفته تا کاربردهای مربوط به بنگاه‌های تجاری را در بر می گيرد. استفاده از مجموعه ی يکپارچه در بنگاه، يکپارچگی درونی داده‌ها و فرايندها را تضمين می کند.

چه کار بايد کرد:

بايد سطوح مهارتی، دورنمای فناوری، فرايندهای آن، مدل اطلاعاتی و نيازهای يکپارچه سازی بنگاه خود را قبل از ارزيابی و گزينش کاربردهای CRM، مورد بازبينی قرار گيرند.

تعريف و پايش معيارها

· تنظيم سطح توفيق بنگاه در تحقق اهداف CRM

· اخذ باز خورد برای اصلاح راهبرد CRM و اجرای آن

· پايش برخورد با مشتريان

· انجام مديريت دگرگونی

· تغيير نحوه پرداخت به کارکنان

· بررسی ميزان علاقه ی بنگاه به ارزيابی در رابطه با رقبا

چارچوب کاری مديريت عملکرد امری ضروری است. بايد در نظر داشت که راهبر CRM بدون داشتن معيارهای بهم متصل سلسله مراتبی، يحتمل محکوم به شکست خواهد بود:

· مديران اجرايي بايد معيارهای واحدی را تدوين کند.

· با ايجاد معيارها، ميزان موفقيت راهبرد CRM ارزيابی شود. اين معيارها بايد ارتباط روشنی با اهداف شرکت داشته باشند.

· معيارهای پردازش و عمليات، خود تاکتيک شرکت‌ها رامحک می زند و ساير معيارهای راهبردی مشتری را تقويت‌مي کند.

· معيارهای زيرساخت کار، مبين کارآمدی فرايندهای خاص و دروندادی برای معيارهای فرايندی و عملياتی است.

برای محقق شدن چارچوب مذکور بايد کارهای زير انجام شود:

· سلسله مراتب معيارهای CRM به منظور تعريف اهداف کليدی راهبرد CRM ايجاد و پيشرفت کار در تحقق اين اهداف پيگيری شود. ايجاد فرايندهايي برای نظارت مستمر بر بازخوردهای دريافتی از مشتريان و هدايت پژوهش بازار از ملزومات اين کار است.

· ايجاد سلسله مراتب معيارهای CRM به صورت اولويت و از بالا به پايين، بررسی نتايج کار و اطمينان از سطوح مختلف و ارتباطات داخلی اين معيارها. در اين ميان، همکاری با بخش مالی امری ضروری است چرا که اين معيارها بايد در کل معيارهای مجتمع شرکت قرار گيرند.

· کسی را به عنوان مسئول ترسيم و تعريف ارتباطات ميان معيارهای CRM منصوب کنيد.

نتيجه گيری

در مجموع بايد متذکر شد که راهبرد تجاری، راهبردی مربوط به کار کسب است و مجموعه ای يا طبقه ای از کاربردها و فناوری‌ها نيست. عليرغم اين که فناوری امری بسيار مهم برای اجرای راهبردهای CRM است، CRM خود فناوری نيست.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 10 شهریورماه 1384

11:48 PM

September 01, 2005

راهنماي خريد: هرآنچه كه بايد درباره MP3 Player بدانيم

مترجم: ميلاد اميريان‌فر
پنجشنبه 10 شهريور 1384
ناشر: مجله شبکه
.shabakeh-mag.com

اشاره :
در اين مقاله خواندني سعي شده است به‌طور كلي معايب و مزاياي يك MP3 Player بررسي شود تا در نهايت با جمع‌بندي خودتان بتوانيد براي خريد يا عدم خريد آن‌ها تصميم بگيريد.

مقدمه:
مي‌توان MP3 Player ها را جزء يكي از بزرگ‌ترين ابداعات صنعت ساخت وسايل پخش موسيقي قابل حمل، به‌حساب آورد. آن‌ها نسبت به مدل‌هاي قديمي‌تر خود مثل واكمن يا CD-Man بسيار كوچك‌تر و نيرومندترند و با قابليت‌هاي بسيار زيادي که دارند اصلاً با آن‌ها قابل مقايسه نيستند.
دريافت مستقيم فايل موسيقي از اينترنت، اجراي ميكس دلخواه روي آهنگ، ضبط صداي محيط و يا صداي خودتان، گوش كردن به راديو و ضبط همزمان برنامه‌ها يا آهنگ‌هاي راديو، افزايش مقدار حافظه و ... بخشي از امكانات فوق‌العاده‌اي است كه امروزه MP3 Player در اختيار شما گذاشته‌است.

در اين مقاله سعي شده است به‌طور كلي معايب و مزاياي يك MP3 Player معرفي شود تا در نهايت با جمع‌بندي خودتان بتوانيد براي خريد يا عدم خريد آن‌ها تصميم بگيريد.

براي خريد يك MP3 Player بايد فاكتورهاي متعددي را در نظر بگيريد. در اينجا مهمترين آن‌ها در پنج دسته تقسيم‌بندي شده است كه به ترتيب به بررسي آن‌ها مي‌پردازيم.

1 – خوب يا بد؛ مسئله اين است!
بهتر است قبل از خريد هر چيزي از مزايا و معايب آن به خوبي مطلع شويم تا بعداً دچار مشكل نشويم. به جرأت مي‌توات گفت: بزرگ‌ترين و شايد اصلي‌ترين امتياز MP3 Player نسبت به ساير دستگاه‌هاي پخش موسيقي قابل حمل، ذخيره كردن تعداد زيادي فايل موسيقي دلخواه در فضايي كوچك باشد. به عبارت ديگر شما با استفاده از MP3 Player مي‌توانيد همواره مجموعه‌اي از آهنگ‌هاي دلخواه خود را همراه داشته باشيد و هر وقت كه از يكي از آن‌ها خسته شديد مي‌توانيد به راحتي آن را پاك كنيد و با آهنگي ديگر تعويض كنيد و اين‌كار را بارها بدون افت كيفيت پخش انجام دهيد. اين مزيت، شما را از حمل ده‌ها نوار كاست يا CD به همراه خود بي‌نياز مي‌كند. ضمناً يادآور مي‌شويم كه روي CDها تنها يك بار مي‌توانيد آهنگ‌هاي دلخواه خود را كپي كنيد و نوار كاست هم بعد از چند بار ضبط، دچار افت كيفيت زيادي مي‌شود، ولي اين اتفاقات در MP3 نخواهد افتاد.

از امكانات ديگر MP3 Player مي‌توان به امكان برنامه‌ريزي پخش اشاره كرد. كساني كه از يك يا دو آهنگ خاص بيشتر لذت مي‌برند مي‌توانند دستگاه را به‌گونه‌اي برنامه‌ريزي كنند كه ابتدا آن چند آهنگ و سپس ساير آهنگ‌ها را پخش کند. تنظيم زمان پخش، طن صدا و حالت پخش (POP، Classic و Rock و ...)، انجام ميكس‌هاي گوناگون، پخش راديو FM و ضبط مستقيم از آن، داشتن ورودي Line-in براي ضبط آهنگ از دستگاه‌هاي پخش ديگر، قابليت ارتقاي حافظه و نمايشگر و ... از ديگر امتيازات يك MP3 Player خوب است كه در هنگام خريد بايد به آن‌ها توجه كنيد.‌
از بارزترين معايب اين دستگاه‌ها، قيمت بالاي آن‌هاست. اگر براي شما ذخيره يك ساعت موسيقي كافي است، مشكل زيادي در تهيه هزينه آن نخواهيد داشت، اما اگر اصرار داريد كه در هر جا و مكاني، هر موسيقي‌اي را كه دوست داريد، بشنويد، شايد به يك شغل خوب يا يك عموي پولدار احتياج پيدا كنيد!
البته همان‌طور كه گفتيم بعضي از MP3 Player ها مي‌توانند از كارت حافظه نيز پشتيباني كنند كه اگر هم‌اكنون در خريدMP3 Player با حافظه بالا مشكل داريد، مي‌توانيد متناسب با بودجه خود يكي از آن‌ها را تهيه كنيد و بعداً به حافظه آن‌ها اضافه كنيد.

2 – انواع مختلف، بهاي مختلف
MP3 Player را مي‌توان به سه دسته كلي تقسيم كرد: مدل‌هاي خانگي، شخصي و ماشيني (براي اتومبيل).
MP3 Player خانگي معمولاً ظاهري شبيه DVD دارد و مي‌تواند فايل‌هاي MP3 را از روي CD پخش كنند. با توجه به امكانات متعدد اين نوع از MP3 Player و توجه بر اين نكته كه شما چقدر به استفاده از همه امكانات اصرار داريد، قيمت آن‌ها متغير است و به چند صدهزار تومان هم مي‌رسد.

آن نوع ازMP3 Player كه در اتومبيل‌ها مورد استفاده واقع مي‌شود، درست مثل پخش اتومبيل در جلوي داشبورد قرار مي‌گيرد. انواع ديگري از آن‌ها درست مثل نوع خانگي خود هستند و برخي ديگر به شما اجازه مي‌دهند آهنگ‌هاي MP3 را روي بلندگوهاي اتومبيل بشنويد. (البته امروز با استفاده از دستگاهي جديد به نام Airwave، مي‌توانيد آهنگ‌هاي يك MP3 Player شخصي را روي باندهاي اتومبيل بشنويد). اين نوع MP3 Player ها نسبتا گران هستند.

بالاخره سومين و آخرين نوع آن‌ها كه در اين مقاله قرار است بيشتر درباره آن‌ها بدانيم، انواع شخصي MP3 است كه خيلي كوچك و سبك هستند كه باعث مي‌شود به راحتي در جيب يا دست قابل حمل باشند. قيمت اين محصولات از 40-50 هزار تومان تا 500 هزارتومان متغير است. ادامه اين مقاله بر MP3 Player شخصي متمركز است.

3 – ويژگي‌هاي اصلي
وزن و اندازه: براي بسياري از مردم داشتن وزني سبك، دليل خوبي براي خريد است و خيلي وقتتشان را صرف آن مي‌كنند. همچنين اغلب مردم دوست دارند كوچك‌ترين نوع را تهيه كنند.

يك تجربه: اگر دستان بزرگي داريد يا انگشتان شما چاق است، از خريد يکMP3 Player كه كليدهاي ريز و كوچكي دارد، حتماً صرف‌نظر كنيد. زيرا اين ويژگي شما سبب مي‌شود نتوانيد به درستي كليدها را فشار دهيد و بعد فكر مي‌كنيد كه MP3 Player شما خراب است و ... . پس حتماً در هنگام خريد مدلي را تهيه كنيد كه با دستان شما سازگار باشد.

فرمت پخش: هم‌اكنون از بين فايل‌هاي فشرده موسيقي مي‌توان به فايل‌هاي ديگري غير از MP3 نيز اشاره كرد. كه MP3 Player مي‌تواند آن‌ها را پخش كند. مثلاً فرمت WMA متعلق به شركت مايكروسافت است يا Real Network از فرمت G2 يا RM استفاده مي‌كنند كه امروزه گسترش زيادي پيدا كرده‌اند. خيلي از‌MP3 Playerها مي‌توانند هر سه فرمت را پخش كنند و بعضي ديگر هيچ فرمت ديگري غير از MP3‌را تشخيص نمي‌دهند. حتي برخي ديگر مي‌توانند براي پخش فرمت‌هاي آينده (مثل MP4) بروز شوند. اين‌كه MP3 Player شما تنها بتواند فايل‌هاي.MP3 را پخش كند نشانه ضعف آن نيست. چون اصلاً براي پخش آن‌ها ساخته شده است، ولي اگر از فرمت‌هاي ديگر نيز پشتيباني كند، يك امتياز براي شما محسوب خواهد شد.

حافظه و نوع آن: بيشتر MP3 Player از يك حافظه داخلي استفاده مي‌كنند. كه معمولاً بين 5 تاMB 64 متغير است. يك MP3 Player با حافظه 64 MB به‌ طور متوسط مي‌تواند در حدود يك ساعت موسيقي را در خود ذخيره كند. برخي ديگر از MP3 Playerها از كارت‌هاي حافظه استفاده مي‌كنند و برخي ديگر كه به آن‌ها گسترش‌پذير نيز مي‌گويند، از هر دو قابليت بهره‌برداري مي‌نمايند.

كارت‌هاي حافظه نيز انواع مختلفي دارند. مثل:MMC (Multi Media Card) ، Smart Media، Compact Flash وMemory Stick (براي محصولات شركت سوني). MP3 Player گران‌تر، از يك هاردديسك استفاده مي‌كنند. البته با اين‌كه در يك هاردديسك مي‌توان صدها هزار فايل موسيقي ذخيره كرد، بايد به قيمت بالاي آن و لزوم احتياط در جابه‌جايي آن (براي پرهيز از ضربه خوردن و صدمه ديدن) نيز توجه كرد.

نوع باتري و عمر آن: معمولاً MP3 Player مي‌توانند از دو نوع باتري استفاده كند. يا يك باتري دروني قابل شارژ يا باتري‌هاي قلمي معمولي (قابل شارژ و غيرقابل شارژ) اگر از MP3 Player‌‌اي كه باتري قلمي مصرف مي‌كنند استفاده مي‌كنيد، بدانيد كه در برخي مدل‌ها بايد نوع باتري خود (قابل شارژ يا غيرقابل شارژ) را انتخاب كنيد و بعد از MP3 Player استفاده كنيد. با اين نوع باتري‌ها تا 35 ساعت (بسته به نوع باتري) مي‌توانيد موسيقي گوش كنيد.
نوع ديگري نيز از MP3 Player‌ باتري‌هاي ليتيم توکار يا NiMH قابل شارژ استفاده مي‌كنند كه با يك شارژر كه در بسته خود MP3 Player است شارژ مي‌شود. اين نوع MP3 Player با هر بار شارژ، 8 تا 10 ساعت كار مي‌كنند.
روي سايت www.batteries.com مي‌توانيد اطلاعات جامع و كاملي درباره بيش از 3500 مدل باتري NiMH و آلكالاين كه در بيشتر MP3 Playerها از آن‌ها استفاده مي‌شود، به دست مي‌آوريد.

صفحه نمايشگر: MP3 Player شما بايد داراي صفحه نمايش باشد تا گزارش دقيقي از نام آهنگ، وضعيت صدا، و نوع پخش، مقدار باقي مانده شارژ، ترتيب پخش، و ... را به شما ارائه دهد. همچنين بايد حتماً قابليت ديد در شب را نيز داشته باشد تا در تاريكي هم بتوانيد از صفحه نمايش استفاده كنيد.

نقل و انتقال: براي آن‌كه بتوانيد روي MP3 Player خود آهنگ كپي كنيد، بايد آن را به رايانه خود متصل كنيد. بالاترين بازده سرعت در اتصالات:
Firewire (IEEE-1394) يا در USB 2.0 قابل دسترسي است. پس بهتر است MP3 Player شما يكي از اين دو را پشتيباني كند.

نرم‌افزار: معمولاً همراه با MP3 Player يك CD نيز به شما ارائه مي‌شود كه نرم‌افزارهايي متعددي براي استفاده ازMP3 روي آن‌ها وجود دارد، نرم‌افزارهائي كه استفاده از آن‌ها باعث مي‌شود لذت بيشتري در كار با MP3 Player خود ببريد. ضمناً از اينترنت نيز مي‌توانيد نرم‌افزارهاي گوناگوني را دريافت كنيد.‌ براي نمونه به سايت نرم‌افزار MusicMatch Jukebox مراجعه كنيد.

سازگاري: اگر شما بهترين MP3 Player را با بهترين نرم‌افزارها و زيباترين شكل بخريد تا زماني كه با رايانه شما سازگاري نداشته باشد، به هيچ دردي نمي‌خورد. بنابراين مطمئن باشيد كه رايانه شما از لحاظ اتصالات، درگاه‌ها و نصب نرم‌افزارهاي موردنياز، حتماً با MP3 Player انتخابي شما سازگار باشد.

4 – ويژگي‌هاي پيشرفته

راديو FM: برخي از MP3 Player درون خود يك تيونر راديو هم دارند كه هر زمان كه از شنيدن موسيقي خسته شديد، مي‌توانيد راديو گوش كنيد. مدل‌هاي جديدتر به صورت مستقيم از راديو صدا را ضبط مي‌كنند و معمولاً مي‌توانند 20 تا 30 ايستگاه را در حافظه خود ذخيره كنند. البته در هنگام حركت ممكن است كمي هم صداي خش‌خش بشنويد كه به اين علت است كه تيونر آن‌ها معمولاً خيلي قوي نيست و ضمناً آنتن هم ندارند.

ضبط صدا: با بهره‌گيري از يك ميكروفون صداي داخلي، MP3 Player مي‌توانند با كيفيت قابل قبولي صداي محيط را ضبط كنند. خيلي از آن‌ها تنظيماتي دارند كه قبل ازضبط مي‌توان نوع ديجيتايز شدن آن‌ها (مثلا PCM)، نوع ضبط كانال (Stereo يا Mono) و ... را مشخص كرد.

اعلام مقدار باقي مانده باتري: خوب است بدانيد كه چقدر از باتري مصرف كرده‌ايد و چقدر ديگر موجودي داريد و كي بايد باتري را عوض يا باتري آن را شارژ كنيد.

كنترلرهاي اكولاريزر: اين توانمندي‌ها قابليت‌هايي است كه براساس آن مي‌توان اكولايزر پخش را تغيير داد تا متناسب با نوع آهنگ به كيفيتي بالاتر برسيم.

پخش اتفاقي: براي آن‌كه از پخش ترتيبي موسيقي‌ها خسته نشويد، اين ويژگي آهنگ‌ها را به‌طور اتفاقي پخش مي‌كنند.

ادامه پخش به صورت خودكار: اين ويژگي اين امكان را فراهم مي‌كند كه ادامه‌هاي آهنگ‌هاي خود را از جايي كه قبلاً MP3 Player را خاموش كرده‌ايد، گوش كنيد.

حمل با خيالي آسوده: برخي از شركت‌ها كيف‌هايي را همراه MP3 Player ارائه مي‌دهند كه مي‌توان آن‌ها به كمربند بست و آن را داخل كيف گذاشت. برخي ديگر دستبندي مي‌دهند كه MP3 Player به راحتي در آن قرار مي‌گيرد و با امنيت كامل مي‌توان آن را حمل كرد. برخي ديگر هم بندهاي گردني ارائه مي‌دهند كه مي‌توان را مثل گردنبندي آويزان كرد تا راحت‌تر قابل دسترسي باشند.

ضد آب بودن: بهتر است اين خاصيت هم در MP3 Player وجود داشته باشد تا اگر خواستيد در استخر هم موسيقي گوش كنيد، مانعي نداشته باشيد! :)

5 – ضمائم

اغلب ابزارهاي موردنياز يك MP3 Player همراه با آن‌ها ارائه مي‌شود، ولي بدانيد حداقل مواردي را كه بايد هنگام خريد به شما ارائه كنند، يك هدفون و يك آداپتور AC و كابل‌هاي اتصال خواهد بود. ساير موارد مثل كنترل از راه دور و كارت حافظه و ... بسته به نوع مدل ارائه خواهد شد.
در آخر هم توجه شما را به اين نكته جلب مي‌كنيم كه قبل از خريد قطعي، از گارانتي آن نيز اطلاع پيدا كنيد. شركت ارائه دهنده گارانتي را بشناسيد و از معتبر بودن آن اطمينان حاصل كنيد. سعي كنيد محصولي را تهيه كنيد كه بالاترين زمان گارانتي را داشته باشند.
روي برگ گارانتي را نيز با دقت بخوانيد و تاريخ شروع آن را، كه معمولاً به ميلادي است، حتماً در نظر بگيريد و مراقب باشيد كه خيلي از زمان آن نگذشته باشد. روي برگ گارانتي، بايد شماره سريال وجود داشته باشد. حتماً آن را با سريال روي دستگاه يا جعبه آن تطبيق دهيد. تا بعداً دچار مشكل نشويد.

نکاتي که در اينجا مطرح شد، مهمترين مواردي است كه بايد در هنگام خريد MP3 Player به آن‌ها توجه كرد. بايد به خيلي از مسائل توجه نمود، تا بتوان يك پخش‌كننده MP3 خوب و مناسب خريد و از كار با آن لذت برد.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
پنجشنبه، 10 شهریورماه 1384

11:49 PM

September 01, 2005

فن آورى Bluetooth چيست ؟

سخاروش - امروزه دستگاه هاى الكترونيكى متعددى از فن آورى Bluetooth براى ارتباط بى سيم با ساير دستگاه هاى مجهز به اين تكنولوژى استفاده مى نمايند . علاقه مندان به استفاده از اين تكنولوژى لازم است در ابتدا با ماهيت ، تهديدات و نحوه حفاظت در مقابل خطرات احتمالى آشنا شوند .

Bluetooth چيست ؟
Bluetooth ، يك فن آورى است كه امكان مبادله اطلاعات بين دستگاه ها بدون نياز به كابل و يا سيم را فراهم مى نمايد . در حقيقت Bluetooth يك استاندارد الكترونيكى است كه توليد كنندگان را ملزم مى نمايد به منظور ايجاد پتاسيل فوق در محصولات خود ، تجهيزات و امكانات خاصى را درون دستگاه هاى الكترونيكى تعبيه نمايند . با رعايت نكات مندرج در استاندارد فوق ، دستگاه هاى توليد شده قادر به تشخيص و ارتباط با يكديگر با استفاده از تكنولوژى Bluetooth خواهند بود.
امروزه اغلب توليد كنندگان معتبر و شناخته شده ،‌ دستگاه هائى را با قابليت استفاده از Bluetooth توليد مى نمايند . تلفن هاى موبايل ، كامپيوترها و دستگاه هاى PDA ( برگرفته از Personal Digital Assistant ) ،‌ نمونه هائى در اين زمينه مى باشند . فن آورى Bluetooth از فركانس هاى راديوئى با برد محدود استفاده مى نمايد و دستگاه هائى كه از تكنولوژى فوق حمايت مى نمايند ، مى توانند با يكديگر و در يك مسافت مشخص شده و محدود ارتباط برقرار نمايند .
از فن آورى فوق اغلب به منظور برقرارى ارتباط بين دو دستگاه متفاوت استفاده مى گردد ( مثلا" استفاده از يك صفحه كليد بدون كابل براى هدايت سيستم ) .

تهديدات امنيتى مرتبط با فن آورى Bluetooth
Bluetooth همانند بسيارى از تكنولوژى هاى ديگر مى تواند تهديدات امنيتى خاص خود را براى استفاده كننده به دنبال داشته باشد . با رعايت نكات ايمنى و بكارگيرى پتانسل هاى خاصى نظير "تائيد" و يا "رمزنگارى" مى توان يك محيط ايمن ارتباطى را ايجاد كه داراى شرايط ايمنى مساعدى باشد . متاسفانه تعداد زيادى از دستگاه هائى كه از Bluetooth استفاده مى نمايند از كدهاى عددى كوچك ( موسوم به Pin code ) در مقابل رمزهاى عبور استفاده مى نمايند و همين موضوع مى تواند مسائل و مشكلات امنيتى خاص خود را به دنبال داشته باشد .
در صورتى كه افراد غير مجاز قادر به تشخيص و رديابى يك دستگاه Bluetooth گردند ، مى توانند اقدام به ارسال پيام هاى ناخواسته نموده و يا حتى عملا" امكان استفاده از دستگاه bluetooth را غير ممكن نمايند . يك مهاجم مى تواند با استفاده از مكانيزم هاى موجود به اطلاعات موجود بر روى دستگاه مورد نظر دستيابى و حتى به آنان آسيب رساند . bluesnarfing نمونه اى در اين زمينه است كه مهاجمان با استفاده از يك اتصال Bluetooth مى توانند اطلاعات موجود بر روى يك دستگاه مجهز به تكنولوژى Bluetooth را سرقت نمايند . ويروس ها و ساير كدهاى مخرب نيز مى توانند از فن آورى Bluetooth براى آلودگى دستگاه مورد نظر استفاده نمايند .

حفاظت در مقابل تهديدات
براى حفاظت در مقابل تهديدات مرتبط با فن آورى Bluetooth موارد زير پيشنهاد مى گردد :

غير فعال كردن Bluetooth در زمانى كه از آن استفاده نمى گردد . صرفا" در مواردى كه قصد ارسال اطلاعات از يك دستگاه به دستگاه ديگر وجود دارد ، مى بايست پتانسيل Bluetooth فعال گردد و از فعال نمودن آن در ساير موارد اجتناب گردد . با غير فعال شدن پتانسل فوق، امكان دستيابى افراد غيرمجاز به دستگاه مورد نظر سلب مى گردد .

استفاده از Bluetooth در hidden mode . در صورتى كه Bluetooth فعال شده است ، اطمينان نمائيد كه در hidden mode و نه discoverable mode پيكربندى شده است . با پيكربندى دستگاه مورد نظر در hidden mode ، ساير دستگاه ها قادر به شناسائى دستگاه مورد نظر نخواهند بود . اين موضوع باعث نمى گردد كه دستگاه هاى Bluetooth قادر به برقرارى ارتباط با يكديگر نباشند . در چنين مواردى مى توان دستگاه ها را "pair" نمود . بدين ترتيب آنان مى توانند حتى در hidden mode نيز با يكديگر ارتباط برقرار نمايند . با اين كه دستگاه ها ( نظير تلفن هاى موبايل و يا headset ) لازم است در ابتدا در discoverable mode به منظور شناسائى يكديگر پيكربندى گردند ولى در ادامه ( پس از اين كه "paired" شدند ) مى توانند بدون نياز به شناسائى مجدد اتصال، با يكديگر ارتباط برقرار نمايند .

دقت لازم در زمان استفاده از Bluetooth . در زمان استفاده از تكنولوژى فوق در يك محيط عمومى و در مواردى كه دستگاه ها pair و در discoverable mode پيكربندى شده اند ، مى بايست نكات امنيتى را رعايت نمود . در صورت استفاده از دستگاه مورد نظر در يك محيط عمومى ، همواره احتمال شناسائى ارتباط توسط افراد غير مجاز وجود خواهد داشت .

بررسى تنظيمات امنيتى . اكثر دستگاه ها ويژگى هاى متعددى را به منظور تامين طيف وسيع خواسته استفاده كنندگان ارائه مى نمايند . فعال نمودن برخى از ويژگى هاى ارائه شده ممكن است شما را در معرض تهديدات بيشترى قرار دهد . در اين رابطه لازم است ويژگى هاى غير ضرورى و يا اتصالات Bluetooth ، غير فعال شود . همچنين پيشنهاد مى شود تنظيمات دستگاه مورد نظر خصوصا" مقادير درنظر گرفته شده در ارتباط با سيستم امنيتى دستگاه مورد نظر به دقت بررسى گردد . سعى نمائيد صرفا" گزينه هائى را فعال نمائيد كه ضمن تامين خواسته هاى مورد نظر ، مشكلات و تهديدات امنيتى خاصى را به دنبال نداشته باشند .

استفاده از پتانسل هاى امنيتى پيش بينى شده در دستگاه . قبل از استفاده دستگاه Bluetooth ، مى بايست امكانات امنيتى ارائه شده همراه دستگاه بررسى و با آگاهى كامل از آنان استفاده گردد . ويژگى هائى نظير تائيد و رمزنگارى نمونه هائى در اين زمينه مى باشد .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 10 شهریورماه 1384

11:52 PM

September 01, 2005

آشنايي با مسيريابهاي سيسكو

نوشته: مسعود راستكار
ناشر: ماهنامه شبکه - آبان ۱۳۸۳ شماره 48
shabakeh-mag.com

اشاره :
در شماره 46 ماهنامه شبكه و در مقاله آشنايي با مسيرياب‌ها، با وظايف كلي مسيرياب‌ها و نحوه عملكرد آن‌ها در شبكه‌هاي محلي و اينترنت صرف‌نظر از نوع و يا كارخانه سازنده آن‌ها آشنا شديد. اما اگرمايليد كه درباره جزئيات اين ادوات و محصولات شركت‌هاي فعال و صاحب‌نام در زمينه مسيرياب‌هاي سخت‌افزاري بيشتر بدانيد لازم است كه اين مقاله را نيز مطالعه نماييد . قبل از شروع بحث توصيه مي‌كنم علاقمنداني كه نسبت به موضوع مسيرياب‌ها ذهنيت قبلي ندارند، با توجه به پيوستگي مطالب، مقاله آشنايي با مسيرياب‌ها را مطالعه نمايند. همان‌گونه كه اشاره شد، در آن مقاله، مسيرياب‌ها را در يك طبقه‌بندي كلي به دو نوع كلي سخت افزاري و نرم افزاري تقسيم نموديم، اما در اين شماره قصد داريم به طور خاص بر روي مسيرياب‌هاي سخت افزاري شركت سيسكوسيستمز تمركز كنيم و بحث در مورد روترهاي نرم‌افزاري را به فرصت بعدي موكول مي‌كنيم.

تاريخچه مسيرياب‌هاي سخت افزاري
همان‌طوركه قبلا گفته شد نام كلي كه براي مسيرياب‌ها در نظرگرفته شده به خاطر اولين و اصلي‌ترين وظيفه هر روتر يعني عمل مسيريابي است و انتخاب اين نام هم به سال 1984 بر‌مي‌گردد. يعني زماني‌كه رفته رفته با ظهور كامپيوترهاي شخصي مشكل تعدد استانداردها تبديل به يك مشكل حاد براي شبكه هاي موجود شد. گويا در اين هنگام دو دانشمند به نام‌هاي Leonard Bosack و Sandy Lerner از دانشگاه استنفورد براي اتصال شبكه ها و مسيريابي داده ها بين اين شبكه‌ها و حل مشكل عدم سازگاري پروتكل‌هاي مختلف در سطح مسيرياب‌ها، ايده مسيريابي (Routing) را مطرح نمودند و موفق شدند اولين مسيرياب را با هزينه شخصي توليد كرده و آن‌را در دانشگاه استنفورد نصب نمايند. با توجه به استقبالي كه از اين محصول جديد شد اين دو نفر تصميم گرفتند كه محصول خود را تجاري كنند. در اين سال بود كه غول تجهيزات شبكه‌هاي كامپيوتري يعني شركت در‌زمينه طراحي و توليد مسيرياب‌هاي سخت‌افزاري حرف اول را مي زند و در اين زمينه به‌جز چند شركت ازجمله Foundry Networks و Nortel Networks رقيب جدي ديگري ندارد و طي سال‌ها با ارائه راه‌حل‌هاي جديدي نظير ايجاد تنوع در كليه محصولات و ارائه گواهينامه‌هاي مهندسي تجهيزات سيسكو نظيرCCNA ،CCDA ، CCNP و CCIE و ... موقعيت خود را بيش از پيش تثبيت نموده است. به همين دليل از مجموعه شركت‌هاي توليدكننده روترهاي سخت‌افزاري تنها برروي مسيرياب‌هاي شركت سيسكو تمركز مي كنيم و به‌دليل تنوع زياد مسيرياب‌هاي اين شركت و همچنين تعدد ماجول‌هاي مورد استفاده كه به منظور افزايش انعطاف‌پذيري مسيرياب‌ها استفاده مي‌شوند، تنها به تشريح مدل‌هاي معروف‌تر خواهيم پرداخت. البته در قسمت نخست مقاله به بيان ويژگي‌هاي كلي و در قسمت دوم كه در شماره آينده به چاپ مي‌رسد به بررسي سري‌هاي پركاربرد آن مي‌پردازيم.
يك مسيرياب صرف‌نظر از نوع، سري و قيمت آن، همانند يك كامپيوتر داراي اجزاي <سخت‌افزاري نظير جعبه
(Case) برد اصلي (MotherBoard) ، پردازنده، حافظه موقت (RAM)، حافظه دائمي (Flash) و رابط‌ها و ماجول‌هاي مختلف است كه بسته به كاربرد هر مسيرياب توان و ظرفيت متفاوتي دارند و همچنين هر مسيرياب داراي يك سيستم عامل است كه IOS ناميده مي شود و سرنام كلمات Internetworking Operating System مي‌باشد. ولي از‌آنجائي‌كه مسيرياب‌ها فاقد صفحه كليد و مانيتور هستند، معمولا به سه طريق مي‌توان فرامين سيستم عامل را براي پيكربندي مسيرياب وارد نمود، اين سه روش عبارتند از:

1) كنسول
به همراه هر مسيرياب يك كابل 8 رشته مخصوص به نام كابل Rollover ارائه مي شود كه با استفاده از آن و يك كامپيوتر شخصي و از طريق برنامه هايي نظير Term90 يا HyperTerminal ويندوز كه قابليت تبادل داده با پورت‌هاي سريال كامپيوتر را دارند، مي‌توان پيكربندي روتر را در بالاترين سطح دسترسي انجام داد.
نكته‌
- با امكان دسترسي فقط در اين سطح، مي توان تحت شرايطي حتي رمزهاي عبور دستگاه را نيز تعويض نمود. به همين دليل است كه حفاظت فيزيكي دستگاه روتر بسيار حائز اهميت است.
- اولين باري كه بخواهيد پيكربندي يك روتر را انجام دهيد، حتما" مي‌بايست از اين طريق اقدام كنيد.

2) Telnet
از آنجايي‌كه اصولاً مسيرياب‌ها در لايه شبكه مدل TCP/IP كار مي‌كنند، مي‌توانيم به آنها آدرس IP اختصاص دهيم و طبعاً با استفاده از پروتكل Telnet و پورت اترنت روتر مي توانيم از راه دور به آن متصل شده و روتر را پيكربندي كنيم. البته بايد بدانيد كه اجازه اين نوع دسترسي قبلاً مي بايست از طريق كنسول صادر شده باشد و همچنين اين‌كه كاربري كه به اين صورت به مسيرياب متصل شده، نسبت به روش اول از سطح دسترسي كمتري برخوردار است .

3) Aux
اين امكان براي مديراني است كه مي خواهند از طريق شماره گيري به مودم مسيرياب متصل شوند و آن‌را متناسب شرايط مدنظرشان پيكربندي كنند . براي اين‌كار نيز لازم است از طريق كنسول دستگاه امكان استفاده از Aux را فعال نمائيم.
در ادامه ابتدا درخصوص سري‌ها و مدل‌هاي مختلف مسيرياب‌هاي سيسكو و سپس درباره مشخصه هاي سخت‌افزاري مسيرياب‌ها و انواع آن‌ها نكاتي را عنوان مي نمائيم.

سري‌ها و مدل‌هاي مسيرياب‌هاي سيسكو
سيسكو سري‌هاي مختلف مسيرياب‌هاي خود را معمولاً توسط يك عدد چهار رقمي مشخص مي كند كه عبارتند از سري‌هاي 1000، 1600، 1700، 2500، 2600، 3200، 3600، 3700، 6400 و 7200 تا 7600 (البته استثنائاتي مثل سري 70، 90،10000، 10700 و 12000 نيز وجود دارند ) و هر سري شامل مجموعه‌اي از مدل‌هاي مختلف است مثل 1601 و 1605 از سري 1600 يا 2620 و 2621 از سري 2600 وغيره، البته دليل اين نوع نامگذاري به خاطر وجود ويژگي‌هاي مشترك بين مدل‌هاي مختلف يك سري خاص مي باشد كه هر سري را از بقيه سري‌ها متمايز مي نمايد و به طراح شبكه كمك مي كند كه با توجه به نيازهاي كلي‌اش سري مورد نظر خود را انتخاب كرده و سپس با در نظرگرفتن جزئيات مورد نظرش، مدل مناسب محيط سازماني خود را خريداري نمايد.

مشخصه‌هاي سخت‌افزاري مسيرياب‌هاي سيسكو
• Case
روترهاي سيسكو با توجه به نوع و مدل داراي بدنه‌هاي متفاوتي هستند. مثلا‌ً بدنه‌هاي Desktop كه مربوط به سري‌هاي 70 يا 90 مي‌باشند. اين بدنه‌ها قابليت افزودن ماجول يا ساير ملحقات را ندارند. در مقابل بدنه‌هايrackmount هستند كه قابليت نصب در رك را دارند. از همين نوع بدنه، بعضي كه بزرگتر بوده و قابليت نصب ماجول‌ها و كارت‌هاي زيادي را دارند به نام شاسي (Chasis) شناخته مي‌شوند.

• CPU
اگر بخواهيد سرعت پردازنده هاي كامپيوترهاي شخصي را با مسيرياب‌ها مقايسه كنيد حتماً تعجب خواهيد كرد، چرا كه حتي سريع‌ترين روترها كه مي‌توانند در ستون فقرات شبكه‌هاي اينترنتي استفاده شوند و طبعاً مي‌بايست حجم بسيار وسيعي از ترافيك اينترنت را در زمان بسيار كوتاهي پردازش نمايند، سرعتي در حدود 200 مگاهرتز دارند. وليكن از آنجايي‌كه مسيرياب‌ها واسط گرافيكي كاربر ندارند و در محيط متني كار مي كنند و همچنين به دليل تك‌منظوره بودن اين پردازنده ها اين سرعت براي اين منظور كفايت خواهد كرد. ضمناً جالب است كه بدانيد مسيرياب‌هاي سيسكو عمدتاً از پردازنده‌هاي سري 68000 شركت موتورلا استفاده مي كنند.

• مادربورد
مادربوردهاي مورد استفاده شركت سيسكو عمدتا توسط شركت‌هاي Asus و Iwill و Supermicro ساخته
مي شوند و طبيعتا" براي سري‌هاي مختلف توان و مشخصه هاي متفاوتي ارائه مي‌شود.

• حافظه
در سخت افزار مسيرياب‌هاي سيسكو بسته به نوع و كاربرد، از انواع مختلفي از حافظه ها پشتيباني مي شود كه عبارتند از:
‌-‌ RAM كه گاهي DRAM نيز ناميده مي‌شود و براي ذخيره اطلاعات حين كار به كار مي رود و يا به اصلاح سيسكو براي نگهداري Running Config مورد استفاده قرار مي‌گيرد.
در بعضي مدل‌ها، اين حافظه قابل ارتقاء و در برخي ديگر ثابت مي باشد و عموماً در ظرفيت‌هاي 4 و 8 و 16 و 32 و 64 مگابايت موجود مي باشد.
- ‌‌ROM كه در اين نوع حافظه يك تصوير قابل بوت از سيتم عامل روتر (IOS Image) قرار مي گيرد و در مراحل اوليه روند بوت مسيرياب مورد استفاده قرار مي گيرد .
- Flash Memory
همانند هاردديسك درPC ‌ها مي‌باشد و براي ذخيره كل IOS مورد‌استفاده قرار مي‌گيرد. ضمناً براي ذخيره فايل‌هاي پيكربندي نيز از اين حافظه استفاده مي‌شود كه در ظرفيت‌هاي مختلفي عرضه مي‌شود. البته نسبت به مدل و سري مسيرياب معمولاً قابل ارتقا است.
- ‌‌NVRAM
روترها از فايلي به نام Startup Config براي نگهداري تنظيمات ابتدايي پيكربندي مسيرياب استفاده مي كنند و اين فايل در اين حافظه نگهداري مي شود و پس از اين‌كه در روند بوت به داخل RAM دستگاه روتر بارگذاري شد، Running Config ناميده مي‌شود.
- ‌‌Interfaces
لينك‌هاي هر مسيرياب براي ارتباط با دنياي خارج در قالب پورت‌ها و ماجول‌ها كه براي انعطاف‌پذيري روترها درجهت انجام وظايف گوناگون قابل استفاده و تغيير است و داخل اسلات‌هاي توسعه قرار مي گيرند. به عنوان مثال مي‌توان يك ISP را درنظرگرفت كه پس افزايش خطوط تلفن خود قادرخواهد بود ماجولي به نام AM (كه شامل تعدادي مودم است) را به اسلات روتر خود (روتري كه در نقش يك Access Server عمل مي‌كند) متصل كند و كارآيي روتر را افزايش دهد. البته به شرط اين‌كه آن روتر خاص امكان اين گسترش را داشته باشد. براي آگاهي از امكانات هر مسيرياب و بررسي قابل گسترش بودن آن و نوع ماجول‌هايي كه مي‌توانيد به آن متصل كنيد، مي‌بايست به راهنماي فني هر مسيرياب يا سايت وب شركت سيسكو ( www.cisco.com ) مراجعه كنيد، مطمئناً در اين سايت اطلاعات بسيار مفيدي خواهيد يافت. ادامه اين مقاله كه به معرفي سري‌هاي مختلف روترهاي سيسكو مي‌باشد را در شماره بعدي خواهيد خواند.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

چهارشنبه، 16 شهریورماه 1384

01:11 PM

September 07, 2005

+ADSL2 - ADSL2 عبور از مرزهاي سرعت

ترجمه عليرضا تقي زاده
ماهنامه شبکه - اسفند ۱۳۸۳ شماره 52
shabakeh-mag.com

اشاره :
شركت‌هاي مخابرات منطقه‌اي را به قولي صاحبان بزرگترين معادن مس دنيا مي‌دانند و اين كنايه‌اي است از حجم عظيم سيم‌هاي مسي كه بين اين مراكز مخابراتي و محل سكونت يا محل كار مشتركين تلفن نصب گرديده‌اند. استفاده بهينه از اين سرمايه، در دستور كار اين شركت‌ها قرار دارد و چند سالي است كه فناوري مودم‌هاي ديجيتال (DSL) به عنوان راه‌حلي هوشمندانه‌ جهت انتقال ديتاي پرسرعت برروي اين سيم‌ها مطرح گرديده است. در اين ميان، مودم‌هاي خانواده‌ ADSL به لحاظ وسعتِ به‌كارگيري در كاربردهاي خانگي، رتبه اول فروش را به خود اختصاص داده‌اند. در مقاله فناوري ADSL (ماهنامه شبكه شماره 41) مباني اين مودم‌ها تشريح گرديده است و در اين نوشتار سعي داريم شما را با جديدترين گونه‌هاي آنها آشنا نماييم.

در ژانويه 2003 سازمان ITU (سازمان بين‌المللي استانداردهاي مخابراتي) پس از فروش حدود پانزده ميليون مودمADSL در سطح جهان، مشخصات جديدي را براي اين استاندارد منتشر نمود. سري مودم‌هاي ADSL موفقترين رده ADSL را در جهان به خود اختصاص مي‌دهند و ITU سعي فراواني جهت توسعه آن دارد.

نوع مودم | استاندارد | تاريخ ‌معرفي‌
ADSL | G.992.1 G.992.2 | 1999
ADSL2 +ADSL2 | G.992.3 G.992.4 G.992.5 | 2002 2003
RE-ADSL2 | G.992.3 Reach Extended | 2003

استانداردهاي جديد با نام‌هاي ADSL2 و +2 ADSL به بازار معرفي شده‌اند. (ITU-G.992.5) براي اولين بار موفق‌شد نرخ گذردهي در جهت دريافت (downstream) را به 24 مگابيت در ثانيه برساند و گونه‌اي از 2 ADSL كه در اكتبر 2003 معرفي شد، حداكثر مسافت قابل دسترسي را به بيش از 6 كيلومتر رساند. افزايش كارآيي در استانداردهاي فوق در واقع انعكاسي از نياز استفاده‌كنندگان و فراهم‌كنندگان خدمات ADSL درارتباط با افزايش نرخ گذردهي و مسافت قابل‌ا‌ستفاده مي‌باشد. سرعت بالاي اين گروه از مودم‌هاي DSL، به فراهم‌كنندگان خدمات، امكان ارائه خدماتي همچون ويدئوي OnLine را مي‌دهد.
با وجود ارتقاء صورت گرفته، مودم‌هاي جديد به طور كامل با مودم‌هاي نسل پيشين خود سازگار مي‌باشند. به اين ترتيب فراهم‌كنندگان خدمات نيازي به جايگزيني سيستم‌هاي موجود خود ندارند و امكان توسعه تدريجي را مي‌يابند. جدول 1
خلاصه‌اي از استانداردهاي اوليه و جديد ADSL را نشان مي‌دهد.

بهبود كارآيي
ADSL2 به شكلي طراحي شده كه در خطوط مخابراتي و با وجود تداخلات ناشي از مكالمات تلفني به نرخ گذردهي و مسافت بيشتري دست يابد. بهبود در تكنيك مدولاسيون، كاهش سرباره، بهره‌وري بيشتر در مكانيسم كدينگ، بهبود فرايند آماده‌سازي مودم، ارتقاء الگوريتم‌هاي پردازش سيگنال و كاهش در نسبت لازم براي سيگنال به نويز (SNR) برخي از تغييرات انجام گرفته جهت دستيابي به اهداف فوق مي باشند.

كاهش اتلاف در پهناي باند

ميزان افزايش كارايي در مودم هاي ADSL2

در مودم‌هاي معمولي ADSL، سرباره‌هاي ارتباطي از يك مقدار ثابت برخوردار مي‌باشند و در مجموع 32Mbps از ظرفيت گذردهي را به خود اختصاص مي‌دهند. اين مقدار سرباره در مسافت‌هاي طولاني كه ظرفيت گذردهي تا 128Kbps كاهش مي‌يابد، به معني اتلاف 25 درصدي خواهد بود. در مقابل در مودم‌هاي جديد، مقدار سرباره متناسب با نوع كاربرد و شرايط خط ارتباطي از 4Kbps تا 32Kbps انتخاب مي‌گردد كه تا 8 برابر كاهش اتلاف را نشان مي‌دهد.
به طور همزمان، به كارگيري تكنيك كدينگ Reed-Solomon در مودم‌هاي جديد، بهره‌وري كدينگ را افزايش داده است و به كاهش پديده انعكاس در انتهاي خطوط و همچنين كاهش تداخل ناشي از امواج راديويي AM كمك مي‌كند.
افزايش كارآيي كدينگ و كاهش اتلاف به افزايش نرخ گذردهي در مودم‌هاي 2 ADSL نسبت به انواع پيشين منجر گرديده است. افزايش نرخ گذردهي در مسافت‌هاي بالاي 5 كيلومتر در حد 50Kbps مي‌باشد و افزايش مسافت در حد 180 متر مي‌باشد كه در مجموع فضاي قابل پوشش را تا 6درصد افزايش مي‌دهد.

ساير ويژگي‌ها
● تشخيص خودكار: تشخيص خودكار كارآيي در مودم 2 ADSL به مراتب بهتر از سلف خود انجام مي‌گيرد، به اين ترتيب كه مودم‌هاي هر دو طرف ارتباط قادر به اندازه‌گيري ميزان نويز، شدت تضعيف و نسبت سيگنال به نويز مي‌باشند. اطلاعات فوق در اختيار نرم‌افزار مديريت شبكه قرار مي‌گيرد تا در انجام فرايند نصب و خدمات پس از نصب شركت‌هاي فراهم‌كننده خدمات به كارگرفته شود.
● شروع سريع: آغاز به كار در 2 ADSL بسيار سريعتر از گونه‌هاي پيشين و در مدت 3 ثانيه انجام مي‌گيرد، درصورتي‌كه همين زمان در مورد مودم‌هاي ADSL در حدود 10 ثانيه است.
● ديتاي اختصاصي: يك گزينه اختياري در 2 ADSL وجود دارد كه استفاده از پهناي باند تلفني (POTS) را براي ارسال ديتا در جهت ارسال (Upstream) امكانپذير مي‌كند. اين گزينه براي مكان‌هايي كه داراي دو يا چند خط تلفن مي‌باشند و نيازي به استفاده از قابليت تلفني 2 ADSL ندارند، مفيد خواهد بود.

بهبود در مديريت توان الكتريكي

نسل اول مودم‌هاي ADSL در تمام مدت با حداكثر توان مصرفي كار مي‌كنند كه اتلاف انرژي و افزايش حرارت از نتايج آن است. در مقابل 2 ADSL مانند يك كامپيوتر شخصي قادر است به حالت آماده‌باش(Stand by) درآيد و مصرف توان را به حداقل برساند. در اين حالت، مودم علاوه بر صرفه‌جويي در مصرف انرژي، حرارت كمتري نيز توليد مي‌كند كه به كارگيري آن را در ايستگاه‌هاي مركزي آسانتر مي‌سازد. مديريت توان در مودم‌هاي 2 ADSL داراي دو سطح عملياتي 2 L و 3 L مي‌باشد. انتخاب اينكه مودم در كدام حالت (عادي يا آماده‌باش) كاركند، با توجه به نرخ ترافيك عبوري يا بدون فعاليت‌ماندن مودم براي يك مدت مشخص تعيين مي‌گردد.
براي مثال زماني كه فايلي بزرگ از روي اينترنت بارگذاري مي‌گردد، 2 ADSL در حالت توان كامل قرار مي‌گيرد تا گذردهي را به حداكثر برساند. اما با كاهش ترافيك (براي مثال در زماني كه يك صفحه وب معمولي مطالعه مي‌شود) مودم به حالت 2 L فرو مي‌رود و توان مصرفي را كاهش مي‌دهد. البته مودم همواره آماده است تا به سرعت به حالت عادي بازگردد و تمام اين تغييرات بدون درگير شدن برنامه‌هاي كاربردي و بدون از دست رفتن حتي يك بيت از اطلاعات انجام مي‌گيرد. درصورتي‌كه مودمي براي مدتي خاص بدون هر گونه ترافيكي باقي بماند، مي‌تواند به پايين‌ترين حالت مصرف انرژي يعني 3 L برود. در اين حالت حدود 3 ثانيه براي بازگشت مجدد به وضعيت عادي زمان لازم است.

تطبيق نرخ انتقال

افزايش نرخ گذر با استفاده از ADSL2 دو رشته اي
خطوط تلفن معمولاً در قالب كابل‌هاي چندرشته‌اي (با حداقل 25 رشته‌سيم) به كار گرفته مي‌شوند. يكي از آثار فيزيكي به كارگيري كابل‌هاي چند‌رشته‌اي، امكان القاي الكترومغناطيسي علائم الكتريكي يك رشته سيم در ديگري است كه به همشنوايي (Crosstalk) موسوم است. همشنوايي به همراه رطوبت، تغيير درجه حرارت و تداخلات ناشي از راديوهاي AM، از مهمترين عوامل كاهش كارآيي در خطوط ADSL محسوب مي‌گردند.
ADSL2 به كمك يكي از قابليت‌هاي خود موسوم به <تطبيق پيوسته نرخ انتقال> بدون ايجاد تداخل در فرايند ارائه خدمات، شرايط كانال ارتباطي را تشخيص داده و نرخ انتقال را با شرايط فوق هماهنگ مي‌كند. براي مثال شروع به كار فرستنده يك ايستگاه راديويي محلي مي‌تواند شرايط جديدي را براي خطوط مخابراتي آن منطقه ايجاد كند كه در اين صورت 2 ADSL بدون آنكه كاربر را متوجه سازد، نرخ انتقال خود را با شرايط فوق تطبيق مي‌دهد.

ADSL2 چندتايي ( Bounded ADSL2)

طيف فركانسي مودم هاي ADSL

فراهم كنندگان خدمات طيف گسترده‌اي از مشتريان را پوشش مي‌دهند و بديهي است كه با نيازها و خواسته‌هاي متفاوتي روبرو باشند، مشتريان تجاري معمولا خواستار نرخ گذردهي بالاتر از مقادير استاندارد مي‌باشند. خوشبختانه 2 ADSL اين قابليت را دارد كه با به كارگيري همزمان چند رشته سيم به نرخ بالاتري دست يابد. تكنيك به كار گرفته شده اقتباسي از تكنيك مالتي پلكس وارونه در شبكه‌هاي ATM مي‌باشد. در اين تكنيك اطلاعات در مبداء به قطعاتي تقسيم مي‌شوند كه هر يك برروي يكي از كانال‌هاي موجود ارسال مي‌گردد، در گيرنده فرايند عكس انجام مي‌پذيرد و با سرهم كردن قطعات فوق، اطلاعات اوليه بازسازي مي‌شود.

روش‌هاي انتقال همزمان صدا بر روي ADSL2

توسعه فضاي تحت پوشش در ADSL2 گسترش يافته

يكي از ويژگي‌هاي مودم‌هاي ADSL، تقسيم طيف فركانسي يك خط تلفن به دو بخش مستقل با مشخصات متمايز مي‌باشد كه اين دو بخش به مكالمات تلفني (POTS) و تبادل ديتا اختصاص دارند. به اين ترتيب دارندگان مودم‌هاي ADSL قادر به استفاده همزمان از خط تلفن خود خواهند بود، بدون آنكه اختلالي در فرايند ارسال و دريافت ديتا ايجاد كنند.
مودم‌هاي ADSL2، علاوه بر اين، امكان برقراري ارتباطات صوتي از طريق تكنيكي موسوم به <صداي كاناليزه شده بر روي>
(CVoDSL DSL) را فراهم مي‌كند. CVoDSL يك كانال به پهناي 64 كيلو هرتز را از داخل پهناي باند مربوط به 2 ADSL جدا مي‌كند و به صورت يك خط معمولي تلفني به كار مي‌گيرد. تكنيك فوق از نوآوري‌هاي 2 ADSL مي‌باشد و به‌طور كلي با تكنيك‌هاي معمول انتقال صوت برروي
مودم‌هاي DSL (مانند VoIP يا VoATM) كه مبتني‌بر تبديل صوت به ترافيك بسته‌اي ديتا مي‌باشند، متمايز است.
با استفاده از تكنيك CVoDSL صوت به صورت دست نخورده و بدون تبديل باقي مي‌ماند و سرويس‌دهنده قادر خواهد بود تا 4 خط تلفني را بر روي يك خط 2 ADSL ايجاد كند.

تكنيك انتقال در مودم‌هاي ADSL

تكنيك انتقال مورد استفاده در مودم هاي ADSL، تكنيك Discrete Multition) DMT) مي‌باشد. DMT فضاي فركانسي كانال را به تعدادي ريزكانال با عرض باند 4KHZ براي هريك تقسيم مي‌كند. تعداد اين زيركانال‌ها كه اصطلا‌حاً تن (Tone) ناميده مي‌شوند، براي استانداردهاي سري ADSL2 به 512 عدد بالغ مي‌گردد. به طور معمول تن‌هاي 1 الي 5 خاص ارتباطات تلفني مي‌باشند. از تن 6 الي 31 و يا 64 براي ارسال ديتا استفاده مي‌شود و باقي تن‌ها به دريافت ديتا اختصاص دارند. يكي از قابليت‌هاي ADSL به‌كارگيري انعطاف‌پذير تن‌ها متناسب با كاربرد و شرايط كانال مي‌باشد.

+ADSL2
سير پيشرفت مودم‌هاي ADSL با معرفي (ADSL2+ (G.299.5 باز هم كامل‌تر گرديد. در +ADSL2 افزايش دو برابري پهناي باند از 1/1 مگا‌هرتز به 2/2مگاهرتز، در مسافت‌هاي كمتر از 1500 متر، نرخ دريافت را تا دو برابر افزايش مي‌دهد. طيف فركانسي بزرگتر، همچنين +2 ADSL را نسبت به معضل همشنوايي مقاومتر مي‌كند.

طيف فركانسي مودم هاي +ADSL2

ضمائم استاندارد
كاربردها و شرايط خاص، مشخصات ويژه‌اي را طلب مي‌كند كه در استانداردهاي اصلي ADSL وجود ندارد. ضمائم به منظور پوشش‌دادن به اين شرايط خاص ايجاد گرديده‌اند. به طور كلي هر ضميمه از بخشي از پهناي باند ADSL براي كاربردي خاص استفاده مي‌كند و بسياري از ضمائم اوليه ADSL براي استانداردهاي نسل جديد 2 ADSL و +2 ADSL نيز كاربرد دارند.

ضميمه A: متداولترين گونه ADSL مي‌باشد كه در آمريكاي شمالي، اروپا و آسيا كاربرد دارد. در اين ضميمه، بخش پايين پهناي باند براي ارتباطات عادي تلفني و بخش‌هاي بعدي به ترتيب براي ارسال و دريافت ديتا مورد استفاده قرار مي‌گيرد.

ضميمه B: شبيه به گونه A مي‌باشد، با اين تفاوت كه براي خطوط تلفن ISDN كاربرد دارد. تلفن ISDN نسبت به تلفن عادي از پهناي باند بيشتري استفاده مي‌كند. ضميمه B به طور گسترده‌اي در كشور آلمان به كار گرفته شده‌است.
ضميمه C: خاص سيستم مخابرات تلفني كشور ژاپن طرح شده است كه در واقع گونه‌ خاصي از استاندارد ISDN

مي‌باشد.

ضميمه I: نسخه جديدي از ضميمه C مي باشد كه نرخ گذردهي را

درسمت دريافت تا دو برابر افزايش مي‌دهد.
ضميمه J: اين گونه به صورت كاملاً ديجيتالي كار مي‌كند و فضاي اختصاص يافته به ارتباطات تلفني را براي افزايش نرخ گذردهي ديتا به كار مي‌گيرد.

ضميمه L: يكي از جديدترين ضمائم استاندارد 2 ADSL مي‌باشد كه در بازار با نام 2 ADSL <گسترش‌يافته (RE-ADSL2)> شناخته مي‌شود. RE-ADSL2 با افزايش توان ارسال علائم، بر تضعيف حاصل از خطوط طولاني غلبه مي‌كند. نتيجه حاصل، افزايش 37 درصدي در فضاي قابل پوشش مي باشد. البته توان اضافي
RE-ADSL در فواصل كوتاهتر نيز به افزايش نرخ گذردهي نسبت به استاندارد پايه ADSL كمك مي‌كند.

پيش‌بيني‌ها
از آنجايي‌كه ارتقاء استاندارد ADSL به سطح 2 ADSL و +ADSL2 در ITU ناشي از خواست فراهم‌كنندگان خدمات و استفاده‌كنندگان اين فناوري بوده است، بديهي است كه كليه پيش‌بيني‌ها انتظار تكرار موفقيت ADSL را در انواع جديد آن نيز دارند.

تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

شنبه، 19 شهریورماه 1384

04:31 PM

September 10, 2005

نگاهي به امكانات نسخه جديد SQL Server 2005

نوشته: مهيار داعي‌الحق
ناشر: ماهنامه شبکه - فروردين و ارديبهشت ۱۳۸۳ شماره 53
shabakeh-mag.com

اشاره :
عرضه شدن نسخه 2005 پايگاه داده‌اي مشهور مايكروسافت يعني SQLServer، بازار نرم‌افزارهاي بانك اطلاعاتي را به شدت تحت تأثير خود قرار داد. امكانات گسترده‌اي كه در اين نسخه جديد تعبيه شده، طراحي و پياده‌سازي بانك‌هاي اطلاعاتي را سرعت بخشيده و تلفيق و انطباق آن با انواع فناوري‌هاي نو مانند XML وADO.NET، باعث افزايش قدرت و كارايي آن شده است. در اين مقاله به برخي از ويژگي‌هاي جديد اين برنامه نگاهي خواهيم داشت.

Snapshot Isolation Level
يكي از روش‌هايي كه به انواع متدهاي قفل كردن رديف‌هاي يك جدول بانك‌اطلاعاتي در نسخه جديد اضافه شده است، شيوه تصويربرداري از ركورد است. در روش‌هاي قبلي، اگر يك يا چند ركورد بانك اطلاعاتي توسط دستور BeginTrans كه شروع يك فرآيند را مشخص مي‌كند در شرف تغيير يا حذف قرار مي‌گرفتند، تا مادامي‌ كه فرآيند مذكور توسط دستور Commit Trans تأييد يا توسط RollBack منتفي نشود، از هيچ جا و برنامه‌اي نمي‌توان ركوردهاي مذكور را حتي با دستور ساده SELECT خواند. اما در روش جديد قفل‌گذاري، در صورت بروز چنين رويدادي ساير كاربران مي‌توانند همواره آخرين ارزش ركوردهاي مذكور را با اين فرض كه هنوز هيچ تغييري در آن‌ها ايجاد نشده است بخوانند و مورد استفاده قرار دهند.

باز هم دات‌نت
با نسخه جديد SQL Server، برنامه‌نويسان بانك‌هاي اطلاعاتي قادرند از امكانات و قابليت‌هاي موجود در پلتفرم دات‌نت و كليه توابع و كلاس‌هاي ساخته شده در آن بهره‌مند شوند. يكي از ابتدايي‌ترين و در عين حال اساسي‌ترين اين قابليت‌ها، امكان استفاده از دو زبان مهم و كاربرپسند دات‌نت يعني ويژوال بيسيك و سي‌شارپ در پياده‌سازي اجزاي مختلف يك بانك‌اطلاعاتي است. اين عامل نه‌تنها باعث مي‌شود كه برنامه‌نويسان براي نوشتن ماژول‌هايي مثل تريگرها، روال‌ها (Stored Procedures) در توابع به جاي استفاده از زبان استاندارد و در عين حال پيچيده T-SQL ، بتوانند از زبان‌هاي محيط دات‌نت با تمام ساختارها، دستورات، كلاس‌ها، آرايه‌ها، و خلاصه تمام ويژگي‌هاي يك زبان شي گرا استفاده كنند، بلكه اين همكاري نزديك بين موتور برنامه‌نويسي دات‌نت يعني CLR (كه مسؤول تبديل كدهاي نوشته شده دات‌نت به زبان سيستم‌عامل است) و موتور بانك اطلاعاتي SQLServer باعث شده تا به غير از تنوع زبان‌هاي برنامه‌نويسي قابل استفاده درSQLServer، تغيير قابل توجهي نيز در كارايي ماژول‌هاي مذكور پيش آيد. در واقع موضوع از اين قرار است كه اصولاً كدهاي نوشته شده به زبان‌هاي دات‌نت، ابتدا توسط كامپايلر به زبان (IL) ترجمه مي‌شوند. سپس CLR اين كد مياني را به كد قابل فهم سيستم‌عامل تبديل و آماده اجرا مي‌نمايد. اين كار سبب مي‌شود تا كدهاي نهايي به دليل اين‌كه بسيار به سيستم‌عامل نزديك مي‌باشد سريع‌تر از كدهاي TSQL (كه فقط توسط موتور بانك اطلاعاتي قابل اجرا هستند) اجرا شوند و در زمان اجرا از كارايي بيشتري برخوردار باشند. البته اين مسأله بدين معني نيست كه استفاده از زبان‌هاي دات‌نت هميشه بر زبان‌هاي SQL ارجحيت دارد، بلكه منظور آن است كه در برخي موارد ممكن است آن قدر منطق و الگوريتم يك ماژول پيچيده باشد كه برنامه‌نويس استفاده از زبان‌هاي دات‌نت را به دليل آسان‌تر بودن ساختار و دستورات آن به زبان SQL ترجيح دهد. بنابراين زماني كه بيشترعمليات يك ماژول مربوط به خواندن و نوشتن اطلاعات باشد بهتر است از همان دستورات استاندارد SQL يعني SELECT ،UPDATE ،DELETE وINSERT استفاده كرده و بي‌جهت منابع سيستم را صرف تعريف متغيرها و كلاس‌هاي دات‌نت ننمايد. اما در ماژول‌هايي كه بيشتر عملياتشان شامل پردازش اطلاعات مثل انجام عمليات‌هاي رياضي يا مقايسه اطلاعات با يكديگر است بهتر است تا هم از امكانات برنامه‌نويسي و هم از سرعت و كارايي بالاي دات‌نت در اين زمينه بهره برد و ماژول‌هاي مذكور را با زبان‌هاي دات‌نت پياده‌سازي كرد.

ADO .NET وارد مي‌شود
طبق يك سنت نه‌چندان قديمي برنامه‌نويسي در محيط ويندوز، برنامه‌نويسان SQLServer، بانك اطلاعاتي موردنظرشان را برروي سرور و برنامه كاربردي نوشته شده با زباني مثل ويژوال بيسيك را بر روي كلاينت‌ها قرار مي‌دهند. سپس از طريق اين برنامه كاربردي و با استفاده از اشيايي از جنس ADO داده‌هاي موردنياز خود را از سمت سرور دريافت كرده و يا به آن ارسال مي‌كنند. اكنون اين ارتباط به لطف نسخه جديد SQLServer و همچنين محيط دات‌نت، با امكانات جديدADO.NET بسيار كامل‌تر از قبل شده است. اين ارتباط جديد با استفاده از مكانيسمي به نام اعلان (Notification) به يك ارتباط دو‌طرفه فعال تبديل شده به طوري كه ADO.NET قادر است پيغام‌هايي را از سمت پايگاه داده به سمت كلاينت ارسال كند. به عنوان مثال فرض كنيد كه شما با استفاده ازADO تعدادي از ركوردهاي يك جدول بانك اطلاعاتي را انتخاب كرده و مشغول كار برروي آن‌ها هستيد. در همين هنگام كاربر ديگري از طريق كلاينت و ADO خود، ركوردي در محدوده ركوردهاي مورد انتخاب شما را تغيير مي‌دهد يا حذف مي‌كند. در اين وقت موتور پايگاه داده با ارسال پيغامي به ADO شما، اين مسأله را با استفاده از فراخواني يك رخداد (Event) شي ADO به اطلاعتان مي‌رساند.
علاوه براين قابليت جديد، فناوري جديد ديگري هم با استفاده ازADO.NET به نسخه جديد SQLServer اضافه شده و آن امكان چند پرس‌وجوي همزمان توسط يك شي ADO است. در اين شيوه اگر يك شي ADO با استفاده از دستور SELECT مشغول خواندن تعدادي از ركوردهاي يك جدول بانك اطلاعاتي باشد، مي‌تواند بدون اين‌كه منتظر به پايان رسيدن اين عمليات شود، تعداد ديگري از ركوردهاي يك جدول ديگر بانك اطلاعاتي را بخواند. اين قابليت جديد با نام (Multiple Active Result Set (MARS كه قبلاً فقط در كرسرهاي سمت سرور (server side) و آن هم نه با كارايي بالا وجود داشت اكنون در كرسرهاي سمت راست كلاينت هم وجود دارد و تفاوت عمده آن با شكل قديمي هم علاوه بر مورد مذكور، امكان ايجاد چند كرسر در يك شي ADO به صورت همزمان است. SQLServer نسخه 2005 به خوبي از تمام اين ويژگي‌ها، پشتيباني مي‌كند.

تكنولوژي XML

اكنون كه XML به يك استاندارد ارتباطي بين سكوهاي مختلف تبديل شده است، نسخه جديد SQLServer هم از توجه كافي به آن و ايجاد يك انقلاب در ساده‌تر استفاده كردن از آن طفره نرفته است. در نسخه 2000 كاربران قادر بودند تا با استفاده از دستور FOR XML نتيجه يك پرس‌وجوي SELECT از يك بانك اطلاعاتي را به درون يك فايل XML بريزند يا مثلاً با دستور OPEN XML مي‌توانستند يك فايل XML را باز كرده و شروع به خواندن دستورات درون آن نمايند.
از آن‌جا كه در نسخه جديد SQLServer توجه خاصي به اين استاندارد و زبان ارتباطي شده است، يك نوع داده جديد (Data type) به انواع داده‌هاي قبلي و استاندارد SQL مثل int ، char و امثال آن اضافه شده است. اين نوع داده جديد كه XML نام دارد و داراي خصوصيات يك نوع داده موجود در يك محيط شي‌گرا است، داراي متدهاي پيشرفته‌اي چون ()nodes() ،Value() ،exist() ،query و ()modify بوده و قادر است انواع پردازش‌هاي قابل انجام برروي اسناد XML را به راحتي انجام دهد. عمليات جستجو، تغيير، حذف و درج مقادير موردنظر در داخل يك فايل XML را مي‌توان با استفاده از متدهاي مذكور و صرفاً با چند خط برنامه‌نويسي انجام داد. همچنين در اين نسخه برخلاف نسخه 2000، با استفاده از دستور FOR XML مي‌توان يك شيء از جنس XML را بدون ارسال آن به كلاينت، برروي سرور ساخته و از آن نگهداري كرد. با اين كار مي‌توان جداولي را كه مرتباً مورد رجوع كاربران قرار مي‌گيرند هراز گاهي در قالب XML به داخل حافظه آورد و كاربران مذكور به جاي رجوع به جداول اصلي در هاردديسك، با استفاده از دستورات ويژه جستجو درXML ، متغير مذكور را در حافظه سرور مورد جستجو قرار دهند و بدين‌وسيله يك نوع عمل Cache كردن را جهت افزايش سرعت دسترسي به اطلاعات تكراري شبيه‌سازي كنند. در اين حالت، كاربران به جاي استفاده از دستورSELECT استاندارد مي‌توانند از OPEN XML كه در نسخه 2005 قادر است متغيرهاي جديد از نوع XML را بخواند استفاده كرده و به سرعت به اطلاعات موردنياز خود دسترسي پيدا كنند. اين قابليت جديد آن‌قدر در سريع‌تر كردن جستجو در برنامه‌هاي تحت وب مهم و مؤثر است كه جاي هيچ مشكلي را در استفاده از آن باقي نمي‌گذارد.

سرويس اعلان (Notification)
همان‌طور كه گفتيم سيستم اعلان درSQLServer قادر است پيغام‌هايي را طي زمان‌هاي مشخص به سمت كاربران بفرستد. مثلاً تصور كنيد كه تعدادي كاربر در حال اتصال به يك بانك حاوي اطلاعات مربوط به ارزش سهام در بورس هستند. از آن‌جايي كه ممكن است قيمت سهام هر شركت يا مؤسسه براي تعدادي از كاربران از اهميت زيادي برخوردار باشد، مي‌توان اين سيستم را طوري تنظيم كرد تا هرگاه ارزش سهام خاصي كه موردنظر هر كاربر است تغيير كرد، به صورت اتوماتيك به وي اعلام شود. كاربر هم مي‌تواند اين تغييرات را برروي برنامه كاربردي خود، تلفن همراه (در قالب Windows Messenger ،(SMS و يا ايميل به‌صورت مرتب دريافت و مشاهده كند.

سرويس گزارش‌گيري
سرويس جديد توليد گزارش‌هاي متنوع در نسخه 2005 به يكي از جالب‌ترين و پركاربردترين قابليت‌هاي اين نسخه تبديل شده است، وجود يك موتور گزارشگر قوي در سمت سرور و يك ابزار مناسب ساخت گزارش با واسط كاربر عالي، باعث شده تا برنامه‌نويسان بتوانند گزارش‌هاي موردنظر خود را با كارايي و سرعت مناسب در سمت سرور بسازند به طوري كه اين گزارش‌هاي سمت سرور توسط هر برنامه كاربردي سمت كلاينت در هر پلتفرمي با همان امكانات اتصال به SQLServer قابل مشاهده است.

بهبودهاي ايجاد شده در زبان
در 2005 SQLServer تغييرات بسيار مثبتي در زبان SQL T ايجاد شده است. اين تغييرات در زمينه‌هاي مختلف مثل مديريت خطاها، جستجوهاي بازگشتي (Recursive Query) و حتي در بدنه موتور پايگاه داده‌ها انجام شده و كارايي كلي ذخيره و يا خواندن اطلاعات را به نحو مطلوبي افزايش داده است. به عنوان مثال دردستورات
TSQL، دو اپراتور جديد ديده مي‌شود، كه PIVOT وUNPIVOT نام دارند. اين دو اپراتور كه در قسمت FROM يك پرس‌وجو مورد استفاده قرار مي‌گيرند مي‌توانند نتيجه يك جستجوي انجام شده توسط دستور SELECT را به جاي برگرداندن در قالب رديف‌ها يا ركوردهاي پشت‌سرهم، به صورت ستون‌هاي مختلف يك يا چند ركورد برگردانند. در اين روش يكي از ستون‌هاي (فيلدهاي) يك جستجو به عنوان محور معرفي شده و بقيه ستون‌ها براساس آن به صورت افقي طبقه‌بندي مي‌شوند. به يك مثال توجه كنيد:
SELECT CUSTOMER ID, order No
FROM orders PIVOT CustomerID

Order No | Order No | Order No | Order No | Customer ID
 | 4400 | 1120 | 25 | 1
 |  |  | 350 | 2
 |  | 1780 | 443 | 3
8989 | 2222 | 1980 | 555 | 4

نتيجه جستجوي فوق چيزي شبيه جدول بالا‌ خواهد بود

همان‌طور كه مشاهده مي‌كنيد با استفاده از اپراتور مذكور، نتيجه پرس‌وجوي انجام شده به اين صورت كه هر رديف به يك شماره مشتري و چندين شماره سفارش مربوطه به آن مشتري در قالب ستون‌هاي مختلف است، در مي‌آيد. اين همان چيزي است كه سال‌ها درSQLServer وجود نداشت و ابزارهاي مختلف گزارش‌سازي مثل CrystalReport آن را با نام Cross Tab به كاربران خود ارايه مي‌دادند. در همين رابطه اپراتورUNPIVOT هم عمل عكس اپراتور مذكور را انجام مي‌دهد.
اپراتور ديگري كه مي‌تواند نقش مهمي را در دستورات SQL بازي كند APPLY نام دارد كه در قسمت FROM يك دستور SQL به كار مي‌رود. با استفاده از اين دستور مي‌توان خروجي يك تابع (Function) را با يك يا چند جدول ديگر تركيب (Join) كرد همان‌طور كه مي‌دانيد در 2005 SQLServer توابع مي‌توانند يك يا چند رديف يك جدول اطلاعاتي را برگردانند كه اين خروجي مي‌تواند با يك جدول ديگر با استفاده از اپراتور مذكور تركيب شود.

مديريت خطا
در نسخه‌هاي قديمي SQLServer براي كشف و مديريت خطا از سيستم Error Handling استفاده مي‌شد. اين شيوه كشف خطا كه در زباني مثل ويژوال بيسيك 6 هم مورد استفاده قرار مي‌گرفت با استفاده از دستور GOTO مي‌توانست كنترل و خط اجراي روال را از يك محل به محل ديگر و در واقع از محل بروز خطا به محل مديريت و آشكار كردن (Raise) آن ببرد و بدين‌وسيله پيغام خطايي را به كار نشان دهد. نسخه جديد SQLServer با تأثير از پلتفرم دات‌نت، از دستورات ويژه كشف و مديريت خطا با عنوان Exception Handling استفاده مي‌كند. اين روش با استفاده از دستورات جديد TRY/CATCH شيوه بهتري از مديريت خطا را به اجرا مي‌گذارد. در اين روش برخلاف روش قبل، تمام خطاهاي اتفاق‌افتادني مثل خطاهاي مربوط به تبديل داده‌ها به يكديگر (DataConversion) به خوبي مديريت شده و از بروز خطاهايي كه منجر به اتمام ناقص عمليات يك روال يا تريگر مي‌شود جلوگيري به عمل مي‌آيد.

پي‌نوشت:
اطلاعات بيشتر درباره اين نرم‌افزار (از جمله چند دموي Flash) را مي‌توانيد از اين نشاني بدست آوريد.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

جمعه، 1 مهرماه 1384

09:27 PM

September 23, 2005

آشنايي با پروتكل SSL و عملكرد آن

مسعود راستكار
ماهنامه شبکه - آذر ۱۳۸۳ شماره 49

اشاره :
اگر مقالات الفباي رمزنگاري و PKI در شماره 42 ماهنامه شبكه را مطالعه كرده باشيد به طور قطع با اصطلاحات رمزنگاري (Cryptography)، كليدهاي نامتقارن و متقارن، گواهي‌هاي ديجيتال (Digital Certificate) كه اساس بحث اين مقاله را تشكيل مي‌دهند، آشنا هستيد. در غير‌اين‌صورت توصيه مي‌شود كه حتماً مقالات مذكور را مطالعه كنيد.

SSL چيست؟
(SSL يا Secure Socket Layer) راه‌حلي جهت برقراري ارتباطات ايمن ميان يك سرويس‌دهنده و يك سرويس‌گيرنده است كه توسط شركت Netscape ارايه شده است. در واقع SSL پروتكلي است كه پايين‌تر از لايه كاربرد (لايه 4 از مدل TCP/IP) و بالاتر از لايه انتقال (لايه سوم از مدل TCP/IP) قرار مي‌گيرد. (شكل 1)

شكل 1

مزيت استفاده از اين پروتكل بهره‌گيري از موارد امنيتي تعبيه شده آن براي امن كردن پروتكل‌هاي غيرامن لايه كاربردي نظيرHTTP ،LDAP ،IMAP و... مي‌باشد كه براساس آن الگوريتم‌هاي رمزنگاري بر روي داده‌هاي خام (plain text) كه قرار است از يك كانال ارتباطي غيرامن مثل اينترنت عبور كنند، اعمال مي‌شود و محرمانه ماندن داده‌ها را در طول كانال انتقال تضمين مي‌كند.
به بيان ديگر شركتي كه صلاحيت صدور و اعطاء گواهي‌هاي ديجيتال SSL را دارد براي هر كدام از دو طرفي كه قرار است ارتباطات ميان شبكه‌اي امن داشته باشند، گواهي‌هاي مخصوص سرويس‌دهنده و سرويس‌گيرنده را صادر مي‌كند و با مكانيزم‌هاي احراز هويت خاص خود، هويت هر كدام از طرفين را براي طرف مقابل تأييد مي‌كند، البته غير از اين‌كار مي‌بايست تضمين كند كه اگر اطلاعات حين انتقال مورد سرقت قرار گرفت، براي رباينده قابل درك و استفاده نباشد كه اين‌كار را با كمك الگوريتم‌هاي رمزنگاري و كليدهاي رمزنگاري نامتقارن و متقارن انجام مي‌دهد.

ملزومات يك ارتباط مبتني بر پروتكل امنيتي SSL
براي داشتن ارتباطات امن مبتني بر SSL عموماً به دو نوع گواهي ديجيتال SSL يكي براي سرويس‌دهنده و ديگري براي سرويس‌گيرنده و يك مركز صدور و اعطاي گواهينامه ديجيتال يا CA نياز مي‌باشد. وظيفه CA اين است كه هويت طرفين ارتباط، نشاني‌ها، حساب‌هاي بانكي و تاريخ انقضاي گواهينامه را بداند و براساس آن‌ها هويت‌ها را تعيين نمايد.

مكانيزم‌هاي تشكيل‌دهنده SSL
1- تأييد هويت سرويس‌دهنده‌
با استفاده از اين ويژگي در SSL، يك كاربر از صحت هويت يك سرويس‌دهنده مطمئن مي‌شود. نرم‌افزارهاي مبتني بر SSL سمت سرويس‌گيرنده (مثلاً يك مرورگر وب نظيرInternet Explerer از تكنيك‌هاي استاندارد رمزنگاري مبتني بر كليد عمومي و مقايسه با كليدهاي عمومي يك سرويس‌دهنده (مثلاً يك برنامه سرويس‌دهنده وب نظير (IIS مي‌تواند از هويت او مطلع شود و پس از اطمينان كامل، كاربر مي‌تواند نسبت به وارد نمودن اطلا‌عات خود مانند شماره كارت‌هاي اعتباري و يا گذرواژه‌ها اقدام نمايد.

2- تأييد هويت سرويس‌گيرنده
برعكس حالت قبلي در اينجا سرويس‌دهنده است كه مي‌بايست از صحت هويت سرويس‌گيرنده اطمينان يابد. طي اين مكانيزم، نرم‌افزار مبتني بر SSL سمت سرويس‌دهنده پس از مقايسه نام سرويس‌گيرنده با نام‌هاي مجاز موجود در ليست سرويس‌گيرنده‌هاي مجاز كه در داخل سرويس‌دهنده تعريف مي‌شود و در صورت وجود، اجازه استفاده از سرويس هاي مجاز را به او مي‌دهد.

3- ارتباطات رمز شده
كليه اطلاعات مبادله شده ميان سرويس‌دهنده و گيرنده مي‌بايست توسط نرم‌افزارهاي موجود در سمت سرويس‌دهنده و سرويس‌گيرنده رمزنگاري (Encrypt) شده و در طرف مقابل رمزگشايي (Decrypt) شوند تا حداكثر محرمانگي (Confidentiality) در اين‌گونه سيستم‌ها لحاظ شود.

اجزاي پروتكل SSL
پروتكل SSL داراي دو زير پروتكل تحت عناوين زير مي‌باشد.
1- ‌SSL Rocord Protocol كه نوع قالب‌بندي داده‌هاي ارسالي را تعيين مي‌كند.
2- SSL Handshake Protocol كه براساس قالب تعيين شده در پروتكل قبلي، مقدمات ارسال داده‌ها ميان سرويس‌دهنده‌ها و سرويس‌گيرنده‌هاي مبتني بر SSL را تهيه مي‌كند.
بخش‌بندي پروتكل SSL به دو زير پروتكل داراي مزاياي چندي است. از جمله:
اول: در ابتداي كار و طي مراحل اوليه ارتباط (Handshake) هويت سرويس‌دهنده براي سرويس‌گيرنده مشخص مي‌گردد.
دوم:‌ در همان ابتداي شروع مبادلات، سرويس‌دهنده و گيرنده بر سر نوع الگوريتم رمزنگاري تبادلي توافق مي‌كنند.
سوم: در صورت لزوم، هويت سرويس گيرنده نيز براي سرويس‌دهنده احراز مي‌گردد.
چهارم: در صورت استفاده از تكنيك‌هاي رمزنگاري مبتني بر كليد عمومي، مي‌توانند كليدهاي اشتراكي مخفي را ايجاد نمايند.
پنجم: ارتباطات بر مبناي SSL رمزنگاري مي‌شوند.

شكل 2

الگوريتم‌هاي رمزنگاري پشتيباني شده درSSL
در استانداردSSL ، از اغلب الگورتيم‌هاي عمومي رمزنگاري و مبادلات كليد (Key Exchcenge Algorithm) نظير DES ،DSA ،KEA ، MD5، RC2،RC4، RSA و RSA Key Exchauge ،SHA-1 ،Skipjack و 3DES پشتيباني مي‌شود و بسته به اين‌كه نرم‌افزارهاي سمت سرويس‌دهنده و سرويس‌دهنده نيز از موارد مذكور پشتيباني نماييد، ارتباطاتSSL مي‌تواند براساس هر كدام اين از الگوريتم‌ها صورت ‌پذيرد. البته بسته به طول كليد مورد استفاده در الگوريتم و قدرت ذاتي الگوريتم مي‌توان آن‌ها را در رده‌هاي مختلفي قرار دارد كه توصيه مي‌شود با توجه به سناريوهاي موردنظر، از الگوريتم‌هاي قوي‌تر نظير 3DES با طول كليد 168 بيت براي رمزنگاري داده‌ها و همچنين الگوريتم 1-SHA براي مكانيزم‌هاي تأييد پيغام 5 MD استفاده شود و يا اين‌كه اگر امنيت در اين حد موردنياز نبود، مي‌توان در مواردي خاص از الگوريتم رمزنگاري 4 RC با طول كليد 40 بيت و الگوريتم تأييد پيغام 5 MD استفاده نمود. (شكل 2 )

نحوه عملكرد داخلي پروتكلSSL
همان‌طور كه مي‌دانيد SSL مي‌تواند از تركيب رمزنگاري متقارن و نامتقارن استفاده كند. رمزنگاري كليد متقارن سريع‌تر از رمزنگاري كليدعمومي است و از طرف ديگر رمزنگاري كليد عمومي تكنيك‌هاي احراز هويت قوي‌تري را ارايه مي‌كند. يك جلسه SSL Session) SSL) با يك تبادل پيغام ساده تحت عنوان SSL Handshake شروع مي‌شود. اين پيغام اوليه به سرويس‌دهنده اين امكان را مي‌دهد تا خودش را به سرويس‌دهنده داراي كليد عمومي معرفي نمايد و سپس به سرويس‌گيرنده و سرويس‌دهنده اين اجازه را مي‌دهد كه يك كليد متقارن را ايجاد نمايند كه براي رمزنگاري‌ها و رمزگشايي‌ سريع‌تر در جريان ادامه مبادلات مورد استفاده قرار مي‌گيرد. گام‌هايي كه قبل از برگزاري اين جلسه انجام مي‌شوند براساس الگوريتم RSA Key Exchange عبارتند از:
1- سرويس‌گيرنده، نسخه SSL مورد استفاده خود، تنظيمات اوليه درباره نحوه رمزگذاري و يك داده تصادفي را براي شروع درخواست يك ارتباط امن مبتني بر SSL به سمت سرويس‌دهنده ارسال مي‌كند.
2- سرويس‌دهنده نيز در پاسخ نسخه SSL مورد استفاده خود، تنظيمات رمزگذاري و داده تصادفي توليد شده توسط خود را به سرويس‌گيرنده مي‌فرستد و همچنين سرويس‌دهنده گواهينامه خود را نيز براي سرويس‌گيرنده ارسال مي‌كند و اگر سرويس‌گيرنده از سرويس‌دهنده، درخواستي داشت كه نيازمند احراز هويت سرويس‌گيرنده بود، آن را نيز از سرويس‌گيرنده درخواست مي‌كند.
3- سپس سرويس‌گيرنده با استفاده از اطلا‌عاتي كه از سرويس‌دهنده مجاز در خود دارد، داده‌ها را بررسي مي‌كند و اگر سرويس‌دهنده مذكور تأييد هويت شد، وارد مرحله بعدي مي‌شود و در غيراين‌صورت با پيغام هشداري به كاربر، ادامه عمليات قطع مي‌گردد.
4- سرويس‌گيرنده يك مقدار به نام Premaster Secret را براي شروع جلسه ايجاد مي‌كند و آن را با استفاده از كليد عمومي (كه اطلاعات آن معمولاً در سرويس‌دهنده موجود است) رمزنگاري مي‌كند و اين مقدار رمز شده را به سرويس‌دهنده ارسال مي‌كند.
5- اگر سرويس‌دهنده به گواهينامه سرويس‌گيرنده نياز داشت مي‌بايست در اين گام براي سرويس‌دهنده ارسال شود و اگر سرويس‌گيرنده نتواند هويت خود را به سرويس‌دهنده اثبات كند، ارتباط در همين‌جا قطع مي‌شود.
6- به محض اين‌كه هويت سرويس‌گيرنده براي سرويس‌دهنده احراز شد، سرويس‌دهنده با استفاده از كليد اختصاصي خودش مقدار Premaster Secret را رمزگشايي مي‌كند و سپس اقدام به تهيه مقداري به نام Master Secret مي‌نمايد.
7- هم سرويس‌دهنده و هم سرويس‌گيرنده با استفاده از مقدار master Secret كليد جلسه (Session Key) را توليد مي‌كنند كه در واقع كليد متقارن مورد استفاده در عمل رمزنگاري و رمزگشايي داد‌ه‌ها حين انتقال اطلاعات است و در اين مرحله به نوعي جامعيت داد‌ها بررسي مي‌شود.
8- سرويس‌گيرنده پيغامي را به سرويس‌دهنده مي‌فرستد تا به او اطلاع دهد، داده بعدي كه توسط سرويس‌گيرنده ارسال مي‌شود به وسيله كليد جلسه رمزنگاري خواهد شد و در ادامه، پيغام رمز شده نيز ارسال مي‌شود تا سرويس‌دهنده از پايان يافتن Handshake سمت سرويس‌گيرنده مطلع شود.
9- سرويس‌دهنده پيغامي را به سرويس‌گيرنده ارسال مي‌كند تا او را از پايان Handshake سمت سرويس‌دهنده آگاه نمايد و همچنين اين‌كه داده بعدي كه ارسال خواهد شد توسط كليد جلسه رمز مي‌شود.
10- در اين مرحله SSL Handshake تمام مي‌شود و از اين به بعد جلسه SSL شروع مي‌شود و هر دو عضو سرويس‌دهنده و گيرنده شروع به رمزنگاري و رمزگشايي و ارسال داده‌ها مي‌كنند. (همانند شكل 2)

حملا‌ت تأثيرگذار برSSL
SSL نيز از حملا‌ت و نفوذهاي مختلف در امان نيست. بعضي از حملا‌ت متداولي كه براين پروتكل واقع مي‌شود عبارتند ازTraffic Analysis : يا تحليل ترافيك، حملا‌تCut ِ Paste بلووين، حملا‌ت Certification Injection و حملا‌ت از نوع Man in the middle.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

جمعه، 1 مهرماه 1384

09:30 PM

September 23, 2005

مروري بر ويژگي هاي نسخه 5.0.1 بانك اطلاعاتي MySQL

مسعود سعيدي
ماهنامه شبکه - آبان ۱۳۸۳ شماره 48

اشاره :
بانك اطلاعاتي معروف MySQL كه اپن‌سورس است، طرفداران زيادي در بين برنامه‌نويسان دارد. MySQL علاوه بر آن‌كه يكي از نمونه‌هاي بسيار موفق نرم‌افزارهاي منبع باز محسوب مي‌شود، مثالي از نرم‌افزاري است كه در اروپا (سوئد) پا به عرصه گذاشته است. نخستين نسخه اين بانك اطلاعاتي توسط دو نفر از برنامه‌نويسان سوئدي نوشته شد و از آن پس بر اساس مدل نرم‌افزارهاي منبع باز توسعه يافت. البته در ميانه راه (يعني در زمان عرضه نسخه سوم اين نرم‌افزار) بر اساس توافقي ميان شركت MySQL AB از يك سو و شركت معظم SAP (كه داراي خط تحقيق و توسعه بانك اطلاعاتي اختصاصي خود بود) از طرف ديگر، نسخه ويژه‌اي موسوم به MaxDB از تلفيق تكنولوژي‌هاي اين دو شركت در فهرست محصولات MySQL قرار گرفت. اما شركت MySQL همچنان كار توسعه نسخه قبلي و منبع باز نرم‌افزار MySQL را تا اين لحظه به موازات MaxDB ادامه داده است.

طرف‌داران فلسفه نرم‌افزار‌هاي منبع باز همواره از MySQL به عنوان نمونه‌اي ياد مي‌كنند كه توانسته است به‌خوبي با نمونه‌هاي بانك‌هاي اطلاعاتي اختصاصي همانندSQL server كه سرمايه‌گذاري‌هاي سنگيني براي توسعه آن انجام مي‌شود، رقابت كند (هر چند كه مايكروسافت بر اساس يك سياست كلي تنها رقيب خود را در زمينه بانك‌هاي اطلاعاتي، محصولا‌ت اوراكل مي‌داند و اصولاً توجهي به نرم‌افزارهاي منبع باز نمي‌كند). اما واقعيت آن است كه در دنياي برنامه‌نويسي اين دو نرم‌افزار در رقابت تنگاتنگ قرار دارند.
آخرين نسخه MySQL همراه مجموعه‌اي از قابليت‌ها و امكانات عرضه شده است كه آنرا بيش از پيش به‌سمت كاربردهاي <بزرگ مقياس> سوق مي‌دهد. برخي از ناظران معتقدند هدف اوليه تغييرات و پيشرفت‌هاي ارائه شده در نسخه 5 اين نرم‌افزار، بيش از هر چيز ديگري معطوف برنامه‌نويسي پيشرفته در كاربردهاي گسترده و بزرگ است. يكي از منابع مورداستفاده در تهيه اين مقاله در اين زمينه چنين بيان مي‌كند: <آيا زمان آن فرا رسيده است كه اوراكل باز گردد و به پشت‌سر خود نگاه كند؟> جالب است كه نويسنده در نوشته خود اصلاً اسمي از مايكروسافت و SQL server نياورده است!

بانك‌اطلاعاتي سرور از نوع Embedded
اگرچه قابليت استفاده از اين بانك اطلاعاتي به صورت سرور Embedded موضوع جديدي محسوب ن-م-ي‌ش-ود و از نسخه 4 MySQL به بعد همواره وجودداشته است، اما اين ويژگي از سوي كاربران همچنان نسبتاً ناشناخته باقي‌مانده است. استفاده از موتور نرم‌افزاري اين بانك اطلاعاتي به صورت Embedded با توجه به آن‌كه اين نرم‌افزار از نظر توابع API به‌طور كامل با مدل Client/Server سازگاري دارد، بسيار ساده است. در واقع براي به‌كارگيري اين نرم‌افزار به صورت Embedded تنها كافي است تا يك تغيير كوچك در سورس كد (نسبت به روش معمول) اعمال شود. نمونه‌اي از يك قطعه كد به زبان C (كه در گوشه و كنار اينترنت به فراواني يافت مي‌شود) اين مطلب را به‌خوبي نمايش مي‌دهد. (به قطعه كد شماره يك مراجعه نماييد)

Unionها
يونيون‌ها موجوداتي هستند كه امكان تركيب دو يا چند Query را در يك DataSet فراهم مي‌كنند (البته با فرض اين كه اسامي ستون، نوع داده و ترتيب فيلد مطابقت داشته باشند). يونيون‌ها مكانيسم بسيار قدرتمندي براي انواع گوناگون جستجو‌هاي پيشرفته محسوب مي‌شوند. به‌طور معمول زماني يونيون‌ها به‌كار برنامه‌نويسان مي‌آيند كه در كاربردهاي مورد نظر آن‌ها، دو جدول شامل اطلاعات نسبتاً مرتبط وجود داشته باشند. به عنوان مثال، در صورتي‌كه در ساختار يك بانك اطلاعاتي، يك جدول شامل اطلاعات فروشندگان باشد و جدول ديگري براي ثبت داده‌هاي شركت‌هاي فروشنده لوازم ساختماني به‌كار رفته باشد، مي‌توان از يونيون براي جستجوي همزمان در دو جدول و به‌دست آوردن يك مجموعه پاسخ يا result set بهره گرفت.

SubQueryها
از SubQuery‌ها و جداول مشتق شده براي قرار دادن عبارات انتخابي در يك SQL Statement ديگر استفاده مي‌شود. مثلاً اگر در بخش FROM عبارت جستجوي خود از يك عبارت SELECT ديگر استفاده كنيد، در اين صورت، عبارت SELECT خارجي از نتايج به‌دست آمده از عبارت SELECT به‌كار رفته در بخش FROM كلي جستجو، استفاده خواهد كرد. اين ويژگي هم يكي از ابزارهاي قدرتمندي است كه در كاربردهاي پيشرفته به كمك برنامه‌نويسان مي‌آيد.

عبارات از قبل آماده
برنامه‌نويسان آشنا با گرامر عبارات ODBC ازپيش آماده (ODBC Prepared statement) از اين پس مي‌توانند اين ويژگي را در مجموعه API بانك اطلاعاتي MySQL كه به زبان C نوشته است، نيز بيابند. مثلاً:
SELECT * FROM customer WHERE annual_sales > ? AND
?= region
اصطلاح عبارت جستجوي فوق آماده يا‌ prepare شد، برنامه‌نويس مي‌تواند توسط توابع API نرم‌افزار MySQL مقادير گوناگوني را به علامت‌هاي سؤال‌هاي به‌كار رفته در عبارت، متصل يا Bind كنند. مزيت عمده پشتيباني از چنين قابليتي در آن نهفته است كه ديگر براي هر عبارت جستجويي كه به ازاي هر يك از مقادير متغير علامت سؤال ايجاد مي‌شود، نيازي به توليد مجدد query نخواهد بود. اهميت اين موضوع زماني بيشتر آشكار مي‌گردد كه قرار باشد يك عبارت جستجوي از پيش آماده مكرراً اجرا شود. در اين وضعيت‌ به‌دليل آن‌كه query‌ها فقط يك‌بار ساخته و بهينه‌سازي مي‌شوند، سرعت اجراي نرم‌افزار به طرز محسوسي بالا خواهد بود (در واقع سرعت اجراي نرم‌افزار در قياس با حالت معمول، دچار افت قابل توجهي نخواهد شد).

چندين DataSet در يك فراخواني
از زمان عرضه نسخه 4.1 نرم‌افزار MySQL، برنامه‌نويسان مي‌توانسته‌اند توسط يك فراخواني، چندينquery را بر روي سرور به اجرا بگذارند. اين مطلب به معني آن است كه نرم‌افزار Client قادر به دريافت چندين resultSet خواهد بود. اين قابليت در مواقعي كه برنامه‌نويس از پيش مي‌داند كه چندين جستجو مستقل و ناوابسته به يكديگر بايد در كاربرد مشخصي به اجرا گذاشته شوند، عامل صرفه‌جويي بسيار مفيدي محسوب مي‌شود. علاوه بر مواردي كه در بالا مورد بررسي قرار داديم، اين قابليت زماني كه آن‌را در كنار ويژگي جديد نسخه 5 اين نرم‌افزار يعني پشتيباني ازStored Procedure‌ها مورد بررسي قرار دهيم، اهميت دوچندان خواهد يافت. زيرا مي‌دانيم كه هر Stored Procedure ممكن است منجر به توليد و بازگشت دادن چندين resultSet شود.

Viewها
Viewها براي نخستين بار در نسخه جديد MySQL مورد پشتيباني قرار گرفته‌اند. Viewها اين امكان را براي كاربر فراهم مي‌آورند كه بتواند داده‌هاي مجموعه‌اي از جداول را همانند اطلاعات يك جدول ببيند. واقعيت آن است كه Viewها از ديد برنامه‌نويسان از اهميت چنداني برخوردار نيستند. اما براي مديران بانك‌هاي اطلاعاتي، view يك ابزار كارآمد محسوب مي‌شود. در آخرين نسخه بانك‌اطلاعاتي MySQL ،view‌ها داراي قابليت Update شدن هستند.

Stored procedureها و توابع
طرفداران MySQL تا همين اواخر از اين‌كه نرم‌افزار بانك‌اطلاعاتي محبوبشان ازStored procedure‌ها پشتيباني نمي‌كند، دلخور مي‌شدند. اما از زمان عرضه نسخه 4، شركت MySQL AB وعده داده بود كه از اين قابليت در نسخه 5 پشتيباني خواهد كرد. بدين ترتيب براي نخستين بارStored procedureها در نسخه‌هاي 5 و 5.0.10 به كار گرفته شدند.
يك stored procedure ‌همان‌طور كه از نام آن مشخص مي‌شود، دستور فرايند يا تابعي است كه در محل خودِ بانك اطلاعاتي ذخيره‌سازي مي‌شود. stored procedure از چندين منظر داراي اهميت فراوان است. اصولاً يك stored procedure تابعي است كه برنامه‌نويس از آن براي انجام عمليات منطقي پيچيده بر روي داده‌هاي بانك اطلاعاتي استفاده مي‌كند. البته بايد توجه داشته باشيد كه چنين تابعي در خود بانك اطلاعاتي ذخيره مي‌شود. بدين ترتيب خواص متعددي كه به آن اشاره كرديم،‌ در اين شرايط تحقق مي‌يابند. نخست آن‌كه در يك مدل برنامه‌هاي كاربردي از نوع Client/server، انجام چنين عمليات پيچيده‌اي به هيچ وجه به سكويي كه بخش Client بر روي آن در حال اجرا خواهد بود، وابسته نيست. نكته ديگر آن‌كه در سيستم‌هاي شبكه، انجام عمليات پيچيده و سنگين تحت هيچ شرايطي منجر به ايجاد ترافيك در سطح شبكه و در نتيجه ايجاد تأخير نخواهد شد. زبان مورد استفاده براي نوشتن توابع ذخيره شده در بانك Stored procedure، زبان استانداردي است كه 2003 SQL نام دارد. اين زبان همان زباني است كه بسياري از بانك‌هاي اطلاعاتي از آن براي چنين منظور‌هايي استفاده مي‌كنند. به عنوان مثال بانك اطلاعاتي معتبر و معروف IBM به نام DB2 هم از همين زبان براي بيان روتين‌هاي توابع خود بهره مي‌گيرد.

مطلب ديگري كه نبايد آن‌را فراموش كرد آن است كه در نسخه آخر MySQL قابليت مهمي گنجانده شده است كه امكان بازگرداندن نتايج يك عبارت جستجويSELECT را به‌سمت كلاينت، فراهم مي‌كند. در صورتي‌كه نرم‌افزارMySQL از چنين قابليتي پشتيباني نمي‌كرد و برنامه‌نويسان ناگزير مي‌شدند تا يك cursor بر روي query باز كنند و نهايتاً يك resultSet بسازند. هرچند كه انجام چنين عملياتي براي برنامه‌نويسان بانك‌هاي اطلاعاتي كار دشواري محسوب نمي‌شود، اما با اين حال كاري است كه نياز به توجه كامل برنامه‌نويس براي برگرداندن نتيجه يك query به كاربر دارد. از آنجايي‌كه در كاربردهاي مشخصي، امكان بازگشت چندين resultSet به كاربر متصور است، اهميت ويژگي مورد بحث در چنين شرايط خاصي بيشتر نمايان خواهد شد. بر همين اساس توصيه مي‌شود در چنين شرايطي، حد‌المقدور از نسخه‌هاي بالاتر از نسخه 4.1 MySQL استفاده شود.
در پروژه‌هاي بزرگ و پيچيده‌تر،stored procedureها نقش ديگري نيز مي‌يابند. معمولاً مرسوم است كه در پروژه‌هاي بزرگ، يك يا دو نفر از برنامه‌نويسان خبره بانك‌هاي اطلاعاتي وظيفه مي‌يابند تا به حل مسائل پيچيده‌تر بپردازند و حاصل كار خود را به‌صورت يك عبارت SQL و در قالب يك Stored procedure تحويل دهند. بدين ترتيب مابقي برنامه‌نويسان مي‌توانند به پياده‌سازي بخش‌هاي ديگر پروژه بپردازند.

Replication
اگرچه اين ويژگي از ديرباز در نرم‌افزار MySQL مورد توجه بوده است، در نسخه جديد MySQL پيشرفت‌هاي قابل توجهي در ارتباط با اين موضوع از جهات سرعت اجرا و قابليت اطمينان صورت گرفته است. ويژگي replication از چندين جهت مهم تلقي مي‌شود.
نخست آن‌كه استفاده از replication تقريباً در اكثر نرم‌افزارهاي كاربردي بزرگ مقياس (كه كاربران متعددي در حال قرائت اطلاعات از جداول هستند)، روش متداولي به‌شمار مي‌رود. در چنين شرايطي به‌طور معمول كاهش سرعت اجراي نرم‌افزار كاربردي، هيچ چاره‌اي به‌جز بهره جستن از منابع سخت‌افزاري سريع‌تر نخواهد داشت. اما يك راه‌حل هوشمندانه ديگر نيز براي جبران مسأله سرعت اجرا وجود دارد. در اين روش مي‌توان يك بانك اطلاعاتي را فقط براي خواندن از اطلاعات به‌كار گرفت و از چندين بانك‌هاي اطلاعاتي ديگر براي نوشتن و ذخيره اطلاعات استفاده كرد.
كاربرد متداول ديگر replication، ايجاد يك پشتيبان زنده يا Hot Backup از بانك‌هاي اطلاعاتي به اصطلاح mission critical است. (اصطلاح mission critical به وضعيت‌هايي گفته مي‌شود كه در آن‌ها حتي توقف‌هاي لحظه‌اي نرم‌افزار، منجر به بروز خسارت خواهد شد. به عنوان مثال، نرم‌افزارهاي كنترلي دماي راكتور يك نيروگاه هسته‌اي، تشكيل چنين حالتي دارند. زيرا توقف لحظه‌اي فرايند كنترل دما در چنين كاربردهايي مسلماً بسيار خطرآفرين محسوب مي‌شود) سناريوي استفاده ازreplication در تهيه نسخه‌هاي <پشتيبان زنده> در كاربردهاي حساس چنان است كه به محض از كارافتادگي بانك اطلاعاتي اصلي، نسخه‌هاي پشتيبان، قابليت در مدار قرار دادن اطلاعات و جايگزين بانك اطلاعاتي اصلي شدن را دارا باشند. در يك طراحي مناسب، استفاده از replication مي‌تواند زمان‌هاي توقف يا Downtime را به حداقل برساند.

نتيجه‌گيري‌
مسير تغيير و تحولات و توسعه‌اي كه نرم‌افزار MySQL از نسخه 3 به بعد تا اين لحظه طي كرده است، مسيري دشوار و طولاني محسوب مي‌شود. اما تنها از طريق طي كردن چنين مسيرهايي يك نرم‌افزار، خصوصاً از نوع بانك‌هاي اطلاعاتي مي‌تواند خود را براي كاربرد در سطوح سازماني بزرگ (Enterprise) آماده سازد.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 7 مهرماه 1384

05:31 PM

September 29, 2005

آشنايي با مسيريابهاي سيسكو

مسعود راستكار - ماهنامه شبکه - آبان ۱۳۸۳ شماره ۴۸ و ۴۹

اشاره :
در شماره 46 ماهنامه شبكه و در مقاله آشنايي با مسيرياب‌ها، با وظايف كلي مسيرياب‌ها و نحوه عملكرد آن‌ها در شبكه‌هاي محلي و اينترنت صرف‌نظر از نوع و يا كارخانه سازنده آن‌ها آشنا شديد. اما اگرمايليد كه درباره جزئيات اين ادوات و محصولات شركت‌هاي فعال و صاحب‌نام در زمينه مسيرياب‌هاي سخت‌افزاري بيشتر بدانيد لازم است كه اين مقاله را نيز مطالعه نماييد . قبل از شروع بحث توصيه مي‌كنم علاقمنداني كه نسبت به موضوع مسيرياب‌ها ذهنيت قبلي ندارند، با توجه به پيوستگي مطالب، مقاله آشنايي با مسيرياب‌ها را مطالعه نمايند. همان‌گونه كه اشاره شد، در آن مقاله، مسيرياب‌ها را در يك طبقه‌بندي كلي به دو نوع كلي سخت افزاري و نرم افزاري تقسيم نموديم، اما در اين شماره قصد داريم به طور خاص بر روي مسيرياب‌هاي سخت افزاري شركت سيسكوسيستمز تمركز كنيم و بحث در مورد روترهاي نرم‌افزاري را به فرصت بعدي موكول مي‌كنيم.

تاريخچه مسيرياب‌هاي سخت افزاري
همان‌طوركه قبلا گفته شد نام كلي كه براي مسيرياب‌ها در نظرگرفته شده به خاطر اولين و اصلي‌ترين وظيفه هر روتر يعني عمل مسيريابي است و انتخاب اين نام هم به سال 1984 بر‌مي‌گردد. يعني زماني‌كه رفته رفته با ظهور كامپيوترهاي شخصي مشكل تعدد استانداردها تبديل به يك مشكل حاد براي شبكه هاي موجود شد. گويا در اين هنگام دو دانشمند به نام‌هاي Leonard Bosack و Sandy Lerner از دانشگاه استنفورد براي اتصال شبكه ها و مسيريابي داده ها بين اين شبكه‌ها و حل مشكل عدم سازگاري پروتكل‌هاي مختلف در سطح مسيرياب‌ها، ايده مسيريابي (Routing) را مطرح نمودند و موفق شدند اولين مسيرياب را با هزينه شخصي توليد كرده و آن‌را در دانشگاه استنفورد نصب نمايند. با توجه به استقبالي كه از اين محصول جديد شد اين دو نفر تصميم گرفتند كه محصول خود را تجاري كنند. در اين سال بود كه غول تجهيزات شبكه‌هاي كامپيوتري يعني شركت در‌زمينه طراحي و توليد مسيرياب‌هاي سخت‌افزاري حرف اول را مي زند و در اين زمينه به‌جز چند شركت ازجمله Foundry Networks و Nortel Networks رقيب جدي ديگري ندارد و طي سال‌ها با ارائه راه‌حل‌هاي جديدي نظير ايجاد تنوع در كليه محصولات و ارائه گواهينامه‌هاي مهندسي تجهيزات سيسكو نظيرCCNA ،CCDA ، CCNP و CCIE و ... موقعيت خود را بيش از پيش تثبيت نموده است. به همين دليل از مجموعه شركت‌هاي توليدكننده روترهاي سخت‌افزاري تنها برروي مسيرياب‌هاي شركت سيسكو تمركز مي كنيم و به‌دليل تنوع زياد مسيرياب‌هاي اين شركت و همچنين تعدد ماجول‌هاي مورد استفاده كه به منظور افزايش انعطاف‌پذيري مسيرياب‌ها استفاده مي‌شوند، تنها به تشريح مدل‌هاي معروف‌تر خواهيم پرداخت. البته در قسمت نخست مقاله به بيان ويژگي‌هاي كلي و در قسمت دوم كه در شماره آينده به چاپ مي‌رسد به بررسي سري‌هاي پركاربرد آن مي‌پردازيم.
يك مسيرياب صرف‌نظر از نوع، سري و قيمت آن، همانند يك كامپيوتر داراي اجزاي <سخت‌افزاري نظير جعبه
(Case) برد اصلي (MotherBoard) ، پردازنده، حافظه موقت (RAM)، حافظه دائمي (Flash) و رابط‌ها و ماجول‌هاي مختلف است كه بسته به كاربرد هر مسيرياب توان و ظرفيت متفاوتي دارند و همچنين هر مسيرياب داراي يك سيستم عامل است كه IOS ناميده مي شود و سرنام كلمات Internetworking Operating System مي‌باشد. ولي از‌آنجائي‌كه مسيرياب‌ها فاقد صفحه كليد و مانيتور هستند، معمولا به سه طريق مي‌توان فرامين سيستم عامل را براي پيكربندي مسيرياب وارد نمود، اين سه روش عبارتند از:

1) كنسول
به همراه هر مسيرياب يك كابل 8 رشته مخصوص به نام كابل Rollover ارائه مي شود كه با استفاده از آن و يك كامپيوتر شخصي و از طريق برنامه هايي نظير Term90 يا HyperTerminal ويندوز كه قابليت تبادل داده با پورت‌هاي سريال كامپيوتر را دارند، مي‌توان پيكربندي روتر را در بالاترين سطح دسترسي انجام داد.
نكته‌
- با امكان دسترسي فقط در اين سطح، مي توان تحت شرايطي حتي رمزهاي عبور دستگاه را نيز تعويض نمود. به همين دليل است كه حفاظت فيزيكي دستگاه روتر بسيار حائز اهميت است.
- اولين باري كه بخواهيد پيكربندي يك روتر را انجام دهيد، حتما" مي‌بايست از اين طريق اقدام كنيد.

2) Telnet
از آنجايي‌كه اصولاً مسيرياب‌ها در لايه شبكه مدل TCP/IP كار مي‌كنند، مي‌توانيم به آنها آدرس IP اختصاص دهيم و طبعاً با استفاده از پروتكل Telnet و پورت اترنت روتر مي توانيم از راه دور به آن متصل شده و روتر را پيكربندي كنيم. البته بايد بدانيد كه اجازه اين نوع دسترسي قبلاً مي بايست از طريق كنسول صادر شده باشد و همچنين اين‌كه كاربري كه به اين صورت به مسيرياب متصل شده، نسبت به روش اول از سطح دسترسي كمتري برخوردار است .

3) Aux
اين امكان براي مديراني است كه مي خواهند از طريق شماره گيري به مودم مسيرياب متصل شوند و آن‌را متناسب شرايط مدنظرشان پيكربندي كنند . براي اين‌كار نيز لازم است از طريق كنسول دستگاه امكان استفاده از Aux را فعال نمائيم.
در ادامه ابتدا درخصوص سري‌ها و مدل‌هاي مختلف مسيرياب‌هاي سيسكو و سپس درباره مشخصه هاي سخت‌افزاري مسيرياب‌ها و انواع آن‌ها نكاتي را عنوان مي نمائيم.

سري‌ها و مدل‌هاي مسيرياب‌هاي سيسكو
سيسكو سري‌هاي مختلف مسيرياب‌هاي خود را معمولاً توسط يك عدد چهار رقمي مشخص مي كند كه عبارتند از سري‌هاي 1000، 1600، 1700، 2500، 2600، 3200، 3600، 3700، 6400 و 7200 تا 7600 (البته استثنائاتي مثل سري 70، 90،10000، 10700 و 12000 نيز وجود دارند ) و هر سري شامل مجموعه‌اي از مدل‌هاي مختلف است مثل 1601 و 1605 از سري 1600 يا 2620 و 2621 از سري 2600 وغيره، البته دليل اين نوع نامگذاري به خاطر وجود ويژگي‌هاي مشترك بين مدل‌هاي مختلف يك سري خاص مي باشد كه هر سري را از بقيه سري‌ها متمايز مي نمايد و به طراح شبكه كمك مي كند كه با توجه به نيازهاي كلي‌اش سري مورد نظر خود را انتخاب كرده و سپس با در نظرگرفتن جزئيات مورد نظرش، مدل مناسب محيط سازماني خود را خريداري نمايد.

مشخصه‌هاي سخت‌افزاري مسيرياب‌هاي سيسكو
• Case
روترهاي سيسكو با توجه به نوع و مدل داراي بدنه‌هاي متفاوتي هستند. مثلا‌ً بدنه‌هاي Desktop كه مربوط به سري‌هاي 70 يا 90 مي‌باشند. اين بدنه‌ها قابليت افزودن ماجول يا ساير ملحقات را ندارند. در مقابل بدنه‌هايrackmount هستند كه قابليت نصب در رك را دارند. از همين نوع بدنه، بعضي كه بزرگتر بوده و قابليت نصب ماجول‌ها و كارت‌هاي زيادي را دارند به نام شاسي (Chasis) شناخته مي‌شوند.

• CPU
اگر بخواهيد سرعت پردازنده هاي كامپيوترهاي شخصي را با مسيرياب‌ها مقايسه كنيد حتماً تعجب خواهيد كرد، چرا كه حتي سريع‌ترين روترها كه مي‌توانند در ستون فقرات شبكه‌هاي اينترنتي استفاده شوند و طبعاً مي‌بايست حجم بسيار وسيعي از ترافيك اينترنت را در زمان بسيار كوتاهي پردازش نمايند، سرعتي در حدود 200 مگاهرتز دارند. وليكن از آنجايي‌كه مسيرياب‌ها واسط گرافيكي كاربر ندارند و در محيط متني كار مي كنند و همچنين به دليل تك‌منظوره بودن اين پردازنده ها اين سرعت براي اين منظور كفايت خواهد كرد. ضمناً جالب است كه بدانيد مسيرياب‌هاي سيسكو عمدتاً از پردازنده‌هاي سري 68000 شركت موتورلا استفاده مي كنند.

• مادربورد
مادربوردهاي مورد استفاده شركت سيسكو عمدتا توسط شركت‌هاي Asus و Iwill و Supermicro ساخته
مي شوند و طبيعتا" براي سري‌هاي مختلف توان و مشخصه هاي متفاوتي ارائه مي‌شود.

• حافظه
در سخت افزار مسيرياب‌هاي سيسكو بسته به نوع و كاربرد، از انواع مختلفي از حافظه ها پشتيباني مي شود كه عبارتند از:
‌-‌ RAM كه گاهي DRAM نيز ناميده مي‌شود و براي ذخيره اطلاعات حين كار به كار مي رود و يا به اصلاح سيسكو براي نگهداري Running Config مورد استفاده قرار مي‌گيرد.
در بعضي مدل‌ها، اين حافظه قابل ارتقاء و در برخي ديگر ثابت مي باشد و عموماً در ظرفيت‌هاي 4 و 8 و 16 و 32 و 64 مگابايت موجود مي باشد.
- ‌‌ROM كه در اين نوع حافظه يك تصوير قابل بوت از سيتم عامل روتر (IOS Image) قرار مي گيرد و در مراحل اوليه روند بوت مسيرياب مورد استفاده قرار مي گيرد .
- Flash Memory
همانند هاردديسك درPC ‌ها مي‌باشد و براي ذخيره كل IOS مورد‌استفاده قرار مي‌گيرد. ضمناً براي ذخيره فايل‌هاي پيكربندي نيز از اين حافظه استفاده مي‌شود كه در ظرفيت‌هاي مختلفي عرضه مي‌شود. البته نسبت به مدل و سري مسيرياب معمولاً قابل ارتقا است.
- ‌‌NVRAM
روترها از فايلي به نام Startup Config براي نگهداري تنظيمات ابتدايي پيكربندي مسيرياب استفاده مي كنند و اين فايل در اين حافظه نگهداري مي شود و پس از اين‌كه در روند بوت به داخل RAM دستگاه روتر بارگذاري شد، Running Config ناميده مي‌شود.
- ‌‌Interfaces
لينك‌هاي هر مسيرياب براي ارتباط با دنياي خارج در قالب پورت‌ها و ماجول‌ها كه براي انعطاف‌پذيري روترها درجهت انجام وظايف گوناگون قابل استفاده و تغيير است و داخل اسلات‌هاي توسعه قرار مي گيرند. به عنوان مثال مي‌توان يك ISP را درنظرگرفت كه پس افزايش خطوط تلفن خود قادرخواهد بود ماجولي به نام AM (كه شامل تعدادي مودم است) را به اسلات روتر خود (روتري كه در نقش يك Access Server عمل مي‌كند) متصل كند و كارآيي روتر را افزايش دهد. البته به شرط اين‌كه آن روتر خاص امكان اين گسترش را داشته باشد. براي آگاهي از امكانات هر مسيرياب و بررسي قابل گسترش بودن آن و نوع ماجول‌هايي كه مي‌توانيد به آن متصل كنيد، مي‌بايست به راهنماي فني هر مسيرياب يا سايت وب شركت سيسكو ( www.cisco.com ) مراجعه كنيد، مطمئناً در اين سايت اطلاعات بسيار مفيدي خواهيد يافت. ادامه اين مقاله كه به معرفي سري‌هاي مختلف روترهاي سيسكو مي‌باشد را در شماره بعدي خواهيد خواند.

سري 800
سري 800 به طور عمده شامل دو گروه ISDN و Serial مي‌باشد كه در ادامه توضيح مختصري درباره هريك خواهد آمد:

Cisco 800 Series ISDN Routers
تاكيد اين سري از محصولات سيسكو بر روي افزايش قابليت اطمينان و امنيت با بهره‌گيري از فايروال داخلي و استفاده از پروتكل امن IPSec و الگوريتم‌هاي رمزنگاري DES و 3DES مي‌باشد. از اين مسيرياب در جهت ايجاد و برقراري شبكه‌هاي VPN ميان شبكه‌هاي شعبه‌هاي شركت‌هاي كوچك از طريق خطوط ISDN استفاده مي‌شود.

Cisco 508 Series Serial Routers
توسط اين مدل مي توان ارتباط ميان شبكه‌اي راه دور و امن را از طريق خطوط سريال سازگار با استانداردهاي EIA/TIA-232 و EIA/TIA-530 و EIA/TIA-530A و 21 EIA/TIA-449 X و 35.V برقرار كرد. ساير مشخصات اين سري تقريبا همانند مدل‌هاي مشابه در سري 800 مي باشد.
در ضمن اين سري از محصولات سيسكو معمولا به صورت غير ماجولا‌ر ارائه مي‌شوند، به اين معني كه جايي براي قرارگيري ماجول‌هاي مختلف توسعه كه براي افزايش انعطاف‌پذيري هر محصول مورد استفاده قرار مي گيرد، در اين سري وجود ندارد. كه طبعا اين گروه از محصولا‌ت امكان توسعه را ندارند و به همين سبب از قيمت پايين‌تري برخوردار هستند.

سري 1700
با اين سري كه به جاي سري 1600 عرضه شده‌اند، مي‌توان دسترسي شعبه‌هاي مختلف يك شركت را از طريق خطوط مختلف نظير خطوط استيجاري 1 E و 1 T و يا از طريق اينترنت با سرعت بالا با يكديگر برقرار نمود. همچنين، ارتباطي ايمن را با بهره‌گيري از فايروال داخلي نوع Stateful و نيز امكان استفاده از سيستم كشف نفوذ
Intrusion Detection System) IDS) با كمك تكنولوژي‌هاي دستيابي WAN مختلف فراهم مي‌نمايد.
در عين حال ماجولار بودن برخي مدل‌ها و امكان بهره گيري از سرويس Voice over IP توسط ماجول‌هاي توسعه و همچنين پشتيباني از خطوط پشتيبان ISDN اين قدرت را به سري 1700 داده است تا درISP‌ها نيز مورد استفاده قرار گيرند.
اين سري شامل مدل‌ها وماجول‌هاي متفاوتي است كه در ادامه به برخي ازآن‌ها اشاره خواهد شد.

Cisco 1701 ADSL Security Access Router
درسناريوهاي شركت‌هاي كوچك و متوسط تجاري با هزينه محدود، براي استفاده از خطوط ADSL جهت برقراري ارتباطات ميان‌شبكه‌اي و همچنين داشتن خط پشتيبان براي مواقعي كه خط اصلي دچار مشكل مي‌شود، يكي از بهترين انتخاب‌ها مي‌باشد.

مشخصات مدل 1701
- مقدار حافظه DRAM پيش فرض اين مدل 64 مگابايت بوده و تا 128 مگابايت قابل افزايش است .
- مقدار حافظه Flash پيش فرض 32 مگا بايت است و قابليت ارتقاء ندارد .
- داراي يك پورت كنسول و يك پورت Aux از نوع 45 RJ مي باشد.
- يك پورت 45-RJ اترنت سريع از نوع BASE-TXو 10/100 دارد .
- داراي يك پورت WAN از نوع ISDN BRI مي‌باشد .
- همچنين داراي يك پورت WAN براي خطوط اسيجاري مي باشد .

Cisco1711,1712 Security Access Router
با داشتن هر كدام از اين دو مدل، غير از يك مسيرياب نسبتا قوي، فايروال و IDS و VPN و سوييچ اترنت سريع داخلي و رابط‌هاي WAN اضافي خواهيد داشت. اين امكانات همه در يك مسيرياب، پاسخگوي اغلب نيازهاي يك شبكه متوسط خواهد بود كه نتيجتا" منجر به كاهش هزينه نهائي پياده‌سازي نهايي شبكه مي‌شود.

مشخصات مدل‌هاي 1711 و 1712
- اين دو مدل داراي يك سوييچ 4 پورت اترنت سريع BASE-TXو 10/100 مي‌باشند.
- در مدل 1712 يك پورت ISDNBRI از طريق ماجول WIC-1B-S/T پشتيباني مي شود.
- در مدل 1711 يك پورت مودم آنالوگ از طريق يك ماجول توسعه در‌‌دسترس است.
- اين دو مدل داراي يك پورت 45 RJ براي پورت WAN از نوع BASE-TXو 10/100 مي‌باشند.
- داراي يك پورت Aux با نرخ انتقال 2/115 كيلو بيت در ثانيه است .
- پورت كنسول اين دستگاه با پورت 45-RJ قابليت انتقال داده با سرعت پيش فرض b9600 bpsرا دارد.
- براي تضمين امنيت اطلاعات از دو الگوريتم رمزنگاري 3DES-168bit و AES-128bit استفاده مي‌شود .
- حافظه Flash اين دو مدل به صورت غير قابل ارتقاء، داراي ظرفيت پيش‌فرض 32 مگابايت مي‌باشد.
- حافظه DRAM در دو مدل 1711 و 1712 به صورت پيش فرض 64 مگابايت است و حداكثر تا مقدار 128 مگابايت قابل
افزايش مي باشد.
در شكل 1 مي‌توانيد نمايي از قسمت پشتي يك مدل 1711/1712 و نحوه ارتباط مسيرياب با شبكه‌هاي ديگر را مشاهده كنيد.

سري 2600

شكل 1

مدل‌هاي قبلي اين سري كه شامل مدل‌هاي 2610، 2611، 2613، 2620، 2621، 2650 و 2651 بودند، مدل‌هاي خارج از رده محسوب مي شوند و شركت سيسكو به جاي آن‌ها سري 0062XM را ارئه نموده است . شركت سيسكو مدعي است كه از اين سري مي توان براي فراهم نمودن سرويس‌هاي چندگانه در شبكه‌هاي محلي از طريق ارتباطات WAN با بهره گيري بيش از 70 نوع ماجول مختلف استفاده كرد .
برخي از امكاناتي كه توسط ماجول‌هاي توسعه به اين سري اضافه مي شود عبارتند از: دسترسي امن به اينترنت و اينترانت از طريق فايروال داخلي‌،امكان استفاده ازVoIP ،VPN ،مسيريابي با امكان مديريت پهناي باند و ... اين سري شامل مدل‌هاي زير مي باشد :
2651XM،2650XM ،2621XM ،2620XM ،2612XM ،2611XM ،2610XM و 2691XM .

سري 3600
از اين سري براي برقراري ارتباط ميان شعبه‌هاي شركت‌هاي متوسط و بزرگ و همچنين درISP‌ها استفاده مي شود كه هم اكنون در ايران نيز تعدادي از ISP‌ها از مدل‌هاي مختلف اين سري براي انتقال صوت و داده بهره مي گيرند. اين سري از توان پردازشي نسبتا بالا‌ و قابليت ارتقا خوبي برخوردار است.
البته اغلب مدل‌هاي اين سري نظير 3620، 3631، 3640، 3660، 3661 توسط شركت سيسكو، مدل‌هاي خارج از رده معرفي شده اند .

سري 3700
شامل دو مدل 3725 و 3745 است كه در رده روترهاي دسترسي با سرويس چندگانه(Multiservice Access Router) قرار دارند و داراي مشخصات كلي زير هستند:
- دو پورت 100/10 LAN
- دو اسلات براي ماجول‌هاي مجتمع پيشرفته (AIM) داخلي .
- سه اسلات براي كارت‌هاي رابط WAN كه با نام WIC شناخته مي شوند .
- دو اسلات ماجول شبكه (NM) در مدل 3725 و چهار اسلات NM براي مدل 3745
يك اسلات (در مدل 3725) و دو اسلات (در مدل 3745) براي ماجول.HDSM
مقدار حافظه Flash پيش فرض 32 مگابايت كه تا 128 مگابايت قابل افزايش است.
داراي حافظه نوع DRAM با ظرفيت 128 مگابايت كه تا 256 مگابايت قابل افزايش است.
پشتيباني از اكثر پروتكل‌ها و رسانه هاي WAN نظير FR ،LL ،ISDN ،X.25 ،ATM ،T1/E1، انواع DSL ،T3/E3 و ... .
لا‌زم به ذكر است كه در اين مقاله، از معرفي سري‌هاي پيشرفته نظير 7600، 10000 و 12000 صرف‌نظر شده است.

ماجول‌ها
همان‌طور كه گفته شد، در مدل‌هاي ماجولار، امكان افزايش امكانات از طريق انواع مختلفي از ماجول‌هاي توسعه صورت مي پذيرد. با اين روش كاربر قادر خواهد بود يك مدل خاص با مشخصات عمومي مناسب شرايطش را خريداري كرده و با توجه به نيازهاي اختصاصي اش از انواع مختلف ماجول‌هاي توسعه استفاده نمايد .
ماجول‌هاي سيسكو تنوع بسيار زيادي دارند و نيز از آنجائي‌كه براي اغلب مدل‌ها به صورت اشتراكي قابل استفاده‌اند، پاسخگوي تمامي نيازهاي كاربران مي باشند. در ادامه به طور خلاصه به ذكر چند نوع ماجول از ميان ده‌ها ماجول مورد استفاده در مسيرياب‌ها مي پردازيم .
شركت سيسكو ماجول‌هاي مختلف خود را در حدود 30 نوع كلي طبقه بندي كرده است كه اغلب آن‌ها در محصولا‌ت مختلف سيسكو و بسترهاي خاص مخابراتي كاربرد دارند. ولي ماجول‌هاي عمومي‌تر عبارتند از :

Cisco Gigabit Ethernet Network Module
اين ماجول كه در مدل‌هاي 2691 و 3660 و سري 3700 قابل استفاده است و تحت نام NM-1GE شناخته مي شود، امكان بهره گيري از ارتباطات نوري و مسي به صورت گيگابيت اترنت را از طريق انواع مبدل رابط گيگابيت (GBIC) كه بر اساس محدوديت فاصله و نوع مسي يا نوري كابل رابط طبقه بندي مي‌شوند را مي دهد و براي ايجاد ارتباطات ميان شبكه‌اي سريع استفاده مي شوند.

Alarm Interface Controller Network Module
اين ماجول كه تحت شماره NM-AIC-64 شناخته مي‌شود، براي سري 2600 و 3600 قابل استفاده است .
با نصب اين ماجول، مدير شبكه مي تواند از مشكلات مختلفي كه در طول شبكه رخ مي‌دهد از راه دور و از طريق آلارم‌هاي هشداردهنده با خبر شود و اشكالا‌ت را برطرف كند .
برخي اتفاقاتي كه توسط اين نوع ماجول قابل بررسي و كنترل هستند عبارتند از :
تغييرات ولتاژ، تغييرات دما كه با استفاده از سنسور حرارتي تعبيه شده در ماجول صورت مي گيرد، تغييرات كشف شده توسط سيستم IDS شبكه، حملات سيل آسا (Flooding Atacks) و ... .

Cisco IP Communication Voice/Fax Network Module

با استفاده از انواع مختلف اين ماجول در مسيرياب‌هاي سري 2600XM و 2691 و 3640 و 3660 و سري 3700 شركت‌هاي بزرگ و ISPها قادر خواهند بود، با بهره گيري از امكانات مخابراتي صوت/فكس را از طريق پروتكل IP منتقل كنند. (در ارائه سرويس تلفن اينترنتيVoIP ازاين ماجول‌ها استفاده مي شود.)
اين ماجول بسته به نوع كانكتور ارتباطي داراي انواع مختلفي مي باشد كه عبارتند از:NM-HDV-1E1/1T:و1باكمك اين ماجول مي‌توان يك خط 1 T1/E را به روتر متصل كرد.NM-HDV-2E1/2T1: با نصب اين ماجول در پشت روتر اين امكان را داريم تا همزمان دو خط1 E1/T را به روتر متصل كنيم .
البته بر روي اين ماجول‌ها شكاف‌هايي نيز به منظور افزايش انعطاف پذيري روترها تعبيه شده است كه با نامVIC/VWIC شناخته مي‌شوند و در مدل‌هاي زير توليد مي شوند:
VIC22FXS: كه داراي 2 پورت براي ارتباطات صوت/فكس از طريق رابط FXS مي باشد .
VIC22FXO: همانند ماجول قبلي است ، با اين تفاوت كه اين نوع اسلات براي اتصال به دروازه هاي نوع FXO كاربرد دارد.

البته مدل‌هاي متنوع ديگري نيز وجود دارند كه نيازمند بسترهاي خاص مخابراتي مي باشند.

Cisco Analog Modem Network Module
تفاوت مدل‌هاي مختلف اين ماجول در تعداد پورت‌هاي مودم‌هاي داخلي ماجول است كه يا داراي 8 پورت و يا 16 پورت از نوع 11-RJ مي باشد.
اين ماجول در مدل‌هاي NM-8AM و NM-61AM و NM-8AM-J و NM-61AM-J موجود است كه دو ماجول با پسوند J فقط با سيستم مخابراتي كشورهاي ژاپن و سنگاپور سازگارند ولي از دو ماجول اولي مي توان براي شماره گيري در ساير كشور ها استفاده كرد. به اين معني كه مي توان روتر را طوري تنظيم كرد كه هم بتوان با استفاده از اين ماجول شماره گيري نمود و هم در صورت نياز، پيكره‌بندي روتر را به گونه اي انجام داد تا كاربران بتوانند از خارج از محيط سازمان يا ISP با آن تماس بگيرند، كه در اين مواقع روتر در نقش يك Access Server عمل مي كند.
از انواع اين ماجول مي توان در سري‌هاي 2600 و 2600XM و 3700 و مدل‌هاي 3620 و 3641 و 3661 و 2691 استفاده نمود .

Cisco Memory Modules
در برخي مدل‌هاي مسيرياب كه قابليت ارتقاء حافظه را دارند مي توانيد با توجه به حداكثر ظرفيت پذيرش هر مسيرياب كه در اين مقاله هم به مقدار برخي از آن‌ها اشاره شد، ماجول‌هاي اضافي را كه براي دو نوع حافظه Flash و DRAM موجود است را تهيه كرده و به راحتي آن‌ها را در پشت روتر نصب كنند .

سخن نهايي
خوانندگان علاقه‌مند به اين گونه مباحث مي‌توانند براي يافتن اطلاعات جامع و كامل درباره ديگر مدل‌هاي مسيرياب و ماجول‌هاي سيسكو، وب سايت رسمي شركت سيسكو به آدرس www.cisco.com را ملا‌حظه نمايند.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 21 مهرماه 1384

01:40 PM

October 13, 2005

پدر فراموش شده كامپيوتر

نوشته:عليرضا صالحي
ناشر:ماهنامه شبکه - مهر ۱۳۸۳ شماره 47

دنيا همواره به آدم‌هايي نياز داشته است كه بتوانند آينده را شكل دهند و John Vincent Atanasoff يكي از همين نوابع با چنين ديدگاهي بود. وي از جمله نخستين توسعه‌دهندگان كامپيوتر ديجيتال الكترونيكي بوده است و در واقع پديدآمدن رشته محاسبات الكترونيكي مديون وي است. وي در عين نوآور بودن، فيزيكدان و رياضيدان نيز بود.

اولين كامپيوتر الكترونيكي كه از لامپ‌هاي خلاء استفاده مي‌كرد توسط آتاناسف و كليفورد بِري در دانشكده ايالتي يوتا ساخته شد. كامپيوتر آن‌ها كه مي‌توان لقب نخستين كامپيوتر ديجيتالي را نيز به آن داد، بين سال‌هاي 1937 و 1942 ساخته شد. اين كامپيوتر مي‌توانست محاسبات دودويي را انجام دهد، حافظه‌اي پاك‌شونده داشت و مدارات منطقي را شامل مي‌شد. البته اين كامپيوتر هيچ‌گاه به توليد انبوه نرسيد و در حد يك نمونه باقي ماند.
جان، به رياضيات بسيارعلاقه‌مند بود و از سن ده‌سالگي اين علاقه خود را با مطالعه كتاب‌هاي جبر و سروكله‌زدن با ادوات مكانيكي كه كاركرد آن‌ها تابع منطق رياضي بودند، نشان مي‌داد.
جان موفق شد دوران دبيرستان را زودتر از موقع يعني طي دو سال بگذارند. اما با اين حال به دليل نياز مالي نتوانست به دانشگاه برود و در عوض پي كسب و كار رفت تا درآمدي براي گذراندن زندگي داشته باشد.
وي سرانجام در سال 1921 توانست به دانشگاه فلوريدا وارد شود و چهارسال بعد در رشته مهندسي الكترونيك با درجه A فارغ‌التحصيل شود.
جان سپس براي ادامه تحصيل وارد كالج ايالتي‌يوتا شد و در همان جا با همسر آينده‌اش Lura Meeks آشنا شد. در سال 1926 يك سال پس از ورود به كالج موفق به دريافت مدرك عالي خود در رشته رياضيات گرديد. اما علاقه او به رياضيات، فيزيك و مكانيك خاموش نشدني بود. براي همين منظور، جهت كسب مدرك دكتري به دانشگاه ويكانسين رفت تا در تئوري فيزيك صاحب مدرك PHD شود.

پس از تكميل مدارج تحصيلي، جان به ياد آرزوي ديرينه خود افتاد. آرزوي وي همواره اين بود كه راهي بيابد تا انجام محاسبات رياضي با سرعت بيشتري صورت بگيرند. هر چند كه در آن زمان ماشين‌حساب‌هاي شركت IBM با نامTabulator و نوع ديگري از ماشين‌حساب با نام Monroe Calculator وجود داشتند، اما اين دستگاه‌ها از نظر آتاناسف، هنوز كُند بودند و رضايت وي را ‌حاصل نمي‌كردند. وي اعتقاد داشت كه دستگاه آنالوگ (قياسي) نمي‌تواند به آن سرعتي برسد كه محاسبات موردنظر وي را در مدت زمان كوتاهي انجام دهد و لذا به فناوري ديجيتالي بسيار علاقمند و معتقد بود.
وي با كمك همكارانش در كالج‌يوتا، چهار اصل را براي ساخت يك كامپيوتر ديجيتالي در نظر گرفت. اين اصول عبارت بودند از:
1- كامپيوتر موردنظر بايد الكتريكي يا الكترونيكي باشد.
2- كامپيوتر موردنظر بايد از سيستم دودويي (باينري) استفاده نمايد.
3- حافظه كامپيوتر بايد از ظرفيت بالا برخوردار باشد. ضمن آن‌كه حافظه‌اي پاك‌شدني و احياشونده باشد و توان مصرفي پاييني نيز داشته باشد.
4- كامپيوتر بايد از عمليات منطقي به‌طور مستقيم استفاده نمايد و نبايد از روش‌ها يا دستگاه‌هاي آنالوگ براي انجام محاسبات بهره بگيرد.
وي با درنظرگرفتن اين چهار ويژگي، از دانشكده تقاضا كرد كه يكي از دانشجويان تازه فارغ‌التحصيل شده را به وي معرفي نمايد و كليفورد بري به همين منظور به وي معرفي شد.
آن‌ها در سال 1939، اولين نمونه از كامپيوترشان را به نام ABC كه سرنام Atanasoff Berry Computer بود آماده كردند كه به خوبي كار مي‌كرد. اما جان براي ثبت كامپيوتر خود به عنوان اولين نمونه كامپيوتر ديجيتالي مقداري تعلل كرد كه اين نتيجه خوبي در پي نداشت.
در سال 1940، دكتر جان ماچلي كه چيزهايي از كامپيوتر ABC شنيده بود، از آتاناسف تقاضا كرد كه كامپيوترش را ببينيد و وي پذيرفت. اما اين‌كار باعث شد كه ماچلي از ايده ساخت ABC بهره برداري‌هاي فراواني كند و بتواند به سرعت كامپيوتر خود به نام انياك (ENIAC) را آماده كند.
در نتيجه انياك كه با كمك دكتر اكرت ساخته شده بود، با نمايش‌هايي كه به راه انداخت نزد اغلب مردم به عنوان اولين كامپيوتر ديجيتالي شناخته ‌شد.
اما طي يك ماجراي حقوقي در سال 1972، قاضي ايالتي عنوان مبدع نخستين كامپيوتر ديجيتالي الكترونيكي را به آتاناسف اعطا كرد و مشخص گرديد كه در ساخت انياك تا حد زيادي از ABC الگوبرداري شده است. وي سپس در سال 1990، مدال ملي تكنولوژي ايالات متحده را به لحاظ همين ابداع دريافت نمود.
دكتر جان ونيسنت آتاناسف در سال 1995 و در سن 91 سالگي درگذشت. وي هر چند كه نتوانست حق اختراع ABC را براي خود ثبت نمايد اما پس از آن، 32 اختراع مختلف ديگر را به نام خود به ثبت رساند.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 24 مهرماه 1384

01:30 PM

October 16, 2005

تلفن همراه – ابزار تجارت همراه

نوشته: آقاي دكتر عياد- پژوهشگر ارشد شركت GN Netcom
از كشور دانمارك

ICTna.ir - رواج تلفن‌هاي همراه تاثير زيادي در نحوه رفتار استفاده كنندگان از اين ابزار بوجود آورده است تلفن همراه نحوه تعامل افراد با همديگر و نيز نحوه كسب و كار را تغيير داده و شغلهاي جديدي ايجاد كرده است اختراعات جديد نظير تلفن همراه، از يك طرف مرهون پيشرفت تكنولوژي و از طرف ديگر مرهون تعداد روزافزون محققين و پژوهشگران در زمينه‌هاي تكنولوژي نو از جمله تكنولوژي ارتباطات مي‌باشد ارتباطات بي‌سيم نيز از اين قاعده مستثني نمي‌باشند تلفن همراه ابزار ارسال و دريافت اطلاعات مي‌باشد منظور از اطلاعات مي‌تواند صوت، تصوير، برنامه‌هاي كامپيوتري، فيلم، ويدئو و يا حتي موقعيت جغرافيايي يك فرد ‌باشد همه اين موارد به داده‌هاي كامپيوتري تبديل شده و مخابره مي‌گردند. وسايل ارتباطي نظير تلفن همراه براي ارتباط با همديگر به يك شبكه (network) نياز دارند. اين شبكه اعم از شبكه مخابراتي و شبكه داده‌هاست و مي‌توان به آن شبكه اطلاعات كشور اطلاق نمود. اگر از نقطه نظر شبكه به جريان اطلاعات نگاه كنيم اطلاعات را مي‌توان جرياني از داده‌ها به حساب آورد حال آنكه از نقطه نظر كاربران تجاري چيزي كه در شبكه رد و بدل مي‌شود مي‌تواند اعتبار و يا پول در نظر گرفته شود. چرا كه ارتباطات بستري براي بده بستان‌هاي تجاري هستند و تفاوتي نمي‌كند اين بده بستان‌ها به صورت صوتي صورت گيرند از ابزار فكس استفاده شود و يا داده‌هاي كامپيوتري مورد نظر قرار گيرند به عنوان مثال وقتي شما با استفاده از وسايل ارتباطي مدرن امكان برقراري مكالمه صوتي، ‌تصويري و داده‌اي مطمئن و سريع را ايجاد مي‌نمائيد در واقع امكان بده بستان‌هاي تجاري سريع و مطمئن را فراهم نموده‌ايد.

سيستم‌هاي موبايل امروزي انواع مختلف ارتباط بدون سيم را فراهم مي‌كنند. در گذشته تنها ارتباط دستگاه موبايل از طريق امواج راديويي با ايستگاه تلفني مورد نظر بود اما هم اكنون امكان ارتباط يك دستگاه موبايل به صورت بي‌سيم با بسياري از تجهيزات وجود دارد از جمله مي‌توان به ارتباط بي‌سيم موبايل با كامپيوتر همراه، ارتباط بي‌سيم با گوشي همراه، ارتباط بي‌سيم با تلويزيون، ارتباط بي‌سيم با استريو،‌ ارتباط بي‌سيم با چاپگر اشاره نمود بسياري از اين ارتباط‌ها مرهون تكنولوژي ارتباط بي‌سيم دندان آبي (Bluetooth) است از طرف ديگر سرويس‌هاي روي موبايل هم به شدت متنوع شده‌اند، دريافت تلويزيون از طريق تلفن همراه، ‌دسترسي به اينترنت و دسترسي به تمام انواع سرويس‌هاي وب، دسترسي به پست الكترونيكي،‌ دريافت اطلاعات موقعيت جغرافيايي از طريق تلفن همراه از جمله اين سرويس‌ها هستند لذا مي‌توان گفت عموم سيستم‌هاي مخابراتي و سيستم‌هاي راديو تلويزيوني در حال همگرايي هستند به عبارت ديگر ارتباط 3G, 2G, WLAN, Bluetooth, RFID, Radio, DVB, GPS همگي با موبايل امكانپذير شده‌اند در سالهاي آينده تمام ارتباطات اعم از شبكه‌هاي محلي تا شبكه‌هاي گسترده با استفاده از موبايل امكان‌پذير خواهد بود. نظر به موارد ذكر شده هر كاربر موبايل تلفني به عنوان يك مشتري از طرف بنگاههاي اقتصادي مورد نظر قرار مي‌گيرد. فرض كنيد به يك شهر جديدي به صورت هوايي سفر مي‌كنيد همينكه از هواپيما خارج شده و موبايل خود را روشن كنيد به عنوان يك مشترك جديد از طريق شبكه شناخته مي‌شويد و از طرف تمام بنگاههاي اقتصادي منطقه به عنوان يك مشتري بالقوه مي‌توانيد خدمات و آگهي دريافت نمائيد از جمله مي‌توان به رستوران‌ها، فروشگاهها و ادارات دولتي اشاره نمود. استفاده از موبايل به عنوان پول الكترونيكي نيز زمينه‌اي است كه به شدت در سالهاي آينده مورد نظر خواهد بود به عبارت ديگر با داشتن تكنولوژي RFID پرداخت‌هايي نظير پرداخت بليط اتوبوس، پرداخت به فروشگاهها براي خريد و فروش با استفاده از تلفن همراه امكانپذير خواهد بود با گسترش استفاده از سيستم‌هاي RFID در خريد و فروش به جاي سيستم‌هاي باركد و عمومي شدن اين سيستم‌ها در فروشگاهها دستگاه موبايل نقش بزرگتري در تجارت ايفاء خواهند نمود. آمار اطلاعات ارائه شده از طريق شبكه موبايل از برخي كشورهاي پيشرفته مي‌تواند اين حقيقت را نشان دهد كه تا چه حد سيستم‌هاي موبايل تجارت را تحت تاثير قرار داده است.

موبايل نسل سوم به عنوان بستري براي ارتباطات كامپيوتري همراه در ژاپن از سال 1999 با ارائه سيستم NTTDocomo ارائه شده است. اين تجربه نشان مي‌دهد كه ميليونها پيغام الكترونيكي از طريق اين شبكه جابجا شده است و كاربران آن به بيش از چهل ميليون نفر رسيده است . آمار نشان مي‌دهد كه در سال 2003 تعداد سرانه پست الكترونيكي ارسال شده از طرف هر فرد در شبانه روز به بيش از ده عدد رسيده است اين تعداد پيغام الكترونيكي علاوه بر مكالمات صوتي است كه از طريق سيستم رد و بدل شده است.

Slides:
 Mobile Phone: A Tool for Everyone

مركز تحقيقات فناوري اطلاعات
دانشگاه علم و صنعت ايران
 HTTP://ITRC.IUST.AC.IR

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 24 مهرماه 1384

03:03 PM

October 16, 2005

مختل كننده‌ تلفن‌هاي همراه

تلفن‌هاي همراه امروزه در هر جاي جهان يافت مي‌شوند، تنها در ايالات متحده تا ماه ژوئن سال 2004 تعداد كاربران تلفن‌هاي همراه و اينترنت همراه 169 ميليون نفر برآورده شده است.

اين تجهيزات كاربران را قادر مي‌سازند تا در هر زمان و مكان تماس تلفني را برقرار و يا دريافت كنند، ولي متاسفانه امروزه، معضل بزرگ، استفاده كاربران از تلفن‌هاي همراه در مكان‌هايي مانند، بيمارستان‌ها،‌ بانك‌ها، كليسا‌ها، تالارهاي سينما- تاتر و موسيقي است، چرا كه كاربران نمي‌دانند كه در چه زمان‌ها و مكان‌هايي مي‌بايست گوشي خود را خاموش كنند . تلفن‌هاي همراه اساسا نوعي راديوي دو طرفه دستي هستند و طبعا هر سيگنال راديويي قابل گسيختگي و اختلال است.

مباني اختلال

ايجاد اختلال در تلفن همراه درست همانند اختلال در سايرانواع سامانه‌هاي ارتباط راديويي است. تلفن‌هاي همراه ارتباط را به وسيله آنتن‌هاي مستقردر سلول‌هاو گوشي برقرار مي‌سازند. سلول‌ها، منطقه تحت پوشش شبكه تلفن همراه را به چندين قسمت كوچك تقسيم مي‌كنند. هنگامي كه كاربر در حال رانندگي و يا حركت است، سيگنال تلفن همراه وي از سلولي به سلول ديگر دست به دست و منتقل مي‌گردد، اين ويژگي موجب پايداري تماس و عدم قطع ارتباط در هنگام حركت مي‌شود. دستگاه‌هاي مختل كنندهتلفن همراه با ارسال بسامدي همانند بسامد‌هاي تلفن همراه و يكسان

با آن‌ها موجب قطع ارتباط سيگنال ميان گوشي تلفن و سلول BTS مي‌شوند. قدرت سيگنال دستگاه‌هاي مختل كننده همواره بر تلفن‌هاي همراه غالب مي‌گردد، چرا كه اين تجهيزات با ارسال سيگنال‌هاي مخرب بر روي بسامد‌هايي مشابه بسامد‌هاي تلفن همراه اما با تواني بيشتر از آن‌ها موجب اختلال و لغو اثر سيگنال اصلي مي‌گردند. از طرف ديگر، تلفن‌هاي همراه دستگاه‌هايي هستند كه ارتباطي تمام دو طرفه را برقرار مي‌سازند،‌ بدين معني كه آن‌ها از دو بسامد يكي براي ارسال ( صحبت كردن ) و ديگري براي دريافت ( شنيدن ) به صورت همزمان، بهره مي‌برند. برخي از مختل كننده‌ها تنها يكي از بسامد‌ها را سد مي‌كند، اما تاثير نهايي قطع هر دو سيگنال است، چرا كه در اين حالت تلفن به كاربر پيغام خارج از سرويس را نشان مي‌دهد، زيرا تنها يكي از بسامد‌ها را دريافت مي‌كند. همچنين برخي از تجهيزات ساد مختل كننده، تنها يك نوع ( باند بسامدي ) از سيگنال‌ها را مختل مي‌نمايند، اما انواع پيشرفته تر قادرند تا، چندين نوع سيگنال ( باند‌هاي مختلف ) را در يك زمان مختل و قطع نمايند، چرا كه برخي از انواع گوشي‌ها كه به دو باندي و سه باندي مشهورند، در صورت قطع سيگنال دريافتي در يكي از باند‌ها، به صورت خودكار جهت برقراري ارتباط بر روي باند‌هاي ديگر فعال شده و شروع به جستجو مي‌نمايند كه انواع پيشرفتۀ مختل كننده‌ها قادر به مقابله با اين تجهيزات نيز خواهند بود. تمام آن چه كه براي مختل كردن ارتباط تلفن همراه نياز است، عبارت است از دستگاهي كه سيگنال‌هاي مورد نظر را با تواني مناسب منتشر نمايد. اگر چه شبكه‌هاي مختلف تلفن همراه از بسامد‌هاي متفاوتي بهره مي‌برند اما تمامي آن‌ها از سيگنال‌هاي راديويي استفاده مي‌كنند كه قابل مختل شدن هستند. سامانۀ متداولGSM در باند‌هاي 900 مگاهرتز و 1800 مگاهرتز در اروپا و آسيا و همچنين باند 1900 مگاهرتز در آمريكا عمل مي‌كند. مختل كننده‌ها در برابر هر يك از باند‌هاي فوق و سامانه‌هايي چون GSM، CDMA، IDEN و........ موثر واقع مي‌گردند. از سامانه‌هاي تلفن همراه آنالوگ قديمي تا جديد ديجيتالي، همگي به وسيله اين تجهيزات اخلال پذيرند.

برد موثر

برد مفيد سيگنال‌هاي دستگاه مختل كننده بيشتر تابع توان خروجي دستگاه و محيط استفاده از آن است، مختل كننده‌هاي كم توان و قابل حمل،‌ قادرند تا محيطي به شعاع 10 متر تا يك كيلومتري خود را پوشش دهند، اما مدل‌هايي با توان بالاتر كه به صورت ثابت و نصب شده استفاده مي‌شوند

فضايي تا شعاع 8 كيلومتر را نيز پوشش مي‌دهند.

ساختار يك مختل كننده

اغلب اين تجهيزات بسيار ساده و ابتدايي هستند، به طوري كه همگي داراي كليد روشن و خاموش و چراغ نمايشگري براي نشان دادن روشن بودن دستگاه هستند. تجهيزات پيشرفته تر آن‌ها،‌ شامل دستگاه‌هايي است كه به طور خودكار بر روي باند‌هاي بسامدي مختلف تلفن همراه فعاليت مي‌كنند. يك مختل كننده اغلب از اجزاء زير تشكيل يافته است:

مدار الكترونيكي: مركب است از اجزاء اصلي الكترونيكي مختل كننده.

كنترل كننده نوسانات ولتاژ: سيگنال‌هاي راديويي را براي تداخل با سيگنال‌هاي تلفن همراه توليد مي‌نمايد.

مدار كنترل: براي كنترل سيگنال‌هاي توليد شده توسط نوسان ساز.

ايجاد كننده نويز: توليد كننده سيگنال‌هاي خروجي در محدوده بسامد‌هاي شبكه تلفن همراه (بخشي از مدار كنترل است).

تقويت كننده سيگنال: توان بسامد‌هاي راديويي خروجي سامانه را به منظور بالا بردن سطح اختلال در سيگنال‌هاي اصلي تقويت مي‌نمايد.

آنتن: هر دستگاه مختل كننده داراي يك آنتن براي ارسال سيگنال است، تجهيزات قوي تر براي ارسال كردن سيگنال‌ها تا فواصل دورتر داراي آنتن خارجي و بزرگتري هستند.
كاربرد‌هاي مختلف

اين تجهيزات كه به منظور قطع ارتباط و تماس‌هاي تلفني با خارج از محدوده به كار مي‌روند، اغلب توسط نيروهاي امنيتي و مكان‌هاي حفاظت شده حساس كه خطر سرقت اشياء و يا اطلاعات و يا حملات تروريستي در آن‌ها بيشتر احساس مي‌شود به كار گرفته مي‌شوند. براي مثال در جلساتي كه شخصيت‌هاي مهم سياسي حضور دارند براي خنثي نمودن حملات احتمالي و افزايش ضريب امنيت از چنين تجهيزاتي استفاده مي‌گردد. همچنين اين تجهيزات مي‌توانند در مكان‌هايي كه بر قراري مكالمات با تلفن همراه خطرناك هستند، همچون انبارهاي مواد شيميايي حساس و منفجره و يا بيمارستان‌ها، به كار برده مي‌شوند.
معيار قانوني

در ايالات متحده، انگلستان،‌ استراليا و بسياري كشورهاي ديگر، ايجاد اختلال و سد كردن خدمات تلفن‌هاي همراه بر خلاف قانون است و سازندگان، واردكنندگان و فروشندگان اين گونه وسائل، از طرف قانون منع شده اند. دلايلي نيز براي توجيه آن وجود دارد كه از جمله آن‌ها اين است كه، خريد و استفاده از دستگاه‌هاي مختل كننده تلفن همراه از آن رو كه اين تجهيزات بر روي بسامد‌هايي كه شركت‌هاي تلفن همراه قبلا حق امتياز و مجوز ارائه خدمات خود را به صورت قانوني بر روي آن اخذ نموده اند،‌ سيگنال ارسال مي‌كنند،‌ در حقيقت نوعي دزدي و سرقت حقوق ديگران است. دليل ديگر اين كه، مختل شدن تلفن همراه مي‌تواند خطر آفرين و مضر باشد،‌ زيرا اين تجهيزات، تمامي تماس‌ها را بي ثمر و قطع مي‌نمايند، حال آن كه ممكن است شخصي نياز به ارتباط اضطراري و فوري مثل تماس با فوريت‌ها يا پليس داشته باشد.

در آمريكا FCC مسئوليت اجراي قوانين مربوط به اختلال تلفن‌هاي همراه را بر عهده دارد. در اين كشور متخلفان براي بار اول استفاده از اين تجهيزات جريمه نقدي برابر 11 هزار دلار خواهند شدو دستگاه آن‌ها نيز توقيف مي‌گردد.

بر خلاف موارد گفته شده،‌ برخي از كشور‌ها نيز، بعضا اجازه استفاده از مختل كننده‌ها را به سازمان‌هاي دولتي و تجاري يا نظامي خود مي‌دهند. براي مثال دولت فرانسه در ماه دسامبر 2004 به يكي از تالار‌هاي سينما تاتر اين كشور اجازه داد تا به شرط فراهم آوردن امكان بر قراري تماس با شماره‌هاي اضطراري، داخل سالن را تحت پوشش دستگاه‌هاي مختل كننده قرار بدهد. همچنين هندوستان نيز اين تجهيزات را در مجلس ملي و زندان‌هاي اين كشور نصب نموده است. به تازگي دانشگاه‌هاي ايتاليا نيز جهت جلوگيري از تقلب دانشجويان در امتحانات، ار اين وسائل بهره گرفته اند، زيرا تا پيش از آن، دانشجويان به وسيله تلفن‌هاي دوربين دار خود تصاويري از پاسخ آزمون را ضبط كرده و آن‌ها را براي همكلاسي خود ارسال مي‌نمودند.
بهبود عملكرد

هم اكنون شركت‌هاي سازنده مشغول بررسي براي ساخت تجهيزاتي هستند كه كارآيي بيشتري خواهند داشت. اين تجهيزات قادرند تا تماس‌هاي دريافتي تلفن‌هاي تحت پوشش خود را به سوي صندوق پست صوتي مشتركان هدايت نموده و تنها تماس‌هاي خروجي را مختل نمايند.
هشدار دهنده تلفن همراه

اين تجهيزات معمولا در مكان‌هايي كه احتمال ايجاد تداخل سيگنال‌هاي تلفن همراه و تجهيزات حساس الكترونيكي، همانند وسائل پزشكي بيمارستان‌ها و يا بانك‌ها، وجود دارد،‌ جستجو مي‌نمايند و به محض يافتن سيگنال يك تلفن همراه پيغامي را براي آن ارسال مي‌كنند و از صاحب تلفن مي‌خواهند تا گوشي خود را خاموش نمايد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 24 مهرماه 1384

03:05 PM

October 16, 2005

سامانه نمایشگر موقعیت اضطراری

Radio Beacon
شروین هادی نژاد
 hadinejad@tcwmagazine.com

برای چند دقیقه تصور کنید، هواپیمای حامل شما در دریا و یا هر جای دیگری سقوط کرده اما شما و چند نفر دیگر جان سالم به در برده اید و نیاز به کمک دارید، یا این که در بیابان یا جنگل سر در گم شده اید و نیازمند کمک فوری هستید، در این شرایط چه خواهید کرد؟ ناامید خواهید شد و شکست را خواهید پذیرفت؟ یا از قبل فکری برای این گونه حوادث نموده اید؟ تجهیزات رادیو بیکن دستگاه‌های فرستنده سیگنالی هستند که تقریبا در هر نقطه از کره زمین در صورتی که دچار شرایط اضطراری شوید، به کار افتاده و تیم‌های امداد و نجات را برای کمک به شما و یافتن محل وقوع حادثه ای که شما دچار آن شده اید آگاه می سازند

چگونگی کارکرد

هنگامی که دستگاه بیکن به واسطه ضربه یا سقوط و یا عامل انسانی به کار می افتد، شروع به ارسال سیگنال اضطراری می نماید، در این هنگام ماهواره‌های کنترل کننده بیکن، این سیگنال‌ها را دریافت کرده و آن را برای مراکز کنترل زمینی ارسال می کنند، سیگنالی که از ماهواره برای مراکز زمینی ارسال می گردد، شامل موقعیت مکانی و علائم شناسایی بیکن است. مرکز زمینی پس از دریافت اطلاعات فوق آن را در اختیار مراکز جستجو و نجات قرار داده و آن‌ها نیز به سرعت کار جستجو را آغاز می نمایند، کلیه مراحل مذکور اغلب در کم تر از چند دقیقه انجام می شوند. سامانه‌های مختلفی از بیکن‌ها در حال حاضر، برحسب هزینه، روش و نوع ماهواره‌ها در حال استفاده می باشند. اغلب سامانه‌های جدید بیکن 406 mhz به همراه یک گیرنده GPS قادرند تا یک فرستنده بیکن را با دقتی در حدود 100 متر در هر جای کره زمین مکان یابی نمایند و با دریافت شماره شناسایی که از دستگاه ارسال می گردد در کمتر از 4 دقیقه خانواده شخص یا اشخاص سانحه دیده را به وسیله تلفن در جریان وقوع حادثه قرار داده و به سرعت عملیات نجات را آغاز نمایند. قیمت چنین فرستنده ای بین 1200 تا 3000 دلار آمریکا است.

در نوع دیگر که یک سامانه متوسط بیکن 406 mhz با پوشش جهانی است ، عمل مکان یابی با دقتی در حدود شعاع 2 کیلومتر انجام خواهد گرفت. ( یعنی تیم نجات می بایست برای یافتن محل حادثه مساحتی به شعاع 5,12 کیلومتر مربع را جستجو نمایند.) همچنین آگاهی دادن به خویشاوندان و شروع عملیات جستجو در این سامانه حداکثر 2 ساعت به طول می انجامد ( به طور متوسط 45 دقیقه). این تفاوت زمانی میان 4 دقیقه در نوع پیشرفته اول و 2 ساعت در نوع دوم ناشی از تفاوت میان توان خروجی سیگنال‌های ارسالی توسط دستگاه بیکن است، چنانچه در نوع اول فرستنده قادر است تا سيگنالي با توان 5w (وات) ارسال كند ولي در نوع دوم توان سيگنال ارسالي بيكن تنها 25 ميلي وات (25 هزارم يك وات ) است، زيرا تجهيزات نوع دوم اين سيگنال را براي هواپيما‌هاي جستجو گر بر فراز منطقه ارسال مي‌نمايند. قيمت تجهيزات اخير نيز چيزي در حدود 500 تا 900 دلار است.

اما مدل‌هاي اوليه قديمي و ارزان تر كه در حدود 150 دلار قيمت دارند، شامل بيكن‌هايي هستند كه سيگنال‌هاي نا شناس ( بدون امكان ارسال شماره شناسايي ) را بر روي بسامد 121.5 mhz

( مگاهرتز ) ارسال مي‌كنند. اين تجهيزات قديمي تنها در 60 درصد مساحت كره زمين قابل استفاده هستند و از زمان اعلان تا شروع به جستجو 6 ساعت زمان لازم دارند، همچنين دقت آن‌ها در حدود شعاع 20 كيلومتري از محل ارسال است. ( تيم نجات براي يافتن منبع ارسال سيگنال و محل حادثه مي‌بايست مساحتي در حدود 1214 كيلومتر مربع را جستجو نمايد ) پوشش اين سامانه در نواحي قطبي و نيم كره شمالي زمين مناسب نيست و بسامد مورد استفاده آن نيز بسامد استاندارد اضطراري هوانوردي است كه متاسفانه تداخل بر روي آن به وسيله ديگر تجهيزات الكترونيكي، بسيار ايجاد مي‌گردد. چنانچه باعث به وجود آمدن در خواست‌هاي اضطراري كذب و يا خطا در مكان يابي خواهد شد، توان خروجي آن‌ها نيز چيزي در حدود 75 الي 100 ميلي وات است.
دسته بندي تجهيزات بر حسب كاربري

سه نوع تجهيزات راديو بيكن جهت انتشار و ارسال سيگنال‌هاي اضطراري بر حسب نوع كاربرد به كار مي‌روند كه به شرح زير است:

1- " EPIRB" (1) براي كاربران دريايي و شناورها

2- " ELT" (2) براي كاربرد‌هاي هوانوردي

3- " PLB" (3) براي كاربرد‌هاي شخصي و زميني

* -1 ERIRB:

اين سامانه كه اغلب توسط كاربران دريايي و شناور‌ها مورد استفاده قرار دارد، خود شامل دو نوع مختلف است، يكي سيگنال آنالوگ را بر روي بسامد 121.5 mhz ارسال مي‌نمايد و ديگري يك شماره شناسايي منحصر به فرد ديجيتالي را براي بسامد 406 mhz با توان كمتري نيز همزمان بر روي 121.5 mhz ارسال مي‌نمايد. فرستنده‌هاي بيكن دريايي جديد 406 mhz خود به دو دسته تقسيم مي‌شوند، دسته اول آن‌هايي را شامل مي‌شود كه قابليت به كار افتادن هم به صورت خودكارو هم به شكل دستي ( توسط عامل انساني ) را دارند. دسته دوم شامل تجهيزاتي مي‌شوند

كه تنها به شكل دستي فعال مي‌گردند، در اين صورت بايد آن‌ها را در جايي قرار داد كه در شرايط وقوع حوادث،‌ دسترسي به آن‌ها به راحتي و به سرعت امكان پذير باشد. در صورتي كه از يك فرستنده جديد بيكن 406 mhz استفاده شود، سيگنال‌هاي آن به سرعت توسط ماهواره شناسايي خواهد شد، بدين معني كه كوچكترين بي توجهي و بي ملاحظه گي از طرف كاربران ويا به كار انداختن سهوي و يا عمدي دستگاه در شرايط غير اضطراري قادر است تا يك پيام هشدار كذب را ايجاد و ارسال نمايد، بنابراين همواره كاربران مي‌بايست به منظور آزمايش دستگاه‌هاي بيكن خود مطابق با توصيه‌هاي شركت سازنده آن و يا راهنماي آيين نامه استفاده از خدمات بيكن قسمت" آزمايش صحت عملكرد" عمل نمايند تا از بروز هشدار‌هاي غير واقعي و كذب جلوگيري شود.

همچنين كاربران مي‌بايست اطلاعات اين گونه تجهيزات را بلافاصله پس از خريداري به سازمان‌هاي مربوطه معرفي و شماره شناسايي آن را به نام خود، نزد آن‌ها ثبت نمايند. در چنين شرايطي در صورتي كه به هر دليل دستگاه در شرايط غير اضطراري به كار بيافتد، عوامل امدادي و يا گشت ساحلي براي تاييد صحت وقوع حادثه با شماره تلفني كه كاربر دراختيار آن‌ها ( در هنگام ثبت )

قرار داده است،‌ تماس مي‌گيرند تا موضوع را جويا شوند، اما اگر دستگاه قبلا ثبت نشده باشد آن‌ها نمي‌توانند موضوع را تلفني بررسي كنند، بنابراين همواره فرض را بر وقوع حادثه نهاده و در جستجوي محل ارسال سيگنال بر مي‌آيند، كه در اين حالت با متخلفان ( در صورت كذب بودن هشدار ) برخورد خوبي نخواهند داشت. تمامي بيكن‌هاي دريايي 121.5 mhz آنالوگ به طور دستي به كار مي‌افتد، از آن جا كه اين تجهيزات با ماهواره‌هاي مدار پايين كار مي‌كنند نمي‌توانند به خوبي بيكن‌هاي 406 mhz عمل نمايند، به علاوه به علت مجهز نبودن تجهيزات آنالوگ به سامانه ارسال شناسه و ثبت آن‌ها، هر سيگنال ارسالي از طرف آن‌ها، چه واقعي و چه كذب باشد، مي‌بايست توسط تيم‌هاي جستجو و نجات مورد پيگيري واقع شود، بدين جهت اين تجهيزات همواره زمان و نيروي زيادي را از سازمان‌هاي جستجو و نجات هدر مي‌دهند. اما اين روند تنها تا تاريخ اول فوريه 2009 ادامه خواهد داشت. چرا كه خوشبختانه از آن زمان به بعد عمر ماهواره‌هاي مدار پايين مربوط به بيكن‌هاي قديمي به پايان مي‌رسد و همه كاربران ملزم خواهند بود تا از سامانه جديد 406 mhz ديجيتالي استفاده نمايند.

* 2- ELT:

يك فرستنده بسامد راديويي است كه سيگنال‌هايي را جهت كمك به عمليات جستجو و نجات توليد مي‌كند، براي مثال در هنگام سقوط يك هواپيما ، اين سامانه زماني كه تحت شرايط خاصي همچون ضربه‌ي شديد، فشار شديد و ناشي از انفجار و حتي به طور دستي توسط اشخاص بر جاي مانده از حادثه به طور خودكار شروع به كار مي‌نمايد. در چنين حالتي هواپيماها و يا ايستگاه‌هاي زميني كنترل،‌ بعد از دريافت سيگنال اضطراري از چنين سامانه‌اي كه بر روي بسامد 121.5 mhz منتشر مي‌شود، شروع به عمليات جستجو براي يافتن محل حادثه مي‌نمايند. تقريبا همه هواپيما‌هاي عمومي در آمريكا ملزم به حمل و استفاده از يك دستگاه ELT

هستند. به تازگي ماهواره‌اي نيز به منظور بهبود رديابي و كشف محل سيگنال‌هاي ELT در حوادث وارد عمل شده است، اگر چه هنوز هم خطاهايي انساني از قبيل به كار انداختن دستگاه به عنوان آزمايش صحت عملكرد و يا در حالتي كه هيچ گونه اتفاقي رخ نداده است و يا تداخل‌هاي بسامد ي، كه باعث سردر گمي و يا خطا در كشف دقيق محل مي‌شوند،‌ وجود دارند،‌ چنانكه بايد بدانيد كه تقريبا نسبت انتشار سيگنال‌هاي اضطراري كذب ( به كار انداختن دستگاه توسط افراد براي تفريح و يا آزمايش در شرايط عادي و غير اضطراري ) به انتشار سيگنال‌هاي اضطراري واقعي 500 به 1 است. نسل جديد و قدرتمندتر سامانه ‌هاي ELT ماهواره‌اي كه سيگنال‌هاي ديجيتالي را به همراه يك شماره شناسايي منحصر به فرد بر روي بسامد 406 mhz ارسال مي‌كند، مشكلات ناشي از تداخل‌هاي بسامد‌ي را تا حد زيادي بر طرف نموده است همچنين دقت كشف محل ارسال سيگنال را تا حد زيادي بالا برده است، چرا كه براي تيم جستجو مشخص است كه هر سيگنال از كدام دستگاه ELT ارسال مي‌گردد و آن‌ها را قادر مي‌سازد تا مستقيما به سمت محدوده محل انتشار سيگنال مشخص حركت كنند. در اين سامانه هر يك از كاربران يا دستگاه‌ها مي‌بايست از قبل شماره شناسايي دستگاه را در مركزي كه مسئوليت اين كار را بر عهده دارد ثبت شوند، بر اين اساس صحت فعاليت‌هاي كذب در چنين شرايطي به وسيله يك تماس تلفني و يا راديويي مشخص خواهد شد. در اين سامانه به وسيله استفاده از يك گيرنده موقعيت ياب جهاني (GPS) دقت در كشف محل حادثه تا شعاع 100 متر كاهش مي‌يابد. ELT اولين سامانه بيكن اضطراري بود كه در آمريكا استفاده از آن براي هواپيما‌ها اجباري شد.

* 3- PLB

اين تجهيزات نوعي از بيكن‌ها هستند كه به وسيله اشخاص حمل و استفاده مي‌گردند. هدف از كاربرد اين وسائل يافتن و نجات دادن جان انسان‌هاي حادثه ديده در روز‌هاي حساس است. روز‌هاي حساس نخستين روز‌هاي پس از وقوع حوادث مرگباري هستند كه اغلب امكان زنده ماندن نفرات در آن روز‌ها پيش بيني مي‌گردد. تنها طي سال‌هاي 1982 تا 2002 اين تجهيزات جان700 و 14 نفر را نجات داده است. تعداد دستگاه‌هاي ثبت نشده برابر نيم ميليون تخمين زده مي‌شود. اغلب اين دستگاه‌ها داراي رنگ‌هاي روشن، بدنه ضد آب و وزني در حدود 2 تا 5 كيلوگرم هستند و آن‌ها را مي‌توان به راحتي از فروشندگان تجهيزات دريانوردي و يا هوانوردي و حتي فروشندگان تجهيزات شكار خريداري كرد. عمر مفيد اين دستگاه‌ها معمولا 10 سال است و در گستره‌ي دماي ميان [-40,+40] درجه سانتيگراد كار مي‌كنند، اين تجهيزات قادرند بين 24 تا 48 ساعت سيگنال ارسال كنند. بر خلاف مدل‌هاي هوايي و دريايي كه به صورت خودكار و يا دستي فعال مي‌شوند، اين مدل‌ها تنها به طريقه دستي فعال مي‌گردند و بر روي بسامد 406 mhz عمل ارسال را انجام مي‌دهند. به علاوه، مدل‌هايي از آن‌ها كه مجهز به گيرنده GPS نيز باشند با ارسال دقيق تر موقعيت كمك بزرگي به اشخاص حادثه ديده نموده و وسعت محل مورد جستجو توسط تيم نجات را تا حدود يك زمين فوتبال (شعاع 100 متر ) كاهش مي‌دهند.

استفاده از اين تجهيزات در آمريكا براي هيچ كس منعي نداشته و نياز به هيچ گونه مجوزي نيز ندارد، اما مي‌بايست شماره سريال دستگاه به همراه اطلاعات ديگر نزد مراجع مربوطه به نام شخص كاربر ثبت مي‌گردد. اين عمل علاوه بر ايجاد توانايي بيشتر در برخورد و شناسايي سيگنال‌هاي كذب، كمك شاياني به شخص استفاده كننده جهت امداد رساني سريع تر به وي مي‌نمايد. زيرا سيگنالي كه راديو بيكن در هنگام فعاليت ارسال مي‌نمايد، شامل ارسال شماره شناسايي است كه، كاربر قبلا آن را به ثبت رسانيد،‌ است.

اجازه حمل و استفاده از PLB‌هاي شخصي براي همه مردم در سرتاسر آمريكا در تاريخ اول جولاي 2003 از سوي (FCC)كميته ملي ارتباطات صادر شد. تا پيش از اين تاريخ، تنها مردم آلاسكا قادر بودند تا از اين وسيله استفاده كنند، در اين حال برنامه استفاده از بيكن‌هاي شخصي در آلاسكا همراه با آزمايشي براي سنجش ميزان موفقيت و صحت عملكرد و كارآيي اين سامانه نيز دنبال شد،‌ كه نتايج قابل ملاحظه‌اي را در بر داشت،‌ زيرا توانسته بود جان 400 نفر را نجات بخشد و راه را براي استفاده سراسري از اين سامانه در جهان باز كند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

سه شنبه، 26 مهرماه 1384

12:26 AM

October 18, 2005

تخصص شبكه و مدرك ‍‍‍CCNP

مهيار داعي‌الحق
ماهنامه شبکه - مهر ۱۳۸۳ شماره 47

اشاره :
در شماره‌هاي گذشته ماهنامه شبكه، مطالبي در مورد مدارك مخصوص مهندسي شبكه همانند +Network و CCNA به چاپ رسيده است. مدرك +Network مربوط به آشنايي اصولي و پايه‌اي با مفاهيم اساسي شبكه است و مدرك CCNA مربوط به برپايي و پيكربندي شبكه‌هاي مبتني بر تجهيزات سيسكو كه كمتر از يكصد كلاينت در شبكه دارند. در اين شماره قصد داريم مدرك مقطع بالاتر شركت سيسكو براي شبكه‌هاي بزرگتر را معرفي كنيم. لازم به يادآوري است كه منابع مورداستفاده اين مقاله، سايت شركت سيسكو، مجلات الكترونيكي مربوط به كسب مدرك و راهنماي موسسه آموزشي كاريار ارقام مي‌باشد.

معرفي
CCNP يك مدرك رده بالاي مهندسي شبكه است. افرادي كه صاحب مدرك مذكور شوند قادر خواهند بود شبكه‌هاي بزرگ كامپيوتري كه بين صد تا بيش از پانصد كامپيوتر دارند، را نصب، پيكربندي و عيب‌يابي نمايند. اين نوع شبكه‌ها كه عموماً در كارخانجات صنعتي بزرگ مراكز عظيم تجاري و همچنين سازمان‌هاي بزرگ مستقر هستند، برخلاف شبكه‌هاي محلي كوچك و شبكه‌هاي دفتري، به دليل نوع استفاده، تعداد كاربران زياد و نقشي كه در پيشبرد اهداف نهايي آن سازمان ايفا مي‌كنند، از حساسيت و اهميت حياتي برخوردارند. لذا افرادي كه با كسب مدرك CCNP پا به عرصه پرداختن به اين‌گونه شبكه‌ها مي‌گذارند نسبت به دارندگان مدارك ديگري چون CCNA، اهداف بزرگتر و به دنبال آن مشكلات و دردسرهاي بيشتري را پيش‌رو دارند. در عوض، اين افراد از لحاظ موقعيت شغلي در رده‌هاي بالاتر، از لحاظ حساسيت نقشي كه به عهده دارند داراي مسؤوليت خطيرتر، و از لحاظ درآمد، وضعيتي مطلوبتر از ساير دست‌اندركاران طراحي و نصب شبكه دارند.
به‌طور كلي CCNP مدركي است كه چيزي را جهت دستيابي داوطلب به فناوري روز شبكه‌هاي بزرگ كم نمي‌گذارد. مباحث متعددي كه در اين دوره مطرح مي‌شود به صورت همه جانبه، هر نوع فناوري در زمينه شبكه‌هاي مذكور را مورد بررسي قرار مي‌دهد و در اين راه هر مسأله مهمي مثل امنيت، كيفيت سرويس (QoS)، شبكه‌هاي مجازي (VPN) و تكنولوژي باند‌پهن را به تفصيل مطرح مي‌نمايد.

پيش‌نياز
داوطلبان كسب مدرك CCNP بايد اولين قاعده هرم تحصيلي شركت سيسكو يعني مدرك CCNA را كه مربوط به شبكه‌هاي محلي كوچك مي‌شود گذرانده باشند. به طور كلي و بدون در نظر گرفتن هدف كسب مدرك، اشخاصي كه مايلند در دوره‌هاي آموزشي CCNP شركت نمايند بايد با مفاهيم اساسي و مهمي چون موارد زير آشنايي قبلي داشته باشند:
ISL،Route Redistribution ،IP ،X.25 ،OSPF ،IPX ،DDR ،VLSM ،IGRP ،PSTN ،Frame Relay ،Async Routing ،VLAN ،ISDN ،Apple talk ،Ethernet ،FDDI و 10. 802.

اهداف
شخصي كه به دريافت مدرك CCNP نايل مي‌شود از لحاظ رده شغلي در ميان تمام شغل‌هايي كه مربوط به مهندسي شبكه و خصوصاً نصب راه‌اندازي شبكه با استفاده از تجهيزات سيسكو مي‌شود، در رده دوم يعني پس از مدرك CCIE كه مربوط به مشاوران حرفه‌اي سيسكو است قرار مي‌گيرد. اين بدين معني است كه شخص دارندهCCNP مي‌تواند اولاً فاصله مقام خود را با ارشد‌ترين سطح كارشناسي شبكه به يك قدم برساند. كارشناس شبكه با ارتقاي مدرك خود از CCNA به CCNP نه تنها تسلط خود بر مباحث مربوط به شبكه‌هاي LAN و Dial up را افزايش مي‌دهد بلكه از محدوده شبكه‌هاي محلي با كاربرد كوچك خارج شده و توانايي خود را در راه‌اندازي شبكه‌هاي WAN تثبيت مي‌كند.
براي كسب مدرك CCNP شركت در 4 دوره آموزشي و گذراندن موفقيت‌آميز آزمون‌هاي هر كدام از آن‌ها الزامي است. اين دوره عبارتند از:

1- ساخت شبكه‌هاي عادي سيسكو (BSCI)
در اين دوره، نحوه اتصال و استفاده از روترهاي سيسكو در شبكه‌هاي LAN و WAN براي سايت‌هاي متوسط تا بزرگ آموزش داده مي‌شود. در اين دوره مباحث جامعي در زمينه پروتكل‌هاي EIGRP ،BGP ،EGP ،OSPF و ISIS مطرح شده و داوطلبان با دو نوع پروتكل مسيريابي به نام‌هاي Distance Vector و Link State آشنا شوند. با اتمام اين دوره، داوطلب مي‌تواند سرويس‌هاي IOS مناسب يك روتر سيسكو را انتخاب و راه‌اندازي نمايد.

2- ساخت شبكه‌هاي چند لايه سيسكو (BCMSN)
در اين دوره، نحوه ايجاد يك فضاي شبكه براساس فناوري سوئيچينگ چند‌لايه در سرعت‌هاي بالاي اترنت به مديران شبكه‌ها آموزش داده مي‌شود. اين دوره شامل مفاهيم مسيريابي و سوئيچينگ و فناوري‌هاي لايه دو و سه است. داوطلبان پس از طي اين دوره قادر خواهند بود يك فضاي سوئيچينگ چند لايه را برپا ساخته و به كنترل ترافيك شبكه با استفاده از سيستم‌هاي احراز هويت لايه‌هاي مختلف بپردازند.

3- ساخت شبكه‌هاي راه‌دور (BCRAN)
در اين دوره، داوطلب چگونگي پيكربندي و عيب‌يابي شبكه‌هايي كه در جاهاي ديگر ايجاد شده و از طريق تكنولوژي راه‌دور (Remote) به سايت مركزي دسترسي دارند را فرا مي‌گيرد. همچنين حالت عكس اين عمل يعني دسترسي راه‌دور به سايت مركزي با مصرف كمترين پهناي‌باند نيز در اين دوره مورد بحث قرار مي‌گيرد. به طور كلي در BCRAN توجه ويژه‌اي به شبكه‌هاي WAN به عمل آمده و نحوه پيكربندي تجهيزات سيسكو و برقراري ارتباط بهينه بين سايت مركزي و ساير شعبات و مسايل مربوط به كيفيت سرويس (QOS) در يك شبكه WAN تشريح مي‌شود.
اين دوره به خصوص براي مديران شبكه‌ها كه مسؤول اجرا و عيب‌يابي Backbone يك شبكه WAN هستند از اهميت خاصي برخوردار است.

4- پشتيباني و رفع عيب شبكه (CIT)

در اين دوره، داوطلب چگونگي عيب‌يابي كامپيوترهاي‌ سرويس‌ گيرنده يا سرويس‌دهنده كه تحت پروتكل‌هاي مختلف به هم متصل گشته‌اند و از سوئيچ‌ها و روترهاي سيسكو استفاده مي‌كنند را فرا مي‌گيرد. بنابراين با گذراندن دوره مذكور، مي‌توان به تحليل و شناسايي مشكلات در محيط‌هاي Fast Ethrnet ،VLAN ،Frame Relay ،ISDN BRI و ... پرداخت و مشكلات پيچيده مربوط به سوئيچ‌ها و روترهاي سيسكو را حل كرد.

وضعيت درآمد
طبق آمار مجله Certification، ميانگين درآمد دارندگان مدرك CCNP در سال 2003 برابر 64 هزار دلار در سال بوده است كه در مقايسه با مدرك بنيادين و سطح مبتدي شبكه يعني +Network با 38 هزار دلار در سال و مدرك سيسكو سطح متوسط شبكه يعني CCNA با 48 هزاردلار در سال، از فاصله جالب توجهي برخوردار است. در اين آمار، مدرك مهندسي شبكه مايكروسافت درآمدي در حدود 43 هزاردلار در سال را از آن خود كرده است كه اين مسأله به نوعي بيانگر دشواري مراحل يادگيري و سطح بالاي مدرك CCNP است. همچنين طبق آمار ديگري كه از طرف موسسه آموزشي Cert City صورت گرفته است، دارندگان مدرك CCNP با حداقل 12 درصد افزايش حقوق يعني بيش از 6 هزار دلار نسبت به وضعيت قبلي خود با مدرك CCNA مواجه گشته‌اند.
همچنين آماري كه مجله TCPMag ارايه مي‌دهد حاكي از كاهش 7 درصدي تعداد دارندگان اين مدرك نسبت به سال قبل 2002 است. اما در همين مورد سايت Cert Mag اعلام كرده است كه ميانگين درآمد دارندگان مدرك CCNP برابر 69 هزاردلار در سال بوده است كه نسبت به مدرك CCNA از يك افزايش 10 هزاردلاري در سال حكايت مي‌كند
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

سه شنبه، 26 مهرماه 1384

04:09 PM

October 18, 2005

نگاهي دوباره: سولاريس ۱۰ رويدادي در دنياي اپن سورس

مهيار داعي‌الحق
ماهنامه شبکه - آذر ۱۳۸۳ شماره 49

اشاره :
شايد بسياري از ما نام سيستم‌عامل شركت سان مايكروسيستمز، يعني سولاريس را كمتر از ساير سيستم‌عامل‌هاي محبوب مثل ويندوز و لينوكس شنيده باشيم. دليل آن هم كاملاً روشن است. اين سيستم‌عامل به دليل كاربردهاي خاص آن كه مربوط به ميني كامپيوترهاي SPARC مي‌شود صرفاً در دسترس افراد خاصي كه شبكه‌هاي مبتني بر كامپيوترهاي مذكور را مديريت مي‌كنند قرار دارد. پس از مدتي نسخه‌هايي از اين سيستم‌عامل قدرتمند براي نصب بر روي كامپيوترهاي شخصي X86 توسط شركت سان ارايه گرديد كه در برخي كاربردهاي خاص مثل سرورهاي اينترتني مورد اقبال كارشناسان و كاربران قرار گرفت. در اين مقاله نگاهي خواهيم داشت به اين سيستم‌عامل و نسخه جديد آن.

پس از يك سال و اندي قول و قرار، بالاخره تلاش‌هاي شبانه‌روزي و انجام آزمون‌هاي مختلف بر روي نسخه‌هاي آزمايشي نتيجه‌ و ياران اسكات مك‌نلي، مديرعامل شركت سان مايكروسيستمز، به‌طور رسمي جشن گرفتند و دوشنبه 15 نوامبر را به عنوان روزي خاطره‌انگيز اعلام نمودند. كه هم‌اكنون يك نسخه آزمايشي با عنوان Express Edition بر روي سايت شركت سان از اين نشاني آماده دريافت و نصب رايگان است.

اما طبق اظهارات مديران پروژه سولاريس، نسخه كامل آن به زودي عرضه خواهد شد و به احتمال زياد چند ماه بعد از آن هم با ارايه سورس‌كد آن به صورت، سولاريس را به جمع جامعه اُپن‌سورس رهنمون خواهد ساخت.
سيستم‌عامل سولاريس كه هم بر روي كامپيوترهاي SPARC و هم بر روي كامپيوترهاي شخصي X86 با پردازنده‌هاي اينتل و AMD قابل‌اجرا است، در طول حيات خود از سال‌ها قبل تاكنون دچار افت و خيزهاي فراواني شده است. در ابتدا اين سيستم‌عامل با ارايه يك محيط گرافيكي براي يك سيستم‌عامل مبتني بر يونيكس، توانست نظر بسياري از كاربران يونيكس‌هاي متني و قديمي‌تر مثل SCO را به خود جلب كند اما به تدريج و با مطرح شدن لينوكس و دنياي اپن‌سورس، خصوصاً در نقش سرورهاي مربوط به شبكه‌هاي كوچك، اين سيستم‌عامل در معرض رقابتي دشوار قرار گرفت. محيط‌هاي زيبا و كاربرپسند مشهور لينوكس مثل Gnome و KDE و انواع و اقسام برنامه‌ها، هر روز محبوبيت محيط گرافيكي X سولاريس را تحت‌تأثير قرار داد. البته با تمام اين اوصاف و پس از گذشت سال‌ها از ارايه نسخه‌هاي مختلف لينوكس‌هاي سرور و نرم‌افزارهاي متعدد تحت آن، هنوز سرويس‌دهنده‌هاي بزرگ اينترنتي مثل ياهو يا Hotmail و MSN، سولاريس را به عنوان يكي از قدرتمندترين، پايدارترين و امن‌ترين سيستم‌عامل‌ها مورد استفاده قرار داده و هيچگاه سخني از جايگزيني سرورهاي سولاريس خود با آلترناتيوي به نام لينوكس سخن به ميان نياورده‌اند. اما به هر حال مسأله مهمي كه در اين زمينه اتفاق افتاد، كاهش موارد استفاده و كاربرد سولاريس به عنوان يك سيستم‌عامل گرافيكي مبتني بر يونيكس بود و از اين جا به بعد بود كه بسياري از كاربران قديمي يونيكس كه به دنبال راه‌حلي براي رهايي از مشكلات و عدم جذابيت سيستم‌عامل خود بودند، به غير از سولاريس، به آلترناتيو ديگري مثل لينوكس هم به شدت توجه مي‌كردند. سان را بر آن داشت تا به هر صورتي كه شده سعي كند سولاريس را به جايگاه قبلي خود برگرداند. طبق اظهارات مقامات سان، بيش از ششصد تغيير و بهبود در نسخه جديد سولاريس 10 به‌وجود آمده است. تكنولوژي مشهور سولاريس به‌نام Big Five اكنون شامل پنج برنامه قدرتمند به‌ نام‌هاي N1 Grid Container براي ايجاد محيط‌هاي چندگانه، DTrace كه يك ابزار ويژه شناسايي و تست سيستم براي مديران شبكه است، سيستم
Predictive self healing جهت تشخيص زودهنگام اشكالات احتمالي و رفع خودكار آن‌ها، تكنولوژي
.crypto infrastructure و همچنين فايل سيستم زتابايتي (يك ميليون گيگابايتي) به‌نام ZFS مي‌باشد. از ديگر تغييرات عمده، امكان اجراي توابع كتابخانه‌اي نوشته شده براي لينوكس است. بدين‌صورت برنامه‌هاي كامپايل شده براي لينوكس، در سولاريس هم قابل‌اجرا هستند، پديده‌اي كه قبلاً سيستم‌عاملي مثل FreeBSD به داشتن آن به خود مي‌باليد.
از سوي ديگر، توسعه‌گران سيستم و برنامه‌نويسان هم از ويژگي‌هاي جديد سولاريس 10 بي‌نصب نخواهند ماند. نسخه‌هاي بتاي (Java studio 10 (JS و همچنين (7 Java studio Enterprise 7 (JSE مژده‌اي به علاقه‌مندان زبان جاوا براي برنامه‌نويسي راحت‌تر در محيط‌هاي جديد متعلق به سولاريس است.

نمايي از محيط Gnom در سولاريس، برنامه XMMS كه در سمت راست و پايين مشاهده مي شود يك برنامه پخش چندرسانه اي مشهوردر لينوكس است.
يكي از بزرگ‌ترين تغييراتي كه در نسخه جديد سولاريس به‌وجود آمده، مسأله قيمت و مجوز استفاده (License) است. در اين وادي، دارندگان نسخه‌هاي قبلي سولاريس قابل نصب بر روي سرورهاي SPARC هيچ تغيير خاصي را احساس نخواهند كرد و سياست خريد يك سرور و يك مجوز كماكان برقرار ماند. اما در مورد سرورهاي X86 احتمال اعمال دو سياست مختلف در اين زمينه وجود دارد. در ابتدا يك نسخه كاملاً رايگان و قابل دريافت از طريق اينترنت به مشتريان اعطا مي‌شود و آن‌ها فرصت كافي را براي تست و سنجش انگيزه خود جهت استفاده از نسخه جديد را مي‌‌يابند. اين نسخه هيچ جاي بروز شدن (uptodate)، رفع باگ و هر نوع پشتيباني از طرف سان را ندارد. در صورت متقاعد شدن كاربران به استفاده دائمي از سولاريس 10، يك مجوز از ميان دو انتخاب زير به آن‌ها داده مي‌شود: قيمت 120 دلار در سال براي هر پردازنده با امكان بروز شدن سيستم‌عامل و رفع باگ‌ها و يا قيمت 240 تا 360 دلار در سال براي هر پردازنده با امكانات مورد قبلي يا به علاوه هر نوع پشتيباني.
سياست مذكور صرفاً به جهت ترغيب كاربران سرورهاي ويندوز و لينوكس به روي آوردن به طرف سيستم‌عامل جديد 64 بيتي سولاريس 10 است.
مارك مك كلين، معاون فروش نرم‌افزار در سان، معتقد است: سيستم جديد قيمت‌گذاري محصولات سان، بسياري از طرفداران لينوكس ردهت و حتي فدورا را به خود جلب خواهد كرد. اگر چه فدوراي 3 يك سيستم مجوز استفاده چند لايه به نام Kick-the-tires دارد كه كاربران را تشويق به خريدن يك نسخه و استفاده از چند نسخه رايگان مي‌كند، اما آقاي مك كلين معتقد است كه سان با ارايه يك نسخه رايگان در ابتداي كار نه‌تنها مشتريان ردهت بلكه مشتريان لينوكس HP و حتي سولاريس نسخه 9 خودش را هم به شدت تحت‌تأثير قرار مي‌دهد. اين كار باعث مي‌شود تا كاربران ابتدا سرويس‌هاي مختلف موجود در سولاريس 10 را آزمايش كرده و سپس هر طور كه مي‌پسندند اقدام به خريد آن‌ها نمايند. مايكل دُرچ تحليلگر و مشاور مسايل IT معتقد است كه مديران سيستم‌هاي Enterprise به هيچ عنوان نبايد به سادگي از كنار سولاريس 10 بگذرند زيرا در صورتي كه شركت سان در اظهاراتي كه در مورد اين سيستم‌عامل مي‌كند، صادق باشد، فضاي جديدي با ارايه آن در حوزه سيستم‌عامل‌هاي قدرتمند ايجاد خواهد شد و به‌خصوص با اين سيستم قيمت‌گذاري جديد خيلي چيزها تحت‌تأثير قرار خواهند گرفت.
جان لوياسونو، معاون اجرايي سان معتقد است اين شركت در طراحي و ساخت اين نسخه سيستم‌عامل كه هزينه‌اي در حدود نيم‌ميليارد دلار و ارزش كاري بيش از سه‌هزار مهندس را دربرداشته است، اهداف كوتاه‌مدت و بلندمدت ويژه‌اي را دنبال مي‌كند. كارايي غيرقابل تصور، امنيت غيرقابل رقابت و كاربرد فراوان از جمله اين اهداف هستند. مكانيسم بهينه‌يافته TCP stack موجود در سولاريس 10، افزايش 20 درصدي سرعت انتقال ده‌ها گيگابايت اطلاعات را از طريق شبكه اترنت فراهم آورده است. يا مثلاً ابزار DTrace به بهترين وسيله مديران سيستم يا حتي برنامه‌نويسان براي مانيتورينگ سيستم تبديل شده است. بدين‌وسيله مي‌توان كليه عمليات ورودي - خروجي در حال اجرا را مشاهده كرد. بسياري از خطاهاي رخ داده در ماژول‌هاي كرنل كه پيش از اين فرصت زيادي جهت كشف آن‌ها زمان مصرف مي‌شد، اكنون در عرض چند دقيقه قابل رديابي هستند. در زمينه سيستم N1 Grid، در نسخه‌هاي قبل، اين فناوري قادر بود چند محيط مجازي جدا از هم سولاريس را بر روي يك دستگاه كامپيوتر شبيه‌سازي كند. به واسطه اين قابليت، در واقع كاربر احساس مي‌كرد كه داراي چند سيستم‌عامل سولاريس بر روي يك كامپيوتر است و مثلاً با يكي از آن‌ها شروع به نصب برنامه مي‌كرد و با ديگري به اينترنت متصل مي‌شد و غيره. اما اكنون اين مسأله به چيزي غير از وجود چند دسكتاپ مختلف براي كاربر تبديل شده است. اكنون شما با تكنولوژي N1 Grid Container قادر خواهيد بود براي اين محيط‌هاي جديد آدرس‌هاي IP جداگانه و يا فايل سيستم مجزا در نظر بگيريد. شايد بسياري از متخصصان، تكنولوژي جديد سولاريس را همتراز ماشين‌هاي مجازي WMWare كه همين كار را قادر است انجام دهد بدانند. اما نكته مهم اين است كه اصولاً محيط‌هاي شبيه‌سازي شده با WMWare بسيار كندتر و با كارايي كمتري نسبت به فناوري جديد سولاريس هستند. در سولاريس شما مي‌توانيد مثلاً 3 محيط مختلف را در عرض پانزده دقيقه ايجاد كرده و با سرعت عالي به گشت‌وگذار و كار در هر يك از آن‌ها بپردازيد. ضمن اين‌كه نياز به هيچ برنامه واسطي هم نداريد و خود سيستم‌عامل اين سرويس را به بهترين شكل و بالاترين سطح مديريت در اختيارتان قرار مي‌دهد.
به‌طور كلي ادعاي جديد سان مبني بر افزايش سرعت نسخه ويژه SPARC در سولاريس 10 و همچنين سريع‌تر بودن نسخه ويژه X86 آن نسبت به كليه لينوكس‌هاي سرور مسأله‌اي است كه با گذشت زمان و نظر كارشناسان و كاربران مشخص خواهد شد. اما در اين موضوع كه سولاريس 10 را مي‌توان يك نقطه عطف در فعاليت‌هاي شركت سان دانست، چه به لحاظ ارايه يك نسخه رايگان، چه به لحاظ ارايه سورس‌كد سيستم‌عامل و چه به‌خاطر بهبود‌هاي شگفت‌انگيز در كارايي، امنيت و سادگي استفاده. ضمن اين‌كه اصولاً شركت سان به دليل ارايه پلتفرم كامل سخت‌افزاري و نرم‌افزاري مختص خودش هميشه زبانزد جامعه IT بوده و احتمالاً اين‌بار نيز سعي در توليد سخت‌‌افزارهاي ويژه‌اي خواهد نمود كه در تعامل با سولاريس 10، قدرتي غيرقابل رقابت را در ميان سرورهاي Enterprise و حتي سرورهاي شبكه‌هاي كوچك‌تر، به دست آورد. در شماره‌هاي آينده سعي خواهيم كرد از سيستم‌عامل جديد سان، گفتني‌هاي بيشتري داشته باشي
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 30 مهرماه 1384

12:23 AM

October 22, 2005

تهيه قوانين و مقررات براي كيفيت ارائه خدمات

نوشته: سيد حسين هاشمي فشاركي و نجلا محقق (مركز تحقيقات مخابرات)

چكيده

در سال هاي اخير يكي از مباحث مطرح در زمينه ارائه خدمات مخابراتي، مسأله كيفيت ارائه است، به طوري كه بهره بردارها علاوه بر جلب رضايت مشتريان در بازار مخابراتي به دنبال صرفه‌جويي در هزينه نيز هستند و تكيه بر مورد دوم باعث كاهش كيفيت ارائه خدمات در دراز مدت مي‌گردد. بررسي تجربه كشورهايي كه در اين زمينه عملكرد مناسبي داشته‌اند براي كشورهاي در حال توسعه، راه گشا و سودمند است. اين مقاله با بررسي بخش مخابرات انگلستان و نيز نگاهي اجمالي بر جنبه‌هاي مختلف خدمات، راهكارهايي براي عملكرد بهتر در زمينه تهيه قوانين و مقررات كيفيت ارائه خدمات فراهم مي‌نمايد.

١. ضرورت تهيه قوانين و مقررات كيفيت ارائه خدمات

تهيه قوانين و مقررات كيفيت ارائه خدمات مخابرات، چالش قابل توجهي براي هر سازمان تنظيم مقررات است. قبل از درگيري با چنين كار دشواري، سازمان تنظيم مقررات بايد از اهميت آن آگاه باشد. معمولا سه بحث تقريبا متفاوت به عنوان دليل تهيه قوانين و مقررات براي كيفيت ارائه خدمات مطرح مي‌شود:

  • تقابل كيفيت- قيمت: كنترل قيمت شركت هاي بهره برداري اصلي و مادر، يكي از نخستين و اساسي‌ترين وظايف سازمان تنظيم مقررات است. كم تر كسي ضرورت كنترل قيمت را زير سؤال مي‌برند. با اين حال نوعي بينش عمومي مي‌گويد: كاهش كيفيت ارائه خدمات به تعبيري، افزايش پنهان قيمت است. راه حل ساده رسيدن به قيمت هاي هدف در يك شركت بهره برداري كه از قانون سقف قيمت تبعيت مي‌كنند، كم‌ كردن هزينه‌ها بدون توجه به كيفيت ارائه خدمات است. اگر قوانين و مقرراتي براي كيفيت، وضع نشود، نتيجه مورد انتظار اين خواهد بود كه حداقل در برخي جنبه‌ها كيفيت بدتر شده و افت كند.

  • حمايت از مصرف‌كنندگان در برابر قدرت انحصاري بهره بردار اصلي: يك مورد مرتبط ولي نه چندان مطرح اين است كه شركت بهره بردار اصلي (صرف نظر از كنترل قيمت) ممكن است نسبت به نظرات مشتريان خود در مورد كيفيت بي‌تفاوت باشد. بعضي جنبه‌هاي خدمات، مانند سرعت اصلاح خطا، ممكن است در سطحي پايين‌تر از خواسته مشتري (سطحي كه مشتري حاضر است براي آن هزينه بالاتري بپردازد) عرضه شود. ساير موارد از قبيل احتمال اجتناب از تداخل، تنها بايد آن قدر باشد كه وجود آن قابل تشخيص نباشد و موجب هزينه‌هاي اضافه غير ضروري نيز نگردد (مثلا، مصرف‌كنندگان احتمالي قادر نخواهند بود تفاوت بين عدم برقراري ١ تماس در ١٠٠٠ يا ١ تماس در ١٠٠٠٠ را تشخيص دهند).

  • انتخاب آگاهانه: هر دو مورد قبل مربوط به حالت عادي قبل از شروع رقابت هستند. اما حتي در صورت رقابت كامل، مسأله مهمي وجود دارد و آن اين است كه براي اين كه مشتريان قادر به انتخاب درست باشند، شاخص هاي كيفيت ارائه خدمات قابل مقايسه و منتشر شده، مورد نياز است.

٢. چه جنبه‌هايي از خدمات نياز به تهيه قوانين و مقررات دارد؟

با قبول ضرورت تعيين قوانين و مقررات براي كيفيت ارائه خدمات، پرسش بعد اين خواهد بود كه چه جنبه‌هايي از كيفيت و براي چه خدماتي مورد نظر است؟ يكي از دلايل اين كه مقررات كيفيت ارائه ، چالش تلقي مي‌شود، تعداد زياد جنبه‌هاي نامتجانسي است كه مي‌تواند پوشش ‌دهد. البته، محدوده‌اي از خدمات و بخش هاي بازاري هم وجود دارد. دراين مقاله، به شبكه تلفن عمومي (PSTN) به دليل تجربه مناسب مشتريان خانگي و تجاري كوچك در آن، پرداخته شده است ولي بايد توجه داشت كه فشار تهيه قوانين و مقررات براي كيفيت ارائه خدمات براي مدارهاي استيجاري، تلفن همراه، خدمات راه دور غير مستقيم و ... هم وجود دارد.

براي تصميم‌گيري در مورد اين كه چه جنبه‌هاي از خدمات مورد توجه قرار گيرد، معمولا بايد مشتريان و نظرات آن‌ها را مورد بررسي قرار داد. در عين حال ممكن است ابتدا بررسي آن چه در ساير كشورها اتفاق مي‌افتد، سودمند باشد. اين نوشته، بررسي كوتاهي روي توسعه كشورهاي اروپايي به خصوص تجربه انگلستان دارد.

در سال ١٩٨٩، جرمي ميچل و كلر ميلن، از طرف كميسيون اروپايي DGXIII ، مطالعه‌اي اجمالي درباره ي اين موضوع انجام دادند. با تركيب جنبه‌هاي خدمات مورد توجه سازمان هاي مصرف‌كننده و جنبه‌هاي عملي قابل اندازه‌گيري و نظارت شركت هاي تلفن، به هشت بخش اصلي براي تعريف و انتشار شاخص هاي كيفيت ارائه خدمات بر اساس مقايسه دست يافتند كه عبارتند از:

  • تهيه و تدارك خدمات

  • وقوع خطا

  • عاري بودن از خطا

  • برقراري تماس

  • انتقال صدا

  • تلفن هاي عمومي

  • صورت حساب

  • خدمات بهره بردار

اين مجموعه از شاخص هاي كيفيت ارائه خدمات بسيار شبيه به موارد تعيين شده توسط OECD به همين منظور بودند (مجموعه OECD تأخير بوق آزاد را اضافه كرده و انتقال صدا و صورت حساب را در درجه دوم اهميت قرار داده است). CEU پيشنهادات را تبديل به دستورالعمل يا راهنماي قوانين تدارك شبكه باز[1] و تلفن صوتي كرده است. اهداف و كارايي براي موارد زير انتشار خواهد يافت:

  • زمان لازم براي اتصال شبكه اوليه

  • زمان جبران خطا

  • نرخ خطا در تماس براي تماس هاي داخلي، داخل محدوده و خارج از محدوده

  • تاخير بوق آزاد

  • تاخير برقراري ارتباط

  • آمارهاي كيفيت انتقال

  • زمان پاسخ براي خدمات بهره بردار

  • در دسترس بودن تلفن هاي سكه‌اي و كارتي در تلفن هاي عمومي

  • صحت صورت حساب

از انجمن استانداردهاي مخابراتي اروپايي (ETSI) خواسته شد، پيش‌نويسي از استانداردهاي اروپا براي تعاريف متداول و روش هاي اندازه‌گيري براي همه اين بخش‌ها تهيه كند.

حال كه مدتي از مطالعات اوليه گذشته بايد پرسيد آيا نتايج آن هنوز معتبر است؟ در واقع، به نظر مي‌رسد كه اين طور باشد، با اين حال همان طور كه خواهيم ديد براي هر كشور بازنگري منظمي مورد نياز خواهد بود. با وجود اين كه اجزاي مناسب براي هر يك از انواع معيارها ممكن است تغيير كند، حوزه معيار ثابت خواهد ماند. براي مثال، “زمان لازم براي اتصال اوليه شبكه“ ممكن است در ابتدا به صورت ماهانه يا حتي سالانه اندازه‌گيري شده و سپس به روزانه و در انتها مطابق زمان هاي توافق شده، تغيير يابد. با اين حال، اين معيارها ممكن است به تدريج به نوعي “هسته“ نظارت دائمي و لازم، كاهش يابد و تمركز اصلي مصرف كننده به موارد جانبي و تغيير معيارهاي اساسي بدل شود.

٣. راه هاي تهيه قوانين و مقررات براي كيفيت ارائه خدمات

دو رويكرد براي تهيه قوانين و مقررات براي كيفيت ارائه خدمات وجود دارد: تشويق و اجبار. مورد اول كه اساساٌ تئوري مناسبي دارد، معمولا در اروپا استفاده مي‌شود و به عنوان گزينه ملايم‌تر ديده مي‌شود. اين مقاله عمدتاٌ روي اين روش تكيه دارد ولي براي تكميل بحث اشاره‌اي هم به روش دوم (كه در آمريكاي شمالي استفاده مي‌شود) خواهيم داشت.

روش تشويق بر اساس قدرت تبليغات و رقابت است. شركت‌ها لازم است به صورت مداوم جنبه‌هاي خاصي از كارايي خود را اندازه‌گيري كرده و منتشر كنند. موارد مؤثر در اين روش عبارتند از:

  • لزوم قابل مقايسه بودن شاخص هاي كارايي بين همه بهره بردارهاي يك كشور يا به صورت بين المللي

  • لزوم انتشار آمار و ارقام جداگانه براي نواحي مختلف كشور

  • تنظيم اهداف يا استانداردهاي دستيابي به شاخصهاي اصلي

مورد سوم بيشتر در زمان استفاده از رويكرد اجبار مورد توجه قرار مي‌گيرد و تنها مشخص مي‌كند كه يكي از اهداف، برآورده نشده و تا حدي براي افزايش كارايي به شركت، اعمال فشار مي‌كند. ولي اجبار به معناي تعيين مجازات در صورت برآورده نشدن اهداف است. اين مورد نيز ممكن است صورت هاي گوناگون داشته باشد:

  • ممكن است استانداردها در سطوح جداگانه‌اي تنظيم شده و در صورت برآورده نشدن آن ها، جبران خسارت مصرف‌كنندگان (يا خدمات جايگزين) لازم باشد. براي مثال، به مشتريان به ازاي هر روزي كه خدمات داده نمي‌شود، خسارت نقدي پرداخت شود.

  • ممكن است اهداف در سطح كلان تنظيم شوند و مجازات هاي عمومي براي عدم تحقق آن‌ها در نظر گرفته شود. مجازات‌ها به عنوان مثال مي‌تواند شامل كنترل دقيق‌تر قيمت يا پرداخت وجه نقدي براي رفاه عمومي باشد.

اجبار راه خوبي به نظر مي‌رسد ولي مشكل است بتوان نظامي طراحي كرد كه تمايلات صحيح مشتري را منعكس كرده و از موارد ناخواسته در كارايي اجتناب كند. بسيار محتمل است بتوان توجه مديريت شركت را از چند حوزه محدود در كارايي به بقيه حوزه‌ها جلب كرد.

٤. تجربه انگلستان

٤.١. تهيه قوانين و مقررات براي كيفيت ارائه خدمات در انگلستان

در طول سال هاي ٨٤-١٩٨٣، هنگامي كه پيش‌نويس قانون بخش مخابرات انگلستان نوشته شد، شرايطي براي تهيه قوانين و مقررات براي كيفيت ارائه خدمات در نظر گرفته شد. به دليل دشواري تعريف نيازهاي كيفيت ارائه خدمات به صورت دقيق و در عين حال قابل انعطاف، شركت BT، به شدت با گنجاندن اين بخش در پيش‌نويس مخالفت كرد و در نهايت ديدگاه شركت BT پيروز شد و اين شرايط از پيش‌نويس حذف گشت.

معمولا شركت BT، مجموعه‌اي سالانه از شاخص هاي كيفيت ارائه خدمات انتشار مي‌داد. با وجود خصوصي‌سازي در 1984، شركت BT به بهانه “محرمانگي تجاري“، انتشار اطلاعات كيفيت ارائه خدمات را متوقف كرد. با اين حال اين اندازه‌گيري‌ها ادامه يافته و براي آفتل (سازمان تنظيم مقررات انگلستان) قابل دسترسي بود. در سال ١٩٨٧، پس از بروز مشكلاتي در زمينه كيفيت ارائه خدمات، آفتل، شركت BT را مجبور كرد كه انتشار مجموعه‌اي مشابه از شاخص‌ها را ادامه دهد. همچنين شركت مركوري نيز مجموعه‌اي مرتبط (ولي نه قابل مقايسه) از شاخص‌ها را منتشر كرد.

كنترل RPI[2] روي قيمتهاي شركت BT، چندين بار بازنگري شد (اثر عمده آن افزايش ارزش پيشرفتهاي كارايي سالانه مورد نياز بود). در همان زمان، دوباره اثبات شد كه كيفيت بايد به عنوان “روي ديگر سكه“ در كنترل قيمت ديده شود زيرا كاهش كيفيت موجب افزايش پنهان قيمت مي‌شود. سؤالاتي به وجود آمد كه آيا سازوكارهاي كنترل قيمت بايد براي برخورد مستقيم با كيفيت گسترش داده شود يا خير. براي مثال، آيا بايد نوعي شاخص كيفيت ايجاد شود و با نرخ معيني افزايش يابد يا در غير اين صورت حد قيمت را تعيين نمايد؟ تا به امروز اين رويكرد هر چند نه به صورت قطعي، رد شده است. آفتل اعلام كرده است “اگر قرار باشد افتي در كيفيت ارائه خدمات رخ دهد، اين مسأله مي‌تواند دليلي براي بررسي دوباره سطح سقف قيمت باشد“.

برنامه فعلي تعهد نسبت به مشتري شركت BT، در آوريل 1989 اعلام شد. اين برنامه در صورت برآورده نشدن استانداردهاي مشخصي از خدمات، بر مبناي مجموعه‌اي از مقياس ها، براي مشتريان، جبران خسارت در نظر مي‌گرفت.

گزارش هاي سالانه آفتل در مورد كيفيت ارائه خدمات تلفن، فشار بيشتري بر شركت BT گذاشت. اين گزارش‌ها علاوه بر عمومي كردن مقياس هاي اندازه‌گيري BT، شامل نتايج بررسي هاي مختلف از طرف آفتل نيز بود. مواردي كه آفتل مد نظر قرار داد عبارت بودند از: تماس هاي ناخواسته مربوط به فروش، مزاحمت هاي تلفني ، خدمات تلفن عمومي، پاسخ به درخواست هاي راهنماي تلفن و پاسخ به ٩٩٩ (تلفنهاي ضروري).

در پاييز ١٩٩٣، آفتل، آنچه را كه به عنوان نسخه اوليه شاخص هاي كارايي قابل مقايسه (CPI) شناخته شده، ارائه كرد. از بخش صنعتي درخواست شد تا شاخص هاي كيفيت ارائه خدمات را بررسي نمايد و با بعضي شاخص هاي كيفيت ارائه خدمات كه اصلي‌ترين جنبه‌هاي خدمات مورد نظر مشتريان را پوشش مي‌دادند، توافق كند. به اين ترتيب همه بهره بردارها به روشي كاملا سازگار اندازه‌گيري خود را انجام دادند و مقايسات احتمالي بين بهره بردارها ساده‌تر شد. بالاخره (در ژانويه ١٩٩٦) يك برنامه كاري سطح بالا و هدف مند، با شركت گروه هاي كاري متعدد و منابع مشاوره خارجي، به نتيجه رسيده و مجموعه‌اي منظم از شاخص هاي قابل مقايسه و مميزي شده را منتشر كرد. كتابچه‌هاي فعلي مشتريان مسكوني و تجاري به صورت جداگانه، مقياسهاي “سخت افزاري“ را در حوزه‌هاي زير پوشش مي‌دهند:

  • تهيه و تداركات خدمات

  • خطاهاي گزارش شده توسط مشتريان

  • جبران خطا

  • رسيدگي به شكايات

  • صحت صورت حساب

اين موارد به زودي با مقياس هاي “نرم افزاري“ مرتبط بر اساس بررسي نظرات مشتريان تكميل شده و در ادامه مقياسهاي جديد كه جنبه‌هاي جديد خدمات را پوشش مي‌دهند، در صورت لزوم به آنها اضافه مي‌گردد.

نتايج اين كار وارد چرخه‌هاي استاندارد اروپايي شده كه انتظار مي‌رود به دليل اينكه در نوع خود بي‌نظير بوده و براي اولين بار عرضه شده‌اند، اثر قابل توجهي داشته باشند.

وضعيت اقدامات اوليه در اين رابطه جالب است. آفتل تأكيد كرده است مي‌خواهد بخش صنعتي، مالك اين فرايند باشد كه در اين صورت توسط آفتل مديريت خواهد شد. همچنين كاملا روشن شده است كه مشاركت، اختياري نيست و هر بهره بردار داراي پروانه كه از اين قوانين پيروي نكند، با برخورد از طرف آفتل رو به رو خواهد شد. با اين حال در مواقعي كه سرعت پيشرفت كند باشد، مداخله آفتل باعث سرعت بخشيدن به كار مي‌شود. در اينجا به سازمانهاي تنظيم مقرراتي كه در حال انجام مقدمات اين امور هستند، توصيه مي‌شود كه از ابتدا اجبار لازم را در اين رابطه به بهره بردارها اعمال كنند.

٢.٤. تغييرات در كيفيت ارائه خدمات شركت BT

از زمان شروع خصوصي‌سازي، بيشتر مقياس هاي عمومي كيفيت ارائه خدمات BT بهبود يافته است. نتايج كيفيت ارائه خدمات BT براي حوزه‌هاي جغرافيايي مختلف منتشر نشده (احتمالا به دلايل تجاري خاص) ولي براي آفتل در دسترس است.

جان هارپر (مدير بازنشسته BT) توجه عموم را به سمت پيشرفت هاي دراز مدت در زمينه كارايي شبكه BT جلب كرده است. در ٢٥ سال گذشته، خطاهاي تماس ناشي از مشكل شبكه به طرز قابل ملاحظه‌اي كاهش يافته، به گونه‌اي كه تقريبا قابل چشم‌پوشي است. اين پيشرفت تقريبا به طور كامل مديون حذف تجهيزات سوييچينگ استراجر از شبكه است كه قبل از آزادسازي نيز در حال انجام بود. مدرن سازي شبكه در هر سياستي، امري ضروري است.

همچنين مواقعي نيز بوده است كه بعضي جنبه‌هاي خدمات بدتر شده است: تلفن هاي عمومي و تداخل منطقه‌اي مهم ترين مثال هاي آن هستند. هر دوي اين موارد كاملا مرتبط با وضعيت اقتصادي نيروهاي ستادي هستند.

به طور خلاصه، موارد مؤثر در پيشرفت كيفيت به شرح زير است:

  • برنامه مداوم نو‌سازي شبكه شركت BT (كه به شدت به هدف كاهش هزينه‌ها دنبال مي‌شود)

  • فرهنگ متغير شركت BT كه به دلايل تجاري، رضايت مشتري را هدف قرار داده است (و توسط بررسي و نظرخواهي منظم از رضايت مشتري پشتيباني مي‌شود).

  • عدم رضايت عمومي هنگام افت كيفيت و فشار ناشي از افكار عمومي

  • تمايل به اجتناب از پرداخت خسارت

موارد مؤثر در جهت عكس عبارتند از:

  • وضعيت جوي نامناسب غيرمنتظره

  • كمبود نيروي كار يا سازماندهي ضعيف به دليل ريزش سريع نيروها (نتيجه غير مستقيم فشارهاي كارايي از طريق كنترل قيمت)

  • روحيه ضعيف بين كارمندان باقيمانده

٥. تغيير اولويت ها

اولويت هاي مصرف كنندگان براي معيارهاي كيفيت ارائه خدمات در طول زمان تغيير مي‌كند. جنبه‌هاي “پايه‌“ مانند برقراري تماس، اهميت خود را از دست داده و در انظار عموم با جنبه‌هاي جديد از قبيل توانايي كنترل و شناسايي خط تماس گيرنده جايگزين مي‌شوند. با اين حال، براي اينكه جنبه‌هاي پايه‌ همچنان خارج از توجه بمانند، بايد آنها را در حد عالي نگه داشت. بنابراين نظارت بر آنها نمي‌تواند متوقف شود؛ در عين اينكه توزيع گسترده نتايج ممكن است تضمين نشود.

اين روش نوعي سلسله مراتب نيازهاست كه در آن پس از برآورده شدن نيازهاي سطح پايين‌تر، تمايل شديدي در جهت نيازهاي سطح بالاتر ايجاد مي‌شود. معمولا با توسعه شبكه، جنبه‌هاي مختلف خدمات اهميت اساسي پيدا مي‌كنند. در يك كشور در حال توسعه با فهرست انتظار طولاني، سال هاي انتظار براي دريافت خط تلفن ممكن است اصلي‌ترين مسأله باشد. با گسترش شبكه، سهولت برقراري تماسهاي موفق، اهميت مي‌يابد. هنگامي كه شبكه كاملا توسعه يافت، خدمات پشتيباني از قبيل صورت حساب، بيشتر توجهات را به خود جلب مي‌كنند. به صورت موازي، معيارهاي اوليه هنوز مورد توجه هستند ولي نحوه معياربندي آنها ممكن است تصحيح شود. براي مثال، تهيه و تدارك خدمات ممكن است به جاي سالانه، روزانه اندازه‌گيري شود و يا به تدريج در صورت تقاضاي كاربر.

مثال قبل بيان گر تحول ديگري از معيارهاي “سخت“ به “نرم“ (رضايت) در طول زمان است. مي‌توانيم موقعيت را به صورت يك انتقال توجه از معيارهاي عيني خدماتي (مانند درصد تماس هاي موفق و كامل) به سمت معيارهاي ضمني خدمات انساني (مثلا درصد مشتريان راضي از رفتار بهره بردار) خلاصه كنيم.

پرسش هاي مقايسات بين المللي روي معيارهاي عيني تمركز يافته (و هنوز پيشرفت سريعي نداشته است). رسيدن به حد مقايسات بين المللي بر اساس معيارهاي ضمني ممكن است عاقلانه نباشد. رضايت حتي با فرهنگ يكسان و نه فرهنگ هاي متفاوت، امري كاملا نسبي است .

پرسش نامه‌اي براي مقايسه بين كشورها طراحي شده كه ممكن است در حل اين مشكلات مفيد باشد.

٦. آسيب‌پذيري در رقابت جنبه‌هاي مختلف خدمات

در زير فهرستي از جنبه‌هاي مختلف خدمات مخابرات كه مشتريان خانگي را تحت تأثير قرار مي‌دهد، آمده است. توجه داشته باشيد كه اين فهرست فراتر از آنچه معمولا به عنوان كيفيت ارائه خدمات شناخته مي‌شود است. در اين حالت همه چيز ممكن است به طرز تلقي مشتري مربوط شود؛ فرد عادي لزوما تفاوت‌ها و امتيازاتي را كه يك متخصص مخابرات مشاهده مي‌كند، درك نخواهد كرد.

(علامات [3]N ،[4]S ،[5]C ذيلا توضيح داده شده‌اند).

دسترسي

  • در دسترس بودن فيزيكي اتصال شبكه در خانه (N)

  • قابل حصول بودن اتصال شبكه در منزل از نظر مالي (شارژهاي اوليه و بعدي) (C)

  • در دسترس بودن تلفن جايگزين براي كساني كه در خانه تلفن ندارند

  • در دسترس بودن و قابل خريد بودن لوازم تلفن قابل اطمينان و مناسب (*) (S)

تماسها

  • توانايي فيزيكي براي ارسال و دريافت تماس (بيشتر مربوط به افراد با ناتوانيهاي جسمي مي‌شود)

  • قابل خريد بودن سطح اوليه كاربري

هزينه

  • قيمت اصلي مجموعه كامل تلفن (C)

  • مشخص بودن قيمت هاي جزئي در صورت حساب كلي (C)

  • كنترل روي ميزان استفاده از تلفن/ سطح صورت حساب صادر شده (C) (S)

كيفيت

  • تماس هاي موفق (عدم بروز مشكل در برقراري تماس يا كيفيت مكالمه) (S) (C) (N)

  • سازوكار دريافت و پرداخت صورت حساب به صورت قابل قبول (صحت، درك، گزينه‌هاي مناسب پرداخت) (S) (C)

  • تلفن هاي عمومي (نصب در مكانهاي ضروري، سادگي و سهولت استفاده)

  • پاسخ گويي تامين كننده (به خطاها، درخواستهاي خدمات، خدمات بهره بردار، شكايات، ارجاع مخصوص براي مكالمه كنندگان غير انگليسي زبان)

  • تماس هاي ناخواسته (تماسهاي فروش، مزاحمت تلفني، خطا در شماره گيري) (*)

  • كتاب هاي راهنماي تلفن (صحت، سهولت استفاده، كنترل روي اعلان شماره خود) (C) (S)

انتخاب

  • پيشنهادهاي بهتر از طرف تامين كننده اصلي (خدمات شبكه ديجيتال و ...) (N)

  • پيشنهادهاي از ساير تامين كنندگان (راه دور، تلفن همراه و ...) (*)

  • آگاهي و علاقه به انتخاب (سردرگمي، هزينه‌هاي انتقال، ...) (*)

  • اثرات جانبي رقابت (پيشنهادات خاص، رويكردهاي فروش، عمليات جاده‌اي) (*)

حقوق

  • موارد ذكر شده در قرارداد، روند مشاجرات و جبران خسارت

  • ارائه ديدگاه ها

  • كنترل روي اثرات محيطي

  • تساوي حقوق

موارد موجود در فهرست بالا به صورت زير دسته بندي شده‌اند:

N- آيا توسط شبكه تعيين مي‌شوند؟

C- آيا توسط يك واحد مركزي خاص در مخابرات تهيه مي‌شوند؟

S- آيا يك استاندارد واحد براي همه، از نظر اقتصادي به نفع مخابرات است؟

*- اين مورد توسط بهره بردار اصلي مخابرات تحت تأثير قرار نمي‌گيرد.

براي مثال، در دسترس بودن فيزيكي اتصال شبكه و درصد بالاي تماس هاي موفق، توسط شبكه تعيين مي‌شود. در حالي كه پاسخگويي تأمين كننده به خطاها و تهيه كتب راهنما اين طور نيستند. همچنين سازوكارهاي صدور و پرداخت صورت حساب توسط واحد مركزي خاصي از مخابرات ارائه مي‌شوند در حالي كه تميز كردن تلفنهاي عمومي چنين نيست.

اهميت اين تفاوتها در پايداري و حدود تغييرات در سطوح خدمات است:

  • زماني كه سرمايه‌گذاري در يك شبكه نو‌سازي شده انجام شد و خدمات پيشرفته و بهبود يافته‌اي توسط آن فراهم شد، حتي اگر نيروي انساني نگهداري كننده قطع شده و سرمايه‌گذاري ديگري انجام نشود، اين پيشرفت براي سال‌ها باقي خواهد ماند. سطوح خدمات غير مرتبط با شبكه در صورتي كه نگهداري آنها در اولويت نباشد، مي‌توانند به سرعت تنزل كنند. (اين مسأله در انگلستان مشاهده شده است- مثال آن خدمات تلفن عمومي BT در ١٩٨٧ و زمان پاسخگويي به پرسش از راهنماي تلفن در ١٩٩٢)

  • در صورتي كه توسعه و بهبودي براي خدمات يك مشتري (كه به صورت مركزي فراهم شده است)، رخ دهد؛ همه مشتريان از آن بهره‌مند خواهند شد. (به عنوان مثالي ديگر، در انگلستان، صورت حساب هاي شركت BT براي همه مشتريان تغيير يافت زيرا صورت حسابهاي دقيق و جزء بندي شده شركت مركوري، رقابت سختي را در اين زمينه ايجاد كرده بود). خدماتي كه به صورت گسترده مورد استفاده مشتريان قرار مي‌گيرند، مي‌توانند به راحتي براي گروه هاي مشتريان متفاوت در سطوح متفاوتي فراهم شوند. با اينكه اين خصوصيت به خودي خود خوب و درست است و مي‌تواند براي نيازهاي متفاوتي به كار برده شود، درعين حال خطرناك نيز هست زيرا اجازه تبعيض قائل شدن به نفع مشترياني كه در رقابت آسيب‌پذير هستند عليه كساني كه مشتريان امن تلقي مي‌شوند را مي‌دهد. به عنوان نوعي دسته بندي سطح بالا، مشتريان خانگي بيشتر احتمال دارد در گروه دوم باشند.

  •

    لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 30 مهرماه 1384

12:26 AM

October 22, 2005

دندان هاي آبي براي يك هدست

امروزه تعداد روشهاي اتصال بدون سيم نسبت به راه هاي قديمي اتصال كابلي افزايش يافته است Fi. 802.11b,802.11a,Wi-GPRS,IRDAودندان آبي تنها برخي از روش هاي متداول جهت برقراري ارتباط بدون سيم ميان وسا يل گوناگون‌ اند.

در اين نوشتار قصد داريم ضمن توضيح تفاوتهاي ميان روش هاي ارتباطي بدون سيم خوانندگان گرامي را با كارايي هاي فناوري دندان آبي بيشتر آشنا نموده و كمك كنيم تا بهترين انتخاب را از ميان هدست هاي موجود دندان آبي براي تلفن همراه خود برگزينيد .

* دندان آبي (bluetooth )چيست؟

دندان آبي نوع خيلي ساده‌اي از شبكۀ بدون سيم است كه‌مي تواند ارتباط حداكثر 8 دستگاه مختلف (مجهز به اين سامانه) را دريك شبكۀ محدود برقرار نمايد .در عمل فضاي كوچكي را‌مي توان بوسيلۀ اين دستگاه ها پوشش داد چرا كه اساساً اين سامانه جهت مصارف و كاربرد شبكه هاي شخصي خصوصي طراحي واجرا شده است. محدوديت برد اين سامانه به كاربر كمك‌مي كند تا تنها در محدودۀ فضاي خانه ويا دفتر كار خود از اين روش (به شكل مطمئن وايمن ) استفاده نموده وامواج مربوطه فراتر ازآن ارسال نگردند.

كسي هم خواهان شنيده شدن ويا سوء استفاده ديگران از شبكۀ خصوصي ارتباطي خود نيست .

سامانه ي دندان آبي علاوه بر آنچه اغلب تصور‌مي شود قادر است گسترۀ وسيعي از تجهيزات كاربردي را به هم متصل نمايد.،

چنانچه علاوه بر رايانه هاي شخصي حتي گوشي هايي (هدفون ها) كه جهت شنيدن موسيقي و....به كار‌مي روند از اين طريق

مي توانند بدون نياز به سيم به رايانۀ شخصي، دستگاه پخش موزيك قابل حمل، تلفن همراه و يا رايانه هاي جيبي كاربران متصل شوند

در مورد تلفن ها، در صورتي كه تلفن همراه به اين سامانه مجهز باشد مي توان تلفن را در داخل جيب يا كيف خود رها كرده ولي در زماني كه يك تماس در يافت‌مي شود بدون نياز به دسترسي به گوشي تماس خود را پا سخ داد . حتي در مواردي كه تلفن مجهز به سامانۀ شماره گيري صوتي باشد مي توان بدون لمس وتماس با گوشي (شماره گيري اعداد بوسيلۀ صفحۀ ارقام گوشي) تماس برقرار كرد واين كار به همان راحتي پاسخ گويي به تماسهاي دريافتي‌ است.

همچنين محدوديت در برد امواج راديويي اين سامانه كه ناشي از توان كم فرستنده آن‌ است يكي از عوامل مؤثر در حفظ سلامتي

انسان در برابر قرار گيري در معرض تابش امواج الكترومغناطيسي به ويژه از ناحيه مغز‌است، به شكلي كه در برابر ديگر وسائل همچون تلفن هاي همراه خطر كمتري خواهد داشت .

*برد امواج دندان آبي:

اغلب دستگاه هاي دندان آبي در گروه 2 استاندارد مربوطه عمل‌مي كنند، تجهيزات اين گروه همگي با توان بسيار كم(برابر1 ميلي وات يا يك هزارم وات )عمل‌مي كنند، چنانچه بردي حداكثر در حدود 10 متر خواهند داشت.

اما به ياد داشته باشيم كه در سامانۀ دندان آ بي محدوديت برد نه تنها نقص به شمار‌نمي رود بلكه مزيت نيز محسوب مي گردد.

*گسترۀ تجهيزات قابل استفاده:

تعدادوسائلي كه در عمل با اين فناوري سازگار ند، محدود ولي رو به افزايش است كه در زير نمونه هايي از آن را نام‌مي بريم: دوربين هاي ديجيتالي، چاپگرها، پويش گرها، تلفن هاي همراه، رايانه هاي جيبي وقابل حمل، گوشي ها وميكروفون ها، گيرنده هاي مسير يابي(جي پي اس ) و برخي لوازم خانگي.

*Wi-Fi يا دندان آبي، كداميك بهتر است؟

Wi-Fi هم اكنون جايگزين اصلي براي شبكه هاي رايج وقديمي مبتني بر ارتباط كابلي است، همچنينWi-Fi برد وسيع تري را نسبت به دندان آبي فراهم آورده و از نرخ سرعت بيشتري براي تبادل اطلاعات پشتيباني‌مي نمايد، پس در برخي موارد ‌مي تواند از دندان آبي بهتر باشد . اما در حقيقت Wi-Fi و دندان آبي هر يك اهداف متفاوتي را دنبال‌مي كنند .

هدف استاندارد دندان آبي فراهم آ وردن بستر ارتباطي جهت تبادل داده وانتقال محدود آن ميان تجهيزات مختلف است . اماWi-Fiتوجه بيشتري را بر روي تبادل اطلاعات با سرعت بيشتر ميان رايانه و يك شبكۀ ارتباطي(مانند اينترنت) معطوف‌مي دارد.از نگاه ديگر توان كم تجهيزات دندان آبي (1ميلي وات ) باعث معرف كمترين ميزان انرژي (باتري)‌مي گردد . در حالي كه توان و برد بيشترسامانۀ Wi-Fi در مقابل باعث مصرف بيشتر انرژي باتري و كاهش عمر آن در مقابل تجهيزات دندان آبي‌مي گردد .

در نهايت در صورتي كه نيازمند ارتباط ساده وغير مهم با تجهيزات مختلف خود در محدودۀ محيط منزل يا دفتر كارتان هستيد دندان آبي راه حل مناسب اين امر و اگر نيازمند پوشش برد بيشتر و پهناي باند وسرعت بالاتري جهت تبادل داده ميان رايانه و شبكه محلي خود هستيد Wi-Fi انتخاب مناسب تري خواهد بود .

*انتخاب مناسب ترين هدست براي تلفن همراه:

صنايع مختلف ساخت گوشي و ميكروفون هاي بدون سيم امروزه از روش ها و فنون نويني جهت طراحي و ساخت هدست هاي دندان آبي بهره‌مي گيرند ،در حالي كه نسل هاي اوليه، چه از نظر ساختار وچه از نظر ظاهر وضعيت مناسبي نداشتند اما هدست هاي جديد عموماً بهبود بيشتري يافته اند .هدست هاي دندان آبي دگر گوني عظيمي را در قيمت ها پديد آورده اند به طوري كه حتي برخي از آنها به قيمت كمتر از 30 دلار تا 300 دلار ويا بيشتر قابل دسترسي هستند .

*چرا از هدست هاي دندان آبي استفاده مي‌كنيم؟

ابتدا بايد اين نكته را متذكر شويم كه استفاده از هر نوع هدست علاوه بر سهولت كار ومكالمه با تلفن همراه كمك‌مي كند تا كمتر در معرض تابش تشعشعات مضر تلفن همراه قرار گيريد، اگر چه ضرر اين تشعشعات براي مغز هنوز كاملاً قطعي نشده است .

در كشور ما و بسياري از كشورهاي ديگر اجازه نداريد در هنگام رانندگي گوشي را با دست خود نگاه داشته و مكالمه كنيد، از اين رو استفاده از هدست در اين شرايط مفيد خواهد بود .

هدست با سيم معمولي عموماً توقعات اغلب مردم را برآورده‌مي سازد اما مسئله اين است كه در اين مدل ها ،تلفن به شكلي از سيم هدست آويزان است ممكن است سيم آن دست وپا گير جلوه كند . اما هنگامي كه از فناوري دندان آبي استفاده‌مي كنيد ،‌مي توانيد گوشي خود را داخل كيف، داشبورد ماشين ويا جيب خود قرار داده و همچنان تماس خود را حفظ وبه آن پاسخ دهيد .ولي به ياد داشته باشيد كه زياد‌نمي توانيد از دور وبر تلفن خود دور شويد، براي مثال ماشين خود را پارك كرده و(در حالي كه گوشي خودرا داخل ماشين به جا‌مي گذاريد )به سوپر ماركت رفته وخريد نماييد ، در چنين حالتي فاصلۀ هدست و گوشي تلفن تان زياد‌مي شود ودر نتيجه قادر به در يافت ارتباط نخواهيد بود.

هدست دندان آبي اين امكان را‌مي دهد تا علاوه بر تلفن با وسائل ديگري مانند رايانه ها نيز ارتباط برقرار‌مي كنيد، براي مثال اگر از رايانه تان براي يك كنفرانس تلفني استفاده‌مي كنيد،‌مي توانيد از هدست خود براي مكالمه بهره مند شويد .همچنين اگر از چندين گوشي تلفن مختلف مجهز به فناوري دندان آبي استفاده‌مي نماييد ،هدست ‌مي تواند براحتي با تمامي آنها ارتباط برقرار كند ، اين ويژگي روند ساخت وطراحي هدست مخصوص براي هر مدل گوشي تلفن را دچار تغيير وتحول اساسي نموده است ، در نتيجه ناسازگاري هاي متداول ناشي از نوع و مدل گوشي ها وسازندگان مختلف از ميان رفته است .

*چالش در طراحي:

شايد نتوانيم از نظر طراحي و ساختار، مقايسۀ مناسبي ميان هدست هاي معمولي (با سيم) و هدست هاي دندان آبي (بدون سيم) به عمل آوريم زيرا تفاوتهايي ناشي از ساختار در اين گونه تجهيزات به چشم‌مي خورند ، اما در كل‌مي با يست توجه ويژه‌اي را به وزن اين هدست ها مبذول داشت زيرا سبكي و ظرافت بخشي از ويژگي هاي بر جستۀ هدست ها هستند . توجه داشته باشيد كه هدست دندان آبي هرگز‌نمي تواند به كوچكي و سبكي هدست معمولي (با سيم) باشد چرا كه هدست هاي دندان آبي شامل

باتري وتجهيزات الكترونيكي اضافي ديگري نيز هستند . اين وزن وحجم اضافي زماني مشكل آفرين‌مي شود كه قرار است برروي گوش ويا سرو صورت قرار گيرد .چنانچه امروزه تمركز همۀ سازندگان برروي عرضۀ هدست هايي با طراحي ظريف و كوچك است.*مشكلات رايج با هدست هاي دندان آبي:در حالت آرماني يك هدست دندان آبي‌مي بايست طوري باشد كه در هر زمان بتوان به راحتي و به سرعت آن را برروي گوش (يا محل مورد نظر) خود نصب نموده و به تماس هاي رسيده پاسخ داد و حتي يك تماس خروجي بر قرار نمود . هدست هاي دندان آبي داراي منبع تغذيۀ باتري هستند كه در هر حال يك محدوديت زماني را تحميل‌مي نمايند .(بعضاً 10 الي 12 ساعت مكالمه و25تا200 ساعت در حالت آماده باش ) . در حالت آرماني ميبايست زماني كه مكالمه‌اي نداريد ، سامانۀ ذخيرۀ خودكار انرژي باطري فعال شده و دستگاه را به حالت نيمه خاموش در آورد و هنگام تماس آن را دوباره فعال سازد ، بدين روش طول عمر باتري تا حد چشم گيري افزايش خواهد يافت

*برد هدست:

در حالت نظري تمام تجهيزات دندان آبي گروه2 استاندارد ، براي بردي در حدود 10 متر طراحي شده اند ،اما اين مقدار برد ‌مي تواند تحت شرايط مختلف، متغير باشد .اگر هدست وتلفن بدون وجود مانع ميان آن دو و در ديد مستقيم يكديگر باشند، به همان مقدار 10 متر ويا حتي بيشتر برد مفيد داريم ، اما اگر ميان تلفن و هدست آن ، موانعي مانند ديوار
و.... وجود داشته باشد ، بايد افت زياد برد و محدوديت در فاصله را در نظر داشت .بهتر است در عمل جهت بدست آوردن ميزان برد مفيد در هر محيطي ، گوشي و هدست خود را در حالت هاي مختلف آزمايش كنيد.
*عوامل كليدي در مقايسۀ هدست ها:
1. هزينه:يكي از عوامل مهم و اصلي در مقايسۀ مدل هاي گوناگون قيمت آنها است، ا ما به ياد داشته باشيد كه گران بودن برخي از مدل ها لزوماً بدون دليل نخواهد بود و حتماً مزايايي نسبت به مدل هاي ارزان خواهند داشت .

2.ظاهر شكيل:سرعت وسهولت نصب برروي گوش وراحتي استفاده از كليدهاي كنترل تعبيه شده برروي دستگاه ، همچنين راحتي قرار گيري برروي گوشي در دراز مدت (مكالمات طولاني ) وسهولت استفادۀ همزمان با عينك وبا استفادۀ آسان برروي هريك از دو گوش چپ يا راست به همراه سبكي وزن آن مواردي است كه در اين زمينه بايد مورد توجه قرار گيرند

3.سهولت كاربرد :لازم است بررسي شود كه:

آيا استفاده از كليدهاي تعبيه شده براحتي ممكن است؟

آيا تنظيم سطح صداي گوشي به آساني ميسر است؟

آيا قادريد به سرعت هدست را روشن و خاموش نماييد؟

و آيا خدمات پس از فروش مطمئني براي شما فراهم آ مده است؟

4.برخي ويژگي هاي ديگر كه بهتر است پيش از خريد مورد بررسي قرار گيرندعبارت اند از:

طول عمر باتري در حالت مكلالمه وآماده باش چه مقدار است؟

آيا در هنگامي كه عمر باطري (شارژ) رو به پايان است (قبل از اتمام كامل آن) متوجه اين موضوع خواهيد شد يا خير؟

باتري از چه نوعي است وآيا قابليت تعويض دارد؟

باطري چگونه شارژ‌مي شود و اين عمل چه مدت به طول‌مي انجامد؟

آ يا در هنگام اتمام عمل شارژ مجدد باتري ، متوجه اين امر خواهيد شد يا خير؟

وآيا هدست فوق در مدار داخلي خود مجهز به سامانۀ كاهندۀ صداهاي مزاحم است يا خير؟

و در نهايت كيفيت صداي دستگاه (ارسالي ودر يافتي) مطلوب است يا خير؟

*خلاصه:

رابط هاي دندان آبي كاربرد هاي مفيد و سهولت استفاده را به ارمغان‌ مي‌آورند، اگر چه هزينه اين امر نيز كم نيست. هدست دندان آبي خوب، تنظيم و كاربرد ساده‌اي خواهد داشت ، بطوري كه زندگي را سهولت و آسايش بيشتري‌مي بخشد . در پايان توصيه‌مي گردد از اطلاعات ارائه شده در بالا جهت بررسي وانتخاب دقيق تر هد ست دندان آبي مناسب قبل از اقدام به خريد استفاده نماييد .

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 30 مهرماه 1384

09:14 PM

October 22, 2005

FreeBSD انتخابي ديگر

مهيار داعي‌الحق
ماهنامه شبکه - آبان ۱۳۸۳ شماره 48

اشاره :
يكي از نگارش‌هاي سيستم‌عامل قديمي يونيكس كه همانند سلف خود در دانشگاه متولد شد،FreeBSD مي‌باشد. اين سيستم‌عامل كه در سال 1992 زاده شد، دگرگوني‌هاي بسياري را پشت سرگذاشته و همواره تكامل يافته است تا آن جا كه سايت قدرتمند ياهو، اين سيستم‌عامل را به عنوان سيستم‌عامل سرورهاي خود انتخاب كرده است. در اين نوشتار نگاهي به FreeBSD داريم.

معرفي
FreeBSD يك سيستم‌عامل قدرتمند و مشابه يونيكس است كه در سال 1992 براساس پروژه‌اي قديمي به نامBSD و توسط يك تيم نرم‌افزاري در دانشگاه بركلي كاليفرنيا (به نام‌هاي جردن كي هوبارد، گريمس، ويليامز) و با نام اوليه 386BSD Patchkit ابداع شد. سپس اين تيم با افزودن بسياري از قابليت‌ها و برطرف نمودن مشكلات اين سيستم‌عامل، نسخه‌اي جديد از آن را به نام 386BSD 0.5 طراحي كردند و در نهايت در سال 1993 شخصي به نام ديويد گريمن در والنات كريك كاليفرنيا يك سيستم‌عامل جديد به نام FreeBSD 1.0 را براساس نسخه قديمي‌اش يعني Patchkit و با همكاري سازنده اصلي آن يعني هوبارد ساخت و روانه بازار كرد. پس از آن و در سال‌هاي 1994 به بعد، نسخه‌هاي كامل‌تري از آن و تحت عنوان ويرايش‌هاي 4 و 5 توسط والنات كريك ارايه گرديد. هدف از ساخت اين سيستم‌عامل طبق گفته‌هاي جردن هوبارد، ارايه يك نرم‌افزار كامل همه منظوره و مستقل است. درضمن سورس‌كد موجود در آن طوري در اختيار كاربر قرار مي‌گيرد كه وي بتواند به راحت‌ترين و بهترين شكل از آن استفاده كند. به همين دليل اين سيستم‌عامل آزادي بيشتري را به كاربران و توسعه‌دهندگان سيستم‌عامل مي‌دهد و در اين راه نه‌تنها به ليسانس GPL كه مخصوص توسعه‌دهندگان اپن‌سورس است اكتفا نمي‌كند بلكه مجوز آزادتري براي استفاده از سورس برنامه به‌نام FreeBSD License را به علاقمندان خود اعطا مي‌نمايد. در اين ميان والنات كريك اعلام مي‌كند FreeBSD سيستم‌عاملي بسيار قدرتمند و در واقع بهترين انتخاب براي سرورهاي بزرگ محلي و يا اينترنتي محسوب مي‌شود. از بين كمپاني‌هاي سرشناس دنيا، ياهو يكي از اولين‌هايي است كه با مبنا قرار دادن FreeBSD به عنوان سيستم‌عامل سرورهاي اصلي خود، براين گفته والنات، صحه مي‌گذارد. اين سايت روزانه بيش از نيم ميليارد صفحه وب را در سراسر جهان براي كاربران خود ارسال مي‌كند كه نشان از قدرت و سرعت سيستم‌هاي مورد استفاده‌اش دارد. همچنين سرويس پست‌الكترونيك رايگان شركتي مثل مايكروسافت يعني هات‌ميل كه خود از سازندگان سيستم‌عامل‌هاي سرور است، براي تحت پوشش قرار دادن بيش از 30 ميليون كاربر در سراسر جهان، تركيبي از ويندوز، سولاريس و FreeBSD را مورد استفاده قرار مي‌دهد. طبق آزمايش‌هايي كه والنات كريك از سيستم‌عامل خود به عمل آورده، اين سيستم‌عامل موفق به انتقال دو ترابايت اطلاعات در اينترنت طي 24 ساعت شده است كه يك ركورد در نوع خود محسوب مي‌شود.

مقايسه‌
سيستم‌عاملFreeBSD از جهات بسياري با رقباي خود از دنياي لينوكس و ويندوز قابل مقايسه است. كارايي، امنيت، قابليت اطمينان و ... از مهمترين عوامل اين مقايسه محسوب مي شود.

1- قابليت اطمينان‌

تيم اصلي سازنده FreeBSD در يك كنفرانس خبري
(نفر دوم از سمت چپ جردن هوبارد است)

FreeBSD در اين زمينه بسيار خوب عمل مي‌كند. استفاده بسياري از سايت‌ها و مراكز كامپيوتري مربوط به مؤسسات بزرگ و مشهور، خود گوياي اين واقعيت است كه اين سيستم‌عامل از قابليت اطمينان زيادي به‌خصوص در اجراي فرآيندهاي مربوط به پايگاه داده‌ها برخوردار است. در همين حال لينوكس هم از ديرباز به دليل پايداري و عملكرد خوب در اين زمينه زبانزد متخصصان بوده است. اما در مقام مقايسه و براي كاربردهاي حجيم و بزرگ سيستم ورودي و خروجي ديسك (FreeBSD (Disk I/O بهتر عمل مي‌كند. زيرا در لينوكس به دليل اين‌كه به صورت پيش‌فرض به طور غيرهمزمان (non syncronous) كار مي‌كند، احتمال بروز اشكال در فايل‌سيستم در زمان قطع يا نوسانات برق يا خاموش شدن اتفاقي، افزايش مي‌يابد. در مورد ويندوز 2000 كه قبلاً به دليل ناپايداري بيشتر و به‌خصوص به دليل نمايش صفحه آبي مرگبار در هنگام بروز اشكال شهرت خاصي پيدا كرده بود، اكنون بايد گفت كه با به صحنه آمدن ويندوز 2003 تا حد زيادي اين مشكل رفع شده است، اما باز هم اين سيستم‌عامل به دليل يك ايراد مادرزادي خود يعني استفاده زياد از منابع سيستم مثل حافظه و CPU، ممكن است هر از چند ماهي با مشكلي مواجه شود كه آسان‌ترين راه‌حل آن بوت مجدد سرور مي‌باشد.

2- كارايي
FreeBSD در زمينه كارايي، بسيار بي‌نقص عمل مي‌كند. عملكرد اين سيستم‌عامل در عرصه شبكه و توانايي در انتقال اطلاعات بي‌نظير است. به همين دليل برخي از بزرگ‌ترين و پرمراجعه‌ترين سايت‌هاي دنيا مثل yahoo ،Freesoftware ،Qwest ،Hotmail و ديگران از اين سيستم‌عامل بهره مي‌گيرند. سايت Freesoftware كه سايتي برمبناي انتقال با پروتكلFTP است، بيش از 2/1 ترابايت اطلاعات را در طي روز به سراسر دنيا ارسال مي‌كند. در مورد لينوكس بايد عنوان كرد كه اين سيستم‌عامل هم از سرعت پردازش و كارايي بالايي برخوردار است، اما در آزمايش‌هاي خود تحت يك محيط بزرگ شبكه‌اي پرترافيك در حدود 20 الي 30 درصد از رقيب خود يعني FreeBSD عقب مي‌ماند. البته سازندگان كرنل ادعا مي‌كنند كه اين مسأله با استفاده از نسخه 4/2 كرنل لينوكس كه داراي يك حافظه مجازي مشابه FreeBSD است حل مي‌شود. به هر حال از آن‌جايي كه هر دو اين سيستم‌عامل‌ها با سورس‌باز ارايه مي‌شوند، اين اميدواري وجود دارد كه از لحاظ سطح تكنولوژي به دليل الگوپذيري از يكديگر، هيچ‌گاه داراي اختلاف اساسي نخواهد بود.
در مورد ويندوز بايد گفت كه كارايي كم در محيط شبكه پرترافيك، هميشه از بزرگ‌ترين معضلات اين سيستم‌عامل بوده و هست. حتي با ارتقاي ويندوزNT به نسخه 2003 هم آن‌چنان تفاوت آشكاري در كارايي و سرعت سيستم به‌خصوص در زمينه‌ سرورهاي اينترنتي پركاربرد ايجاد نمي‌شود.

3- امنيت
در مقوله امنيت،FreeBSD هميشه به عنوان يكي از امن‌ترين سيستم‌ها مدنظر كارشناسان قرار داشته است. تمام ماژول‌ها و اجزاء آن بارها از جهت امنيت مورد آزمايش و بررسي قرار گرفته‌اند. اين سيستم‌عامل همچنين داراي سطوح مختلف امنيت در داخل كرنل است و به مدير سيستم اجازه مي‌دهد تا سطح دسترسي كاربران را، حتي براي توابع دروني آن كرنل مشخص كند. به علاوه اين‌كه FreeBSD داراي مكانيسم ديواره آتش، Packet Fillering و بسياري از ابزارهاي كشف و رديابي نفوذ است.
عليرغم اين‌كه لينوكس نيز همانند FreeBSD داراي ديواره آتش و ابزارهاي متعدد IDS است اما نحوه ارايه اين سيستم‌عامل به صورت سورس‌باز و اين‌كه در اختيار گروه‌هايي است كه بسياري از آن‌ها داراي دانش كافي در زمينه امنيت نمي‌باشند و همچنين تعداد زيادي شركت‌هاي توسعه‌دهنده لينوكس، به‌خصوص آن‌هايي كه به مقوله كارايي و كاربرد بيش از امنيت اهميت مي‌دهند (مثل ردهت) باعث شده تا اين سيستم‌عامل در رده‌بندي امنيتي، پايين‌تر از رقيب خود قرار گيرد.
در مورد ويندوز نيز از آن‌جا كه اين سيستم عامل داراي سورس‌باز نمي‌باشد، ضعف‌هاي دروني آن كمتر از سايرين به گوش مي‌رسد اما به هرحال اين ضعف‌ها از چشم متخصصان امنيت دور نمي‌ماند و هر از گاهي چند نمونه از اين موارد در قالب ويروس، كرم و حفره‌هاي امنيتي برملا مي‌شود به هر حال اين سيستم‌عامل براي استفاده در مكان‌هايي كه عامل امنيت ارزش زيادي دارد، انتخاب مناسبي محسوب نمي‌شود

4- فايل سيستم
FreeBSD از سيستم‌ فايلي Unix File System) UFS) كه مختص سيستم‌عامل يونيكس است استفاده مي‌كند.
اين سيستم، اندكي از سيستم مورد استفاده لينوكس يعني 2ext پيچيده‌تر و پيشرفته‌تر است و عمليات ناهمزمان خواندن و نوشتن ديسك (Asyscronous I/O) را بيشتر و بهتر انجام مي‌دهد. همچنين اين سيستم‌ فايلي از File Flag هم پشتيباني مي‌كند كه از نوشته شدن تراك‌هاي خراب بر روي ديسك جلوگيري مي‌كند. يا هر گونه تغييري را در محتويات يك فايل يا يك دايركتوري در تمام زمان عمر آن محدود مي كند، يا از حذف شدن يك فايل جلوگيري مي‌كند. اين قابليت‌ها زماني كه با توانايي‌هاي موجود در كرنل تلفيق مي‌شود، محيط كاملاً قابل كنترل و جالبي را پديد مي‌آورد.
فايل سيستم مورد استفاده لينوكس هم كارايي بسيارخوبي دارد اما نقطه ضعف آن، عدم پايداري كافي مي‌باشد. چه بسا بروز يك اشكال در زمان Mount بتواند قسمتي از يك فايل سيستم را دچار خرابي نمايد و باعث از دست رفتن اطلاعات آن قسمت شود.
در مورد ويندوز، آنچه كه از آن به نامFAT يا NTFS نام برده مي‌شود، براي موارد محدود مثل دسترسي چند كاربر به شبكه و هاردديسك، بسيار آسان و روان عمل مي‌كند اما زماني كه بحث شبكه‌هاي بزرگ به ميان مي‌آيد، مجالي براي رقابت با UFS يا ext2 پيدا نمي‌كند.

5- درايورها
FreeBSD سيستم‌عاملي است كه هم قابليت نصب درايورهاي با سورس بسته يا همان درايورهاي باينري و هم درايورهاي با سورس‌باز را دارا مي‌باشد. اما متأسفانه بسياري از سازندگان سخت‌افزار خصوصاً آن‌هايي كه سخت‌افزار ارزان و نه‌چندان مرغوب اما با توليد انبوه را فراهم مي‌كنند، هيچ تمايلي براي ارايه درايورهاي خود تحت سيستم‌عاملي به غير از ويندوز ندارند و اين يكي از بزرگ‌ترين نقاط قوت ويندوز در برابر ساير سيستم‌عامل‌ها به‌شمار مي‌رود. در مورد لينوكس هم وضعيت متفاوتي حاكم است. اين سيستم‌عامل درايورهاي با سورس‌باز را بسيار خوب شناسايي و نصب مي‌كند اما بسياري از توليدكنندگان سخت‌افزار حتي آن‌هايي كه درايورهاي غيرويندوزي را به بازار ارايه مي‌دهند علا‌قه چنداني براي توليد درايورهاي با سورس‌باز نشان نمي‌دهند.

6- نرم‌افزارهاي كاربردي
تعداد نرم‌افزارهاي كاربردي تحت FreeBSD روزبه‌روز در حال افزايش است اما هنوز هم به فراواني نرم‌افزارهاي تحت ويندوز نمي‌رسد. در عين‌حال اين سيستم‌عامل قادر است برنامه‌هايي را كه براي برخي يونيكس‌ها مثل SCO يا براي لينوكس كامپايل شده‌اند را اجرا نمايد. مشابه همين وضع براي لينوكس هم وجود دارد با اين تفاوت كه لينوكس قادر نيست برنامه‌هاي كامپايل شده براي يونيكس يا FreeBSD را اجرا نمايد. در مورد ويندوز، ناگفته پيداست كه اكثر برنامه‌هاي كاربردي اصولاً براي اجرا در اين سيستم‌عامل طراحي و ساخت شده‌اند و ويندوز از لحاظ تعدد اين نوع برنامه‌ها هيچ كمبودي ندارد و در اين زمينه تكتاز ميدان است.

7 - محيط توسعه

نماي از محيط KDE در FreeBSD

در زمينه برنامه‌نويسي، FreeBSD داراي يك محيط بسيارقوي و كامل براي زبان ++C مي‌باشد. همچنين ابزارهاي ديگري براي برنامه‌نويسي با جاوا، پرل و پايتون در اين سيستم وجود دارد. در لينوكس هم همين ابزارهاي برنامه‌نويسي وجود دارند اما گاهي اوقات ممكن است برنامه‌اي كه شما با يك لينوكس مثلاً RedHat كامپايل مي‌كنيد، در لينوكس ديگري مثل Slackware قابل اجرا نباشد. در ويندوز هم ابزارهاي برنامه‌نويسي خوب و متعددي براي توسعه نرم‌افزار وجود دارند اما هيچكدام از آن‌ها با خود سيستم‌عامل همراه نيستند و بايد به‌صورت جداگانه خريداري و نصب شوند.

8 - نرم‌افزارهاي رايگان
در حوزه سيستم‌عامل FreeBSD و لينوكس، هزاران برنامه كاربردي خوب و رايگان با سورس‌باز وجود دارند كه روز به روز هم در حال افزايش هستند. هزاران گيگابايت برنامه به عنوان نرم‌افزارهاي GNU ارايه شده‌اند كه به صورت مجاني قابل نصب و اجرا بر روي هر دو سيستم‌عامل مذكور مي‌باشند. به علاوه اين‌كه خود FreeBSD يك كتابخانه منحصربه‌فرد و مخصوص به نام FreeBSD Ports Collection دارد كه به نظر بسياري از متخصصان، بهترين منبع براي دسترسي به نرم‌افزارهاي سورس‌باز مي‌باشد. در مورد لينوكس تعداد محدودي برنامه تحت عنوان Shareware به صورت رايگان وجود دارد، اما اين برنامه‌ها با سورس‌كد عرضه نمي‌شوند و در نتيجه امكان مانور را از برنامه‌نويسان و طراحان سيستم در جهت عيب‌يابي و بهتر كردن اين برنامه‌ها، سلب مي‌كند. براي ويندوز نيز برنامه‌هاي رايگان بسياري وجود دارند.

9 - پشتيباني
بسياري از شركت‌ها و سايت‌هاي اينترنتي مثل BSDi.com كار پشتيباني از FreeBSD را انجام مي‌دهند. تعداد زيادي از اين سرويس‌هاي مجاني هم از طريق گروه‌هاي خبري و پست‌الكترونيكي مثل question@freebsd.org قابل دريافت مي‌باشند.
در مورد لينوكس هم، اوضاع پشتيباني از اين سيستم‌عامل، خوب به نظر مي‌رسد. تمام توليدكنندگان لينوكس مثل ردهت، مندريك و ديگران بازار رقابتي را در ارايه پشتيباني به مشتريان خود درست كرده‌اند. در مورد ويندوز هم اوضاع چندان بد به نظر نمي‌رسد. اما باز هم بسته بودن سورس‌كد در اين سيستم‌عامل باعث شده تا مقوله پشتيباني هم به صورت انحصاري و توسط سازنده‌اش يعني مايكروسافت و آن هم بيشتر از طريق تلفن و با تأخير زماني انجام شود.

10 - قيمت و هزينه
همان‌طور كه از نام FreeBSD برمي‌آيد، اين سيستم‌عامل كاملاً رايگان و از سايت freebsd.org قابل دريافت و نصب است. البته اگر بخواهيد هم مي‌توانيد با پرداخت تنها 40 دلار، يك بسته حاوي 4 سي‌دي اين سيستم‌عامل به علاوه چندين گيگابايت برنامه كاربردي را يك‌جا خريداري نماييد. در مورد لينوكس هم به غير از نسخه‌هاي Enterprise كه نسبتاً قيمت قابل توجهي دارند، بقيه محصولات متعلق به توزيع‌كننده‌هاي مختلف از قيمت بسيار مناسبي برخوردارند. اما ويندوز در اين مقايسه كمي گران به نظر مي‌رسد.

نتيجه‌گيري
با توجه به موارد ده‌گانه‌اي كه برشمرديم، درمي‌يابيم كه FreeBSD سيستم‌عاملي است كه مي‌تواند به عنوان سيستم‌عامل پايه سرورهاي قدرتمند و در شبكه‌هاي بزرگ مورد استفاده قرار گيرد. از اين نظر بد نيست كه آن را به عنوان انتخابي جديد، مورد بررسي بيشتري قرار دهيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
یکشنبه، 1 آبانماه 1384

11:19 PM

October 23, 2005

بررسي شاخص‌هاي جهاني فناوري ارتباطات و اطلاعات

دنيا هنوز براي كسب اجماع و توافق بر روي يك مجموعه شاخص‌هاي پوشش دهنده و عمومي دسترسي به جامعه‌ي اطلاعات، راهی طولاني پيش رو دارد. زيرا در جايي كه اطلاعات وجود دارد. منابع آن ها گاهي نامعتبر، مغشوش، ناقص، نابهنگام و يا غيرقابل مقايسه در سطح بين‌المللي هستند. ضمن اين كه، دست يابي به منابع آن ها نيز اغلب مشكل است. اين مشكل، به ويژه در كشورهاي در حال توسعه به صورت حاد وجود دارد. زيرا برخي از اين كشور‌ها فاقد دانش فني و يا منابع براي جمع‌آوري، تدوين و انتشار آمار وضعيت فناوري‌هاي ارتباطات و اطلاعات (آي،سي،تي) هستند.

اتحاديه‌ي بين‌المللي مخابرات (ITU) در تلاشي براي استاندارد كردن شاخص‌ها، يك مجموعه حداقلي از شاخص‌هاي دسترسي به جامعه اطلاعات (جدول شماره 1) را پيشنهاد داده كه كشورهاي عضو طبق آن آمارهاي مربوط را جمع‌آوري و ارايه نمايند. اين‌ها از بين طيف وسيعي از شاخص‌هاي اقتصادي به عنوان مرتبط ترين شاخص‌ها در طول زمان انتخاب شده و امكان الگوبرداري يك اقتصاد را از اقتصاد ديگر فراهم مي‌كند. اين شاخص‌ها را همچنين مي‌توان تجزيه كرد. براي مثال، شاخص‌ درصد خانوارهايي كه به اينترنت دسترسي دارند مي‌تواند به خانوارهايي كه به اينترنت پرسرعت دسترسي دارند تجزيه شود. اين به ويژه براي كشورهايي كه خواهان تصريح بيشتر و يا مقايسه خود با اقتصادهاي پيشرفته تر هستند، كاربرد دارد.

اين قابليت به خصوص براي شاخص‌هايي جالب است كه پيش پا افتاده و كم اهميت به نظر مي‌آيند، مانند: درصد خانوارهاي داراي راديو. در اين مورد، شاخص مي‌تواند به راديوهاي ديجيتالي يا راديوهاي با قابليت اينترنت تجزيه شود.

به علاوه، توصيه‌هاي زير براي بهبود بخشيدن به جمع‌آوري اطلاعات شاخص‌هاي خواسته شده و تقويت امكان مقايسه بين‌المللي آنها از سوي اتحاديه بين‌المللي مخابرات ارايه شده است:

مدل پيمايش هايي(survey) كه توسط «يورواستات» (Eurostat) طراحي شده براي جمع‌آوري اطلاعات راجع به كسب و كارها، افراد و خانوارهايي كه از فناوري‌هاي اطلاعات و ارتباطات استفاده مي‌كنند، مي‌تواند به كار گرفته شود. اين‌ها بايد براي افزايش امكان مقايسه بين‌المللي مورد استفاده قرار گيرند. در مواردي كه پيمايش‌هاي راجع به خانوار و كسب و كار توسط دفاتر آمار ملي1 انجام شده بايد سؤال‌هاي مربوط به دسترسي به آي، سي، تي نيز در آن گنجانده شوند.

ملت‌هاي توسعه يافته و آژانس‌هاي بين‌المللي بايد به ملل در حال توسعه براي تدوين شاخص‌هاي آي، سي، تي از طريق ارايه كمك‌هاي فني و منابع مادي ياري رسانند. كشورهاي در حال توسعه كه پيمايش‌هاي آي، سي، تي را انجام داده‌اند، مي‌توانند با انتقال روش‌ها و ساختار پرسش نامه‌ها به ديگر كشورها كمك كنند. كمك بين‌المللي نيز بايد فراهم شود تا ادارات آمار كشورهاي در حال توسعه بيشتر بتوانند از اطلاعات به صورت بر خط استفاده كنند. همچنين، منابع مادي بيشتري براي انجام پيمايش‌هاي آي، سي، تي در اختيار اين كشورها قرار داده شود.

آژانس‌هاي دولتي آي، سي، تي همچون سازمان مقررات گذار مخابرات بهترين و مطلوب ترين محل براي جمع‌آوري و انتشار آمارهاي ملي آي، سي، تي (مانند: تعداد مشتركان تلفن، تعداد مشتركان اينترنت، اينترنت پرسرعت بين‌المللي) هستند. سياست‌گذاران آي، سي، تي بايد براي حصول اطمينان از تهيه آمارهاي مبتني بر پيمايش همچون: درصد خانوارهايي بهره‌مند از آي، سي، تي يا درصد جمعيت استفاده كنند. همچنين، آمارهاي تهيه شده بايد در معرض ديد قرار داده شود و اين يك نياز است. كشورها، بايد وبگاه دائمي خود را كه در آن آمارهاي جامعه اطلاعات وجود دارند ايجاد و معرفي نمايند. يك نمونه عالي استراليا است كه دفتر آمار آن صفحاتي از وب را به تعدادي شاخص‌هاي دسته‌بندي شده آي، سي، تي اختصاص داده است. نمونه ديگر، خدمات آماري مصر است كه تركيبي از آمارهاي مربوط به دسترسي فرد، خانوار، كسب و كار، آموزش و پرورش را در يك صفحه وب قرار داده است. در سطح بين‌المللي، يك درگاه(پورتال) شاخص‌هاي جامعه اطلاعاتي مي‌توان ايجاد کرد كه به پايگاه اطلاعاتي ملي متصل باشد و الگوي پرسش نامه و روش‌ كسب اطلاعات را نيز ارايه دهد.جدول (1) شاخص‌هاي كليدي سنجش دسترسي به جامعه اطلاعات

رديف | شاخص | دسته‌بندي | تعريف
1 | درصد خانوارهاي داراي برق | خدمت عام | درصد خانوارهاي بهره‌مند از برق
2 | درصد خانوارهاي داراي راديو | خدمت عام | درصد خانوارهايي كه داراي گيرنده راديو هستند. اين شامل راديوهايي كه داراي قابليت ديگر وسايل همچون سيستم‌هاي استريو، ساعت‌هاي زنگ دار، همچنين گوشي همراه و راديو خودرو نيز مي‌شود.
3 | درصد خانوارهاي داراي تلويزيون | خدمت عام | درصد خانوارهايي كه داراي گيرنده تلويزيون هستند. اين شامل تلويزيون‌هاي رنگي و سياه و سفيد مي‌شود.
4 | درصد خانوارهاي داراي تلفن | خدمت عام | درصد خانوارهايي كه داراي تلفن هستند. اين شاخص بايد به زير شاخص‌هايي چون: خانوارهاي داراي تلفن ثابت و همراه و فقط تلفن حمايت، فقط تلفن همراه تجزيه شود. در مورد خانوارهاي داراي تلفن همراه چنانچه مشخص شود كه امكان دسترسي به اينترنت نيز دارد مفيد خواهد بود.
5 | درصد خانوارهاي داراي رایانه | خدمت عام | درصد خانوارهايي كه داراي رایانه شخصي هستند و در منزل از آن استفاده مي‌كنند.
6 | درصد خانوارهايي كه به اينترنت دسترسي دارند. | خدمت عام | درصد خانوارهايي كه دسترسي به اينترنت در خانه برايشان فراهم است. تجزيه اين شاخص بر اساس نوع دسترسي (مانند: شماره‌گيري، پرسرعت) مفيد است.
7 | پوشش جمعيتي تلفن سيار به درصد | دسترسي عام2 | درصد جمعيتي كه توسط تلفن همراه با سيگنال پوشش داده شده است نبايد با درصد پوشش زميني تلفن همراه و يا درصد جمعيت مشترك تلفن همراه اشتباه شود. دقت شود اين شاخص به طور نظري قابليت استفاده از تلفن همراه را بررسي مي‌كند، اگر كسي گوشي داشته باشد و مشترك شود اين قابليت را به فعليت رسانده است.
8 | درصد جمعيتي كه از رایانه استفاده مي‌كنند. | دسترسي عام | درصد جمعيتي كه از رایانه شخصي در مكان‌هاي مختلف (براي مثال، خانه، مدرسه، محل كار) استفاده مي‌كنند.
9 | درصد جمعيتي كه به اينترنت دسترسي دارند. | دسترسي عام | درصد جمعيتي كه از دسترسي آسان به اينترنت (براي مثال، در خانه، محل كار، مدرسه و يا با طي مسافت نه چندان طولاني به يك مركز خدمات ارتباطي) برخوردارند با كاربران اينترنت يكسان نيست، زيرا فردي ممكن است دسترسي به اينترنت داشته باشد اما از آن استفاده نكند.
10 | درصد كسب و كارهاي داراي رایانه | كسب و كار | درصد كسب و كارهايي كه در محل كار داراي رایانه هستند بايد برحسب اندازه كسب و كار (كوچك، بزرگ و غيره) تجزيه شود.
11 | درصد كسب و كارهايي كه به اينترنت دسترسي دارند. | كسب و كار | درصد كسب و كارهايي كه در محل كار داراي رایانه هستند و به اينترنت دسترسي دارند بايد برحسب اندازه كسب و كار (كوچك، بزرگ و غيره) تجزيه شود.
12 | درصد كسب و كارهاي داراي وبگاه | كسب و كار | درصد كسب و كارهايي كه در محل كار داراي رایانه هستند و وبگاه دارند بايد برحسب اندازه كسب و كار (كوچك، بزرگ و غيره) تجزيه شود.
13 | نسبت شماردانش‌آموزان به شماررایانه | آموزش و پرورش | نسبت تعداد دانش‌آموزان به رایانه، بايد به مدارس سطوح ابتدايي، راهنمايي و متوسطه تجزيه شود. اين شاخص شامل رایانه هايي است كه براي دانش‌آموزان وجود دارد نه آنهايي كه در امور اداري به كار گرفته مي‌شود. ضمن اينكه اين شاخص ارتباطي به اينكه رایانه ها به اينترنت متصل هستند يا خير، ندارد.

14 | درصد مدارسي كه به اينترنت دسترسي دارند | آموزش و پرورش | درصد مدارسي كه به اينترنت دسترسي دارند بايد به مدارس سطوح ابتدايي، راهنمايي و متوسطه تجزيه شود. اين شاخص همچنين مي‌تواند براساس نوع اتصال به اينترنت بيشتر تجزيه شود.
15 | درصد ادارات دولتي كه به اينترنت دسترسي دارند | دولت | درصد ادارات دولتي برخوردار از دسترسي به اينترنت، اين شاخص بايد برحسب تعداد كاركنان و نيز نوع ادارات دولتي (مانند، مركزي، محلي) تجزيه شود.
16 | درصد ادارات دولتي داراي وبگاه | دولت | درصد ادارات دولتي داراي وبگاه، اين شاخص بايدبرحسب تعداد كاركنان همچنين نوع ادارات دولتي تجزيه شود. اين شاخص مي‌تواند براساس اين كه گاه خدمات تعاملي نيز ارايه مي‌دهد يا خير، بيشتر تجزيه شود.
17 | درصد كاركنان دولت كه به اينترنت دسترسي دارند | دولت | اين شاخص تنها كاركناني را شامل مي‌شود كه در ادارات به اينترنت دسترسي دارند.
18 | مشتركان تلفن ثابت به ازاي هر 100 نفر جمعيت | شاخص دسترسي ديجيتالي3 (DAI) | مشتركان تلفن ثابت دلالت بر افرادي دارد كه براي خط تلفن سوئيچ عمومي شبكه تلفن متصل به تجهيزات مشتري (مانند، گوشي تلفن يا دور نگار) هزينه مي‌پردازند و يك درگاهه(پورت) اختصاصي در مركز تلفن دارند. به ازاي 100 نفر جمعيت نيز از طريق تقسيم تعداد مشتركان تلفن ثابت به جمعيت، ضربدر 100 محاسبه مي‌شود.
19 | مشتركان تلفن همراه به ازاي هر 100 نفر جمعيت |  | مشتركان تلفن همراه دلالت بر كاربران تلفن‌هاي همراه قابل حمل دارد كه از طريق مشترك شدن با يك خدمات تلفن همراه عمومي خودکار كه از فناوري سلولي استفاده مي‌كند امكان دسترسي به شبكه تلفن عمومي برايشان فراهم شده است. به ازاي 100 نفر جمعيت نيز از طريق تقسيم تعداد مشتركان تلفن سيار به جمعيت، ضربدر 100 محاسبه مي‌شود.
20 | نرخ دسترسي به اينترنت (20 ساعت در ماه) به عنوان درصدي از درآمد سرانه | شاخص دسترسي ديجيتالي | هزينه‌هاي مربوط به 20 ساعت استفاده از اينترنت شماره‌گيري در ماه، اگر نرخ هاي باند پهن ارزان تر باشد بايد جايگزين آن شود. داده بايد شامل تمامي هزينه‌هاي مربوط به استفاده از تلفن باشد اما نه هزينه اجاره خط، ضمناً درآمد سرانه نيز با تقسيم بر 12 به صورت ماهانه محاسبه مي‌شود.
21 | پهناي باند اينترنت بين‌المللي به جمعيت | شاخص دسترسي ديجيتالي | پهناي باند اينترنت بين‌المللي دلالت بر سرعت گردش داده از كشور به نقاط اتصال اينترنت بين‌المللي دارد و بيت (bit) در ثانيه اندازه‌گيري مي‌شود. بيت به ازاي جمعيت با تقسيم پهناي باند اينترنت بين‌المللي به جمعيت حاصل مي‌شود.
22 | مشتركان باند پهن به ازاي 100 نفر جمعيت | شاخص دسترسي ديجيتالي | مشتركان باند پهن دلالت بر مجموع DSL ، مودم كابلي و ديگر مشتركان باند پهن كه سرعت آن بيش از 128 كيلوبيت بر ثانيه در لااقل يك مسير است. به ازاي 100 نفر جمعيت با تقسيم كل مشتركان باند پهن به جمعيت، ضربدر 100 حاصل مي‌شود.
23 | كاربران اينترنت به ازاي 100 نفر جمعيت | شاخص دسترسي ديجيتالي | كاربران اينترنت كساني هستند كه به طور منظم از اينترنت استفاده مي‌كنند (ترجيحاً لااقل يك بار در ماه)، بهترين روش تعيين كاربران اينترنت، انجام پيمايش است. از طريق پيمايش مي‌توان اطلاعاتي درباره سن، تناوب استفاده و نوع دسترسي فراهم كرد. به ازاي 100 نفر جمعيت با تقسيم تعداد كاربران اينترنت به جمعيت، ضربدر 100 حاصل مي‌شود.

انجام عمليات آماري خوب بسيار مهم است؛ همچنين شفافيت، وضوح، بهنگام و مرتبط بودن بسيار اساسي است. برخي كشورها آمار جزيي مربوط به مناطق را تهيه مي‌كنند، اما آمار كل كشور را تهيه نمي‌نمايند. گاهي نيز تاريخ‌هايي كه اطلاعات به آن تعلق دارد مشخص و شفاف نيست.

واژه‌هايي همچون دسترسي، مشترك و كاربر اغلب از روي سهل انگاري يا عدم درك صحيح مفهوم، يكسان و هم معنا به كار برده مي‌شود؛ درحالي كه، هر يك معناي خاص خود را دارد. همچنين، برخي اطلاعات نمي‌تواند از طريق سوابق اداري جمع‌آوري شود و انجام پيمايش اجتناب ناپذير است. اين موضوع، بويژه در مورد كاربران اينترنت مصداق دارد. كاربران اينترنت بايد از طريق پيمايش و برپايه‌اي منظم و لااقل به صورت سالانه انجام پذيرد.

مشاركت بين سازمان‌هاي بين‌المللي، مؤسسات آماري ملي و سياست‌گذاران آي، سي، تي در بسياري از كشورها مي‌تواند در نيل به هدف تهيه يك مجموعه از شاخص‌هاي كليدي دسترسي به جامعة اطلاعاتي مؤثر باشد. دومين مرحله اجلاس سران دربارة جامعه اطلاعات (WSIS) كه قرار است در تونس برگزار شود، محمل مناسبي بويژه براي همين مطلب است4. اگر اين موضوع محقق شود، دنيا گام بسيار بزرگي به سوي سنجش بهتر و درك جامعه اطلاعاتي برداشته است.

منبع و پي‌نوشت‌ها

World Telecommunication Development Report 2003, International Telecommunication Union, First Printing December 2003, PP 127-132.

1- National statistical offices, (NSO).

2- اغلب، واژه‌هاي دسترسي و خدمت عام به يك مفهوم و به جاي يكديگر استفاده كرده‌اند، زيرا معنايشان مشابه يكديگر است. با اين وجود، اين دو مفهوم با هم متفاوت هستند. خدمت عام به معناي آن است كه خدمت براي هر خانوار ارايه شده است و به طور سنتي به ازاي هر خانوار يك خط تلفن ثابت وجود دارد. اما دسترسي عام به معناي آن است كه خدمت نه در خانه بلكه در بيرون و با طي مسافتي قابل قبول در دسترس است. مثلاً، هر كس در جامعه مي‌تواند به يك تلفن عمومي دسترسي داشته باشد البته ضرورتاً نه در خانه خود. دسترسي عام مي‌تواند از طريق تلفن عمومي، مراكز تلفن شبيه به مغازه‌ها، مراكز چند منظوره و حتي توسط كارفرماياني انجام شود كه خدمت تلفن همراه را به ازاي برخواني صورت گرفته عرضه مي‌كنند.

خدمت و دسترسي عام يك مفهوم چندگانه است. اين مفهوم ابعاد مختلفي را در بر مي‌گيرد كه عبارت است از:

1- قابلیت دستیابی (Availability) ، كيفيت و چگونگي ارايه خدمت در محل كار و زندگي افراد يكسان است و بستگي به موقعيت و مكان جغرافيايي ندارد و همه جا موجود است. بويژه اينكه، شهري و روستايي بودن تأثيري بر توانايي فرد در دسترسي به خدمات ارتباطي ندارد.

2- استطاعت پرداخت (Affordability) ، اكثريت جامعه قادر به پرداخت هزينه اين خدمات هستند و افراد به دليل برخورداري از سطح پائين درآمدي از اين خدمات بي‌بهره نخواهند شد. اختلاف در نرخ خدمات به دليل مكان، موقعيت آب و هوايي و جغرافيايي اثر چنداني بر دسترسي و استفاده افراد از خدمت عام آي، سي، تي ندارد. اين بُعد خدمت عام چالش‌هاي خاصي را در ارتباط با گسترش شبكه ايجاد مي‌كند.

3- قابليت دسترسي (Accessibility) ، حتي افراد ناتوان نيز مي‌توانند از اين خدمات بهره‌مند شوند و سطح ناتواني جسمي و ذهني آنها بر دسترسي به خدمت عام آي، سي، تي، تأثير عمده نخواهد داشت.

3- در گزارش توسعه مخابرات سال 2003 كه در پائيز آن سال در آستانه برگزاري «اجلاس جهاني سران دربارة جامعه اطلاعاتي» از سوي ITU در ژنو انتشار يافت، مدل «شاخص دسترسي ديجيتالي» مطرح و ارايه شد. در اين مدل چگونگي و ميزان كاربرد اينترنت در كشورهاي توسعه يافته و در حال توسعه مشخص شده است

در اين گزارش، برمبناي مدل «شاخص دسترسي ديجيتالي» كه از طرف ITU ارايه شد، توانايي كلي شهروندان هر كشور براي دسترسي به اطلاعات و كاربرد فناوري‌هاي اطلاعات و ارتباطات بررسي و سنجش شده است. اين بررسي و سنجش براساس 8 متغير در 5 زمينه انجام شده، زمينه‌هاي 5 گانه در اين بررسي، شامل: آمادگي زيرساخت، امكان دسترسي، سطح آموزش، كيفيت خدمات آي، سي، تي و كاربرد اينترنت (ميزان استفاده از اينترنت) بوده‌اند و 8 متغير در برگيرنده‌ي: 1- ضريب نفوذ تلفن ثابت 2- ضريب نفوذ تلفن همراه، 3- نرخ استفاده از اينترنت به عنوان درصدي از سرانه درآمد (به ساعت استفاده در ماه)، 4- نرخ باسوادي بزرگسالان، 5- نرخ تركيب شده‌ي ثبت‌نام دانش‌آموزان در مقاطع ابتدايي، راهنمايي و دبيرستان، 6- پهناي باند اينترنت بين‌المللي، 7- ضريب نفوذ مشتركان باند پهن، 8- ضريب نفوذ مشتركان اينترنت.

نتايج به دست آمده از اين بررسي و سنجش، كه در شاخص دسترسي ديجيتالي سال 2002 انعكاس يافته، ميزان توانايي كشورها براي به كارگيري آي، سي، تي و قوت‌ها و ضعف‌هاي آن‌ها مشخص شده است.

در اين بررسي و سنجش كه 178 كشور جهان را دربرگرفته، براي نخستين بار، سلسله مراتب توسعه دسترسي و ميزان كاربرد آي، سي، تي در سراسر دنيا تعيين شده است. براساس مدل شاخص دسترسي ديجيتالي، در رأس 10 كشور بسيار پيشرفته دنيا، غير از كشور كانادا، كه در رديف دهم سلسله مراتب توسعه دسترسي به اطلاعات ديجيتال قرار گرفته، 9 كشور قبل از آن، از كشورهاي آسيايي و اروپايي هستند. در اين ميان بيشترين پيشرفت‌ها در زمينه‌ي توسعه اطلاعات ديجيتال، در فاصله سال‌هاي 1998 تا 2003 متعلق به چهار «ببر آسيايي» شامل: كرة جنوبي، هنگ كنگ، تايوان و سنگاپور است. با توجه به آن، چنين به نظر مي‌رسد كه زبان انگليسي، ديگر عامل تعيين‌كننده‌ي پيشبرد و گسترش آي، سي، تي، به شمار نمي‌رود و توليد و توزيع بيش از پيش محتويات ديجيتال به زبان‌هاي ديگر، وابستگي كاربران اينترنت به اين زبان را كاهش داده است. در مدل شاخص دسترسي ديجيتالي، كشورهاي جهان از لحاظ دسترسي به آي، سي، تي، به چهار دسته طبقه‌بندي شده‌اند. برمبناي اين طبقه‌بندي، كشورهاي داراي «دسترسي بسيار بالا»، «دسترسي بالا»، «دسترسي متوسط» و «دسترسي پائين» از هم متمايز شده‌اند. در گزارش ITU در معرفي اين مدل تأكيد شده است كه اين مدل يك مرجع اساسي براي دولت‌ها، مؤسسات بين‌المللي توسعه، سازمان‌هاي غيردولتي و بخش خصوصي، براي ارزيابي شرايط ملي كشورها در استفاده از آي، سي، تي، محسوب مي‌شود.

ايران در اين بررسي و سنجش با كسب امتياز 43 درصد و رتبه 77 از بين 178 كشور جهان در ردة دسترسي متوسط قرار گرفته است.

4- منظور، بازنگري و روزآمدسازي شاخص‌هاي كليدي دسترسي به جامعة اطلاعات است.

حمد حافظي

معاون دفتر توسعه مخابرات

وزارت ارتباطات و فناوري اطلاعات

E-Mail: AHMAD_HAFEZI@yahoo.com

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

پنجشنبه، 5 آبانماه 1384

07:14 PM

October 27, 2005

فروشگاه‌ آينده و نگراني درباره سوء استفاده از RFID

بابک احترامي
ماهنامه شبکه - مهر ۱۳۸۳ شماره 47

اشاره :
احتمالاً در مورد RFID چيزهايي شنيده‌ايد (اگر نه، مي‌توانيد به مقاله <هويت ديجيتالي، خطري براي حريم خصوصي> در شماره 34 ماهنامه شبكه مراجعه كنيد). به طور خلاصه، RFID يك تراشه بسيار ريز الكترونيكي است كه با فركانس راديويي كار مي‌كند. يكي از موارد استفاده RFID در ساخت <برچسب قيمت> اجناسي است كه در فروشگاه‌ها عرضه مي‌شوند. برچسب‌هاي RFID مي‌توانند انقلابي را در امر خريد و فروش به‌پا كنند. ولي اين تكنولوژي به همان اندازه كه طرفدار پيدا كرده, نگراني هم به دنبال داشته است. طرفداران خوشحالند از اين كه سير حركت اجناس از كارخانه تا فروشگاه را مي‌توانند تحت نظر داشته باشند و نگراني از اين جهت كه مي‌توان اين نظارت را تا داخل خانه‌هاي مردم هم ادامه داد. ببينيم ديگران چه نظري در اين مورد دارند.

خيابان آكسفورد در لندن شلوغ‌ترين مركز خريد اروپاست و براي فروشندگان اين خيابان، مراقبت و ردگيري هزاران كالايي كه از درهاي فروشگاه‌ها وارد يا خارج مي‌شوند دردسر ديرينه‌اي است. فناوري باركد كه در دهه 70 ميلادي عرضه شد، پرهزينه و از بسياري جهات نامناسب است. به همين دليل خيلي از فروشندگان به فناوري جديدي روي آورده‌اند كه برچسب RFID ناميده مي‌شود.

برچسب‌هاي RFID تراشه‌اي دارند در حدود 2 كيلوبايت و متصل به يك آنتن كه امكان خواندن محتواي حافظه را از فاصله نسبتاً دور ميسر مي‌سازد. و بهتر اين‌كه، لازم نيست بين اسكنر و برچسب، ديد مستقيم وجود داشته باشد. تراشه انرژي خود را از اسكنر تأمين مي‌كند، يعني به باتري هم نيازي نيست. همه اين‌ها به گرفتن دزدان فروشگاهي، تشخيص اصل يا تقلبي بودن كالا، و سرعت دادن به عمليات صورت‌برداري از انبار كمك مي‌كنند.
راينبرگ شهر كوچكي در شمال دوسلدورف آلمان است كه اولين نمونه‌هاي عملي برچسب‌هاي RFID طي يك پروژه در يكي از سوپرماركت‌هاي زنجيره‌اي معروف دنيا متعلق به شركت METRO Group (نشاني www.metrogroup.de ‌) مورد آزمايش قرار گرفته است. نام اين پروژه <فروشگاه آينده> (نشاني www.futurestore.org ) گذاشته شده و شركت‌هاي بزرگ SAP، اينتل و IBM در آن مشاركت دارند.

در اين شهر، آلبرت يكي از قفسه‌هاي هوشمند مغازه‌اش را نشان مي‌دهد و مي‌گويد: <قفسه هوشمند به يك دستگاه reader مجهز است كه به ما مي‌فهماند روي هر قفسه از هر جنس چه تعداد باقي مانده است. روي اجناس باركد چسبيده، ولي اگر باركد را بلند كنيد، آينده را خواهيد ديد. يك تراشه كوچك. با استفاده از اين تراشه، اطلاعات خيلي زيادي درباره هر كالا (نه مشتري) عايد ما مي‌شود. مثلاً مي‌توانيم بفهميم آيا مشتري بعد از مدتي جنس را سرجايش گذاشته يا نه. يا چقدر طول كشيده آن را برگرداند. اين اطلاعات براي بازاريابي بسيار ارزشمند هستند>.

در حال حاضر فقط سه كارخانه توليد كالاهاي مصرفي در اين آزمايش مشاركت دارند، ولي Metro پيوسته بر اطلاعات به دست آمده از قفسه‌هاي هوشمند داخل فروشگاه‌ها نظارت مي‌كند تا پرفروش‌ترين اجناس را بشناسد. تمام اجناسي كه چنين برچسبي خورده باشند از طريق يك نمايشگر كنترلي قابل مشاهده هستند و مي‌توان رد حركت آن‌ها را در فروشگاه گرفت. اگر لازم باشد مي‌توان قفسه‌ها را حتي قبل از خريد جنس توسط مشتري و خروج از فروشگاه دوباره پر كرد.

اگر اين فناوري به مرحله تكامل برسد، ديگر انتظار كشيدن پشت آن صف‌هاي طولاني براي رسيدن به صندوق و پرداخت پول بي‌معني خواهد بود. كافي است سبد خريد را به جلو هل بدهيد و رد شويد. ولي سؤال اين است كه بعد از خريد و ترك فروشگاه، تكليف اين تراشه‌ها چيست؟ آيا كسي هست كه خارج از فروشگاه هم دوست داشته باشد با خريدهايي كه در دست دارد كنترل شود؟ اتفاقاً در نزديكي راينبرگ، شهر سرسبز بيلفيلد قرار دارد. جايي كه گروهي از روشنفكران و طراحان فني‌گرد هم جمع شده‌اند تا در مورد گسترش و نوع و استفاده از برچسب‌هاي راديويي تصميم‌گيري كنند (نشاني www.foebud.org )

رِنا‌ تانجنس مؤسس FoeBud مي‌گويد: <حرف ما اين است كه فناوري برچسب‌گذاري به شيوه RFID قابليت پنهان‌كاري دارد و بنابراين ممكن است از آن سوءاستفاده شود. يعني بدون اين كه خودتان خبر داشته باشيد، ردتان را مي‌گيرند، بي‌خبر از همه جا محل زندگي شما را پيدا مي‌كنند، و بدون اين كه خودتان بخواهيد مي‌فهمند شما به چه چيزهايي علاقه داريد و چه چيزهايي مي‌خريد.>

اين گروه در صدد ساخت نوعي RFID detector است تا اگر كسي رد برچسب‌هاي RFID همراه شما را گرفت، بلافاصله هشدار بدهد. گروه صد در صد مطمئن است كه شركت‌هاي بزرگ حتماً از اين اطلاعات به نفع خود استفاده خواهند كرد تا بفهمند هر كس به چه كالايي علاقه دارد و مردم در فروشگاه‌ها به دنبال چه مي‌گردند. همين Metro يك نوع كارت جايزه درست كرده كه در نگاه عادي شبيه به بقيه كارت‌هايي است كه خيلي از فروشگاه‌ها براي جذب مشتري به دست مردم مي‌دهند. ولي اگر با اشعه ايكس به اين كارت نگاه كنيد، تراشه‌اي كه داخل آن تعبيه شده است را خواهيد ديد. گروه FoeBud مي‌گويد: مردم روحشان هم از اين قضيه خبر ندارد، ولي Metro ادعا مي‌كند كه در اين مورد قبلاً اطلاع‌رساني كرده است: <ما هيچ وقت از اين كارت براي ثبت اطلاعات مشتري استفاده نمي‌كنيم. تنها چيزي در مورد مشتري كه داخل تراشه هوشمند ثبت شده يك شماره سريال است كه آن هم روي خود كارت چاپ شده است. ولي حتي همين شماره هم هيچ جا داخل فروشگاه ثبت نشده است>. اينها را آلبرت مدير فروشگاه مي‌گويد.

ولي موضوع به قدري نزد عموم جدي شد (نشاني http://www.spychips.com/metro/scandalpayback.html )
كه Metro اخيراً مجبور شده به جاي تراشه، از نوارهاي مغناطيسي معمولي استفاده كند، و تازه داخل فروشگاه هم دستگاهي نصب كرده كه هر كس بخواهد مي‌تواند اطلاعات داخل اجناسي كه خريده است را به وسيله آن پاك كند. ولي فروشگاه‌هاي ديگري از جمله Prada در نيويورك مدت‌هاست در كارت‌هاي جايزه‌اي كه به مشتري مي‌دهد از تراشه‌هاي هوشمند استفاده مي‌كند و در آلمان هم مي‌گويند ممكن است اين فناوري را با كارت‌هاي شناسايي الكترونيك تلفيق كنند.

رِنا تانجنس مي‌گويد: <كابوسي كه من از الان دارم مي‌بينم اين است كه شما در يك همايش قانوني شركت كرده‌ايد و داريد مطالبات قانوني خود را بيان مي‌كنيد، و از آن طرف يك اسكنر بزرگ بالاي سر شما كار گذاشته‌اند كه همه را شناسايي مي‌كند>.

به هر ترتيب، تكنولوژي RFID قطعاً فوايد بسياري خواهد داشت، اما بايد ديد تا چه اندازه در امور عادي مردم ايجاد مزاحمت خواهد كرد. اگر قرار باشد اين برچسب‌ها اعتراض عموم را در پي داشته باشد، بهتر است <فروشگاه سنتي> داشته باشيم تا <فروشگاه آينده>.

برگي از وب

1- اگر به علم و دانش علاقه داريد، لزوماً نبايد دانشمند باشيد، مخصوصاً وقتي اين همه سايت علمي در اينترنت وجود دارد كه مباحث پيچيده علمي را به شكلي ساده و آموزشي براي شما تشريح مي‌كنند. DNA interactive (به‌نشاني www.dnai.org ) يكي از بهترين نمونه‌هاي اين سايت‌هاست. در اين سايت، مطالب بسياري به فرمت‌هاي گوناگون (نوشته، عكس، ويدئو و بازي) تركيب شده و به صورت تعاملي در خدمت بازديدكننده قرار مي‌گيرد كه واقعاً جاي تقدير دارد. همان طور كه از اسم اين سايت مي‌توان فهميد، مطالب آن كلاً در مورد DNA است و عناوين بالاي صفحه اصلي محتواي هر بخش را به روشني مشخص كرده‌اند. وقتي ماوس را روي يكي از اين عناوين نگه مي‌داريد، اطلاعات بسيار مفيدي به‌صورت خلاصه در مورد آن بخش نشان داده مي‌شود. روي هر كدام از اين عناوين هم اگر كليك كنيد، صفحات ديگري باز مي‌شوند كه ده‌ها ويدئو و بازي‌هاي آموزشي داخل آن‌ها طراحي شده است. اطلاعات علمي و سابقه ذهني شما در مورد اين موضوعات هر چقدر هم كه باشد، باز هم از اين تصاوير و صفحات نمايشي، مطالبي دستگيرتان خواهد شد كه در مطالعات‌تان به درد خواهند خورد.

2- اگر موضوعات علمي و جدي برايتان سنگين است، بد نيست بدانيد كه اينترنت هنوز هم براي تفريح و موضوعات غيرجدي رتبه اول را در ميان وسايل ارتباط جمعي دارد.
Morphases (به نشاني www.morphases.com/edit )
ساعت‌ها مرا سرگرم كرد، و طراحي آن واقعاً تحسين‌انگيز است. صفحه اول كه طي يك زمان كوتاه لود مي‌شود، ويرايشگر morphase را نشان مي‌دهد كه يك ابزار فلشي براي حركت دادن و انتخاب كردن اجزاي مختلف صورت انسان است. با كليك روي دكمه Random face چهره يك نفر به صورت تصادفي ظاهر مي‌شود كه از آنجا مي‌توانيد هنرنمايي خود را آغاز كنيد. دكمه‌هايي در سمت راست چهره تعبيه شده كه هر كدام متناظر با يكي از اجزاي صورت است (مثلاً دهان، بيني، گوش‌هاي چپ و راست و غيره). بعد از انتخاب يك يا چند عضو صورت، مي‌توانيد آن را بچرخانيد، جابه‌جا كنيد يا اندازه آن را تغيير دهيد. از قسمت Image Search مي‌توانيد چيزهاي ديگري چون ريش و سبيل و عينك را به چهره اضافه كنيد يا هر يك از اجزا فعلي را تغيير دهيد. براي اين منظور، ابتدا عضو مورد نظر را از صورت فرد انتخاب و سپس روي تصويري كه مي‌خواهيد جايگزين آن عضو شود كليك كنيد. اگر از چهره‌اي كه ساخته‌ايد خوشتان آمد، مي‌توانيد از قسمت Esend آن را براي دوستان خود email كنيد.
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
شنبه، 7 آبانماه 1384

02:06 PM

October 29, 2005

حفظ مشتری با استفاده از خدمات پست الکترونيک

نوشته: محمود بشاش

من با شرکت در سمينارها و گردهمايي ها فرصت اين را داشته‌ام كه با عده زیادی از صاحبان مشاغل كوچك صحبت كنم. پرسشي درباره‌ي اين شركت‌هاي كوچك همواره ذهن مرا به خود مشغول كرده است:” اين شركت‌ها چگونه با مشتريان و مراجعان خود ارتباط برقرار مي‌كنند؟“در بسياري موارد پاسخ به ”فرستادن كارت‌هاي تبريك تعطيلات رسمي سالیانه“ محدود مي‌شود.

با توجه به اين كه اين كارت تبريك‌ها جايگاه زماني مخصوص خود را دارند‏، به نظر نمي‌رسد شركت‌ها بتوانند با اتكا به آنها به موفقيت چنداني برسند. به هر حال موارد مشابه بسيارند اما اميدوارم شما به روش‌هاي ارتباطي خود با مشتري انديشيده باشيد. آيا به اندازه‌ي كافي در اين راه تلاش مي‌كنيد؟

توصيه‌ي من به صاحبان مشاغل اين است كه تعداد دفعاتي را كه مشتري در سال/فصل/ماه به آنها، توليدات و خدمات شان نيازمند است، تخمين بزنند و از اين زمان تقريبي به عنوان راهنمايي براي خدمت به مشتري استفاده كنند. اين عدد را به عنوان يك حداقل و مبنا در نظر بگيريد و از همين نقطه فعاليت خود را آغاز كنيد.

شركت شما مي‌تواند يك موسسه‌ي مشاوره‌ي بازاريابي، يك مركز نرم‌افزاري، موسسه‌اي غيرانتفاعي، يك مجتمع آموزشي، نمايندگي فروش اتومبيل، مغازه‌ گل فروشي، رستوران يا حتي يك گروه موسيقي باشد. در هر صورت موفقیت و سود بيشتر به ايجاد مشتريان وفادار(مراجعان، كاربران، خريدارن، مشتريان و اعضا) و ايجاد علاقه در آنها و فعاليت مستمر تجاری مربوط مي‌شود.
از آن‌جا كه فروش محصولات و ارايه‌ي خدمات به مشتريان فعلي شش تا دوازده برابر كم‌تر از دست‌ و پا كردن مشتريان جديد هزینه دارد، دانستن ارزش وفاداري مشتري و ارتباط تجاري مستمر، امري غير قابل انكار است.

بر اساس گزارش هاي موجود:

• بازگشت دوباره پنج درصدي مشتريان، 25 تا 100 درصد سود بيشتر ايجاد خواهد نمود.
• مشتريان دايمي به طور متوسط 67% بيش از مشتريان جديد، براي خدمات شما، پول خرج مي کنند.

همه‌ي راه‌ها به روش‌هاي برقراري ارتباط منتهي مي‌شود
در هر رابطه‌اي، روش‌هاي ارتباط اهميت بسزايي دارند. توصيه مي‌كنم روش شركت‌هاي كوچكي را كه در گذشته‌هاي دور به اهميت برقراري ارتباط مناسب و پويا با مشتريان خود پي بردند، الگوي خود قرار دهيد. آنها مشتريان خود را در طول زمان با آموزش و به خاطر سپردن علايق و حق انتخاب‌ فردي تغذيه مي‌كردند. آنها اين اطلاعات را به واسطه‌ي مشتري و در جريان همين ارتباط خصوصي دوطرفه به دست مي‌آوردند. به عبارت ديگر، شركت‌هاي مذكور مطابق برنامه‌اي منظم همواره با مشتريان خود در تماس بودند و سعي مي‌كردند همواره خود را در ذهن افراد زنده نگه دارند.
محاسبات آماري نشان مي‌دهد كه براي تبديل يك مراجعه کننده معمولي به يك مشتري، شركت‌ها دست كم به برقراري 6 يا 7 تماس نياز دارند. به ياد داشته باشيم كه اين تماس‌ها هم وقت‌گير و هم پرهزينه است. در اين مرحله است كه بازاريابي الكترونيكي به عنوان مهم‌ترين بخش فعاليت بازاريابي شركت‌ها وارد عمل مي‌شود.

پست الکترونيک، بازديد کنندگان را به مشتريان وفادار دائمي تبديل مي کند
بازاريابي الكترونيكي شما را قادر مي‌سازد تا به جاي آنكه منفعلانه در انتظار بازديد افراد از وب سايت، دفتر كار يا فروشگاه خود و يا تماس تلفني آنها باشيد، به شكلي فعال با آنها در ارتباط باشيد. با اين روش شما مي‌توانيد روابط فعلي خود را استحكام ببخشيد و ضمن ايجاد ارتباطات جديد، بازديدكنندگان تصادفي، خريداران و اعضا را به مشتريان و حاميان بلندمدت شركت خود تبديل كنيد.
اهميتي ندارد كه مشتريان و بازديدكنندگان چگونه اطلاعات شركت شما را مي‌يابند. ممكن است شما برای ورود به موتورهاي جستجو مبالغي را پرداخت كرده باشيد، يا حمايت از يک خبرنامه را به عهده گرفته باشيد، يک ليست خبري را اجاره کرده باشيد، تبليغات بنري، فلايرها يا حتي از كارت‌پستال استفاده کرده باشيد. در هر صورت بازاريابي الكترونيكي حرف اول را مي‌زند. اين روش امكان سرمايه‌گذاري شركت شما را در ديگر شيوه‌هاي پرهزينه و وقت‌گير بازاريابي فراهم كرده، روند بازگشت سرمايه را، به ازاي هر ريالي كه صرف جذب مشتري و ايجاد يک ارتباط تجاري سودآور مي کنيد، بهبود مي‌بخشد.

مطابق تحقيقات شرکت "DoubleClick" بازاريابي الكترونيكي موفق مي‌تواند مشتري را متقاعد و با اهداف شرکت همراه كند:
• اجراي مناسب و موفقيت‌آميز بازاريابي الكترونيكي مي‌تواند تاثيري مثبت بر ديد مشتري نسبت به شركت داشته باشد.
• 67% مصرف‌كنندگان آمريكايي به شركت‌هايي نظر مساعد دارند كه از بازاريابي الكترونيكي مجاز به شيوه‌اي مناسب بهره برده‌اند.
• 58% مصرف‌كنندگان اين نامه هاي الکترونيکي را گشوده‌اند و 53% آنها ادعا مي‌كنند كه نامه ‌هاي مذكور بر تصميم آنها در مورد خريد اجناس تاثير گذاشته است.

چرا بازاريابي الكترونيكي پاسخ مناسبي براي مشكلات است؟
بازاريابي الكترونيكي به دليل راحتي، در دسترس بودن، بي‌واسطه‌گي، قابليت پي‌گيري و تاثير گذاري آن يكي از ابزارهاي بازاريابي قدرتمند امروز است. در واقع با افزودن اين روش به برنامه‌ي كاري خود، در مقايسه با روش‌هاي سنتي(نامه مستقيم يا تبليغات چاپي) در زمان، هزينه و منابع صرفه‌جويي مي‌كنيد. هم‌چنين اطلاعات مورد نظر شما بسيار سريع منتقل شده، نتيجه‌ تبليغات خود را در سريع‌ترين زمان ممكن(در مقابل روزها و هفته‌ها) مشاهده مي‌كنيد.
اگر از بازاريابي الكترونيكي به عنوان ابزاري براي برقراري ارتباط با ليست مشتريان فعلي و تلاش در مداوم سازي آنها استفاده کنيد، بيشترين تاثير را خواهد داشت.

سعي كنيد اطلاعات بيشتري را به دفعات بيشتر، ارائه كنيد
بازاريابي الكترونيكي راهي آسان و در دسترس براي صرفه‌جويي در هزينه‌هاي بازاريابي است. در واقع اين روش با نسبت پاسخ 5 برابر نامه مستقيم و 25 برابر تبليغات بنري، موثرترين شيوه براي افزايش فروش، توليد ترافيك و ايجاد مشتريان دايمي است.
برخلاف نامه هاي معمولي، در اين شيوه هيچ هزينه‌اي صرف توليدات، مواد خام يا پست نمي‌شود. به عبارت ديگر با بازاريابي الكترونيكي شما مي‌توانيد به سادگي روابط جديدي را بر اساس ارزش هاي مشتريان خود پايه‌گذاري كنيد و مطمئن باشيد كه اين روابط، حامي و مکمل نام شركت و عامل متمايز كننده‌ي شما از شركت‌هاي رقيب خواهد بود.
روش‌هاي ارتباطي شما مي‌تواند شامل خبرنامه، تبليغات اختصاصي محصولات و خدمات، اطلاعيه‌ي فروش، معرفي خدمات جديد، دعوت‌نامه به مناسبت مراسم مختلف، كارت‌هاي تبريك و بسيار بيش‌تر از اينها باشد.

به مشتريان خود آموزش دهيد
اطلاعات و آموزش مشتريان شما را به عوامل با ارزشي تبديل مي‌كند، به اين معنا كه با ايجاد امكان تصميم‌گيري آگاهانه براي مشتري، احتمال تمایل او به خرید افزايش پيدا مي‌كند. چرا آنها را مجبور مي‌كنيم که براي كسب اطلاعات مورد نياز خود به جای دیگری مراجعه كنند؟ شما مي‌توانيد ضمن فراهم كردن داده‌هاي ضروري و سوق دادن افراد به وب‌ سايت خود براي استفاده از جزييات بيش‌تر يا خريد، آرام آرام افراد را به فرايند فروش هدايت كنيد.
یک خبرنامه الکترونیکی علاوه بر آنکه برای اهداف بلندمدت حفظ مشتری مفید است، می تواند در فروش هاي لحظه اي با دعوت به خريد مشتري، به اهداف کوتاه مدت شما نیز کمک کند.
در بيشتر موارد، يك مشتري آموزش ديده، توليدات و خدمات را به بهترين نحو استفاده مي‌‌كند. حال حدس بزنيد كه با ظهور يك محصول جديد، چه کسي اولين خريد را انجام خواهد داد؟
مطالعات حاكي از اين است كه هم گروه فروشندگان و هم خريداران به طور روز افزون بازاريابي الكترونيكي را ترجيح مي‌دهند. مطابق تحقيقات “DoubleClick”:
استفاده از نامه ه اي الکترونيک كه با اخذ رضايت مشتري فرستاده مي‌شوند، بسيار مورد توجه مشتريان است. 75% افراد از اين روش، 25% از روش‌پستي و 0% از روش بازاریابی تلفني استقبال كرده‌اند.

پرورش دادن روابط درازمدت و بادوام
فرستادن نامه الکترونيکي، راهي آسان و كم‌هزينه براي برقراري روابط سريع و دوام با مشتري است. مزاياي اين روش دور از تصور شما است. در واقع شما با ارايه‌ي اطلاعات و آموزش به مشتري اين ذهنيت را در او ايجاد مي‌كنيد كه فقط شما هستيد كه مي‌توانيد به درستي نيازهاي او را برآورده كنيد. و حتي از اين هم مهم‌تر اين‌كه ممكن است آنها شما را به عنوان يك صاحب‌ نظر و خبره در اين كار به شمار بياورند. با اين كار ضمن ايجاد اعتماد، درهاي روابط دوجانبه با مشتري گشود شده، آنها مسايل و مشكلات خود را با شما در ميان مي‌گذارند.
با اطلاعاتي كه از مشتريان خود به دست مي‌آوريد، به تامين نيازهاي جاري آنها قادر مي‌شويد، پيشنهادهاي فروش اختصاصي خود را تنظيم كرده، رقباي خود را پشت سر مي‌گذاريد. در اين فرايند به برخي فرصتهاي پنهان در حيطه‌ي فروش كه تاكنون به آن نپرداخته بوديد نيز واقف مي‌شويد.

نتايج را اندازه گيري و روش ها را بهبود ببخشيد
منافع به دست آمده از بيش‌تر روش‌هاي بازاريابي و تبليغاتي، به سختي قابل اندازه‌گيري است. حال آنكه در بازاريابي الكترونيكي شما به راحتي مي‌توانيد تعداد نامه ‌هاي ارسالي، گشوده‌شده، باز نشده، اشتراك و عدم اشتراك افراد و بالاخره تعدادكليك‌ها را برآورد كنيد.
همچنين در اين روش مي‌دانيد كه دقيقا چه كسي نامه الکترونيکي شما را گشوده، کدام لينک در نامه شما بيشتر کليک شده، بيشترين كليك را داشته‌اند و حتي اين كه چه كسي روي هر لينك كليك کرده نيز پي مي‌بريد. تمام اين اطلاعات ضروري شما را قادر مي‌سازد تا هرچه بيش‌تر مطالب هدفمندي را به افرادي كه احتمال پاسخگويي آنها وجود دارد بفرستيد و از اين طريق نتايج فروش خود را بهبود بخشيد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

جمعه، 13 آبانماه 1384

01:22 PM

November 04, 2005

راهنماي ابزار پيكربندي PPP در لينوكس

نوشته: ميثاق محمدي‌زاده
ناشر: ماهنامه شبکه - مهر 1383 شماره 47

اشاره :
براي اتصال به اينترنت بهترين ابزار در نظر كاربران خانگي، Dialup يا همان سيستم شماره‌گيري است. Dialup سرويسي ارايه مي‌كند كه با نصب و پيكربندي پروتكل‌هايي مانندSLIP و PPP خواهيد توانست از يك كامپيوتر راه‌دور به شبكه ايتنرنت متصل شويد. يكي از دلايل محبوبيت لينوكس، ارايه ابزارهاي متنوع و كاربردي براي هر بخش است. در اين مقاله در پي آنيم كه شما را با ابزارهاي ايجاد يك اتصال (connection) در لينوكس آشنا كنيم. به تناسب اين‌كه از محيط‌هاي گرافيكي لينوكس استفاده مي‌كنيد يا از خط فرمان (shell)، مقاله زير مي‌تواند برايتان مفيد باشد، چرا كه براي هر دو گروه راه‌حل‌هايي دارد. براي شروع، بهتر است آشنايي مختصري با پروتكلPPP داشته باشيم كه مبناي تمام سرويس‌هاي Dialup است.

PPP يا اتصال دو كامپيوتر از راه‌دور
Point to Point Protocol، جزء پروتكل‌هاي لايه شبكه مي‌باشد كه وظيفه ايجاد يك سرويس اتصال سريال به صورت ترمينالي يا نقطه به نقطه را بين دو كامپيوتر از راه دور فراهم مي‌آورد. PPP تشابهات بسياري با پروتكل
(SLIP (Serial line Internet protocol دارد و همان كار SLIP را انجام مي‌دهد با اين تفاوت كه PPP نسبت به SLIP بروزتر و جديدتر، پيكربندي آن آسان‌تر و از محبوبيت بيشتري برخوردار است. از طريق PPP مي‌توان يك كامپيوتر كاربر خانگي را از راه‌دور به يك شبكه از طريق خط تلفن، مودم و سرويس‌هاي ديجيتالي همانند DSL متصل كرد و از اين طريق امكان ورود به شبكه سراسري اينترنت را فراهم ‌آورد. از جمله وظايف PPP مديريت ارسال بسته‌هاي IP، سنكرون كردن ارتباط داده‌اي بين دو كامپيوتر، پيكربندي پيوند داده‌ها، تست كيفيت اتصال، شناسايي خطاها و ايجاد يك ارتباط با پروتكل‌هاي چندگانه شبكه است. سرويس گيرنده مي‌تواند با بهره‌گيري از PPP يك سرويس شماره‌گيري (Dialup) را بر روي سيستم خودش راه‌اندازي كند و از اين طريق با ارسال بسته‌هاي TCP/IP به سمت ماشين سرويس‌دهنده، به آساني و كمترين هزينه و از طريق يك مودم و خط تلفن به شبكه مقصد متصل شود. به همين دليلPPP در سيستم‌عامل‌هاي كامپيوترهاي شخصي براي ايجاد اتصال به اينترنت استفاده مي‌شود. لينوكس، ويندوز و بسياري ديگر از سيستم‌عامل‌ها ابزاري را فراهم مي‌آورند كه بتوان PPP را راه‌اندازي و پيكربندي نمود. لازم به ذكر است از ديگر توانايي‌هاي PPP ايجاد يك ارتباط چندگانه پروتكلي در سطح شبكه است. يعني علاوه بر پروتكل TCP/IP مي‌تواند از IPX ،Appletalk ،Decnet و پروتكل‌هاي ديگري نيز پشتيباني به‌عمل آورد. در سمت سرويس دهنده‌ها يا سرورها هم مي‌بايست PPP به كار گرفته شود و نرم‌افزار اين پروتكل به روي ماشين سرور شبكه اجرا شود. در لينوكس ابزاري ارايه شده است كه مي توانيد با استفاده از پيكربندي PPP يك حساب كاربري براي اتصال به اينترنت درست كنيد. RP3،kppp ،Linuxconf و WvDial معروف‌ترين و آسان‌ترين اين ابزارها هستند.
قبل از شروع آشنايي با اين ابزارها ذكر نكات زير ضروري به نظر مي‌رسد:

‌● كرنل لينوكس مي‌بايست از پروتكل PPP پشتيباني كند. از نسخه به بعد اين توانايي در هسته لينوكس فراهم شده است.
‌●‌ براي كار با ابزار پيكربندي PPP و ساخت يك Connection حتماً مي‌بايست در حساب ريشه (Root) لينوكس خود باشيد.
‌●‌ ابزار پيكربندي PPP نياز به شناسايي مودم دارد. لذا مي‌بايست از قبل مودم را به روي سيستم نصب كرده باشيد. مي‌توانيد در اين نشاني اطلاعاتي در مورد نصب انواع مودم به دست آوريد.

‌● در هنگام ايجاد يك اكانت، شما نيازمند اطلاعاتي از قبيل شماره تلفن شبكه (ISP) مقصد username ،password ، DNS Address ،IP Address و اطلاعات ديگري خواهيد بود. اين اطلاعات را عموماً مي‌توانيد از سرويس‌دهنده اينترنت مورد نظر خود دريافت كنيد.
● PPP براي خود استانداردهايي دارد كه مهمترين آنان DIP و pppd مي‌باشد. ‌pppd به عنوان مدير هدايت پروتكلIP در شبكه PPP استفاده مي‌شود. مي‌توانيد در خط فرمان Xterm با تايپ man pppd اطلاعات بيشتري كسب كنيد.
● RP3 ابزار مخصوص شركت RedHat است. Kppp ابزار محيط گرافيكي KDE است. Linuxconf در محيط گرافيكي Gnome براي مديريت و پيكربندي سيستم است و ابزار خط فرمان WVDial مخصوص shell مي‌باشد.

RP3 در Redhat

شكل 1

ساده‌ترين ابزار نصب و پيكربندي سرويس PPP در نسخه 6.2 به بعد توزيع ردهت گنجانده شده است و با نام RP3 يا PPP OE شناخته مي‌شود. اين ابزار مبتني بر رابط گرافيكي Gnome بوده و در شاخه زير مي‌توانيد آن را اجرا كنيد:
Gnome\programs\Internet\RH PPP Dialer
در خط فرمان shell هم مي‌توانيد با تايپ user/bin/RP3 برنامه را اجرا كنيد.
براي نصب، بايد ابتدا با استفاده از Dialup configuration اقدام به ايجاد يك Account نماييم. در شاخه Internet مي‌توانيد اين گزينه را انتخاب كنيد. مراحل كار به صورت زير است:

1- در صفحه Add New Internet connection با انتخاب
Dial up configuration شكل 1 ظاهر مي‌شود.
‌2- در گام بعدي سيستم به صورت خودكار اقدام به شناسايي مودم سيستم شما مي‌كند و پس از شناسايي، صفحه تنظيمات مودم ظاهر مي‌شود. در اين صفحه مي‌توان مودم را به صورت دلخواه تنظيم كرد.
3- در مرحله بعد براي حسابي كه مي‌خواهيد درست كنيد يك نام درخواست مي‌شود و همچنين پيش شماره

شكل 2

كشور و شماره شبكه‌اي كه مي‌خواهيد متصل شويد را در اين صفحه بايد وارد كنيد.
4username و password در گام بعدي درخواست مي‌شوند.
5- در صفحه other option نام ISP را بايد انتخاب كنيد. اگر ISP شما در ليست نباشد كه عموماً نيست، گزينه Normal را برگزينيد.
6- در صفحه آخر، يعني Creat the account، اطلاعات ورودي شما به سيستم نمايش داده مي‌شود. كلمه Finish پايان كار را نشان مي‌دهد.
با اجراي RH PPP Dial در شاخه Internet و انتخاب اتصال PPP0 مي‌توان اقدام به شماره‌گيري شبكه مقصد نمود. براي عيب‌يابي از برنامه 3 RP مي‌توان با اجراي برنامه از زبانه Internet connections و زبانه Accoant اقدام به ديباگ نمودن برنامه كرد. در هنگام اتصال به شبكه هم با كليك راست روي آيكون برنامه RP3 مي‌توان اقدام به سفارشي كردن آن نمود.

شكل 3

Linuxconf، ابزاري عمومي
حتماً با اين ابزار آشنايي داريد و مي‌دانيد چگونه و در كجا به كارتان مي‌آيد. اگر كليد انجام عمليات در ابزارLinuxconf در دستتان باشد انجام آن عمليات برايتان بسيار آسان خواهد بود. PPP را هم مي‌توان با اين ابزار راه‌اندازي كرد و اقدام به ساخت يك Account نمود. مراحل كار را با هم مرور مي‌كنيم:

1- با اجراي برنامه Linux conf مسير زير را طي مي‌كنيم (شكل 2):
‌/‌networking /client tasks Config

شكل 4

2- از tasks Client گزينه PPP/SLIP/PLIP را كليك مي‌نماييم. در سمت راست صفحه، برنامه مذكور مشاهده مي‌شود (شكل 3) .
3- در اين مرحله يك اتصال را از ليست انتخاب مي‌كنيم. به عنوان مثال PPP0 و به مرحله بعد مي‌رويم.
4- در صفحه جديد شماره تلفن ISP، پورت نصب مودم، اسم كاربردي و رمز شبكه از شما درخواست مي‌شود (شكل 4).

نامگذاري پورت com در لينوكس به صورت زير است:

com1:/dev/ttys0
com2:/dev/ttys1
com3:/dev/ttys2
com4:/dev/ttys3

با زدن دكمه Accept حساب جديدي ايجاد مي‌شود. در اين صفحه دكمه Customize براي تنظيمات پيشرفته‌ مودم است.

شكل 5

اكنون شما يك Account ساخته‌ايد و بايد به شبكه متصل شود. در همان برنامه Linux conf با طي كردن مسير زير مي‌توان اقدام به شماره‌گيري كرد (شكل 5):
‌/‌controlpanel/control ppp/SLIP/PLIP linksControl
‌يكي از معايب Linux conf محدوديت در تنظيم و سفارشي نمودن حساب ايجاد شده است. از طريق اعلان shell هم مي‌توان با ابزار Linux conf كار كرد. سه دستور netconfconnect pppsetup ،netconfdialctl و
netconfdisconnect pppsetup براي ايجاد، پيكربندي و قطع ارتباط از طريق خط فرمان هستند.

WVDial، ابزار پوسته فرمان لينوكس‌
زماني كه نمي‌خواهيد از محيط‌هاي گرافيكي استفاده كنيد يا اقدام به نصب آنان نكرده‌ايد و يا دنبال ابزاري مبتني بر پوسته خط فرمان (shell) مي‌گرديد، WVDial را مي‌توان مورد استفاده قرار داد. با تايپ man WVDial در خط فرمان مي‌توان اطلاعات كامل اين ابزار را به دست آورد. WVDial خود به دو دستور WVDial conf و WVDial تقسيم مي‌شود. WVDial conf مي‌تواند فايلي به نام WVDial.conf را در شاخه /etc ايجاد كند كه شامل اطلاعات سيستم و مودم براي يك اتصال به اينترنت است. با اجراي دستور سيستم به صورت خودكار اقدام به شناسايي مودم و اطلاعات مرتبط با آن مي‌كند و اين اطلاعات را در فايل WVDial.conf ذخيره مي‌كند. با دستور Cat مي‌توان محتويات اين فايل را مشاهده نمود. يك نمونه از اين فايل به صورت كد 1 است.

كد 1

اگر مشكلي پيش نيامده باشد اكنون ما فايلي حاوي اطلاعات مودم داريم و كافي است اطلاعات تكميلي مانند شماره تلفن شبكه مقصد، username و password را به اين فايل اضافه كنيم. فايل را در يك Editor باز مي‌كنيم و با قرار دادن “;” ابتداي هر خط اطلاعات تكميلي را وارد مي‌كنيم.‌(كد 2)
اكنون تنها يك كار مانده است و آن هم اجراي فايل است تا به شبكه متصل شويم. براي پايان دادن به اتصال، كليدهاي Ctrl+C را استفاده مي‌كنيم.

كد 2

KPPP، قدرتمندترين ابزار

شكل 6

KDesktop ابزار قدرتمندي براي سرويس ppp و ايجاد يك حساب اتصال به اينترنت دارد Kppp .تنظيمات بسيار زيادي از مقدماتي تا پيشرفته در يك محيط گرافيكي در اختيار شما قرار مي‌دهد. ديگر مزيت kppp راهنماي بسيار آسان ولي كامل و كاربردي براي هر قسمت است. با كليك راست به روي هر قسمت و در هر بخش از كار و انتخاب help Quick مي‌توان از اين راهنما استفاده كرد.
براي شروع كار از منوي اصلي محيط KDE شاخه Internet گزينه Internet dialer را انتخاب مي‌كنيم (شكل 6).

شكل 7

اگر براي بار اول باشد كه kppp را اجرا مي‌كنيد. اين گزينه‌هاي برنامه kppp غيرفعال خواهند بود و براي پيكربندي آن نياز داريد كه دكمه setup را كليك كنيد (شكل 7).

اين پنجره داراي زبانه‌هاي Accounts ،Device ،Modem ،Graph ،Misc و About است كه هر يك تنظيمات خاص خود را دارند.
زبانه Accounts براي ايجاد يك حساب كاربري است. زبانه Device مخصوص تنظيمات مودم و وسايل ارتباطي است. نصب مودم و گرفتن تست از آن از زبانه Modem انجام مي‌شود. با زبانه Graph مي‌توان تنظيمات مربوط به رنگ‌هاي نمودار گرافيكي و ترسيم نمودار را انجام داد. زبانه Misc براي شماره‌گيري مجدد، نمايش تماس، نمايش kppp به روي پنل هنگام برقراري ارتباط و ... استفاده مي‌شود.
اگر زبانه Accounts را انتخاب كنيم با زدن دكمه New مي‌توان شروع به ساخت يك اتصال كرد.
در هر يك از زبانه‌ها يك سري تنظيمات خاص قرار دارد و اين جلوه‌اي از قدرت برنامه kppp مي‌باشد. در زبانه Dial نام حساب، شماره تلفن شبكه و تنظيمات ديگري مانند CHAP/ PAP انجام مي‌شود. PAP و CHAP روش‌هايي براي بررسي سيستم ورود به شبكه مي‌باشند (شكل 8) .

شكل 8

در زبانهIP ، نوع IP را برحسب ايستا يا پويا (Dynamic) تنظيم مي‌كنند. اگر شبكه مقصد يك Gateway مشخص در اختيار شما قرار داده است مي‌توانيد آن را در زبانه مربوطه وارد كنيد. زبانه DNS نيز نام Domain شبكه مقصد و IP آن را از شما مي‌خواهد. زبانه Script Login اسكريپت‌هاي موردنياز را براي ورود به سيستم مشخص مي‌نمايد. تنظيمات مربوط به نمايش اطلاعات در حين برقراري ارتباط در زبانه Accounting انجام مي‌شود. همان‌طور كه مشخص است در kppp گستردگي كار به مراتب بيشتر از ديگر ابزار است و شما هيچ‌گونه محدوديتي احساس نمي‌كنيد و به راحتي و آساني مي‌توان آن‌چه را دنبالش هستيد در kppp انجام دهيد. مزاياي kppp منحصر به راه‌اندازي و پيكربندي نيست بلكه گزارش‌گيري، نمايش اطلاعات اتصال و بسياري ديگر از موارد هستند كه اين ابزار در اختيار شما قرار مي‌دهد.

مراجع:
http://www.ibiblio.org/mdw/LDP/naq/naq.html (1
 http://www.ibilio.org/mdw/Howto/netHowto (2
 http://Linuxports.com/Howto/ppp (3
 http://sunsit.unc.edu/pub/linuxdocs/faqs (4
ppp-FAQ
 http://www.Linuxdoc.org (5
 http://oslab.sun.ac.kr/djshinlinux/mail-list/ (6
index-shtml
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
سه شنبه، 17 آبانماه 1384

06:18 PM

November 08, 2005

با Thin Clientها آشنا شويد

ترجمه و تنظيم: افسانه دشتي
ماهنامه شبکه - آذر 1383 شماره 49

اشاره :
همچنان كه فناوري اطلا‌عات، توسعه بيشتري مي‌يابد، شبكه‌ها نيز به عنوان يكي از پيامدهاي اين توسعه اهميت بيشتري مي‌يابند. اما شبكه‌ها فقط منحصر به انواع متداول LANها يا WANها نمي‌گردند و شبكه‌سازي روش‌هاي ديگري نيز دارد. در اين زمينه تجهيزاتي مانند Thin Clientها، Net PCها و يا Network computerها مطرح مي‌گردند كه هر يك ويژگي‌هاي خاص خود را دارند. در اين مقاله قصد داريم به معرفي فناوري مرتبط با Thin Clientها بپردازيم.

آشنايي
شبكه مبتني بر Thin Client، شبكه‌اي مبتني بر سرور است كه تقريباً كليه پردازش ها در آن توسط اين سرور صورت مي‌پذيرد. كليه برنامه‌هاي كاربردي روي سرور اجرا شده و توسط Clientها قابل استفاده هستند. واژه thin در اين تكنولوژي، به دليل حجم پايين پردازشي است كه توسط Clientها صورت مي‌پذيرد. در مقابلِ اين تكنولوژيFat Clientها مطرح مي‌باشند كه كليه پردازش‌ها را روي Client انجام مي‌دهند. به طور كلي ساختار شبكه هاي مبتني بر Thin Client از يك سرور با قدرت بالا و تعدادي Client تشكيل شده است كه كارآيي محدودي دارند.

Thin Client چيزي جز يک کامپيوتر جمع و جور نيست اما اين کامپيوتر براي استفاده به صورت يک پايانه‌ي شبکه‌اي طراحي و تنظيم شده است. شکل بالا نمونه‌اي از يک Thin Client ساخت HP را نشان مي‌دهد. براي ديدن عکس در ابعاد بزرگتر، روي آن کليک کنيد.

يك شبكه مبتني بر Thin Client چگونه فعاليت مي‌كند؟
يك شبكه مبتني بر اين تكنولوژي داراي يك يا چند سرور با ويژگي‌هاي خاص مي‌باشد. سيستم‌‌عامل اين سرورها مي‌تواند هريك از سيستم عامل‌هاي موجود (با توجه به برنامه‌هاي كاربردي موردنظر) نظير يونيكس، لينوكس،
(Windows NT Terminal Server Edition (NT TSE ، يا ويندوز باشد. علاوه بر سيستم‌عامل، بر روي هر يك از اين سرورها يك نرم افزار كنترلي وجود دارد كه فعاليت‌هاي Clientها را كنترل مي‌نمايد. بسياري از اين نرم افزارهاي كنترلي به صورت رايگان عرضه مي‌شوند و معمولا‌ً توسط شركت‌هاي نرم‌افزاري، توليد مي‌گردند.

كاربردها
اين شبكه‌ها در بسياري از سازمان‌ها مورد استفاده قرار مي گيرند. اما بزرگترين مشتريان اين شبكه‌ها، بانك‌ها، آژانس‌هاي هوايي و سازمان‌هايي هستند كه داراي شعبات متعدد مي‌باشند. امروزه از اين تجهيزات براي تجهيز مدارس نيز استفاده مي‌شود. با توجه به اين نكته كه سيستم‌هاي Thin Client داراي هاردديسك نمي‌باشند و امكان download كردن نرم‌افزار نيز روي آن‌ها وجود ندارد، هيچ نوع ويروسي نمي تواند سيستم را مورد حمله قرار دهد. به اين ترتيب امنيت اين نوع سيستم ها تضمين شده مي‌باشد. ارتقاء و نگهداري Thin Clientها بسيار ساده و مقرون به صرفه است. زيرا براي ارتقاء شبكه لازم است فقط سرور مربوطه را upgrade نمود.

مزايا و معايب
مديريت‌پذيري، هزينه‌ پايين، امكان كنترل ونظارت و مواردي از اين دست از جمله مزاياي اين‌گونه از شبكه‌ها مي‌باشند كه در ادامه به آن‌ها اشاره خواهيم كرد.

مديريت پذيري
در اين شبكه فقط كافي است سرور مديريت گردد. جهت رفع نقايص احتمالي نيز سرور اصلي مد نظر مي باشد.

امنيت
در سيستم‌هاي Thin Client به علت عدم وجود نقطه ورود به شبكه، عدم امكان download كردن نرم‌افزار از اينترنت و نصب آن بر روي Client‌ها و همچنين عدم وجود هاردديسك، ويروسي شدن سيستم‌ها غيرممكن است. همچنين با استفاده از امكانات سيستم مديريتي و كنترلي موجود بر روي سرورها مي‌توان دسترسي كاربران را نيز به نحو مطلوب محدود نمود.

كنترل و نظارت
كاربران شبكه‌هاي Thin Client نمي‌توانند applicationهاي خود را بر روي Client نصب نمايند همچنين قادر به تغيير پيكربندي سيستم نيز نمي‌باشند.

هزينه سخت افزار
اين تجهيزات از PCها به مراتب ارزان‌تر مي‌باشند. به علاوه به دليل عدم وجود قطعات جانبي، كمتر دچار خرابي مي شوند. نكته قابل ذكر در اين در نتيجه هزينه نگهداري اين تجهيزات نيز كمتر است.

سهولت ارتقاء
براي اضافه كردن ترمينال‌هاي جديد به شبكه، فقط كافي است از طريق نرم افزار مركزي كه روي سرور نصب شده نرم افزار كنترلي را روي Client جديد نصب نمود. در صورت خرابي نيز مي‌توان به راحتي ترمينال مورد نظر را از شبكه خارج نمود.

ذخيره انرژي
در مقايسه با كامپيوترهاي شخصي، اين سيستم‌ها انرژي كمتري مصرف مي نمايند. در اين سيستم‌ها به علت پردازش پايين، توان مصرفي آنها در حدود ده الي بيست وات در ساعت مي‌باشد. در حالي كه توان مصرفي يك كامپيوتر از نوع PC در حدود 250 وات در ساعت مي باشد.
اما معايب استفاده از اين كلا‌ينت‌ها را مي‌توان اين‌گونه برشمرد:

عدم انعطاف پذيري
در صورتي كه نرم افزاري بر روي سرور نصب نشده باشد، كاربران نمي توانند از آن استفاده نمايند.

وابستگي به سرور
با توجه به ساختار Thin Client، لازم است سرور از امنيت بالايي برخوردار باشد. زيرا در صورت از كار افتادن سرور، شبكه به طور كامل مختل خواهد شد. در نتيجه براي جلوگيري از اين امر، روش‌هاي مختلفي جهت ايجاد redundancy نرم افزاري و سخت‌افزاري استفاده مي شود. مكانيزم‌هاي متفاوت Failover نيز براي پردازنده‌ها و پايگاه داده مورد استفاده قرار مي‌گيرد. امكان Load balancing سخت‌افزاري و نرم‌افزاري نيز براي اين سرورها از موارد ضروري مي باشد كه همه اين‌ها قيمت سرور موردنظر را به شدت بالا‌ مي‌برد.

پهناي باند
مانند ساير شبكه هاي كامپيوتري، پهناي باند اين شبكه نيز وابسته به تعداد Clientها مي باشد. با توجه به انجام كليه فرآيندهاي پردازشي توسط سرور، ترافيك اين شبكه بسيار بالا است. زيرا كليه دستورات پردازشي بايد به سرور منتقل شده و نتايج به Clientها تحويل گردند.

كمبود فضاي حافظه
با توجه به ساختار اين سيستم ها امكان استفاده از هيچ نوع حافظه جانبي نظير انواع ديسك ها وجود ندارد.

استفاده از تجهيزات جانبي
در اين نوع شبكه‌ها تجهيزات جانبي محدود مي‌باشند. تجهيزاتي نظير دوربين‌هاي ديجيتال يا تجهيزات تصويري را نمي‌توان به اين ترمينال‌ها متصل نمود. اما در حال حاضر انواعي از ترمينال‌ها وجود دارند كه پورت هاي مختلفي را پشتيباني مي‌كنند.

امكانات ضعيف پشتيباني از مالتي مديا
برنامه‌هاي كاربردي كه نياز به پردازش‌هاي تصويري زياد دارند، روي اين شبكه‌ها به خوبي كار نمي‌كنند. زيرا كليه فرآيندهاي پردازشي توسط سرور مركزي صورت مي گيرد كه در صورت تخصيص پردازنده به applicationهاي مالتي مديا، كارآيي شبكه به شدت كاهش مي يابد. پيشرفت هايي كه در زمينه تكنولوژي هاي پردازنده ها و سرورها صورت پذيرفته است، تا حدودي اين قبيل مشكلات را كاهش داده است. اما هنوز هم عدم پشتيباني از اين چنين كاربردهايي از نقاط ضعف Thin Clientها محسوب مي گردد.

انواع Thin Client
همان‌گونه كه اشاره شد اين سيستم ها نيز انواع مختلفي دارند كه با توجه به ميزان پردازشي كه توسط Clientها و سرور صورت مي گيرد از يكديگر متمايز مي‌گردند. در ادامه تعدادي از انواع اين‌ سيستم ها معرفي مي گردند.

Ultra thin client
در اين سيستم كاربر يك صفحه كليد، ماوس و مانيتور دارد. كليه پردازشي كه توسط Clientها در اين سيستم انجام مي شود پردازش ورودي صفحه كليد، ماوس و خروجي روي مانيتور مي‌باشد و ساير پردازش‌ها توسط سرور انجام مي‌شود. ترمينال‌هاي ويژه‌اي از اين نوع، امكان پردازش كارت‌هاي هوشمند را نيز دارند.

(Windows Based Terminal (WBT
اين ترمينال‌ها خود بر دو نوع هستند:
1- ترمينال‌هاي استانداردي كه از پروتكل‌هاي (RDP (Remote Desktop Protocol مايكروسافت يا Citrix ICA (Independent Computing Architecture) استفاده مي نمايند.

2- ترمينال‌هايي كه از سيستم عامل‌هاي نوشته شده توسط يك سازنده خاص (براي Client‌هاي خاص) استفاده مي نمايند. البته ا‌ين سيستم‌ها از پروتكل‌هاي استاندارد نيز پشتيباني مي‌نمايند.
عمده ترين شركت هايي كه اين نوع ترمينال‌ها را توليد مي كنند عبارتند از: NCD ،Wyse ،Neoware و Compaq
در رابطه با اين نوع ترمينال‌ها نكته قابل ذكر اين است كه مجموعه‌اي ازPC ‌ها نيز وجود دارند كه با محدود كردن عملكردشان مي‌توان از آن‌ها در شبكه‌هاي Thin Client استفاده نمود. از اين PCها براي مواردي كه كاربردهاي چندرسانه‌اي در شبكه‌ها وجود دارد استفاده مي شود. مثلا‌ً به اين ترتيب پردازش‌هاي تصويري و صوتي توسط خود Client انجام مي شود.

Internet terminal
اين ترمينال‌ها مرورگرهاي اينترنت را به طور توكار ضمني همراه دارند.

Low spec PC solution
به علت عدم نياز به پردازش توسط Clientها مي‌توان از PCهايي كه از رده خارج شده‌اند نيز براي ايجاد شبكه‌هايThin Client استفاده نمود. از اين راه‌حل بيشتر در مدارس استفاده مي شود.

Tubby client
اين نوع Client‌ها در حقيقت PC‌هايي مي‌باشند كه خود داراي سيستم عامل و application‌هايي مستقل هستند اين PCها با استفاده از يك نرم افزار امكان اتصال به شبكه Thin Client را نيز دارند. به ترتيب مي‌توانند از application ‌هايي كه روي سرور موجود مي‌باشند نيز استفاده نمايند.

Disabled PC solution
در اين نوع از ترمينال‌ها، از امكانات موجود در PC‌ها نظير Floppy disk و CD استفاده نمي‌شود. و به اصطلا‌ح آن‌هاDisable مي‌شوند. البته اين روش براي مدت زمان طولاني روش مناسبي محسوب نمي شود. در صورتي كه از اين شبكه در كنار يك شبكه استاندارد استفاده شود، راه‌حل بهينه‌اي است.

Blade PC architecture
از اين ساختار براي Clustering يا خوشه‌بندي استفاده مي‌شود. در ساختار Blade PC از PCها به عنوان سرور استفاده مي شود. اين سرورها در يك محل به صورت متمركز گرد‌آوري شده و يك سرور مديريت، كليه PCها را كنترل مي نمايد و ترافيك را ميان آن‌ها تقسيم مي‌نمايد. كليه اجزاي جانبي نظير صفحه كليد، ماوس و مانيتور كاربران از طريق يك ارتباط استاندارد (به طور مثال 5-Cat) به PCها متصل مي‌شود. البته ا‌ين راه حل بسيار گران بوده و در عين حال ساختار مديريتي پيچيده‌اي نيز دارد.

پروتكل‌هاي ارتباطي
همان گونه كه ذكر شد، دو پروتكل مطرح در اين زمينه وجود دارند.
پروتكل Citrix ICA: پروتكلي است محصول شركت Citrix كه به Client‌ها اين امكان را مي‌دهد تا با سرور مركزي ارتباط برقرار نمايند. با استفاده از اين پروتكل بسياري از application‌هاي تحت ويندوز قابل اجرا هستند.
پروتكل RDP: اين پروتكل كه توسط شركت مايكروسافت توسعه داده شده، نيز يك پروتكل ارتباطي است كه امكان برقراري ارتباط ميان سرور و Clientها را ميسر مي سازد.

نتيجه‌گيري
در اين نوشتار با نوع ديگري از شبكه سازي مبتني‌بر فناوري Thin Clientها آشنا شديد. شبكه‌هايي كه تمركز اصلي آن بر روي سرور بوده و كلا‌ينت‌ها با حداقل توان پردازشي در اختيار كاربران قرار مي‌گيرند. كاربر عمده اين قبيل شبكه‌ها، با توجه به معايب و مزاياي گفته شده، مكان‌هايي نظير آژانس‌هاي هواپيمايي، بانك‌ها و مراكز آموزشي مي‌باشند.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ

جمعه، 20 آبانماه 1384

12:27 PM

November 11, 2005

نقش R&D در نوآوري و موفقيت شركت‌ها

ترجمه و تلخيص: عليرضا صالحي
ناشر: ماهنامه شبکه - آذر ۱۳۸۳ شماره 49

اشاره :
كدام شركت‌ها آينده ما را مي‌سازند؟ كدام‌يك نوآورترند و كدام‌يك بودجه زيادي را به امر تحقيق و توسعه (R&D) اختصاص مي‌دهند؟ يكي از معيارهاي سنجش اين امر، بررسي ميزان سرمايه‌اي است كه شركت‌ها در راه تحقيقات گذاشته‌اند. اين سرمايه يعني بودجه تحقيقاتي، دستگاه‌ها، تجهيزات و همچنين ايده‌هايي كه در اين بين وجود دارند. هفته‌نامه بيزنس ويك، به مناسبت هفتاد و پنج سالگي خود، براي نخستين بار پژوهشي را در اين زمينه صورت داده است. در اين بررسي، بودجه‌هاي تحقيقاتي شركت‌ها تحت بررسي بوده‌اند و نشان داده شده كه چه سهمي از بودجه كل شركت در اختيار بخش R&D بوده است.

نام شركت | ميزان فروش(ميليون دلار) | تحقيق و توسعه (ميليون دلار) | درصد سهم تحقيق و توسعه از Outlay
Applied Micro Circuits | 131 | 128 | 64/3
Biogen Idec | 679 | 233 | 57/1
PMC-Sierra | 250 | 120 | 54/6
BMC Software | 1419 | 586 | 49/3
Gilead Sciences | 868 | 165 | 48/5
AMD | 3519 | 852 | 42/6
Broadcom | 1610 | 653 | 41/5
Micron Technology | 3091 | 656 | 39/2
Intel | 30141 | 4360 | 38/8
Linear Technology | 807 | 105 | 36/6
National Semiconductor | 1983 | 353 | 35/1
Adobe Systems | 1295 | 277 | 34/9
Microsoft | 1109 | 7779 | 34/8
Comverse Technology | 766 | 227 | 33/7
Analog Device | 2047 | 450 | 33/1
QLogic | 524 | 88 | 33/1
Texas Instruments | 9834 | 1725 | 31/6
Veritas Software | 1747 | 302 | 31/0
Peoplesoft | 2267 | 433 | 30/9
eBay | 2165 | 159 | 30/6
Tellabs | 980 | 286 | 30/4
جدول 1
شركت‌هاي آينده‌گرا شركت‌هاي بزرگ به دو روش در امر تحقيق و توسعه سرمايه گذاري مي‌كنند. يا آن كه به پژوهش مي پردازند تا محصولات و خدمات جديدي را پديد بياورند يا آن كه هزينه زيادي را صرف ظرفيت سازي از طريق خريد دستگاه هاي جديد، نرم افزار ها و ساختارهاي نو مي نمايند.
بررسي‌ها نشان دادند كه شركت‌هاي فعال در حوزه بيوتكنولوژي يا زيست‌فناوري، بيشترين بودجه را به امر تحقيق و توسعه اختصاص داده‌اند و در اين زمينه بسيار فعال هستند (شركت‌هاي Amgen و Biogen)، پس از آن‌ها، تعجب‌آور نخواهد بود اگر نام شركت‌هاي فعالIT را ببينيم. شركت‌هاي Micro Circuits، اينتل و مايكروسافت اين زمره هستند. نكته مهم ديگر آن است كه تمامي سي شركت صدر جدول (به غير از يك شركت) همگي در حوزه‌هاي فناوري برتر يعني بيوتكنولوژي، نيمه‌رساناها، نرم‌افزار، IT و بهداشت فعال هستند. حتي حراجي بزرگي مانند eBay نيز كمابيش برخلاف انتظار، در بين اسامي ديده مي‌شود.

البته اگر بخواهيم سهم بودجه R&D از بودجه كلي شركت را به عنوان ملاك اصلي در نظر بگيريم، نتيجه‌گيري‌ها صحيح نخواهد بود. زيرا مثلاً در مورد شركتي مانند اينتل، عامل فوق به همراه سرمايه‌گذاري‌هاي انجام شده روي تجهيزات، نرم‌افزارها، ساختمان‌ها و اين‌كه اين شركت‌ با ايجاد كارخانه‌هاي جديدي در راه توليد تراشه‌هاي جديد گام برمي‌دارد، مي‌تواند روي تصميم‌گيري درخصوص رتبه‌بندي اينتل، تأثير بگذارد.همچنين درخصوص شركت‌ ديگري مانند eBay اين موضوع وارونه است. زيرا اين حراجي، سرمايه‌گذاري كمتري را روي ساختمان و مكان‌هاي فيزيكي مي‌كند و بيشترين حجم سرمايه‌گذاري او روي ميان‌افزارها و ساختارهاي نرم‌‌افزاري ديگر است. در واقع اين نحوه محاسبه بيشتر درخصوص كارخانجات يا صنايعي مانند نفت و گاز، به خوبي جواب مي‌دهد.

نكته ديگر آن است كه حجم سرمايه‌گذاري در امر تحقيق و توسعه، چيزي نيست كه نتايج آن در نگاه اول مشخص شود. در واقع اين‌كار، ابزاري است براي ظرفيت‌سازي جهت انجام نوآوري در آينده. در ضمن در بعضي كشورها نظير آلمان يا ايالات متحده، حجم سرمايه‌گذاري در R&D مقوله بسيار مهم‌تري نسبت به ساير كشورها محسوب مي‌شود. زيرا اين امر رابط مستقيمي با ميزان تقاضا براي كالاهاي جديد در آن كشورها دارد. از طرف ديگر براي آن‌كه بتوانيم شركت‌هاي حوزه‌هاي مختلف را با يكديگر مقايسه كنيم. مفهومي را به نام outlay تعريف كرديم.
Outlayها در واقع تركيبي از ميزان سرمايه‌گذاري مستقيم به‌علاوه بررسي شرايط شركت از نظر ميزان پرداخت دستمزدها، هزينه خريد مواد اوليه و نوع تحقيقات است. يعني حجم سرمايه‌گذاري در امر تحقيق و توسعه فقط بخشي از outlay را شامل مي‌شود. پس اگر شركتي بودجه R&D خود را بدون توجه به اثرات آن در امر فروش يا سهم از بازار كم كند، در نتيجه در فهرست ما نيز جايگاه مناسبي نخواهد داشت. از آن‌جايي كه تحقيق و توسعه و تلاش براي ساخت آينده‌اي بهتر، منحصربه ايالات متحده نمي‌گردد، در نتيجه در فهرست‌ ارايه شده، شركت‌هاي غيرآمريكايي نيز حضور دارند. براي تهيه فهرست‌ها، مطابق معمول براي شركت‌هاي آمريكايي از ليست پانصدتايي standard &Poor's 500 استفاده كرديم. براي شركت‌هاي غير آمريكايي نيز آمار مربوط به 700 شركت را از ليست S&P 2100 مورد توجه قرار داديم.

نام شركت | كشور | ميزان فروش (ميليون دلار) | تحقيق و توسعه(ميليون دلار) | درصد سهم تحقيق و توسعه از outlay
صنعت نيمه رسانا
ARM Holdings | بريتانيا | 228 | 86 | 53.9
United Micro electronics | تايوان | 2758 | 174 | 45.9
STMicro electronics | هلند | 7234 | 1238 | 39.0
نرم افزار و خدمات
Systems Dassault | فرانسه | 913 | 261 | 45.4
SAP | آلمان | 8495 | 1202 | 23.7
Sage Group | بريتانيا | 996 | 103 | 22.8
سخت افزار
Murata Manufacturing | ژاپن | 3793 | 313 | 20.4
(Ericsson(LM Telefon | سوئد | 19322 | 3888 | 19.9
Spirent | بريتانيا | 829 | 117 | 19.8
جدول 2- فهرست شركت‌هاي غير آمريكايي آينده گرا
نكته ديگري كه بايد خاطر نشان كنيم آن است كه سرمايه‌گذاري در امر تحقيق و توسعه با خطر يا ريسك زيادي روبرو است كه ميزان اين ريسك با توجه به نوع صنايع متفاوت است. قطعاً نتايج صرف بودجه R&D در صنايع نفت و گاز با صنعت IT كاملاً متفاوت است. مثلاً اگر شركتي مانند مايكروسافت هزينه‌اي زيادي را صرف R&D مي‌نمايد، قطعاً اميد بيشتري به بازگشت سرمايه‌اش دارد. وليكن اين اطمينان باعث نمي‌شود كه اين شركت مرتباً بر حجم سرمايه‌گذاري در اين حوزه نيفزايد. اين غول نرم‌افزاري براي آن‌كه پيشتاز فناوري اطلاعات باشد بايد تن به پرداخت چنين هزينه‌هايي بدهد. بيل گيتس به گزارشگر بيزنس ويك گفته است كه مايكروسافت روي هر موضوعي كه قدري جدي به نظر برسد يا نوآورانه باشد آنقدر سرمايه‌گذاري مي‌كند كه اين كار بيشتر به شرط‌بندي كلان مي‌ماند تا يك سرمايه‌گذاري ساده.

و البته همه ما مي‌دانيم كه هميشه شرط‌بندي، به برنده شدن منتهي نمي‌شود اما آينده متعلق به شركت‌هايي است كه از سرمايه‌گذاري در تحقيق و توسعه نمي‌هراسند و مي‌توانند آن سرمايه‌ها را به نحو صحيح مديريت كنند تا در نهايت به آينده‌اي حقيقي برسند.

(مطابق روال هميشگي، ماهنامه شبكه در اين گزارش نيز توجه خود را معطوف شركت‌هاي IT نموده است)
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 27 آبانماه 1384

12:46 PM

November 18, 2005

پنج روش رايگان براي افزايش ترافيك وب‌سايت

محمود بشاش - وقتي براي اولين بار وارد دنياي بازاريابي اينترنتي شدم، فكر كردم مي‌توانم وب‌سايت تازه تأسيسم را به تعدادكمي موتور جستجو معرفي كرده، سپس منتظر هجوم مراجعين بمانم. منتظر معجزه‌اي بودم تا افراد را وادار كند به وب‌سايت من مراجعه كرده، كالا بخرند و دوباره باز گردند.
اما، چه خيال باطلي! ... تازه فهميدم اين كار به زمان بيشتري نیاز دارد.از آن زمان به بعد به كارآيي عجيب وغريب و خارق العاده بازاريابي اينترنتي پي برده‌ام.
در اين جا پنج روش رايگان افزايش ترافيك وب سايت را براي شما بازگو مي‌كنم.
مطمئن باشيد تمام ‌اين‌ روش ها كاملا رايگان بوده،با صرف كمي وقت به سودمند‌بودن آنها پي مي‌بريد.

1-‌ نوشتن مقالات
نوشتن وانتشار مقاله با موضوع مرتبط با سايت شما دست كم دو فايده‌ي اساسي دارد:
- افرادي كه مجذوب اين مقاله شده‌اند، آن را خوانده، براي جستجوي مطالب بيشتر،روي
URL شما كليك مي‌كنند.به اين ترتيب يك مراجع هدف دار داريد.از اين جهت از كلمه‌ي
جهت دار استفاده مي‌كنم كه اين خواننده مي‌خواهد، مطالب بيشتري در مورد موضوع مقاله‌ي قبلي پيدا كند.
- با هر بار انتشار اين مقاله ،لينك‌هاي شما نيز منتشر مي‌شود.همراه بودن ليست لينك‌ها و URLبا مقالات ، تعداد لينك‌هاي برگشتي سايت شمارا زياد كرده، به نوبه‌ي خود رتبه‌ي شما را در موتور جستجوي مربوطه افزايش مي‌دهد.

2-شبكه‌ي تالار گفتگو
تالارهاي گفتگوي فراواني درباره‌ي هر موضوعي كه فكرش را بكنيد، به شكل برخط(OnLine) وجود دارد. دربيشتر اعلان‌هاي گفتگو، پوسترهايي براي ضميمه كردن امضا و همين طور اطلاعات ديگر مانند نام، URL و حتي گاهي تبليغات، در نظر گرفته شده‌است. با مراجعه‌ي منظم به اين تالارهاي گفتگو، شركت در بحث‌ها، مطرح‌كردن پرسش و پاسخ به پرسش‌ها، مي‌توانيد ضمن ايجاد رابطه‌ي توأم با اعتماد با ساير اعضا ، به طور رايگان به تبليغ سايت خود بپردازيد. فقط سعي كنيد براي تالارهاي گفتگو مفيد بوده، به قوانين آن احترام گذاشته، هيچ‌گاه هرزنامه نفرستيد.

3- لينك‌هاي دوطرفه
اين لينك‌ها دو فايده براي شما دارد:
اول اين كه با تبادل هرچه بيشتر لينك‌ها‌ ، احتمال اين كه افراد، لينك شما را در سايت‌هاي ديگر ديده و به سايت شما مراجعه كنند، بيش‌تر مي‌شود.
نكته‌ي ديگر اين‌كه، موقعيت شما در موتورهاي جستجو به كل تغيير مي‌كند به طور خلاصه لينك‌هاي بيش‌تر از سايت‌هاي ديگر، مساوي است با رتبه‌ي بالاتر در موتورهاي جستجو.
در اين جا چند "بايد" و"نبايد" را در مورد تبادل لينك ذكر مي‌كنم:
- لينك خودرا به سايت‌هايي بفرستيد كه مورد علاقه‌ي مراجعين شما هستند.
- به صفحاتي با هزاران لينك،كه دايركتوري‌هاي لينك نامنظمي دارند، لينك نفرستيد.چون نه براي ايجاد ترافيك سايت سودمند است ونه براي رتبه‌ي شما در موتورهاي جستجو.
- با سايت‌هايي لينك، مبادله كنيدكه در صفحه‌ي اصلي شان، دايركتوري لينك به طور صريح ذكر شده باشد.
- از صفحات، با لينك‌هاي‌انبوه ياFFA استفاده نكنيد.احتمال بالا بردن ترافيك سايت، از اين طريق، بعيدبه نظر‌ مي‌رسدو حتي ممكن است موتورهاي جستجو شما را جريمه كنند.
- از دايركتوري‌هاي لينك، براي پيداكردن شركاي مناسب تبادل لينك، استفاده كنيد.سايتhttp:/www.homebiz-direct.com-Link-Exchange-Resources.html سايت مناسبي براي جستجوي دايركتوري‌هاي مشهور تبادل لينك است.
همواره كارهاي‌تان را طبق اصولي مشخص انجام دهيد.مي‌توانيداز نرم افزارهاي تبادل لينك يا صفحه‌ي گسترده براي پي‌گيري لينك‌هاي درخواستي و حفظ جزييات ارتباط با ساير سايت‌ها استفاده كنيد.

4- امضاي ايميل
اين روشي بسيار ساده ، اما تقريبا فراموش شده براي افزايش مراجعين به سايت است.
ما تقريبا هرروز، ايميل‌هاي زيادي مي‌فرستيم، اما اغلب فقط اسم خودرا در آن نوشته،گاه حتي چيزي نمي‌نويسيم. چرا ايميل‌هاي‌تان را با امضايي حاوي اسم و مطالب اندكي درباره‌ي وب سايت‌تان به همراه URL تمام نمي‌كنيد؟
باوركنيد بدون زياده روي مي‌توان در چهار خط، تمام مطالب لازم را بـيان كرد. حتماً از افزايش خارق العاده‌ي مراجعين به سايت، پس از اين كار، متعجب خواهيد شد. باورش سخت است، اما كنجكاوي، دريافت كنندگان ايميل‌ها را وادار مي‌كند روي لينك شما كليك كنند.

5- تبادل ترافيك
اين روش ازآسان‌ترين راه‌هاي جذب مخاطب به سايت است. مثلاً، مي‌توانيد مزيت‌هاي رايگان براي وب گردي تعيين كنيد.
نقطه‌ي ضعف اين روش اين است كه افرادي كه از طريق مبادله‌ي ترافيك به سايت شما مراجعه مي‌كنند، به اندازه مراجعين از روش‌هاي قبلي هدف‌مند نيستند، زيرا اين افراد به يك دليل در اين تبادل ترافيك شركت مي‌‌كنند و آن به دست آوردن اعتبار بيش‌تر در كم‌ترين زمان ممكن است. اكنون زمان آن فرا رسيده كه شما وارد عمل شويد، چگونه مي‌توانيد فردي را كه فقط بيست ثانيه يا كم‌تر در صفحه‌ي وب شما توقف مي‌كند، تحت تأثير قرار دهيد.
- مخاطبين خود را بشناسيد. زماني را به مبادله‌ي تبليغات اختصاص داده، در عين حال به نوع صفحات وبي كه تبليغ مي‌كنيد، توجه كنيد. اطمينان حاصل كنيد كه تبليغات شما به شكلي هدف‌مند، افراد را جذب مي‌كند.
- سعي كنيد، تبليغاتي تنظيم كنيد كه خواندن آنها حداكثر چند ثانيه وقت بگيرد. تهيه‌ي تبليغات طولاني وقت‌گير، هنر چنداني نمي‌خواهد. مطمئن باشيد افراد از خواندن آنها خسته شده، بدون توجه به مطالب، روي دكمه‌ي "Next" كليك مي‌كنند.
به طور منظم، زماني را به مطالعه اين پنج روش مولد ترافيك، اختصاص دهيد. خواهيد ديد در يك چشم به هم زدن سايت‌ شما در مسير پيشرفتي هدفمند گام برمي‌دارد.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 4 آذرماه 1384

12:18 PM

November 25, 2005

راديوآماتور كيست؟

به موجب مقررات موجود در كشور، راديوآماتوري نوعي ارتباط راديوئي است كه به منظور خودآموزي و تبادل اطلاعات علمي و عملي وبررسي‌هاي فني ارتباطي، بين راديوآماتورهاي مجاز در دنيا، برقرار مي‌گردد و راديوآماتور كسي است كه بخاطر علاقه به فن ارتباطات راديوئي و بدون هيچ گونه نظر انتفاعي وسياسي، با دريافت پروانه راديوآماتوري از وزارت ارتباطات وفناوري اطلاعات نسبت به انجام آزمايشات راديوئي به‌منظور پيشبرد فن راديو و الكترونيك اقدام مي‌نمايد .

به لحاظ بكارگيري امواج راديوئي توسط راديوآماتورها، تمامي كشورها مقرراتي وضع نموده‌اند تا آماتورهاي آن كشور قبل از اقدام به ارتباط راديوئي آزمون‌هاي فني لازم را گذرانده باشند. هدف از برگزاري پيش زمينه‌هاي فني كافي براي طراحي، ساخت، نگهداري و بكارگيري تجهيزات خود را در حد بالاتر از استاندارد بدست آورده باشد تا موجب حداقل ريسك ايجاد اختلال راديوئي در ساير سرويس‌ها گردد.

همين آموزشها وآزمونهاي فني است كه راديوآماتورها را تقريباً از تمامي بكارگيرندگان واقعي طيف فركانس متمايز مي‌سازد و در نتيجه شاهد گروه كثيري از جمعيت جهان در مشاغل فعاليت‌هاي مختلف هستيم كه در كنار آن يك راديوآماتور نيز محسوب مي‌شوند، گروه‌هاي جوان دانشجويان و دانش‌آموزان، اساتيد دانشگاه‌ها، متخصصين رشته‌هاي گوناگون، سياستمداران و شاغلين حرفه‌هاي عمومي، بازنشستگان و از كارافتادگان و حتي معلولين را ميتوان در زمره راديوآماتورهاي جهان يافت.
گاهي سطح مهارت علمي و فني راديوآماتورها موجب حيرت همگان مي‌شود و از جمله ميتوان به ساخت بيش از 60 ماهواره راديوآماتوري توسط راديوآماتورهاي جهان اشاره نمود كه تعدادي از آنها هم اكنون نيز در حال سرويس‌دهي به راديوآماتورهاي جهان مي‌باشند.

راديوآماتورها از طرق گوناگوني با يكديگر ارتباط برقرار مينمايند. اين روشها عبارتند از:

گفتگوي مستقيم، استفاده از علائم مورس، امواج تلويزيوني وارسال ديتا
_ در گفتگوي مستقيم شكل كار هنگامي كه دريافت علائم راديوئي خوب باشد، مانند مكالمات تلفن است با اين تفاوت كه در هر لحظه فقط يك طرف قادر به صحبت كردن است و طرف مقابل شنونده ميباشد. تعداد بسياري از راديوآماتورها در سراسر جهان به زبان انگليسي گفتگو ميكنند ليكن البته بسياري زبانهاي ديگر نيز در اين روش بكار گرفته مي‌شوند.

_ در ارتباطات راديوئي با استفاده از علائم مورس تجهيزات مورد نياز ساده‌تر بوده و موثرترين روش در برقراري ارتباطات راديوئي در شرايط ضعيف بودن علائم راديوئي است. يكي از مزاياي بكارگيري علائم مورس اينست كه در اين روش علائم اختصاري استاندارد شده‌اي وجود دارد كه موجب ميشود حتي اگر زبان مشتركي بين دو طرفه مكالمه وجود نداشته باشد آنها بتوانند با يكديگر ارتباط برقرار نمايند.

_ ارتباط از طريق تلويزيون يعني ارسال تصاوير نيز روش ديگري است كه بعضاً مورد بهره‌برداري قرار ميگيرد توضيح اينكه ارسال تصاوير تلويزيوني معمولاً در فواصل كوتاه انجام ميشود. البته راديوآماتورها روشي ايجاد كرده‌اند كه به "جاروب آهسته تصاوير تلويزيوني" معروف است و به آنان اين توان را مي‌دهد كه تصاوير مورد نظر خود را براي فواصل دور نيز ارسال نمايند كه البته كيفيت اينگونه تصاوير ضعيف و حركت تصوير بسياركند است.

تجهيزات موجود در يك ايستگاه راديوآماتوري و نحوه برقراري ارتباط

ايستگاه‌هاي راديوآماتوري شامل مجموعهاي ثابت يا متحركي هستند از يك يا چند دستگاه فرستنده و گيرنده و اداوات جانبي مربوط به آن كه پس از صدور پروانه مربوطه با مسئوليت يك راديوآماتور تاسيس مي‌گردند و بمنظور آزمايش و كسب تجربه و برقراري ارتباط با ساير راديوآماتورهاي مجاز مورد استفاده قرارمي‌گيرند.
آنتن‌ها در انواع و اقسام آن، دستگاه‌هاي اندازه‌گيري فركانس‌هاي راديوئي و قدرت تشعشع آنتن، منابع تغذيه الكتريكي، ميكروفون، كليد مورس و گاهي اوقات رايانه را ميتوان بعنوان بخشي از اداوات جانبي يك دستگاه راديوآماتوري قلمداد كرد.

بخش عمده و گاهي تمامي تجهيزات موجود در يك ايستگاه راديوآماتوري توسط راديوآماتورها تهيه ميشود و همين امر موجب ميگردد كه طرحهاي جديد و روشهاي متنوعي توسط اينگونه افراد ابداع و اختراع شود كه بنوبه خود بهبود تكنيك‌هاي فني و ايجاد فنآوري‌هاي جديدي را به دنبال دارد.

هر ايستگاه راديوآماتوري داراي يك علامت خطاب يا Call sign ميباشد كه توسط سازمانهاي مسئول در هر كشور به ايستگاه مربوطه تخصيص مي‌يابد. Call sign تركيبي از حروف و اعداد است و پبشوند آن بيانگر كشور متبوع ايستگاه ميباشد از اين معرف براي شناسايي ايستگاه‌هاي راديوآماتوري و تعيين كشور آنها استفاده مي‌گردد و راديوآماتور موظف است قبل و بعد از برقراري هر ارتباط راديوآماتوري آنرا اعلام نمايد.

معرف‌هاي ايستگاه‌هاي راديوئي به ايران، با پيشنوندهاي EP و EQ آغاز مي‌گردد. به عنوان مثال معرف ايستگاه راديوآماتوري وزارت پست و تلگراف و تلفن درتهران EP3PTT مي‌باشد و هيمن معرف براي ايستگاه مستق در شهر شيراز EP4PTT تعيين شده است.

ضوابط و قوانين ملي دريافت پروانه

راديوآماتور براي برقراري ارتباط راديوئي به تاسيس ايستگاه راديوئي اقدام مي‌نمايد و ايستگاه راديوآماتوري عبارت از مجموعه ثابت و متحركي است كه از يك يا چند دستگاه فرستنده و گيرنده فراهم شده و پس از صدور پروانه تاسيس ايستگاه مورد استفاده قرار مي‌گيرد.

علاوه بر پروانه تاسيس ايستگاه، راديوآماتوري نسبت به دريافت گواهينامه راديوآماتوري نيز اقدام مي‌نمايد و اين گواهينامه، اجازه نامه‌ايست كه از طرف وزارت ارتباطات وفناوري اطلاعات به اشخاص حقيقي براي اشتغال به كارهاي راديوآماتوري داده مي‌شود.

پس از دريافت گواهينامه راديوآماتوري و پروانه تاسيس ايستگاه راديوآماتوري با دريافت خطاب (Call Sign) مجاز به تاسيس ايستگاه و بهره‌برداري از دستگاه‌هاي فرستنده و گيرنده كه خود آنها را ساخته يا خريداري نموده است، مي‌شود.

لازم به ذكر است علامت خطاب يا Call Sign مشخصه‌اي است كه قبل و در انتهاي برقراري ارتباط راديوآماتوري و به منظور معرفي ايستگاه اعلام مي‌شود.

پروانه راديوآماتوري درجه سه به كساني داده ميشود كه:
1.داراي 16 سال تمام سن باشند.
2.در آزمون‌هاي كتبي مربوطه قبول شوند.
3.صلاحيت اخلاقي و سياسي آنان مورد تاييد قرار گيرد.

دارندگان اين پروانه مي‌توانند در باندهاي آماتوري 7، 14، 21، 28 مگاهرتز و VHF ار فرستنده تلگرافي با حداكثر قدرت متوسط 30 وات استفاده نمايند.

براي دريافت پروانه راديوآماتوري درجه 2، راديوآماتور بايستي حداقل 6 ماه با پروانه مبتدي درجه 3 كاركرده باشد و از عهده امتحانات مربوطه نيز برآيد. دارندگان آن مي‌توانند در كليه باندهاي آماتوري از فرستنده‌هايي با حداكثر قدرت 100 وات استفاده نمايند.

پروانه راديوآماتوري پيشرفته درجه 1، به كساني داده ميشود كه علاوه بر دارا بودن شرايط دارندگان پروانه راديوآماتوري درجه 2، بتوانند از عهده امتحانات تكميلي برآيند و مجاز به مخابره تلفني و تلگرافي تله تايپ و ارسال تصوير SSTY در باندهاي HF، حداكثر با قدرت 200 وات و VHFبا حداكثر قدرت 50 وات و UHF با حداكثر قدرت 30 وات مي‌باشند كه در شرايط خاص قدرتهاي مذكور به تشخيص مديريت فركانس و روابط بين‌الملل تا 400 وات قابل افزايش است.

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 4 آذرماه 1384

12:34 PM

November 25, 2005

راديوهاي "FRS" سرويس راديويي خانوادگي

دنیای مخابرات و ارتباطات - راديوهاي FRS نوعي از راديوهاي دستي "ارتباط دو طرفه" هستند. همه ما اسباب‌ بازي‌هايي به نام "تاكي واكي" را به ياد داريم. اين دستگاه‌ها كه به صورت جفت بودند، داراي يك بسامد تخصيص يافته از باند FM و با توان خروجي حداقل بودند كه معمولا وسيله بازي كودكان قرار داشتند.

یکی از سرویس هایی که کمیته ملی ارتباطات جهت فعالیت های روزانه به عموم مردم واگذار نموده است سرویسهای خانوادگی است. این دو سرویس از جمله سرویس های کم نظیری میباشند که دارای رادیو های مختص خود هستند . این رادیوها که به نام همین سرویس ها نامیده میشوند اکثرا توسط عموم مردم جهت انجام کارهای مختلف مورد استفاده قرار می گیرند.از آنجایی که فرکانس اختصاص یافته به این سرویس ها مشخص می باشد سازندگان این رادیو ها در هنگام ساخت فرکانس مورد نظر را بر روی دستگاه تنظیم و همچنین توان خروجی آن را نیز معیین می نمایند که بر خلاف رادیوهای حرفه ای در هنگام استفاده قابل تغییر نمی باشند

امروزه مي‌توان راديوهاي FRS را نسل پيشرفته‌تر همان اسباب‌ بازي‌ها دانست كه توسط كاربران غير حرفه‌اي مورد استفاده واقع مي‌گيرند. گرچه امروزه اين دستگاه‌هاي ارتباطي در انواع مختلفي توليد و عرضه مي‌گردند ولي همگي داراي ويژگي‌هاي مشتركي مي‌باشند كه در زير برخي از آنها را براي آشنايي بيشتر از نظر مي‌گذرانيم:

* بسامد FRS:

اولين و اساسي‌ترين مطلب بسامد تخصيص يافته براي اين راديوها است، در كل مي‌توان FRS ها را برحسب بسامد به دو دسته آمريكايي و اروپايي تقسيم‌ كرد. در اكثر دستگاه‌هاي اروپايي تعداد كانال‌ها 8 و تعداد كدها 38 هست. اين در حالي است كه دستگاه‌هاي آمريكايي داراي 14 كانال و بين 38 الي 99 كد كاهش تداخل براي هر كانال هستند.

در جدول زير فهرست كانال‌هاي هر دو دسته از FRS ها همراه بسامد آمده است:

اروپایی PMR جدول کانال های استاندارد

جدول FRS هاي آمريكايي

تا اینجا به این نتیجه رسید یم که تمامی سازنده گان رادیوهای این سرویس جهت ارئه محصول خود ملزم به رعایت استاندارد هایی از جمله تنظیم دقیق فرکانس های فوق برای هر یک از کانالها از طرف کمیسیون ملی ارتباطات هستند و حتما می دانید که هر گاه دو رادیو دوطرفه در محدوده برد یکدیگر قرار بگیرند و در صورتیکه بر روی یک فرکانس مشابه عمل ارسال و دریافت را انجام دهند با یکدیگر تداخل می نمایند و می توانند با یکدیگر نیز ارتباط بر قرار نمایند . این موضوع هم دارای معایبی و هم دارای محاسنی است که در زیر به آن می پردازم.

مزیت: فرض کنید شما با دوستانتان و یا خانواده به یک سفر یا گردش تفریحی به طبیعت رفته اید و برای حفظ ارتباط بین خود و بقیه دوستان از یک یا چند جفت رادیو خانوادگی استفاده میکنید در حین گردش از محل اصلی دور می شوید و ناگهان مشکلی برای شما پیش می آید که قادر به بازگشت به محل اولیه و اطلاع به دوستان برای کمک نیستید( افتادن در چاله ویا شکستن پاو ...)

در این حالت در صورتیکه شما در برد پوششی رادیو خانواده یا دوستان قرار گرفته باشید و همچنین کانال فرکانسی آنها را بدانید می توانید با آنها ارتباط بر قرار کرده و آنها را از وقوع حادثه مطلع نمایید تا به کمک شما بیایند. کاربران این گونه رادیو ها همواره خاطرات زیادی از کاربرد مفید و به موقع این دستگاه ها در شرایط مختلف بیان می کنند

و اما عیب آن: حال فرض کنید که در یک محیط شهری می خواهید بوسیله این رادیو ها با خانواده یا دوستانتان برای انجام کارهایی (خرید یا گردش و ...) ارتباط داشته باشید. شما بر روی یکی از کانالها با آنها به مکالمه می پردازید ولی شخص ثالثی که از این نوع رادیوها را در اختیار دارد و در برد رادیو شما یا دوست شما و یا هردو قرار گرفته است و نیز فرکانس کانالی مشابه دستگاه شما بر روی رادیو او نیز تنظیم شده است می تواند بهطور کامل مکالمات رد و بدل شده شما را بشنود و یا حتی با شما به مکالمه پرداخته و ایجاد مزاحمت نماید. این حالت به اصطلاح تداخل نامیده می شود.

اما راه حل این مشکل چیست؟

جدول کدهای استاندارد کاهش تداخل

باید بدانید که امروزه اکثر سازندگان برای رفع این دست مشکلات راه هایی را پیش بینی نموده اند. از جمله:

رمز گذاری: در این حالت مکالمات هر دو طرف رمزگذاری شده و شخص سوم قادر به شنیدن مکالمات نیست در حالی که این روش بیشتر در بین کاربری های حرفه ای از رادیو ها ی دو طرفه کاربرد دارد ولی شرکت کنوود بیشتر رادیو های خانوادگی خود را به این سیستم مجهز نموده است.

ا ستفاده از کدهای کاهش تداخل: این کدها ریز فرکانس هایی در حد کیلوهرتز می باشند که رقم سمت راست بعد از اعشار فرکانس اصلی کانالها را دچار تغییر می نماید . تعداد این کدها معمولا 38 عدد برای هر کانال در نظر گرفته می شوند و می توانند احتمال بوجود آمدن تداخل را تا حد چشم گیری کاهش دهند. بطوریکه برای ایجاد امکان شنود و مکالمه می بایست همه موارد زیر بر قرار باشند:

1-هر دو رادیو در برد پوششی یکدیگر قرار داشته باشند.

2-هر دو رادیو بر روی فرکانس کانالی یکسان تنظیم شده باشند.

3-هر دو رادیو بر روی کد کانالی یکسانی تنظیم شده باشند.

در صورت عدم برقراری هر یک از سه شرط فوق امکان ایجاد تداخل وجود ندارد. جدول کدهای کاهش تداخل استاندارد برای رادیو های خانوادگی را مشاهده می نمایید

* كدهاي كاهش تداخل:

با توجه به اين امر كه بسامد‌هاي راديويي براي تمام دستگاه‌هاي FRS استاندارد مشابه است، بدون شك، ايجاد تداخل كانالي و يا شنود مكالمات در محدوده خاص بسيار محتمل است، از اين رو سازندگان جهت جلوگيري از امكان تداخل مكالمات و تاحدي ممانعت از شنود توسط ديگران، اقدام به ايجاد كد براي هر كانال نموده‌اند، اين كدها چيزي نيست جز ريزبسامد‌هاي مختلف در حد (hz) كه رقم سمت راست اعشار بسامد كانال‌ها را (جدول كانال‌ها) تغيير داده و در نهايت مانع از شنود و تداخل تا حد زيادي مي‌گردد.

در جدول زير ريزبسامد‌هاي مختص كدهاي استاندارد از 1 لي 38 آمده است، كاربر مي‌تواند روي هر كانال يك كد خاص را تنظيم نمايد. براي مثال كانال 12 كد 32 در اين صورت تنها دستگاه‌هايي قادر به دريافت مكالمات ارسالي از راديوي كاربر را دارند كه اولا در محدوده برد دستگاه كاربر بوده و ثانيا امكان تنظيم بر روي كد و كانالي مشابه دستگاه كاربر را داشته باشند. بنابراين با يك حساب ساده رياضي در مي‌يابيم كه اين كدها احتمال تداخل را از مثلا 14/1 (براي دستگاه بدون كد) تا

532=38×14 ، 532/1 (براي دستگاه 14، 38) كاهش خواهند داد كه رقم چشم‌گيري است.

* توان خروجي: مشخصه ديگري از FRS ها توان خروجي آنها است كه معمولا بين 1 الي 2/1 وات متغير است.

* مقدار برد: برد FRS ها بين 3 تا 5 كيلومتر اسمي و 1 الي 2 كيلومتر حقيقي (فضاي شهري) متغير است.

لازم به ذكر است كه ميزان برد وابستگي شديدي به محيط استفاده از دستگاه دارد.

امکانات اضافیعلاوه بر موارد ياد شده هر سازنده امكاناتي را در محصولات خود به طور مختلف ارائه مي‌دهد كه از آن جمله عبارتند از:

اسکن یا جستجو کا نالها:

جستجو بین کانالها و کد ها جهت تعیین کانالهای مشغول و کانالهای آزاد. بدین شکل که رادیو تک تک کانال ها و کدها را به ترتیب و به طور متوالی از نظر مشغول یا آزاد بودن بررسی می نماید و در صورت یافتن کانال مشغول بر روی آن توقف نموده و صدای مکالمات را پخش می نماید.

Vox سیستم

سیستم فوق یک سیستم فعال سازی صوتی می باشد که به شما کمک می کند تا بدون فشردن کلید ( پی تی تی ) (کلیدی که در هنگام ارسال مکالمه باید فشرده و نگه داشته شود) و تنها با شروع به صحبت عمل ارسال را انجام دهید بدین شکل که میکروفون حساس داخلی یا خارجی دستگاه تنها با صدای شما فعال شده و کار کلید فوق را انجام می دهد.

باطری های قابل شارژ:

اکثر این رادیوها از چند عدد باطری سایز قلمی و یا نیم قلمی استفاده می کنند که در گاهی موارد ممکن است قابلیت شارژ داخلی ( شارژ باطری ها بدون خارج کردن از رادیو و تنها با قرار دادن رادیو داخل دستگاه شارژر) داشته باشند . بیشتر رادیوهای شرکت موتورولا از این گونه اند

تن های مختلف:

از جمله این تن ها که زنگهای کوتاه میباشند می توان به تن دریافت پیام ( اندکی قبل از رسیدن پیام به رادیو شما پخش می شود) و یا تن هشدار و یا تن خاتمه پیام ( در زمان رها کردن کلید ارسال پیام از طرف مقابل جهت اعلام آمادگی برای دریافت پاسخ از طرف وی ارسال می گردد) اشاره نمود.

کانال اطلاعات آب و هوا:

تعداد این کانال ها 7 عدد می باشد و بطور یکطرفه ( فقط دریافت) اطلاعات مختلف مربوط به شرایط جوی را در طول شبانه روز (در ایالات متحده و کانادا) در اختیار کاربران قرار می دهند. گفتنی است برخی تولیدات شرکت موتورولا از جمله این و این دارای این مزیت هستند. در زیر جدول فرکانس های این کانال ها آمده است در ضمن جهت مطالعه اطلاعات بیشتر در این خصوص می توانید به این سایت مراجعه نمایید.

چه کسانی از رادیوهای فوق استفاده می کنند؟

این رادیو ها در محیط شهری بردی بین 1 الی 2 کیلومتر و در محیط باز ( دشت و صحرا ) بردی برابر با 3 الی 6 کیلومتر را پوشش می دهند با توجه به این موضوع اکثر کاربران را موارد زیر تشکیل می دهند:

گروه های نو جوانان و جوانان/ گروه های ورزشی: اسکی و کوهنوردی و.../ تفریح و سرگرمی افراد خانواده در گردش یا سفر و یا خرید/ گروه های گردشگری/ کارکنان هتل ها / پرسنل بیمارستان ها / کار گاه های ساختمان و گروه های نقشه برداری/ نگهبانان و پرسنل کارخانه ها و بسیاری مواردی از این قبیل که نیاز به یک ارتباط لحظه ای و سریع دارند.

آیا فقط می توان در آن واحد 2 به 2 با یکدیگر در ارتباط بود؟

خیر/ تعداد رادیوها میتواند تا بینهایت گسترش یابد و همه می توانند باهم درارتباط باشند.هرنوع رادیو خانوادگی با هر مارک و مدل میتواند دیگر رادیوهای خانوادگی را نیز دریافت نماید

* موارد كاربرد FRS ها:

راديوهاي FRS براي موارد زير مطلوب هستند: كاركنان هتل‌ها، شركت‌ها و فروشگاه‌هاي زنجيره‌اي، نگهبانان كارخانجات و كارگاه‌هاي ساختماني و صنعتي، پرسنل بيمارستان‌ها، گروه‌هاي اردويي، ورزشي و كوهنوردي و سرگرمي و تفريح افراد خانواده در پيك نيك.

شروین هادی نژاد

ماهنامه دنیای مخابرات وارتباطات شماره 8

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 4 آذرماه 1384

12:41 PM

November 25, 2005

باند شهروندان;چگونه عمل كنيم؟

سرانجام و پس از سال ها چندي پيش علاقه مندان به ارتباطات راديويي خبري مبني بر راه اندازي خدمات " باند شهروندان" از طرف سازمان تنظيم مقررات و ارتباطات راديويي دريافت نمودند كه قطعا باعث مسرت و خوشحالي آن ها گشته است. ما هم اميدواريم آغاز ارائه خدمات عمومي ارتباطي همچون " باند شهروندان" گام نخست در راهي باشد كه به عرضه خدمات مفيد عمومي منتهی مي شود، اما خدمت باند شهروندان ( كه در شماره12 بخش آموزش همين ماهنامه اجمالا معرفي شد به واسطه ی تازگي آن براي مردم ما، مشابه تمامي فناوري هاي ديگر، در بدو ورود قطعا نياز به ايجاد بستر هاي فرهنگي و آموزشي جهت شناساندن و تعليم كاربرد هاي صحيح آن دارد. از اين رو در بخش آموزش ماهنامه به عنوان يك رسانه تخصصي در حوزه مخابرات و ارتباطات وظيفه خود مي دانيم كه در حد امكان بخشي از بار سنگين فرهنگ سازي در اين خصوص را به دوش گيريم و آن را به بهترين وجه ادا نماييم.)

معرفي:

" باند شهروندان"( Citizen Band) از جمله خدمات ارتباط راديويي عمومي است كه در اكثر كشور هاي جهان جهت استفاده عموم جامعه از بستر ارتباطي فارغ از سيم ها و ارتباط كابلي، ارائه مي شود.

مشخصات اين خدمات در تمامي كشور هاي ارائه دهنده يك سان نيست اما شباهت هاي بسیاری با يكديگر دارند،‌ چنان كه تفاوت ها ممكن است در برخي از مشخصات فني همچون تعداد كانال ها، بسامد آن ها و يا توان خروجي خلاصه گردد.

مهم ترين ويژگي خدمات راديويي عمومي اشتراك و سهيم بودن همه شهروندان در استفاده از تمامي كانال هاي موجود است،‌ بدين معني كه هيچ يك ار كانال ها به هيچ وجه اختصاصا در اختيار شخصي يا اشخاص خاصي قرار نمي گيرد و همه كاربران مي توانند با رعايت دقيق نكات آيين نامه از تمامي كانال ها بهره مند شوند.

در اين خدمات شهروندان قادر خواهند بود تا با يكديگر تنها ارتباط صوتي ( مكالمه ) به صورت دو طرفه ( ارسال و دريافت غير همزمان ) داشته باشند. هر يك از متقاضيان برابر آيين نامه و مقررات مي توانند نسبت به ارائه تقاضا جهت صدور پروانه بهره برداري از مراجع قانوني متولي اقدام و پس از دريافت آن، تجهيزات مربوطه را خريداري و مطابق ضوابط استفاده نمايند. همچنين هر يك از كاربران مي بايست هزينه مجوز يا حق فركانس مقرر را پرداخت و يك علامت خطاب (call sign) منحصر به فرد دريافت نمايد كه علامت شناسايي هر يك از كاربران بوده و مي بايست حين استفاده و در مواقع لزوم به طور صحيح و واضح عنوان شود. در كشور ما متولي صدور مجوز و كنترل خدمت باند شهروندان" سازمان تنظيم و ارتباطات راديويي" است كه كلیه امور وظايف مربوط به اين خدمات را عهده دار است. بنابراین كاربران مي بايست جهت دريافت مجوز، در خواست خود را به همراه مدارك مورد نياز به اين سازمان تسليم نمايند. همچنين اكيدا توصيه مي گردد تا متقاضيان حتما ضوابط استفاده از خدمت باند شهروندان را كه از طرف اين سازمان منتشر شده است دقيقا مورد مطالعه قرار داده و به دقت به آن عمل نمايند. جهت دريافت اطلاعات بيشتر در اين زمينه مي توانيد به وبگاه سازمان مراجعه نماييد. ( www.tra.ir )
شايد از خود بپرسيم:

استفاده از راديو هاي دو طرفه هنگامي كه مي توانيم از تلفن ( همراه يا ثابت ) استفاده كنيم چه مزيتي مي تواند داشته باشد؟

همواره توجه داشته باشيد كه: تلفن ها وسائل ارتباطي با كاربرد هاي خاص خود و متفاوت از راديو هاي دو طرفه است، از اين رو به نكات زير به عنوان تفاوت ها توجه كنيد:

* صرفه اقتصادي:‌ فرض كنيد بخواهيد با شخصي در فاصله اي به محدوده 6 يا 7 كيلومتر ارتباط بر قرار نمايید،‌ مطمئنا در صورت در دسترس بودن تلفن اگر هر دوي شما در محل ثابتي قرار داشته باشيد قطعا از تلفن ( ثابت )‌ استفاده خواهيد نمود و اگر هم يك يا هر دو در حال حركت ( در شهر يا مسافرت ) باشيد باز هم در صورت در اختيار داشتن تلفن همراه از آن استفاده خواهيد نمود، مسلم است كه هر ارتباط تلفني بسته به مدت زمان آن هزينه در بر خواهد داشت،‌ اما اگر نياز به ارتباط مداوم ( چندين بار در روز يا ساعت ) در محدوده اي خاص داشته باشيد و در مقابل هم تلفن ( ثابت و همراه )‌ و هم يك راديوي بدون سيم ( متحرك يا ثابت ) دو طرفه در اختيار داشته باشيد،‌ كدام را ترجيح مي دهيد، پرداخت هزينه، يا مكالمه رايگان نا محدود؟!

* شرايط بحراني: حتما تلفن ها در چنين شرايطي كمك شاياني محسوب خواهند شد، اما از ياد نبريم كه در مواردي بستر شبكه هاي مخابراتي همچون تلفن همراه و يا ثابت ممكن است نتواند به خوبي پاسخگوي نياز فوري شما باشد و يا حتي به كلی دچار قطع يا اختلال گردد، به موارد زير دقت كنيد:

1. پس از زلزله،‌ سيل، آتش سوزي.

2. قطع و اختلال برق و شبكه هاي مخابراتي به هر دليل.

3. گم كردن راه و يا وقوع حادثه در مسير و جاده هاي دور افتاده كه امكانات ارتباطي موجود نيست.

شايد در چنين شرايطي بهترين وسيله ارتباطي وسيله اي مبتني بر امواج راديويي و فارغ از بستر هاي سيمي و كابلي باشد،‌ كه دراينجا لزوم استفاده از خدمات باند شهروندان مشهودتر است.

سرعت: هرگز نمي توان سرعت برقراري ارتباط ميان تلفن و يك راديوي دو طرفه را مقايسه نمود چرا كه در تماس تلفني بايد، شماره گيري كرد، منتظر بر قراري ارتباط ماند، و در نهايت بعد از شنيدن صداي بوق آزاد و برداشتن گوشي از طرف مقابل مكالمه کرد، مسلم است كه تمامي اين موارد نياز به زماني هر چند اندك خواهند داشت، اما در راديوي دو طرفه تنها با فشردن و نگه داشتن يك كليد قادريد پيام خود را به گوش مخاطب يا مخاطبان خود برسانيد، اين سرعت قطعا در مواقعي كه حتي لحظه ها ارزشمند خواهند بود، كمك شاياني خواهد كرد.

اما از ياد نبريد كه در مقابل موارد فوق تلفن ها مزاياي ديگري دارند، كه راديو هاي دو طرفه هرگز نخواهند داشت و بسته به نوع كار بري مي توانيد مناسب ترين وسيله را جهت استفاده خود انتخاب نماييد، به گوشه اي از اين مزايا توجه كنيد:

1. عدم محدوديت در فاصله طرفين ارتباط (مي توانيد به وسيله تلفن با مخاطب خود در فواصل بسيار دور ارتباط بر قرار نماييد.)

2. پوشيدگي تماس ها ( ديگران قادر به شنيدن مكالمات شخصي و خصوصي شما نخواهند بود.)

3. خط ارتباطي فقط متعلق به شما است و ديگران در استفاده از آن شريك نيستند.

* تجهيزات مورد استفاده:

مطابق ضوابط كشور، از ميان تجهيزات دستي، خودرويي و ثابت تعريف شده براي اين خدمات تنها استفاده از دو نوع ثابت و متحرك خودرويي مجاز است. اين تجهيزات عموما راديو هاي دو طرفه اي ( با قابليت ارسال و دريافت ) هستند كه بسامد و تعداد كانال مشخصي و غير قابل تغييري دارند، تعداد كانال ها براي كشور ما 40 كانال از باند HFو با فاصله ي كانالي 10 كيلو هرتز پيش بيني شده است كه موارد فوق در جدولي ضميمه ضوابط مندرج است. در اين جدول بسامد براي هر كانال مشخص و غير قابل تغيير است و هر راديويي كه از نظر سازمان مطابق با ضوابط فني شناخته مي شوددقيقا از جدول مذکور پيروي مي نمايد.

* نوع ثابت: مي تواند نوع مخصوص ايستگاه هاي ثابت استفاده شود مي بايست موارد ذيل را مد نظر قرار داد.

1. منبع تغذيه داراي ورودي و خروجي جريان متناسب با مشخصات فني و ولتاژ ذكر شده توسط سازنده به كار گرفته شود، به شكلي كه به وسيله يك مبدل جريان، برق شهري را تبديل به ولتاژ مورد نياز دستگاه نمايد.

2. آنتن دستگاه مي بايست بر فراز محلي چون پشت بام و يا در مواردي بر روي دكلي كه بر روي پشت بام افراشته مي گردد نصب شود، به طوري كه مشخصات فني مجموعه نصب شده در نهايت مطابق با ضوابط مربوطه باشد.

* نوع خودرويي ( متحرك ): معمول ترين وسيله در استفاده از خدمات " باند شهروندان" است،‌ كه بر روي خودرو نصب شده و به همراه آن حمل و استفاده مي گردد، معمولا بايد جهت نصب آن به فروشنده و يا دفترچه راهنماي دستگاه مراجعه نماييد. انرژي مورد نياز دستگاه خودرويي از منابع الكتريكي داخل خودرو تغذیه مي گردد، همچنين آنتن آن مي بايد در محل مناسبي خارج از خودرو نصب شود . غالبا محل هاي مناسب براي نصب آنتن را بر روي سقف و يا صندوق عقب خودرو در نظر مي گيرند. از اين رو اتصال بين آنتن و خودرو دستگاه مي بايست به واسطه سيم مخصوص كه توسط شركت سازنده توصيه شده است انجام گيرد ( معمولا كابل هم محور يا كواكسيال )، زيرا نوع كابل مورد استفاده تاثير بسيار زيادي بر كيفيت سيگنال هاي ارسال و دريافت خواهد داشت.

* روش بر قراري ارتباط:

پس از نصب راديو و آنتن آن بر روي خودرو و يا در محل ايستگاه ثابت دستگاه آماده بهره برداري مي گردد، در اين زمان تنها چيزي كه براي مكالمه نياز است اين است كه شما راديوي خود را روشن نموده و آن را بر روي هر كانالي كه مي خواهيد " به جز كانال 9 " تنظيم نماييد.

* نكته مهم: همواره و در هر زمان تنها كار براني صداي شما را مي شنوند و مي توانند با شما ارتباط بر قرار نمايندكه:

1. در محدوده برد سيگنال هاي راديويي شما قرار داشته باشند.

* تذكر1: هنگام حركت خودرو، دايره فرضي پوشش راديوي شما نيز همزمان حركت مي نمايد.

* تذكر2: جهت حفظ ارتباط بين چند خودروي در حال حركت لازم است به ميزان شعاع پوششي فاصله بين خودروها نيز حفظ گردد.

در صورت بر قراري چنين شرايطي تقريبا مي توانيد مطمئن باشيد كه آن ها صداي شما را خواهند شنيد، پس لازم است براي رساندن صداي خود به آن ها كليد (PTT) يا ارسال رل كه معمولا بر روي ميكروفون دستگاه قرار دارد فشار داده و نگه داريد، حال ميكروفون را با فاصله 5 تا 10 سانتيمتري از دهان خود نگه داشته و با صداي معمولي ( نه بلند و نه آهسته ) صحبت نماييد، اما پس از پايان صحبت خود حتما كليد ارسال را رها كنيد تا بتوانيد صداي طرف مقابل را بشنويد.

همواره توجه كنيد در هر زمان قبل از شروع به صحبت و ارسال بر روي هر كانال از خالي بودن آن و عدم اشغال كانال توسط ديگران اطمينان حاصل نماييد، براي اين كار بايد هر بار چند لحظه قبل از ارسال پيام به راديوي خود گوش كنيد و بفهميد كه آيا سكوت بر قرار است يا اينكه ديگران در حال مكالمه هستند، اگر در اين هنگام كانال توسط كاربران ديگر در حال استفاده و اصطلاحا " اشغال " بود، مي توانيد تا خالي شدن آن ( پايان مكالمه جاري بر روي كانال ) صبر نموده و يا كانال ديگري را جهت ارتباط انتخاب و آزمايش كنيد، اما هرگز در صورت اشغال بودن كانال نسبت به ارسال پيام اقدام ننماييد، چرا كه اين كار باعث به وجود آمدن تداخل عمدي شده و نه تنها پيام شما در اين ميان به مقصد نخواهد رسيد، بلكه باعث نا مفهوم شدن و اختلال در پيام هاي در حال تبادل توسط كاربران ديگر نيز خواهد شد. توجه نماييد كه شروع به صحبت مي بايد با فاصله زماني در حدود 1 تا 2 ثانيه پس از فشردن و نگه داشتن كليد PTT انجام گيرد و همچنين در خاتمه حتما كليد را پس از 1 تا 2 ثانيه بعد از اتمام صحبت خود رها كنيد، زيرا در غير اين صورت ممكن است كلمات ابتدايي و انتهايي مكالمه شما در هر ارتباط به خوبي ارسال نگردد، البته هماهنگ نمودن اين اعمال در ابتدا كمي مشكل به نظر مي رسد ولي به مرور و طي استفاده به شكل عادت در آمده و به صورت خودكار اين كار را انجام خواهيد داد. حتي ممكن است در ابتدا فراموش كنيد حين صحبت كليد ارسال را نگه داريد و يا پس از پايان آن را رها سازيد، اما معمولا به مرور عادت خواهيد كرد.براي اين امردر ابتدا مي توانيد در صورتي كه دستگاه شما به چراغ نمايشگر ارسال و دريافت مجهز است، به آن توجه نماييد تا مطمئن شويد آيا صداي شما در هنگام صحبت ارسال مي گردد يا اينكه فراموش كرده ايد كليد را نگه داريد.

مدت زمان ارسال و صحبت كردن شما در هر ارتباط به طور پيوسته نبايد بيشتر از 5 دقيقه به طول بيانجامد، اين كار علاوه بر احتمال آسيب رساندن به راديوي شما، باعث اشغال شدن بيش از حد كانال و عدم امكان استفاده ديگران از كانال فوق مي گردد بنابراين، اين عمل خلاف ضوابط است.

* كد هاي اختصاري:

كاربران راديوهاي باند شهري در سراسر جهان جهت دوري از به كار بردن جملات و مكالمات تكراري و بعضا طولاني متداول، از كد هايي به نام " 10 كد " استفاده مي نمايند. اين كد ها كه به صورت تركيبي از اعداد به كار مي روند، جايگزيني اختصاري براي جملات هستند كه به طور قرار دادي ميان كاربران باند شهري پذيرفته و استفاده شده اند، علاوه بر اين استعمال اين كد ها در مكالمات موجب كوتاه شدن طول زمان هر پيام به مقدار زياد و در نتيجه كاهش حجم ترافيك پيام ها بر روي كانال خواهد شد. جدول كد هاي "10" در ادامه به همراه راهنماي آن ها آمده است كه كاربران قادرند به راحتي به آن ها عادت نموده و جايگزين مكالمات رايج خود قرار دهند. اما به ياد داشته باشيد كه استفاده از آن ها به هيچ وجه اجباري نيست و كاملا اختياري خواهد بود.

بوسیله تلفن ( نام شخص ) راخبر کنید | 21-10 | صدای شما مفهوم نیست | 1-10
پیام وضعیت اظطراری منتفی است و لغو می گردد | 22-10 | پیام شما دریافت شد | 2-10
ما به منطقه شما رسید یم / نزدیک شده ایم | 23-10 | لطفا به صحبت خود پایان دهید | 3-10
دستور شما به طور کامل انجام شد | 24-10 | صدای شما کاملا واضح می باشد | 4-10
می توانید ---- را ملاقات یا با او تماس بگیرید؟ | 25-10 | پیام خود را برای ----------- ارسال کنید | 5-10
در حدود ------- دققه دیگر به آنجا/ شما می رسیم | 26-10 | من فعلا مشغول هستم منتظر بمانید | 6-10
من کانال را به شماره ----- تغییر می دهم | 27-10 | شخص مورد نظر در شبکه پاسخگو نیست | 7-10
موقعیت شما را پیدا کردم | 28-10 | شخص مورد نظر پاسخگو می باشد | 8-10
-- دقیقه/ ساعت دیگردوباره با شما تماس می گیرم | 29-10 | پیام خود را دوباره تکرار کنید | 9-10
اعلام اخطار (عمل بر خلاف مقررات) | 30-10 | جواب منفی است | 10-10
من رادیو را تا ------ خاموش می نمایم | 31-10 | لطفا سریع پاسخ دهید | 11-10
---- (غریبه/ مزاحم) است | 32-10 | من گوش به پیام و منتظر می مانم | 12-10
ساعت چند است | 33-10 | لطفا وضعیت (مسیر/ آب و هوا ) را گزارش دهید | 13-10
پیام (فوری/ اظطراری) دارم کانال را خالی کنید | 34-10 | اطلاعات بیشتری بدهید | 14-10
لطفا کانال را تغییر دهید | 35-10 | پیام شما را به مقصد رساندم | 15-10
در مسیر تصادف رخ داده است احتیاط کنید | 36-10 | لطفا جواب دهید | 16-10
مسیر اشتباه است برگردید | 37-10 | وضعیت اظراری رخ داده است | 17-10
ما در ----- توقف خواهیم کرد | 38-10 | لطفا (پلیس/ آتشنشانی/ اورژانس ) را خبر کنید | 18-10
لطفا علامت خطاب خود را اعلام کنید | 39-10 | با تلفن----------- تماس بگیرید | 19-10
در حال حاضر نمیتوانم پاسخ گوی شما باشم | 40-10 | موقعیت خود را اعلام کنید/ موقعیت من ------- | 20-10

جدول 10 کد مربوط به راد یوهای باند شهروندان

تا اينجا با مقدمات و نيز روش بر قراري ارتباط به وسيله راديوهاي باند شهري آشنا شديد، حال برخي از نكاتي را كه ممكن است براي كاربران ايجاد سوال نمايد، مطرح مي نماييم.

مسافت تحت پوشش يا " برد " راديوهاي باند شهروندی چه مقدار است؟

اين امر بستگي به عوامل زيادي همچون توان خروجي فرستنده، محيط استفاده،‌ همچنين ارتفاع و ميزان حساسيت آنتن و برخي عوامل ديگر دارد،‌ در كل براي راديو هاي متحرك خودرويي در فضاي شهري مي توان بردي در حدود 3 الي 6 كيلومتر را پيش بيني نمود، كه اين فاصله براي انواع ثابت كه آنتن مرتفع تري نيز دارند بيشتر خواهد شد.

بهره( Gain ) يا حساسيت ميكروفون چيست؟

حساسيت ميكروفون كمك مي كند تا در شرايط مختلف بهترين حالت را براي سطح ارسالي صداي ميكروفون تنظيم نماييد كه هر چه مقدار اين حساسيت بالاتر باشد،‌ علاوه بر وضوح و شدت صداي ارسالي توسط ميكروفون صدا هاي اطراف نيز واضح تر ارسال مي گردد و هنگاميكه اين حساسيت در حالت كم تنظيم شده باشد. تنها صدا هاي بلندتر و نزديك تر به ميكروفون را ارسال خواهد كرد.

"SWR" خاصيتي جهت تنظيم و تطبيق آنتن

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر


مقاله

گزارش

 ياداشت

اخبار شرکتها

همايشها

فراخوانها و آئين نامه ها

عکس

ICT نگاران چه ميگويند ؟‌‌
تبليغات

سفارش آگهی
مقاله
جمعه، 4 آذرماه 1384

01:37 PM

November 25, 2005

نخستین نگاه به OpenOffice.org 2.0

به طور قطع امروزه یکی از پر استفاده‌ترین بسته‌های نرم‌افزاری بر روی هر کامپیوتر شخصی، مجموعه‌های اداری یا Office Suite ها هستند. تعداد زیادی از کاربران مخصوصا کاربران اداری ممکن است کمتر روزی را پشت سر گذاشته باشند بدون اینکه یک سند یا صفحه گسترده را ایجاد، بررسی یا ویرایش کرده باشند.

در دنیای یونیکس، مجموعه‌های اداری آزاد متعددی وجود دارند که بی‌شک بزرگترین و قدرتمندترین آنها، مجموعه اداری OpenOffice.org محصول سان می‌باشد. ممکن است اطلاع داشته باشید که به تازگی نسخه 2.0 این مجموعه اداری قدرتمند با تغییرات و بهینه سازی‌های زیادی ارائه شده است که در این مقاله کوتاه سعی بر آن داریم تا با یک مرور سریع، مهمترین ویژگی‌های نسخه جدید را بررسی کنیم.

۱) سرعت
یکی از موارد بهینه شده در نسخه جدید سرعت بارگذاری و عملکرد مجموعه OpenOffice.org است. موردی که ایرادات زیادی در نسخه 1.1 به آن وارد بود.

۲) ظاهر جدید و بهینه سازی رابط کاربر
ظاهر نسخه جدید مجموعه اداری OpenOffice.org تغییـر داده شده و بهینه سازی‌هایی در رابط کاربر آن برای استفاده آسان‌تر و بهتر انجام شده است. بیشترین تغییر را در نحوه چیدمان نوار ابزارهای برنامه شاهد هستیم.

۳) پشتیبانی سراسری از OASIS Open Document Format
ظاهرا فرمت استاندارد و عمومی OASIS Open Document در حال فراگیر شدن در بین برنامه‌های کاربردی اداری است [ ۱ ] . با اینکه از این فــرمت در نسخــه 1.1.5 پشــتیبانی شده بود، در نسخه 2.0 این فرمت تبدیل به فرمت پیش‌گزیده برای ذخیره مستندات شده است. مجموعه اداری Koffice نیز از این فرمت پشتیبانی می‌کند. با توصیه استفاده شدن استفاده از این فرمت در برخی از کشورها و مناطق مانند اروپا [ ۲ ] در مقابل فرمت‌های روز به روز انحصاری‌تر مایکروسافت، به زودی شاهد فراگیر شدن هرچه بیشتر آن در بین مجموعه‌های اداری مختلف خواهیم بود.

۵) خروجی بهینه PDF
مجموعه OpenOffice.org همیشه به امکان ایجاد خروجی آسان PDF مشهور بوده و این شهرت را در نسخه جدید با بهینه کردن این خروجی مانند درج لینک‌ها و Bookmarkها در فایل PDF ادامه خواهد داد. خروجی xHTML نیز در کنار PDF اضافه شده است.

پنجره OpenOffice.org Writer 2.0 در پارسیکس 0.70

۶) OpenOffice.org Base
یکی از ابزارهای کاملا جدید نسخه 2.0 مجموعه اداری OpenOffice.org ابزاری است که قطعا تا بحال جای خالی آن در این مجموعه احساس می‌شد: یک ایجاد کننده بانک‌های اطلاعاتی مبتنی بر فایل مشابه با MS-Access. برای استفاده از این ابزار، باید سیستم شما مجهز به JRE یا Java Runtime Environment باشد.

۷) rpm بجای نصاب
نسخه 2.0 مجموعه اداری OpenOffice.org بجای استفاده از نصاب سنتی که در نسخه‌های 1.0 و 1.1 با آن آشنا بودیم، بصورت بسته‌های rpm و فقط rpm برای نصب ارائه شده است. این در صورتی است که مایل باشید نسخه ارائه شده در سایت رسمی آنرا استفاده کنید. البته به مرور زمان، توزیع‌های مختلف در حال ایجاد بسته‌های مخصوص به خود از این نسخه هستند. برای نصب rpmهای ارائه شده در سایت OpenOffice.org باید یک توزیع کاملا جدید مجهز به libc6 نسخه 2.3.5 و یا بالاتر داشته باشید. در غیر این صورت این بسته‌های پس از نصب اجرا نخواهند شد. البته بسیاری از توزیع‌های جدید این امکان را دارا هستند، ولی برخی دیگر مانند Debian 3.1 از libc6 نسخه 2.3.2 استفاده می‌کنند که امکان نصب بسته OpenOffice.org 2.0 در آنها وجود ندارد. البته در حال حاضر بسته OpenOffice.org 2.0 در شاخه unstable دبیان قرار داده شده است و کاربران استفاده کننده از این توزیع می‌توانند بسته OpenOffice.org خود را به نسخه جدید ارتقاء دهند:

# apt-get update && apt-get install openoffice.org

۷) حل بسیاری از مشکلات فارسی
خوب شاید این یکی از بهترین خبرها برای این نسخه باشد. در نسخه جدید بسیاری از مشکلات زبان فارسی برطرف شده است. مانند مشکل خط عمودی هنگام تایپ Shift+Space و مشکل فواصل تیره ایجاد شده در هنگام استفاده از پاراگراف‌های Justify. البته مشکل Justify هنگامی کاملا تصحیح می‌شود که در بخش تنظیمات زبان، زبان پیش‌گزیده برنامه بر روی Arabic تنظیم شود.

۸) امکانات گسترده‌تر
تقریبا در تمامی برنامه‌های مجموعه اداری OpenOffice.org 2.0 اصلاحات و بهینه سازی‌هایی در راستای ایجاد امکانات جــدیــد و بــهتر ایجاد شده است. مثــلا پشــتیبانی Calc از ۶۵۰۰۰ سطر و صفحات Right-To-Left و امکانات و جلوه‌های بسیار تکامل یافته در Impress. از دیگر امکانات بهینه شده در این نسخه می‌توان به موارد زیر اشاره کرد:

الف): پشتیبانی از Custom Shapes.
ب): Mail Merge Wizard یا ویزارد ادغام پستی برای ارسال مستندات ایجاد شده به تعداد زیادی کاربر.
ج): پشتیبانی از Nested Tables یا جداول درون جداول دیگر.
د): پشتیبانی از امضاهای دیجیتالی.
ه): پشتیبانی از Xforms.
و): پشتیبانی از فرمت‌های ورودی بیشتر مانند WordPerfect.
ز): پشتیبانی از نوار ابزارهای شناور.

برای اطلاعات دقیق‌تر در مورد امکانات این نسخه و تصاویر بیشتر به [ ۳ ] مراجعه نمایید.

نوشته : آلن باغومیان alan@technotux.com
ناشر: IranTUX

PDF Version

لینک ثابت || نوشته شده توسط آرش کریم بیگی|| نسخه قابل چاپ
تبليغات متنی

گُماش
گروه مشاوران ارتباطات و شبکه

مشاوره و ارائه راه کارهای امنيت اطلاعات و سيستم های رايانه ای

مشاوره،طراحی و اجرای شبکه داخلی و گسترده

مشاوره،طراحی و راه اندازی وبسايت ، ميزبانی وب و ثبت دامنه

مشاوره،طراحی،نصب و راه اندازی مرکز کوته پيام و سرويس های ارزش افزوده مبتنی بر بستر کوته پيام

سفارش آگهی
ICTNA در وبسايت شما
با استفاده از اين سرويس ICTNA کليه مديران وبسايتها و وبلاگها ميتوانند تيتر پنج مطلب آخر هر يک از بخشهای ICTNA را به طور خودکار در وبسايت خود درج کنند.
برای مطالعه راهنما و دريافت کدهای اين سرويس اينجا را کليک کنيد
بيشتر